Panorama Administrator's Guide
Version 10.1

docs.paloaltonetworks.com

Contact Informaon

Corporate Headquarters:
Palo Alto Networks
3000 Tannery Way
Santa Clara, CA 95054
www.paloaltonetworks.com/company/contact-support.html
About the Documentaon

• For the most recent version of this guide or for access to related documentaon, visit the
Technical Documentaon portal docs.paloaltonetworks.com.
• To search for a speciﬁc topic, go to our search page docs.paloaltonetworks.com/search.html.
• Have feedback or quesons for us? Leave a comment on any page in the portal, or write to us
at documentaon@paloaltonetworks.com.
Copyright

Palo Alto Networks, Inc.
www.paloaltonetworks.com
©2021–2022 Palo Alto Networks, Inc. Palo Alto Networks is a registered trademark of Palo

Alto Networks. A list of our trademarks can be found at www.paloaltonetworks.com/company/
trademarks.html. All other marks menoned herein may be trademarks of their respecve
companies.
Last Revised

February 22, 2022

Panorama Administrator's Guide Version Version 10.1

2

©2022 Palo Alto Networks, Inc.

Table of Contents
Panorama Overview........................................................................................ 11
About Panorama........................................................................................................................ 12
Panorama Models......................................................................................................................14
Centralized Firewall Conﬁguraon and Update Management........................................17
Context Switch—Firewall or Panorama.................................................................... 17
Total Conﬁguraon Size for Panorama.....................................................................18
Templates and Template Stacks..................................................................................18
Device Groups................................................................................................................ 20
Centralized Logging and Reporng....................................................................................... 26
Managed Collectors and Collector Groups..............................................................26
Local and Distributed Log Collecon........................................................................27
Caveats for a Collector Group with Mulple Log Collectors...............................28
Log Forwarding Opons...............................................................................................30
Centralized Reporng................................................................................................... 31
Data Redistribuon Using Panorama................................................................................... 33
Role-Based Access Control..................................................................................................... 34
Administrave Roles......................................................................................................34
Authencaon Proﬁles and Sequences....................................................................36
Access Domains............................................................................................................. 36
Administrave Authencaon....................................................................................37
Panorama Commit, Validaon, and Preview Operaons................................................. 39
Plan Your Panorama Deployment..........................................................................................40
Deploy Panorama: Task Overview........................................................................................ 42

Set Up Panorama............................................................................................. 43
Determine Panorama Log Storage Requirements..............................................................44
Manage Large-Scale Firewall Deployments........................................................................ 46
Determine the Opmal Large-Scale Firewall Deployment Soluon.................. 46
Increased Device Management Capacity for M-600 and Panorama Virtual
Appliance..........................................................................................................................46
Set Up the Panorama Virtual Appliance.............................................................................. 50
Setup Prerequisites for the Panorama Virtual Appliance..................................... 50
Install the Panorama Virtual Appliance.................................................................... 54
Perform Inial Conﬁguraon of the Panorama Virtual Appliance....................114
Set Up The Panorama Virtual Appliance as a Log Collector..............................118
Set Up the Panorama Virtual Appliance with Local Log Collector................... 125
Set up a Panorama Virtual Appliance in Panorama Mode................................. 130
Set up a Panorama Virtual Appliance in Management Only Mode..................131
Expand Log Storage Capacity on the Panorama Virtual Appliance..................132
Panorama Administrator's Guide Version Version 10.1

3

©2022 Palo Alto Networks, Inc.

Table of Contents
Increase CPUs and Memory on the Panorama Virtual Appliance.................... 160
Increase the System Disk on the Panorama Virtual Appliance......................... 167
Complete the Panorama Virtual Appliance Setup............................................... 173
Convert Your Panorama Virtual Appliance............................................................173
Set Up the M-Series Appliance........................................................................................... 185
M-Series Appliance Interfaces................................................................................. 185
Perform Inial Conﬁguraon of the M-Series Appliance...................................187
M-Series Setup Overview......................................................................................... 192
Set Up the M-Series Appliance as a Log Collector..............................................194
Increase Storage on the M-Series Appliance........................................................203
Conﬁgure Panorama to Use Mulple Interfaces..................................................209
Register Panorama and Install Licenses.............................................................................217
Register Panorama...................................................................................................... 217
Acvate a Panorama Support License................................................................... 219
Acvate/Retrieve a Firewall Management License when the Panorama Virtual
Appliance is Internet-connected..............................................................................220
Acvate/Retrieve a Firewall Management License when the Panorama Virtual
Appliance is not Internet-connected...................................................................... 221
Acvate/Retrieve a Firewall Management License on the M-Series
Appliance....................................................................................................................... 223
Install the Panorama Device Cerﬁcate............................................................................226
Transion to a Diﬀerent Panorama Model....................................................................... 228
Migrate from a Panorama Virtual Appliance to an M-Series Appliance..........228
Migrate a Panorama Virtual Appliance to a Diﬀerent Hypervisor................... 231
Migrate from an M-Series Appliance to a Panorama Virtual Appliance..........236
Migrate from an M-100 Appliance to an M-500 Appliance..............................243
Access and Navigate Panorama Management Interfaces............................................. 247
Log in to the Panorama Web Interface..................................................................247
Navigate the Panorama Web Interface..................................................................247
Log in to the Panorama CLI......................................................................................248
Set Up Administrave Access to Panorama.....................................................................250
Conﬁgure an Admin Role Proﬁle............................................................................. 250
Conﬁgure an Access Domain................................................................................... 251
Conﬁgure Administrave Accounts and Authencaon....................................251
Conﬁgure Tracking of Administrator Acvity....................................................... 265
Set Up Authencaon Using Custom Cerﬁcates......................................................... 268
How Are SSL/TLS Connecons Mutually Authencated?................................ 268
Conﬁgure Authencaon Using Custom Cerﬁcates on Panorama............... 269
Conﬁgure Authencaon Using Custom Cerﬁcates on Managed
Devices........................................................................................................................... 271
Add New Client Devices........................................................................................... 273

Panorama Administrator's Guide Version Version 10.1

4

©2022 Palo Alto Networks, Inc.

Table of Contents
Change Cerﬁcates.....................................................................................................273

Manage Firewalls........................................................................................... 277
Add a Firewall as a Managed Device.................................................................................278
Install the Device Cerﬁcate for Managed Firewalls..................................................... 286
Install the Device Cerﬁcate for a Managed Firewall........................................ 286
Install the Device Cerﬁcate for Mulple Managed Firewalls..........................288
Set Up Zero Touch Provisioning..........................................................................................292
ZTP Overview.............................................................................................................. 292
Install the ZTP Plugin................................................................................................. 294
Conﬁgure the ZTP Installer Administrator Account............................................302
Add ZTP Firewalls to Panorama.............................................................................. 303
Use the CLI for ZTP Tasks........................................................................................ 307
Uninstall the ZTP Plugin............................................................................................310
Manage Device Groups......................................................................................................... 311
Add a Device Group................................................................................................... 311
Create a Device Group Hierarchy........................................................................... 312
Create Objects for Use in Shared or Device Group Policy................................ 314
Revert to Inherited Object Values...........................................................................315
Manage Unused Shared Objects............................................................................. 316
Manage Precedence of Inherited Objects.............................................................316
Move or Clone a Policy Rule or Object to a Diﬀerent Device Group..............317
Select a URL Filtering Vendor on Panorama........................................................ 318
Push a Policy Rule to a Subset of Firewalls.......................................................... 323
Device Group Push to a Mul-VSYS Firewall.......................................................326
Manage the Rule Hierarchy...................................................................................... 326
Manage Templates and Template Stacks...........................................................................329
Template Capabilies and Excepons.................................................................... 329
Add a Template............................................................................................................ 329
Conﬁgure a Template Stack...................................................................................... 332
Conﬁgure a Template or Template Stack Variable............................................... 336
Import and Overwrite Exisng Template Stack Variables..................................339
Override a Template or Template Stack Value..................................................... 341
Disable/Remove Template Sengs.........................................................................343
Manage the Master Key from Panorama.......................................................................... 345
Schedule a Conﬁguraon Push to Managed Firewalls...................................................352
Redistribute Data to Managed Firewalls...........................................................................355
Transion a Firewall to Panorama Management............................................................. 358
Plan the Transion to Panorama Management.................................................... 358
Migrate a Firewall to Panorama Management..................................................... 359
Migrate a Firewall HA Pair to Panorama Management......................................363

Panorama Administrator's Guide Version Version 10.1

5

©2022 Palo Alto Networks, Inc.

Table of Contents
Load a Paral Firewall Conﬁguraon into Panorama..........................................368
Localize a Panorama Pushed Conﬁguraon on a Managed Firewall............... 371
Device Monitoring on Panorama........................................................................................ 373
Monitor Device Health.............................................................................................. 373
Monitor Policy Rule Usage........................................................................................375
Use Case: Conﬁgure Firewalls Using Panorama.............................................................. 381
Device Groups in this Use Case.............................................................................. 381
Templates in this Use Case....................................................................................... 382
Set Up Your Centralized Conﬁguraon and Policies........................................... 383

Manage Log Collecon.................................................................................391
Conﬁgure a Managed Collector...........................................................................................392
Conﬁgure Authencaon for a Dedicated Log Collector..............................................399
Conﬁgure an Administrave Account for a Dedicated Log Collector............. 399
Conﬁgure RADIUS Authencaon for a Dedicated Log Collector.................. 401
Conﬁgure TACACS+ Authencaon for a Dedicated Log Collector............... 405
Conﬁgure LDAP Authencaon for a Dedicated Log Collector.......................408
Manage Collector Groups..................................................................................................... 413
Conﬁgure a Collector Group.....................................................................................413
Conﬁgure Authencaon with Custom Cerﬁcates Between Log
Collectors.......................................................................................................................416
Move a Log Collector to a Diﬀerent Collector Group........................................ 418
Remove a Firewall from a Collector Group...........................................................419
Conﬁgure Log Forwarding to Panorama............................................................................421
Conﬁgure Syslog Forwarding to External Desnaons................................................. 426
Forward Logs to Cortex Data Lake.....................................................................................430
Verify Log Forwarding to Panorama...................................................................................431
Modify Log Forwarding and Buﬀering Defaults.............................................................. 433
Conﬁgure Log Forwarding from Panorama to External Desnaons......................... 435
Log Collecon Deployments................................................................................................ 438
Deploy Panorama with Dedicated Log Collectors...............................................438
Deploy Panorama M-Series Appliances with Local Log Collectors..................445
Deploy Panorama Virtual Appliances with Local Log Collectors...................... 451
Deploy Panorama Virtual Appliances in Legacy Mode with Local Log
Collecon.......................................................................................................................456

Manage WildFire Appliances......................................................................459
Add Standalone WildFire Appliances to Manage with Panorama............................... 460
Conﬁgure Basic WildFire Appliance Sengs on Panorama..........................................465
Conﬁgure Authencaon for a WildFire Appliance............................................465
Set Up Authencaon Using Custom Cerﬁcates on WildFire Appliances and
Clusters...................................................................................................................................... 479

Panorama Administrator's Guide Version Version 10.1

6

©2022 Palo Alto Networks, Inc.

Table of Contents
Conﬁgure a Custom Cerﬁcate for a Panorama Managed WildFire
Appliance....................................................................................................................... 479
Conﬁgure Authencaon with a Single Custom Cerﬁcate for a WildFire
Cluster............................................................................................................................ 481
Apply Custom Cerﬁcates on a WildFire Appliance Conﬁgured through
Panorama....................................................................................................................... 483
Remove a WildFire Appliance from Panorama Management.......................................486
Manage WildFire Clusters.................................................................................................... 487
Conﬁgure a Cluster Centrally on Panorama..........................................................487
View WildFire Cluster Status Using Panorama.................................................... 511

Manage Licenses and Updates...................................................................513
Manage Licenses on Firewalls Using Panorama.............................................................. 514

Monitor Network Acvity...........................................................................517
Use Panorama for Visibility.................................................................................................. 518
Monitor the Network with the ACC and AppScope........................................... 518
Analyze Log Data........................................................................................................ 520
Generate, Schedule, and Email Reports................................................................. 521
Conﬁgure Key Limits for Scheduled Reports........................................................524
Ingest Traps ESM Logs on Panorama.................................................................................527
Use Case: Monitor Applicaons Using Panorama...........................................................529
Use Case: Respond to an Incident Using Panorama.......................................................532
Incident Noﬁcaon................................................................................................... 532
Review the Widgets in the ACC..............................................................................533
Review Threat Logs.....................................................................................................533
Review WildFire Logs................................................................................................. 534
Review Data Filtering Logs....................................................................................... 534
Update Security Rules................................................................................................535

Panorama High Availability.........................................................................537
Panorama HA Prerequisites..................................................................................................538
Priority and Failover on Panorama in HA......................................................................... 540
Failover Triggers.......................................................................................................................541
HA Heartbeat Polling and Hello Messages........................................................... 541
HA Path Monitoring................................................................................................... 541
Logging Consideraons in Panorama HA..........................................................................543
Logging Failover on a Panorama Virtual Appliance in Legacy Mode............... 543
Logging Failover on an M-Series Appliance or Panorama Virtual Appliance in
Panorama Mode...........................................................................................................544
Synchronizaon Between Panorama HA Peers...............................................................545
Manage a Panorama HA Pair...............................................................................................546

Panorama Administrator's Guide Version Version 10.1

7

©2022 Palo Alto Networks, Inc.

Table of Contents
Set Up HA on Panorama........................................................................................... 546
Set Up Authencaon Using Custom Cerﬁcates Between HA Peers.......... 549
Test Panorama HA Failover.......................................................................................551
Switch Priority aer Panorama Failover to Resume NFS Logging....................551
Restore the Primary Panorama to the Acve State............................................ 552

Administer Panorama................................................................................... 553
Preview, Validate, or Commit Conﬁguraon Changes................................................... 554
Enable Automated Commit Recovery................................................................................557
Manage Panorama and Firewall Conﬁguraon Backups............................................... 559
Schedule Export of Conﬁguraon Files................................................................. 559
Save and Export Panorama and Firewall Conﬁguraons................................... 560
Revert Panorama Conﬁguraon Changes..............................................................563
Conﬁgure the Maximum Number of Conﬁguraon Backups on
Panorama....................................................................................................................... 566
Load a Conﬁguraon Backup on a Managed Firewall........................................ 567
Compare Changes in Panorama Conﬁguraons.............................................................. 568
Manage Locks for Restricng Conﬁguraon Changes................................................... 569
Add Custom Logos to Panorama........................................................................................ 571
Use the Panorama Task Manager....................................................................................... 572
Manage Storage Quotas and Expiraon Periods for Logs and Reports......................573
Log and Report Storage............................................................................................. 573
Log and Report Expiraon Periods......................................................................... 574
Conﬁgure Storage Quotas and Expiraon Periods for Logs and Reports....... 574
Conﬁgure the Run Time for Panorama Reports...................................................577
Monitor Panorama.................................................................................................................. 578
Panorama System and Conﬁguraon Logs............................................................578
Monitor Panorama and Log Collector Stascs Using SNMP.......................... 579
Reboot or Shut Down Panorama........................................................................................ 582
Conﬁgure Panorama Password Proﬁles and Complexity...............................................583

Panorama Plugins.......................................................................................... 585
About Panorama Plugins.......................................................................................................586
Install Panorama Plugins............................................................................................588
VM-Series Plugin and Panorama Plugins.......................................................................... 590
Install the VM-Series Plugin on Panorama............................................................590

Troubleshoong..............................................................................................593
Troubleshoot Panorama System Issues..............................................................................594
Generate Diagnosc Files for Panorama............................................................... 594
Diagnose Panorama Suspended State....................................................................594
Monitor the File System Integrity Check.............................................................. 594

Panorama Administrator's Guide Version Version 10.1

8

©2022 Palo Alto Networks, Inc.

Table of Contents
Manage Panorama Storage for Soware and Content Updates.......................595
Recover from Split Brain in Panorama HA Deployments...................................596
Troubleshoot Log Storage and Connecon Issues.......................................................... 597
Verify Panorama Port Usage.....................................................................................597
Resolve Zero Log Storage for a Collector Group................................................. 600
Replace a Failed Disk on an M-Series Appliance................................................. 600
Replace the Virtual Disk on an ESXi Server..........................................................600
Replace the Virtual Disk on vCloud Air................................................................. 601
Migrate Logs to a New M-Series Appliance in Log Collector Mode................602
Migrate Logs to a New M-Series Appliance in Panorama Mode......................608
Migrate Logs to a New M-Series Appliance Model in Panorama Mode in High
Availability..................................................................................................................... 616
Migrate Logs to the Same M-Series Appliance Model in Panorama Mode in
High Availability........................................................................................................... 625
Migrate Log Collectors aer Failure/RMA of Non-HA Panorama................... 632
Regenerate Metadata for M-Series Appliance RAID Pairs................................ 636
View Log Query Jobs................................................................................................. 637
Replace an RMA Firewall...................................................................................................... 639
Paral Device State Generaon for Firewalls...................................................... 639
Before Starng RMA Firewall Replacement......................................................... 639
Restore the Firewall Conﬁguraon aer Replacement...................................... 641
Troubleshoot Commit Failures............................................................................................. 645
Troubleshoot Registraon or Serial Number Errors........................................................646
Troubleshoot Reporng Errors.............................................................................................647
Troubleshoot Device Management License Errors......................................................... 648
Troubleshoot Automacally Reverted Firewall Conﬁguraons....................................649
View Task Success or Failure Status...................................................................................651
Test Policy Match and Connecvity for Managed Devices.......................................... 652
Troubleshoot Policy Rule Traﬃc Match................................................................. 652
Troubleshoot Connecvity to Network Resources............................................. 653
Generate a Stats Dump File for a Managed Firewall..................................................... 655
Recover Managed Device Connecvity to Panorama....................................................657

Panorama Administrator's Guide Version Version 10.1

9

©2022 Palo Alto Networks, Inc.

Table of Contents

Panorama Administrator's Guide Version Version 10.1

10

©2022 Palo Alto Networks, Inc.

Panorama Overview
The Panorama™ management server provides centralized monitoring and
management of mulple Palo Alto Networks next-generaon ﬁrewalls and of WildFire
appliances and appliance clusters. It provides a single locaon from which you can
oversee all applicaons, users, and content traversing your network, and then use
this knowledge to create applicaon enablement policies that protect and control the
network. Using Panorama for centralized policy and ﬁrewall management increases
operaonal eﬃciency in managing and maintaining a distributed network of ﬁrewalls.
Using Panorama for centralized WildFire appliance and WildFire appliance cluster
management increases the number of ﬁrewalls a single network supports, provides
high availability for fault tolerance, and increases management eﬃciency.
> About Panorama
> Panorama Models
> Centralized Firewall Conﬁguraon and Update Management
> Centralized Logging and Reporng
> Data Redistribuon Using Panorama
> Role-Based Access Control
> Panorama Commit, Validaon, and Preview Operaons
> Plan Your Panorama Deployment
> Deploy Panorama: Task Overview
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About Panorama
Panorama enables you to eﬀecvely conﬁgure, manage, and monitor your Palo Alto Networks
ﬁrewalls with central oversight. The three main areas in which Panorama adds value are:
• Centralized conﬁguraon and deployment—To simplify central management and rapid
deployment of the ﬁrewalls and WildFire appliances on your network, use Panorama to prestage the ﬁrewalls and WildFire appliances for deployment. You can then assemble the ﬁrewalls
into groups, and create templates to apply a base network and device conﬁguraon and use
device groups to administer globally shared and local policy rules. See Centralized Firewall
Conﬁguraon and Update Management.
• Aggregated logging with central oversight for analysis and reporng—Collect informaon
on acvity across all the managed ﬁrewalls on the network and centrally analyze, invesgate
and report on the data. This comprehensive view of network traﬃc, user acvity, and the
associated risks empowers you to respond to potenal threats using the rich set of policies to
securely enable applicaons on your network. See Centralized Logging and Reporng.
• Distributed administraon—Enables you to delegate or restrict access to global and local
ﬁrewall conﬁguraons and policies. See Role-Based Access Control for delegang appropriate
levels of access for distributed administraon.
Four Panorama Models are available: the Panorama virtual appliance, M-600 appliance,
M-500 appliance, and M-200 appliance are supported in PAN-OS 10.0. Panorama Centralized
Management illustrates how you can deploy Panorama in a high availability (HA) conﬁguraon to
manage ﬁrewalls.
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Figure 1: Panorama Centralized Management
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Panorama Models
Panorama is available as one of the following virtual or physical appliances, each of which
supports licenses for managing up to 25, 100, or 1,000 ﬁrewalls. Addionally, M-600 appliances
support licenses for managing up to 5,000 ﬁrewalls and similarly resourced Panorama virtual
appliances support licenses for managing up to 2,500 ﬁrewalls:
• Panorama virtual appliance—This model provides simple installaon and facilitates server
consolidaon for sites that need a virtual management appliance. You can install Panorama on
Alibaba Cloud, Amazon Web Services (AWS), AWS GovCloud, Microso Azure, Google Cloud
Plaorm (GCP), KVM, Hyper-V, Oracle Cloud Infrastructure (OCI), a VMware ESXi server, or
on VMware vCloud Air. The virtual appliance can collect ﬁrewall logs locally at rates of up to
20,000 logs per second and can manage Dedicated Log Collectors for higher logging rates. The
virtual appliance can funcon as a dedicated management server, a Panorama management
server with local log collecon capabilies, or as a Dedicated Log Collector. For the supported
interfaces, log storage capacity, and maximum log collecon rates, see the Setup Prerequisites
for the Panorama Virtual Appliance. You can deploy the virtual appliance in the following
modes:
• Panorama mode—In this mode, the Panorama virtual appliance supports a local Log
Collector with 1 to 12 virtual logging disks (see Deploy Panorama Virtual Appliances with
Local Log Collectors). Each logging disk has 2TB of storage capacity for a total maximum of
24TB on a single virtual appliance and 48TB on a high availability (HA) pair. Only Panorama
mode enables you to add mulple virtual logging disks without losing logs on exisng disks.
Panorama mode also provides the beneﬁt of faster report generaon. In Panorama mode,
the virtual appliance does not support NFS storage.
As a best pracce, deploy the virtual appliance in Panorama mode to opmize log
storage and report generaon.
• Legacy mode (ESXi and vCloud Air only)—In this mode, the Panorama virtual appliance
receives and stores ﬁrewall logs without using a local Log Collector (see Deploy Panorama
Virtual Appliances in Legacy Mode with Local Log Collecon). By default, the virtual
appliance in Legacy mode has one disk paron for all data. Approximately 11GB of the
paron is allocated to log storage. If you need more local log storage, you can add one
virtual disk of up to 8TB on ESXi 5.5 and later versions or on vCloud Air. Earlier ESXi
versions support one virtual disk of up to 2TB. If you need more than 8TB, you can mount
the virtual appliance in Legacy mode to an NFS datastore but only on the ESXi server, not in
vCloud Air. This mode is only available if your Panorama virtual appliance is in Legacy mode
on upgrade to PAN-OS 10.0. On upgrade to PAN-OS 9.0 and later releases, Legacy mode is
no longer available if you change to any other mode. If you change your Panorama virtual
appliance from Legacy mode to one of the available modes, you will no longer be able to
change back into Legacy mode.
While supported, Legacy mode is not recommended for producon environments
but may sll be used for lab or demo environments.
• Management Only mode—In this mode, the Panorama virtual appliance is a dedicated
management appliance for your managed devices and Dedicated Log Collectors.
Addionally, an appropriately resourced Panorama virtual appliance can manage up to 2,500
ﬁrewalls in this mode. The Panorama virtual appliance has no log collecon capabilies
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except for conﬁg and system logs and requires a Dedicated Log Collector to these store logs.
By default, the virtual appliance in Management Only mode has only one disk paron for
all data so all logs forwarded to a Panorama virtual appliance in Management Only mode
are dropped. Therefore, to store the log data from your managed appliances, you must
conﬁgure log forwarding in order to store the log data from your managed devices. For more
informaon, see Increased Device Management Capacity Requirements.
• Log Collector mode—The Panorama virtual appliance funcons as a Dedicated Log
Collector. If mulple ﬁrewalls forward large volumes of log data, a Panorama virtual
appliance in Log Collector mode provides increased scale and performance. In this mode, the
appliance does not have a web interface for administrave access; it has only a command
line interface (CLI). However, you can manage the appliance using the web interface of the
Panorama management server. CLI access to a Panorama virtual appliance in Log Collector
mode is necessary only for inial setup and debugging. For conﬁguraon details, see Deploy
Panorama with Dedicated Log Collectors.
• M-Series appliance—The M-200, M-500, and M-600 appliances are dedicated hardware
appliances intended for large-scale deployments. In environments with high logging rates
(over 10,000 logs per second) and log retenon requirements, these appliances enable scaling
of your log collecon infrastructure. For the supported interfaces, log storage capacity, and
maximum log collecon rates, see M-Series Appliance Interfaces. All M-Series models share the
following aributes:
• RAID drives to store ﬁrewall logs and RAID 1 mirroring to protect against disk failures
• SSD to store the logs that Panorama and Log Collectors generate
• MGT, Eth1, Eth2, and Eth3 interfaces that support 1Gbps throughput
• Redundant, hot-swappable power supplies
• front-to-back airﬂow
The M-600 and M-500 appliances have the following addional aributes, which make them
more suitable for data centers:
• Eth4 and Eth5 interfaces that support 10Gbps throughput
Addionally, the following aribute makes the M-600 appliance more suitable for large-scale
ﬁrewall deployments:
• The M-600 appliance in Management Only mode can manage up to 5,000 ﬁrewalls.
You can deploy the M-Series appliances in the following modes:
• Panorama mode—The appliance funcons as a Panorama management server to manage
ﬁrewalls and Dedicated Log Collectors. The appliance also supports a local Log Collector to
aggregate ﬁrewall logs. Panorama mode is the default mode. For conﬁguraon details, see
Deploy Panorama M-Series Appliances with Local Log Collectors.
• Management Only mode—The Panorama appliance is a dedicated management appliance
for your managed devices and Dedicated Log Collectors. The Panorama appliance has no
log collecon capabilies except for conﬁg and system logs and your deployment requires
a Dedicated Log Collector to store these logs. By default, the Panorama appliance in
Management Only mode has only one disk paron for all data so all logs forwarded to a
Panorama virtual appliance in Management Only mode are dropped. Therefore, to store the
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log data from your managed appliances, you must conﬁgure log forwarding in order to store
the log data from your managed devices.
• Log Collector mode—The appliance funcons as a Dedicated Log Collector. If mulple
ﬁrewalls forward large volumes of log data, an M-Series appliance in Log Collector mode
provides increased scale and performance. IIn this mode, the appliance does not have a web
interface for administrave access; it has only a command line interface (CLI). However, you
can manage the appliance using the web interface of the Panorama management server. CLI
access to an M-Series appliance in Log Collector mode is necessary only for inial setup and
debugging. For conﬁguraon details, see Deploy Panorama with Dedicated Log Collectors.
For more details and speciﬁcaons for the M-Series appliances, see the M-Series Appliance
Hardware Reference Guides.
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Centralized Firewall Conﬁguraon and Update
Management
Panorama™ uses device groups and templates to group ﬁrewalls into logical sets that require
similar conﬁguraon. You use device groups and templates to centrally manage all conﬁguraon
elements, policies, and objects on the managed ﬁrewalls. Panorama also enables you to centrally
manage licenses, soware (PAN-OS® soware, SSL-VPN client soware, GlobalProtect™ agent/
app soware), and content updates (Applicaons, Threats, WildFire®, and Anvirus). All device
group, template, and template stack conﬁguraon objects are required to have a unique name.
In the event an unforeseen restart of your managed ﬁrewall or Panorama occurs, all uncommied
conﬁguraon changes in your device groups and templates are preserved locally unl you
successfully commit the changes. A restart can be the restart of the ﬁrewall or Panorama or of a
PAN-OS management process related to conﬁguraon management. For ﬁrewalls or Panorama in
a high availability (HA) conﬁguraon, the uncommied conﬁguraon changes do not automacally
sync across the HA peers in the event of an unforeseen restart.
• Context Switch—Firewall or Panorama
• Total Conﬁguraon Size for Panorama
• Templates and Template Stacks
• Device Groups

Context Switch—Firewall or Panorama
The Panorama™ web interface enables you to toggle between a Panorama-centric view and a
ﬁrewall-centric view using the Context drop-down at the top-le of every tab. Set the Context
to Panorama to manage ﬁrewalls centrally or switch context to the web interface of a speciﬁc
ﬁrewall to conﬁgure it locally. The similarity of the Panorama and ﬁrewall web interfaces enables
you to seamlessly move between them to monitor and manage ﬁrewalls.
The Context drop-down lists only the ﬁrewalls that are connected to Panorama. For a Device
Group and Template administrator, the drop-down lists only the connected ﬁrewalls that are
within the Access Domains assigned to that administrator. To search a long list, use the Filters
within the drop-down.
For ﬁrewalls in a high availability (HA) conﬁguraon, the icons have colored backgrounds to
indicate the HA state (as follows). Knowing the HA state is useful when selecng a ﬁrewall
context. For example, you generally make ﬁrewall-speciﬁc conﬁguraon changes on an acve
ﬁrewall.
• Green—Acve.
• Yellow—Passive or the ﬁrewall is iniang (the iniang state lasts for up to 60 seconds aer
boot up).
• Red—The ﬁrewall is non-funconal (error state), suspended (an administrator disabled the
ﬁrewall), or tentave (for a link or path monitoring event in an acve/acve HA conﬁguraon).
When you conﬁgure an admin role proﬁle for a Device Group and Template admin, you must
assign a Device Admin Role that is pushed to your managed ﬁrewalls to context switch between
the Panorama and ﬁrewall web interface.
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During the context switch, Panorama validates if the admin has access to a speciﬁc vsys or for all
vsys. If the admin has access to all vsys, then Panorama uses the device admin role context switch.
If the admin has access to one or some of the vsys, then Panorama uses the vsys admin role to
context switch.

Total Conﬁguraon Size for Panorama
The total conﬁguraon ﬁle size of Panorama™ M-Series and virtual appliances is an important
piece of the performance metric when determining which M-Series appliance or the minimum
amount of virtual resources you need to allocate on your Panorama virtual appliance to ensure
that you meet your Security requirements. Exceeding the supported total conﬁguraon ﬁle size of
the Panorama management server results in reduced performance when performing conﬁguraon
changes, commits, and pushes to managed ﬁrewalls.
The Panorama management server in Panorama mode supports a total conﬁguraon ﬁle size
of 80MB for all template, device group, and Panorama-speciﬁc conﬁguraons. Panorama in
Management Only mode supports up to 120MB or 150MB total conﬁguraon ﬁle size depending
on the Panorama model or resources you allocate to the Panorama virtual appliance. Refer to the
table below for the recommended maximum conﬁguraon ﬁle size based on the Panorama MSeries appliance model or on the resources you allocate to the Panorama virtual appliance.
Panorama Model

Virtual Resources Required

Maximum Recommended
Panorama Conﬁguraon File Size

M-200

N/A

120MB

M-500

120MB

M-600

150MB

Panorama Virtual
Appliance
Refer to the Setup
Prerequisites for the
Panorama Virtual
Appliance for addional
setup informaon.

• 16 vCPU

120MB

• 128GB memory
• 56 vCPU

150MB

• 256GB memory

Templates and Template Stacks
You use templates and template stacks to conﬁgure the sengs that enable ﬁrewalls to
operate on the network. Templates are the basic building blocks you use to conﬁgure the
Network and Device tabs on Panorama™. You can use templates to deﬁne interface and zone
conﬁguraons, to manage the server proﬁles for logging and syslog access, or to deﬁne VPN
conﬁguraons. Template stacks give you the ability to layer mulple templates and create a
combined conﬁguraon. Template stacks simplify management because they allow you to deﬁne
a common base conﬁguraon for all devices aached to the template stack and they give you the
ability to layer templates to create a combined conﬁguraon. This enables you to deﬁne templates
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with locaon- or funcon-speciﬁc sengs and then stack the templates in descending order of
priority so that ﬁrewalls inherit the sengs based on the order of the templates in the stack.
Both templates and template stacks support variables. Variables allow you to create placeholder
objects with their value speciﬁed in the template or template stack based on your conﬁguraon
needs. Create a template or template stack variable to replace IP addresses, Group IDs, and
interfaces in your conﬁguraons. Template variables are inherited by the template stack and you
can override them to create a template stack variable. However, templates do not inherit variables
deﬁned in the template stack. When a variable is deﬁned in the template or template stack and
pushed to the ﬁrewall, the value deﬁned for the variable is displayed on the ﬁrewall.
Use templates to accommodate ﬁrewalls that have unique sengs. Alternavely, you can push
a broader, common base conﬁguraon and then override certain pushed sengs with ﬁrewallspeciﬁc values on individual ﬁrewalls. When you override a seng on the ﬁrewall, the ﬁrewall
saves that seng to its local conﬁguraon and Panorama no longer manages the seng. To
restore template values aer you override them, use Panorama to force the template or template
stack conﬁguraon onto the ﬁrewall. For example, aer you deﬁne a common NTP server in a
template and override the NTP server conﬁguraon on a ﬁrewall to accommodate a local me
zone, you can later revert to the NTP server deﬁned in the template.
When deﬁning a template stack, consider assigning ﬁrewalls that are the same hardware model
and require access to similar network resources, such as gateways and syslog servers. This enables
you to avoid the redundancy of adding every seng to every template stack. The following ﬁgure
illustrates an example conﬁguraon in which you assign data center ﬁrewalls in the Asia-Paciﬁc
(APAC) region to a stack with global sengs, one template with APAC-speciﬁc sengs, and one
template with data center-speciﬁc sengs. To manage ﬁrewalls in an APAC branch oﬃce, you can
then re-use the global and APAC-speciﬁc templates by adding them to another stack that includes
a template with branch-speciﬁc sengs. Templates in a stack have a conﬁgurable priority order
that ensures Panorama pushes only one value for any duplicate seng. Panorama evaluates the
templates listed in a stack conﬁguraon from top to boom with higher templates having priority.
The following ﬁgure illustrates a data center stack in which the data center template has a higher
priority than the global template: Panorama pushes the idle meout value from the data center
template and ignores the value from the global template.
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Figure 2: Template Stacks
You cannot use templates or template stacks to set ﬁrewall modes: virtual private network (VPN)
mode, mulple virtual systems (mul-vsys) mode, or operaonal modes (normal or FIPS-CC mode).
For details, see Template Capabilies and Excepons. However, you can assign ﬁrewalls that
have non-matching modes to the same template or stack. In such cases, Panorama pushes modespeciﬁc sengs only to ﬁrewalls that support those modes. As an excepon, you can conﬁgure
Panorama to push the sengs of the default vsys in a template to ﬁrewalls that don’t support
virtual systems or that don’t have any virtual systems conﬁgured.
For the relevant procedures, see Manage Templates and Template Stacks.

Device Groups
To use Panorama eﬀecvely, you have to group the ﬁrewalls in your network into logical units
called device groups. A device group enables grouping based on network segmentaon, geographic
locaon, organizaonal funcon, or any other common aspect of ﬁrewalls that require similar
policy conﬁguraons. Using device groups, you can conﬁgure policy rules and the objects they
reference. You can organize device group hierarchically, with shared rules and objects at the top,
and device group-speciﬁc rules and objects at subsequent levels. This enables you to create a
hierarchy of rules that enforce how ﬁrewalls handle traﬃc. For example, you can deﬁne a set of
shared rules as a corporate acceptable use policy. Then, to allow only regional oﬃces to access
peer-to-peer traﬃc such as BitTorrent, you can deﬁne a device group rule that Panorama pushes
only to the regional oﬃces (or deﬁne a shared security rule and target it to the regional oﬃces).
For the relevant procedures, see Manage Device Groups. The following topics describe device
group concepts and components in more detail:
• Device Group Hierarchy
• Device Group Policies
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• Device Group Objects

Device Group Hierarchy
You can Create a Device Group Hierarchy to nest device groups in a tree hierarchy of up to four
levels, with lower-level groups inhering the sengs (policy rules and objects) of higher-level
groups. At the boom level, a device group can have parent, grandparent, and great-grandparent
device groups (ancestors). At the top level, a device group can have child, grandchild, and greatgrandchild device groups (descendants). All device groups inhering sengs from the Shared
locaon—a container at the top of the hierarchy for conﬁguraons that are common to all device
groups.
Creang a device group hierarchy enables you to organize ﬁrewalls based on common policy
requirements without redundant conﬁguraon. For example, you could conﬁgure shared sengs
that are global to all ﬁrewalls, conﬁgure device groups with funcon-speciﬁc sengs at the
ﬁrst level, and conﬁgure device groups with locaon-speciﬁc sengs at lower levels. Without
a hierarchy, you would have to conﬁgure both funcon- and locaon-speciﬁc sengs for every
device group in a single level under Shared.

Figure 3: Device Group Hierarchy
For details on the order in which ﬁrewalls evaluate policy rules in a device group hierarchy, see
Device Group Policies. For details on overriding the values of objects that device groups inherit
from ancestor device groups, see Device Group Objects.
In a mulple Panorama plugin deployment to perform, a device group containing ﬁrewalls
deployed in a parcular hypervisor cannot be the child or parent of a device group containing
ﬁrewalls deployed in a diﬀerent hypervisor. For example, if Panorama receives IP address updates
from VMware NSX-V and AWS, you cannot create a device group of NSX-V VM-Series ﬁrewalls
that is a child of an AWS VM-Series ﬁrewall device group.
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Device Group Policies
Device groups provide a way to implement a layered approach for managing policies across a
network of managed ﬁrewalls. A ﬁrewall evaluates policy rules by layer (shared, device group,
and local) and by type (pre-rules, post-rules, and default rules) in the following order from top to
boom. When the ﬁrewall receives traﬃc, it performs the acon deﬁned in the ﬁrst evaluated
rule that matches the traﬃc and disregards all subsequent rules. To change the evaluaon order
for rules within a parcular layer, type, and rulebase (for example, shared Security pre-rules), see
Manage the Rule Hierarchy.
Whether you view rules on a ﬁrewall or in Panorama, the web interface displays them in
evaluaon order. All the shared, device group, and default rules that the ﬁrewall inherits from
Panorama are shaded orange. Local ﬁrewall rules display between the pre-rules and post-rules.
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Evaluaon Order

Rule Scope and Descripon

Administraon Device

Shared pre-rules

Panorama pushes shared pre-rules
to all the ﬁrewalls in all device
groups. Panorama pushes device
group-speciﬁc pre-rules to all the
ﬁrewalls in a parcular device group
and its descendant device groups.

These rules are visible on ﬁrewalls
but you can only manage them in
Panorama.

Device group prerules

If a ﬁrewall inherits rules from
device groups at mulple levels
in the device group hierarchy, it
evaluates pre-rules in the order of
highest to lowest level. This means
the ﬁrewall ﬁrst evaluates shared
rules and last evaluates the rules of
device groups with no descendants.
You can use pre-rules to enforce
the acceptable use policy of an
organizaon. For example, a prerule might block access to speciﬁc
URL categories or allow Domain
Name System (DNS) traﬃc for all
users.
Local ﬁrewall
rules

Local rules are speciﬁc to a single
ﬁrewall or virtual system (vsys).

A local ﬁrewall administrator, or
a Panorama administrator who
switches to a local ﬁrewall context,
can edit local ﬁrewall rules.

Device group
post-rules

Panorama pushes shared postrules to all the ﬁrewalls in all device
groups. Panorama pushes device
group-speciﬁc post-rules to all the
ﬁrewalls in a parcular device group
and its descendant device groups.

These rules are visible on ﬁrewalls
but you can only manage them in
Panorama.

Shared post-rules

If a ﬁrewall inherits rules from
device groups at mulple levels
in the device group hierarchy, it
evaluates post-rules in the order
of lowest to highest level. This
means the ﬁrewall ﬁrst evaluates
the rules of device groups with no
descendants and last evaluates
shared rules.
Post-rules typically include rules
to deny access to traﬃc based on
the App-ID™ signatures, User-ID™
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Evaluaon Order

Rule Scope and Descripon

Administraon Device

informaon (users or user groups),
or service.
intrazone-default
interzone-default

The default rules apply only to
the Security rulebase, and are
predeﬁned on Panorama (at the
Shared level) and the ﬁrewall (in
each vsys). These rules specify how
PAN-OS handles traﬃc that doesn’t
match any other rule.
The intrazone-default rule allows all
traﬃc within a zone. The interzonedefault rule denies all traﬃc
between zones.
If you override default rules, their
order of precedence runs from
the lowest context to the highest:
overridden sengs at the ﬁrewall
level take precedence over sengs
at the device group level, which
take precedence over sengs at
the Shared level.

Default rules are inially readonly, either because they are part
of the predeﬁned conﬁguraon
or because Panorama pushed
them to ﬁrewalls. However, you
can override the rule sengs for
tags, acon, logging, and security
proﬁles. The context determines
the level at which you can override
the rules:
• Panorama—At the Shared or
device group level, you can
override default rules that
are part of the predeﬁned
conﬁguraon.
• Firewall—You can override
default rules that are part of
the predeﬁned conﬁguraon
on the ﬁrewall or vsys, or that
Panorama pushed from the
Shared locaon or a device
group.

Device Group Objects
Objects are conﬁguraon elements that policy rules reference, for example: IP addresses, URL
categories, security proﬁles, users, services, and applicaons. Rules of any type (pre-rules, postrules, default rules, and rules locally deﬁned on a ﬁrewall) and any rulebase (Security, NAT, QoS,
Policy Based Forwarding, Decrypon, Applicaon Override, Capve Portal, and DoS Protecon)
can reference objects. You can reuse an object in any number of rules that have the same scope
as that object in the Device Group Hierarchy. For example, if you add an object to the Shared
locaon, all rules in the hierarchy can reference that shared object because all device groups
inherit objects from Shared. If you add an object to a parcular device group, only the rules in that
device group and its descendant device groups can reference that device group object. If object
values in a device group must diﬀer from those inherited from an ancestor device group, you can
Override inherited object values (see Step Override inherited object values.). You can also Revert
to Inherited Object Values at any me. When you Create Objects for Use in Shared or Device
Group Policy once and use them many mes, you reduce administrave overhead and ensure
consistency across ﬁrewall policies.
You can conﬁgure how Panorama handles objects system-wide:
• Pushing unused objects—By default, Panorama pushes all objects to ﬁrewalls regardless of
whether any shared or device group policy rules reference the objects. Oponally, you can
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conﬁgure Panorama to push only referenced objects. For details, see Manage Unused Shared
Objects.
• Precedence of ancestor and descendant objects—By default, when device groups at mulple
levels in the hierarchy have an object with the same name but diﬀerent values (because of
overrides, as an example), policy rules in a descendant device group use the object values in
that descendant instead of object values inherited from ancestor device groups or Shared.
Oponally, you can reverse this order of precedence to push values from Shared or the highest
ancestor containing the object to all descendant device groups. For details, see Manage
Precedence of Inherited Objects.
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Centralized Logging and Reporng
Panorama aggregates logs from all managed ﬁrewalls and provides visibility across all the traﬃc on
the network. It also provides an audit trail for all policy modiﬁcaons and conﬁguraon changes
made to the managed ﬁrewalls. In addion to aggregang logs, Panorama can forward them as
SNMP traps, email noﬁcaons, syslog messages, and HTTP payloads to an external server.
For centralized logging and reporng, you also have the opon to use the cloud-based Cortex
Data Lake that is architected to work seamlessly with Panorama. The Cortex Data Lake allows
your managed ﬁrewalls to forward logs to the Cortex Data Lake infrastructure instead of to
Panorama or to the managed Log Collectors, so you can augment your exisng distributed log
collecon setup or to scale your current logging infrastructure without having to invest me and
eﬀort yourself.
The Applicaon Command Center (ACC) on Panorama provides a single pane for uniﬁed
reporng across all the ﬁrewalls. It enables you to centrally Monitor Network Acvity, to analyze,
invesgate, and report on traﬃc and security incidents. On Panorama, you can view logs and
generate reports from logs forwarded to the Cortex Data Lake, Panorama or to the managed Log
Collectors, if conﬁgured, or you can query the managed ﬁrewalls directly. For example, you can
generate reports about traﬃc, threat, and/or user acvity in the managed network based on logs
stored on Panorama (and the managed collectors) or by accessing the logs stored locally on the
managed ﬁrewalls, or in the Cortex Data Lake.
If you don’t Conﬁgure Log Forwarding to Panorama or the Cortex Data Lake, you can schedule
reports to run on each managed ﬁrewall and forward the results to Panorama for a combined
view of user acvity and network traﬃc. Although reports don’t provide a granular drill-down on
speciﬁc informaon and acvies, they sll provide a uniﬁed monitoring approach.
• Managed Collectors and Collector Groups
• Local and Distributed Log Collecon
• Caveats for a Collector Group with Mulple Log Collectors
• Log Forwarding Opons
• Centralized Reporng

Managed Collectors and Collector Groups
Panorama uses Log Collectors to aggregate logs from managed ﬁrewalls. When generang reports,
Panorama queries the Log Collectors for log informaon, providing you visibility into all the
network acvity that your ﬁrewalls monitor. Because you use Panorama to conﬁgure and manage
Log Collectors, they are also known as managed collectors. Panorama can manage two types of Log
Collectors:
• Local Log Collector—This type of Log Collector runs locally on the Panorama management
server. Only an M-600, M-500 appliance, M-200, M-100 appliance, or Panorama virtual
appliance in Panorama mode supports a local Log Collector.
If you forward logs to a Panorama virtual appliance in Legacy mode, it stores the logs
locally without a Log Collector.
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• Dedicated Log Collector—This is an M-600, M-500, M-200, M-100 appliance or Panorama
virtual appliance in Log Collector mode. You can use an M-Series appliance in Panorama mode
or a Panorama virtual appliance in Panorama or Legacy (ESXi and vCloud Air) mode to manage
Dedicated Log Collectors. To use the Panorama web interface for managing Dedicated Log
Collectors, you must add them as managed collectors. Otherwise, administrave access to a
Dedicated Log Collector is only available through its CLI using the predeﬁned administrave
user (admin) account. Dedicated Log Collectors don’t support addional administrave user
accounts.
You can use either or both types of Log Collectors to achieve the best logging soluon for your
environment (see Local and Distributed Log Collecon).
A Collector Group is 1 to 16 managed collectors that operate as a single logical log collecon
unit. If the Collector Group contains Dedicated Log Collectors, Panorama uniformly distributes
the logs across all the disks in each Log Collector and across all Log Collectors in the group. This
distribuon opmizes the available storage space. To enable a Log Collector to receive logs,
you must add it to a Collector Group. You can enable log redundancy by assigning mulple Log
Collectors to a Collector Group (see Caveats for a Collector Group with Mulple Log Collectors).
The Collector Group conﬁguraon speciﬁes which managed ﬁrewalls can send logs to the Log
Collectors in the group.
To conﬁgure Log Collectors and Collector Groups, see Manage Log Collecon.

Local and Distributed Log Collecon
Before you Conﬁgure Log Forwarding to Panorama, you must decide whether to use local Log
Collectors, Dedicated Log Collectors, or both.
A local Log Collector is easy to deploy because it requires no addional hardware or virtual
machine instance. In a high availability (HA) conﬁguraon, you can send logs to the local Log
Collector on both Panorama peers; the passive Panorama doesn’t wait for failover to start
collecng logs.
For local log collecon, you can also forward logs to a Panorama virtual appliance in
Legacy mode, which stores the logs without using a Log Collector as a logical container.
Dedicated Log Collectors are M-600, M-500, M-200, or Panorama virtual appliance in Log
Collector mode. Because they perform only log collecon, not ﬁrewall management, Dedicated
Log Collectors allow for a more robust environment than local Log Collectors. Dedicated Log
Collectors provide the following beneﬁts:
• Enable the Panorama management server to use more resources for management funcons
instead of logging.
• Provide high-volume log storage on a dedicated hardware appliance.
• Enable higher logging rates.
• Provide horizontal scalability and redundancy with RAID 1 storage.
• Opmize bandwidth resources in networks where more bandwidth is available for ﬁrewalls to
send logs to nearby Log Collectors than to a remote Panorama management server.
• Enable you to meet regional regulatory requirements (for example, regulaons might not allow
logs to leave a parcular region).
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Distributed Log Collecon illustrates a topology in which the Panorama peers in an HA
conﬁguraon manage the deployment and conﬁguraon of ﬁrewalls and Dedicated Log Collectors.
You can deploy the Panorama management server in an HA conﬁguraon but not the
Dedicated Log Collectors.

Figure 4: Distributed Log Collection

Caveats for a Collector Group with Mulple Log Collectors
You can Conﬁgure a Collector Group with mulple Log Collectors (up to 16) to ensure log
redundancy, increase the log retenon period, and accommodate logging rates that exceed
the capacity of a single Log Collector (see Panorama Models for capacity informaon). In any
single Collector Group, all the Log Collectors must run on the same Panorama model: all M-600
appliances, all M-500 appliances, all, M-200 appliances all, or all Panorama virtual appliances. For
example, if a single managed ﬁrewall generates 48TB of logs, the Collector Group that receives
those logs will require at least six Log Collectors that are M-200 appliances or two Log Collectors
that are M-500 appliances or Panorama virtual appliances.
A Collector Group with mulple Log Collectors uses the available storage space as one logical
unit and uniformly distributes the logs across all its Log Collectors. The log distribuon is based
on the disk capacity of the Log Collectors (see Panorama Models) and a hash algorithm that
dynamically decides which Log Collector owns the logs and writes to disk. Although Panorama
uses a preference list to priorize the list of Log Collectors to which a managed ﬁrewall can
forward logs, Panorama does not necessarily write the logs to the ﬁrst Log Collector speciﬁed in
the preference list. For example, consider the following preference list:
Managed Firewall

Log Forwarding Preference List Deﬁned in a Collector Group

FW1

L1,L2,L3

FW2

L4,L5,L6
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Using this list, FW1 will forward logs to L1 so long as that primary Log Collector is available.
However, based on the hash algorithm, Panorama might choose L2 as the owner that writes the
logs to its disks. If L2 becomes inaccessible or has a chassis failure, FW1 will not know because it
can sll connect to L1.

Figure 5: Example - Typical Log Collector Group Setup
In the case where a Collector Group has only one Log Collector and the Log Collector fails, the
ﬁrewall stores the logs to its HDD/SSD (the available storage space varies by ﬁrewall model). As
soon as connecvity is restored to the Log Collector, the ﬁrewall resumes forwarding logs where it
le oﬀ before the failure occurred.
In the case of a Collector Group with mulple Log Collectors, the ﬁrewall does not buﬀer logs to
its local storage if only one Log Collector is down. In the example scenario where L2 is down, FW1
connues sending logs to L1, and L1 stores the log data that would be sent to L2. Once L2 is back
up, L1 no longer stores log data intended for L2 and distribuon resumes as expected. If one of
the Log Collectors in a Collector Group goes down, the logs that would be wrien to the down
Log Collector are redistributed to the next Log Collector in the preference list.
Palo Alto Networks recommends adding at least three Log Collectors to a Collector Group
to avoid split brain and log ingeson issues should one Log Collector go down. See the
changes to default Collector Group behavior for more informaon.

Figure 6: Example - When a Log Collector Fails
Palo Alto Networks recommends the following migaons if using mulple Log Collectors in a
Collector Group:
• Enable log redundancy when you Conﬁgure a Collector Group. This ensures that no logs are
lost if any one Log Collector in the Collector Group becomes unavailable. Each log will have
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two copies and each copy will reside on a diﬀerent Log Collector. Log redundancy is available
only if each Log Collector has the same number of logging disks.
Because enabling redundancy creates more logs, this conﬁguraon requires more
storage capacity. When a Collector Group runs out of space, it deletes older logs.
Enabling redundancy doubles the log processing traﬃc in a Collector Group, which
reduces its maximum logging rate by half, as each Log Collector must distribute a copy
of each log it receives.
• Obtain an On-Site-Spare (OSS) to enable prompt replacement if a Log Collector failure occurs.
• In addion to forwarding logs to Panorama, conﬁgure forwarding to an external service as
backup storage. The external service can be a syslog server, email server, SNMP trap server, or
HTTP server.

Log Forwarding Opons
By default, each ﬁrewall stores its log ﬁles locally. To use Panorama for centralized log monitoring
and report generaon, you must Conﬁgure Log Forwarding to Panorama. Panorama supports
forwarding logs to either a Log Collector, the Cortex Data Lake, or both in parallel. You can also
use external services for archiving, noﬁcaon, or analysis by forwarding logs to the services
directly from the ﬁrewalls or from Panorama. External services include the syslog servers, email
servers, SNMP trap servers, or HTTP-based services. In addion to forwarding ﬁrewall logs, you
can forward the logs that the Panorama management server and Log Collectors generate. The
Panorama management server, Log Collector, or ﬁrewall that forwards the logs converts them to
a format that is appropriate for the desnaon (syslog message, email noﬁcaon, SNMP trap, or
HTTP payload).
Palo Alto Networks ﬁrewalls and Panorama support the following log forwarding opons. Before
choosing an opon, consider the logging capacies of your Panorama Models and Determine
Panorama Log Storage Requirements.
• Forward logs from ﬁrewalls to Panorama and from Panorama to external services—This
conﬁguraon is best for deployments in which the connecons between ﬁrewalls and external
services have insuﬃcient bandwidth to sustain the logging rate, which is oen the case when
the connecons are remote. This conﬁguraon improves ﬁrewall performance by oﬄoading
some processing to Panorama.
You can conﬁgure each Collector Group to forward logs to diﬀerent desnaons.
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Figure 7: Log Forwarding to Panorama and then to External Services
• Forward logs from ﬁrewalls to Panorama and to external services in parallel—In this
conﬁguraon, both Panorama and the external services are endpoints of separate log
forwarding ﬂows; the ﬁrewalls don’t rely on Panorama to forward logs to external services. This
conﬁguraon is best for deployments in which the connecons between ﬁrewalls and external
services have suﬃcient bandwidth to sustain the logging rate, which is oen the case when the
connecons are local.

Figure 8: Log Forwarding to External Services and Panorama in Parallel

Centralized Reporng
Panorama aggregates logs from all managed ﬁrewalls and enables reporng on the aggregated
data for a global view of applicaon use, user acvity, and traﬃc paerns across the enre
network. As soon as the ﬁrewalls are added to Panorama, the ACC can display all traﬃc traversing

Panorama Administrator's Guide Version Version 10.1

31

©2022 Palo Alto Networks, Inc.

Panorama Overview
your network. With logging enabled, clicking into a log entry in the ACC provides direct access to
granular details about the applicaon.
For generang reports, Panorama uses two sources: the local Panorama database and the remote
ﬁrewalls that it manages. The Panorama database refers to the local storage on Panorama that
is allocated for storing both summarized logs and some detailed logs. If you have a distributed
Log Collecon deployment, the Panorama database includes the local storage on Panorama
and all the managed Log Collectors. Panorama summarizes the informaon—traﬃc, applicaon,
threat— collected from all managed ﬁrewalls at 15-minute intervals. Using the local Panorama
database allows for faster response mes, however, if you prefer to not forward logs to Panorama,
Panorama can directly access the remote ﬁrewall and run reports on data that is stored locally on
the managed ﬁrewalls.
Panorama oﬀers more than 40 predeﬁned reports that can be used as is, or they can be
customized by combining elements of other reports to generate custom reports and report groups
that can be saved. Reports can be generated on demand, on a recurring schedule, and can be
scheduled for email delivery. These reports provide informaon on the user and the context so
that you correlate events and idenfy paerns, trends, and potenal areas of interest. With the
integrated approach to logging and reporng, the ACC enables correlaon of entries from mulple
logs relang to the same event.
For more informaon, see Monitor Network Acvity.
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Data Redistribuon Using Panorama
With data redistribuon, you only have to conﬁgure each source once, then you can redistribute
mulple data types to as many clients as needed. This helps you to scale your network so that you
can easily add or remove source and clients as your network needs change.
Data redistribuon also provides granularity by redistribung only the types of informaon to only
the ﬁrewalls or Panorama management systems that you specify. You can use subnets, ranges, and
regions to further reduce network traﬃc and maximize device capacity.
One of the key beneﬁts of the Palo Alto Networks ﬁrewall is that it can enforce policies and
generate reports based on usernames and tags instead of IP addresses. The challenge for largescale networks is ensuring every ﬁrewall that enforces policies and generates reports has the
mappings and tags that apply for all of your policy rules. Addionally, every ﬁrewall that enforces
Authencaon Policy requires a complete, idencal set of authencaon mestamps for your
user base. Whenever users authencate to access services and applicaons, individual ﬁrewalls
record the associated mestamps but don’t automacally share them with other ﬁrewalls to
ensure consistency. Data redistribuon solves these challenges for large-scale networks by
enabling you to redistribute the necessary data. However, instead of seng up extra connecons
to redistribute the data between ﬁrewalls, you can leverage your Panorama infrastructure to
Redistribute Data to Managed Firewalls. The infrastructure has exisng connecons that enable
you to redistribute data in layers, from ﬁrewalls to Panorama. Panorama can then redistribute the
informaon to the ﬁrewalls that enforce policies and generate reports.
Each ﬁrewall or Panorama management server can receive data from up to 100 redistribuon
points. The redistribuon points can be other ﬁrewalls or Panorama management servers.
However, you can also use Windows-based User-ID agents to perform the mapping and
redistribute the informaon to ﬁrewalls. Only the ﬁrewalls record authencaon mestamps
when user traﬃc matches Authencaon policy rules.
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Role-Based Access Control
Role-based access control (RBAC) enables you to deﬁne the privileges and responsibilies of
administrave users (administrators). Every administrator must have a user account that speciﬁes
a role and authencaon method. Administrave Roles deﬁne access to speciﬁc conﬁguraon
sengs, logs, and reports within Panorama and ﬁrewall contexts. For Device Group and Template
administrators, you can map roles to Access Domains, which deﬁne access to speciﬁc device
groups, templates, and ﬁrewalls (through context switching). By combining each access domain
with a role, you can enforce the separaon of informaon among the funconal or regional areas
of your organizaon. For example, you can limit an administrator to monitoring acvies for data
center ﬁrewalls but allow that administrator to set policies for test lab ﬁrewalls. By default, every
Panorama appliance (virtual appliance or M-Series appliance) has a predeﬁned administrave
account (admin) that provides full read-write access (superuser access) to all funconal areas
and to all device groups, templates, and ﬁrewalls. For each administrator, you can deﬁne an
authencaon proﬁle that determines how Panorama veriﬁes user access credenals.
Instead of using the default account for all administrators, it is a best pracce to create a
separate administrave account for each person who needs access to the administrave
or reporng funcons on Panorama. This provides beer protecon against unauthorized
conﬁguraon changes and enables Panorama to log and idenfy the acons of each
administrator.
• Administrave Roles
• Authencaon Proﬁles and Sequences
• Access Domains
• Administrave Authencaon

Administrave Roles
You conﬁgure administrator accounts based on the security requirements of your organizaon,
any exisng authencaon services that your network uses, and the required administrave roles.
A role deﬁnes the type of system access that is available to an administrator. You can deﬁne and
restrict access as broadly or granularly as required, depending on the security requirements of
your organizaon. For example, you might decide that a data center administrator can have access
to all device and networking conﬁguraons, but a security administrator can control only security
policy deﬁnions, while other key individuals can have limited CLI or XML API access. The role
types are:
• Dynamic Roles—These are built-in roles that provide access to Panorama and managed
ﬁrewalls. When new features are added, Panorama automacally updates the deﬁnions of
dynamic roles; you never need to manually update them. The following table lists the access
privileges associated with dynamic roles.
Dynamic Role

Privileges

Superuser

Full read-write access to Panorama
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Dynamic Role

Privileges

Superuser (readonly)

Read-only access to Panorama

Panorama
administrator

Full access to Panorama except for the following acons:
• Create, modify, or delete Panorama or ﬁrewall administrators and
roles.
• Export, validate, revert, save, load, or import a conﬁguraon in the
Device > Setup > Operaons page.
• Conﬁgure Scheduled Conﬁg Export funconality in the Panorama
tab.
• Generate Tech Support File, Generate Stats Dump File, and
Download Core Files (Panorama > Support)

• Admin Role Proﬁles—To provide more granular access control over the funconal areas of the
web interface, CLI, and XML API, you can create custom roles. When new features are added
to the product, you must update the roles with corresponding access privileges: Panorama does
not automacally add new features to custom role deﬁnions. You select one of the following
proﬁle types when you Conﬁgure an Admin Role Proﬁle.
Admin Role Proﬁle

Descripon

Panorama

For these roles, you can assign read-write access, read-only access,
or no access to all the Panorama features that are available to
the superuser dynamic role except the management of Panorama
administrators and Panorama roles. For the laer two features, you can
assign read-only access or no access, but you cannot assign read-write
access.
An example use of a Panorama role would be for security administrators
who require access to security policy deﬁnions, logs, and reports on
Panorama.
Custom Panorama admin roles have the following limitaons:
• No access to Reboot Panorama (Panorama > Setup > Operaons)
• No access to Generate Tech Support File, Generate Stats Dump File,
and Download Core Files (Panorama > Support)

Device Group and
Template

For these roles, you can assign read-write access, read-only access, or
no access to speciﬁc funconal areas within device groups, templates,
and ﬁrewall contexts. By combining these roles with Access Domains,
you can enforce the separaon of informaon among the funconal or
regional areas of your organizaon. Device Group and Template roles
have the following limitaons:
• No access to the CLI or XML API
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Admin Role Proﬁle

Descripon
• No access to conﬁguraon or system logs
• No access to VM informaon sources
• No access to Reboot Panorama (Panorama > Setup > Operaons)
• No access to Generate Tech Support File, Generate Stats Dump File,
and Download Core Files (Panorama > Support)
• In the Panorama tab, access is limited to:
• Device deployment features (read-write, read-only, or no access)
• The device groups speciﬁed in the administrator account (readwrite, read-only, or no access)
• The templates and managed ﬁrewalls speciﬁed in the
administrator account (read-only or no access)
An example use of this role would be for administrators in your
operaons staﬀ who require access to the device and network
conﬁguraon areas of the web interface for speciﬁc device groups and/
or templates.

Authencaon Proﬁles and Sequences
An authencaon proﬁle deﬁnes the authencaon service that validates the login credenals
of administrators when they access Panorama. The service can be local authencaon or an
external authencaon service. Some services (SAML, TACACS+, and RADIUS) provide the opon
to manage both authencaon and authorizaon for administrave accounts on the external
server instead of on Panorama. In addion to the authencaon service, the authencaon proﬁle
deﬁnes opons such as Kerberos single sign-on (SSO) and SAML single logout (SSO).
Some networks have mulple databases (such as TACACS+ and LDAP) for diﬀerent users and user
groups. To authencate administrators in such cases, conﬁgure an authencaon sequence—a
ranked order of authencaon proﬁles that Panorama matches an administrator against during
login. Panorama checks against each proﬁle in sequence unl one successfully authencates the
administrator. An administrator is denied access only if authencaon fails for all the proﬁles in
the sequence.

Access Domains
Access domains control administrave access to speciﬁc Device Groups and templates, and also
control the ability to switch context to the web interface of managed ﬁrewalls. Access domains
apply only to administrators with Device Group and Template roles. Mapping Administrave
Roles to access domains enables very granular control over the informaon that administrators
access on Panorama. For example, consider a scenario where you conﬁgure an access domain
that includes all the device groups for ﬁrewalls in your data centers and you assign that access
domain to an administrator who is allowed to monitor data center traﬃc but who is not allowed
to conﬁgure the ﬁrewalls. In this case, you would map the access domain to a role that enables
all monitoring privileges but disables access to device group sengs. Addionally, Device Group
and Template admins can perform administrave tasks for managed ﬁrewalls in their access
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domain such as viewing the conﬁguraon and system logs, perform conﬁguraon audits, review
pending tasks, and directly access ﬁrewall operaons such as reboot, generang a tech support
ﬁle, execung a stats dump, and exporng a core ﬁle.
You conﬁgure access domains in the local Panorama conﬁguraon and then assign them to
administrave accounts and roles. You can perform the assignment locally or use an external
SAML, TACACS+, or RADIUS server. Using an external server enables you to quickly reassign
access domains through your directory service instead of reconﬁguring sengs on Panorama.
To use an external server, you must deﬁne a server proﬁle that enables Panorama to access the
server. You must also deﬁne Vendor-Speciﬁc Aributes (VSAs) on the RADIUS or TACACS+ server,
or SAML aributes on the SAML IdP server.
For example, if you use a RADIUS server, you would deﬁne a VSA number and value for each
administrator. The value deﬁned has to match the access domain conﬁgured on Panorama.
When an administrator tries to log in to Panorama, Panorama queries the RADIUS server for the
administrator access domain and aribute number. Based on the response from the RADIUS
server, the administrator is authorized for access and is restricted to the ﬁrewalls, virtual systems,
device groups, and templates that are assigned to the access domain.
For the relevant procedures, see:
• Conﬁgure an Access Domain.
• Conﬁgure RADIUS Authencaon for Panorama Administrators.
• Conﬁgure TACACS+ Authencaon for Panorama Administrators.
• Conﬁgure SAML Authencaon for Panorama Administrators.

Administrave Authencaon
You can conﬁgure the following types of authencaon and authorizaon (Administrave Roles
and Access Domains) for Panorama administrators:
AuthencaonAuthorizaon Descripon
Method
Method
Local

Local

The administrave account credenals and authencaon
mechanisms are local to Panorama. You use Panorama to assign
administrave roles and access domains to the accounts. To
further secure the accounts, you can create a password proﬁle
that deﬁnes a validity period for passwords and set Panoramawide password complexity sengs. For details, see Conﬁgure
Local or External Authencaon for Panorama Administrators.

SSH Keys

Local

The administrave accounts are local to Panorama, but
authencaon to the CLI is based on SSH keys. You use Panorama
to assign administrave roles and access domains to the accounts.
For details, see Conﬁgure an Administrator with SSH Key-Based
Authencaon for the CLI.

Cerﬁcates

Local

The administrave accounts are local to Panorama, but
authencaon to the web interface is based on client cerﬁcates.
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AuthencaonAuthorizaon Descripon
Method
Method
You use Panorama to assign administrave roles and access
domains to the accounts. For details, see Conﬁgure a Panorama
Administrator with Cerﬁcate-Based Authencaon for the Web
Interface.
External
service

Local

The administrave accounts you deﬁne locally on Panorama
serve as references to the accounts deﬁned on an external MulFactor Authencaon, SAML, Kerberos, TACACS+, RADIUS, or
LDAP server. The external server performs authencaon. You
use Panorama to assign administrave roles and access domains
to the accounts. For details, see Conﬁgure Local or External
Authencaon for Panorama Administrators.

External

External
service

The administrave accounts are deﬁned only on an external
SAML, TACACS+, or RADIUS server. The server performs both
authencaon and authorizaon. For authorizaon, you deﬁne
Vendor-Speciﬁc Aributes (VSAs) on the TACACS+ or RADIUS
server, or SAML aributes on the SAML server. Panorama maps
the aributes to administrator roles and access domains that you
deﬁne on Panorama. For details, see:
• Conﬁgure SAML Authencaon for Panorama Administrators
• Conﬁgure TACACS+ Authencaon for Panorama
Administrators
• Conﬁgure RADIUS Authencaon for Panorama
Administrators
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Panorama Commit, Validaon, and Preview Operaons
When you are ready to acvate changes that you made to the candidate conﬁguraon on
Panorama or to push changes to the devices that Panorama manages (ﬁrewalls, Log Collectors, and
WildFire appliances and appliance clusters), you can Preview, Validate, or Commit Conﬁguraon
Changes. For example, if you add a Log Collector to the Panorama conﬁguraon, ﬁrewalls cannot
send logs to that Log Collector unl you commit the change to Panorama and then push the
change to the Collector Group that contains the Log Collector.
You can ﬁlter changes by administrator or locaon and then commit, push, validate, or preview
only those changes. The locaon can be speciﬁc device groups, templates, Collector Groups, Log
Collectors, shared sengs, or the Panorama management server.
When you commit changes, they become part of the running conﬁguraon. Changes that you
haven’t commied are part of the candidate conﬁguraon. Panorama queues commit requests
so that you can iniate a new commit while a previous commit is in progress. Panorama performs
the commits in the order they are iniated but priorizes auto-commits that are iniated by
Panorama (such as FQDN refreshes). However, if the queue already has the maximum number of
administrator-iniated commits (10), you must wait for Panorama to ﬁnish processing a pending
commit before iniang a new one. You can Use the Panorama Task Manager (
) to cancel
pending commits or to see details about commits that are pending, in progress, completed, or
failed. To check which changes a commit will acvate, you can run a commit preview.
When you iniate a commit, Panorama checks the validity of the changes before acvang them.
The validaon output displays condions that block the commit (errors) or that are important to
know (warnings). For example, validaon could indicate an invalid route desnaon that you need
to ﬁx for the commit to succeed. The validaon process enables you to ﬁnd and ﬁx errors before
you commit (it makes no changes to the running conﬁguraon). This is useful if you have a ﬁxed
commit window and want to be sure the commit will succeed without errors.
Automated commit recovery is enabled by default, allowing the managed ﬁrewalls to locally
test the conﬁguraon pushed from Panorama to verify that the new changes do not break the
connecon between Panorama and the managed ﬁrewall. If the commied conﬁguraon breaks
the connecon between Panorama and a managed ﬁrewall then the ﬁrewall automacally fails
the commit and the conﬁguraon is reverted to the previous running conﬁguraon and the
Shared Policy or Template Status (Panorama > Managed Devices > Summary) gets out of sync
depending on which conﬁguraon objects were pushed. Addionally, the managed ﬁrewalls test
their connecon to Panorama every 60 minutes and if a managed ﬁrewall detects that it can no
longer successfully connect to Panorama then it reverts its conﬁguraon to the previous running
conﬁguraon.
For details on candidate and running conﬁguraons, see Manage Panorama and Firewall
Conﬁguraon Backups.
To prevent mulple administrators from making conﬁguraon changes during concurrent
sessions, see Manage Locks for Restricng Conﬁguraon Changes.
When pushing conﬁguraons to managed ﬁrewalls, Panorama pushes the running
conﬁguraon. Because of this, Panorama does not let you push changes to managed
ﬁrewalls unl you ﬁrst commit the changes to Panorama.
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Plan Your Panorama Deployment
Determine the management approach. Do you plan to use Panorama to centrally conﬁgure
and manage the policies, to centrally administer soware, content and license updates, and/or
centralize logging and reporng across the managed ﬁrewalls in the network?
If you already deployed and conﬁgured the Palo Alto Networks ﬁrewalls on your network,
determine whether to transion the ﬁrewalls to centralized management. This process requires
a migraon of all conﬁguraon and policies from your ﬁrewalls to Panorama. For details, see
Transion a Firewall to Panorama Management.
Verify the Panorama and ﬁrewall soware versions. Panorama can manage ﬁrewalls running
PAN-OS versions that match the Panorama version or are earlier than the Panorama version.
For example, Panorama 8.0 cannot manage ﬁrewalls running PAN-OS 8.1. Addionally,
Panorama 8.1 cannot manage ﬁrewalls running PAN-OS 6.0.0 through 6.0.3 and cannot
manage ﬁrewalls that run a later PAN-OS version than the Panorama version.
Plan to use the same URL ﬁltering database (BrightCloud or PAN-DB) across all managed
ﬁrewalls. If some ﬁrewalls are using the BrightCloud database and others are using PAN-DB,
Panorama can only manage security rules for one or the other URL ﬁltering database. URL
ﬁltering rules for the other database must be managed locally on the ﬁrewalls that use that
database.
Determine your authencaon method between Panorama and its managed devices and
high availability peer. By default, Panorama uses predeﬁned cerﬁcates to authencate
the SSL connecons used for management and inter-device communicaon. However, you
can conﬁgure custom cerﬁcate-based authencaon to enhance the security of the SSL
connecons between Panorama, ﬁrewalls, and log collectors. By using custom cerﬁcates,
you can establish a unique chain of trust to ensure mutual authencaon between Panorama
and the devices it manages. You can import the cerﬁcates from your enterprise public key
infrastructure (PKI) or generate it on Panorama.
Plan to use Panorama in a high availability conﬁguraon; set it up as an acve/passive high
availability pair. See Panorama High Availability.
Plan how to accommodate network segmentaon and security requirements in a large-scale
deployment. By default, Panorama running on an M-Series appliance uses the management
(MGT) interface for administrave access to Panorama and for managing devices (ﬁrewalls,
Log Collectors, and WildFire appliances and appliance clusters), collecng logs, communicang
with Collector Groups, and deploying soware and content updates to devices. However, to
improve security and enable network segmentaon, you can reserve the MGT interface for
administrave access and use dedicated M-Series Appliance Interfaces (Eth1, Eth2, Eth3, Eth4,
and Eth5) for the other services.
For meaningful reports on network acvity, plan a logging soluon:
• Verify the resource allocaon for your Panorama virtual appliance deployed in Log Collector
mode on AWS or Azure. The Panorama virtual appliance does not retain Log Collector mode
if resized. This results in log data loss.
• Esmate the log storage capacity your network needs to meet security and compliance
requirements. Consider such factors as the logging capacies of your Panorama Models,
network topology, number of ﬁrewalls sending logs, type of log traﬃc (for example, URL
Filtering and Threat logs versus Traﬃc logs), the rate at which ﬁrewalls generate logs,
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and the number of days for which you want to store logs on Panorama. For details, see
Determine Panorama Log Storage Requirements.
• Do you need to forward logs to external services (such as a syslog server) in addion to
Panorama? See Log Forwarding Opons.
• Do you want to own or manage your own log storage on premises, or do you want to
leverage the Cortex Data Lake provided by Palo Alto Networks?
• If you need a long-term storage soluon, do you have a Security Informaon and Event
Management (SIEM) soluon, such as Splunk or ArcSight, to which you can forward logs?
• Do you need redundancy in logging?
If you conﬁgure a Collector Group with mulple Log Collectors, you can enable redundancy
to ensure that no logs are lost if any one Log Collector becomes unavailable (see Caveats for
a Collector Group with Mulple Log Collectors).
If you deploy Panorama virtual appliances in Legacy mode in an HA conﬁguraon, the
managed ﬁrewalls can send logs to both HA peers so that a copy of each log resides on
each peer. This redundancy opon is enabled by default (see Modify Log Forwarding and
Buﬀering Defaults).
• Will you log to a Network File System (NFS)? If the Panorama virtual appliance is in Legacy
mode and does not manage Dedicated Log Collectors, NFS storage is the only opon for
increasing log storage capacity beyond 8TB. NFS storage is available only if Panorama runs
on an ESXi server. If you use NFS storage, keep in mind that the ﬁrewalls can send logs only
to the primary peer in the HA pair; only the primary peer is mounted to the NFS and can
write to it.
Determine which role-based access privileges administrators require to access managed
ﬁrewalls and Panorama. See Set Up Administrave Access to Panorama.
Plan the required Device Groups. Consider whether to group ﬁrewalls based on funcon,
security policy, geographic locaon, or network segmentaon. An example of a funcon-based
device group is one that contains all the ﬁrewalls that a Research and Development team uses.
Consider whether to create smaller device groups based on commonality, larger device groups
to scale more easily, or a Device Group Hierarchy to simplify complex layers of administraon.
Plan a layering strategy for administering policies. Consider how ﬁrewalls inherit and evaluate
policy rules within the Device Group Hierarchy, and how to best implement shared rules,
device-group rules, and ﬁrewall-speciﬁc rules to meet your network needs. For visibility and
centralized policy management, consider using Panorama for administering rules even if you
need ﬁrewall-speciﬁc excepons for shared or device group rules. If necessary, you can Push a
Policy Rule to a Subset of Firewalls within a device group.
Plan the organizaon of your ﬁrewalls based on how they inherit network conﬁguraon
sengs from Templates and Template Stacks. For example, consider assigning ﬁrewalls to
templates based on hardware models, geographic proximity, and similar network needs for me
zones, a DNS server, and interface sengs.
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Deploy Panorama: Task Overview
The following task list summarizes the steps to get started with Panorama. For an example of how
to use Panorama for central management, see Use Case: Conﬁgure Firewalls Using Panorama.
STEP 1 | (M-Series appliance only) Rack mount the appliance.
STEP 2 | Perform inial conﬁguraon to enable network access to Panorama. See Set Up the
Panorama Virtual Appliance or Set Up the M-Series Appliance.
STEP 3 | Register Panorama and Install Licenses.
STEP 4 | Install Content and Soware Updates for Panorama.
STEP 5 | (Recommended) Set up Panorama in a high availability conﬁguraon. See Panorama High
Availability.
STEP 6 | Add a Firewall as a Managed Device.
STEP 7 | Add a Device Group or Create a Device Group Hierarchy, Add a Template, and (if applicable)
Conﬁgure a Template Stack.
STEP 8 | (Oponal) Conﬁgure log forwarding to Panorama and/or to external services. See Manage
Log Collecon.
STEP 9 | Monitor Network Acvity using the visibility and reporng tools on Panorama.
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For centralized reporng and cohesive policy management across all the ﬁrewalls
on your network, you can deploy the Panorama™ management server as a virtual
appliance or as a hardware appliance (the M-200, M-500 or M-600 appliance).
The following topics describe how to set up Panorama on your network:
>

Determine Panorama Log Storage
Requirements

>

Install the Panorama Device
Cerﬁcate

>

Manage Large-Scale Firewall
Deployments

>

Transion to a Diﬀerent Panorama
Model

>

Set Up the Panorama Virtual
Appliance

>

Access and Navigate Panorama
Management Interfaces

>

Set Up the M-Series Appliance

>

>

Register Panorama and Install
Licenses

Set Up Administrave Access to
Panorama

>

Set Up Authencaon Using Custom
Cerﬁcates
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Determine Panorama Log Storage Requirements
When you Plan Your Panorama Deployment, esmate how much log storage capacity Panorama
requires to determine which Panorama Models to deploy, whether to expand the storage on those
appliances beyond their default capacies, whether to deploy Dedicated Log Collectors, and
whether to Conﬁgure Log Forwarding from Panorama to External Desnaons. When log storage
reaches the maximum capacity, Panorama automacally deletes older logs to create space for new
ones.
Perform the following steps to determine the approximate log storage that Panorama requires. For
details and use cases, refer to Panorama Sizing and Design Guide.
STEP 1 | Determine the log retenon requirements of your organizaon.
Factors that aﬀect log retenon requirements include:
• IT policy of your organizaon
• Log redundancy—If you enable log redundancy when you Conﬁgure a Collector Group, each
log will have two copies, which doubles your required log storage capacity.
• Regulatory requirements, such as those speciﬁed by the Payment Card Industry Data
Security Standard (PCI DSS), Sarbanes-Oxley Act, and Health Insurance Portability and
Accountability Act (HIPAA).
If your organizaon requires the removal of logs aer a certain period, you can set the
expiraon period for each log type. You can also set a storage quota for each log type
as a percentage of the total space if you need to priorize log retenon by type. For
details, see Manage Storage Quotas and Expiraon Periods for Logs and Reports.
STEP 2 | Determine the average daily logging rates.
Do this mulple mes each day at peak and non-peak mes to esmate the average. The more
oen you sample the rates, the more accurate your esmate.
1. Display the current log generaon rate in logs per second:
• If Panorama is not yet collecng logs, access the CLI of each ﬁrewall, run the following
command, and calculate the total rates for all the ﬁrewalls. This command displays the
number of logs received in the last second.
> debug log-receiver statistics
• If Panorama is already collecng logs, run the following command at the CLI of
each appliance that receives logs (Panorama management server or Dedicated Log
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Collector) and calculate the total rates. This command gives the average logging rate
for the last ﬁve minutes.
> debug log-collector log-collection-stats show incoming-logs
You can also use an SNMP manager to determine the logging rates of Log
Collectors (see the panLogCollector MIB, OID 1.3.6.1.4.1.25461.1.1.6) and
ﬁrewalls (see the panDeviceLogging, OID 1.3.6.1.4.1.25461.2.1.2.7).
2. Calculate the average of the sampled rates.
3. Calculate the daily logging rate by mulplying the average logs-per-second by 86,400.
STEP 3 | Esmate the required storage capacity.
This formula provides only an esmate; the exact amount of required storage will diﬀer
from the formula result.
Use the formula:
<required_storage_duraon> x <average_log_size> x <average_logging_rate>
The average log size varies considerably by log type. However, you can use 500 bytes as an
approximate average log size.
For example, if Panorama must store logs for 30 days and the average total logging rate for
all ﬁrewalls is 21,254,400 logs per day, then the required log storage capacity is: 30 x 500 x
21,254,400 = 318,816,000,000 bytes (approximately 318GB).
STEP 4 | Next steps...
If you determine that Panorama requires more log storage capacity:
• Expand Log Storage Capacity on the Panorama Virtual Appliance.
• Increase Storage on the M-Series Appliance.

Panorama Administrator's Guide Version Version 10.1

45

©2022 Palo Alto Networks, Inc.

Set Up Panorama

Manage Large-Scale Firewall Deployments
Panorama™ provides mulple opons to manage a large-scale ﬁrewall deployment. For
consolidaon of all management funcons, Panorama supports management of up to 5,000
ﬁrewalls using an M-600 appliance in Management Only mode or up to 2,500 ﬁrewalls with
a Panorama virtual appliance in Management Only mode. To simplify the deployment and
operaonal management of a large-scale ﬁrewall deployment greater than 5,000 ﬁrewalls, the
Panorama Interconnect plugin allows you to manage mulple Panorama management server
Nodes from a single Panorama Controller.
• Determine the Opmal Large-Scale Firewall Deployment Soluon
• Increased Device Management Capacity for M-600 and Panorama Virtual Appliance

Determine the Opmal Large-Scale Firewall Deployment Soluon
To ease the operaonal burden of managing the conﬁguraon of your large-scale ﬁrewall
deployment, Palo Alto Networks provides diﬀerent ﬁrewall management opons to best suit your
deployment scenario.
If your large-scale ﬁrewall deployment is composed of one or very few Panorama management
servers, you can deploy an M-600 appliance to manage up to 5,000 ﬁrewalls, or Panorama virtual
appliance to manage up to 2,500 ﬁrewalls, to leverage all Panorama capabilies from a single
Panorama management server. The Increased Device Management Capacity for M-600 and
Panorama Virtual Appliance is ideal for vercally scaled deployments where you manage a large
number of ﬁrewalls from a single Panorama management server rather than deploying mulple
Panorama management servers to manage fewer ﬁrewalls.
If your large-scale ﬁrewall deployment is composed of mulple Panorama management servers
with similar conﬁguraons, the Panorama Interconnect plugin allows you to manage mulple
Panorama Nodes from a single Panorama Controller. This plugin simpliﬁes the deployment and
operaonal management of large scale ﬁrewall deployments because you can centrally manage
policy and conﬁguraon from a Panorama Controller. From the Panorama Controller, the device
group and template stack conﬁguraon is synchronized to the Panorama Nodes and pushed
to managed devices. The Panorama Interconnect plugin is ideal for horizontally-scaled ﬁrewall
deployments with mulple distributed Panorama management servers.

Increased Device Management Capacity for M-600 and Panorama
Virtual Appliance
The M-600 appliance in Management Only mode can manage up to 5,000 ﬁrewalls or a Panorama
virtual appliance in Management Only mode can manage up to 2,500 ﬁrewalls in order to reduce
the management footprint of your large-scale ﬁrewall deployment.
• Increased Device Management Capacity Requirements
• Install Panorama for Increased Device Management Capacity

Increased Device Management Capacity Requirements
You can manage up to 5,000 ﬁrewalls using a single M-600 appliance in Management Only mode
or manage up to 2,500 ﬁrewalls using a single Panorama virtual appliance in Management Only
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mode. Managing such large deployments from a single Panorama management server alleviates
the operaonal complexity of conﬁguraon management and reduces the security and compliance
risk of managing mulple Panorama management servers.
For log collecon, a single Panorama management server is ideal because it provides a centralized
locaon to view and analyze log data from managed devices rather than requiring you to access
each individual Panorama management server. To provide redundancy in the event of system or
network failure, Palo Alto Networks recommends deploying two Panorama management servers
in a high availability (HA) conﬁguraon. For Panorama system and conﬁg logs, an addional disk
with a minimum 92GB capacity is required. This addional disk is automacally detected by the
Panorama virtual appliance when Panorama is rebooted and mounted as a paron for system
and conﬁg log storage.
For generang pre-deﬁned reports, you must enable Panorama to use Panorama data for predeﬁned reports. This generates pre-deﬁned reports using log data already collected by Panorama
or the Dedicated Log Collector, which reduces the resource ulizaon when generang reports.
Enabling this seng is required, otherwise Panorama performance may be impacted, and
Panorama may become unresponsive.
To manage up to 5,000 ﬁrewalls, the Panorama management server must meet the following
minimum requirements:
Requirement

M-Series Appliance

Panorama Virtual Appliance

Model

M-600

All supported Panorama
hypervisors. For more
informaon, see Panorama
Models.

Panorama Mode

Management Only

Management Only

Number of managed
ﬁrewalls

5,000

2,500

System Disk

240GB SSD—Used to store
the operang system ﬁles and
system logs.

• 81GB—Used to store the
operang system ﬁles and
system logs.
• Addional disk with a
minimum 92GB capacity
used for storing Panorama
system and conﬁg logs.

CPUs

56

28

Memory

256GB

128GB

Log Collecon

Local log collecon is not supported.
See Deploy Panorama with Dedicated Log Collectors to set up log
collecon.
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Requirement

M-Series Appliance

Panorama Virtual Appliance

Logging and Reporng

Enable the Use Panorama Data for Pre-Deﬁned Reports seng
(Panorama > Setup > Management > Logging and Reporng
Sengs > Log Export and Reporng)

Install Panorama for Increased Device Management Capacity
Acvate the device management license to manage more than 1,000 ﬁrewalls from a single M-600
Panorama™ management server or a single Panorama virtual appliance.
STEP 1 | Contact your Palo Alto Networks sales representave to obtain the Panorama device
management license that enables you to manage up to 5,000 ﬁrewalls.
• If you are deploying an M-600 appliance, obtain the PAN-M-600-P-1K device management
license.
• If you are deploying a Panorama virtual appliance, obtain the PAN-PRA-1000 device
management license.
STEP 2 | Set up the Panorama management server.
• (M-600 appliances only) Set Up the M-Series Appliance.
or
• Set Up the Panorama Virtual Appliance.
STEP 3 | Change the Panorama management server to Management Only mode if Panorama is not
already in this mode.
• Begin at Step 5 to Set Up an M-Series Appliance in Management Only Mode.
• Set up a Panorama Virtual Appliance in Management Only Mode.
STEP 4 | Register your Panorama management server and install licenses.
1. Register Panorama.
2. Acvate a Panorama Support License.
3. Acvate the device management license on the Panorama management server.
• Acvate/Retrieve a Firewall Management License on the M-Series Appliance.
• Acvate/Retrieve a Firewall Management License when the Panorama Virtual
Appliance is not Internet-connected.
• Acvate/Retrieve a Firewall Management License when the Panorama Virtual
Appliance is Internet-connected.
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STEP 5 | Select Panorama > Licenses and verify that the device management license is successfully
acvated.

If you are acvang a new device management license on a Panorama, you can
manage up to 5,000 ﬁrewalls with an M-600 appliance, or up to 2,500 ﬁrewalls with a
Panorama virtual appliance, but the Descripon sll displays Device management
license to manage up to 1000 devices or more.
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Set Up the Panorama Virtual Appliance
The Panorama virtual appliance enables you to use your exisng VMware virtual infrastructure to
centrally manage and monitor Palo Alto Networks ﬁrewalls and Dedicated Log Collectors. You can
install the virtual appliance on an ESXi server, Alibaba Cloud, Amazon Web Services (AWS), AWS
GovCloud, Microso Azure, Google Cloud Plaorm (GCP), KVM, Hyper-V, or in vCloud Air. In
addion to or instead of deploying Dedicated Log Collectors, you can forward ﬁrewall logs directly
to the Panorama virtual appliance. For greater log storage capacity and faster reporng, you have
the opon to switch the virtual appliance from Legacy mode to Panorama mode and conﬁgure
a local Log Collector. For more details about the Panorama virtual appliance and its modes, see
Panorama Models.
These topics assume you are familiar with the public and private hypervisor products
required to create the virtual appliance, and don’t cover any related concepts or
terminology.
• Setup Prerequisites for the Panorama Virtual Appliance
• Install the Panorama Virtual Appliance
• Perform Inial Conﬁguraon of the Panorama Virtual Appliance
• Set Up The Panorama Virtual Appliance as a Log Collector
• Set Up the Panorama Virtual Appliance with Local Log Collector
• Set up a Panorama Virtual Appliance in Panorama Mode
• Set up a Panorama Virtual Appliance in Management Only Mode
• Expand Log Storage Capacity on the Panorama Virtual Appliance
• Increase CPUs and Memory on the Panorama Virtual Appliance
• Increase the System Disk on the Panorama Virtual Appliance
• Complete the Panorama Virtual Appliance Setup
• Convert Your Panorama Virtual Appliance

Setup Prerequisites for the Panorama Virtual Appliance
Complete the following tasks before you Install the Panorama Virtual Appliance:
Use your browser to access the Palo Alto Networks Customer Support web site and Register
Panorama You will need the Panorama serial number that you received in the order fulﬁllment
email. Aer registering Panorama, you can access the Panorama soware downloads page.
Review the supported Panorama hypervisors to verify the hypervisor meets the minimum
version requirements to deploy Panorama.
If you will install Panorama on a VMware ESXi server, verify that the server meets the minimum
requirements as listed in the System Requirements for the Panorama Virtual Appliance. These
requirements apply to Panorama 5.1 and later releases. The requirements vary based on
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whether you will run the virtual appliance in Panorama mode or Management Only mode. For
details on the modes, see Panorama Models.
If you install Panorama on VMware vCloud Air, you set the system sengs during
installaon.
Review the minimum resource requirements for deploying the Panorama virtual appliance on
Alibaba Cloud, Amazon Web Services (AWS), AWS GovCloud, Microso Azure, Google Cloud
Plaorm (GCP), Hyper-V, KVM, Oracle Cloud Infrastructure (OCI), and VMware ESXi to ensure
that the virtual machine meets the minimum required resources for the desired mode (Panorama,
Management Only, or Log Collector). The minimum resource requirements for the Panorama
virtual appliance are designed to help you achieve the maximum number of logs per second (LPS)
for log collecon in Panorama and Log Collector mode. If you add or remove virtual logging disks
that results in a conﬁguraon that does not meet or exceed the number of virtual logging disks
recommended (below), your LPS will be reduced.
If the minimum resource requirements are not met for Panorama mode when you Install the
Panorama Virtual Appliance, Panorama defaults to Management Only mode for all supported
public (Alibaba Cloud, AWS, AWS GovCloud, Azure, GCP, and OCI) and private (Hyper-V,
KVM, and VMware ESXi) hypervisors. If the minimum resource requirements are not met for
Management Only mode, Panorama defaults to Maintenance mode for all supported public
hypervisors, Hyper-V, and KVM. If the minimum resource requirements for Management Only
mode are not met when you Install Panorama on VMware, Panorama defaults to Legacy mode.
It is recommended to deploy the Panorama management server in Panorama mode for
both device management and log collecon capabilies. While sll supported, Legacy
mode is not recommended for producon environments. Addionally, you can no longer
switch Panorama to Legacy mode. For more informaon on supported modes, see
Panorama Models.
Table 1: System Requirements for the Panorama Virtual Appliance
RequirementsPanorama Virtual
Panorama Virtual
Appliance in
Appliance in Panorama
Management Only Mode Mode
Virtual
hardware
version

Panorama Virtual
Appliance in Log
Collector Mode

• VMware ESXi and vCloud Air—64-bit kernel-based VMware ESXi 6.0, 6.5, 6.7,
or 7.0. The supported version of the virtual hardware family type (also known
as the VMware virtual hardware version) on the ESXi server is vmx-10
• Hyper-V—Windows Server 2016 with Hyper-V role or Hyper-V 2016
• KVM—Ubuntu version 16.04 or CentOS7
In Panorama mode, the virtual appliance running on any ESXi version supports
up to 12 virtual logging disks with 2TB of log storage each, for a total maximum
capacity of 24TB.
(VMware ESXi and vCloud Air only) In Legacy mode, the virtual appliance
supports one virtual logging disk. ESXi 5.5 and later versions supports one disk of
up to 8TB. Earlier ESXi versions support one disk of up to 2TB.
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RequirementsPanorama Virtual
Panorama Virtual
Appliance in
Appliance in Panorama
Management Only Mode Mode
(ESXi and
vCloud Air
only)

Panorama Virtual
Appliance in Log
Collector Mode

To install the Panorama virtual appliance and manage its resources, you must
install a VMware vSphere Client or VMware Infrastructure Client that is
compable with your ESXi server.

Client
computer
System
disk

• Default—81GB

• Default—81GB

81GB

• (ESXi and GCP only)
Upgraded—224GB

• (ESXi and GCP only)
Upgraded—224GB

For log storage,
Panorama uses virtual
logging disks instead of
the system disk or an
NFS datastore.

An upgraded system
disk is required for
SD-WAN.

An upgraded system
disk is required for SDWAN.
For log storage, Panorama
uses virtual logging disks
instead of the system disk
or an NFS datastore.

CPUs,
memory,
and
logging
disks

• Manage up to 500
managed devices
• 16 CPUs
• 32GB memory
• Local log storage
not supported
• Manage up to 1,000
managed devices
• 32 CPUs
• 128GB memory
• Local log storage
not supported
• To manage more
than 1,000 ﬁrewalls,
see Increased
Device Management
Capacity
Requirements.

Minimum
CPUs and
memory

• 16 CPUs
• 32GB memory
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• Up to 10,000 logs/sec:

• Up to 15,000 log/sec

• 16 CPUs

• 16 CPUs

• 32GB memory

• 32GB memory

• 4x2TB logging disks

• 4x2TB logging
disks

• Manage up to 500
managed devices
• Up to 20,000 log/sec
• 32 CPUs
• 128GB memory
• 8x2TB logging disks
• Manage up to 1,000
managed devices

• Up to 25,000 logs/
sec
• 32 CPUs
• 128GB memory
• 8x2TB logging
disks

The minimum resources below do not take LPS into
consideraon and are only required for the Panorama
virtual appliance to funcon based on the number of
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RequirementsPanorama Virtual
Panorama Virtual
Appliance in
Appliance in Panorama
Management Only Mode Mode

Panorama Virtual
Appliance in Log
Collector Mode

logging disks added. Palo Alto Networks recommends
you refer to the recommended resources above.
For larger Panorama deployments, be aware that
you may be under-provisioning your Panorama. This
may lead to impacted performance and may cause
Panorama to become unresponsive depending on the
number of ﬁrewalls managed, the conﬁguraon size,
the number of administrators logged in to Panorama,
and the volume of logs ingested.
• 2TB to 8TB—16 CPUs, 32GB memory
• 10TB to 24TB— 16 CPUs, 64GB memory
Log
storage
capacity

Panorama in
Management Only mode
requires log forwarding
to a Dedicated Log
Collector.

2TB to 24TB

2TB to 24TB

Supported Interfaces
Interfaces can be used for device management, log collecon, Collector Group communicaon,
licensing and soware updates. The Panorama virtual appliance supports up to six interfaces
(MGT and Eth1 - Eth5).
Table 2: Supported interfaces for public hypervisors
Funcon

Alibaba
Cloud

Amazon Web Services
(AWS) and AWS
GovCloud

Microso
Azure

Google
Cloud
Plaorm
(GCP)

OCI

Device
Management

Any
interface
supported

Any
interface
supported

Any
interface
supported

Any
interface
supported

Any
interface
supported

Any
interface
supported

Device Log
Collecon

Any
interface
supported

Any
interface
supported

Any
interface
supported

Any
interface
supported

Any
interface
supported

Any
interface
supported

Collector
Any
Group
interface
Communicaonsupported

Any
interface
supported

Any
interface
supported

Any
interface
supported

Any
interface
supported

Any
interface
supported
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Funcon

Alibaba
Cloud

Amazon Web Services
(AWS) and AWS
GovCloud

Microso
Azure

Google
Cloud
Plaorm
(GCP)

OCI

Licensing
and
Soware
Updates

MGT
interface
only

MGT
interface
only

MGT
interface
only

MGT
interface
only

MGT
interface
only

MGT
interface
only

Table 3: Supported Interfaces for Private Hypervisors
Funcon

KVM

Hyper-V

VMware (ESXi,
vCloud Air)

Device Management

Any interface
supported

Any interface
supported

Any interface
supported

Device Log Collecon

Any interface
supported

Any interface
supported

Any interface
supported

Collector Group
Communicaon

Any interface
supported

Any interface
supported

Any interface
supported

Licensing and Soware
Updates

Any interface
supported

Any interface
supported

Any interface
supported

Install the Panorama Virtual Appliance
Before installaon, decide whether to run the virtual appliance in Panorama mode, Management
Only mode, Log Collector mode, or Legacy mode (VMware only). Each mode has diﬀerent resource
requirements, as described in Setup Prerequisites for the Panorama Virtual Appliance. You must
complete the prerequisites before starng the installaon.
As a best pracce, install the virtual appliance in Panorama mode to opmize log storage
and report generaon. For details on Panorama and Legacy mode, see Panorama Models.
• Install Panorama on VMware
• Set Up Panorama on Alibaba Cloud
• Install Panorama on AWS
• Install Panorama on AWS GovCloud
• Install Panorama on Azure
• Install Panorama on Google Cloud Plaorm
• Install Panorama on KVM
• Install Panorama on Hyper-V
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• Set Up Panorama on Oracle Cloud Infrastructure (OCI)

Install Panorama on VMware
You can install the Panorama virtual appliance on the ESXi and vCloud Air VMware plaorms.
• Install Panorama on an ESXi Server
• Install Panorama on vCloud Air
• Support for VMware Tools on the Panorama Virtual Appliance
Install Panorama on an ESXi Server
Use these instrucons to install a new Panorama virtual appliance on a VMware ESXi server. For
upgrades to an exisng Panorama virtual appliance, skip to Install Content and Soware Updates
for Panorama.
STEP 1 | Download the Panorama 10.1 base image Open Virtual Appliance (OVA) ﬁle.
1. Go to the Palo Alto Networks soware downloads site. (If you can’t log in, go to the Palo
Alto Networks Customer Support web site for assistance.)
2. In the Download column in the Panorama Base Images secon, download the latest
version of the Panorama release OVA ﬁle (Panorama-ESX-10.0.0.ova).
STEP 2 | Install Panorama.
1. Launch the VMware vSphere Client and connect to the VMware server.
2. Select File > Deploy OVF Template.
3. Browse to select the Panorama OVA ﬁle and click Next.
4. Conﬁrm that the product name and descripon match the downloaded version, and click
Next.
5. Enter a descripve name for the Panorama virtual appliance, and click Next.
6. Select a datastore locaon (system disk) on which to install the Panorama image. See the
Setup Prerequisites for the Panorama Virtual Appliance for the supported system disk
sizes. Aer selecng the datastore, click Next.
7. Select Thick Provision Lazy Zeroed as the disk format, and click Next.
8. Specify which networks in the inventory to use for the Panorama virtual appliance, and
click Next.
9. Conﬁrm the selected opons, click Finish to start the installaon process, and click Close
when it ﬁnishes. Do not power on the Panorama virtual appliance yet.
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STEP 3 | Conﬁgure resources on the Panorama virtual appliance.
1. Right-click the Panorama virtual appliance and Edit Sengs.
2. In the Hardware sengs, allocate the CPUs and memory as necessary.
The virtual appliance boots up in Panorama mode if you allocate suﬃcient CPUs
and Memory and add a virtual logging disk (later in this procedure). Otherwise,
the appliance boots up in Management Only mode. For details on the modes, see
Panorama Models.
3. Set the SCSI Controller to LSI Logic Parallel.
4. (Oponal) Add a virtual logging disk.
This step is required in the following scenarios:
• In Panorama mode to store logs on a dedicated logging disk.
• Manage your SD-WAN deployment in Management Only mode.
1. Add a disk, select Hard Disk as the hardware type, and click Next.
2. Create a new virtual disk and click Next.
3. Set the Disk Size to exactly 2TB.
In Panorama mode, you can later add addional logging disks (for a total
of 12) with 2TB of storage each. Expanding the size of a logging disk that is
already added to Panorama is not supported.
4. Select your preferred Disk Provisioning disk format.
Consider your business needs when selecng the disk provisioning format. For more
informaon regarding the disk provisioning performance consideraons, refer to the
VMware Thick vs Thin Disks and All Flash Arrays document, or addional VMware
documentaon.
When adding mulple logging disks, it is a best pracce to select the same
Disk Provisioning format for all disks to avoid any unexpected performance
issues that may arise.
5. Select Specify a datastore or datastore structure as the locaon, Browse to a
datastore that has suﬃcient storage, click OK, and click Next.
6. Select a SCSI Virtual Device Node (you can use the default selecon) and click Next.
Panorama will fail to boot if you select a format other than SCSI.
7. Verify that the sengs are correct and click Finish.
5. Click OK to save your changes.
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STEP 4 | Power on the Panorama virtual appliance.
1. In the vSphere Client, right-click the Panorama virtual appliance and select Power >
Power On. Wait for Panorama to boot up before connuing.
2. Verify that the virtual appliance is running in the correct mode:
1. Right-click the Panorama virtual appliance and select Open Console.
2. Enter your username and password to log in (default is admin for both).
3. Display the mode by running the following command:
> show system info
In the output, the system-mode indicates either panorama or management-only
mode.
STEP 5 | Register the Panorama virtual appliance and acvate the device management license and
support licenses.
1. (VM Flex Licensing Only) Provisioning the Panorama Virtual Appliance Serial Number.
When leveraging VM Flex licensing, this step is required to generate the Panorama
virtual appliance serial number needed to register the Panorama virtual appliance with
the Palo Alto Networks Customer Support Portal (CSP).
2. Register Panorama.
You must register the Panorama virtual appliance using the serial number provided by
Palo Alto Networks in the order fulﬁllment email.
This step is not required when leveraging VM Flex licensing as the serial number is
automacally registered with the CSP when generated.
3. Acvate the ﬁrewall management license.
• Acvate/Retrieve a Firewall Management License when the Panorama Virtual
Appliance is Internet-connected.
• Acvate/Retrieve a Firewall Management License when the Panorama Virtual
Appliance is not Internet-connected.
4. Acvate a Panorama Support License.
STEP 6 | Increase the System Disk for Panorama on an ESXi Server if you intend to use the Panorama
virtual appliance for the following:
• Manage your SD-WAN deployment in Panorama mode.
• Requires addional storage space for dynamic updates when managing large-scale ﬁrewall
deployments.
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STEP 7 | Complete conﬁguring the Panorama virtual appliance for your deployment needs.
• For Panorama in Log Collector Mode.
1. Add a Virtual Disk to Panorama on an ESXi Server as needed.
Adding at least one virtual logging disk is required before you can change the Panorama
virtual appliance to Log Collector mode.
2. Begin at Step 6 to switch to Log Collector mode.
Enter the Public IP address of the Dedicated Log Collector when you add the
Log Collector as a managed collector to the Panorama management server. You
cannot specify the IP Address, Netmask, or Gateway.
• For Panorama in Panorama mode.
1. Add a Virtual Disk to Panorama on an ESXi Server.
Adding at least one virtual logging disk is required before you can change the Panorama
virtual appliance to Panorama mode.
2. Set up a Panorama Virtual Appliance in Panorama Mode.
3. Conﬁgure a Managed Collector.
• For Panorama in Management Only mode.
1. Set up a Panorama Virtual Appliance in Management Only Mode.
2. Conﬁgure a Managed Collector to add a Dedicated Log Collector to the Panorama virtual
appliance.
Management Only mode does not support local log collecon, and requires a Dedicated
Log Collector to store managed device logs.
• For SD-WAN deployments.
1. Increase the System Disk for Panorama on an ESXi Server
To leverage SD-WAN on Panorama deployed on ESXi, you must increase the system disk
to 224GB.
You cannot migrate back to a 81GB system disk aer successfully increasing the
system disk to 224GB.
2. Set up a Panorama Virtual Appliance in Management Only Mode.
3. Add a Virtual Disk to Panorama on an ESXi Server.
To leverage SD-WAN, you must add a single 2TB logging disk to Panorama in
Management Only mode.
Install Panorama on vCloud Air
Use these instrucons to install a new Panorama virtual appliance in VMware vCloud Air. If you
are upgrading a Panorama virtual appliance deployed in vCloud Air, skip to Install Content and
Soware Updates for Panorama.

Panorama Administrator's Guide Version Version 10.1

58

©2022 Palo Alto Networks, Inc.

Set Up Panorama
STEP 1 | Download the Panorama 10.1 base image Open Virtual Appliance (OVA) ﬁle.
1. Go to the Palo Alto Networks soware downloads site. (If you can’t log in, go to the Palo
Alto Networks Customer Support web site for assistance.)
2. In the Download column in the Panorama Base Images secon, download the Panorama
10.1 release OVA ﬁle (Panorama-ESX-10.0.0.ova).
STEP 2 | Import the Panorama image to the vCloud Air catalog.
For details on these steps, refer to the OVF Tool User’s Guide.
1. Install the OVF Tool on your client system.
2. Access the client system CLI.
3. Navigate to the OVF Tool directory (for example, C:\Program Files\VMware\VMware
OVF Tool).
4. Convert the OVA ﬁle to an OVF package:
ovftool.exe <OVA‑file‑pathname> <OVF‑file‑pathname>
5. Use a browser to access the vCloud Air web console, select your Virtual
Private Cloud OnDemand locaon, and record the browser URL. You will
use the URL informaon to complete the next step. The URL format is:
https://<virtual‑cloud‑location>.vchs.vmware.com/compute/
cloud/org/<vCloud‑account‑number>/#/catalogVAppTemplateList?
catalog=<catalog‑ID>.
6. Import the OVF package, using the informaon from the vCloud Air URL to complete the
<virtual#cloud#locaon>, <vCloud#account#number>, and <catalog#ID> variables. The
other variables are your vCloud Air username and domain <user>@<domain>, a virtual
data center <datacenter>, and a vCloud Air template <template>.
ovftool.exe -st="OVF" "<OVF‑file‑pathname>"
"vcloud://<user>@<domain>:password@<virtual-cloudlocation>.vchs.vmware.com?vdc=<datacenter>&org=<vCloudaccount-number>&vappTemplate=<template>.ovf&catalog=defaultcatalog"
STEP 3 | Install Panorama.
1. Access the vCloud Air web console and select your Virtual Private Cloud OnDemand
region.
2. Create a Panorama virtual machine. For the steps, refer to Add a Virtual Machine from
a Template in the vCloud Air Documentaon Center. Conﬁgure the CPU, Memory and
Storage as follows:
• Set the CPU and Memory based on whether the virtual appliance mode: see Setup
Prerequisites for the Panorama Virtual Appliance.
• Set the Storage to conﬁgure the Panorama virtual appliance system disk. See Setup
Prerequisites for the Panorama Virtual Appliance for the supported disk sizes
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based on the Panorama virtual appliance mode. For beer logging and reporng
performance, select the SSD-Accelerated opon.
To increase the log storage capacity, you must Add a Virtual Disk to Panorama on
vCloud Air. In Panorama mode, the virtual appliance does not use the system disk for
log storage; you must add a virtual logging disk.
STEP 4 | Create vCloud Air NAT rules on the gateway to allow inbound and outbound traﬃc for the
Panorama virtual appliance.
Refer to Add a NAT Rule in the vCloud Air Documentaon Center for the detailed instrucons:
1. Add a NAT rule that allows Panorama to receive traﬃc from the ﬁrewalls and allows
administrators to access Panorama.
2. Add a NAT rule that allows Panorama to retrieve updates from the Palo Alto Networks
update server and to access the ﬁrewalls.
STEP 5 | Create a vCloud Air ﬁrewall rule to allow inbound traﬃc on the Panorama virtual appliance.
Outbound traﬃc is allowed by default.
Refer to Add a Firewall Rule in the vCloud Air Documentaon Center for the detailed
instrucons.
STEP 6 | Power on the Panorama virtual appliance if it isn’t already on.
In the vCloud Air web console, select the Virtual Machines tab, select the Panorama virtual
machine, and click Power On.
You are now ready to Perform Inial Conﬁguraon of the Panorama Virtual Appliance.
Support for VMware Tools on the Panorama Virtual Appliance
VMware Tools is bundled with the soware image (ovf) for the Panorama virtual appliance. The
support for VMware Tools allows you to use the vSphere environment—vCloud Director and
vCenter server—for the following:
• View the IP address assigned to the Panorama management interface.
• View resource ulizaon metrics on hard disk, memory, and CPU. You can use these metrics to
enable alarms or acons on the vCenter server or vCloud Director.
• Graceful shutdown and restart of Panorama using the power oﬀ funcon on the vCenter server
or vCloud Director.
• Enables a heartbeat mechanism between the vCenter server and Panorama for verifying that
Panorama is funconing, or if the ﬁrewall/Panorama is reboong. If the ﬁrewall goes into
maintenance mode, heartbeats are disabled so that the vCenter server does not shut down the
ﬁrewall. Disabling heartbeats allows the ﬁrewall to stay operaonal in maintenance mode when
it cannot not send heartbeats to the vCenter server.

Set Up Panorama on Alibaba Cloud
Set up a Panorama™ virtual appliance on Alibaba Cloud to centrally managed the conﬁguraon of
physical and VM-Series ﬁrewalls.
• Upload the Panorama Virtual Appliance Image to Alibaba Cloud
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• Install Panorama on Alibaba Cloud
Upload the Panorama Virtual Appliance Image to Alibaba Cloud
Complete the following procedure to upload a Panorama™ management server qcow2 ﬁle
for KVM and create a custom image that you need to launch the Panorama virtual appliance.
Uploading and creang the image is required only once. You can use the same image for all
subsequent deployments of the Panorama virtual appliance.
STEP 1 | Download the Panorama qcow2 ﬁle for KVM from the Palo Alto Networks Customer Support
Portal (CSP).
1. Log in to the Palo Alto Networks CSP.
2. Select Updates > Soware Updates and select Panorama Base Images from the soware
updates ﬁlter drop-down.
3. Download the latest version of the Panorama-KVM qcow2 ﬁle.
STEP 2 | Log in to the Alibaba Cloud Console.
STEP 3 | Create an Object Storage Service (OSS) bucket for the Panorama virtual appliance image.
1. From the Alibaba Cloud menu, select Object Storage Service > Buckets and Create
Bucket.
2. Enter a descripve Bucket Name.
3. Select the bucket Region.
This region must be in the same region you plan on deploying your Panorama virtual
appliance and in the same region as the ﬁrewalls you plan to manage with Panorama.
4. Conﬁgure the remaining OSS bucket sengs as needed.
5. Click OK.
You are automacally taken to the OSS bucket Overview page aer successful creaon.
STEP 4 | Upload the qcow2 ﬁle to the OSS bucket.
1. In the OSS bucket Overview, select Files and Upload the qcow2 ﬁle you downloaded in
the previous step.
2. For Upload To target, select Current.
3. For the File ACL, select Inherited from Bucket.
4. Click Select Files and select the qcow2 ﬁle.
Alternavely, you can drag and drop the qcow2 ﬁle into the Files to Upload secon.
5. Upload the qcow2 ﬁle.
A Task List window appears displaying the upload Status. Connue to the next step aer
the qcow2 ﬁle upload Status displays Uploaded.
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STEP 5 | Make the qcow2 ﬁle a bootable image.
1. In the OSS bucket Overview, select Files and click the qcow2 ﬁle you uploaded to view
the ﬁle Details.
2. Click Copy File URL and exit the ﬁle Details.

3. From the Alibaba Cloud menu, select Elasc Compute Service > Instances & Images >
Images and Import Image.
4. Paste the OSS Object Address for the qcow2 ﬁle.
This the ﬁle URL you copied in the previous step.
5. Enter an Image Name.
6. For the Operang System/Plaorm, select Linux CentOS.
7. For the System Disk (GiB), enter 81.
8. For the System Architecture, select x86_64.
9. For the Image Format, select QCOW2.
10. Click OK.
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Install Panorama on Alibaba Cloud
Use the Elasc Compute Service (ECS) to create a Panorama™ virtual appliance instance on
Alibaba Cloud. An ECS instance supports a single NIC by default and automacally aached an
Elasc Network Interface (ENI) to it. You must manually upload a Panorama virtual appliance
qcow2 image downloaded from the Palo Alto Networks Customer Supported Portal (CSP) to
Alibaba Cloud to successfully install the Panorama virtual appliance on Alibaba Cloud.
A Panorama virtual appliance deployed on Alibaba Cloud is Bring Your Own License (BYOL),
supports all deployment modes (Panorama, Log Collector, and Management Only), and shares the
same processes and funconality as the M-Series hardware appliances. For more informaon on
Panorama modes, see Panorama Models.
Review the Setup Prerequisites for the Panorama Virtual Appliance to determine the correct
Elasc Computer Service (ECS) instance type for your needs. The virtual resources requirement
for the Panorama virtual appliance is based on the total number of ﬁrewalls managed by the
Panorama virtual appliance and the required Logs Per Second (LPS) for forwarding logs from your
managed ﬁrewalls to your Log Collector.
Palo Alto Networks supports the following instance types.
• ecs.g5.xlarge, ecs.g5.2xlarge, ecs.g5.4xlarge
• ecs.sn2ne.xlarge, ecs.sn2ne.2xlarge, ecs.sn2ne.4xlarge
Under-provisioning the Panorama virtual appliance will impact management performance.
This includes the Panorama virtual appliance becoming slow or unresponsive depending on
how under-provisioning the Panorama virtual appliance is.
STEP 1 | Log in to the Alibaba Cloud Console.
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STEP 2 | Upload the Panorama Virtual Appliance Image to Alibaba Cloud.
STEP 3 | Set up the virtual private cloud (VPC) for your network needs.
Whether you launch the Panorama virtual appliance in an exisng VPC or you create a new
VPC, the Panorama virtual appliance must be able to receive traﬃc from other instances in the
VPC and perform inbound and outbound communicaon between the VPC and the internet as
needed.
Refer to the Alibaba Cloud VPC documentaon for more informaon.
1. Create a VPC and Conﬁgure Networks or use an exisng VPC.
2. Verify that the network and security components are appropriately deﬁned.
• Create an internet gateway to enable internet access to the subnet of your Panorama
virtual appliance. Internet access is required to install soware and content updates,
acvate licenses, and leverage Palo Alto Networks cloud services. Otherwise, you
must manually install updates and acvate licenses.
• Create subnets. Subnets are segments of the IP address range assigned to the VPC in
which you can launch Alibaba Cloud instances. It is recommended that the Panorama
virtual appliance belong to the management subnet so that you can conﬁgure it to
access the internet if needed.
• Add routes to the route table for a private subnet to ensure traﬃc can be routed
across subnets in the VPC and from the internet if applicable.
Ensure you create routes between subnets to allow communicaon between:
• Panorama, managed ﬁrewalls, and Log Collectors.
• (Oponal) Panorama and the internet.
• Ensure that the following ingress security rules are allowed for the VPC to manage
VPC traﬃc. The ingress traﬃc source for each rule is unique to your deployment
topology.
See Ports Used for Panorama for more informaon.
• Allow SSH (port 22) traﬃc to enable access to the Panorama CLI.
• Allow HTTPS (port 443 and 27280) traﬃc to enable access to the Panorama web
interface.
• Allow traﬃc on port 3978 to enable communicaon between Panorama, manage
ﬁrewalls, and managed Log Collectors. This port is also used by Log Collectors to
forward logs to Panorama.
• Allow traﬃc on port 28443 to enable managed ﬁrewalls to get soware and
content updates from Panorama.
STEP 4 | Select Elasc Compute Service > Instances & Images > Instances and click Create Instance
in the upper right corner.
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STEP 5 | Create the Panorama virtual appliance instance.
1. Select Custom Launch.
2. Conﬁgure the Panorama virtual appliance instance.
• Billing Method—Select the desired subscripon method for the instance.
• Region—Select a region of your choice. The region you select must provide on of the
supported instance types.
• Instance Type—Select one of the supported instance types. You can select Type-based
Selecon to search for the instance type.
• Image— Select Custom Image and select the Panorama virtual appliance image you
uploaded.
• Storage—Choose a disk type and enter 81GiB as the system disk capacity.
• (Oponal) Add Disk—Add addional logging disks.
If you intend to use the Panorama virtual appliance in Panorama mode or as a
Dedicated Log Collector, add the virtual logging disks during the inial deployment.
By default, the Panorama virtual appliance is in Panorama mode for the inial
deployment when you meet the Panorama mode resource requirements and have
added at least one virtual logging disk. Otherwise, the Panorama virtual appliance
defaults to Management Only mode. Change the Panorama virtual appliance to
Management Only mode if you just want to manage devices and Dedicated Log
Collectors, and to not collect logs locally.
The Panorama virtual appliance on Alibaba Cloud only supports 2TB logging disks,
and in total supports up to 24TB of log storage. You are unable to add a logging disk
smaller than 2TB, or a logging disk with a size not divisible by the 2TB logging disk
requirement. The Panorama virtual appliance parons logging disks larger than 2TB
into 2TB parons.
• (Oponal) Snapshot—Specify how oen a snapshot is automacally taken of the
Panorama virtual appliance instance to prevent risks and accidental data deleon.
• Duraon—Specify the duraon for the Panorama virtual appliance instance.
STEP 6 | Conﬁgure the Panorama virtual appliance network sengs.
1. Select Next: Networking.
2. Conﬁgure the network sengs for the Panorama virtual appliance instance.
• Network Type—Select the VPC and management VSwitch you created.
• Public IP Address—If you do not have a public IP address, enable (check) Assign Public
IPv4 Address and a public IPv4 address is automacally assigned to the Panorama
virtual appliance instance.
If you must use a speciﬁc IP address, or an address in a speciﬁc range, you can request
a custom IP address. Refer to the Elasc IP Address User Guide.
• Security Group—Select the management security group you created and enable Port
443 (HTTPS), Port 22, and Port 3389.
• Elasc Network Interface—No conﬁguraon needed. The Management interface is
already aached to eth0.
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STEP 7 | Conﬁgure the Panorama virtual appliance instance system sengs.
1. Select Next: System Conﬁguraons.
2. Conﬁgure system sengs for the Panorama virtual appliance instance.
• Logon Credenals—Select Key Pair and select the key pair. If a key pair has not
already been created, select Create Key Pair to create an new key pair on Alibaba
Cloud or import an exisng key pair.
Password authencaon is not supported.
• Instance Name—Enter a descripve name for the Panorama virtual appliance. This the
name displayed for the instance throughout the Alibaba Cloud Console.
• Host—Enter a hostname for the Panorama virtual appliance instance.
STEP 8 | (Oponal) Select Next: Grouping to conﬁguring grouping for all Alibaba Cloud resources
associated with the Panorama virtual appliance instance.
STEP 9 | Select Preview to view the conﬁguraon before ordering.
STEP 10 | View and check the ECS Terms of Service and Product Terms of Service.
STEP 11 | Create Instance to create the Panorama virtual appliance instance.
When prompted, click Console to view the instance creaon status.
STEP 12 | Allocate Elasc IP (EIP) addresses.
The EIP is a public IP address used to connect to the Panorama virtual appliance.
This step is required only if you want to enable internet access for the Panorama virtual
appliance.
1. Select Elasc Compute Service > Network & Security > VPC > Elasc IP Addresses >
Elasc IP Addresses.
Select Create EIP if you do not have any exisng EIPs.
2. In the Acons column, select Bind Resource to bind an EIP to any interface exposed to
the Internet.
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STEP 13 | Log in to the Panorama CLI using the SSH to conﬁgure the Panorama virtual appliance
network sengs.
You must conﬁgure the system IP address , netmask, and default gateway. Addionally, you
must add the Alibaba Cloud DNS servers to successfully connect to the Palo Alto Networks
update server.
You can also access the Panorama CLI from the Alibaba console. To access the
Panorama CLI from the Alibaba console, select Elasc Compute Service > Instances &
Images > Instances and select the Panorama virtual appliance instance. In the Instance
Details, select Connect.
You are prompted to create a VCN password for the Panorama virtual appliance
instance on ﬁrst connecon from the Alibaba VCN. Be sure to save this password as it
cannot be recovered and is required to connect using the VCN or update the password
in the future.
STEP 14 | Conﬁgure the inial network sengs for the Panorama virtual appliance.
admin> configure
admin#

set deviceconfig system type static

admin# set deviceconfig system ip-address <instance-private-IP
address> netmask <netmask> default-gateway <default-gateway-IP>
The default gateway on Alibaba Cloud ends in .253. For example, if the private IP
address for your Panorama virtual appliance instance is 192.168.100.20, the default
gateway is 192.168.100.253.
admin# set deviceconfig system dns-setting servers primary
100.100.2.136
admin# set deviceconfig system dns-setting servers secondary
100.100.2.138
admin# commit
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STEP 15 | Register the Panorama virtual appliance and acvate the device management license and
support licenses.
1. (VM Flex Licensing Only) Provisioning the Panorama Virtual Appliance Serial Number.
When leveraging VM Flex licensing, this step is required to generate the Panorama
virtual appliance serial number needed to register the Panorama virtual appliance with
the Palo Alto Networks Customer Support Portal (CSP).
2. Register Panorama.
You must register the Panorama virtual appliance using the serial number provided by
Palo Alto Networks in the order fulﬁllment email.
This step is not required when leveraging VM Flex licensing as the serial number is
automacally registered with the CSP when generated.
3. Acvate the ﬁrewall management license.
• Acvate/Retrieve a Firewall Management License when the Panorama Virtual
Appliance is Internet-connected.
• Acvate/Retrieve a Firewall Management License when the Panorama Virtual
Appliance is not Internet-connected.
4. Acvate a Panorama Support License.
STEP 16 | Complete conﬁguring the Panorama virtual appliance for your deployment needs.
• (Management Only mode) Set up a Panorama Virtual Appliance in Management Only Mode.
• (Log Collector mode) Begin at Step 6 to Switch from Panorama mode to Log Collector mode.
Enter the Public IP address of the Dedicated Log Collector when you Add the Log
Collector as a managed collector to the Panorama management server. You cannot
specify the IP Address, Netmask, or Gateway.
• (Panorama and Management Only mode) Conﬁgure a Managed Collector to add a Dedicated
Log Collector to the Panorama virtual appliance. Management Only mode does not support
local log collecon, and requires a Dedicated Log Collector to store managed device logs.
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STEP 17 | Complete conﬁguring the Panorama virtual appliance for your deployment needs.
• For Panorama in Log Collector Mode.
1. Add a Virtual Disk to Panorama on Alibaba Cloud as needed.
Adding at least one virtual logging disk is required before you can change the Panorama
virtual appliance to Log Collector mode.
2. Begin at Step 6 to switch to Log Collector mode.
Enter the Public IP address of the Dedicated Log Collector when you add the
Log Collector as a managed collector to the Panorama management server. You
cannot specify the IP Address, Netmask, or Gateway.
• For Panorama in Panorama mode.
1. Add a Virtual Disk to Panorama on Alibaba Cloud as needed.
Adding at least one virtual logging disk is required before you can change the Panorama
virtual appliance to Panorama mode.
2. Set up a Panorama Virtual Appliance in Panorama Mode.
3. Conﬁgure a Managed Collector.
• For Panorama in Management Only mode.
1. Set up a Panorama Virtual Appliance in Management Only Mode.
2. Conﬁgure a Managed Collector to add a Dedicated Log Collector to the Panorama virtual
appliance.
Management Only mode does not support local log collecon, and requires a Dedicated
Log Collector to store managed device logs.

Install Panorama on AWS
You can now deploy Panorama™ and a Dedicated Log Collector on Amazon Web Services
(AWS). Panorama deployed on AWS is Bring Your Own License (BYOL), supports all deployment
modes (Panorama, Log Collector, and Management Only), and shares the same processes and
funconality as the M-Series hardware appliances. For more informaon on Panorama modes, see
Panorama Models.
STEP 1 | Log in to AWS Web Service console and select the EC2 Dashboard.
• Amazon Web Service Console
• AWS GovCloud Web Service Console
STEP 2 | Set up the virtual private cloud (VPC) for your network needs.
Whether you launch the Panorama virtual appliance in an exisng VPC or you create a new
VPC, the Panorama virtual appliance must be able to receive traﬃc from other instances in the

Panorama Administrator's Guide Version Version 10.1

69

©2022 Palo Alto Networks, Inc.

Set Up Panorama
VPC and perform inbound and outbound communicaon between the VPC and the internet as
needed.
Refer to the AWS VPC documentaon for instrucons on creang a VPC and seng it up for
access.
1. Create a new VPC or use an exisng VPC. Refer to the AWS Geng Started
documentaon
2. Verify that the network and security components are appropriately deﬁned.
• Create an internet gateway to enable internet access to the subnet of your Panorama
virtual appliance. Internet access is required to install soware and content updates,
acvate licenses, and leverage Palo Alto Networks cloud services. Otherwise, you
must manually install updates and acvate licenses.
• Create subnets. Subnets are segments of the IP address range assigned to the VPC in
which you can launch AWS instances. It is recommended that the Panorama virtual
appliance belong to the management subnet so that you can conﬁgure it to access the
internet if needed.
• Add routes to the route table for a private subnet to ensure traﬃc can be routed
across subnets in the VPC and from the internet if applicable.
Ensure you create routes between subnets to allow communicaon between:
• Panorama, managed ﬁrewalls, and Log Collectors.
• (Oponal) Panorama and the internet.
• Ensure that the following inbound security rules are allowed for the VPC to manage
VPC traﬃc. The ingress traﬃc source for each rule is unique to your deployment
topology.
See Ports Used for Panorama for more informaon.
• Allow SSH (port 22) traﬃc to enable access to the Panorama CLI.
• Allow HTTPS (port 443) traﬃc to enable access to the Panorama web interface.
• Allow traﬃc on port 3978 to enable communicaon between Panorama, manage
ﬁrewalls, and managed Log Collectors. This port is also used by Log Collectors to
forward logs to Panorama.
• Allow traﬃc on port 28443 to enable managed ﬁrewalls to get soware and
content updates from Panorama.
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STEP 3 | Deploy Panorama on Amazon Web Services.
1. Select Services > EC2 > Instances and Launch Instance.
2. Select AWS Marketplace, search for Palo Alto Networks Panorama, and Select
the Panorama AMI and Connue.
3. Choose the EC2 instance type for allocang the resources required for the Panorama
virtual appliance, and click Next: Conﬁgure Instance Details. Review the Setup
Prerequisites for the Panorama Virtual Appliance for resource requirements.
If you plan to use the Panorama virtual appliance as a Dedicated Log Collector,
ensure that you conﬁgure the appliance with the required resources during inial
deployment. The Panorama virtual appliance does not remain in Log Collector
mode if you resize the virtual machine aer you deploy it, and this results in a
loss of log data.
4. Conﬁgure the instance details.
1. Select Next: Conﬁgure Instance Details.
2. For the Network, select the VPC.
3. Select the Subnet.
4. To Auto-assign Public IP select Enable.
This IP must be accessible by the ﬁrewalls you plan to manage using Panorama. This
allows you to obtain a publicly accessible IP address for the management interface
of the Panorama virtual appliance. You can later aach an Elasc IP address to the
management interface. Unlike the public IP address that is disassociated from the
virtual appliance when the instance is terminated, the Elasc IP address provides
persistence and you can the IP address to a new (or replacement) instance of the
Panorama virtual appliance without the need to reconﬁgure the IP address whenever
the Panorama virtual appliance instance is powered oﬀ.
5. Conﬁgure any addional instance details as needed.
5. (Oponal) Conﬁgure the Panorama virtual appliance storage.
1. Select Next: Add Storage.
2. Add New Volume to add addional log storage.
(SD-WAN only) If you plan on managing your SD-WAN deployment in Management
Only mode, you must add a 2TB logging disk.
If you intend to use the Panorama virtual appliance in Panorama mode or as a
Dedicated Log Collector, add the virtual logging disks during the inial deployment.
By default, the Panorama virtual appliance is in Panorama mode for the inial
deployment when you meet the Panorama mode resource requirements and have
added at least one virtual logging disk. Otherwise, the Panorama virtual appliance
defaults to Management Only mode. Change the Panorama virtual appliance to
Management Only mode if you just want to manage devices and Dedicated Log
Collectors, and to not collect logs locally.
The Panorama virtual appliance on AWS only supports 2TB logging disks, and in total
supports up to 24TB of log storage. You are unable to add a logging disk smaller than
2TB, or a logging disk with a size not divisible by the 2TB logging disk requirement.
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The Panorama virtual appliance parons logging disks larger than 2TB into 2TB
parons.
6. (Oponal) Select Next: Add Tags and add one or more tags as metadata to help you
idenfy and group the Panorama virtual appliance. For example, add a Name tag with a
Value that helps you idenfy which ﬁrewalls the Panorama virtual appliance manages.
7. Conﬁgure the instance security group.
1. Select Next: Conﬁgure Security Group.
2. Select an exisng security group to assign a security group for the Panorama virtual
appliance instance.
3. Select the security group you previously created.
You can select the default security group to allow all inbound and outbound traﬃc
types.
8. Review and Launch the Panorama virtual appliance instance to verify that your
selecons are accurate before you Launch.
9. Select an exisng key pair or create a new one and acknowledge the disclaimer.
If you created a new key from AWS, download and save the key to a safe
locaon. The ﬁle extension is .pem. You must load the public key into PuTTYgen
and save it in .ppk format. You cannot regenerate this key if lost.
It takes about 30 minutes to ﬁnish deploying the Panorama virtual appliance aer you
launch it on AWS. Deploying the Panorama virtual appliance may take longer depending
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on the number and size of the disks aached to the instance. View the Launch Time by
selecng the Panorama virtual appliance instance (Instances).

If you plan to use the Panorama virtual appliance as a Dedicated Log Collector,
ensure that you provision the appliance with the required resources. The
Panorama virtual appliance does not remain in Log Collector mode if you resize
the virtual machine aer you deploy it and this results in a loss of log data.
STEP 4 | Shut down the Panorama virtual appliance.
1. On the EC2 Dashboard, select Instances.
2. Select the Panorama virtual appliance and click Instance State > Stop Instance.
STEP 5 | Create or assign an Elasc IP (EIP) address to the management interface.
1. Select Services > EC2 > Elasc IPs and Allocate Elasc IP address.
2. Select a Network Border Group to specify the logical group of zones from where the
public IP4v address is adversed.
3. For the Public IPv4 address pool, select Amazon’s pool of IPv4 addresses.
4. Allocate the EIP.
5. Click the IPv4 address in the Allocated IPv4 address column and Associate Elasc IP
address.
6. Select the Panorama virtual appliance Instance.
7. Select the Panorama virtual appliance Private IP address to with which to associate the
EIP.
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STEP 6 | Power on the Panorama virtual appliance.
1. On the EC2 Dashboard, select Instance.
2. From the list, select the Panorama virtual appliance and click Acons > Instance State >
Start.
STEP 7 | Conﬁgure a new administrave password for the Panorama virtual appliance.
You must conﬁgure a unique administrave password before you can access the web interface
of the Panorama virtual appliance. To access the CLI, the private key used to launch the
Panorama virtual appliance is required.
• If you have an SSH service installed on your computer:
1. Enter the following command to log into the Panorama virtual appliance:
ssh -i <private_key.ppk> admin@<public-ip_address>
2. Conﬁgure a new password using the following commands and follow the on screen
prompts:
admin> configure

Panorama Administrator's Guide Version Version 10.1

74

©2022 Palo Alto Networks, Inc.

Set Up Panorama
admin# set mgt-config users admin password
3. If you need to acvate a BYOL, set the DNS server IP address so that the Panorama
virtual appliance can access the Palo Alto Networks licensing server. Enter the following
command to set the DNS server IP address:
admin# set deviceconfig system dns-setting servers
primary <ip_address>
4. Commit your changes with the command:
admin# commit
5. Terminate the SSH session.
• If you are using PuTTY to SSH into the Panorama virtual appliance:
1. If you are using an exisng key pair and have the .ppk ﬁle available, connue to the Step
7.3. If you created a new key pair or have only the .pem ﬁle of the exisng key pair, open
PuTTYgen and Load the .pem ﬁle.
2. Save the private key to a local accessible desnaon.
3. Open PuTTY and select SSH > Auth and then Browse to the .ppk ﬁle you saved in the
previous step.

4. Select Sessions and enter the public IP address of the Panorama virtual appliance. Click
Open and click Yes when the security prompt appears.
5. Log in as admin when prompted.
6. Conﬁgure a new password using the following commands and follow the onscreen
prompts:
admin> configure
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admin# set mgt-config users admin password
7. Set the DNS server IP address so that the Panorama virtual appliance can access the Palo
Alto Networks licensing server. Enter the following command to set the DNS server IP
address:
admin# set deviceconfig system dns-setting servers
primary <ip_address>
8. Commit your changes with the command:
admin# commit
9. Terminate the SSH session.
STEP 8 | Register the Panorama virtual appliance and acvate the device management license and
support licenses.
1. (VM Flex Licensing Only) Provisioning the Panorama Virtual Appliance Serial Number.
When leveraging VM Flex licensing, this step is required to generate the Panorama
virtual appliance serial number needed to register the Panorama virtual appliance with
the Palo Alto Networks Customer Support Portal (CSP).
2. Register Panorama.
You must register the Panorama virtual appliance using the serial number provided by
Palo Alto Networks in the order fulﬁllment email.
This step is not required when leveraging VM Flex licensing as the serial number is
automacally registered with the CSP when generated.
3. Acvate the ﬁrewall management license.
• Acvate/Retrieve a Firewall Management License when the Panorama Virtual
Appliance is Internet-connected.
• Acvate/Retrieve a Firewall Management License when the Panorama Virtual
Appliance is not Internet-connected.
4. Acvate a Panorama Support License.
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STEP 9 | Complete conﬁguring the Panorama virtual appliance for your deployment needs.
• For Panorama in Log Collector Mode.
1. Add a Virtual Disk to Panorama on AWS as needed.
Adding at least one virtual logging disk is required before you can change the Panorama
virtual appliance to Log Collector mode.
2. Begin at Step 6 to switch to Log Collector mode.
Enter the Public IP address of the Dedicated Log Collector when you add the
Log Collector as a managed collector to the Panorama management server. You
cannot specify the IP Address, Netmask, or Gateway.
• For Panorama in Panorama mode.
1. Add a Virtual Disk to Panorama on AWS.
Adding at least one virtual logging disk is required before you can change the Panorama
virtual appliance to Panorama mode.
2. Set up a Panorama Virtual Appliance in Panorama Mode.
3. Conﬁgure a Managed Collector.
• For Panorama in Management Only mode.
1. Set up a Panorama Virtual Appliance in Management Only Mode.
2. Conﬁgure a Managed Collector to add a Dedicated Log Collector to the Panorama virtual
appliance.
Management Only mode does not support local log collecon, and requires a Dedicated
Log Collector to store managed device logs.

Install Panorama on AWS GovCloud
You can now deploy Panorama™ and a Dedicated Log Collector on Amazon Web Services (AWS)
GovCloud. AWS GovCloud is an isolated AWS region that meets the regulatory and compliance
requirements of the US government agencies and customers. Panorama deployed on AWS
GovCloud is Bring Your Own License (BYOL), supports all deployment modes (Panorama, Log
Collector, and Management Only). For more informaon on Panorama modes, see Panorama
Models.
To secure your workloads that contain all categories of Controlled Unclassiﬁed Informaon (CUI)
data and government-oriented, publicly available data in the AWS GovCloud (US) region, the
Panorama virtual appliance provides the same security features oﬀered in the standard AWS
public cloud on AWS GovCloud. The Panorama virtual appliance on AWS GovCloud and the
standard AWS public cloud support the same features and capabilies.
Review the Setup Prerequisites for the Panorama Virtual Appliance to review the supported EC2
instance types. Once you are ready, refer to Install Panorama on AWS to install the Panorama
virtual appliance on AWS GovCloud.
See the following procedures to add addional logging storage to your Panorama virtual appliance,
or to increase the allocated CPU cores and memory:
• Add a Virtual Disk to Panorama on AWS
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• Increase CPUs and Memory for Panorama on AWS

Install Panorama on Azure
You can now deploy Panorama™ and a Dedicated Log Collector on Microso Azure. Panorama
deployed on Azure is Bring Your Own License (BYOL), supports all deployment modes (Panorama,
Log Collector, and Management Only), and shares the same processes and funconality as the MSeries hardware appliances. For more informaon on Panorama modes, see Panorama Models.
STEP 1 | Log into to the Microso Azure portal.
STEP 2 | Set up the virtual network for your network needs.
Whether you launch the Panorama virtual appliance in an exisng virtual network or you
create a new virtual network, the Panorama virtual appliance must be able to receive
traﬃc from other instances in the virtual network and perform inbound and outbound
communicaon between the virtual network and the internet as needed.
Refer to the Micros Azure Virtual Network documentaon for more informaon.
1. Create a Virtual Network or use an exisng virtual network.
2. Verify that the network and security components are appropriately deﬁned.
• Create a NAT gateway if you want to enable only outbound internet access for the
subnet to which the Panorama virtual appliance belongs.
• Create subnets. Subnets are segments of the IP address range assigned to the
VPC in which you can launch Microso Azure instances. It is recommended that
the Panorama virtual appliance belong to the management subnet so that you can
conﬁgure it to access the internet if needed.
• Add routes to the route table for a private subnet to ensure traﬃc can be routed
across subnets in the VPC and from the internet if applicable.
Ensure you create routes between subnets to allow communicaon between:
• Panorama, managed ﬁrewalls, and Log Collectors.
• (Oponal) Panorama and the internet.
• Ensure that the following ingress security rules are allowed for the VPC to manage
VPC traﬃc. The ingress traﬃc source for each rule is unique to your deployment
topology.
See Ports Used for Panorama for more informaon.
• Allow SSH (port 22) traﬃc to enable access to the Panorama CLI.
• Allow HTTPS (port 443) traﬃc to enable access to the Panorama web interface.
• Allow traﬃc on port 3978 to enable communicaon between Panorama, manage
ﬁrewalls, and managed Log Collectors. This port is also used by Log Collectors to
forward logs to Panorama.
• Allow traﬃc on port 28443 to enable managed ﬁrewalls to get soware and
content updates from Panorama.
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STEP 3 | Deploy the Panorama virtual appliance.
1. In the Azure Dashboard, select Virtual machines and Add a new virtual machine.
2. Search for Palo Alto Networks and select the latest Panorama virtual appliance image.
3. Create the Panorama virtual appliance.
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STEP 4 | Conﬁgure the Panorama virtual appliance.
1. Select your Azure Subscripon.
2. Select the Azure Resource Group to contain all your Azure instance resources.
3. Enter a Virtual machine name for the Panorama virtual appliance.
4. Select the Region for the Panorama virtual appliance to be deployed in.
5. (Oponal) Select the Availability opons. See How to use availability sets for more
informaon.
6. Select the Image used to deploy the Panorama management server. Browse all public
and private images to deploy the Panorama management server from the Panorama
image on the Azure marketplace.
7. Conﬁgure the Panorama virtual appliance size. Review the Setup Prerequisites for the
Panorama Virtual Appliance for sizing requirements.
If you plan to use the Panorama virtual appliance as a Dedicated Log Collector,
ensure that you conﬁgure the appliance with the required resources during inial
deployment. The Panorama virtual appliance does not remain in Log Collector
mode if you resize the virtual machine aer you deploy it, and this results in a
loss of log data.
8. Enter a Username for the Panorama virtual appliance administrator. To ensure that your
username is secure, admin is not a valid entry.
9. Enter a Password or copy and paste an SSH public key for securing administrave access
to the Panorama virtual appliance.
You must enable SSH key authencaon if you plan to use this instance of the
Panorama virtual appliance in FIPS-CC operaonal mode. Although you can
deploy the Panorama virtual appliance using a username and password, you will
be unable to authencate using the username and password aer changing the
operaonal mode to FIPS-CC. Aer reseng to FIPS-CC mode, you must use the
SSH key to log in and can then conﬁgure a username and password that you can
use for subsequently logging in to the Panorama web interface. For details on
creang the SSH key, refer to the Azure documentaon.
10. Conﬁgure the Panorama virtual appliance instance Networking
1. Select an exisng Virtual network or create a new virtual network.
2. Conﬁgure the Subnet. The subnet is dependent on the virtual network you selected
or created in the previous step. If you selected an exisng virtual network, you can
choose one of the subnets for the selected virtual network.
3. Select an exisng Public IP address or create a new one. This creates the
management interface used to access your Panorama virtual appliance.
4. Select an exisng NIC network security group or create a new security group.
Network security groups control traﬃc to the virtual machine. Make sure that HTTPS
and SSH are allowed for the Inbound rules.
11. Conﬁgure the instance Management sengs.
1. Select whether to enable Auto-shutdown. Auto-shutdown allows you to conﬁgure
a daily me to automacally shut down the virtual machine that you disable autoshutdown to avoid the possibility that a new public IP address gets assigned to the
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virtual machine, that logs are dropped, that logs are not or that you are unable to
manage your ﬁrewalls while the Panorama virtual appliance is shut down.
2. Select whether to enable boot Monitoring. Select the Diagnosc storage account if
enabled. Monitoring automacally sends boot-up diagnosc logs to your Diagnoscs
storage account. For more informaon, see Overview of Monitoring in Microso
Azure.
3. Conﬁgure any other sengs as needed.
12. Review the summary, accept the terms of use and privacy policy, and Create the
Panorama virtual appliance.
STEP 5 | Verify that you the Panorama virtual appliance has been successfully deployed.
1. Select Dashboard > Resource Groups and select the resource group containing the
Panorama virtual appliance.
2. Under Sengs, select Deployments for the virtual machine deployment status.
It takes about 30 minutes to deploy the Panorama virtual appliance. Launching
the Panorama virtual appliance may take longer depending on the resources
conﬁgured for the virtual machine. Microso Azure does not permit the ICMP
protocol to test whether it deployed successfully.
If you plan to use the Panorama virtual appliance as a Dedicated Log Collector,
ensure that you correctly conﬁgured the appliance the required resources. The
Panorama virtual appliance does not remain in Log Collector mode if you resize
the virtual machine aer you deploy it and this results in a loss of log data.
STEP 6 | Conﬁgure a stac Public IP address.
1. On the Azure portal, select Virtual machines and select the Panorama virtual machine.
2. Select Overview and click the Public IP address.
3. Under Assignment, select Stac and Save the new IP address conﬁguraon.
STEP 7 | Log in to the web interface of the Panorama virtual appliance.
1. On the Azure portal, in All Resources, select the Panorama virtual appliance and view the
public IP address located in the Overview secon.

2. Use a secure (hps) connecon from your web browser to log in to the Panorama virtual
appliance using the public IP address.
3. Enter the username and password of the Panorama virtual appliance. You are prompted
with a cerﬁcate warning. Accept the cerﬁcate warning and connue to the web page.
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STEP 8 | Register the Panorama virtual appliance and acvate the device management license and
support licenses.
1. (VM Flex Licensing Only) Provisioning the Panorama Virtual Appliance Serial Number.
When leveraging VM Flex licensing, this step is required to generate the Panorama
virtual appliance serial number needed to register the Panorama virtual appliance with
the Palo Alto Networks Customer Support Portal (CSP).
2. Register Panorama.
You must register the Panorama virtual appliance using the serial number provided by
Palo Alto Networks in the order fulﬁllment email.
This step is not required when leveraging VM Flex licensing as the serial number is
automacally registered with the CSP when generated.
3. Acvate the ﬁrewall management license.
• Acvate/Retrieve a Firewall Management License when the Panorama Virtual
Appliance is Internet-connected.
• Acvate/Retrieve a Firewall Management License when the Panorama Virtual
Appliance is not Internet-connected.
4. Acvate a Panorama Support License.
STEP 9 | Complete conﬁguring the Panorama virtual appliance for your deployment needs.
• For Panorama in Log Collector Mode.
1. Add a Virtual Disk to Panorama on Azure as needed.
Adding at least one virtual logging disk is required before you can change the Panorama
virtual appliance to Log Collector mode.
2. Begin at Step 6 to switch to Log Collector mode.
Enter the Public IP address of the Dedicated Log Collector when you add the
Log Collector as a managed collector to the Panorama management server. You
cannot specify the IP Address, Netmask, or Gateway.
• For Panorama in Panorama mode.
1. Add a Virtual Disk to Panorama on Azure.
Adding at least one virtual logging disk is required before you can change the Panorama
virtual appliance to Panorama mode.
2. Set up a Panorama Virtual Appliance in Panorama Mode.
3. Conﬁgure a Managed Collector.
• For Panorama in Management Only mode.
1. Set up a Panorama Virtual Appliance in Management Only Mode.
2. Conﬁgure a Managed Collector to add a Dedicated Log Collector to the Panorama virtual
appliance.
Management Only mode does not support local log collecon, and requires a Dedicated
Log Collector to store managed device logs.
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Install Panorama on Google Cloud Plaorm
You can now deploy Panorama™ and a Dedicated Log Collector on Google Cloud Plaorm
(GCP). Panorama deployed on GCP is Bring Your Own License (BYOL), supports all deployment
modes (Panorama, Log Collector, and Management Only), and shares the same processes and
funconality as the M-Series hardware appliances. For more informaon on Panorama modes, see
Panorama Models.
To deploy the Panorama virtual appliance on GCP, you need to build a custom image. To begin
this process, you must download the Panorama tar.gz from the Palo Alto Networks Customer
Support portal and upload it to a GCP storage bucket. You can then create the custom image and
use the image to deploy the Panorama virtual appliance on GCP.
STEP 1 | Download the Panorama virtual appliance image.
1. Log in to the Palo Alto Networks Support Portal.
2. Select Updates > Soware Updates and ﬁlter by Panorama Base Images.
3. Download the latest version of the Panorama on GCP tar.gz image.
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STEP 2 | Upload the Panorama virtual appliance image to the Google Cloud Plaorm.
1. Log in to the Google Cloud Console.
2. From the Products and Services menu, select Storage.
3. Click Create Bucket, conﬁgure the new storage bucket and click Create.

4. Select the storage bucket you created in the previous step, click Upload ﬁles, and select
the Panorama virtual appliance image you downloaded.

5. From the Products and Services menu, select Compute Engine > Images.
6. Click Create Image and create the Panorama virtual appliance image:
1. Name the Panorama virtual appliance image.
2. In the Source ﬁeld, select Cloud Storage ﬁle from the drop-down menu.
3. Click Browse and navigate to the storage bucket where you uploaded the Panorama
virtual appliance image, and Select the uploaded image.
4. Create the Panorama virtual appliance image.
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STEP 3 | Conﬁgure the Panorama virtual appliance.
1. From the Products and Services menu and select the Compute Engine.
2. Click Create Instance to begin deploying the Panorama virtual appliance.
3. Add a descripve Name to easily idenfy the Panorama virtual appliance.
4. Select the Region and Zone where you want to deploy the Panorama virtual appliance.
5. Allocate the Machine Type and Customize the CPU cores, memory and CPU plaorm.
Review the Setup Prerequisites for the Panorama Virtual Appliance for minimum
resource requirements.
If you plan to use the Panorama virtual appliance as a Dedicated Log Collector,
ensure that you conﬁgure the appliance with the required resources during inial
deployment. The Panorama virtual appliance does not remain in Log Collector
mode if you resize the virtual machine aer you deploy it, and this results in a
loss of log data.
The GCP zone selecon determines the CPU plaorms available to you. For more
informaon, refer to Regions and Zones for details.

6. Conﬁgure the Panorama boot disk.
1. For the Boot Disk, click Change > Custom image and select the Panorama image ﬁle
you uploaded in Step 2
2. Review the boot disk Size and verify the system disk is 81GB.
3. Click Select to save your conﬁguraon.
7. Under Identy and API access, select Allow full access to all Cloud APIs.

8. Under Firewall, select Allow HTTPS traﬃc.
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STEP 4 | Expand Management, security, disks, networking, sole tenancy

.

STEP 5 | Enable access to the serial port so you can manage the Panorama virtual appliance.
1. Select Management.
2. Enter the following name-value pair as Metadata:
serial-port-enable true
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STEP 6 | Reserve a stac IP address for the management interface.
Reserve stac internal and external IP addresses for the management interface in the
event that if the Panorama virtual appliance is rebooted, your managed devices do not lose
connecon to the Panorama virtual appliance when the IP addresses are reassigned.
For more informaon on how to reserve IP addresses, refer to Reserving a Stac Internal IP
Address and Reserving a Stac External IP Address.
1. Select Networking.
2. Edit the network interface.

3. Select the Panorama virtual appliance Network.
4. Select the Panorama virtual appliance Subnetwork. Instances in the same subnetwork
will communicate with each other using their internal IP addresses.
5. Set the Primary internal IP address.
• Ephemeral (Automac)— Automacally assign a primary internal IP address.
• Ephemeral (Custom)—Conﬁgure a custom IP range that GCP uses to assign a primary
internal IP address.
• Reserve a stac internal IP address—Manually conﬁgure a stac primary internal IP
address.
6. Set the External IP address.
• Ephemeral—Automacally assign an external IP address from a shared IP pool.
• Select an exisng reserved external IP address.
• Create IP address—Reserve an external IP address.
7. Set IP forwarding to On to allow the Panorama virtual appliance to receive packets from
non-matching desnaons or source IP addresses.
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STEP 7 | Conﬁgure the SSH key. You need an SSH key to access the Panorama virtual appliance CLI to
conﬁgure the administrave user password aer the inial deployment.
• PuTTY Users
1. Select Security.
2. Select the Block project-wide SSH keys box. Only instance keys are currently supported
for logging in to the Panorama virtual appliance aer inial deployment.
3. Paste the SSH key in the comment box. For informaon on the correct SSH key format
and how to generate SSH keys for GCP, refer to Managing SSH keys in Metadata.
When generang the SSH key, save the private key in .ppk format. The private
key is required to log in to the Panorama virtual appliance aer the inial
deployment before you can conﬁgure the administrave password.

• Linux and macOS Users
1. Generate the SSH key from the CLI of your Linux device.
ssh-keygen -C admin@panorama -f <panorama_key_name>
Where admin@panorama is a comment GCP requires and <panorama_key_name> is
the name of the key ﬁle being generated.
2. Create an output ﬁle for the SSH key.
cat <panorama_key_name>.pub
Aer the output ﬁle for the SSH key is created, manually copy the SSH key contents.
3. Paste the public key into the SSH Keys secon of the GCP instance creaon.
STEP 8 | (Oponal) Add addional storage for log collecon. Repeat this step as needed to add
addional virtual logging disks.
If you intend to use the Panorama virtual appliance in Panorama mode or as a Dedicated Log
Collector, add the virtual logging disks during inial deployment. By default, the Panorama
virtual appliance is in Panorama mode for the inial deployment when you meet the Panorama
mode resource requirements and have added at least one virtual logging disk. Otherwise, the
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Panorama virtual appliance defaults to Management Only mode in which you can manage
devices and Dedicated Log Collectors, and cannot collect logs locally.
The Panorama virtual appliance on GCP only supports 2TB logging disks, and in total supports
up to 24TB of log storage. You are unable to add a logging disk smaller than 2TB, or a logging
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disk with a size not divisible by the 2TB logging disk requirement. The Panorama virtual
appliance parons logging disks larger than 2TB into 2TB parons.
1. Select Disks > Add new disk.

2. Enter the Name.
3. Expand the Type drop-down menu and select the desired type.
4. For the Source type, select Blank disk.
5. For the Mode, select Read/write.
6. Select the Deleon rule to conﬁgure whether to delete the virtual logging disk if the
Panorama virtual appliance instance is deleted. To
7. Set the Size (GB) of the virtual logging disk.
8. Set your preferred Encrypon soluon for the data on the virtual logging disk.
9. Click Done.
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STEP 9 | Create the Panorama virtual appliance. The Panorama virtual appliances takes roughly 10
minutes to boot up aer inial deployment.
STEP 10 | Conﬁgure a new administrave password for the Panorama virtual appliance.
You must conﬁgure a unique administrave password before you can access the web interface
of the Panorama virtual appliance. To access the CLI, use the private key to launch the
Panorama virtual appliance.
• If you have an SSH service installed on your computer:
1. Enter the following command to log into the Panorama virtual appliance:
• Windows Devices
ssh -i <private_key.ppk> admin@<public-ip_address>
• Linux Devices
ssh -i panorama <public-ip_address>
2. Conﬁgure a new password using the following commands and follow the onscreen
prompts:
admin> configure
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admin# set mgt-config users admin password
3. If you have a BYOL that you need to, set the DNS server IP address so that the
Panorama virtual appliance can access the Palo Alto Networks licensing server. Enter the
following command to set the DNS server IP address:
admin# set deviceconfig system dns-setting servers
primary <ip_address>
4. Commit your changes:
admin# commit
5. Terminate the SSH session.
• If you are using PuTTY to SSH into the Panorama virtual appliance:
1. If you are using an exisng key pair and have the .ppk ﬁle available, connue to Step
11.3. If you created a new key pair or only have the .pem ﬁle of the exisng key pair,
open PuTTYgen and Load the .pem ﬁle.
2. Save the private key to a local accessible desnaon.
3. Open PuTTY and select SSH > Auth and Browse for the .ppk ﬁle saved in the previous
step.

4. Select Sessions and enter the public IP address of the Panorama virtual appliance. Then
Open and click Yes when the security prompt appears.
5. Login as admin when prompted.
6. Conﬁgure a new password using the following commands and follow the on screen
prompts:
admin> configure
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admin# set mgt-config users admin password
7. Set the DNS server IP address so that the Panorama virtual appliance can access the Palo
Alto Networks licensing server. Enter the following command to set the DNS server IP
address:
admin# set deviceconfig system dns-setting servers
primary <ip_address>
8. Commit your changes with the command:
admin# commit
9. Terminate the SSH session.
STEP 11 | Register the Panorama virtual appliance and acvate the device management license and
support licenses.
1. (VM Flex Licensing Only) Provisioning the Panorama Virtual Appliance Serial Number.
When leveraging VM Flex licensing, this step is required to generate the Panorama
virtual appliance serial number needed to register the Panorama virtual appliance with
the Palo Alto Networks Customer Support Portal (CSP).
2. Register Panorama.
You must register the Panorama virtual appliance using the serial number provided by
Palo Alto Networks in the order fulﬁllment email.
This step is not required when leveraging VM Flex licensing as the serial number is
automacally registered with the CSP when generated.
3. Acvate the ﬁrewall management license.
• Acvate/Retrieve a Firewall Management License when the Panorama Virtual
Appliance is Internet-connected.
• Acvate/Retrieve a Firewall Management License when the Panorama Virtual
Appliance is not Internet-connected.
4. Acvate a Panorama Support License.
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STEP 12 | Complete conﬁguring the Panorama virtual appliance for your deployment needs.
• For Panorama in Log Collector Mode.
1. Add a Virtual Disk to Panorama on Google Cloud Plaorm as needed.
Adding at least one virtual logging disk is required before you can change the Panorama
virtual appliance to Log Collector mode.
2. Begin at Step 6 to switch to Log Collector mode.
Enter the Public IP address of the Dedicated Log Collector when you add the
Log Collector as a managed collector to the Panorama management server. You
cannot specify the IP Address, Netmask, or Gateway.
• For Panorama in Panorama mode.
1. Add a Virtual Disk to Panorama on Google Cloud Plaorm.
Adding at least one virtual logging disk is required before you can change the Panorama
virtual appliance to Panorama mode.
2. Set up a Panorama Virtual Appliance in Panorama Mode.
3. Conﬁgure a Managed Collector.
• For Panorama in Management Only mode.
1. Set up a Panorama Virtual Appliance in Management Only Mode.
2. Conﬁgure a Managed Collector to add a Dedicated Log Collector to the Panorama virtual
appliance.
Management Only mode does not support local log collecon, and requires a Dedicated
Log Collector to store managed device logs.
• For SD-WAN deployments.
1. Increase the System Disk for Panorama on Google Cloud Plaorm
To leverage SD-WAN on Panorama deployed on GCP, you must increase the the system
disk to 224GB.
You cannot migrate back to a 81GB system disk aer successfully increasing the
system disk to 224GB.
2. Set up a Panorama Virtual Appliance in Management Only Mode.
3. Add a Virtual Disk to Panorama on Google Cloud Plaorm.
To leverage SD-WAN, you must add a single 2TB logging disk to Panorama in
Management Only mode.

Install Panorama on KVM
You can now deploy Panorama™ and a Dedicated Log Collector on KVM. Panorama deployed
on KVM is Bring Your Own License (BYOL), supports all deployment modes (Panorama, Log
Collector, and Management Only), and shares the same processes and funconality as the MSeries hardware appliances. For more informaon on Panorama modes, see Panorama Models.
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STEP 1 | Download the Panorama virtual appliance image for KVM.
1. Log in to the Palo Alto Networks Support Portal.
2. Select Soware Updates and ﬁnd the Panorama for KVM Base image.
3. Download the latest available Panorama .qcow2 ﬁle.
STEP 2 | Create a new virtual machine image and add the Panorama virtual appliance image for KVM
to the Virtual Machine Manager.
1. On the Virtual Machine Manager, select Create a new virtual machine.
2. Select Import Exisng disk image and click Forward.

3. Browse and select the Panorama virtual appliance image volume and Choose volume.
4. Click Forward.
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STEP 3 | Conﬁgure the memory and CPU sengs.
Review the Setup Prerequisites for the Panorama Virtual Appliance for minimum resource
requirements.
If you plan to use the Panorama virtual appliance as a Dedicated Log Collector, ensure
that you conﬁgure the appliance with the required resources during inial deployment.
The Panorama virtual appliance does not remain in Log Collector mode if you resize the
virtual machine aer you deploy it, and this results in a loss of log data.
1. Conﬁgure the Memory based on the requirements for the desired operaonal mode.
The Virtual Machine Manager may use MiB (mebibyte) to allocate memory
depending on the version you are running. If MiB is used, be sure to correctly
convert your required memory allocaon to avoid under provisioning the
Panorama virtual appliance.
2. Conﬁgure the CPU based on the requirements for the desired operaonal mode.
3. Click Forward.
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STEP 4 | Name the Panorama virtual appliance, enable conﬁguraon customizaon, and select the
management interface bridge.
1. Enter a descripve Name for the Panorama virtual appliance.
2. Customize conﬁguraon before install.
3. Make a Network selecon—select the bridge for the management interface and accept
the default sengs.
4. Click Finish.

STEP 5 | Conﬁgure the virtual system disk sengs.
1. Select IDE Disk 1, go to Advanced opons, and select the following:
• Disk Bus—VirtIO or IDE, depending on your conﬁguraon.
• Storage format—qcow2
2. Go to Performance opons and set Cache mode to writethrough. This seng improves
installaon me and execuon speed on the Panorama virtual appliance.
3. Click Apply.
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STEP 6 | Conﬁgure the virtual machine console display to use the VNC server to interact with the
virtual machine.
1. Select Display Spice.
Connue to the next step if Display VNC is listed in the Hardware list because
the virtual machine is already conﬁgured to use the VNC server for the display.
2. In the Type drop-down, select VNC server.
3. Click Apply.

STEP 7 | (Oponal) Add addional storage for log collecon. Repeat this step as needed to add
addional virtual logging disks.
If you intend to use the Panorama virtual appliance in Panorama mode or as a Dedicated Log
Collector, add the virtual logging disks during the inial deployment. By default, the Panorama
virtual appliance is in Panorama mode for the inial deployment when you meet the Panorama
mode resource requirements and have added at least one virtual logging disk. Otherwise, the
Panorama virtual appliance defaults to Management Only mode. Change the Panorama virtual
appliance to Management Only mode if you just want to manage devices and Dedicated Log
Collectors, and to not collect logs locally.
The Panorama virtual appliance on KVM only supports 2TB logging disks, and in total supports
up to 24TB of log storage. You are unable to add a logging disk smaller than 2TB, or a logging
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disk with a size not divisible by the 2TB logging disk requirement. The Panorama virtual
appliance parons logging disks larger than 2TB into 2TB parons.
1. Add Hardware.
2. Conﬁgure the new Storage disk:
1. Create a disk image for a virtual machine and conﬁgure the virtual disk storage
capacity to 14901.2 GiB (this is equivalent to 2TB).
The Virtual Machine Manager may use GiB (gibibyte) to allocate memory
depending on the version you are running. If GiB is used, be sure to correctly
convert the required storage capacity to avoid under provisioning the virtual
logging disk and sending the Panorama virtual appliance into maintenance
mode.
2. Set the Device type to Disk device.
3. Set the Bus type to VirtIO or IDE, depending on your conﬁguraon.
4. Go to Advanced opons and set Cache mode to writethrough.
3. Click Finish.

STEP 8 | Begin Installaon (
minutes to boot.

). The Panorama virtual appliances takes approximately 10

STEP 9 | Conﬁgure the network access sengs for the management interface.
1. Open a connecon to the console.
2. Log in to the ﬁrewall using the default username and password: admin/admin.
3. Enter conﬁguraon mode using the following command:
admin> configure
4. Use the following commands to conﬁgure and enable access to the management
interface:
admin# set deviceconfig system type static
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admin# set deviceconfig system ip-address <Panorama-IP>
netmask <netmask> default-gateway <gateway-IP> dns-setting
servers primary <DNS-IP>
where <Panorama-IP> is the IP address you want to assign to the management interface,
<netmask> is the subnet mask, <gateway-IP> is the IP address of the network gateway,
and <DNS-IP> is the IP address of the DNS server.
admin# commit
STEP 10 | Register the Panorama virtual appliance and acvate the device management license and
support licenses.
1. (VM Flex Licensing Only) Provisioning the Panorama Virtual Appliance Serial Number.
When leveraging VM Flex licensing, this step is required to generate the Panorama
virtual appliance serial number needed to register the Panorama virtual appliance with
the Palo Alto Networks Customer Support Portal (CSP).
2. Register Panorama.
You must register the Panorama virtual appliance using the serial number provided by
Palo Alto Networks in the order fulﬁllment email.
This step is not required when leveraging VM Flex licensing as the serial number is
automacally registered with the CSP when generated.
3. Acvate the ﬁrewall management license.
• Acvate/Retrieve a Firewall Management License when the Panorama Virtual
Appliance is Internet-connected.
• Acvate/Retrieve a Firewall Management License when the Panorama Virtual
Appliance is not Internet-connected.
4. Acvate a Panorama Support License.
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STEP 11 | Complete conﬁguring the Panorama virtual appliance for your deployment needs.
• For Panorama in Log Collector Mode.
1. Add a Virtual Disk to Panorama on KVM as needed.
Adding at least one virtual logging disk is required before you can change the Panorama
virtual appliance to Log Collector mode.
2. Begin at Step 6 to switch to Log Collector mode.
Enter the Public IP address of the Dedicated Log Collector when you add the
Log Collector as a managed collector to the Panorama management server. You
cannot specify the IP Address, Netmask, or Gateway.
• For Panorama in Panorama mode.
1. Add a Virtual Disk to Panorama on KVM.
Adding at least one virtual logging disk is required before you can change the Panorama
virtual appliance to Panorama mode.
2. Set up a Panorama Virtual Appliance in Panorama Mode.
3. Conﬁgure a Managed Collector.
• For Panorama in Management Only mode.
1. Set up a Panorama Virtual Appliance in Management Only Mode.
2. Conﬁgure a Managed Collector to add a Dedicated Log Collector to the Panorama virtual
appliance.
Management Only mode does not support local log collecon, and requires a Dedicated
Log Collector to store managed device logs.

Install Panorama on Hyper-V
You can now deploy Panorama™ and a Dedicated Log Collector on Hyper-V. Panorama deployed
on Hyper-V is Bring Your Own License (BYOL), supports all deployment modes (Panorama, Log
Collector, and Management Only), and shares the same processes and funconality as the MSeries hardware appliances. For more informaon on Panorama modes, see Panorama Models.
Panorama virtual appliance and virtual Dedicated Log Collector on Hyper-V is available only on
PAN-OS 8.1.3 and later releases.
STEP 1 | Download the VHDX ﬁle.
1. Log in to the Palo Alto Networks Support Portal.
2. Select Updates > Soware Updates, ﬁlter by Panorama Base Images, and download the
VHDX ﬁle.
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STEP 2 | Set up any vSwitch(es) that you will need. For more informaon, review the Virtual Switch
Types for more informaon.
1. From Hyper-V Manager, select the host and select Acon > Virtual Switch Manager to
open the Virtual Switch Manager window.

2. Under Create virtual switch, select the type of vSwitch to create and click Create Virtual
Switch.
STEP 3 | Install the Panorama virtual appliance.
1. On the Hyper-V Manager, select the host and select Acon > New > Virtual Machine.
Conﬁgure the following sengs in the New Virtual Machine Wizard:

1. Choose a Name and Locaon for the Panorama virtual appliance. The Panorama
virtual appliance stores the VHDX ﬁle at the speciﬁed locaon.
2. Choose Generaon 1. This is the default opon and the only version supported.
3. For Startup Memory, assign the memory based on the intended system mode. See the
Setup Prerequisites for the Panorama Virtual Appliance for the memory requirements
for each mode.
Do not enable dynamic memory; the Panorama virtual appliance requires
stac memory allocaon.
4. Conﬁgure Networking. Select an external vSwitch to connect the management
interface on the ﬁrewall.
5. To connect the Virtual Hard Disk, select Use an exisng virtual hard disk and browse
to the VHDX ﬁle you downloaded earlier.
6. Review the summary and click Finish.
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STEP 4 | Allocate the Panorama virtual appliance CPU cores.
Review the Setup Prerequisites for the Panorama Virtual Appliance for minimum resource
requirements.
If you plan to use the Panorama virtual appliance as a Dedicated Log Collector, ensure
that you conﬁgure the appliance with the required resources during inial deployment.
The Panorama virtual appliance does not remain in Log Collector mode if you resize the
virtual machine aer you deploy it, and this results in a loss of log data.
1. In the Hardware list, select Processor.
2. Edit the currently allocated Number of virtual processors.

STEP 5 | Connect at least one network adapter for the dataplane interface on the ﬁrewall. Repeat this
to create addional network interfaces on the Panorama virtual appliance.
1. Select Sengs > Hardware > Add Hardware and select the Hardware type for your
network adapter.
Legacy Network Adapter and SR-IOV are not supported. If selected, the VMSeries ﬁrewall will boot into maintenance mode.
2. Click OK.
STEP 6 | (Oponal) Add addional storage for log collecon. Repeat this step as needed to add
addional virtual logging disks. If you want to deploy the Panorama virtual appliance in
Management Only mode, connue to Step 6.
If you intend to use the Panorama virtual appliance in Panorama mode or as a Dedicated Log
Collector, add the virtual logging disks during the inial deployment. By default, the Panorama
virtual appliance is in Panorama mode for the inial deployment when you meet the Panorama
mode resource requirements and have added at least one virtual logging disk. Otherwise, the
Panorama virtual appliance defaults to Management Only mode. Change the Panorama virtual
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appliance to Management Only mode if you just want to manage devices and Dedicated Log
Collectors, and to not collect logs locally.
The Panorama virtual appliance on Hyper-V only supports 2TB logging disks, and in total
supports up to 24TB of log storage. You are unable to add a logging disk smaller than 2TB, or a
logging disk with a size not divisible by the 2TB logging disk requirement. The Panorama virtual
appliance parons logging disks larger than 2TB into 2TB parons.
1. On the Hyper-V Manager, select the host and select Acon > New > Hard Disk.
2. If you see the Before You Begin prompt, click Next to begin adding the virtual logging
disk.
3. For the Disk Format, select VHDX. Click Next. to connue
4. For the Disk Type, select Fixed Size or Dynamically Expanding based on your needs.
Click Next to connue.
5. Specify the Name and Locaon for the virtual logging disk ﬁle. Click Next to connue.
6. To conﬁgure the disk, select Create a new virtual hard disk and enter the disk size. Click
Next to connue.
7. Review the Summary and Finish adding the virtual hard logging disk.
STEP 7 | Power on the Panorama virtual appliance.
1. Select the Panorama virtual appliance instance from the list of Virtual Machines.
2. Select Acon > Start to power on the Panorama virtual appliance.

STEP 8 | Conﬁgure the IP address of the management interface.
1. In the Virtual Machines list, select the Panorama virtual appliance.
2. Select Acons > Connect and enter the username and password to log in (default is
admin for both).
3. Enter the following commands, where <Panorama-IP> is the IP address you want to
assign to the Panorama management interface, <netmask> is the subnet mask, <gatewayIP> is the IP address of the network gateway, and <DNS-IP> is the IP address of the DNS
server:
admin> configure
admin# set deviceconfig system ip-address <Panorama-IP>
netmask <netmask> default-gateway <gateway-IP> dns-setting
servers primary <DNS-IP>
admin# commit
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admin# exit
4. Troubleshoot Connecvity to Network Resources to verify network access to external
services required for ﬁrewall management, such as the default gateway, DNS server, and
the Palo Alto Networks Update Server, as shown in the following example:

STEP 9 | Register the Panorama virtual appliance and acvate the device management license and
support licenses.
1. (VM Flex Licensing Only) Provisioning the Panorama Virtual Appliance Serial Number.
When leveraging VM Flex licensing, this step is required to generate the Panorama
virtual appliance serial number needed to register the Panorama virtual appliance with
the Palo Alto Networks Customer Support Portal (CSP).
2. Register Panorama.
You must register the Panorama virtual appliance using the serial number provided by
Palo Alto Networks in the order fulﬁllment email.
This step is not required when leveraging VM Flex licensing as the serial number is
automacally registered with the CSP when generated.
3. Acvate the ﬁrewall management license.
• Acvate/Retrieve a Firewall Management License when the Panorama Virtual
Appliance is Internet-connected.
• Acvate/Retrieve a Firewall Management License when the Panorama Virtual
Appliance is not Internet-connected.
4. Acvate a Panorama Support License.
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STEP 10 | Complete conﬁguring the Panorama virtual appliance for your deployment needs.
• For Panorama in Log Collector Mode.
1. Add a Virtual Disk to Panorama on Hyper-V as needed.
Adding at least one virtual logging disk is required before you can change the Panorama
virtual appliance to Log Collector mode.
2. Begin at Step 6 to switch to Log Collector mode.
Enter the Public IP address of the Dedicated Log Collector when you add the
Log Collector as a managed collector to the Panorama management server. You
cannot specify the IP Address, Netmask, or Gateway.
• For Panorama in Panorama mode.
1. Add a Virtual Disk to Panorama on Hyper-V.
Adding at least one virtual logging disk is required before you can change the Panorama
virtual appliance to Panorama mode.
2. Set up a Panorama Virtual Appliance in Panorama Mode.
3. Conﬁgure a Managed Collector.
• For Panorama in Management Only mode.
1. Set up a Panorama Virtual Appliance in Management Only Mode.
2. Conﬁgure a Managed Collector to add a Dedicated Log Collector to the Panorama virtual
appliance.
Management Only mode does not support local log collecon, and requires a Dedicated
Log Collector to store managed device logs.

Set Up Panorama on Oracle Cloud Infrastructure (OCI)
Set up a Panorama™ virtual appliance on Oracle Cloud Infrastructure (OCI) to centrally managed
the conﬁguraon of physical and VM-Series ﬁrewalls.
• Upload the Panorama Virtual Appliance Image to OCI
• Install Panorama on Oracle Cloud Infrastructure (OCI)
• Generate a SSH Key for Panorama on OCI
Upload the Panorama Virtual Appliance Image to OCI
Complete the following procedure to upload a Panorama qcow2 ﬁle for KVM and create a custom
image that you need to launch the Panorama virtual appliance. Uploading and creang the
image is required only once. You can use the same image for all subsequent deployments of the
Panorama virtual appliance.
STEP 1 | Download the Panorama qcow2 ﬁle for KVM from the Palo Alto Networks Customer Support
Portal (CSP).
1. Log in to the Palo Alto Networks CSP.
2. Select Updates > Soware Updates and select Panorama Base Images from the soware
updates ﬁlter drop-down.
3. Download the latest version of the Panorama-KVM qcow2 image.
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STEP 2 | Log in to the Oracle Cloud Infrastructure console.
STEP 3 | Create a storage bucket for the qcow2 ﬁle.
1. Select Object Storage > Object Storage and Create Bucket.
2. Enter a descripve Bucket Name.
3. For the Storage Tier, select Standard.
4. Create Bucket.
STEP 4 | Upload the qcow2 image to the OCI storage bucket.
1. Click the storage bucket you created in the previous step to view the bucket details.
2. Click Upload and select the qcow2 image you downloaded from the Palo Alto Networks
CSP.
3. Upload the image.
STEP 5 | Create a pre-authencated request for the qcow2 ﬁle.
This is required to create the object URL used in the creaon of the custom image for the
Panorama virtual appliance.
1. Select Object Storage > Object Storage and click the storage bucket you created in the
previous step.
2. Select Pre-Authencated Requests > Create Pre-Authencated Request.
3. Enter a descripve Name for your Pre-Authencated Request.
4. Select Object and enter the qcow2 image name for the Object Name.
5. Create Pre-Authencated Request.
6. For the Access Type, select Permit object reads and writes.
7. Enter an Expiraon date and me.
8. Create Pre-Authencated Request.
9. In the Pre-Authencated Request Details, copy the Pre-Authencated Request URL.
The Pre-Authencated Request URL is required to create the custom image and
must be copied when displayed to you.
The Pre-Authencated Request URL is only displayed aer the request is created
and is not shown again.
10. Close the Pre-Authencated Request Details aer you copy the URL.
STEP 6 | Import the qcow2 ﬁle and create a custom Panorama virtual appliance image.
1. Select Compute > Custom Images and Import Image.
2. Enter a descripve Name for your image.
3. Select Import from an Object Storage URL and paste the object storage URL.
4. For the Image type, select QCOW2.
5. For the Launch Mode, select Paravirtualized Mode.
6. Import Image.
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Install Panorama on Oracle Cloud Infrastructure (OCI)
Create a Panorama™ virtual appliance instance on Oracle Cloud Infrastructure (OCI). An OCI
instance supports a single NIC by default. You must manually upload a Panorama virtual appliance
qcow2 image downloaded from the Palo Alto Networks Customer Supported Portal (CSP) to OCI
to successfully install the Panorama virtual appliance on OCI.
A Panorama virtual appliance deployed on OCI is Bring Your Own License (BYOL), supports
all deployment modes (Panorama, Log Collector, and Management Only), and shares the same
processes and funconality as the M-Series hardware appliances. For more informaon on
Panorama modes, see Panorama Models.
A machine running a Linux operang system is required successfully install the Panorama on
OCI. To successfully install Panorama on OCI, you must generate a .pub key using OpenSSH.
Addionally, you can only use a Linux machine to log into the Panorama CLI for the inial network
conﬁguraon.
Review the Setup Prerequisites for the Panorama Virtual Appliance to determine the virtual
resources required for your needs. The virtual resources requirement for the Panorama virtual
appliance is based on the total number of ﬁrewalls managed by the Panorama virtual appliance
and the required Logs Per Second (LPS) for forwarding logs from your managed ﬁrewalls to your
Log Collector.
Under-provisioning the Panorama virtual appliance will impact management performance.
This includes the Panorama virtual appliance becoming slow or unresponsive depending on
how under-provisioning the Panorama virtual appliance is.
STEP 1 | Log in to the Oracle Cloud Infrastructure console.
STEP 2 | Upload the Panorama Virtual Appliance Image to OCI.
STEP 3 | Set up the Virtual Cloud Network (VCN) for your network needs.
Whether you launch the Panorama virtual appliance in an exisng VCN or you create a new
VCN, the Panorama virtual appliance must be able to receive traﬃc from other instances in the
VCN and perform inbound and outbound communicaon between the VCN and the internet
as needed.
Refer to the OCI VCN documentaon for more informaon.
1. Conﬁgure a VCN or use an exisng VCN.
2. Verify that the network and security components are appropriately deﬁned.
• Create an internet gateway to enable internet access to the subnet of your Panorama
virtual appliance. Internet access is required to install soware and content updates,
acvate licenses, and leverage Palo Alto Networks cloud services. Otherwise, you
must manually install updates and acvate licenses.
If the Panorama virtual appliance instance is part of a private subnet, you can
conﬁgure a NAT gateway to enable only outbound internet access for the subnet.
• Create subnets. Subnets are segments of the IP address range assigned to the VCN
in which you can launch OCI instances. It is recommended that the Panorama virtual
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appliance belong to the management subnet so that you can conﬁgure it to access the
internet if needed.
• Add routes to the route table for a private subnet to ensure traﬃc can be routed
across subnets in the VCN and from the internet if applicable.
Ensure you create routes between subnets to allow communicaon between:
• Panorama, managed ﬁrewalls, and Log Collectors.
• (Oponal) Panorama and the internet.
• Ensure that the following ingress security rules are allowed for the VCN to manage
VCN traﬃc. The ingress traﬃc source for each rule is unique to your deployment
topology.
See Ports Used for Panorama for more informaon.
• Allow SSH (port 22) traﬃc to enable access to the Panorama CLI.
• Allow HTTPS (port 443 and 28270) traﬃc to enable access to the Panorama web
interface.
• Allow traﬃc on port 3978 to enable communicaon between Panorama, manage
ﬁrewalls, and managed Log Collectors. This port is also used by Log Collectors to
forward logs to Panorama.
• Allow traﬃc on port 28443 to enable managed ﬁrewalls to get soware and
content updates from Panorama.
STEP 4 | Select Compute > Instances and Create Instance.
STEP 5 | Enter a descripve Name for the Panorama virtual appliance image.
STEP 6 | Select the Availability domain.
STEP 7 | Select the custom Panorama image.
1. Under Image and shape, select Change Image.
2. For the Image Source, select Custom Image.
3. Select the custom Panorama image you created.
4. Select Image.
STEP 8 | Conﬁgure the instance resources.
Refer to the Setup Prerequisites for the Panorama Virtual Appliance for more informaon for
the minimum resources required based on your Panorama usage needs.
1. Under Image and shape, select Change Shape.
2. Select the shape with number of CPUs, amount of RAM, and number of interfaces you
require.
3. Select Shape.

Panorama Administrator's Guide Version Version 10.1

110

©2022 Palo Alto Networks, Inc.

Set Up Panorama
STEP 9 | Conﬁgure the instance Networking sengs.
1. For the Network, Select exisng virtual cloud network and select the VCN.
2. For the Subnet, Select exisng subnet and select the subnet.
It is recommended to deploy the Panorama virtual appliance instance in a management
subnet to safely allow internet access if needed.
3. (Oponal) For the Public IP Address, select Assign a public IPv4 address if you want to
make the Panorama virtual appliance accessible from outside the VCN.
STEP 10 | Conﬁgure the Panorama virtual appliance instance boot volume.
1. For the Boot volume, specify a custom boot volume size.
2. For the Boot volume size, enter 81.
STEP 11 | Create the Panorama virtual appliance image.
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STEP 12 | Conﬁgure a new administrave password and the system IP address sengs for the
Panorama virtual appliance.
1. Generate a SSH Key for Panorama on OCI.
2. In the OCI console, select Instances and select the Panorama virtual appliance instance.
3. Select Console Connecon and Create Console Connecon.
4. Select Upload public key ﬁles (.pub) and upload the public SSH key you generated to
Create Console Connecon.
5. In the Instance Details screen, expand the Console Connecon opons and Copy Serial
Connecon for Linux/Mac.
6. On your Linux machine, open a terminal and paste the serial connecon.
7. Create the new admin password when prompted.
8. Conﬁgure the inial network sengs for the Panorama virtual appliance.
admin> configure
admin#

set deviceconfig system type static

admin# set deviceconfig system ip-address <instance-privateIP address> netmask <netmask> default-gateway <defaultgateway-IP>
admin# set deviceconfig system dns-setting servers primary
<primary-dns-IP>
admin# set deviceconfig system dns-setting servers secondary
<secondary-dns-IP>
admin# commit
9. Verify you can log in to the Panorama web interface.
If you cannot log in to the Panorama web interface, review your route table and VCN
security rules to ensure the correct routes and security rules are created.
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STEP 13 | Register the Panorama virtual appliance and acvate the device management license and
support licenses.
1. (VM Flex Licensing Only) Provisioning the Panorama Virtual Appliance Serial Number.
When leveraging VM Flex licensing, this step is required to generate the Panorama
virtual appliance serial number needed to register the Panorama virtual appliance with
the Palo Alto Networks Customer Support Portal (CSP).
2. Register Panorama.
You must register the Panorama virtual appliance using the serial number provided by
Palo Alto Networks in the order fulﬁllment email.
This step is not required when leveraging VM Flex licensing as the serial number is
automacally registered with the CSP when generated.
3. Acvate the ﬁrewall management license.
• Acvate/Retrieve a Firewall Management License when the Panorama Virtual
Appliance is Internet-connected.
• Acvate/Retrieve a Firewall Management License when the Panorama Virtual
Appliance is not Internet-connected.
4. Acvate a Panorama Support License.
STEP 14 | Complete conﬁguring the Panorama virtual appliance for your deployment needs.
• For Panorama in Log Collector Mode.
1. Add a Virtual Disk to Panorama on Oracle Cloud Infrastructure (OCI) as needed.
Adding at least one virtual logging disk is required before you can change the Panorama
virtual appliance to Log Collector mode.
2. Begin at Step 6 to switch to Log Collector mode.
Enter the Public IP address of the Dedicated Log Collector when you add the
Log Collector as a managed collector to the Panorama management server. You
cannot specify the IP Address, Netmask, or Gateway.
• For Panorama in Panorama mode.
1. Add a Virtual Disk to Panorama on Oracle Cloud Infrastructure (OCI).
Adding at least one virtual logging disk is required before you can change the Panorama
virtual appliance to Panorama mode.
2. Set up a Panorama Virtual Appliance in Panorama Mode.
3. Conﬁgure a Managed Collector.
• For Panorama in Management Only mode.
1. Set up a Panorama Virtual Appliance in Management Only Mode.
2. Conﬁgure a Managed Collector to add a Dedicated Log Collector to the Panorama virtual
appliance.
Management Only mode does not support local log collecon, and requires a Dedicated
Log Collector to store managed device logs.
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Generate a SSH Key for Panorama on OCI
To connect to the Panorama™ virtual appliance installed on Oracle Cloud Infrastructure (OCI), you
must generate a public and private SSH key on a Linux machine. You use the generated SSH key to
log in to the Panorama CLI to set up a new administrave password and conﬁgure the Panorama
network sengs.
A Linux machine is required to generate the SSH key and access the Panorama CLI for
the inial conﬁguraon. Generang a SSH from OCI or third-party applicaons such as
PuTTygen is not supported.
STEP 1 | Open the terminal on your Linux machine.
STEP 2 | Navigate to the hidden .ssh directory.
admin:~$ cd ~/.ssh
STEP 3 | Generate an SSH key in the .ssh directory.
admin:~/.ssh$ ssh-keygen
When prompted, save the key in the default .ssh directory. A password for the key is
oponal.
The default name for the private key is id_rsa and the default name for the public key is
id_rsa.pub.
STEP 4 | Copy the public key from the .ssh directory to your home directory.
This step is required to upload the public key to OCI.
admin: ~/.ssh$ cp id_rsa.pub ~

Perform Inial Conﬁguraon of the Panorama Virtual Appliance
Based on your Panorama model, use the Alibaba Cloud Console, AWS, Azure, GCP, or OCI web
interface, KVM Virtual Machine Manager, Hyper-V Manager, VMware vSphere Client, or vCloud
Air web console to set up network access to the Panorama virtual appliance. By default, the
Panorama virtual appliance is deployed in Panorama mode. For uniﬁed reporng, consider using
Greenwich Mean Time (GMT) or Coordinated Universal Time (UTC) as the uniform me zone
across Panorama and all the managed ﬁrewalls and Log Collectors.
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STEP 1 | Gather the required informaon from your network administrator.
Collect the following informaon for the management (MGT) interface:
IP address for the management (MGT) interface
The default management interface IP address is 192.168.1.1. if you do not
conﬁgure the management interface as described when you install the Panorama
virtual appliance.
Netmask
Default gateway
DNS server IP address
To complete the conﬁguraon of the MGT interface, you must specify the IP
address, netmask (for IPv4) or preﬁx length (for IPv6), and default gateway. If you
omit sengs (such as the default gateway), you can access Panorama only through
the console port for future conﬁguraon changes. As a best pracce, always commit
a complete MGT interface conﬁguraon.
STEP 2 | Access the console of the Panorama virtual appliance.
1. Access the console.
On an ESXi server:
1. Launch the VMware vSphere Client.
2. Select the Console tab for the Panorama virtual appliance and press enter to access
the login screen.
On vCloud Air:
1. Access the vCloud Air web console and select your Virtual Private Cloud OnDemand
region.
2. Select the Virtual Machines tab, right-click the Panorama virtual machine, and select
Open In Console.
2. Enter your username and password to log in (default is admin for both).
On Alibaba Cloud, AWS, Azure, GCP, KVM, Hyper-V, and OCI:
• Log in to the Panorama CLI.
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STEP 3 | Change the default administrator password.
Starng with PAN-OS 9.0.4, the predeﬁned, default administrator password (admin/
admin) must be changed on the ﬁrst login on a device. The new password must be
a minimum of eight characters and include a minimum of one lowercase and one
uppercase character, as well as one number or special character.
Be sure to use the best pracces for password strength to ensure a strict password
and review the password complexity sengs.
To ensure that the management interface remains secure, conﬁgure the Minimum
Password Complexity (Panorama > Setup > Management).
1. Click the admin link on the le side of the web interface footer.
2. Enter the Old Password and the New Password and record the new password in a safe
locaon.
3. Click OK.
STEP 4 | Conﬁgure the network access sengs for the MGT interface.
Panorama uses the MGT interface for management traﬃc, high availability synchronizaon, log
collecon, and communicaon within Collector Groups.
1. Enter the following commands, where <Panorama-IP> is the IP address you want to
assign to the Panorama management interface, <netmask> is the subnet mask, <gatewayIP> is the IP address of the network gateway, and <DNS-IP> is the IP address of the DNS
server:
> configure
# set deviceconfig system ip-address <Panorama-IP>
netmask <netmask> default-gateway <gateway-IP> dns-setting
servers primary <DNS-IP>
# commit
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# exit
2. Troubleshoot Connecvity to Network Resources to verify network access to external
services required for ﬁrewall management, such as the default gateway, DNS server, and
the Palo Alto Networks Update Server, as shown in the following example:

STEP 5 | Conﬁgure the general sengs.
1. Using a secure connecon (HTTPS) from a web browser, log in to the Panorama web
interface using the IP address and password you assigned to the management interface
(hps://<IP address>).
2. Select Panorama > Setup > Management and edit the General Sengs.
3. Enter a Hostname for the server and enter the network Domain name. The domain name
is just a label; Panorama doesn’t use it to join the domain.
4. Align the clock on Panorama and the managed ﬁrewalls to use the same Time Zone, for
example GMT or UTC. If you plan to use the Cortex Data Lake, you must conﬁgure NTP
so that Panorama can stay in sync with the Cortex Data Lake.
Timestamps are recorded when Panorama receives the logs and the managed ﬁrewalls
generate the logs. Aligning the me zones on Panorama and the ﬁrewalls ensures that
the mestamps are synchronized and the process of querying logs and generang
reports on Panorama is harmonious.
5. Enter the Latude and Longitude to enable accurate placement of the Panorama
management server on the world map.
6. Enter the Serial Number you received in the order fulﬁllment email.
7. Click OK to save your changes.
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STEP 6 | (Oponal) Modify the management interface sengs.
To conﬁgure connecvity to Panorama using an IPv6 IP address, you must conﬁgure
both an IPv4 and IPv6 to successfully conﬁgure Panorama using an IPv6 IP address.
Panorama does not support conﬁguring the management interface with only an IPv6 IP
address.
1. Select Panorama > Setup > Interfaces and click Management.
2. If your ﬁrewalls connect to the Panorama management server using a public IP address
that is translated to a private IP address (NAT), enter the public IP in the Public IP
Address ﬁeld, and the private IP in the IP Address ﬁeld to push both addresses to your
ﬁrewalls.
3. Select which Network Connecvity Services to allow on the interface (such as SSH
access).
Don’t select Telnet or HTTP. These services use plaintext and are less secure
than the other services.
4. Click OK to save your changes to the interface.
STEP 7 | Commit your conﬁguraon changes.
Select Commit > Commit to Panorama and Commit your changes.
STEP 8 | Next steps...
1. If necessary, Expand Log Storage Capacity on the Panorama Virtual Appliance.
2. (Best Pracce) Replace the default cerﬁcate that Panorama uses to secure HTTPS traﬃc
over the management (MGT) interface.
3. Acvate a Panorama Support License.
4. Acvate/Retrieve a Firewall Management License when the Panorama Virtual Appliance
is Internet-connected.
5. Install Content and Soware Updates for Panorama.
6. Set Up Administrave Access to Panorama

Set Up The Panorama Virtual Appliance as a Log Collector
If you want a dedicated virtual appliance for log collecon, conﬁgure a Panorama virtual appliance
on ESXi, Alibaba Cloud, AWS, AWS GovCloud, Azure, Google Cloud Plaorm, KVM, HyperV, or Oracle Cloud Infrastructure (OCI) in Log Collector mode. To do this, you ﬁrst perform
the inial conﬁguraon of the virtual appliance in Panorama mode, which includes licensing,
installing soware and content updates, and conﬁguring the management (MGT) interface.
You then switch the Panorama virtual appliance to Log Collector mode and complete the
Log Collector conﬁguraon. Addionally, if you want to use dedicated M-Series Appliance
Interfaces (recommended) instead of the MGT interface for log collecon and Collector Group
communicaon, you must ﬁrst conﬁgure the interfaces for the Panorama management server,
then conﬁgure them for the Log Collector, and then perform a Panorama commit followed by a
Collector Group commit.
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Perform the following steps to set up a new virtual appliance as a Log Collector or to convert an
exisng virtual appliance that was previously deployed as a Panorama management server.
Switching the virtual appliance from Panorama mode to Log Collector mode reboots the
appliance, deletes the local Log Collector, deletes any exisng log data, and deletes all
conﬁguraons except the management access sengs. Switching the mode does not
delete licenses, soware updates, or content updates.
STEP 1 | Set up the Panorama virtual appliance management server that will manage the Log Collector
if you have not already done so.
Perform one of the following tasks:
• Set Up the Panorama Virtual Appliance
• Set Up the M-Series Appliance
STEP 2 | Record the management IP addresses of the Panorama management server.
If you deployed Panorama in a high availability (HA) conﬁguraon, you need the IP address of
each HA peer.
1. Log in to the web interface of the Panorama management server.
2. Record the IP Address of the solitary (non-HA) or acve (HA) Panorama by selecng
Panorama > Setup > Management and checking the Management Interface Sengs.
3. For an HA deployment, record the Peer HA IP Address of the passive Panorama by
selecng Panorama > High Availability and checking the Setup secon.
STEP 3 | Set up the Panorama virtual appliance that will serve as a Dedicated Log Collector.
If you previously deployed this appliance as a Panorama management server, you can skip this
step because the MGT interface is already conﬁgured and the licenses and updates are already
installed.
The Panorama virtual appliance in Log Collector mode does not have a web interface for
conﬁguraon tasks, only a CLI. Therefore, before changing the mode on the Panorama virtual
appliance, use the web interface in Panorama mode to:
1. Set up the Panorama virtual appliance in one of the following supported hypervisors:
• Install Panorama on an ESXi Server
• Install Panorama on Alibaba Cloud
• Install Panorama on AWS
• Install Panorama on AWS GovCloud
• Install Panorama on Azure
• Install Panorama on Google Cloud Plaorm
• Install Panorama on Hyper-V
• Set Up Panorama on Oracle Cloud Infrastructure (OCI)
2. Perform Inial Conﬁguraon of the Panorama Virtual Appliance.
3. Register Panorama and Install Licenses.
4. Install Content and Soware Updates for Panorama.
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STEP 4 | (Panorama on Azure only) Modify the admin password.
The Dedicated Log Collector supports only the admin Administrator user in order to change
in to Log Collector mode. Modify the admin password to allow you to log in using the admin
Administrator user.
1. Log in to the Panorama Web Interface.
2. Select Panorama > Administrators and select admin.
3. Enter the Password, Conﬁrm Password and click OK.
4. Select Commit > Commit to Panorama and Commit your changes.
STEP 5 | (Panorama on AWS and Azure only) Delete all users, except for the admin user.
1. Log in to the Panorama Web Interface as admin.
2. Select Panorama > Administrators.
3. Select the exisng Administrators, except admin, and Delete.
4. Select Commit > Commit to Panorama and Commit your changes.
STEP 6 | Log in to the Panorama CLI.
STEP 7 | Switch from Panorama mode to Log Collector mode.
1. Switch to Log Collector mode by entering the following command:
> request system system-mode logger
2. Enter Y to conﬁrm the mode change. The virtual appliance reboots. If the reboot process
terminates your terminal emulaon soware session, reconnect to the virtual appliance
to see the Panorama login prompt.
If you see a CMS Login prompt, this means the Log Collector has not ﬁnished
reboong. Press Enter at the prompt without typing a username or password.
3. Log back in to the CLI.
4. Verify that the switch to Log Collector mode succeeded:
> show system info | match system-mode
If the mode change succeeded, the output displays:
system-mode: logger
STEP 8 | Enable connecvity between the Log Collector and Panorama management server.
Enter the following commands at the Log Collector CLI, where <IPaddress1> is for the MGT
interface of the solitary (non-HA) or acve (HA) Panorama and <IPaddress2> is for the MGT
interface of the passive (HA) Panorama, if applicable.
> configure
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# set deviceconfig system panorama-server <IPaddress1> panoramaserver-2 <IPaddress2>
# commit
# exit
STEP 9 | Record the serial number of the Log Collector.
You need the serial number to add the Log Collector as a managed collector on the Panorama
management server.
1. At the Log Collector CLI, enter the following command to display its serial number.
> show system info | match serial
2. Record the serial number.
STEP 10 | Add the Log Collector as a managed collector to the Panorama management server.
1. Select Panorama > Managed Collectors and Add a managed collector.
2. In the General sengs, enter the serial number (Collector S/N) you recorded for the Log
Collector.
3. In the Panorama Server IP ﬁeld, enter the IP address or FQDN of the solitary (non-HA)
or acve (HA) Panorama. For HA deployments, enter the IP address or FQDN of the
passive Panorama peer in the Panorama Server IP 2 ﬁeld.
These IP addresses must specify a Panorama interface that has Device Management and
Device Log Collecon services enabled. By default, these services are enabled only on
the MGT interface. However, you might have enabled the services on other interfaces
when you Set Up the M-Series Appliance that is a Panorama management server.
4. Select Interfaces, click Management, and enter the Public IP Addressof the Dedicated
Log Collector.
5. Click OK twice to save your changes to the Log Collector.
6. Select Commit > Commit to Panorama and Commit your changes to the Panorama
conﬁguraon.
7. Verify that Panorama > Managed Collectors lists the Log Collector you added. The
Connected column displays a check mark to indicate that the Log Collector is connected
to Panorama. You might have to wait a few minutes before the page displays the updated
connecon status.
At this point, the Conﬁguraon Status column displays Out of Sync and the Run
Time Status column displays disconnected. The status will change to In Sync and
connected aer you conﬁgure a Collector Group.
STEP 11 | Enable the logging disks.
1. Select Panorama > Managed Collectors and edit the Log Collector.
2. Select Disks and Add each disk.
3. Click OK to save your changes.
4. Select Commit > Commit to Panorama and Commit your changes to the Panorama
conﬁguraon.
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STEP 12 | (Recommended) Conﬁgure the Ethernet1, Ethernet2, Ethernet3, Ethernet4, and Ethernet5
interfaces if the Panorama management server and Log Collector will use them for Device
Log Collecon (receiving logs from ﬁrewalls) and Collector Group Communicaon.
If you previously deployed the Log Collector as a Panorama management server and conﬁgured
these interfaces, you must reconﬁgure them because switching to Log Collector mode would
have deleted all conﬁguraons except the management access sengs.
1. Conﬁgure each interface on the Panorama management server (other than the MGT
interface) if you haven’t already:
1. Select Panorama > Setup > Interfaces and click the Interface Name.
2. Select <interface-name> to enable the interface.
3. Complete one or both of the following ﬁeld sets based on the IP protocols of your
network:
• For ESXi
• IPv4—Public IP Address, IP Address, Netmask, and Default Gateway
IPv6—IPv6 Address/Preﬁx Length and Default IPv6 Gateway
• For Alibaba Cloud, AWS, Azure, GCP, and OCI
• Public IP address
4. Select the Device Management Services that the interface supports:
Device Management and Device Log Collecon—You can assign one or more
interfaces.
Collector Group Communicaon—You can assign only one interface.
Device Deployment (soware and content updates)—You can assign only one
interface.
5. Click OK to save your changes.
2. Conﬁgure each interface on the Log Collector (other than the MGT interface):
1. Select Panorama > Managed Collectors and edit the Log Collector.
2. Select Interfaces and click the name of the interface.
3. Select <interface-name> to enable the interface.
4. Complete one or both of the following ﬁeld sets based on the IP protocols of your
network:
• For ESXi
• IPv4—Public IP Address, IP Address, Netmask, and Default Gateway
IPv6—IPv6 Address/Preﬁx Length and Default IPv6 Gateway
• For Alibaba Cloud, AWS, Azure, GCP, and OCI
• Public IP address
5. Select the Device Management Services that the interface supports:
Device Log Collecon—You can assign one or more interfaces.
Collector Group Communicaon—You can assign only one interface.
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6. Click OK to save your changes to the interface.
3. Click OK to save your changes to the Log Collector.
4. Select Commit > Commit to Panorama and Commit your changes to the Panorama
conﬁguraon.
STEP 13 | (Oponal) If your deployment is using custom cerﬁcates for authencaon between
Panorama and managed devices, deploy the custom client device cerﬁcate. For more
informaon, see Set Up Authencaon Using Custom Cerﬁcates.
1. Select Panorama > Cerﬁcate Management > Cerﬁcate Proﬁle and choose the
cerﬁcate proﬁle from the drop-down or click New Cerﬁcate Proﬁle to create one.
2. Select Panorama > Managed Collectors > Add > Communicaon for a Log Collector.
3. Select the Secure Client Communicaon check box.
4. Select the type of device cerﬁcate the Type drop-down.
• If you are using a local device cerﬁcate, select the Cerﬁcate and Cerﬁcate Proﬁle
from the respecve drop-downs.
• If you are using SCEP as the device cerﬁcate, select the SCEP Proﬁle and Cerﬁcate
Proﬁle from the respecve drop-downs.
5. Click OK.
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STEP 14 | (Oponal) Conﬁgure Secure Server Communicaon Sn a Log Collector. For more informaon,
see Set Up Authencaon Using Custom Cerﬁcates.
1. Select Panorama > Managed Collectors > Add > Communicaon.
2. Verify that the Custom Cerﬁcate Only check box is not selected. This allows you to
connue managing all devices while migrang to custom cerﬁcates.
When the Custom Cerﬁcate Only check box is selected, the Log Collector
does not authencate and cannot receive logs from devices using predeﬁned
cerﬁcates.
3. Select the SSL/TLS service proﬁle from the SSL/TLS Service Proﬁle drop-down. This
SSL/TLS service proﬁle applies to all SSL connecons between the Log Collector and
devices sending it logs.
4. Select the cerﬁcate proﬁle from the Cerﬁcate Proﬁle drop-down.
5. Select Authorize Client Based on Serial Number to have the server check clients against
the serial numbers of managed devices. The client cerﬁcate must have the special
keyword $UDID set as the CN to authorize based on serial numbers.
6. In Disconnect Wait Time (min), enter the number of minutes Panorama should wait
before breaking and reestablishing the connecon with its managed devices. This ﬁeld is
blank by default and the range is 0 to 44,640 minutes.
The disconnect wait me does not begin counng down unl you commit the
new conﬁguraon.
7. (Oponal) Conﬁgure an authorizaon list.
1. Click Add under Authorizaon List.
2. Select the Subject or Subject Alt Name as the Idenﬁer type.
3. Enter an idenﬁer of the selected type.
4. Click OK.
5. Select Check Authorizaon List to enforce the authorizaon list.
8. Click OK.
9. Select Commit > Commit to Panorama.
STEP 15 | Assign the Log Collector to a Collector Group.
1. Conﬁgure a Collector Group. You must perform a Panorama commit and then a Collector
Group commit to synchronize the Log Collector conﬁguraon with Panorama and to put
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the Eth1, Eth2, Eth3, Eth4, and Eth5 interfaces (if you conﬁgured them) in an operaonal
state on the Log Collector.
In any single Collector Group, all the Log Collectors must run on the same
Panorama model: all M-600 appliances, all M-500 appliances, all M-200
appliances, or all Panorama virtual appliances.
As a best pracce, Enable log redundancy across collectors if you add mulple
Log Collectors to a single Collector group. This opon requires each Log Collector
to have the same number of logging disks.
2. Select Panorama > Managed Collectors to verify that the Log Collector conﬁguraon is
synchronized with Panorama.
The Conﬁguraon Status column should display In Sync and the Run Time Status column
should display connected.
3. Access the Log Collector CLI and enter the following command to verify that its
interfaces are operaonal:
> show interface all
The output displays the state as up for each interface that is operaonal.
4. If the Collector Group has mulple Log Collectors, Troubleshoot Connecvity to Network
Resources to verify they can communicate with each other by performing a Ping
connecvity test for each interface that the Log Collectors use. For the source IP
address, specify the interface of one of the Log Collectors. For the host IP address,
specify the matching interface of another Log Collector in the same Collector Group.
STEP 16 | Next steps...
To enable the Log Collector to receive ﬁrewall logs:
1. Conﬁgure Log Forwarding to Panorama.
2. Verify Log Forwarding to Panorama.

Set Up the Panorama Virtual Appliance with Local Log Collector
If the Panorama virtual appliance is in Legacy mode aer you upgrade from a Panorama 8.0 or
earlier release to a Panorama 8.1 (or later) release, switch to Panorama mode in order to create a
local Log Collector, add mulple logging disks without losing exisng logs. increase log storage up
to 24TB, and enable faster report generaon.
Once you change from Legacy mode to Panorama mode, Legacy mode will no longer be
available.
Aer upgrading to Panorama 8.1, the ﬁrst step is to increase the system resources on the virtual
appliance to the minimum required for Panorama mode. Panorama reboots when you increase
resources, so perform this procedure during a maintenance window. You must install a larger
system disk (81GB), increase CPUs and memory based on the log storage capacity, and add a
virtual logging disk. The new logging disk must have at least as much capacity as the appliance
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currently uses in Legacy mode and cannot be less than 2TB. Adding a virtual disk enables you to
migrate exisng logs to the Log Collector and enables the Log Collector to store new logs.
If Panorama is deployed in an HA conﬁguraon, perform the following steps on the secondary
peer ﬁrst and then on the primary peer.
STEP 1 | Determine which system resources you need to increase before the virtual appliance can
operate in Panorama mode.
You must run the command speciﬁed in this step even if you have determined that
Panorama already has adequate resources.
1. Access the Panorama CLI:
1. Use terminal emulaon soware such as PuTTY to open an SSH session to the IP
address that you speciﬁed for the Panorama MGT interface.
2. Log in to the CLI when prompted.
2. Check the resources you must increase by running the following command:
> request system system-mode panorama
Enter y when prompted to connue. The output speciﬁes the resources you must
increase. For example:
Panorama mode not supported on current system disk of size
52.0 GB.
Please attach a disk of size 81.0 GB, then use 'request system
clone-system-disk' to migrate the current system disk
Please add a new virtual logging disk with more than 50.00 GB
of storage capacity.
Not enough CPU cores: Found 4 cores, need 8 cores
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STEP 2 | Increase the CPUs and memory, and replace the system disk with a larger disk.
1. Access the VMware ESXi vSphere Client, select Virtual Machines, right-click the
Panorama virtual appliance, and select Power > Power Oﬀ.
2. Right-click the Panorama virtual appliance and Edit Sengs.
3. Select Memory and enter the new Memory Size.
4. Select CPUs and specify the number of CPUs (the Number of virtual sockets mulplied
by the Number of cores per socket).
5. Add a virtual disk.
You will use this disk to replace the exisng system disk.
1. In the Hardware sengs, Add a disk, select Hard Disk as the hardware type, and click
Next.
2. Create a new virtual disk and click Next.
3. Set the Disk Size to exactly 81GB and select the Thick Provision Lazy Zeroed disk
format.
4. Select Specify a datastore or datastore structure as the locaon, Browse to a
datastore of at least 81GB, click OK, and click Next.
5. Select a SCSI Virtual Device Node (you can use the default selecon) and click Next.
Panorama will fail to boot if you select a format other than SCSI.
6. Verify that the sengs are correct and then click Finish and OK.
6. Right-click the Panorama virtual appliance and select Power > Power On. Wait for
Panorama to reboot before connuing.
7. Return to the Panorama CLI and copy the data from the original system disk to the new
system disk:
> request system clone-system-disk target sdb
Enter y when prompted to connue.
The copying process takes around 20 to 25 minutes, during which Panorama reboots.
When the process ﬁnishes, the output tells you to shut down Panorama.
8. Return to the vSphere Client console, right-click the Panorama virtual appliance, and
select Power > Power Oﬀ.
9. Right-click the Panorama virtual appliance and Edit Sengs.
10. Select the original system disk, click Remove, select Remove from virtual machine, and
click OK.
11. Right-click the Panorama virtual appliance and Edit Sengs.
12. Select the new system disk, set the Virtual Device Node to SCSI (0:0), and click OK.
13. Right-click the Panorama virtual appliance and select Power > Power On. Before
proceeding, wait for Panorama to reboot on the new system disk (around 15 minutes).
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STEP 3 | Add a virtual logging disk.
This is the disk to which you will migrate exisng logs.
1. In the VMware ESXi vSphere Client, right-click the Panorama virtual appliance and select
Power > Power Oﬀ.
2. Right-click the Panorama virtual appliance and Edit Sengs.
3. Repeat the steps to Add a virtual disk. Set the Disk Size to a mulple of 2TB based on
the amount of log storage you need. The capacity must be at least as large as the exisng
virtual disk or NFS storage that Panorama currently uses for logs. The disk capacity must
be a mulple of 2TB and can be up to 24TB. For example, if the exisng disk has 5TB of
log storage, you must add a new disk of at least 6TB.
Aer you switch to Panorama mode, Panorama will automacally divide the new disk
into 2TB parons, each of which will funcon as a separate virtual disk.
4. Right-click the Panorama virtual appliance and select Power > Power On. Wait for
Panorama to reboot before connuing.
STEP 4 | Switch from Legacy mode to Panorama mode.
Aer switching the mode, the appliance reboots again and then automacally creates a
local Log Collector and Collector Group. The exisng logs won’t be available for querying or
reporng unl you migrate them later in this procedure.
1. Return to the Panorama CLI and run the following command.
> request system system-mode panorama
Enter y when prompted to connue. Aer reboong, Panorama automacally creates a
local Log Collector (named Panorama) and creates a Collector Group (named default) to
contain it. Panorama also conﬁgures the virtual logging disk you added and divides it into
separate 2TB disks. Wait for the process to ﬁnish and for Panorama to reboot (around
ﬁve minutes) before connuing.
2. Log in to the Panorama web interface.
3. In the Dashboard, General Informaon sengs, verify that the Mode is now panorama.
In an HA deployment, the secondary peer is in a suspended state at this point because
its mode (Panorama) does not match the mode on the primary peer (Legacy). You will un-
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suspend the secondary peer aer switching the primary peer to Panorama mode later in
this procedure.
4. Select Panorama > Collector Groupsto verify that the default collector group has been
created, and that the local Log Collector is part of the default collector group.
5. Push the conﬁguraon to the managed devices.
• If there are no pending changes:
1. Select Commit > Push to Devices and Edit Selecons.
2. Select Collector Group and make sure the default collector group is selected.
3. Click OK and Push.
• If you have pending changes:
1. Select Commit > Commit and Push and Edit Selecons.
2. Verify that your Device Group devices and Templates are included.
3. Select Collector Group and make sure the default collector group is selected.
4. Click OK and Commit and Push.
6. Select Panorama > Managed Collectors and verify that the columns display the following
informaon for the local Log Collector:
• Collector Name—This defaults to the Panorama hostname. It should be listed under
the default Collector Group.
• Connected—Check mark
• Conﬁguraon Status—In sync
• Run Time Status—connected
STEP 5 | (HA only) Switch the primary Panorama from Legacy mode to Panorama mode.
This step triggers failover.
1. Repeat Step 1 through Step 4 on the primary Panorama.
Wait for the primary Panorama to reboot and return to an acve HA state. If preempon
is not enabled, you must manually fail back: select Panorama > High Availability and, in
the Operaonal Commands secon, Make local Panorama funconal.
2. On the primary Panorama, select Dashboard and, in the High Availability secon, Sync to
peer, click Yes, and wait for the Running Conﬁg to display Synchronized status.
3. On the secondary Panorama, select Panorama > High Availability and, in the Operaonal
Commands secon, Make local Panorama funconal.
This step is necessary to bring the secondary Panorama out of its suspended HA state.
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STEP 6 | Migrate exisng logs to the new virtual logging disks.
If you deployed Panorama in an HA conﬁguraon, perform this only on the primary peer.
Palo Alto Networks recommends migrang exisng logs to the new virtual logging disks
during your maintenance window. The log migraon requires a large number of the
Panorama virtual appliance CPU cores to execute and impacts Panorama operaonal
performance.
1. Return to the Panorama CLI.
2. Start the log migraon:
> request logdb migrate vm start
The process duraon varies by the volume of log data you are migrang. To check the
status of the migraon, run the following command:
> request logdb migrate vm status
When the migraon ﬁnishes, the output displays: migrationhas been done.
3. Verify that the exisng logs are available.
1. Log in to the Panorama web interface.
2. Select Panorama > Monitor, select a log type that you know matches some exisng
logs (for example, Panorama > Monitor > System), and verify that the logs display.
STEP 7 | Next steps...
Conﬁgure log forwarding to Panorama so that the Log Collector receives new logs from
ﬁrewalls.

Set up a Panorama Virtual Appliance in Panorama Mode
Panorama mode allows the Panorama™ virtual appliance to operate as a Panorama management
server with local log collecon capabilies. By default, the Panorama virtual appliance is deployed
in Panorama mode when at least one virtual logging disk is aached to a Panorama virtual
appliance.
While sll supported, switching from Legacy mode with a 50GB logging disk to Panorama
mode is not recommended for producon environments. If you switch to Panorama mode
with a 50GB logging disk, you are unable to add addional logging disks.
STEP 1 | Log in to the Panorama CLI.
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STEP 2 | Switch to Panorama mode.
1. Change to Panorama mode:
> request system system-mode panorama
2. Enter Y to conﬁrm the mode change. The Panorama virtual appliance reboots. If the
reboot process terminates your terminal emulaon soware session, reconnect to the
Panorama virtual appliance to see the Panorama login prompt.
If you see a CMS Login prompt, this means the Panorama virtual appliance has not
ﬁnished reboong. Press Enter at the prompt without typing a username or password.
STEP 3 | Verify that the switch to Panorama mode succeeded.
1. Log back in to the CLI.
2. Verify that the switch to Panorama mode succeeded:
> show system info | match system-mode
If the mode change succeeded, the output displays:
> system mode:panorama

Set up a Panorama Virtual Appliance in Management Only Mode
Management Only mode allows the Panorama virtual appliance to operate strictly as a Panorama
management server without local log collecon capabilies. By default, the Panorama virtual
appliance is in Panorama mode for the inial deployment. It is recommended to change the
Panorama virtual appliance to Management Only immediately aer the inial deployment because
changing to Management Only mode requires that there are no logs being forwarded to the
Panorama management server because the Panorama virtual appliance in Management Only mode
does not support log collecon. Aer you change to Management Only mode, any exisng log
data stored on the Panorama virtual appliance becomes inaccessible, and the ACC and reporng
features cannot query the logs stored on the Panorama virtual appliance.
If you conﬁgured a local Log Collector, the local Log Collector sll exists on Panorama
when you change to Management Only mode despite having no log collecon capabilies.
Deleng the local Log Collector (Panorama > Managed Collectors) deletes the Eth1/1
interface conﬁguraon the local Log Collector uses by default. If you decide to delete the
local Log Collector, you must reconﬁgure the Eth1/1 interface.
STEP 1 | Log in to the Panorama CLI.
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STEP 2 | Switch to Management Only mode.
1. Change to Management Only mode:
> request system system-mode management-only
2. Enter Y to conﬁrm the mode change. The Panorama virtual appliance reboots. If the
reboot process terminates your terminal emulaon soware session, reconnect to the
Panorama virtual appliance to see the Panorama login prompt.
If you see a CMS Login prompt, this means the Panorama virtual appliance has not
ﬁnished reboong. Press Enter at the prompt without typing a username or password.
STEP 3 | Verify that the switch to Management Only mode succeeded.
1. Log back in to the CLI.
2. Verify that the switch to Management Only mode succeeded:
> show system info | match system-mode
If the mode change succeeded, the output displays:
> system mode:management-only

Expand Log Storage Capacity on the Panorama Virtual Appliance
Aer you Perform Inial Conﬁguraon of the Panorama Virtual Appliance, the available log
storage capacity and the opons for expanding it depend on the virtual plaorm (VMware ESXi,
vCloud Air, Alibaba Cloud, AWS, AWS GovCloud, Azure, Google Cloud Plaorm, KVM, Hyper-V,
or OCI) and mode (Legacy, Panorama, or Log Collector mode): see Panorama Models for details.
To expand the log storage capacity on the Panorama virtual appliance, you must add addional
logging disks. Expanding the log storage capacity of an exisng logging disk is not supported,
and Panorama does not recognize the addional storage capacity. For example; if you added a
2TB logging disk, and then expanded that exisng logging disk to 4TB, Panorama connues to
recognize the logging disk as having 2TB of storage capacity and ignores the addional 2TB of
storage capacity.
For addional log storage, you can also forward ﬁrewall logs to Dedicated Log Collectors
(see Conﬁgure a Managed Collector) or Conﬁgure Log Forwarding from Panorama to
External Desnaons.
Before expanding log storage capacity on Panorama, Determine Panorama Log Storage
Requirements.
• Preserve Exisng Logs When Adding Storage on Panorama Virtual Appliance in Legacy Mode
• Add a Virtual Disk to Panorama on an ESXi Server
• Add a Virtual Disk to Panorama on vCloud Air
• Add a Virtual Disk to Panorama on Alibaba Cloud
• Add a Virtual Disk to Panorama on AWS
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• Add a Virtual Disk to Panorama on Azure
• Add a Virtual Disk to Panorama on Google Cloud Plaorm
• Add a Virtual Disk to Panorama on KVM
• Add a Virtual Disk to Panorama on Hyper-V
• Add a Virtual Disk to Panorama on Oracle Cloud Infrastructure (OCI)
• Mount the Panorama ESXi Server to an NFS Datastore

Preserve Exisng Logs When Adding Storage on Panorama Virtual Appliance in Legacy
Mode
The Panorama virtual appliance in Legacy mode can use only one virtual disk for logging.
Therefore, if you add a virtual disk that is dedicated for logging, Panorama stops using the default
11GB log storage on the system disk and automacally copies any exisng logs to the new logging
disk. (Panorama connues using the system disk for data other than logs.)
If you replace an exisng dedicated logging disk of up to 2TB storage capacity with a disk of up to
8TB, you will lose the logs on the exisng disk. To preserve the logs, your choices are:
Conﬁgure log forwarding to external desnaons before you replace the virtual disk.
Set up a new Panorama virtual appliance for the new 8TB disk and maintain access to the
Panorama containing the old disk for as long as you need the logs. To forward ﬁrewall logs to
the new Panorama virtual appliance, one opon is to reconﬁgure the ﬁrewalls to connect with
the new Panorama IP address (select Device > Setup > Management and edit the Panorama
Sengs), add the ﬁrewalls as managed devices to the new Panorama, and Conﬁgure Log
Forwarding to Panorama. To reuse the old Panorama IP address on the new Panorama, another
opon is to export the conﬁguraon of the old Panorama and then import and load the
conﬁguraon on the new Panorama.
Copy logs from the old disk to the new disk. Copying can take several hours, depending on
how many logs the disk currently stores, and Panorama cannot collect logs during the process.
Contact Palo Alto Networks Customer Support for instrucons.

Add a Virtual Disk to Panorama on an ESXi Server
To expand log storage capacity on the Panorama virtual appliance, you can add virtual logging
disks. If the appliance is in Panorama mode, you can add 1 to 12 virtual logging disks of 2TB each
or 1 24TB logging disk, for a maximum total of 24TB. If the appliance is in Legacy mode, you can
add one virtual logging disk of up to 8TB on ESXi 5.5 and later versions or one disk of up to 2TB
on earlier ESXi versions. Addionally, it is recommended to add logging disks with the same disk
provisioning format to avoid any unexpected performance that may arise from having mulple
disk with diﬀerent provisioning formats.
If Panorama loses connecvity to the new virtual disk, Panorama might lose logs during
the failure interval.
To allow for redundancy, use the virtual disk in a RAID conﬁguraon. RAID10 provides the
best write performance for applicaons with high logging characteriscs.
If necessary, you can Replace the Virtual Disk on an ESXi Server.
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STEP 1 | Add addional disks to Panorama
In all modes, the ﬁrst logging disk on the Panorama VM must be at least 2TB in order
to add addional disks. If the ﬁrst logging disk is smaller than 2TB, you will be unable
to add addional disk space.
1. Access the VMware vSphere Client and select Virtual Machines.
2. Right-click the Panorama virtual appliance and select Power > Power oﬀ.
3. Right-click the Panorama virtual appliance and select Edit Sengs.
4. Click Add in the Hardware tab to launch the Add Hardware wizard.
5. Select Hard Disk as the hardware type and click Next.
6. Create a new virtual disk and click Next.
7. Set the Disk Size. If the Panorama virtual appliance is in Panorama mode, set the size to
at least 2TB. If the appliance is in Legacy mode, you can set the size to as much as 8TB.
In Panorama mode, you can add disk sizes larger than 2TB and Panorama will
automacally create as many 2TB parons as possible. For example, if disk sdc
was 24TB, it will create 12 2TB parons. These disks will be named sdc1-12.
8. Select the Disk Provisioning format and click Next.
9. Specify a datastore or datastore structure, Browse to a datastore with enough space for
the speciﬁed Disk Size, click OK, and click Next.
10. Select a SCSI Virtual Device Node (you can use the default selecon) and click Next.
The selected node must be in SCSI format; Panorama will fail to boot if you
select another format.
11. Verify that the sengs are correct and then click Finish and OK.
The new disk appears in the list of devices for the virtual appliance.
12. Repeat Step 4 through Step 11 to add addional disks to the Panorama virtual appliance
if necessary.
13. Right click the Panorama virtual appliance and select Power > Power On. The virtual disk
inializes for ﬁrst-me use. The size of the new disk determines how long inializaon
takes.
STEP 2 | Conﬁgure each disk.
The following example uses the sdc virtual disk.
1. Log in to the Panorama CLI.
2. Enter the following command to view the disks on the Panorama virtual appliance:
show system disk details
The user will see the following response:
Name
: sdb
State : Present
Size : 2048000 MB
Panorama Administrator's Guide Version Version 10.1

134

©2022 Palo Alto Networks, Inc.

Set Up Panorama
Status : Available
Reason : Admin enabled
Name : sdc
State : Present
Size : 2048000 MB
Status : Available
Reason : Admin disabled
3. Enter the following command and conﬁrm the request when prompted for all disks with
the Reason : Admin disabled response:
request system disk add sdc
The request system disk add command is not available on a Panorama
management server in Management Only mode because logging is not supported
in this mode. If you do not see the command, Set up a Panorama Virtual
Appliance in Panorama Mode to enable the logging disks. Once in Panorama
mode, Log in to the Panorama CLI and connue to Step 4 to verify the disk
addion.
4. Enter the show system disk details command to verify the status of the disk
addion. Connue to Step 3 when all newly added disk responses display Reason :
Admin enabled.
STEP 3 | Make disks available for logging.
1. Log in to the Panorama web interface.
2. Select Panorama > Managed Collectors and edit the Log Collector.
3. Select Disks and Add each newly added disk.
4. Click OK.
5. Select Commit > Commit to Panorama.
For Panorama in an Acve/Passive high availability (HA) conﬁguraon, wait for
HA sync to complete before connuing.
6. Select Commit > Push to Devices and push the changes to the Collector Group the Log
Collector belongs to.
STEP 4 | Conﬁgure Panorama to receive logs.
This step is intended for new Panorama deployments in Panorama mode. If you are adding
logging disks to an exisng Panorama virtual appliance, connue to Step 5.
1. Conﬁgure a Managed Collector.
2. Conﬁgure a Collector Group.
3. Conﬁgure Log Forwarding to Panorama.
STEP 5 | Verify that the Panorama Log Storage capacity has been increased.
1. Log in to the Panorama web interface.
2. Select Panorama > Collector Groups and select the Collector Group that the Panorama
virtual appliance belongs to.
3. Verify that the Log Storage capacity accurately displays the disk capacity.
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Add a Virtual Disk to Panorama on vCloud Air
You can add virtual logging disks to expand log storage capacity on the Panorama™ virtual
appliance. If the appliance is in Panorama mode, you can add 1 to 12 virtual logging disks of 2TB
each or 1 24TB logging disk, for a maximum total of 24TB. If the appliance is in Legacy mode, you
can add one virtual logging disk of up to 8TB.
If Panorama loses connecvity to the new virtual disk, Panorama might lose logs for the
duraon of the failure.
If necessary, you can Replace the Virtual Disk on vCloud Air.
STEP 1 | Add addional disks to Panorama.
In all modes, the ﬁrst logging disk on the Panorama VM must be at least 2TB to add
addional disks. If the ﬁrst logging disk is less than 2TB, you will be unable to add
addional disk space.
1. Access the vCloud Air web console and select your Virtual Private Cloud On Demand
region.
2. Select the Panorama virtual appliance in the Virtual Machines tab.
3. Add another disk (Acons > Edit Resources).
4. Set the Storage size. If the Panorama virtual appliance is in Panorama mode, set the size
to at least 2TB. If the appliance is in Legacy mode, you can set the size to as much as
8TB.
In Panorama mode, you can add disk sizes larger than 2TB and Panorama will
automacally create as many 2TB parons as possible. For example, if disk sdc
was 24TB, Panorama will create 12 2TB parons. These disks will be named
sdc1 through sdc12.
5. Set the storage er to Standard or SSD-Accelerated.
6. Repeat the previous steps to add addional disks to the Panorama virtual appliance as
needed.
7. Save your changes.
STEP 2 | Conﬁgure each disk.
The following example uses the sdc virtual disk.
1. Log in to the Panorama CLI.
2. Enter the following command to view the disks on the Panorama virtual appliance:
show system disk details
The user will see the following response:
Name
: sdb
State : Present
Size : 2048000 MB
Status : Available
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Reason : Admin enabled
Name : sdc
State : Present
Size : 2048000 MB
Status : Available
Reason : Admin disabled
3. Enter the following command and conﬁrm the request when prompted for all disks with
the Reason : Admin disabled response:
request system disk add sdc
The request system disk add command is not available on a Panorama
management server in Management Only mode because logging is not supported
in this mode. If you do not see the command, Set up a Panorama Virtual
Appliance in Panorama Mode to enable the logging disks. Once in Panorama
mode, Log in to the Panorama CLI and connue to Step 4 to verify the disk
addion.
4. Enter the show system disk details command to verify the status of the disk
addion. Connue to the next step when all newly added disk responses display
Reason : Admin enabled.
STEP 3 | Make disks available for logging.
1. Log in to the Panorama web interface.
2. Select Panorama > Managed Collectors and edit the Log Collector.
3. Select Disks and Add each new disk.
4. Click OK.
5. Select Commit > Commit to Panorama.
For Panorama in an Acve/Passive high availability (HA) conﬁguraon, wait for
HA sync to complete before connuing.
6. Select Commit > Push to Devices and push the changes to the Collector Group the Log
Collector belongs to.
STEP 4 | Conﬁgure Panorama to receive logs.
This step is intended for new Panorama deployments in Panorama mode. If you are adding
logging disks to an exisng virtual Panorama appliance, connue to the next step.
1. Conﬁgure a Managed Collector.
2. Conﬁgure a Collector Group.
3. Conﬁgure Log Forwarding to Panorama.
STEP 5 | Verify that the Panorama Log Storage capacity has been increased.
1. Log in to the Panorama web interface.
2. Select Panorama > Collector Groups and select the Collector Group to which the virtual
Panorama appliance belongs.
3. Verify that the Log Storage capacity accurately displays your new disk capacity.
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Add a Virtual Disk to Panorama on Alibaba Cloud
Aer you Install Panorama on Alibaba Cloud, add addional virtual logging disks to expand log
storage capacity on the Panorama™ virtual appliance for logs generated by managed ﬁrewalls. You
can add virtual disks to a local Log Collector for a Panorama virtual appliance in Panorama mode
or for a Dedicated Log Collector. To add virtual disks, you must have access to the Alibaba Cloud
Console, the Panorama command-line interface (CLI), and the Panorama web interface.
The Panorama virtual appliance on Alibaba Cloud supports only 2TB logging disks and, in total,
supports up to 24TB of log storage. You cannot add a logging disk smaller than 2TB or a logging
disk of a size that is not evenly divisible by 2TB because the Panorama virtual appliance parons
logging disks in to 2TB parons. For example, if you aach a 4TB logging disk, Panorama will
create two 2TB parons. However, you cannot add a 5TB logging disk because the leover 1TB
is not supported as a paron.
STEP 1 | Log in to the Alibaba Cloud Console.
STEP 2 | Select Elasc Compute Service > Instances & Images > Instances and navigate to the
Panorama virtual appliance instance.
STEP 3 | Add a virtual logging disk to Panorama.
In all modes, the ﬁrst logging disk on the Panorama VM must be at least 2TB in order
to add addional disks. If the ﬁrst logging disk is smaller than 2TB, you will be unable
to add addional disk space.
1. In the Acons column, select Manage.
2. Select Cloud Disk and Create Disk.
3. Conﬁgure the virtual logging disk.
• Aach—Select Aach to ECS Instance.
• ECS Instance—Select the region and the Panorama virtual appliance instance.
• Storage—Select type of virtual disk and enter the disk capacity.
• (Oponal) Quanty—Specify how many virtual disks to create. By default, 1 virtual
disk is created. When creang mulple logging disks, be sure that the sum of all
virtual disks does not exceed 24TB.
• Terms of Service—Review the Alibaba Cloud Terms of Service and check aer you
have reviewed.
4. Preview the virtual disk creaon.
5. Create the new virtual disk.
A status window displays aer you create the new virtual disk. Aer the virtual disk is
successfully created, Go to the Disk List to conﬁrm the disk is successfully created.
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STEP 4 | Conﬁgure each disk.
The following example uses the sdc virtual disk.
1. Log in to the Panorama CLI.
2. Enter the following command to view the disks on the Panorama virtual appliance:
show system disk details
The user will see the following response:
Name : sdb
State : Present
Size : 2048000 MB
Status : Available
Reason : Admin disabled
3. Enter the following command and conﬁrm the request when prompted for all disks with
the Reason : Admin disabled response:
request system disk add sdc
The request system disk add command is not available on a Panorama
management server in Management Only mode because logging is not supported
in this mode. If you do not see the command, Set up a Panorama Virtual
Appliance in Panorama Mode to enable the logging disks. Once in Panorama
mode, log in to the Panorama CLI and connue to the next step to verify the
disk addion.
4. Enter the show system disk details command to verify the status of the disk
addion. Connue to the next step when all newly added disk responses display
Reason : Admin enabled.
STEP 5 | Make disks available for logging.
1. Log in to the Panorama web interface.
2. Edit a Log Collector (Panorama > Managed Collectors).
3. Select Disks and Add each newly added disk.
4. Click OK.
5. Select Commit > Commit to Panorama.
For Panorama in an Acve/Passive high availability (HA) conﬁguraon, wait for
HA sync to complete before connuing.
6. Select Commit > Push to Devices and push the changes to the Collector Group the Log
Collector belongs to.
STEP 6 | (New Panorama deployments in Panorama mode only) Conﬁgure Panorama to receive logs.
If you are adding logging disks to an exisng Panorama virtual appliance, skip to step 6.
1. Conﬁgure a Collector Group.
2. Conﬁgure Log Forwarding to Panorama.
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STEP 7 | Verify that the Panorama Log Storage capacity is increased.
1. Log in to the Panorama web interface.
2. Select the Collector Group to which the Panorama virtual appliance belongs (Panorama >
Collector Groups).
3. Verify that the Log Storage capacity accurately displays the disk capacity.

Add a Virtual Disk to Panorama on AWS
Aer you Install Panorama on AWS or Install Panorama on AWS GovCloud, add virtual logging
disks to the Panorama™ virtual appliance instance to provide storage for logs generated by
managed ﬁrewalls. You can add virtual disks to a local log Collector for a Panorama virtual
appliance in Panorama mode or for a Dedicated Log Collector. To add virtual disks, you must have
access to the Amazon Web Service Console, the Panorama command-line interface (CLI), and the
Panorama web interface.
The Panorama virtual appliance on AWS supports only 2TB logging disks and, in total, supports up
to 24TB of log storage. You cannot add a logging disk smaller than 2TB or a logging disk of a size
that is not evenly divisible by 2TB because the Panorama virtual appliance parons logging disks
in to 2TB parons. For example, if you aach a 4TB logging disk, Panorama will create two 2TB
parons. However, you cannot add a 5TB logging disk because the leover 1TB is not supported
as a paron.
STEP 1 | Log in to AWS Web Service console and select the EC2 Dashboard.
• Amazon Web Service Console
• AWS GovCloud Web Service Console

Panorama Administrator's Guide Version Version 10.1

140

©2022 Palo Alto Networks, Inc.

Set Up Panorama
STEP 2 | Add a virtual logging disk to Panorama.
In all modes, the ﬁrst logging disk on the Panorama VM must be at least 2TB in order
to add addional disks. If the ﬁrst logging disk is smaller than 2TB, you will be unable
to add addional disk space.
1. On the EC2 Dashboard, select Volumes and Create Volume:
• Select your preferred Volume Type. For general purpose use, select General Purpose
SSD (GP2).
• Conﬁgure the Size of the volume as 2048 GiB.
• Select the same Availability Zone that your Panorama virtual appliance instance is
located in.
• (Oponal) Encrypt the volume.
• (Oponal) Add tags to your volume.
2. Click Create Volume.

3. In the Volumes page, select the volume you, select Acons > Aach Volume.
4. Aach the Panorama virtual appliance Instance.
STEP 3 | Conﬁgure each disk.
The following example uses the sdc virtual disk.
1. Log in to the Panorama CLI.
2. Enter the following command to view the disks on the Panorama virtual appliance:
show system disk details
The user will see the following response:
Name
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: sdb
State : Present
Size : 2048000 MB
Status : Available
Reason : Admin enabled
Name : sdc
State : Present
Size : 2048000 MB
Status : Available
Reason : Admin disabled
3. Enter the following command and conﬁrm the request when prompted for all disks with
the Reason : Admin disabled response:
request system disk add sdc
The request system disk add command is not available on a Panorama
management server in Management Only mode because logging is not supported
in this mode. If you do not see the command, Set up a Panorama Virtual
Appliance in Panorama Mode to enable the logging disks. Once in Panorama
mode, Log in to the Panorama CLI and connue to Step 4 to verify the disk
addion.
4. Enter the show system disk details command to verify the status of the disk
addion. Connue to the next step when all newly added disk responses display
Reason : Admin enabled.
STEP 4 | Make disks available for logging.
1. Log in to the Panorama web interface.
2. Edit a Log Collector (Panorama > Managed Collectors).
3. Select Disks and Add each newly added disk.
4. Click OK.
5. Select Commit > Commit to Panorama.
For Panorama in an Acve/Passive high availability (HA) conﬁguraon, wait for
HA sync to complete before connuing.
6. Select Commit > Push to Devices and push the changes to the Collector Group the Log
Collector belongs to.
STEP 5 | (New Panorama deployments in Panorama mode only) Conﬁgure Panorama to receive logs.
If you are adding logging disks to an exisng Panorama virtual appliance, skip to step 6.
1. Conﬁgure a Collector Group.
2. Conﬁgure Log Forwarding to Panorama.
STEP 6 | Verify that the Panorama Log Storage capacity is increased.
1. Log in to the Panorama web interface.
2. Select the Collector Group to which the Panorama virtual appliance belongs (Panorama >
Collector Groups).
3. Verify that the Log Storage capacity accurately displays the disk capacity.
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Add a Virtual Disk to Panorama on Azure
Aer you Install Panorama on Azure, add virtual logging disks to the Panorama™ virtual appliance
instance to provide storage for logs generated by managed ﬁrewalls. You can add virtual disks to
a local log Collector for a Panorama virtual appliance in Panorama mode or for a Dedicated Log
Collector. To add virtual disks, you must have access to the Microso Azure portal, the Panorama
command-line interface (CLI), and the Panorama web interface.
The Panorama virtual appliance on Azure supports only 2TB logging disks and, in total, supports
up to 24TB of log storage. You cannot add a logging disk smaller than 2TB or a logging disk of a
size that is not evenly divisible by 2TB because the Panorama virtual appliance paron logging
disks in to 2TB parons. For example, if you aach a 4TB logging disk, Panorama will create
two 2TB parons. However, you cannot add a 5TB logging disk because the leover 1TB is not
supported as a paron.
STEP 1 | Log in to the Microso Azure portal.
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STEP 2 | Add a virtual logging disk to Panorama.
In all modes, the ﬁrst logging disk on the Panorama VM must be at least 2TB in order
to add addional disks. If the ﬁrst logging disk is smaller than 2TB, you will be unable
to add addional disk space.
1. In the Azure Dashboard, select the Panorama Virtual Machines to which you want to add
a logging disk.
2. Select Disks.
3. +Add data disk.
4. In the drop-down for the new disk, Create disk.

5. Conﬁgure the logging disk.
1. Enter the disk Name.
2. Select the Resource group. If you Create new resource groups, enter the group name.
3. Verify the Account type (this ﬁeld is automacally populated).
4. In the Source type drop-down, select None.
5. Select Change Size and select a 2048 GiB logging disk.
6. Create the new logging disk.
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7. For the Host caching, select Read/write.

STEP 3 | Enable each disk.
The following example uses the sdc virtual disk.
1. Log in to the Panorama CLI.
2. Enter the following command to view the disks on the Panorama virtual appliance:
show system disk details
The user will see the following response:
Name
: sdb
State : Present
Size : 2048000 MB
Status : Available
Reason : Admin enabled
Name : sdc
State : Present
Size : 2048000 MB
Status : Available
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Reason : Admin disabled
3. Enter the following command and conﬁrm the request when prompted for all disks with
the Reason : Admin disabled response:
request system disk add sdc
The request system disk add command is not available on a Panorama
management server in Management Only mode because logging is not supported
in this mode. If you do not see the command, Set up a Panorama Virtual
Appliance in Panorama Mode to enable the logging disks. Once in Panorama
mode, Log in to the Panorama CLI and connue to Step 4 to verify the disk
addion.
4. Enter the show system disk details command to verify the status of the disk
addion. Connue to the next step when all newly added disk responses display
Reason : Admin enabled.
STEP 4 | Make disks available for logging.
1. Log in to the Panorama web interface.
2. Edit a Log Collector (Panorama > Managed Collectors)
3. Select Disks and Add each newly added disk.
4. Click OK.
5. Select Commit > Commit to Panorama.
For Panorama in an Acve/Passive high availability (HA) conﬁguraon, wait for
HA sync to complete before connuing.
6. Select Commit > Push to Devices and push the changes to the Collector Group the Log
Collector belongs to.
STEP 5 | (New Panorama deployments in Panorama mode only) Conﬁgure Panorama to receive logs.
If you are adding logging disks to an exisng Panorama virtual appliance, skip to step 6.
1. Conﬁgure a Collector Group.
2. Conﬁgure Log Forwarding to Panorama.
STEP 6 | Verify that the Panorama Log Storage capacity is increased.
1. Log in to the Panorama web interface.
2. Select the Collector Group to which the Panorama virtual appliance belongs (Panorama >
Collector Groups).
3. Verify that the Log Storage capacity accurately displays the disk capacity.

Add a Virtual Disk to Panorama on Google Cloud Plaorm
Aer you Install Panorama on Google Cloud Plaorm, add virtual logging disks to the Panorama™
virtual appliance instance to provide storage for logs generated by managed ﬁrewalls. You can
add virtual disks to a local log Collector for a Panorama virtual appliance in Panorama mode or for
a Dedicated Log Collector. The Panorama virtual appliance on Google Cloud Plaorm supports
only 2TB logging disks and, in total, supports up to 24TB of log storage. You cannot add a logging
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disk smaller than 2TB or a logging disk of a size that is not evenly divisible by 2TB because the
Panorama virtual appliance parons logging disks in to 2TB parons. For example, if you aach
a 4TB logging disk, Panorama will create two 2TB parons. However, you cannot add a 5TB
logging disk because the leover 1TB is not supported as a paron.
STEP 1 | Log in to the Google Cloud Console.
STEP 2 | Add the virtual logging disk.
In all modes, the ﬁrst logging disk on the Panorama VM must be at least 2TB in order
to add addional disks. If the ﬁrst logging disk is smaller than 2TB, you will be unable
to add addional disk space.
1. In the Products & Services menu, select and then Edit the Panorama virtual appliance
instance (Compute Engine > VM Instances).
2. In the Addional Disks secon, Add Item.
3. Create disk (Name drop-down).
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STEP 3 | Conﬁgure the virtual logging disks.
1. Enter the Name.
2. Expand the Disk Type drop-down menu and select the desired type.
3. For the Source type, select None (blank disk).
4. Set the Size (GB) of the virtual logging disk.
5. Click Create.

6. Save the changes to update the Panorama virtual appliance instance.
STEP 4 | Conﬁgure each disk.
The following example uses the sdc virtual disk.
1. Log in to the Panorama CLI.
2. Enter the following command to view the disks on the Panorama virtual appliance:
show system disk details
The user will see the following response:
Name
: sdb
State : Present
Size : 2048000 MB
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Status : Available
Reason : Admin enabled
Name : sdc
State : Present
Size : 2048000 MB
Status : Available
Reason : Admin disabled
3. Enter the following command and conﬁrm the request when prompted for all disks with
the Reason : Admin disabled response:
request system disk add sdc
The request system disk add command is not available on a Panorama
management server in Management Only mode because logging is not supported
in this mode. If you do not see the command, Set up a Panorama Virtual
Appliance in Panorama Mode to enable the logging disks. Once in Panorama
mode, Log in to the Panorama CLI and connue to Step 4 to verify the disk
addion.
4. Enter the show system disk details command to verify the status of the disk
addion. Connue to the next step when all newly added disk responses display
Reason : Admin enabled.
STEP 5 | Make disks available for logging.
1. Log in to the Panorama web interface.
2. Edit a Log Collector (Panorama > Managed Collectors).
3. Select Disks and Add each newly added disk.
4. Click OK.
5. Select Commit > Commit to Panorama.
For Panorama in an Acve/Passive high availability (HA) conﬁguraon, wait for
HA sync to complete before connuing.
6. Select Commit > Push to Devices and push the changes to the Collector Group the Log
Collector belongs to.
STEP 6 | (New Panorama deployments in Panorama mode only) Conﬁgure Panorama to receive logs.
If you are adding logging disks to an exisng Panorama virtual appliance, skip to step 7.
1. Conﬁgure a Collector Group.
2. Conﬁgure Log Forwarding to Panorama.
STEP 7 | Verify that the Panorama Log Storage capacity is increased.
1. Log in to the Panorama web interface.
2. Select the Collector Group to which the Panorama virtual appliance belongs (Panorama >
Collector Groups).
3. Verify that the Log Storage capacity accurately displays the disk capacity.
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Add a Virtual Disk to Panorama on KVM
Aer you Install Panorama on KVM, add virtual logging disks to the Panorama™ virtual appliance
instance to provide storage for logs generated by managed ﬁrewalls. You can add virtual disks to
a local log Collector for a Panorama virtual appliance in Panorama mode or for a Dedicated Log
Collector. The Panorama virtual appliance on KVM supports only 2TB logging disks and, in total,
supports up to 24TB of log storage. You cannot add a logging disk smaller than 2TB or a logging
disk of a size that is not evenly divisible by 2TB because the Panorama virtual appliance parons
logging disks in to 2TB parons. For example, if you aach a 4TB logging disk, Panorama will
create two 2TB parons. However, you cannot add a 5TB logging disk because the leover 1TB
is not supported as a paron.
STEP 1 | Shutdown the Panorama virtual appliance instance on the Virtual Machine Manager.
STEP 2 | Double-click the Panorama virtual appliance instance in the Virtual Machine Manager and
Show virtual hardware details .
STEP 3 | Add the virtual logging disk. Repeat this step as many mes as needed.
In all modes, the ﬁrst logging disk on the Panorama VM must be at least 2TB in order
to add addional disks. If the ﬁrst logging disk is smaller than 2TB, you will be unable
to add addional disk space.
1. Create a disk image for a virtual image (Add Hardware > Storage) and conﬁgure the
virtual disk storage capacity to the appropriate 2TB value:2000GB or 14901.2GiB
depending on your Virtual Machine Manager.
Depending on the version, some Virtual Machine Managers use GiB (gibibyte)
to allocate memory. Be sure you correctly convert the required storage capacity
to avoid under provisioning the virtual logging disk and sending the Panorama
virtual appliance into maintenance mode.
2. In the Device type drop-down, select Disk device.
3. In the Bus type drop-down, select VirtIO or IDE based on your conﬁguraon.
4. Expand Advanced opons and, in the Cache mode drop-down, select writethrough.
5. Click Finish.

STEP 4 | Power on the Panorama virtual appliance instance.
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STEP 5 | Conﬁgure each disk.
The following example uses the sdc virtual disk.
1. Log in to the Panorama CLI.
2. Enter the following command to view the disks on the Panorama virtual appliance:
show system disk details
The user will see the following response:
Name
: sdb
State : Present
Size : 2048000 MB
Status : Available
Reason : Admin enabled
Name : sdc
State : Present
Size : 2048000 MB
Status : Available
Reason : Admin disabled
3. Enter the following command and conﬁrm the request when prompted for all disks with
the Reason : Admin disabled response:
request system disk add sdc
The request system disk add command is not available on a Panorama
management server in Management Only mode because logging is not supported
in this mode. If you do not see the command, Set up a Panorama Virtual
Appliance in Panorama Mode to enable the logging disks. Once in Panorama
mode, Log in to the Panorama CLI and connue to Step 4 to verify the disk
addion.
4. Enter the show system disk details command to verify the status of the disk
addion. Connue to the next step when all newly added disk responses display
Reason : Admin enabled.
STEP 6 | Make disks available for logging.
1. Log in to the Panorama web interface.
2. Edit a Log Collector (Panorama > Managed Collectors).
3. Select Disks and Add each newly added disk.
4. Click OK.
5. Select Commit > Commit to Panorama.
For Panorama in an Acve/Passive high availability (HA) conﬁguraon, wait for
HA sync to complete before connuing.
6. Select Commit > Push to Devices and push the changes to the Collector Group the Log
Collector belongs to.
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STEP 7 | (New Panorama deployments in Panorama mode only) Conﬁgure Panorama to receive logs.
If you are adding logging disks to an exisng Panorama virtual appliance, skip to step 8.
1. Conﬁgure a Collector Group.
2. Conﬁgure Log Forwarding to Panorama.
STEP 8 | Verify that the Panorama Log Storage capacity is increased.
1. Log in to the Panorama web interface.
2. Select the Collector Group to which the Panorama virtual appliance belongs (Panorama >
Collector Groups).
3. Verify that the Log Storage capacity accurately displays the disk capacity.

Add a Virtual Disk to Panorama on Hyper-V
Aer you Install Panorama on Hyper-V, add virtual logging disks to the Panorama™ virtual
appliance instance to provide storage for logs generated by managed ﬁrewalls. You can add
virtual disks to a local log Collector for a Panorama virtual appliance in Panorama mode or for a
Dedicated Log Collector. The Panorama virtual appliance on Hyper-V supports only 2TB logging
disks and, in total, supports up to 24TB of log storage. You cannot add a logging disk smaller
than 2TB or a logging disk of a size that is not evenly divisible by 2TB because the Panorama
virtual appliance parons logging disks in to 2TB parons. For example, if you aach a 4TB
logging disk, Panorama will create two 2TB parons. However, you cannot add a 5TB logging
disk because the leover 1TB is not supported as a paron.
STEP 1 | Power oﬀ the Panorama virtual appliance.
1. On the Hyper-V Manager, select the Panorama virtual appliance instance from the list of
Virtual Machines.
2. Select Acon > Turn Oﬀ to power oﬀ the Panorama virtual appliance.
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STEP 2 | Add the virtual logging disk. Repeat this step as many mes as needed.
In all modes, the ﬁrst logging disk on the Panorama VM must be at least 2TB in order
to add addional disks. If the ﬁrst logging disk is smaller than 2TB, you will be unable
to add addional disk space.
1. Select the Panorama virtual appliance from the list of Virtual Machines, and select
Acon > Sengs.
2. In the Hardware list, select IDE Controller 0.
3. From the IDE Controller drives list, select Hard Drive and Add the new virtual logging
disk.

4. Select the new Hard Drive created under IDE Controller 0.
5. Under Media, add a New hard disk.
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STEP 3 | Conﬁgure the new virtual logging disk.
1. If you see the Before You Begin prompt, click Next to begin adding the virtual logging
disk
2. For the Disk Format, select VHDX. Click Next to connue
3. For the Disk Type, select Fixed Size or Dynamically Expanding based on your needs.
Click Next to connue.
4. Specify the Name and Locaon for the virtual logging disk ﬁle. Click Next to connue.
5. To conﬁgure the disk, select Create a new virtual hard disk and enter the disk size. Click
Next to connue.
6. Review the Summary and Finish adding the virtual hard logging disk.
7. Apply the new hard disk addion.

STEP 4 | Power on the Panorama virtual appliance.
1. Select the Panorama virtual appliance instance from the list of Virtual Machines.
2. Select Acon > Start to power on the Panorama virtual appliance.
STEP 5 | Conﬁgure each disk.
The following example uses the sdc virtual disk.
1. Log in to the Panorama CLI.
2. Enter the following command to view the disks on the Panorama virtual appliance:
show system disk details
The user will see the following response:
Name
: sdb
State : Present
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Size : 2048000 MB
Status : Available
Reason : Admin enabled
Name : sdc
State : Present
Size : 2048000 MB
Status : Available
Reason : Admin disabled
3. Enter the following command and conﬁrm the request when prompted for all disks with
the Reason : Admin disabled response:
request system disk add sdc
The request system disk add command is not available on a Panorama
management server in Management Only mode because logging is not supported
in this mode. If you do not see the command, Set up a Panorama Virtual
Appliance in Panorama Mode to enable the logging disks. Once in Panorama
mode, Log in to the Panorama CLI and connue to Step 4 to verify the disk
addion.
4. Enter the show system disk details command to verify the status of the disk
addion. Connue to the next step when all newly added disk responses display
Reason : Admin enabled.
STEP 6 | Make disks available for logging.
1. Log in to the Panorama web interface.
2. Edit a Log Collector (Panorama > Managed Collectors).
3. Select Disks and Add each newly added disk.
4. Click OK.
5. Select Commit > Commit to Panorama.
For Panorama in an Acve/Passive high availability (HA) conﬁguraon, wait for
HA sync to complete before connuing.
6. Select Commit > Push to Devices and push the changes to the Collector Group the Log
Collector belongs to.
STEP 7 | (New Panorama deployments in Panorama mode only) Conﬁgure Panorama to receive logs.
If you are adding logging disks to an exisng Panorama virtual appliance, skip to Step 8.
1. Conﬁgure a Collector Group.
2. Conﬁgure Log Forwarding to Panorama.
STEP 8 | Verify that the Panorama Log Storage capacity is increased.
1. Log in to the Panorama web interface.
2. Select the Collector Group to which the Panorama virtual appliance belongs (Panorama >
Collector Groups).
3. Verify that the Log Storage capacity accurately displays the disk capacity.
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Add a Virtual Disk to Panorama on Oracle Cloud Infrastructure (OCI)
Aer you Install Panorama on Oracle Cloud Infrastructure (OCI), add addional virtual logging
disks to expand log storage capacity on the Panorama™ virtual appliance for logs generated
by managed ﬁrewalls. You can add virtual disks to a local Log Collector for a Panorama virtual
appliance in Panorama mode or for a Dedicated Log Collector. To add virtual disks, you must have
access to the OCI console, the Panorama command-line interface (CLI), and the Panorama web
interface.
The Panorama virtual appliance on OCI supports only 2TB logging disks and, in total, supports up
to 24TB of log storage. You cannot add a logging disk smaller than 2TB or a logging disk of a size
that is not evenly divisible by 2TB because the Panorama virtual appliance parons logging disks
in to 2TB parons. For example, if you aach a 4TB logging disk, Panorama will create two 2TB
parons. However, you cannot add a 5TB logging disk because the leover 1TB is not supported
as a paron.
STEP 1 | Log in to the Oracle Cloud Infrastructure console.
STEP 2 | Create a 2TB block volume.
1. Select Block Storage > Block Volumes and Create Block Volume.
2. Enter a descripve Name for the volume.
3. Select the same Availability Domain as the Panorama virtual appliance instance.
4. Select the Custom volume size.
5. For the Volume Size, enter 2000.
6. Create Block Volume.
STEP 3 | Aach a virtual logging disk to the Panorama virtual appliance instance.
In all modes, the ﬁrst logging disk on the Panorama VM must be at least 2TB in order
to add addional disks. If the ﬁrst logging disk is smaller than 2TB, you will be unable
to add addional disk space.
1. Select Compute > Instances and click the name of the Panorama virtual appliance
instance.
2. Under resources, select Aached Block Volumes and Aach Block Volume.
3. For the Volume, Select volume and select the virtual logging disk.
4. For the Access, select Read/Write.
5. Aach the virtual logging disk.
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STEP 4 | Conﬁgure each disk.
The following example uses the sdc virtual disk.
1. Log in to the Panorama CLI.
2. Enter the following command to view the disks on the Panorama virtual appliance:
show system disk details
The user will see the following response:
Name : sdb
State : Present
Size : 2048000 MB
Status : Available
Reason : Admin disabled
3. Enter the following command and conﬁrm the request when prompted for all disks with
the Reason : Admin disabled response:
request system disk add sdc
The request system disk add command is not available on a Panorama
management server in Management Only mode because logging is not supported
in this mode. If you do not see the command, Set up a Panorama Virtual
Appliance in Panorama Mode to enable the logging disks. Once in Panorama
mode, Log in to the Panorama CLI and connue to the next step to verify the
disk addion.
4. Enter the show system disk details command to verify the status of the disk
addion. Connue to the next step when all newly added disk responses display
Reason : Admin enabled.
STEP 5 | Make disks available for logging.
1. Log in to the Panorama web interface.
2. Edit a Log Collector (Panorama > Managed Collectors).
3. Select Disks and Add each newly added disk.
4. Click OK.
5. Select Commit > Commit to Panorama.
For Panorama in an Acve/Passive high availability (HA) conﬁguraon, wait for
HA sync to complete before connuing.
6. Select Commit > Push to Devices and push the changes to the Collector Group the Log
Collector belongs to.
STEP 6 | (New Panorama deployments in Panorama mode only) Conﬁgure Panorama to receive logs.
If you are adding logging disks to an exisng Panorama virtual appliance, skip to step 6.
1. Conﬁgure a Collector Group.
2. Conﬁgure Log Forwarding to Panorama.
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STEP 7 | Verify that the Panorama Log Storage capacity is increased.
1. Log in to the Panorama web interface.
2. Select the Collector Group to which the Panorama virtual appliance belongs (Panorama >
Collector Groups).
3. Verify that the Log Storage capacity accurately displays the disk capacity.

Mount the Panorama ESXi Server to an NFS Datastore
When the Panorama virtual appliance in Legacy mode runs on an ESXi server, mounng to a
Network File System (NFS) datastore enables logging to a centralized locaon and expanding
the log storage capacity beyond what a virtual disk supports. (ESXi 5.5 and later versions can
support a virtual disk of up to 8TB. Earlier ESXi versions support a virtual disk of up to 2TB.)
Before seng up an NFS datastore in a Panorama high availability (HA) conﬁguraon, see Logging
Consideraons in Panorama HA.
The Panorama virtual appliance in Panorama mode does not support NFS.
STEP 1 | Select Panorama > Setup > Operaons and, in the Miscellaneous secon, click Storage
Paron Setup.
STEP 2 | Set the Storage Paron type to NFS V3.
STEP 3 | Enter the IP address of the NFS Server.
STEP 4 | Enter the Log Directory path for storing the log ﬁles. For example, export/panorama.
STEP 5 | For the Protocol, select TCP or UDP, and enter the Port for accessing the NFS server.
To use NFS over TCP, the NFS server must support it. Common NFS ports are UDP/TCP
111 for RPC and UDP/TCP 2049 for NFS.
STEP 6 | For opmal NFS performance, in the Read Size and Write Size ﬁelds, specify the maximum
size of the chunks of data that the client and server pass back and forth to each other.
Deﬁning a read/write size opmizes the data volume and speed in transferring data between
Panorama and the NFS datastore.
STEP 7 | (Oponal) Select Copy On Setup to copy the exisng logs stored on Panorama to the NFS
volume. If Panorama has a lot of logs, this opon might iniate the transfer of a large volume
of data.
STEP 8 | Click Test Logging Paron to verify that Panorama can access the NFS Server and Log
Directory.
STEP 9 | Click OK to save your changes.
STEP 10 | Select Commit > Commit to Panorama and Commit your changes. Unl you reboot, the
Panorama virtual appliance writes logs to the local storage disk.
STEP 11 | Select Panorama > Setup > Operaons and select Reboot Panorama in the Device
Operaons secon. Aer reboong, Panorama starts wring logs to the NFS datastore.
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Increase CPUs and Memory on the Panorama Virtual Appliance
When you Perform Inial Conﬁguraon of the Panorama Virtual Appliance, you specify
the memory and number of CPUs based on whether the appliance is in Panorama mode or
Management Only mode and based on the log storage capacity or number of managed ﬁrewalls.
If you later add storage capacity or managed ﬁrewalls, you must also increase the memory and
CPUs. A Panorama virtual appliance in Log Collector mode must meet the system requirements,
and does not need to have the CPU and memory increased beyond the minimum requirement.
Review the Setup Prerequisites for the Panorama Virtual Appliance for the CPU and memory
requirements for each Panorama mode.
• Increase CPUs and Memory for Panorama on an ESXi Server
• Increase CPUs and Memory for Panorama on vCloud Air
• Increase CPUs and Memory for Panorama on Alibaba Cloud
• Increase CPUs and Memory for Panorama on AWS
• Increase CPUs and Memory for Panorama on Azure
• Increase CPUs and Memory for Panorama on Google Cloud Plaorm
• Increase CPUs and Memory for Panorama on KVM
• Increase CPUs and Memory for Panorama on Hyper-V
• Increase the CPUs and Memory for Panorama on Oracle Cloud Infrastructure (OCI)

Increase CPUs and Memory for Panorama on an ESXi Server
For the minimum CPUs and memory that Panorama requires, see Increase CPUs and Memory on
the Panorama Virtual Appliance.
STEP 1 | Access the VMware vSphere Client and select Virtual Machines.
STEP 2 | Right-click the Panorama virtual appliance and select Power > Power Oﬀ.
STEP 3 | Right-click the Panorama virtual appliance and select Edit Sengs.
STEP 4 | Select Memory and enter the new Memory Size.
STEP 5 | Select CPUs and specify the number of CPUs (the Number of virtual sockets mulplied by
the Number of cores per socket).
STEP 6 | Click OK to save your changes.
STEP 7 | Right-click the Panorama virtual appliance and select Power > Power On.

Increase CPUs and Memory for Panorama on vCloud Air
For the minimum CPUs and memory that Panorama requires, see Increase CPUs and Memory on
the Panorama Virtual Appliance.
STEP 1 | Access the vCloud Air web console and select your Virtual Private Cloud OnDemand region.
STEP 2 | In the Virtual Machines tab, select the Panorama virtual machine and Power Oﬀ.
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STEP 3 | Select Acons > Edit Resources.
STEP 4 | Set the CPU and Memory.
STEP 5 | Save your changes.
STEP 6 | Select the Panorama virtual machine and Power On.

Increase CPUs and Memory for Panorama on Alibaba Cloud
You can change the instance type of the Panorama™ virtual appliance to increase the CPUs and
memory allocated to the Panorama virtual appliance instance. Be sure to review the supported
Alibaba Cloud instance types and the Setup Prerequisites for the Panorama Virtual Appliance
before changing the instance type.
STEP 1 | Log in to the Alibaba Cloud Console.
STEP 2 | Select Elasc Compute Service > Instances & Images > Instances and navigate to the
Panorama virtual appliance instance.
STEP 3 | In the Acons column, select More > Instance Status > Stop.
STEP 4 | Change the Panorama virtual appliance instance type.
1. Select the Panorama virtual appliance if not already selected.
2. In the Acons column, select Change Instance Type.
3. Select the desired instance type and Change the instance type.
4. When prompted, select Console to view your Panorama virtual appliance instance.
STEP 5 | In the Acons column for the Panorama virtual appliance instance, select More > Instance
Status > Start.
STEP 6 | Verify the increased CPU and memory.
1. Log in to the Panorama CLI.
2. View the Panorma virtual appliance system informaon.
admin> show system info
3. Verify that the num-cpus and ram-in-gb display the correct number of CPUs and
amount of memory as per the instance type you selected.

Increase CPUs and Memory for Panorama on AWS
For the minimum CPUs and memory that Panorama™ requires, see Increase CPUs and Memory on
the Panorama Virtual Appliance.
A Panorama virtual appliance in Log Collector mode does not remain in Log Collector mode
if you resize the virtual machine aer you deploy it and this can result in a loss of log data.
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STEP 1 | Log in to AWS Web Service console and select the EC2 Dashboard.
• Amazon Web Service Console
• AWS GovCloud Web Service Console
STEP 2 | On the EC2 Dashboard, select Instances and select the Panorama virtual appliance instance.
STEP 3 | Select Acons > Instance State > Stop to power oﬀ the Panorama virtual appliance instance.
STEP 4 | Select Acons > Instance Sengs > Change Instance Type to change the Panorama virtual
appliance instance type.
STEP 5 | Select the Instance Type to which you want to upgrade and Apply it.

STEP 6 | Select Acons > Instance State > Start to power on the Panorama virtual appliance instance.

Increase CPUs and Memory for Panorama on Azure
For the minimum CPUs and memory that Panorama™ requires, see Increase CPUs and Memory on
the Panorama Virtual Appliance.
A Panorama virtual appliance in Log Collector mode does not remain in Log Collector mode
if you resize the virtual machine aer you deploy it and this can result in a loss of log data.
STEP 1 | Log in to the Microso Azure portal.
STEP 2 | On the Azure Dashboard, under Virtual machines, select the Panorama virtual appliance.
STEP 3 | Select Overview and Stop the Panorama virtual appliance.
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STEP 4 | Choose the new virtual machine Size and then Select it.

STEP 5 | Select Overview and Start the Panorama virtual appliance.

Increase CPUs and Memory for Panorama on Google Cloud Plaorm
For the minimum CPUs and memory that Panorama™ requires, see Increase CPUs and Memory on
the Panorama Virtual Appliance.
A Panorama virtual appliance in Log Collector mode does not remain in Log Collector mode
if you resize the virtual machine aer you deploy it and this can result in a loss of log data.
STEP 1 | Log in to the Google Cloud Console.
STEP 2 | Stop the Panorama virtual appliance instance.
1. Select the Panorama virtual appliance instance in the Products & Services menu
(Compute Engine > VM Instances).
2. Stop the Panorama virtual appliance instance. It can take 2 to 3 minutes for the
Panorama virtual appliance to completely shut down.
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STEP 3 | Reconﬁgure the Panorama virtual appliance resources.
1. Edit the Panorama virtual appliance instance details.
2. Under Machine Type, Customize the Panorama virtual appliance CPU cores and memory.

STEP 4 | Save the changes to update the Panorama virtual appliance instance.
STEP 5 | Start the Panorama virtual appliance.

Increase CPUs and Memory for Panorama on KVM
For the minimum CPUs and memory that Panorama™ requires, see Increase CPUs and Memory on
the Panorama Virtual Appliance.
A Panorama virtual appliance in Log Collector mode does not remain in Log Collector mode
if you resize the virtual machine aer you deploy it and this can result in a loss of log data.
STEP 1 | Shutdown the Panorama virtual appliance instance on the Virtual Machine Manager.
STEP 2 | Double-click the Panorama virtual appliance instance in the Virtual Machine Manager and
Show virtual hardware details .
STEP 3 | Edit the allocated Panorama virtual appliance CPU cores.
1. Edit the currently allocated CPUs.
2. Apply the reconﬁgured CPU core allocaon.
STEP 4 | Edit the allocated Panorama virtual appliance memory.
1. Edit the currently allocated Memory.
2. Apply the reconﬁgured memory allocaon.
STEP 5 | Power on the Panorama virtual appliance instance.
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Increase CPUs and Memory for Panorama on Hyper-V
For the minimum CPUs and memory that Panorama™ requires, see Increase CPUs and Memory on
the Panorama Virtual Appliance.
A Panorama virtual appliance in Log Collector mode does not remain in Log Collector mode
if you resize the virtual machine aer you deploy it and this can result in a loss of log data.
STEP 1 | Power oﬀ the Panorama virtual appliance.
1. On the Hyper-V Manager, select the Panorama virtual appliance instance from the list of
Virtual Machines.
2. Select Acon > Turn Oﬀ to power oﬀ the Panorama virtual appliance.

STEP 2 | On the Hyper-V Manager, select the Panorama virtual appliance instance form the list
of Virtual Machines, and select Acon > Sengs to edit the Panorama virtual appliance
resources.
STEP 3 | Edit the allocated Panorama virtual appliance memory.
1. In the Hardware list, select Memory.
2. Edit the currently allocated Startup RAM.
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STEP 4 | Edit the allocated Panorama virtual appliance CPU cores.
1. In the Hardware list, select Processor.
2. Edit the currently allocated Number of virtual processors.

STEP 5 | Apply the reallocated memory and CPU cores.
STEP 6 | Power on the Panorama virtual appliance.
1. Select the Panorama virtual appliance instance from the list of Virtual Machines.
2. Select Acon > Start to power on the Panorama virtual appliance.

Increase the CPUs and Memory for Panorama on Oracle Cloud Infrastructure (OCI)
You can change the instance type of the Panorama™ virtual appliance to increase the CPUs
and memory allocated to the Panorama virtual appliance instance. Be sure to review the Setup
Prerequisites for the Panorama Virtual Appliance before modifying the Panorama virtual appliance
instance CPUs and memory.
STEP 1 | Log in to the Oracle Cloud Infrastructure console.
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STEP 2 | Power oﬀ the Panorama virtual appliance instance.
1. Select Compute > Instances and click the name of the Panorama virtual appliance
instance.
2. Stop the Panorama virtual appliance instance.
STEP 3 | Increase the CPUs and memory.
1. In the instance details, select Edit > Edit Shape.
2. Increase the number of CPUs and memory allocated to the instance.
3. Save Changes.
STEP 4 | In instance details, Start the Panorama virtual appliance.
STEP 5 | Verify the increased CPU and memory.
1. Log in to the Panorama CLI.
2. View the Panorma virtual appliance system informaon.
admin> show system info
3. Verify that the num-cpus and ram-in-gb display the correct number of CPUs and
amount of memory as per the instance type you selected.

Increase the System Disk on the Panorama Virtual Appliance
Expand the system disk capacity to 224GB for the Panorama virtual appliance to support large
datasets to allow for suﬃcient disk space for things such as dynamic updates when you Manage
Large-Scale Firewall Deployments. Addionally, a 224GB system disk expands storage for
monitoring and reporng data for managed ﬁrewall health if you intended to use the Panorama
virtual appliance in Panorama mode to manage your SD-WAN deployment
• Increase the System Disk for Panorama on an ESXi Server
• Increase the System Disk for Panorama on Google Cloud Plaorm

Increase the System Disk for Panorama on an ESXi Server
Add a 224GB system disk to replace the default 81GB system disk. For the minimum resource
requirements for the Panorama virtual appliance, see Setup Prerequisites for the Panorama Virtual
Appliance.
Decreasing the Panorama virtual appliance system disk back to 81GB is not supported.
STEP 1 | (Best Pracce) Save and Export Panorama and Firewall Conﬁguraons.
Save and export your Panorama and ﬁrewall conﬁguraon to ensure you can recover Panorama
if you encounter any issues.
STEP 2 | Access the VMware vSphere Client and navigate to your Panorama virtual appliance.
STEP 3 | Right-click the Panorama virtual appliance and select Power > Power Oﬀ.
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STEP 4 | Add the new 224GB system disk.
1. Right-click the Panorama virtual appliance and Edit Sengs.
2. Select New Hard Disk as the New Device and Add the new device.
3. Conﬁgure the new hard disk with 224GB and click OK.

STEP 5 | Right-click the Panorama virtual appliance and select Power > Power On.
Panorama may take up to 30 minutes to inialize the new system disk. During this me
the Panorama web interface and CLI are unavailable.
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STEP 6 | Migrate disk data from the old system disk to the new system disk.
In this example, we are migrang to the newly added system disk labeled sdb.
1. Log in to the Panorama CLI.
2. Enter the following command to view the available system disks for migraon:
admin> request system clone-system-disk target ?
3. Migrate the disk data to the new system disk using the following command:
admin> request system clone-system-disk target sdb
Enter Y when prompted to begin the disk migraon.
To begin the migraon, Panorama reboots and takes at least 20 minutes to
complete the disk migraon. During this me the Panorama web interface and
CLI are unavailable.
4. Monitor the disk migraon from the web Console. Connue to the next step only aer
Panorama displays the following message to indicate the disk migraon is complete.

STEP 7 | Delete the old system disk.
1. Access the VMware vSphere Client and navigate to your Panorama virtual appliance.
2. Right-click the Panorama virtual appliance and select Power > Power Oﬀ.
3. Right-click the Panorama virtual appliance and Edit Sengs.
4. Delete the old 81GB system disk and click OK.
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STEP 8 | Modify the Virtual Device Node for the new system disk.
1. Expand the sengs opons for the new system disk.
2. Select SCSI(0:0) as the Virtual Device Node.
3. Click OK to save your conﬁguraon changes.

STEP 9 | Right-click the Panorama virtual appliance and select Power > Power On.
STEP 10 | Verify that you successfully migrated to the new system disk.
1. Log in to the Panorama CLI.
2. Enter the following command to view the system disk parons.
You must add the /dev/root, /dev/sda5, /dev/sda6, and /dev/sda8 parons to
conﬁrm the disk size is increased.
admin> show system disk-space
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Increase the System Disk for Panorama on Google Cloud Plaorm
Add a 224GB system disk to replace the default 81GB system disk. For the minimum resource
requirements for the Panorama virtual appliance, see Setup Prerequisites for the Panorama Virtual
Appliance.
STEP 1 | (Best Pracce) Save and Export Panorama and Firewall Conﬁguraons.
Save and export your Panorama and ﬁrewall conﬁguraon to ensure you can recover Panorama
if you encounter any issues.
STEP 2 | Log in to the Google Cloud Console.
STEP 3 | In VM Instances, Stop the Panorama VM instance.
STEP 4 | Add the new 224GB system disk.
1. Select the Panorama VM instance and select Edit.
2. In the Addional disks secon Add new disk.
3. Conﬁgure the new disk with 224GB and click OK.

STEP 5 | In VM Instances, Start the Panorama VM instance.
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STEP 6 | Migrate disk data from the old system disk to the new system disk.
In this example, we are migrang to the newly added system disk labeled sdb.
1. Log in to the Panorama CLI.
2. Enter the following command to view the available system disks for migraon:
admin> request system clone-system-disk target ?
3. Migrate the disk data to the new system disk using the following command:
admin> request system clone-system-disk target sdb
Enter Y when prompted to begin the disk migraon.
To begin the migraon, Panorama reboots and takes at least 20 minutes to
complete the disk migraon. During this me the Panorama web interface and
CLI are unavailable.
4. Monitor the disk migraon by aempng to log in to the Panorama CLI. The Panorama
management server is in maintenance mode aer the system disk migraon is completed
and will allow you to log in to the Panorama CLI while in maintenance mode.
STEP 7 | Aach the new 224GB system disk.
1. In VM Instances, Stop the Panorama VM instance.
2. Select the Panorama VM instance and select Edit.
3. In the Addional disks secon, detach the new 224GB system disk.
4. In the Boot Disk secon, detach the old 81GB system disk.
5. In the Boot Disk secon, Add item and select the new 224GB system disk.
6. Save your conﬁguraon changes.
STEP 8 | In VM Instances, Start the Panorama VM instance.
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STEP 9 | Verify that you successfully migrated to the new system disk.
1. Log in to the Panorama CLI.
2. Enter the following command to view the system disk parons.
You must add the /dev/root, /dev/sda5, /dev/sda6, and /dev/sda8 parons to
conﬁrm the disk size is increased.
admin> show system disk-space

Complete the Panorama Virtual Appliance Setup
Aer you Perform Inial Conﬁguraon of the Panorama Virtual Appliance, connue with the
following tasks for addional conﬁguraon:
• Acvate a Panorama Support License
• Acvate/Retrieve a Firewall Management License when the Panorama Virtual Appliance is
Internet-connected
• Install Content and Soware Updates for Panorama
• Access and Navigate Panorama Management Interfaces
• Set Up Administrave Access to Panorama
• Manage Firewalls

Convert Your Panorama Virtual Appliance
You can convert your evaluaon Panorama™ virtual appliance to a producon Panorama virtual
appliance to preserve its exisng conﬁguraon and begin leveraging the management plaorm.
If you are ulizing Enterprise License Agreement (ELA) licensing, you can convert an exisng
producon Panorama virtual appliance to leverage the beneﬁts of ELA licensing.
• Convert Your Evaluaon Panorama to a Producon Panorama with Local Log Collector
• Convert Your Evaluaon Panorama to a Producon Panorama without Local Log Collector
• Convert Your Evaluaon Panorama to VM-Flex Licensing with Local Log Collector
• Convert Your Evaluaon Panorama to VM-Flex Licensing without Local Log Collector
• Convert Your Producon Panorama to an ELA Panorama
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Convert Your Evaluaon Panorama to a Producon Panorama with Local Log Collector
If you have an evaluaon Panorama™ virtual appliance in Panorama mode conﬁgured with a local
Log Collector, you can convert it to a producon Panorama by migrang the conﬁguraon from
the evaluaon Panorama to the producon Panorama and modifying as needed.
Logs ingested by the Log Collector on a Panorama virtual appliance cannot be migrated.
If you need to maintain access to the logs stored on your evaluaon Panorama virtual
appliance, aer you migrate the evaluaon Panorama conﬁguraon to the producon
Panorama, keep your evaluaon Panorama powered on to access the logs locally for
the remainder of the evaluaon license lifeme. Adding the evaluaon Panorama to the
producon Panorama as a managed collector is not supported.
STEP 1 | Plan the migraon.
Upgrade the soware on the Panorama virtual appliance before you convert your evaluaon
Panorama virtual appliance to a producon Panorama virtual appliance. Review the
Compability Matrix for the minimum PAN-OS version required for your hypervisor. For
important details about soware versions, see Panorama, Log Collector, Firewall, and
WildFire Version Compability.
Schedule a maintenance window for the migraon.
STEP 2 | Set up your producon Panorama virtual appliance.
1. Set Up the Panorama Virtual Appliance.
2. Register the Panorama virtual appliance with the Palo Alto Networks Customer Support
Portal (CSP).
The Panorama serial number and authorizaon code are found in the Order Summary
email from Palo Alto Networks.
3. Install Content and Soware Updates for Panorama.
STEP 3 | Acvate the device management license on the Palo Alto Networks Custer Support Portal
(CSP) for the producon Panorama virtual appliance.
1. Log in to the Palo Alto Networks CSP.
2. Select Assets > Devices and locate your Panorama virtual appliance.
3. In the Acon column, click the pencil icon to edit the device licenses.
4. Select Acvate Auth-Code and enter the Authorizaon Code.
5. Select Agree and Submit to acvate the device management license.
STEP 4 | Export the Panorama conﬁguraon from the evaluaon Panorama virtual appliance.
1. Log in to the Panorama Web Interface.
2. Select Panorama > Setup > Operaons.
3. Click Export named Panorama conﬁguraon snapshot, select running-config.xml
and click OK. Panorama exports the conﬁguraon to your client system as an XML ﬁle.
4. Locate the running-config.xml ﬁle you exported and rename the XML ﬁle. This is
required to import the conﬁguraon as Panorama does not support imporng an XML
ﬁle with the name running-config.xml.
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STEP 5 | Load the Panorama conﬁguraon snapshot that you exported from the evaluaon Panorama
virtual appliance into the producon Panorama virtual appliance.
1. Log in to the Panorama Web Interface of the producon Panorama virtual appliance.
2. Select Panorama > Setup > Operaons.
3. Click Import named Panorama conﬁguraon snapshot, Browse to the Panorama
conﬁguraon ﬁle you exported from the Panorama virtual appliance, and click OK.
4. Click Load named Panorama conﬁguraon snapshot, select the Name of the
conﬁguraon you just imported, leave the Decrypon Key blank (empty), and click OK.
Panorama overwrites its current candidate conﬁguraon with the loaded conﬁguraon.
Panorama displays any errors that occur when loading the conﬁguraon ﬁle.
5. If errors occurred, save them to a local ﬁle. Resolve each error to ensure the migrated
conﬁguraon is valid.
STEP 6 | Modify the conﬁguraon on the producon Panorama virtual appliance.
1. Select Panorama > Setup > Management.
2. Edit the General Sengs, modify the Hostname, and click OK.
3. Edit the Management Interface Sengs to conﬁgure the management IP address and
click OK.
The most eﬃcient approach is to assign a new IP address to the evaluaon
Panorama virtual appliance and reuse its old IP address for the producon
Panorama virtual appliance. This ensures that the evaluaon Panorama virtual
appliance remains accessible and that ﬁrewalls can point to the producon
Panorama virtual appliance without you reconﬁguring the Panorama IP address
on each ﬁrewall.
4. Remove the Log Collector conﬁguraon imported from the evaluaon Panorama.
1. Select Panorama > Collector Group and Delete all conﬁgured collector groups.
2. Select Panorama > Managed Collectors and Delete all conﬁgured Log Collectors.
5. Select Commit > Commit to Panorama and Commit your changes to the Panorama
conﬁguraon.
STEP 7 | Conﬁgure your Log Collectors and collector groups.
You must add the managed collectors, collector group conﬁguraon, and log forwarding
conﬁguraons you deleted in the previous step, as well as add the local Log Collector.
1. Conﬁgure a Managed Collector.
2. Conﬁgure a Collector Group.
3. Conﬁgure Log Forwarding to Panorama.
STEP 8 | Verify that the support and device management licenses are successfully acvated.
1. Select Panorama > Licenses and Retrieve license keys from license server.
2. Verify the Device Management License displays the correct number of devices.
3. Select Panorama > Support and verify that the correct support Level and Expiry Date are
displayed.
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STEP 9 | Synchronize the producon Panorama virtual appliance with the ﬁrewalls to resume ﬁrewall
management.
Complete this step during a maintenance window to minimize network disrupon.
1. On the producon Panorama virtual appliance, select Panorama > Managed Devices and
verify that the Device State column displays Connected for the ﬁrewalls.
At this point, the Shared Policy (device groups) and Template columns display Out of sync
for the ﬁrewalls.
2. Push your changes to device groups and templates:
1. Select Commit > Push to Devices and Edit Selecons.
2. Select Device Groups, select every device group, Include Device and Network
Templates, and click OK.
3. Push your changes.
3. In the Panorama > Managed Devices page, verify that the Shared Policy and Template
columns display In sync for the ﬁrewalls.

Convert Your Evaluaon Panorama to a Producon Panorama without Local Log
Collector
Change the serial number of your evaluaon Panorama virtual appliance in Management Only
mode or in Panorama mode with no local Log Collector conﬁgured to convert it to a producon
Panorama virtual appliance.
If a local Log Collector is conﬁgured, see Convert Your Evaluaon Panorama to a Producon
Panorama with Local Log Collector.
STEP 1 | Log in to the Panorama web interface.
STEP 2 | Select Panorama > Setup > Management and edit the General Sengs.
STEP 3 | Enter the Serial Number provided by Palo Alto Networks.
The Panorama serial number and authorizaon code are obtained from the deployment proﬁle
you created in the previous step.
STEP 4 | Click OK.
STEP 5 | Select Commit and Commit to Panorama.
STEP 6 | Restart management server on the Panorama virtual appliance.
1. Log in to the Panorama CLI.
2. Restart the management server.
admin> debug software restart process management-server
All administrators are logged out of the Panorama web interface and CLI when
you restart the management server.
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STEP 7 | Verify that the support and device management licenses are successfully acvated.
1. Log in to the Panorama web interface.
2. Select Panorama > Licenses and Retrieve license keys from license server.
3. Verify the Device Management License displays the correct number of devices.
4. Select Panorama > Support and verify that the correct support Level and Expiry Date are
displayed.
STEP 8 | Synchronize the producon Panorama virtual appliance with the ﬁrewalls to resume ﬁrewall
management.
Complete this step during a maintenance window to minimize network disrupon.
1. On the producon Panorama virtual appliance, select Panorama > Managed Devices and
verify that the Device State column displays Connected for the ﬁrewalls.
At this point, the Shared Policy (device groups) and Template columns display Out of sync
for the ﬁrewalls.
2. Push your changes to device groups and templates:
1. Select Commit > Push to Devices and Edit Selecons.
2. Select Device Groups, select every device group, Include Device and Network
Templates, and click OK.
3. Push your changes.
3. In the Panorama > Managed Devices page, verify that the Shared Policy and Template
columns display In sync for the ﬁrewalls.

Convert Your Evaluaon Panorama to VM-Flex Licensing with Local Log Collector
If you have an evaluaon Panorama™ virtual appliance in Panorama mode conﬁgured with a local
Log Collector, you can convert it to a producon Panorama with VM Flex licensing by migrang
the conﬁguraon from the evaluaon Panorama to the producon Panorama and modifying as
needed.
If a local Log Collector is not conﬁgured, see Convert Your Evaluaon Panorama to VM-Flex
Licensing without Local Log Collector.
Logs ingested by the Log Collector on a Panorama virtual appliance cannot be migrated.
If you need to maintain access to the logs stored on your evaluaon Panorama virtual
appliance, aer you migrate the evaluaon Panorama conﬁguraon to the producon
Panorama, keep your evaluaon Panorama powered on to access the logs locally for
the remainder of the evaluaon license lifeme. Adding the evaluaon Panorama to the
producon Panorama as a managed collector is not supported.
STEP 1 | Plan the migraon.
Upgrade the soware on the Panorama virtual appliance before you convert your evaluaon
Panorama virtual appliance to a producon Panorama virtual appliance. Review the
Compability Matrix for the minimum PAN-OS version required for your hypervisor. For
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important details about soware versions, see Panorama, Log Collector, Firewall, and
WildFire Version Compability.
Schedule a maintenance window for the migraon.
STEP 2 | Obtain the Panorama serial number and auth code from your ﬂexible VM-Series licensing
deployment proﬁle.
1. Log in to the Palo Alto Networks Customer Support Portal (CSP).
2. Create a deployment proﬁle that enables a Panorama virtual appliance.
3. Provision Panorama to generate the a serial number for Panorama.
4. Copy the Serial Number and Auth Code.
STEP 3 | Set up your producon Panorama virtual appliance.
1. Log in to the Palo Alto Networks CSP.
2. Set Up the Panorama Virtual Appliance.
3. Register the Panorama virtual appliance with the Palo Alto Networks Customer Support
Portal (CSP).
The Panorama serial number and authorizaon code you generated in the previous step.
4. Install Content and Soware Updates for Panorama.
STEP 4 | Acvate the device management license on the Palo Alto Networks CSP for the producon
Panorama virtual appliance.
1. Select Assets > Devices and locate your Panorama virtual appliance.
2. In the Acon column, click the pencil icon to edit the device licenses.
3. Select Acvate Auth-Code and enter the Authorizaon Code.
4. Select Agree and Submit to acvate the device management license.
STEP 5 | Export the Panorama conﬁguraon from the evaluaon Panorama virtual appliance.
1. Log in to the Panorama Web Interface.
2. Select Panorama > Setup > Operaons.
3. Click Export named Panorama conﬁguraon snapshot, select running-config.xml
and click OK. Panorama exports the conﬁguraon to your client system as an XML ﬁle.
4. Locate the running-config.xml ﬁle you exported and rename the XML ﬁle. This is
required to import the conﬁguraon as Panorama does not support imporng an XML
ﬁle with the name running-config.xml.
STEP 6 | Load the Panorama conﬁguraon snapshot that you exported from the evaluaon Panorama
virtual appliance into the producon Panorama virtual appliance.
1. Log in to the Panorama Web Interface of the producon Panorama virtual appliance.
2. Select Panorama > Setup > Operaons.
3. Click Import named Panorama conﬁguraon snapshot, Browse to the Panorama
conﬁguraon ﬁle you exported from the Panorama virtual appliance, and click OK.
4. Click Load named Panorama conﬁguraon snapshot, select the Name of the
conﬁguraon you just imported, leave the Decrypon Key blank (empty), and click OK.
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Panorama overwrites its current candidate conﬁguraon with the loaded conﬁguraon.
Panorama displays any errors that occur when loading the conﬁguraon ﬁle.
5. If errors occurred, save them to a local ﬁle. Resolve each error to ensure the migrated
conﬁguraon is valid.
STEP 7 | Modify the conﬁguraon on the producon Panorama virtual appliance.
1. Select Panorama > Setup > Management.
2. Edit the General Sengs, modify the Hostname, and click OK.
3. Edit the Management Interface Sengs to conﬁgure the management IP address and
click OK.
The most eﬃcient approach is to assign a new IP address to the evaluaon
Panorama virtual appliance and reuse its old IP address for the producon
Panorama virtual appliance. This ensures that the evaluaon Panorama virtual
appliance remains accessible and that ﬁrewalls can point to the producon
Panorama virtual appliance without you reconﬁguring the Panorama IP address
on each ﬁrewall.
4. Remove the Log Collector conﬁguraon imported from the evaluaon Panorama.
1. Select Panorama > Collector Group and Delete all conﬁgured collector groups.
2. Select Panorama > Managed Collectors and Delete all conﬁgured Log Collectors.
5. Select Commit > Commit to Panorama and Commit your changes to the Panorama
conﬁguraon.
STEP 8 | Reconﬁgure your Log Collectors and collector groups.
You must add the managed collectors, collector group conﬁguraon, and log forwarding
conﬁguraons you deleted in the previous step, as well as add the local Log Collector.
1. Conﬁgure a Managed Collector.
2. Conﬁgure a Collector Group.
3. Conﬁgure Log Forwarding to Panorama.
STEP 9 | Verify that the support and device management licenses are successfully acvated.
1. Select Panorama > Licenses and Retrieve license keys from license server.
2. Verify the Device Management License displays the correct number of devices.
3. Select Panorama > Support and verify that the correct support Level and Expiry Date are
displayed.
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STEP 10 | Synchronize the producon Panorama virtual appliance with the ﬁrewalls to resume ﬁrewall
management.
Complete this step during a maintenance window to minimize network disrupon.
1. On the producon Panorama virtual appliance, select Panorama > Managed Devices and
verify that the Device State column displays Connected for the ﬁrewalls.
At this point, the Shared Policy (device groups) and Template columns display Out of sync
for the ﬁrewalls.
2. Push your changes to device groups and templates:
1. Select Commit > Push to Devices and Edit Selecons.
2. Select Device Groups, select every device group, Include Device and Network
Templates, and click OK.
3. Push your changes.
3. In the Panorama > Managed Devices page, verify that the Shared Policy and Template
columns display In sync for the ﬁrewalls.

Convert Your Evaluaon Panorama to VM-Flex Licensing without Local Log Collector
Change the serial number of your evaluaon Panorama virtual appliance in Management Only
mode or in Panorama mode with no local Log Collector conﬁgured to convert it to a producon
Panorama virtual appliance.
If a local Log Collector is conﬁgured, see Convert Your Evaluaon Panorama to VM-Flex Licensing
with Local Log Collector.
STEP 1 | Obtain the Panorama serial number and auth code from your ﬂexible VM-Series licensing
deployment proﬁle.
1. Log in to the Palo Alto Networks Customer Support Portal (CSP).
2. Create a deployment proﬁle that enables a Panorama virtual appliance.
3. Provision Panorama to generate the a serial number for Panorama.
4. Copy the Serial Number and Auth Code.
STEP 2 | Log in to the Panorama web interface.
STEP 3 | Select Panorama > Setup > Management and edit the General Sengs.
STEP 4 | Enter the Serial Number provided by Palo Alto Networks.
The Panorama serial number and authorizaon code you generated in the previous step.
STEP 5 | Click OK.
STEP 6 | Select Commit and Commit to Panorama.
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STEP 7 | Restart management server on the Panorama virtual appliance.
1. Log in to the Panorama CLI.
2. Restart the management server.
admin> debug software restart process management-server
All administrators are logged out of the Panorama web interface and CLI when
you restart the management server.
STEP 8 | Verify that the support and device management licenses are successfully acvated.
1. Log in to the Panorama web interface.
2. Select Panorama > Licenses and Retrieve license keys from license server.
3. Verify the Device Management License displays the correct number of devices.
4. Select Panorama > Support and verify that the correct support Level and Expiry Date are
displayed.
STEP 9 | Synchronize the producon Panorama virtual appliance with the ﬁrewalls to resume ﬁrewall
management.
Complete this step during a maintenance window to minimize network disrupon.
1. On the producon Panorama virtual appliance, select Panorama > Managed Devices and
verify that the Device State column displays Connected for the ﬁrewalls.
At this point, the Shared Policy (device groups) and Template columns display Out of sync
for the ﬁrewalls.
2. Push your changes to device groups and templates:
1. Select Commit > Push to Devices and Edit Selecons.
2. Select Device Groups, select every device group, Include Device and Network
Templates, and click OK.
3. Push your changes.
3. In the Panorama > Managed Devices page, verify that the Shared Policy and Template
columns display In sync for the ﬁrewalls.

Convert Your Producon Panorama to an ELA Panorama
You can convert your producon Panorama™ virtual appliance to connue leveraging your
Panorama with the beneﬁts of ELA licensing. To convert your producon deployment, Panorama
must have out-bound Internet access.
Converng your producon Panorama to ELA licensing is supported in Management Only and
Panorama mode with or without a local Log Collector conﬁgured. If your Panorama has a local Log
Collector conﬁgured, you must submit a support cket with Palo Alto Networks to convert your
Panorama to ELA licensing.
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During conversion from a producon Panorama to ELA licensing, do not change the
Panorama serial number if a local Log Collector is conﬁgured.
The log on the local Log collector become inaccessible and other Log Collectors in the
Collector Group may become inaccessible and no longer ingest logs if the serial number of
a Log Collector is changed.
STEP 1 | Covert your Panorama to ELA licensing.
• Panorama virtual appliance in Panorama mode with a local Log Collector.
Submit support cket with Palo Alto Networks to convert your Panorama to ELA licensing.
This is required in order to preserve all exisng logs on the local Log Collector when
converng a Panorama with a local Log Collector to ELA licensing. An example is provided
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below to assist in ﬁling the support cket. Create the cket exactly as displayed below, and
select the OS Release your Panorama is running.
Connue to the next step only aer Palo Alto Networks support successfully resolves your
support cket.

• Panorama virtual appliance in Management Only mode or Panorama mode with no local
Log Collector.
1. Generate a serial number from your ELA licensing pool.
1. Log in to the Palo Alto Networks CSP.
2. Select Assets > VM-Series Auth-Codes and locate your ELA licensing pool.
3. In the Acons column, select Panorama and Provision a new serial number.
Conﬁrm the new serial number provision when prompted.
4. Copy the newly provisioned serial number.
2. Log in to the Panorama web interface.
3. Select Panorama > Setup > Management and edit the General Sengs.
4. Enter the Serial Number you provisioned.
5. Click OK.
6. Select Commit and Commit to Panorama.
STEP 2 | Log in to the Panorama web interface if not already logged in.
STEP 3 | Select Panorama > Licenses and Retrieve new licenses from the license server.
STEP 4 | Verify that Panorama retrieved the new licenses as per your ELA agreement.
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STEP 5 | Verify that the support and device management licenses are successfully acvated.
1. Select Panorama > Licenses and verify that the correct licenses are acvated.
2. Select Panorama > Support and verify that the correct support Level and Expiry Date are
displayed.
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Set Up the M-Series Appliance
The M-600, M-500, and M-200 appliances are high performance hardware appliances that you
can deploy in Management Only mode (as Panorama management servers with no local log
collecon), Panorama mode (as Panorama management servers with local log collecon) or in Log
Collector mode (as Dedicated Log Collectors). The appliances provide mulple interfaces that
you can assign to various Panorama services such as ﬁrewall management and log collecon.
Before seng up the appliance, consider how you can conﬁgure the interfaces to opmize
security, enable network segmentaon (in large-scale deployments), and load balance the traﬃc
for Panorama services.
• M-Series Appliance Interfaces
• Perform Inial Conﬁguraon of the M-Series Appliance
• M-Series Setup Overview
• Set Up the M-Series Appliance as a Log Collector
• Increase Storage on the M-Series Appliance
• Conﬁgure Panorama to Use Mulple Interfaces

M-Series Appliance Interfaces
The Panorama M-600, M-500, M-200 and M-100 appliances have several interfaces for
communicang with other systems such as managed ﬁrewalls and the client systems of Panorama
administrators. Panorama communicates with these systems to perform various services, including
managing devices (ﬁrewalls, Log Collectors, and WildFire appliances and appliance clusters),
collecng logs, communicang with Collector Groups, deploying soware and content updates
to devices, and providing administrave access to Panorama. By default, Panorama uses its
management (MGT) interface for all these services. However, you can improve security by
reserving the MGT interface for administrave access and dedicang separate interfaces for the
other services. In a large-scale network with mulple subnetworks and heavy log traﬃc, using
mulple interfaces for device management and log collecon also enables network segmentaon
and load balancing (see Conﬁgure Panorama to Use Mulple Interfaces).
When assigning Panorama services to various interfaces, keep in mind that only the MGT
interface allows administrave access to Panorama for conﬁguraon and monitoring tasks. You
can assign any interface to the other services when you Perform Inial Conﬁguraon of the MSeries Appliance. The M-Series Appliance Hardware Reference Guides explain where to aach
cables for the interfaces. The M-100 appliance support 1Gbps throughput on all its interfaces:
MGT, Eth1, Eth2, and Eth3. In addion to these interfaces, the M-500 appliance supports 10Gbps
throughput on its Eth4 and Eth5 interfaces.
The M-Series appliances do not support Link Aggregaon Control Protocol (LACP) for
aggregang interfaces.

Supported Interfaces
Interfaces can be used for device management, log collecon, Collector Group communicaon,
licensing and soware updates. See Conﬁgure Panorama to Use Mulple Interfaces for more
informaon on network segmentaon.
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Interface

Maximum Speed

M-600 Appliance M-500 Appliance M-200 Appliance

Management
(MGT)

1Gbps

Ethernet 1
(Eth1)

1Gbps

Ethernet 2
(Eth2)

1Gbps

Ethernet 3
(Eth3)

1Gbps

Ethernet 4
(Eth4)

10Gbps

—

Ethernet 5
(Eth5)

10Gbps

—

Logging Rates
Review the logging rates for the all M-Series appliance models. To achieve the logging rates listed
below, the M-Series appliance must be a single log collector in a collector group and you must
install all the logging disks for your M-Series model. For example, to achieve 30,000 logs/second
for the M-500 appliance, you must install all 12 logging disks with either 1TB or 2TB disks.
Model Capacies and
Features

M-600 Appliance

M-500 Appliance

M-200 Appliance

Maximum Logging
Rate for Panorama
in Management Only
mode

Local log storage is not supported

Maximum Logging
Rate for Panorama in
Panorama Mode

25,000 logs/second

20,000 logs/second

10,000 logs/second

Maximum Logging Rate
for Panorama in Log
Collector Mode

50,000 logs/second

30,000 logs/second

28,000 logs/second

Maximum Log Storage
on Appliance

48TB (12x8TB RAID
disk)

• 24TB (24x2TB
RAID disks)

16TB (4x8TB RAID
disk)

• 12TB (24x1TB
RAID Disk)
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Model Capacies and
Features

M-600 Appliance

M-500 Appliance

M-200 Appliance

Default Log Storage on
Appliance

16TB (4x8TB RAID
disks)

4TB (4x2TB RAID
disks)

16TB (4x8TB RAID
disks)

SSD Storage on
Appliance (for logs that
M-Series appliances
generate)

240GB

240GB

240GB

NFS Aached Log
Storage

Not available

Perform Inial Conﬁguraon of the M-Series Appliance
By default, Panorama has an IP address of 192.168.1.1 and a username/password of admin/
admin. For security reasons, you must change these sengs before connuing with other
conﬁguraon tasks. You must perform these inial conﬁguraon tasks either from the
Management (MGT) interface or using a direct serial port connecon to the console port on the
M-600, M-500, or M-200 appliance.
If you are conﬁguring an M-Series appliance in Log Collector mode with 10GB interfaces,
you must complete this enre conﬁguraon procedure for the 10GB interfaces to display
as Up.
STEP 1 | Gather the required interface and server informaon from your network administrator.
• Gather the IP address, netmask (for IPv4) or preﬁx length (for IPv6), and default gateway for
each interface that you plan to conﬁgure (MGT, Eth1, Eth2, Eth3, Eth4, Eth5). Only the MGT
interface is mandatory.
Palo Alto Networks recommends that you specify all these sengs for the MGT
interface. If you omit values for some of these sengs (such as the default gateway),
you can access Panorama only through the console port for future conﬁguraon
changes. You cannot commit the conﬁguraons for other interfaces unless you
specify all these sengs.
If you plan to use the appliance as a Panorama management server, Palo Alto Networks
recommends using the MGT interface only for managing Panorama and using other
interfaces for managing devices, collecng logs, communicang with Collector Groups, and
deploying updates to devices (see M-Series Appliance Interfaces).
• Gather the IP addresses of the DNS servers.
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STEP 2 | Access the M-Series appliance from your computer.
1. Connect to the M-Series appliance in one of the following ways:
• Aach a serial cable from a computer to the Console port on the M-Series appliance
and connect using terminal emulaon soware (9600-8-N-1).
• Aach an RJ-45 Ethernet cable from a computer to the MGT port on the MSeries appliance. From a browser, go to hps://192.168.1.1. Enabling access to this
URL might require changing the IP address on the computer to an address in the
192.168.1.0 network (for example, 192.168.1.2).
2. When prompted, log in to the appliance using the default username and password
(admin/admin). The appliance starts inializing.
STEP 3 | Change the default admin password.
Starng with PAN-OS 9.0.4, the predeﬁned, default administrator password (admin/
admin) must be changed on the ﬁrst login on a device. The new password must be
a minimum of eight characters and include a minimum of one lowercase and one
uppercase character, as well as one number or special character.
Be sure to use the best pracces for password strength to ensure a strict password
and review the password complexity sengs.
1. Click the admin link in the lower le of the web interface.
2. Enter the Old Password, New Password, and Conﬁrm New Password, and then click OK.
Store the new password in a safe locaon.
To ensure that the MGT interface remains secure, conﬁgure Minimum Password
Complexity sengs (select Panorama > Setup > Management) and specify the
interval at which administrators must change their passwords.
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STEP 4 | Conﬁgure the network access sengs for each interface that you will use to manage
Panorama, manage devices, collect logs, communicate with Collector Groups, and deploy
updates to devices.
To conﬁgure connecvity to Panorama using an IPv6 IP address, you must conﬁgure
both an IPv4 and IPv6 to successfully conﬁgure Panorama using an IPv6 IP address.
Panorama does not support conﬁguring the management interface with only an IPv6 IP
address.
1. Select Panorama > Setup > Interfaces and click the Interface Name.
2. (Non-MGT interfaces only) Enable the interface.
3. Edit the network access sengs of each interface that Panorama will use. Only the MGT
interface is required. The Eth1, Eth2, Eth3, Eth4, and Eth5 interfaces are oponal and
apply only if you plan to use the M-Series appliance as a Panorama management server.
1. Complete one or both of the following ﬁeld sets based on the IP protocols of your
network:
IPv4—Public IP Address, IP Address, Netmask, and Default Gateway
If your ﬁrewalls connect to the Panorama management server using a public
IP address that is translated to a private IP address (NAT), enter the public
IP in the Public IP Address ﬁeld, and the private IP in the IP Address ﬁeld to
push both addresses to your ﬁrewalls.
IPv6—IPv6 Address/Preﬁx Length and Default IPv6 Gateway
2. Select the Device Management Services that the interface supports:
Device Management and Device Log Collecon—You can assign one or more
interfaces.
Collector Group Communicaon—You can assign only one interface.
Device Deployment (soware and content updates)—You can assign only one
interface.
3. (Oponal) Select the Network Connecvity Services that the interface supports.
(MGT interface only) Disable Telnet and HTTP; these services use plaintext
and so are less secure than other services.
4. Click OK to save your changes.
STEP 5 | Conﬁgure the hostname, me zone, and general sengs.
1. Select Panorama > Setup > Management and edit the General Sengs.
2. Align the clock on Panorama and the managed ﬁrewalls to use the same Time Zone, for
example GMT or UTC. If you plan to use the Cortex Data Lake, you must conﬁgure NTP
so that Panorama can stay in sync with the Cortex Data Lake.
The ﬁrewall records mestamps when it generate logs and Panorama records mestamps
upon receiving the logs. Aligning the me zones ensures that the mestamps are
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synchronized and that the process of querying logs and generang reports on Panorama
is harmonious.
3. Enter a Hostname for the server. Panorama uses this as the display name/label for the
appliance. For example, this is the name that appears at the CLI prompt. It also appears
in the Collector Name ﬁeld if you add the appliance as a managed collector on the
Panorama > Managed Collectors page.
4. (Oponal) Enter the Latude and Longitude to enable accurate placement of the MSeries appliance on the world map. The App Scope > Traﬃc Maps and App Scope >
Threat Maps use these values.
5. Click OK to save your entries.
STEP 6 | Conﬁgure the DNS servers and Palo Alto Networks Update Server.
1. Select Panorama > Setup > Services and edit the sengs.
2. Enter the IP address of the Primary DNS Server and (oponally) of the Secondary DNS
Server.
3. Enter the URL or stac address of the Update Server (default
updates.paloaltonetworks.com).
Select Verify Update Server Identy if you want Panorama to verify that the
Update Server from which it downloads soware or content packages has an SSL
cerﬁcate that a trusted authority signed. This opon adds an addional level
of security for communicaon between the Panorama management server and
Update Server.
4. Click OK to save your entries.
STEP 7 | Commit your conﬁguraon changes.
Select Commit > Commit to Panorama and Commit your changes.
If you plan to use the M-Series appliance as a Panorama management server and you
conﬁgured interfaces other than MGT, you must assign those interfaces to the Device
Log Collecon or Collector Group Communicaon funcons when you Conﬁgure a
Managed Collector. To make the interfaces operaonal, you must then Conﬁgure a
Collector Group for the managed collector and perform a Collector Group commit.
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STEP 8 | Verify network access to external services required for Panorama management, such as the
Palo Alto Networks Update Server.
1. Connect to the M-Series appliance in one of the following ways:
• Aach a serial cable from your computer to the Console port on the M-Series
appliance. Then use a terminal emulaon soware (9600-8-N-1) to connect.
• Use terminal emulaon soware such as PuTTY to open an SSH session to the IP
address that you speciﬁed for the MGT interface of the M-Series appliance during
inial conﬁguraon.
2. Log in to the CLI when prompted. Use the default admin account and the password that
you speciﬁed during inial conﬁguraon.
3. Use the Update Server Connecvity test to verify network connecvity to the Palo Alto
Networks Update Server as shown in the following example.
1. Select Panorama > Managed Devices > Troubleshoong, and select Updates Server
Connecvity from the Select Test drop-down.
2. Execute the update server connecvity test.

4. Use the following CLI command to retrieve informaon on the support entlement for
Panorama from the Update Server:
admin> request support check
If you have connecvity, the Update Server responds with the support status for
Panorama. Because Panorama is not registered, the Update Server returns the following
message:
Contact Us
https://www.paloaltonetworks.com/company/contact-us.html
Support Home
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https://www.paloaltonetworks.com/support/tabs/overview.html
Device not found on this update server
STEP 9 | Next steps...
1. Register Panorama and Install Licenses.
2. Install Content and Soware Updates for Panorama.
As a best pracce, replace the default cerﬁcate that Panorama uses to secure
HTTPS traﬃc over the MGT interface.

M-Series Setup Overview
Use the following procedures to set up an M-Series appliance:
• Set Up an M-Series Appliance in Management Only Mode
• Set Up an M-Series Appliance in Panorama Mode
• Set Up an M-Series Appliance in Log Collector Mode

Set Up an M-Series Appliance in Management Only Mode
Set up the Panorama management server in Management Only mode to dedicate Panorama to
managing ﬁrewalls and Dedicated Log Collectors. Panorama in Management Only mode have
no log collecon capabilies, except for conﬁg and system logs, and requires a Dedicated Log
Collector to store logs.
If you conﬁgured a local Log Collector, the local Log Collector sll exists on Panorama
when you change to Management Only mode despite having no log collecon capabilies.
Deleng the local Log Collector (Panorama > Managed Collectors) deletes the Eth1/1
interface conﬁguraon the local Log Collector uses by default. If you decide to delete the
local Log Collector, you must reconﬁgure the Eth1/1 interface.
STEP 1 | Rack mount the M-Series appliance. Refer to the M-Series Appliance Hardware Reference
Guide for instrucons.
STEP 2 | Perform Inial Conﬁguraon of the M-Series Appliance.
STEP 3 | Register Panorama and Install Licenses.
STEP 4 | Install content and soware updates on Panorama.
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STEP 5 | Change to Management Only mode.
1. Log in to the Panorama CLI.
2. Switch from Panorama mode to Management Only mode:
request system system-mode management-only
3. Enter Y to conﬁrm the mode change. The Panorama management server reboots. If the
reboot process terminates your terminal emulaon soware session, reconnect to the
Panorama management server to see the Panorama login prompt.
If you see a CMS Login prompt, this means the Panorama management server has not
ﬁnished reboong. Press Enter at the prompt without typing a username or password.
4. Log back in to the CLI.
5. Verify that the switch to Management Only mode succeeded:
show system info | match system-mode
If the mode change succeeded, the output displays:
system mode:management-only
STEP 6 | Set Up Administrave Access to Panorama
STEP 7 | Manage Firewalls
STEP 8 | Manage Log Collecon

Set Up an M-Series Appliance in Panorama Mode
STEP 1 | Rack mount the M-Series appliance. Refer to the M-Series Appliance Hardware Reference
Guide for instrucons.
STEP 2 | Perform Inial Conﬁguraon of the M-Series Appliance.
STEP 3 | Register Panorama and Install Licenses.
STEP 4 | Install Content and Soware Updates for Panorama.
STEP 5 | Conﬁgure each array. This task is required to make the RAID disks available for logging.
Oponally, you can add disks to Increase Storage on the M-Series Appliance.
STEP 6 | Set Up Administrave Access to Panorama.
STEP 7 | Manage Firewalls.
STEP 8 | Manage Log Collecon.

Set Up an M-Series Appliance in Log Collector Mode
STEP 1 | Rack mount the M-Series appliance. Refer to the M-Series Appliance Hardware Reference
Guide for instrucons.
STEP 2 | Perform Inial Conﬁguraon of the M-Series Appliance
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STEP 3 | Register Panorama and Install Licenses
STEP 4 | Install Content and Soware Updates for Panorama
STEP 5 | Conﬁgure each array. This task is required to make the RAID disks available for logging.
Oponally, you can add disks to Increase Storage on the M-Series Appliance.
STEP 6 | Set Up the M-Series Appliance as a Log Collector
STEP 7 | Manage Log Collecon

Set Up the M-Series Appliance as a Log Collector
If you want a dedicated appliance for log collecon, conﬁgure an M-200, M-500, or M-600
appliance in Log Collector mode. To do this, you ﬁrst perform the inial conﬁguraon of the
appliance in Panorama mode, which includes licensing, installing soware and content updates,
and conﬁguring the management (MGT) interface. You then switch the M-Series appliance to Log
Collector mode and complete the Log Collector conﬁguraon. Addionally, if you want to use
dedicated M-Series Appliance Interfaces (recommended) instead of the MGT interface for log
collecon and Collector Group communicaon, you must ﬁrst conﬁgure the interfaces for the
Panorama management server, then conﬁgure them for the Log Collector, and then perform a
Panorama commit followed by a Collector Group commit.
Perform the following steps to set up a new M-Series appliance as a Log Collector or to convert an
exisng M-Series appliance that was previously deployed as a Panorama management server.
If you are conﬁguring an M-Series appliance in Log Collector mode with 10GB interfaces,
you must complete this enre conﬁguraon procedure for the 10GB interfaces to display
as Up.
Switching the M-Series appliance from Panorama mode to Log Collector mode reboots
the appliance, deletes the local Log Collector, deletes any exisng log data, and deletes
all conﬁguraons except the management access sengs. Switching the mode does not
delete licenses, soware updates, or content updates.
STEP 1 | Set up the Panorama management server that will manage the Log Collector if you have not
already done so.
Perform one of the following tasks:
• Set Up the Panorama Virtual Appliance
• Set Up the M-Series Appliance
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STEP 2 | Record the management IP addresses of the Panorama management server.
If you deployed Panorama in a high availability (HA) conﬁguraon, you need the IP address of
each HA peer.
1. Log in to the web interface of the Panorama management server.
2. Record the IP Address of the solitary (non-HA) or acve (HA) Panorama by selecng
Panorama > Setup > Management and checking the Management Interface Sengs.
3. For an HA deployment, record the Peer HA IP Address of the passive Panorama by
selecng Panorama > High Availability and checking the Setup secon.
STEP 3 | Set up the M-Series appliance that will serve as a Dedicated Log Collector.
If you previously deployed this appliance as a Panorama management server, you can skip this
step because the MGT interface is already conﬁgured and the licenses and updates are already
installed.
The M-Series appliance in Log Collector mode does not have a web interface for conﬁguraon
tasks, only a CLI. Therefore, before changing the mode on the M-Series appliance, use the web
interface in Panorama mode to:
1. Perform Inial Conﬁguraon of the M-Series Appliance.
2. Register Panorama and Install Licenses.
3. Install Content and Soware Updates for Panorama.
STEP 4 | Access the CLI of the M-Series appliance.
1. Connect to the M-Series appliance in one of the following ways:
• Aach a serial cable from your computer to the Console port on the M-Series
appliance. Then use terminal emulaon soware (9600-8-N-1) to connect.
• Use terminal emulaon soware such as PuTTY to open an SSH session to the IP
address that you speciﬁed for the MGT interface of the M-Series appliance during
inial conﬁguraon.
2. Log in to the CLI when prompted. Use the default admin account and the password that
you speciﬁed during inial conﬁguraon.
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STEP 5 | Switch from Panorama mode to Log Collector mode.
1. Switch to Log Collector mode by entering the following command:
> request system system-mode logger
2. Enter Y to conﬁrm the mode change. The M-Series appliance reboots. If the reboot
process terminates your terminal emulaon soware session, reconnect to the M-Series
appliance to see the Panorama login prompt.
If you see a CMS Login prompt, this means the Log Collector has not ﬁnished
reboong. Press Enter at the prompt without typing a username or password.
3. Log back in to the CLI.
4. Verify that the switch to Log Collector mode succeeded:
> show system info | match system-mode
If the mode change succeeded, the output displays:
system-mode: logger
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STEP 6 | Conﬁgure the logging disks as RAID1 pairs.
If you previously deployed the appliance as a Panorama management server, you can skip this
step because the disk pairs are already conﬁgured and available.
The me required to conﬁgure the drives varies from several minutes to a couple of
hours, based on the amount of data on the drives.
1. Determine which disk pairs are present for conﬁguring as RAID pairs on the M-Series
appliance:
> show system raid detail
Perform the remaining steps to conﬁgure each disk pair that has present disks. This
example uses disk pair A1/A2.
2. To add the ﬁrst disk in the pair, enter the following command and enter y when
prompted to conﬁrm the request:
> request system raid add A1
Wait for the process to ﬁnish before adding the next disk in the pair. To monitor the
progress of the RAID conﬁguraon, re-enter:
> show system raid detail
Aer the process ﬁnishes for the ﬁrst disk, the output displays the disk pair status as
Available but degraded.
3. Add the second disk in the pair:
> request system raid add A2
4. Verify that the disk setup is complete:
> show system raid detail
Aer the process ﬁnishes for the second disk, the output displays the disk pair status as
Available and clean:
Disk Pair A
Status

Available
clean
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STEP 7 | Enable connecvity between the Log Collector and Panorama management server.
Enter the following commands at the Log Collector CLI, where <IPaddress1> is for the MGT
interface of the solitary (non-HA) or acve (HA) Panorama and <IPaddress2> is for the MGT
interface of the passive (HA) Panorama, if applicable.
> configure
# set deviceconfig system panorama-server <IPaddress1> panoramaserver-2 <IPaddress2>
# commit
# exit
STEP 8 | Record the serial number of the Log Collector.
You need the serial number to add the Log Collector as a managed collector on the Panorama
management server.
1. At the Log Collector CLI, enter the following command to display its serial number.
> show system info | match serial
2. Record the serial number.
STEP 9 | Add the Log Collector as a managed collector to the Panorama management server.
1. Select Panorama > Managed Collectors and Add a managed collector.
2. In the General sengs, enter the serial number (Collector S/N) you recorded for the Log
Collector.
3. In the Panorama Server IP ﬁeld, enter the IP address or FQDN of the solitary (non-HA)
or acve (HA) Panorama. For HA deployments, enter the IP address or FQDN of the
passive Panorama peer in the Panorama Server IP 2 ﬁeld.
These IP addresses must specify a Panorama interface that has Device Management and
Device Log Collecon services enabled. By default, these services are enabled only on
the MGT interface. However, you might have enabled the services on other interfaces
when you Set Up the M-Series Appliance that is a Panorama management server.
4. Select Interfaces, click Management, and conﬁgure one or both of the following ﬁeld
sets for the MGT interface based on the IP protocols of your network.
• IPv4—IP Address, Netmask, and Default Gateway
• IPv6—IPv6 Address/Preﬁx Length and Default IPv6 Gateway
5. Click OK twice to save your changes to the Log Collector.
6. Select Commit > Commit to Panorama and Commit your changes to the Panorama
conﬁguraon.
This step is required before you can enable logging disks.
7. Verify that Panorama > Managed Collectors lists the Log Collector you added. The
Connected column displays a check mark to indicate that the Log Collector is connected
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to Panorama. You might have to wait a few minutes before the page displays the updated
connecon status.
At this point, the Conﬁguraon Status column displays Out of Sync and the Run
Time Status column displays disconnected. The status will change to In Sync and
connected aer you conﬁgure a Collector Group (Step Assign the Log Collector
to a Collector Group.).
STEP 10 | Enable the logging disks.
1. Select Panorama > Managed Collectors and edit the Log Collector.
2. Select Disks and Add each RAID disk pair.
3. Click OK to save your changes.
4. Select Commit > Commit to Panorama and Commit your changes to the Panorama
conﬁguraon.
STEP 11 | (Recommended) Conﬁgure the Ethernet1, Ethernet2, Ethernet3, Ethernet4, and Ethernet5
interfaces if the Panorama management server and Log Collector will use them for Device
Log Collecon (receiving logs from ﬁrewalls) and Collector Group Communicaon.
If you previously deployed the Log Collector as a Panorama management server and conﬁgured
these interfaces, you must reconﬁgure them because switching to Log Collector mode (Switch
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from Panorama mode to Log Collector mode.) would have deleted all conﬁguraons except the
management access sengs.
1. Conﬁgure each interface on the Panorama management server (other than the MGT
interface) if you haven’t already:
1. Select Panorama > Setup > Interfaces and click the Interface Name.
2. Select <interface-name> to enable the interface.
3. Complete one or both of the following ﬁeld sets based on the IP protocols of your
network:
IPv4—IP Address, Netmask, and Default Gateway
IPv6—IPv6 Address/Preﬁx Length and Default IPv6 Gateway
4. Select the Device Management Services that the interface supports:
Device Management and Device Log Collecon—You can assign one or more
interfaces.
Collector Group Communicaon—You can assign only one interface.
Device Deployment (soware and content updates)—You can assign only one
interface.
5. Click OK to save your changes.
2. Conﬁgure each interface on the Log Collector (other than the MGT interface):
1. Select Panorama > Managed Collectors and edit the Log Collector.
2. Select Interfaces and click the name of the interface.
3. Select <interface-name> to enable the interface.
4. Complete one or both of the following ﬁeld sets based on the IP protocols of your
network:
IPv4—IP Address, Netmask, and Default Gateway
IPv6—IPv6 Address/Preﬁx Length and Default IPv6 Gateway
5. Select the Device Management Services that the interface supports:
Device Log Collecon—You can assign one or more interfaces.
Collector Group Communicaon—You can assign only one interface.
6. Click OK to save your changes to the interface.
3. Click OK to save your changes to the Log Collector.
4. Select Commit > Commit to Panorama and Commit your changes to the Panorama
conﬁguraon.
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STEP 12 | (Oponal) If your deployment is using custom cerﬁcates for authencaon between
Panorama and managed devices, deploy the custom client device cerﬁcate. For more
informaon, see Set Up Authencaon Using Custom Cerﬁcates.
1. Select Panorama > Cerﬁcate Management > Cerﬁcate Proﬁle and choose the
cerﬁcate proﬁle from the drop-down or click New Cerﬁcate Proﬁle to create one.
2. Select Panorama > Managed Collectors > Add > Communicaon for a Log Collector.
3. Select the Secure Client Communicaon check box.
4. Select the type of device cerﬁcate the Type drop-down.
• If you are using a local device cerﬁcate, select the Cerﬁcate and Cerﬁcate Proﬁle
from the respecve drop-downs.
• If you are using SCEP as the device cerﬁcate, select the SCEP Proﬁle and Cerﬁcate
Proﬁle from the respecve drop-downs.
5. Click OK.
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STEP 13 | (Oponal) Conﬁgure Secure Server Communicaon on a Log Collector. For more informaon,
see Set Up Authencaon Using Custom Cerﬁcates.
1. Select Panorama > Managed Collectors > Add > Communicaon.
2. Verify that the Custom Cerﬁcate Only check box is not selected. This allows you to
connue managing all devices while migrang to custom cerﬁcates.
When the Custom Cerﬁcate Only check box is selected, the Log Collector
does not authencate and cannot receive logs from devices using predeﬁned
cerﬁcates.
3. Select the SSL/TLS service proﬁle from the SSL/TLS Service Proﬁle drop-down. This
SSL/TLS service proﬁle applies to all SSL connecons between the Log Collector and
devices sending it logs.
4. Select the cerﬁcate proﬁle from the Cerﬁcate Proﬁle drop-down.
5. Select Authorize Client Based on Serial Number to have the server check clients against
the serial numbers of managed devices. The client cerﬁcate must have the special
keyword $UDID set as the CN to authorize based on serial numbers.
6. In Disconnect Wait Time (min), enter the number of minutes Panorama should wait
before breaking and reestablishing the connecon with its managed devices. This ﬁeld is
blank by default and the range is 0 to 44,640 minutes.
The disconnect wait me does not begin counng down unl you commit the
new conﬁguraon.
7. (Oponal) Conﬁgure an authorizaon list.
1. Click Add under Authorizaon List.
2. Select the Subject or Subject Alt Name as the Idenﬁer type.
3. Enter an idenﬁer of the selected type.
4. Click OK.
5. Select Check Authorizaon List to enforce the authorizaon list.
8. Click OK.
9. Select Commit > Commit to Panorama.
STEP 14 | Assign the Log Collector to a Collector Group.
1. Conﬁgure a Collector Group. You must perform a Panorama commit and then a Collector
Group commit to synchronize the Log Collector conﬁguraon with Panorama and to put
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the Eth1, Eth2, Eth3, Eth4, and Eth5 interfaces (if you conﬁgured them) in an operaonal
state on the Log Collector.
In any single Collector Group, all the Log Collectors must run on the same
Panorama model: all M-600 appliances, all M-500 appliances, all M-200
appliances, or all Panorama virtual appliances.
As a best pracce, Enable log redundancy across collectors if you add mulple
Log Collectors to a single Collector group. This opon requires each Log Collector
to have the same number of logging disks.
2. Select Panorama > Managed Collectors to verify that the Log Collector conﬁguraon is
synchronized with Panorama.
The Conﬁguraon Status column should display In Sync and the Run Time Status column
should display connected.
3. Access the Log Collector CLI and enter the following command to verify that its
interfaces are operaonal:
> show interface all
The output displays the state as up for each interface that is operaonal.
4. If the Collector Group has mulple Log Collectors, Troubleshoot Connecvity to Network
Resources to verify they can communicate with each other by performing a Ping
connecvity test for each interface that the Log Collectors use. For the source IP
address, specify the interface of one of the Log Collectors. For the host IP address,
specify the matching interface of another Log Collector in the same Collector Group.
STEP 15 | Next steps...
To enable the Log Collector to receive ﬁrewall logs:
1. Conﬁgure Log Forwarding to Panorama.
2. Verify Log Forwarding to Panorama.

Increase Storage on the M-Series Appliance
Aer you Perform Inial Conﬁguraon of the M-Series Appliance, you can increase log storage
capacity of the appliance by upgrading the exisng drive pairs to larger capacity drives or by
installing addional drive pairs in empty drive bays. For example, you can choose to upgrade the
exisng 1TB drives to 2TB on an M-500 appliance, or you can add 2TB drives to the empty drive
bays (B1 through D2).
The M-Series appliances leverage RAID 1 for data redundancy in the event of disk failure.
Therefore, the pair of drives in a RAID 1 array need to be idencal. However, you are free
to mix drive capacies across diﬀerent RAID 1 arrays. For example, the drives in the A1/
A2 RAID 1 array can be 1TB drives, and the drives in the B1/B2 RAID 1 array can be 2TB
drives.
The following table lists the maximum number of drive bays (disks) and the available drive
capacies supported on M-Series appliances.
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Because each drive pair (A1/A2 for example) is in a RAID 1 array, the total storage
capacity is half of the total drives installed. For example, if an M-500 appliance has 2TB
drives installed in drive bays A1/A2 and B1/B2, the A1/A2 array provides 2TB total
storage and the B1/B2 array provides another 2TB for a total of 4TB.
Appliance

Number of Supported Drive
Bays (Disks)

Supported Drive Capacity

M-200
Appliance

4

8TB

M-500
Appliance

24

1TB or 2TB

M-600
Appliance

12

8TB

Before expanding log storage capacity, Determine Panorama Log Storage Requirements. If you
need more log storage than a single M-Series appliance supports, you can add Dedicated Log
Collectors (see Conﬁgure a Managed Collector) or you can Conﬁgure Log Forwarding from
Panorama to External Desnaons.
You don’t need to take the M-Series appliance oﬄine to expand the storage when adding
drives to an M-Series appliance that is already deployed. When the addional drives
are conﬁgurable and available, the M-Series appliance redistributes the logs among all
available drives. This log redistribuon process happens in the background and does
not impact upme or the availability of the M-Series appliance. However, the process
does diminish the maximum logging rate. The Redistribuon State column (Panorama >
Collector Groups) indicates the compleon status of the process as a percentage.
• Add Addional Drives to an M-Series Appliance
• Upgrade Drives on an M-Series Appliance

Add Addional Drives to an M-Series Appliance
STEP 1 | Install the new drives in the appropriate drive bays.
Make sure to add the drives sequenally in the next open drive bays. For example, add drives
to B1 and B2 before adding drives to C1 and C2.
STEP 2 | Access the command line interface (CLI) on the M-Series appliance.
Connect to the M-Series appliance in one of two ways:
• Connect a serial cable from your computer to the Console port and connect to the M-Series
appliance using terminal emulaon soware (9600-8-N-1).
• Use terminal emulaon soware (such as PuTTY) to open a Secure Shell (SSH) session to the
IP address of the M-Series appliance.

Panorama Administrator's Guide Version Version 10.1

204

©2022 Palo Alto Networks, Inc.

Set Up Panorama
STEP 3 | When prompted, log in to the appliance.
Use the default administrator account and the assigned password.
STEP 4 | Conﬁgure each array.
The me required to mirror the data on the drive can take minutes, a few hours, or
more than a day depending on the amount of data on the drive.
The following example uses the drives in bays B1 and B2.
1. Enter the following commands and conﬁrm the request when prompted:
> request system raid add B1
> request system raid add B2
2. To monitor the progress of the RAID conﬁguraon, enter the following command:
> show system raid detail
When the RAID set up is complete, the following response displays:
Disk Pair A
Status
Disk id A1
model
size
status
Disk id A2
model
size
status
Disk Pair B
Status
Disk id B1
model
size
status
Disk id B2
model
size
status

Panorama Administrator's Guide Version Version 10.1

Available
clean
Present
: ST91000640NS
: 953869 MB
: active sync
Present
: ST91000640NS
: 953869 MB
: active sync
Available
clean
Present
: ST91000640NS
: 953869 MB
: active sync
Present
: ST91000640NS
: 953869 MB
: active sync

205

©2022 Palo Alto Networks, Inc.

Set Up Panorama
STEP 5 | Make the array available for logging.
To enable the array for logging, you must ﬁrst add the appliance as a managed collector on
Panorama. If not already added, see Conﬁgure a Managed Collector.
1. Log in to the web interface of the Panorama management server that manages this Log
Collector.
2. Select Panorama > Managed Collectors and edit the Log Collector.
3. Select Disks and Add each array.
4. Click OK to save your changes.
5. Select Commit > Commit to Panorama and Commit your changes.
6. Select Commit > Push to Devices, select the Collector Group, and Push your changes.

Upgrade Drives on an M-Series Appliance
STEP 1 | Access the command line interface (CLI) on the M-Series appliance.
Connect to the M-Series appliance in one of two ways:
• Connect a serial cable from your computer to the Console port and connect to the M-Series
appliance using terminal emulaon soware (9600-8-N-1).
• Use terminal emulaon soware (such as PuTTY) to open a Secure Shell (SSH) session to the
IP address of the M-Series appliance.
STEP 2 | When prompted, log in to the appliance.
Use the default administrator account and the assigned password.
STEP 3 | Verify that the RAID 1 status for the installed drives shows there are at least two funconing
RAID 1 arrays. During the upgrade, you will upgrade one RAID 1 array at a me and there
must be at least one other RAID 1 array that is available to the appliance. The appliance will
show an abort error if you try to remove the only funconing array from the conﬁguraon.
Enter the following command to view RAID status:
> show system raid detail
For example, the following shows an output from an M-500 appliance with two available arrays
(Disk Pair A and Disk Pair B). If there is only one available array, you must add a second array as
described in Add Addional Drives to an M-Series Appliance before you upgrade the drives.
Disk Pair A
Status
Disk id A1
model
size
status
Disk id A2
model
size
status
Disk Pair B

: ST91000640NS
: 953869 MB
: active sync
: ST91000640NS
: 953869 MB
: active sync
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Status
Disk id B1
model
size
status
Disk id B2
model
size
status

: ST91000640NS
: 953869 MB
: active sync
: ST91000640NS
: 953869 MB
: active sync

clean
Present

Present

STEP 4 | Remove the ﬁrst 1TB drive and replace it with a 2TB drive.
1. To remove the ﬁrst drive from the RAID 1 array conﬁguraon (A1 in this example), enter
the following command and enter y when prompted to conﬁrm the request:
> request system raid remove A1
2. Physically remove the ﬁrst drive from the drive bay. Press the ejector buon on the drive
carrier in drive bay A1 to release the ejector handle. Then pull the handle toward you and
slide the drive out of the appliance.
3. Remove a 2TB drive from its packaging and place the drive on a table next to the drive
you just removed. Take note of how the drive is installed in the carrier because you will
install the 2TB drive in this same carrier.
4. Remove the four screws holding the 1TB drive in the carrier and remove the drive from
the carrier.
5. Aach the 2TB drive to the carrier using the same four screws you removed from the
1TB drive and then reinsert the carrier with the 2TB drive into drive bay A1.
6. Enter the following command to verify the 2TB drive is recognized:
show system raid detail
Verify that the A1 disk shows the correct model and size (about 2TB). If the model and
size are not correct, run the above command again unl the correct model and size are
shown.
If the wrong model and size are consistently shown, enter the following command:
request system raid remove A1
Wait for 30 seconds once you run the above command, then remove the disk and
reinsert it and repeat the show system raid detail command to verify the size and
model.
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STEP 5 | Copy the data from the remaining installed 1TB drive in the RAID 1 array to the newly
installed 2TB drive in that array.
The me required to copy the data may vary from several minutes to a few hours,
depending on the amount of data on the drive.
1. To copy the data from the 1TB drive in drive bay A2 to the newly installed 2TB drive in
drive bay A1, enter the following command and enter y when prompted:
> request system raid copy from A2 to A1
2. To view the status of the copy process, run the following command:
> show system raid detail
Connue running this command to view the RAID detail output unl you see that the
array (A1/A2 in this example) shows Available.
At this point, drive A2 will show not in use because there is a drive size
mismatch.
STEP 6 | Upgrade the second drive in the RAID 1 array to a 2TB drive.
1. Remove the second 1TB drive (from drive bay A2 in the current example) for the RAID 1
array conﬁguraon:
> request system raid remove A2
2. Insert the carrier with the newly installed 2TB drive into drive bay A2 and add it to the
RAID 1 array conﬁguraon:
> request system raid add A2
The system will copy the data from A2 to A1 to mirror the drives.
3. To view the status of the copy process, run the following command:
> show system raid detail
Connue to view the RAID detail output unl you see that the array (A1/A2 in this
example) shows Available and both disks show active sync.
Disk Pair A
Status
Disk id A1
model
size
status
Disk id A2
model

Available
clean
Present
: ST2000NX0253
: 1907138 MB
: active sync
Present
: ST2000NX0253
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size
status

: 1907138 MB
: active sync

STEP 7 | Upgrade drives for addional RAID 1 arrays as needed.
To upgrade addional RAID 1 arrays to 2TB drives, repeat this procedure replacing the drive
designators as applicable. For example, replace A1 with B1 and A2 with B2 to upgrade the
drives in the B1/B2 RAID 1 array.

Conﬁgure Panorama to Use Mulple Interfaces
In a large-scale network, you can improve security and reduce congeson by implemenng
network segmentaon, which involves segregang the subnetworks based on resource usage,
user roles, and security requirements. Panorama supports network segmentaon by enabling you
to use mulple M-Series Appliance Interfaces for managing devices (ﬁrewalls, Log Collectors, and
WildFire appliances and appliance clusters) and collecng logs; you can assign separate interfaces
to the devices on separate subnetworks.
Using mulple interfaces to collect logs also provides the beneﬁt of load balancing, which is
parcularly useful in environments where the ﬁrewalls forward logs at high rates to the Log
Collectors. If you enable the forward to all Log Collectors seng in the Collector Group log
forwarding preference list, logs are sent on all conﬁgured interfaces conﬁgured. Otherwise, logs
are forwarded over a single interface, and if that interface goes down, log forwarding connues
over the next conﬁgured interface. For example, you conﬁgure Eth1/1, Eth1/2, and Eth1/3 for log
forwarding. In the event the Eth1/1 interface goes down, log forwarding connues over Eth1/2.
Because administrators access and manage Panorama over the MGT interface, securing that
interface is especially important. One method for improving the security of the MGT interface
is to oﬄoad Panorama services to other interfaces. In addion to device management and log
collecon, you can also oﬄoad Collector Group communicaon and deployment of soware and
content updates to ﬁrewalls, Log Collectors, and WildFire appliances and appliance clusters. By
oﬄoading these services, you can reserve the MGT interface for administrave traﬃc and assign
it to a secure subnetwork that is segregated from the subnetworks where your ﬁrewalls, Log
Collectors, and WildFire appliances and appliance clusters reside.
• Mulple Interfaces for Network Segmentaon Example
• Conﬁgure Panorama for Network Segmentaon

Mulple Interfaces for Network Segmentaon Example
Figure 9: Mulple Panorama Interfaces illustrates a deployment that uses mulple interfaces on
M-500 appliances in Panorama mode and Log Collector mode. In this example, the interfaces
support network segmentaon as follows:
• Panorama management network—To protect the Panorama web interface, CLI, and XML API
from unauthorized access, the MGT interface on Panorama connects to a subnetwork that only
administrators can access.
• Internet—Panorama uses the MGT interface to communicate with external services such as the
Palo Alto Networks Update Server.
• Perimeter Gateway and Data Center—Panorama uses a separate pair of interfaces to manage
the ﬁrewalls and Log Collectors in each of these subnetworks. Managing ﬁrewalls typically
generates less traﬃc than querying Log Collectors for report informaon. Therefore, Panorama
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uses 1Gbps interfaces (Eth1 and Eth2) for managing the ﬁrewalls and uses 10Gbps interfaces
(Eth4 and Eth5) for querying and managing the Log Collectors. Each Log Collector uses its MGT
interface to respond to the queries but uses its Eth4 and Eth5 interfaces for the heavier traﬃc
associated with collecng logs from the ﬁrewalls.
• Soware and content updates—The ﬁrewalls and Log Collectors in both subnetworks retrieve
soware and content updates over the Eth3 interface on Panorama.

Figure 9: Multiple Panorama Interfaces

Conﬁgure Panorama for Network Segmentaon
To oﬄoad Panorama services from the MGT interface to other interfaces, start by conﬁguring the
interfaces on the Panorama management server. If your network has heavy log traﬃc, remember
that the Eth4 and Eth5 interfaces on the M-500 and M-600 appliances support higher throughput
(10Gbps) than the other interfaces (1Gbps). Then, conﬁgure the Log Collectors in each subnetwork
to connect with speciﬁc interfaces on Panorama. For each Log Collector, you also select an
interface for Collector Group communicaon and one or more interfaces for collecng logs

Panorama Administrator's Guide Version Version 10.1

210

©2022 Palo Alto Networks, Inc.

Set Up Panorama
from ﬁrewalls. Finally, conﬁgure the ﬁrewalls in each subnetwork to connect with interfaces on
Panorama.
If you are conﬁguring an M-Series appliance in Log Collector mode with 10GB interfaces,
you must complete this enre conﬁguraon procedure for the 10GB interfaces to display
as Up.
Palo Alto Networks recommends that you specify the IP address, netmask (for IPv4) or
preﬁx length (for IPv6), and default gateway for the MGT interface. If you omit one of
these sengs (such as the default gateway), you can access the M-Series appliance only
through the console port for future conﬁguraon changes.
Perform the following steps to conﬁgure Panorama and Dedicated Log Collectors to use mulple
interfaces:
STEP 1 | Verify that the Panorama appliances and ﬁrewalls support mulple interfaces, and have the
prerequisite soware versions and conﬁguraons.
The M-Series appliances must run Panorama 8.0 or later to use a separate interface for
deploying updates and to use mulple interfaces for device management and log collecon.
The M-200 and M-600 appliances must run Panorama 8.1 or later. Panorama appliances
deployed on ESXi, vCloud, Air, Hyper-V and KVM must run Panorama 8.1 or later.
If you deployed a Panorama or Log Collector as a virtual appliance, verify the Supported
Interfaces for the Panorama Virtual Appliance.
The M-Series appliances must run Panorama 6.1 or later to use separate interfaces for log
collecon or Collector Group communicaon.
The inial conﬁguraon of each Panorama management server is complete. This includes
conﬁguraon of the MGT interface.
To conﬁgure an IPv6 IP address for the Panorama MGT interface, you must
conﬁgure both an IPv4 and IPv6 to successfully conﬁgure Panorama using an IPv6
IP address. Panorama does not support conﬁguring the MGT interface with only an
IPv6 IP address.
Log Collectors and Collector Groups are conﬁgured. This includes conﬁguraon of the MGT
interface on the Log Collectors.
To conﬁgure an IPv6 IP address for the MGT interface of a Log Collector, you must
conﬁgure both an IPv4 and IPv6 to successfully conﬁgure Panorama using an IPv6
IP address. Panorama does not support conﬁguring the MGT interface with only an
IPv6 IP address.
The inial conﬁguraon of the ﬁrewalls is complete, you have added the ﬁrewalls to
Panorama as managed devices, and the ﬁrewalls in each subnetwork are assigned to a
separate template.
The inial conﬁguraon of WildFire appliances is complete and you have added WildFire
appliances to Panorama as managed devices.
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STEP 2 | Conﬁgure the interfaces on the solitary (non-HA) or acve (HA) Panorama management
server.
Because the MGT interface was conﬁgured during inial Panorama conﬁguraon, you
don’t have to conﬁgure it again.
Perform these steps for each interface:
1. Log in to the Panorama Web Interface of the solitary (non-HA) or acve (HA) Panorama
management server.
2. Select Panorama > Setup > Interfaces.
3. Click an Interface Name to edit the interface.
4. Select <interface-name> to enable the interface.
5. Conﬁgure one or both of these ﬁeld sets based on the IP protocols of your network:
• IPv4—IP Address, Netmask, and Default Gateway
• IPv6—IPv6 Address/Preﬁx Length and Default IPv6 Gateway
6. Select the services that the interface supports:
• Device Management and Device Log Collecon—Manage ﬁrewalls, Log Collectors,
and WildFire appliances and appliance clusters, collect logs that the Log Collectors
generate, and query the Log Collectors for report informaon. To support a
segmented network, you can enable these services on mulple interfaces.
• Collector Group Communicaon—Communicate with the Collector Groups that
Panorama manages across all subnetworks.
• Device Deployment—Deploy soware and content updates to managed ﬁrewalls, Log
Collectors, and WildFire appliances and appliance clusters across all subnetworks.
7. Click OK to save your changes to the interface.
8. Click Commit > Commit to Panorama and Commit your changes.
9. Click Commit > Push to Devices and push the changes to the Collector Group that
contain the Log Collectors you modiﬁed.
STEP 3 | (HA only) Conﬁgure the interfaces on the passive Panorama management server.
1. Log in to the Panorama Web Interface of the acve Panorama management server.
2. Select Panorama > Managed Collectors and select the passive HA peer.
3. Select Interfaces and click an interface to edit.
4. Check the Enable Interface box to enable the interface.
5. Conﬁgure one or both of these ﬁeld sets based on the IP protocols of your network:
• IPv4—IP Address, Netmask, and Default Gateway
• IPv6—IPv6 Address/Preﬁx Length and Default IPv6 Gateway
6. Select the services that the interface supports:
• Device Management and Device Log Collecon—Manage ﬁrewalls, Log Collectors,
and WildFire appliances and appliance clusters, collect logs that the Log Collectors
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generate, and query the Log Collectors for report informaon. To support a
segmented network, you can enable these services on mulple interfaces.
• Collector Group Communicaon—Communicate with the Collector Groups that
Panorama manages across all subnetworks.
• Device Deployment—Deploy soware and content updates to managed ﬁrewalls, Log
Collectors, and WildFire appliances and appliance clusters across all subnetworks.
7. Click OK to save your changes to the interface.
8. Select Commit > Commit and Push to commit your changes to Panorama and to push
the changes to Collector Groups that contain the passive HA peer you modiﬁed.
STEP 4 | Conﬁgure each Log Collector to connect with a Panorama interface.
To support a segmented network, you can connect the Log Collectors in each subnetwork to
separate Panorama interfaces. The interfaces must have Device Management and Device Log
Collecon enabled, as described in the previous step.
1. Log in to the Panorama Web Interface of the solitary (non-HA) or acve (HA) Panorama
management server.
2. Select Panorama > Managed Collectors and edit the Log Collector.
3. In the Panorama Server IP ﬁeld, enter the IP address of an interface on the solitary (nonHA) or acve (HA) Panorama.
4. (HA only) In the Panorama Server IP 2 ﬁeld, enter the IP address of an interface on the
passive Panorama that will support Device Management and Device Log Collecon if
failover occurs on the acve Panorama.
5. Click OK to save your changes.
6. Select Commit > Commit and Push to commit your changes to Panorama and to push
the changes to Collector Groups that contain the Log Collector you modiﬁed.
7. Perform the following steps on each Dedicated Log Collector:
1. Access the Log Collector CLI by using emulaon soware such as PuTTY to open a
SSH session to the Log Collector using its MGT interface IP address. When prompted,
log in using Panorama administrator credenals.
2. Run the following commands, where <IPaddress1> is for the solitary (non-HA) or
acve (HA) Panorama and <IPaddress2> is for the passive Panorama (if applicable).
> configure
# set deviceconfig system panorama-server <IPaddress1>
panorama-server-2 <IPaddress2>
# commit
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STEP 5 | (HA only) Conﬁgure an interface on the passive Panorama management server to deploy
updates in case the acve Panorama fails over.
1. Log in to the Panorama Web Interface of the passive Panorama management server.
2. Select Panorama > Setup > Interfaces.
3. Click an Interface Name to edit the interface.
4. Select <interface-name> to enable the interface.
5. Conﬁgure one or both of these ﬁeld sets based on the IP protocols of your network:
• IPv4—IP Address, Netmask, and Default Gateway
• IPv6—IPv6 Address/Preﬁx Length and Default IPv6 Gateway
6. Select Device Deployment.
7. Click OK to save your changes.
8. Click Commit > Commit to Panorama and Commit your changes.

Panorama Administrator's Guide Version Version 10.1

214

©2022 Palo Alto Networks, Inc.

Set Up Panorama
STEP 6 | Conﬁgure the interfaces that the Log Collectors will use to collect logs from ﬁrewalls and
communicate with other Log Collectors.
Because the MGT interface was conﬁgured during inial conﬁguraon of the Log
Collectors, you don’t have to conﬁgure it again.
1. Log in to the Panorama Web Interface of the solitary (non-HA) or acve (HA) Panorama
management server.
2. Select Panorama > Managed Collectors and edit the Log Collector.
3. Select Interfaces and perform the following steps for each interface:
1. Click an interface name to edit that interface.
2. Select <interface-name> to enable the interface.
3. Conﬁgure one or both of the following ﬁeld sets based on the IP protocols of your
network.
IPv4—IP Address, Netmask, and Default Gateway
IPv6—IPv6 Address/Preﬁx Length and Default IPv6 Gateway
4. Select the funcons that the interface supports:
Device Log Collecon—Collect logs from ﬁrewalls. You can load balance the logging
traﬃc by enabling mulple interfaces to perform this funcon.
Collector Group Communicaon—Communicate with other Log Collectors in the
Collector Group.
5. Click OK to save your changes to the interface.
4. Click OK to save your changes to the Log Collector.
5. Select Commit > Commit and Push to commit your changes to Panorama and to push
the changes to Collector Groups that contain the Log Collectors you modiﬁed.
6. Select Panorama > Managed Collectors to verify that the Log Collectors are
synchronized and connected with Panorama.
The Conﬁguraon Status column should display InSync and the Run Time Status
column should display connected.
STEP 7 | Conﬁgure the ﬁrewalls to connect with a Panorama interface.
To support a segmented network, you can connect the ﬁrewalls in each subnetwork to
separate Panorama interfaces. The interfaces must have Device Management and Device
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Log Collecon enabled. This step assumes that you use separate templates to conﬁgure the
ﬁrewalls in separate subnetworks.
In this example deployment, Panorama uses these interfaces to manage the ﬁrewalls
but not to collect ﬁrewall logs. You specify which Dedicated Log Collectors will collect
ﬁrewall logs when you conﬁgure Collector Groups.
1. Log in to the Panorama Web Interface of the solitary (non-HA) or acve (HA) Panorama
management server.
2. On Panorama, select Device > Setup > Management, select a Template and edit the
Panorama Sengs.
3. In the ﬁrst Panorama Servers ﬁeld, enter the IP address of an interface on the solitary
(non-HA) or acve (HA) Panorama.
4. (HA only) In the second Panorama Servers ﬁeld, enter the IP address of an interface on
the passive Panorama that will support device management if failover occurs.
5. Click OK to save your changes.
6. Select Commit > Commit and Push to commit your changes to Panorama and push the
template changes to ﬁrewalls.
7. Select Panorama > Managed Devices to verify that the ﬁrewalls are synchronized and
connected with Panorama.
The Device State column should display Connected. The Shared Policy and Template
columns should display InSync.
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Register Panorama and Install Licenses
Before you can begin using Panorama for centralized management, logging, and reporng, you are
required to register, acvate, and retrieve the Panorama device management and support licenses.
Every instance of Panorama requires valid licenses that entle you to manage ﬁrewalls and obtain
support. The ﬁrewall device management license enforces the maximum number of ﬁrewalls that
Panorama can manage. This license is based on ﬁrewall serial numbers, not on the number of
virtual systems on each ﬁrewall. The support license enables Panorama soware updates and
dynamic content updates (for the latest Applicaons and Threats signatures, as an example).
Addionally, Panorama virtual appliances on AWS and Azure must be purchased from Palo Alto
Networks, and cannot be purchased on the AWS or Azure marketplaces.
Aer upgrading your Panorama virtual appliance to PAN-OS 8.1, you are prompted if a capacity
license has not been successfully installed or if the total number of ﬁrewalls being managed by
Panorama exceeds the device management license. You have 180 days from the date of upgrade
to install a valid device management license if no license has been installed. If the number of
managed ﬁrewalls exceeds the device management license, you have 180 days to delete ﬁrewalls
to meet the device management license requirements or upgrade your device management
license. All commits fail if a valid device management license is not installed, or the exisng
device management license limit is not met, within 180 days of upgrade. To purchase a device
management license, contact your Palo Alto Networks sales representave or authorized reseller.
If you want to use the cloud-based Cortex Data Lake, you require a Cortex Data Lake license, in
addion to the ﬁrewall management license and premium support license. To purchase licenses,
contact your Palo Alto Networks Systems Engineer or reseller.
If you are running an evaluaon license for ﬁrewall management on your Panorama virtual
appliance and want to apply a Panorama license that you purchased, perform the tasks
Register Panorama and Acvate/Retrieve a Firewall Management License when the
Panorama Virtual Appliance is Internet-connected.
• Register Panorama
• Acvate a Panorama Support License
• Acvate/Retrieve a Firewall Management License when the Panorama Virtual Appliance is
Internet-connected
• Acvate/Retrieve a Firewall Management License when the Panorama Virtual Appliance is not
Internet-connected
• Acvate/Retrieve a Firewall Management License on the M-Series Appliance

Register Panorama
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STEP 1 | Record the Panorama serial number or auth-code and record your Sales Order Number or
Customer ID.
For the auth-code, Sales Order Number, or Customer ID, see the order fulﬁllment email that
Palo Alto Networks Customer Service sent when you placed your order for Panorama.
For the serial number, the locaon depends on the model:
• M-Series appliance—Log in to the Panorama web interface and record the Serial # value in
the Dashboard tab, General Informaon secon.
• Panorama virtual appliance—See the order fulﬁllment email or refer to the serial number
generated when provisioning Panorama using VM Flex licensing.
The Panorama virtual appliance is automacally registered when you allocate a
serial number using VM Flex licensing.
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STEP 2 | Register Panorama in the Palo Alto Networks Customer Support Portal (CSP).
The steps depend on whether you already have a login for the Palo Alto Networks CSP.
• If this is the ﬁrst Palo Alto Networks appliance you are registering and you do not yet have a
CSP login:
1. Go to the Palo Alto Networks CSP.
2. Click Create my account.
3. Enter Your Email Address and respond to the reCAPTCHA prompt.
4. Click Submit aer you successfully respond to the reCAPTCHA prompt.
5. Select Register device using Serial Number or Authorizaon Code and click Submit
6. Complete the ﬁelds in the Create Contact Details and Create UserID and Password
secons.
7. Enter the Panorama Device Serial Number or Auth Code.
8. Enter your Sales Order Number or Customer ID.
9. Respond to the reCAPTCHA prompt.
10.Click Submit aer you successfully respond to the reCAPTCHA prompt.
• If you already have a CSP login:
1. Log in to the Palo Alto Networks CSP.
2. Click Assets > Devices > Register New Device.
You can also Register a Device in the CSP Support Home.
3. Select Register device using Serial Number and click Next.
4. Enter the Panorama Serial Number.
5. Enter the Device Name to apply a name to search for and idenfy your Panorama.
6. (Oponal) Select a Device Tag to group Panorama with any other devices for which you
have selected a device tag.
The device tag must ﬁrst be created at the account level (Assets > Devices > Device Tag)
before it can be selected when you register Panorama.
7. If the Panorama management server is not internet-connected, check Device will be used
oﬄine and select the OS Release version.
8. Enter the required Locaon Informaon (as indicated by the asterisks) if you have
purchased the 4 hour RMA.
9. Agree and Submit the EULA.
Aer you see the registraon complete message, close the Device Registraon dialog.

Acvate a Panorama Support License
Before acvang a Panorama support license on a Panorama M-Series appliance or Panorama
virtual appliance, you must Register Panorama.
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If the support license expires, Panorama can sll manage ﬁrewalls and collect logs, but
soware and content updates will be unavailable. The soware and content versions on
Panorama must be the same as or later than the versions on the managed ﬁrewalls, or
else errors will occur. For details, see Panorama, Log Collector, Firewall, and WildFire
Version Compability.
STEP 1 | Log in to the Palo Alto Networks customer support portal to acvate the auth-code.
1. Select Assets > Devices and enter your Panorama serial number to Filter by the Serial
Number.

2. Select the pencil icon in the Acon column, select Acvate Auth-Code and enter your
support license Authorizaon Code, and click Agree and Submit.
STEP 2 | Log in to the Panorama web interface, and select Panorama > Support > Acvate feature
using authorizaon code.
STEP 3 | Enter the Authorizaon Code and click OK.
STEP 4 | Verify that the subscripon is acvated. Check the details (for example, the Expiry Date,
support Level, and Descripon) in the Support secon of the page.

Acvate/Retrieve a Firewall Management License when the
Panorama Virtual Appliance is Internet-connected
In order to manage devices on Panorama, you need to acvate a ﬁrewall management license
generated by PAN-OS. The device management license you acvate determines the number of
devices Panorama can manage. Log Collectors and WildFire appliances are not treated as managed
devices and do not count toward the number of devices alloed by the device management
license.
Before acvang and retrieving a ﬁrewall management license on the Panorama virtual appliance,
you must Register Panorama. If you are running an evaluaon license and want to apply a
license that you purchased, you must sll register and acvate/retrieve the purchased license.
Addionally, you must then change the serial number of the Panorama from the evaluaon serial
number to the producon serial number.
STEP 1 | Log in to the Panorama Web Interface.
STEP 2 | Select Panorama > Setup > Management and edit the General Sengs.
STEP 3 | Enter the Panorama Serial Number (included in the order fulﬁllment email) and click OK.
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STEP 4 | Select Panorama > Licenses to acvate or retrieve the ﬁrewall management license:
• Retrieve license keys from license server—Panorama automacally retrieves and acvates
the ﬁrewall management license from the Panorama Update Server.
• Acvate feature using authorizaon code—Enter the ﬁrewall management license
authorizaon code and click OK to acvate the license. The authorizaon code can be
obtained from the order fulﬁllment email or by logging in to the Palo Alto Networks
Customer Support web site by ﬁnding the Panorama management server.
• Manually upload license key—Log in to the Palo Alto Networks Customer Support web site,
ﬁnd your Panorama management server, and download the ﬁrewall management license
key to your local device. Aer you download the license key, click Choose File to select the
license key and click OK.
STEP 5 | Verify the ﬁrewall management license is acvated.
The Device Management License secon now appears displaying the date the license was
issued, when the license expires, and a descripon of the ﬁrewall management license.

Acvate/Retrieve a Firewall Management License when the
Panorama Virtual Appliance is not Internet-connected
Before acvang and retrieving a ﬁrewall management license on the Panorama virtual appliance,
you must Register Panorama. In order to manage devices on Panorama, you will need to acvate
a device management license. The device management license you acvate will determine the
number of devices Panorama can manage. Log Collectors and WildFire appliances are not treated
as managed devices and will not count toward the number of devices alloed by the device
management license. If you are running an evaluaon license and want to apply a license that you
purchased, you must sll register and acvate/retrieve the purchased license.
Aer upgrading to PAN-OS 8.1, you will be prompted to retrieve a valid Panorama management
license when you ﬁrst log in to the Panorama web interface when Panorama has ﬁnished
reboong. To acvate or retrieve the valid management license if the Panorama virtual appliance
is oﬄine or unable to reach the Palo Alto Networks update server, you must get the relevant
appliance informaon for the Panorama virtual appliance and upload it to the Customer Support
web site.
STEP 1 | Log in to the Panorama Web Interface.
STEP 2 | (Inial Deployment only) Enter the Panorama Serial Number.
1. Select Panorama > Setup > Management and edit the General Sengs.
2. Enter the Panorama Serial Number (included in the order fulﬁllment email) and click OK.
3. Select Commit > Commit to Panorama and Commit your changes.
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STEP 3 | Upload the Panorama virtual appliance informaon to the Customer Support website.
1. On the Retrieve Management License dialogue, click the here link to gather the UUID,
CPUID, Panorama Version and Virtual Plaorm informaon. Click Download Link to
download a XML ﬁle of the required Panorama informaon that can be uploaded to the
Customer Support Portal.
On inial deployment, may need to log out and back in to the web interface to see the
dialogue.
2. Log in to the Palo Alto Networks Customer Support web site.
3. Click Get Support in the upper right-hand corner.
4. Select Assets > Devices, ﬁnd your Panorama virtual appliance and in the Acon column,
click the edit icon ( ).
5. Select Is the Panorama Oﬄine? and enter the Panorama informaon gathered in Step 2,
or click Select ﬁles... to upload the downloaded XML ﬁle.
6. Agree and Submit the EULA.
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STEP 4 | Install the device management license.
1. In the Acons column, download the device management license.

2. In the Panorama web interface, click Panorama > Licenses and Manually upload license
key.
3. Click Choose ﬁle, locate the downloaded device management license key and click OK.
STEP 5 | Conﬁrm that the device management license was successfully uploaded by verify that the
Device Management License displays with the license informaon.

Acvate/Retrieve a Firewall Management License on the M-Series
Appliance
In order to manage devices on Panorama, you need to acvate a Capacity License. The Capacity
License determines the number of devices Panorama can manage. Log Collectors and WildFire
appliances are not treated as managed devices and do not count toward the number of devices
alloed by the Capacity License.
Before acvang and retrieving a Panorama ﬁrewall management license on the M-Series
appliance:
• Register Panorama.
• Locate the auth-codes for the product/subscripon you purchased. When you placed your
order, Palo Alto Networks Customer Service sent you an email that listed the auth-code
associated with the purchase. If you cannot locate this email, contact Palo Alto Networks
Customer Support to obtain your codes before proceeding.
Aer you acvate and retrieve the license, the Panorama > Licenses page displays the associated
issuance date, expiraon date, and the number of ﬁrewalls that the license enables Panorama to
manage.
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To acvate and retrieve the license, the opons are:
Use the web interface to acvate and retrieve the license.
Select this opon if Panorama is ready to connect to the Palo Alto Networks update server
(you completed the task Perform Inial Conﬁguraon of the M-Series Appliance) but you have
not acvated the license on the Palo Alto Networks Customer Support web site.
1. Select Panorama > Licenses and click Acvate feature using authorizaon code.
2. Enter the Authorizaon Code and click OK. Panorama retrieves and acvates the license.
Retrieve the license key from the license server.
If Panorama is not ready to connect to the update server (for example, you have not completed
the inial M-Series appliance setup), you can acvate the license on the Support website so
that, when Panorama is ready to connect, you can then use the web interface to retrieve the
acvated license. The process of retrieving an acvated license is faster than the process of
both retrieving and acvang.
1. Acvate the license on the Palo Alto Networks Customer Support web site.
1. On a host with internet access, use a web browser to access the Palo Alto Networks
Customer Support web site and log in.
2. Select Assets > Devices, ﬁnd your M-Series appliance and, in the Acon column, click
the edit icon ( ).
3. Select Acvate Auth-Code, enter the Authorizaon Code and click Agree and Submit
to acvate the license.
2. Conﬁgure Panorama to connect to the update server: see Perform Inial Conﬁguraon of
the M-Series Appliance.
3. Select Panorama > Licenses and click Retrieve license keys from the license server.
Panorama retrieves the acvated license.
Manually upload the license from a host to Panorama. Panorama must have access to that host.
If Panorama is set up (you completed the task Perform Inial Conﬁguraon of the M-Series
Appliance) but does not have a connecon to the update server, acvate the license on the

Panorama Administrator's Guide Version Version 10.1

224

©2022 Palo Alto Networks, Inc.

Set Up Panorama
Support website, download it to a host that has a connecon to the update server, then upload
it to Panorama.
1. Acvate and download the license from the Palo Alto Networks Customer Support web
site.
1. On a host with internet access, use a web browser to access the Palo Alto Networks
Customer Support web site and log in.
2. Select Assets > Devices, ﬁnd your M-Series appliance and, in the Acon column, click
the edit icon ( ).
3. Select Acvate Auth-Code, enter the Authorizaon Code and click Agree and Submit
to acvate the license.
4. In the Acon column, click the download icon and save the license key ﬁle to the host.
2. In the Panorama web interface, select Panorama > Licenses, click Manually upload
license key and click Browse.
3. Select the key ﬁle you downloaded to the host and click Open.
4. Click OK to upload the acvated license key.
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Install the Panorama Device Cerﬁcate
In PAN-OS 9.1.3 and later releases, you must install the device cerﬁcate on the Panorama™
management server to successfully authencate Panorama with the Palo Alto Networks Customer
Support Portal (CSP) and leverage cloud services such as Zero Touch Provisioning (ZTP), Device
Telemetry, IoT, and Enterprise Data Loss Prevenon (DLP). Panorama must have internet access to
successfully install the device cerﬁcate.
If you are leveraging the Cloud Services plugin, you must have Cloud Services plugin 1.5
or later release installed to successfully install the Panorama device cerﬁcate.
STEP 1 | Register Panorama with the Palo Alto Networks Customer Support Portal (CSP).
STEP 2 | Conﬁgure the Network Time Protocol (NTP) server.
An NTP server is required validate the device cerﬁcaon expiraon date, ensure the device
cerﬁcate does not expire early or become invalid.
1. Log in to the Panorama Web Interface.
2. Select Panorama > Setup > Services.
3. Select NTP and enter the hostname pool.ntp.org as the Primary NTP Server or enter
the IP address of your primary NTP server.
4. (Oponal) Enter a Secondary NTP Server address.
5. (Oponal) To authencate me updates from the NTP server(s), for Authencaon Type,
select one of the following for each server.
• None (default)—Disables NTP authencaon.
• Symmetric Key—Firewall uses symmetric key exchange (shared secrets) to
authencate me updates.
• Key ID—Enter the Key ID (1-65534)
• Algorithm—Select the algorithm to use in NTP authencaon (MDS or SHA1)
6. Click OK to save your conﬁguraon changes.
7. Select Commit and Commit to Panorama.
STEP 3 | Generate the One Time Password (OTP).
1. Log in to the Customer Support Portal.
2. Select Assets > Device Cerﬁcates and Generate OTP.
3. For the Device Type, select Generate OTP for Panorama and Generate OTP.
4. Select the Panorama Device serial number.
5. Generate OTP and copy the OTP.
STEP 4 | Log in to the Panorama Web Interface as an admin user.
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STEP 5 | Select Panorama > Setup > Management > Device Cerﬁcate Sengs and Get cerﬁcate.

STEP 6 | Enter the One-me Password you generated and click OK.
STEP 7 | Panorama successfully retrieves and installs the cerﬁcate.
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Transion to a Diﬀerent Panorama Model
When your network requirements change (for example, the logging rate increases), you can
migrate the Panorama management server and Dedicated Log Collectors to Panorama Models that
beer support those requirements.
• Migrate from a Panorama Virtual Appliance to an M-Series Appliance
• Migrate a Panorama Virtual Appliance to a Diﬀerent Hypervisor
• Migrate from an M-Series Appliance to a Panorama Virtual Appliance
• Migrate from an M-100 Appliance to an M-500 Appliance

Migrate from a Panorama Virtual Appliance to an M-Series
Appliance
You can migrate the Panorama conﬁguraon from a Panorama virtual appliance to an M-Series
appliance in Panorama mode. However, you cannot migrate the logs because the log format on
the Panorama virtual appliance is incompable with that on M-Series appliances. Therefore, if
you want to maintain access to the old logs stored on the Panorama virtual appliance, you must
connue running the Panorama virtual appliance aer the migraon. The M-Series appliance will
collect the new logs that ﬁrewalls forward aer the migraon. Aer the pre-migraon logs expire
or become irrelevant due to aging, you can shut down the Panorama virtual appliance.
Legacy mode is no longer supported in PAN-OS 8.1 or later releases. If the old Panorama
virtual appliance is in Legacy mode, you must change Panorama to Panorama mode before
migrang to the new hypervisor in order to preserve the log sengs and Log Collector forwarding
conﬁguraons. Imporng the conﬁguraon of the old Panorama in Legacy mode to a new
Panorama in Panorama mode causes all log and log forwarding sengs to be removed.
You cannot migrate logs between hypervisors. Therefore, if you want to maintain access to the
logs stored on the old Panorama virtual appliance, you must connue running the old Panorama
virtual appliance aer the migraon and add it as a managed Log Collector on the new Panorama
virtual appliance. This allows the new Panorama virtual appliance to collect the new logs that
ﬁrewalls forward aer the migraon, while maintaining access to the old log data. Aer the premigraon logs expire or become irrelevant due to aging, you can shut down the Panorama virtual
appliance.
If you store ﬁrewall logs on Dedicated Log Collectors (M-Series appliances in Log Collector
mode) instead of on the Panorama virtual appliance, you can maintain access to the logs
by migrang the Dedicated Log Collectors to the M-Series appliance in Panorama mode.
STEP 1 | Plan the migraon.
Upgrade the soware on the Panorama virtual appliance before the migraon if the MSeries appliance requires a later release of the current soware (the M-500 appliance
requires Panorama 7.0 or a later release. The M-600 and M-200 appliances require
Panorama 8.1 or later release). For important details about soware versions, see Panorama,
Log Collector, Firewall, and WildFire Version Compability.
Schedule a maintenance window for the migraon. Although ﬁrewalls can buﬀer logs aer
the Panorama virtual appliance goes oﬄine and then forward the logs aer the M-Series
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appliance comes online, compleng the migraon during a maintenance window minimizes
the risk that logs will exceed the buﬀer capacies and be lost during the transion between
Panorama models.
Consider whether to maintain access to the Panorama virtual appliance aer the migraon
to access exisng logs. The most eﬃcient approach is to assign a new IP address to the
Panorama virtual appliance and reuse its old IP address for the M-Series appliance. This
ensures that the Panorama virtual appliance remains accessible and that ﬁrewalls can point
to the M-Series appliance without you reconﬁguring the Panorama IP address on each
ﬁrewall.
STEP 2 | Purchase the new M-Series appliance, and migrate your subscripons to the new appliance.
1. Purchase the new M-Series appliance.
2. Purchase the new support license and migraon license.
3. At the me you purchase the new M-Series appliance, provide your sales representave
the serial number and device management auth-code of the Panorama virtual appliance
you are phasing out, as well as a license migraon date of your choosing. On receipt of
your M-Series appliance, register the appliance and acvate the device management
and support licenses using the migraon and support auth-codes provided by Palo Alto
Networks. On the migraon date, the device management license on the Panorama
virtual appliance is decommissioned, and you can no longer manage devices or collect
logs using the Panorama virtual appliance. However, the support license is preserved and
the Panorama appliance remains under support. You can complete the migraon aer
the eﬀecve date, but you are unable to commit any conﬁguraon changes on the now
decommissioned Panorama virtual appliance.
STEP 3 | (Legacy mode only) On the old Panorama virtual appliance, change to Panorama mode .
This step is required to preserve the log data, sengs and log forwarding conﬁguraon
of the Panorama virtual appliance. If you export the Panorama conﬁguraon while in
Legacy mode, these sengs are lost. You must complete Step 9 if you do not change
Panorama to Panorama mode before connuing.
Connue to the next step if the Panorama virtual appliance is already in Panorama or
Management Only mode.
STEP 4 | Export the Panorama conﬁguraon from the Panorama virtual appliance.
1. Log in to the Panorama virtual appliance and select Panorama > Setup > Operaons.
2. Click Save named Panorama conﬁguraon snapshot, enter a Name to idenfy the
conﬁguraon, and click OK.
3. Click Export named Panorama conﬁguraon snapshot, select the Name of the
conﬁguraon you just saved, and click OK. Panorama exports the conﬁguraon to your
client system as an XML ﬁle.
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STEP 5 | Power oﬀ the Panorama virtual appliance if you won’t need to access to it aer the migraon
or assign a new IP address to its management (MGT) interface if you will need access to it.
To power oﬀ the Panorama virtual appliance, see the documentaon for your VMware product.
To change the IP address on the Panorama virtual appliance:
1. Select Panorama > Setup > Management, and edit the Management Interface Sengs.
2. Enter the new IP Address and click OK.
3. Select Commit > Commit to Panorama and Commit your changes.
STEP 6 | Perform the inial setup of the M-Series appliance.
1. Rack mount the M-Series appliance. Refer to the M-Series Appliance Hardware
Reference Guide for instrucons.
2. Perform Inial Conﬁguraon of the M-Series Appliance to deﬁne the network
connecons required to acvate licenses and install updates.
3. Register Panorama.
4. Acvate a Panorama Support License.
5. Acvate/Retrieve a Firewall Management License on the M-Series Appliance. Use the
auth-code associated with the migraon license.
6. Install Content and Soware Updates for Panorama. Install the same versions as those on
the Panorama virtual appliance.
STEP 7 | Load the Panorama conﬁguraon snapshot that you exported from the Panorama virtual
appliance into the M-Series appliance.
The Panorama Policy rule Creaon and Modiﬁed dates are updated to reﬂect the
date you commit the imported Panorama conﬁguraon on the new Panorama. The
universially unique idenﬁer (UUID) for each policy rule persists when you migrate
the Panorama conﬁguraon.
The Creaon and Modiﬁed for managed ﬁrewalls are not impacted when you monitor
policy rule usage for a managed ﬁrewall because this data is stored locally on the
managed ﬁrewall and not on Panorama.
1. On the M-Series appliance, select Panorama > Setup > Operaons.
2. Click Import named Panorama conﬁguraon snapshot, Browse to the Panorama
conﬁguraon ﬁle you exported from the Panorama virtual appliance, and click OK.
3. Click Load named Panorama conﬁguraon snapshot, select the Name of the
conﬁguraon you just imported, select a Decrypon Key (the master key for Panorama),
and click OK. Panorama overwrites its current candidate conﬁguraon with the loaded
conﬁguraon. Panorama displays any errors that occur when loading the conﬁguraon
ﬁle.
4. If errors occurred, save them to a local ﬁle. Resolve each error to ensure the migrated
conﬁguraon is valid.
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STEP 8 | Modify the conﬁguraon on the M-Series appliance.
Required if the M-Series appliance will use diﬀerent values than the Panorama virtual
appliance. If you will maintain access to the Panorama virtual appliance to access its logs, use a
diﬀerent hostname and IP address for the M-Series appliance.
1. Select Panorama > Setup > Management.
2. Edit the General Sengs, modify the Hostname, and click OK.
3. Edit the Management Interface Sengs, modify the values as necessary, and click OK.
STEP 9 | Add the default managed collector and Collector Group back to the M-Series appliance.
Loading the conﬁguraon from the Panorama virtual appliance (Step 7) removes the default
managed collector and Collector Group that are predeﬁned on each M-Series appliance.
1. Conﬁgure a Managed Collector that is local to the M-Series appliance.
2. Conﬁgure a Collector Group for the default managed collector.
3. Select Commit > Commit to Panorama and Commit your changes to the Panorama
conﬁguraon.
STEP 10 | Synchronize the M-Series appliance with the ﬁrewalls to resume ﬁrewall management.
Complete this step during a maintenance window to minimize network disrupon.
1. On the M-Series appliance, select Panorama > Managed Devices and verify that the
Device State column displays Connected for the ﬁrewalls.
At this point, the Shared Policy (device groups) and Template columns display Out of sync
for the ﬁrewalls.
2. Push your changes to device groups and templates:
1. Select Commit > Push to Devices and Edit Selecons.
2. Select Device Groups, select every device group, Include Device and Network
Templates, and click OK.
3. Push your changes.
3. In the Panorama > Managed Devices page, verify that the Shared Policy and Template
columns display In sync for the ﬁrewalls.

Migrate a Panorama Virtual Appliance to a Diﬀerent Hypervisor
Migrate the Panorama conﬁguraon of a Panorama virtual appliance from one supported
hypervisor to another supported hypervisor in Management Only mode or Panorama mode.
Before migrang to the Panorama virtual appliance to a new hypervisor, review the Panorama
Models to ensure that the new hypervisor you are migrang to is supported. Addionally, if your
Panorama conﬁguraon has mulple interfaces conﬁguraon for device management includes
mulple interfaces for device management, log collecon, Collector Group communicaon,
licensing and soware updates, review Setup Prerequisites for the Panorama Virtual Appliance to
verify that the hypervisor you are migrang to supports mulple interfaces.
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Legacy mode is no longer supported in PAN-OS 8.1 or later releases. If the old Panorama
virtual appliance is in Legacy mode, you must change Panorama to Panorama mode before
migrang to the new hypervisor in order to preserve the log sengs and Log Collector forwarding
conﬁguraons. Imporng the conﬁguraon of the old Panorama in Legacy mode to a new
Panorama in Panorama mode causes all log and log forwarding sengs to be removed.
You cannot migrate logs from Panorama virtual appliance. Therefore, if you want to maintain
access to the logs stored on the old Panorama virtual appliance, you must connue running the
old Panorama virtual appliance in Log Collector mode aer the migraon and add it as a managed
Log Collector on the new Panorama virtual appliance. This allows the new Panorama virtual
appliance to collect the new logs that ﬁrewalls forward aer the migraon, while maintaining
access to the old log data. Aer the pre-migraon logs expire or become irrelevant due to aging,
you can shut down the Panorama virtual appliance.
If you store ﬁrewall logs on Dedicated Log Collectors (Panorama virtual appliance in Log
Collector mode) instead of on the Panorama virtual appliance, you can maintain access
to the logs by migrang the Dedicated Log Collectors to the new Panorama virtual
appliance in Panorama mode.
STEP 1 | Plan the migraon.
Upgrade the soware on the Panorama virtual appliance before the migraon if the new
Panorama virtual appliance requires a later release of the current soware. For the minimum
PAN-OS version for each hypervisor, see Panorama Hypervisor Support. For important
details about soware versions, see Panorama, Log Collector, Firewall, and WildFire Version
Compability.
Schedule a maintenance window for the migraon. Although ﬁrewalls can buﬀer logs
aer the Panorama virtual appliance goes oﬄine and then forward the logs aer the new
Panorama virtual appliance comes online, compleng the migraon during a maintenance
window minimizes the risk that logs will exceed the buﬀer capacies and be lost during the
transion between hypervisors.
Consider whether to maintain access to the old Panorama virtual appliance aer the
migraon to access exisng logs. The most eﬃcient approach is to assign a new IP address
to the old Panorama virtual appliance and reuse its old IP address for the Panorama virtual
appliance. This ensures that the old Panorama virtual appliance remains accessible and that
ﬁrewalls can point to the new Panorama virtual appliance without you reconﬁguring the
Panorama IP address on each ﬁrewall.
If you to intend to maintain access to the old Panorama virtual appliance, you must purchase
a new device management license and support license for the new Panorama virtual
appliance before you can complete the migraon successfully.
STEP 2 | (Legacy mode only) On the old Panorama virtual appliance, Set up a Panorama Virtual
Appliance in Panorama Mode.
This step is required to preserve the log sengs (Panorama > Log Sengs) on the old
Panorama virtual appliance. If you export the Panorama conﬁguraon while in Legacy
mode, these sengs are lost.
Connue to the next step if the Panorama virtual appliance is already in Panorama or
Management Only mode.
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STEP 3 | Export the Panorama conﬁguraon from the old Panorama virtual appliance.
1. Log in to the Panorama Web Interface.
2. Select Panorama > Setup > Operaons.
3. Click Export named Panorama conﬁguraon snapshot, select running-config.xml
and click OK. Panorama exports the conﬁguraon to your client system as an XML ﬁle.
4. Locate the running-config.xml ﬁle you exported and rename the XML ﬁle. This is
required to import the conﬁguraon as Panorama does not support imporng an XML
ﬁle with the name running-config.xml.
STEP 4 | Install the Panorama virtual appliance.
STEP 5 | Migrate the serial number of the old Panorama virtual appliance to the new Panorama virtual
appliance.
This step is required to migrate all subscripons and the device management license
ed to the Panorama serial number and only if you intend to shut down the old
Panorama virtual appliance. If you do intend on maintaining access to the old
Panorama virtual appliance, connue to the next step.
You have up to 90 days to shut down the old Panorama virtual appliance. Running
mulple Panorama virtual appliances with the same serial number violates the EULA.
1. Log in to the Panorama web interface of the old Panorama virtual appliance.
2. In the Dashboard, copy the Serial # of the old Panorama virtual appliance located in
the General Informaon widget.
3. Log in to the Panorama web interface of the new Panorama virtual appliance.
4. Add the serial number of the old Panorama virtual appliance to the new Panorama virtual
appliance.
1. Select Panorama > Setup > Management and edit the General Sengs.
2. Enter (paste) the Serial Number and click OK.
3. Select Commit and Commit to Panorama.
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STEP 6 | Perform the inial setup of the new Panorama virtual appliance.
1. Perform Inial Conﬁguraon of the Panorama Virtual Appliance to deﬁne the network
connecons required to acvate licenses and install updates.
2. (For maintaining access to the old Panorama virtual appliance only) Register Panorama.
3. (For maintaining access to the old Panorama virtual appliance only) Acvate a Panorama
Support License.
4. (For maintaining access to the old Panorama virtual appliance only) Acvate/Retrieve
a Firewall Management License when the Panorama Virtual Appliance is Internetconnected. Use the auth-code associated with the migraon license.
5. Install Content and Soware Updates for Panorama. Install the same versions as those on
the old Panorama virtual appliance.
This step is required before loading conﬁguraon from the old Panorama virtual
appliance. Ensure that all required content updates are installed to avoid security
outages.
6. Select Panorama > Plugins and install all plugins that were installed on the old Panorama
virtual appliance.
STEP 7 | Power oﬀ the old Panorama virtual appliance if you won’t need to access to it aer the
migraon or assign a new IP address to its management (MGT) interface if you will need
access to it.
To power oﬀ the Panorama virtual appliance, see the supported documentaon for the
hypervisor on which the old Panorama virtual appliance has been deployed.
To change the IP address on the Panorama virtual appliance:
1. On the web interface of the old Panorama virtual appliance, select Panorama > Setup >
Management, and edit the Management Interface Sengs.
2. Enter the new IP Address and click OK.
3. Select Commit > Commit to Panorama and Commit your changes.
STEP 8 | (Prisma Access) Transfer the Prisma Access license from the old Panorama virtual appliance
to the new Panorama virtual appliance.
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STEP 9 | Load the Panorama conﬁguraon snapshot that you exported from the old Panorama virtual
appliance into the new Panorama virtual appliance.
The Panorama Policy rule Creaon and Modiﬁed dates are updated to reﬂect the
date you commit the imported Panorama conﬁguraon on the new Panorama. The
universially unique idenﬁer (UUID) for each policy rule persists when you migrate
the Panorama conﬁguraon.
The Creaon and Modiﬁed for managed ﬁrewalls are not impacted when you monitor
policy rule usage for a managed ﬁrewall because this data is stored locally on the
managed ﬁrewall and not on Panorama.
1. Log in to the Panorama Web Interface of the new Panorama virtual appliance.
2. Select Panorama > Setup > Operaons.
3. Click Import named Panorama conﬁguraon snapshot, Browse to the Panorama
conﬁguraon ﬁle you exported from the Panorama virtual appliance, and click OK.
4. Click Load named Panorama conﬁguraon snapshot, select the Name of the
conﬁguraon you just imported, leave the Decrypon Key blank (empty), and click OK.
Panorama overwrites its current candidate conﬁguraon with the loaded conﬁguraon.
Panorama displays any errors that occur when loading the conﬁguraon ﬁle.
5. If errors occurred, save them to a local ﬁle. Resolve each error to ensure the migrated
conﬁguraon is valid.
STEP 10 | Modify the conﬁguraon on the new Panorama virtual appliance.
Required if the new Panorama virtual appliance will use diﬀerent values than the old Panorama
virtual appliance. If you will maintain access to the old Panorama virtual appliance to access its
logs, use a diﬀerent hostname and IP address for the new Panorama virtual appliance.
1. Select Panorama > Setup > Management.
2. Edit the General Sengs, modify the Hostname, and click OK.
3. Edit the Management Interface Sengs, modify the values as necessary, and click OK.
4. Select Commit > Commit to Panorama and Commit your changes to the Panorama
conﬁguraon.
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STEP 11 | Add the default managed collector and Collector Group to the new Panorama virtual
appliance.
Loading the conﬁguraon from the old Panorama virtual appliance (Step 7) removes the default
managed collector and Collector Group that are predeﬁned on each Panorama virtual appliance
in Panorama mode.
1. To maintain access to logs stored on the old Panorama virtual appliance, change to
Log Collector mode and add the Dedicated Log Collector to the new Panorama virtual
appliance.
1. Set Up The Panorama Virtual Appliance as a Log Collector.
2. Conﬁgure a Managed Collector.
2. Conﬁgure a Managed Collector that is local to the Panorama virtual appliance.
3. Conﬁgure a Collector Group for the default managed collector.
4. Select Commit > Commit to Panorama and Commit your changes to the Panorama
conﬁguraon.
STEP 12 | Synchronize the new Panorama virtual appliance with the ﬁrewalls to resume ﬁrewall
management.
Complete this step during a maintenance window to minimize network disrupon.
1. On the new Panorama virtual appliance, select Panorama > Managed Devices and verify
that the Device State column displays Connected for the ﬁrewalls.
At this point, the Shared Policy (device groups) and Template columns display Out of sync
for the ﬁrewalls.
2. Push your changes to device groups and templates:
1. Select Commit > Push to Devices and Edit Selecons.
2. Select Device Groups, select every device group, Include Device and Network
Templates, and click OK.
3. Push your changes.
3. In the Panorama > Managed Devices page, verify that the Shared Policy and Template
columns display In sync for the ﬁrewalls.

Migrate from an M-Series Appliance to a Panorama Virtual
Appliance
You can migrate the Panorama conﬁguraon from an M-100, M-200, M-500, M-600 appliance to
a Panorama virtual appliance in Panorama mode. However, you cannot migrate the logs because
the log format on the M-Series appliances is incompable with that on the Panorama virtual
appliances. Therefore, if you want to maintain access to the old logs stored on the M-Series
appliance, you must connue running the M-Series appliance as a Dedicated Log Collector aer
the migraon and add it to the Panorama virtual appliance as a managed collector.
If your Panorama management server is part of a high availability conﬁguraon, you must deploy
a second Panorama virtual appliance of the same hypervisor or cloud environment, and purchase

Panorama Administrator's Guide Version Version 10.1

236

©2022 Palo Alto Networks, Inc.

Set Up Panorama
the required device management and support licenses. See Panorama HA Prerequisites for a full
list of HA requirements.
STEP 1 | Plan the migraon.
Upgrade the M-Series appliance to PAN-OS 10.1 or later release before the migrang to
the Panorama virtual appliance. To upgrade Panorama, see Install Content and Soware
Updates for Panorama. For important details about soware versions, see Panorama, Log
Collector, Firewall, and WildFire Version Compability.
Schedule a maintenance window for the migraon. Although ﬁrewalls can buﬀer logs aer
the M-Series appliance goes oﬄine and then forward the logs aer the Panorama virtual
appliance comes online, compleng the migraon during a maintenance window minimizes
the risk that logs will exceed the buﬀer capacies during the transion to a diﬀerent
Panorama model.
STEP 2 | Purchase management and support licenses for the new Panorama virtual appliance.
1. Contact your sales representave to purchase the new device management and support
licenses.
2. Provide your sales representave the serial number of the M-Series appliance you
to plan phase out, the serial number and support auth code you received when you
purchased the new Panorama virtual appliance, and the date when you expect your
migraon from the old device to the new virtual appliance to be completed. Before the
migraon date, register the serial number and acvate support auth code on the new
virtual appliance so that you can begin your migraon. The capacity auth code on the old
M-Series appliance is automacally removed on the expected migraon compleon date
you provided.
STEP 3 | Perform the inial setup of the Panorama virtual appliance.
1. Set Up the Panorama Virtual Appliance.
2. Perform Inial Conﬁguraon of the Panorama Virtual Appliance to deﬁne the network
connecons required to acvate licenses and install updates.
3. Register Panorama.
4. Acvate a Panorama Support License.
5. Acvate/Retrieve a Firewall Management License when the Panorama Virtual Appliance
is Internet-connected
6. Install Content and Soware Updates for Panorama. Install the same versions as those on
the M-Series appliance.
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STEP 4 | Edit the M-Series appliance Panorama interface conﬁguraon to only use the management
interface.
The Panorama virtual appliance supports only the management interface for device
management and log collecon.
1. Log in to the Panorama Web Interface of the M-Series appliance.
2. Select Panorama > Setup > Management.
3. Edit the General Sengs, modify the Hostname, and click OK.
4. Select Interfaces and edit the Management interface to enable the required services.
5. Disable services for the remaining interfaces.
6. Select Commit > Commit to Panorama.
STEP 5 | Add the IP address of the new Panorama virtual appliance.
On the M-Series appliance, add the Public IP address of the Panorama virtual appliance as the
second Panorama Server to manage devices from the new Panorama management server. If
the Panorama virtual appliance is deployed on Alibaba Cloud, AWS, Azure, GCP, or OCI, use
the public IP address.
1. Select Device > Setup.
2. In the Template context drop-down, select the template or template stack containing the
Panorama server conﬁguraon.
3. Edit the Panorama Sengs.
4. Enter the Panorama virtual appliance public IP address and click OK.
5. Select Commit > Commit and Push.
STEP 6 | Export the conﬁguraon from the M-Series appliance.
1. Select Panorama > Setup > Operaons.
2. Click Save named Panorama conﬁguraon snapshot, enter a Name to idenfy the
conﬁguraon, and click OK.
3. Click Export named Panorama conﬁguraon snapshot, select the Name of the
conﬁguraon you just saved, and click OK. Panorama exports the conﬁguraon to
your client system as an XML ﬁle. Save the conﬁguraon to a locaon external to the
Panorama appliance.
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STEP 7 | Power oﬀ the M-Series appliance or assign a new IP address to the management (MGT)
interface.
If the M-Series appliance is in Panorama mode and has logs stored on the local Log
Collector that you need access on the new Panorama virtual appliance, you must
change the IP address on the M-Series appliance in order to add it to the Panorama
virtual appliance as a managed Log Collector.
• To Power oﬀ the M-Series appliance:
1. Log in to the Panorama web interface.
2. Select Panorama > Setup > Operaons, and under Device Operaons, Shutdown
Panorama. Click Yes to conﬁrm the shutdown.
• To change the IP address on the M-Series appliance:
1. Log in to the Panorama web interface.
2. Select Panorama > Setup > Management, and edit the Management Interface Sengs.
3. Enter the new IP Address and click OK.
4. Select Commit > Commit to Panorama and Commit your changes.
STEP 8 | Load the Panorama conﬁguraon snapshot that you exported from the M-Series appliance
into the Panorama virtual appliance.
The Panorama Policy rule Creaon and Modiﬁed dates are updated to reﬂect the
date you commit the imported Panorama conﬁguraon on the new Panorama. The
universially unique idenﬁer (UUID) for each policy rule persists when you migrate
the Panorama conﬁguraon.
The Creaon and Modiﬁed for managed ﬁrewalls are not impacted when you monitor
policy rule usage for a managed ﬁrewall because this data is stored locally on the
managed ﬁrewall and not on Panorama.
1. Log in to the Panorama web interface of the Panorama virtual appliance, and select
Panorama > Setup > Operaons.
2. Click Import named Panorama conﬁguraon snapshot, Browse to the Panorama
conﬁguraon ﬁle you exported from the M-Series appliance, and click OK.
3. Click Load named Panorama conﬁguraon snapshot, select the Name of the
conﬁguraon you just imported, select a Decrypon Key (the master key for Panorama),
and click OK. Panorama overwrites its current candidate conﬁguraon with the loaded
conﬁguraon. Panorama displays any errors that occur when loading the conﬁguraon
ﬁle.
If errors occurred, save them to a local ﬁle. Resolve each error to ensure the migrated
conﬁguraon is valid. The conﬁguraon has been loaded once the commit is successful.
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STEP 9 | Change the M-Series appliance to Log Collector mode to preserve exisng log data.
Logging data is erased if you change to Log Collector mode while the logging disks are
sll inserted in the M-Series appliance. Logging disks must be removed before changing
mode to avoid log data loss.
Generang the metadata for each disk pair rebuilds the indexes. Therefore, depending
on the data size, this process can take a long me to complete. To expedite the process,
you can launch mulple CLI sessions and run the metadata regeneraon command
in each session to complete the process simultaneously for every pair. For details, see
Regenerate Metadata for M-Series Appliance RAID Pairs.
1. Remove the RAID disks from the old M-Series appliance.
1. Power oﬀ the M-Series appliance by pressing the Power buon unl the system shuts
down.
2. Remove the disk pairs. For details, refer to the disk replacement procedure in the MSeries Appliance Hardware Reference Guides.
2. Power on the M-Series appliance by pressing the Power buon.
3. Conﬁgure an admin superuser administrator account.
If an admin administrator account already is already created, connue to the next step.
An admin account with superuser privileges must be created before you
switch to Log Collector mode or you lose access to the M-Series appliance aer
switching modes.
4. Log in to the Panorama CLI on the old M-Series appliance.
5. Switch from Panorama mode to Log Collector mode.
• Switch to Log Collector mode by entering the following command:
> request system system-mode logger
• Enter Y to conﬁrm the mode change. The M-Series appliance reboots. If the reboot
process terminates your terminal emulaon soware session, reconnect to the MSeries appliance to see the Panorama login prompt.
If you see a CMS Login prompt, this means the Log Collector has not
ﬁnished reboong. Press Enter at the prompt without typing a username or
password.
• Log back in to the CLI.
• Verify that the switch to Log Collector mode succeeded:
> show system info | match system-mode
If the mode change succeeded, the output displays:

Panorama Administrator's Guide Version Version 10.1

240

©2022 Palo Alto Networks, Inc.

Set Up Panorama
> system-mode: logger
6. Insert the disks back into the old M-Series appliance. For details, refer to the disk
replacement procedure in the M-Series Appliance Hardware Reference Guides.
You must maintain the disk pair associaon. Although you can place a disk pair from
slot A1/A2 on the into slot B1/B2, you must keep the disks together in the same slot;
otherwise, Panorama might not restore the data successfully.
7. Enable the disk pairs by running the following CLI command for each pair:
> request system raid add <slot> force no-format
For example:
> request system raid add A1 force no-format
> request system raid add A2 force no-format
The force and no-format arguments are required. The force argument associates the disk
pair with the new appliance. The no-format argument prevents reformang of the drives
and retains the logs stored on the disks.
8. Generate the metadata for each disk pair.
> request metadata-regenerate slot <slot_number>
For example:
> request metadata-regenerate slot 1
9. Enable connecvity between the Log Collector and Panorama management server.
Enter the following commands at the Log Collector CLI, where <IPaddress1> is for the
MGT interface of the solitary (non-HA) or acve (HA) Panorama and <IPaddress2> is for
the MGT interface of the passive (HA) Panorama, if applicable.
> configure
# set deviceconfig system panorama-server <IPaddress1>
panorama-server-2 <IPaddress2>
# commit
# exit
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STEP 10 | Synchronize the Panorama virtual appliance with the ﬁrewalls to resume ﬁrewall
management.
Complete this step during a maintenance window to minimize network disrupon.
1. On the Panorama virtual appliance, select Panorama > Managed Devices and verify that
the Device State column displays the ﬁrewalls as Connected.
At this point, the Shared Policy (device groups) and Template columns display Out of sync
for the ﬁrewalls.
2. Push your changes to device groups and templates:
1. Select Commit > Push to Devices and Edit Selecons.
2. Select Device Groups, select every device group, and Include Device and Network
Templates.
3. Select Collector Groups, select every collector group, and click OK.
4. Push your changes.
3. In the Panorama > Managed Devices page, verify that the Shared Policy and Template
columns display In sync for the ﬁrewalls.
STEP 11 | (HA only) Set up the Panorama HA peer.
If the Panorama management servers are in a high availability conﬁguraon, perform the steps
below on the HA peer.
1. Perform the inial setup of the Panorama virtual appliance.
2. Edit the M-Series appliance Panorama interface conﬁguraon to only use the
management interface.
3. Add the IP address of the new Panorama virtual appliance.
4. Power oﬀ the M-Series appliance or assign a new IP address to the management (MGT)
interface.
5. Change the M-Series appliance to Log Collector mode to preserve exisng log data.
STEP 12 | (HA only) Modify the Panorama virtual appliance HA peer conﬁguraon.
1. On an HA peer, Log in to the Panorama Web Interface, select Panorama > High
Availability and edit the Setup.
2. In the Peer HA IP Address ﬁeld, enter the new IP address of the HA peer and click OK.
3. Select Commit > Commit to Panorama and Commit your change
4. Repeat these steps on the other peer in the HA peer.
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STEP 13 | (HA only) Synchronize the Panorama peers.
1. Access the Dashboard on one of the HA peers and select Widgets > System > High
Availability to display the HA widget.
2. Sync to peer, click Yes, and wait for the Running Conﬁg to display Synchronized.
3. Access the Dashboard on the remaining HA peer and select Widgets > System > High
Availability to display the HA widget.
4. Verify that the Running Conﬁg displays Synchronized.

Migrate from an M-100 Appliance to an M-500 Appliance
You can migrate the Panorama conﬁguraon and ﬁrewall logs from an M-100 appliance to an
M-500 appliance in Panorama mode (Panorama management server). You can also migrate the
ﬁrewall logs from an M-100 appliance to an M-500 appliance in Log Collector mode (Dedicated
Log Collector). Because all the Log Collectors in a Collector Group must be the same Panorama
model, you must migrate all or none of the M-100 appliances in any Collector Group.
In the following procedure, the Panorama management server is deployed in an acve/passive
high availability (HA) conﬁguraon, you will migrate both the conﬁguraon and logs, and the
M-500 appliances will reuse the IP addresses from the M-100 appliances.
This procedure assumes you are no longer using the M-100 for device management or
log collecon. If you plan on using the decommissioned M-100 appliance as a Dedicated
Log Collector, a device management license is required on the M-100. Without a device
management license, you are unable to use the M-100 as a Dedicated Log Collector.
If you do not plan on using the M-100 appliance as a Dedicated Log Collector, but the
M-100 appliance contains log data that you must access at a later date, you may sll
query and generate reports using the exisng log data. Palo Alto Networks recommends
reviewing the log retenon policy before decommissioning the M-100 appliance.
If you will migrate only the logs and not the Panorama conﬁguraon, perform the task
Migrate Logs to a New M-Series Appliance in Log Collector Mode or Migrate Logs to
a New M-Series Appliance in Panorama Mode.
If you will migrate to a new Panorama management server that is not deployed in an
HA conﬁguraon and the new Panorama must access logs on exisng Dedicated Log
Collectors, perform the task Migrate Log Collectors aer Failure/RMA of Non-HA
Panorama.
STEP 1 | Plan the migraon.
• Upgrade the soware on the M-100 appliance if its current release is earlier than 7.0;
the M-500 appliance requires Panorama 7.0 or a later release. For important details
about soware versions, see Panorama, Log Collector, Firewall, and WildFire Version
Compability.
• Forward the System and Conﬁg logs that Panorama and Log Collectors generate to an
external desnaon before the migraon if you want to preserve those logs. The M-Series
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appliance in Panorama mode stores these log types on its SSD, which you cannot move
between models. You can move only the RAID drives, which store ﬁrewall logs.
• Schedule a maintenance window for the migraon. Although ﬁrewalls can buﬀer logs aer
the M-100 appliance goes oﬄine and then forward the logs aer the M-500 appliance
comes online, compleng the migraon during a maintenance window minimizes the
risk that logs will exceed the buﬀer capacies and be lost during the transion between
Panorama models.
STEP 2 | Purchase the new M-500 appliance, and migrate your subscripons to the new appliance.
1. Purchase the new M-500 appliance.
2. Purchase the new support license and migraon license.
3. At the me you purchase the new M-500 appliance, provide your sales representave
the serial number and device management auth-code of the M-100 appliance you
are phasing out, as well as a license migraon date of your choosing. On receipt of
your M-500 appliance, register the appliance and acvate the device management
and support licenses using the migraon and support auth-codes provided by Palo
Alto Networks. On the migraon date, the device management license on the M-100
is decommissioned, and you can no longer manage devices or collect logs using the
M-100 appliance. However, the support license is preserved and the Panorama appliance
remains under support. You can complete the migraon aer the eﬀecve date, but you
are unable to commit any conﬁguraon changes on the now decommissioned M-100
appliance.
STEP 3 | Export the Panorama conﬁguraon from each M-100 appliance in Panorama mode.
Perform this task on each M-100 appliance HA peer:
1. Log in to the M-100 appliance and select Panorama > Setup > Operaons.
2. Click Save named Panorama conﬁguraon snapshot, enter a Name to idenfy the
conﬁguraon, and click OK.
3. Click Export named Panorama conﬁguraon snapshot, select the Name of the
conﬁguraon you just saved, and click OK. Panorama exports the conﬁguraon to your
client system as an XML ﬁle.
STEP 4 | Power oﬀ each M-100 appliance in Panorama mode.
1. Log in to the M-100 appliance HA peer that you will power oﬀ.
2. Select Panorama > Setup > Operaons, and click Shutdown Panorama.
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STEP 5 | Perform the inial setup of each M-500 appliance.
1. Rack mount the M-500 appliances. Refer to the M-500 Appliance Hardware Reference
Guide for instrucons.
2. Perform Inial Conﬁguraon of the M-Series Appliance to deﬁne the network
connecons required to acvate licenses and install updates.
3. Register Panorama.
4. Acvate a Panorama Support License.
5. Acvate a ﬁrewall management license. Use the auth-code associated with the migraon
license.
6. Install Content and Soware Updates for Panorama. Install the same versions as those on
the M-100 appliance.
7. (Dedicated Log Collector only) Set Up the M-Series Appliance as a Log Collector.
STEP 6 | Load the Panorama conﬁguraon snapshot that you exported from each M-100 appliance
into each M-500 appliance in Panorama mode (both HA peers).
The Panorama Policy rule Creaon and Modiﬁed dates are updated to reﬂect the
date you commit the imported Panorama conﬁguraon on the new Panorama. The
universially unique idenﬁer (UUID) for each policy rule persists when you migrate
the Panorama conﬁguraon.
The Creaon and Modiﬁed for managed ﬁrewalls are not impacted when you monitor
policy rule usage for a managed ﬁrewall because this data is stored locally on the
managed ﬁrewall and not on Panorama.
Perform this task on each M-500 appliance HA peer:
1. Log in to the M-500 appliance and select Panorama > Setup > Operaons.
2. Click Import named Panorama conﬁguraon snapshot, Browse to the conﬁguraon
ﬁle you exported from the M-100 appliance that has the same HA priority (primary or
secondary) as the M-500 appliance will have, and click OK.
3. Click Load named Panorama conﬁguraon snapshot, select the Name of the
conﬁguraon you just imported, select a Decrypon Key (the master key for Panorama),
and click OK. Panorama overwrites its current candidate conﬁguraon with the loaded
conﬁguraon. Panorama displays any errors that occur when loading the conﬁguraon
ﬁle. If errors occurred, save them to a local ﬁle. Resolve each error to ensure the
migrated conﬁguraon is valid.
4. Select Commit > Commit to Panorama and Validate Commit. Resolve any errors before
proceeding.
5. Commit your changes to the Panorama conﬁguraon.
STEP 7 | Synchronize the conﬁguraon between the M-500 appliance HA peers in Panorama mode.
1. On the acve M-500 appliance, select the Dashboard tab and, in the High Availability
widget, click Sync to peer.
2. In the High Availability widget, verify that the Local (primary M-500 appliance) is acve,
the Peer is passive, and the Running Conﬁg is synchronized.

Panorama Administrator's Guide Version Version 10.1

245

©2022 Palo Alto Networks, Inc.

Set Up Panorama
STEP 8 | Move the RAID drives from each M-100 appliance to its replacement M-500 appliance to
migrate the logs collected from ﬁrewalls.
In the following tasks, skip any steps that you already completed on the M-500 appliance.
• Migrate Logs to a New M-Series Appliance in Panorama Mode. Migrate logs from the
M-100 appliance only if it uses a default managed collector for log collecon.
• Migrate Logs to a New M-Series Appliance in Log Collector Mode.
STEP 9 | Synchronize the acve M-500 appliance in Panorama mode with the ﬁrewalls to resume
ﬁrewall management.
Complete this step during a maintenance window to minimize network disrupon.
1. In the acve M-500 appliance, select Panorama > Managed Devices, and verify that the
Device State column displays Connected for the ﬁrewalls.
At this point, the Shared Policy (device groups) and Template columns display Out of sync
for the ﬁrewalls.
2. Push your changes to device groups and templates:
1. Select Commit > Push to Devices and Edit Selecons.
2. Select Device Groups, select every device group, Include Device and Network
Templates, and click OK.
3. Push your changes.
3. In the Panorama > Managed Devices page, verify that the Shared Policy and Template
columns display In sync for the ﬁrewalls.
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Access and Navigate Panorama Management Interfaces
Panorama provides three management interfaces:
• Web interface—The Panorama web interface has a look and feel similar to the ﬁrewall web
interface. If you are familiar with the laer, you can easily navigate, complete administrave
tasks, and generate reports from the Panorama web interface. This graphical interface enables
you to access Panorama using HTTPS and it is the best way to perform administrave tasks.
See Log in to the Panorama Web Interface and Navigate the Panorama Web Interface. If you
need to enable HTTP access to Panorama, edit the Management Interface Sengs on the
Panorama > Setup > Management tab.
• Command line interface (CLI)—The CLI is a no-frills interface that allows you to type commands
in rapid succession to complete a series of tasks. The CLI supports two command modes—
operaonal and conﬁguraon—and each has its own hierarchy of commands and statements.
When you become familiar with the nesng structure and the syntax for the commands, the
CLI enables quick response mes and administrave eﬃciency. See Log in to the Panorama CLI.
• XML API—The XML-based API is provided as a web service that is implemented using HTTP/
HTTPS requests and responses. It enables you to streamline your operaons and integrate with
exisng, internally developed applicaons and repositories. For details on using the Panorama
API, refer to the PAN-OS and Panorama XML API Usage Guide.

Log in to the Panorama Web Interface
STEP 1 | Launch an internet browser and enter the Panorama IP address using a secure connecon
(hps://<IP address>).
STEP 2 | Log in to Panorama according to the type of authencaon used for your account. If logging
in to Panorama for the ﬁrst me, use the default value admin for your username and
password.
• SAML—Click Use Single Sign-On (SSO). If Panorama performs authorizaon (role
assignment) for administrators, enter your Username and Connue. If the SAML identy
provider (IdP) performs authorizaon, Connue without entering a Username. In both cases,
Panorama redirects you to the IdP, which prompts you to enter a username and password.
Aer you authencate to the IdP, the Panorama web interface displays.
• Any other type of authencaon—Enter your user Name and Password. Read the login
banner and select I Accept and Acknowledge the Statement Below if the login page has the
banner and check box. Then click Login.
STEP 3 | Read and Close any messages of the day.

Navigate the Panorama Web Interface
Use the Panorama web interface to conﬁgure Panorama, manage and monitor ﬁrewalls, Log
Collectors, and WildFire appliances and appliance clusters, and access the web interface of each
ﬁrewall through the Context drop-down. Refer to the Panorama online help for details on the
opons and ﬁelds in each web interface tab. The following is an overview of the tabs:
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Tab

Descripon

Dashboard

View general informaon about the Panorama model and network
access sengs. This tab includes widgets that display informaon
about applicaons, logs, system resources, and system sengs.

ACC

View the overall risk and threat level on the network, based on
informaon that Panorama gathered from the managed ﬁrewalls.

Monitor

View and manage logs and reports.

Device Groups > Policies

Create centralized policy rules and apply them to mulple
ﬁrewalls/device groups.
You must Add a Device Group for this tab to display.

Device Groups > Objects

Deﬁne policy objects that policy rules can reference and that
managed ﬁrewalls/device groups can share.
You must Add a Device Group for this tab to display.

Templates > Network

Conﬁgure network seng, such as network proﬁles, and apply
them to mulple ﬁrewalls.
You must Add a Template for this tab to display.

Templates > Device

Conﬁgure device sengs, such as server proﬁles and admin roles,
and apply them to mulple ﬁrewalls.
You must Add a Template for this tab to display.

Panorama

Conﬁgure Panorama, manage licenses, set up high availability,
access soware updates and security alerts, manage administrave
access, and manage the deployed ﬁrewalls, Log Collectors, and
WildFire appliances and appliance clusters.

Log in to the Panorama CLI
You can log in to the Panorama CLI using a serial port connecon or remotely using a Secure Shell
(SSH) client.
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Use SSH to log in to the Panorama CLI.
The same instrucons apply to an M-Series appliance in Log Collector mode.
Oponally, you can Conﬁgure an Administrator with SSH Key-Based
Authencaon for the CLI.
1. Ensure the following prerequisites are met:
• You have a computer with network access to Panorama.
• You know the Panorama IP address.
• The Management interface supports SSH, which is the default seng. If an
administrator disabled SSH and you want to re-enable it: select Panorama > Setup
> Interfaces, click Management, select SSH, click OK, select Commit > Commit to
Panorama, and Commit your changes to the Panorama conﬁguraon.
2. To access the CLI using SSH:
1. Enter the Panorama IP address in the SSH client and use port 22.
2. Enter your administrave access credenals when prompted. Aer you log in, the
message of the day displays, followed by the CLI prompt in Operaonal mode. For
example:
admin@ABC_Sydney>
Use a serial port connecon to log in to the Panorama CLI.
1. Make sure that you have the following:
• A null-modem serial cable that connects Panorama to a computer with a DB-9 serial
port
• A terminal emulaon program running on the computer
2. Use the following sengs in the terminal emulaon soware to connect: 9600 baud; 8
data bits; 1 stop bit; No parity; No hardware ﬂow control.
3. Enter your administrave access credenals when prompted. Aer you log in, the
message of the day displays, followed by the CLI prompt in Operaonal mode.
Change to Conﬁguraon mode.
To switch to Conﬁguraon mode, enter the following command at the prompt:
admin@ABC_Sydney> configure
The prompt changes to admin@ABC_Sydney#.
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Set Up Administrave Access to Panorama
Panorama implements Role-Based Access Control (RBAC) to enable you to specify the privileges
and responsibilies of administrators. The following topics describe how to create administrator
roles, access domains, and accounts for accessing the Panorama web interface and command line
interface (CLI):
• Conﬁgure an Admin Role Proﬁle
• Conﬁgure an Access Domain
• Conﬁgure Administrave Accounts and Authencaon
• Conﬁgure Tracking of Administrator Acvity

Conﬁgure an Admin Role Proﬁle
Admin Role proﬁles are custom Administrave Roles that enable you to deﬁne granular
administrave access privileges to ensure protecon for sensive company informaon and
privacy for end users. As a best pracce, create Admin Role proﬁles that allow administrators to
access only the areas of the management interfaces required to perform their jobs.
STEP 1 | Select Device > Admin Roles and select the Template in which to conﬁgure a ﬁrewall admin
role proﬁle.
You must create an Admin Role proﬁle on the ﬁrewall and assign it to the Panorama
management server Admin Role proﬁle to allow administrators to context switch between
Panorama and managed ﬁrewall web interfaces.
STEP 2 | Select Panorama > Admin Roles and click Add.
STEP 3 | Enter a Name for the proﬁle and select the Role type: Panorama or Device Group and
Template.
STEP 4 | Conﬁgure access privileges to each funconal area of Panorama (Web UI) by toggling the
icons to the desired seng: Enable (read-write), Read Only, or Disable.
If administrators with custom roles will commit device group or template changes to
managed ﬁrewalls, you must give those roles read-write access to Panorama > Device
Groups and Panorama > Templates. If you upgrade from an earlier Panorama version,
the upgrade process provides read-only access to those nodes.
STEP 5 | If the Role type is Panorama, conﬁgure access to the XML API by toggling the Enabled/
Disabled icon for each funconal area.
STEP 6 | If the Role type is Panorama, select an access level for the Command Line interface: None
(default), superuser, superreader, or panorama-admin.
STEP 7 | (Oponal) To allow Panorama administrators to Context Switch between the Panorama and
ﬁrewall web interface, enter the name of Device Admin Role you conﬁgured in Step 1.
STEP 8 | Click OK to save the proﬁle.
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Conﬁgure an Access Domain
Use Access Domains to deﬁne access for Device Group and Template administrators for speciﬁc
device groups and templates, and also to control the ability of those administrators to switch
context to the web interface of managed ﬁrewalls. Panorama supports up to 4,000 access
domains.
STEP 1 | Select Panorama > Access Domain and click Add.
STEP 2 | Enter a Name to idenfy the access domain.
STEP 3 | Select an access privilege for Shared Objects:
• write—Administrators can perform all operaons on Shared objects. This is the default
value.
• read—Administrators can display and clone but cannot perform other operaons on Shared
objects. When adding non-Shared objects or cloning Shared objects, the desnaon must
be a device group within the access domain, not the Shared locaon.
• shared-only—Administrators can add objects only to the Shared locaon. Administrators
can display, edit, and delete Shared objects but cannot move or clone them.
A consequence of this opon is that administrators can’t perform any operaons
on non-Shared objects other than to display them. An example of why you might
select this opon is for an organizaon that requires all objects to be in a single, global
repository.
STEP 4 | Toggle the icons in the Device Groups tab to enable read-write or read-only access for device
groups in the access domain.
If you set the Shared Objects access to shared-only, Panorama applies read-only
access to the objects in any device groups for which you specify read-write access.
STEP 5 | Select the Templates tab and Add each template you want to assign to the access domain.
STEP 6 | Select the Device Context tab, select ﬁrewalls to assign to the access domain, and click OK.
Administrators can access the web interface of these ﬁrewalls by using the Context dropdown in Panorama.

Conﬁgure Administrave Accounts and Authencaon
If you have already conﬁgured an authencaon proﬁle or you don’t require one to authencate
administrators, you are ready to Conﬁgure a Panorama Administrator Account. Otherwise,
perform one of the other procedures listed below to conﬁgure administrave accounts for speciﬁc
types of authencaon.
• Conﬁgure a Panorama Administrator Account
• Conﬁgure Local or External Authencaon for Panorama Administrators
• Conﬁgure a Panorama Administrator with Cerﬁcate-Based Authencaon for the Web
Interface
• Conﬁgure an Administrator with SSH Key-Based Authencaon for the CLI
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• Conﬁgure RADIUS Authencaon for Panorama Administrators
• Conﬁgure TACACS+ Authencaon for Panorama Administrators
• Conﬁgure SAML Authencaon for Panorama Administrators

Conﬁgure a Panorama Administrator Account
Administrave accounts specify Administrave Roles and authencaon for Panorama
administrators. The service that you use to assign roles and perform authencaon determines
whether you add the accounts on Panorama, on an external server, or both (see Administrave
Authencaon). For an external authencaon service, you must conﬁgure an authencaon
proﬁle before adding an administrave account (see Conﬁgure Administrave Accounts
and Authencaon). If you already conﬁgured the authencaon proﬁle or you will use the
authencaon mechanism that is local to Panorama, perform the following steps to add an
administrave account on Panorama.
STEP 1 | Modify the number of supported administrator accounts.
Conﬁgure the total number of supported concurrent administrave accounts sessions for
Panorama in the normal operaonal mode or in FIPS-CC mode. You can allow up to four
concurrent administrave account sessions or conﬁgure Panorama to support an unlimited
number of concurrent administrave account sessions.
1. Select Panorama > Setup > Management and edit the Authencaon Sengs.
2. Edit the Max Session Count to specify the number of supported concurrent sessions
(range is 0 to 4) allowed for all administrator and user accounts.
Enter 0 to conﬁgure Panorama to support an unlimited number of administrave
accounts.
3. Edit the Max Session Time in minutes for an administrave account. Default is 720
minutes.
4. Click OK.
5. Commit and Commit to Panorama.
You can also conﬁgure the total number of supported concurrent sessions by logging in
to the Panorama CLI.
admin> configure
admin# set deviceconfig setting management admin-session
max-session-count <0-4>
admin# set deviceconfig setting management admin-session
max-session-time <0, 60-1499>
admin# commit
STEP 2 | Select Panorama > Administrators and Add an account.
STEP 3 | Enter a user Name for the administrator.
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STEP 4 | Select an Authencaon Proﬁle or sequence if you conﬁgured either for the administrator.
This is required if Panorama will use Kerberos SSO or an external service for authencaon.
If Panorama will use local authencaon, set the Authencaon Proﬁle to None and enter a
Password and then Conﬁrm Password.
STEP 5 | Select the Administrator Type:
• Dynamic—Select a predeﬁned administrator role.
• Custom Panorama Admin—Select the Admin Role Proﬁle you created for this administrator
(see Conﬁgure an Admin Role Proﬁle).
• Device Group and Template Admin—Map access domains to administrave roles as
described in the next step.
STEP 6 | (Device Group and Template Admin only) In the Access Domain to Administrator Role
secon, click Add, select an Access Domain from the drop-down (see Conﬁgure an Access
Domain), click the adjacent Admin Role cell, and select an Admin Role proﬁle.
STEP 7 | Click OK to save your changes.
STEP 8 | Select Commit > Commit to Panorama and Commit your changes.

Conﬁgure Local or External Authencaon for Panorama Administrators
You can use an external authencaon service or the service that is local to Panorama to
authencate administrators who access Panorama. These authencaon methods prompt
administrators to respond to one or more authencaon challenges, such as a login page for
entering a username and password.
If you use an external service to manage both authencaon and authorizaon (role and
access domain assignments), see:
• Conﬁgure RADIUS Authencaon for Panorama Administrators
• Conﬁgure TACACS+ Authencaon for Panorama Administrators
• Conﬁgure SAML Authencaon for Panorama Administrators
To authencate administrators without a challenge-response mechanism, you can
Conﬁgure a Panorama Administrator with Cerﬁcate-Based Authencaon for the
Web Interface and Conﬁgure an Administrator with SSH Key-Based Authencaon
for the CLI.
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STEP 1 | (External authencaon only) Enable Panorama to connect to an external server for
authencang administrators.
1. Select Panorama > Server Proﬁles, select the service type (RADIUS, TACACS+, SAML,
LDAP, or Kerberos), and conﬁgure a server proﬁle:
• Conﬁgure RADIUS Authencaon for Panorama Administrators.
You can use a RADIUS server to support RADIUS authencaon services or
mul-factor authencaon(MFA) services.
• Conﬁgure TACACS+ Authencaon for Panorama Administrators.
• Add a SAML IdP server proﬁle. You cannot combine Kerberos single sign-on (SSO)
with SAML SSO; you can use only one type of SSO service.
• Add a Kerberos server proﬁle.
• Add a LDAP Server Proﬁle.
STEP 2 | (Oponal) Deﬁne password complexity and expiraon sengs if Panorama uses local
authencaon.
These sengs help protect Panorama against unauthorized access by making it harder for
aackers to guess passwords.
1. Deﬁne global password complexity and expiraon sengs for all local administrators.
1. Select Panorama > Setup > Management and edit the Minimum Password Complexity
sengs.
2. Select Enabled.
3. Deﬁne the password sengs and click OK.
2. Deﬁne a Password Proﬁle.
You assign the proﬁle to administrator accounts for which you want to override the
global password expiraon sengs.
1. Select Panorama > Password Proﬁles and Add a proﬁle.
2. Enter a Name to idenfy the proﬁle.
3. Deﬁne the password expiraon sengs and click OK.
STEP 3 | (Kerberos SSO only) Create a Kerberos keytab.
A keytab is a ﬁle that contains Kerberos account informaon for Panorama. To support
Kerberos SSO, your network must have a Kerberos infrastructure.
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STEP 4 | Conﬁgure an authencaon proﬁle.
If your administrave accounts are stored across mulple types of servers, you
can create an authencaon proﬁle for each type and add all the proﬁles to an
authencaon sequence.
In the authencaon proﬁle, specify the Type of authencaon service and related sengs:
• External service—Select the Type of external service and select the Server Proﬁle you
created for it.
• Local authencaon—Set the Type to None.
• Kerberos SSO—Specify the Kerberos Realm and Import the Kerberos Keytab you created.
STEP 5 | (Device group and template administrators only) Conﬁgure an Access Domain.
Conﬁgure one or more access domains.
STEP 6 | (Custom roles only) Conﬁgure an Admin Role Proﬁle.
Conﬁgure one or more Admin Role proﬁles.
For custom Panorama administrators, the proﬁle deﬁnes access privileges for the account. For
device group and template administrators, the proﬁle deﬁnes access privileges for one or more
access domains associated with the account.
STEP 7 | Conﬁgure an administrator.
1. Conﬁgure a Panorama Administrator Account.
• Assign the Authencaon Proﬁle or sequence that you conﬁgured.
• (Device Group and Template Admin only) Map the access domains to Admin Role
proﬁles.
• (Local authencaon only) Select a Password Proﬁle if you conﬁgured one.
2. Select Commit > Commit to Panorama and Commit your changes.
3. (Oponal) Test authencaon server connecvity to verify that Panorama can use the
authencaon proﬁle to authencate administrators.

Conﬁgure a Panorama Administrator with Cerﬁcate-Based Authencaon for the
Web Interface
As a more secure alternave to password-based authencaon to the Panorama web interface,
you can conﬁgure cerﬁcate-based authencaon for administrator accounts that are local to
Panorama. Cerﬁcate-based authencaon involves the exchange and veriﬁcaon of a digital
signature instead of a password.
Conﬁguring cerﬁcate-based authencaon for any administrator disables the username/
password logins for all administrators on Panorama and all administrators thereaer
require the cerﬁcate to log in.
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STEP 1 | Generate a cerﬁcate authority (CA) cerﬁcate on Panorama.
You will use this CA cerﬁcate to sign the client cerﬁcate of each administrator.
Create a self-signed root CA cerﬁcate.
Alternavely, you can import a cerﬁcate from your enterprise CA.
STEP 2 | Conﬁgure a cerﬁcate proﬁle for securing access to the web interface.
1. Select Panorama > Cerﬁcate Management > Cerﬁcate Proﬁle and click Add.
2. Enter a Name for the cerﬁcate proﬁle and set the Username Field to Subject.
3. Select Add in the CA Cerﬁcates secon and select the CA Cerﬁcate you just created.
4. Click OK to save the proﬁle.
STEP 3 | Conﬁgure Panorama to use the cerﬁcate proﬁle for authencang administrators.
1. Select the Panorama > Setup > Management and edit the Authencaon Sengs.
2. Select the Cerﬁcate Proﬁle you just created and click OK.
STEP 4 | Conﬁgure the administrator accounts to use client cerﬁcate authencaon.
Conﬁgure a Panorama Administrator Account for each administrator who will access the
Panorama web interface. Select the Use only client cerﬁcate authencaon (Web) check box.
If you have already deployed client cerﬁcates that your enterprise CA generated, skip to Step
8. Otherwise, connue with Step 5.
STEP 5 | Generate a client cerﬁcate for each administrator.
Generate a cerﬁcate on Panorama. In the Signed By drop-down, select the CA cerﬁcate you
created.
STEP 6 | Export the client cerﬁcates.
1. Export the cerﬁcates.
2. Select Commit > Commit to Panorama and Commit your changes.
Panorama restarts and terminates your login session. Thereaer, administrators can
access the web interface only from client systems that have the client cerﬁcate you
generated.
STEP 7 | Import the client cerﬁcate into the client system of each administrator who will access the
web interface.
Refer to your web browser documentaon as needed to complete this step.

Panorama Administrator's Guide Version Version 10.1

256

©2022 Palo Alto Networks, Inc.

Set Up Panorama
STEP 8 | Verify that administrators can access the web interface.
1. Open the Panorama IP address in a browser on the computer that has the client
cerﬁcate.
2. When prompted, select the cerﬁcate you imported and click OK. The browser displays
a cerﬁcate warning.
3. Add the cerﬁcate to the browser excepon list.
4. Click Login. The web interface should appear without prompng you for a username or
password.

Conﬁgure an Administrator with SSH Key-Based Authencaon for the CLI
For administrators who use Secure Shell (SSH) to access the Panorama CLI, SSH keys provide a
more secure authencaon method than passwords. SSH keys almost eliminate the risk of bruteforce aacks, provide the opon for two-factor authencaon (private key and passphrase), and
don’t send passwords over the network. SSH keys also enable automated scripts to access the CLI.
STEP 1 | Use an SSH key generaon tool to create an asymmetric key pair on the client system of the
administrator.
The supported key formats are IETF SECSH and Open SSH. The supported algorithms are DSA
(1024 bits) and RSA (768-4096 bits).
For the commands to generate the key pair, refer to your SSH client documentaon.
The public key and private key are separate ﬁles. Save both to a locaon that Panorama can
access. For added security, enter a passphrase to encrypt the private key. Panorama prompts
the administrator for this passphrase during login.
STEP 2 | Conﬁgure the administrator account to use public key authencaon.
1. Conﬁgure a Panorama Administrator Account.
• Conﬁgure one of two authencaon methods to use as a fallback if SSH key
authencaon fails:
External authencaon service—Select an Authencaon Proﬁle.
Local authencaon—Set the Authencaon Proﬁle to None and enter a Password
and Conﬁrm Password.
• Select the Use Public Key Authencaon (SSH) check box, click Import Key, Browse
to the public key you just generated, and click OK.
2. Click OK to save the administrave account.
3. Select Commit > Commit to Panorama and Commit your changes.
STEP 3 | Conﬁgure the SSH client to use the private key to authencate to Panorama.
Perform this task on the client system of the administrator. Refer to your SSH client
documentaon as needed to complete this step.
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STEP 4 | Verify that the administrator can access the Panorama CLI using SSH key authencaon.
1. Use a browser on the client system of the administrator to go to the Panorama IP
address.
2. Log in to the Panorama CLI as the administrator. Aer entering a username, you will see
the following output (the key value is an example):
Authenticating with public key “dsa-key-20130415”
3. If prompted, enter the passphrase you deﬁned when creang the keys.

Conﬁgure RADIUS Authencaon for Panorama Administrators
You can use a RADIUS server to authencate administrave access to the Panorama web
interface. You can also deﬁne Vendor-Speciﬁc Aributes (VSAs) on the RADIUS server to manage
administrator authorizaon. Using VSAs enables you to quickly change the roles, access domains,
and user groups of administrators through your directory service, which is oen easier than
reconﬁguring sengs on Panorama.
You can use a RADIUS server to authencate administrave access to the Panorama web
interface. You can also deﬁne Vendor-Speciﬁc Aributes (VSAs) on the RADIUS server to
manage administrator authorizaon. Using VSAs enables you to quickly change the roles,
access domains, and user groups of administrators through your directory service, which is
oen easier than reconﬁguring sengs on Panorama.
You can Import the Palo Alto Networks RADIUS diconary into RADIUS server to deﬁne
the authencaon aributes needed for communicaon between Panorama and the
RADIUS server.
You can also use a RADIUS server to implement mul-factor authencaon (MFA) for
administrators.
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STEP 1 | Add a RADIUS server proﬁle.
The proﬁle deﬁnes how Panorama connects to the RADIUS server.
1. Select Panorama > Server Proﬁles > RADIUS and Add a proﬁle.
2. Enter a Proﬁle Name to idenfy the server proﬁle.
3. Enter a Timeout interval in seconds aer which an authencaon request mes out
(default is 3; range is 1–20).
If you use the server proﬁle to integrate Panorama with an MFA service, enter an
interval that gives administrators enough me to respond to the authencaon
challenge. For example, if the MFA service prompts for a one-me password
(OTP), administrators need me to see the OTP on their endpoint device and
then enter the OTP in the MFA login page.
4. Select the Authencaon Protocol (default is CHAP) that Panorama uses to authencate
to the RADIUS server.
Select CHAP if the RADIUS server supports that protocol; it is more secure than
PAP.
5. Add each RADIUS server and enter the following:
• Name to idenfy the server
• RADIUS Server IP address or FQDN
• Secret/Conﬁrm Secret (a key to encrypt usernames and passwords)
• Server Port for authencaon requests (default is 1812)
6. Click OK to save the server proﬁle.
STEP 2 | Assign the RADIUS server proﬁle to an authencaon proﬁle.
The authencaon proﬁle deﬁnes authencaon sengs that are common to a set of
administrators.
1. Select Panorama > Authencaon Proﬁle and Add a proﬁle.
2. Enter a Name to idenfy the authencaon proﬁle.
3. Set the Type to RADIUS.
4. Select the Server Proﬁle you conﬁgured.
5. Select Retrieve user group from RADIUS to collect user group informaon from VSAs
deﬁned on the RADIUS server.
Panorama matches the group informaon against the groups you specify in the Allow
List of the authencaon proﬁle.
6. Select Advanced and, in the Allow List, Add the administrators that are allowed to
authencate with this authencaon proﬁle.
7. Click OK to save the authencaon proﬁle.
STEP 3 | Conﬁgure Panorama to use the authencaon proﬁle for all administrators.
1. Select Panorama > Setup > Management and edit the Authencaon Sengs.
2. Select the Authencaon Proﬁle you conﬁgured and click OK.
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STEP 4 | Conﬁgure the roles and access domains that deﬁne authorizaon sengs for administrators.
1. Conﬁgure an Admin Role Proﬁle if the administrator uses a custom role instead of a
predeﬁned (dynamic) role.
2. Conﬁgure an Access Domain if the administrator uses a Device Group and Template role.
STEP 5 | Commit your changes.
Select Commit > Commit to Panorama and Commit your changes.
STEP 6 | Conﬁgure the RADIUS server.
Refer to your RADIUS server documentaon for the speciﬁc instrucons to perform these
steps:
1. Add the Panorama IP address or hostname as the RADIUS client.
2. Add the administrator accounts.
If the RADIUS server proﬁle speciﬁes CHAP as the Authencaon Protocol, you
must deﬁne accounts with reversibly encrypted passwords. Otherwise, CHAP
authencaon will fail.
3. Deﬁne the vendor code for Panorama (25461) and deﬁne the RADIUS VSAs for the role,
access domain, and user group of each administrator.
When you predeﬁne dynamic administrator roles for users, use lower-case to specify the
role (for example, enter superuser, not SuperUser).
STEP 7 | Verify that the RADIUS server performs authencaon and authorizaon for administrators.
1. Log in the Panorama web interface using an administrator account that you added to the
RADIUS server.
2. Verify that you can access only the web interface pages that are allowed for the role you
associated with the administrator.
3. In the Monitor, Policies, and Objects tabs, verify that you can access only the device
groups that are allowed for the access domain you associated with the administrator.

Conﬁgure TACACS+ Authencaon for Panorama Administrators
You can use a TACACS+ server to authencate administrave access to the Panorama web
interface. You can also deﬁne Vendor-Speciﬁc Aributes (VSAs) on the TACACS+ server to
manage administrator authorizaon. Using VSAs enables you to quickly change the roles, access
domains, and user groups of administrators through your directory service, which is oen easier
than reconﬁguring sengs on Panorama.
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STEP 1 | Add a TACACS+ server proﬁle.
The proﬁle deﬁnes how Panorama connects to the TACACS+ server.
1. Select Panorama > Server Proﬁles > TACACS+ and Add a proﬁle.
2. Enter a Proﬁle Name to idenfy the server proﬁle.
3. Enter a Timeout interval in seconds aer which an authencaon request mes out
(default is 3; range is 1–20).
4. Select the Authencaon Protocol (default is CHAP) that Panorama uses to authencate
to the TACACS+ server.
Select CHAP if the TACACS+ server supports that protocol; it is more secure
than PAP.
5. Add each TACACS+ server and enter the following:
• Name to idenfy the server
• TACACS+ Server IP address or FQDN
• Secret/Conﬁrm Secret (a key to encrypt usernames and passwords)
• Server Port for authencaon requests (default is 49)
6. Click OK to save the server proﬁle.
STEP 2 | Assign the TACACS+ server proﬁle to an authencaon proﬁle.
The authencaon proﬁle deﬁnes authencaon sengs that are common to a set of
administrators.
1. Select Panorama > Authencaon Proﬁle and Add a proﬁle.
2. Enter a Name to idenfy the proﬁle.
3. Set the Type to TACACS+.
4. Select the Server Proﬁle you conﬁgured.
5. Select Retrieve user group from TACACS+ to collect user group informaon from VSAs
deﬁned on the TACACS+ server.
Panorama matches the group informaon against the groups you specify in the Allow
List of the authencaon proﬁle.
6. Select Advanced and, in the Allow List, Add the administrators that are allowed to
authencate with this authencaon proﬁle.
7. Click OK to save the authencaon proﬁle.
STEP 3 | Conﬁgure Panorama to use the authencaon proﬁle for all administrators.
1. Select Panorama > Setup > Management and edit the Authencaon Sengs.
2. Select the Authencaon Proﬁle you conﬁgured and click OK.
STEP 4 | Conﬁgure the roles and access domains that deﬁne authorizaon sengs for administrators.
1. Conﬁgure an Admin Role Proﬁle if the administrator will use a custom role instead of a
predeﬁned (dynamic) role.
2. Conﬁgure an Access Domain if the administrator uses a Device Group and Template role.
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STEP 5 | Commit your changes.
Select Commit > Commit to Panorama and Commit your changes.
STEP 6 | Conﬁgure the TACACS+ server to authencate and authorize administrators.
Refer to your TACACS+ server documentaon for the speciﬁc instrucons to perform these
steps:
1. Add the Panorama IP address or hostname as the TACACS+ client.
2. Add the administrator accounts.
If you selected CHAP as the Authencaon Protocol, you must deﬁne accounts
with reversibly encrypted passwords. Otherwise, CHAP authencaon will fail.
3. Deﬁne TACACS+ VSAs for the role, access domain, and user group of each administrator.
When you predeﬁne dynamic administrator roles for users, use lower-case to
specify the role (for example, enter superuser, not SuperUser).
STEP 7 | Verify that the TACACS+ server performs authencaon and authorizaon for
administrators.
1. Log in the Panorama web interface using an administrator account that you added to the
TACACS+ server.
2. Verify that you can access only the web interface pages that are allowed for the role you
associated with the administrator.
3. In the Monitor, Policies, and Objects tabs, verify that you can access only the virtual
systems that are allowed for the access domain you associated with the administrator.

Conﬁgure SAML Authencaon for Panorama Administrators
You can use Security Asseron Markup Language (SAML) 2.0 for administrave access to
the Panorama web interface (but not the CLI). You can also use SAML aributes to manage
administrator authorizaon. SAML aributes enable you to quickly change the roles, access
domains, and user groups of administrators through your directory service instead of reconﬁguring
sengs on Panorama.
To conﬁgure SAML single sign-on (SSO) and single logout (SLO), you must register Panorama and
the identy provider (IdP) with each other to enable communicaon between them. If the IdP
provides a metadata ﬁle containing registraon informaon, you can import it onto Panorama to
register the IdP and to create an IdP server proﬁle. The server proﬁle deﬁnes how to connect to
the IdP and speciﬁes the cerﬁcate that the IdP uses to sign SAML messages. You can also use a
cerﬁcate for Panorama to sign SAML messages. Using cerﬁcates is oponal but recommended
to secure communicaons between Panorama and the IdP.
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STEP 1 | (Recommended) Obtain the cerﬁcates that the IdP and Panorama will use to sign SAML
messages.
If the cerﬁcates don’t specify key usage aributes, all usages are allowed by default, including
signing messages. In this case, you can obtain cerﬁcates by any method.
If the cerﬁcates do specify key usage aributes, one of the aributes must be Digital
Signature, which is not available on cerﬁcates that you generate on Panorama. In this case,
you must import the cerﬁcates:
• Cerﬁcate Panorama uses to sign SAML messages—Import the cerﬁcate from your
enterprise cerﬁcate authority (CA) or a third-party CA.
• Cerﬁcate the IdP uses to sign SAML messages—Import a metadata ﬁle containing the
cerﬁcate from the IdP (see the next step). The IdP cerﬁcate is limited to the following
algorithms:
• Public key algorithms—RSA (1,024 bits or larger) and ECDSA (all sizes).
• Signature algorithms—SHA1, SHA256, SHA384, and SHA512.
STEP 2 | Add a SAML IdP server proﬁle.
The server proﬁle registers the IdP with Panorama and deﬁnes how they connect.
In this example, you import a SAML metadata ﬁle from the IdP so that Panorama can
automacally create a server proﬁle and populate the connecon, registraon, and IdP
cerﬁcate informaon.
If the IdP doesn’t provide a metadata ﬁle, select Panorama > Server Proﬁles > SAML
Identy Provider, Add the server proﬁle, and manually enter the informaon (consult
your IdP administrator for the values).
1. Export the SAML metadata ﬁle from the IdP to a client system that Panorama can access.
The cerﬁcate speciﬁed in the ﬁle must meet the requirements listed in the preceding
step. Refer to your IdP documentaon for instrucons on exporng the ﬁle.
2. Select Panorama > Server Proﬁles > SAML Identy Provider and Import the metadata
ﬁle onto Panorama.
3. Enter a Proﬁle Name to idenfy the server proﬁle.
4. Browse to the Identy Provider Metadata ﬁle.
5. (Recommended) Select Validate Identy Provider Cerﬁcate (default) to have Panorama
validate the Identy Provider Cerﬁcate.
Validaon occurs only aer you assign the server proﬁle to an authencaon proﬁle and
Commit. Panorama uses the Cerﬁcate Proﬁle in the authencaon proﬁle to validate
the cerﬁcate.
Validang the cerﬁcate is a best pracce for improved security.
6. Enter the Maximum Clock Skew, which is the allowed diﬀerence in seconds between
the system mes of the IdP and Panorama at the moment when Panorama validates
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IdP messages (default is 60; range is 1 to 900). If the diﬀerence exceeds this value,
authencaon fails.
7. Click OK to save the server proﬁle.
8. Click the server proﬁle Name to display the proﬁle sengs. Verify that the imported
informaon is correct and edit it if necessary.
STEP 3 | Conﬁgure an authencaon proﬁle.
The authencaon proﬁle speciﬁes a SAML IdP server proﬁle and deﬁnes opons for the
authencaon process, such as SLO.
1. Select Panorama > Authencaon Proﬁle and Add a proﬁle.
2. Enter a Name to idenfy the proﬁle.
3. Set the Type to SAML.
4. Select the IdP Server Proﬁle you conﬁgured.
5. Select the Cerﬁcate for Signing Requests.
Panorama uses this cerﬁcate to sign messages it sends to the IdP.
6. (Oponal) Enable Single Logout (disabled by default).
7. Select the Cerﬁcate Proﬁle that Panorama will use to validate the Identy Provider
Cerﬁcate.
8. Enter the Username Aribute that IdP messages use to idenfy users (default
username).
When you predeﬁne dynamic administrator roles for users, use lower-case
to specify the role (for example, enter superuser, not SuperUser). If you
manage administrator authorizaon through the IdP identy store, specify the
Admin Role Aribute and Access Domain Aribute also.
9. Select Advanced and Add the administrators who are allowed to authencate with this
authencaon proﬁle.
10. Click OK to save the authencaon proﬁle.
STEP 4 | Conﬁgure Panorama to use the authencaon proﬁle for all administrators.
1. Select Panorama > Setup > Management, edit the Authencaon Sengs, and select
the Authencaon Proﬁle you conﬁgured.
2. Select Commit > Commit to Panorama to acvate your changes on Panorama and to
validate the Identy Provider Cerﬁcate that you assigned to the SAML IdP server
proﬁle.
STEP 5 | Create a SAML metadata ﬁle to register Panorama on the IdP.
1. Select Panorama > Authencaon Proﬁle and, in the Authencaon column for the
authencaon proﬁle you conﬁgured, click Metadata.
2. Set the Management Choice to Interface (default is selected) and select the management
(MGT) interface.
3. Click OK and save the metadata ﬁle to your client system.
4. Import the metadata ﬁle into the IdP server to register Panorama. Refer to your IdP
documentaon for instrucons.
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STEP 6 | Verify that administrators can authencate using SAML SSO.
1. Go to the URL of the Panorama web interface.
2. Click Use Single Sign-On.
3. Click Connue.
Panorama redirects you to authencate to the IdP, which displays a login page. For
example:

4. Log in using your SSO username and password.
Aer you successfully authencate on the IdP, it redirects you back to Panorama, which
displays the web interface.
5. Use your Panorama administrator account to request access to another SSO applicaon.
Successful access indicates SAML SSO authencaon succeeded.

Conﬁgure Tracking of Administrator Acvity
Track administrator acvity on the web interface and CLI of your Panorama™ management
server, managed ﬁrewalls, and Log Collectors to achieve real me reporng of acvity across your
deployment. If you have reason to believe an administrator account is compromised, you have a
full history of where this administrator account navigated throughout the web interface or what
operaonal commands they executed so you can analyze in detail and respond to all acons the
compromised administrator took.
When an event occurs, an audit log is generated and forwarded to the speciﬁed syslog server each
me an administrator navigates through the web interface or when an operaonal command is
executed in the CLI. An audit log is generated for each navigaon or commend executed. Take for
example if you want to create a new address object. An audit log is generated when you click on
Objects, and a second audit log is generated when you then click on Addresses.
Audit logs are only visible as syslogs forwarded to your syslog server and cannot be viewed in
the Panorama or managed ﬁrewall web interface. Audit logs can only be forwarded to a syslog
server, cannot be forwarded to Cortex Data Lake (CDL), and are not stored locally on the ﬁrewall,
Panorama, or Log Collector.
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STEP 1 | Conﬁgure a syslog server proﬁle to forward audit logs of administrator acvity for Panorama,
managed ﬁrewalls, and Log Collectors.
This step is required to successfully store audit logs for tracking administrator acvity.
1. Select Panorama > Server Proﬁles > Syslog and Add a new syslog server proﬁle.
2. Conﬁgure a syslog server proﬁle.
STEP 2 | Conﬁgure administrator acvity tracking for your managed ﬁrewalls.
This step is required to successfully store audit logs for tracking administrator acvity on
managed ﬁrewalls.
1. Select Device > Setup > Management and edit the Logging and Reporng Sengs.
2. Conﬁgure Tracking of Administrator Acvity.
3. Select Commit and Commit and Push.
STEP 3 | Conﬁgure administrator acvity tracking for Panorama.
1. Select Panorama > Setup > Management and edit the Logging and Reporng Sengs.
2. Select Log Export and Reporng.
3. In the Log Admin Acvity secon, conﬁgure what administrator acvity to track.
• Operaonal Commands—Generate an audit log when an administrator executes an
operaonal or debug command in the CLI or an operaonal command triggered from
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the web interface. See the CLI Operaonal Command Hierarchy for a full list of PANOS operaonal and debug commands.
• UI Acons—Generate an audit log when an administrator navigates throughout
the web interface. This includes navigaon between conﬁguraon tabs, as well as
individual objects within a tab.
For example, an audit log is generated when an administrator navigates from the
ACC to the Policies tab. Addionally, an audit log is generated when an administrator
navigates from Objects > Addresses to Objects > Tags.
• Syslog Server—Select a target syslog server proﬁle to forward audit logs.
4. Click OK

5. Select Commit and Commit to Panorama.
STEP 4 | Conﬁgure administrator acvity tracking for a Log Collector.
1. Select Panorama > Managed Collectors and select a Log Collector.
2. Select Audit.
3. In the Log Admin Acvity secon, conﬁgure audit tracking for CLI acvity.
You can only track CLI acvity for Log Collectors because Log Collectors you can
only access Log Collectors through the CLI.
• Operaonal Commands—Generate an audit log when an administrator executes
an operaonal or debug command in the CLI. See the CLI Operaonal Command
Hierarchy for a full list of PAN-OS operaonal and debug commands.
• Syslog Server—Select a target syslog server proﬁle to forward audit logs.
4. Click OK.
5. Select Commit and Commit to Panorama.
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Set Up Authencaon Using Custom Cerﬁcates
By default, Palo Alto Networks devices use predeﬁned cerﬁcates for mutual authencaon to
establish the SSL connecons used for management access and inter-device communicaon.
However, you can conﬁgure authencaon using custom cerﬁcates instead. Addionally,
you can use custom cerﬁcates to secure the High Availability (HA) connecons between
Panorama HA peers. Custom cerﬁcates allow you to establish a unique chain of trust to ensure
mutual authencaon between Panorama and the managed ﬁrewalls and log collectors. See
Cerﬁcate Management for detailed informaon about the cerﬁcates and how to deploy them
on Panorama, Log Collectors, and ﬁrewalls.
The following topics describe how to conﬁgure and manage custom cerﬁcates using Panorama.
• How Are SSL/TLS Connecons Mutually Authencated?
• Conﬁgure Authencaon Using Custom Cerﬁcates on Panorama
• Conﬁgure Authencaon Using Custom Cerﬁcates on Managed Devices
• Add New Client Devices
• Change Cerﬁcates

How Are SSL/TLS Connecons Mutually Authencated?
In a regular SSL connecon, only the server needs to idenfy itself to the client by presenng
its cerﬁcate. However, in mutual SSL authencaon, the client presents its cerﬁcate to the
server as well. Panorama, the primary Panorama HA peer, Log Collectors, WildFire appliances, and
PAN-DB appliances can act as the server. Firewalls, Log Collectors, WildFire appliances, and the
secondary Panorama HA peer can act as the client. The role that a device takes on depends the
deployment. For example, in the diagram below, Panorama manages a number of ﬁrewalls and a
collector group and acts as the server for the ﬁrewalls and Log Collectors. The Log Collector acts
as the server to the ﬁrewalls that send logs to it.
To deploy custom cerﬁcates for mutual authencaon in your deployment, you need:
• SSL/TLS Service Proﬁle—An SSL/TLS service proﬁle deﬁnes the security of the connecons by
referencing your custom cerﬁcate and establishing the SSL/TLS protocol versions used by the
server device to communicate with client devices.
• Server Cerﬁcate and Proﬁle—Devices in the server role require a cerﬁcate and cerﬁcate
proﬁle to idenfy themselves to the client devices. You can deploy this cerﬁcate from your
enterprise public key infrastructure (PKI), purchase one from a trusted third-party CA, or
generate a self-signed cerﬁcate locally. The server cerﬁcate must include the IP address or
FQDN of the device’s management interface in the cerﬁcate common name (CN) or Subject
Alt Name. The client ﬁrewall or Log Collector matches the CN or Subject Alt Name in the
cerﬁcate the server presents against the server’s IP address or FQDN to verify the server’s
identy.
Addionally, use the cerﬁcate proﬁle to deﬁne cerﬁcate revocaon status (OCSP/CRL) and
the acons taken based on the revocaon status.
• Client Cerﬁcates and Proﬁle—Each managed device requires a client cerﬁcate and cerﬁcate
proﬁle. The client device uses its cerﬁcate to idenfy itself to the server device. You can
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deploy cerﬁcates from your enterprise PKI, using Simple Cerﬁcate Enrollment Protocol
(SCEP), purchase one from a trusted third-party CA, or generate a self-signed cerﬁcate locally.
Custom cerﬁcates can be unique to each client device or common across all devices. The
unique device cerﬁcates uses a hash of the serial number of the managed device and CN. The
server matches the CN or the subject alt name against the conﬁgured serial numbers of the
client devices. For client cerﬁcate validaon based on the CN to occur, the username must be
set to Subject common-name. The client cerﬁcate behavior also applies to Panorama HA peer
connecons.
You can conﬁgure the client cerﬁcate and cerﬁcate proﬁle on each client device or push the
conﬁguraon from Panorama to each device as part of a template.

Figure 10: SSL/TLS Authentication

Conﬁgure Authencaon Using Custom Cerﬁcates on Panorama
Complete the following procedure to conﬁgure the server side (Panorama) to use custom
cerﬁcates instead of predeﬁned cerﬁcates for mutual authencaon with managed devices in
your deployment. See Set Up Authencaon Using Custom Cerﬁcates Between HA Peers to
conﬁgure custom cerﬁcates on a Panorama HA pair.
STEP 1 | Deploy the server cerﬁcate.
You can deploy cerﬁcates on Panorama or a server Log Collector by generang a self-signed
cerﬁcate on Panorama or obtaining a cerﬁcate from your enterprise cerﬁcate authority
(CA) or a trusted third-party CA.
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STEP 2 | On Panorama, conﬁgure a cerﬁcate proﬁle This cerﬁcate proﬁle deﬁnes what cerﬁcate to
use and what cerﬁcate ﬁeld to look for the IP address or FQDN in.
1. Select Panorama > Cerﬁcate Management > Cerﬁcate Proﬁle.
2. Conﬁgure a cerﬁcate proﬁle.
If you conﬁgure an intermediate CA as part of the cerﬁcate proﬁle, you must
include the root CA as well.
STEP 3 | Conﬁgure an SSL/TLS service proﬁle.
1. Select Panorama > Cerﬁcate Management > SSL/TLS Service Proﬁle.
2. Conﬁgure an SSL/TLS proﬁle to deﬁne the cerﬁcate and protocol that Panorama and its
managed devices use for SSL/TLS services.
STEP 4 | Conﬁgure Secure Server Communicaon on Panorama or a Log Collector in the server role.
1. Select one of the following navigaon paths:
• For Panorama: Panorama > Setup > Management and Edit the Secure
Communicaons Sengs
• For a Log Collector: Panorama > Managed Collectors > Add > Communicaon
2. Select the Customize Secure Server Communicaon opon.
3. Verify that the Allow Custom Cerﬁcate Only check box is not selected. This allows you
to connue managing all devices while migrang to custom cerﬁcates.
When the Custom Cerﬁcate Only check box is selected, Panorama does not
authencate and cannot manage devices using predeﬁned cerﬁcates.
4. Select the SSL/TLS Service Proﬁle. This SSL/TLS service proﬁle applies to all SSL
connecons between Panorama, ﬁrewalls, Log Collectors, and Panorama HA peers.
5. Select the Cerﬁcate Proﬁle that idenﬁes the cerﬁcate to use to establish secure
communicaon with clients such as ﬁrewalls.
6. (Oponal) Conﬁgure an authorizaon list. The authorizaon list adds an addional
layer of security beyond cerﬁcate authencaon. The authorizaon list checks the
client cerﬁcate Subject or Subject Alt Name. If the Subject or Subject Alt Name

Panorama Administrator's Guide Version Version 10.1

270

©2022 Palo Alto Networks, Inc.

Set Up Panorama
presented with the client cerﬁcate does not match an idenﬁer on the authorizaon
list, authencaon is denied.
You can also authorize client devices based on their serial number.
1. Add an Authorizaon List.
2. Select the Subject or Subject Alt Name conﬁgured in the cerﬁcate proﬁle as the
Idenﬁer type.
3. Enter the Common Name if the idenﬁer is Subject or and IP address, hostname or
email if the idenﬁer is Subject Alt Name.
4. Click OK.
5. Select Check Authorizaon List to enforce the authorizaon list.
7. Select Authorize Client Based on Serial Number to have the server authencate
client based on the serial numbers of managed devices. The CN or subject in the client
cerﬁcate must have the special keyword $UDID to enable this type of authencaon.
8. Select the Data Redistribuon opon in the Customize Communicaon secon to use a
custom cerﬁcate to secure outgoing communicaon with data redistribute clients.
9. In Disconnect Wait Time (min), specify how long Panorama should wait before
terminang the current session and reestablishing the connecon with its managed
devices. This ﬁeld is blank by default and the range is 0 to 44,640 minutes. Leaving this
ﬁeld blank is the same as seng it to 0.
The disconnect wait me does not begin counng down unl you commit the
new conﬁguraon.
10. Click OK.
11. Commit your changes.

Conﬁgure Authencaon Using Custom Cerﬁcates on Managed
Devices
Complete the following procedure to conﬁgure the client side (ﬁrewall or Log Collector) to use
custom cerﬁcates instead of predeﬁned cerﬁcates for mutual authencaon with managed
devices in your deployment.
STEP 1 | Upgrade each managed ﬁrewall or Log Collector. All managed devices must be running PANOS 8.0 or later to enforce custom cerﬁcate authencaon.
Upgrade the ﬁrewall. Aer upgrade, each ﬁrewall connects to Panorama using the default
predeﬁned cerﬁcates.
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STEP 2 | Obtain or generate the device cerﬁcate.
You can deploy cerﬁcates on Panorama or a server Log Collector by generang a self-signed
cerﬁcate on Panorama or obtaining a cerﬁcate from your enterprise cerﬁcate authority
(CA) or a trusted third-party CA.
Set the common name to $UDID or subject to CN=$UDID (in the SCEP proﬁle) if authorizing
client devices based on serial number.
• You can generate a self-signed cerﬁcate on Panorama or obtain a cerﬁcate from your
enterprise CA or a trusted third-party CA.
• If you are using SCEP for the device cerﬁcate, conﬁgure a SCEP proﬁle. SCEP allows you
to automacally deploy cerﬁcates to managed devices. When a new client devices with
a SCEP proﬁle aempts to authencate with Panorama, the cerﬁcate is sent by the SCEP
server to the device.
STEP 3 | Conﬁgure the cerﬁcate proﬁle for the client device.
You can conﬁgure this on each client device individually or you can push this conﬁguraon to
the managed device as part of a template.
1. Select one of the following navigaon paths:
• For ﬁrewalls—Select Device > Cerﬁcate Management > Cerﬁcate Proﬁle.
• For Log Collectors—Select Panorama > Cerﬁcate Management > Cerﬁcate Proﬁle.
2. Conﬁgure the cerﬁcate proﬁle.
STEP 4 | Deploy custom cerﬁcates on each ﬁrewall or Log Collector.
1. Select one of the following navigaon paths:
• For ﬁrewalls: Select Device > Setup > Management and Edit the Panorama Sengs
• For Log Collectors: Select Panorama > Managed Collectors and Add a new Log
Collector or select an exisng one. Select Communicaon.
2. Select the Secure Client Communicaon check box (ﬁrewall only).
3. Select the Cerﬁcate Type.
• If you are using a local device cerﬁcate, select the Cerﬁcate and Cerﬁcate Proﬁle.
• If you are using SCEP to deploy device cerﬁcate, select the SCEP Proﬁle and
Cerﬁcate Proﬁle.
• If you are using the default Panorama cerﬁcate, select Predeﬁned.
4. (Oponal) Enable Check Server Identy. The ﬁrewall or Log Collector checks the CN in
the server cerﬁcate against Panorama’s IP address or FQDN to verify its identy.
5. Click OK.
6. Commit your changes.
Aer comming your changes, the managed device does not terminate its current
session with Panorama unl the Disconnect Wait Time is complete.
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STEP 5 | Select the incoming communicaon types for which you want to use a custom cerﬁcate:
• HA Communicaon
• WildFire Communicaon
• Data Redistribuon
STEP 6 | Aer deploying custom cerﬁcates on all managed devices, enforce authencaon using
custom cerﬁcates.
The WildFire appliance does not currently support custom cerﬁcates. If your
Panorama is managing a WildFire appliance, do not select Allow Custom Cerﬁcates
Only.
1. Select Panorama > Setup > Management and Edit the Panorama sengs.
2. Select Allow Custom Cerﬁcate Only.
3. Click OK.
4. Commit your changes.
Aer comming this change, all devices managed by Panorama must use custom
cerﬁcates. If not, authencaon between Panorama and the device fails.

Add New Client Devices
When adding a new ﬁrewall or Log Collector to Panorama, the workﬂow depends on whether or
not these devices are conﬁgured to use custom cerﬁcates only for mutual authencaon.
• If the Custom Cerﬁcates Only is not selected on Panorama, you can add the device to
Panorama and then deploy the custom cerﬁcate by following the process beginning in step
Conﬁgure Authencaon Using Custom Cerﬁcates on Managed Devices.
• If the Custom Cerﬁcates Only is selected on Panorama, you must deploy the custom
cerﬁcates on the ﬁrewall before adding it to Panorama. If not, the managed device will not
be able to authncate with Panorama. This can be done manually through the ﬁrewall web
interface or through bootstrapping as part of the bootstrap.xml ﬁle.

Change Cerﬁcates
If a custom cerﬁcate in your deployment has expired or been revoked and needs to be replaced,
you can complete one of the tasks below.
• Change a Server Cerﬁcate
• Change a Client Cerﬁcate
• Change a Root or Intermediate CA Cerﬁcate

Change a Server Cerﬁcate
Complete the following task to replace a server cerﬁcate.
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STEP 1 | Deploy the new server cerﬁcate.
You can deploy cerﬁcates on Panorama or a server Log Collector by generang a self-signed
cerﬁcate on Panorama or obtaining a cerﬁcate from your enterprise CA or a trusted thirdparty CA.
STEP 2 | Change the cerﬁcate in the SSL/TLS Service Proﬁle.
1. Select Panorama > Cerﬁcate Management > SSL/TLS Service Proﬁle and select the
SSL/TLS service proﬁle.
2. Select the Cerﬁcate.
3. Click OK.
STEP 3 | Reestablish the connecon between the server (Panorama or a Log Collector) and client
devices.
1. Select Panorama > Setup > Management and Edit the Panorama Sengs for Panorama
or select Panorama > Managed Collectors > Add > Communicaon for a Log Collector.
2. Set the Disconnect Wait Time.
3. Click OK.
4. Commit your changes.

Change a Client Cerﬁcate
Complete the following task to replace a client cerﬁcate.
STEP 1 | Obtain or generate the device cerﬁcate.
You can deploy cerﬁcates on Panorama or a server Log Collector by generang a self-signed
cerﬁcate on Panorama or obtaining a cerﬁcate from your enterprise CA or a trusted thirdparty CA.
Set the common name to $UDID or subject to CN=$UDID (in the SCEP proﬁle) if authorizing
client devices based on serial number.
• You can generate a self-signed cerﬁcate on Panorama or obtain a cerﬁcate from your
enterprise CA or a trusted third-party CA.
• If you are using SCEP for the device cerﬁcate, conﬁgure a SCEP proﬁle. SCEP allows you
to automacally deploy cerﬁcates to managed devices. When a new client devices with
a SCEP proﬁle aempts to authencate with Panorama, the cerﬁcate is sent by the SCEP
server to the device.
STEP 2 | Change the cerﬁcate in the cerﬁcate proﬁle.
1. Select Device > Cerﬁcate Management > Cerﬁcate Proﬁle and select the cerﬁcate
proﬁle.
2. Under CA Cerﬁcates, Add the new cerﬁcate to assign to the cerﬁcate proﬁle.
3. Click OK.
4. Commit your changes.

Change a Root or Intermediate CA Cerﬁcate
Complete the following task to replace a root or intermediate CA cerﬁcate.
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STEP 1 | Conﬁgure the server to accept predeﬁned cerﬁcates from clients.
1. Select Panorama > Setup > Management and Edit the Panorama Sengs.
2. Uncheck Custom Cerﬁcate Only.
3. Select None from the Cerﬁcate Proﬁle drop-down.
4. Click OK.
5. Commit your changes.
STEP 2 | Deploy the new root or intermediate CA cerﬁcate.
You can deploy cerﬁcates on Panorama or a server Log Collector by generang a self-signed
cerﬁcate on Panorama or obtaining a cerﬁcate from your enterprise CA or a trusted thirdparty CA.
STEP 3 | Update the CA cerﬁcate in the server cerﬁcate proﬁle.
1. Select Panorama > Cerﬁcate Management > Cerﬁcate Proﬁle and select the
cerﬁcate proﬁle to update.
2. Delete the old CA cerﬁcate.
3. Add the new CA Cerﬁcate.
4. Click OK.
STEP 4 | Generate or import the new client cerﬁcate.
1. Select Device > Cerﬁcate Management > Cerﬁcates.
2. Create a self-signed root CA cerﬁcate or import a cerﬁcate from your enterprise CA.
STEP 5 | Update the CA cerﬁcate in the client cerﬁcate proﬁle.
1. Select Device > Setup > Management and click the Edit icon in Panorama Sengs for
a ﬁrewall or Select Panorama > Managed Collectors > Add > Communicaon for a Log
Collector and select the cerﬁcate proﬁle to update.
2. Delete the old CA cerﬁcate.
3. Add the new CA Cerﬁcate.
4. Click OK.
STEP 6 | Aer updang the CA cerﬁcates on all managed devices, enforce custom-cerﬁcate
authencaon.
1. Select Panorama > Setup > Management and Edit the Panorama Sengs.
2. Select Custom Cerﬁcate Only.
3. Click OK.
4. Commit your changes.
Aer comming this change, all devices managed by Panorama must use custom
cerﬁcates. If not, authencaon between Panorama and the device fails.
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To use the Panorama™ management server for managing Palo Alto Networks ﬁrewalls,
you must add the ﬁrewalls as managed devices and then assign them to device
groups and to templates or template stacks. The following tasks best suit a ﬁrst-me
ﬁrewall deployment. Before proceeding, review Plan Your Panorama Deployment to
understand the deployment opons.
>

Add a Firewall as a Managed Device

>

>

Install the Device Cerﬁcate for
Managed Firewalls

Schedule a Conﬁguraon Push to
Managed Firewalls

>

>

Set Up Zero Touch Provisioning

Redistribute Data to Managed
Firewalls

>

Manage Device Groups

>

>

Manage Templates and Template
Stacks

Transion a Firewall to Panorama
Management

>

Device Monitoring on Panorama

>

Manage the Master Key from
Panorama

>

Use Case: Conﬁgure Firewalls Using
Panorama

To view the Objects and Policies tabs on the Panorama web interface, you must ﬁrst
create at least one device group. To view the Network and Device tabs, you must
create at least one template. These tabs contain the opons by which you conﬁgure
and manage the ﬁrewalls on your network.
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Add a Firewall as a Managed Device
To use a Panorama™ management server to manage your ﬁrewalls, you need to enable a
connecon between the ﬁrewall and the Panorama management server. To strengthen your
Security posture when onboarding a new ﬁrewall, you must create a unique device registraon
authencaon key on the Panorama management server for mutual authencaon between the
new ﬁrewall and the server on ﬁrst connecon. A successful ﬁrst connecon requires that you add
the Panorama IP address on each ﬁrewall the server will manage, add the serial number on the
server for each ﬁrewall, and specify the device registraon authencaon key on both the server
and the ﬁrewall. When you add a ﬁrewall as a managed device, you can also associate the new
ﬁrewall with a device group, template stack, collector group, and Log Collector during the inial
deployment. Addionally, you have the opon to automacally push the conﬁguraon to your
newly added ﬁrewall when the ﬁrewall ﬁrst connects to the Panorama server, which ensures that
ﬁrewalls are immediately conﬁgured and ready to secure your network.
You can bulk import only single-vsys ﬁrewalls to the Panorama management server.
The ﬁrewall uses the Panorama management server IP address for registraon with the server.
The Panorama server and the ﬁrewall authencate with each other using 2,048-bit cerﬁcates
and AES-256 encrypted SSL connecons for conﬁguraon management and log collecon.
To conﬁgure the device registraon authencaon key, specify the key lifeme and the number of
mes you can use the authencaon key to onboard new ﬁrewalls. Addionally, you can specify
one or more ﬁrewall serial numbers for which the authencaon key is valid.
The authencaon key expires 90 days aer the key lifeme expires. Aer 90 days, you are
prompted to re-cerfy the authencaon key to maintain its validity. If you do not re-cerfy,
then the authencaon key becomes invalid. A system log is generated each me a ﬁrewall
uses the Panorama-generated authencaon key. The ﬁrewall uses the authencaon key to
authencate the Panorama server when it delivers the device cerﬁcate that is used for all
subsequent communicaons.
(PAN-OS 10.1 only) For ﬁrewalls running a PAN-OS 10.1 release, Panorama running PANOS 10.1.3 or later release supports onboarding ﬁrewalls running PAN-OS 10.1.3 or later
release only. You cannot add a ﬁrewall running PAN-OS 10.1.2 or earlier PAN-OS 10.1
release to Panorama management if Panorama is running PAN-OS 10.1.3 or later release.
Panorama supports onboarding ﬁrewalls running the following releases:
• Panorama running PAN-OS 10.1.2 or earlier PAN-OS 10.1 release— Firewalls running
PAN-OS 10.1.2 or earlier PAN-OS 10.1 release, and ﬁrewalls running PAN-OS 10.0 or
earlier PAN-OS release.
• Panorama running PAN-OS 10.1.3 or later release— Firewalls running PAN-OS 10.1.3
or later release, and ﬁrewalls running PAN-OS 10.0 or earlier PAN-OS release.
There is no impact to ﬁrewalls already managed by Panorama on upgrade to PAN-OS
10.1.
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STEP 1 | Set up the ﬁrewall.
1. Perform inial conﬁguraon on the ﬁrewall so that it is accessible and can communicate
with the Panorama server over the network.
2. Conﬁgure each data interface you plan to use on the ﬁrewall and aach it to a security
zone so that you can push conﬁguraon sengs and policy rules from the Panorama
server.
STEP 2 | Create a device registraon authencaon key.
1. Log in to the Panorama Web Interface.
2. Select Panorama > Device Registraon Auth Key and Add a new authencaon key.
3. Conﬁgure the authencaon key.
• Name—Add a descripve name for the authencaon key.
• Lifeme—Specify the key lifeme to limit how long you can use the authencaon
key to onboard new ﬁrewalls.
• Count—Specify how many mes you can use the authencaon key to onboard new
ﬁrewalls.
• Device Type—Specify that this authencaon key is used to authencate only a
Firewall.
You can select Any to use the device registraon authencaon key to
onboard ﬁrewalls, Log Collectors, and WildFire appliances.
• (Oponal) Devices—Enter one or more device serial numbers to specify for which
ﬁrewalls the authencaon key is valid.
4. Click OK.

5. Copy Auth Key and Close.
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STEP 3 | Add ﬁrewalls to a Panorama management server. You can manually add one or more ﬁrewalls
or bulk import ﬁrewalls using a CSV ﬁle.
You cannot bulk import ﬁrewalls with more than one virtual system (vsys).
• Add one or more ﬁrewalls manually.
1. Select Panorama > Managed Devices > Summary and Add a new ﬁrewall.
2. Enter the ﬁrewall Serial number. If you are adding mulple ﬁrewalls, enter each serial
number on a separate line.
3. (Oponal) Select Associate Devices to associate the ﬁrewall with a device group,
template stack, Log Collector, or Collector group when the ﬁrewall ﬁrst connect to the
Panorama management server.
4. Enter the device registraon authencaon key you created.

5. Click OK.
6. Associate your managed ﬁrewalls as needed.
If you did not select Associate Devices, skip this step and connue to conﬁgure the
ﬁrewall to communicate with Panorama.
1. Assign the Device Group, Template Stack, Collector Group, and Log Collector as
needed from the drop-down in each column.
2. Enable Auto Push on 1st connect to automacally push the device group and
template stack conﬁguraon to the new devices when they ﬁrst successfully connect
to the Panorama server.
The Auto Push on 1st Connect opon is supported only on ﬁrewalls running
PAN-OS® 8.1 and later releases. The commit all job executes from
Panorama to managed devices running PAN-OS 8.1 and later releases.
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3. (Oponal) Select a PAN-OS release version (To SW Version column) to begin
automacally upgrading the managed ﬁrewall to the speciﬁed PAN-OS version upon
successful connecon to the Panorama management server.
To upgrade a managed ﬁrewall to a target PAN-OS release on ﬁrst
connecon, you must install the minimum content release version required
for that PAN-OS release before adding the ﬁrewall as a managed device.
To do this, you must register the ﬁrewall, acvate the support license,
and install the content update before adding the ﬁrewall to Panorama
management.
Leave this column empty if you do not want to automacally upgrade the managed
ﬁrewall.
4. Click OK to add the devices.

• Bulk import mulple ﬁrewalls using a CSV ﬁle.
1. Select Panorama > Managed Devices > Summary and Add your new ﬁrewalls.
2. Add the device registraon authencaon key you created.
3. Click Import.
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4. Download Sample CSV and edit the downloaded CSV ﬁle with the ﬁrewalls you are
adding. You can choose to assign the ﬁrewalls to a device group, template stack,
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Collector Group, and Log Collector from the CSV or enter only the ﬁrewall serial numbers
and assign them from the web interface. Save the CSV aer you ﬁnish eding.
5. Browse to and select the CSV ﬁle you edited in the previous step.

6. If not already assigned in the CSV, assign the ﬁrewalls a Device Group, Template Stack,
Collector Group, and Log Collector as needed from the drop-down in each column
7. If not already enabled in the CSV, enable Auto Push on 1st connect to automacally
push the device group and template stack conﬁguraon to the new devices when they
ﬁrst successfully connect to the Panorama server.
8. (Oponal) Select a PAN-OS release version (To SW Version column) to begin
automacally upgrading the managed ﬁrewall to the speciﬁed PAN-OS version upon
successful connecon to the Panorama server.
To upgrade a managed ﬁrewall to a target PAN-OS release on ﬁrst connecon,
you must install the minimum content release version required for that PANOS release before adding the ﬁrewall as a managed device. To do this, you must
register the ﬁrewall, acvate the support license, and install the content
update before adding the ﬁrewall to Panorama management.
Leave this column empty if you do not want to automacally upgrade the managed
ﬁrewall.
9. Click OK to add the ﬁrewalls.
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STEP 4 | Conﬁgure the ﬁrewall to communicate with the Panorama management server.
Repeat this step for each ﬁrewall the Panorama server will manage.
1. Log in to the ﬁrewall web interface.
2. Conﬁgure the Panorama Sengs for the ﬁrewall.
1. Select Device > Setup > Management and edit the Panorama Sengs.
2. Enter the Panorama IP address in the ﬁrst ﬁeld.
Panorama issues a single IP address for device management, log collecon,
reporng, and dynamic updates. Enter the external, Internet-bound IP
address to ensure Panorama can successfully access exisng and new
managed devices and Log Collectors. If an internal Panorama IP address is
conﬁgured, you may be unable to manage some devices. For example, if you
Install Panorama on AWS and enter the internal IP address, Panorama is
unable to manage devices or Log Collectors outside of the AWS security
group.
3. (Oponal) If you have conﬁgured a high availability (HA) pair in Panorama, enter the IP
address of the secondary Panorama in the second ﬁeld.
4. Enter the Auth key you created on Panorama.
5. Click OK.

6. Commit your changes.
STEP 5 | (Oponal) Add a Tag. Tags make it easier for you to ﬁnd a ﬁrewall from a large list; they help
you dynamically ﬁlter and reﬁne the list of ﬁrewalls in your display. For example, if you add a
tag called branch office, you can ﬁlter for all branch oﬃce ﬁrewalls across your network.
1. Select each ﬁrewall and click Tag.
2. Click Add, enter a string of up to 31 characters (no empty spaces), and click OK.
STEP 6 | If your deployment is using custom cerﬁcates for authencaon between Panorama and
managed devices, deploy the custom client device cerﬁcate. For more informaon, see Set
Up Authencaon Using Custom Cerﬁcates and Add New Client Devices.
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STEP 7 | Select Commit > Commit to Panorama and Commit your changes.
STEP 8 | Verify that the ﬁrewall is connected to Panorama.
1. Click Panorama > Managed Devices > Summary.
2. Verify that the Device State for the new device shows as Connected.
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Install the Device Cerﬁcate for Managed Firewalls
In PAN-OS 10.1 and later releases, you must install the device cerﬁcate on your managed
ﬁrewalls to successfully authencate your managed ﬁrewalls to leverage Palo Alto Networks cloud
services such as Device Telemetry, IoT, and Enterprise Data Loss Prevenon (DLP). You can install
the device cerﬁcate for a single managed ﬁrewall or mulple managed ﬁrewalls at once.
See Device Cerﬁcates to install the ﬁrewall device cerﬁcate locally.
• Install the Device Cerﬁcate for a Managed Firewall
• Install the Device Cerﬁcate for Mulple Managed Firewalls

Install the Device Cerﬁcate for a Managed Firewall
In PAN-OS 10.1 and later releases, you must install the device cerﬁcate for a managed ﬁrewall
from the Panorama management server. The managed ﬁrewall must have internet access to
successfully install the device cerﬁcate.
STEP 1 | Register Panorama and managed ﬁrewalls with the Palo Alto Networks Customer Support
Portal (CSP).
STEP 2 | Log in to the Panorama Web Interface as an admin user.
STEP 3 | Conﬁgure the Network Time Protocol (NTP) server.
An NTP server is required validate the device cerﬁcaon expiraon date, ensure the device
cerﬁcate does not expire early or become invalid.
1. Select Device > Setup > Services and select the Template.
2. Select one of the following depending on your plaorm:
• For mul-virtual system plaorms, select Global and edit the Services secon.
• For single virtual system plaorms, edit the Services secon.
3. Select NTP and enter the hostname pool.ntp.org as the Primary NTP Server or enter
the IP address of your primary NTP server.
4. (Oponal) Enter a Secondary NTP Server address.
5. (Oponal) To authencate me updates from the NTP server(s), for Authencaon Type,
select one of the following for each server.
• None (default)—Disables NTP authencaon.
• Symmetric Key—Firewall uses symmetric key exchange (shared secrets) to
authencate me updates.
• Key ID—Enter the Key ID (1-65534)
• Algorithm—Select the algorithm to use in NTP authencaon (MDS or SHA1)
6. Click OK to save your conﬁguraon changes.
7. Select Commit and Commit and Push your conﬁguraon changes to your managed
ﬁrewalls.
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STEP 4 | Select Panorama > Managed Devices > Summary and select a managed ﬁrewall.
STEP 5 | Select Request OTP From CSP > Custom selected devices.
STEP 6 | Copy the enre OTP request token.
STEP 7 | Generate the One Time Password (OTP) for managed ﬁrewalls.
1. Log in to the Customer Support Portal.
2. Select Assets > Device Cerﬁcates and Generate OTP.
3. For the Device Type, select Generate OTP for Panorama managed ﬁrewalls.
4. Paste the OTP request you copied in the previous step and Generate OTP.
5. Click Done and wait a few minutes for the OTP to successfully generate. You can refresh
the page if the new OTP does not display.
6. Copy to Clipboard or Download the OTP.

STEP 8 | Log in to the Panorama Web Interface as an admin user.
STEP 9 | Select Panorama > Managed Devices > Summary and Upload OTP.
STEP 10 | Paste the OTP you generated and click Upload.
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STEP 11 | Verify that the Device Cerﬁcate column displays as Valid and that the Device Cerﬁcate
Expiry Date displays an expiraon date.

Install the Device Cerﬁcate for Mulple Managed Firewalls
In PAN-OS 10.1 and later releases, you must install the device cerﬁcate for managed ﬁrewalls
from the Panorama management server. The managed ﬁrewalls must have internet access to
successfully install the device cerﬁcate.
STEP 1 | Register Panorama and managed ﬁrewalls with the Palo Alto Networks Customer Support
Portal (CSP).
STEP 2 | Log in to the Panorama Web Interface as an admin user.
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STEP 3 | Conﬁgure the Network Time Protocol (NTP) server.
An NTP server is required validate the device cerﬁcaon expiraon date, ensure the device
cerﬁcate does not expire early or become invalid.
1. Select Device > Setup > Services and select the Template.
2. Select one of the following depending on your plaorm:
• For mul-virtual system plaorms, select Global and edit the Services secon.
• For single virtual system plaorms, edit the Services secon.
3. Select NTP and enter the hostname pool.ntp.org as the Primary NTP Server or enter
the IP address of your primary NTP server.
4. (Oponal) Enter a Secondary NTP Server address.
5. (Oponal) To authencate me updates from the NTP server(s), for Authencaon Type,
select one of the following for each server.
• None (default)—Disables NTP authencaon.
• Symmetric Key—Firewall uses symmetric key exchange (shared secrets) to
authencate me updates.
• Key ID—Enter the Key ID (1-65534)
• Algorithm—Select the algorithm to use in NTP authencaon (MDS or SHA1)
6. Click OK to save your conﬁguraon changes.
7. Select Commit and Commit and Push your conﬁguraon changes to your managed
ﬁrewalls.
STEP 4 | Select Panorama > Managed Devices > Summary.
STEP 5 | Select Request OTP From CSP > Select all devices without a cerﬁcate.
STEP 6 | Copy the enre OTP request token.
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STEP 7 | Generate the One Time Password (OTP) for managed ﬁrewalls.
1. Log in to the Customer Support Portal.
2. Select Assets > Device Cerﬁcates and Generate OTP.
3. For the Device Type, select Generate OTP for Panorama managed ﬁrewalls.
4. Paste the OTP request you copied in the previous step and Generate OTP.
5. Click Done and wait a few minutes for the OTP to successfully generate. You can refresh
the page if the new OTP is not displayed.
6. Copy to Clipboard or Download the OTP.

STEP 8 | Log in to the Panorama Web Interface as an admin user.
STEP 9 | Select Panorama > Managed Devices > Summary and Upload OTP.
STEP 10 | Paste the OTP you generated and click Upload.
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STEP 11 | Verify that the Device Cerﬁcate column displays as Valid and that the Device Cerﬁcate
Expiry Date displays an expiraon date.
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Set Up Zero Touch Provisioning
Set up Zero Touch Provisioning (ZTP) to simplify and streamline inial ﬁrewall deployments by
automang the new managed ﬁrewall on-boarding without the need for network administrators to
manually provision the ﬁrewall.
To successfully leverage the ZTP service, on-board your ZTP ﬁrewalls with the factory
default PAN-OS version before upgrading to PAN-OS 10.0.0 or later release.
The ZTP plugin is supported on PAN-OS 10.0.1 and later releases.
• ZTP Overview
• Install the ZTP Plugin
• Conﬁgure the ZTP Installer Administrator Account
• Add ZTP Firewalls to Panorama
• Use the CLI for ZTP Tasks
• Uninstall the ZTP Plugin

ZTP Overview
Learn more about Zero Touch Provisioning (ZTP) and its conﬁguraon elements.
• About ZTP
• ZTP Conﬁguraon Elements

About ZTP
Zero Touch Provisioning (ZTP) is designed to simplify and automate the on-boarding of new
ﬁrewalls to the Panorama™ management server. ZTP streamlines the inial ﬁrewall deployment
process by allowing network administrators to ship managed ﬁrewalls directly to their branches
and automacally add the ﬁrewall to the Panorama™ management server aer the ZTP ﬁrewall
successfully connects to the Palo Alto Networks ZTP service. This allows businesses to save on
me and resources when deploying new ﬁrewalls at branch locaons by removing the need for
IT administrators to manually provision the new managed ﬁrewall. Aer successful on-boarding,
Panorama provides the means to conﬁgure and manage your ZTP conﬁguraon and ﬁrewalls.
Review and subscribe to ZTP Service Status events to be noﬁed about scheduled
maintenance windows, outages, and workarounds.
ZTP is supported on the following ZTP ﬁrewalls:
• PA-220-ZTP and PA-220R-ZTP
• PA-410, PA-440, PA-450, and PA-460
• PA-820-ZTP and PA-850-ZTP
• PA-3220-ZTP, PA-3250-ZTP, and PA-3260-ZTP
• PA-5450

Panorama Administrator's Guide Version Version 10.1

292

©2022 Palo Alto Networks, Inc.

Manage Firewalls
Before you begin seng up ZTP on Panorama, review the Firewall Hardware Quick Start and
Reference Guides to understand how to correctly install your ﬁrewall to successfully leverage ZTP.

ZTP Conﬁguraon Elements
The following elements work together to allow you to quickly on-board newly deployed ZTP
ﬁrewalls by automacally adding them to the Panorama management server using the ZTP
service.
• ZTP Plugin—The ZTP plugin allows Panorama to connect to the ZTP service and claim a ZTP
ﬁrewall for simpliﬁed on-boarding.
• Customer Support Portal (CSP)—The Palo Alto Networks Customer Support Portal is used
to register your Panorama to connect to the CSP to automacally register newly added ZTP
ﬁrewalls.
• One-me Password (OTP)—A one-me password provided by Palo Alto Networks used to
retrieve and install a cerﬁcate on Panorama for it to communicate with the CSP and ZTP
service.
• Installer—An administrator user created using the installeradmin admin role for ZTP
ﬁrewall on-boarding. This admin user has limited access to the Panorama web interface, only
allowing access to enter the ZTP ﬁrewall serial number and claim key to register ﬁrewalls on the
CSP and Panorama. The installer admin can be created on Panorama or created using remote
authencaon such as RADIUS, SAML, or TACACS+.
• Claim Key—Eight digit numeric key physically aached to the ZTP ﬁrewall used to register the
ZTP ﬁrewall with the CSP.
• To-SW-Version—Designate the PAN-OS soware version of the ZTP ﬁrewall (Panorama >
Managed Devices > Summary). Select the target PAN-OS release, and if the ﬁrewall is running
an earlier release than the indicated version, the ﬁrewall begins an upgrade loop unl the target
release is successfully installed.
Panorama can only manage ﬁrewalls running a PAN-OS release equal to or less than
that installed on the Panorama.
Aer you successfully install the ZTP plugin on Panorama and register Panorama with the ZTP
service, the ZTP on boarding process connues as follows:
1. Installer or IT administrator registers ZTP ﬁrewalls by adding them to Panorama using the
ﬁrewall serial number and claim key.
2. Panorama registers the ﬁrewalls with the CSP. Aer the ﬁrewalls are successfully registered,
the ﬁrewall is associated with the same ZTP tenant as the Panorama in the ZTP service.
ZTP ﬁrewalls successfully registered with the ZTP service are automacally added as managed
ﬁrewalls (Panorama > Managed Devices) on Panorama.
3. When the ﬁrewall connects to the Internet, the ZTP ﬁrewall requests a device cerﬁcate from
the CSP in order to connect to the ZTP service.
4. The ZTP service pushes the Panorama IP or FQDN to the ZTP ﬁrewalls.
5. The ZTP ﬁrewalls connect to Panorama and the device group and template conﬁguraons are
pushed from Panorama to the ZTP ﬁrewalls.
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Install the ZTP Plugin
Install the ZTP plugin on your Panorama™ management server to register Panorama with the ZTP
service in order to claim ZTP ﬁrewalls for simpliﬁed on-boarding.
If your Panorama is in a high availability (HA) conﬁguraon, install the ZTP plugin and register both
Panorama HA peers with the ZTP service.
• Install the ZTP Plugin on Panorama
• Register Panorama with the ZTP Service

Install the ZTP Plugin on Panorama
Simplify the on-boarding and management of ZTP ﬁrewalls by installing the ZTP plugin on your
Panorama management server.
STEP 1 | Install the Panorama Device Cerﬁcate.
STEP 2 | Log in to the Panorama web interface as a superuser or Panorama administrator with access
to Panorama plugins (Panorama > Plugins).
STEP 3 | Select Panorama > Plugins and search for the ztp plugin.
STEP 4 | Download and Install the most recent version of the ZTP plugin.

Register Panorama with the ZTP Service
Register the Panorama™ management server with the ZTP service for new and exisng
deployments.
• Register Panorama with the ZTP Service for New Deployments
• Register Panorama with the ZTP Service for Exisng Deployments
Register Panorama with the ZTP Service for New Deployments
Aer you install the ZTP plugin on the Panorama™ management server, you must register
the Panorama with the ZTP service to enable the ZTP service to associate ﬁrewalls with the
Panorama. As part of the registraon process for ZTP new deployment, automacally generate

Panorama Administrator's Guide Version Version 10.1

294

©2022 Palo Alto Networks, Inc.

Manage Firewalls
the device group and template conﬁguraons required to connect your ZTP ﬁrewalls to the ZTP
service. Aer the device group and template are automacally generated, you must add your ZTP
ﬁrewalls to the device group and template so they can connect to the ZTP service aer they ﬁrst
connect to Panorama.
STEP 1 | Install the Panorama Device Cerﬁcate.
STEP 2 | Log in to the Palo Alto Networks Customer Support Portal (CSP).
STEP 3 | Associate your Panorama with the ZTP Service on the Palo Alto Networks CSP.
The ZTP Service supports associang up to two Panoramas only if they are in a high availability
(HA) conﬁguraon. If Panorama is not in an HA conﬁguraon, only a single Panorama can be
associated.
1. Select Assets > ZTP Service and Associate Panorama(s).
2. Select the serial number of the Panorama managing your ZTP ﬁrewalls.
3. (HA only) Select the serial number of the Panorama HA peer.
4. Click OK.
STEP 4 | Log in to the Panorama Web Interface.
STEP 5 | Select Panorama > Zero Touch Provisioning > Setup and edit the General ZTP sengs.
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STEP 6 | Register Panorama with the ZTP service.
1. Enable ZTP Service.
2. Enter the Panorama FQDN or IP Address.
This is the FQDN or public IP address of the Panorama the ZTP plugin is installed on and
that the CSP pushes to the ZTP ﬁrewalls.
(Managed ﬁrewalls running PAN-OS 10.1.4 and earlier releases) Enter the
Panorama IP address to avoid the managed ﬁrewall disconnecng from
Panorama on reboot or aer a successful PAN-OS upgrade.
If you need to use the Panorama FQDN, conﬁgure a stac desnaon route to
avoid the managed ﬁrewall disconnecng from Panorama on reboot or aer a
successful PAN-OS upgrade.
3. (HA only) Enter the Peer FQDN or IP Address.
This is the FQDN or public IP address of the Panorama peer on which the ZTP plugin is
installed and that the CSP pushes to the ZTP ﬁrewalls in case of failover.
(Managed ﬁrewalls running PAN-OS 10.1.4 and earlier releases) Enter the
Panorama IP address to avoid the managed ﬁrewall disconnecng from
Panorama on reboot or aer a successful PAN-OS upgrade.
If you need to use the Panorama FQDN, conﬁgure a stac desnaon route to
avoid the managed ﬁrewall disconnecng from Panorama on reboot or aer a
successful PAN-OS upgrade.
4. Click OK to save your conﬁguraon changes.
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STEP 7 | Create the default device group and template to automacally generate the required
conﬁguraon to connect your ZTP ﬁrewalls to Panorama.
Adding the device group and template automacally generates a new device group and
template that contain the default conﬁguraon to connect the Panorama and the ZTP ﬁrewalls.
1. Add Device Group and Template.
2. Enter the Device Group name.
3. Enter the Template name.
4. Click OK to save your conﬁguraon changes.

STEP 8 | Add your ZTP ﬁrewalls to the device group and template speciﬁed in the previous step.
1. Select Panorama > Device Groups and select the device group that was automacally
created.
2. Select the ZTP Devices.
3. Click OK to save your conﬁguraon changes.
4. Select Panorama > Templates and Add Stack.
5. In the Templates secon, Add the template that was automacally generated.
6. Select the ZTP Devices.
7. Click OK to save your conﬁguraon changes.
STEP 9 | Verify that the required device group and template conﬁguraons generated successfully.
1. Select Network > Interfaces > Ethernet and select the Template you created in the
previous step.
2. Verify that ethernet1/1 is conﬁgured with an IP Address, Virtual Router, and Security
Zone.
3. Select Network > Interfaces > Loopback and select the Template you created in the
previous step.
4. Verify that the loopback.900 interface is successfully created.
5. Select Policies > Security > Pre Rules and select the Device Group you created in the
previous step.
6. Verify that rule1 is successfully created.
7. Select Policies > NAT > Pre Rules and select the Device Group you created in the
previous step.
8. Verify that ztp-nat is successfully created.
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STEP 10 | Modify your device groups and templates as needed.
Create and conﬁgure new or exisng device groups and templates to complete your
deployment.
When considering your device group hierarchy and template priority in your template
stack, ensure that the device group and template containing the required ZTP conﬁguraon
that allows the ZTP ﬁrewall and Panorama to communicate have priority such that the
conﬁguraon is not overridden in the event of conﬂicng conﬁguraons.
Do not modify the IP address, virtual router, and Security zone of the ethernet1/1
interface, the loopback.900 loopback interface, the rule1 Security policy rule,
or ztp-nat NAT policy rule. These conﬁguraons are required to connect your ZTP
ﬁrewall to Panorama.
STEP 11 | Select Commit and Commit to Panorama
STEP 12 | Sync to ZTP Service and verify that the Panorama Sync Status displays as In Sync.

Register Panorama with the ZTP Service for Existing Deployments
Aer you install the ZTP plugin on the Panorama™ management server, you must register
Panorama with the ZTP service to enable the ZTP service to associate ﬁrewalls with the
Panorama. As part of the registraon process, add your ZTP ﬁrewalls to a device group and
template that contain the required ZTP conﬁguraon to connect your ZTP ﬁrewalls with the ZTP
service aer they ﬁrst connect to Panorama.
STEP 1 | Install the Panorama Device Cerﬁcate.
STEP 2 | Log in to the Palo Alto Networks Customer Support Portal (CSP).
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STEP 3 | Associate your Panorama with the ZTP Service on the Palo Alto Networks CSP.
The ZTP Service supports associang up to two Panoramas only if they are in a high availability
(HA) conﬁguraon. If Panorama is not in an HA conﬁguraon, only a single Panorama can be
associated.
1. Select Assets > ZTP Service and Modify Associaon.
2. Select the serial number of the Panorama managing your ZTP ﬁrewalls.
3. (HA only) Select the serial number of the Panorama HA peer.
4. Click OK.
STEP 4 | Log in to the Panorama Web Interface.
STEP 5 | Select Panorama > Zero Touch Provisioning > Setup and edit the General ZTP sengs.
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STEP 6 | Register Panorama with the ZTP service.
1. Enable ZTP Service.
2. Enter the Panorama FQDN or IP Address.
This is the FQDN or public IP address of the Panorama the ZTP plugin is installed on and
that the CSP pushes to the ZTP ﬁrewalls.
(Managed ﬁrewalls running PAN-OS 10.1.4 and earlier releases) Enter the
Panorama IP address to avoid the managed ﬁrewall disconnecng from
Panorama on reboot or aer a successful PAN-OS upgrade.
If you need to use the Panorama FQDN, conﬁgure a stac desnaon route to
avoid the managed ﬁrewall disconnecng from Panorama on reboot or aer a
successful PAN-OS upgrade.
3. (HA only) Enter the Peer FQDN or IP Address.
This is the FQDN or public IP address of the Panorama peer on which the ZTP plugin is
installed and that the CSP pushes to the ZTP ﬁrewalls in case of failover.
(Managed ﬁrewalls running PAN-OS 10.1.4 and earlier releases) Enter the
Panorama IP address to avoid the managed ﬁrewall disconnecng from
Panorama on reboot or aer a successful PAN-OS upgrade.
If you need to use the Panorama FQDN, conﬁgure a stac desnaon route to
avoid the managed ﬁrewall disconnecng from Panorama on reboot or aer a
successful PAN-OS upgrade.
4. Click OK to save your conﬁguraon changes.

STEP 7 | Add your ZTP ﬁrewalls to the device group and template that will contain the required ZTP
conﬁguraon.
1. Select Panorama > Device Groups and select the device group that will contain the
required ZTP conﬁguraon.
2. Select the ZTP Devices.
3. Click OK to save your conﬁguraon changes.
4. Select Panorama > Templates and select the template stack that contains the template
that will have the required ZTP conﬁguraon.
5. Select the ZTP Devices.
6. Click OK to save your conﬁguraon changes.

Panorama Administrator's Guide Version Version 10.1

300

©2022 Palo Alto Networks, Inc.

Manage Firewalls
STEP 8 | Modify your device groups and templates as needed.
When considering your device group hierarchy and template priority in your template
stack, ensure that the device group and template containing the required ZTP conﬁguraon
that allows the ZTP ﬁrewall and Panorama to communicate have priority such that the
conﬁguraon is not overridden in the event of conﬂicng conﬁguraons.
1. Conﬁgure the Ethernet1/1 interface.
1. Select Network > Interfaces > Ethernet, select a Template to contain your ZTP
conﬁguraon and select ethernet1/1.
2. For Interface Type, select Layer3.
3. Select Conﬁg and conﬁgure a Virtual Router and set the Security Zone to Untrust.
4. Select IPv4 and for the Type, select DHCP Client.
A DHCP client is required for the ZTP ﬁrewalls to communicate with the ZTP
service.
5. Press OK to save your conﬁguraon changes.
2. Create the loopback interface
1. Select Network > Interfaces > Loopback, select a Template to contain your ZTP
conﬁguraon and Add a loopback interface.
2. For the Interface Name, enter loopback and enter the 900 suﬃx.
3. Select Conﬁg, select a Virtual Router, and set the Security Zone to Trust.
4. Press OK to save your conﬁguraon changes.
3. Create the Security policy rule to allow the ZTP ﬁrewall and Panorama to communicate.
1. Select Policies > Security > Pre Rules, select the Device Group to contain your ZTP
policy rules, and Add a new rule.
2. Enter a descripve Name for the policy rule.
3. Select Source > Source Zone and Add the Trust zone.
4. Select Desnaon > Desnaon Zone and Add the Untrust zone.
5. Select Acon > Acon Sengs > Acon and select Allow.
4. Create the NAT policy rule to allow the ZTP ﬁrewall and Panorama to communicate.
1. Select Policies > NAT > Pre Rules, select the Device Group to contain your ZTP policy
rules, and Add a new rule.
2. Enter a descripve Name for the policy rule.
3. Select Original Packet and conﬁgure the following:
1. For the Source Zone, Add the Trust zone.
2. For the Desnaon Zone, select the Untrust zone.
3. For the Desnaon Interface, select the ethernet1/1 interface.
4. Click OK to save your conﬁguraon changes.
STEP 9 | Select Commit and Commit to Panorama
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STEP 10 | Sync to ZTP Service and verify that the Panorama Sync Status displays as In Sync.

Conﬁgure the ZTP Installer Administrator Account
The ZTP installer admin user is an administrator account created for non-IT staﬀ or installaon
contractor to on-board new ZTP ﬁrewalls. The installer admin uses an automacally created
installeradmin admin role to limit visibility into the Panorama web interface and only allow
the installer the ability to enter the ZTP ﬁrewall claim key and serial number on Panorama.
STEP 1 | Log in to the Panorama Web Interface.
STEP 2 | Select Panorama > Admin Roles and verify that the installeradmin admin role is created.
The installeradmin is automacally created aer you successfully install the ZTP plugin on
Panorama.
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STEP 3 | Conﬁgure the ZTP installer administrator user.
1. Select Panorama > Administrators and Add a new admin user.
2. Enter a descripve Name for the ZTP installer admin user.
3. Enter a secure Password and Conﬁrm Password.
4. For the Administrator Type, select Custom Panorama Admin.
5. For the Proﬁle, select installeradmin
6. Click OK to save your conﬁguraon changes.

STEP 4 | Select Commit and Commit to Panorama.

Add ZTP Firewalls to Panorama
You can add a single ZTP ﬁrewall or import mulple ZTP ﬁrewalls to the Panorama™ management
server.
• Add a ZTP Firewall to Panorama
• Import Mulple ZTP Firewalls to Panorama

Add a ZTP Firewall to Panorama
Log in to the web interface of the Panorama™ management server as a Superuser, Panorama
admin, or as the ZTP installer admin to add a ZTP ﬁrewall to Panorama. To add the ZTP ﬁrewall,
you must enter the ﬁrewall serial number and claim key provided by Palo Alto Networks and then
register the ﬁrewall with the ZTP service. Registering the ﬁrewall claims the ﬁrewall as an asset in
your account in the Customer Support Portal and allows the ZTP service to associate the ﬁrewall
with the Panorama.
While adding ZTP ﬁrewalls to Panorama, do not perform any commits on the ZTP ﬁrewall
before you verify that the ﬁrewall is successfully added to Panorama in Step 4. Performing
a local commit on the ZTP ﬁrewall disables ZTP funconality and results in the failure to
successfully add the ﬁrewall to Panorama.
STEP 1 | Log in to the Panorama Web Interface.
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STEP 2 | Add a ZTP ﬁrewall to Panorama.
You must connect the Eth1/1 interface on ZTP ﬁrewalls to successfully register ZTP
ﬁrewalls with the CSP and push the policy and network conﬁguraons.
1. Select Firewall Registraon and Add a new ZTP ﬁrewall.
2. Enter the Serial Number of the ZTP ﬁrewall.
3. Enter the Claim Key for the ZTP ﬁrewall provided by Palo Alto Networks.
The eight digit numeric claim key is printed on a physical label aached to the back of
the ZTP ﬁrewall you received from Palo Alto Networks.

4. Click OK to save your conﬁguraon changes.

STEP 3 | Register the ZTP ﬁrewall.
1. Select the newly added ZTP ﬁrewall and Register the ﬁrewall.
2. When prompted, click Yes to conﬁrm registering the ZTP ﬁrewall.
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STEP 4 | Verify the ﬁrewall successfully registered with the CSP.
The ﬁrewall must successfully register with the CSP to successfully obtain device
cerﬁcate.
1. Select Registraon Status and verify that the ZTP ﬁrewall successfully registered with
the CSP.

2. Log in to the Panorama Web Interface using admin credenals.
3. Select Panorama > Managed Devices > Summary and verify that the ZTP ﬁrewall is
successfully added as a managed ﬁrewall.
Ensure that the To SW Version column is conﬁgured to the correct PAN-OS
version so that the ﬁrewall does not upgrade or downgrade unintenonally.
ZTP funconality is supported only for PAN-OS 10.0.1 and later releases.
Addionally, the PAN-OS version must be the same or an earlier version of the
PAN-OS version running on Panorama.
For more informaon, see Upgrade a ZTP Firewall.
STEP 5 | Add the ZTP ﬁrewall to device group and template stack.
You must add the ZTP ﬁrewall to a device group and template stack for your ﬁrewalls to display
as Connected to push policy and network conﬁguraons.
1. Log in to the Panorama Web Interface using admin credenals.
2. Select Panorama > Device Groups, add a device group, and the ZTP ﬁrewall to the device
group.
Add a device group to create and conﬁgure a new device group to contain the policy
objects and rules for your ZTP ﬁrewalls.
3. Select Panorama > Templates, conﬁgure a template stack, and the ZTP ﬁrewall to the
template stack.
Conﬁgure a template stack to create and conﬁgure a new template stack to contain the
network conﬁguraon for your ZTP ﬁrewalls.
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Import Mulple ZTP Firewalls to Panorama
Log in to the web interface of the Panorama™ management server as a Superuser, Panorama
admin, or as the ZTP installer admin to import mulple ZTP ﬁrewalls to Panorama. To import
mulple ZTP ﬁrewalls, you must import a CSV ﬁle of the ZTP ﬁrewall serial number and
corresponding claim key provided by Palo Alto Networks and then register the ﬁrewalls with the
ZTP service. Registering the ﬁrewall claims the ﬁrewalls as assets in your account in the Customer
Support Portal and allows the ZTP service to associate the ﬁrewalls with the Panorama.
While adding ZTP ﬁrewalls to Panorama, do not perform any commits on the ZTP ﬁrewall
before you verify that the ﬁrewall is successfully added to Panorama in Step 5. Performing
a local commit on the ZTP ﬁrewall disables ZTP funconality and results in the failure to
successfully add the ﬁrewall to Panorama.
STEP 1 | Gather the serial numbers and claim keys for your ZTP ﬁrewalls.
The eight digit numeric claim key is printed on a physical label aached to the back of the ZTP
ﬁrewall you received from Palo Alto Networks.

STEP 2 | Create a CSV ﬁle containing the ZTP ﬁrewall serial numbers and claim keys. The ﬁrst column
must contain the serial numbers and the second column must contain the corresponding
claim key for that ﬁrewall. Refer to the following example for reference.

STEP 3 | Import the ZTP ﬁrewalls to Panorama.
You must connect the Eth1/1 interface on ZTP ﬁrewalls to successfully register ZTP
ﬁrewalls with the CSP and push the policy and network conﬁguraons.
1. Log in to the Panorama Web Interface using the ZTP installer admin credenals.
2. Select Panorama > Zero Touch Provisioning > Firewall Registraon and Import the ZTP
ﬁrewalls.
3. Browse and select the CSV ﬁle containing the ZTP ﬁrewall informaon and click OK.
STEP 4 | Register the ZTP ﬁrewalls.
1. Select the newly added ZTP ﬁrewalls and Register the ﬁrewalls.
2. When prompted, click Yes to conﬁrm registering the ZTP ﬁrewalls.
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STEP 5 | Verify the ﬁrewall successfully registered with the ZTP service.
1. Select Registraon Status and verify that the ZTP ﬁrewalls successfully registered with
the ZTP service.
2. Log in to the Panorama Web Interface using admin credenals.
3. Select Panorama > Managed Devices > Summary and verify that the ZTP ﬁrewalls are
successfully added as a managed ﬁrewall.
Ensure that the To SW Version column is conﬁgured to the correct PAN-OS
version so that the ﬁrewall does not upgrade or downgrade unintenonally.
ZTP funconality is supported only for PAN-OS 10.0.1 and later releases.
Addionally, the PAN-OS version must be the same or an earlier version of the
PAN-OS version running on Panorama.
For more informaon, see Upgrade a ZTP Firewall.
STEP 6 | Add the ZTP ﬁrewalls to a device group and template stack.
You must add the ZTP ﬁrewall to a device group and template stack for your ﬁrewalls to display
as Connected to push policy and network conﬁguraons.
1. Log in to the Panorama Web Interface using admin credenals.
2. Select Panorama > Device Groups and assign the ﬁrewalls to the appropriate device
group.
Add a device group to create and conﬁgure a new device group to contain the policy
objects and rules for your ZTP ﬁrewalls.
3. Select Panorama > Templates and assign the ﬁrewalls to the appropriate template stack.
Conﬁgure a template stack to create and conﬁgure a new template stack to contain the
network conﬁguraon for your ZTP ﬁrewalls.

Use the CLI for ZTP Tasks
Use the following CLI commands to perform Zero Touch Provisioning (ZTP) tasks and view the
ZTP service status.
If you want to ...

Use ...

Administer the ﬁrewall from the ﬁrewall CLI
Display the connecon status to the ZTP
service.

> show system ZTP status

Display the connecon status to the
Panorama management server.

> show panorama status

Display the ZTP model number and ﬁrewall
system informaon.

> show system info
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If you want to ...

Use ...

Disable the ZTP state machine on the ﬁrewall.
Running this command does not delete any
exisng ZTP conﬁguraon.

> request disable-ztp

You cannot re-enable the ZTP
state machine on the ﬁrewall aer
it is disabled from the CLI.
To re-enable, you must reset
the ﬁrewall to factory default
sengs.
Register, conﬁgure, and manage your ZTP ﬁrewalls from Panorama
Create a device group or template containing
the necessary conﬁguraons to connect
managed ﬁrewalls with Panorama using the
ZTP service on the Eth1/1 interface.

> request plugins ztp create dgr
oup-template device-group <devic
e group name>
> request plugins ztp create dgr
oup-template template <template
name>

Add a ZTP ﬁrewall to the list of ﬁrewalls for
future registraon with the ZTP service.

> request plugins ztp firewall-a
dd <serial number> claim-key <cl
aim key>

Modify the serial number of a ZTP ﬁrewall
that has already been added to the list of
ﬁrewalls for future registraon with the ZTP
service.
Delete a ZTP ﬁrewall from the list of ﬁrewalls
for future registraon with the ZTP service.

Add a ZTP ﬁrewall to the list of ﬁrewalls for
future re-registraon with the ZTP service.
Use this command when a ZTP ﬁrewall
inially fails registraon with the ZTP service
and needs.
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If you want to ...

Use ...

Register your Panorama™ management server
with the ZTP service.

Register a ZTP ﬁrewall with the ZTP service.

Re-register ZTP ﬁrewalls with the ZTP service.
Use this command to start the re-registraon
process for a ZTP ﬁrewall that failed inial
registraon with the ZTP service.
Import ZTP ﬁrewall serial number and claim
key informaon.

> request plugins ztp panorama-r
egistration

> request plugins ztp firewall-r
egistration firewall <serial num
ber> claim-key <claim key>

> request plugins ztp firewall-r
egister-retry firewall <serial n
umber> claim-key <claim key>

> request plugins ztp ztp-add-im
port import-path <file path>

The speciﬁed ﬁle must be in CSV format.

View ZTP ﬁrewall informaon and ZTP service status from Panorama
Retrieve the list of ZTP ﬁrewalls registered to
the Panorama from the ZTP service.

> request plugins ztp ztp-servic
e-info
The following details are displayed:
• first-firewall-connect-time—
Timestamp of when the ZTP ﬁrewall ﬁrst
connected to the ZTP service.
• last-firewall-connect-time—
Timestamp of when the ZTP ﬁrewall last
connected to the ZTP service.
• registration-time—Timestamp of
when the ZTP ﬁrewall registered with the
ZTP service.
• isZTPFirewall—Whether the ﬁrewall is
a ZTP ﬁrewall.
• created_by—Administrave user that
added the ZTP ﬁrewall.
• IP address—IP address of the ZTP
ﬁrewall.

Panorama Administrator's Guide Version Version 10.1

309

©2022 Palo Alto Networks, Inc.

Manage Firewalls
If you want to ...

Use ...

View the list of ZTP ﬁrewalls in the list of
ﬁrewalls to be registered with the ZTP service.

View the registraon status of your ZTP
ﬁrewalls.

> show plugins ztp device-add-l
ist

> show plugins ztp device-reg-st
atus

View the ZTP service synchronizaon status
for ZTP ﬁrewalls.

Show the full management plane ZTP
connecvity history.

> request plugins ztp ztp-sync-s
tatus

> tail follow yes mp-log ms.log

This is helpful for troubleshoong
connecvity to the ZTP service.

Uninstall the ZTP Plugin
Follow the procedure to remove the ZTP conﬁguraon from your Panorama™ management server
and uninstall the ZTP plugin. If your Panorama is in a high availability (HA) conﬁguraon, repeat
these steps on both Panorama HA peers.
STEP 1 | Log in to the Panorama Web Interface.
STEP 2 | Delete the ZTP installer administrator account.
1. Select Panorama > Administrators and select the ZTP installer administrator account you
previously conﬁgured.
2. Delete the ZTP installer administrator account.
3. Select Panorama > Administrators and select the installeradmin admin role.
4. Delete the installeradmin admin role.
5. Select Commit and Commit to Panorama.
STEP 3 | Uninstall the ZTP plugin
1. Select Panorama > Plugins and navigate to the ZTP plugin installed on Panorama.
2. In the Acons column, Remove Conﬁg to delete ZTP related conﬁguraons from
Panorama
3. Click OK when prompted to conﬁrm removing the ZTP conﬁguraon from Panorama.
4. Select Commit and Commit to Panorama.
5. Uninstall the ZTP plugin.
6. Click OK when prompted to uninstall the ZTP plugin from Panorama.
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Manage Device Groups
• Add a Device Group
• Create a Device Group Hierarchy
• Create Objects for Use in Shared or Device Group Policy
• Revert to Inherited Object Values
• Manage Unused Shared Objects
• Manage Precedence of Inherited Objects
• Move or Clone a Policy Rule or Object to a Diﬀerent Device Group
• Select a URL Filtering Vendor on Panorama
• Push a Policy Rule to a Subset of Firewalls
• Device Group Push to a Mul-VSYS Firewall
• Manage the Rule Hierarchy

Add a Device Group
Aer adding ﬁrewalls (see Add a Firewall as a Managed Device), you can group them into Device
Groups (up to 1,024), as follows. Be sure to assign both ﬁrewalls in an acve-passive high
availability (HA) conﬁguraon to the same device group so that Panorama will push the same
policy rules and objects to those ﬁrewalls. PAN-OS doesn’t synchronize pushed rules across HA
peers. To manage rules and objects at diﬀerent administrave levels in your organizaon, Create a
Device Group Hierarchy.
STEP 1 | Select Panorama > Device Groups, and click Add.
STEP 2 | Enter a unique Name and a Descripon to idenfy the device group.
STEP 3 | In the Devices secon, select check boxes to assign ﬁrewalls to the group. To search a long
list of ﬁrewalls, use the Filters.
You can assign any ﬁrewall to only one device group. You can assign each virtual
system on a ﬁrewall to a diﬀerent device group.
STEP 4 | In the Reference Template secon, Add any templates or template stacks with objects
referenced by the device group conﬁguraon.
You must assign the appropriate template or template stack references to the device group
in order to successfully associate the template or template stack to the device group. This
allows you to reference objects conﬁgured in a template or template stack without adding an
unrelated device to a template stack.
Skip this step if the device group conﬁguraon does not reference any objects conﬁgured in a
template or template stack.
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STEP 5 | (Oponal) Select Group HA Peers for ﬁrewalls that are HA peers.
You can only group managed ﬁrewall HA peers if they are in the same device group.
The ﬁrewall name of the passive or acve-secondary peer is in parentheses. Grouping
HA peers is a visual change and no conﬁguraon change occurs.
STEP 6 | Select the Parent Device Group (default is Shared) that will be just above the device group
you are creang in the device group hierarchy.
STEP 7 | If your policy rules will reference users and groups, assign a Master ﬁrewall.
This will be the only ﬁrewall in the device group from which Panorama gathers username and
user group informaon.
STEP 8 | Click OK to save your changes.
STEP 9 | Select Commit > Commit and Push and then Commit and Push your changes to the
Panorama conﬁguraon and to the device group you added.

Create a Device Group Hierarchy
STEP 1 | Plan the Device Group Hierarchy.
1. Decide the device group levels, and which ﬁrewalls and virtual systems you will assign
to each device group and the Shared locaon. You can assign any one ﬁrewall or virtual
system (vsys) to only one device group. If a device group will be just an organizaonal
container for lower level device groups, you don’t need to assign ﬁrewalls to it.
2. Remove ﬁrewall or vsys assignments from exisng device groups if those assignments
don’t ﬁt your planned hierarchy.
1. Select Panorama > Device Groups and select the device group.
2. In the Devices secon, clear the check boxes of ﬁrewalls and virtual systems you want
to remove, and click OK.
3. If necessary, add more ﬁrewalls that you will assign to device groups: see Add a Firewall
as a Managed Device.
4. If you are using mulple Panorama plugins to perform endpoint monitoring, a device
group containing ﬁrewalls deployed in a parcular hypervisor cannot be the child or
parent of a device group containing ﬁrewalls deployed in a diﬀerent hypervisor. See
Device Group Hierarchy for more informaon.
STEP 2 | For each top-level device group, Add a Device Group.
1. In the Panorama > Device Groups page, click Add and enter a Name to idenfy the
device group.
2. In the Devices secon, select check boxes to assign ﬁrewalls and virtual systems to the
device group.
3. Leave the Parent Device Group opon at Shared (the default) and click OK.
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STEP 3 | For each lower-level device group, Add a Device Group.
• For new device groups at each lower level, repeat the previous step, but set the Parent
Device Group to a device group at the next level above.
• For each exisng device group, in the Device Groups page, select the device group to edit it,
select a Parent Device Group, and click OK.
If you move a device group to a diﬀerent parent, all its descendant device groups move
with it, along with all ﬁrewalls, policy rules, and objects associated with the device
group and its descendants. If the new parent is in another access domain, the moved
device group will no longer have membership in the original access domain. If the new
access domain has read-write access for the parent device group, it will also have
read-write access for the moved device group. If the new access domain has read-only
access for the parent, it will have no access for the moved device group. To reconﬁgure
access for device groups, see Conﬁgure an Access Domain.
STEP 4 | Conﬁgure, move, and clone objects and policy rules as needed to account for inheritance in
the device group hierarchy.
• Create Objects for Use in Shared or Device Group Policy, or edit exisng objects.
You can edit objects only at their locaon: the device group to which they are assigned.
Descendant device groups inherit read-only instances of the objects from that locaon.
However, you can oponally see Step Override inherited object values.
• Create or edit policies.
• Move or Clone a Policy Rule or Object to a Diﬀerent Device Group.
STEP 5 | Override inherited object values.
Applicable only if object values in a parcular device group must diﬀer from the values
inherited from an ancestor device group.
Aer overriding an object, you can override it again in descendant device groups. However,
you can never override shared or predeﬁned (default) objects.
In the Objects tab, inherited objects have a green icon in the Name column, and the Locaon
column displays the ancestor device group.
1. In the Objects tab, select the object type (for example, Objects > Addresses).
2. Select the Device Group that will have the override instance.
3. Select the object and click Override.
4. Edit the values. You can’t edit the Name or Shared sengs.
5. Click OK. The Name column displays a yellow-overlapping-green icon for the object to
indicate it is overridden.
If necessary, you can later Revert to Inherited Object Values.
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STEP 6 | Save and commit your changes.
Commit to Panorama and push to device groups aer any change to the hierarchy.
You must also push changes to templates if a template references objects in a device group
(such as interfaces referencing addresses), and a ﬁrewall assigned to the template is no longer
assigned to that device group because of a hierarchy change.
Select Commit > Commit and Push and then Commit and Push your changes to the Panorama
conﬁguraon and to the device groups you added or changed.

Create Objects for Use in Shared or Device Group Policy
You can use an object in any policy rule that is in the Shared locaon, or in the same device group
as the object, or in descendants of that device group (for details, see Device Group Objects).
Shared device group objects can be viewed and referenced in a speciﬁc device group. Changing
the name of a Shared device group object in one device group changes the name of the Shared
object in all device groups. This includes any conﬁguraon the Shared object is referenced, such
as in Policy rules. Changing the name of a Shared device group object may cause the conﬁguraon
push to managed ﬁrewalls to fail.
For example, you create a Shared object named ObjectA and create a Security policy rule in the
DG1 device group where ObjectA is referenced. This conﬁguraon is pushed to your managed
ﬁrewalls. Later in the DG1 device group, you change the name of ObjectA to ObjectB and try to
push the conﬁguraon to your managed ﬁrewalls. This push fails because your managed ﬁrewalls
have the Shared object with the name ObjectA as part of their conﬁguraon, and are expecng
that conﬁguraon object to have the same name.
See Use Dynamic Address Groups in Policy to verify the number of supported registered
IP addresses on Panorama if you intended to leverage dynamic address groups in order to
create policies that automacally adapt to changes in your network.
Create a shared object.
In this example, we add a shared object for URL Filtering categories for which we want to
trigger alerts.
1. Select the Objects > Security Proﬁles > URL Filtering tab and click Add.
The Objects tab appears only aer you Add a Device Group (at least one).
2. Enter a Name and a Descripon.
3. Select Shared.
4. The Disable Override opon is cleared by default, which means you can override
inherited instances of the object in all device groups. To disable overrides for the object,
select the check box.
5. In the Categories tab, select every Category for which you want noﬁcaon.
6. In the Acon column, select Alert.
7. Click OK to save your changes to the object.
8. Select Commit > Commit to Panorama and Commit your changes.
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Create a device group object.
In this example, we add an address object for speciﬁc web servers on your network.
1. Select Objects > Addresses and select the Device Group in which you will use the
object.
2. Click Add and enter a Name to idenfy the object.
3. Be sure to leave the Shared opon cleared.
4. The Disable Override opon is cleared by default, which means you can override
inherited instances of the object in device groups that are descendants of the selected
Device Group. To disable overrides for the object, select the Disable Override opon.
5. Select the Type of address object and the associated value. For example, select IP Range
and enter the IP address range for the web servers.
6. Click OK to save your changes to the object.
7. Select Commit > Commit and Push and then Commit and Push your changes to the
Panorama conﬁguraon and to the device group where you added the object.
When you acvate an anvirus license on a ﬁrewall, a list of predeﬁned IP lists
are automacally added to the ﬁrewall. As a result, this reduces the total number
of individual address objects, dynamic groups, external IP lists, predeﬁned IP
block lists, and external predeﬁned IP lists you can push from Panorama.
View shared objects and device group objects in Panorama.
In the pages of the Objects tab, the Locaon column indicates whether an object is shared or is
speciﬁc to a device group.
1. In the Objects tab, select the object type (Objects > Addresses, in this example).
2. Select the Device Group to which you added the object.
The Objects tab only displays objects that are in the selected Device Group or
are inherited from an ancestor device group or the Shared locaon.
3. Verify that the device group object appears. Note that the device group name in the
Locaon column matches the selecon in the Device Group drop-down.

Revert to Inherited Object Values
Aer overriding the values that a device group object inherits from an ancestor device group, you
can revert the object to its ancestor values at any me. In the Objects tab, overridden objects
have a yellow-overlapping-green icon (
) in the Name column.
If you want to push ancestor values to all overridden objects instead of reverng a speciﬁc
object, see Manage Precedence of Inherited Objects.
For the steps to override values, see Step 5
For details on object inheritance and overrides, see Device Group Objects.
STEP 1 | In the Objects tab, select the object type (for example, Objects > Addresses) and select the
Device Group that has an override instance of the object.
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STEP 2 | Select the object, click Revert, and click Yes. The Name column displays a green icon for the
object, indicang that it now inherits all values from an ancestor device group.
STEP 3 | Select Commit > Commit and Push and then Commit and Push your changes to the
Panorama conﬁguraon and to the device group where you reverted the object.

Manage Unused Shared Objects
When you push conﬁguraon changes Device Groups, by default Panorama pushes all shared
objects to ﬁrewalls whether or not any shared or device group policy rules reference the objects.
However, you can conﬁgure Panorama to push only the shared objects that rules reference in the
device groups. The Share Unused Address and Service Objects with Devices opon enables you
to limit the objects that Panorama pushes to the managed ﬁrewalls.
When Share Unused Address and Service Objects with Devices is disabled, Panorama
ignores the Target ﬁrewalls when you Push a Policy Rule to a Subset of Firewalls. This
means that all objects referenced by any rules are pushed to all ﬁrewalls in the device
group.
To limit the number of objects pushed to a set of managed ﬁrewalls, add the policy rules to
a child device group and reference shared objects as needed. See Create a Device Group
Hierarchy for more informaon on creang a child device group.
On lower-end models, such as the PA-220, consider pushing only the relevant shared objects to
the managed ﬁrewalls. This is because the number of objects that can be stored on the lower-end
models is considerably lower than that of the mid- to high-end models. Also, if you have many
address and service objects that are unused, clearing Share Unused Address and Service Objects
with Devices reduces the commit mes signiﬁcantly on the ﬁrewalls because the conﬁguraon
pushed to each ﬁrewall is smaller. However, disabling this opon might increase the commit
me on Panorama because Panorama has to dynamically check whether policy rules reference a
parcular object.
STEP 1 | Select Panorama > Setup > Management, and edit the Panorama Sengs.
STEP 2 | Clear the Share Unused Address and Service Objects with Devices opon to push only
the shared objects that rules reference, or select the opon to re-enable pushing all shared
objects.
STEP 3 | Click OK to save your changes.
STEP 4 | Select Commit > Commit to Panorama and Commit your changes.

Manage Precedence of Inherited Objects
By default, when device groups at diﬀerent levels in the Device Group Hierarchy have an object
with the same name but diﬀerent values (because of overrides, as an example), policy rules in a
descendant device group use the object values in that descendant instead of using object values
inherited from ancestor device groups. Oponally, you can reverse this order of precedence to
push values from the highest ancestor containing the object to all descendant device groups. Aer
you enable this opon, the next me you push conﬁguraon changes to device groups, the values
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of inherited objects replace the values of any overridden objects in the descendant device groups.
The ﬁgure below demonstrates the precedence of inherited objects in a device group:

If a ﬁrewall has locally deﬁned objects with the same name as shared or device group
objects that Panorama pushes, a commit failure occurs.
If you want to revert a speciﬁc overridden object to its ancestor values instead of pushing
ancestor values to all overridden objects, see Revert to Inherited Object Values.
STEP 1 | Select Panorama > Setup > Management and edit the Panorama Sengs.
STEP 2 | If you want to reverse the default order of precedence, select Objects deﬁned in ancestors
will take higher precedence. The dialog then displays the Find Overridden Objects link,
which provides the opon to see how many overridden (shadowed) objects will have
ancestor values aer you commit this change. You can hover over the quanty message to
display the object names.
If you want to revert to the default order of precedence, clear Objects deﬁned in ancestors will
take higher precedence.
Find Overridden Objects only detects a Shared device group object that shares a name
with another object in the device group.
STEP 3 | Click OK to save your changes.
STEP 4 | Select Commit > Commit to Panorama and Commit your changes.
STEP 5 | (Oponal) If you selected Objects deﬁned in ancestors will take higher precedence,
Panorama does not push the ancestor objects unl you push conﬁguraon changes to device
groups: select Commit > Push to Devices and Push your changes.

Move or Clone a Policy Rule or Object to a Diﬀerent Device Group
On Panorama, if a policy rule or object that you will move or clone from a device group has
references to objects that are not available in the target device group (Desnaon), you must
move or clone the referenced objects and the referencing rule or object in the same operaon.
In a Device Group Hierarchy, remember that referenced objects might be available through
inheritance. For example, shared objects are available in all device groups. You can perform
a global ﬁnd to check for references. If you move or clone an overridden object, be sure that
overrides are enabled for that object in the parent device group of the Desnaon (see Create
Objects for Use in Shared or Device Group Policy).
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When cloning mulple policy rules, the order by which you select the rules will determine
the order they are copied to the device group. For example, if you have rules 1-4 and your
selecon order is 2-1-4-3, the device group where these rules will be cloned will display
the rules in the same order you selected. However, you can reorganize the rules as you see
ﬁt once they have been successfully copied.
STEP 1 | Log in to Panorama and select the rulebase (for example, Policy > Security > Pre Rules) or
object type (for example, Objects > Addresses).
STEP 2 | Select the Device Group and select one or more rules or objects.
STEP 3 | Perform one of the following steps:
• (Rules only) Move > Move to other device group
• (Objects only) Move
• (Rules or objects) Clone
STEP 4 | In the Desnaon drop-down, select the new device group or Shared. The default is
previously selected Device Group.
STEP 5 | (Rules only) Select the Rule order:
• Move top (default)—The rule will come before all other rules.
• Move boom—The rule will come aer all other rules.
• Before rule—In the adjacent drop-down, select the rule that comes aer the Selected Rules.
• Aer rule—In the adjacent drop-down, select the rule that comes before the Selected Rules.
STEP 6 | The Error out on ﬁrst detected error in validaon check box is selected by default, which
means Panorama will display the ﬁrst error it ﬁnds and stop checking for more errors.
For example, an error occurs if the Desnaon device group doesn't have an object that
is referenced in the rule you are moving. When you move or clone many items at once,
selecng this check box can simplify troubleshoong. If you clear the check box, Panorama
will ﬁnd all the errors before displaying them. Regardless of this seng, Panorama won’t
move or clone anything unl you ﬁx all the errors for all the selected items.
STEP 7 | Click OK to start the error validaon. If Panorama ﬁnds errors, ﬁx them and retry the move or
clone operaon. If Panorama doesn't ﬁnd errors, it performs the operaon.
STEP 8 | Select Commit > Commit and Push, Edit Selecons in the Push Scope, select Device Groups,
select the original and desnaon device groups, click OK, and then Commit and Push your
changes to the Panorama conﬁguraon and to the device groups.

Select a URL Filtering Vendor on Panorama
URL ﬁltering enables ﬁrewalls to monitor and control web access for your users. The policy rules
that you conﬁgure to control web access (Security, QoS, Capve Portal, and Decrypon rules)
reference URL categories. The URL ﬁltering vendor you select on Panorama determines which
URL categories are available for referencing in the rules that you add to device groups and push to
ﬁrewalls.
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By default, Panorama uses PAN-DB, a URL ﬁltering database that is ghtly integrated into PANOS and the Palo Alto Networks threat intelligence cloud. PAN-DB provides high-performance
local caching to maximize in-line performance for URL lookups. The other vendor opon is
BrightCloud, a third-party URL database.
Unlike ﬁrewalls, Panorama does not download the URL database and does not require a
URL ﬁltering license.
The following topics describe how to change the URL ﬁltering vendor on Panorama or on both
Panorama and managed ﬁrewalls. You can also change the URL ﬁltering vendor on just the
ﬁrewalls.
• Must Panorama and Firewalls Have Matching URL Filtering Vendors?
• Change the URL Filtering Vendor on HA Panorama
• Change the URL Filtering Vendor on non-HA Panorama
• Migrate Panorama and HA Firewalls from BrightCloud to PAN-DB
• Migrate Panorama and non-HA Firewalls from BrightCloud to PAN-DB

Must Panorama and Firewalls Have Matching URL Filtering Vendors?
On any single Panorama management server or ﬁrewall, only one URL ﬁltering vendor can be
acve: PAN-DB or BrightCloud. When selecng a vendor for Panorama, you must consider the
vendor and PAN-OS version of the managed ﬁrewalls:
• PAN-OS 5.0.x and earlier versions—Panorama and the ﬁrewalls require matching URL ﬁltering
vendors.
• PAN-OS 6.0 or later versions—Panorama and the ﬁrewalls do not require matching URL
ﬁltering vendors. If a vendor mismatch is detected, the ﬁrewall maps the URL categories in the
URL Filtering proﬁles and rules that it received from Panorama to URL categories that align
with those of the vendor enabled on the ﬁrewall.
Therefore, for a deployment in which some ﬁrewalls run PAN-OS 6.0 or later and some ﬁrewalls
run earlier PAN-OS versions, Panorama must use the same URL ﬁltering vendor as the ﬁrewalls
that run earlier PAN-OS versions. For example, if ﬁrewalls that run PAN-OS 5.0 use PAN-DB, and
ﬁrewalls that run PAN-OS 7.0 use BrightCloud, Panorama must use PAN-DB.

Change the URL Filtering Vendor on HA Panorama
In a high availability (HA) deployment, each Panorama peer must be in a non-funconal state
when you change the URL ﬁltering vendor. Therefore, to avoid disrupng Panorama operaons,
change the URL ﬁltering vendor on the passive Panorama (Panorama2 in this example) and then
trigger failover before changing the vendor on the acve Panorama (Panorama1 in this example).
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STEP 1 | Change the URL ﬁltering vendor on each Panorama HA peer.
Complete this task on Panorama2 (passive peer) before Panorama1 (acve peer).
1. Log in to the Panorama web interface.
2. Select Panorama > High Availability and Suspend local Panorama.
When you perform this step on Panorama1, failover occurs and Panorama2 becomes
acve.
3. Select Panorama > Setup > Management and edit the General Sengs.
4. Select the URL Filtering Database vendor: paloaltonetworks (PAN-DB) or brightcloud.
5. Select Panorama > High Availability and Make local Panorama funconal.
When you perform this step on Panorama1 with preempon enabled on both HA peers,
Panorama1 automacally reverts to acve status and Panorama2 reverts to passive
status.
STEP 2 | Verify that the URL categories are available for referencing in policies.
1. Select Objects > Security Proﬁles > URL Filtering.
2. Click Add and verify that the Categories tab of the URL Filtering proﬁle dialog displays
the URL categories associated with the selected vendor.

Change the URL Filtering Vendor on non-HA Panorama
Perform this procedure to change the URL ﬁltering vendor on a Panorama management server
that is not deployed in a high availability (HA) conﬁguraon.
STEP 1 | Change the URL ﬁltering vendor.
1. Select Panorama > Setup > Management and edit the General Sengs.
2. Select the URL Filtering Database vendor: paloaltonetworks (PAN-DB) or brightcloud.
STEP 2 | Verify that the URL categories are available for referencing in policies.
1. Select Objects > Security Proﬁles > URL Filtering.
2. Click Add and verify that the Categories tab of the URL Filtering proﬁle dialog displays
the URL categories associated with the selected vendor.

Migrate Panorama and HA Firewalls from BrightCloud to PAN-DB
Perform this procedure to migrate the URL ﬁltering vendor from BrightCloud to PAN-DB on
Panorama and ﬁrewalls when the ﬁrewalls are deployed in a high availability (HA) conﬁguraon.
In this example, the acve (or acve-primary) ﬁrewall is named fw1 and the passive (or acvesecondary) ﬁrewall is named fw2. The migraon automacally maps BrightCloud URL categories
to PAN-DB URL categories.
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STEP 1 | Determine which ﬁrewalls require new PAN-DB URL ﬁltering licenses.
1. Log in to Panorama and select Panorama > Device Deployment > Licenses.
2. Check the URL column to determine which ﬁrewalls have PAN-DB licenses and whether
the licenses are valid or expired.
A ﬁrewall can have valid licenses for both BrightCloud and PAN-DB, but only one license
can be acve.
If you’re not sure whether a PAN-DB URL ﬁltering license is acve, access the
ﬁrewall web interface, select Device > Licenses, and verify that the Acve ﬁeld
displays Yes in the PAN-DB URL Filtering secon.
3. Purchase a new license for each ﬁrewall that does not have a valid PAN-DB license.
In HA deployments, each ﬁrewall peer needs a disnct PAN-DB license and authorizaon
code. Palo Alto Networks sends an email containing acvaon codes for the licenses you
purchase. If you can’t ﬁnd this email, contact Customer Support before proceeding.
STEP 2 | Change the URL ﬁltering vendor to PAN-DB on Panorama.
Access the Panorama web interface and perform one of the following tasks:
• Change the URL Filtering Vendor on HA Panorama
• Change the URL Filtering Vendor on non-HA Panorama
STEP 3 | Conﬁgure the TCP session sengs on both ﬁrewall HA peers to ensure sessions that are not
yet synchronized will fail over when you suspend a peer.
Log in to the CLI of each ﬁrewall and run the following command:
> set session tcp-reject-non-syn no

Panorama Administrator's Guide Version Version 10.1

321

©2022 Palo Alto Networks, Inc.

Manage Firewalls
STEP 4 | Migrate the URL ﬁltering vendor to PAN-DB on each ﬁrewall HA peer.
Complete this task on fw2 (passive or acve-secondary peer) before fw1 (acve or
acve-primary peer).
1. Access the ﬁrewall web interface, select Device > High Availability > Operaonal
Commands, and Suspend local device.
Performing this step on fw1 triggers failover to fw2.
2. Select Device > Licenses.
3. In the License Management secon, select Acvate feature using authorizaon code,
enter the Authorizaon Code and click OK.
Acvang the PAN-DB license automacally deacvates the BrightCloud license.
4. In the PAN-DB URL Filtering secon, Download the seed ﬁle, select your region, and
click OK.
5. Commit and push your conﬁguraon changes:
1. Access the Panorama web interface.
2. Select Commit > Commit and Push and Edit Selecons in the Push Scope
3. Select Device Groups, select the ﬁrewall, and click OK.
4. Commit and Push your changes to the Panorama conﬁguraon and to device groups.
6. Access the ﬁrewall web interface, select Device > High Availability > Operaonal
Commands, and Make local device funconal.
When you perform this step on fw1 with preempon enabled on both ﬁrewalls, fw1
automacally reverts to acve (or acve-primary) status and fw2 reverts to passive (or
acve-secondary) status.
STEP 5 | Revert both ﬁrewall HA peers to the original TCP session sengs.
Run the following command at the CLI of each ﬁrewall:
> set session tcp-reject-non-syn yes

Migrate Panorama and non-HA Firewalls from BrightCloud to PAN-DB
Perform this procedure to migrate the URL ﬁltering vendor from BrightCloud to PAN-DB
on Panorama and ﬁrewalls when the ﬁrewalls are not deployed in a high availability (HA)
conﬁguraon. The migraon automacally maps BrightCloud URL categories to PAN-DB URL
categories.
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STEP 1 | Determine which ﬁrewalls require new PAN-DB URL ﬁltering licenses.
1. Log in to Panorama and select Panorama > Device Deployment > Licenses.
2. Check the URL column to determine which ﬁrewalls have PAN-DB licenses and whether
the licenses are valid or expired.
A ﬁrewall can have valid licenses for both BrightCloud and PAN-DB, but only one license
can be acve.
If you’re not sure whether a PAN-DB URL ﬁltering license is acve, access the
ﬁrewall web interface, select Device > Licenses, and verify that the Acve ﬁeld
displays Yes in the PAN-DB URL Filtering secon.
3. Purchase new licenses for the ﬁrewalls that don’t have valid PAN-DB licenses.
Palo Alto Networks sends an email containing acvaon codes for the licenses you
purchase. If you can’t ﬁnd this email, contact Customer Support before proceeding.
STEP 2 | Change the URL ﬁltering vendor to PAN-DB on Panorama.
Access the Panorama web interface and perform one of the following tasks:
• Change the URL Filtering Vendor on HA Panorama
• Change the URL Filtering Vendor on non-HA Panorama
STEP 3 | Migrate the URL ﬁltering vendor to PAN-DB on each ﬁrewall.
1. Access the ﬁrewall web interface and select Device > Licenses.
2. In the License Management secon, select Acvate feature using authorizaon code,
enter the Authorizaon Code, and click OK.
Acvang the PAN-DB license automacally deacvates the BrightCloud license.
3. In the PAN-DB URL Filtering secon, Download the seed ﬁle, select your region, and
click OK.
4. Commit and push your conﬁguraon changes:
1. Access the Panorama web interface.
2. Select Commit > Commit and Push and Edit Selecons in the Push Scope
3. Select Device Groups, select the ﬁrewall, and click OK.
4. Commit and Push your changes to the Panorama conﬁguraon and to device groups.

Push a Policy Rule to a Subset of Firewalls
A policy target allows you to specify the ﬁrewalls in a device group to which to push policy rules.
It allows you to exclude one or more ﬁrewalls or virtual systems, or to apply a rule only to speciﬁc
ﬁrewalls or virtual systems in a device group.
As your rulebase evolves and you push new or modiﬁed rules to ﬁrewalls, changes and audit
informaon get lost over me unless they are archived at the me the rule is created or modiﬁed.
Use the audit comment archive to view the audit comment and conﬁguraon log history of a
selected rule, as well to compare two policy rule versions to see how the rule changed. The
audit comment history for a rule pushed from Panorama is viewable only from the Panorama
management server. However, you can view the audit comments in the conﬁguraons logs
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forwarded to Panorama from managed ﬁrewalls. However, the audit comment archive is not
viewable for rules created or modiﬁed locally on the ﬁrewall. To ensure that audit comments are
captured at the me a rule is created or modiﬁed, Enforce Policy Rule, Descripon, Tag and Audit
Comment.
The ability to target a rule enables you to keep policies centralized on Panorama. Targeted rules
allow you to deﬁne the rules (as either shared or device group pre- or post-rules) on Panorama and
improve visibility and eﬃciency when managing the rules (see Device Group Policies). The audit
comment archive adds further visibility by allowing you to track how and why your policy rules
change over me so you can audit the rule evoluon over the course of the rule lifecycle.
STEP 1 | (Best Pracce) Enforce audit comments for policy rules.
Although this step is oponal, it is a best pracce to enforce audit comments for policy rules to
ensure that you capture the reason for creang or modifying the rule. This also helps maintain
an accurate rule history for auding purposes.
1. Select Panorama > Setup > Management and edit the Policy Rulebase Sengs.
2. Enable the opon to Require audit comment on policies.
3. Conﬁgure the Audit Comment Regular Expression to specify the audit comment format.
When creang or modifying a rule, require audit comments to adhere to a speciﬁc format
based on your business and auding needs by specifying leer and number expressions.
For example, you can use this seng to specify regular expressions to match your
ckeng number formats:
• [0-9]{<Number of digits>}—Requires the audit comment to contain a
minimum number of digits ranging from 0 to 9. For example, [0-9]{6} requires a
minimum of 6 digit numerical expression with numbers 0 to 9. Conﬁgure the minimum
number of digits as needed.
• <Letter Expression>—Requires the audit comment to contain a leer expression.
For example, Reason for Change- requires that the administrator to begin the
audit comment with this leer expression.
• <Letter Expression>-[0-9]{<Number of digits>}—Requires the audit
comment to contain a set character preﬁx with a minimum number of digits ranging
from 0 to 9. For example, SB-[0-9]{6} requires the audit comment format to begin
with SB-, followed by a minimum 6 digit numerical expression with numbers 0 to 9
such as SB-012345.
• (<Letter Expression>)|(<Letter Expression>)|(<Letter
Expression>)|-[0-9]{<Number of digits>}—Requires the audit comment to
contain a preﬁx using one of the conﬁgured set of leer expressions with a minimum
number of digits ranging from 0 to 9. For example, (SB|XY|PN)-[0-9]{6} requires
the audit comment format begin with SB-, XY-, or PN- followed by a minimum 6
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digit numerical expression with numbers 0 to 9 such as SB-012345, XY-654321, or
PN-012543.
4. Click OK to apply the new policy rulebase sengs.

5. Select Commit and Commit to Panorama.
STEP 2 | Create a rule.
In this example, we deﬁne a pre-rule in the Security rulebase that permits users on the internal
network to access the servers in the DMZ.
1. On the Policies tab and select the Device Group for which you want to deﬁne a rule.
2. Select the rulebase. For this example, select Policies > Security > Pre-Rules and Add a
rule.
3. In the General tab, enter a descripve rule Name and enter an Audit Comment.
4. In the Source tab, set the Source Zone to Trust.
5. In the Desnaon tab, set the Desnaon Zone to DMZ.
6. In the Service/ URL Category tab, set the Service to applicaon-default.
7. In the Acons tab, set the Acon to Allow.
8. Leave all the other opons set to their default values.
STEP 3 | Target the rule to include or exclude a subset of ﬁrewalls.
To apply the rule to a selected set of ﬁrewalls:
1. Select the Target tab in the Policy Rule dialog.
2. Select the ﬁrewalls to which you want to apply the rule.
If you do not select ﬁrewalls to target, the rule is added to all of the (unchecked) ﬁrewalls
in the device group.
By default, although the check box for the virtual systems in the device group is
disabled, all virtual systems will inherit the rule on commit unless you select one
or more virtual systems to which you want the rule to apply.
3. (Oponal) To exclude a subset of ﬁrewalls from inhering the rule, Install on all but
speciﬁed devices and select the ﬁrewalls you want to exclude.
If you Install on all but speciﬁed devices and do not select any ﬁrewalls, the rule
is not added to any of the ﬁrewalls in the device group.
4. Click OK to add the rule.
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STEP 4 | Commit and push the conﬁguraon changes.
1. Select Commit > Commit and Push and Edit Selecons in the Push Scope.
2. Select Device Groups, select the device group where you added the rule, and click OK.
3. Commit and Push your changes to the Panorama conﬁguraon and to device groups.
STEP 5 | Troubleshoot Policy Rule Traﬃc Match to verify that the rules allow and deny traﬃc as the
intended.

Device Group Push to a Mul-VSYS Firewall
Device group conﬁguraon changes pushed manually or from a scheduled conﬁguraon push of a
device groups from the Panorama™ management server to a mul-vsys ﬁrewall are automacally
bundled into a single job. When a push is executed from Panorama to managed ﬁrewalls,
Panorama inspects the managed ﬁrewalls associated with the device group push. If Panorama
detects that mulple vsys belonging to the same mul-vsys ﬁrewall are associated with a device
group push, it bundles the commit job for each vsys into a single commit job on the managed
ﬁrewall to reduce the overall commit job compleon me.
If one of the bundled commit jobs fails, then the enre push fails and you need to push enre
the device group conﬁguraon changes from Panorama again. Addionally, if mulple mul-vsys
ﬁrewalls are included in a push from Panorama and one push fails, then the enre push fails to all
ﬁrewalls included in the push from Panorama. When you monitor the device group push locally
on the ﬁrewall, a single job is displayed rather than mulple individual jobs. If any warnings are
failures occur, an error descripon indicang the impacted vsys is displayed.
This funconality is supported for mul-vsys ﬁrewalls managed by Panorama running PAN-OS
10.1 and later releases by default.

Manage the Rule Hierarchy
The order of policy rules is crical for the security of your network. Within any policy layer
(shared, device group, or locally deﬁned rules) and rulebase (for example, shared Security prerules), the ﬁrewall evaluates rules from top to boom in the order they appear in the pages of the
Policies tab. The ﬁrewall matches a packet against the ﬁrst rule that meets the deﬁned criteria and
ignores subsequent rules. Therefore, to enforce the most speciﬁc match, move the more speciﬁc
rules above more generic rules.
To understand the order in which the ﬁrewall evaluates rules by layer and by type (prerules, post-rules, and default rules) across the Device Group Hierarchy, see Device
Group Policies.
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STEP 1 | View the rule hierarchy for each rulebase.
1. Select the Policies tab and click Preview Rules.
2. Filter the preview by Rulebase (for example, Security or QoS).
3. Filter the preview to display the rules of a speciﬁc Device Group and the rules it inherits
from the Shared locaon and ancestor device groups. You must select a device group
that has ﬁrewalls assigned to it.
4. Filter the preview by Device to display its locally deﬁned rules.
5. Click the green arrow icon to apply your ﬁlter selecons to the preview (see Device
Group Policies).
6. Close the Combined Rules Preview dialog when you ﬁnish previewing rules.
STEP 2 | Delete or disable rules, if necessary.
To determine which rules a ﬁrewall doesn’t currently use, select that ﬁrewall in the
Context drop-down on Panorama, select the rulebase (for example, Policies > Security),
and select the Highlight Unused Rules check box. A doed orange background
indicates the rules that the ﬁrewall doesn’t use.
1. Select the rulebase (for example, Policies > Security > Pre Rules) that contains the rule
you will delete or disable.
2. Select the Device Group that contains the rule.
3. Select the rule, and click Delete or Disable as desired. Disabled rules appear in italicized
font.
STEP 3 | Reposion rules within a rulebase, if necessary.
To reposion local rules on a ﬁrewall, access its web interface by selecng that ﬁrewall
in the Context drop-down before performing this step.
1. Select the rulebase (for example, Policies > Security > Pre Rules) that contains the rule
you will move.
2. Select the Device Group that contains the rule.
3. Select the rule, select Move, and select:
• Move Top—Moves the rule above all other rules in the device group (but not above
rules inherited from Shared or ancestor device groups).
• Move Up—Moves the rule above the one that precedes it (but not above rules
inherited from Shared or ancestor device groups).
• Move Down—Moves the rule below the one that follows it.
• Move Boom—Moves the rule below all other rules.
• Move to other device group—See Move or Clone a Policy Rule or Object to a
Diﬀerent Device Group.
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STEP 4 | If you modiﬁed the rules, commit and push the changes.
1. Select Commit > Commit and Push and Edit Selecons in the Push Scope
2. Select Device Groups, select the device group that contains the rules you changed or
deleted, and click OK.
3. Commit and Push your changes to the Panorama conﬁguraon and to device groups.
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Manage Templates and Template Stacks
Use templates and template stacks to deﬁne the common base conﬁguraons that enable ﬁrewalls
to operate in your network. See Templates and Template Stacks for an overview of the issues you
should consider when deciding which ﬁrewalls to add to which templates, ordering templates in
a stack to manage layers of common and ﬁrewall group-speciﬁc sengs, and overriding template
sengs with ﬁrewall-speciﬁc values.
To delete a template, you must ﬁrst locally Disable/Remove Template Sengs on the
ﬁrewall. Only administrators with the superuser role can disable a template.
• Template Capabilies and Excepons
• Add a Template
• Conﬁgure a Template Stack
• Conﬁgure a Template or Template Stack Variable
• Import and Overwrite Exisng Template Stack Variables
• Override a Template Seng
• Disable/Remove Template Sengs

Template Capabilies and Excepons
You can use Templates and Template Stacks to deﬁne a wide array of sengs but you can perform
the following tasks only locally on each managed ﬁrewall:
• Conﬁgure a device block list.
• Clear logs.
• Enable operaonal modes such as normal mode, mul-vsys mode, or FIPS-CC mode.
• Conﬁgure the IP addresses of ﬁrewalls in an HA pair.
• Conﬁgure a master key and diagnoscs.
• Compare conﬁguraon ﬁles (Conﬁg Audit).
To Manage Licenses and Updates (soware or content) for ﬁrewalls, use the
Panorama > Device Management tab opons; do not use templates.
• Renaming a vsys on a mul-vsys ﬁrewall.

Add a Template
You must add at least one template before Panorama™ displays the Device and Network tabs
required to deﬁne the network setup and device conﬁguraon elements for ﬁrewalls. Panorama
supports up to 1,024 templates. Every managed ﬁrewall must belong to a template stack. While
templates contain managed device conﬁguraons, template stacks allow you to manage and push
the template conﬁguraons to all managed ﬁrewalls assigned to the template stack.
Combine templates in to a template stack to avoid duplicang many conﬁguraons among
templates (see Templates and Template Stacks and Conﬁgure a Template Stack).
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STEP 1 | Add a template.
1. Select Panorama > Templates.
2. Click Add and enter a unique Name to idenfy the template.
3. (Oponal) Enter a Descripon for the template.
4. Click OK to save the template.
5. If the template has a virtual system (vsys) with conﬁguraons (for example, interfaces)
that you want Panorama to push to ﬁrewalls that don’t have virtual systems, select the
template you created, select the vsys from the Default VSYS drop-down and click OK.
6. Select Commit > Commit and Push and then Commit and Push your changes to the
Panorama conﬁguraon and to the template.
STEP 2 | Verify that the template is available.
Aer you add the ﬁrst template, Panorama displays the Device and Network tabs. These
tabs display a Template drop-down. Check that the drop-down displays the template you just
added.
STEP 3 | Conﬁgure a Template Stack and add the template to the template stack.
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STEP 4 | Use the template to push a conﬁguraon change to ﬁrewalls.
Renaming a vsys is allowed only on the local ﬁrewall, not on Panorama the result is an
enrely new vsys or the new vsys name gets mapped to the wrong vsys on the ﬁrewall.
For example, deﬁne a primary Domain Name System (DNS) server for the ﬁrewalls in the
template.
You can also Conﬁgure a Template or Template Stack Variable to push devicespeciﬁc values to managed devices.
1. In the Device tab, select the Template from the drop-down.
2. Select Device > Setup > Services > Global, and edit the Services secon.
3. Enter an IP address for the Primary DNS Server.

4. Select Commit > Commit and Push and then Commit and Push your changes to the
Panorama conﬁguraon and to the template.
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STEP 5 | Verify that the ﬁrewall is conﬁgured with the template sengs that you pushed from
Panorama.
1. In the Context drop-down, select one of the ﬁrewalls to which you pushed the template
seng.
2. Select Device > Setup > Services > Global. The IP address that you pushed from the
template appears. The Services secon header displays a template icon (
) to indicate
that sengs in the secon have values pushed from a template.

STEP 6 | Troubleshoot Connecvity to Network Resources to verify your ﬁrewalls can access your
network resources.

Conﬁgure a Template Stack
A template stack is conﬁgurable and allows you to combine mulple templates to push full
conﬁguraons to your managed ﬁrewalls. While templates are modular porons of your ﬁrewall
conﬁguraon that you can reuse across diﬀerent stacks, you can also conﬁgure the template stack
to ﬁll in the remaining conﬁguraons that you need to apply across all ﬁrewalls assigned to the
stack. Panorama supports up to 1,024 template stacks and each stack can have up to 8 templates
assigned to it. You can reference objects conﬁgured in a template stack from a template belonging
to the temple stack. The template stack inherits conﬁguraon objects from the templates you add
and is based on how you order templates in the template stack. You can also override template
seng in the template stack to create a template stack conﬁguraon object. For details and
planning, see Templates and Template Stacks.
Add a Template to conﬁgure interfaces, VLANs, Virtual Wires, IPSec Tunnels, DNS Proxy
and Virtual Systems. These objects must be conﬁgured and pushed from a template, and
not a template stack. Once pushed from a template, you can override these objects, except
for Virtual Systems, in the template stack.
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STEP 1 | Plan the templates and their order in the stack.
Add a Template you plan to assign to the template stack.
When planning the priority order of templates within the stack (for overlapping
sengs), you must check the order to prevent misconﬁguraon. For example, consider
a stack in which the ethernet1/1 interface is of type Layer 3 in Template_A but of type
Layer 2 with a VLAN in Template_B. If Template_A has a higher priority, Panorama will
push ethernet1/1 as type Layer 3 but assigned to a VLAN.
Also note that a template conﬁguraon can’t reference a conﬁguraon in another template
even if both templates are in the same stack. For example, a zone conﬁguraon in Template_A
can’t reference a zone protecon proﬁle in Template_B.
STEP 2 | Create a template stack.
1. Select Panorama > Templates and Add Stack.
Panorama supports only Add Stack to create a new template stack. You cannot
clone an exisng template stack.
2. Enter a unique Name to idenfy the stack.
3. For each of the templates the stack will combine (up to 8), Add and select the template.
The dialog lists the added templates in order of priority with respect to duplicate
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sengs, where values in the higher templates override those that are lower in the list. To
change the order, select a template and Move Up or Move Down.

4. In the Devices secon, select ﬁrewalls to assign them to the stack. For ﬁrewalls with
mulple virtual systems, you can’t assign individual virtual systems, only an enre
ﬁrewall. You can assign any ﬁrewall to only one template stack.
Whenever you add a new managed ﬁrewall to Panorama, you must assign it to
the appropriate template stack; Panorama does not automacally assign new
ﬁrewalls to a template or template stack. When you push conﬁguraon changes
to a template, Panorama pushes the conﬁguraon to every ﬁrewall assigned to
the template stack.
5. (Oponal) Select Group HA Peers to display a single check box for ﬁrewalls that are in
a high availability (HA) conﬁguraon. Icons indicate the HA state: green for acve and
yellow for passive. The ﬁrewall name of the secondary peer is in parentheses.
For acve/passive HA, add both peers to the same template so that both will receive
the conﬁguraons. For acve/acve HA, whether you add both peers to the same
template depends on whether each peer requires the same conﬁguraons. For a list of
the conﬁguraons that PAN-OS synchronizes between HA peers, see High Availability
Synchronizaon.
6. Click OK to save the template stack.
STEP 3 | (Oponal) Conﬁgure a Template or Template Stack Variable.
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STEP 4 | Edit the Network and Device sengs, as necessary.
Renaming a vsys is allowed only on the local ﬁrewall. If you rename a vsys on
Panorama, the result is an enrely new vsys or the new vsys name gets mapped to the
wrong vsys on the ﬁrewall.
In an individual ﬁrewall context, you can override sengs that Panorama pushes from a stack
in the same way you override sengs pushed from a template, see Override a Template or
Template Stack Value.
1. Filter the tabs to display only the mode-speciﬁc sengs you want to edit:
While Panorama pushes mode-speciﬁc sengs only to ﬁrewalls that support
those modes, this selecve push doesn’t adjust mode-speciﬁc values. For
example, if a template has ﬁrewalls in Federal Informaon Processing Standards
(FIPS) mode and an IKE Crypto proﬁle that uses non-FIPS algorithms, the
template push will fail. To avoid such errors, use the Mode drop-down in the
Network and Device tabs to ﬁlter mode-speciﬁc features and value opons.
• In the Mode drop-down, select or clear the Mul VSYS, Operaonal Mode, and VPN
Mode ﬁlter opons.
• Set all the Mode opons to reﬂect the mode conﬁguraon of a parcular ﬁrewall by
selecng it in the Device drop-down.
2. Set up your interfaces and network connecvity. For example, Conﬁgure Zones and
Interfaces to segment your network to manage and control traﬃc passing through your
ﬁrewall.
3. Edit the sengs as needed.
4. Select Commit > Commit and Push, Edit Selecons in the Push Scope, select Templates,
select the ﬁrewalls assigned to the template stack, and then Commit and Push your
changes to the Panorama conﬁguraon and to the template stack.
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STEP 5 | Verify that the template stack works as expected.
1. Select a device assigned to the template stack from the Context drop-down.
2. Select a tab to which you pushed conﬁguraon changes using the template stack.
3. Values pushed from the template stack display a template icon (
) to indicate that
sengs in the secon have values pushed from a template stack. Hover your mouse over
the stack to view which template stack from which the value was pushed.

STEP 6 | Troubleshoot Connecvity to Network Resources to verify your ﬁrewalls can access your
network resources.

Conﬁgure a Template or Template Stack Variable
To enable you to more easily reuse templates or template stacks, you can use template and
template stack variables to replace IP addresses, Group IDs, and interfaces in your conﬁguraons.
Template variables are deﬁned at either the template or template stack level and you can use
variables to replace IP addresses, IP ranges, FQDN, interfaces in IKE, VPN and HA conﬁguraons,
and group IDs. If mulple templates in the template stack use diﬀerent variables for the same
conﬁguraon object, the variable value inherited by the template stack is based on the order of
inheritance described in Templates and Template Stacks. Addionally, you can override a template
value using a template stack variable to manage a conﬁguraon object from the template stack.
Variables allow you to reduce the total number of templates and template stacks you need to
manage, while allowing you to keep any ﬁrewall- or appliance-speciﬁc values. For example, if you
have a template stack with a base conﬁguraon, you can use variables to create values that do
not apply to all ﬁrewalls in the template or template stack. This allows you to manage and push
conﬁguraons from fewer templates and template stacks while accounng for any ﬁrewall- or
appliance speciﬁc values that you would otherwise need before you can create a new template or
template stack.
To create a template or template stack variable:
STEP 1 | Log in to the Panorama Web Interface.
STEP 2 | Create a template and template stack.
1. Add a Template
2. Conﬁgure a Template Stack.
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STEP 3 | Select Panorama > Templates and Manage (Variables column) the template or template stack
for which you want to create a variable.
STEP 4 | Add the new variable.
A variable name must start with the dollar ( $ ) symbol.
1. Name the new variable. In this example, the variables are named $DNS-primary and
$DNS-secondary.
2. Select the variable Type and enter the corresponding value for the selected variable type.
For this example, select IP Netmask.
3. (Oponal) Enter a descripon for the variable.
4. Click OK and Close
Variables can also be created inline where variables are supported.

STEP 5 | From the Template drop-down, select the template or template stack to which the variable
belongs.
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STEP 6 | Enter the variable in the appropriate locaon.
For this example, reference the previously deﬁned DNS value.
1. Select Device > Setup > Services and edit Services.
2. Type $DNS-primary or select it from the drop-down for Primary DNS Server.
3. Type $DNS-secondary or select it from the drop-down for Secondary DNS Server.
4. Click OK.

STEP 7 | Click Commit and Commit and Push your changes to managed ﬁrewalls.
When you push a device group conﬁguraon with references to template or template
stack variables, you must Edit Selecons and Include Device and Network Templates.
STEP 8 | Verify that the values for all variables were pushed to the managed devices.
1. From the Context drop-down, select a ﬁrewall that belongs to the template stack for
which the variable was created.
2. Select Device > Setup > Services.
3. Sengs with values deﬁned by a template or template stack are indicated by a template
symbol (
). Hover over the indicator to view to which template or template stack the
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variable deﬁnion belongs. When viewing from the ﬁrewall context, the variables display
as the IP address you conﬁgured for the variable.

STEP 9 | Troubleshoot Connecvity to Network Resources to verify your ﬁrewalls can access your
network resources.

Import and Overwrite Exisng Template Stack Variables
Use template stack variables to replace IP addresses, IP ranges, FQDN, interfaces, or group ID
in your ﬁrewall conﬁguraons. Variables allow you to reduce the total number of templates and
template stacks you need to manage, while allowing you to preserve any ﬁrewall-speciﬁc values.
Imporng template stack variables allows you to overwrite the values of mulple exisng
variables, and you cannot create new template stack variables when imporng. For more
informaon how on how to create new template or template stack variable, see Conﬁgure a
Template or Template Stack Variable.
STEP 1 | Log in to the Panorama Web Interface.
STEP 2 | Export the exisng template stack variables.
1. Select Panorama > Templates and select a template or template stack.
2. Select Variable CSV > Export. The conﬁgured template stack variables are downloaded
locally as a CSV ﬁle.
3. Open the exported CSV.
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STEP 3 | Edit the CSV ﬁle containing the template stack variables to import to Panorama in the
following format:
Values that display as #inherited# are values that are deﬁned in the template stack.
1. Correct the number of the cells containing the ﬁrewall serial number. Repeat this step for
all ﬁrewalls in the CSV ﬁle.
1. Right-click the cell containing the ﬁrewall serial number and select Format Cells.
2. Select Number > Text and click OK.
3. Add a 0 at the beginning of the serial number.

2. Enter a new value for the desired template variable.
3. Select File > Save As and save the ﬁle in CSV UTF-8 format.

STEP 4 | Import the CSV ﬁle to the template stack.
1. Log in to the Panorama Web Interface.
2. Select Panorama > Templates and select the template stack for which you exported the
variables in Step 2.
3. Select Variable CSV > Import and Browse for the CSV ﬁle edited in Step 3.
4. Click OK to import the template stack variables.
STEP 5 | Select Commit > Commit to Panorama and Commit your changes.
STEP 6 | Enter the variables in the appropriate locaons.
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STEP 7 | Click Commit and Commit and Push your changes to managed ﬁrewalls.
When you push a device group conﬁguraon with references to template or template
stack variables, you must Edit Selecons and Include Device and Network Templates.

Override a Template or Template Stack Value
While Templates and Template Stacks enable you to apply a base conﬁguraon to mulple
ﬁrewalls, you might want to conﬁgure ﬁrewall-speciﬁc sengs that don’t apply to all the ﬁrewalls
in a template or template stack. Conversely, you may want to override the template sengs
to create a template stack conﬁguraon that you can apply as a base conﬁguraon to all your
managed ﬁrewalls. Overrides allow for excepons or modiﬁcaons to meet your conﬁguraon
needs. For example, if you use a template to create a base conﬁguraon but a few ﬁrewalls in a
test lab environment need diﬀerent sengs for the Domain Name System (DNS) server IP address
or the Network Time Protocol (NTP) server, you can override the template and template stack
sengs.
If you want to disable or remove all the template or stack sengs on a ﬁrewall instead of
overriding a single value, see Disable/Remove Template Sengs.
You can override a template or template stack value in one of the following ways:
• Override a Template Value on the Firewall or Override a Template or Template Stack Value
Using Variables—There are two ways to override values pushed from a template or template
stack. The ﬁrst is to deﬁne a value locally on the ﬁrewall to override a value pushed from a
template or template stack. The second is to deﬁne ﬁrewall-speciﬁc variables to override values
pushed from a template or template stack.
• Override a Template Value Using a Template Stack—Deﬁne values or variables on the template
stack to override values pushed from a template.

Override a Template Value on the Firewall
Override a seng on the local ﬁrewall that was pushed from a template or template stack to
create ﬁrewall-speciﬁc conﬁguraons. This allows you to manage the base template or template
stack conﬁguraon from Panorama™, while maintaining any ﬁrewall-speciﬁc conﬁguraons that
do not apply to other ﬁrewalls.
STEP 1 | Access the ﬁrewall web interface.
Directly access the ﬁrewall by entering its IP address in the URL ﬁeld of your browser or use
the Context drop-down in Panorama to switch to the ﬁrewall context.

Panorama Administrator's Guide Version Version 10.1

341

©2022 Palo Alto Networks, Inc.

Manage Firewalls
STEP 2 | Override a value pushed from a template or template Stack.
In this example, you override the DNS server IP address that you assigned using a template in
Add a Template
1. Select Device > Setup > Services and edit the Services secon.
2. Click the template icon (
ﬁeld.

) for the Primary DNS Server to enable overrides for that

3. Enter the new IP address for the Primary DNS Server. A template override symbol (
indicates that the template value wasoverridden.

)

4. Click OK and Commit your changes.

Override a Template Value Using a Template Stack
You can use template stack values to override conﬁguraons pushed to the managed ﬁrewall
from a template to create a template stack conﬁguraon that you can use to manage the base
conﬁguraon of your managed ﬁrewalls from Panorama™. This enables you to leverage the
management capabilies of Panorama to push conﬁguraon changes to mulple devices from a
single locaon. In this example, you will use a template stack to override the Primary DNS server
IP address variable called $DNS that was pushed from a template.
Panorama supports using a template stack to override interfaces conﬁgured in a template
except for Layer2 sub-interfaces of an aggregated interface.
STEP 1 | Log in to the Panorama Web Interface.
STEP 2 | From the Template drop-down, select the template stack that will override the template
conﬁguraon.
STEP 3 | Override the pushed template conﬁguraon.
1. Select Device > Setup > Services and edit the Services secon.
2. Conﬁgure the Primary DNS with the IP address to override the pushed template
conﬁguraon and click OK.
STEP 4 | Commit and Push the conﬁguraon change.
Override a Template Value Using a Template Stack Variable
You can use template stack values and variables to override conﬁguraons pushed to the managed
ﬁrewall from a template to create a template stack conﬁguraon that you can use to manage the
base conﬁguraon of your managed ﬁrewalls from Panorama™. This enables you to leverage the
management capabilies of Panorama to push conﬁguraon changes to mulple ﬁrewalls from a
single locaon. In this example, you will create a template stack variable by overriding the Primary
DNS server IP address variable called $DNS that was pushed from a template.
Panorama supports using a template stack to override interfaces conﬁgured in a template
except for Layer2 sub-interfaces of an aggregated interface.
STEP 1 | Log in to the Panorama Web Interface.
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STEP 2 | Override the template variable.
1. Select Panorama > Templates.
2. Manage (Variables column) the template stack containing the template variable you need
to override.
3. Locate and select the $DNS variable.
4. Select Override.
5. Enter the new variable value and click OK.
STEP 3 | Commit and Push your changes.

Override a Template or Template Stack Value Using Variables
You can use ﬁrewall-speciﬁc variables to override variables pushed to the managed ﬁrewall
from a template or template stack to create ﬁrewall-speciﬁc conﬁguraons. This allows you
to manage the base template or template stack conﬁguraon while maintaining any ﬁrewallspeciﬁc conﬁguraons that do not apply to other ﬁrewalls—all from Panorama™. This allows
you to leverage the management capabilies of Panorama while accounng for any speciﬁc
conﬁguraons required for individual ﬁrewalls. In this example, the Primary DNS server IP address
variable called $DNS that has been pushed from a template will be overridden to create a ﬁrewallspeciﬁc variable.
You can override template or template stack variables that have not been overridden. If a
template or template stack variable is already overridden, Revert the override to create a
ﬁrewall-speciﬁc variable.
STEP 1 | Log in to the Panorama Web Interface.
STEP 2 | Override the template or template stack variable.
1. Select Panorama > Managed Devices > Summary.
2. Edit (Variables column) the ﬁrewall containing the variable you need to override.
3. Locate and select the $DNS variable.
4. Select Override.
5. Enter the new ﬁrewall-speciﬁc IP address and click OK.
STEP 3 | Commit and Push your changes.

Disable/Remove Template Sengs
If you want to stop using a template or template stack for managing the conﬁguraon on a
managed ﬁrewall, you can disable the template or stack. When disabling, you can copy the
template/stack values to the local conﬁguraon of the ﬁrewall or delete the values.
If you want to override a single seng instead of disabling or removing every template or
stack seng, see Override a Template Seng.
See Templates and Template Stacks for details on how to use these for managing
ﬁrewalls.
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STEP 1 | Access the web interface of the managed ﬁrewall as an administrator with the Superuser
role. You can directly access the ﬁrewall by entering its IP address in the browser URL ﬁeld
or, in Panorama, select the ﬁrewall in the Context drop-down.
STEP 2 | Select Device > Setup > Management and edit the Panorama Sengs.
STEP 3 | Click Disable Device and Network Template.
STEP 4 | (Oponal) Select Import Device and Network Template before disabling, to save the
conﬁguraon sengs locally on the ﬁrewall. If you do not select this opon, PAN-OS will
delete all Panorama-pushed sengs from the ﬁrewall.
STEP 5 | Click OK twice and then Commit the changes.
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Manage the Master Key from Panorama
Panorama, ﬁrewalls, Log Collectors, and WF-500 appliances use a master key to encrypt sensive
elements in the conﬁguraon and they have a default master key they use to encrypt passwords
and conﬁguraon elements. As part of a standard security pracce, you should replace the default
master key and change the key on each individual ﬁrewall, Log Collector, WildFire appliance, and
Panorama before it expires.
To strengthen your security posture, conﬁguring a unique master key for Panorama and for
each managed ﬁrewall. By conﬁguring unique master keys, you can ensure that a compromised
master key does not compromise the conﬁguraon encrypon of your enre deployment. Unique
master keys are supported only for Panorama and managed ﬁrewalls. Log Collectors and WildFire
appliances must share the same master key as Panorama. For Panorama or managed ﬁrewalls in
a high availability (HA) conﬁguraon, you must deploy the same master key for both HA peers as
the master key is not synchronized across HA peers.
Conﬁguring a unique master key also eases the operaonal burden of updang your master
keys. By conﬁguring a unique master key for a managed ﬁrewall, you can update each master key
individually without the need to coordinate changing the master key across a large number of
managed ﬁrewalls.
To update the master key for managed ﬁrewalls from Panorama, the conﬁguraon pushed from
Panorama and the local ﬁrewall conﬁguraon must not contain any cross references to each other
in their conﬁguraon objects.
Palo Alto Networks recommends updang the master key from Panorama during a
planned maintenance window and with the help of Palo Alto Networks Support to avoid
network disrupons for your organizaon.
If your managed ﬁrewalls contain both local and Panorama pushed conﬁguraon that
reference one another, you are required to either localize the conﬁguraon to the ﬁrewall.
This removes any local overrides of a Panorama pushed conﬁguraon which may lead to
network disrupons if not restored correctly.
For managed ﬁrewalls in a high availability (HA) conﬁguraon, you are required to disable
HA as well.
When a master key expires, you must enter the current master key in order to conﬁgure a
new master key.
Be sure to keep track of the master key you deploy to your managed ﬁrewalls, Log
Collectors, and WildFire appliances because master keys cannot be recovered. you must
reset to factory default if you cannot provide the current master key when it expires.
STEP 1 | Log in to the Panorama Web Interface.
STEP 2 | (Best Pracce) Select Commit and Commit and Push any pending conﬁguraon changes.
Panorama must re-encrypt data using the new master key. To ensure all conﬁguraon elements
are encrypted with the new master key, you should commit all pending changes before
deploying the new master key.
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STEP 3 | Localize the managed ﬁrewall conﬁguraon.
This step is required only if the managed ﬁrewall has a local and Panorama pushed
conﬁguraon that reference each other or local overrides of a Panorama pushed
conﬁguraon.
Skip this step if your managed ﬁrewall conﬁguraon is enrely pushed from Panorama,
or if the managed ﬁrewall conﬁguraon contains both a local and Panorama pushed
conﬁguraon contains no references to each other or local overrides.
1. Log in to the ﬁrewall web interface.
2. Locate and document all local overrides of the Panorama pushed conﬁguraon.
This step is required when you restore conﬁguraon objects pushed from Panorama
to the managed ﬁrewall conﬁguraon. Localizing the managed ﬁrewall conﬁguraon
removes all local overrides and converts them into local conﬁguraon objects. When
you restore the managed ﬁrewall conﬁguraon, these objects may be overridden with
a Panorama pushed conﬁguraon objects of the same name and not have the ﬁrewall
speciﬁc values.
3. Select Device > Setup > Management and edit the Panorama Sengs.
4. Disable Panorama Policy and Objects and Import Panorama Policy and Objects before
disabling.
Import Panorama Policy and Objects before disabling to import the Panorama pushed
policy and device group objects to the local ﬁrewall conﬁguraon. Otherwise, the ﬁrewall
deletes these Panorama pushed policy and device sengs from the managed ﬁrewall.
5. Click OK.
6. Disable Device and Network Templates and Import Device and Network Templates
before disabling.
Import Device and Network Templates before disabling to import the Panorama pushed
device and template objects to the local ﬁrewall conﬁguraon. Otherwise, the ﬁrewall
deletes these Panorama pushed device and template sengs from the managed ﬁrewall.
7. Click OK.
8. Commit.
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STEP 4 | Conﬁgure a unique master key for a managed ﬁrewall.
1. (HA only) Disable Conﬁg Sync for managed ﬁrewalls.
This step is required before deploying a new master key to a ﬁrewall HA pair
1. Log in to the Panorama Web Interface.
2. Select Device > High Availability > General and select the Template containing the
managed ﬁrewall HA conﬁguraon.
3. Edit the HA Pair Sengs Setup.
4. Disable (clear) Enable Conﬁg Sync and click OK.
5. Commit and Commit and Push your conﬁguraon changes.
2. Select Panorama > Managed Devices > Summary and Deploy Master Key.
3. Select a managed ﬁrewall and Change the master key.
If you want to deploy a unique master key for a speciﬁc set of managed ﬁrewalls,
you can select those speciﬁc managed ﬁrewalls as well.

4. Conﬁgure the master key:
1. If renewing a master key, enter the Current Master Key. If you are replacing the
default master key with a new master key, do not specify a Current Master Key.
2. (Oponal) Enable (check) Stored on HSM if the master key is encrypted on a
Hardware Security Module (HSM).
3. Specify the New Master Key and Conﬁrm Master Key.
4. Conﬁgure the master key Lifeme and Time for Reminder.
5. Click OK.
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5. Verify that the master key was deployed successfully to all selected managed ﬁrewalls.
A System log generates when you deploy a new master key from Panorama.
6. (Oponal) Conﬁgure the master key to automacally renew for your managed ﬁrewalls.
Conﬁgure this seng to automacally renew the master key deployed on the managed
ﬁrewalls associated with the selected template. Otherwise, the master key expires per
the conﬁgured master key lifeme and you must deploy a new master key.
1. Select Device > Master Key and Diagnosc and select the Template containing the
target managed ﬁrewalls.
2. Edit the Master Key sengs and conﬁgure the Auto Renew With Same Master Key
seng.
3. Click OK.
4. Commit and Commit and Push your conﬁguraon changes.

Panorama Administrator's Guide Version Version 10.1

348

©2022 Palo Alto Networks, Inc.

Manage Firewalls
STEP 5 | Conﬁgure the master key on Panorama.
1. (HA only) Disable the HA conﬁguraon for Panorama.
This step is required to successfully change the master for both Panorama HA peers. You
are unable to commit conﬁguraon changes on the secondary HA peer when Panorama
is in an HA conﬁguraon.
1. Log in to the Panorama Web Interface.
2. Select Panorama > High Availability > General and edit the HA Setup.
3. Disable (uncheck) Enable HA and click OK.
4. Commit and Commit to Panorama.
2. Select Panorama > Master Key and Diagnoscs and conﬁgure the master key.
1. If renewing a master key, enter the Current Master Key. If you are replacing the
default master key with a new master key, o not specify a Current Master Key.
2. Conﬁgure the New Master Key and Conﬁrm Master Key.
3. Conﬁgure the master key Lifeme and Time for Reminder.
4. Click OK.
3. (Oponal) Conﬁgure the Panorama master key to automacally renew.
Conﬁgure this seng to automacally renew the master key deployed on Panorama.
Otherwise, the master key expires per the conﬁgured master key lifeme and you must
deploy a new master key.
1. Select Panorama > Master Key and Diagnosc and edit the Master Key seng.
2. Conﬁgure the Auto Renew With Same Master Key seng.
3. Click OK.
4. Select Commit > Commit to Panorama and Commit your changes.
5. (HA only) Repeat this step to conﬁgure an idencal master key on the secondary HA
peer.
You must manually conﬁgure an idencal master key on the primary and secondary HA
peers when Panorama is in an HA conﬁguraon. The master key is not synchronized
between the primary and secondary HA peers.
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STEP 6 | Deploy the master key to Log Collectors.
The master key conﬁgured for your Log Collectors must be idencal to the master key
conﬁgured for Panorama.
1. Select Panorama > Managed Collectors and Deploy Master Key.
2. Select all devices and Change the master key.
3. Conﬁgure the master key:
1. If renewing a master key, enter the Current Master Key. If you are replacing the
default master key with a new master key, do not specify a Current Master Key.
2. Specify the New Master Key and Conﬁrm Master Key.
3. Conﬁgure the master key Lifeme and Time for Reminder.
4. Click OK.
4. Verify that the master key was deployed successfully to all selected devices.
A System log generates when you deploy a new master key from Panorama.
STEP 7 | Deploy the master key to managed WildFire appliances.
The master key conﬁgured your WildFire appliances must be idencal to the master key
conﬁgured for Panorama.
1. Select Panorama > Managed WildFire Appliances and Deploy Master Key.
2. Select all devices and Change the master key.
3. Conﬁgure the master key:
1. If renewing a master key, enter the Current Master Key. If you are replacing the
default master key with a new master key, do not specify a Current Master Key.
2. Specify the New Master Key and Conﬁrm Master Key.
3. Conﬁgure the master key Lifeme and Time for Reminder.
4. Click OK.
4. Verify that the master key was deployed successfully to all selected devices.
A System log generates when you deploy a new master key from Panorama.
STEP 8 | (HA Panorama only) Reconﬁgure the Panorama HA conﬁguraon.
Repeat this step for both the primary and secondary Panorama HA peers.
1. Select Panorama > High Availability > General and edit the HA Setup.
2. Enable (check) Enable HA and click OK.
3. Commit and Commit to Panorama.
STEP 9 | (HA Firewalls only) Enable conﬁg sync for managed ﬁrewalls.
1. Select Device > High Availability > General and select the Template containing the
managed ﬁrewall HA conﬁguraon.
2. Edit the HA Pair Sengs Setup.
3. Enable (check) Enable Conﬁg Sync and click OK.
4. Commit and Commit and Push your conﬁguraon changes.
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STEP 10 | Enable Panorama to push conﬁguraon objects to the managed ﬁrewall.
1. Log in to the ﬁrewall web interface.
2. Select Device > Setup > Management and edit the Panorama Sengs.
3. Enable Panorama Policy and Objects and click OK.
4. Enable Device and Network Templates and click OK.
5. Click OK.
6. Commit.
STEP 11 | Push the Panorama conﬁguraon back to managed ﬁrewalls for which you localized the
conﬁguraon.
Perform this step with Palo Alto Networks Support and ensure you have a complete
list of all local overrides on your managed ﬁrewalls. Failure to preserve important local
ﬁrewall conﬁguraons or restore any local overrides or references can result in network
disrupons.
1. Log in to the Panorama Web Interface.
2. Select Commit > Push to Devices and Edit Selecons.
3. Check (enable) Include Device and Network Templates and Force Template Values.
This is required to convert the localized Panorama conﬁguraon on the managed ﬁrewall
back to a Panorama pushed conﬁguraon.
4. Select Device Groups or Templates to select the managed ﬁrewall that required localizing
the Panorama pushed conﬁguraon.
5. Click OK.
6. Push to the selected managed ﬁrewalls.
7. Log in to the ﬁrewall web interface of the impacted managed ﬁrewalls to modify the local
ﬁrewall conﬁguraon as needed.
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Schedule a Conﬁguraon Push to Managed Firewalls
Reduce the operaonal overhead of pushing conﬁguraon changes to managed ﬁrewalls by
creang a scheduled conﬁguraon push to automacally push changes to your managed ﬁrewalls
on a speciﬁed date and me. You can conﬁgure a scheduled conﬁguraon push to either occur
once or on a regularly occurring schedule. This allows you to push conﬁguraon made by mulple
administrators to mulple ﬁrewalls without the need for involvement of any administrator. A
scheduled conﬁguraon push is supported for a target managed ﬁrewall running any PAN-OS
release.
Superusers and custom Panorama admins with an appropriately deﬁned admin role proﬁle can
create a scheduled conﬁguraon push to managed ﬁrewalls. To create a scheduled conﬁguraon
push, you set the schedule parameters of when and how frequently a push occurs and to which
managed ﬁrewalls to push to. For a Panorama in a high availability (HA) conﬁguraon, the
scheduled conﬁguraon push is synchronized across the HA peers.
If you create mulple scheduled conﬁguraon pushes, you must create them at a minimum
of a 5 minute interval to allow for the Panorama management server to validate the
conﬁguraon. Scheduled conﬁguraon pushes that are within 5 minutes of each other
may fail due to Panorama being unable to validate the ﬁrst scheduled conﬁguraon push
changes.
Aer a successful scheduled conﬁguraon push occurs, you can view the scheduled conﬁguraon
push execuon history to understand when the last push for a speciﬁc schedule occurred, and
how many managed ﬁrewalls were impacted. From the total number of impacted managed
ﬁrewalls, you can view how many conﬁguraon pushes to managed ﬁrewalls were successful
and how many failed. Of the failed pushes, you can view the total number of managed ﬁrewalls
with automacally reverted conﬁguraons due to a conﬁguraon change that interrupted the
connecon between the managed ﬁrewall and Panorama.
STEP 1 | Log in to the Panorama Web Interface.
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STEP 2 | Create a scheduled conﬁguraon push.
1. Select Panorama > Scheduled Conﬁg Push and Add a new scheduled conﬁguraon push.
You can also schedule a conﬁguraon push to managed ﬁrewalls when you push
to devices (Commit > Push to Devices).
2. Conﬁgure name and frequency of the scheduled conﬁguraon push.
• Name—Name of the conﬁguraon push schedule.
• Date—Date on which the conﬁguraon push is scheduled to occur next.
• Time—Time (hh:mm:ss) at which the conﬁguraon push is scheduled to occur on the
scheduled conﬁguraon push Date.
• Recurrence—Whether the scheduled conﬁguraon push is a one me push or a
recurring scheduled push (monthly, weekly, or daily).
3. In the Push Scope Selecon, select one or more device groups, templates, or template
stacks.
You must select at least one device group, template, or template stack to successfully
schedule a conﬁg push.
All managed ﬁrewalls associated with the selected device groups, templates, or template
stacks are included in the scheduled conﬁg push.
1. Select one or more Device Groups you want to schedule to push.
2. Select one or more Templates you want to schedule to push.
Up to 64 templates are supported for a single scheduled conﬁguraon push.
3. Verify whether to Merge with Device Candidate conﬁg to merge the conﬁguraon
changes pushed from Panorama with any pending conﬁguraon changes implemented
locally on the ﬁrewall.
This seng is enabled by default.
4. Verify whether to Include Device and Network Templates to push both device group
changes and the associate template changes in a single operaon.
This seng is enabled by default. If disabled, Panorama pushes the device group and
associated template changes as separate operaons.
Force Template Values is not supported for a scheduled conﬁguraon push to
prevent outages during oﬀ hours caused by a conﬁguraon push that overwrites
the local ﬁrewall conﬁguraon.
4. Click OK.
5. Click Commit and Commit to Panorama.
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STEP 3 | View the execuon history to verify that the scheduled conﬁguraon push for all managed
ﬁrewalls was successful.
1. Select Panorama > Scheduled Conﬁg Push and click the Last Executed me stamp in the
Status column.
2. View the execuon history for the scheduled conﬁguraon push.
This includes the last me the scheduled conﬁguraon push occurred and the total
number of impacted managed ﬁrewalls. Of the total number of impacted ﬁrewalls, you
can view how many scheduled conﬁguraon pushes were successful, how many failed,
and how many of the managed ﬁrewalls automacally reverted their conﬁguraon due
to a conﬁguraon change that caused a disconnect between the managed ﬁrewall on
Panorama.
3. Click Tasks to view the full operaon details for the latest scheduled conﬁguraon push.
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Redistribute Data to Managed Firewalls
To ensure all the ﬁrewalls that enforce policies and generate reports have the required data and
authencaon mestamps for your policy rules, you can leverage your Panorama infrastructure to
redistribute the mappings and mestamps.
Conﬁgure the Panorama management server to redistribute data.
1. Add ﬁrewalls, virtual systems, or Windows User-ID agents as redistribuon agents to
Panorama:
1. Select Panorama > Data Redistribuon and Add each redistribuon agent.
2. Enter a Name to idenfy the redistribuon agent.
3. Conﬁrm that the agent is Enabled.
4. Enter the Host name or IP address of the MGT interface on ﬁrewall.
5. Enter the Port number on which the ﬁrewall will listen for data redistribuon queries
(default is 5007).
6. If the redistribuon agent is a ﬁrewall or virtual system, enter the Collector Name and
Collector Pre-Shared Key.
7. Select the Data type that you want to redistribute. You can select all data types, but
you must select at least one of the following data types:
• IP User Mappings
• IP Tags
• User Tags
• HIP
• Quaranne List
8. Click OK to save the conﬁguraon.
2. Enable the Panorama MGT interface to respond to data redistribuon queries from
ﬁrewalls:
If the Panorama management server has a high availability (HA) conﬁguraon,
perform this step on each HA peer as a best pracce so that redistribuon
connues if Panorama fails over.
1. Select Panorama > Setup > Interfaces and Management.
2. Select User-ID in the Network Services secon and click OK.
3. Select Commit > Commit to Panorama to acvate your changes on Panorama.
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Conﬁgure ﬁrewalls to receive data that Panorama redistributes.
1. Select Device > Data Redistribuon > Agents then select the Template to which the
ﬁrewalls are assigned.
2. Add an agent and enter a Name.
3. Select how you want to add the agent:
• Serial Number—Select the Serial Number of the Panorama you want to use from the
list:
• panorama—The acve or solitary Panorama
• panorama2—(HA only) The passive Panorama
• Host and Port—Specify the following informaon:
• Select the Host name or IP address of the MGT interface on ﬁrewall.
• Select whether the host is an LDAP Proxy.
• Enter the Port number on which the ﬁrewall will listen for data redistribuon
queries (default is 5007).
• If the redistribuon agent is a ﬁrewall or virtual system, enter the Collector Name
and Collector Pre-Shared Key.
• Select the Data type that you want to redistribute.
4. Conﬁrm that the agent is Enabled and click OK to save the conﬁguraon.
5. Select Commit > Commit and Push to acvate your changes on Panorama and push the
changes to the ﬁrewalls.
Verify that Panorama and ﬁrewalls receive redistributed data.
1. View the agent stascs Panorama > Data Redistribuon > Agents and select Status
to view a summary of the acvity for the redistribuon agent, such as the number of
mappings that the client ﬁrewall has received.
2. Conﬁrm the Source Name in the User-ID logs (Monitor > Logs > User-ID) to verify that
the ﬁrewall receives the mappings from the redistribuon agents.
3. View the IP-Tag log (Monitor > Logs > IP-Tag) to conﬁrm that the client ﬁrewall receives
data.
4. Access the CLI of a ﬁrewall or Panorama management server that redistributes data.
5. Display all the user mappings by running the following command:
> show user ip-user-mapping all
6. Record the IP address associated with any one username.
7. Access the CLI of a ﬁrewall or Panorama management server that receives redistributed
data.
8. Display the mapping informaon and authencaon mestamp for the <IP-address> you
recorded:
> show user ip-user-mapping ip <IP-address>
IP address:
192.0.2.0 (vsys1)
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User:
From:
Idle Timeout:
Max. TTL:
MFA Timestamp:
Group(s):

corpdomain\username1
UIA
10229s
10229s
first(1) - 2016/12/09 08:35:04
corpdomain\groupname(621)

This example output shows the mestamp for a response to one authencaon
challenge (factor). For Authencaon rules that use mul-factor authencaon
(MFA), the output shows mulple mestamps.
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Transion a Firewall to Panorama Management
If you have already deployed Palo Alto Networks ﬁrewalls and conﬁgured them locally, but now
want to use Panorama for centrally managing them, you must perform pre-migraon planning. The
migraon involves imporng ﬁrewall conﬁguraons into Panorama and verifying that the ﬁrewalls
funcon as expected aer the transion. If some sengs are unique to individual ﬁrewalls, you
can connue accessing the ﬁrewalls to manage the unique sengs. You can manage any given
ﬁrewall seng by pushing its value from Panorama or by conﬁguring it locally on the ﬁrewall, but
you cannot manage the seng through both Panorama and the ﬁrewall. If you want to exclude
certain ﬁrewall sengs from Panorama management, you can either:
• Migrate the enre ﬁrewall conﬁguraon and then, on Panorama, delete the sengs that you
will manage locally on ﬁrewalls. You can also Override a Template or Template Stack Value that
Panorama pushes to a ﬁrewall instead of deleng the seng on Panorama.
• Load a paral ﬁrewall conﬁguraon, including only the sengs that you will use Panorama to
manage.
Firewalls do not lose logs during the transion to Panorama management.
• Plan the Transion to Panorama Management
• Migrate a Firewall to Panorama Management
• Migrate a Firewall HA Pair to Panorama Management
• Load a Paral Firewall Conﬁguraon into Panorama
• Localize a Panorama Pushed Conﬁguraon on a Managed Firewall

Plan the Transion to Panorama Management
The following tasks are a high-level overview of the planning required to migrate ﬁrewalls to
Panorama management:
Decide which ﬁrewalls to migrate.
Plan a maintenance window and ensure there are no pending conﬁguraon changes on
Panorama or the ﬁrewalls.
If you are migrang the ﬁrewall from one Panorama to another, localize the Panorama pushed
conﬁguraon on the ﬁrewall.
Preserve your known working Panorama and ﬁrewall conﬁguraons prior to migraon.
• Export the device state of your ﬁrewalls.
• Export a named Panorama conﬁguraon shapshot of the running Panorama conﬁguraon.
Determine the Panorama and ﬁrewall soware and content versions, and how you will manage
licenses and soware upgrades. For important details, see Panorama, Log Collector, Firewall,
and WildFire Version Compability.
Plan Your Panorama Deployment with respect to the URL ﬁltering database (BrightCloud or
PAN-DB), log collecon, and administrator roles.
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Plan how to manage shared sengs.
Plan the Device Group Hierarchy, Templates and Template Stacks in a way that will reduce
redundancy and streamline the management of sengs that are shared among all ﬁrewalls or
within ﬁrewall sets. During the migraon, you can select whether to import objects from the
Shared locaon on the ﬁrewall into Shared on Panorama, with the following excepons:
• If a shared ﬁrewall object has the same name and value as an exisng shared Panorama
object, the import excludes that ﬁrewall object.
• If the name or value of the shared ﬁrewall object diﬀers from an exisng shared Panorama
object, Panorama imports the ﬁrewall object into each new device group that is created for
the import.
• If a conﬁguraon imported into a template references a shared ﬁrewall object, or if a shared
ﬁrewall object references a conﬁguraon imported into a template, Panorama imports
the object as a shared object regardless of whether you select the Import devices' shared
objects into Panorama's shared context check box.
Determine if the ﬁrewall has conﬁguraon elements (policies, objects, and other sengs)
that you don’t want to import, either because Panorama already contains similar elements or
because those elements are ﬁrewall-speciﬁc (for example, mezone sengs) and you won’t use
Panorama to manage them. You can perform a global ﬁnd to determine if similar elements exist
on Panorama.
Decide the common zones for each device group. This includes a zone-naming strategy for
the ﬁrewalls and virtual systems in each device group. For example, if you have zones called
Branch LAN and WAN, Panorama can push policy rules that reference those zones without
being aware of the variaons in port or media type, model, or logical addressing schema.
Create a post-migraon test plan.
You will use the test plan to verify that the ﬁrewalls work as eﬃciently aer the migraon as
they did before. The plan might include tasks such as:
• Monitor the ﬁrewalls for at least 24 hours aer the migraon.
• Monitor Panorama and ﬁrewall logs for anomalies.
• Check administrator logins on Panorama.
• Test various types of traﬃc from mulple sources. For example, check bandwidth graphs,
session counts, and deny-rule traﬃc log entries (see Use Panorama for Visibility). The tesng
should cover a representave sample of policy conﬁguraons.
• Check with your network operaons center (NOC) and security operaons center (SOC) for
any user-reported issues.
• Include any other test criteria that will help verify ﬁrewall funconality.

Migrate a Firewall to Panorama Management
When you import a ﬁrewall conﬁguraon, Panorama automacally creates a template to contain
the imported network and device sengs. To contain the imported policies and objects, Panorama
automacally creates one device group for each ﬁrewall or one device group for each virtual
system (vsys) in a mul-vsys ﬁrewall.
When you perform the following steps, Panorama imports the enre ﬁrewall conﬁguraon.
Alternavely, you can Load a Paral Firewall Conﬁguraon into Panorama.
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To migrate a ﬁrewall HA pair to Panorama management, see Migrate a Firewall HA Pair to
Panorama Management.
Panorama can import conﬁguraons from ﬁrewalls that run PAN-OS 5.0 or later releases
and can push conﬁguraons to those ﬁrewalls. The excepon is that Panorama 6.1 and
later releases cannot push conﬁguraons to ﬁrewalls running PAN-OS 6.0.0 through 6.0.3.
Panorama can import conﬁguraons from ﬁrewalls that are already managed devices but
only if they are not already assigned to device groups or templates.
STEP 1 | Plan the migraon.
See the checklist in Plan the Transion to Panorama Management.
STEP 2 | Add the ﬁrewall as a managed device.
Add a Firewall as a Managed Device:
1. Log in to the Panorama Web Interface and select Panorama > Managed Devices >
Summary to Add a ﬁrewall as a managed device.
2. Enter the serial number of the ﬁrewall and click OK.
If you will import mulple ﬁrewall conﬁguraons, enter the serial number of each
one on a separate line. Oponally, you can copy and paste the serial numbers
from a Microso Excel worksheet.
3. Select Commit > Commit to Panorama and Commit your changes.
STEP 3 | Set up a connecon from the ﬁrewall to Panorama.
1. Log in to the ﬁrewall web interface and select Device > Setup to edit the Panorama
Sengs.
2. In the Panorama Servers ﬁelds, enter the IP addresses of the Panorama management
server.
3. Click OK and Commit.
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STEP 4 | Import the ﬁrewall conﬁguraon into Panorama.
If you later decide to re-import a ﬁrewall conﬁguraon, ﬁrst remove the ﬁrewall device
groups and template to which it is a member. If the device group and template names
are the same as the ﬁrewall hostname, then you can delete the device group and
template before re-imporng the ﬁrewall conﬁguraon or use the Device Group Name
Preﬁx ﬁelds to deﬁne new names for the device group and template created by the
re-import. Addionally, ﬁrewalls don’t lose logs when you remove them from device
groups or templates.
1. From Panorama, select Panorama > Setup > Operaons, click Import device
conﬁguraon to Panorama, and select the Device.
Panorama can’t import a conﬁguraon from a ﬁrewall that is assigned to an
exisng device group or template.
2. (Oponal) Edit the Template Name. The default value is the ﬁrewall name. You can’t use
the name of an exisng template or template stack.
3. (Oponal) Edit the Device Group names. For a mul-vsys ﬁrewall, each device group
has a vsys name by default, so add a character string as a Device Group Name Preﬁx
for each. Otherwise, the default value is the ﬁrewall name. You can’t use the names of
exisng device groups.
The Import devices' shared objects into Panorama's shared context check
box is selected by default, which means Panorama compares imports objects
that belong to the Shared locaon in the ﬁrewall to Shared in Panorama. If an
imported object is not in the Shared context of the ﬁrewall, it is applied to each
device group being imported. If you clear the check box, Panorama copies will
not compare imported objects, and apply all shared ﬁrewall objects into device
groups being imported instead of Shared. This could create duplicate objects,
so selecng the check box is a best pracce in most cases. To understand the
consequences of imporng shared or duplicate objects into Panorama, see Plan
how to manage shared sengs.
4. Select a Rule Import Locaon for the imported policy rules: Pre Rulebase or Post
Rulebase. Regardless of your selecon, Panorama imports default security rules
(intrazone-default and interzone-default) into the post-rulebase.
If Panorama has a rule with the same name as a ﬁrewall rule that you import,
Panorama displays both rules. Delete one of the rules before performing a
Panorama commit to prevent a commit error.
5. Click OK. Panorama displays the import status, result, details about your selecons,
details about what was imported, and any warnings. Click Close.
6. Select Commit > Commit to Panorama and Commit your changes.
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STEP 5 | Push the conﬁguraon bundle from Panorama to the newly added ﬁrewall to remove all
policy rules and objects from its local conﬁguraon.
This step is necessary to prevent duplicate rule or object names, which would cause commit
errors when you push the device group conﬁguraon from Panorama to the ﬁrewall in the next
step.
Pushing the imported ﬁrewall conﬁguraon from Panorama to remove local ﬁrewall
conﬁguraon updates Policy rule Creaon and Modiﬁed dates to reﬂect the date you
pushed to your newly managed ﬁrewalls when you monitor policy rule usage for a
managed ﬁrewall. Addionally, a new universially unique idenﬁer (UUID) for each
policy rule is created.
This step is required to successfully migrate ﬁrewall management to the Panorama
management server. Failure to perform this step successfully causes conﬁguraon
errors and commit failures.
1. Log in to the Panorama Web Interface.
2. Select Panorama > Setup > Operaons and Export or push device conﬁg bundle.
3. Select the Device from which you imported the conﬁguraon and click OK.
If a master key is conﬁgured, Use Master Key and enter the master key before
you click OK.
4. Select Push & Commit. Panorama pushes the bundle and iniates a commit on the
ﬁrewall.
5. Click Close aer the push has commied successfully.
6. Launch the Web Interface of the ﬁrewall and ensure that the conﬁguraon has been
successfully commied. If not, Commit the changes locally on the ﬁrewall.
7. Select Commit > Commit to Panorama and Commit your changes.
STEP 6 | Push the device group and template conﬁguraons to complete the transion to centralized
management.
This step overwrites any local Network and Device sengs conﬁgured on the ﬁrewall.
If you are migrang mulple ﬁrewalls, perform all the preceding steps—including this one—for
each ﬁrewall before connuing.
1. Select Commit > Commit and Push and Edit Selecons in the Push Scope.
2. Select Device Groups and select the device groups that contain the imported ﬁrewall
conﬁguraons.
3. Select Merge with Device Candidate Conﬁg, Include Device and Network Templates,
and Force Template Values.
4. Click OK to save your changes to the Push Scope.
5. Commit and Push your changes.
STEP 7 | On the Panorama web interface, select Panorama > Managed Devices > Summary and
verify that the device group and template stack are in sync for the ﬁrewall. On the ﬁrewall
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web interface, verify that conﬁguraon objects display a green cog (
conﬁguraon object is pushed from Panorama.

), signifying that the

STEP 8 | Fine-tune the imported conﬁguraon.
1. In Panorama, select Panorama > Conﬁg Audit, select the Running conﬁg and Candidate
conﬁg for the comparison, click Go, and review the output.
2. Update the device group and template conﬁguraons as needed based on the
conﬁguraon audit and any warnings that Panorama displayed aer the import. For
example:
• Delete redundant objects and policy rules.
• Move or Clone a Policy Rule or Object to a Diﬀerent Device Group.
• Move ﬁrewalls to diﬀerent device groups or templates.
• Move a device group that Panorama created during the import to a diﬀerent parent
device group: Select Panorama > Device Groups, select the device group you want to
move, select a new Parent Device Group, and click OK.
STEP 9 | Consolidate all the imported ﬁrewall conﬁguraons.
This step is required if you are migrang mulple ﬁrewalls.
1. Aer imporng all the ﬁrewall conﬁguraons, update the device groups and templates
as needed to eliminate redundancy and streamline conﬁguraon management: see Finetune the imported conﬁguraon. (You don’t need to push ﬁrewall conﬁguraon bundles
again.)
2. Conﬁgure any ﬁrewall-speciﬁc sengs.
If the ﬁrewalls will have local zones, you must create them before performing a device
group or template commit; Panorama can’t poll the ﬁrewalls for zone name or zone
conﬁguraon. If you will use local ﬁrewall rules, ensure their names are unique (not
duplicated in Panorama). If necessary, you can Override a Template or Template Stack
Value with a ﬁrewall-speciﬁc value.
3. Commit and push your changes:
1. Select Commit > Commit and Push and Edit Selecons in the Push Scope.
2. Select Device Groups, select the device groups you changed, and Include Device and
Network Templates.
3. Click OK to save your changes to the Push Scope.
4. Commit and Push your changes.
STEP 10 | Perform your post-migraon test plan.
Perform the veriﬁcaon tasks that you devised during the migraon planning to conﬁrm that
the ﬁrewalls work as eﬃciently with the Panorama-pushed conﬁguraon as they did with their
original local conﬁguraon: see Create a post-migraon test plan.

Migrate a Firewall HA Pair to Panorama Management
If you have a pair of ﬁrewalls in an HA conﬁguraon that you want to manage using Panorama,
you have the opon to import the conﬁguraon local to your ﬁrewall HA pair to Panorama
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without needing to recreate any conﬁguraons or policies. You ﬁrst import the ﬁrewall
conﬁguraons to Panorama, which are used to create a new device group and template. You
will perform a special conﬁguraon push of the device group and template to the ﬁrewalls to
overwrite the local ﬁrewall conﬁguraons and synchronize the ﬁrewalls with Panorama.
STEP 1 | Plan the migraon.
See the checklist in Plan the Transion to Panorama Management.
STEP 2 | Disable conﬁguraon synchronizaon between the HA peers.
Repeat these steps for both ﬁrewalls in the HA pair.
1. Log in to the web interface on each ﬁrewall, select Device > High Availability > General
and edit the Setup secon.
2. Clear Enable Conﬁg Sync and click OK.
3. Commit the conﬁguraon changes on each ﬁrewall.
STEP 3 | Connect each ﬁrewall to Panorama.
If Panorama is already receiving logs from these ﬁrewalls, you do not need to perform
this step. Connue to Step 5.
Repeat these steps for both ﬁrewalls in the HA pair.
1. Log in to the web interface on each ﬁrewall, select Device > Setup > Management and
edit the Panorama Sengs.
2. In the Panorama Servers ﬁelds, enter the IP addresses of the Panorama management
servers, conﬁrm Panorama Policy and Objects and Device and Network Template are
enabled and select OK.
3. Commit the conﬁguraon changes on each ﬁrewall.
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STEP 4 | Add each ﬁrewall as a managed device.
If Panorama is already receiving logs from these ﬁrewalls, you do not need to perform
this step. Connue to Step 5.
Add a Firewall as a Managed Device.
1. Log in to the Panorama Web Interface, select Panorama > Managed Devices and click
Add.
2. Enter the serial number of each ﬁrewall and click OK.
3. Select Commit > Commit to Panorama and Commit your changes.
4. Verify that the Device State for each ﬁrewall is Connected.

STEP 5 | Import each ﬁrewall conﬁguraon into Panorama.
Do no push any device group or template stack conﬁguraon to your managed ﬁrewalls
in this step. Pushing the device group and template stack conﬁguraon during this step
wipes the local ﬁrewall HA conﬁguraon in the next steps.
If you later decide to re-import a ﬁrewall conﬁguraon, ﬁrst remove the ﬁrewall device
groups and template to which it is a member. If the device group and template names
are the same as the ﬁrewall hostname, then you can delete the device group and
template before re-imporng the ﬁrewall conﬁguraon or use the Device Group Name
Preﬁx ﬁelds to enter a new name for the device group and template created by the
re-import. Addionally, ﬁrewalls don’t lose logs when you remove them from device
groups or templates.
1. From Panorama, select Panorama > Setup > Operaons, click Import device
conﬁguraon to Panorama, and select the Device.
Panorama can’t import a conﬁguraon from a ﬁrewall that is assigned to an
exisng device group or template stack.
2. (Oponal) Edit the Template Name. The default value is the ﬁrewall name. You can’t use
the name of an exisng template or template stack.
3. (Oponal) Edit the Device Group names. For a mul-vsys ﬁrewall, each device group
has a vsys name by default, so add a character string as a Device Group Name Preﬁx
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for each. Otherwise, the default value is the ﬁrewall name. You can’t use the names of
exisng device groups.
The Imported devices’ shared objects into Panorama’s shared context check
box is selected by default, which means Panorama compares imports objects
that belong to the Shared locaon in the ﬁrewall to Shared in Panorama. If an
imported object is not in the Shared context of the ﬁrewall, it is applied to each
device group being imported. If you clear the check box, Panorama copies will
not compare imported objects, and apply all shared ﬁrewall objects into device
groups being imported instead of Shared. This could create duplicate objects,
so selecng the check box is a best pracce in most cases. To understand the
consequences of imporng shared or duplicate objects into Panorama, see Plan
how to manage shared sengs.
4. Commit to Panorama.
5. Select Panorama > Setup > Operaons and Export or push device conﬁg bundle. Select
the Device, select OK and Push & Commit the conﬁguraon.
The Enable Conﬁg Sync seng in Step 2 must be cleared on both ﬁrewalls before
you push the device group and template stack.
6. Launch the Web Interface of the ﬁrewall HA peer and ensure that the conﬁguraon
pushed in the previous step commied successfully. If not, Commit the changes locally
on the ﬁrewall.
7. Repeat Step 1-6 above on the second ﬁrewall. The process creates a device group and
template stack per each ﬁrewall.
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STEP 6 | Add the HA ﬁrewall pair into the same device group and template stack.
(Firewalls in acve/acve conﬁguraon) It is recommended to add HA peers to
the same device group but not to the same template stack because ﬁrewalls in
an acve/acve HA conﬁguraon typically need unique network conﬁguraons.
This simpliﬁes policy management for the HA peers while reducing the operaonal
burden of managing the network conﬁguraon of each HA peer when their network
conﬁguraons are independent of each other. For example, ﬁrewalls in an acve/acve
HA conﬁguraon oen mes need unique network conﬁguraons, such as unique
ﬂoang IP that are used as the default gateway for hosts.
Ulmately, deciding whether to add ﬁrewalls in an acve/acve HA conﬁguraon to
the same device group and template stack is a design decision you must make when
designing your conﬁguraon hierarchy.
1. Select Panorama > Device Group, select the device group of the second ﬁrewall, and
remove the second ﬁrewall from the device group.
2. Select the device group from which you removed the second ﬁrewall and Delete it.
3. Select the device group for the ﬁrst ﬁrewall, select the second ﬁrewall, click OK and
Commit to Panorama to add it to the same device group as the HA peer.
4. Select Panorama > Templates, select the template stack of the second ﬁrewall, and
remove the second ﬁrewall from the template stack.
5. Select the template stack from which you removed the second ﬁrewall and Delete it.
6. Select the template stack for the ﬁrst ﬁrewall, add the second ﬁrewall, select OK and
Commit to Panorama to add it to the same template stack as the HA peer.
7. Remove the HA sengs in the template associated with the newly migrated ﬁrewalls.
1. Select Device > High Availability and select the Template containing the HA
conﬁguraon.
2. Select Remove All.
3. Commit to Panorama.
8. Push the device group and template stack conﬁguraons to your managed ﬁrewalls.
First push the device group and template stack conﬁguraon to your passive HA
peer and then to the acve HA peer.
Pushing the imported ﬁrewall conﬁguraon from Panorama to remove local
ﬁrewall conﬁguraon updates Policy rule Creaon and Modiﬁed dates to reﬂect
the date you pushed to your newly managed ﬁrewalls when you monitor policy
rule usage for a managed ﬁrewall. Addionally, a new universially unique
idenﬁer (UUID) for each policy rule is created.
1. Select Commit > Push to Devices and Edit Selecons.
2. Enable (select) Merge Device Candidate Conﬁg, Include Device and Network
Templates, and Force Template Values.
3. Click OK.
4. Push to your managed ﬁrewalls.
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5. Launch the Web Interface of the acve HA peer and select Device > High Availability
> Operaonal Commands to Suspend local device.
Fail over to the passive HA peer before modifying the acve HA peer to maintain your
security posture while compleng the conﬁguraon migraon.
6. Repeat steps 1-4 for the now passive HA peer.
7. Launch the Web Interface of the now acve HA peer and select Device > High
Availability > Operaonal Commands to Suspend local device.
This restores the original acve/passive HA peer roles.
9. Select Panorama > Managed Devices > Summary, and verify that the device group and
template are in sync for the passive ﬁrewall. Verify policy rules, objects and network
sengs on the passive ﬁrewall match the acve ﬁrewall.
STEP 7 | Enable conﬁguraon synchronizaon between the HA peers.
Repeat these steps for both ﬁrewalls in the HA pair if you plan on maintaining a local
conﬁguraon that needs to be synchronized.
1. Log in to the web interface on each ﬁrewall, select Device > High Availability > General
and edit the Setup secon.
2. Select Enable Conﬁg Sync and click OK.
3. Commit the conﬁguraon changes on each ﬁrewall.

Load a Paral Firewall Conﬁguraon into Panorama
If some conﬁguraon sengs on a ﬁrewall are common to other ﬁrewalls, you can load those
speciﬁc sengs into Panorama and then push them to all the other ﬁrewalls or to the ﬁrewalls in
parcular device groups and templates.
Loading a conﬁguraon into a Panorama management server requires a full commit and must
be performed by a superuser. Full commits are required when performing certain Panorama
operaons, such as reverng and loading a conﬁguraon snapshot, and are not supported for
custom Admin Role proﬁles.
STEP 1 | Plan the transion to Panorama.
See the checklist in Plan the Transion to Panorama Management.
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STEP 2 | Resolve how to manage duplicate sengs, which are those that have the same names in
Panorama as in a ﬁrewall.
Before you load a paral ﬁrewall conﬁguraon, Panorama and that ﬁrewall might already have
duplicate sengs. Loading a ﬁrewall conﬁguraon might also add sengs to Panorama that are
duplicates of sengs in other managed ﬁrewalls.
If Panorama has policy rules or objects with the same names as those on a ﬁrewall, a
commit failure will occur when you try to push device group sengs to that ﬁrewall.
If Panorama has template sengs with the same names as those on a ﬁrewall, the
template values will override the ﬁrewall values when you push the template.
1. On Panorama, perform a global ﬁnd to determine if duplicate sengs exist.
2. Delete or rename the duplicate sengs on the ﬁrewall if you will use Panorama to
manage them, or delete or rename the duplicate sengs on Panorama if you will use
the ﬁrewall to manage them. If you will use the ﬁrewall to manage device or network
sengs, instead of deleng or renaming the duplicates on Panorama, you can also push
the sengs from Panorama (Step 6) and then Override a Template or Template Stack
Value on the ﬁrewall with ﬁrewall-speciﬁc values.
STEP 3 | Export the enre ﬁrewall conﬁguraon to your local computer.
1. On the ﬁrewall, select Device > Setup > Operaons.
2. Click Save named conﬁguraon snapshot, enter a Name to idenfy the conﬁguraon,
and click OK.
3. Click Export named conﬁguraon snapshot, select the Name of the conﬁguraon you
just saved, and click OK. The ﬁrewall exports the conﬁguraon as an XML ﬁle.
STEP 4 | Import the ﬁrewall conﬁguraon snapshot into Panorama.
1. On Panorama, select Panorama > Setup > Operaons.
2. Click Import named Panorama conﬁguraon snapshot, Browse to the ﬁrewall
conﬁguraon ﬁle you exported to your computer, and click OK.
Aer using this opon to import a ﬁrewall conﬁguraon ﬁle, you can’t use
the Panorama web interface to load it. You must use the XML API or CLI, as
described in the next step.
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STEP 5 | Load the desired part of the ﬁrewall conﬁguraon into Panorama.
To specify a part of the conﬁguraon (for example, all applicaon objects), you must idenfy
the:
• Source xpath—The XML node in the ﬁrewall conﬁguraon ﬁle from which you are loading.
• Desnaon xpath—The node in the Panorama conﬁguraon to which you are loading.
Use the XML API or CLI to idenfy and load the paral conﬁguraon:
1. Use the ﬁrewall XML API or CLI to idenfy the source xpath.
For example, the xpath for applicaon objects in vsys1 of the ﬁrewall is:
/config/devices/entry[@name='localhost.localdomain']/vsys/
entry[@name='vsys1']/application
2. Use the Panorama XML API or CLI to idenfy the desnaon xpath.
For example, to load applicaon objects into a device group named US-West, the xpath
is:
/config/devices/entry[@name='localhost.localdomain']/devicegroup/entry[@name='US-West']/application
3. Use the Panorama CLI to load the conﬁguraon and commit the change:
# load config partial mode [append|merge|replace]
from-xpath <source-xpath> to-xpath <destination-xpath>
from <filename>
# commit
For example, enter the following to load the applicaon objects from vsys1 on an
imported ﬁrewall conﬁguraon named fw1-conﬁg.xml into a device group named USWest on Panorama:
# load config partial mode merge from-xpath
devices/entry[@name='localhost.localdomain']/vsys/
entry[@name='vsys1']/application to-xpath /config/
devices/entry[@name='localhost.localdomain']/device-group/
entry[@name='US-West']/application from fw1-config.xml
# commit
STEP 6 | Push the paral conﬁguraon from Panorama to the ﬁrewall to complete the transion to
centralized management.
1. On the ﬁrewall, delete any rules or objects that have the same names as those in
Panorama. If the device group for that ﬁrewall has other ﬁrewalls with rules or objects
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that are duplicated in Panorama, perform this step on those ﬁrewalls also. For details, see
Step 2.
2. On Panorama, push the paral conﬁguraon to the ﬁrewall.
1. Select Commit > Commit and Push and Edit Selecons in the Push Scope.
2. Select Device Groups and select the device groups that contain the imported ﬁrewall
conﬁguraons.
3. Select Merge with Device Candidate Conﬁg, Include Device and Network Templates,
and Force Template Values.
4. Click OK to save your changes to the Push Scope.
5. Commit and Push your changes.
3. If the ﬁrewall has a device or network seng that you won’t use Panorama to manage,
Override a Template or Template Stack Value on the ﬁrewall.
STEP 7 | Perform your post-migraon test plan.
Perform the veriﬁcaon tasks that you devised during the migraon planning to conﬁrm that
the ﬁrewall works as eﬃciently with the Panorama-pushed conﬁguraon as it did with its
original local conﬁguraon: see Create a post-migraon test plan.

Localize a Panorama Pushed Conﬁguraon on a Managed Firewall
You can localize the template and device group conﬁguraons pushed from the Panorama™
management server to:
• Remove the ﬁrewall from Panorama management.
• Migrate ﬁrewall management to a diﬀerent Panorama.
• In the case of an emergency where Panorama is not accessible, ensure administrators can
modify the managed ﬁrewall conﬁguraon locally.
STEP 1 | Launch the web interface of the managed ﬁrewall as an administrator with the Superuser
role. You can directly access the ﬁrewall by entering its IP address in the browser URL ﬁeld
or, in Panorama, select the ﬁrewall in the Context drop-down.
STEP 2 | (Best Pracce) Select Device > Setup > Operaons and Export device state.
Save a copy of the ﬁrewall system state, including device group and template sengs pushed
from Panorama, in the event you need to reload a known working conﬁguraon on the
managed ﬁrewall.
STEP 3 | Disable the template conﬁguraon to stop using template and template stacks to manage the
network conﬁguraon objects of the managed ﬁrewall.
1. Select Device > Setup > Management and edit the Panorama Sengs.
2. Click Disable Device and Network Template.
3. (Oponal) Select Import Device and Network Template before disabling to save the
template conﬁguraon sengs locally on the ﬁrewall. If you do not select this opon,
PAN-OS deletes all Panorama-pushed sengs from the ﬁrewall.
4. Click OK twice to connue.
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STEP 4 | Disable the device group conﬁguraon to stop using a device group to manage the policy and
object conﬁguraons of the managed ﬁrewall.
1. Select Device > Setup > Management and edit the Panorama Sengs.
2. (Oponal) Select Import Panorama Policy Objects before disabling to save the policy
and object conﬁguraons locally on the ﬁrewall. If you do not select this opon, PAN-OS
deletes all Panorama-pushed conﬁguraons from the ﬁrewall.
3. Click OK to connue.
Do not aempt to commit your conﬁguraon changes on the managed ﬁrewall yet as
all commits fail unl the following steps are successfully completed.
STEP 5 | Select Device > Setup > Operaons and Save named conﬁguraon snapshot.
STEP 6 | Load named conﬁguraon snapshot and enable (check) Regenerate Rule UUIDs for selected
named conﬁguraon to generate new policy rule UUIDs.
This step is required to successfully localize the Panorama-pushed policy rules on the managed
ﬁrewalls.
STEP 7 | Click OK to load the named conﬁguraon snapshot.
STEP 8 | Commit the named conﬁguraon snapshot load.
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Device Monitoring on Panorama
Aer adding your ﬁrewalls and conﬁguring policy rules, you can monitor the health status to
ensure that your ﬁrewalls are operang within healthy parameters. For policy rules, monitor rule
traﬃc matches to idenfy which rules match your traﬃc enforcement needs.
• Monitor Device Health
• Monitor Policy Rule Usage

Monitor Device Health
Monitor the health informaon of your managed ﬁrewalls to idenfy and resolve hardware
issues before they impact your network security. Both Panorama™ and the managed ﬁrewalls
must be running PAN-OS® 8.1 or later releases but ﬁrewalls do not need to be part of a device
group or template stack to monitor their summary session, logging, resource, and environmental
performance. Panorama stores the last 90 days of health monitoring stascs of your managed
ﬁrewalls so when you select a ﬁrewall, you can view the me-trended graphs and tables for
sessions, environmentals, interfaces, logging, resources, and high availability performance.
Panorama calculates the baseline performance of each metric using seven-day averages and
standard deviaon to determine a normal operang range for the speciﬁc ﬁrewall. In addion to
tracking the baseline and comparing me-trended performance, you can view which ﬁrewalls have
deviang metrics and isolate performance-related issues before they impact your network. When
Panorama idenﬁes that a metric is outside the normal operang range, it marks the metric and
populates the Deviang Devices tab with the deviang ﬁrewall.
The health monitoring data is stored on Panorama, and is preserved in the event a ﬁrewall
is removed. When a ﬁrewall is removed from Panorama management, the health monitoring
data no longer display but are preserved for 90 days. Aer 90 days, all health monitoring data
of the removed ﬁrewall are removed from Panorama. If a ﬁrewall is added back to Panorama
management, the latest health monitoring data from when the ﬁrewall was removed is displayed.
STEP 1 | Log in to the Panorama Web Interface.
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STEP 2 | Select Panorama > Managed Devices > Health to monitor the health of managed ﬁrewalls.
View All Devices to see a list of all managed ﬁrewalls and the monitored health metrics. Select
an individual ﬁrewall to view Detailed Device View with me-trended graphs and tables of
monitored metrics.

Figure 11: Managed Firewall Health Monitoring

Figure 12: Detailed Device View
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STEP 3 | Select Deviang Devices to view ﬁrewalls with health metrics that deviated outside of the
calculated baseline.
Panorama lists all ﬁrewalls that are reporng metrics that deviate from the calculated baseline
and displays deviang metrics in red.

Monitor Policy Rule Usage
As your policies change, tracking rule usage on Panorama helps you evaluate whether your policy
implementaon connues to match your enforcement needs. This visibility helps you idenfy
and remove unused rules to reduce security risks and keep your policy rule base organized.
Addionally, rule usage tracking allows you to quickly validate new rule addions and rule changes
and to monitor rule usage for operaons and troubleshoong tasks. On Panorama, you can view
the rule usage of ﬁrewalls in a device group—to which you pushed policies—to determine if all,
some, or none of the ﬁrewalls have traﬃc matches instead of being able to monitor only the total
number of hits across all ﬁrewalls in a device group. You can quickly ﬁlter rules using the rule
usage data, such as Created and Modiﬁed dates, within a customizable me frame. The displayed
rule usage informaon persists across reboot, dataplane restarts, and upgrades.
On Panorama, you can view the rule usage details for managed ﬁrewalls that are running a PANOS 8.1 or later release, that have policy rule hit count enabled (default), and for which you have
deﬁned and pushed policy rules using device groups. Panorama cannot retrieve rule usage details
for policy rules conﬁgured locally on the ﬁrewall so you must log in to the ﬁrewall to view rule
usage informaon for locally conﬁgured rules.
Aer ﬁltering your policy rulebase, administrators can take acon to delete, disable, enable, and
tag policy rules directly from the policy opmizer. For example, you can ﬁlter for unused rules
and then tag them for review to determine whether they can be safely deleted or kept in the
rulebase. By enabling administrators to take acon directly from the policy opmizer, you reduce
the management overhead required to further assist in simplifying your rule lifecycle management
and ensure that your ﬁrewalls are not over-provisioned.
Policy rule usage data may also be useful when using Policy Opmizer to priorize which
rules to migrate or clean up ﬁrst.
To view the rule usage across any Shared rule or for a speciﬁc device group:
STEP 1 | Log in to the Panorama Web Interface.
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STEP 2 | Verify that the Policy Rule Hit Count is enabled.
1. Navigate to Policy Rulebase Sengs (Panorama > Setup > Management.
2. Verify that Policy Rule Hit Count is enabled.

STEP 3 | Select Policies > <policy rule> to view a rule.
STEP 4 | Change the Device Group context to Shared or to the speciﬁc device group you want to
view.
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STEP 5 | Determine whether the rule is being used (Rule Usage). The policy rule usage status is one of
the following:
Firewalls must run PAN-OS 8.1 or later release with Policy Rule Hit Count enabled for
Panorama to determine rule usage.
• Used—When all ﬁrewalls in the device group—to which you pushed the policy rule—have
traﬃc matches for the policy rule.
• Parally Used—When some of the ﬁrewalls in the device group—to which you pushed the
policy rule—have traﬃc matches for the policy rule.
• Unused—When no ﬁrewalls in the device group—to which you pushed the policy rule—have
traﬃc matches for the policy rule.
• Em-dash (—)—When no ﬁrewalls in the device group—to which you pushed the policy rule—
have Policy Rule Hit Count enabled or available for Panorama to determine the rule usage.
• Modiﬁed—The date and me the policy rule was last modiﬁed.
• Created—The date and me the policy rule was created.
If the rule was created when Panorama was running PAN-OS 8.1 and the Policy
Rule Hit Count seng is enabled, the First Hit date and me is used as the Created
date and me on upgrade to PAN-OS 9.0 or later releases. If the rule was created in
PAN-OS 8.1 when the Policy Rule Hit Count seng was disabled or if the rule was
created when Panorama was running PAN-OS 8.0 or an earlier release, the Created
date for the rule will be the date and me you successfully upgraded Panorama to
PAN-OS 9.0 or later releases.
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STEP 6 | Click the Rule Usage status to view the list of ﬁrewalls using the rule and the hit-count data
for traﬃc that matches that rule on each ﬁrewall.

STEP 7 | (Oponal) View the policy rule hit-count data for individual ﬁrewalls in the device group.
1. Click Preview Rules.
2. From the Device context, select the ﬁrewall for which you want to view the policy rule
usage data.
STEP 8 | Select Policies and, in the Policy Opmizer dialog, view the Rule Usage ﬁlter.
STEP 9 | Filter rules in the selected rulebase.
You can ﬁlter the rule usage for rules pushed to ﬁrewalls from Panorama. Panorama cannot
ﬁlter rule usage for rules conﬁgured locally on the ﬁrewall.
Use the rule usage ﬁlter to evaluate the rule usage within a speciﬁed period of me. For
example, ﬁlter the selected rulebase for Unused rules within the last 30 days. You can
also evaluate rule usage with other rule aributes, such as the Created and Modiﬁed
dates, which enables you to ﬁlter for the correct set of rules to review. You can use this
data to help manage your rule lifecycle and to determine if a rule needs to be removed
to reduce your network aack surface.
1. Select the Timeframe you want to ﬁlter on, or specify a Custom me frame.
2. Select the rule Usage on which you want to ﬁlter.
3. (Oponal) If you have reset the rule usage data for any rules, check for Exclude rules
reset during the last <number of days> days and decide when to exclude a rule based
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on the number of days you specify since the rule was reset. Only rules that were reset
before your speciﬁed number of days are included in the ﬁltered results.

4. (Oponal) Specify search ﬁlters based on addional rule data, other than the rule usage.
1. Hover your mouse over the column header, and from the drop-down select Columns.
2. Add any addional columns you want to ﬁlter with or to display.

3. Hover your mouse over the column data that you would like to ﬁlter, and select Filter
from the drop-down. For data that contain dates, select whether to ﬁlter using This
date, This date or earlier, or This date or later.
4. Click Apply Filter (

).
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STEP 10 | Take acon on one or more unused policy rules.
1. Select one or more unused policy rules.
2. Perform one of the following acons:
• Delete—Delete one or more selected policy rules.
• Enable—Enable one or more selected policy rules when disabled.
• Disable—Disable one or more selected policy rules.
• Tag—Apply one or more group tags to one or more selected policy rules. The group
tag must already exist in order to tag policy rule.
• Untag—Remove one or more group tags from one or more selected policy rules.
3. Select Commit and Commit and Push your changes.

Panorama Administrator's Guide Version Version 10.1

380

©2022 Palo Alto Networks, Inc.

Manage Firewalls

Use Case: Conﬁgure Firewalls Using Panorama
Let’s say that you want to use Panorama in a high availability conﬁguraon to manage a dozen
ﬁrewalls on your network: you have six ﬁrewalls deployed across six branch oﬃces, a pair of
ﬁrewalls in a high availability conﬁguraon at each of two data centers, and a ﬁrewall in each of
the two regional head oﬃces.

Figure 13: Firewall Distribution Example
The ﬁrst step in creang your central management strategy is to determine how to group the
ﬁrewalls into device groups and templates to eﬃciently push conﬁguraons from Panorama. You
can base the grouping on the business funcons, geographic locaons, or administrave domains
of the ﬁrewalls. In this example, you create two device groups and three templates to administer
the ﬁrewalls using Panorama:
• Device Groups in this Use Case
• Templates in this Use Case
• Set Up Your Centralized Conﬁguraon and Policies

Device Groups in this Use Case
In Use Case: Conﬁgure Firewalls Using Panorama, we need to deﬁne two device groups based on
the funcons the ﬁrewalls will perform:
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• DG_BranchAndRegional for grouping ﬁrewalls that serve as the security gateways at the
branch oﬃces and at the regional head oﬃces. We placed the branch oﬃce ﬁrewalls and the
regional oﬃce ﬁrewalls in the same device group because ﬁrewalls with similar funcons will
require similar policy rulebases.
• DG_DataCenter for grouping the ﬁrewalls that secure the servers at the data centers.
We can then administer shared policy rules across both device groups as well as administer
disnct device group rules for the regional oﬃce and branch oﬃce groups. Then for added
ﬂexibility, the local administrator at a regional or branch oﬃce can create local rules that match
speciﬁc source, desnaon, and service ﬂows for accessing applicaons and services that are
required for that oﬃce. In this example, we create the following hierarchy for security rules. you
can use a similar approach for any of the other rulebases.

Figure 14: Security Rules Hierarchy

Templates in this Use Case
When grouping ﬁrewalls for templates, we must take into account the diﬀerences in the
networking conﬁguraon. For example, if the interface conﬁguraon is not the same—the
interfaces are unlike in type, or the interfaces used are not alike in the numbering scheme and
link capacity, or the zone to interface mappings are diﬀerent—the ﬁrewalls must be in separate
templates. Further, the way the ﬁrewalls are conﬁgured to access network resources might be
diﬀerent because the ﬁrewalls are spread geographically; for example, the DNS server, syslog
servers and gateways that they access might be diﬀerent. So, to allow for an opmal base
conﬁguraon, in Use Case: Conﬁgure Firewalls Using Panorama we must place the ﬁrewalls in
separate templates as follows:
• T_Branch for the branch oﬃce ﬁrewalls
• T_Regional for the regional oﬃce ﬁrewalls
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• T_DataCenter for the data center ﬁrewalls

Figure 15: Device Group Example
If you plan to deploy your ﬁrewalls in an acve/acve HA conﬁguraon, assign each
ﬁrewall in the HA pair to a separate template. Doing so gives you the ﬂexibility to set
up separate networking conﬁguraons for each peer. For example, you can manage
the networking conﬁguraons in a separate template for each peer so that each can
connect to diﬀerent northbound and southbound routers, and can have diﬀerent OSPF
or BGP peering conﬁguraons.

Set Up Your Centralized Conﬁguraon and Policies
In Use Case: Conﬁgure Firewalls Using Panorama, we would need to perform the following tasks
to centrally deploy and administer ﬁrewalls:
• Add the Managed Firewalls and Deploy Updates
• Use Templates to Administer a Base Conﬁguraon
• Use Device Groups to Push Policy Rules
• Preview the Rules and Commit Changes

Add the Managed Firewalls and Deploy Updates
The ﬁrst task in Use Case: Conﬁgure Firewalls Using Panorama is to add the ﬁrewalls as managed
devices and deploy content updates and PAN-OS soware updates to those ﬁrewalls.
STEP 1 | For each ﬁrewall that Panorama will manage, Add a Firewall as a Managed Device.
In this example, add 12 ﬁrewalls.
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STEP 2 | Deploy the content updates to the ﬁrewalls. If you purchased a Threat Prevenon
subscripon, the content and anvirus databases are available to you. First install the
Applicaons or Applicaons and Threats database, then the Anvirus.
To review the status or progress for all tasks performed on Panorama, see Use the
Panorama Task Manager.
1. Select Panorama > Device Deployment > Dynamic Updates.
2. Click Check Now to check for the latest updates. If the value in the Acon column is
Download, this indicates an update is available.
3. Click Download. When the download completes, the value in the Acon column changes
to Install.
4. In the Acon column, click Install. Use the ﬁlters or user-deﬁned tags to select the
managed ﬁrewalls on which you would like to install this update.
5. Click OK, then monitor the status, progress, and result of the content update for each
ﬁrewall. The Result column displays the success or failure of the installaon.
STEP 3 | Deploy the soware updates to the ﬁrewalls.
1. Select Panorama > Device Deployment > Soware.
2. Click Check Now to check for the latest updates. If the value in the Acon column is
Download, this indicates an update is available.
3. Locate the version that you need for each hardware model and click Download. When
the download completes, the value in the Acon column changes to Install.
4. In the Acon column, click the Install link. Use the ﬁlters or user-deﬁned tags to select
the managed ﬁrewalls on which to install this version.
5. Enable the check box for Reboot device aer install or Upload only to device (do
not install) and click OK. The Results column displays the success or failure of the
installaon.

Use Templates to Administer a Base Conﬁguraon
The second task in Use Case: Conﬁgure Firewalls Using Panorama is to create the templates you
will need to push the base conﬁguraon to the ﬁrewalls.
STEP 1 | For each template you will use, Add a Template and assign the appropriate ﬁrewalls to each.
In this example, create templates named T_Branch, T_Regional, and T_DataCenter.
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STEP 2 | Deﬁne a DNS server, NTP server, syslog server, and login banner. Repeat this step for each
template.
1. In the Device tab, select the Template from the drop-down.
2. Deﬁne the DNS and NTP servers:
1. Select Device > Setup > Services > Global and edit the Services.
2. In the Services tab, enter an IP address for the Primary DNS Server.
For any ﬁrewall that has more than one virtual system (vsys), for each vsys,
add a DNS server proﬁle to the template (Device > Server Proﬁles > DNS).
3. In the NTP tab, enter an IP address for the Primary NTP Server.
4. Click OK to save your changes.
3. Add a login banner: select Device > Setup > Management, edit the General Sengs,
enter text for the Login Banner and click OK.
4. Conﬁgure a Syslog server proﬁle (Device > Server Proﬁles > Syslog).
STEP 3 | Enable HTTPS, SSH, and SNMP access to the management interface of the managed
ﬁrewalls. Repeat this step for each template.
1. In the Device tab, select the Template from the drop-down.
2. Select Setup > Management, and edit the Management Interface Sengs.
3. Under Services, select the HTTPS, SSH, and SNMP check boxes, and click OK.
STEP 4 | Create a Zone Protecon proﬁle for the ﬁrewalls in the data center template (T_DataCenter).
1. Select the Network tab and, in the Template drop-down, select T_DataCenter.
2. Select Network Proﬁles > Zone Protecon and click Add.
3. For this example, enable protecon against a SYN ﬂood—In the Flood Protecon tab,
select the SYN check box, set the Acon to SYN Cookies as, set the Alert packets/
second to 100, set the Acvate packets/second to 1000, and set the Maximum packets/
second to 10000.
4. For this example, enable alerts—In the Reconnaissance Protecon tab, select the Enable
check boxes for TCP Port Scan, Host Sweep, and UDP Port Scan. Ensure the Acon
values are set to alert (the default value).
5. Click OK to save the Zone Protecon proﬁle.
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STEP 5 | Conﬁgure the interface and zone sengs in the data center template (T_DataCenter), and
then aach the Zone Protecon proﬁle you just created.
Before performing this step, you must have conﬁgured the interfaces locally on the
ﬁrewalls. As a minimum, for each interface, you must have deﬁned the interface type,
assigned it to a virtual router (if needed), and aached a security zone.
1. Select the Network tab and, in the Template drop-down, select T_DataCenter.
2. Select Network > Interface and, in the Interface column, click the interface name.
3. Select the Interface Type from the drop-down.
4. In the Virtual Router drop-down, click New Virtual Router. When deﬁning the router,
ensure the Name matches what is deﬁned on the ﬁrewall.
5. In the Security Zone drop-down, click New Zone. When deﬁning the zone, ensure that
the Name matches what is deﬁned on the ﬁrewall.
6. Click OK to save your changes to the interface.
7. Select Network > Zones, and select the zone you just created. Verify that the correct
interface is aached to the zone.
8. In the Zone Protecon Proﬁle drop-down, select the proﬁle you created, and click OK.
STEP 6 | Push your template changes.
1. Select Commit > Commit and Push and Edit Selecons in the Push Scope.
2. Select Templates and select the ﬁrewalls assigned to the templates where you made
changes.
3. Commit and Push your changes to the Panorama conﬁguraon and to the template.

Use Device Groups to Push Policy Rules
The third task in Use Case: Conﬁgure Firewalls Using Panorama is to create the device groups to
manage policy rules on the ﬁrewalls.
STEP 1 | Create device groups and assign the appropriate ﬁrewalls to each device group: see Add a
Device Group.
In this example, create device groups named DG_BranchAndRegional and DG_DataCenter.
When conﬁguring the DG_BranchAndRegional device group, you must assign a Master ﬁrewall.
This is the only ﬁrewall in the device group that gathers user and group mapping informaon
for policy evaluaon.
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STEP 2 | Create a shared pre-rule to allow DNS and SNMP services.
1. Create a shared applicaon group for the DNS and SNMP services.
1. Select Objects > Applicaon Group and click Add.
2. Enter a Name and select the Shared check box to create a shared applicaon group
object.
3. Click Add, type DNS, and select dns from the list. Repeat for SNMP and select snmp,
snmp-trap.
4. Click OK to create the applicaon group.
2. Create the shared rule.
1. Select the Policies tab and, in the Device Group drop-down, select Shared.
2. Select the Security > Pre-Rules rulebase.
3. Click Add and enter a Name for the security rule.
4. In the Source and Desnaon tabs for the rule, click Add and enter a Source Zone
and a Desnaon Zone for the traﬃc.
5. In the Applicaons tab, click Add, type the name of the applicaons group object you
just created, and select it from the drop-down.
6. In the Acons tab, set the Acon to Allow, and click OK.
STEP 3 | Deﬁne the corporate acceptable use policy for all oﬃces. In this example, create a shared rule
that restricts access to some URL categories and denies access to peer-to-peer traﬃc that is
of risk level 3, 4, or 5.
1. Select the Policies tab and, in the Device Group drop-down, select Shared.
2. Select Security > Pre-Rules and click Add.
3. In the General tab, enter a Name for the security rule.
4. In the Source and Desnaon tabs, click Add and select any for the traﬃc Source Zone
and Desnaon Zone.
5. In the Applicaon tab, deﬁne the applicaon ﬁlter:
1. Click Add and click New Applicaon Filter in the footer of the drop-down.
2. Enter a Name, and select the Shared check box.
3. In the Risk column, select levels 3, 4, and 5.
4. In the Technology column, select peer-to-peer.
5. Click OK to save the new ﬁlter.
6. In the Service/URL Category tab, URL Category secon, click Add and select the
categories you want to block (for example, streaming-media, dang, and onlinepersonal-storage).
7. You can also aach the default URL Filtering proﬁle—In the Acons tab, Proﬁle Seng
secon, select the Proﬁle Type opon Proﬁles, and select the URL Filtering opon
default.
8. Click OK to save the security pre-rule.
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STEP 4 | Allow Facebook for all users in the Markeng group in the regional oﬃces only.
Enabling a security rule based on user and group has the following prerequisite tasks:
• Set up User-ID on the ﬁrewalls.
• Enable User-ID for each zone that contains the users you want to idenfy.
• Deﬁne a master ﬁrewall for the DG_BranchAndRegional device group (see step 1).
1. Select the Policies tab and, in the Device Group drop-down, select
DG_BranchAndRegional.
2. Select the Security > Pre-Rules rulebase.
3. Click Add and enter a Name for the security rule.
4. In the Source tab, Add the Source Zone that contains the Markeng group users.
5. In the Desnaon tab, Add the Desnaon Zone.
6. In the User tab, Add the Markeng user group to the Source User list.
7. In the Applicaon tab, click Add, type Facebook, and then select it from the drop-down.
8. In the Acon tab, set the Acon to Allow.
9. In the Target tab, select the regional oﬃce ﬁrewalls and click OK.
STEP 5 | Allow access to the Amazon cloud applicaon for the speciﬁed hosts/servers in the data
center.
1. Create an address object for the servers/hosts in the data center that need access to the
Amazon cloud applicaon.
1. Select Objects > Addresses and, in the Device Group drop-down, select
DG_DataCenter.
2. Click Add and enter a Name for the address object.
3. Select the Type, and specify an IP address and netmask (IP Netmask), range of IP
addresses (IP Range), or FQDN.
4. Click OK to save the object.
2. Create a security rule that allows access to the Amazon cloud applicaon.
1. Select Policies > Security > Pre-Rules and, in the Device Group drop-down, select
DG_DataCenter.
2. Click Add and enter a Name for the security rule.
3. Select the Source tab, Add the Source Zone for the data center, and Add the address
object (Source Address) you just deﬁned.
4. Select the Desnaon tab and Add the Desnaon Zone.
5. Select the Applicaon tab, click Add, type amazon, and select the Amazon
applicaons from the list.
6. Select the Acon tab and set the Acon to Allow.
7. Click OK to save the rule.
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STEP 6 | To enable logging for all internet-bound traﬃc on your network, create a rule that matches
trust zone to untrust zone.
1. Select the Policies tab and, in the Device Group drop-down, select Shared.
2. Select the Security > Pre-Rules rulebase.
3. Click Add and enter a Name for the security rule.
4. In the Source and Desnaon tabs for the rule, Add trust_zone as the Source Zone
and untrust_zone as the Desnaon Zone.
5. In the Acon tab, set the Acon to Deny, set the Log Seng to Log at Session end, and
click OK.

Preview the Rules and Commit Changes
The ﬁnal task in Use Case: Conﬁgure Firewalls Using Panorama is to review the rules and commit
the changes you have made to Panorama, device groups, and templates.
STEP 1 | Preview the rules.
This preview enables you to visually evaluate how rules are layered for a parcular rulebase.
1. Select Policies and Preview Rules.
2. Select a Rulebase, Device Group, and Device.
3. Close the preview dialog when you ﬁnish.
STEP 2 | Commit and push your conﬁguraon changes.
1. Select Commit > Commit and Push and Edit Selecons in the Push Scope.
2. Select Device Groups, select the device groups you added, and Include Device and
Network Templates.
3. Click OK to save your changes to the Push Scope.
4. Commit and Push your changes.
STEP 3 | Verify that Panorama applied the template and policy conﬁguraons.
1. In the Panorama header, set the Context to the ﬁrewall to access its web interface.
2. Review the template and policy conﬁguraons to ensure your changes are there.
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All Palo Alto Networks ﬁrewalls can generate logs that provide an audit trail of ﬁrewall
acvies. For Centralized Logging and Reporng, you must forward the logs generated
on the ﬁrewalls to your on-premise infrastructure that includes the Panorama™
management server or Log Collectors or send the logs to the cloud-based Cortex Data
Lake. Oponally, you can then conﬁgure Panorama to forward the logs to external
logging desnaons (such as syslog servers).
If you forward logs to a Panorama virtual appliance in Legacy mode, you don’t
need to perform any addional tasks to enable logging. If you forward logs to Log
Collectors, you must conﬁgure them as managed collectors and assign them to
Collector Groups. A managed collector can be local to an M-Series appliance, or
Panorama virtual appliance in Panorama mode. Addionally, an M-Series appliance,
or Panorama virtual appliance in Log Collector mode can be Dedicated Log Collectors.
To determine whether to deploy either or both types of managed collectors, see Local
and Distributed Log Collecon.
To manage the System and Conﬁg logs that Panorama generates locally, see Monitor
Panorama.
>

Conﬁgure a Managed Collector

>

Forward Logs to Cortex Data Lake

>

Conﬁgure Authencaon for a
Dedicated Log Collector

>

Verify Log Forwarding to Panorama

>

Manage Collector Groups

>

Modify Log Forwarding and Buﬀering
Defaults

>

Conﬁgure Log Forwarding to
Panorama

>

Conﬁgure Log Forwarding from
Panorama to External Desnaons

>

Conﬁgure Syslog Forwarding to
External Desnaons

>

Log Collecon Deployments

391

Manage Log Collecon

Conﬁgure a Managed Collector
To enable the Panorama management server to manage a Log Collector, you must add it as a
managed collector. Log Collectors support communicaon using a public or private IPv4 or IPv6
address only, including when you conﬁgure custom cerﬁcates for mutual authencaon.
You can add two types of managed collectors:
• Dedicated Log Collector—To set up a new M-600, M-500, or M-200 appliance or a Panorama
virtual appliance as a Log Collector to switch an exisng M-Series appliance or Panorama
virtual appliance from Panorama mode to Log Collector mode, you must Set Up the MSeries Appliance as a Log Collector. Keep in mind that switching from Panorama Mode to Log
Collector Mode removes the local Log Collector that is predeﬁned on the M-Series appliance in
Panorama mode.
• Local Log Collector—A Log Collector can run locally on a M-600, M-500, or M-200 appliance or
a Panorama virtual appliance in Panorama mode. On the M-Series appliances, the Log Collector
is predeﬁned; on the virtual appliance, you must add the Log Collector. When the Panorama
management server has a high availability (HA) conﬁguraon, each HA peer can have a local
Log Collector. However, relave to the primary Panorama, the Log Collector on the secondary
Panorama is remote, not local. Therefore, to use the Log Collector on the secondary Panorama,
you must manually add it to the primary Panorama (for details, see Deploy Panorama M-Series
Appliances with Local Log Collectors or Deploy Panorama Virtual Appliances with Local Log
Collectors). If you delete a local Log Collector, you can later add it back. The following steps
describe how to add a local Log Collector.
If the Panorama virtual appliance is in Legacy mode, you must switch to Panorama mode to create
a Log Collector. For details, see Set Up the Panorama Virtual Appliance with Local Log Collector.
A device registraon authencaon key is used to securely authencate and connect the
Panorama management server and the managed collector on ﬁrst connect. To conﬁgure the device
registraon authencaon key, specify the key lifeme and the number of mes you can use the
authencaon key to onboard new Log Collectors. Addionally, you can specify one or more Log
Collector serial numbers for which the authencaon key is valid.
The authencaon key expires 90 days aer the key lifeme expires. Aer 90 days, you are
prompted to re-cerfy the authencaon key to maintain its validity. If you do not re-cerfy,
then the authencaon key becomes invalid. A system log is generated each me a Log Collector
uses the Panorama-generated authencaon key. The Log Collector uses the authencaon key
to authencate Panorama when it delivers the device cerﬁcate that is used for all subsequent
communicaons.
As a best pracce, retain a local Log Collector and Collector Group on the Panorama
management server, regardless whether it manages Dedicated Log Collectors.
(Panorama evaluaon only) If you are evaluang a Panorama virtual appliance with a local
Log Collector, Conﬁgure Log Forwarding from Panorama to External Desnaons to
preserve logs generated during your evaluaon period.
Logs stored on the local Log Collector cannot be preserved when you Convert Your
Evaluaon Panorama Instance to a Producon Panorama Instance with a Local Log
Collector.
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(PAN-OS 10.1 only) For Dedicated Log Collectors running a PAN-OS 10.1 release,
Panorama running PAN-OS 10.1.3 or later release supports onboarding a Dedicated
Log Collector running PAN-OS 10.1.3 or later release only. You cannot add a Dedicated
Log Collector running PAN-OS 10.1.2 or earlier PAN-OS 10.1 release to Panorama
management if Panorama is running PAN-OS 10.1.3 or later release.
Panorama supports onboarding Dedicated Log Collectors running the following releases:
• Panorama running PAN-OS 10.1.2 or earlier PAN-OS 10.1 release— Dedicated Log
Collectors running PAN-OS 10.1.2 or earlier PAN-OS 10.1 release, and Dedicated Log
Collectors running PAN-OS 10.0 or earlier PAN-OS release.
• Panorama running PAN-OS 10.1.3 or later release— Dedicated Log Collectors running
PAN-OS 10.1.3 or later release, and Dedicated Log Collectors running PAN-OS 10.0 or
earlier PAN-OS release.
There is no impact to Dedicated Log Collectors already managed by Panorama on upgrade
to PAN-OS 10.1.
STEP 1 | Record the serial number of the Log Collector.
You will need the serial number when you add the Log Collector as a managed collector.
1. Access the Panorama web interface.
2. Select Dashboard and record the Serial # in the General Informaon secon.
STEP 2 | Log in to the Panorama Web Interface.
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STEP 3 | Create a device registraon authencaon key.
1. Select Panorama > Device Registraon Auth Key and Add a new authencaon key.
2. Conﬁgure the authencaon key.
• Name—Add a descripve name for the authencaon key.
• Lifeme—Specify the key lifeme for how long you can use the authencaon key to
onboard new Log Collectors.
• Count—Specify how many mes you can use the authencaon key to onboard new
Log Collectors.
• Device Type—Specify that this authencaon key is used to authencate only a Log
Collector.
You can select Any to use the device registraon authencaon key to
onboard ﬁrewalls, Log Collectors, and WildFire appliances.
• (Oponal) Devices—Enter one or more device serial numbers to specify for which Log
Collectors the authencaon key is valid.
3. Click OK.

4. Copy Auth Key and Close.
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STEP 4 | (Dedicated Log Collector only) Add the device registraon authencaon key to the Log
Collector.
Add the device registraon authencaon key only to a Dedicated Log Collector. A Panorama
in Panorama mode does not need to authencate its own local Log Collector.
1. Log in to the Log Collector CLI.
2. Add the device registraon authencaon key.
admin> request authkey set <auth-key>

STEP 5 | Add the Log Collector as a managed collector.
1. In the Panorama web interface, select Panorama > Managed Collectors and Add a new
Log Collector.
2. In the General sengs, enter the serial number (Collector S/N) you recorded for the Log
Collector.
3. Click OK to save your changes.
4. Select Commit > Commit to Panorama.
STEP 6 | (Oponal) Conﬁgure the Log Collector admin authencaon.
1. Select Panorama > Managed Collectors and edit the Log Collector by clicking its name.
2. Conﬁgure the Log Collector admin password:
1. Select the password Mode.
2. If you selected Password mode, enter a plaintext Password and Conﬁrm Password.
If you selected Password Hash mode, enter a hashed password string of up to 63
characters.
3. Conﬁgure the admin login security requirements:
If you set the Failed Aempts to a value other than 0 but leave the Lockout
Time at 0, then the admin user is indeﬁnitely locked out unl another
administrator manually unlocks the locked out admin. If no other administrator
has been created, you must reconﬁgure the Failed Aempts and Lockout Time
sengs on Panorama and push the conﬁguraon change to the Log Collector. To
ensure that an admin is never locked out, use the default 0 value for both Failed
Aempts and Lockout Time.
1. Enter the number of login Failed Aempts value. The range is between the default
value 0 to the maximum of 10 where the value 0 speciﬁes unlimited login aempts.
2. Enter the Lockout Time value between the default value 0 to the maximum of 60
minutes.
4. Click OK to save your changes.
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STEP 7 | Enable the logging disks.
1. Select Panorama > Managed Collectors and edit the Log Collector by clicking its name.
The Log Collector name has the same value as the hostname of the Panorama
management server.
2. Select Disks and Add each disk pair.
3. Click OK to save your changes.
4. Select Commit > Commit to Panorama.
STEP 8 | (Oponal) If your deployment is using custom cerﬁcates for authencaon between
Panorama and managed devices, deploy the custom client device cerﬁcate. For more
informaon, see Set Up Authencaon Using Custom Cerﬁcates.
1. Select Panorama > Cerﬁcate Management > Cerﬁcate Proﬁle and choose the
cerﬁcate proﬁle from the drop-down or click New Cerﬁcate Proﬁle to create one.
2. Select Panorama > Managed Collectors and Add a new Log Collector or select an
exisng one. Select Communicaon.
3. Select the type of device cerﬁcate the Type drop-down.
• If you are using a local device cerﬁcate, select the Cerﬁcate and Cerﬁcate Proﬁle
from the respecve drop-downs.
• If you are using SCEP as the device cerﬁcate, select the SCEP Proﬁle and Cerﬁcate
Proﬁle from the respecve drop-downs.
4. Click OK.
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STEP 9 | (Oponal) Conﬁgure Secure Server Communicaon on a Log Collector. For more informaon,
see Set Up Authencaon Using Custom Cerﬁcates.
1. Select Panorama > Managed Collectors and click Add. Select Communicaon.
2. Verify that the Custom Cerﬁcate Only check box is not selected. This allows you to
connue managing all devices while migrang to custom cerﬁcates.
When the Custom Cerﬁcate Only check box is selected, the Log Collector
does not authencate and cannot receive logs from devices using predeﬁned
cerﬁcates.
3. Select the SSL/TLS service proﬁle from the SSL/TLS Service Proﬁle drop-down. This
SSL/TLS service proﬁle applies to all SSL connecons between the Log Collector and
devices sending it logs.
4. Select the cerﬁcate proﬁle from the Cerﬁcate Proﬁle drop-down.
5. Select Authorize Client Based on Serial Number to have the server check clients against
the serial numbers of managed devices. The client cerﬁcate must have the special
keyword $UDID set as the CN to authorize based on serial numbers.
6. In Disconnect Wait Time (min), enter the number of minutes Panorama should before
breaking and reestablishing the connecon with its managed devices. This ﬁeld is blank
by default and the range is 0 to 44,640 minutes.
The disconnect wait me does not begin counng down unl you commit the
new conﬁguraon.
7. (Oponal) Conﬁgure an authorizaon list.
1. Add an Authorizaon List.
2. Select the Subject or Subject Alt Name as the Idenﬁer type.
3. Specify an idenﬁer of the selected type.
4. Click OK.
5. Enable the Log Collector to Check Authorizaon List to enforce the authorizaon list.
8. Click OK.
9. Select Commit > Commit to Panorama.
STEP 10 | Verify your changes.
1. Verify that the Panorama > Managed Collectors page lists the Log Collector you added.
The Connected column displays a check mark to indicate that the Log Collector is
connected to Panorama. You might have to wait a few minutes before the page displays
the updated connecon status.
Unl you Conﬁgure a Collector Group and push conﬁguraon changes to the
Collector Group, the Conﬁguraon Status column displays Out of Sync, the
Run Time Status column displays disconnected, and the CLI command show
interface all displays the interfaces as down.
2. Click Stascs in the last column to verify that the logging disks are enabled.
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STEP 11 | Next steps...
Before a Log Collector can receive ﬁrewall logs, you must:
1. Conﬁgure Log Forwarding to Panorama.
2. Conﬁgure a Collector Group—On the M-Series appliances, a default Collector Group is
predeﬁned and already contains the local Log Collector as a member. On the Panorama
virtual appliance, you must add the Collector Group and add the local Log Collector as a
member. On both models, assign ﬁrewalls to the local Log Collector for log forwarding.
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Conﬁgure Authencaon for a Dedicated Log Collector
Create and conﬁgure enhanced authencaon for your Dedicated Log Collector by conﬁguring
local administrave users with granular authencaon parameters, as well as leveraging RADIUS,
TACAS+, or LDAP for authorizaon and authencaon.
When you Conﬁgure and push administrators from Panorama, you overwrite the exisng
administrators on the Dedicated Log Collectors with those you conﬁgure on Panorama.
• Conﬁgure an Administrave Account for a Dedicated Log Collector
• Conﬁgure RADIUS Authencaon for a Dedicated Log Collector
• Conﬁgure TACACS+ Authencaon for a Dedicated Log Collector
• Conﬁgure LDAP Authencaon for a Dedicated Log Collector

Conﬁgure an Administrave Account for a Dedicated Log Collector
Create one or more administrators with granular authencaon parameters for your Dedicated
Log Collector to manage from the Panorama™ management server. Addionally, you can
conﬁgure local administrators from Panorama that can be conﬁgured directly on the CLI of
the Dedicated Log Collector. However, pushing new conﬁguraon changes to a Dedicated Log
Collector overwrites exisng local administrators with the administrators conﬁgured for the
Dedicated Log Collector.
STEP 1 | Log in to the Panorama Web Interface.
STEP 2 | Conﬁgure a Managed Collector.
STEP 3 | (Oponal) Conﬁgure an authencaon proﬁle to deﬁne the authencaon service that
validates the login credenals of the administrators who access the Dedicated Log Collector
CLI.
STEP 4 | Conﬁgure one or more administrator accounts as needed.
The administrator accounts created on Panorama are later imported to the Dedicated Log
Collector and managed from Panorama.
You must conﬁgure the administrave account with Superuser admin role privileges to
successfully conﬁgure authencaon for the Dedicated Log Collector.
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STEP 5 | Conﬁgure the authencaon for the Dedicated Log Collector.
1. Select Panorama > Managed Collectors and select the Dedicated Log Collector you
previously added.
2. (Oponal) Select the Authencaon Proﬁle you conﬁgured in the previous step.
3. Conﬁgure the authencaon Timeout Conﬁguraon for the Dedicated Log Collector.
1. Enter the number of Failed Aempts before a user is locked out of the Dedicated Log
Collector CLI.
2. Enter the Lockout Time, in minutes, for which the Dedicated Log Collector locks out a
user account aer that user reaches the conﬁgured number of Failed Aempts.
3. Enter the Idle Timeout, in minutes, before the user account is automacally logged
out due to inacvity.
4. Enter the Max Session Count to set how many user accounts can simultaneously
access the Dedicated Log Collector.
5. Enter the Max Session Time the administrator can be logged in before being
automacally logged out.
4. Add the Dedicated Log Collector administrators.
Administrators may either be added as a local administrator or as an imported Panorama
administrator—but not both. Adding the same administrator as both a local administrator
and as an imported Panorama administrator is not supported and causes the Panorama
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commit to fail. For example, the commit to Panorama fails if you add admin1 as both a
local and Panorama administrator.
1. Add and conﬁgure new administrators unique to the Dedicated Log Collector. These
administrators are speciﬁc to the Dedicated Log Collector for which they are created
and you manage these administrators from this table.
2. Add any administrators conﬁgured on Panorama. These administrators are created on
Panorama and imported to the Dedicated Log Collector.
5. Click OK to save the Dedicated Log Collector authencaon conﬁguraon.

STEP 6 | Commit and then Commit and Push your conﬁguraon changes.
STEP 7 | Log in to the Panorama CLI of the Dedicated Log Collector to verify you can successfully
access the Dedicated Log Collector using the local admin user.

Conﬁgure RADIUS Authencaon for a Dedicated Log Collector
Use a RADIUS server to authencate administrave access to the Dedicated Log Collector
CLI. You can also deﬁne Vendor-Speciﬁc Aributes (VSAs) on the RADIUS server to manage
administrator authorizaon. Using VSAs enables you to quickly change the roles, access domains,
and user groups of administrators through your directory service, which is oen easier than
reconﬁguring sengs on the Panorama™ management server.
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You can Import the Palo Alto Networks RADIUS diconary into RADIUS server to deﬁne
the authencaon aributes needed for communicaon between Panorama and the
RADIUS server.
STEP 1 | Log in to the Panorama Web Interface.
STEP 2 | Conﬁgure a Managed Collector.

Panorama Administrator's Guide Version Version 10.1

402

©2022 Palo Alto Networks, Inc.

Manage Log Collecon
STEP 3 | Conﬁgure RADIUS authencaon.
Administrator accounts conﬁgured for RADIUS authencaon are required to have
Superuser admin role privileges to successfully conﬁgure authencaon for the
Dedicated Log Collector.
1. Add a RADIUS server proﬁle.
The proﬁle deﬁnes how the Dedicated Log Collector connects to the RADIUS server.
1. Select Panorama > Server Proﬁles > RADIUS and Add a proﬁle.
2. Enter a Proﬁle Name to idenfy the server proﬁle.
3. Enter a Timeout interval in seconds aer which an authencaon request mes out
(default is 3; range is 1–20).
4. Select the Authencaon Protocol (default is CHAP) that the Dedicated Log Collector
uses to authencate to the RADIUS server.
Select CHAP if the RADIUS server supports that protocol; it is more secure
than PAP.
5. Add each RADIUS server and enter the following:
1. Name to idenfy the server.
2. RADIUS Server IP address or FQDN.
3. Secret/Conﬁrm Secret (a key to encrypt usernames and passwords).
4. Server Port for authencaon requests (default is 1812).
6. Click OK to save the server proﬁle.
2. Assign the RADIUS server proﬁle to an authencaon proﬁle.
The authencaon proﬁle deﬁnes authencaon sengs that are common to a set of
administrators.
1. Select Panorama > Authencaon Proﬁle and Add a proﬁle.
2. Enter a Name to idenfy the authencaon proﬁle.
3. Set the Type to RADIUS.
4. Select the Server Proﬁle you conﬁgured.
5. Select Retrieve user group from RADIUS to collect user group informaon from VSAs
deﬁned on the RADIUS server.
Panorama matches the group informaon against the groups you specify in the Allow
List of the authencaon proﬁle.
6. Select Advanced and, in the Allow List, Add the administrators that are allowed to
authencate with this authencaon proﬁle.
7. Click OK to save the authencaon proﬁle.
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STEP 4 | Conﬁgure the authencaon for the Dedicated Log Collector.
1. Select Panorama > Managed Collectors and select the Dedicated Log Collector you
previously added.
2. Select the Authencaon Proﬁle you conﬁgured in the previous step.
If a global authencaon proﬁle is not assigned you must assign an authencaon proﬁle
to each individual local administrator to leverage remote authencaon.
3. Conﬁgure the authencaon Timeout Conﬁguraon for the Dedicated Log Collector.
1. Enter the number of Failed Aempts before a user is locked out of the Dedicated Log
Collector CLI.
2. Enter the Lockout Time, in minutes, for which the Dedicated Log Collector locks out a
user account aer that user reaches the conﬁgured number of Failed Aempts.
3. Enter the Idle Timeout, in minutes, before the user account is automacally logged
out due to inacvity.
4. Enter the Max Session Count to set how many user accounts can simultaneously
access the Dedicated Log Collector.
5. Enter the Max Session Time the administrator can be logged in before being
automacally logged out.
4. Add the Dedicated Log Collector administrators.
Administrators may either be added as a local administrator or as an imported Panorama
administrator—but not both. Adding the same administrator as both a local administrator
and as an imported Panorama administrator is not supported and causes the Panorama
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commit to fail. For example, the commit to Panorama fails if you add admin1 as both a
local and Panorama administrator.
1. Add and conﬁgure new administrators unique to the Dedicated Log Collector. These
administrators are speciﬁc to the Dedicated Log Collector for which they are created
and you manage these administrators from this table.
2. Add any administrators conﬁgured on Panorama. These administrators are created on
Panorama and imported to the Dedicated Log Collector.
5. Click OK to save the Dedicated Log Collector authencaon conﬁguraon.

STEP 5 | Commit and then Commit and Push your conﬁguraon changes.
STEP 6 | Log in to the Panorama CLI of the Dedicated Log Collector to verify you can successfully
access the Dedicated Log Collector using the local admin user.

Conﬁgure TACACS+ Authencaon for a Dedicated Log Collector
You can use a TACACS+ server to authencate administrave access to the Dedicated Log
Collector CLI. You can also deﬁne Vendor-Speciﬁc Aributes (VSAs) on the TACACS+ server to
manage administrator authorizaon. Using VSAs enables you to quickly change the roles, access
domains, and user groups of administrators through your directory service, which is oen easier
than reconﬁguring sengs on Panorama.
STEP 1 | Log in to the Panorama Web Interface.
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STEP 2 | Conﬁgure a Managed Collector.
STEP 3 | Conﬁgure TACACS+ authencaon.
Administrator accounts conﬁgured for TACACS+ authencaon are required to have
Superuser admin role privileges to successfully conﬁgure authencaon for the
Dedicated Log Collector.
1. Add a TACACS+ server proﬁle.
The proﬁle deﬁnes how the Dedicated Log Collector connects to the TACACS+ server.
1. Select Panorama > Server Proﬁles > TACACS+ and Add a proﬁle.
2. Enter a Proﬁle Name to idenfy the server proﬁle.
3. Enter a Timeout interval in seconds aer which an authencaon request mes out
(default is 3; range is 1–20).
4. Select the Authencaon Protocol (default is CHAP) that Panorama uses to
authencate to the TACACS+ server.
5. Select CHAP if the TACACS+ server supports that protocol; it is more secure than
PAP.
6. Add each TACACS+ server and enter the following:
1. Name to idenfy the server.
2. TACACS+ Server IP address or FQDN.
3. Secret/Conﬁrm Secret (a key to encrypt usernames and passwords).
4. Server Port for authencaon requests (default is 49).
7. Click OK to save the server proﬁle.
2. Assign the TACACS+ server proﬁle to an authencaon proﬁle.
The authencaon proﬁle deﬁnes authencaon sengs that are common to a set of
administrators.
1. Select Panorama > Authencaon Proﬁle and Add a proﬁle.
2. Enter a Name to idenfy the proﬁle.
3. Set the Type to TACACS+.
4. Select the Server Proﬁle you conﬁgured.
5. Select Retrieve user group from TACACS+ to collect user group informaon from
VSAs deﬁned on the TACACS+ server.
Panorama matches the group informaon against the groups you specify in the Allow
List of the authencaon proﬁle.
6. Select Advanced and, in the Allow List, Add the administrators that are allowed to
authencate with this authencaon proﬁle.
7. Click OK to save the authencaon proﬁle.
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STEP 4 | Conﬁgure the authencaon for the Dedicated Log Collector.
1. Select Panorama > Managed Collectors and select the Dedicated Log Collector you
previously added.
2. Select the Authencaon Proﬁle you conﬁgured in the previous step.
If a global authencaon proﬁle is not assigned you must assign an authencaon proﬁle
to each individual local administrator to leverage remote authencaon.
3. Conﬁgure the authencaon Timeout Conﬁguraon for the Dedicated Log Collector.
1. Enter the number of Failed Aempts before a user is locked out of the Dedicated Log
Collector CLI.
2. Enter the Lockout Time, in minutes, for which the Dedicated Log Collector locks out a
user account aer that user reaches the conﬁgured number of Failed Aempts.
3. Enter the Idle Timeout, in minutes, before the user account is automacally logged
out due to inacvity.
4. Enter the Max Session Count to set how many user accounts can simultaneously
access the Dedicated Log Collector.
5. Enter the Max Session Time the administrator can be logged in before being
automacally logged out.
4. Add the Dedicated Log Collector administrators.
Administrators may either be added as a local administrator or as an imported Panorama
administrator—but not both. Adding the same administrator as both a local administrator
and as an imported Panorama administrator is not supported and causes the Panorama
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commit to fail. For example, the commit to Panorama fails if you add admin1 as both a
local and Panorama administrator.
1. Add and conﬁgure new administrators unique to the Dedicated Log Collector. These
administrators are speciﬁc to the Dedicated Log Collector for which they are created
and you manage these administrators from this table.
2. Add any administrators conﬁgured on Panorama. These administrators are created on
Panorama and imported to the Dedicated Log Collector.
5. Click OK to save the Dedicated Log Collector authencaon conﬁguraon.

STEP 5 | Commit and then Commit and Push your conﬁguraon changes.
STEP 6 | Log in to the Panorama CLI of the Dedicated Log Collector to verify you can successfully
access the Dedicated Log Collector using the local admin user.

Conﬁgure LDAP Authencaon for a Dedicated Log Collector
You can use LDAP to authencate end users who access Dedicated Log Collector web interface.
STEP 1 | Log in to the Panorama Web Interface.
STEP 2 | Conﬁgure a Managed Collector.
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STEP 3 | Add an LDAP server proﬁle.
The proﬁle deﬁnes how the Dedicated Log Collector connects to the LDAP server.
Administrator accounts conﬁgured for LDAP authencaon are required to have
Superuser admin role privileges to successfully conﬁgure authencaon for the
Dedicated Log Collector.
1. Select Panorama > Server Proﬁles > LDAP and Add a server proﬁle.
2. Enter a Proﬁle Name to idenfy the server proﬁle.
3. Add the LDAP servers (up to four). For each server, enter a Name (to idenfy the server),
LDAP Server IP address or FQDN, and server Port (default 389).
If you use an FQDN address object to idenfy the server and you subsequently
change the address, you must commit the change for the new server address to
take eﬀect.
4. Select the server Type.
5. Select the Base DN.
To idenfy the Base DN of your directory, open the Acve Directory Domains and
Trusts Microso Management Console snap-in and use the name of the top-level
domain.
6. Enter the Bind DN and Password to enable the authencaon service to authencate
the ﬁrewall.
The Bind DN account must have permission to read the LDAP directory.
7. Enter the Bind Timeout and Search Timeout in seconds (default is 30 for both).
8. Enter the Retry Interval in seconds (default is 60).
9. (Oponal) If you want the endpoint to use SSL or TLS for a more secure connecon with
the directory server, enable the opon to Require SSL/TLS secured connecon (enabled
by default). The protocol that the endpoint uses depends on the server port:
• 389 (default)—TLS (Speciﬁcally, the Dedicated Log Collector uses the StartTLS
operaon, which upgrades the inial plaintext connecon to TLS.)
• 636—SSL
• Any other port—The Dedicated Log Collector ﬁrst aempts to use TLS. If the directory
server doesn’t support TLS, the Dedicated Log Collector falls back to SSL.
10. (Oponal) For addional security, enable to the opon to Verify Server Cerﬁcate
for SSL sessions so that the endpoint veriﬁes the cerﬁcate that the directory server
presents for SSL/TLS connecons. To enable veriﬁcaon, you must also enable the
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opon to Require SSL/TLS secured connecon. For veriﬁcaon to succeed, the
cerﬁcate must meet one of the following condions:
• It is in the list of Panorama cerﬁcates: Panorama > Cerﬁcate Management >
Cerﬁcates > Device Cerﬁcates. If necessary, import the cerﬁcate into Panorama.
• The cerﬁcate signer is in the list of trusted cerﬁcate authories: Panorama >
Cerﬁcate Management > Cerﬁcates.
11. Click OK to save the server proﬁle.
STEP 4 | Conﬁgure the authencaon for the Dedicated Log Collector.
1. Select Panorama > Managed Collectors and select the Dedicated Log Collector you
previously added.
2. Conﬁgure the authencaon Timeout Conﬁguraon for the Dedicated Log Collector.
1. Enter the number of Failed Aempts before a user is locked out of the Dedicated Log
Collector CLI.
2. Enter the Lockout Time, in minutes, for which the Dedicated Log Collector locks out a
user account aer that user reaches the conﬁgured number of Failed Aempts.
3. Enter the Idle Timeout, in minutes, before the user account is automacally logged
out due to inacvity.
4. Enter the Max Session Count to set how many user accounts can simultaneously
access the Dedicated Log Collector.
5. Enter the Max Session Time the administrator can be logged in before being
automacally logged out.
3. Add the Dedicated Log Collector administrators.
Administrators may either be added as a local administrator or as an imported Panorama
administrator—but not both. Adding the same administrator as both a local administrator
and as an imported Panorama administrator is not supported and causes the Panorama
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commit to fail. For example, the commit to Panorama fails if you add admin1 as both a
local and Panorama administrator.
• Conﬁgure the local administrators.
Conﬁgure new administrators unique to the Dedicated Log Collector. These
administrators are speciﬁc to the Dedicated Log Collector for which they are created
and you manage these administrators from this table.
1. Add one or more new local administrator.
2. Enter a Name for the local administrator.
3. Assign an Authencaon Proﬁle you previously created.
LDAP authencaon proﬁles are supported only for individual local
administrators.
4. Enable (check) Use Public Key Authencaon (SSH) to import a public key ﬁle for
authencaon.
5. Select a Password Proﬁle to set the expiraon parameters.
• Import exisng Panorama administrators
Import exisng administrators conﬁgured on Panorama. These administrators are
conﬁgured and managed on Panorama and imported to Dedicated Log Collector.
1. Add an exisng Panorama administrator
4. Click OK to save the Dedicated Log Collector authencaon conﬁguraon.
STEP 5 | Conﬁgure the authencaon for the Dedicated Log Collector.
1. Select Panorama > Managed Collectors and select the Dedicated Log Collector you
previously added.
2. Select the Authencaon Proﬁle you conﬁgured in the previous step.
3. Conﬁgure the authencaon Timeout Conﬁguraon for the Dedicated Log Collector.
1. Enter the number of Failed Aempts before a user is locked out of the Dedicated Log
Collector CLI.
2. Enter the Lockout Time, in minutes, for which the Dedicated Log Collector locks out a
user account aer that user reaches the conﬁgured number of Failed Aempts.
3. Enter the Idle Timeout, in minutes, before the user account is automacally logged
out due to inacvity.
4. Enter the Max Session Count to set how many user accounts can simultaneously
access the Dedicated Log Collector.
5. Enter the Max Session Time the administrator can be logged in before being
automacally logged out.
4. Add the Dedicated Log Collector administrators.
You must add the administrator (admin) as either a local administrator or as an imported
Panorama administrator—but not both. The push to managed collectors fails if an
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administrator is not added or if the administrator is added as both a local administrator
and as an imported Panorama administrator.
1. Add and conﬁgure new administrators unique to the Dedicated Log Collector. These
administrators are speciﬁc to the Dedicated Log Collector for which they are created
and you manage these administrators from this table.
2. Add any administrators conﬁgured on Panorama. These administrators are created on
Panorama and imported to the Dedicated Log Collector.
5. Click OK to save the Dedicated Log Collector authencaon conﬁguraon.

STEP 6 | Commit and then Commit and Push your conﬁguraon changes.
STEP 7 | Log in to the Panorama CLI of the Dedicated Log Collector to verify you can successfully
access the Dedicated Log Collector using the local admin user.
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Manage Collector Groups
A Collector Group is 1 to 16 Log Collectors that operate as a single logical unit for collecng
ﬁrewall logs. You must assign at least one Log Collector to a Collector Group for ﬁrewalls to
successfully send logs to a Log Collector. Firewall logs are dropped if there is no Collector Group
conﬁgured or none of the Log Collectors are assigned to a Collector Group. You can conﬁgure a
Collector Group with mulple Log Collectors to ensure log redundancy or to accommodate logging
rates that exceed the capacity of a single Log Collector (see Panorama Models). To understand
the risks and recommended migaons, see Caveats for a Collector Group with Mulple Log
Collectors.
The M-600, M-500, and M-200 appliances in Panorama mode have a predeﬁned Collector Group
that contains a predeﬁned local Log Collector. You can edit all the sengs of the predeﬁned
Collector Group except its name (default).
If you delete a Collector Group, you will lose logs.
Palo Alto Networks recommends preserving the predeﬁned Log Collector and Collector
Group on the Panorama management server, regardless of whether Panorama also
manages Dedicated Log Collectors.
If you switch an M-Series appliance from Panorama mode to Log Collector mode, the
appliance will lose its predeﬁned Collector Group and Log Collector. You would then have
to Set Up the M-Series Appliance as a Log Collector, add it as a managed collector to
Panorama, and conﬁgure a Collector Group to contain the managed collector.
• Conﬁgure a Collector Group
• Conﬁgure Authencaon with Custom Cerﬁcates Between Log Collectors
• Move a Log Collector to a Diﬀerent Collector Group
• Remove a Firewall from a Collector Group

Conﬁgure a Collector Group
Before conﬁguring Collector Groups, decide whether each one will have a single Log Collector or
mulple Log Collectors (up to 16). A Collector Group with mulple Log Collectors supports higher
logging rates and log redundancy but has the following requirements:
• In any single Collector Group, all the Log Collectors must run on the same Panorama model:
all M-600 appliances, all M-500 appliances, all M-200 appliances, or all Panorama virtual
appliances.
• Log redundancy is available only if each Log Collector has the same number of logging disks. To
add disks to a Log Collector, see Increase Storage on the M-Series Appliance.
• (Best Pracce) All Log Collectors in the same Collector Group should be in the same local
area network (LAN). Avoid adding Log Collectors in the same or diﬀerent wide area networks
(WAN) to the same Collector Group as network disrupon are much more common and may
result in log data loss. Addionally, it is recommended that Log Collectors in the same Collector
Group be in close physical proximity to each other to allow Panorama to quickly query the Log
Collectors when needed.
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STEP 1 | Perform the following tasks before conﬁguring the Collector Group.
1. Add a Firewall as a Managed Device for each ﬁrewall that you will assign to the Collector
Group.
2. Conﬁgure a Managed Collector for each Log Collector that you will assign to the
Collector Group.
STEP 2 | Add the Collector Group.
1. Access the Panorama web interface, select Panorama > Collector Groups, and Add a
Collector Group or edit an exisng one.
2. Enter a Name for the Collector Group if you are adding one.
You cannot rename an exisng Collector Group.
3. Enter the Minimum Retenon Period in days (1 to 2,000) for which the Collector Group
will retain ﬁrewall logs.
By default, the ﬁeld is blank, which means the Collector Group retains logs indeﬁnitely.
4. Add Log Collectors (1 to 16) to the Collector Group Members list.
5. (Recommended) Enable log redundancy across collectors if you are adding mulple Log
Collectors to a single Collector group.
Redundancy ensures that no logs are lost if any one Log Collector becomes unavailable.
Each log will have two copies and each copy will reside on a diﬀerent Log Collector. For
example, if you have two Log Collectors in the collector group the log is wrien to both
Log Collectors.
Enabling redundancy creates more logs and therefore requires more storage capacity,
reducing storage capability in half. When a Collector Group runs out of space, it deletes
older logs. Redundancy also doubles the log processing traﬃc in a Collector Group,
which reduces its maximum logging rate by half, as each Log Collector must distribute a
copy of each log it receives.
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STEP 3 | Assign Log Collectors and ﬁrewalls to the Collector Group.
1. Select Device Log Forwarding and Add log forwarding preference lists for the ﬁrewalls.
Log data is forwarded over a separate TCP channel. By adding a log forwarding
preference, list you enable the creaon of separate TCP connecons for forwarding log
data.
A preference list determines the order in which Log Collectors receive logs from
a ﬁrewall. If a log forwarding preference list is not assigned, you may encounter
one of the following scenarios:
• If Panorama is in Management Only mode, Panorama drops all incoming logs.
• If the local Log Collector is not conﬁgured as a managed collector when
Panorama is in Panorama mode, Panorama drops all incoming logs.
• If the local Log Collector is conﬁgured as a managed collector when Panorama
is in Panorama mode, incoming logs are received but the Panorama may act
as a boleneck because all managed ﬁrewalls are forwarding logs to the local
Log Collector ﬁrst before being redistributed to other available Log Collectors.
1. In the Devices secon, Modify the list of ﬁrewalls and click OK.
2. In the Collectors secon, Add Log Collectors to the preference list.
If you enabled redundancy in Step 2, it is recommended to add at least two Log
Collectors. If you assign mulple Log Collectors, the ﬁrst one will be the primary; if the
primary becomes unavailable, the ﬁrewalls send logs to the next Log Collector in the
list. To change the priority of a Log Collector, select it and Move Up (higher priority) or
Move Down (lower priority).
3. Click OK.
STEP 4 | Deﬁne the storage capacity (log quotas) and expiraon period for each log type.
1. Return to the General tab and click the Log Storage value.
If the ﬁeld displays 0MB, verify that you enabled the disk pairs for logging and
commied the changes (see Conﬁgure a Managed Collector, Disks tab).
2. Enter the log storage Quota(%) for each log type.
3. Enter the Max Days (expiraon period) for each log type (1 to 2,000).
By default, the ﬁelds are blank, which means the logs never expire.
STEP 5 | Commit and verify your changes.
1. Select Commit > Commit and Push and then Commit and Push your changes to
Panorama and the Collector Group you conﬁgured.
2. Select Panorama > Managed Collectors to verify the Log Collectors in the Collector
Group are:
• Connected to Panorama—The Connected column displays a check mark icon to
indicate that a Log Collector is connected to Panorama.
• Synchronized with Panorama—The Conﬁguraon Status column indicates whether a
Log Collector is In Sync (green icon) or Out of Sync (red icon) with Panorama.
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STEP 6 | Troubleshoot Connecvity to Network Resources to verify your ﬁrewalls successfully
connected to the Log Collector.
STEP 7 | Next steps...
1. Conﬁgure Log Forwarding to Panorama.
The Collector Group won’t receive ﬁrewall logs unl you conﬁgure the ﬁrewalls to
forward to Panorama.
2. (Oponal) Conﬁgure Log Forwarding from Panorama to External Desnaons.
You can conﬁgure each Collector Group to forward logs to separate desnaons (such as
a syslog server).

Conﬁgure Authencaon with Custom Cerﬁcates Between Log
Collectors
Complete the following procedure to conﬁgure custom cerﬁcates for communicaon between
Log Collectors. You must conﬁgure secure server communicaon and secure client communicaon
on each Log Collector in a Collector Group because the server and client roles are chosen
dynamically. Use custom cerﬁcates to create a unique chain of trust that ensures mutual
authencaon between the members of your Log Collector Group.
For more informaon about using custom cerﬁcates, see How Are SSL/TLS Connecons
Mutually Authencated?
STEP 1 | Obtain key pairs and cerﬁcate authority (CA) cerﬁcates for each Log Collector.
STEP 2 | Import the CA cerﬁcate to validate the identy of the client Log Collector, the server key
pair, and the client key pair for each Log Collector in the Collector Group.
1. Select Panorama > Cerﬁcate Management > Cerﬁcates > Import.
2. Import the CA cerﬁcate, server key pair, and client key pair.
3. Repeat th step for the each Log Collector.
STEP 3 | Conﬁgure a cerﬁcate proﬁle that includes the root CA and intermediate CA for secure
server communicaon. This cerﬁcate proﬁle deﬁnes the authencaon between Log
Collectors.
1. Select Panorama > Cerﬁcate Management > Cerﬁcate Proﬁle.
2. Conﬁgure a cerﬁcate proﬁle.
If you conﬁgure an intermediate CA as part of the cerﬁcate proﬁle, you must also
include the root CA.
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STEP 4 | Conﬁgure the cerﬁcate proﬁle for secure client communicaon. You can conﬁgure this
proﬁle on each client Log Collector individually or you can push the conﬁguraon from
Panorama™ to managed Log Collectors.
If you are using SCEP for the client cerﬁcate, conﬁgure a SCEP proﬁle instead of a
cerﬁcate proﬁle.
1. Select Panorama > Cerﬁcate Management > Cerﬁcate Proﬁle.
2. Conﬁgure a Cerﬁcate Proﬁle.
STEP 5 | Conﬁgure an SSL/TLS service proﬁle.
1. Select Panorama > Cerﬁcate Management > SSL/TLS Service Proﬁle.
2. Conﬁgure an SSL/TLS service proﬁle to deﬁne the cerﬁcate and protocol that the Log
Collectors use for SSL/TLS services.
STEP 6 | Aer deploying custom cerﬁcates on all Log Collectors, enforce custom-cerﬁcate
authencaon.
1. Select Panorama > Collector Groups and select the Collector Group.
2. On the General tab, Enable secure inter LC Communicaon.
If you enable secure inter LC communicaon and your Collector Group includes a local
Log Collector, a link should appear that stang that the Log Collector on local Panorama
is using the secure client conﬁguraon from Panorama > Secure Communicaon
Sengs. You can click this link to open the Secure Communicaon Sengs dialog and
conﬁgure the secure server and secure client sengs for the Local Log Collector from
there.
3. Click OK.
4. Commit your changes.
STEP 7 | Conﬁgure secure server communicaon on each Log Collector.
1. Select Panorama > Managed Collectors for Dedicated Log Collectors or Panorama
> Setup > Management and Edit the Secure Communicaon Sengs for a Local Log
Collector.
2. For Dedicated Log Collectors, click the Log Collector and select Communicaons.
3. Enable the Customize Secure Server Communicaon feature.
4. Select the SSL/TLS service proﬁle from the SSL/TLS Service Proﬁle drop-down. This
SSL/TLS service proﬁle applies to all SSL connecons between Log Collectors.
5. Select the Cerﬁcate Proﬁle from the drop-down.
6. Verify that the Custom Cerﬁcates Only is disabled (cleared). This allows the inter Log
Collector communicaon to connue with the predeﬁned cerﬁcate while conﬁguring to
custom cerﬁcates.
7. Set the disconnect wait me—the number of minutes Log Collectors wait before
breaking and reestablishing the connecon with other Log Collectors. This ﬁeld is empty
by default (range is 0 to 44,640).
8. (Oponal) Conﬁgure an authorizaon list. The authorizaon list adds an addional
layer of security beyond cerﬁcate authencaon. The authorizaon list checks the
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client cerﬁcate Subject or Subject Alt Name. If the Subject or Subject Alt Name
presented with the client cerﬁcate does not match an idenﬁer in the authorizaon list,
authencaon is denied.
1. Add an Authorizaon List.
2. Select the Subject or Subject Alt Name conﬁgured in the cerﬁcate proﬁle as the
Idenﬁer type.
3. Enter the Common Name if the idenﬁer is Subject or an IP address, hostname, or
email if the idenﬁer is Subject Alt Name.
4. Click OK.
5. Enable the Check Authorizaon List opon to conﬁgure Panorama to enforce the
authorizaon list.
9. Click OK.
10. Commit your changes.
Aer comming these changes, the disconnect wait me countdown begins. When the
wait me ends, Log Collectors in the Collector Group cannot connect without the conﬁgured
cerﬁcates.
STEP 8 | Conﬁgure secure client communicaon on each Log Collector.
1. Select Panorama > Managed Collectors for Dedicated Log Collectors or Panorama
> Setup > Management and Edit the Secure Communicaon Sengs for a Local Log
Collector.
2. For Dedicated Log Collectors, click the Log Collector and select Communicaons.
3. Under Secure Client Communicaons, select the Cerﬁcate Type, Cerﬁcate, and
Cerﬁcate Proﬁle from the respecve drop-downs.
4. Click OK.
5. Commit your changes.

Move a Log Collector to a Diﬀerent Collector Group
M-600, M-500, M-200, and Panorama virtual appliances can have one or more Log Collectors in
each Collector Group. You assign Log Collectors to a Collector Group based on the logging rate
and log storage requirements of that Collector Group. If the rates and required storage increase in
a Collector Group, the best pracce is to Increase Storage on the M-Series Appliance or Conﬁgure
a Collector Group with addional Log Collectors. However, in some deployments, it might be more
economical to move Log Collectors between Collector Groups.
When a Log Collector is local to an M-600, M-500, or M-200 in Panorama mode, move
it only if the appliance is the passive peer in a high availability (HA) conﬁguraon. HA
synchronizaon applies the conﬁguraons associated with the new Collector Group. Never
move a Log Collector that is local to the acve HA peer.
In any single Collector Group, all the Log Collectors must run on the same Panorama
model: all M-600 appliances, all M-500 appliances, all M-200 appliances, or all Panorama
virtual appliances.
Log redundancy is available only if each Log Collector has the same number of logging
disks. To add disks to a Log Collector, see Increase Storage on the M-Series Appliance.
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STEP 1 | Remove the Log Collector from Panorama management.
1. Select Panorama > Collector Groups and edit the Collector Group that contains the Log
Collector you will move.
2. In the Collector Group Members list, select and Delete the Log Collector.
3. Select Device Log Forwarding and, in the Log Forwarding Preferences list, perform the
following steps for each set of ﬁrewalls assigned to the Log Collector you will move:
1. In the Devices column, click the link for the ﬁrewalls assigned to the Log Collector.
2. In the Collectors column, select and Delete the Log Collector.
To reassign the ﬁrewalls, Add the new Log Collector to which they will
forward logs.
3. Click OK twice to save your changes.
4. Select Panorama > Managed Collectors and then select and Delete the Log Collector
you will move.
STEP 2 | Conﬁgure a Collector Group.
Add the Log Collector to its new Collector Group and assign ﬁrewalls to the Log Collector.
When you push changes to the Collector Group conﬁguraon, Panorama starts
redistribung logs across the Log Collectors. This process can take hours for each
terabyte of logs. During the redistribuon process, the maximum logging rate is
reduced. In the Panorama > Collector Groups page, the Log Redistribuon State
column indicates the compleon status of the process as a percentage.
STEP 3 | Conﬁgure Log Forwarding to Panorama for the new Collector Group you conﬁgured.
STEP 4 | Select Commit > Commit and Push to commit your changes to Panorama and push the
changes to device groups, templates, and Collector Groups if you have not already done so.

Remove a Firewall from a Collector Group
If you use a Panorama virtual appliance in Legacy mode to manage Dedicated Log Collectors, you
have the opon to forward ﬁrewall logs to Panorama instead of forwarding to the Log Collectors.
For such cases, you must remove the ﬁrewall from the Collector Group; the ﬁrewall will then
automacally forward its logs to Panorama.
To temporarily remove the log forwarding preference list on the ﬁrewall, you can delete
it using the CLI on the ﬁrewall. You must however, remove the assigned ﬁrewalls in the
Collector Group conﬁguraon on Panorama. Otherwise, the next me you push changes
to the Collector Group, the ﬁrewall will be reconﬁgured to send logs to the assigned Log
Collector.
STEP 1 | Select Panorama > Collector Groups and edit the Collector Group.
STEP 2 | Select Device Log Forwarding, click the ﬁrewall in the Devices list, Modify the Devices list,
clear the check box of the ﬁrewall, and click OK three mes.
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STEP 3 | Select Commit > Commit and Push and then Commit and Push your changes to Panorama
and the Collector Group from which you removed the ﬁrewall.
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Conﬁgure Log Forwarding to Panorama
Each ﬁrewall stores its log ﬁles locally by default and cannot display the logs that reside on other
ﬁrewalls. Therefore, to achieve global visibility into the network acvity that all your ﬁrewalls
monitor, you must forward all ﬁrewall logs to Panorama and Use Panorama for Visibility. In cases
where some teams in your organizaon can achieve greater eﬃciency by monitoring only the logs
that are relevant to their operaons, you can create forwarding ﬁlters based on any log aributes
(such as threat type or source user). For example, a security operaons analyst who invesgates
malware aacks might be interested only in Threat logs with the type aribute set to wildﬁrevirus.
The following steps describe how to use Panorama templates and device groups for conﬁguring
mulple ﬁrewalls to forward logs.
If Panorama manages ﬁrewalls running soware versions earlier than PAN-OS 7.0, specify
a WildFire® server from which Panorama can gather analysis informaon for WildFire
samples that those ﬁrewalls submit. Panorama uses the informaon to complete WildFire
Submissions logs that are missing ﬁeld values introduced in PAN-OS 7.0. Firewalls running
earlier releases won’t populate those ﬁelds. To specify the server, select Panorama > Setup
> WildFire, edit the General Sengs, and enter the WildFire Private Cloud name. The
default is wildﬁre-public-cloud, which is the WildFire cloud hosted in the United States.
You can also forward ﬁrewall logs to external services (such as a syslog server). For details,
see Log Forwarding Opons.
STEP 1 | Add a Device Group for the ﬁrewalls that will forward logs.
Panorama requires a device group to push a Log Forwarding proﬁle to ﬁrewalls. Create a new
device group or assign the ﬁrewalls to an exisng device group.
STEP 2 | Add a Template for the ﬁrewalls that will forward logs.
Panorama requires a template to push log sengs to ﬁrewalls. Create a new template or assign
the ﬁrewalls to an exisng template.
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STEP 3 | Create a Log Forwarding proﬁle.
The proﬁle deﬁnes the desnaons for Traﬃc, Threat, WildFire Submission, URL Filtering, Data
Filtering, Tunnel and Authencaon logs.
1. Select Objects > Log Forwarding, select the Device Group of the ﬁrewalls that will
forward logs, and Add a proﬁle.
2. Enter a Name to idenfy the Log Forwarding proﬁle.
3. Add one or more match list proﬁles.
The proﬁles specify log query ﬁlters, forwarding desnaons, and automac acons such
as tagging. For each match list proﬁle:
1. Enter a Name to idenfy the proﬁle.
2. Select the Log Type.
3. In the Filter drop-down, select Filter Builder. Specify the following and then Add each
query:
Connector logic (and/or)
Log Aribute
Operator to deﬁne inclusion or exclusion logic
Aribute Value for the query to match
4. Select Panorama.
4. Click OK to save the Log Forwarding proﬁle.
STEP 4 | Assign the Log Forwarding proﬁle to policy rules and network zones.
Security, Authencaon, and DoS Protecon rules support log forwarding. In this example, you
assign the proﬁle to a Security rule.
Perform the following steps for each rule that will trigger log forwarding:
1. Select the rulebase (for example, Policies > Security > Pre Rules), select the Device
Group of the ﬁrewalls that will forward logs, and edit the rule.
2. Select Acons and select the Log Forwarding proﬁle you created.
3. Set the Proﬁle Type to Proﬁles or Group, and then select the security proﬁles or Group
Proﬁle required to trigger log generaon and forwarding for:
• Threat logs—Traﬃc must match any security proﬁle assigned to the rule.
• WildFire logs—Traﬃc must match a WildFire Analysis proﬁle assigned to the rule.
4. For Traﬃc logs, select Log At Session Start and/or Log At Session End.
5. Click OK to save the rule.
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STEP 5 | Conﬁgure the desnaons for System logs, Conﬁguraon logs, User-ID™ logs, and HIP
Match logs.
Panorama generates Correlaon logs based on the ﬁrewall logs it receives, rather than
aggregang Correlaon logs from ﬁrewalls.
1. Select Device > Log Sengs and select the Template of the ﬁrewalls that will forward
logs.
2. For each log type that the ﬁrewall will forward, see step Add one or more match list
proﬁles.
STEP 6 | (PA-7000 Series ﬁrewalls only) Conﬁgure a log card interface to perform log forwarding.
When you conﬁgure a data port on one of the PA-7000 Series Network Processing Cards
(NPCs) as a Log Card interface, the ﬁrewall will automacally begin using this interface to
forward logs to the logging desnaons you conﬁgure and forward ﬁles for WildFire analysis.
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Make sure that the interface you conﬁgure can reach the log forwarding desnaons and the
WildFire cloud, WildFire appliance, or both.
Because PA-7000 Series ﬁrewall can now forward logs to Panorama, Panorama no
longer treats the PA-7000 Series ﬁrewalls it manages as Log Collectors. If you have
not conﬁgured the PA-7000 Series ﬁrewalls to forward logs to Panorama, all logs a
managed PA-7000 Series ﬁrewall generates are only viewable from the local ﬁrewall
and not from Panorama. If you do not yet have a log forwarding infrastructure that is
capable of handling the logging rate and volume from the PA-7000 Series ﬁrewalls,
starng with PAN-OS 8.0.8 you can enable Panorama to directly query PA-7000
Series ﬁrewalls when monitoring logs. To use this funconality, both Panorama and the
PA-7000 Series ﬁrewalls must be running PAN-OS 8.0.8 or later. Enable Panorama to
directly query PA-7000 Series ﬁrewalls by entering the following command from the
Panorama CLI:
> debug reportd send-request-to-7k yes
Aer running this command, you will be able to view logs for managed PA-7000 Series
ﬁrewalls on the Panorama Monitor tab. Addionally, as with all managed devices, you
can also generate reports that include PA-7000 Series log data by selecng Remote
Device Data as the Data Source. If you later decide to enable the PA-7000 Series
ﬁrewalls to forward logs to Panorama, you must ﬁrst disable this opon using the
debug reportd send-request-to-7k no command.
1. Select Network > Interfaces > Ethernet, select the Template of the ﬁrewalls that will
forward logs, and Add Interface.
2. Select the Slot and Interface Name.
3. Set the Interface Type to Log Card.
4. Enter the IP Address, Default Gateway, and (for IPv4 only) Netmask.
5. Select Advanced and specify the Link Speed, Link Duplex, and Link State.
These ﬁelds default to auto, which speciﬁes that the ﬁrewall automacally
determines the values based on the connecon. However, the minimum
recommended Link Speed for any connecon is 1000 (Mbps).
6. Click OK to save your changes.
STEP 7 | Conﬁgure Panorama to receive the logs.
If you will forward logs to a Panorama virtual appliance in Legacy mode, you can skip
this step.
1. For each Log Collector that will receive logs, Conﬁgure a Managed Collector.
2. Conﬁgure a Collector Group to assign ﬁrewalls to speciﬁc Log Collectors for log
forwarding.
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STEP 8 | Commit your conﬁguraon changes.
1. Select Commit > Commit and Push and Edit Selecons.
2. Select Merge with Device Candidate Conﬁg and Include Device and Network Templates,
and click OK.

3. Commit and Push your changes to Panorama and push the changes to the device groups,
templates, and Collector Groups.
4. Verify Log Forwarding to Panorama to conﬁrm that your conﬁguraon is successful.
To change the log forwarding mode that the ﬁrewalls use to send logs to
Panorama, you can Modify Log Forwarding and Buﬀering Defaults. You can
also Manage Storage Quotas and Expiraon Periods for Logs and Reports.
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Conﬁgure Syslog Forwarding to External Desnaons
In the case of a deployment with a high rate of log generaon, you can forward syslogs over an
Ethernet interface to prevent loss of logs and reduce the load on the management interface, which
opmizes management operaons.
Syslog forwarding using an Ethernet interface is supported only for a Panorama™ management
server in Panorama mode or in Log Collector mode. Addionally, you can enable syslog forwarding
on only a single interface regardless whether Panorama is in Panorama mode or Log Collector
mode.
STEP 1 | Log in to the Panorama web interface.
STEP 2 | Conﬁgure a Managed Collector.
STEP 3 | Conﬁgure a Collector Group.
On the M-Series appliance, a default Collector Group is predeﬁned and already contains the
local Log Collector as a member. However on the Panorama virtual appliance, you must add
the Collector Group and add the local Log Collector as a member. For both conﬁguraons, you
need to assign ﬁrewalls to a Log Collector for log forwarding.
STEP 4 | Conﬁgure a Syslog server proﬁle.
1. Select Panorama > Server Proﬁles > Syslog and Add a new syslog server proﬁle.
2. Enter a Name for the syslog server proﬁle.
3. For each syslog server, Add the informaon that Panorama or the Dedicated Log
Collector requires to connect to it:
• Name—Unique name for the syslog server.
• Syslog Server—IP address or fully qualiﬁed domain name (FQDN) of the syslog server.
• Transport—Select UDP, TCP, or SSL as the method of communicaon with the syslog
server.
• Port—The port number to use when sending syslog messages (default is UDP on port
514); you must use the same port number on Panorama and on the Dedicated Log
Collector.
• Format—Select the syslog message format to use: BSD (default) or IETF. Tradionally,
BSD format is over UDP and IETF format is over TCP or SSL.
• Facility—Select the syslog standard value (default is LOG_USER) to calculate the
priority (PRI) ﬁeld in your syslog server implementaon. Select the value that maps to
how you use the PRI ﬁeld to manager your syslogs.
4. (Oponal) To customize which format of syslog messages that Panorama or the
Dedicated Log Collector sends, select Custom Log Format. For details about how to
create custom formats for the various log types, refer to the Common Event Format
Conﬁgurauon Guide.
5. Click OK to save the syslog server proﬁle.
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STEP 5 | Conﬁgure an Ethernet interface for forwarding syslogs.
By default, syslog forwarding is enabled on the management interface and is supported on only
one interface at a me.
• Conﬁgure an Ethernet interface on the local Log Collector from the Panorama web
interface.
1. Select Panorama > Setup > Interfaces and select an Ethernet interface.
2. Enable Interface.
3. Conﬁgure the Ethernet interface as appropriate.
4. In the Device Management Services secon, enable Syslog Forwarding.
5. Select Yes to conﬁrm your syslog forwarding change.
You can only on a single Ethernet interface on the local Log Collector.
6. Click OK to save your changes.
7. Commit and then Commit and Push your conﬁguraon changes.

• Conﬁgure an Ethernet interface on a Dedicated Log Collector.
1. Select Panorama > Managed Collectors and select a Dedicated Log Collector.
2. Enable Interface.
3. Conﬁgure the Ethernet interface as appropriate.
4. In the Log Collecon Services secon, enable Syslog Forwarding.
5. Select Yes to conﬁrm your syslog forwarding change.
You can only on a single Ethernet interface on the Dedicated Log Collector.
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6. Click OK to save your changes.
7. Commit and then Commit and Push your conﬁguraon changes.

• Conﬁgure an Ethernet interface on the local Log Collector or Dedicated Log Collector from
the Panorama CLI.
To successfully conﬁgure syslog forwarding over an Ethernet interface from the CLI, you
must ﬁrst disable syslog forwarding on the management interface and then enable syslog
forwarding on the Ethernet interface from the CLI; Panorama does not automacally disable
syslog forwarding over the management interface you enable syslog forwarding on an
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Ethernet interface from the CLI so syslog forwarding connues over the management
interface if you enable it on both the management and Ethernet interfaces.
1. Log in to the Panorama CLI
2. Disable syslog forwarding on the management interface:
admin@Panorama> configure
admin@Panorama> set log-collector <Log Collector Serial Number>
deviceconfig system service disable-syslog-forwarding yes
3. Enable syslog forwarding on the Ethernet interface:
admin@Panorama> configure
admin@Panorama> set log-collector <Log Collector Serial Number>
deviceconfig system eth<Interface Number> service disablesyslog-forwarding no
admin@Panorama> commit
4. Commit your conﬁguraon changes:
admin@Panorama> run commit-all log-collector-config logcollector-group <Collector Group name>
STEP 6 | Conﬁgure Log Forwarding to Panorama.
STEP 7 | Conﬁgure syslog forwarding from Panorama to a syslog server.
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Forward Logs to Cortex Data Lake
Cortex Data Lake is Palo Alto Networks’ cloud-based logging infrastructure. Before you can
conﬁgure your managed ﬁrewalls to send logs to Cortex Data Lake (previously called the Logging
Service), you need to purchase a license for the volume of logs in your deployment, and install the
cloud services plugin. If you already have on premise Log Collectors, you can use Cortex Data Lake
to complement and augment your exisng setup.
You can view logs forwarded to Cortex Data Lake in the last 30 days on Panorama. You are unable
to view logs forwarded to Cortex Data Lake if forwarded logs are more than 30 days old or if you
Enable Duplicate Logging. To view these logs, log in to the the hub and navigate to the Cortex
Data Lake app to use the Explore tab to view the logs older than 30 days.
STEP 1 | Install Panorama Plugins.
STEP 2 | Conﬁgure the ﬁrewalls to send logs to Cortex Data Lake.
For ﬁrewalls running PAN-OS 8.1 or later releases, you can opt to send logs to both the Cortex
Data Lake and to your Panorama and on premise log collecon setup when you select Enable
Duplicate Logging (Cloud and On-Premise). When enabled, the ﬁrewalls that belong to the
selected Template will save a copy of the logs to both locaons. You may select either Enable
Duplicate Logging (Cloud and On-Premise) or Enable Cortex Data Lake, but not both.
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Verify Log Forwarding to Panorama
Verify log forwarding to Panorama once you Conﬁgure Log Forwarding to Panorama or to the
Cortex Data Lake to test that your conﬁguraon succeeded.
Aer you conﬁgure log forwarding to Log Collectors, managed ﬁrewalls open a TCP connecon
to all conﬁgured Log Collectors. These connecons meout every sixty (60) seconds and do
not indicate that the ﬁrewall has lost connecon to the Log Collectors. When you conﬁgure log
forwarding to a local or Dedicated Log Collector over a supported ethernet interface, the ﬁrewall
traﬃc logs show incomplete sessions despite the ﬁrewall being able to successfully connect
to the Log Collectors. If you conﬁgure log forwarding over the management port, no traﬃc logs
showing incomplete sessions are generated. Traﬃc logs showing incomplete sessions are
generated by all ﬁrewalls except for the PA-5200 and PA-7000 series ﬁrewalls.
STEP 1 | Access the ﬁrewall CLI.
STEP 2 | If you conﬁgured Log Collectors, verify that each ﬁrewall has a log forwarding preference list.
> show log-collector preference-list
If the Collector Group has only one Log Collector, the output will look something like this:
Forward to all: No
Log collector Preference List
Serial Number: 003001000024
IP Address: 10.2.133.48
IPV6 Address: unknown
STEP 3 | Verify that each ﬁrewall is forwarding logs.
> show logging-status
For successful forwarding, the output indicates that the log forwarding agent is acve.
• For a Panorama virtual appliance, the agent is Panorama.
• For an M-Series appliance, the agent is a LogCollector.
• For the Cortex Data Lake, the agent is Log CollectionService.. And the
‘Log Collection log forwarding agent’ is active and connected
to <IP_address>.
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STEP 4 | View the average logging rate. The displayed rate will be the average logs/second for the last
ﬁve minutes.
• If Log Collectors receive the logs, access the Panorama web interface, select Panorama >
Managed Collectors and click the Stascs link in the far-right column.
• If a Panorama virtual appliance in Legacy mode receives the logs, access the Panorama CLI
and run the following command: debug log-collector log-collection-stats
show incoming-logs
This command also works on an M-Series appliance.
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Modify Log Forwarding and Buﬀering Defaults
You can deﬁne the log forwarding mode that the ﬁrewalls use to send logs to Panorama and, when
conﬁgured in a high availability (HA) conﬁguraon, specify which Panorama peer can receive logs.
To access these opons, select Panorama > Setup > Management, edit the Logging and Reporng
Sengs, and select Log Export and Reporng.
• Deﬁne the log forwarding mode on the ﬁrewall: The ﬁrewalls can forward logs to Panorama
(pertains to both the M-Series appliance and the Panorama virtual appliance) in either Buﬀered
Log Forwarding mode or in the Live Mode Log Forwarding mode.
Logging Opons

Descripon

(Best Pracce) Buﬀered Log
Forwarding from Device

Allows each managed ﬁrewall to buﬀer logs and send the logs
at 30-second intervals to Panorama (not user conﬁgurable).

Default: Enabled

Buﬀered log forwarding is very valuable when the ﬁrewall loses
connecvity to Panorama. The ﬁrewall buﬀers log entries to its
local hard disk and keeps a pointer to record the last log entry
that was sent to Panorama. When connecvity is restored the
ﬁrewall resumes forwarding logs from where it le oﬀ.
The disk space available for buﬀering depends on the log
storage quota for the ﬁrewall model and the volume of logs
that are pending roll over. If the ﬁrewall was disconnected for
a long me and the last log forwarded was rolled over, all the
logs from its local hard disk will be forwarded to Panorama on
reconnecon. If the available space on the local hard disk of
the ﬁrewall is consumed, the oldest entries are deleted to allow
logging of new events.

Live Mode Log Forwarding
from Device

In live mode, the managed ﬁrewall sends every log transacon
to Panorama at the same me as it records it on the ﬁrewall.

This opon is enabled when
the check box for Buﬀered
Log Forwarding from Device
is cleared.
• Deﬁne log forwarding preference on a Panorama virtual appliance in Legacy mode that is
deployed in a high availability (HA) conﬁguraon:
• When logging to a virtual disk, enable logging to the local disk on the primary Panorama
peer only. By default, both Panorama peers in the HA conﬁguraon receive logs.
For the 5200 and 7000 series ﬁrewalls, only the acve peer receive logs.
• When logging to an NFS (ESXi server only), enable the ﬁrewalls to send only newly
generated logs to a secondary Panorama peer, which is promoted to primary, aer a failover.
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Logging Opons

Pertains to

Descripon

Only Acve Primary Logs to
Local Disk

Panorama virtual
appliance in Legacy mode
that is logging to a virtual
disk and is deployed in an
HA conﬁguraon.

Allows you to conﬁgure only the
primary Panorama peer to save
logs to the local disk.

Panorama virtual
appliance in Legacy mode
that is mounted to a
Network File System
(NFS) datastore, runs on
a VMware ESXi server,
and is deployed in an HA
conﬁguraon

With NFS logging, when you
have a pair of Panorama servers
conﬁgured in a high availability
conﬁguraon, only the primary
Panorama peer mounts the NFS
datastore. Therefore, the ﬁrewalls
can only send logs to the primary
Panorama peer, which can write
to the NFS datastore.

Default: Disabled

Get Only New Logs on
Convert to Primary
Default: Disabled

When an HA failover occurs,
the Get Only New Logs on
Convert to Primary opon allows
an administrator to conﬁgure
the managed ﬁrewalls to send
only newly generated logs to
Panorama. This event is triggered
when the priority of the acvesecondary Panorama is promoted
to primary and it can begin
logging to the NFS. This behavior
is typically enabled to prevent
the ﬁrewalls from sending a large
volume of buﬀered logs when
connecvity to Panorama is
restored aer a signiﬁcant period
of me.
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Conﬁgure Log Forwarding from Panorama to External
Desnaons
Panorama enables you to forward logs to external services, including syslog, email, SNMP trap,
and HTTP-based services. Using an external service enables you to receive alerts for important
events, archive monitored informaon on systems with dedicated long-term storage, and integrate
with third-party security monitoring tools. In addion to forwarding ﬁrewall logs, you can forward
the logs that the Panorama management server and Log Collectors generate. The Panorama
management server or Log Collector that forwards the logs converts them to a format that is
appropriate for the desnaon (syslog message, email noﬁcaon, SNMP trap, or HTTP payload).
If your Panorama management server is a Panorama virtual appliance in Legacy mode, it
converts and forwards logs to external services without using Log Collectors.
You can also forward logs directly from ﬁrewalls to external services: see Log Forwarding
Opons.
On a Panorama virtual appliance running Panorama 5.1 or earlier releases, you can use
Secure Copy (SCP) commands from the CLI to export the enre log database to an SCP
server and import it to another Panorama virtual appliance. A Panorama virtual appliance
running Panorama 6.0 or later releases, and M-Series appliances running any release, do
not support these opons because the log database on those models is too large for an
export or import to be praccal.
To forward logs to external services, start by conﬁguring the ﬁrewalls to forward logs to Panorama.
Then you must conﬁgure the server proﬁles that deﬁne how Panorama and Log Collectors connect
to the services. Lastly, you assign the server proﬁles to the log sengs of Panorama and to
Collector Groups.
STEP 1 | Conﬁgure the ﬁrewalls to forward logs to Panorama.
Conﬁgure Log Forwarding to Panorama.
STEP 2 | Conﬁgure a server proﬁle for each external service that will receive log informaon.
1. Select Panorama > Server Proﬁles and select the type of server that will receive the log
data: SNMP Trap, Syslog, Email, or HTTP.
2. Conﬁgure the server proﬁle:
• Conﬁgure an SNMP Trap server proﬁle. For details on how SNMP works for Panorama
and Log Collectors, refer to SNMP Support.
• Conﬁgure a Syslog server proﬁle. If the syslog server requires client authencaon,
use the Panorama > Cerﬁcate Management > Cerﬁcates page to create a
cerﬁcate for securing syslog communicaon over SSL.
• Conﬁgure an Email server proﬁle.
• Conﬁgure an HTTP server proﬁle.
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STEP 3 | Conﬁgure desnaons for:
• Logs that the Panorama management server and Log Collectors generate.
• Firewall logs that a Panorama virtual appliance in Legacy mode collects.
1. Select Panorama > Log Sengs.
2. Add one or more match list proﬁles for each log type.
The proﬁles specify log query ﬁlters, forwarding desnaons, and automac acons such
as tagging. For each match list proﬁle:
1. Enter a Name to idenfy the proﬁle.
2. Select the Log Type.
3. In the Filter drop-down, select Filter Builder. Specify the following and then Add each
query:
Connector logic (and/or)
Log Aribute
Operator to deﬁne inclusion or exclusion logic
Aribute Value for the query to match
4. Add the server proﬁles you conﬁgured for each external service.
5. Click OK to save the proﬁle.
STEP 4 | Conﬁgure desnaons for ﬁrewall logs that Log Collectors receive.
Each Collector Group can forward logs to diﬀerent desnaons. If the Log Collectors
are local to a high availability (HA) pair of Panorama management servers, you must
log into each HA peer to conﬁgure log forwarding for its Collector Group.
1. Select Panorama > Collector Groups and edit the Collector Group that receives the
ﬁrewall logs.
2. (Oponal, SNMP trap forwarding only) Select Monitoring and conﬁgure the SNMP
sengs.
3. Select Collector Log Forwarding and Add conﬁgured match list proﬁles as necessary.
4. Click OK to save your changes to the Collector Group.
STEP 5 | (Syslog forwarding only) If the syslog server requires client authencaon and the
ﬁrewalls forward logs to Dedicated Log Collectors, assign a cerﬁcate that secures syslog
communicaon over SSL.
Perform the following steps for each Dedicated Log Collector:
1. Select Panorama > Managed Collectors and edit the Log Collector.
2. Select the Cerﬁcate for Secure Syslog and click OK.
STEP 6 | (SNMP trap forwarding only) Enable your SNMP manager to interpret traps.
Load the Supported MIBs and, if necessary, compile them. For the speciﬁc steps, refer to the
documentaon of your SNMP manager.
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STEP 7 | Commit and verify your conﬁguraon changes.
1. Select Commit > Commit and Push to commit your changes to Panorama and push the
changes to device groups, templates, and Collector Groups.
2. Verify that the external services are receiving the log informaon:
• Email server—Verify that the speciﬁed recipients are receiving logs as email
noﬁcaons.
• Syslog server—Refer to the documentaon for your syslog server to verify it’s
receiving logs as syslog messages.
• SNMP manager—Refer to the documentaon for your SNMP trap server to verify it’s
receiving logs as SNMP traps.
• HTTP server—Verify that the HTTP-based server is receiving logs in the correct
payload format.

Panorama Administrator's Guide Version Version 10.1

437

©2022 Palo Alto Networks, Inc.

Manage Log Collecon

Log Collecon Deployments
The following topics describe how to conﬁgure log collecon in the most typical deployments.
Before starng, Plan Your Panorama Deployment according to your current and future logging
needs.
The deployments in these topics all describe Panorama in a high availability (HA)
conﬁguraon. Palo Alto Networks recommends HA because it enables automac recovery
(in case of server failure) of components that are not saved as part of conﬁguraon
backups. In HA deployments, the Panorama management server only supports an acve/
passive conﬁguraon.
• Deploy Panorama with Dedicated Log Collectors
• Deploy Panorama M-Series Appliances with Local Log Collectors
• Deploy Panorama Virtual Appliances with Local Log Collectors
• Deploy Panorama Virtual Appliances in Legacy Mode with Local Log Collecon

Deploy Panorama with Dedicated Log Collectors
The following ﬁgures illustrate Panorama in a distributed log collecon deployment. In these
examples, the Panorama management server comprises two M-Series or Panorama virtual
appliances in Panorama mode that are deployed in an acve/passive high availability (HA)
conﬁguraon. The ﬁrewalls send logs to Dedicated Log Collectors (M-Series or Panorama virtual
appliances in Log Collector mode). This is the recommended conﬁguraon if the ﬁrewalls generate
over 10,000 logs/second.
If you will assign more than one Log Collector to a Collector Group, see Caveats for a
Collector Group with Mulple Log Collectors to understand the requirements, risks, and
recommended migaons.
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Figure 16: Single Dedicated Log Collector Per Collector Group

Figure 17: Multiple Dedicated Log Collectors Per Collector Group
Perform the following steps to deploy Panorama with Dedicated Log Collectors. Skip any steps
you have already performed (for example, the inial setup).
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STEP 1 | Perform the inial setup of the Panorama management server (virtual appliances or M-Series
appliances) and the Dedicated Log Collectors.
For each M-Series appliance:
1. Rack mount the M-Series appliance. Refer to the M-Series Hardware Reference Guide for
instrucons.
2. Perform Inial Conﬁguraon of the M-Series Appliance.
Palo Alto Networks recommends reserving the management (MGT) interface for
administrave access to Panorama and dedicang separate M-Series Appliance
Interfaces to other Panorama services.
3. Conﬁgure each array. This task is required to make the RAID disks available for logging.
Oponally, you can add disks to Increase Storage on the M-Series Appliance.
4. Register Panorama and Install Licenses.
5. Install Content and Soware Updates for Panorama.
For each virtual appliance (if any):
1. Install the Panorama Virtual Appliance.
2. Perform Inial Conﬁguraon of the Panorama Virtual Appliance.
3. Register Panorama and Install Licenses.
4. Install Content and Soware Updates for Panorama.
For the Panorama management server (virtual appliance or M-Series appliance), you must also
Set Up HA on Panorama.

Panorama Administrator's Guide Version Version 10.1

440

©2022 Palo Alto Networks, Inc.

Manage Log Collecon
STEP 2 | Switch from Panorama mode to Log Collector mode on each Panorama management server
that will be a Dedicated Log Collector.
Switching the mode of an M-Series or Panorama virtual appliance deletes any exisng
log data and deletes all conﬁguraons except the management access sengs. Aer
the switch, the M-Series or Panorama virtual appliance retains CLI access but loses
web interface access.
1. Connect to Panorama in one of the following ways:
• (M-Series appliances only) Aach a serial cable from your computer to the Console
port on the M-Series appliance. Then use terminal emulaon soware (9600-8-N-1)
to connect.
• Use terminal emulaon soware such as PuTTY to open an SSH session to the IP
address that you speciﬁed for the MGT interface of the Panorama management server
during inial conﬁguraon.
2. Log in to the CLI when prompted. Use the default admin account and the password that
you speciﬁed during inial conﬁguraon.
3. Switch to Log Collector mode by entering the following command:
> request system system-mode logger
4. Enter Y to conﬁrm the mode change. The Panorama management server reboots. If
the reboot process terminates your terminal emulaon soware session, reconnect to
Panorama to see the Panorama login prompt.
If you see a CMS Login prompt, this means the Log Collector has not ﬁnished
reboong. Press Enter at the prompt without typing a username or password.
5. Log back in to the CLI.
6. Verify that the switch to Log Collector mode succeeded:
> show system info | match system-mode
If the mode change succeeded, the output displays:
system-mode: logger
STEP 3 | Enable connecvity between each Log Collector and the Panorama management server.
This step is required before you can enable logging disks on the Log Collectors.
Enter the following commands at the CLI of each Log Collector. <IPaddress1> is for the MGT
interface of the acve Panorama and <IPaddress2> is for the MGT interface of the passive
Panorama.
> configure
# set deviceconfig system panorama-server <IPaddress1> panoramaserver-2 <IPaddress2>
# commit
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# exit
STEP 4 | Record the serial number of each Log Collector.
You need the serial numbers to add the Log Collectors as managed collectors on the Panorama
management server.
1. At the CLI of each Log Collector, enter the following command to display its serial
number.
> show system info | match serial
2. Record the serial number.
STEP 5 | Add each Log Collector as a managed collector.
Use the web interface of the primary Panorama management server peer to Conﬁgure a
Managed Collector:
1. Select Panorama > Managed Collectors and Add the managed collector.
2. In the General tab, enter the serial number (Collector S/N) you recorded for the Log
Collector.
3. Enter the IP address or FQDN of the acve and passive Panorama HA peers in the
Panorama Server IP ﬁeld and Panorama Server IP 2 ﬁeld respecvely. These ﬁelds are
required.
4. Select Interfaces, click Management, and conﬁgure one or both of the following ﬁeld
sets for the MGT interface based on the IP protocols of your network.
If you conﬁgure a Public IP Address for the interface, Log Collectors in the
Collector Group always use the public IP address for communicaon within
the Collector Group. To ensure Log Collectors in a Collector use the private IP
address to communicate, do not conﬁgure a public IP address.
• IPv4—IP Address, Netmask, and Default Gateway
• IPv6—IPv6 Address/Preﬁx Length and Default IPv6 Gateway
5. (Oponal) Select SNMP if you will use an SNMP manager to monitor Log Collector
stascs.
Using SNMP requires addional steps besides conﬁguring the Log Collector (see Monitor
Panorama and Log Collector Stascs Using SNMP).
6. Click OK to save your changes.
7. Select Commit > Commit to Panorama and Commit your changes.
This step is required before you can enable logging disks on the Log Collectors.
8. Verify that the Panorama > Managed Collectors page lists the Log Collector you added.
The Connected column displays a check mark to indicate that the Log Collector is
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connected to Panorama. You might have to wait a few minutes before the page displays
the updated connecon status.
At this point, the Conﬁguraon Status column displays Out of Sync and the Run
Time Status column displays disconnected. The status will change to In Sync and
connected aer you conﬁgure a Collector Group (Step 9).
STEP 6 | Enable the logging disks on each Log Collector.
Use the web interface of the primary Panorama management server peer to perform these
steps:
1. Select Panorama > Managed Collectors and edit the Log Collector.
2. Select Disks, Add each disk pair, and click OK.
3. Select Commit > Commit to Panorama and Commit your changes.
STEP 7 | (Recommended) Conﬁgure the Ethernet1, Ethernet2, Ethernet3, Ethernet4, and Ethernet5
interfaces if the Log Collector will use them for Device Log Collecon (receiving logs from
ﬁrewalls) and Collector Group Communicaon.
By default, the Log Collector uses the MGT interface for log collecon and Collector Group
communicaon. Assigning other interfaces to these funcons enables you to reserve the MGT
interface for management traﬃc. In an environment with heavy log traﬃc, consider using the
10Gbps interfaces (Ethernet4 and Ethernet5) on the M-500 appliance for log collecon and
Collector Group communicaon. To load balance the logging traﬃc across interfaces, you can
enable Device Log Collecon on mulple interfaces.
Use the web interface of the primary Panorama management server peer to perform these
steps for each Log Collector:
1. Select Panorama > Managed Collectors, edit the Log Collector, and select Interfaces.
2. Perform the following steps for each interface:
1. Click the name of the interface to edit it.
2. Select <interface-name> to enable the interface.
3. Complete one or both of the following ﬁeld sets based on the IP protocols of your
network:
IPv4—IP Address, Netmask, and Default Gateway
IPv6—IPv6 Address/Preﬁx Length and Default IPv6 Gateway
4. Select the Device Management Services that the interface supports:
Device Log Collecon—You can assign one or more interfaces.
Collector Group Communicaon—You can assign only one interface.
5. Click OK to save your changes to the interface.
3. Click OK to save your changes to the Log Collector.
4. Select Commit > Commit to Panorama and Commit your changes to the Panorama
conﬁguraon.
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STEP 8 | Add a Firewall as a Managed Device.
Use the web interface of the primary Panorama management server peer to perform this task
for each ﬁrewall that will forward logs to Log Collectors.
STEP 9 | Conﬁgure the Collector Group.
If each Collector Group will have one Log Collector, repeat this step for each Collector Group
before connuing.
If you will assign all the Log Collectors to one Collector Group, perform this step only once.
Use the web interface of the primary Panorama management server peer to Conﬁgure a
Collector Group:
1. Select Panorama > Collector Groups and Add the Collector Group.
2. Enter a Name to idenfy the Collector Group.
3. Add one or more Log Collectors to the Collector Group Members list.
In any single Collector Group, all the Log Collectors must run on the same
Panorama model: all M-600 appliances, all M-500 appliances, all M-200
appliances, or all Panorama virtual appliances.
4. (Best Pracce) Enable log redundancy across collectors if you add mulple Log
Collectors to a single Collector group. This opon requires each Log Collector to have the
same number of logging disks.
5. (Oponal) Select Monitoring and conﬁgure the sengs if you will use SNMP to monitor
Log Collector stascs and traps.
6. Select Device Log Forwarding and conﬁgure the Log Forwarding Preferences list. This list
deﬁnes which ﬁrewalls forward logs to which Log Collectors. Assign ﬁrewalls according
to the number of Log Collectors in this Collector Group:
• Single—Assign the ﬁrewalls that will forward logs to that Log Collector, as illustrated in
Single Dedicated Log Collector Per Collector Group.
• Mulple—Assign each ﬁrewall to both Log Collectors for redundancy. When you
conﬁgure the preferences, make Log Collector 1 the ﬁrst priority for half the ﬁrewalls
and make Log Collector 2 the ﬁrst priority for the other half, as illustrated in Mulple
Dedicated Log Collectors Per Collector Group.
7. Click OK to save your changes to the Collector Group.
8. Select Commit > Commit and Push and then Commit and Push your changes to
Panorama and to the Collector Groups you added.
9. Select Panorama > Managed Collectors to verify that the Log Collector conﬁguraon is
synchronized with Panorama.
The Conﬁguraon Status column should display In Sync and the Run Time Status column
should display connected.
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STEP 10 | Conﬁgure log forwarding from ﬁrewalls to Panorama.
Use the web interface of the primary Panorama management server peer to:
1. Conﬁgure Log Forwarding to Panorama.
2. Verify Log Forwarding to Panorama.
3. (Oponal) Conﬁgure Log Forwarding from Panorama to External Desnaons.

Deploy Panorama M-Series Appliances with Local Log Collectors
The following ﬁgures illustrate Panorama in a centralized log collecon deployment. In these
examples, the Panorama management server comprises two M-Series appliances in Panorama
mode that are deployed in an acve/passive high availability (HA) conﬁguraon. The ﬁrewalls send
logs to the predeﬁned (default) local Log Collector on each Panorama M-Series appliance. This is
the recommended deployment if the ﬁrewalls generate up to 10,000 logs/second.
If you will assign more than one Log Collector to a Collector Group, see Caveats for a
Collector Group with Mulple Log Collectors to understand the requirements, risks, and
recommended migaons.
Aer implemenng this deployment, if the logging rate increases beyond 10,000 logs per
second, Palo Alto Networks recommends that you add Dedicated Log Collectors (M-Series
appliances in Log Collector mode) as described in Deploy Panorama with Dedicated
Log Collectors. Such an expansion might require reassigning ﬁrewalls from the local Log
Collectors to Dedicated Log Collectors.

Figure 18: Single Local Log Collector Per Collector Group
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Figure 19: Multiple Local Log Collectors Per Collector Group
Perform the following steps to deploy Panorama with local Log Collectors. Skip any steps you have
already performed (for example, the inial setup).
STEP 1 | Perform the inial setup of each M-Series appliance.
1. Rack mount the M-Series appliance. Refer to the M-Series Hardware Reference Guides
for instrucons.
2. Perform Inial Conﬁguraon of the M-Series Appliance.
Palo Alto Networks recommends reserving the management (MGT) interface for
administrave access to Panorama and dedicang separate M-Series Appliance
Interfaces to other Panorama services.
3. Conﬁgure each array. This task is required to make the RAID disks available for logging.
Oponally, you can add disks to Increase Storage on the M-Series Appliance.
4. Register Panorama and Install Licenses.
5. Install Content and Soware Updates for Panorama.
6. Set Up HA on Panorama.
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STEP 2 | Perform the following steps to prepare Panorama for log collecon.
1. Connect to the primary Panorama in one of the following ways:
• Aach a serial cable from your computer to the Console port on the primary
Panorama. Then use terminal emulaon soware (9600-8-N-1) to connect.
• Use terminal emulaon soware such as PuTTY to open an SSH session to the IP
address that you speciﬁed for the MGT interface of the primary Panorama during
inial conﬁguraon.
2. Log in to the CLI when prompted. Use the default admin account and the password that
you speciﬁed during inial conﬁguraon.
3. Enable the primary Panorama to connect to the secondary Panorama by entering the
following command, where <IPaddress2> represents the MGT interface of the secondary
Panorama:
> configure
# set deviceconfig system panorama-server <IPaddress2>
# commit
4. Log in to the CLI of the secondary Panorama.
5. Enable the secondary Panorama to connect to the primary Panorama by entering the
following command, where <IPaddress1> represents the MGT interface of the primary
Panorama:
>
#
#
#

configure
set deviceconfig system panorama-server <IPaddress1>
commit
exit

6. In the CLI of the secondary Panorama, enter the following command to display the serial
number, and then record it:
> show system info | match serial
You need the serial number to add the Log Collector of the secondary Panorama as a
managed collector to the primary Panorama.
STEP 3 | Edit the Log Collector that is local to the primary Panorama.
Use the web interface of the primary Panorama to perform these steps:
1. Select Panorama > Managed Collectors and select the default (local) Log Collector.
2. Select Disks and Add each logging disk pair.
3. Click OK to save your changes.
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STEP 4 | Conﬁgure the Log Collector that is local to the secondary Panorama.
Panorama treats this Log Collector as remote because it’s not local to the primary
Panorama. Therefore you must manually add it on the primary Panorama.
Use the web interface of the primary Panorama to Conﬁgure a Managed Collector:
1. Select Panorama > Managed Collectors and Add the Log Collector.
2. Enter the serial number (Collector S/N) you recorded for the Log Collector of the
secondary Panorama.
3. Enter the IP address or FQDN of the primary and secondary Panorama HA peers in the
Panorama Server IP ﬁeld and Panorama Server IP 2 ﬁeld respecvely.
Both of these ﬁelds are required.
4. Select Interfaces and conﬁgure each interface that the Log Collector will use. The
Management interface is required. Perform the following steps for each interface:
1. Click the interface name.
2. Conﬁgure one or both of the following ﬁeld sets based on the IP protocols of your
network.
IPv4—IP Address, Netmask, and Default Gateway
IPv6—IPv6 Address/Preﬁx Length and Default IPv6 Gateway
3. (Management interface only) Select SNMP if you will use an SNMP manager to
monitor Log Collector stascs.
Using SNMP requires addional steps besides conﬁguring the Log Collector (see
Monitor Panorama and Log Collector Stascs Using SNMP).
4. Click OK to save your changes to the interface.
5. Click OK to save your changes to the Log Collector.
6. Select Commit > Commit to Panorama and Commit your changes.
This step is required before you can enable logging disks.
7. Edit the Log Collector by clicking its name.
8. Select Disks, Add each RAID disk pair, and click OK.
9. Select Commit > Commit to Panorama and Commit your changes.
STEP 5 | Add a Firewall as a Managed Device.
Use the web interface of the primary Panorama to perform this task for each ﬁrewall that will
forward logs to the Log Collectors.
STEP 6 | Edit the default Collector Group that is predeﬁned on the primary Panorama.
Use the web interface of the primary Panorama to Conﬁgure a Collector Group:
1. Select Panorama > Collector Groups and edit the default Collector Group.
2. Add the local Log Collector of the secondary Panorama to the Collector Group Members
list if you are adding mulple Log Collectors to a single Collector group. By default, the

Panorama Administrator's Guide Version Version 10.1

448

©2022 Palo Alto Networks, Inc.

Manage Log Collecon
list displays the local Log Collector of the primary Panorama because it is pre-assigned to
the default Collector Group.
In any single Collector Group, all the Log Collectors must run on the same
Panorama model: all M-600 appliances, all M-500 appliances, all M-200
appliances, or all Panorama virtual appliances.
3. (Best Pracce) Enable log redundancy across collectors if you add mulple Log
Collectors to a single Collector group. This opon requires each Log Collector to have the
same number of logging disks.
4. (Oponal) Select Monitoring and conﬁgure the sengs if you will use SNMP to monitor
Log Collector stascs and traps.
5. Select Device Log Forwarding and conﬁgure the Log Forwarding Preferences list. This list
deﬁnes which ﬁrewalls forward logs to which Log Collectors. Assign ﬁrewalls according
to the number of Log Collectors in this Collector Group:
• Single—Assign the ﬁrewalls that will forward logs to the local Log Collector of the
primary Panorama, as illustrated in Single Local Log Collector Per Collector Group.
• Mulple—Assign each ﬁrewall to both Log Collectors for redundancy. When you
conﬁgure the preferences, make Log Collector 1 the ﬁrst priority for half the ﬁrewalls
and make Log Collector 2 the ﬁrst priority for the other half, as illustrated in Mulple
Local Log Collectors Per Collector Group.
6. Click OK to save your changes.
STEP 7 | Conﬁgure a Collector Group that contains the Log Collector of the secondary Panorama.
Required if each Collector Group has only one Log Collector.
Use the web interface of the primary Panorama to Conﬁgure a Collector Group:
1. Select Panorama > Collector Groups and Add the Collector Group.
2. Enter a Name to idenfy the Collector Group.
3. Add the local Log Collector of the secondary Panorama to the Collector Group Members
list.
4. (Oponal) Select Monitoring and conﬁgure the sengs if you will use an SNMP manager
to monitor Log Collector stascs and traps.
5. Select Device Log Forwarding and Add an entry to the Log Forwarding Preferences list:
1. Modify the Devices list, select the ﬁrewalls that will forward logs to the local Log
Collector of the secondary Panorama (see Single Local Log Collector Per Collector
Group), and click OK.
2. Add the local Log Collector of the secondary Panorama to the Collectors list and click
OK.
6. Click OK to save your changes.
STEP 8 | Commit and push your changes to the Panorama conﬁguraon and the Collector Groups.
In the web interface of the primary Panorama, select Commit > Commit and Push and then
Commit and Push your changes to Panorama and the Collector Groups you added.
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STEP 9 | Manually fail over so that the secondary Panorama becomes acve.
Use the web interface of the primary Panorama to perform the following steps:
1. Select Panorama > High Availability.
2. Click Suspend local Panorama in the Operaonal Commands secon.
STEP 10 | On the secondary Panorama, conﬁgure the network sengs of the Log Collector that is local
to the primary Panorama.
Use the web interface of the secondary Panorama to perform the following steps:
1. In the Panorama web interface, select Panorama > Managed Collectors and select the
Log Collector that is local to the primary Panorama.
2. Enter the IP address or FQDN of the primary and secondary Panorama HA peers in the
Panorama Server IP ﬁeld and Panorama Server IP 2 ﬁeld respecvely.
Both of these ﬁelds are required.
3. Select Interfaces, click Management, and complete one or both of the following ﬁeld
sets (based on the IP protocols of your network) with the MGT interface values of the
primary Panorama:
• IPv4—IP Address, Netmask, and Default Gateway
• IPv6—IPv6 Address/Preﬁx Length and Default IPv6 Gateway
4. Click OK to save your changes.
5. Select Commit > Commit and Push and then Commit and Push your changes to
Panorama and the Collector Groups you added.
STEP 11 | Manually fail back so that the primary Panorama becomes acve.
Use the web interface of the secondary Panorama to perform the following steps:
1. Select Panorama > High Availability.
2. Click Suspend local Panorama in the Operaonal Commands secon.
STEP 12 | Conﬁgure log forwarding from ﬁrewalls to Panorama.
Use the web interface of the primary Panorama to:
1. Conﬁgure Log Forwarding to Panorama.
2. Verify Log Forwarding to Panorama.
3. (Oponal) Conﬁgure Log Forwarding from Panorama to External Desnaons.
You can assign separate external server proﬁles to each Panorama HA peer. For
example, you might want each peer to forward logs to a diﬀerent syslog server.
To make each Panorama peer forward logs to diﬀerent external services, log in to
the web interface of each peer, select Panorama > Collector Groups, select the
Collector Group, select Collector Log Forwarding, assign the server proﬁles, and
click OK.
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Deploy Panorama Virtual Appliances with Local Log Collectors
You can conﬁgure ﬁrewalls to send logs to a Log Collector that runs locally on a Panorama virtual
appliance in Panorama mode. In a high availability (HA) conﬁguraon, each Panorama HA peer can
have a local Log Collector. You can assign the local Log Collectors on the HA peers to the same
Collector Group or to separate Collector Groups, as illustrated in the following ﬁgures. Refer to the
Setup Prerequisites for the Panorama Virtual Appliance to review the supported logs per second
when deploying the Panorama virtual appliance with local Log Collectors in a VMware virtual
infrastructure.
If you will assign more than one Log Collector to a Collector Group, see Caveats for a
Collector Group with Mulple Log Collectors to understand the requirements, risks, and
recommended migaons.

Figure 20: Single Log Collector Per Collector Group
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Figure 21: Multiple Log Collectors Per Collector Group
Perform the following steps to deploy Panorama with local Log Collectors. Skip any steps you have
already performed (such as the inial setup).
STEP 1 | Perform the inial setup of each Panorama virtual appliance.
1. Install the Panorama Virtual Appliance. You must conﬁgure the following resources to
ensure the virtual appliance starts in Panorama mode:
• System disk with exactly 81GB of storage.
• CPUs and memory that are suﬃcient for the quanty of logs that Panorama will
receive and store.
• Virtual logging disk with 2–24TB of storage.
Panorama automacally divides the new disk into 2TB parons, each of which
will funcon as a separate virtual disk.
2. Perform Inial Conﬁguraon of the Panorama Virtual Appliance.
3. Register Panorama and Install Licenses.
4. Install Content and Soware Updates for Panorama.
STEP 2 | Set up the Panorama virtual appliances in an HA conﬁguraon.
1. Set Up HA on Panorama.
2. Test Panorama HA Failover.

Panorama Administrator's Guide Version Version 10.1

452

©2022 Palo Alto Networks, Inc.

Manage Log Collecon
STEP 3 | Add a Log Collector that is local to the primary Panorama.
On the primary Panorama:
1. Record the Panorama serial number.
1. Access the Panorama web interface.
2. Select Dashboard and record the Serial # in the General Informaon secon.
2. Add the Log Collector as a managed collector.
1. Select Panorama > Managed Collectors and Add a new Log Collector.
2. In the General sengs, enter the serial number (Collector S/N) you recorded for
Panorama.
3. Click OK to save your changes.
4. Select Commit > Commit to Panorama.
This step is required before you can add the virtual logging disks.
3. Add the virtual logging disks.
1. Select Panorama > Managed Collectors and edit the Log Collector by clicking its
name.
The Log Collector name has the same value as the hostname of the primary
Panorama.
2. Select Disks and Add the virtual logging disks.
3. Click OK to save your changes.
4. Select Commit > Commit to Panorama.
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STEP 4 | Add a Log Collector that is local to the secondary Panorama.
Panorama treats this Log Collector as remote because it does not run locally on the
primary Panorama.
1. Record the serial number of the secondary Panorama.
1. Access the web interface of the secondary Panorama.
2. Select Dashboard and record the Serial # in the General Informaon secon.
2. Access the web interface of the primary Panorama.
3. Select Panorama > Managed Collectors and Add the Log Collector.
4. In the General sengs, enter the serial number (Collector S/N) you recorded for the
secondary Panorama.
5. Enter the IP address or FQDN of the primary and secondary Panorama HA peers in the
Panorama Server IP ﬁeld and Panorama Server IP 2 ﬁeld respecvely.
Both of these ﬁelds are required.
6. Click OK to save your changes to the Log Collector.
7. Select Commit > Commit to Panorama and Commit your changes.
This step is required before you can add the virtual logging disks.
8. Edit the Log Collector by clicking its name.
The Log Collector name has the same value as the hostname of the secondary Panorama.
9. Select Disks, Add the virtual logging disks, and click OK.
10. Select Commit > Commit to Panorama and Commit your changes.
STEP 5 | Add a Firewall as a Managed Device.
Use the primary Panorama to perform this task for each ﬁrewall that will forward logs to the
Log Collectors.
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STEP 6 | Conﬁgure the Collector Group.
Perform this step once if you will assign both Log Collectors to the same Collector Group.
Otherwise, conﬁgure a Collector Group for each Log Collector.
On the primary Panorama:
1. Select Panorama > Collector Groups and Add a Collector Group.
2. Add one or both Log Collectors as Collector Group Members.
In any single Collector Group, all the Log Collectors must run on the same
Panorama model: all M-600 appliances, all M-500 appliances, all M-200
appliances, or all Panorama virtual appliances.
3. (Best Pracce) Enable log redundancy across collectors if you add mulple Log
Collectors to a single Collector group. This opon requires each Log Collector to have the
same number of virtual logging disks.
Enabling redundancy doubles the amount of logs and log processing traﬃc in a
Collector Group. If necessary, Expand Log Storage Capacity on the Panorama
Virtual Appliance.
4. Select Device Log Forwarding and conﬁgure the Log Forwarding Preferences list. This list
deﬁnes which ﬁrewalls forward logs to which Log Collectors. Assign ﬁrewalls according
to the number of Log Collectors in this Collector Group:
• Single—Assign the ﬁrewalls that will forward logs to the Log Collector that is local to
the primary Panorama, as illustrated in Single Log Collector Per Collector Group.
• Mulple—Assign each ﬁrewall to both Log Collectors for redundancy. When you
conﬁgure the preference list, make Log Collector 1 the ﬁrst priority for half the
ﬁrewalls and make Log Collector 2 the ﬁrst priority for the other half, as illustrated in
Mulple Log Collectors Per Collector Group.
5. Click OK to save your changes.
6. Select Commit > Commit and Push and then Commit and Push your changes to
Panorama and the Collector Groups you added.
STEP 7 | Trigger failover on the primary Panorama so that the secondary Panorama becomes acve.
On the primary Panorama:
1. Select Panorama > High Availability.
2. Click Suspend local Panorama in the Operaonal Commands secon.
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STEP 8 | Conﬁgure the connecon from the secondary Panorama to the Log Collector that is local to
the primary Panorama.
On the secondary Panorama:
1. In the Panorama web interface, select Panorama > Managed Collectors and select the
Log Collector that is local to the primary Panorama.
2. Enter the IP address or FQDN of the primary and secondary Panorama HA peers in the
Panorama Server IP ﬁeld and Panorama Server IP 2 ﬁeld respecvely.
Both of these ﬁelds are required.
3. Click OK to save your changes.
4. Select Commit > Commit and Push and then Commit and Push your changes to
Panorama and the Collector Groups.
STEP 9 | Trigger fail-back on the secondary Panorama so that the primary Panorama becomes acve.
On the secondary Panorama:
1. Select Panorama > High Availability.
2. Click Suspend local Panorama in the Operaonal Commands secon.
STEP 10 | Conﬁgure log forwarding from the ﬁrewalls to Panorama.
On the primary Panorama to:
1. Conﬁgure Log Forwarding to Panorama from ﬁrewalls.
2. Verify Log Forwarding to Panorama.

Deploy Panorama Virtual Appliances in Legacy Mode with Local
Log Collecon
The following ﬁgure illustrates Panorama in a centralized log collecon deployment. In this
example, the Panorama management server comprises two Panorama virtual appliances in Legacy
mode that are deployed in an acve/passive high availability (HA) conﬁguraon. This conﬁguraon
suits ﬁrewall management within a VMware virtual infrastructure in which Panorama processes up
to 10,000 logs/second. The ﬁrewalls send logs to the NFS datastore (ESXi server only) or virtual
disk on the Panorama management server. By default, the acve and passive peers both receive
logs, though you can Modify Log Forwarding and Buﬀering Defaults so that only the acve peer
does. For the 5200 and 7000 series ﬁrewalls, only the acve peer receive logs. By default, the
Panorama virtual appliance in Legacy mode uses approximately 11GB on its internal disk paron
for log storage, though you can Expand Log Storage Capacity on the Panorama Virtual Appliance if
necessary.
If the logging rate increases beyond 10,000 logs per second, it is recommended that you
Deploy Panorama with Dedicated Log Collectors.
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Figure 22: Panorama Virtual Appliances in Legacy Mode with Local Log Collection
Perform the following steps to deploy Panorama virtual appliances with local log collecon. Skip
any steps you have already performed (for example, the inial setup).
STEP 1 | Perform the inial setup of each Panorama virtual appliance.
1. Install the Panorama Virtual Appliance. To ensure the virtual appliance starts in Panorama
mode, do not add a virtual logging disk during installaon.
By default, Panorama uses an 11GB paron on its system disk for log storage.
If you want more storage, you can add a dedicated virtual logging disk of up to
8TB aer the installaon.
2. Perform Inial Conﬁguraon of the Panorama Virtual Appliance.
3. Register Panorama and Install Licenses.
4. Install Content and Soware Updates for Panorama.
STEP 2 | Set up the Panorama virtual appliances in an HA conﬁguraon.
1. Set Up HA on Panorama.
2. Test Panorama HA Failover.
STEP 3 | Perform the following steps to prepare Panorama for log collecon.
1. Add a Firewall as a Managed Device for each one that will forward logs to Panorama.
2. Conﬁgure Log Forwarding to Panorama.
STEP 4 | Commit your changes.
Select Commit > Commit to Panorama and Commit your changes.
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You can manage up to 200 standalone WildFire appliances and WildFire appliance
cluster nodes centrally using a Panorama M-Series or virtual appliance. Compared
to managing WildFire appliances and appliance clusters individually using the local
CLI, using Panorama provides centralized management and monitoring of mulple
appliances and appliance clusters. Centralized management enables you to push
common conﬁguraons, conﬁguraon updates, and soware upgrades to all or
a subset of the managed WildFire appliances, which makes it easy to ensure that
WildFire appliances and appliance clusters have consistent conﬁguraons.
When you use Panorama to manage WildFire appliance clusters, Panorama must run
an equal or later version than the WildFire appliances being managed.
> Add Standalone WildFire Appliances to Manage with Panorama
> Conﬁgure Basic WildFire Appliance Sengs on Panorama
> Set Up Authencaon Using Custom Cerﬁcates on WildFire Appliances and
Clusters
> Remove a WildFire Appliance from Panorama Management
> Manage WildFire Clusters
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Add Standalone WildFire Appliances to Manage with
Panorama
You can manage up to 200 WildFire® appliances with a Panorama® M-Series or virtual appliance.
The WildFire 200-appliance limit is a combined total of standalone appliances and WildFire
appliance cluster nodes (if you also Conﬁgure a Cluster and Add Nodes on Panorama).
Ensure that your Panorama server is running PAN-OS® 8.1.0 or a later PAN-OS version, and that
any WildFire appliance you add to your Panorama management server is also running PAN-OS
8.1.0 or a later release.
A device registraon authencaon key is used to securely authencate and connect the
Panorama management server and the WildFire appliance on ﬁrst connect. To conﬁgure the device
registraon authencaon key, specify the key lifeme and the number of mes you can use the
authencaon key to onboard new WildFire appliances. Addionally, you can specify one or more
WildFire appliance serial numbers for which the authencaon key is valid.
The authencaon key expires 90 days aer the key lifeme expires. Aer 90 days, you are
prompted to re-cerfy the authencaon key to maintain its validity. If you do not re-cerfy,
then the authencaon key becomes invalid. A system log is generated each me a WildFire
appliance uses the Panorama-generated authencaon key. The WildFire appliance uses the
authencaon key to authencate Panorama when it delivers the device cerﬁcate that is used
for all subsequent communicaons.
(PAN-OS 10.1 only) For WildFire appliances running a PAN-OS 10.1 release, Panorama
running PAN-OS 10.1.3 or later release supports onboarding a WildFire appliance running
PAN-OS 10.1.3 or later release only. You cannot add a WildFire appliance running PANOS 10.1.2 or earlier PAN-OS 10.1 release to Panorama management if Panorama is
running PAN-OS 10.1.3 or later release.
Panorama supports onboarding WildFire appliances running the following releases:
• Panorama running PAN-OS 10.1.2 or earlier PAN-OS 10.1 release— WildFire
appliances running PAN-OS 10.1.2 or earlier PAN-OS 10.1 release, and WildFire
appliances running PAN-OS 10.0 or earlier PAN-OS release.
• Panorama running PAN-OS 10.1.3 or later release— WildFire appliances running PANOS 10.1.3 or later release, and WildFire appliances running PAN-OS 10.0 or earlier
PAN-OS release.
There is no impact to WildFire appliances already managed by Panorama on upgrade to
PAN-OS 10.1.
STEP 1 | Using the local CLI, verify that each WildFire appliance that you want to manage on a
Panorama management server is running PAN-OS 8.1.0 or a later release.
admin@qa16> show system info | match version
sw-version: 8.0.1-c45
wf-content-version: 702-283
logdb-version: 8.0.15
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STEP 2 | On each Panorama appliance you want to use to manage WildFire appliances, verify that the
Panorama management server is running PAN-OS 8.1.0 or a later release.
Dashboard > General Informaon > Soware Version displays the running soware version.
STEP 3 | If you aren’t sure whether a WildFire appliance belongs to a WildFire appliance cluster or is
a standalone appliance on the local WildFire appliance CLI, check the Node mode to ensure
that the status is stand_alone and check the Applicationstatus to ensure that the
global-db-service and global-queue-service indicate ReadyStandalone.
admin@WF-500> show cluster membership
Service Summary: wfpc signature
Cluster name:
Address:
10.10.10.100
Host name:
WF-500
Node name:
wfpc-012345678901-internal
Serial number:
012345678901
Node mode:
stand_alone
Server role:
True
HA priority:
Last changed:
Mon, 06 Mar 2017 16:34:25 -0800
Services:
wfcore signature wfpc infra
Monitor status:
Serf Health Status: passing
Agent alive and reachable
Application status:
global-db-service: ReadyStandalone
wildfire-apps-service: Ready
global-queue-service: ReadyStandalone
wildfire-management-service: Done
siggen-db: ReadyMaster
Diag report:
10.10.10.100: reported leader '10.10.10.100', age
0.
10.10.10.100: local node passed sanity check.
STEP 4 | If the WildFire appliances you want to manage with Panorama are new, check Get
Started with WildFire to ensure that you complete basic steps such as conﬁrming your
WildFire license is acve, enabling logging, connecng ﬁrewalls to WildFire appliances, and
conﬁguring basic WildFire features.
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STEP 5 | Create a device registraon authencaon key.
1. Select Panorama > Device Registraon Auth Key and Add a new authencaon key.
2. Conﬁgure the authencaon key.
• Name—Add a descripve name for the authencaon key.
• Lifeme—Specify the key lifeme for how long you can use the authencaon key
used to onboard new WildFire appliances.
• Count—Specify how many mes you can use the authencaon key to onboard new
WildFire appliances.
• Device Type—Specify that the authencaon key is used to authencate Any device.
• (Oponal) Devices—Enter one or more device serial numbers to specify for which
WildFire appliances the authencaon key is valid.
3. Click OK.

4. Copy Auth Key and Close.

STEP 6 | On the local CLI of each WildFire appliance the Panorama server will manage, conﬁgure the
IP address of the Panorama server and add the device registraon authencaon key.
Before you register standalone WildFire appliances to a Panorama appliance, you must ﬁrst
conﬁgure the Panorama IP address or FQDN and add the device registraon authencaon
key on each WildFire appliance. This enables each WildFire appliance to securely connect
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to the Panorama appliance that manages the WildFire appliance. The device registraon
authencaon key is used only for the inial connecon to the Panorama server.
1. Conﬁgure the IP address or FQDN of the management interface for the primary
Panorama server.
admin@WF-500# set deviceconfig system panorama-server <ipaddress | FQDN>
2. If you use a backup Panorama appliance for high availability (recommended), conﬁgure
the IP address or FQDN of the management interface for the backup Panorama server:
admin@WF-500# set deviceconfig system panorama-server-2 <ipaddress | FQDN>
3. Add the device registraon authencaon key.
admin> request authkey set <auth-key>

STEP 7 | Register WildFire appliances on the primary Panorama appliance.
1. From the Panorama web interface, Panorama > Managed WildFire Appliances and Add
Appliance.
2. Enter the serial number of each WildFire appliance on a separate line. If you do not have
a list of serial numbers, on each WildFire appliance, run:
admin@WF-500> show system info | match serial
serial: 012345678901
Several local CLI commands display the WildFire appliance serial number, including show
cluster membership.
3. Click OK.
If it is available, informaon about conﬁguraon that is already commied on the
WildFire appliances displays, such as IP address and soware version.
STEP 8 | (Oponal) Import WildFire appliance conﬁguraons into the Panorama appliance.
1. Select the appliances that have conﬁguraons you want to import from the list of
managed WildFire appliances.
2. Import Conﬁg.
3. Select Yes.
Imporng conﬁguraons updates the displayed informaon and makes the imported
conﬁguraons part of the Panorama appliance candidate conﬁguraon.
4. Commit to Panorama to make the imported WildFire appliance conﬁguraons part of the
Panorama running conﬁguraon.
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STEP 9 | Conﬁgure or conﬁrm the conﬁguraon of the WildFire appliance interfaces.
Each WildFire appliance has four interfaces: Management (Ethernet0), Analysis Network
Environment (Ethernet1), Ethernet2, and Ethernet3.
1. Select Panorama > Managed WildFire Appliances and select a WildFire appliance.
2. Select Interfaces.
3. Select an interface to conﬁgure or edit it. You can enable the interface, set the speed
and duplex, and conﬁgure the IP address and netmask, the default gateway, the MTU,
the DNS server, the link state, and the Management Services for each interface. You can
also Add permied IP addresses so that an interface accepts traﬃc only from speciﬁed
addresses.
The Analysis Network Environment, Ethernet2, and Ethernet3 interfaces support only
Ping as a Management Services opon.
The Management interface supports Ping, SSH, and SNMP as Management Services
opons. In addion, the Management interface supports proxy server conﬁguraon in
case a direct connecon to the internet is not possible.
4. Click OK save your changes.
STEP 10 | Commit the conﬁguraon on the Panorama appliance and push it to the appliance or to
mulple appliances.
1. Commit and Push.
2. If there are conﬁguraons on the Panorama appliance that you do not want to push,
Edit Selecons to choose the appliances to which you want to push conﬁguraons. The
pushed conﬁguraon overwrites the running conﬁguraon on a WildFire appliance.
STEP 11 | Verify the conﬁguraon.
1. Select Panorama > Managed WildFire Appliances.
2. Check the following ﬁelds:
• Connected—The state is Connected.
• Role—The role of each WildFire appliance is Standalone.
• Conﬁg Status—The status is InSync.
• Last Commit State—Commitsucceeded.
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Conﬁgure Basic WildFire Appliance Sengs on
Panorama
Conﬁguring basic sengs such as content update and WildFire cloud servers, WildFire cloud
services, logging, authencaon, and so on, is similar to how you Conﬁgure General Cluster
Sengs on Panorama. Instead of selecng a cluster and conﬁguring sengs on the cluster, select
a WildFire appliance and conﬁgure the individual sengs for that appliance. Select and conﬁgure
each WildFire appliance that you add to Panorama.
Conﬁgure the WildFire Appliance describes how to integrate a WildFire appliance into a network
and perform basic setup with the CLI, but the concepts are the same as performing basic setup
using Panorama.
Many sengs are pre-populated with either defaults, informaon from previously exisng
sengs on the WildFire appliance, or the sengs you conﬁgured when adding the
WildFire appliance to Panorama.
• Conﬁgure Authencaon for a WildFire Appliance

Conﬁgure Authencaon for a WildFire Appliance
Create and conﬁgure enhanced authencaon for your WildFire appliance by conﬁguring local
administrave users with granular authencaon parameters, as well as leveraging RADIUS,
TACAS+, or LDAP for authorizaon and authencaon.
When you Conﬁgure and push administrators from Panorama, you overwrite the exisng
administrators on the WildFire appliance with those you conﬁgure on Panorama.
• Conﬁgure An Administrave Account for a WildFire Appliance
• Conﬁgure RADIUS Authencaon for a WildFire Appliance
• Conﬁgure TACACS+ Authencaon for a WildFire Appliance
• Conﬁgure LDAP Authencaon for a WildFire Appliance

Conﬁgure An Administrave Account for a WildFire Appliance
Create one or more administrators with granular authencaon parameters for your WildFire
appliance to manage from the Panorama™ management server. Addionally, you can conﬁgure
local administrators from Panorama that can be conﬁgured directly on the CLI of the WildFire
appliance. However, pushing new conﬁguraon changes to the WildFire appliance will overwrites
local administrators with the administrators conﬁgured for the WildFire appliance.
STEP 1 | Log in to the Panorama Web Interface.
STEP 2 | Add Standalone WildFire Appliances to Manage with Panorama.
STEP 3 | (Oponal) Conﬁgure an authencaon proﬁle to deﬁne the authencaon service that
validates the login credenals of the administrators who access the WildFire appliance CLI.
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STEP 4 | Conﬁgure one or more administrator accounts as needed.
The administrator accounts created on Panorama are later imported to the WildFire appliance
and managed from Panorama.
You must conﬁgure the administrave account with Superuser admin role privileges to
successfully conﬁgure authencaon for the WildFire appliance.
STEP 5 | Conﬁgure the authencaon for the WildFire appliance.
1. Select Panorama > Managed WildFire Appliance and select the WildFire appliance you
previously added.
2. (Oponal) Select the Authencaon Proﬁle you conﬁgured in the previous step.
3. Conﬁgure the authencaon Timeout Conﬁguraon for the WildFire appliance.
1. Enter the number of Failed Aempts before a user is locked out of the WildFire
appliance CLI.
2. Enter the Lockout Time, in minutes, for which the WildFire appliance locks out a user
account aer that user reaches the conﬁgured number of Failed Aempts.
3. Enter the Idle Timeout, in minutes, before the user account is automacally logged
out due to inacvity.
4. Enter the Max Session Count to set how many user accounts can simultaneously
access the WildFire appliance.
5. Enter the Max Session Time the administrator can be logged in before being
automacally logged out.
4. Add the WildFire appliance administrators.
Administrators may either be added as a local administrator or as an imported Panorama
administrator—but not both. Adding the same administrator as both a local administrator
and as an imported Panorama administrator is not supported and causes the Panorama
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commit to fail. For example, the commit to Panorama fails if you add admin1 as both a
local and Panorama administrator.
1. Add and conﬁgure new administrators unique to the WildFire appliancer. These
administrators are speciﬁc to the WildFire appliance for which they are created and
you manage these administrators from this table.
2. Add any administrators conﬁgured on Panorama. These administrators are created on
Panorama and imported to the WildFire appliance.
5. Click OK to save the WildFire appliance authencaon conﬁguraon.

STEP 6 | Commit and then Commit and Push your conﬁguraon changes.
STEP 7 | Access the WildFire appliance CLI to verify you can successfully access the WildFire
appliance using the local admin user.

Conﬁgure RADIUS Authencaon for a WildFire Appliance
Use a RADIUS server to authencate administrave access to the WildFire appliance CLI. You
can also deﬁne Vendor-Speciﬁc Aributes (VSAs) on the RADIUS server to manage administrator
authorizaon. Using VSAs enables you to quickly change the roles, access domains, and user
groups of administrators through your directory service, which is oen easier than reconﬁguring
sengs on the Panorama™ management server.
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You can Import the Palo Alto Networks RADIUS diconary into RADIUS server to deﬁne
the authencaon aributes needed for communicaon between Panorama and the
RADIUS server.
STEP 1 | Log in to the Panorama Web Interface.
STEP 2 | Add Standalone WildFire Appliances to Manage with Panorama.
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STEP 3 | Conﬁgure RADIUS authencaon.
Administrator accounts conﬁgured for RADIUS authencaon are required to have
Superuser admin role privileges to successfully conﬁgure authencaon for the
Wildﬁre appliance.
1. Add a RADIUS server proﬁle.
The proﬁle deﬁnes how the WildFire appliance connects to the RADIUS server.
1. Select Panorama > Server Proﬁles > RADIUS and Add a proﬁle.
2. Enter a Proﬁle Name to idenfy the server proﬁle.
3. Enter a Timeout interval in seconds aer which an authencaon request mes out
(default is 3; range is 1–20).
4. Select the Authencaon Protocol (default is CHAP) that the WildFire appliance uses
to authencate to the RADIUS server.
Select CHAP if the RADIUS server supports that protocol; it is more secure
than PAP.
5. Add each RADIUS server and enter the following:
1. Name to idenfy the server.
2. RADIUS Server IP address or FQDN.
3. Secret/Conﬁrm Secret (a key to encrypt usernames and passwords).
4. Server Port for authencaon requests (default is 1812).
6. Click OK to save the server proﬁle.
2. Assign the RADIUS server proﬁle to an authencaon proﬁle.
The authencaon proﬁle deﬁnes authencaon sengs that are common to a set of
administrators.
1. Select Panorama > Authencaon Proﬁle and Add a proﬁle.
2. Enter a Name to idenfy the authencaon proﬁle.
3. Set the Type to RADIUS.
4. Select the Server Proﬁle you conﬁgured.
5. Select Retrieve user group from RADIUS to collect user group informaon from VSAs
deﬁned on the RADIUS server.
Panorama matches the group informaon against the groups you specify in the Allow
List of the authencaon proﬁle.
6. Select Advanced and, in the Allow List, Add the administrators that are allowed to
authencate with this authencaon proﬁle.
7. Click OK to save the authencaon proﬁle.
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STEP 4 | Conﬁgure the authencaon for the WildFire appliance.
1. Select Panorama > Managed WildFire Appliance and select the WildFire appliance you
previously added.
2. Select the Authencaon Proﬁle you conﬁgured in the previous step.
If a global authencaon proﬁle is not assigned you must assign an authencaon proﬁle
to each individual local administrator to leverage remote authencaon.
3. Conﬁgure the authencaon Timeout Conﬁguraon for the WildFire appliance.
1. Enter the number of Failed Aempts before a user is locked out of the WildFire
appliance CLI.
2. Enter the Lockout Time, in minutes, for which the WildFire appliance locks out a user
account aer that user reaches the conﬁgured number of Failed Aempts.
3. Enter the Idle Timeout, in minutes, before the user account is automacally logged
out due to inacvity.
4. Enter the Max Session Count to set how many user accounts can simultaneously
access the WildFire appliance.
5. Enter the Max Session Time the administrator can be logged in before being
automacally logged out.
4. Add the WildFire appliance administrators.
Administrators may either be added as a local administrator or as an imported Panorama
administrator—but not both. Adding the same administrator as both a local administrator
and as an imported Panorama administrator is not supported and causes the Panorama
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commit to fail. For example, the commit to Panorama fails if you add admin1 as both a
local and Panorama administrator.
1. Add and conﬁgure new administrators unique to the WildFire appliance. These
administrators are speciﬁc to the WildFire appliance for which they are created and
you manage these administrators from this table.
2. Add any administrators conﬁgured on Panorama. These administrators are created on
Panorama and imported to the WildFire appliance.
5. Click OK to save the WildFire appliance authencaon conﬁguraon.

STEP 5 | Commit and then Commit and Push your conﬁguraon changes.
STEP 6 | Access the WildFire appliance CLI to verify you can successfully access the WildFire
appliance using the local admin user.

Conﬁgure TACACS+ Authencaon for a WildFire Appliance
You can use a TACACS+ server to authencate administrave access to the WildFire appliance
CLI. You can also deﬁne Vendor-Speciﬁc Aributes (VSAs) on the TACACS+ server to manage
administrator authorizaon. Using VSAs enables you to quickly change the roles, access domains,
and user groups of administrators through your directory service, which is oen easier than
reconﬁguring sengs on Panorama.
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STEP 1 | Log in to the Panorama Web Interface.
STEP 2 | Add Standalone WildFire Appliances to Manage with Panorama.
STEP 3 | Conﬁgure TACACS+ authencaon.
Administrator accounts conﬁgured for TACACS+ authencaon are required to have
Superuser admin role privileges to successfully conﬁgure authencaon for the
Wildﬁre appliance.
1. Add a TACACS+ server proﬁle.
The proﬁle deﬁnes how the WildFire appliance connects to the TACACS+ server.
1. Select Panorama > Server Proﬁles > TACACS+ and Add a proﬁle.
2. Enter a Proﬁle Name to idenfy the server proﬁle.
3. Enter a Timeout interval in seconds aer which an authencaon request mes out
(default is 3; range is 1–20).
4. Select the Authencaon Protocol (default is CHAP) that Panorama uses to
authencate to the TACACS+ server.
5. Select CHAP if the TACACS+ server supports that protocol; it is more secure than
PAP.
6. Add each TACACS+ server and enter the following:
1. Name to idenfy the server.
2. TACACS+ Server IP address or FQDN.
3. Secret/Conﬁrm Secret (a key to encrypt usernames and passwords).
4. Server Port for authencaon requests (default is 49).
7. Click OK to save the server proﬁle.
2. Assign the TACACS+ server proﬁle to an authencaon proﬁle.
The authencaon proﬁle deﬁnes authencaon sengs that are common to a set of
administrators.
1. Select Panorama > Authencaon Proﬁle and Add a proﬁle.
2. Enter a Name to idenfy the proﬁle.
3. Set the Type to TACACS+.
4. Select the Server Proﬁle you conﬁgured.
5. Select Retrieve user group from TACACS+ to collect user group informaon from
VSAs deﬁned on the TACACS+ server.
Panorama matches the group informaon against the groups you specify in the Allow
List of the authencaon proﬁle.
6. Select Advanced and, in the Allow List, Add the administrators that are allowed to
authencate with this authencaon proﬁle.
7. Click OK to save the authencaon proﬁle.
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STEP 4 | Conﬁgure the authencaon for the WildFire appliance.
1. Select Panorama > Managed WildFire Appliance and select the WildFire appliance you
previously added.
2. Select the Authencaon Proﬁle you conﬁgured in the previous step.
If a global authencaon proﬁle is not assigned you must assign an authencaon proﬁle
to each individual local administrator to leverage remote authencaon.
3. Conﬁgure the authencaon Timeout Conﬁguraon for the WildFire appliance.
1. Enter the number of Failed Aempts before a user is locked out of the WildFire
appliance CLI.
2. Enter the Lockout Time, in minutes, for which the WildFire appliance locks out a user
account aer that user reaches the conﬁgured number of Failed Aempts.
3. Enter the Idle Timeout, in minutes, before the user account is automacally logged
out due to inacvity.
4. Enter the Max Session Count to set how many user accounts can simultaneously
access the WildFire appliance.
5. Enter the Max Session Time the administrator can be logged in before being
automacally logged out.
4. Add the WildFire appliance administrators.
Administrators may either be added as a local administrator or as an imported Panorama
administrator—but not both. Adding the same administrator as both a local administrator
and as an imported Panorama administrator is not supported and causes the Panorama
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commit to fail. For example, the commit to Panorama fails if you add admin1 as both a
local and Panorama administrator.
1. Add and conﬁgure new administrators unique to the WildFire appliancer. These
administrators are speciﬁc to the WildFire appliance for which they are created and
you manage these administrators from this table.
2. Add any administrators conﬁgured on Panorama. These administrators are created on
Panorama and imported to the WildFire appliance.
5. Click OK to save the WildFire appliance authencaon conﬁguraon.

STEP 5 | Commit and then Commit and Push your conﬁguraon changes.
STEP 6 | Access the WildFire appliance CLI to verify you can successfully access the WildFire
appliance using the local admin user.

Conﬁgure LDAP Authencaon for a WildFire Appliance
You can use LDAP to authencate end users who access the WildFire appliance CLI.
STEP 1 | Log in to the Panorama Web Interface.
STEP 2 | Add Standalone WildFire Appliances to Manage with Panorama.
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STEP 3 | Add an LDAP server proﬁle.
The proﬁle deﬁnes how the WildFire appliance connects to the LDAP server.
Administrator accounts conﬁgured for LDAP authencaon are required to have
Superuser admin role privileges to successfully conﬁgure authencaon for the
WildFire appliance.
1. Select Panorama > Server Proﬁles > LDAP and Add a server proﬁle.
2. Enter a Proﬁle Name to idenfy the server proﬁle.
3. Add the LDAP servers (up to four). For each server, enter a Name (to idenfy the server),
LDAP Server IP address or FQDN, and server Port (default 389).
If you use an FQDN address object to idenfy the server and you subsequently
change the address, you must commit the change for the new server address to
take eﬀect.
4. Select the server Type.
5. Select the Base DN.
To idenfy the Base DN of your directory, open the Acve Directory Domains and
Trusts Microso Management Console snap-in and use the name of the top-level
domain.
6. Enter the Bind DN and Password to enable the authencaon service to authencate
the ﬁrewall.
The Bind DN account must have permission to read the LDAP directory.
7. Enter the Bind Timeout and Search Timeout in seconds (default is 30 for both).
8. Enter the Retry Interval in seconds (default is 60).
9. (Oponal) If you want the endpoint to use SSL or TLS for a more secure connecon with
the directory server, enable the opon to Require SSL/TLS secured connecon (enabled
by default). The protocol that the endpoint uses depends on the server port:
• 389 (default)—TLS (Speciﬁcally, the WildFire appliance uses the StartTLS operaon,
which upgrades the inial plaintext connecon to TLS.)
• 636—SSL
• Any other port—The WildFire appliance ﬁrst aempts to use TLS. If the directory
server doesn’t support TLS, the WildFire appliance falls back to SSL.
10. (Oponal) For addional security, enable to the opon to Verify Server Cerﬁcate
for SSL sessions so that the endpoint veriﬁes the cerﬁcate that the directory server
presents for SSL/TLS connecons. To enable veriﬁcaon, you must also enable the

Panorama Administrator's Guide Version Version 10.1

475

©2022 Palo Alto Networks, Inc.

Manage WildFire Appliances
opon to Require SSL/TLS secured connecon. For veriﬁcaon to succeed, the
cerﬁcate must meet one of the following condions:
• It is in the list of Panorama cerﬁcates: Panorama > Cerﬁcate Management >
Cerﬁcates > Device Cerﬁcates. If necessary, import the cerﬁcate into Panorama.
• The cerﬁcate signer is in the list of trusted cerﬁcate authories: Panorama >
Cerﬁcate Management > Cerﬁcates.
11. Click OK to save the server proﬁle.
STEP 4 | Conﬁgure the authencaon for the WildFire appliance.
1. Select Panorama > Managed WildFire Appliance and select the WildFire appliance you
previously added.
2. Conﬁgure the authencaon Timeout Conﬁguraon for the WildFire appliance.
1. Enter the number of Failed Aempts before a user is locked out of the WildFire
appliance CLI.
2. Enter the Lockout Time, in minutes, for which the WildFire appliance locks out a user
account aer that user reaches the conﬁgured number of Failed Aempts.
3. Enter the Idle Timeout, in minutes, before the user account is automacally logged
out due to inacvity.
4. Enter the Max Session Count to set how many user accounts can simultaneously
access the WildFire appliance.
5. Enter the Max Session Time the administrator can be logged in before being
automacally logged out.
3. Add the WildFire appliance administrators.
Administrators may either be added as a local administrator or as an imported Panorama
administrator—but not both. Adding the same administrator as both a local administrator
and as an imported Panorama administrator is not supported and causes the Panorama
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commit to fail. For example, the commit to Panorama fails if you add admin1 as both a
local and Panorama administrator.
• Conﬁgure the local administrators.
Conﬁgure new administrators unique to the WildFire appliances. These administrators
are speciﬁc to the WildFire appliance for which they are created and you manage
these administrators from this table.
1. Add one or more new local administrator.
2. Enter a Name for the local administrator.
3. Assign an Authencaon Proﬁle you previously created.
LDAP authencaon proﬁles are supported only for individual local
administrators.
4. Enable (check) Use Public Key Authencaon (SSH) to import a public key ﬁle for
authencaon.
5. Select a Password Proﬁle to set the expiraon parameters.
• Import exisng Panorama administrators
Import exisng administrators conﬁgured on Panorama. These administrators are
conﬁgured and managed on Panorama and imported to WildFire appliance.
1. Add an exisng Panorama administrator
4. Click OK to save the WildFire appliance authencaon conﬁguraon.
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STEP 5 | Commit and then Commit and Push your conﬁguraon changes.
STEP 6 | Access the WildFire appliance CLI to verify you can successfully access the WildFire
appliance using the local admin user.
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Set Up Authencaon Using Custom Cerﬁcates on
WildFire Appliances and Clusters
By default, a WildFire® appliance uses predeﬁned cerﬁcates for mutual authencaon with
other Palo Alto Networks® ﬁrewalls and appliances to establish the SSL connecons used for
management access and inter-device communicaon. However, you can conﬁgure authencaon
using custom cerﬁcates instead. Custom cerﬁcates allow you to establish a unique chain
of trust to ensure mutual authencaon betweenyour WildFire appliance or WildFire cluster
managed by Panorama™ and ﬁrewalls. You can generate these cerﬁcates locally on Panorama or
the ﬁrewall, obtain them from a trusted third-party cerﬁcate authority (CA), or obtain cerﬁcates
from enterprise private key infrastructure (PKI).
For more informaon about using custom cerﬁcates, see How Are SSL/TLS Connecons
Mutually Authencated?
• Conﬁgure a Custom Cerﬁcate for a Panorama Managed WildFire Appliance
• Conﬁgure Authencaon with a Single Custom Cerﬁcate for a WildFire Cluster
• Apply Custom Cerﬁcates on a WildFire Appliance Conﬁgured through Panorama

Conﬁgure a Custom Cerﬁcate for a Panorama Managed WildFire
Appliance
If you use Panorama™ to manage your WildFire® appliance or WildFire cluster, you can conﬁgure
custom cerﬁcate authencaon through the Panorama web interface instead of using WildFire
appliance CLI. The ﬁrewall or Panorama uses this connecon to forward samples to WildFire for
analysis.
This procedure describes how to install a unique cerﬁcate on a single WildFire appliance. If the
WildFire appliance is part of a cluster, that device and each cluster member has a unique client
cerﬁcate. To deploy a single cerﬁcate to all WildFire appliances in the cluster, see Conﬁgure
Authencaon with a Single Custom Cerﬁcate for a WildFire Cluster.
STEP 1 | Obtain key pairs and cerﬁcate authority (CA) cerﬁcates for the WildFire appliance and the
ﬁrewall.
STEP 2 | Import the CA cerﬁcate to validate the identy of the ﬁrewall and the key pair for the
WildFire appliance.
1. Select Panorama > Cerﬁcate Management > Cerﬁcates > Import.
2. Import the CA cerﬁcate and the key pair on Panorama.
STEP 3 | Conﬁgure a cerﬁcate proﬁle that includes the root CA and intermediate CA. This cerﬁcate
proﬁle deﬁnes how the WildFire appliance and the ﬁrewalls authencate mutually.
1. Select Panorama > Cerﬁcate Management > Cerﬁcate Proﬁle.
2. Conﬁgure a cerﬁcate proﬁle.
If you conﬁgure an intermediate CA as part of the cerﬁcate proﬁle, you must also
include the root CA.
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STEP 4 | Conﬁgure an SSL/TLS proﬁle for the WildFire appliance.
PAN-OS 8.0 and later releases support only TLS 1.2 and higher so ou must set the max
version to TLS 1.2 or max.
1. Select Panorama > Cerﬁcate Management > SSL/TLS Service Proﬁle.
2. Conﬁgure an SSL/TLS service proﬁle to deﬁne the cerﬁcate and protocol that the
WildFire appliance and its the ﬁrewalls use for SSL/TLS services.
STEP 5 | Conﬁgure Secure Server Communicaon on WildFire.
1. Select Panorama > Managed WildFire Clusters or Panorama > Managed WildFire
Appliances and select a cluster or appliance.
2. Select Communicaon.
3. Enable the Customize Secure Server Communicaon feature.
4. Select the SSL/TLS Service Proﬁle. This SSL/TLS service proﬁle applies to all SSL
connecon between the WildFire appliance and the ﬁrewall or Panorama.
5. Select the Cerﬁcate Proﬁle you conﬁgured for communicaon between the WildFire
appliance and the ﬁrewall or Panorama.
6. Verify that Custom Cerﬁcates Only is disabled (cleared). This allows the WildFire
appliance to connue communicang with the ﬁrewalls with the predeﬁned cerﬁcate
while migrang to custom cerﬁcates.
7. (Oponal) Conﬁgure an authorizaon list.
1. Add an Authorizaon List.
2. Select the Subject or Subject Alt Name conﬁgured in the cerﬁcate proﬁle as the
Idenﬁer type.
3. Enter the Common Name if the idenﬁer is Subject or enter an IP address, hostname,
or email if the idenﬁer is Subject Alt Name.
4. Click OK.
5. Enable Check Authorizaon List to enforce the list.
8. Click OK.
9. Commit your changes.
STEP 6 | Import the CA cerﬁcate to validate the cerﬁcate for the WildFire appliance.
1. Log in to the ﬁrewall web interface.
2. Import the CA cerﬁcate.
STEP 7 | Conﬁgure a local or SCEP cerﬁcate for the ﬁrewall.
• If you are using a local cerﬁcate, import the key pair for the ﬁrewall.
• If you are using SCEP for the ﬁrewall cerﬁcate, conﬁgure a SCEP proﬁle.
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STEP 8 | Conﬁgure the cerﬁcate proﬁle for the ﬁrewall or Panorama. You can conﬁgure this proﬁle on
each client ﬁrewall or Panorama appliance individually or you can use a template to push the
conﬁguraon from Panorama to managed ﬁrewalls.
1. Select Device > Cerﬁcate Management > Cerﬁcate Proﬁle for ﬁrewalls or Panorama >
Cerﬁcate Management > Cerﬁcate Proﬁle for Panorama.
2. Conﬁgure a Cerﬁcate Proﬁle.
STEP 9 | Deploy custom cerﬁcates on each ﬁrewall or Panorama appliance.
1. Log in to the ﬁrewall web interface.
2. Select Device > Setup > Management for a ﬁrewall or Panorama > Setup > Management
for Panorama and Edit the Secure Communicaon Sengs.
3. Select the Cerﬁcate Type, Cerﬁcate, and Cerﬁcate Proﬁle.
4. In the Customize Communicaon sengs, select WildFire Communicaon.
5. Click OK.
6. Commit your changes.
STEP 10 | Aer deploying custom cerﬁcates on all managed devices, enforce custom-cerﬁcate
authencaon.
1. Log in to Panorama.
2. Select Panorama > Managed WildFire Clusters or Panorama > Managed WildFire
Appliances and select a cluster or appliance.
3. Select Communicaon.
4. Select Custom Cerﬁcate Only.
5. Click OK.
6. Commit your changes.
Aer comming this change, WildFire immediately begins the enforcement of custom
cerﬁcates.

Conﬁgure Authencaon with a Single Custom Cerﬁcate for a
WildFire Cluster
Instead of assigning unique cerﬁcates to each WildFire® appliance in a cluster, you can assign
a single, shared client cerﬁcate to the enre WildFire cluster, which, in turn, allows you to
push a single cerﬁcate to all WildFire appliances in the cluster instead of conﬁguring separate
cerﬁcates for each cluster member. Because the individual WildFire appliances share a client
cerﬁcate, you must conﬁgure a unique hostname (DNS name) for each WildFire appliance.
Then you can add all the hostnames as cerﬁcate aributes to the shared cerﬁcate or use a
one-wildcard string that matches all the custom hostnames on all the WildFire appliances in the
cluster.
To conﬁgure a single custom cerﬁcate for your WildFire cluster to use when communicang with
the Panorama™, complete the following procedure.
STEP 1 | Obtain a server key pair and CA cerﬁcate for Panorama.
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STEP 2 | Conﬁgure a cerﬁcate proﬁle that includes the root cerﬁcate authority (CA) and the
intermediate CA. This cerﬁcate proﬁle deﬁnes the authencaon between the WildFire
cluster (client) and the Panorama appliance (server).
1. Select Panorama > Cerﬁcate Management > Cerﬁcate Proﬁle.
2. Conﬁgure a cerﬁcate proﬁle.
If you conﬁgure an intermediate CA as part of the cerﬁcate proﬁle, you must also
include the root CA.
STEP 3 | Conﬁgure an SSL/TLS service proﬁle.
1. Select Panorama > Cerﬁcate Management > SSL/TLS Service Proﬁle.
2. Conﬁgure an SSL/TLS service proﬁle to deﬁne the cerﬁcate and protocol that the
WildFire cluster and Panorama appliance use for SSL/TLS services.
STEP 4 | Connect each node in the cluster to Panorama.
STEP 5 | Conﬁgure a unique hostname (DNS name) on each node in the cluster or use a string with
a single wildcard that matches all custom DNS names set on the WildFire appliances in the
cluster.
If using a single-wildcard string, see RFC-6125,Secon 6.4.3 for requirements and limitaons
of wildcard string values. Make sure you understand these requirements and limitaons when
conﬁguring your custom DNS names.
1. Log in to the WildFire CLI on a node.
2. Use the following command to assign a unique custom DNS name to the node.
admin@WF-500> configure
admin@WF-500# set deviceconfig setting wildfire custom-dnsname <dns-name>
3. Commit your change.
4. Repeat this process for each node in the cluster.
STEP 6 | On Panorama, generate a client cerﬁcate for all nodes in the cluster. Under Cerﬁcate
Aributes, add a hostname entry for each custom DNS name you assigned to the cluster
nodes or add one hostname entry with a one-wildcard string that matches all of the node
hostnames, such as *.example.com; you can do this only if each custom DNS name shares a
common string.
STEP 7 | On Panorama, conﬁgure the cerﬁcate proﬁle for the cluster client cerﬁcate.
1. Select Panorama > Cerﬁcate Management > Cerﬁcate Proﬁle for Panorama.
2. Conﬁgure a Cerﬁcate Proﬁle.
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STEP 8 | Deploy custom cerﬁcates on each node. This cerﬁcate proﬁle must contain the CA
cerﬁcate that signed the Panorama server cerﬁcate.
1. Select Panorama > Managed WildFire Clusters and click on the cluster name.
2. Select Communicaons.
3. Under Secure Client Communicaons, select the Cerﬁcate Type, Cerﬁcate, and
Cerﬁcate Proﬁle.
4. Click OK.
5. Commit your changes.
STEP 9 | Conﬁgure secure server communicaon on Panorama.
1. Select Panorama > Setup > Management and Edit to select Customize Secure Server
Communicaon.
2. Enable Customize Secure Server Communicaon.
3. Select the SSL/TLS Service Proﬁle. This SSL/TLS service proﬁle applies to all SSL
connecon between WildFire and Panorama.
4. Select the Cerﬁcate Proﬁle for Panorama.
5. Enable Custom Cerﬁcates Only.
6. Click OK.
7. Commit your changes.

Apply Custom Cerﬁcates on a WildFire Appliance Conﬁgured
through Panorama
By default, Panorama™ uses a predeﬁned cerﬁcate when communicang with a WildFire®
appliance to push conﬁguraons. You can alternavely conﬁgure custom cerﬁcates to establish
mutual authencaon for the connecon Panorama uses to push conﬁguraons to a managed
WildFire appliance or cluster. Complete the following procedure to conﬁgure the server cerﬁcate
on Panorama and the client cerﬁcate on the WildFire appliance.
STEP 1 | Obtain key pairs and cerﬁcate authority (CA) cerﬁcates for Panorama and the WildFire
appliance.
STEP 2 | Import the CA cerﬁcate to validate the idenfy of the WildFire appliance and the key pair
for Panorama.
1. Select Panorama > Cerﬁcate Management > Cerﬁcates > Import.
2. Import the CA cerﬁcate and the key pair on Panorama.
STEP 3 | Conﬁgure a cerﬁcate proﬁle that includes the root CA and intermediate CA. This cerﬁcate
proﬁle deﬁnes the authencaon between the WildFire appliance (client) and the Panorama
virtual or M-Series appliance (server).
1. Select Panorama > Cerﬁcate Management > Cerﬁcate Proﬁle.
2. Conﬁgure a cerﬁcate proﬁle.
If you conﬁgure an intermediate CA as part of the cerﬁcate proﬁle, you must also
include the root CA.
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STEP 4 | Conﬁgure an SSL/TLS service proﬁle.
1. Select Panorama > Cerﬁcate Management > SSL/TLS Service Proﬁle.
2. Conﬁgure an SSL/TLS service proﬁle to deﬁne the cerﬁcate and protocol that the
WildFire and Panorama appliances use for SSL/TLS services.
STEP 5 | Conﬁgure secure server communicaon on the Panorama appliance.
1. Select Panorama > Setup > Management and Edit to select Customize Secure Server
Communicaon.
2. Enable the Customize Secure Server Communicaon feature.
3. Select the SSL/TLS Service Proﬁle.
4. Select the cerﬁcate proﬁle from the Cerﬁcate Proﬁle drop-down.
5. Verify that Custom Cerﬁcates Only is disabled (cleared). This allows Panorama to
connue communicang with WildFire with the predeﬁned cerﬁcate while migrang to
custom cerﬁcates.
6. (Oponal) Conﬁgure an authorizaon list.
1. Add an Authorizaon List.
2. Select the Subject or Subject Alt Name conﬁgured in the cerﬁcate proﬁle as the
Idenﬁer type.
3. Enter the Common Name if the idenﬁer is Subject or an IP address, hostname, or
email if the idenﬁer is Subject Alt Name.
4. Click OK.
5. Enable the Check Authorizaon List opon to conﬁgure Panorama to enforce the
authorizaon list.
7. Click OK.
8. Commit your changes.
STEP 6 | Import the CA cerﬁcate to validate the cerﬁcate on Panorama.
1. Log in to the Panorama user interface.
2. Import the CA cerﬁcate.
STEP 7 | Conﬁgure a local or a SCEP cerﬁcate for the WildFire appliance.
1. If you are using a local cerﬁcate, import the key pair for the WF-500 appliance.
2. If you are using SCEP for the WildFire appliance cerﬁcate, conﬁgure a SCEP proﬁle.
STEP 8 | Conﬁgure the cerﬁcate proﬁle for the WildFire appliance.
1. Select Panorama > Cerﬁcate Management > Cerﬁcate Proﬁle.
2. Conﬁgure a cerﬁcate proﬁle.
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STEP 9 | Deploy custom cerﬁcates on each managed WildFire appliance.
1. Log in to Panorama.
2. Select Panorama > Managed WildFire Appliances and click on a cluster or appliance
name.
3. Select Communicaons.
4. Under Secure Client Communicaons, select the Cerﬁcate Type, Cerﬁcate, and
Cerﬁcate Proﬁle from the respecve drop-downs.
5. Click OK.
6. Commit your changes.
STEP 10 | Aer deploying custom cerﬁcates on all managed WildFire appliances, enforce customcerﬁcate authencaon.
1. Select Panorama > Setup > Management and Edit the Secure Communicaons Sengs.
2. Allow Custom Cerﬁcate Only.
3. Click OK.
4. Commit your changes.
Aer comming this change, the disconnect wait me begins counng down. When the
wait me ends, Panorama and its managed WildFire appliances cannot connect without the
conﬁgured cerﬁcates.
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Remove a WildFire Appliance from Panorama
Management
You can remove WildFire standalone appliances from Panorama management. When you remove
a standalone WildFire appliance from Panorama management, you no longer enjoy the beneﬁts of
centralized management and must manage the appliance using its local CLI and scripts.
STEP 1 | Select Panorama > Managed WildFire Appliances.
STEP 2 | Select the WildFire appliance or appliances you want to remove from Panorama management
by selecng the checkbox next to each appliance or by clicking in an appliance’s row.
STEP 3 | Remove the selected WildFire appliances from Panorama management.
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Manage WildFire Clusters
A WildFire appliance cluster is an interconnected group of WildFire appliances that pool resources
to increase sample analysis and storage capacity, support larger groups of ﬁrewalls and simplify
conﬁguraon and management of mulple WildFire appliances. For enhanced security and to
maintain conﬁdenality of transmied content, you can also encrypt communicaons between
WildFire appliances in a cluster. For more informaon about WildFire clusters and deployment
processes, refer to WildFire Appliance Clusters.
The following tasks can be performed using Panorama to manage your WildFire cluster.
• Conﬁgure a Cluster Centrally on Panorama
• View WildFire Cluster Status Using Panorama
• Conﬁgure Appliance-to-Appliance Encrypon Using Predeﬁned Cerﬁcates Centrally on
Panorama
• Conﬁgure Appliance-to-Appliance Encrypon Using Custom Cerﬁcates Centrally on Panorama

Conﬁgure a Cluster Centrally on Panorama
Before you conﬁgure a WildFire appliance cluster on a Panorama M-Series or virtual appliance,
have two WildFire appliances available to conﬁgure as a high availability controller node pair and
any addional WildFire appliances needed to serve as worker nodes to increase the analysis,
storage capacity, and resiliency of the cluster.
If the WildFire appliances are new, check Get Started with WildFire to ensure that you complete
basic steps such as conﬁrming your WildFire license is acve, enabling logging, connecng
ﬁrewalls to WildFire appliances, and conﬁguring basic WildFire features.
To create WildFire appliance clusters, you must upgrade all of the WildFire appliances
that you want to place in a cluster to PAN-OS 8.0.1 or later. If you use Panorama to
manage WildFire appliance clusters, Panorama also must run PAN-OS 8.0.1 or later. On
each WildFire appliance that you want to add to a cluster, run show system info |
match version on the WildFire appliance CLI to ensure that the appliance is running
PAN-OS 8.0.1 or later. On each Panorama appliance you use to manage clusters (or
standalone appliances), Dashboard > General Informaon > Soware Version displays
the running soware version.
When your WildFire appliances are available, perform the appropriate tasks:
• Conﬁgure a Cluster and Add Nodes on Panorama
• Conﬁgure General Cluster Sengs on Panorama
• Conﬁgure Authencaon for a WildFire Cluster
• Remove a Cluster from Panorama Management
Removing a node from a cluster using Panorama is not supported. Instead, Remove a
Node from a Cluster Locally using the local WildFire CLI.
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Conﬁgure a Cluster and Add Nodes on Panorama
Before conﬁguring a WildFire appliance cluster from Panorama, you must upgrade Panorama to
8.0.1 or later and upgrade all WildFire appliances you plan to add to the cluster to 8.0.1 or later.
All WildFire appliances must run the same version of PAN-OS.
You can manage up to 200 WildFire appliances with a Panorama M-Series or virtual appliance. The
200 WildFire appliance limit is the combined total of standalone appliances and WildFire appliance
cluster nodes (if you also Add Standalone WildFire Appliances to Manage with Panorama). Except
where noted, conﬁguraon takes place on Panorama.
Each WildFire appliance cluster node must have a stac IP address in the same subnet and
have low-latency connecons.
STEP 1 | Using the local CLI, conﬁgure the IP address of the Panorama server that will manage the
WildFire appliance cluster.
Before you register cluster or standalone WildFire appliances to a Panorama appliance, you
must ﬁrst conﬁgure the Panorama IP address or FQDN on each WildFire appliance using the
local WildFire CLI. This is how each WildFire appliance knows which Panorama appliance
manages it.
1. On each WildFire appliance, conﬁgure the IP address or FQDN of the primary Panorama
appliance’s management interface:
admin@WF-500# set deviceconfig system panorama-server <ipaddress | FQDN>
2. On each WildFire appliance, if you use a backup Panorama appliance for high availability
(recommended), conﬁgure the IP address or FQDN of the backup Panorama appliance’s
management interface:
admin@WF-500# set deviceconfig system panorama-server-2 <ipaddress | FQDN>
3. Commit the conﬁguraon on each WildFire appliance:
admin@WF-500# commit
STEP 2 | On the primary Panorama appliance, Register the WildFire appliances.
The newly registered appliances are in standalone mode unless they already belong to a cluster
due to local cluster conﬁguraon.
1. Select Panorama > Managed WildFire Appliances and Add Appliance.
2. Enter the serial number of each WildFire appliance on a separate line. If you do not have
a list of WildFire appliance serial numbers, using the local CLI, run show system info
on each WildFire appliance to obtain the serial number.
3. Click OK.
If it is available, informaon about conﬁguraon that is already commied on the
WildFire appliances displays, such as IP address and soware version. WildFire
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appliances that already belong to a cluster (for example, because of local cluster
conﬁguraon) display their cluster informaon and connecon status.
STEP 3 | (Oponal) Import WildFire appliance conﬁguraons into the Panorama appliance.
Imporng conﬁguraons saves me because you can reuse or edit the conﬁguraons on
Panorama and then push them to one or more WildFire appliance clusters or standalone
WildFire appliances. If there are no conﬁguraons you want to import, skip this step. When
you push a conﬁguraon from Panorama, the pushed conﬁguraon overwrites the local
conﬁguraon.
1. Select Panorama > Managed WildFire Appliances, and select the appliances that have
conﬁguraons you want to import from the list of managed WildFire appliances.
2. Import Conﬁg.
3. Select Yes.
Imporng conﬁguraons updates the displayed informaon and makes the imported
conﬁguraons part of the Panorama appliance candidate conﬁguraon.
4. Commit to Panorama to make the imported WildFire appliance conﬁguraons part of the
Panorama running conﬁguraon.
STEP 4 | Create a new WildFire appliance cluster.
1. Select Managed WildFire Clusters.
Appliance > No Cluster Assigned displays standalone WildFire appliances (nodes) and
indicates how many available nodes are not assigned to a cluster.
2. Create Cluster.
3. Enter an alphanumeric cluster Name of up to 63 characters in length. The Name can
contain lower-case characters and numbers, and hyphens and periods if they are not the
ﬁrst or last character. No spaces or other characters are allowed.
4. Click OK.
The new cluster name displays but has no assigned WildFire nodes.
STEP 5 | Add WildFire appliances to the new cluster.
The ﬁrst WildFire appliance added to the cluster automacally becomes the controller node,
and the second WildFire appliance added to the cluster automacally becomes the controller
backup node. All subsequent WildFire appliances added to the cluster become worker
nodes. Worker nodes use the controller node sengs so that the cluster has a consistent
conﬁguraon.
1. Select the new cluster.
2. Select Clustering.
3. Browse the list of WildFire appliances that do not belong to clusters.
4. Add (
) each WildFire appliance you want to include in the cluster. You can add up
to twenty nodes to a cluster. Each WildFire appliance that you add to the cluster is
displayed along with its automacally assigned role.
5. Click OK.
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STEP 6 | Conﬁgure the Management, Analysis Environment Network, HA, and cluster management
interfaces.
Conﬁgure the Management, Analysis Environment Network, and cluster management
interfaces on each cluster member (controller and worker nodes) if they are not already
conﬁgured. The cluster management interface is a dedicated interface for management and
communicaon within the cluster and is not the same as the Management interface.
Conﬁgure the HA interfaces individually on both the controller node and the controller backup
node. The HA interfaces connect the primary and backup controller nodes and enable them to
remain in sync and ready to respond to a failover.
Cluster nodes need IP addresses for each of the four WildFire appliance interfaces. You
cannot conﬁgure HA services on worker nodes.
1. Select the new cluster.
2. Select Clustering.
3. If the management interface is not conﬁgured on a cluster node, select Interface Name >
Management and enter the IP address, netmask, services, and other informaon for the
interface.
4. If the interface for the Analysis Environment Network is not conﬁgured on a cluster
node, select Interface Name > Analysis Environment Network and enter the IP address,
netmask, services, and other informaon for the interface.
5. On both the controller node and controller backup node, select the interface to use for
the HA control link. You must conﬁgure the same interface on both controller nodes for
the HA service. For example, on the controller node and then on the controller backup
node, select Ethernet3.
6. For each controller node, select Clustering Services > HA. (The HA opon is not available
for worker nodes.) If you also want the ability to ping the interface, select Management
Services > Ping.
7. Click OK.
8. (Recommended) Select the interface to use as the backup HA control link between the
controller node and the controller backup node. You must use the same interface on both
nodes for the HA backup service. For example, on both nodes, select Management.
Select Clustering Services > HA Backup for both nodes. You can also select Ping, SSH,
and SNMP if you want those Management Services on the interface.
The Analysis Environment Network interface cannot be an HA or HA Backup
interface or a cluster management interface.
9. Select the dedicated interface to use for management and communicaon within the
cluster. You must use the same interface on both nodes, for example, Ethernet2.
10. Select Clustering Services > Cluster Management for both nodes. If you also want the
ability to ping on the interface, select Management Services > Ping.
Worker nodes in the cluster automacally inherit the controller node’s sengs
for the dedicated management and communicaon interface.
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STEP 7 | Commit the conﬁguraon on the Panorama appliance and push it to the cluster.
1. Commit and Push.
2. If there are conﬁguraons on the Panorama appliance that you do not want to push,
Edit Selecons to choose the appliances to which you push conﬁguraons. The pushed
conﬁguraon overwrites the running conﬁguraon on the cluster nodes so that all
cluster nodes run the same conﬁguraon.
STEP 8 | Verify the conﬁguraon.
1. Select Panorama > Managed WildFire Clusters.
2. Check the following ﬁelds:
• Appliance—Instead of displaying as standalone appliances, the WildFire nodes added
to the cluster display under the cluster name.
• Cluster Name—The cluster name displays for each node.
• Role—The appropriate role (Controller, Controller Backup, or Worker) displays for
each node.
• Conﬁg Status—Status is InSync.
• Last Commit State—Commitsucceeded.
STEP 9 | Using the local CLI on the primary controller node (not the Panorama web interface), check
to ensure that the conﬁguraons are synchronized.
If they are not synchronized, manually synchronize the high availability conﬁguraons on the
controller nodes and commit the conﬁguraon.
Even though you can perform most other conﬁguraon on Panorama, synchronizing the
controller node high availability conﬁguraons must be done on the primary controller node’s
CLI.
1. On the primary controller node, check to ensure that the conﬁguraons are
synchronized:
admin@WF-500(active-controller)> show high-availability all
At the end of the output, look for the ConfigurationSynchronization output:
Configuration Synchronization:
Enabled: yes
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Running Configuration: synchronized
If the running conﬁguraon is synchronized, you do not need to manually synchronize
the conﬁguraon. However, if the conﬁguraon is not synchronized, you need to
synchronize the conﬁguraon manually.
2. If the conﬁguraon is not synchronized, on the primary controller node, synchronize the
high availability conﬁguraon to the remote peer controller node:
admin@WF-500(active-controller)> request high-availability
sync-to-remote running-config
If there is a mismatch between the primary controller node’s conﬁguraon and the
conﬁguraon on the controller backup node, the conﬁguraon on the primary controller
node overrides the conﬁguraon on the controller backup node.
3. Commit the conﬁguraon:
admin@WF-500# commit

Conﬁgure General Cluster Sengs on Panorama
Some general sengs are oponal and some general sengs are pre-populated with default
values. It’s best to at least check these sengs to ensure that the cluster conﬁguraon matches
your needs. General sengs include:
• Connecng to the WildFire public cloud and subming samples to the public cloud.
• Conﬁguring data retenon policies.
• Conﬁguring logging.
• Seng the analysis environment (the VM image that best matches your environment) and
customizing the analysis environment to best service the types of samples the ﬁrewalls submit
to WildFire.
• Set IP addresses for the DNS server, NTP server, and more.
STEP 1 | Conﬁgure sengs for the WildFire appliance cluster nodes.
Many sengs are pre-populated with either defaults, informaon from previously exisng
sengs on the controller node, or the sengs you just conﬁgured.
1. Select the cluster.
2. Select Appliance.
3. Enter new informaon, keep the pre-populated informaon from the cluster controller
node, or edit the pre-populated informaon, including:
• Domain name.
• IP address of the Primary DNS Server and the Secondary DNS Server.
• NTP Server Address and Authencaon Type of the Primary NTP Server and the
Secondary NTP Server. The Authencaon Type opons are None, Symmetric Key,
and AutoKey.
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STEP 2 | Conﬁgure general cluster sengs.
Many sengs are pre-populated with either defaults, informaon from previously exisng
sengs on the controller node, or the sengs you just conﬁgured.
1. Select the new cluster > General.
2. (Oponal) Enable DNS for the controller node to adverse the service status using
DNS protocol. The cluster controller provides DNS services on the management (MGT)
interface port.
3. Register Firewall To the use the service adversed by the cluster controller(s). Palo Alto
Networks recommends adding both controllers as authority servers as this provides the
beneﬁt of high-availability. Use the form:
wfpc.service.<cluster-name>.<domain>
For example, a cluster named mycluster in the paloaltonetworks.com domain would have
the domain name:
wfpc.service.mycluster.paloaltonetworks.com
4. Enter the Content Update Server for the cluster. Use the default
updates.paloaltonetworks.com FQDN to connect to the closest server. Check
Server Identy to conﬁrm the update server identy by matching the common name
(CN) in the cerﬁcate with the IP address or FQDN of the server (this is checked by
default).
5. (Oponal) Enter the public WildFire Cloud Server locaon or use the default
wildfire.paloaltonetworks.com so that the cluster (or standalone appliance
managed by Panorama) can send informaon to the closest WildFire cloud server. If you
leave this ﬁeld blank and do not connect to a WildFire cloud server, the cluster can’t
receive signature updates directly from the WildFire public cloud, and can’t send samples
for analysis or contribute data to the public cloud.
6. If you connect the cluster to the public WildFire cloud, select the cloud services you
want to enable:
• Send Analysis Data—Send an XML report about local malware analysis. If you send
the actual samples, the cluster doesn’t send reports.
• Send Malicious Samples—Send malware samples.
• Send Diagnoscs—Send diagnosc data.
• Verdict Lookup—Automacally query the WildFire public cloud for verdicts before
performing local analysis to reduce the load on the local WildFire appliance cluster.
7. Select the Sample Analysis Image to use, based on the types of samples the cluster will
analyze.
8. Conﬁgure the amount of me for the cluster to retain Benign/Grayware sample
data (1-90 day range, 14 day default) and Malicious sample data (minimum 1 day, no
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maximum (indeﬁnite), default is indeﬁnite). Malicious sample data includes phishing
verdicts.
9. (Oponal) Select Preferred Analysis Environment to allocate more resources to
Executables or Documents, depending on your environment. The Default allocaon is
balanced between Executables and Documents. The available resource amount depends
on the number of WildFire nodes in the cluster.
STEP 3 | Check to ensure that the primary and backup Panorama servers are conﬁgured.
If you did not conﬁgure a backup Panorama server and want to do so, you can add the backup
Panorama server.
1. Select the cluster.
2. Select Appliance.
3. Check (or enter) the IP address or FQDN of the primary Panorama Server and of
the backup Panorama Server 2 if you are using a high availability conﬁguraon for
centralized cluster management.
STEP 4 | (Oponal) Conﬁgure system and conﬁguraon log sengs for the cluster, including log
forwarding.
1. Select the cluster.
2. Select Logging.
3. Select System or Conﬁguraon to conﬁgure a system or conﬁguraon log, respecvely.
The process for conﬁguring them is similar.
4. Add (
) and Name the log forwarding instance, select the Filter, and conﬁgure the
Forward Method (SNMP, Email, Syslog, or HTTP).
STEP 5 | Conﬁgure administrator authencaon.
1. Select the cluster.
2. Select Authencaon.
3. Select the Authencaon Proﬁle, either None or radius. RADIUS is the only supported
external authencaon method.
4. Set the Local Authencaon mode for admin users as either Password or Password
Hash, and enter the Password.
STEP 6 | Commit the conﬁguraon on the Panorama appliance and push it to the cluster.
1. Commit and Push.
2. If there are conﬁguraons on the Panorama appliance that you do not want to push,
Edit Selecons to choose the appliances to which you push conﬁguraons. The pushed
conﬁguraon overwrites the running conﬁguraon on the cluster nodes so that all
cluster nodes run the same conﬁguraon.

Conﬁgure Authencaon for a WildFire Cluster
Create and conﬁgure enhanced authencaon for all WildFire appliances in a WildFire cluster
by conﬁguring local administrave users with granular authencaon parameters, as well as
leveraging RADIUS, TACAS+, or LDAP for authorizaon and authencaon.
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When you Conﬁgure and push administrators from Panorama, you overwrite the exisng
administrators for all WildFire appliances in the WildFire cluster with those you conﬁgure on
Panorama.
• Conﬁgure an Administrave Account for a WildFire Cluster
• Conﬁgure RADIUS Authencaon for a WildFire Cluster
• Conﬁgure TACACS+ Authencaon for a WildFire Cluster
• Conﬁgure LDAP Authencaon for a WildFire Cluster
Configure an Administrative Account for a WildFire Cluster
Create one or more administrators with granular authencaon parameters for all WildFire
appliances in a WildFire cluster to manage from the Panorama™ management server. Addionally,
you can conﬁgure local administrators from Panorama that can be conﬁgured directly on the CLI
of the WildFire appliance. However, pushing new conﬁguraon changes to the WildFire appliance
will overwrites local administrators with the administrators conﬁgured for the WildFire appliance.
STEP 1 | Log in to the Panorama Web Interface.
STEP 2 | Conﬁgure a Cluster Centrally on Panorama.
STEP 3 | (Oponal) Conﬁgure an authencaon proﬁle to deﬁne the authencaon service that
validates the login credenals of the administrators who access the WildFire appliance CLI.
STEP 4 | Conﬁgure one or more administrator accounts as needed.
The administrator accounts created on Panorama are later imported to the WildFire appliances
in the WildFire Cluster and managed from Panorama.
You must conﬁgure the administrave account with Superuser admin role privileges to
successfully conﬁgure authencaon for Wildﬁre appliances in the WildFire cluster.
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STEP 5 | Conﬁgure the authencaon for the WildFire appliances in the WildFire cluster.
1. Select Panorama > Managed WildFire Clusters and select the WildFire cluster you
previously conﬁgured.
2. (Oponal) Select the Authencaon Proﬁle you conﬁgured in the previous step.
3. Conﬁgure the authencaon Timeout Conﬁguraon for the WildFire appliances.
1. Enter the number of Failed Aempts before a user is locked out of the WildFire
appliance CLI.
2. Enter the Lockout Time, in minutes, for which a WildFire appliance locks out a user
account aer that user reaches the conﬁgured number of Failed Aempts.
3. Enter the Idle Timeout, in minutes, before the user account is automacally logged
out due to inacvity.
4. Enter the Max Session Count to set how many user accounts can simultaneously
access a WildFire appliance.
5. Enter the Max Session Time the administrator can be logged in before being
automacally logged out.
4. Add the WildFire appliance administrators.
Administrators may either be added as a local administrator or as an imported Panorama
administrator—but not both. Adding the same administrator as both a local administrator
and as an imported Panorama administrator is not supported and causes the Panorama
commit to fail. For example, the commit to Panorama fails if you add admin1 as both a
local and Panorama administrator.
1. Add and conﬁgure new administrators unique to the WildFire appliances in the
WildFire cluster. These administrators are speciﬁc to the WildFire appliances in the
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WildFire cluster for which they are created and you manage these administrators from
this table.
2. Add any administrators conﬁgured on Panorama. These administrators are created on
Panorama and imported to the WildFire appliances in the WildFire cluster.
5. Click OK to save the WildFire cluster authencaon conﬁguraon.

STEP 6 | Commit and then Commit and Push your conﬁguraon changes.
STEP 7 | Access the WildFire appliance CLI to verify you can successfully access a WildFire appliance
using the local admin user.
Configure RADIUS Authentication for a WildFire Cluster
Use a RADIUS server to authencate administrave access to the CLI of the WildFire appliances
in a WildFire cluster. You can also deﬁne Vendor-Speciﬁc Aributes (VSAs) on the RADIUS server
to manage administrator authorizaon. Using VSAs enables you to quickly change the roles,
access domains, and user groups of administrators through your directory service, which is oen
easier than reconﬁguring sengs on the Panorama™ management server.
You can Import the Palo Alto Networks RADIUS diconary into RADIUS server to deﬁne
the authencaon aributes needed for communicaon between Panorama and the
RADIUS server.
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STEP 1 | Log in to the Panorama Web Interface.
STEP 2 | Conﬁgure a Cluster Centrally on Panorama.
STEP 3 | Conﬁgure RADIUS authencaon.
Administrator accounts conﬁgured for RADIUS authencaon are required to have
Superuser admin role privileges to successfully conﬁgure authencaon for Wildﬁre
appliances in the WildFire cluster.
1. Add a RADIUS server proﬁle.
The proﬁle deﬁnes how the WildFire appliances in the WildFire clust connect to the
RADIUS server.
1. Select Panorama > Server Proﬁles > RADIUS and Add a proﬁle.
2. Enter a Proﬁle Name to idenfy the server proﬁle.
3. Enter a Timeout interval in seconds aer which an authencaon request mes out
(default is 3; range is 1–20).
4. Select the Authencaon Protocol (default is CHAP) that a WildFire appliance uses to
authencate to the RADIUS server.
Select CHAP if the RADIUS server supports that protocol; it is more secure
than PAP.
5. Add each RADIUS server and enter the following:
1. Name to idenfy the server.
2. RADIUS Server IP address or FQDN.
3. Secret/Conﬁrm Secret (a key to encrypt usernames and passwords).
4. Server Port for authencaon requests (default is 1812).
6. Click OK to save the server proﬁle.
2. Assign the RADIUS server proﬁle to an authencaon proﬁle.
The authencaon proﬁle deﬁnes authencaon sengs that are common to a set of
administrators.
1. Select Panorama > Authencaon Proﬁle and Add a proﬁle.
2. Enter a Name to idenfy the authencaon proﬁle.
3. Set the Type to RADIUS.
4. Select the Server Proﬁle you conﬁgured.
5. Select Retrieve user group from RADIUS to collect user group informaon from VSAs
deﬁned on the RADIUS server.
Panorama matches the group informaon against the groups you specify in the Allow
List of the authencaon proﬁle.
6. Select Advanced and, in the Allow List, Add the administrators that are allowed to
authencate with this authencaon proﬁle.
7. Click OK to save the authencaon proﬁle.

Panorama Administrator's Guide Version Version 10.1

498

©2022 Palo Alto Networks, Inc.

Manage WildFire Appliances
STEP 4 | Conﬁgure the authencaon for the WildFire cluster.
1. Select Panorama > Managed WildFire Clusters and select the WildFire cluster you
previously added.
2. Select the Authencaon Proﬁle you conﬁgured in the previous step.
If a global authencaon proﬁle is not assigned you must assign an authencaon proﬁle
to each individual local administrator to leverage remote authencaon.
3. Conﬁgure the authencaon Timeout Conﬁguraon for a WildFire appliance.
1. Enter the number of Failed Aempts before a user is locked out of a WildFire
appliance CLI.
2. Enter the Lockout Time, in minutes, for which a WildFire appliance locks out a user
account aer that user reaches the conﬁgured number of Failed Aempts.
3. Enter the Idle Timeout, in minutes, before the user account is automacally logged
out due to inacvity.
4. Enter the Max Session Count to set how many user accounts can simultaneously
access a WildFire appliance.
5. Enter the Max Session Time the administrator can be logged in before being
automacally logged out.
4. Add the WildFire appliance administrators.
Administrators may either be added as a local administrator or as an imported Panorama
administrator—but not both. Adding the same administrator as both a local administrator
and as an imported Panorama administrator is not supported and causes the Panorama
commit to fail. For example, the commit to Panorama fails if you add admin1 as both a
local and Panorama administrator.
1. Add and conﬁgure new administrators unique to the WildFire appliances in the
WildFire cluster. These administrators are speciﬁc to the WildFire appliances in the
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WildFire cluster for which they are created and you manage these administrators from
this table.
2. Add any administrators conﬁgured on Panorama. These administrators are created on
Panorama and imported to the WildFire appliances in the WildFire cluster.
5. Click OK to save the WildFire cluster authencaon conﬁguraon.

STEP 5 | Commit and then Commit and Push your conﬁguraon changes.
STEP 6 | Access the WildFire appliance CLI to verify you can successfully access a WildFire appliance
using the local admin user.
Configure TACACS+ Authentication for a WildFire Cluster
You can use a TACACS+ server to authencate administrave access to the CLI of the WildFire
appliances in a WildFire cluster. You can also deﬁne Vendor-Speciﬁc Aributes (VSAs) on the
TACACS+ server to manage administrator authorizaon. Using VSAs enables you to quickly
change the roles, access domains, and user groups of administrators through your directory
service, which is oen easier than reconﬁguring sengs on Panorama.
STEP 1 | Log in to the Panorama Web Interface.
STEP 2 | Conﬁgure a Cluster Centrally on Panorama.
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STEP 3 | Conﬁgure TACACS+ authencaon.
Administrator accounts conﬁgured for TACACS+ authencaon are required to have
Superuser admin role privileges to successfully conﬁgure authencaon for Wildﬁre
appliances in the WildFire cluster.
1. Add a TACACS+ server proﬁle.
The proﬁle deﬁnes how a WildFire appliance connects to the TACACS+ server.
1. Select Panorama > Server Proﬁles > TACACS+ and Add a proﬁle.
2. Enter a Proﬁle Name to idenfy the server proﬁle.
3. Enter a Timeout interval in seconds aer which an authencaon request mes out
(default is 3; range is 1–20).
4. Select the Authencaon Protocol (default is CHAP) that Panorama uses to
authencate to the TACACS+ server.
5. Select CHAP if the TACACS+ server supports that protocol; it is more secure than
PAP.
6. Add each TACACS+ server and enter the following:
1. Name to idenfy the server.
2. TACACS+ Server IP address or FQDN.
3. Secret/Conﬁrm Secret (a key to encrypt usernames and passwords).
4. Server Port for authencaon requests (default is 49).
7. Click OK to save the server proﬁle.
2. Assign the TACACS+ server proﬁle to an authencaon proﬁle.
The authencaon proﬁle deﬁnes authencaon sengs that are common to a set of
administrators.
1. Select Panorama > Authencaon Proﬁle and Add a proﬁle.
2. Enter a Name to idenfy the proﬁle.
3. Set the Type to TACACS+.
4. Select the Server Proﬁle you conﬁgured.
5. Select Retrieve user group from TACACS+ to collect user group informaon from
VSAs deﬁned on the TACACS+ server.
Panorama matches the group informaon against the groups you specify in the Allow
List of the authencaon proﬁle.
6. Select Advanced and, in the Allow List, Add the administrators that are allowed to
authencate with this authencaon proﬁle.
7. Click OK to save the authencaon proﬁle.
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STEP 4 | Conﬁgure the authencaon for the WildFire cluster.
1. Select Panorama > Managed WildFire Clusters and select the WildFire cluster you
previously added.
2. Select the Authencaon Proﬁle you conﬁgured in the previous step.
If a global authencaon proﬁle is not assigned you must assign an authencaon proﬁle
to each individual local administrator to leverage remote authencaon.
3. Conﬁgure the authencaon Timeout Conﬁguraon for a WildFire appliance.
1. Enter the number of Failed Aempts before a user is locked out of a WildFire
appliance CLI.
2. Enter the Lockout Time, in minutes, for which a WildFire appliance locks out a user
account aer that user reaches the conﬁgured number of Failed Aempts.
3. Enter the Idle Timeout, in minutes, before the user account is automacally logged
out due to inacvity.
4. Enter the Max Session Count to set how many user accounts can simultaneously
access a WildFire appliance.
5. Enter the Max Session Time the administrator can be logged in before being
automacally logged out.
4. Add the WildFire appliance administrators.
Administrators may either be added as a local administrator or as an imported Panorama
administrator—but not both. Adding the same administrator as both a local administrator
and as an imported Panorama administrator is not supported and causes the Panorama
commit to fail. For example, the commit to Panorama fails if you add admin1 as both a
local and Panorama administrator.
1. Add and conﬁgure new administrators unique to the WildFire appliances in the
WildFire cluster. These administrators are speciﬁc to the WildFire appliances in the
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WildFire cluster for which they are created and you manage these administrators from
this table.
2. Add any administrators conﬁgured on Panorama. These administrators are created on
Panorama and imported to the WildFire appliances in the WildFire cluster.
5. Click OK to save the WildFire cluster authencaon conﬁguraon.

STEP 5 | Commit and then Commit and Push your conﬁguraon changes.
STEP 6 | Access the WildFire appliance CLI to verify you can successfully access a WildFire appliance
using the local admin user.
Configure LDAP Authentication for a WildFire Cluster
You can use LDAP to authencate end users to access the CLI of the WildFire appliances in a
WildFire cluster.
STEP 1 | Log in to the Panorama Web Interface.
STEP 2 | Conﬁgure a Cluster Centrally on Panorama.
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STEP 3 | Add an LDAP server proﬁle.
The proﬁle deﬁnes how a WildFire appliance connects to the LDAP server.
Administrator accounts conﬁgured for LDAP authencaon are required to have
Superuser admin role privileges to successfully conﬁgure authencaon for WildFire
appliances in the WildFire cluster.
1. Select Panorama > Server Proﬁles > LDAP and Add a server proﬁle.
2. Enter a Proﬁle Name to idenfy the server proﬁle.
3. Add the LDAP servers (up to four). For each server, enter a Name (to idenfy the server),
LDAP Server IP address or FQDN, and server Port (default 389).
If you use an FQDN address object to idenfy the server and you subsequently
change the address, you must commit the change for the new server address to
take eﬀect.
4. Select the server Type.
5. Select the Base DN.
To idenfy the Base DN of your directory, open the Acve Directory Domains and
Trusts Microso Management Console snap-in and use the name of the top-level
domain.
6. Enter the Bind DN and Password to enable the authencaon service to authencate
the ﬁrewall.
The Bind DN account must have permission to read the LDAP directory.
7. Enter the Bind Timeout and Search Timeout in seconds (default is 30 for both).
8. Enter the Retry Interval in seconds (default is 60).
9. (Oponal) If you want the endpoint to use SSL or TLS for a more secure connecon with
the directory server, enable the opon to Require SSL/TLS secured connecon (enabled
by default). The protocol that the endpoint uses depends on the server port:
• 389 (default)—TLS (Speciﬁcally, the WildFire appliance uses the StartTLS operaon,
which upgrades the inial plaintext connecon to TLS.)
• 636—SSL
• Any other port—The WildFire appliance ﬁrst aempts to use TLS. If the directory
server doesn’t support TLS, the WildFire appliance falls back to SSL.
10. (Oponal) For addional security, enable to the opon to Verify Server Cerﬁcate
for SSL sessions so that the endpoint veriﬁes the cerﬁcate that the directory server
presents for SSL/TLS connecons. To enable veriﬁcaon, you must also enable the
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opon to Require SSL/TLS secured connecon. For veriﬁcaon to succeed, the
cerﬁcate must meet one of the following condions:
• It is in the list of Panorama cerﬁcates: Panorama > Cerﬁcate Management >
Cerﬁcates > Device Cerﬁcates. If necessary, import the cerﬁcate into Panorama.
• The cerﬁcate signer is in the list of trusted cerﬁcate authories: Panorama >
Cerﬁcate Management > Cerﬁcates.
11. Click OK to save the server proﬁle.
STEP 4 | Conﬁgure the authencaon for the WildFire cluster.
1. Select Panorama > Managed WildFire Clusters and select the WildFire cluster you
previously added.
2. Conﬁgure the authencaon Timeout Conﬁguraon for a WildFire appliance.
1. Enter the number of Failed Aempts before a user is locked out of a WildFire
appliance CLI.
2. Enter the Lockout Time, in minutes, for which a WildFire appliance locks out a user
account aer that user reaches the conﬁgured number of Failed Aempts.
3. Enter the Idle Timeout, in minutes, before the user account is automacally logged
out due to inacvity.
4. Enter the Max Session Count to set how many user accounts can simultaneously
access a WildFire appliance.
5. Enter the Max Session Time the administrator can be logged in before being
automacally logged out.
3. Add the WildFire appliance administrators.
Administrators may either be added as a local administrator or as an imported Panorama
administrator—but not both. Adding the same administrator as both a local administrator
and as an imported Panorama administrator is not supported and causes the Panorama
commit to fail. For example, the commit to Panorama fails if you add admin1 as both a
local and Panorama administrator.
• Conﬁgure the local administrators.
Conﬁgure new administrators unique to the WildFire appliances in the WildFire
cluster. These administrators are speciﬁc to the WildFire appliances in the WildFire
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cluster for which they are created and you manage these administrators from this
table.
1. Add one or more new local administrator.
2. Enter a Name for the local administrator.
3. Assign an Authencaon Proﬁle you previously created.
LDAP authencaon proﬁles are supported only for individual local
administrators.
4. Enable (check) Use Public Key Authencaon (SSH) to import a public key ﬁle for
authencaon.
5. Select a Password Proﬁle to set the expiraon parameters.
• Import exisng Panorama administrators
Import exisng administrators conﬁgured on Panorama. These administrators are
conﬁgured and managed on Panorama and imported to all WildFire appliances in the
WildFire cluster.
1. Add an exisng Panorama administrator
4. Click OK to save the WildFire cluster authencaon conﬁguraon.
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STEP 5 | Commit and then Commit and Push your conﬁguraon changes.
STEP 6 | Access the WildFire appliance CLI to verify you can successfully access the WildFire
appliance using the local admin user.

Remove a Cluster from Panorama Management
To remove a cluster from Panorama management, Panorama > Managed WildFire Clusters and
select the row of the cluster you want to remove (do not click the cluster name) and Remove From
Panorama.
If you remove a WildFire appliance cluster from Panorama management, the Panorama web
interface places the WildFire appliances in that cluster into read-only mode. Although the WildFire
appliances in the removed cluster display in the Panorama web interface, when in read-only mode,
you can’t push conﬁguraons to the WildFire appliances or manage them with Panorama. Aer
being removed from Panorama management, the WildFire appliance cluster members use the local
cluster conﬁguraon and you can manage the cluster using the local CLI.
To manage the WildFire appliances in the cluster with Panorama aer you remove the cluster from
Panorama management, import the cluster back into Panorama (Panorama > Managed WildFire
Clusters > Import Cluster Conﬁg).
STEP 1 | Select the cluster’s controller node. The cluster name populates Cluster automacally.
STEP 2 | Click OK. The cluster backup controller node and worker nodes populate automacally.
STEP 3 | Click OK to import the cluster.
STEP 4 | Commit the changes.

Conﬁgure Appliance-to-Appliance Encrypon Using Predeﬁned Cerﬁcates Centrally
on Panorama
STEP 1 | Upgrade each managed WildFire appliance to PAN-OS 8.1.x. All managed appliances must be
running PAN-OS 8.1 or later to enable appliance-to-appliance encrypon.
STEP 2 | Verify that your WildFire appliance cluster has been properly conﬁgured and is operang in a
healthy state.
STEP 3 | On Panorama, select Panorama > Managed WildFire Clusters > WF_cluster_name>
Communicaon.
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STEP 4 | Enable Secure Cluster Communicaon.

STEP 5 | (Recommended) Enable HA Traﬃc Encrypon. This oponal seng encrypts the HA traﬃc
between the HA pair and is a Palo Alto Networks recommended best pracce.
HA Traﬃc Encrypon cannot be disabled when operang in FIPS/CC mode.

STEP 6 | Click OK to save the WildFire Cluster sengs.
STEP 7 | Commit your changes.

Conﬁgure Appliance-to-Appliance Encrypon Using Custom Cerﬁcates Centrally on
Panorama
STEP 1 | Upgrade each managed WildFire appliance to PAN-OS 8.1.x. All managed appliances must be
running PAN-OS 8.1 or later to enable appliance-to-appliance encrypon.
STEP 2 | Verify that your WildFire appliance cluster has been properly conﬁgured and is operang in a
healthy state.
STEP 3 | Review your exisng WildFire secure communicaons conﬁguraon. Keep in mind,
if you previously conﬁgured the WildFire appliance and the ﬁrewall for secure
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communicaons using a custom cerﬁcate, you can also use that custom cerﬁcate for
secure communicaons between WildFire appliances.
1. Select Panorama >Managed WildFire Clusters> WF_cluster_name> Communicaon.
2. If Customize Secure Server Communicaon has been enabled and you would like to
use that cerﬁcate, idenfy the details of the custom cerﬁcate being used. Otherwise
proceed to Step 5 to begin the process of installing a new custom cerﬁcate.
3. Determine the custom cerﬁcate FQDN (DNS name) that will be used to deﬁne the
ﬁrewall registraon address in Step 4.
Make sure to note the custom cerﬁcate name and the associated FQDN. These
are referenced several mes during the conﬁguraon process.
STEP 4 | Conﬁgure the ﬁrewall registraon address on Panorama.
1. On Panorama, select Panorama >Managed WildFire Clusters> WF_cluster_name>
General.
2. In the Register Firewall To ﬁeld, specify the DNS name used for authencaon found in
the custom cerﬁcate (typically the SubjectName or the SubjectAltName). For example,
the default domain name is wfpc.service.mycluster.paloaltonetworks.com

STEP 5 | Conﬁgure WildFire Secure Server Communicaon sengs on Panorama. If you already
conﬁgured secure communicaons between the ﬁrewall and the WildFire cluster and are
using the exisng custom cerﬁcate, proceed to Step 4 below.
1. On Panorama, select Panorama> Managed WildFire Clusters> WF_cluster_name>
Communicaon.
2. Click Customize Secure Server Communicaon.
3. Conﬁgure and deploy custom cerﬁcates used by the WildFire appliances and the
associated ﬁrewall. The SSL/TLS service proﬁle deﬁnes the custom cerﬁcate used by
WildFire appliances to communicate with WildFire appliance peers and to the ﬁrewall.
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You must also conﬁgure the custom cerﬁcate sengs on the ﬁrewall associated with
the WildFire appliance cluster. This is conﬁgured later in Step 9.
1. Open the SSL/TLS Service Proﬁle drop-down and click SSL/TLS Service Proﬁle.
Conﬁgure an SSL/TLS service proﬁle with the custom cerﬁcate that you want to use.
Aer you conﬁgure the SSL/TLS service proﬁle, click OK and select the newly created
SSL/TLS Service proﬁle.
2. Open the Cerﬁcate Proﬁle drop-down and click Cerﬁcate Proﬁle. Conﬁgure a
Cerﬁcate Proﬁle that idenﬁes the custom cerﬁcate used to establish secure
connecons between the ﬁrewall and WildFire appliances, as well as between peer
WildFire appliances. Aer you conﬁgure the Cerﬁcate Proﬁle, click OK and select the
newly created proﬁle.
4. Select the Custom Cerﬁcate Only check box. This allows you to use the custom
cerﬁcates that you conﬁgured instead of the default preconﬁgured cerﬁcates.
5. (Oponal) Conﬁgure an authorizaon list. The authorizaon list checks the custom
cerﬁcate Subject or Subject Alt Name; if the Subject or Subject Alt Name presented
with the custom cerﬁcate does not match an idenﬁer on the authorizaon list,
authencaon is denied.
1. Add an Authorizaon List.
2. Select the Subject or Subject Alt Name conﬁgured in the custom cerﬁcate proﬁle as
the Idenﬁer type.
3. Enter the Common Name if the idenﬁer is Subject or and IP address, hostname or
email if the idenﬁer is Subject Alt Name.
4. Click OK.
5. Select Check Authorizaon List to enforce the authorizaon list.
6. Click OK.

STEP 6 | Enable Secure Cluster Communicaon.
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STEP 7 | (Recommended) Enable HA Traﬃc Encrypon. This oponal seng encrypts the HA traﬃc
between the HA pair and is a Palo Alto Networks recommended best pracce.
HA Traﬃc Encrypon cannot be disabled when operang in FIPS/CC mode.
STEP 8 | Click OK to save the WildFire Cluster sengs.
STEP 9 | Conﬁgure the ﬁrewall Secure Communicaon Sengs on Panorama to associate the
WildFire appliance cluster with the ﬁrewall custom cerﬁcate. This provides a secure
communicaons channel between the ﬁrewall and WildFire appliance cluster. If you already
conﬁgured secure communicaons between the ﬁrewall and the WildFire appliance cluster
and are using the exisng custom cerﬁcate, proceed to the next step.
1. Select Device > Setup > Management > Secure Communicaon Sengs and click the
Edit icon in Secure Communicaon Sengs to conﬁgure the ﬁrewall custom cerﬁcate
sengs.
2. Select the Cerﬁcate Type, Cerﬁcate, and Cerﬁcate Proﬁle from the respecve dropdowns and conﬁgure them to use the custom cerﬁcate.
3. Under Customize Communicaon, select WildFire Communicaon.
4. Click OK.
STEP 10 | Commit your changes.

View WildFire Cluster Status Using Panorama
To conﬁrm that a conﬁgured WildFire appliance cluster is operang correctly, you can view the
current status using the Panorama appliance.
Palo Alto Networks recommends using the WildFire appliance CLI to verify the status of
your WildFire cluster. Addional status details that are not visible from Panorama are
displayed in the command output.
STEP 1 | On the primary Panorama appliance, select Panorama > Managed WildFire Clusters.
STEP 2 | In the Cluster Status column, verify that:
1. The wfpc and signature services are running.
2. No other operaons are present. Abnormal operaons and their status condions
include:
• Decommission [requested / ongoing / denied / success / fail]
• Suspend [requested / ongoing / denied / success / fail]
• Reboot [requested / ongoing / denied / success / fail]
• Cluster [oﬄine / splitbrain / unready]
• Service [suspended / none]
• HA [peer-oﬄine / cfg-not-sync / cfg-sync-oﬀ]
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STEP 3 | In the Conﬁg Status column, verify that:
1. The appliance conﬁguraon is In Sync with the conﬁguraon stored on the Panorama
appliance.
2. No other status is present. Abnormal status condions include:
• Out of Sync [The appliance conﬁguraon is not in sync with its saved conﬁguraon on
Panorama. You can mouse over the magnifying glass to display the cause of the sync
failure].
STEP 4 | In the Connected column, verify that the conﬁgured WildFire appliances show a status of
Connected.
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You can use the Panorama™ management server to centrally manage licenses,
soware updates, and content updates on ﬁrewalls and Dedicated Log Collectors.
When you deploy licenses or updates, Panorama checks in with the Palo Alto
Networks® licensing server or update server, veriﬁes the request validity, and then
allows retrieval and installaon of the license or update. This capability facilitates
deployment by eliminang the need to repeat the same tasks on each ﬁrewall or
Dedicated Log Collector. It is parcularly useful for managing ﬁrewalls that don’t have
direct internet access or for managing Dedicated Log Collectors, which don’t have a
web interface.
Before deploying updates, see Panorama, Log Collector, Firewall, and WildFire Version
Compability for important details about update version compability.
You must acvate a support subscripon directly on each ﬁrewall; you cannot use
Panorama to deploy support subscripons.
To acvate licenses or install updates on the Panorama management server, see
Register Panorama and Install Licenses and Install Content and Soware Updates for
Panorama.
> Manage Licenses on Firewalls Using Panorama
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Manage Licenses on Firewalls Using Panorama
The following steps describe how to retrieve new licenses using an authencaon (auth) code and
push the license keys to managed ﬁrewalls. It also describes how to manually update (refresh) the
license status of ﬁrewalls that do not have direct internet access. For ﬁrewalls that have direct
internet access, Panorama™ automacally performs a daily check-in with the licensing server,
retrieves license updates and renewals, and pushes them to the ﬁrewalls. The check-in is hardcoded to occur between 1 a.m. and 2 a.m.; you cannot change this schedule.
You cannot use Panorama to acvate the support license for ﬁrewalls. You must access the
ﬁrewalls individually to acvate their support licenses.
To acvate licenses for Panorama, see Register Panorama and Install Licenses.
Acvate newly purchased licenses.
1. Select Panorama > Device Deployment > Licenses and Acvate.
2. Enter the Auth Code that Palo Alto Networks® provided for each ﬁrewall that has a new
license.
3. Acvate the license.
4. (WildFire® subscripons only) Perform a commit on each ﬁrewall that has a new WildFire
subscripon to complete the acvaon:
• Commit any pending changes. You must access each ﬁrewall web interface to do this.
• If no conﬁguraon changes are pending, make a minor change and Commit. For
example, update a rule descripon and commit the change. If the ﬁrewalls belong
to the same device group, you can push the rule change from Panorama to iniate a
commit on all those ﬁrewalls instead of accessing each ﬁrewall separately.
Check that the WildFire Analysis proﬁle rules include the advanced ﬁle types
that the WildFire subscripon supports.
Update the license status of ﬁrewalls.
1. Select Panorama > Device Deployment > Licenses.
Each entry on the page indicates whether the license is acve or inacve and displays
the expiraon date for acve licenses.
2. If you previously acvated auth codes for the support subscripon directly on the
ﬁrewalls, click Refresh and select the ﬁrewalls from the list. Panorama retrieves the
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license, deploys it to the ﬁrewalls, and updates the licensing status on the Panorama web
interface.
3. (Enterprise Data Loss Prevenon (DLP) license only) Push the updated license to the
managed ﬁrewalls leveraging Enterprise DLP.
1. Select Commit and Commit to Panorama.
2. Select Commit > Push to Devices and Edit Selecons.
3. Select Templates and select the template stack associated with the managed ﬁrewalls
leveraging Enterprise DLP.
Click OK to connue.
4. Push the template conﬁguraon to successfully update the Enterprise DLP license.
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Monitor Network Acvity
The Panorama™ management server provides a comprehensive, graphical view of
network traﬃc. Using the visibility tools on Panorama—the Applicaon Command
Center (ACC), logs, and report generaon capabilies—you can centrally analyze,
invesgate and report on all network acvity, idenfy areas with potenal security
impact, and translate them into secure applicaon enablement policies.
This secon covers the following topics:
> Use Panorama for Visibility
> Ingest Traps ESM Logs on Panorama
> Use Case: Monitor Applicaons Using Panorama
> Use Case: Respond to an Incident Using Panorama
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Use Panorama for Visibility
In addion to its central deployment and ﬁrewall conﬁguraon features, Panorama also allows you
to monitor and report on all traﬃc that traverses your network. While the reporng capabilies
on Panorama and the ﬁrewall are very similar, the advantage that Panorama provides is that it is
a single pane view of aggregated informaon across all your managed ﬁrewalls. This aggregated
view provides aconable informaon on trends in user acvity, traﬃc paerns, and potenal
threats across your enre network.
Using the Applicaon Command Center (ACC), the App-Scope, the log viewer, and the standard,
customizable reporng opons on Panorama, you can quickly learn more about the traﬃc
traversing the network. The ability to view this informaon allows you to evaluate where your
current policies are adequate and where they are insuﬃcient. You can then use this data to
augment your network security strategy. For example, you can enhance the security rules to
increase compliance and accountability for all users across the network, or manage network
capacity and minimize risks to assets while meeng the rich applicaon needs for the users in your
network.
The following topics provide a high-level view of the reporng capabilies on Panorama, including
a couple of use cases to illustrate how you can use these capabilies within your own network
infrastructure. For a complete list of the available reports and charts and the descripon of each,
refer to the online help.
• Monitor the Network with the ACC and AppScope
• Analyze Log Data
• Generate, Schedule, and Email Reports
• Conﬁgure Key Limits for Scheduled Reports

Monitor the Network with the ACC and AppScope
Both the ACC and the AppScope allow you to monitor and report on the data recorded from
traﬃc that traverses your network.
The ACC on Panorama displays a summary of network traﬃc. Panorama can dynamically query
data from all the managed ﬁrewalls on the network and display it in the ACC. This display allows
you to monitor the traﬃc by applicaons, users, and content acvity—URL categories, threats,
security policies that eﬀecvely block data or ﬁles—across the enre network of Palo Alto
Networks next-generaon ﬁrewalls.
The AppScope helps idenfy unexpected or unusual behavior on the network at a glance. It
includes an array of charts and reports—Summary Report, Change Monitor, Threat Monitor,
Threat Map, Network Monitor, Traﬃc Map—that allow you to analyze traﬃc ﬂows by threat or
applicaon, or by the source or desnaon for the ﬂows. You can also sort by session or byte
count.
Device Group and Template admins can only network and ACC data for device groups
within their access domains.
Use the ACC and the AppScope to answer quesons such as:
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ACC

Monitor > AppScope

• What are the top applicaons used on
the network and how many are high-risk
applicaons? Who are the top users of
high-risk applicaons on the network?

• What are the applicaon usage trends
—what are the top ﬁve applicaons that
have gained use and the top ﬁve that have
decreased in use?

• What are the top URL categories being
viewed in the last hour?

• How has user acvity changed over the
current week as compared to last week or
last month?

• What are the top bandwidth-using
applicaons? Who are the users/hosts
that consume the highest bandwidth?

• Which users and applicaons take up most
of the network bandwidth? And how has
this consumpon changed over the last 30
days?

• What content or ﬁles are being blocked
and are there speciﬁc users who trigger
this File Blocking/Data Filtering rule?

• What are the threats on the network, and
how are these incoming and outgoing traﬃc
threats distributed geographically?

• What is the amount of traﬃc exchanged
between two speciﬁc IP addresses or
generated by a speciﬁc user? Where is
the desnaon server or client located
geographically?

You can then use the informaon to maintain or enforce changes to the traﬃc paerns on your
network. See Use Case: Monitor Applicaons Using Panorama for a glimpse into how the visibility
tools on Panorama can inﬂuence how you shape the acceptable use policies for your network.
Here are a few ps to help you navigate the ACC:

Figure 23: ACC Navigation Tips
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• Switch from a Panorama view to a Device view—Use the Context drop-down to access the
web interface of any managed ﬁrewall. For details, see Context Switch—Firewall or Panorama.
• Change Device Group and Data Source—The default Data Source used to display the stascs
on the charts in the ACC is Panorama local data, and the default Device Group seng is All.
Using the local data on Panorama provides a quick load me for the charts. You can, however,
change the data source to Remote Device Data if all the managed ﬁrewalls are on PAN-OS
7.0 or a later release. If the managed ﬁrewalls have a mix of PAN-OS 7.0 and earlier releases,
you can only view Panorama data. When conﬁgured to use Remote Device Data, Panorama
will poll all the managed ﬁrewalls and present an aggregated view of the data. The onscreen
display indicates the total number of ﬁrewalls being polled and the number of ﬁrewalls that
have responded to the query for informaon.
• Select the Tabs and Widgets to View—The ACC includes three tabs and an array of widgets
that allow you to ﬁnd the informaon that you care about. With the excepon of the
applicaon usage widget and host informaon widget, all the other widgets display data only if
the corresponding feature has been licensed on the ﬁrewall, and you have enabled logging.
• Tweak Time Frame and Reﬁne Data—The reporng me period in the ACC ranges from the
last 15 minutes to the last hour, day, week, month, or any custom-deﬁned me. By default,
each widget displays the top 10 items and aggregates all the remaining items as others. You
can sort the data in each widget using various aributes—for example, sessions, bytes, threats,
content, and URLs. You can also set local ﬁlters to ﬁlter the display within the table and graph
in a widget, and then promote the widget ﬁlter as a global ﬁlter to pivot the view across all the
widgets in the ACC.

Analyze Log Data
The Monitor tab on Panorama provides access to log data; these logs are an archived list of
sessions that have been processed by the managed ﬁrewalls and forwarded to Panorama.
Log data can be broadly grouped into two types: those that detail informaon on traﬃc ﬂows on
your network such as applicaons, threats, host informaon proﬁles, URL categories, content/
ﬁle types and those that record system events, conﬁguraon changes, and User-ID™ mapping
informaon.
Based on the log forwarding conﬁguraon on the managed ﬁrewalls, the Monitor > Logs tab can
include logs for traﬃc ﬂows, threats, URL ﬁltering, data ﬁltering, host informaon proﬁle (HIP)
matches, and WildFire™ submissions. You can review the logs to verify a wealth of informaon on
a given session or transacon. Some examples of this informaon are the user who iniated the
session, the acon (allow or deny) that the ﬁrewall performed on the session, and the source and
desnaon ports, zones, and addresses. The System and Conﬁg logs can indicate a conﬁguraon
change or an alarm that the ﬁrewall triggered when a conﬁgured threshold was exceeded.
If Panorama will manage ﬁrewalls running soware versions earlier than PAN-OS 7.0,
specify a WildFire server from which Panorama can gather analysis informaon for
WildFire samples that those ﬁrewalls submit. Panorama uses the informaon to complete
WildFire Submissions logs that are missing ﬁeld values introduced in PAN-OS 7.0. Firewalls
running earlier releases won’t populate those ﬁelds. To specify the server, select Panorama
> Setup > WildFire, edit the General Sengs, and enter the WildFire Private Cloud name.
The default is wildﬁre-public-cloud, which is the WildFire cloud hosted in the United
States.
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Generate, Schedule, and Email Reports
You can conﬁgure reports to run immediately or schedule them to run at speciﬁc intervals. You can
save and export the reports or email them to speciﬁc recipients. Emailing is parcularly useful if
you want to share reports with administrators who do not have access to Panorama. Panorama
supports the same report types as the Palo Alto Networks ﬁrewall.
Beginning with Panorama 10.0.2 and Cloud Services plugin version 1.8.0, you can generate
scheduled reports on Cortex Data Lake data.
In PAN-OS 10.0.3 and later, this feature is enabled by default.
To do this, you must ﬁrst enable the feature from the Panorama CLI by entering
admin@Panorama> request plugins cloud_services logging-service schedreport-enable
A regular commit will not enable this change. Instead, you must switch to conﬁguraon
mode:
admin@Panorama> configure
and enter
admin@Panorama# commit force
Then, follow the steps below for generang scheduled reports.
It is recommended that you install matching soware releases on Panorama and the
ﬁrewalls for which you will generate reports. For example, if the Panorama management
server runs Panorama 10.0, install PAN-OS 10.1 on its managed ﬁrewalls before
generang the reports. This pracce avoids issues that might occur if you create reports
that include ﬁelds supported in the Panorama release but not supported in an earlier PANOS release on the ﬁrewalls.
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STEP 1 | Conﬁgure Panorama predeﬁned reports.
1. Select Panorama > Setup > Management and edit Logging and Reporng.
2. (Oponal) Select Log Export and Reporng and enable (check) Use Data for Pre-Deﬁned
Reports to oﬄoad hourly report aggregaon to Log Collectors.
Enabling this seng is recommended for VM-50, VM-50 Lite and PA-200
ﬁrewalls.
3. Select Pre-Deﬁned Reports and enable (check) predeﬁned reports to push from
Panorama.
4. Select Commit > Commit to Panorama and Commit your conﬁguraon changes.
5. (VM-50, VM-50 Lite, and PA-200 ﬁrewalls only) Access the ﬁrewall CLI to enable
predeﬁned reports..
This command must be run on each VM-50, VM-50 Lite, and PA-200 ﬁrewall.
admin> debug run-panorama-predefined-report yes
STEP 2 | Conﬁgure Panorama to receive and store user and user group informaon that it receives
from ﬁrewalls.
Required to generate reports based on usernames and groups instead of just IP addresses.
1. If you want Panorama to include user group informaon in reports, upgrade the
managed ﬁrewalls to PAN-OS 8.1 or a later release. Panorama cannot synchronize group
informaon from ﬁrewalls running earlier releases.
2. Select Panorama > Setup > Management, edit the Panorama Sengs, and Enable
reporng and ﬁltering on groups.
3. Add a Device Group if you haven’t already. For each device group:
• Select a Master Device, which is the ﬁrewall that provides user and user group
informaon to Panorama.
• Enable Panorama to Store users and groups from Master Device.
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STEP 3 | Generate reports.
Scheduled and Run Now summary reports for the same database and meframe have
discrepancies in the data displayed in each report. This is due to how Log Collectors
and ﬁrewalls aggregate logs during hourly aggregaon.
The steps to generate a report depend on the type.
• Custom report:
1. Select Monitor > Manage Custom Reports and Add the report.
2. Enter a Name to idenfy the report.
3. Select a Database for the report.
You can base the report on Summary Databases or Detailed Logs databases.
To base the report on logs stored on the Panorama management server and Log
Collectors, select Panorama Data (recommended for faster performance).
To base the reports on logs stored on the managed ﬁrewalls, select Remote Device Data.
This opon is for cases where the ﬁrewalls might have logs that were not yet forwarded
to Panorama. However, because Panorama must query the ﬁrewalls directly, this opon
is slower.
4. Select Scheduled.
5. Deﬁne your log ﬁltering criteria by selecng the Time Frame, Sort By order, Group By
preference, and the columns (log aributes) that the report will display.
Selecng the Sort By order is required in order to generate an accurate report. If
you do not select a Sort By order, the generated custom report is populated with
the most recent log matches for the selected database.
6. (Oponal) Use the Query Builder to further reﬁne the log ﬁltering criteria based on log
aributes.
7. To test the report sengs, select Run Now. If necessary, modify the sengs to change
the informaon that the report displays.
8. Click OK to save the custom report.
• PDF Summary Report:
1. Select Monitor > PDF Reports > Manage PDF Summary and add the report.
2. Enter a Name to idenfy the report.
3. Use the drop-down for each report group and select one or more of the elements to
design the PDF Summary Report. You can include up to 18 elements.
4. Click OK to save the sengs.
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STEP 4 | Conﬁgure a Report Group.
It can include predeﬁned reports, PDF Summary reports, and custom reports. Panorama
compiles all the included reports into a single PDF.
1. Select Monitor > PDF Reports > Report Groups and Add a report group.
2. Enter a Name to idenfy the report group.
3. (Oponal) Select Title Page and add a Title for the PDF output.
4. Select reports in the Predeﬁned Report, Custom Report, and PDF Summary Report lists.
5. Add the selected reports to the report group.
6. Click OK to save the sengs.
STEP 5 | Conﬁgure an Email server proﬁle.
The proﬁle deﬁnes how the ﬁrewall connects to the server and sends email.
1. Select Panorama > Server Proﬁles > Email and Add a server proﬁle.
2. Enter a Name to idenfy the proﬁle.
3. Add up to four SMTP servers and Add the following informaon for each one:
• Name—A name to idenfy the SMTP server (1 to 31 characters). This ﬁeld is just a
label and doesn’t have to be the hostname of an exisng server.
• Email Display Name—The name to display in the From ﬁeld of the email.
• From—The email address where noﬁcaon emails will be sent from.
• To—The email address to which noﬁcaon emails will be sent.
• Addional Recipient—To send noﬁcaons to a second account, enter the addional
address here.
• Email Gateway—The IP address or hostname of the SMTP gateway to use to send the
emails.
4. Click OK to save the proﬁle.
STEP 6 | Schedule the report for email delivery.
1. Select Monitor > PDF Reports > Email Scheduler and Add an email scheduler proﬁle.
2. Enter a Name to idenfy the proﬁle.
3. Select the Report Group, the Email server proﬁle you just created (Email Proﬁle), and the
Recurrence for the report (default is Disable).
4. Send test email to verify that the email sengs are accurate.
5. Click OK to save your changes.
6. Select Commit > Commit to Panorama and Commit your changes.

Conﬁgure Key Limits for Scheduled Reports
The Panorama™ management server and the PA-7000 Series ﬁrewall reports ulize keys (unique
values on which you can aggregate) from one or more Log Collector to build and generate reports.
To improve the accuracy of scheduled reports, you can now conﬁgurable the maximum and
minimum key limits. By increasing the number of keys supported, scheduled reports can now
include more data that can be aggregated, sorted, and grouped.
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The default minimum key limit is based on the Sort By and Group By values conﬁgured for the
scheduled report using the following calculaon:
<Sort By value> x 100 x <Group By value>
For example, if Sort By is conﬁgured as Top 25 and Group By is conﬁgured as 5 Groups, the
default minimum key limit is 12,500 keys. The Group By value is not factored into the calculaon
when set to None. The default minimum key limit is limited to and cannot exceed the maximum
key limit.
You can only conﬁgure the key limits for the M-Series appliances and Panorama virtual
appliances. The PA-7000 series key limits are not conﬁgurable.
The supported maximum and minimum keys are increased for the following Panorama models:
Panorama Model

Minimum Key Limit

Maximum Key Limit

PA-7000 Series

1,000 - Default, not
conﬁgurable

25,000 - Default, not
conﬁgurable

M-200

15,000

50,000

M-500

15,000

50,000

M-600

15,000

50,000

Panorama Virtual Appliance in
Legacy mode

5,000

25,000

Panorama Virtual Appliance (all
supported models)

15,000

50,000

STEP 1 | Log in to the Panorama CLI.
STEP 2 | Conﬁgure the maximum key limit using the following command:
You can set the maximum key limit between 0 and 50, where 50 equals 50,000 keys. In this
example, we are seng the maximum key limit for the Panorama virtual appliance to 30,000
keys.
admin@Panorama> request max-report-keys set limit <Key Limit>
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STEP 3 | Conﬁgure the minimum key limit using the following command:
You can set the minimum key limit between 0 and 15, where 15 equals 15,000 keys. In this
example, we are seng the minimum key limit for the Panorama virtual appliance to 15,000
keys.
admin@Panorama> request min-report-keys set limit <Key Limit>

STEP 4 | (Oponal) Set the minimum key limit to the default seng.
admin@Panorama> request min-report-keys set limit 0
STEP 5 | Commit the new maximum and minimum key limits to Panorama using the following
command:
admin@Panorama> commit-all
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Ingest Traps ESM Logs on Panorama
Visibility is a crical ﬁrst step in prevenng and reducing the impact of an aack. To help you meet
this challenge, Panorama provides an integrated view of ﬁrewall logs (events on the network) and
Traps™ ESM Server logs (security events on the endpoints) so that you can trace any suspicious or
malicious acvity.
For awareness and context on the events observed on the network and on your endpoints,
forward security events that the Traps agents report to the ESM Server on to Panorama.
Panorama can serve as a Syslog receiver that ingests these logs from the Traps ESM components
using Syslog over TCP, UDP, or SSL. Then, Panorama can correlate discrete security events that
occur on the endpoints with what’s happening on the network and generate match evidence. This
evidence gives you more context on the chronology and ﬂow of events to invesgate issues and
ﬁx security gaps in your network.
STEP 1 | Deﬁne the log ingeson proﬁle on Panorama and aach it to a Collector Group.
Panorama virtual appliance in legacy mode cannot ingest Traps logs.
1. Select Panorama > Log Ingeson Proﬁle, and click Add.
2. Enter a Name for the proﬁle.
3. Click Add and enter the details for the ESM Server. You can add up to four ESM Servers
to a proﬁle.
1. Enter a Source Name.
2. Specify the Port on which Panorama will be listening for syslog messages. The range is
23000 to 23999.
3. Select the Transport layer protocol—TCP, UDP, or SSL.
4. Select Traps_ESM for External Log type and your Traps ESM Version. For example, for
Traps ESM 4.0 or 4.1, select 3.4.1+.
As Traps log formats are updated, the updated log deﬁnions will be available through
content updates on Panorama.
4. Select Panorama > Collector Groups > Log Ingeson and Add the log ingeson proﬁle so
that the Collector Group can receive logs from the ESM Server(s) listed in the proﬁle.
If you are enabling SSL for secure syslog communicaon between Panorama and the
ESM Server(s), you must aach a cerﬁcate to the Managed Collectors that belong to the
Collector Group (Panorama > Managed Collectors > General, and select the cerﬁcate to
use for Inbound Cerﬁcate for Secure Syslog).
5. Commit changes to Panorama and the Collector Group.
STEP 2 | Conﬁgure Panorama as a Syslog receiver on the ESM Server.
Traps ESM 4.0 and later supports log forwarding to both an external syslog receiver and
Panorama. Because earlier Traps ESM releases do not support log forwarding to mulple syslog
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receivers, you must conﬁgure Panorama as a syslog receiver in the Syslog sengs (for Traps
ESM 3.4, see Enable Log Forwarding to an External Logging Plaorm).
For Traps ESM 4.0 and later releases:
1. From the ESM Console, select Sengs > ESM > Panorama, and Enable log forwarding to
Panorama.
2. Enter the Panorama hostname or IP address as the Panorama Server and the Panorama
Server Port on which Panorama is listening. Repeat this step for an oponal Panorama
Failover Server.
3. Select the Transport layer Communicaon Protocol: TCP, TCP with SSL, or UDP. If
you select TCP with SSL, the ESM Server requires a server cerﬁcate to enable client
authencaon.
From Panorama, you must export the root CA cerﬁcate for the Inbound Cerﬁcate for
Secure Syslog, and import the cerﬁcate in to the trusted root cerﬁcate store of the
host on which you have installed the ESM Server.
STEP 3 | View ESM logs and correlated events.
1. Select Monitor > External Logs > Traps ESM to view the logs ingested in to Panorama.
2. Select Monitor > Automated Correlaon Engine > Correlated Events, and ﬁlter on
the Wildﬁre and Traps ESM Correlated C2 correlaon object name to ﬁnd correlated
events. Panorama generates correlated events when a host on your network exhibits
command and control acvity that matches the behavior observed for a malicious ﬁle in
the WildFire virtual environment. This correlated event alerts you to suspicious acvity
that a Traps agent and the ﬁrewall have observed from one or more infected hosts on
your network.
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Use Case: Monitor Applicaons Using Panorama
This example takes you through the process of assessing the eﬃciency of your current policies
and determining where you need to adjust them to forfy the acceptable use policies for your
network.
When you log in to Panorama, the Top Applicaons widget on the Dashboard gives a preview of
the most used applicaons over the last hour. To display the widget, select Widgets > Applicaon
> Top Applicaons in the toolbar. You can either glance over the list of top applicaons and mouse
over each applicaon block for which you want to review the details, or you can select the ACC
tab to view the same informaon as an ordered list. The following image is a view of the Top
Applicaons widget on the Dashboard.

Figure 24: Top Applications Widget
The data source for this display is the applicaon stascs database; it does not use the Traﬃc
logs and is generated whether or not you have enabled logging for security rules. This view into
the traﬃc on your network depicts everything that is allowed on your network and is ﬂowing
through unblocked by any policy rules that you have deﬁned.
In the ACC tab, you can select and toggle the Data Source to be local on Panorama or you
can query the managed ﬁrewalls (Remote Device Data) for the data; Panorama automacally
aggregates and displays the informaon. For a speedier ﬂow, consider using Panorama as the
data source (with log forwarding to Panorama enabled) because the me to load data from the
managed ﬁrewalls varies by the me period for which you choose to view data and the volume of
traﬃc that is generated on your network. If your managed ﬁrewalls have a combinaon of PANOS 7.0 and earlier versions, Remote Device Data is not available.
The Dashboard example in Figure 24: Top Applicaons Widget shows DNS as a popular
applicaon. If you click the DNS applicaon block, Panorama opens the ACC > Network Acvity
tab with DNS applied as a global ﬁlter and shows informaon on the applicaon, users who
accessed the applicaon, and the details on the risk level and characteriscs of the applicaon.
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Figure 25: Network Activity Tab
In the User Acvity widget, you can see how many users are using DNS and the volume of traﬃc
being generated. If you have enabled User-ID, you can view the names of the users who are
generang this traﬃc, and drill in to review all the sessions, content or threats associated with
each user.
In the Threat Acvity tab, view the Compromised Hosts widget to see what correlaon objects
were matched on, and view the match evidence associated with the user and applicaon. You can
also view the threat name, category and ID in the Threat Acvity widget.
With DNS set as a global ﬁlter, use the Desnaon IP Acvity and the Desnaon Regions
widgets to verify where the traﬃc was desned. You can also view the ingress and egress zones
and the security rule that is leng this connecon through.
For more detailed informaon, jump into the Traﬃc logs
for a ﬁltered view and review each
log entry for ports used, packets sent, bytes sent and received. Adjust the columns to view more
informaon or less informaon based on your needs.
The Monitor > App-Scope > Traﬃc Map tab displays a geographical map of the traﬃc ﬂow and
provides a view of incoming versus outgoing traﬃc. You can also use the Monitor > App-Scope >
Change Monitor tab to view changes in traﬃc paerns. For example, compare the top applicaons
used over this hour to the last week or month to determine if there is a paern or trend.
With all the informaon you have now uncovered, you can evaluate what changes to make to your
policy conﬁguraons. Here are some suggesons to consider:
• Be restricve and create a pre-rule on Panorama to block or allow all DNS traﬃc. Then use
Panorama device groups to create and push this policy rule to one or more ﬁrewalls.
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• Enforce bandwidth use limits and create a QoS proﬁle and policy rule that de-priorizes nonbusiness traﬃc. Use Panorama device groups and templates to conﬁgure QoS and then push
rules to one or more ﬁrewalls.
• Schedule a custom report group that pulls together the acvity for the speciﬁc user and that of
top applicaons used on your network to observe that paern for another week or two before
taking acon.
Besides checking for a speciﬁc applicaon, you can also check for any unknown applicaons in
the list of top applicaons. These are applicaons that did not match a deﬁned App-ID™ signature
and display as unknown-udp and unknown-tcp. To delve into these unknown applicaons, click on
the name to drill down to the details for the unclassiﬁed traﬃc.
Use the same process to invesgate the top source IP addresses of the hosts that iniated the
unknown traﬃc along with the IP address of the desnaon host to which the session was
established. For unknown traﬃc, the traﬃc logs, by default, perform a packet capture (pcap) when
an unknown applicaon is detected. The green arrow in the le column represents the packet
capture snippet of the applicaon data. Clicking on the green arrow displays the pcap in the
browser.
Having the IP addresses of the servers (desnaon IP), the desnaon port, and the packet
captures, you will be beer posioned to idenfy the applicaon and make a decision on how
you would like to take acon on your network. For example, you can create a custom applicaon
that idenﬁes this traﬃc instead of labeling it as unknown TCP or UDP traﬃc. Refer to the arcle
Idenfying Unknown Applicaons for more informaon on idenfying unknown applicaon and
Custom Applicaon Signatures for informaon on developing custom signatures to discern the
applicaon.
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Use Case: Respond to an Incident Using Panorama
Network threats can originate from diﬀerent vectors, including malware and spyware infecons
due to drive-by downloads, phishing aacks, unpatched servers, and random or targeted denial of
service (DoS) aacks, to name a few methods of aack. The ability to react to a network aack or
infecon requires processes and systems that alert the administrator to an aack and provide the
necessary forensics evidence to track the source and methods used to launch the aack.
The advantage that Panorama provides is a centralized and consolidated view of the paerns and
logs collected from the managed ﬁrewalls across your network. You can use the informaon from
the automated correlaon engine alone or in conjuncon with the reports and logs generated
from a Security Informaon Event Manager (SIEM), to invesgate how an aack was triggered and
how to prevent future aacks and loss of damage to your network.
The quesons that this use case probes are:
• How are you noﬁed of an incident?
• How do you corroborate that the incident is not a false posive?
• What is your immediate course of acon?
• How do you use the available informaon to reconstruct the sequence of events that preceded
or followed the triggering event?
• What are the changes you need to consider for securing your network?
This use case traces a speciﬁc incident and shows how the visibility tools on Panorama can help
you respond to the report.
• Incident Noﬁcaon
• Review the Widgets in the ACC
• Review Threat Logs
• Review WildFire Logs
• Review Data Filtering Logs
• Update Security Rules

Incident Noﬁcaon
There are several ways that you could be alerted to an incident depending on how you’ve
conﬁgured the Palo Alto Networks ﬁrewalls and which third-party tools are available for further
analysis. You might receive an email noﬁcaon that was triggered by a log entry recorded
to Panorama or to your syslog server, or you might be informed through a specialized report
generated on your SIEM soluon, or a third-party paid service or agency might nofy you. For this
example, let’s say that you receive an email noﬁcaon from Panorama. The email informs you of
an event that was triggered by an alert for a Zero Access gent.Gen Command And Control Traﬃc
that matched against a spyware signature. Also listed in the email are the IP address of the source
and desnaon for the session, a threat ID and the mestamp of when the event was logged.
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Review the Widgets in the ACC
In the ACC > Threat Acvity tab, check the Compromised Hosts widget and Threat Acvity
widget for any crical or high severity threats. In the Compromised Hosts widget, look into the
Matching Objects and click a Match Count value to view the match evidence for the associated
incident.

Review Threat Logs
To begin invesgang the alert, use the threat ID to search the Threat logs on Panorama (Monitor
> Logs > Threat). From the Threat logs, you can ﬁnd the IP address of the vicm, export the packet
capture (PCAP) by clicking the download icon in the log entry, and use a network analyzer tool
such as WireShark to review the packet details. In the HTTP case, look for a malformed or bogus
HTTP REFERER in the protocol, suspicious host, URL strings, the user agent, the IP address and
port in order to validate the incident. Data from these pcaps is also useful in searching for similar
data paerns and creang custom signatures or modifying security policy to beer address the
threat in the future.
As a result of this manual review, if you feel conﬁdent about the signature, consider transioning
the signature from an alert acon to a block acon for a more aggressive approach. In some cases,
you may choose to add the aacker IP to an IP block list to prevent further traﬃc from that IP
address from reaching the internal network.
If you see a DNS-based spyware signature, the IP address of your local DNS server might
display as the Vicm IP address. Oen this is because the ﬁrewall is located north of the
local DNS server, and so DNS queries show the local DNS server as the source IP rather
than showing the IP address of the client that originated the request.
If you see this issue, enable the DNS sinkholing acon in the An-Spyware proﬁle in
security rules to idenfy the infected hosts on your network. DNS sinkholing allows you
to control outbound connecons to malicious domains and redirect DNS queries to an
internal IP address that is unused; the sinkhole that does not put out a response. When a
compromised host iniates a connecon to a malicious domain, instead of going out to the
internet, the ﬁrewall redirects the request to the IP address you deﬁned and it is sinkholed.
Now, reviewing the traﬃc logs for all hosts that connected to the sinkhole allows you
locate all compromised hosts and take remedial acon to prevent the spread.
To connue with the invesgaon on the incident, use the informaon on the aacker and the
vicm IP address to ﬁnd out more informaon, such as:
• Where is the aacker located geographically? Is the IP address an individual IP address or a
NATed IP address?
• Was the event caused by a user being tricked into going to a website, a download, or was it
sent through an email aachment?
• Is the malware being propagated? Are there other compromised hosts/endpoints on the
network?
• Is it a zero-day vulnerability?
The log details
for each log entry display the related logs for the event. This informaon points
you to the Traﬃc, Threat, URL Filtering or other logs that you can review and correlate the events
that led to the incident. For example, ﬁlter the Traﬃc log (Monitor > Logs > Traﬃc) using the IP
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address as both the source and the desnaon IP to get a complete picture of all the external and
internal hosts/clients with which this vicm IP address has established a connecon.

Review WildFire Logs
In addion to the Threat logs, use the vicm IP address to ﬁlter though the WildFire Submissions
logs. The WildFire Submissions logs contain informaon on ﬁles uploaded to the WildFire service
for analysis. Because spyware typically embeds itself covertly, reviewing the WildFire Submissions
logs tells you whether the vicm recently downloaded a suspicious ﬁle. The WildFire forensics
report displays informaon on the URL from which the ﬁle or .exe was obtained, and the behavior
of the content. It informs you if the ﬁle is malicious, if it modiﬁed registry keys, read/wrote into
ﬁles, created new ﬁles, opened network communicaon channels, caused applicaon crashes,
spawned processes, downloaded ﬁles, or exhibited other malicious behavior. Use this informaon
to determine whether to block the applicaon that caused the infecon (web-browsing, SMTP,
FTP), make more stringent URL Filtering rules, or restrict some applicaons/acons (for example,
ﬁle downloads to speciﬁc user groups).
Access to the WildFire logs from Panorama requires the following: a WildFire subscripon,
a File Blocking proﬁle that is aached to a Security rule, and Threat log forwarding to
Panorama.
If Panorama will manage ﬁrewalls running soware versions earlier than PAN-OS 7.0,
specify a WildFire server from which Panorama can gather analysis informaon for
WildFire samples that those ﬁrewalls submit. Panorama uses the informaon to complete
WildFire Submissions logs that are missing ﬁeld values introduced in PAN-OS 7.0. Firewalls
running earlier releases won’t populate those ﬁelds. To specify the server, select Panorama
> Setup > WildFire, edit the General Sengs, and enter the WildFire Private Cloud name.
The default is wildﬁre-public-cloud, which is the WildFire cloud hosted in the United
States.
If WildFire determines that a ﬁle is malicious, a new anvirus signature is created within 24-48
hours and made available to you. If you have a WildFire subscripon, the signature is made
available within 30-60 minutes as part of the next WildFire signature update. As soon as the Palo
Alto Networks next-generaon ﬁrewall has received a signature for it, if your conﬁguraon is
conﬁgured to block malware, the ﬁle will be blocked and the informaon on the blocked ﬁle will
be visible in your threat logs. This process is ghtly integrated to protect you from this threat and
stems the spread of malware on your network.

Review Data Filtering Logs
The Data Filtering log (Monitor > Logs > Data Filtering) is another valuable source for
invesgang malicious network acvity. While you can periodically review the logs for all the ﬁles
that you are being alerted on, you can also use the logs to trace ﬁle and data transfers to or from
the vicm IP address or user, and verify the direcon and ﬂow of traﬃc: server to client or client
to server. To recreate the events that preceded and followed an event, ﬁlter the logs for the vicm
IP address as a desnaon, and review the logs for network acvity.
Because Panorama aggregates informaon from all managed ﬁrewalls, it presents a good overview
of all acvity in your network. Some of the other visual tools that you can use to survey traﬃc on
your network are the Threat Map, Traﬃc Map, and the Threat Monitor. The threat map and traﬃc
map (Monitor > AppScope > Threat Map or Traﬃc Map) allow you to visualize the geographic
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regions for incoming and outgoing traﬃc. It is parcularly useful for viewing unusual acvity that
could indicate a possible aack from outside, such as a DDoS aack. If, for example, you do not
have many business transacons with Eastern Europe, and the map reveals an abnormal level of
traﬃc to that region, click into the corresponding area of the map to launch and view the ACC
informaon on the top applicaons, traﬃc details on the session count, bytes sent and received,
top sources and desnaons, users or IP addresses, and the severity of the threats detected, if
any. The threat monitor (Monitor > AppScope > Threat Monitor) displays the top ten threats on
your network, or the list of top aackers or top vicms on the network.

Update Security Rules
With all the informaon you have now uncovered, you can sketch together how the threat
impacts your network—the scale of the aack, the source, the compromised hosts, the risk factor
—and evaluate what changes, if any, to follow through. Here are some suggesons to consider:
• Forestall DDoS aacks by enhancing your DoS Protecon proﬁle to conﬁgure random early
drop or to drop SYN cookies for TCP ﬂoods. Consider placing limits on ICMP and UDP traﬃc.
Evaluate the opons available to you based on the trends and paerns you noced in your logs,
and implement the changes using Panorama templates.
Create a dynamic block list (Objects > Dynamic Block Lists), to block speciﬁc IP addresses that
you have uncovered from several intelligence sources: analysis of your own threat logs, DDoS
aacks from speciﬁc IP addresses, or a third-party IP block list.
The list must be a text ﬁle that is located on a web server. Using device groups on Panorama,
push the object to the managed ﬁrewalls so that the ﬁrewalls can access the web server and
import the list at a deﬁned frequency. Aer creang a dynamic block list object, deﬁne a
Security rule that uses the address object in the source and desnaon ﬁelds to block traﬃc
from or to the IP address, range, or subnet deﬁned. This approach allows you to block intruders
unl you resolve the issue and make larger policy changes to secure your network.
• Determine whether to create shared policy rules or device group rules to block speciﬁc
applicaons that caused the infecon (web-browsing, SMTP, FTP), make more stringent URL
Filtering rules, or restrict some applicaons/acons (for example, ﬁle downloads to speciﬁc
user groups).
• On Panorama, you can also switch to the ﬁrewall context and conﬁgure the ﬁrewall for Botnet
reports that idenfy potenal botnet-infected hosts on the network.
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To provide redundancy in case of a system or network failure, you can deploy two
Panorama™ management servers in a high availability (HA) conﬁguraon. Panorama
supports an HA conﬁguraon in which one peer is the acve-primary and the other
is the passive-secondary. If a failure occurs on the primary peer, it automacally fails
over and the secondary peer becomes acve.
> Panorama HA Prerequisites
> Priority and Failover on Panorama in HA
> Failover Triggers
> Logging Consideraons in Panorama HA
> Synchronizaon Between Panorama HA Peers
> Manage a Panorama HA Pair
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Panorama HA Prerequisites
To conﬁgure Panorama in HA, you require a pair of idencal Panorama servers with the following
requirements on each:
• The same form factor—The peers must be the same model: both M-600 appliances, M-500
appliances, M-200 appliances, or both deployed on the same supported hypervisor for
Panorama virtual appliances. For example, to successfully conﬁgure HA for a Panorama virtual
appliance deployed on AWS in Panorama mode, the HA peer must also be deployed on AWS
and be in Panorama mode.
• The same mode—The peers must be in the same Panorama mode: both running in Panorama
mode, Management Only mode, or Legacy mode (ESXi and vCloud Air only).
Panorama appliances in Log Collector mode do not support HA.
• The same Panorama OS version—Must run the same Panorama version to synchronize
conﬁguraon informaon and maintain parity for a seamless failover.
• The same set of licenses—Must have the same ﬁrewall management capacity license.
• (Panorama virtual appliance only) FIPCS-CC Mode—FIPS-CC mode must be enabled or disabled
on both Panorama HA peers.
• (Panorama virtual appliance only) Virtual Appliance Resources—Must have the same number of
vCPU cores and memory allocated to successfully synchronize conﬁguraon informaon.
• (Panorama virtual appliance only) Unique serial number—Must have unique serial numbers; if
the serial number is the same for both Panorama instances, they will be in suspended mode
unl you resolve the issue.
While it is recommended to match the number of logging disk and the logging disk
capacies between the Panorama HA peers, having a diﬀerent number logging disks
or diﬀerent logging disk capacies between the Panorama HA peers does not impact
conﬁguraon synchronizaon or HA failover
.
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Figure 26: Panorama HA Organization
The Panorama servers in the HA conﬁguraon are peers and you can use either (acve or passive)
to centrally manage the ﬁrewalls, Log Collectors, and WildFire appliances and appliance clusters,
with a few excepons (see Synchronizaon Between Panorama HA Peers). The HA peers use
the management (MGT) interface to synchronize the conﬁguraon elements pushed to the
managed ﬁrewalls, Log Collectors, and WildFire appliances and appliance clusters to maintain state
informaon. Typically, Panorama HA peers are geographically located in diﬀerent sites, so you
need to make sure that the MGT interface IP address assigned to each peer is routable through
your network. HA connecvity uses TCP port 28 with encrypon enabled. If encrypon is not
enabled, ports 28769 and 28260 are used for HA connecvity and to synchronize conﬁguraon
between the HA peers. We recommend less than 500ms latency between the peers. To determine
the latency, use Ping during a period of normal traﬃc.
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Priority and Failover on Panorama in HA
Each Panorama peer in the HA pair is assigned a priority value. The priority value of the primary or
secondary peer determines which will be eligible for being the main point of administraon and
log management. The peer set as primary assumes the acve state, and the secondary becomes
passive. The acve peer handles all the conﬁguraon changes and pushes them to the managed
ﬁrewalls; the passive peer cannot make any conﬁguraon changes or push conﬁguraon to the
managed ﬁrewalls. However, either peer can be used to run reports or to perform log queries.
The passive peer is synchronized and ready to transion to the acve state if a path, link, system,
or network failure occur on the acve Panorama.
When a failover occurs, only the state (acve or passive) of the Panorama peer changes; the
priority (primary and secondary) does not. For example, when the primary peer fails, its status
changes from acve-primary to passive-primary.
A peer in the acve-secondary state can perform all funcons with two excepons:
• It cannot manage ﬁrewall or Log Collector deployment funcons such as license updates or
soware upgrades.
• It cannot log to an NFS unl you manually change its priority to primary. Only the Panorama
virtual appliance in Legacy mode supports NFS.
The following table lists the capabilies of Panorama based on its state and priority sengs:

Figure 27: Panorama HA Capabilities
For more informaon, see Panorama HA Prerequisites or Set Up HA on Panorama.
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Failover Triggers
When a failure occurs on the acve Panorama and the passive Panorama takes over the task of
managing the ﬁrewalls, the event is called a failover. A failover is triggered when a monitored
metric on the acve Panorama fails. This failure transions the state on the primary Panorama
from acve-primary to passive-primary, and the secondary Panorama becomes acve-secondary.
The condions that trigger a failover are:
• The Panorama peers cannot communicate with each other and the acve peer does not
respond to health and status polls; the metric used is HA Heartbeat Polling and Hello
Messages.
When the Panorama peers cannot communicate with each other, the acve one monitors
whether the peers are sll connected before a failover is triggered. This check helps in avoiding
a failover and causing a split-brain scenario, where both Panorama peers are in an acve state.
• One or more of the desnaons (IP addresses) speciﬁed on the acve peer cannot be reached;
the metric used is HA Path Monitoring.
In addion to the failover triggers listed above, a failover also occurs when the administrator
places the Panorama peer in a suspended state or when preempon occurs. Preempon is a
preference for the primary Panorama to resume the acve role aer recovering from a failure (or
user-iniated suspension). By default, preempon is enabled and when the primary Panorama
recovers from a failure and becomes available, the secondary Panorama relinquishes control and
returns to the passive state. When preempon occurs, the event is logged in the System log.
If you are logging to an NFS datastore, do not disable preempon because it allows the primary
peer (that is mounted to the NFS) to resume the acve role and write to the NFS datastore. For all
other deployments, preempon is only required if you want to make sure that a speciﬁc Panorama
is the preferred acve peer.

HA Heartbeat Polling and Hello Messages
The HA peers use hello messages and heartbeats to verify that the peer is responsive and
operaonal. Hello messages are sent from one peer to the other at the conﬁgured Hello Interval to
verify the state of the other. The heartbeat is an ICMP ping to the HA peer, and the peer responds
to the ping to establish that the peers are connected and responsive. By default, the interval is
1,000 milliseconds for the heartbeat and 8,000ms for hello messages.

HA Path Monitoring
Path monitoring checks the network connecvity and link state for an IP address or group of IP
addresses (path group). The acve peer uses ICMP pings to verify that one or more desnaon
IP addresses can be reached. For example, you can monitor the availability of interconnected
networking devices like a router or a switch, connecvity to a server, or some other vital device
that is in the ﬂow of traﬃc. Make sure that the node/device conﬁgured for monitoring is not likely
to be unresponsive, especially when it comes under load, as this could cause a path monitoring
failure and trigger a failover.
The default ping interval is 5,000ms. An IP address is considered unreachable when three
consecuve pings (the default value) fail, and a peer failure is triggered when any or all of the IP
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addresses monitored become unreachable. By default, if any one of the IP addresses becomes
unreachable, the HA state transions to non-funconal.
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Logging Consideraons in Panorama HA
Seng up Panorama in an HA conﬁguraon provides redundancy for log collecon. Because
the managed ﬁrewalls are connected to both Panorama peers over SSL, when a state change
occurs, each Panorama sends a message to the managed ﬁrewalls. The ﬁrewalls are noﬁed of the
Panorama HA state and can forward logs accordingly.
By default, when the managed ﬁrewalls cannot connect to Panorama, they buﬀer the logs;
when the connecon is restored, they resume sending logs from where it was last le oﬀ.
The logging opons on the hardware-based Panorama and on the Panorama virtual appliance
diﬀer:
• Logging Failover on a Panorama Virtual Appliance in Legacy Mode
• Logging Failover on an M-Series Appliance or Panorama Virtual Appliance in Panorama Mode

Logging Failover on a Panorama Virtual Appliance in Legacy Mode
The Panorama virtual appliance in Legacy mode provides the following log failover opons:
Log Storage Type

Descripon

Virtual disk

By default, the managed ﬁrewalls send logs as independent streams
to each Panorama HA peer. By default, if a peer becomes unavailable,
the managed ﬁrewalls buﬀer the logs and when the peer reconnects it
resumes sending logs from where it had le oﬀ (subject to disk storage
capacity and duraon of the disconnecon).
The maximum log storage capacity depends on the virtual plaorm
(VMware ESXi or vCloud Air); see Panorama Models for details.
You can choose whether to forward logs only to the acve
peer (see Modify Log Forwarding and Buﬀering Defaults).
However, Panorama does not support log aggregaon
across the HA pair. Therefore, if you log to a virtual disk, for
monitoring and reporng you must query the Panorama peer
that collects the logs from the managed ﬁrewalls.

Network File System
(NFS)

You can mount NFS storage only to a Panorama virtual appliance that
runs on a VMware ESXi server. Only the acve-primary Panorama
mounts to the NFS-based log paron and can receive logs. On failover,
the primary device goes into a passive-primary state. In this scenario,
unl preempon occurs, the acve-secondary Panorama manages the
ﬁrewalls, but it does not receive the logs and it cannot write to the
NFS. To allow the acve-secondary peer to log to the NFS, you must
manually switch it to primary so that it can mount to the NFS paron.
For instrucons, see Switch Priority aer Panorama Failover to Resume
NFS Logging.
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Logging Failover on an M-Series Appliance or Panorama Virtual
Appliance in Panorama Mode
If you forward ﬁrewall logs to the local Log Collectors on an HA pair of M-600 appliances, M-500
appliances, M-200 appliances, or Panorama virtual appliances in Panorama mode, you specify
which ﬁrewalls send logs to which Log Collectors when you Conﬁgure a Collector Group. You can
conﬁgure a separate Collector Group for the Log Collector of each Panorama peer or conﬁgure
a single Collector Group to contain the Log Collectors of both peers. In a Collector Group that
contains both local Log Collectors, the log forwarding preference list determines which Log
Collector receives logs from ﬁrewalls. For all managed ﬁrewalls, you have the opon to send logs
to all the Log Collectors in the Collector Group, in which case Panorama uses round-robin load
balancing to select which Log Collector receives the logs at any given moment.
In a Collector Group that contains both Log Collectors, you can also enable redundancy so
that each log will have two copies and each copy will reside on a diﬀerent Log Collector. This
redundancy ensures that, if any one Log Collector becomes unavailable, no logs are lost: you can
see all the logs forwarded to the Collector Group and run reports for all the log informaon. Log
redundancy is available only if each Log Collector in the Collector Group has the same number of
disks.
All the Log Collectors for any parcular Collector Group must be the same model: all
M-200 appliances all M-500 appliances, all M-600 appliances or all Panorama virtual
appliances in Panorama mode.
Because enabling redundancy creates more logs, this conﬁguraon requires more storage
capacity. Enabling redundancy doubles the log processing traﬃc in a Collector Group,
which reduces its maximum logging rate by half, as each Log Collector must distribute a
copy of each log it receives. (When a Collector Group runs out of space, it deletes older
logs.)
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Synchronizaon Between Panorama HA Peers
The Panorama HA peers synchronize the running conﬁguraon each me you commit changes on
the acve Panorama peer. The candidate conﬁguraon is synchronized between the peers each
me you save the conﬁguraon on the acve peer or just before a failover occurs.
Sengs that are common across the pair, such as shared objects and policy rules, device
group objects and rules, template conﬁguraon, cerﬁcates and SSL/TLS service proﬁles, and
administrave access conﬁguraon, are synchronized between the Panorama HA peers.
When you Enable Automated Commit Recovery, HA synchronizaon occurs only aer the ﬁrewall
successfully tests the connecon between itself and Panorama aer a push from Panorama.
The sengs that are not synchronized are those that are unique to each peer, such as the
following:
• Panorama HA conﬁguraon—Priority seng, peer IP address, path monitoring groups and IP
addresses
• Panorama conﬁguraon—Management interface IP address, FQDN sengs, login banner,
NTP server, me zone, geographic locaon, DNS server, permied IP addresses for accessing
Panorama, SNMP system sengs, and dynamic content update schedules
• Scheduled conﬁguraon exports
• NFS paron conﬁguraon and all disk quota allocaon for logging. This applies only to a
Panorama virtual appliance in Legacy mode that runs on a VMware ESXi server
• Disk quota allocaon for the diﬀerent types of logs and databases on the Panorama local
storage (SSD)
If you use a master key to encrypt the private keys and cerﬁcates on Panorama, you
must use the same master key on both HA peers. If the master keys diﬀer, Panorama
cannot synchronize the HA peers.
• Password for the Panorama admin administrator
For more informaon, see Panorama HA Prerequisites or Set Up HA on Panorama.
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Manage a Panorama HA Pair
• Set Up HA on Panorama
• Set Up Authencaon Using Custom Cerﬁcates Between HA Peers
• Test Panorama HA Failover
• Switch Priority aer Panorama Failover to Resume NFS Logging
• Restore the Primary Panorama to the Acve State
To install soware or content updates, see Install Updates for Panorama in an HA
Conﬁguraon.

Set Up HA on Panorama
Review the Panorama HA Prerequisites before performing the following steps.
If you conﬁgure Secure Communicaon Sengs between Panorama HA peers, the
Panorama HA peers use the custom cerﬁcate speciﬁed for authencaon one another.
Otherwise, the Panorama HA peers use the predeﬁned cerﬁcate for authencaon.
Regardless of how you conﬁgure the Panorama HA peers to authencate communicaon,
neither will impact the ability for the Panorama HA peers to communicate with one
another.
STEP 1 | Set up connecvity between the MGT ports on the HA peers.
The Panorama peers communicate with each other using the MGT port. Make sure that the
IP addresses you assign to the MGT port on the Panorama servers in the HA pair are routable
and that the peers can communicate with each other across your network. To set up the MGT
port, see Perform Inial Conﬁguraon of the Panorama Virtual Appliance or Perform Inial
Conﬁguraon of the M-Series Appliance.
Pick a Panorama peer in the pair and complete the remaining tasks.
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STEP 2 | Enable HA and (oponally) enable encrypon for the HA connecon.
1. Select Panorama > High Availability and edit the Setup secon.
2. Select Enable HA.
3. In the Peer HA IP Address ﬁeld, enter the IP address assigned to the peer Panorama.
4. In the Peer HA Serial ﬁeld, enter the serial number of the peer Panorama.
Enter the Panorama HA peer serial number to reduce your aack surface against brute
force aacks on the Panorama IP.
5. In the Monitor Hold Time ﬁeld, enter the length of me (milliseconds) that the system
will wait before acng on a control link failure (range is 1000-60000, default is 3000).
6. If you do not want encrypon, clear the Encrypon Enabled check box and click OK: no
more steps are required. If you do want encrypon, select the Encrypon Enabled check
box, click OK, and perform the following tasks:
1. Select Panorama > Cerﬁcate Management > Cerﬁcates.
2. Select Export HA key. Save the HA key to a network locaon that the peer Panorama
can access.
3. On the peer Panorama, navigate to Panorama > Cerﬁcate Management >
Cerﬁcates, select Import HA key, browse to the locaon where you saved the key,
and import it.
STEP 3 | Set the HA priority.
1. In Panorama > High Availability, edit the Elecon Sengs secon.
2. Deﬁne the Device Priority as Primary or Secondary. Make sure to set one peer as
primary and the other as secondary.
If both peers have the same priority seng, the peer with the higher serial
number will be placed in a suspended state.
3. Deﬁne the Preempve behavior. By default preempon is enabled. The preempon
selecon—enabled or disabled—must be the same on both peers.
If you are using an NFS for logging and you have disabled preempon, to resume
logging to the NFS see Switch Priority aer Panorama Failover to Resume
NFS Logging.
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STEP 4 | To conﬁgure path monitoring, deﬁne one or more path groups.
The path group lists the desnaon IP addresses (nodes) that Panorama must ping to verify
network connecvity.
Perform the following steps for each path group that includes the nodes that you want to
monitor.
1. Select Panorama > High Availability and, in the Path Group secon, click Add.
2. Enter a Name for the path group.
3. Select a Failure Condion for this group:
• any triggers a path monitoring failure if any one of the IP addresses becomes
unreachable.
• all triggers a path monitoring failure only when none of the IP addresses are
reachable.
4. Add each desnaon IP address you want to monitor.
5. Click OK. The Path Group secon displays the new group.
STEP 5 | (Oponal) Select the failure condion for path monitoring on Panorama.
1. Select Panorama > High Availability and edit the Path Monitoring secon.
2. Select a Failure Condion:
• all triggers a failover only when all monitored path groups fail.
• any triggers a failover when any monitored path group fails.
3. Click OK.
STEP 6 | Commit your conﬁguraon changes.
Select Commit > Commit to Panorama and Commit your changes.
STEP 7 | Conﬁgure the other Panorama peer.
Repeat Step 2 through Step 6 on the other peer in the HA pair.
STEP 8 | Synchronize the Panorama peers.
1. Access the Dashboard on the acve Panorama and select Widgets > System > High
Availability to display the HA widget.
2. Sync to peer, click Yes, and wait for the Running Conﬁg to display Synchronized.
3. Access the Dashboard on the passive Panorama and select Widgets > System > High
Availability to display the HA widget.
4. Verify that the Running Conﬁg displays Synchronized.
STEP 9 | (Oponal) Set Up Authencaon Using Custom Cerﬁcates Between HA Peers.
You must conﬁgure the Secure Communicaon Sengs for both Panorama HA peers.
Conﬁguring Secure Communicaon Sengs for Panorama in HA conﬁguraon does not impact
HA connecvity between the HA peers. However, funconality that goes over the Secure
Communicaon link may fail if the Secure Communicaon Sengs are conﬁgured incorrectly,
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or if the HA peer or managed ﬁrewalls do not have the correct cerﬁcate, or have an expired
cerﬁcate.
All traﬃc on the link established by conﬁguring the Secure Communicaon Sengs is always
encrypted.
If you conﬁgure Secure Communicaon Sengs for Panorama in a HA conﬁguraon, it
is required to Customize Secure Server Communicaon as well. Otherwise, managed
ﬁrewalls and WildFire appliances are unable to connect to Panorama and PAN-OS
funconality is impacted.

Set Up Authencaon Using Custom Cerﬁcates Between HA
Peers
You can Set Up Authencaon Using Custom Cerﬁcates for securing the HA connecon
between Panorama HA peers.
STEP 1 | Generate a cerﬁcate authority (CA) cerﬁcate on Panorama.
1. Select Panorama > Cerﬁcate Management > Cerﬁcates.
2. Create a self-signed root CA cerﬁcate or import a cerﬁcate from your enterprise CA.
STEP 2 | Conﬁgure a cerﬁcate proﬁle that includes the root CA and intermediate CA.
1. Select Panorama > Cerﬁcate Management > Cerﬁcate Proﬁle.
2. Conﬁgure a cerﬁcate proﬁle.
STEP 3 | Conﬁgure an SSL/TLS service proﬁle.
1. Select Panorama > Cerﬁcate Management > SSL/TLS Service Proﬁle.
2. Conﬁgure an SSL/TLS proﬁle to deﬁne the cerﬁcate and protocol that Panorama and its
manage devices use for SSL/TLS services.
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STEP 4 | Conﬁgure Secure Communicaon Sengs on Panorama on the primary HA peer.
If you conﬁgure Secure Communicaon Sengs on Panorama for Panorama in a
HA conﬁguraon, it is required to Customize Secure Server Communicaon as well.
Otherwise, managed ﬁrewalls, Dedicated Log Collectors, and WildFire appliances are
unable to connect to Panorama and PAN-OS funconality is impacted.
1. Select Panorama > Setup > Management and Edit the Secure Communicaon Sengs.
2. For the Cerﬁcate Type, select Local.
3. Select the Cerﬁcate and Cerﬁcate Proﬁle you conﬁgured in the previous steps.
4. Check (enable) HA Communicaon, WildFire Communicaon, and Data Redistribuon.
5. Check (enable) Customize Secure Server Communicaon.
6. Select the SSL/TLS service proﬁle from the SSL/TLS Service Proﬁle drop-down. This
SSL/TLS service proﬁle applies to all SSL connecons between Panorama, ﬁrewalls, Log
Collectors, and Panorama’s HA peers.
7. Select the cerﬁcate proﬁle from the Cerﬁcate Proﬁle drop-down.
8. Conﬁgure an authorizaon list.
When you conﬁgure Secure Communicaon Seng for Panorama in a
HA conﬁguraon, you are required to add the Panorama HA peer to the
authorizaon list.
1. Click Add under Authorizaon List.
2. Select the Subject or Subject Alt Name as the Idenﬁer type.
3. Enter the Common Name
9. (Oponal) Verify that Allow Custom Cerﬁcate Only check box is not selected. This
allows you to connue managing all devices while migrang to custom cerﬁcates.
When Allow Custom Cerﬁcate Only check box is selected, Panorama does not
authencate and cannot manage devices using predeﬁned cerﬁcates.
10. In Disconnect Wait Time (min), enter the number of minutes Panorama should before
breaking and reestablishing the connecon with its managed devices. This ﬁeld is blank
by default and the range is 0 to 44,640 minutes.
The disconnect wait me does not begin counng down unl you commit the
new conﬁguraon.
1. Click OK.
2. Commit and Commit to Panorama.
3. Repeat this step on the secondary Panorama HA peer.
When you conﬁgure Secure Communicaon Sengs on the secondary Panorama HA
peer, add the primary HA peer to the authorizaon list as described above.
STEP 5 | Upgrade the client-side Panorama to PAN-OS 10.1.
Upgrade Panorama.
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Test Panorama HA Failover
To test that your HA conﬁguraon works properly, trigger a manual failover and verify that the
peer transions states successfully.
STEP 1 | Log in to the acve Panorama peer.
You can verify the state of the Panorama server in the boom right corner of the web
interface.
STEP 2 | Suspend the acve Panorama peer.
Select Panorama > High Availability, and then click the Suspend local Panorama link in the
Operaonal Commands secon.
STEP 3 | Verify that the passive Panorama peer has taken over as acve.
On the Panorama Dashboard, High Availability widget, verify that the state of the Local
passive server is acve and the state of the Peer is suspended.
STEP 4 | Restore the suspended peer to a funconal state. Wait for a couple minutes, and then verify
that preempon has occurred, if preempve is enabled.
On the Panorama you previously suspended:
1. Select Panorama > High Availability and, in the Operaonal Commands secon, click
Make local Panorama funconal.
2. In the High Availability widget on the Dashboard, conﬁrm that this (Local) Panorama has
taken over as the acve peer and that the other peer is now in a passive state.

Switch Priority aer Panorama Failover to Resume NFS Logging
The Panorama virtual appliance in Legacy mode running on an ESXi server can use an NFS
datastore for logging. In an HA conﬁguraon, only the primary Panorama peer is mounted to
the NFS-based log paron and can write to the NFS. When a failover occurs and the passive
Panorama becomes acve, its state becomes acve-secondary. Although a secondary Panorama
peer can acvely manage the ﬁrewalls, it cannot receive logs or write to the NFS because it does
not own the NFS paron. When the ﬁrewalls cannot forward logs to the primary Panorama peer,
each ﬁrewall writes the logs to its local disk. The ﬁrewalls maintain a pointer for the last set of log
entries that they forwarded to Panorama so that when the passive-primary Panorama becomes
available again, they can resume forwarding logs to it.
Use the instrucons in this secon to manually switch priority on the acve-secondary Panorama
peer so that it can begin logging to the NFS paron. The typical scenarios in which you might
need to trigger this change are as follows:
• Preempon is disabled. By default, preempon is enabled on Panorama and the primary peer
resumes as acve when it becomes available again. When preempon is disabled, you need to
switch the priority on the secondary peer to primary so that it can mount the NFS paron,
receive logs from the managed ﬁrewalls, and write to the NFS paron.
• The acve Panorama fails and cannot recover from the failure in the short term. If you do not
switch the priority, when the maximum log storage capacity on the ﬁrewall is reached, the
oldest logs will be overwrien to enable it to connue logging to its local disk. This situaon
can lead to loss of logs.
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STEP 1 | Log in to the currently passive-primary Panorama, select Panorama > Setup > Operaons
and, in the Device Operaons secon, click Shutdown Panorama.
STEP 2 | Log in to the acve-secondary Panorama, select Panorama > High Availability, edit the
Elecon Sengs, and set the Priority to Primary.
STEP 3 | Click OK to save your changes.
STEP 4 | Select Commit > Commit to Panorama and Commit your changes.
Do not reboot when prompted.
STEP 5 | Log in to the Panorama CLI and enter the following command to change the ownership of the
NFS paron to this peer: request high-availability convert-to-primary
STEP 6 | Select Panorama > Setup > Operaons and, in the Device Operaons secon, click Reboot
Panorama.
STEP 7 | Power on the Panorama peer that you powered oﬀ in step 1. This peer will now be in a
passive-secondary state.

Restore the Primary Panorama to the Acve State
By default, the preempve capability on Panorama allows the primary Panorama to resume
funconing as the acve peer as soon as it becomes available. However, if preempon is disabled,
the only way to force the primary Panorama to become acve aer recovering from a failure, a
non-funconal, or a suspended state, is by suspending the secondary Panorama peer.
Before the acve-secondary Panorama goes into a suspended state, it transfers the candidate
conﬁguraon to the passive Panorama so that all your uncommied conﬁguraon changes are
saved and can be accessed on the other peer.
STEP 1 | Suspend Panorama.
1. Log in to the Panorama peer that you want to place in a suspended state.
2. Select Panorama > High Availability, and click the Suspend local Panorama link in the
Operaonal Commands secon.
STEP 2 | Verify that the status indicates that the Panorama was suspended at user request.
On the Dashboard, High Availability widget, verify that the Local state is suspended.
A failover is triggered when you suspend a peer, and the other Panorama takes over as the
acve peer.
STEP 3 | Restore the suspended Panorama to a funconal state.
1. In the Panorama > High Availability tab, Operaonal Commands secon, click the Make
local Panorama funconal link.
2. On the Dashboard, High Availability widget, conﬁrm that the Panorama has transioned
to either the acve or passive state.
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This secon describes how to administer and maintain the Panorama™ management
server. It includes the following topics:
>

Preview, Validate, or Commit
Conﬁguraon Changes

>

Enable Automated Commit Recovery

>

Manage Panorama and Firewall
Conﬁguraon Backups

>

Compare Changes in Panorama
Conﬁguraons

>

Manage Locks for Restricng
Conﬁguraon Changes

>

Add Custom Logos to Panorama

>

Use the Panorama Task Manager

>

Manage Storage Quotas and
Expiraon Periods for Logs and
Reports

>

Monitor Panorama

>

Reboot or Shut Down Panorama

>

Conﬁgure Panorama Password
Proﬁles and Complexity

For instrucons on compleng inial setup, including deﬁning network access sengs,
licensing, upgrading the Panorama soware version, and seng up administrave
access to Panorama, see Set Up Panorama.
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Preview, Validate, or Commit Conﬁguraon Changes
You can perform Panorama Commit, Validaon, and Preview Operaons on pending changes to
the Panorama conﬁguraon and then push those changes to the devices that Panorama manages,
including ﬁrewalls, Log Collectors, and WildFire appliances and appliance clusters. You can ﬁlter
the pending changes by administrator or locaon and then commit, push, validate, or preview
only those changes. The locaons can be speciﬁc device groups, templates, Collector Groups, Log
Collectors, shared sengs, or the Panorama management server.
Because Panorama pushes its running conﬁguraon, you cannot push changes to devices unl
you ﬁrst commit them to Panorama. If the changes are not ready to acvate on devices, you can
select Commit > Commit to Panorama to commit the changes to the Panorama conﬁguraon
without pushing them to devices. Later, when the changes are ready to acvate on devices, you
can select Commit > Push to Devices. If the changes are ready to acvate on both Panorama and
the devices, select Commit > Commit and Push as described in the following procedure.
STEP 1 | Conﬁgure the scope of conﬁguraon changes that you will commit, validate, or preview.
1. Click Commit at the top of the web interface.
2. Select one of the following opons:
• Commit All Changes (default)—Applies the commit to all changes for which you have
administrave privileges. You cannot manually ﬁlter the commit scope when you
select this opon. Instead, the administrator role assigned to the account you used to
log in determines the commit scope.
• Commit Changes Made By—Enables you to ﬁlter the commit scope by administrator
or locaon. The administrave role assigned to the account you used to log in
determines which changes you can ﬁlter.
To commit the changes of other administrators, the account you used to log in
must be assigned the Superuser role or an Admin Role proﬁle with the Commit
For Other Admins privilege enabled.
3. (Oponal) To ﬁlter the commit scope by administrator, select Commit Changes Made By,
click the adjacent link, select the administrators, and click OK.
4. (Oponal) To ﬁlter by locaon, select Commit Changes Made By and clear any changes
that you want to exclude from the Commit Scope.
If dependencies between the conﬁguraon changes you included and excluded
cause a validaon error, perform the commit with all the changes included. For
example, when you commit changes to a device group, you must include the
changes of all administrators who added, deleted, or reposioned rules for the
same rulebase in that device group.
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STEP 2 | Preview the changes that the commit will acvate.
When you preview changes aer you delete and then re-add the same device to
a policy rule, Panorama displays that same device as both deleted in the running
conﬁguraon and as added in the candidate conﬁguraon. Addionally, the order of
devices in the device target list in the running conﬁguraon may then be diﬀerent from
the candidate conﬁguraon and display as a change when you preview changes even
when there aren't any conﬁguraon changes.
This can be useful if, for example, you don’t remember all your changes and you’re not sure you
want to acvate all of them.
Panorama compares the conﬁguraons you selected in the Commit Scope to the running
conﬁguraon. The preview window displays the conﬁguraons side-by-side and uses color
coding to indicate which changes are addions (green), modiﬁcaons (yellow), or deleons
(red).
Preview Changes and select the Lines of Context, which is the number of lines from the
compared conﬁguraon ﬁles to display before and aer the highlighted diﬀerences. These
lines help you correlate the preview output to sengs in the web interface. Close the preview
window when you ﬁnish reviewing the changes.
Because the preview results display in a new window, your browser must allow pop-up
windows. If the preview window does not open, refer to your browser documentaon
for the steps to unblock pop-up windows.
STEP 3 | Preview the individual sengs for which you are comming changes.
This can be useful if you want to know details about the changes, such as the types of sengs
and who changed them.
1. Click Change Summary.
2. (Oponal) Group By a column name (such as the Type of seng).
3. Close the Change Summary dialog when you ﬁnish reviewing the changes.
STEP 4 | Validate the changes before comming to ensure the commit will succeed.
1. Validate Changes.
The results display all the errors and warnings that an actual commit would display.
2. Resolve any errors that the validaon results idenfy.
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STEP 5 | (Oponal) Modify the Push Scope.
By default, the Push Scope includes all locaons with changes that require a Panorama commit.
If you select Commit > Push to Devices, the push scope includes all locaons
associated with devices that are out of sync with the Panorama running conﬁguraon.
1. No Default Selecons to manually select speciﬁc devices. The default devices Panorama
pushes to are based on the impacted device group and template conﬁguraon changes.
2. Edit Selecons and select:
• Device Groups—Select device groups or individual ﬁrewalls or virtual systems.
• Templates—Select templates, template stacks, or individual ﬁrewalls.
• Collector Groups—Select Collector Groups.
3. Click OK to save your changes to the Push Scope.
STEP 6 | Validate the changes you will push to device groups or templates.
1. Validate Device Group Push or Validate Template Push.
The results display all the errors and warnings that an actual push operaon would
display.
2. Resolve any errors that the validaon results idenfy.
STEP 7 | Commit your changes to Panorama and push the changes to devices.
Commit and Push the conﬁguraon changes.
Use the Panorama Task Manager to see details about commits that are pending
(oponally, you can cancel these), in progress, completed, or failed.
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Enable Automated Commit Recovery
To ensure that broken conﬁguraons caused by conﬁguraon changes pushed from the
Panorama™ management server to managed ﬁrewalls, or commied locally on the ﬁrewall, enable
Automated Commit Recovery to enable managed ﬁrewalls to test conﬁguraon changes for
each commit and to verify that the changes did not break the connecon between Panorama
and the managed ﬁrewall. You can conﬁgure the number of tests that each managed ﬁrewall
performs and the interval at which each test occurs before the managed ﬁrewall automacally
reverts its conﬁguraon back to the previous running conﬁguraon. When you enable automated
commit recovery, the managed ﬁrewall conﬁguraon reverts and not the Panorama conﬁguraon.
Addionally, the managed ﬁrewall tests its connecon to Panorama every 60 minutes to ensure
connued communicaon in the event unrelated network conﬁguraon changed disrupted
connecvity between the ﬁrewall and Panorama or if impacts from a past commied conﬁguraon
aﬀected connecvity. For high availability (HA) conﬁguraons, HA synchronizaon between the
HA peers aer a push from Panorama occurs only aer a connecvity test.
Automated commit recovery is enabled by default. However, if you disabled automated commit
recovery and then want to re-enable this feature in an exisng producon environment, ﬁrst verify
that there are no policy rules that will break the connecon between Panorama and the managed
ﬁrewall. For example, in the event where management traﬃc traverses the dataplane, it is possible
there is a policy rule that restricts traﬃc from the ﬁrewall to Panorama.
The ﬁrewall generates a conﬁg log aer the ﬁrewall conﬁguraon successfully reverts to the last
running conﬁguraon. Addionally, the ﬁrewall generates a system log when the administrator
disables this feature, when a conﬁguraon revert event begins due to a connecvity test that fails
aer a conﬁguraon push, and when the Panorama connecvity test that is performed every 60
minutes fails and causes the ﬁrewall conﬁguraon to revert.
Enable Automated Commit Recovery independent of any other conﬁguraon change.
If enabled alongside any other conﬁguraon changes that result in a connecon break
between Panorama and managed ﬁrewalls, the ﬁrewall conﬁguraon cannot automacally
revert.
STEP 1 | Log in to the Panorama Web Interface.
STEP 2 | Select Device > Setup > Management and select the desired Template or Template Stack
from the Template context drop-down.
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STEP 3 | Enable automated commit recovery.
1. Edit ( ) the Panorama Sengs.
2. Enable automated commit recovery.
3. Conﬁgure the Number of aempts to check for Panorama connecvity (default is 1
aempt).
4. Conﬁgure the Interval between retries (default is 10 seconds).
5. Click OK to save your changes.

STEP 4 | Commit > Commit and Push and Commit and Push your changes.
STEP 5 | Verify that the automated commit recovery feature is enabled on your managed ﬁrewalls.
1. Launch the Firewall Web Interface.
2. Select Device > Setup > Management and, in the Panorama Sengs, verify that Enable
automated commit recovery is enabled (checked).
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Manage Panorama and Firewall Conﬁguraon Backups
The running conﬁguraon on Panorama comprises all the sengs that you have commied and
that are therefore acve. The candidate conﬁguraon is a copy of the running conﬁguraon plus
any inacve changes that you made since the last commit. Saving backup versions of the running
or candidate conﬁguraon enables you to later restore those versions. For example, if a commit
validaon shows that the current candidate conﬁguraon has more errors than you want to ﬁx,
you can restore a previous candidate conﬁguraon. You can also revert to the current running
conﬁguraon without saving a backup ﬁrst.
See Panorama Commit, Validaon, and Preview Operaons for more informaon on
comming conﬁguraon changes to Panorama and pushing the changes to managed
devices.
Aer a commit on a local ﬁrewall that runs PAN-OS 5.0 or later, a backup is sent of its running
conﬁguraon to Panorama. Any commits performed on the local ﬁrewall will trigger the backup,
including commits that an administrator performs locally on the ﬁrewall or automac commits that
PAN-OS iniates (such as an FQDN refresh). By default, Panorama stores up to 100 backups for
each ﬁrewall, though this is conﬁgurable. To store Panorama and ﬁrewall conﬁguraon backups
on an external host, you can schedule exports from Panorama or export on demand. You can also
import conﬁguraons from ﬁrewalls into Panorama device groups and templates to Transion a
Firewall to Panorama Management.
(VMware ESXi and vCloud Air only) VMware snapshot funconality is not supported for a
Panorama virtual appliance deployed on VMware ESXi and vCloud Air. Taking snapshots of a
Panorama virtual appliance can impact performance, result in intermient and inconsistent packet
loss, and Panorama may become unresponsive. Addionally, you may lose access to the Panorama
CLI and web interface and switching to Panorama mode is not supported. Instead, save and export
your named conﬁguraon snapshot to any network locaon.
• Schedule Export of Conﬁguraon Files
• Save and Export Panorama and Firewall Conﬁguraons
• Revert Panorama Conﬁguraon Changes
• Conﬁgure the Maximum Number of Conﬁguraon Backups on Panorama
• Load a Conﬁguraon Backup on a Managed Firewall

Schedule Export of Conﬁguraon Files
Panorama saves a backup of its running conﬁguraon as well as the running conﬁguraons of
all managed ﬁrewalls. The backups are in XML format with ﬁle names that are based on serial
numbers (of Panorama or the ﬁrewalls). Use these instrucons to schedule daily exports of
the backups to a remote host. Panorama exports the backups as a single gzip ﬁle. You require
superuser privileges to schedule the export.
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If Panorama has a high availability (HA) conﬁguraon, you must perform these instrucons
on each peer to ensure the scheduled exports connue aer a failover. Panorama does not
synchronize scheduled conﬁguraon exports between HA peers.
To export backups on demand, see Save and Export Panorama and Firewall
Conﬁguraons.
STEP 1 | Select Panorama > Scheduled Conﬁg Export and click Add.
STEP 2 | Enter a Name and Descripon for the scheduled ﬁle export and Enable it.
STEP 3 | Using the 24-hour clock format, enter a daily Scheduled Export Start Time or select one from
the drop-down.
If you are conﬁguring a scheduled export to two or more servers, stagger the start me
of the scheduled exports. Scheduling mulple exports at the same start me results in
discrepancies between the exported conﬁguraons.
STEP 4 | Set the export Protocol to Secure Copy (SCP) or File Transfer Protocol (FTP).
Export to devices running Windows support only FTP.
STEP 5 | Enter the details for accessing the server, including: Hostname or IP address, Port, Path for
uploading the ﬁle, Username, and Password.
The Path supports the following characters: .(period), +, { and }, /, -, _, 0-9, a-z, and A-Z.
Spaces are not supported in the ﬁle Path.
If you are exporng to an FTP server using an IPv6 address as the Hostname,
you must enter the address enclosed in square brackets ([ ]). For example,
[2001:0db8:0000:0000:0000:8a2e:0370:7334].
If you are exporng to a BSD server, you will need to modify the SSHD password
prompt to <username>@<hostname> <password>: .
STEP 6 | (SCP only) Click Test SCP server connecon. To enable the secure transfer of data, you must
verify and accept the host key of the SCP server. Panorama doesn’t establish the connecon
unl you accept the host key. If Panorama has an HA conﬁguraon, perform this step on
each HA peer so that each one accepts the host key of the SCP server. If Panorama can
successfully connect to the SCP server, it creates and uploads the test ﬁle named ssh-exporttest.txt.
STEP 7 | Click OK to save your changes.
STEP 8 | Select Commit > Commit to Panorama and Commit your changes.

Save and Export Panorama and Firewall Conﬁguraons
Saving a backup of the candidate conﬁguraon to persistent storage on Panorama enables
you to later restore that backup (see Revert Panorama Conﬁguraon Changes). Addionally,
Panorama allows you to save and export the device group, template, and template stack
conﬁguraons that you specify. This is useful for preserving changes that would otherwise be lost
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if a system event or administrator acon causes Panorama to reboot. Aer reboong, Panorama
automacally reverts to the current version of the running conﬁguraon, which Panorama stores
in a ﬁle named running-config.xml. Saving backups is also useful if you want to revert to
a Panorama conﬁguraon that is earlier than the current running conﬁguraon. Panorama does
not automacally save the candidate conﬁguraon to persistent storage. You must manually save
the candidate conﬁguraon as a default snapshot ﬁle (.snapshot.xml) or as a custom-named
snapshot ﬁle. Panorama stores the snapshot ﬁle locally but you can export it to an external host.
You don’t have to save a conﬁguraon backup to revert the changes made since the
last commit or reboot; just select Conﬁg > Revert Changes (see Revert Panorama
Conﬁguraon Changes).
Palo Alto Networks recommends that you back up any important conﬁguraons to an
external host.
STEP 1 | Save changes to the candidate conﬁguraon.
• To overwrite the default snapshot ﬁle (.snapshot.xml) with all the changes that all
administrators made, perform one of the following steps:
• Select Panorama > Setup > Operaons and Save candidate Panorama conﬁguraon.
• Log in to Panorama with an administrave account that is assigned the Superuser role
or an Admin Role proﬁle with the Save For Other Admins privilege enabled. Then select
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Conﬁg > Save Changes at the top of the web interface, select Save All Changes and
Save.
• To overwrite the default snapshot (.snapshot.xml) with changes made by administrators
to speciﬁc device group, template, or template stack conﬁguraons:
1. Select Panorama > Setup > Operaons, Save candidate Panorama conﬁguraon, and
Select Device Group & Templates.
2. Select the speciﬁc device groups, templates, or template stacks to revert.
3. Click OK to conﬁrm the operaon.
4. (Oponal) Select Commit > Commit to Panorama and Commit your changes to overwrite
the running conﬁguraon with the snapshot.
• To create a snapshot that includes all the changes that all administrators made but without
overwring the default snapshot ﬁle:
1. Select Panorama > Setup > Operaons and Save named Panorama conﬁguraon
snapshot.
2. Specify the Name of a new or exisng conﬁguraon ﬁle.
3. Click OK and Close.
• To save only speciﬁc changes to the candidate conﬁguraon without overwring any part of
the default snapshot ﬁle:
1. Log in to Panorama with an administrave account that has the role privileges required to
save the desired changes.
2. Select Conﬁg > Save Changes at the top of the web interface.
3. Select Save Changes Made By.
4. To ﬁlter the Save Scope by administrator, click <administrator-name>, select the
administrators, and click OK.
5. To ﬁlter the Save Scope by locaon, clear any locaons that you want to exclude. The
locaons can be speciﬁc device groups, templates, Collector Groups, Log Collectors,
shared sengs, or the Panorama management server.
6. Click Save, specify the Name of a new or exisng conﬁguraon ﬁle, and click OK.
• To save a speciﬁc device group, template, or template stack conﬁguraon:
1. Select Panorama > Setup > Operaons, Save named Panorama conﬁguraon snapshot,
and Select Device Group & Templates.
2. Select the speciﬁc device groups, templates, or template stacks to save.
3. Click OK to conﬁrm the operaon.
STEP 2 | Export a candidate or running conﬁguraon to a host external to Panorama or to a ﬁrewall.
You can schedule daily exports to an SCP or FTP server (see Schedule Export of Conﬁguraon
Files) or export conﬁguraons on demand. To export on demand, select Panorama > Setup >
Operaons and select one of the following opons:
• Export named Panorama conﬁguraon snapshot—Export the current running conﬁguraon,
a named candidate conﬁguraon snapshot, or a previously imported conﬁguraon
(candidate or running). Panorama exports the conﬁguraon as an XML ﬁle with the Name
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you specify. Select Device Group & Templates to specify the device group, template, or
template stack conﬁguraons to export.
• Export Panorama conﬁguraon version—Select a Version of the running conﬁguraon
to export as an XML ﬁle. Select Device Group & Templates to specify the device group,
template, or template stack conﬁguraons to export as an XML ﬁle.
• Export Panorama and devices conﬁg bundle—Generate and export the latest version of the
running conﬁguraon backup of Panorama and of each managed ﬁrewall. To automate the
process of creang and exporng the conﬁguraon bundle daily to a Secure Copy (SCP) or
FTP server, see Schedule Export of Conﬁguraon Files.
• Export or push device conﬁg bundle—Aer you import a ﬁrewall conﬁguraon
into Panorama, Panorama creates a ﬁrewall conﬁguraon bundle named
<ﬁrewall_name>_import.tgz, in which all local policies and objects are removed. You can
then Export or push device conﬁg bundle to perform one of the following acons:
• Push & Commit the conﬁguraon bundle to the ﬁrewall to remove any local
conﬁguraon from it, enabling you to manage the ﬁrewall from Panorama.
• Export the conﬁguraon to the ﬁrewall without loading it. When you are ready to load
the conﬁguraon, log in to the ﬁrewall CLI and run the conﬁguraon mode command
load device-state. This command cleans the ﬁrewall in the same way as the Push &
Commit opon.
The full procedure to Transion a Firewall to Panorama Management requires
addional steps.

Revert Panorama Conﬁguraon Changes
When you revert changes, you are replacing sengs in the current candidate conﬁguraon with
sengs from another conﬁguraon. Reverng changes is useful when you want to undo changes
to mulple sengs as a single operaon instead of manually reconﬁguring each seng.
You can revert pending changes that were made to the Panorama conﬁguraon since the last
commit. You can revert all pending changes on Panorama or select speciﬁc device groups,
templates, or template stacks. Panorama provides the opon to ﬁlter the pending changes by
administrator or locaon. The locaons can be speciﬁc device groups, templates, Collector
Groups, Log Collectors, shared sengs, or the Panorama management server. If you saved a
snapshot ﬁle for a candidate conﬁguraon that is earlier than the current running conﬁguraon
(see Save and Export Panorama and Firewall Conﬁguraons), you can also revert to that candidate
conﬁguraon snapshot. Reverng to a snapshot enables you to restore a candidate conﬁguraon
that existed before the last commit. Panorama automacally saves a new version of the running
conﬁguraon whenever you commit changes and you can restore any of those versions.
Reverng a Panorama management server conﬁguraon requires a full commit and must
be performed by a superuser. Full commits are required when performing certain Panorama
operaons, such as reverng and loading a Panorama conﬁguraon, and are not supported for
custom Admin Role proﬁles.
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Revert to the current Panorama running conﬁguraon (ﬁle named running-config.xml).
This operaon undoes changes you made to the candidate conﬁguraon since the last commit.
• To revert all the changes that all administrators made, perform one of the following steps:
• Select Panorama > Setup > Operaons, Revert to running Panorama conﬁguraon, and
click Yes to conﬁrm the operaon.
• Log in to Panorama with an administrave account that is assigned the Superuser role or
an Admin Role proﬁle with the Commit For Other Admins privilege enabled. Then select
Conﬁg > Revert Changes, select Revert All Changes, and Revert.
• To revert only speciﬁc changes to the candidate conﬁguraon:
1. Log in to Panorama with an administrave account that has the role privileges required to
revert the desired changes.
The privileges that control commit operaons also control revert operaons.
2. Select Conﬁg > Revert Changes.
3. Select Revert Changes Made By.
4. To ﬁlter the Revert Scope by administrator, click <administrator-name>, select the
administrators, and click OK.
5. To ﬁlter the Revert Scope by locaon, clear any locaons that you want to exclude.
6. Revert the changes.
• To revert speciﬁc device group, template, or template stack changes to the running
conﬁguraon:
1. Select Panorama > Setup > Operaons, Revert to running Panorama conﬁguraon, and
Select Device Group & Templates.
2. Select the speciﬁc device groups, templates, or template stacks to revert.
3. Click OK to conﬁrm the operaon.
4. (Oponal) Select Commit > Commit to Panorama and Commit your changes to overwrite
the running conﬁguraon.
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Revert to the default snapshot (.snapshots.xml) of the Panorama candidate conﬁguraon.
• To revert all the changes that all administrators made:
1. Select Panorama > Setup > Operaons and Revert to last saved Panorama
conﬁguraon.
2. Click Yes to conﬁrm the operaon.
3. (Oponal) Select Commit > Commit to Panorama and Commit your changes to overwrite
the running conﬁguraon with the snapshot.
• To revert speciﬁc device group, template, or template stack changes to the running
conﬁguraon:
1. Select Panorama > Setup > Operaons, Revert to last saved Panorama conﬁguraon,
and Select Device Group & Templates.
2. Select the speciﬁc device groups, templates, or template stacks to revert.
3. Click OK to conﬁrm the operaon.
4. (Oponal) To overwrite the running conﬁguraon, select Commit > Commit to Panorama
and Commit your changes with the snapshot.
Revert to a previous version of the running conﬁguraon that is stored on Panorama.
• To revert all changes that administrators made:
1. Select Panorama > Setup > Operaons, Load Panorama conﬁguraon version, and
Select Device Group & Templates.
2. Select a conﬁguraon Version and click OK.
3. (Oponal) To overwrite the running conﬁguraon with the version you just restored,
select Commit > Commit to Panorama and Commit your changes.
• To revert speciﬁc device group, template, or template changes to the running conﬁguraon:
1. Select Panorama > Setup > Operaons, Load Panorama conﬁguraon version, and
select a conﬁguraon version Name.
2. Select Device Group & Templates and select the speciﬁc device groups, templates, or
template stacks to revert.
3. Click OK to conﬁrm the operaon.
4. (Oponal) To overwrite the running conﬁguraon with the snapshot, select Commit >
Commit to Panorama and Commit your changes.
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Revert to one of the following:
• Custom-named version of the Panorama running conﬁguraon that you previously
imported.
• Custom-named Panorama candidate conﬁguraon snapshot (instead of the default
snapshot).
1. Select Panorama > Setup > Operaons, Load named Panorama conﬁguraon snapshot,
and select the Name of the conﬁguraon ﬁle you just imported.
2. (Oponal) Load Shared Objects or Load Shared Policies to load all shared objects or
policies. You can load all shared objects and policies, as well as load all objects and
policies conﬁgured in the device groups and templates you specify in the next step.
3. (Oponal) Select Device Group & Templates, and select the speciﬁc device group,
template, or template stack conﬁguraons to load. Skip this step if you want to revert the
enre Panorama conﬁguraon.
4. Click OK to conﬁrm the operaon.
5. (Oponal) To overwrite the running conﬁguraon with the snapshot, select Commit >
Commit to Panorama and Commit your changes.
Restore a Panorama running or candidate conﬁguraon that you previously exported to an
external host.
1. Select Panorama > Setup > Operaons, Import named Panorama conﬁguraon
snapshot, Browse to the conﬁguraon ﬁle on the external host, and click OK.
2. Load named Panorama conﬁguraon snapshot and select the Name of the conﬁguraon
ﬁle you just imported.
3. (Oponal) Load Shared Objects or Load Shared Policies to load all shared objects or
policies. You can load all shared objects and policies, as well as load all objects and or
policies conﬁgured in the device groups and templates you specify in the next step.
4. (Oponal) Select Device Group & Templates and select the speciﬁc device group,
template, or template stack conﬁguraons to load. Skip this step if you want to revert the
enre Panorama conﬁguraon.
5. Click OK to conﬁrm the operaon.
6. (Oponal) To overwrite the running conﬁguraon with the snapshot you just imported,
select Commit > Commit to Panorama and Commit your changes.

Conﬁgure the Maximum Number of Conﬁguraon Backups on
Panorama
STEP 1 | Select Panorama > Setup > Management and edit the Logging and Reporng Sengs.
STEP 2 | Select Log Export and Reporng and enter the Number of Versions for Conﬁg Backups
(default is 100; range is 1 to 1,048,576).
STEP 3 | Click OK to save your changes.
STEP 4 | Select Commit > Commit to Panorama and Commit your changes.
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Load a Conﬁguraon Backup on a Managed Firewall
Use Panorama to load a conﬁguraon backup on a managed ﬁrewall. You can choose to revert
to a previously saved or commied conﬁguraon on the ﬁrewall. Panorama pushes the selected
version to the managed ﬁrewall, thereby overwring the current candidate conﬁguraon on the
ﬁrewall.
STEP 1 | Select Panorama > Managed Devices > Summary.
STEP 2 | Select Manage in the Backups column.
STEP 3 | Select from the Saved Conﬁguraons or Commied Conﬁguraons.
• Click a version number to view the contents of that version.
• Load a conﬁguraon version.
STEP 4 | Log in to the ﬁrewall web interface and Commit your changes.
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Compare Changes in Panorama Conﬁguraons
To compare conﬁguraon changes on Panorama, you can select any two sets of conﬁguraon ﬁles:
the candidate conﬁguraon, the running conﬁguraon, or any other conﬁguraon version that has
been previously saved or commied on Panorama. The side-by-side comparison enables you to:
• Preview the conﬁguraon changes before comming them to Panorama. You can, for example,
preview the changes between the candidate conﬁguraon and the running conﬁguraon. As a
best pracce, select the older version on the le pane and the newer version on the right pane,
to easily compare and idenfy modiﬁcaons.
• Perform a conﬁguraon audit to review and compare the changes between two sets of
conﬁguraon ﬁles.
Device Group and Template admins can only compare conﬁguraons for device groups and
templates within their access domains.
Compare changes in Panorama conﬁguraons.
1. Select Panorama > Conﬁg Audit.
2. In each drop-down, select a conﬁguraon for the comparison.
3. Select the number of lines that you want to include for Context and click Go.
Panorama uses color shading to highlight items you added (green), modiﬁed (yellow), or
deleted (red).

Conﬁgure the number of versions Panorama stores for conﬁguraon audits.
1. Select Panorama > Setup > Management and edit the Logging and Reporng Sengs.
2. Enter the Number of Versions for Conﬁg Audit (range is 1–1,048,576; default is 100).
3. Click OK to save your changes.
4. Select Commit > Commit to Panorama and Commit your changes.
View and compare Panorama conﬁguraon ﬁles before comming.
1. Select Commit > Commit to Panorama and Preview Changes.
2. Select the number of Lines of Context you want to see, and click OK.
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Manage Locks for Restricng Conﬁguraon Changes
Locking the candidate or running conﬁguraon prevents other administrators from changing the
conﬁguraon unl you manually remove the lock or Panorama removes it automacally (aer a
commit). Locks ensure that administrators don’t make conﬂicng changes to the same sengs or
interdependent sengs during concurrent login sessions.
If you are changing sengs that are unrelated to the sengs other administrators are
changing in concurrent sessions, you don’t need conﬁguraon locks to prevent commit
conﬂicts. Panorama queues commit operaons and performs them in the order that
administrators iniate the commits. For details, see Panorama Commit, Validaon, and
Preview Operaons.
A template or device group conﬁguraon push will fail if a ﬁrewall assigned to the template
or device group has a commit or conﬁg lock that an administrator set locally on that
ﬁrewall.
View details about current locks.
For example, you can check whether other administrators have set locks and read comments
they entered to explain the locks.
Click the locked padlock ( ) at the top of the web interface. The adjacent number indicates
the number of current locks.
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Lock a conﬁguraon.
Read-only administrators who cannot modify ﬁrewall or Panorama conﬁguraons cannot set
locks.
1. Click the padlock icon at the top of the web interface.
The icon varies based on whether exisng locks are (

) or are not (

) set.

2. Take a Lock and select the lock Type:
• Conﬁg—Blocks other administrators from changing the candidate conﬁguraon.
A custom role administrator who cannot commit changes can set a Conﬁg lock
and save the changes to the candidate conﬁguraon. However, because that
administrator cannot commit the changes, Panorama does not automacally
release the lock aer a commit; the administrator must manually remove the
Conﬁg lock aer making the required changes.
• Commit—Blocks other administrators from changing the running conﬁguraon.
3. Select the Locaon to determine the scope of the lock:
• Shared—Restricts changes to the enre Panorama conﬁguraon, including all device
groups and templates.
• Template—Restricts changes to the ﬁrewalls included in the selected template. (You
can’t take a lock for a template stack, only for individual templates within the stack.)
• Device group—Restricts changes to the selected device group but not its descendant
device groups.
4. (Oponal) As a best pracce, enter a Comment to describe your reason for seng the
lock.
5. Click OK and Close.
Unlock a conﬁguraon.
Only a superuser or the administrator who locked the conﬁguraon can manually unlock it.
However, Panorama automacally removes a lock aer compleng the commit operaon that
the administrator who set the lock iniated.
1. Click the locked padlock (

) at the top of the web interface.

2. Select the lock entry in the list.
3. Click Remove Lock, OK, and Close.
Conﬁgure Panorama to automacally lock the running conﬁguraon when you change the
candidate conﬁguraon. This seng applies to all Panorama administrators.
1. Select Panorama > Setup > Management and edit the General Sengs.
2. Select Automacally Acquire Commit Lock and click OK.
3. Select Commit > Commit to Panorama and Commit your changes.
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Add Custom Logos to Panorama
You can upload image ﬁles to customize the following areas on Panorama:
• Background image on the login screen
• Header on the top le corner of the web interface; you can also hide the Panorama default
background
• Title page and footer image in PDF reports
Supported image types include .jpg, .gif, and .png. Image ﬁles for use in PDF reports cannot
contain an alpha channel. The size of the image must be less than 128 Kilobytes (131,072
bytes); the recommended dimensions are displayed on screen. If the dimension is larger than the
recommended size, the image will be automacally cropped.
STEP 1 | Select Panorama > Setup > Operaons.
STEP 2 | In the Miscellaneous secon, click Custom Logos.
STEP 3 | Click the Upload logo icon and select an image for any of the following opons: the login
screen, the le corner of the main user interface, the PDF report tle page and the PDF
report footer.
STEP 4 | Click Open to add the image. To preview the image, click the preview logo icon.
STEP 5 | (Oponal) To clear the green background header on the Panorama web interface, select the
check box for Remove Panorama background header.
STEP 6 | Click Close to save your changes.
STEP 7 | Select Commit > Commit to Panorama and Commit your changes.
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Use the Panorama Task Manager
Click Tasks (
) at the boom of the web interface to open the Task Manager, which displays
details about all the operaons that administrators iniated (for example, manual commits) or that
Panorama or a managed ﬁrewall iniated (for example, scheduled report generaon) since the
last Panorama or ﬁrewall reboot. You can use the Task Manager to troubleshoot failed operaons,
invesgate warnings associated with completed commits, or cancel pending commits.
Device Group and Template admins can only view tasks for tasks within their access
domains.
STEP 1 | Click Tasks.
STEP 2 | Show the Running (in progress) tasks or All tasks (the default), oponally ﬁlter by type
(Reports; Log Requests; or commit, download, and installaon Jobs), and select Panorama
(default) or the ﬁrewall for which you want to see the tasks.
STEP 3 | Perform any of the following acons:
• Display or hide task details—By default, the Task Manager displays the Type, Status, Start
Time, and Messages for each task. To see the End Time and Job ID for a task, you must
manually display those columns. To display or hide a column, open the drop-down in any
column header, select Columns, and select or clear the columns as desired.
• Invesgate warnings or failures—Read the entries in the Messages column for task details.
If the column says Toomany messages, click the entry in the Type column to see more
informaon.
• Display a commit descripon—If an administrator entered a descripon for a commit, click
Commit Descripon in the Messages column to display it.
• Check the posion of a commit in the queue—The Messages column indicates the queue
posion of commits that are in progress.
• Cancel pending commits—Clear Commit Queue to cancel all pending commits (available
only to predeﬁned administrave roles). To cancel an individual commit, click x in the Acon
column (the commit remains in the queue unl Panorama dequeues it). You cannot cancel
commits that are in progress.
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Manage Storage Quotas and Expiraon Periods for Logs
and Reports
• Log and Report Storage
• Log and Report Expiraon Periods
• Conﬁgure Storage Quotas and Expiraon Periods for Logs and Reports
• Conﬁgure the Run Time for Panorama Reports

Log and Report Storage
You can edit the default storage quotas for each log type. When a log quota reaches the maximum
size, Panorama starts overwring the oldest log entries with the new log entries.The storage
capacity for reports is not conﬁgurable. The Log storage locaons and report storage capacies
vary by Panorama model:
• Panorama virtual appliance in Panorama mode—The storage space for reports is 200MB. The
appliance uses its virtual system disk to store the System and Conﬁg logs that Panorama and
Log Collectors generate. The virtual system disk also stores the Applicaon Stascs (App
Stats) logs that Panorama automacally receives at 15-minute intervals from all managed
ﬁrewalls. Panorama stores all other log types to its virtual logging disks (1 to 12).
• Panorama virtual appliance in Management Only mode—The storage space for reports is
500MB. The appliance uses its virtual system disk to store the System and Conﬁg logs that
Panorama and Log Collectors generate. The virtual system disk also stores the Applicaon
Stascs (App Stats) logs that Panorama automacally receives at 15-minute intervals from
all managed ﬁrewalls. You must Conﬁgure a Managed Collector to forward logs from managed
ﬁrewalls as Panorama in Management Only mode cannot store any other log type.
• Panorama virtual appliance in Legacy mode—The storage space for reports is 200MB for
Panorama 8.0 or earlier releases and 500MB for Panorama 8.0.1 and later releases. Panorama
writes all logs to its assigned storage space, which can be any of one the following:
• Virtual system disk—By default, approximately 11GB is allocated for log storage on the
virtual system disk that you created when installing Panorama. If you add a virtual logging
disk or NFS paron, Panorama sll uses the system disk to store the System and Conﬁg
logs that Panorama and Log Collectors generate and to store the App Stats logs collected
from ﬁrewalls.
• Dedicated virtual logging disk—Stores all log types except those that reside on the system
disk.
• NFS paron—This opon is available only to Panorama running on a VMware ESXi server.
The NFS paron stores all log types except those that reside on the system disk.
• M-600, M-500, or M-200 appliance—The storage space for reports is 500MB for Panorama
6.1 or later releases and 200MB for earlier releases. The M-Series appliances use their internal
SSD to store the Conﬁg logs and System logs that Panorama and Log Collectors generate and
to store the App Stats logs collected from ﬁrewalls. Panorama saves all other log types to its
RAID-enabled disks. The RAID disks are either local to the M-Series appliance in Panorama
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mode or are in a Dedicated Log Collector (M-Series appliance in Log Collector mode). You edit
the log storage quotas on the RAID disks when you Conﬁgure a Collector Group.
For details on the log storage opons and capacies, see Panorama Models. You can
Expand Log Storage Capacity on the Panorama Virtual Appliance by adding virtual
logging disks or NFS storage. You can Increase Storage on the M-Series Appliance by
adding RAID drives or by upgrading from 1TB drives to 2TB drives.

Log and Report Expiraon Periods
You can conﬁgure automac deleon based on me for the logs that the Panorama management
server and Log Collectors collect from ﬁrewalls, as well as the logs and reports that Panorama
and the Log Collectors generate locally. This is useful in deployments where periodically deleng
monitored informaon is desired or necessary. For example, deleng user informaon aer a
certain period might be mandatory in your organizaon for legal reasons. You conﬁgure separate
expiraon periods for:
• Reports—Panorama deletes expired reports at the same it generates new reports (see
Conﬁgure the Run Time for Panorama Reports).
• Each log type—Panorama evaluates logs as it receives them, and deletes logs that exceed the
conﬁgured expiraon period.
•

Panorama synchronizes expiraon periods across high availability (HA) pairs. Because
only the acve HA peer generates logs, the passive peer has no logs or reports to delete
unless failover occurs and it starts generang logs.
Even if you don’t set expiraon periods, when a log quota reaches the maximum size,
Panorama starts overwring the oldest log entries with the new log entries.

Conﬁgure Storage Quotas and Expiraon Periods for Logs and
Reports
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STEP 1 | Conﬁgure the storage quotas and expiraon periods for:
• Logs of all types that a Panorama virtual appliance in Legacy mode receives from ﬁrewalls.
• App Stats logs that Panorama receives from ﬁrewalls.
• System and Conﬁg logs that Panorama and Log Collectors generate locally.
The Panorama management server stores these logs locally.
If you reduce a storage quota such that the current logs exceed it, aer you commit the
change, Panorama removes the oldest logs to ﬁt the quota.
1. Select Panorama > Setup > Management and edit the Logging and Reporng Sengs.
2. In the Log Storage sengs, enter the storage Quota (%) for each log type.
When you change a percentage value, the page refreshes to display the corresponding
absolute value (Quota GB/MB column) based on the total alloed storage on Panorama.
3. Enter the Max Days (expiraon period) for each log type (range is 1 to 2,000).
By default, the ﬁelds are blank, which means the logs never expire.
Restore Defaults if you want to reset the quotas and expiraon periods to the
factory defaults.
STEP 2 | Conﬁgure the expiraon period for reports that Panorama generates.
1. Select Log Export and Reporng and enter the Report Expiraon Period in days (range is
1 to 2,000).
By default, the ﬁeld is blank, which means reports never expire.
2. Click OK to save your changes.

Panorama Administrator's Guide Version Version 10.1

575

©2022 Palo Alto Networks, Inc.

Administer Panorama
STEP 3 | Conﬁgure the storage quotas and expiraon periods for logs of all types (except App Stats
logs) that M-600, M-500, M-200 appliances, or Panorama virtual appliance in Panorama
mode receives from ﬁrewalls.
The local or Dedicated Log Collectors store these logs.
You conﬁgure these storage quotas at the Collector Group level, not for individual Log
Collectors.
1. Select Panorama > Collector Groups and edit the Collector Group.
2. In the General sengs, click the Log Storage value.
A value doesn’t display unless you assigned Log Collectors to the Collector
Group. If the ﬁeld displays 0MB aer you assign Log Collectors, verify that you
enable the disk pairs when you Conﬁgure a Managed Collector and that you
commied the changes (Panorama > Managed Collectors > Disks).
3. Enter the storage Quota(%) for each log type.
When you change a percentage value, the page refreshes to display the corresponding
absolute value (Quota GB/MB column) based on the total storage alloed to the
Collector Group.
4. Enter the Max Days (expiraon period) for each log type (range is 1 to 2,000).
By default, the ﬁelds are blank, which means the logs never expire.
Restore Defaults if you want to reset the quotas and expiraon periods to the
factory defaults.
5. Click OK to save your changes.
STEP 4 | Commit the changes to Panorama and push the changes to the Collector Group.
1. Select Commit > Commit and Push and Edit Selecons in the Push Scope.
2. Select Collector Groups, select the Collector Group you modiﬁed, and click OK.
3. Commit and Push your changes.
STEP 5 | Verify that Panorama applied the storage quota changes.
1. Select Panorama > Setup > Management and, in the Logging and Reporng Sengs,
verify that the Log Storage values are correct for the logs that the Panorama
management server stores.
2. Select Panorama > Collector Groups, select the Collector Group you modiﬁed, and
verify that the Log Storage values in the General tab are correct for the logs that the Log
Collectors store.
You can also verify the Collector Group storage quotas by logging in to a Log
Collector CLI and entering the operaonal command show log-diskquotapct.
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Conﬁgure the Run Time for Panorama Reports
Panorama generates reports daily at the me you specify. Panorama deletes any expired reports
aer generang the new reports.
STEP 1 | Select Panorama > Setup > Management and edit the Logging and Reporng Sengs.
STEP 2 | Select Log Export and Reporng and set the Report Runme to an hour in the 24-hour clock
schedule (default is 02:00; range is 00:00 [midnight] to 23:00).
STEP 3 | Select Commit > Commit to Panorama and Commit your changes.
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Monitor Panorama
To monitor Panorama and its managed collectors, you can periodically view their System and
Conﬁg logs (ﬁlter logs by type), conﬁgure an SNMP manager to collect (GET) Panorama stascs
on a regular basis, or conﬁgure SNMP traps or email alerts that nofy you when a monitored
metric changes state or reaches a threshold on Panorama. Email alerts and SNMP traps are
useful for immediate noﬁcaon about crical system events that need your aenon. To
conﬁgure email alerts or SNMP traps, see Conﬁgure Log Forwarding from Panorama to External
Desnaons.
• Panorama System and Conﬁguraon Logs
• Monitor Panorama and Log Collector Stascs Using SNMP

Panorama System and Conﬁguraon Logs
You can conﬁgure Panorama to send noﬁcaons when a system event or conﬁguraon change
occurs. By default, Panorama records every conﬁguraon change in the Conﬁg logs. In the System
logs, each event has a severity level to indicate its urgency and impact. When you Conﬁgure Log
Forwarding from Panorama to External Desnaons, you can forward all System and Conﬁg logs
or ﬁlter the logs based on aributes such as the receive me or severity level (System logs only).
The following table summarizes the severity levels for System logs.
Panorama regularly connects to the IoT Edge Service to download policy recommendaons
for IoT based policies. This connecon is aempted by Panorama regardless of whether the
IoT license is acve on any managed ﬁrewalls..
A high severity gRPC connecon failure system log is generated in the event of connecon
failure or if Panorama manages no IoT licensed ﬁrewall. No acon is needed regarding
these system logs if you are not leveraging the policy recommendaon capabilies of IoT or
if you are not managing any IoT licensed ﬁrewalls.
If you are leveraging the policy recommendaon capabilies of IoT, review the gRPC
connecon failure system log to understand what is causing the connecon issue between
Panorama and the IoT Edge Service.
Panorama does not support querying conﬁguraon logs in the ACC or when monitoring
conﬁguraon logs (Monitor > Logs) using the ﬁlters:
before-change-preview-contains
after-change-preview-contains
Severity

Descripon

Crical

Indicates a failure and the need for immediate aenon, such as a hardware
failure, including high availability (HA) failover and link failures.

High

Serious issues that will impair the operaon of the system, including
disconnecon of a Log Collector or a commit failure.
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Severity

Descripon

Medium

Mid-level noﬁcaons, such as Anvirus package upgrades, or a Collector
Group conﬁguraon push.

Low

Minor severity noﬁcaons, such as user password changes.

Informaonal

Noﬁcaon events such as log in or log out, any conﬁguraon change,
authencaon success and failure noﬁcaons, commit success, and all
other events that the other severity levels don’t cover.

Panorama stores the System and Conﬁg logs locally; the exact locaon and storage capacity varies
by Panorama model (see Log and Report Storage). Upon reaching the capacity limit, Panorama
deletes the oldest logs to create space for new logs. If you need to store the logs for longer
periods than what the local storage allows, you can Conﬁgure Log Forwarding from Panorama to
External Desnaons.
For informaon on using Panorama to monitor ﬁrewall logs, see Monitor Network
Acvity.

Monitor Panorama and Log Collector Stascs Using SNMP
You can conﬁgure an SNMP manager to request informaon from a Panorama management
server and conﬁgure Panorama to respond. For example, the SNMP manager can request the
high availability (HA) mode, Panorama state, and Panorama version. If the Panorama management
server has a local Log Collector, then Panorama can also provide logging stascs: average
logs per second, storage duraon, retenon periods, log disk usage, log forwarding status from
individual ﬁrewalls to Panorama and external servers, and the status of ﬁrewall-to-Log Collector
connecons. Panorama doesn’t synchronize SNMP conﬁguraons between HA peers; you must
enable SNMP requests and responses on each peer.
You can also conﬁgure a Dedicated Log Collector to respond to requests for the same logging
stascs as the Panorama management server. This informaon is useful when evaluang
whether you need to expand log storage capacity.
You can’t conﬁgure an SNMP manager to control Panorama or Log Collectors (using SET
messages); an SNMP manager can only collect stascs (using GET messages).
For details on how Panorama implements SNMP, see SNMP Support.
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STEP 1 | Conﬁgure the SNMP Manager to get stascs from Panorama and the Log Collectors.
The following steps are an overview of the tasks you perform on the SNMP manager. For the
speciﬁc steps, refer to the documentaon of your SNMP manager.
1. To enable the SNMP manager to interpret stascs, load the Supported MIBs and, if
necessary, compile them.
2. For each Panorama appliance that the SNMP manager will monitor, deﬁne its connecon
sengs (IP address and port) and authencaon sengs (SNMPv2c community string or
SNMPv3 username and password). All Panorama appliances use port 161.
The SNMP manager can use the same or diﬀerent connecon and authencaon
sengs for mulple Panorama management servers and Log Collectors. The sengs
must match those you deﬁne when you conﬁgure SNMP on Panorama (see Conﬁgure the
Panorama management server to respond to stascs requests from an SNMP manager.
and Conﬁgure the Panorama management server to respond to stascs requests from
an SNMP manager.). For example, if you use SNMPv2c, the community string you deﬁne
when conﬁguring Panorama must match the community string you deﬁne in the SNMP
manager for Panorama.
3. Determine the object idenﬁers (OIDs) of the stascs you will monitor. For example,
to monitor the logging rate, a MIB browser shows that this stasc corresponds to OID
1.3.6.1.4.1.25461.2.3.30.1.1 in PAN-PRODUCT-MIB.my. For details, see Use an SNMP
Manager to Explore MIBs and Objects.
4. Conﬁgure the SNMP manager to monitor the desired OIDs.
STEP 2 | Enable SNMP traﬃc on the management (MGT) interface of the Panorama management
server.
1. Select Panorama > Setup > Management and edit the Management Interface Sengs.
2. In the Services secon, select the SNMP check box and click OK.
STEP 3 | Enable SNMP traﬃc on the management (MGT) interface of any M-Series appliances in Log
Collector mode:
1. Select Panorama > Managed Collectors and select the Log Collector.
2. Select the Management tab, select the SNMP check box, and click OK.
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STEP 4 | Conﬁgure the Panorama management server to respond to stascs requests from an SNMP
manager.
1. Select Panorama > Setup > Operaons and, in the Miscellaneous secon, click SNMP
Setup.
2. Select the SNMP Version and conﬁgure the authencaon values as follows. For version
details, see SNMP Support.
• V2c—Enter the SNMP Community String, which idenﬁes a community of SNMP
managers and monitored devices (Panorama, in this case), and serves as a password to
authencate the community members to each other.
Don’t use the default community string public; it is well known and
therefore not secure.
• V3—Create at least one SNMP view group and one user. User accounts and views
provide authencaon, privacy, and access control when SNMP managers get
stascs.
Views—Each view is a paired OID and bitwise mask: the OID speciﬁes a MIB, and the
mask (in hexadecimal format) speciﬁes which objects are accessible inside (include
matching) or outside (exclude matching) that MIB. Click Add in the ﬁrst list and enter a
Name for the group of views. For each view in the group, click Add and conﬁgure the
view Name, OID, matching Opon (include or exclude), and Mask.
Users—Click Add in the second list, enter a username in the Users column, select the
View group from the drop-down, enter the authencaon password (Auth Password)
used to authencate to the SNMP manager, and enter the privacy password (Priv
Password) used to encrypt SNMP messages to the SNMP manager.
3. Click OK to save the sengs.
STEP 5 | Conﬁgure the Dedicated Log Collectors (if any) to respond to SNMP requests.
For each Collector Group:
1. Select Panorama > Collector Groups and select the Collector Group.
2. Select the Monitoring tab, conﬁgure the same sengs as in Step Conﬁgure the
Panorama management server to respond to stascs requests from an SNMP manager.,
and click OK.
STEP 6 | Commit the changes to Panorama and push the changes to Collector Groups.
1. Select Commit > Commit and Push and Edit Selecons in the Push Scope.
2. Select Collector Groups you, select the Collector Groups you edited, and click OK.
3. Commit and Push your changes.
STEP 7 | Monitor the Panorama and Log Collector stascs in an SNMP manager.
Refer to the documentaon of your SNMP manager.
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Reboot or Shut Down Panorama
The reboot opon iniates a graceful restart of Panorama. A shutdown halts the system and
powers it oﬀ. To restart Panorama, aer a shutdown, manually disconnect and re-cable the power
cord on the system.
STEP 1 | Select Panorama > Setup > Operaons.
STEP 2 | In the Device Operaons secon, select Reboot Panorama or Shutdown Panorama.
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Conﬁgure Panorama Password Proﬁles and Complexity
To secure the local administrator account, you can deﬁne password complexity requirements that
are enforced when administrators change or create new passwords. Unlike password proﬁles,
which can be applied to individual accounts, the password complexity rules are ﬁrewall-wide and
apply to all passwords.
To enforce periodic password updates, create a password proﬁle that deﬁnes a validity period for
passwords.
STEP 1 | Conﬁgure minimum password complexity sengs.
1. Select Panorama > Setup > Management and edit the Minimum Password Complexity
secon.
2. Select Enabled.
3. Deﬁne the Password Format Requirements. You can enforce the requirements for
uppercase, lowercase, numeric, and special characters that a password must contain.
4. To prevent the account username (or reversed version of the name) from being used in
the password, select Block Username Inclusion (including reversed).
5. Deﬁne the password Funconality Requirements.
If you have conﬁgured a password proﬁle for an administrator, the values deﬁned in the
password proﬁle will override the values that you have deﬁned in this secon.
STEP 2 | Create password proﬁles.
You can create mulple password proﬁles and apply them to administrator accounts as
required to enforce security.
1. Select Panorama > Password Proﬁles and click Add.
2. Enter a Name for the password proﬁle and deﬁne the following:
1. Required Password Change Period—Frequency, in days, at which the passwords must
be changed.
2. Expiraon Warning Period—Number of days before expiraon that the administrator
will receive a password reminder.
3. Post Expiraon Grace Period—Number of days that the administrator can sll log in
to the system aer the password expires.
4. Post Expiraon Admin Login Count—Number of mes that the administrator can log
in to the system aer the password has expired.
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Panorama Plugins
The Panorama extensible plugin architecture enables support for third-party
integraon plugins, such as VMware NSX, and other Palo Alto Networks products,
such as the GlobalProtect cloud service. With this modular architecture, you can take
advantage of new capabilies without waing for a new PAN-OS version.
You can also conﬁgure the VM-Series plugin from Panorama. The VM-Series plugin
is a single plugin that enables integraon with public cloud environments such as
Google Cloud Plaorm (GCP), Azure, AWS and private cloud hypervisors such as
KVM, ESXi and others. The VM-Series plugin enables you to publish metrics from VMSeries ﬁrewalls deployed in public clouds. You can use Panorama to conﬁgure the VMSeries plugin sengs for public clouds and push your conﬁguraon to your managed
ﬁrewalls.
> About Panorama Plugins
> VM-Series Plugin and Panorama Plugins

585

Panorama Plugins

About Panorama Plugins
Panorama supports an extensible plugin architecture that enables the integraon and
conﬁguraon of the following capabilies:
• AWS—The AWS plugin enables you to monitor your EC2 workloads on AWS. With the
plugin, you can enable communicaon between Panorama (running PAN-OS 8.1.3 or a later
release) and your AWS VPCs so that Panorama can collect a predeﬁned set of aributes (or
metadata elements) as tags for your EC2 instances and register the informaon to your Palo
Alto Networks ﬁrewalls. When you reference these tags in Dynamic Address Groups and match
against them in Security policy rules, you can consistently enforce policy across all assets
deployed within your VPCs.
• Azure—The Azure plugin enables you to monitor your virtual machines on the Azure public
cloud. With the plugin, you can enable communicaon between Panorama (running PAN-OS
8.1.6 or a later release) and your Azure subscripons so that Panorama can collect a predeﬁned
set of aributes (or metadata elements) as tags for your Azure virtual machines and register the
informaon to your Palo Alto Networks ﬁrewalls. When you reference these tags in Dynamic
Address Groups and match against them in Security policy rules, you can consistently enforce
policy across all assets deployed within VNets in your subscripons.
• Cisco ACI—The Cisco ACI plugin enables you to monitor endpoints in your Cisco ACI fabric.
With the plugin, you enable communicaon between Panorama (8.1.6 and later) and your Cisco
APIC so that Panorama can collect endpoint informaon as tags for your Endpoint Groups and
register the informaon to you Palo Alto Networks ﬁrewalls. When you reference these tags in
Dynamic Address Groups and match against them in Security policy rules, you can consistently
enforce policy across all assets deployed within your Cisco ACI fabric.
• Cisco TrustSec—The Cisco TrustSec Plugin enables monitoring of endpoints in your Cisco
TrustSec environment. With the plugin, you enable communicaon between Panorama and
your Cisco pxGrid server so that Panorama can collect endpoint informaon as tags for
your endpoints and register the informaon to you Palo Alto Networks ﬁrewalls. When you
reference these tags in Dynamic Address Groups and match against them in security policy
rules, you can consistently enforce policy across all assets deployed within your Cisco TrustSec
environment.
Not supported on Panorama in FIPS-CC mode.
• Cloud Services—The Cloud Services plugin enables the use of the Cortex Data Lake and Prisma
Access. The Cortex Data Lake solves operaonal logging challenges and the Prisma Access
cloud service extends your security infrastructure to your remote network locaons and mobile
workforce.
• Enterprise Data Loss Prevenon (DLP)— Enterprise DLP is a set of tools and processes that
allow you to protect sensive informaon against unauthorized access, misuse, extracon, or
sharing. Enterprise DLP is enabled through a cloud service to help you inspect content and
analyze the data in the correct context so that you can accurately idenfy sensive data and
secure it to prevent incidents. Enterprise DLP is supported on Panorama and managed ﬁrewalls
running PAN-OS 10.0.2 and later releases.
Not supported on Panorama in FIPS-CC mode.
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• GCP—Enables you to secure Kubernetes services in a Google Kubernetes Engine (GKE) cluster.
Conﬁgure the Panorama plugin for Google Cloud Plaorm (GCP) to connect to your GKE
cluster and learn about the services that are exposed to the internet.
• Panorama Interconnect—The Panorama Interconnect plugin enables you to manage large-scale
ﬁrewall deployments. Use the Interconnect plugin to set up a two-er Panorama deployment
(on Panorama running PAN-OS 8.1.3 or a later release) for a horizontal scale-out architecture.
With the Interconnect plugin, you can deploy a Panorama Controller with up to 64 Panorama
Nodes or 32 Panorama HA pairs to centrally manage a large number of ﬁrewalls.
• Nutanix—The Panorama plugin for Nutanix enables VM monitoring in your Nutanix
environment. It allows you to track the virtual machine inventory within your Nutanix Prism
Central so that you can consistently enforce security policy that automacally adapts to
changes within your Nutanix environment. As virtual machines are provisioned, de-provisioned
or moved, this soluon allows you to collect the IP addresses and associated sets of aributes
(or metadata elements) as tags. You can then use the tags to deﬁne Dynamic Address Groups
and use them in Security policy. The Panorama plugin for Nutanix requires Panorama 9.0.4 or
later.
• SD-WAN—The Soware-Deﬁned Wide Area Network (SD-WAN) plugin allows you to use
mulple internet and private services to create an intelligent and dynamic WAN, which helps
lower costs and maximize applicaon quality and usability. Instead of using costly and meconsuming MPLS with components such as routers, ﬁrewalls, WAN path controllers, and WAN
opmizers to connect your WAN to the internet, SD-WAN on a Palo Alto Networks ﬁrewall
allows you to use less expensive internet services and fewer pieces of equipment.
• VMware NSX—The VMware NSX plugin enables integraon between the VM-Series ﬁrewall
on VMware NSX with VMware NSX Manager. This integraon allows you to deploy the VMSeries ﬁrewall as a service on a cluster of ESXi servers.
• VMware vCenter—The Panorama plugin for VMware vCenter allows you to monitor the virtual
machines in your vCenter environment. The plugin retrieves IP addresses of virtual machines
in your vCenter environment and converts them to tags that you can use to build policy using
dynamic address groups.
• Zero Touch Provisioning—Zero Touch Provisioning (ZTP) is designed to simplify and automate
the on-boarding of new ﬁrewalls to Panorama. ZTP streamlines the inial ﬁrewall deployment
process by allowing network administrators to ship managed ﬁrewalls directly to their branches
and automacally add the ﬁrewall to Panorama, allowing business to save on me and
resources when deploying new ﬁrewalls. ZTP is supported on PAN-OS 9.1.3 and later releases.
Not supported on Panorama in FIPS-CC mode.
• IPS Signature Converter—The IPS Signature Converter plugin for Panorama provides an
automated soluon for converng rules from third-party intrusion prevenon systems—Snort
and Suricata—into custom Palo Alto Networks threat signatures. You can then register these
signatures on ﬁrewalls that belong to device groups you specify and use them to enforce policy
in Vulnerability Protecon and An-Spyware Security Proﬁles.
You can install mulple plugins and retrieve IP address updates from mulple sources on a single
Panorama instance. This allows you to create and enforce consistent security policy to secure
applicaons and workloads across mulple cloud environments. Retrieved IP addresses are used
in security policy through dynamic address groups; when a workload is added or removed from
your environment, Panorama registers the change and pushes the update to the ﬁrewalls. When
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deploying mulple plugins on Panorama, you must carefully plan your device group hierarchy to
ensure that updates are passed to your ﬁrewalls correctly.
Refer to the Palo Alto Networks Compability Matrix for details on the diﬀerent plugin versions
and compability informaon.

Install Panorama Plugins
You can install one or more of the available plugins on Panorama to enable the integraon the
GlobalProtect cloud service and Cortex Data Lake,VMware NSX, or for monitoring your virtual
machines on AWS or Azure public cloud.
For the cloud services plugin, you must acvate a valid auth code on the Customer Support Portal
and select the region—Americas or Europe—to which you want to send logs.
If you have a version of a plugin currently installed and you Install a new version of the
plugin, Panorama replaces the currently installed version.
STEP 1 | Download the plugin.
1. Select Panorama > Plugins.

2. Select Check Now to retrieve a list of available updates.
3. Select Download in the Acon column to download the plugin.
Refer to the Compatability Matrix for the minimum supported PAN-OS version for each
Panorama plugin.
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STEP 2 | Install the plugin.
Select the version of the plugin and click Install in the Acon column to install the plugin.
Panorama will alert you when the installaon is complete. For more details, refer to install the
VMware NSX plugin or the Cloud Services plugin.
When installing the plugin for the ﬁrst me on a Panorama HA pair, install the plugin
on the passive peer before the acve peer. On installing the plugin on the passive peer,
it transions to a non-funconal state. Then, aer you successfully install the plugin on
the acve peer, the passive peer returns to a funconal state.
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VM-Series Plugin and Panorama Plugins
What is the diﬀerence between the VM-Series Plugin and various plugins for Panorama?
The VM-Series Plugin is for the VM-Series ﬁrewalls, and is a single plugin that enables integraon
with public cloud environments such as Google Cloud Plaorm (GCP), Azure and AWS, and private
cloud hypervisors such as KVM, ESXi and others. When you deploy the ﬁrewall, the built-in plugin
automacally detects the virtual environment on which the ﬁrewall is deployed and loads up
the plugin components that enable you to manage interacons with that cloud environment.
For example, when you deploy the VM-Series ﬁrewall on GCP, the VM-Series ﬁrewall loads the
plugin components that enable the integraon with GCP. You can then use the VM-Series plugin
to conﬁgure the VM-Series ﬁrewall on GCP to publish metrics to Google Stackdriver Monitoring.
Similarly, the VM-Series plugin on the VM-Series ﬁrewall on Azure enables you to conﬁgure the
ﬁrewall to publish metrics Azure Applicaon Insights or set up the details that the ﬁrewalls need
to funcon as an HA pair. The VM-Series Plugin is pre-installed on the VM-Series ﬁrewall, and you
can upgrade or downgrade but cannot delete it. On Panorama the VM-Series plugin is available
but it is not pre-installed. If you choose to use Panorama to manage the integraons on your
ﬁrewalls, install the VM-Series plugin on Panorama to establish communicaon with the VMSeries plugin on your ﬁrewalls.
The Panorama plugins are for both hardware-based ﬁrewalls and the VM-Series ﬁrewalls. Since
Panorama plugins are oponal, you can add, remove, reinstall, or upgrade them on Panorama.
The Panorama plugin is not built-in, and you must install the plugin to enable communicaon
with the managing the environment you need. For example, you use the Cloud Services plugin on
Panorama to enable the set up between the Panorama/ﬁrewalls and the Cortex Data Lake. The
GCP plugin on Panorama enables communicaon between Panorama and your GCP deployment
so that you can secure traﬃc entering or exing a service deployed in a Google Kubernetes Engine
(GKE) cluster.

Install the VM-Series Plugin on Panorama
To view and conﬁgure cloud integraons deployed on your VM-Series ﬁrewalls, the VM-Series
plugin must be installed on both Panorama and the VM-Series ﬁrewall. The plugin is automacally
installed on the ﬁrewall, but you must manually install the plugin on Panorama before you can
push conﬁguraons to your device groups.
The VM-Series plugin supports all clouds, so an upgrade might not apply to your VMSeries ﬁrewalls. Before upgrading the plugin, consult the release notes. Update the plugin
only when there are changes relevant to your cloud.
STEP 1 | Download the VM-Series plugin.
1. Select Panorama > Plugins
and use Check Now to look for new plugin packages. The
VM-Series plugin name is vm_series.
2. Consult the plugin release notes to determine which version provides upgrades useful to
you.
3. Select a version of the plugin and select Download in the Acon column.
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STEP 2 | Install the VM-Series plugin.
1. Click Install in the Acon column. Panorama alerts you when the installaon is complete.
2. To view the plugin, select Device > VM-Series.
• If your ﬁrewall is installed on a private cloud and the hypervisor or service does not
have an integraon, you see a tab named VM-Series and the default message, VM
Series plugin infrastructure support is installed to allow
the firewall's functionality to be enhanced in response to new
features launched by hypervisor, or to meet new security needs.
• If your ﬁrewall is deployed on a public cloud, Panorama displays tabs for all supported
clouds.

STEP 3 | (Oponal) Save your conﬁguraon and push it to your managed ﬁrewalls.
STEP 4 | (Oponal) On the VM-Series ﬁrewall, select Device > VM-Series. If you have conﬁgured
the integraon for your plaorm, you see a single tab for the cloud in which the ﬁrewall is
deployed. If you have not conﬁgured an integraon, you see the default message about the
VM-Series plugin infrastructure.
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The following topics address issues for the Panorama™ management server and
Dedicated Log Collectors:
>

Troubleshoot Panorama System
Issues

>

Troubleshoot Device Management
License Errors

>

Troubleshoot Log Storage and
Connecon Issues

>

Troubleshoot Automacally Reverted
Firewall Conﬁguraons

>

Replace an RMA Firewall

>

View Task Success or Failure Status

>

Troubleshoot Commit Failures

>

>

Troubleshoot Registraon or Serial
Number Errors

Test Policy Match and Connecvity
for Managed Devices

>

>

Troubleshoot Reporng Errors

Generate a Stats Dump File for a
Managed Firewall

>

Recover Managed Device
Connecvity to Panorama
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Troubleshoot Panorama System Issues
• Generate Diagnosc Files for Panorama
• Diagnose Panorama Suspended State
• Monitor the File System Integrity Check
• Manage Panorama Storage for Soware and Content Updates
• Recover from Split Brain in Panorama HA Deployments

Generate Diagnosc Files for Panorama
Diagnosc ﬁles aid in monitoring system acvity and in discerning potenal causes for issues
on Panorama. To assist Palo Alto Networks Technical Support in troubleshoong an issue, the
support representave might request a tech support ﬁle. The following procedure describes how
to download a tech support ﬁle and upload it to your support case.
STEP 1 | Select Panorama > Support and click Generate Tech Support File.
STEP 2 | Download and save the ﬁle to your computer.
STEP 3 | Upload the ﬁle to your case on the Palo Alto Networks Customer Support web site.

Diagnose Panorama Suspended State
If Panorama is in a suspended state, check for the following condions:
• Serial numbers—Verify that the serial number on each Panorama virtual appliance is unique. If
the same serial number is used to create two or more instances of Panorama, all instances using
the same serial number will be suspended.
• Mode—If you deploy the Panorama virtual appliance in a high availability (HA) conﬁguraon,
verify that both HA peers are in the same mode: Panorama mode or Legacy mode.
• HA priority—Verify that you have set the HA priority seng on one peer as Primary and the
other as Secondary. If the priority seng is idencal on both peers, the Panorama peer with a
higher numerical value in serial number is placed in a suspended state.
• Panorama soware version—Verify that both Panorama HA peers are running the same
Panorama soware version (major and minor version number).

Monitor the File System Integrity Check
Panorama periodically performs a ﬁle system integrity check (FSCK) to prevent corrupon of the
Panorama system ﬁles. This check occurs aer eight reboots or at a reboot that occurs 90 days
aer the last FSCK was executed. If Panorama is running a FSCK, the web interface and Secure
Shell (SSH) login screens will display a warning to indicate that an FSCK is in progress. You cannot
log in unl this process completes. The me to complete this process varies by the size of the
storage system; depending on the size, it can take several hours before you can log back in to
Panorama.
Aer you successfully download and install a PAN-OS soware update on Panorama or a
managed ﬁrewall, the soware update is validated aer Panorama or the managed ﬁrewall reboots
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as part of the soware installaon process to ensure the PAN-OS soware integrity. This ensures
that the now running soware update is known good and that the Panorama or managed ﬁrewall
are not compromised to due remote or physical exploitaon.
To view the progress on the FSCK, set up console access to Panorama and view the status.

Manage Panorama Storage for Soware and Content Updates
You can Install Content and Soware Updates for Panorama, upgrade ﬁrewalls, and upgrade
upgrade Log Collectors using the Panorama™ management server. You cannot conﬁgure the
amount of space available on Panorama to store updates. When the alloted storage capacity
reaches 90%, Panorama alerts you to free up space (delete stored updates) for new downloads
or uploads. The maximum number of updates is a global seng that applies to all the updates
that Panorama stores. You must access the CLI to conﬁgure this seng. The default value is two
updates of each type.
Modify the maximum number of updates of each type.
Access the Panorama CLI and enter the following, where <number> can be between 2 and 64:
> set max-num-images count <number>
View the number of updates that Panorama currently stores.
Enter:
> show max-num-images
Use the web interface to delete updates to free up space on Panorama.
1. Select the type of update to delete:
• Firewall or Log Collector updates:
PAN-OS/Panorama soware images—Select Panorama > Device Deployment >
Soware.
GlobalProtect™ agent/app soware updates—Select Panorama > Device
Deployment > GlobalProtect Client.
Content updates—Select Panorama > Device Deployment > Dynamic Updates.
• Panorama soware images—Select Panorama > Soware.
• Panorama content updates—Select Panorama > Dynamic Updates.
2. Click the X icon in the far right column for the image or update.
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Use the CLI to delete updates to free up space on Panorama.
Delete soware images by version:
> delete software version <version_number>
Delete content updates:
> delete content update <filename>

Recover from Split Brain in Panorama HA Deployments
When Panorama is conﬁgured in a high availability (HA) setup, the managed ﬁrewalls are
connected to both the acve and passive Panorama HA peers. When the connecon between the
acve and the passive Panorama peers fails, before the passive Panorama takes over as the acve
peer it checks whether any ﬁrewall is connected to both the acve and the passive peer. If even
one ﬁrewall is connected to both peers, the failover is not triggered.
In the rare event that a failover is triggered when a set of ﬁrewalls are connected to the acve
peer and a set of ﬁrewalls are connected to the passive peer, but none of the ﬁrewalls are
connected to both peers, it is called a split brain. When a split brain occurs, the following
condions occur:
• Neither Panorama peer is aware of the state nor the HA role of the other peer.
• Both Panorama peers become acve and manage a unique set of ﬁrewalls.
To resolve a split brain, debug your network issues and restore connecvity between the
Panorama HA peers.
However, if you need to make conﬁguraon changes to your ﬁrewalls without restoring the
connecon between the peers, here are a couple of opons:
• Manually add the same conﬁguraon changes on both Panorama peers. This ensures that when
the link is reestablished the conﬁguraon is synchronized.
• If you need to add/change the conﬁguraon at only one Panorama locaon, make the changes
and synchronize the conﬁguraon (make sure that you iniate the synchronizaon from
the peer on which you made the changes) when the link between the Panorama peers is reestablished. To synchronize the peers, select the Dashboard tab and click the Sync to peer link
in the High Availability widget.
• If you need to add/change the conﬁguraon for only the connected ﬁrewalls at each locaon,
you can make conﬁguraon changes independently on each Panorama peer. Because the
peers are disconnected, there is no replicaon and each peer now has a completely diﬀerent
conﬁguraon ﬁle (they are out of sync). Therefore, to ensure that the conﬁguraon changes
on each peer are not lost when the connecon is restored, you cannot allow the conﬁguraon
to be automacally re-synchronized. To solve this problem, export the conﬁguraon from
each Panorama peer and manually merge the changes using an external diﬀ and merge tool.
Aer the changes are integrated, you can import the uniﬁed conﬁguraon ﬁle on the primary
Panorama and then synchronize the imported conﬁguraon ﬁle with the peer.
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Troubleshoot Log Storage and Connecon Issues
Migrang logs is supported only for M-Series appliance. Refer to Migrate a Panorama
Virtual Appliance to a Diﬀerent Hypervisor to migrate a Panorama virtual appliance.
• Verify Panorama Port Usage
• Resolve Zero Log Storage for a Collector Group
• Replace a Failed Disk on an M-Series Appliance
• Replace the Virtual Disk on an ESXi Server
• Replace the Virtual Disk on vCloud Air
• Migrate Logs to a New M-Series Appliance in Log Collector Mode
• Migrate Logs to a New M-Series Appliance in Panorama Mode
• Migrate Logs to a New M-Series Appliance Model in Panorama Mode in High Availability
• Migrate Logs to the Same M-Series Appliance Model in Panorama Mode in High Availability
• Migrate Log Collectors aer Failure/RMA of Non-HA Panorama
• Regenerate Metadata for M-Series Appliance RAID Pairs
• View Log Query Jobs

Verify Panorama Port Usage
To ensure that Panorama can communicate with managed ﬁrewalls, Log Collectors, and WildFire
appliances and appliance clusters, and its high availability (HA) peer, use the following table to
verify the ports that you must open on your network. Panorama uses TCP protocol for port
communicaons.
By default, Panorama uses the management (MGT) interface to manage devices (ﬁrewalls, Log
Collectors, and WildFire appliances and appliance clusters), collect logs, communicate with
Collector Groups, and deploy soware and content updates to devices. However, you can
oponally assign the log collecon and Collector Group communicaon funcons to the Eth1 or
Eth2 interfaces on an M-600, M-500 or M-200 appliance running Panorama 6.1 through 7.1. If
the appliance runs Panorama 8.0 or a later release, you can assign any funcon to the Eth1, Eth2,
Eth3, Eth4, or Eth5 interfaces on the M-600, M-500, or M-200 appliance. The ports listed in the
following table apply regardless of which funcon you assign to which interface. For example, if
you assign log collecon to MGT and assign Collector Group communicaon to Eth2, then MGT
will use port 3978 and Eth2 will use port 28270. (The Panorama virtual appliance can only use the
MGT interface for all these funcons.)
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Communicang Systems
& Direcon of Connecon
Establishment

Ports
Used in
Panorama
5.x

Ports
Used in
Panorama
6.x to 7.x

Ports
Used in
Panorama
8.x and
later

Descripon

Panorama and Panorama
(HA)

28

28

28

For HA connecvity
and synchronizaon if
encrypon is enabled.

Direcon: Each peer
iniates its own
connecon to the other

Panorama and Panorama
(HA)
Direcon: Each peer
iniates its own
connecon to the other

Panorama and managed
ﬁrewalls

Used for communicaon
between Log Collectors in
a Collector Group for log
distribuon.
28769
and
28260
(5.1)

28260 and
28769

28260
and
28769

For HA connecvity
and synchronizaon if
encrypon is not enabled.

3978

3978

3978

A bi-direconal
connecon where the logs
are forwarded from the
ﬁrewall to Panorama; and
conﬁguraon changes are
pushed from Panorama
to the managed ﬁrewalls.
Context switching
commands are sent over
the same connecon.

3978

3978

3978

For management and log
collecon/reporng.

28769
and
49160
(5.0)

Direcon: Iniated by the
ﬁrewall

Panorama and Log
Collector
Direcon: Iniated by the
Log Collector

Panorama and managed
devices (ﬁrewalls, Log
Collectors, and WildFire

Used for communicaon
between the local Log
Collector on a Panorama
in Panorama mode,
and for communicang
with Log Collectors in a
distributed log collecon
deployment.
3978
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Communicang Systems
& Direcon of Connecon
Establishment

Ports
Used in
Panorama
5.x

Ports
Used in
Panorama
6.x to 7.x

Ports
Used in
Panorama
8.x and
later

appliances and appliance
clusters)

retrieve soware and
content update ﬁles from
Panorama.

Direcon:

Devices running 7.x or
earlier releases do not
retrieve update ﬁles from
Panorama; Panorama
pushes the update ﬁles
to the devices over port
3978.

• Iniated by managed
devices running PANOS 8.x or later releases.
• Iniated by Panorama
for devices running
PAN-OS 7.x or earlier
releases.

Log Collector to Log
Collector

Support for Panorama
management of WildFire
appliances and appliance
clusters requires PANOS 8.0.1 or later
installed on the managed
WildFire appliances.
We recommend that
Panorama runs 8.0.1 or
later to manage WildFire
appliances and appliance
clusters.
49190

28270

28270

NA

NA

444

Direcon: Each Log
Collector iniates a
connecon to the other
Log Collectors in the
Collector Group
Panorama to Cortex Data
Lake

Descripon
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Resolve Zero Log Storage for a Collector Group
The log storage capacity for the Collector Group might display as 0MB if the disk pairs are not
enabled for logging in the Log Collectors. To enable the disk pairs, perform the following steps for
each Log Collector in the Collector Group.
STEP 1 | Add the RAID disk pairs.
1. Select Panorama > Managed Collectors and click the Collector Name.
2. Select Disks, Add each RAID disk pair, and click OK.
STEP 2 | Commit the changes to Panorama and push the changes to the Collector Group.
1. Select Commit > Commit and Push and Edit Selecons in the Push Scope.
2. Select Collector Groups, select the Collector Group you modiﬁed, and click OK.
3. Commit and Push your changes.
STEP 3 |

Verify the state of the Log Collectors and disk pairs.
1. Select Panorama > Managed Collectors and verify that the conﬁguraon of each Log
Collector is synchronized with Panorama.
The Conﬁguraon Status column should display In Sync and the Run Time Status column
should display connected.
2. Click Stascs in the last column for each Log Collector and verify that the disk pairs are
Enabled and Available.

Replace a Failed Disk on an M-Series Appliance
If a disk fails on the M-Series appliance, you must replace the disk and reconﬁgure it in a RAID 1
array. For details, refer to the M-Series appliance Hardware Reference Guides.

Replace the Virtual Disk on an ESXi Server
You cannot resize a virtual disk aer adding it to the Panorama virtual appliance running on a
VMware ESXi server. Because the Panorama virtual appliance in Legacy mode allows only one log
storage locaon, you must replace the virtual disk as follows to modify the log storage capacity.
In Panorama mode, you can simply add another disk (up to the maximum of 12) to Expand Log
Storage Capacity on the Panorama Virtual Appliance.
On the Panorama virtual appliance in Legacy mode, you will lose the logs on the exisng
disk when you replace it. For the opons to preserve exisng logs, see Preserve Exisng
Logs When Adding Storage on Panorama Virtual Appliance in Legacy Mode.
STEP 1 | Remove the old virtual disk.
1. Access the VMware vSphere Client and select the Virtual Machines tab.
2. Right-click the Panorama virtual appliance and select Power > Power Oﬀ.
3. Right-click the Panorama virtual appliance and select Edit Sengs.
4. Select the virtual disk in the Hardware tab and click Remove.
5. Select one of the Removal Opons and click OK.
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STEP 2 | Add the new virtual disk.
1. Add a Virtual Disk to Panorama on an ESXi Server.
Panorama running on ESXi 5.5 and later versions supports a virtual disk of up to 8TB.
Panorama running on an earlier ESXi version supports a virtual disk of up to 2TB.
2. In the vSphere Client, right-click the Panorama virtual appliance and select Power >
Power On.
The reboot process might take several minutes and the message cache data
unavailable will display.
STEP 3 | Verify that the modiﬁed log storage capacity is correct.
1. Log in to the Panorama virtual appliance.
2. Select Panorama > Setup > Management and verify that the Logging and Reporng
Sengs secon, Log Storage ﬁeld, displays the modiﬁed log storage capacity accurately.

Replace the Virtual Disk on vCloud Air
You cannot resize a virtual disk aer adding it to the Panorama virtual appliance running on
VMware vCloud Air. Because the Panorama virtual appliance in Legacy mode allows only one log
storage locaon, you must replace the virtual disk as follows to modify the log storage capacity.
In Panorama mode, you can simply Add a Virtual Disk to Panorama on vCloud Air (up to the
maximum of 12).
On the Panorama virtual appliance in Legacy mode, you will lose the logs on the exisng
disk when you replace it. For the opons to preserve exisng logs, see Preserve Exisng
Logs When Adding Storage on Panorama Virtual Appliance in Legacy Mode.
STEP 1 | Remove the old virtual disk.
1. Access the vCloud Air web console and select your Virtual Private Cloud OnDemand
region.
2. Select the Panorama virtual appliance in the Virtual Machines tab.
3. Select Acons > Edit Resources.
4. Click x for the virtual disk you are removing.
STEP 2 | Add the new virtual disk.
1. Add another disk.
2. Set the Storage to up to 8TB and set the storage er to Standard or SSD-Accelerated.
3. Save your changes.
STEP 3 | Reboot Panorama.
1. Log in to the Panorama virtual appliance.
2. Select Panorama > Setup > Operaons and Reboot Panorama.
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STEP 4 | Verify that the modiﬁed log storage capacity is correct.
1. Log in to the Panorama virtual appliance aer it reboots.
2. Select Panorama > Setup > Management and verify that the Logging and Reporng
Sengs secon, Log Storage ﬁeld, displays the modiﬁed log storage capacity accurately.

Migrate Logs to a New M-Series Appliance in Log Collector Mode
If you need to replace an M-600, M-500, M-200 or M-100 appliance in Log Collector mode
(Dedicated Log Collector), you can migrate the logs it collected from ﬁrewalls by moving its RAID
disks to a new M-Series appliance. This procedure enables you to recover logs aer a system
failure on the M-Series appliance or to migrate logs as part of a hardware upgrade (from an M-100
appliance to a M-500 appliance).
Migrang logs by removing the logging disks from any M-Series appliance and loading
them into an M-600 Panorama management server is not supported. To migrate to an
M-600 appliance, set up the M-600 appliance, conﬁgure log forwarding to the new
M-600 appliance and conﬁgure the M-Series appliance as a managed Log Collector
unl you no longer needed access to the logs stored on the M-Series appliance.
STEP 1 | Perform inial setup of the new M-Series appliance that will be a Dedicated Log Collector.
1. Rack mount the M-Series appliance. Refer to the M-Series Appliance Hardware
Reference Guides for instrucons.
2. Perform Inial Conﬁguraon of the M-Series Appliance.
When conﬁguring interfaces, conﬁgure only the Management (MGT) interface.
Switching to Log Collector mode (later in this procedure) removes the
conﬁguraons for any other interfaces. If the Log Collector will use interfaces
other than MGT, add them when conﬁguring the Log Collector (see Step 2).
3. Register Panorama.
4. Purchase and acvate the Panorama support license or transfer licenses as follows only
if the new M-Series appliance is the same hardware model as the old M-Series appliance.
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If the new M-Series appliance is a diﬀerent model than the old M-Series appliance, you
must purchase new licenses.
1. Log in to the Palo Alto Networks Customer Support web site.
2. Select the Assets tab and click the Spares link.
3. Click the Serial Number of the new M-Series appliance.
4. Click Transfer Licenses.
5. Select the old M-Series appliance and click Submit.
5. Acvate a ﬁrewall management license. If you are migrang from an M-100 appliance to
a M-500 appliance, enter the auth-code associated with the migraon license.
6. Install Content and Soware Updates for Panorama. For important details about
soware versions, see Panorama, Log Collector, Firewall, and WildFire Version
Compability.
7. Switch from Panorama mode to Log Collector mode:
1. Access the Log Collector CLI and switch to Log Collector mode:
> request system system-mode logger
2. Enter Y to conﬁrm the mode change. The M-Series appliance reboots. If the reboot
process terminates your terminal emulaon soware session, reconnect to the MSeries appliance to display the Panorama login prompt.
If you see a CMS Login prompt, press Enter without typing a username or
password.
8. Use the Log Collector CLI to enable connecvity between the Log Collector and
Panorama management server. <IPaddress1 is for the MGT interface of the primary
Panorama and <IPaddress2> is for the MGT interface of the secondary Panorama.
> configure
# set deviceconfig system panorama-server <IPaddress1>
panorama-server-2 <IPaddress2>
# commit
# exit
STEP 2 | On the Panorama management server, add the new Log Collector as a managed collector.
For all steps with commands that require a serial number, you must type the enre
serial number; pressing the Tab key won’t complete a paral serial number.
1. Conﬁgure the Log Collector as a managed collector using the Panorama web interface or
using the following CLI commands:
> configure
# set log-collector <LC_serial_number> deviceconfig system
hostname <LC_hostname>
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# exit
If the old Log Collector used interfaces other than the MGT interface for log
collecon and Collector Group communicaon, you must deﬁne those interfaces
on the new Log Collector when you conﬁgure it as a managed collector
(Panorama > Managed Collectors > Interfaces).
2. Verify that the Log Collector is connected to Panorama and that the status of its disk
pairs is present/available.
> show log-collector serial-number <log-collector_SN>
The disk pairs will display as disabled at this stage of the restoraon process.
3. Commit your changes to Panorama. Don’t commit the changes to the Collector Group
just yet.
> configure
# commit
# exit
STEP 3 | Remove the RAID disks from the old Log Collector.
1. Power oﬀ the old Log Collector by pressing the Power buon unl the system shuts
down.
2. Remove the disk pairs. For details, refer to the disk replacement procedure in the MSeries Appliance Hardware Reference Guides.
STEP 4 | Prepare the disks for migraon.
Generang the metadata for each disk pair rebuilds the indexes. Therefore, depending
on the data size, this process can take a long me to complete. To expedite the process,
you can launch mulple CLI sessions and run the metadata regeneraon command
in each session to complete the process simultaneously for every pair. For details, see
Regenerate Metadata for M-Series Appliance RAID Pairs.
1. Insert the disks into the new Log Collector. For details, refer to the disk replacement
procedure in the M-Series Appliance Hardware Reference Guides.
The disk carriers of the M-100 appliance are incompable with those of the
M-500 appliance. Therefore, when migrang between these hardware models,
you must unscrew each disk from its old carrier and insert the disk in the new
carrier before inserng the disk in the new appliance.
You must maintain the disk pair associaon. Although you can place a disk pair from
slot A1/A2 on the old appliance into slot B1/B2 on the new appliance, you must keep
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the disks together in the same slot; otherwise, Panorama might not restore the data
successfully.
2. Enable the disk pairs by running the following CLI command for each pair:
> request system raid add <slot> force no-format
For example:
> request system raid add A1 force no-format
> request system raid add A2 force no-format
The force and no-format arguments are required. The force argument associates
the disk pair with the new Log Collector. The no-format argument prevents
reformang of the drives and retains the logs stored on the disks.
3. Generate the metadata for each disk pair.
> request metadata-regenerate slot <slot_number>
For example:
> request metadata-regenerate slot 1
STEP 5 | Add a Log Collector with no disks to a Collector Group.
From this point, only commits that are required to complete the migraon process on
Panorama and the Log Collectors. Hold oﬀ making any other changes.
1. Access the Panorama CLI.
2. Overwrite Panorama restricon to allow Log Collector with no disk to be added to a
Collector Group: request log-migration-set-start
STEP 6 | Migrate the logs.
You must use the Panorama CLI for this step, not the web interface.
You must assign the new Log Collector to the Collector Group that contains the old Log
Collector.
1. Assign the new Log Collector to the Collector Group and commit your changes to
Panorama.
> configure
# set log-collector-group <collector_group_name> logfwdsetting collectors <new_LC_serial_number>
# commit
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# exit
2. For each disk pair, migrate the logs from the old Log Collector to the new Log Collector
and aach the disk pair to the new Log Collector.
> request log-migration from <old_LC_serial_number> olddisk-pair <log_disk_pair> to <new_LC_serial_number> new-diskpair <log_disk_pair>
For example:
> request log-migration from 003001000010 old-disk-pair A to
00300100038 new-disk-pair A
STEP 7 | Reconﬁgure the Collector Group.
1. Use the web interface to assign the new Log Collector to the ﬁrewalls that forward logs
(Panorama > Collector Groups > Device Log Forwarding). Give the new Log Collector the
same priority in the ﬁrewall preference lists as the old Log Collector.
You cannot use the CLI change the priority assignments of ﬁrewall preference
lists.
2. Delete the old Log Collector from the Collector Group.
> configure
# delete log-collector-group <group_name> logfwd-setting
collectors <old_LC_serial_number>
For example:
# delete log-collector-group DC-Collector-Group logfwd-setting
collectors 003001000010
3. Delete the old Log Collector from the Panorama conﬁguraon and commit your changes
to Panorama.
# delete log-collector <old_LC_serial_number>
# commit
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# exit
4. Commit the Collector Group changes so that the managed ﬁrewalls can send logs to the
new Log Collector.
> commit-all log-collector-config log-collectorgroup <collector_group_name>
For example:
> commit-all log-collector-config log-collector-group DCCollector-Group
STEP 8 | Generate new keys on the new Dedicated Log Collector.
This command is required in order to add the new Log Collector to the Collector Group
and should only be run for the Collector Group of the Log Collector being replaced. This
step deletes the exisng RSA keys and allows Panorama to create new RSA keys.
1. Access the Panorama CLI.
2. Delete all RSA keys on new Log Collector:
request logdb update-collector-group-after-replace collectorgroup <collector-group-name>
The process can take up to 10 minutes to completed.
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STEP 9 | Conﬁrm that SearchEngine Status is Acve for all Log Collectors in the Collector Group.
Do not connue unl SearchEngine Status is Acve for all Log Collectors in the
Collector Group. This will result in purging of logs from the Log Collector being replaced.
1. Access the Panorama CLI.
2. Show the Log Collector details by running the following commands either:
• On Panorama for all Log Collectors:
show log-collector all
Alternavely, you can run the following command on each Dedicated Log
Collector:
show log-collector detail
3. Conﬁrm that SearchEngine Status is Acve.
Redistribution status:

none

Last commit-all: commit succeeded, current ring version 1
SearchEngine status:

Active

md5sum 4e5055a359f7662fab8f8c4f57e24525 updated at 2017/06/14
09:58:19
STEP 10 | On the new Log Collector, replace previous Log Collector serial number with the new Log
Collector serial number.
You must replace the old Log Collector serial number with the new Log Collector serial number
so that the new Log Collector will not run in to purging issues, resulng in the Log Collector
being unable to purge old data from the migrated logs when necessary.
1. Access the Log Collector CLI.
2. Replace old Log Collector serial number with new Log Collector serial number:
request log-migration-update-logger from <old-log-collectorserial-number> to <new-log-collector-serial-number>

Migrate Logs to a New M-Series Appliance in Panorama Mode
If you need to replace an M-600, M-500, M-200 or M-100 appliance in Panorama mode
(Panorama management server), you can migrate the logs it collected from ﬁrewalls by moving its
RAID disks to the new M-Series appliance. Moving the disks enables you to recover logs aer a
system failure on the M-Series appliance or to migrate logs as part of a hardware upgrade (from an
M-100 appliance to an M-500 appliance).
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Migrang logs by removing the logging disks from any M-Series appliance and loading
them into an M-600 Panorama management server is not supported. To migrate to an
M-600 appliance, set up the M-600 appliance, conﬁgure log forwarding to the new
M-600 appliance and conﬁgure the M-Series appliance as a managed Log Collector
unl you no longer needed access to the logs stored on the M-Series appliance.
This migraon procedure covers the following scenarios where you are replacing a single M-Series
appliance, not in a HA conﬁguraon, with a managed collector (Log Collector) in a Collector Group.
STEP 1 | Forward any logs on the SSD of the old M-Series appliance to an external desnaon if you
want to preserve them.
The SSD stores the System and Conﬁg logs that Panorama and Log Collectors generate. You
cannot move the SSD between M-Series appliances.
Conﬁgure Log Forwarding from Panorama to External Desnaons.
STEP 2 | Export the Panorama conﬁguraon from the decommissioned M-Series appliance in
Panorama mode.
1. Log in to the Panorama appliance and select Panorama > Setup > Operaons.
2. Click Save named Panorama conﬁguraon snapshot, enter a Name to idenfy the
conﬁguraon, and click OK.
3. Click Export named Panorama conﬁguraon snapshot, select the Name of the
conﬁguraon you just saved, and click OK. Panorama exports the conﬁguraon to your
client system as an XML ﬁle.
STEP 3 | Remove the RAID disks from the old M-Series appliance.
1. Power oﬀ the old M-Series appliance by pressing the Power buon unl the system
shuts down.
2. Remove the disk pairs. For details, refer to the disk replacement procedure in the MSeries Appliance Hardware Reference Guides.
STEP 4 | Perform inial setup of the new M-Series appliance.
1. Rack mount the M-Series appliance. Refer to the M-Series Appliance Hardware
Reference Guides for instrucons.
2. Perform Inial Conﬁguraon of the M-Series Appliance.
3. Register Panorama.
4. Purchase and acvate a Panorama support license or transfer licenses as follows only if
the new M-Series appliance is the same hardware model as the old M-Series appliance.
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If the new M-Series appliance is a diﬀerent model than the old M-Series appliance, you
must purchase new licenses.
1. Log in to the Palo Alto Networks Customer Support web site.
2. Select the Assets tab and click the Spares link.
3. Click the Serial Number of the new M-Series appliance.
4. Click Transfer Licenses.
5. Select the old M-Series appliance and click Submit.
5. Acvate a ﬁrewall management license. If you are migrang from an M-100 appliance to
an M-500 appliance, enter the auth-code associated with the migraon license.
6. Install Content and Soware Updates for Panorama. For important details about
soware versions, see Panorama, Log Collector, Firewall, and WildFire Version
Compability.
STEP 5 | Load the Panorama conﬁguraon snapshot that you exported from the decommissioned MSeries appliance into the new M-Series appliance in Panorama mode.
1. Log in to the Panorama Web Interface of the new M-Series appliance and select
Panorama > Setup > Operaons.
2. Click Import named Panorama conﬁguraon snapshot, Browse to the conﬁguraon ﬁle
you exported from the decommissioned M-Series appliance, and click OK.
3. Click Load named Panorama conﬁguraon snapshot, select the Name of the
conﬁguraon you just imported, select a Decrypon Key (the master key for Panorama),
and click OK. Panorama overwrites its current candidate conﬁguraon with the loaded
conﬁguraon. Panorama displays any errors that occur when loading the conﬁguraon
ﬁle. If errors occurred, save them to a local ﬁle. Resolve each error to ensure the
migrated conﬁguraon is valid.
To replace an RMA Panorama, make sure you Retain Rule UUIDs when you load
the named Panorama conﬁguraon snapshot. If you do not select this opon,
Panorama removes all previous rule UUIDs from the conﬁguraon snapshot and
assigns new UUIDs to the rules on Panorama, which means it does not retain
informaon associated with the previous UUIDs, such as the policy rule hit
count.
4. Perform any addional conﬁguraon changes as needed.
If the old M-Series appliance used interfaces other than the MGT interface for
Panorama services (such as log collecon), you must deﬁne those interfaces on
the new M-Series appliance (Panorama > Setup > Interfaces).
5. Select Commit > Commit to Panorama and Validate Commit. Resolve any errors before
proceeding.
6. Commit your changes to the Panorama conﬁguraon.
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STEP 6 | Insert the disks into the new M-Series appliance. For details, refer to the disk replacement
procedure in the M-Series Appliance Hardware Reference Guides.
The disk carriers of the M-100 appliance are incompable with those of the M-500
appliance. Therefore, when migrang between these hardware models, you must
unscrew each disk from its old carrier and insert the disk in the new carrier before
inserng the disk in the new appliance.
You must maintain the disk pair associaon. Although you can place a disk pair from slot A1/A2
on the old appliance into slot B1/B2 on the new appliance, you must keep the disks together in
the same slot; otherwise, Panorama might not restore the data successfully.
STEP 7 | Contact Palo Alto Networks Customer Support to copy log collector group metadata from
the decommissioned M-Series appliance to the new M-Series appliance and restart the
mgmtsrvr process.
STEP 8 | If the M-Series appliance was part of a Collector Group, verify that the decommissioned MSeries appliance serial number is sll part of the correct Collector Group:
debug log-collector-group show name <Log Collector Group name>
If the decommissioned M-Series appliance serial number is no longer a part of the correct
Collector Group, then the Tech Support folders were incorrectly copied in the previous step.
Contact Palo Alto Networks Customer Support again to copy the Tech Support folders to the
correct locaon.
STEP 9 | Prepare the disks for migraon.
Generang the metadata for each disk pair rebuilds the indexes. Therefore, depending
on the data size, this process can take a long me to complete. To expedite the process,
you can launch mulple CLI sessions and run the metadata regeneraon command
in each session to complete the process simultaneously for every pair. For details, see
Regenerate Metadata for M-Series Appliance RAID Pairs.
1. Insert the disks into the new M-Series appliance. For details, refer to the disk
replacement procedure in the M-Series Appliance Hardware Reference Guides.
The disk carriers of the M-100 appliance are incompable with those of the
M-500 appliance. Therefore, when migrang between these hardware models,
you must unscrew each disk from its old carrier and insert the disk in the new
carrier before inserng the disk in the new appliance.
You must maintain the disk pair associaon. Although you can place a disk pair from
slot A1/A2 on the old appliance into slot B1/B2 on the new appliance, you must keep
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the disks together in the same slot; otherwise, Panorama might not restore the data
successfully.
2. Enable the disk pairs by running the following CLI command for each pair:
admin> request system raid add <slot> force no-format
For example:
admin> request system raid add A1 force no-format
admin> request system raid add A2 force no-format
The force and no-format arguments are required. The force argument associates the disk
pair with the new appliance. The no-format argument prevents reformang of the drives
and retains the logs stored on the disks.
3. Generate the metadata for each disk pair.
This step may take up to 6 hours depending on the volume of log data on the
disks.
admin> request metadata-regenerate slot <slot_number>
For example:
admin> request metadata-regenerate slot 1
STEP 10 | Conﬁgure the local Log Collector on the new M-Series appliance.
For all steps with commands that require a serial number, you must type the enre
serial number; pressing the Tab key won’t complete a paral serial number.
Don’t enable the disks on the new M-Series appliance at this point. When you successfully
migrate the logs, Panorama automacally enables the disks.
1. Conﬁgure the local Log Collector as a managed collector using the Panorama web
interface or using the following CLI commands:
admin> configure
admin# set log-collector <log-collector_SN> deviceconfig
system hostname <log-collector-hostname>
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admin# exit
2. Verify that the local Log Collector is connected to Panorama and that the status of its
disk pairs is present/available.
admin> show log-collector serial-number <log-collector_SN>
The disk pairs will display as disabled at this stage of the restoraon process.
3. Commit your changes to Panorama. Don’t commit the changes to the Collector Group
just yet.
admin> configure
admin# commit
STEP 11 | Add a Log Collector with no disks to a Collector Group.
From this point, only commits that are required to complete the migraon process on
Panorama and the Log Collectors. Hold oﬀ making any other changes.
1. Access the Panorama CLI of the new M-Series appliance.
2. Overwrite Panorama restricon to allow Log Collector with no disk to be added to a
Collector Group: request log-migration-set-start
3. Commit the overwrien restricon:
admin> configure
admin# commit force
STEP 12 | Migrate the logs.
1. Access the Panorama CLI of the new M-Series appliance.
2. Add the new local Log Collector as a member of the Collector Group and commit your
changes to Panorama.
admin# set log-collector-group <collector_group_name> logfwdsetting collectors <SN_managed_collector>
admin# commit
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admin# exit
The old local Log Collector sll appears in the list of members, because you haven’t
deleted it from the conﬁguraon.
3. For each disk pair, migrate the logs to the new appliance.
admin> request log-migration from <old_LC_serial_number> olddisk-pair <log_disk_pair> to <new_LC_serial_number> new-diskpair <log_disk_pair>
For example:
admin> request log-migration from 003001000010 old-disk-pair A
to 00300100038 new-disk-pair A
4. Commit the changes to Panorama.
admin> configure
admin# commit
STEP 13 | Reconﬁgure the Collector Group.
1. Log in to the Panorama Web Interface of the new M-Series appliance to assign the new
Log Collector to the ﬁrewalls that forward logs (Panorama > Collector Groups > Device
Log Forwarding). Give the new Log Collector the same priority in the ﬁrewall preference
lists as the old Log Collector.
You cannot use the CLI change the priority assignments of ﬁrewall preference
lists.
2. Access the Panorama CLI of the new M-Series appliance.
3. Delete the old Log Collector from the Collector Group.
admin# delete log-collector-group <group_name> logfwd-setting
collectors <old_LC_serial_number>
For example:
admin# delete log-collector-group DC-Collector-Group logfwdsetting collectors 003001000010
4. Delete the old Log Collector from the Panorama conﬁguraon and commit your changes
to Panorama.
admin# delete log-collector <old_LC_serial_number>
admin# commit
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admin# exit
5. Commit the Collector Group changes so that the managed ﬁrewalls can send logs to the
new Log Collector.
admin> commit-all log-collector-config log-collectorgroup <collector_group_name>
For example:
admin> commit-all log-collector-config log-collector-group DCCollector-Group
STEP 14 | Generate new keys on the new Log Collector.
This command is required in order to add the new Log Collector to the Collector Group
and should only be run for the Collector Group of the Log Collector being replaced. This
step deletes the exisng RSA keys and allows Panorama to create new RSA keys.
1. Access the Panorama CLI of the new M-Series appliance.
2. Delete all RSA keys on the new Log Collector:
request logdb update-collector-group-after-replace collectorgroup <collector-group-name>
The process can take up to 10 minutes to completed.
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STEP 15 | Conﬁrm that SearchEngine Status is Acve for all Log Collectors in the Collector Group.
Do not connue unl SearchEngine Status is Acve for all Log Collectors in the
Collector Group. This will result in purging of logs from the Log Collector being replaced.
1. Access the Panorama CLI of the new M-Series appliance.
2. Show the Log Collector details by running the following commands either:
• On Panorama for all Log Collectors:
show log-collector all
Alternavely, you can run the following command on each Dedicated Log
Collector:
show log-collector detail
3. Conﬁrm that SearchEngine Status is Acve.
Redistribution status:

none

Last commit-all: commit succeeded, current ring version 1
SearchEngine status:

Active

md5sum 4e5055a359f7662fab8f8c4f57e24525 updated at 2017/06/14
09:58:19
STEP 16 | On the new Log Collector, replace previous Log Collector serial number with the new Log
Collector serial number.
You must replace the old Log Collector serial number with the new Log Collector serial number
so that the new Log Collector will not run in to purging issues, resulng in the Log Collector
being unable to purge old data from the migrated logs when necessary.
1. Access the Log Collector CLI.
2. Replace old Log Collector serial number with new Log Collector serial number:
request log-migration-update-logger from <old-log-collectorserial-number> to <new-log-collector-serial-number>

Migrate Logs to a New M-Series Appliance Model in Panorama
Mode in High Availability
If you need to replace an M-600, M-500, M-200 or M-100 appliance in Panorama mode
(Panorama management server) with a diﬀerent M-Series appliance than the M-Series appliance
being replaced, you can migrate the logs it collected from ﬁrewalls by moving its RAID disks to
the new M-Series appliance. Moving the disks enables you to migrate logs as part of a hardware
upgrade (from an M-100 appliance to an M-500 appliance). You can migrate an M-100 appliance
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to and from an M-500 appliance. M-100 and M-500 appliances cannot be migrated to or from
M-200 or M-600 appliances.
Migrang logs by removing the logging disks from any M-Series appliance and loading
them into an M-600 Panorama management server is not supported. To migrate to an
M-600 appliance, set up the M-600 appliance, conﬁgure log forwarding to the new
M-600 appliance and conﬁgure the M-Series appliance as a managed Log Collector
unl you no longer needed access to the logs stored on the M-Series appliance.
This migraon procedure covers the following scenarios:
• One Panorama HA peer has a managed collector (Log Collector) in a Collector Group.

Figure 28: Panorama HA Peer with Collector Group
• Both Panorama HA peers have managed collectors that belong to a single Collector Group. For
details, see Mulple Local Log Collectors Per Collector Group.
• Both Panorama HA peers have a managed collector and each is assigned to a separate
Collector Group. For details, see Single Local Log Collector Per Collector Group.
STEP 1 | Forward any logs on the SSD of the old M-Series appliance to an external desnaon if you
want to preserve them.
The SSD stores the System and Conﬁg logs that Panorama and Log Collectors generate. You
cannot move the SSD between M-Series appliances.
Conﬁgure Log Forwarding from Panorama to External Desnaons.
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STEP 2 | Export the Panorama conﬁguraon from the Primary decommissioned M-Series appliance in
Panorama mode.
1. Log in to the Panorama Web Interface of the M-Series appliance you are replacing and
select Panorama > Setup > Operaons.
2. Click Save named Panorama conﬁguraon snapshot, enter a Name to idenfy the
conﬁguraon, and click OK.
3. Click Export named Panorama conﬁguraon snapshot, select the Name of the
conﬁguraon you just saved, and click OK. Panorama exports the conﬁguraon to your
client system as an XML ﬁle.
STEP 3 | Remove the RAID disks from the old M-Series appliance.
1. Power oﬀ the old M-Series appliance by pressing the Power buon unl the system
shuts down.
2. Remove the disk pairs. For details, refer to the disk replacement procedure in the MSeries Appliance Hardware Reference Guides.
STEP 4 | Perform inial setup of the new M-Series appliance.
Repeat this step for each of the new M-Series appliances in the HA conﬁguraon.
1. Rack mount the M-Series appliance. Refer to the M-Series Appliance Hardware
Reference Guides for instrucons.
2. Perform Inial Conﬁguraon of the M-Series Appliance.
3. Register Panorama.
4. Purchase and acvate a Panorama support license or transfer licenses as follows only if
the new M-Series appliance is the same hardware model as the old M-Series appliance.
If the new M-Series appliance is a diﬀerent model than the old M-Series appliance, you
must purchase new licenses.
1. Log in to the Palo Alto Networks Customer Support web site.
2. Select the Assets tab and click the Spares link.
3. Click the Serial Number of the new M-Series appliance.
4. Click Transfer Licenses.
5. Select the old M-Series appliance and click Submit.
5. Acvate a ﬁrewall management license. If you are migrang from an M-100 appliance to
an M-500 appliance, enter the auth-code associated with the migraon license.
6. Install Content and Soware Updates for Panorama. For important details about
soware versions, see Panorama, Log Collector, Firewall, and WildFire Version
Compability.
7. Set Up HA on Panorama. The new M-Series appliance must have the same priority as the
HA peer you are replacing.
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STEP 5 | Load the Panorama conﬁguraon snapshot that you exported from the Primary
decommissioned M-Series appliance into the new Primary M-Series appliance in Panorama
mode.
1. Log in to the Panorama Web Interface of the new M-Series appliance and select
Panorama > Setup > Operaons.
2. Click Import named Panorama conﬁguraon snapshot, Browse to the conﬁguraon ﬁle
you exported from the decommissioned M-Series appliance, and click OK.
3. Click Load named Panorama conﬁguraon snapshot, select the Name of the
conﬁguraon you just imported, select a Decrypon Key (the master key for Panorama),
and click OK. Panorama overwrites its current candidate conﬁguraon with the loaded
conﬁguraon. Panorama displays any errors that occur when loading the conﬁguraon
ﬁle. If errors occurred, save them to a local ﬁle. Resolve each error to ensure the
migrated conﬁguraon is valid.
To replace an RMA Panorama, make sure you Retain Rule UUIDs when you load
the named Panorama conﬁguraon snapshot. If you do not select this opon,
Panorama removes all previous rule UUIDs from the conﬁguraon snapshot and
assigns new UUIDs to the rules on Panorama, which means it does not retain
informaon associated with the previous UUIDs, such as the policy rule hit
count.
4. Perform any addional conﬁguraon changes as needed.
If the old M-Series appliance used interfaces other than the MGT interface for
Panorama services (such as log collecon), you must deﬁne those interfaces on
the new M-Series appliance (Panorama > Setup > Interfaces).
5. Select Commit > Commit to Panorama and Validate Commit. Resolve any errors before
proceeding.
6. Commit your changes to the Panorama conﬁguraon. Once commied, the Panorama
conﬁguraon is synced across the HA peers.
STEP 6 | Insert the disks into the new M-Series appliance. For details, refer to the disk replacement
procedure in the M-Series Appliance Hardware Reference Guides.
Repeat this step for each of the new M-Series appliances in the HA conﬁguraon.
The disk carriers of the M-100 appliance are incompable with those of the M-500
appliance. Therefore, when migrang between these hardware models, you must
unscrew each disk from its old carrier and insert the disk in the new carrier before
inserng the disk in the new appliance.
You must maintain the disk pair associaon. Although you can place a disk pair from slot A1/A2
on the old appliance into slot B1/B2 on the new appliance, you must keep the disks together in
the same slot; otherwise, Panorama might not restore the data successfully.
STEP 7 | Contact Palo Alto Networks Customer Support to copy log collector group metadata from
the decommissioned M-Series appliance to the new M-Series appliance and restart the
mgmtsrvr process.
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STEP 8 | If the M-Series appliance was part of a Collector Group, verify that the decommissioned MSeries appliance serial number is sll part of the correct Collector Group:
debug log-collector-group show name <Log CollectorGroup name>
If the decommissioned M-Series appliance serial number is no longer a part of the correct
Collector Group, then the Tech Support folders were incorrectly copied in the previous step.
Contact Palo Alto Networks Customer Support again to copy the Tech Support folders to the
correct locaon.
STEP 9 | Prepare the disks for migraon.
Generang the metadata for each disk pair rebuilds the indexes. Therefore, depending
on the data size, this process can take a long me to complete. To expedite the process,
you can launch mulple CLI sessions and run the metadata regeneraon command
in each session to complete the process simultaneously for every pair. For details, see
Regenerate Metadata for M-Series Appliance RAID Pairs.
1. Enable the disk pairs by running the following CLI command for each pair:
admin> request system raid add <slot> force no-format
For example:
admin> request system raid add A1 force no-format
admin> request system raid add A2 force no-format
The force and no-format arguments are required. The force argument associates the disk
pair with the new appliance. The no-format argument prevents reformang of the drives
and retains the logs stored on the disks.
2. Generate the metadata for each disk pair.
This step may take up to 6 hours depending on the volume of log data on the
disks.
admin> request metadata-regenerate slot <slot_number>
For example:
admin> request metadata-regenerate slot 1

Panorama Administrator's Guide Version Version 10.1

620

©2022 Palo Alto Networks, Inc.

Troubleshoong
STEP 10 | Conﬁgure the local Log Collector on the new M-Series appliance.
For all steps with commands that require a serial number, you must type the enre
serial number; pressing the Tab key won’t complete a paral serial number.
Don’t enable the disks on the new M-Series appliance at this point. When you successfully
migrate the logs, Panorama automacally enables the disks.
1. Conﬁgure the local Log Collector as a managed collector using the Panorama web
interface or using the following CLI commands:
admin> configure
admin# set log-collector <log-collector_SN> deviceconfig
system hostname <log-collector-hostname>
admin# exit
2. Commit your changes to Panorama. Don’t commit the changes to the Collector Group
just yet.
admin> configure
admin# commit
3. Verify that the local Log Collector is connected to Panorama and that the status of its
disk pairs is present/available.
admin> show log-collector serial-number <log-collector_SN>
The disk pairs will display as disabled at this stage of the restoraon process.
STEP 11 | Add a Log Collector with no disks to a Collector Group.
From this point, only commits that are required to complete the migraon process on
Panorama and the Log Collectors. Hold oﬀ making any other changes.
1. Access the Panorama CLI of the new M-Series appliance.
2. Overwrite Panorama restricon to allow Log Collector with no disk to be added to a
Collector Group: requestlog-migration-set-start
3. Commit the changes to Panorama.
admin> configure
admin# commit force
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STEP 12 | Migrate the logs.
1. Access the Panorama CLI of the new M-Series appliance.
2. Add the new local Log Collector as a member of the Collector Group and commit your
changes to Panorama.
admin# set log-collector-group <collector_group_name> logfwdsetting collectors <SN_managed_collector>
admin# commit
admin# exit
The old local Log Collector sll appears in the list of members, because you haven’t
deleted it from the conﬁguraon.
3. For each disk pair, migrate the logs to the new appliance.
admin> request log-migration from <old_LC_serial_number> olddisk-pair <log_disk_pair> to <new_LC_serial_number> new-diskpair <log_disk_pair>
For example:
admin> request log-migration from 003001000010 old-disk-pair A
to 00300100038 new-disk-pair A
4. Commit the changes to Panorama.
admin> configure
admin# commit
STEP 13 | Reconﬁgure the Collector Group.
1. Log in to the Panorama Web Interface of the new M-Series appliance to assign the new
Log Collector to the ﬁrewalls that forward logs (Panorama > Collector Groups > Device
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Log Forwarding). Give the new Log Collector the same priority in the ﬁrewall preference
lists as the old Log Collector.
You cannot use the CLI change the priority assignments of ﬁrewall preference
lists.
2. Access the Panorama CLI of the new M-Series appliance.
3. Delete the old Log Collector from the Collector Group.
admin# delete log-collector-group <group_name> logfwd-setting
collectors <old_LC_serial_number>
For example:
admin# delete log-collector-group DC-Collector-Group logfwdsetting collectors 003001000010
4. Delete the old Log Collector from the Panorama conﬁguraon and commit your changes
to Panorama.
admin# delete log-collector <old_LC_serial_number>
admin# commit
admin# exit
5. Commit the Collector Group changes so that the managed ﬁrewalls can send logs to the
new Log Collector.
admin> commit-all log-collector-config log-collectorgroup <collector_group_name>
For example:
admin> commit-all log-collector-config log-collector-group DCCollector-Group
STEP 14 | Generate new keys on the new Log Collector.
This command is required in order to add the new Log Collector to the Collector Group
and should only be run for the Collector Group of the Log Collector being replaced. This
step deletes the exisng RSA keys and allows Panorama to create new RSA keys.
1. Access the Panorama CLI of the new M-Series appliance.
2. Delete all RSA keys on the new Log Collector:
request logdb update-collector-group-after-replacecollectorgroup <collector-group-name>
The process can take up to 10 minutes to completed.
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STEP 15 | Conﬁrm that SearchEngine Status is Acve for all Log Collectors in the Collector Group.
Do not connue unl SearchEngine Status is Acve for all Log Collectors in the
Collector Group. This will result in purging of logs from the Log Collector being replaced.
1. Access the Panorama CLI of the new M-Series appliance.
2. Show the Log Collector details by running the following commands either:
• On Panorama for all Log Collectors:
show log-collector all
Alternavely, you can run the following command on each Dedicated Log
Collector:
show log-collector detail
3. Conﬁrm that SearchEngine Status is Acve.
Redistribution status:

none

Last commit-all: commit succeeded, current ring version 1
SearchEngine status:

Active

md5sum 4e5055a359f7662fab8f8c4f57e24525 updated at 2017/06/14
09:58:19
STEP 16 | On the new Log Collector, replace previous Log Collector serial number with the new Log
Collector serial number.
You must replace the old Log Collector serial number with the new Log Collector serial number
so that the new Log Collector will not run in to purging issues, resulng in the Log Collector
being unable to purge old data from the migrated logs when necessary.
1. Access the Log Collector CLI.
2. Replace old Log Collector serial number with new Log Collector serial number:
request log-migration-update-logger from <old-log-collectorserial-number> to <new-log-collector-serial-number>
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STEP 17 | Set up the new secondary Panorama high availability peer.
1. Forward any logs on the SSD of the old M-Series appliance to an external desnaon if
you want to preserve them.
2. Remove the RAID disks from the old M-Series appliance.
3. Perform inial setup of the new M-Series appliance.
4. Insert the disks into the new M-Series appliance.
5. Repeat Steps 7 through 16 to migrate the logs from the old M-Series appliance to the
new M-Series appliance.
6. Set Up HA on Panorama. The new M-Series appliance must have the same priority as the
HA peer you are replacing.
7. Log in to the Panorama Web Interface of the primary HA peer and click Dashboard
> High Availability > Sync to peer to synchronize the conﬁguraon of the M-Series
appliance HA peers.

Migrate Logs to the Same M-Series Appliance Model in Panorama
Mode in High Availability
If you need to replace an M-600, M-500, M-200, or M-100 appliance deployed in high availability
(HA) conﬁguraon in Panorama mode (Panorama management server) with the same M-Series
appliance as the M-Series appliance being replaced, you can migrate the logs it collected from
ﬁrewalls by moving its RAID disks to the new M-Series appliance. Moving the disks enables you to
recover logs aer a system failure on the M-Series appliance.
This migraon procedure covers the following scenarios:
• One Panorama HA peer has a managed collector (Log Collector) in a Collector Group.

Figure 29: Panorama HA Peer with Collector Group
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• Both Panorama HA peers have managed collectors that belong to a single Collector Group. For
details, see Mulple Local Log Collectors Per Collector Group.
• Both Panorama HA peers have a managed collector and each is assigned to a separate
Collector Group. For details, see Single Local Log Collector Per Collector Group.
STEP 1 | Forward any logs on the SSD of the old M-Series appliance to an external desnaon if you
want to preserve them.
The SSD stores the System and Conﬁg logs that Panorama and Log Collectors generate. You
cannot move the SSD between M-Series appliances.
Conﬁgure Log Forwarding from Panorama to External Desnaons.
STEP 2 | Remove the RAID disks from the old M-Series appliance.
1. Power oﬀ the old M-Series appliance by pressing the Power buon unl the system
shuts down.
2. Remove the disk pairs. For details, refer to the disk replacement procedure in the MSeries Appliance Hardware Reference Guides.
STEP 3 | Perform inial setup of the new M-Series appliance.
1. Rack mount the M-Series appliance. Refer to the M-Series Appliance Hardware
Reference Guides for instrucons.
2. Perform Inial Conﬁguraon of the M-Series Appliance.
If the old M-Series appliance used interfaces other than the MGT interface for
Panorama services (such as log collecon), you must deﬁne those interfaces
during inial conﬁguraon of the new M-Series appliance (Panorama > Setup >
Interfaces).
3. Register Panorama.
4. Purchase and acvate a Panorama support license or transfer licenses as follows only if
the new M-Series appliance is the same hardware model as the old M-Series appliance.
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If the new M-Series appliance is a diﬀerent model than the old M-Series appliance, you
must purchase new licenses.
1. Log in to the Palo Alto Networks Customer Support web site.
2. Select the Assets tab and click the Spares link.
3. Click the Serial Number of the new M-Series appliance.
4. Click Transfer Licenses.
5. Select the old M-Series appliance and click Submit.
5. Acvate a ﬁrewall management license. If you are migrang from an M-100 appliance to
an M-500 appliance, enter the auth-code associated with the migraon license.
6. Install Content and Soware Updates for Panorama. For important details about
soware versions, see Panorama, Log Collector, Firewall, and WildFire Version
Compability.
7. Perform any addional conﬁguraon changes as needed.
If the old M-Series appliance used interfaces other than the MGT interface for
Panorama services (such as log collecon), you must deﬁne those interfaces on
the new M-Series appliance (Panorama > Setup > Interfaces).
8. Set Up HA on Panorama. The new M-Series appliance must have the same priority as the
HA peer you are replacing.
STEP 4 | Insert the disks into the new M-Series appliance. For details, refer to the disk replacement
procedure in the M-Series Appliance Hardware Reference Guides.
The disk carriers of the M-100 appliance are incompable with those of the M-500
appliance. Therefore, when migrang between these hardware models, you must
unscrew each disk from its old carrier and insert the disk in the new carrier before
inserng the disk in the new appliance.
You must maintain the disk pair associaon. Although you can place a disk pair from slot A1/A2
on the old appliance into slot B1/B2 on the new appliance, you must keep the disks together in
the same slot; otherwise, Panorama might not restore the data successfully.
STEP 5 | If the M-Series appliance was part of a Collector Group, verify that the decommissioned MSeries appliance serial number is sll part of the correct Collector Group:
debug log-collector-group show name <Log CollectorGroup name>
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STEP 6 | Prepare the disks for migraon.
Generang the metadata for each disk pair rebuilds the indexes. Therefore, depending
on the data size, this process can take a long me to complete. To expedite the process,
you can launch mulple CLI sessions and run the metadata regeneraon command
in each session to complete the process simultaneously for every pair. For details, see
Regenerate Metadata for M-Series Appliance RAID Pairs.
1. Enable the disk pairs by running the following CLI command for each pair:
admin> request system raid add <slot> force no-format
For example:
admin> request system raid add A1 force no-format
admin> request system raid add A2 force no-format
The force and no-format arguments are required. The force argument associates the disk
pair with the new appliance. The no-format argument prevents reformang of the drives
and retains the logs stored on the disks.
2. Generate the metadata for each disk pair.
admin> request metadata-regenerate slot <slot_number>
For example:
admin> request metadata-regenerate slot 1
STEP 7 | Conﬁgure the local Log Collector on the new M-Series appliance.
For all steps with commands that require a serial number, you must type the enre
serial number; pressing the Tab key won’t complete a paral serial number.
Don’t enable the disks on the new M-Series appliance at this point. When you successfully
migrate the logs, Panorama automacally enables the disks.
1. Conﬁgure the local Log Collector as a managed collector using the Panorama web
interface or using the following CLI commands:
admin> configure
admin# set log-collector <log-collector_SN> deviceconfig
system hostname <log-collector-hostname>
admin# exit
2. Commit your changes to Panorama. Don’t commit the changes to the Collector Group
just yet.
admin> configure
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admin# commit
3. Verify that the local Log Collector is connected to Panorama and that the status of its
disk pairs is present/available.
admin> show log-collector serial-number <log-collector_SN>
The disk pairs will display as disabled at this stage of the restoraon process.
STEP 8 | Add a Log Collector with no disks to a Collector Group.
From this point, only commits that are required to complete the migraon process on
Panorama and the Log Collectors. Hold oﬀ making any other changes.
1. Access the Panorama CLI.
2. Overwrite Panorama restricon to allow Log Collector with no disk to be added to a
Collector Group: request log-migration-set-start
3. Commit the overwrien restricon:
admin> configure
admin# commit force
STEP 9 | Migrate the logs.
1. Access the Panorama CLI.
2. Add the new local Log Collector as a member of the Collector Group and commit your
changes to Panorama.
admin# set log-collector-group <collector_group_name> logfwdsetting collectors <SN_managed_collector>
admin# commit
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admin# exit
The old local Log Collector sll appears in the list of members, because you haven’t
deleted it from the conﬁguraon.
3. For each disk pair, migrate the logs to the new appliance.
admin> request log-migration from <old_LC_serial_number> olddisk-pair <log_disk_pair> to <new_LC_serial_number> new-diskpair <log_disk_pair>
For example:
admin> request log-migration from 003001000010 old-disk-pair A
to 00300100038 new-disk-pair A
4. Commit the changes to Panorama.
admin> configure
admin# commit
STEP 10 | Reconﬁgure the Collector Group.
1. Use the web interface to assign the new Log Collector to the ﬁrewalls that forward logs
(Panorama > Collector Groups > Device Log Forwarding). Give the new Log Collector the
same priority in the ﬁrewall preference lists as the old Log Collector.
You cannot use the CLI change the priority assignments of ﬁrewall preference
lists.
2. Delete the old Log Collector from the Collector Group.
admin# delete log-collector-group <group_name> logfwd-setting
collectors <old_LC_serial_number>
For example:
admin# delete log-collector-group DC-Collector-Group logfwdsetting collectors 003001000010
3. Delete the old Log Collector from the Panorama conﬁguraon and commit your changes
to Panorama.
admin# delete log-collector <old_LC_serial_number>
admin# commit
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admin# exit
4. Synchronize the conﬁguraon of the M-Series appliance HA peers.
admin> request high-availability sync-to-remote running-config
5. Commit the Collector Group changes so that the managed ﬁrewalls can send logs to the
new Log Collector.
admin> commit-all log-collector-config log-collectorgroup <collector_group_name>
For example:
admin> commit-all log-collector-config log-collector-group DCCollector-Group
STEP 11 | Generate new keys on the new Log Collector.
This command is required in order to add the new Log Collector to the Collector Group
and should only be run for the Collector Group of the Log Collector being replaced. This
step deletes the exisng RSA keys and allows Panorama to create new RSA keys.
1. Access the Panorama CLI.
2. Delete all RSA keys on the new Log Collector:
request logdb update-collector-group-after-replacecollectorgroup <collector-group-name>
The process can take up to 10 minutes to completed.
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STEP 12 | Conﬁrm that SearchEngine Status is Acve for all Log Collectors in the Collector Group.
Do not connue unl SearchEngine Status is Acve for all Log Collectors in the
Collector Group. This will result in purging of logs from the Log Collector being replaced.
1. Access the Panorama CLI.
2. Show the Log Collector details by running the following commands either:
• On Panorama for all Log Collectors:
show log-collector all
Alternavely, you can run the following command on each Dedicated Log
Collector:
show log-collector detail
3. Conﬁrm that SearchEngine Status is Acve.
Redistribution status:

none

Last commit-all: commit succeeded, current ring version 1
SearchEngine status:

Active

md5sum 4e5055a359f7662fab8f8c4f57e24525 updated at 2017/06/14
09:58:19
STEP 13 | On the new Log Collector, replace previous Log Collector serial number with the new Log
Collector serial number.
You must replace the old Log Collector serial number with the new Log Collector serial number
so that the new Log Collector will not run in to purging issues, resulng in the Log Collector
being unable to purge old data from the migrated logs when necessary.
1. Access the Log Collector CLI.
2. Replace old Log Collector serial number with new Log Collector serial number:
request log-migration-update-logger from <old-log-collectorserial-number> to <new-log-collector-serial-number>

Migrate Log Collectors aer Failure/RMA of Non-HA Panorama
If a system failure occurs on a Panorama management server that is not deployed in a high
availability (HA) conﬁguraon, use this procedure to restore the conﬁguraon on the replacement
Panorama and restore access to the logs on the Dedicated Log Collectors that it manages. The
allowed migraon scenarios vary by Panorama management server model:
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Old/Failed Panorama

New/Replacement Panorama

Panorama virtual appliance

• Panorama virtual appliance
• M-200 appliance
• M-500 appliance
• M-600 appliance

M-100 appliance

• Panorama virtual appliance
• M-200 appliance
• M-500 appliance
• M-600 appliance

M-500 appliance

• Panorama virtual appliance
• M-200 appliance
• M-500 appliance
• M-600 appliance

Panorama maintains a ring ﬁle that maps the segments and parons that Dedicated Log
Collectors use to store logs. An M-Series appliance in Panorama mode stores the ring ﬁle on its
internal SSD; a Panorama virtual appliance stores the ring ﬁle on its internal disk. When a system
failure occurs, a non-HA Panorama cannot automacally recover the ring ﬁle. Therefore, when
you replace Panorama, you must restore the ring ﬁle to access the logs on the Dedicated Log
Collectors.
This procedure requires that you backed up and exported your Panorama conﬁguraon
before the system failure occurred.
Palo Alto Networks recommends deploying Panorama in an HA conﬁguraon. The acve
Panorama peer automacally synchronizes the ring ﬁle to the passive peer in an HA
conﬁguraon, thereby maintaining access to logs on the Dedicated Log Collectors even if
you must replace one of the peers.
STEP 1 | Perform inial setup of the new Panorama appliance.
1. Set Up the M-Series Appliance or Set Up the Panorama Virtual Appliance based on your
needs. If you are seng up a new M-Series appliance, refer to the M-Series Appliance
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Hardware Reference Guides for instrucons on how to rack mount the new M-Series
appliance.
2. Perform Inial Conﬁguraon of the M-Series Appliance or Perform Inial Conﬁguraon
of the Panorama Virtual Appliance.
If the old M-Series appliance used interfaces other than the MGT interface for
Panorama services (such as log collecon), you must deﬁne those interfaces
during inial conﬁguraon of the new M-Series appliance (Panorama > Setup
> Interfaces). The Panorama virtual appliance does not support interfaces other
than MGT.
3. Register Panorama.
4. Transfer licenses as follows only if the new Panorama appliance is the same model as the
old appliance. Otherwise, you must purchase new licenses.
1. Log in to the Palo Alto Networks Customer Support web site.
2. Select the Assets tab and click the Spares link.
3. Click the Serial Number of the new M-Series appliance.
4. Click Transfer Licenses.
5. Select the old appliance and click Submit.
5. Acvate a Panorama Support License.
6. Acvate a ﬁrewall management license.
7. Install Content and Soware Updates for Panorama.
The M-500 appliance requires Panorama 7.0 or a later release. M-200 and
M-600 appliances require Panorama 8.1. For important details about soware
versions, see Panorama, Log Collector, Firewall, and WildFire Version
Compability.
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STEP 2 | Restore the conﬁguraon from the old Panorama to the replacement Panorama.
1. Log in to the new Panorama and select Panorama > Setup > Operaons.
2. Click Import named Panorama conﬁguraon snapshot, Browse to the backup
conﬁguraon ﬁle, and click OK.
3. Click Load named Panorama conﬁguraon snapshot, select the Name of the ﬁle you just
imported, and click OK.
To replace an RMA Panorama, make sure you Retain Rule UUIDs when you load
the named Panorama conﬁguraon snapshot. If you do not select this opon,
Panorama removes all previous rule UUIDs from the conﬁguraon snapshot and
assigns new UUIDs to the rules on Panorama, which means it does not retain
informaon associated with the previous UUIDs, such as the policy rule hit
count.
4. Select Commit > Commit to Panorama and Commit your changes.
5. Select Panorama > Managed Collectors and verify that the Connected column displays a
check mark for the Dedicated Log Collector.
If the Dedicated Log Collector doesn’t appear, you must reconﬁgure it and its Collector
Group as described in the next step. Otherwise, skip the following step to Fetch the ring
ﬁle to restore access to the logs stored on the Dedicated Log Collector.
STEP 3 | Reconﬁgure the Dedicated Log Collector and Collector Group if they are missing on
Panorama.
1. Access the CLI of the Dedicated Log Collector and enter the following commands to
display the name of its Collector Group.
1. Enter the command:
> request fetch ring from log-collector <serial_number>
The following error will display:
Server error: Failed to fetch ring info from <serial_number>
2. Enter the command:
> less mp-log ms.log
The following error will display:
Dec04 11:07:08 Error:
pan_cms_convert_resp_ring_to_file(pan_ops_cms.c:3719):
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Current configuration does not contain group CA-CollectorGroup
In this example, the error message indicates that the missing Collector Group has the
name CA-Collector-Group.
2. Conﬁgure the Collector Group and assign the Dedicated Log Collector to it.
> configure
# set log-collector-group <collector-group-name>
# set log-collector-group <collector-group-name> logfwdsetting
collector <serial-number>
3. Commit the changes to Panorama but not to the Collector Group.
# commit
# exit
STEP 4 | Fetch the ring ﬁle to restore access to the logs stored on the Dedicated Log Collector.
1. Access the CLI of the new Panorama.
2. Fetch the ring ﬁle:
> request fetch ring from log-collector <serial-number>
For example:
> request fetch ring from log-collector 009201000343
If you don’t know the serial number of the Dedicated Log Collector, log in to its
CLI and enter the show system info operaonal command.
3. Commit your changes to the Collector Group.
> commit-all log-collector-config log-collectorgroup <collector-group-name>

Regenerate Metadata for M-Series Appliance RAID Pairs
When a system failure occurs on the M-600, M-500, or M-200 appliance and you need to
physically move the disks from one appliance to another, regenerang the metadata is necessary.
The metadata is required to locate logs on the disk; when a user issues a log query, the query
consults this metadata to access the requested log data.
For each conﬁgured RAID disk pair in the M-Series appliance, you must access the appliance CLI
and run the following command to regenerate the metadata:
> request metadata-regenerate slot <slot_number>
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For example:
> request metadata-regenerate slot 1
The size of the RAID disks determines how long metadata regeneraon takes. On average, it
takes an hour for every 100GB. When you run the command, the CLI session is locked unl the
command is fully executed. You can use mulple CLI sessions to save me. For example, to replace
four RAID pairs of 1TB drives with a total of 4TB of log data, launch four CLI sessions and run the
command in each session to regenerate metadata simultaneously for all the pairs/slots in about 10
hours.
During metadata regeneraon, the Collector Group to which these disks belong is not available
and the disk pair is not available for any logging or reporng operaons (writes/queries). However,
you can perform other tasks such as handling new ﬁrewall connecons or managing conﬁguraon
changes on the managed ﬁrewalls. All other Collector Groups that Panorama manages and that
aren’t part of this RMA process can perform the assigned logging and reporng funconality as
normal.

View Log Query Jobs
You can view your log query jobs to invesgate and beer understand why querying log data
is taking a longer than expected. To begin, you must ﬁrst show all log query jobs run on the
Panorama. Aer you idenfy the log query job that you need to invesgate, use the job ID to view
detailed informaon about the query to beer understand why your log query is running into
issues. When querying log data on Panorama the detailed job ID informaon is overwrien as new
log query jobs are executed.
STEP 1 | Log in to the Panorama CLI.
STEP 2 | View the log query jobs executed on Panorama.
The CLI output includes general informaon about each executed log query such as the jod
ID, when the query was run, the query state, the log database that was queried, the number of
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logs queried, how long (in ms) it took for the query to return results, the admin that executed
the query. and any ﬁlters applied to the query.
admin@Panorama> show query jobs

STEP 3 | View details log query informaon about a speciﬁc job using the job ID.
admin@Panorama> show query jobid <Job ID>
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Replace an RMA Firewall
To minimize the eﬀort required to restore the conﬁguraon on a managed ﬁrewall involving a
Return Merchandise Authorizaon (RMA), replace the serial number of the old ﬁrewall with that
of the new ﬁrewall on Panorama. To then restore the conﬁguraon on the replacement ﬁrewall,
either import a ﬁrewall state that you previously generated and exported from the ﬁrewall or use
Panorama to generate a paral device state for managed ﬁrewalls running PAN-OS 5.0 and later
versions. By replacing the serial number and imporng the ﬁrewall state, you can resume using
Panorama to manage the ﬁrewall.
• Paral Device State Generaon for Firewalls
• Before Starng RMA Firewall Replacement
• Restore the Firewall Conﬁguraon aer Replacement

Paral Device State Generaon for Firewalls
When you use Panorama to generate a paral device state, it replicates the conﬁguraon of the
managed ﬁrewalls with a few excepons for Large Scale VPN (LSVPN) setups. You create the
paral device state by combining two facets of the ﬁrewall conﬁguraon:
• Centralized conﬁguraon that Panorama manages—Panorama maintains a snapshot of the
shared policy rules and templates that it pushes to ﬁrewalls.
• Local conﬁguraon on the ﬁrewall—When you commit a conﬁguraon change on a ﬁrewall, it
sends a copy of its local conﬁguraon ﬁle to Panorama. Panorama stores this ﬁle and uses it to
compile the paral device state bundle.
In an LSVPN setup, the paral device state bundle that you generate on Panorama is
not the same as the version that you export from a ﬁrewall (by selecng Device > Setup
> Operaons and clicking Export device state). If you manually ran the device state
export or scheduled an XML API script to export the ﬁle to a remote server, you can use
the exported device state in your ﬁrewall replacement workﬂow.
If you did not export the device state, the device state that you generate in the
replacement workﬂow will not include the dynamic conﬁguraon informaon, such as
the cerﬁcate details and registered ﬁrewalls, that is required to restore the complete
conﬁguraon of a ﬁrewall funconing as an LSVPN portal. See Before Starng RMA
Firewall Replacement for more informaon.
Panorama does not store the device state; you generate it on request using the CLI commands
listed in Restore the Firewall Conﬁguraon aer Replacement.

Before Starng RMA Firewall Replacement
The ﬁrewall you will replace must have PAN-OS 5.0.4 or a later version. Panorama cannot
generate the device state for ﬁrewalls running older PAN-OS versions.
Record the following details about the ﬁrewall you will replace:
• Serial number—You must enter the serial number on the Palo Alto Networks Customer
Support web site to transfer the licenses from the old ﬁrewall to the replacement ﬁrewall.
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You will also enter this informaon on Panorama, to replace all references to the old serial
number with the new serial number of the replacement ﬁrewall.
• (Recommended) PAN-OS version and the content database version—Installing the same
soware and content database versions, including the URL database vendor, enables you to
create the same state on the replacement ﬁrewall. If you decide to install the latest version
of the content database, you might noce diﬀerences because of updates and addions to
the database. To determine the versions installed on the ﬁrewall, access the ﬁrewall System
logs stored on Panorama.
Prepare the replacement ﬁrewall for deployment. Before you import the device state bundle
and restore the conﬁguraon, you must:
• Verify that the replacement ﬁrewall is the same model as the old ﬁrewall and is enabled
for similar operaonal capability. Consider the following operaonal features: must the
replacement ﬁrewall have mulple virtual systems, support jumbo frames support, or
operate in CC or FIPS mode?
• Conﬁgure network access, transfer the licenses, and install the appropriate PAN-OS and
content database versions.
You must use the Panorama CLI to complete this ﬁrewall replacement process, and therefore
your administrator account must have the superuser or panorama-admin user role.
If you have an LSVPN conﬁguraon, and are replacing a Palo Alto Networks ﬁrewall deployed
as a satellite or as an LSVPN portal, the dynamic conﬁguraon informaon that is required
to restore LSVPN connecvity will not be available when you restore the paral device state
generated on Panorama. If you followed the recommendaon to frequently generate and
export the device state for ﬁrewalls in an LSVPN conﬁguraon, use the device state that you
previously exported from the ﬁrewall itself instead of generang one on Panorama.
If you have not manually exported the device state from the ﬁrewall, and need to generate
a paral device state on Panorama, the missing dynamic conﬁguraon impacts the ﬁrewall
replacement process as follows:
• If the ﬁrewall you are replacing is a GlobalProtect portal that is explicitly conﬁgured
with the serial number of the satellites (Network > GlobalProtect > Portals > Satellite
Conﬁguraon), when restoring the ﬁrewall conﬁguraon, although the dynamic
conﬁguraon is lost, the portal ﬁrewall will be able to authencate the satellites successfully.
The successful authencaon will populate the dynamic conﬁguraon informaon and
LSVPN connecvity will be reinstated.
• If you are replacing a satellite ﬁrewall, it will not be able to connect and authencate to the
portal. This failure occurs either because the serial number was not explicitly conﬁgured
on the ﬁrewall (Network > GlobalProtect > Portals > Satellite Conﬁguraon) or, if the
serial number was explicitly conﬁgured, because the serial number of the replaced ﬁrewall
does not match that of the old ﬁrewall. To restore connecvity aer imporng the device
state bundle, the satellite administrator must log in to the ﬁrewall and enter the credenals
(username and password) for authencang to the portal. Aer authencaon, the dynamic
conﬁguraon required for LSVPN connecvity is generated on the portal.
However, if the ﬁrewall was conﬁgured in a high availability conﬁguraon, aer restoring the
conﬁguraon, the ﬁrewall will automacally synchronize the running conﬁguraon with its peer
and aain the latest dynamic conﬁguraon required to funcon seamlessly.
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Restore the Firewall Conﬁguraon aer Replacement
To restore the ﬁrewall conﬁguraon on the new ﬁrewall, you will ﬁrst perform inial conﬁguraon
on the new ﬁrewall, including seng the operaonal mode, upgrading the PAN-OS soware and
content release version to match what was installed on the old ﬁrewall. You will then export the
device state of the old ﬁrewall from Panorama and import it onto the new ﬁrewall. Finally, you
will go back to Panorama to validate that the new ﬁrewall has connected and then sync it with
Panorama.
STEP 1 | Perform inial conﬁguraon on the new ﬁrewall and verify network connecvity.
Use a serial port connecon or a Secure Shell (SSH) connecon to add an IP address, a DNS
server IP address, and to verify that the new ﬁrewall can access the Palo Alto Networks
updates server.
STEP 2 | (Oponal) Set the Operaonal mode on the new ﬁrewall to match that on the old ﬁrewall.
A serial port connecon is required for this task.
1. Enter the following CLI command to access maintenance mode on the ﬁrewall:
> debug system maintenance-mode
2. For Operaonal mode, select Set FIPS Mode or Set CCEAL 4 Mode from the main
menu.
STEP 3 | Retrieve the license(s) on the new ﬁrewall.
Enter the following command to retrieve the licenses:
> request license fetch
STEP 4 | (Oponal) Match the operaonal state of the new ﬁrewall with that of the old ﬁrewall. For
example, enable mul-virtual system (mul-vsys) capability for a ﬁrewall that was enabled for
mul-vsys capability.
Enter the commands that pertain to your ﬁrewall sengs:
> set system setting multi-vsys on
> set system setting jumbo-frame on
STEP 5 | Upgrade the PAN-OS version on the new ﬁrewall.
You must upgrade to the same PAN-OS installed on the old ﬁrewall. You must upgrade the
content release versions to the same or later version that is installed on the old ﬁrewall.
Enter the following commands:
1. To upgrade the content release version:
> request content upgrade download latest
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> request content upgrade install version latest
2. To upgrade the an-virus release version:
> request anti-virus upgrade download latest
> request anti-virus upgrade install version latest
3. To upgrade the PAN-OS soware version:
> request system software download version <version>
> request system software install version <version>
STEP 6 | Go to the Panorama CLI and export the device state bundle from the old ﬁrewall to a
computer using Secure Copy (SCP) or TFTP (you cannot do this from the web interface).
If you manually exported the device state from the ﬁrewall, you can skip this step.
The export command generates the device state bundle as a tar zipped ﬁle and exports it to
the speciﬁed locaon. This device state will not include the LSVPN dynamic conﬁguraon
(satellite informaon and cerﬁcate details).
Enter one of the following commands:
> scp export device-state device <old serial#> to <login>
@ <serverIP>: <path>
or
> tftp export device-state device <old serial#> to <serverIP>
STEP 7 | Replace the serial number of the old ﬁrewall with that of the new replacement ﬁrewall on
Panorama.
By replacing the serial number on Panorama you allow the new ﬁrewall to connect to
Panorama aer you restore the conﬁguraon on the ﬁrewall.
1. Enter the following command in Operaonal mode:
> replace device old <old SN#> new <new SN#>
2. Enter Conﬁguraon mode and commit your changes.
> configure
# commit
3. Exit Conﬁguraon mode.
# exit
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STEP 8 | (Oponal) Create a device registraon auth key on Panorama.
This step is required if no valid device registraon auth key is created on Panorama. Skip this
step if a valid device registraon auth key is already created on Panorama.
Exporng the device state bundle does not export the device registraon auth key
used to add the ﬁrewall to Panorama management. When you restore the ﬁrewall
conﬁguraon aer replacement, you must create a new device registraon auth key to
add the new ﬁrewall to Panorama.
1. Log in to the Panorama Web Interface.
2. Select Panorama > Device Registraon Auth Key and Add a new authencaon key.
3. Conﬁgure the authencaon key.
• Name—Enter a descripve name for the authencaon key.
• Lifeme—Enter the key lifeme to specify how long the authencaon key may be
used to onboard new ﬁrewalls.
• Count—Specify how many mes the authencaon key may be used to onboard new
ﬁrewalls.
• Device Type—Specify that the authencaon key is used to authencate a Firewall.
Select Any to use the device registraon auth key to onboard both ﬁrewalls
and Log Collectors.
• (Oponal) Devices—Enter one or more device serial numbers to specify for which
ﬁrewalls the authencaon key is valid.
4. Click OK.

5. Copy Auth Key and Close.
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STEP 9 | On the new ﬁrewall, import the device state and add the device registraon auth key.
1. Log in to the ﬁrewall web interface.
2. Select Device > Setup > Operaons and click the Import Device State link in the
Conﬁguraon Management secon.
3. Browse to locate the ﬁle and click OK.
4. Select Device > Setup > Management and edit the Panorama Sengs
5. Enter the Auth key you created on Panorama and click OK.

6. Commit your changes to the running conﬁguraon on the ﬁrewall.
STEP 10 | From Panorama, verify that you successfully restored the ﬁrewall conﬁguraon.
1. Access the Panorama web interface and select Panorama > Managed Devices.
2. Verify that the Connected column for the new ﬁrewall has a check mark.
STEP 11 | Synchronize the ﬁrewall with Panorama.
1. Access the Panorama web interface, select Commit > Commit and Push and Edit
Selecons in the Push Scope.
2. Select Device Groups, select the device group that contains the ﬁrewall, and Include
Device and Network Templates.
3. Select Collector Groups and select the Collector Group that contains the ﬁrewall.
4. Click OK to save your changes to the Push Scope.
5. Commit and Push your changes.
If you need to generate reports for a period when the old ﬁrewall was sll
funconal aer you installed the new ﬁrewall, you must generate a separate
query for each ﬁrewall serial number because replacing the serial number on
Panorama does not overwrite the informaon in logs.
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Troubleshoot Commit Failures
If commit or push operaon failures occur on Panorama, check for the following condions:
Symptom

Condion

Resoluon

Template or device
group push failure

The ability to receive template
and device groups conﬁguraon
changes from Panorama is disabled
on the ﬁrewall.

Access the ﬁrewall web interface,
select Device > Setup, edit the
Panorama Sengs, and then
click Enable Device and Network
Template and Enable Panorama
Policy and Objects.

Panorama commit
failure or template,
device group, or
Collector Group
push failure

The Panorama management server
has an earlier soware version
than the Dedicated Log Collectors
or ﬁrewalls that it manages.

Upgrade the Panorama
management server to the same or
a higher soware version than the
managed ﬁrewalls, Log Collectors,
and WildFire appliances and
appliance clusters. For details,
see Panorama, Log Collector,
Firewall, and WildFire Version
Compability.
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Troubleshoot Registraon or Serial Number Errors
On the M-600, M-500, or M-200 appliance, if the Panorama > Support page doesn’t display
support license details or the Panorama > Setup > Management page displays Unknown for the
Serial Number even aer you Register Panorama, perform the following steps:
STEP 1 | Record the Panorama serial number from the order fulﬁllment email that Palo Alto Networks
sent when you placed your order for Panorama.
STEP 2 | Select Panorama > Setup > Management and edit the General Sengs.
STEP 3 | Enter the Serial Number and click OK.
STEP 4 | Select Commit > Commit to Panorama and Commit your changes.
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Troubleshoot Reporng Errors
If Panorama fails to generate a report, or the report is missing expected data, its content versions
(such as the Applicaons database) might diﬀer from those on the managed collectors and
ﬁrewalls. The content versions on Panorama must be the same as or lower than the content
versions on the managed collectors and ﬁrewalls. For details, see Panorama, Log Collector,
Firewall, and WildFire Version Compability.
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Troubleshoot Device Management License Errors
Aer upgrading to PAN-OS 8.1, the Panorama virtual appliance will check if a device management
licenses has been successfully installed. If a device management license has not been successfully
installed, or the number of ﬁrewalls managed by the Panorama virtual appliance exceeds the
device management license limit, you have 180 days to install a valid device management license.
If no valid device management license has been installed, the following alert appears each me
you log in to the Panorama web interface:

If the number of ﬁrewalls managed by the Panorama virtual appliance exceeds the device
management license limit, the following alerts appears each me you log in to the Panorama web
interface:

To resolve, install a valid device management license:
STEP 1 | Contact your Palo Alto Networks sales representave or your authorized reseller to purchase
the appropriate device management license.
STEP 2 | Log in to the Panorama Web Interface.
STEP 3 | Acvate/Retrieve a device management license based on whether the Panorama virtual
appliance is online or oﬄine.
• Acvate/Retrieve a Firewall Management License when the Panorama Virtual Appliance is
Internet-connected.
• Acvate/Retrieve a Firewall Management License when the Panorama Virtual Appliance is
not Internet-connected.

Panorama Administrator's Guide Version Version 10.1

648

©2022 Palo Alto Networks, Inc.

Troubleshoong

Troubleshoot Automacally Reverted Firewall
Conﬁguraons
If your managed ﬁrewall automacally reverts its conﬁguraon due to a conﬁguraon change
that caused a connecon to break between the Panorama™ management server and the ﬁrewall,
you can troubleshoot the out-of-sync ﬁrewalls to determine what changes were made and to
determine what aspects of that last conﬁguraon push caused the ﬁrewall revert its conﬁguraon.
STEP 1 | Verify that the managed ﬁrewall automacally reverted to the last running conﬁguraon.
• On the ﬁrewall
1. Launch the Firewall Web Interface.
2. Click Tasks (boom-right hand corner of the web interface).
3. Verify that the last commit operaon (either pushed from Panorama or commied locally)
shows a Reverted status.

• On Panorama
1. Log in to the Panorama Web Interface.
2. Select Panorama > Managed Devices > Summary.
3. View the Shared Policy and Template sync status. If you have recently pushed a
conﬁguraon from Panorama to your managed ﬁrewalls and it reverted, the Shared
Policy or Template display as Out of Sync (depending on what conﬁguraon changes
were made).

STEP 2 | In the Last Merged Diﬀ column for a managed ﬁrewall, Show Last Merged Conﬁg Diﬀ (
)
to compare the current running conﬁguraon and the reverted conﬁguraon. In this example,
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a policy rule pushed from Panorama denied all traﬃc between the managed ﬁrewall and
Panorama, which caused the ﬁrewall conﬁguraon to automacally revert.

STEP 3 | Modify conﬁguraon objects as needed as to not break the connecon between the
managed ﬁrewalls and Panorama before you re-push the conﬁguraon.

Panorama Administrator's Guide Version Version 10.1

650

©2022 Palo Alto Networks, Inc.

Troubleshoong

View Task Success or Failure Status
Click the Task Manager icon
at the boom right of the Panorama web interface to view the
success or failure of a task. The Task Manager also displays a detailed message to help debug an
issue. For details, see Use the Panorama Task Manager.
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Test Policy Match and Connecvity for Managed
Devices
Aer you successfully push the device group and template stack conﬁguraons to your
ﬁrewalls, Log Collectors, and WF-500 appliances, test that the correct traﬃc matches the policy
rules pushed to your managed devices and that your ﬁrewalls can successfully connect to all
appropriate network resources.
• Troubleshoot Policy Rule Traﬃc Match
• Troubleshoot Connecvity to Network Resources

Troubleshoot Policy Rule Traﬃc Match
To perform policy match tests for managed ﬁrewalls, test the policy rule conﬁguraon for your
managed devices to ensure that the running conﬁguraon appropriately secures your network
by allowing and denying the correct traﬃc. Aer the results are generated for traﬃc that was
matched to conﬁgured rules, you can Export to PDF for auding purposes.
STEP 1 | Log in to the Panorama Web Interface.
STEP 2 | Select Panorama > Managed Devices > Troubleshoong to perform a policy match.
You may also run a policy match test from the Policies tab.
STEP 3 | Enter the required informaon to perform the policy match test. In this example, a Security
policy match test is run.
1. Select Security Policy Match from the Select Test drop-down.
2. Select device/VSYS and select the managed ﬁrewalls to test.
3. Enter the Source IP address from which traﬃc originated.
4. Enter the Desnaon IP address of the target device for the traﬃc.
5. Enter the Protocol IP used for the traﬃc.
6. If necessary, enter any addional informaon relevant for your Security policy rule
tesng.
STEP 4 | Execute the Security policy match test.
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STEP 5 | Select the Security policy match Results to review the policy rules that match the test
criteria.

Troubleshoot Connecvity to Network Resources
Perform connecvity tests for managed ﬁrewalls to ensure that your managed devices can
connect to all appropriate network resources. Test the device conﬁguraon for your managed
devices to ensure the running conﬁguraon appropriately secures your network by allowing you
to verify that the conﬁguraons pushed to your managed devices sll allow those devices to
connect to resources such as your Log Collectors, conﬁgured External Dynamic Lists, and the Palo
Alto Networks Update Server. Addionally, you can execute roung, WildFire®, Threat Vault, ping,
and traceroute connecvity tests to verify that Panorama™ and managed devices can access any
external network resources crical to the operaon and security of your network. Aer the results
are generated, you can Export to PDF for auding purposes.
The Ping connecvity test is only supported for ﬁrewalls running PAN-OS 9.0 or later
releases.
STEP 1 | Log in to the Panorama Web Interface.
STEP 2 | Select Panorama > Managed Devices > Troubleshoong to perform a connecvity test.
You may also run a policy match test from the Policies tab.
STEP 3 | Enter the required informaon to perform the connecvity test. In this example, a Log
Collector Connecvity test is run.
1. Select Log Collector Connecvity from the Select Test drop-down.
2. Select device/VSYS and select the managed ﬁrewalls to test.
3. If necessary, enter any addional informaon relevant for your connecvity tesng.
STEP 4 | Execute the Log Collector connecvity test.
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STEP 5 | Select the log collector connecvity Results to review the Log Collector connecvity status
for the selected devices.
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Generate a Stats Dump File for a Managed Firewall
Generate a set of XML reports that summarize the network traﬃc over the last seven days for
a single ﬁrewall managed by the Panorama™ management server or for all ﬁrewalls managed
by Panorama. Aer you select a managed ﬁrewall and generate the stats dump ﬁle, you can
download the stats dump ﬁle locally to your device.
The Palo Alto Networks or Authorized Partner systems engineer use the stat dump ﬁle to create
a Security Lifecycle Review (SLR) and to perform security checkups aer you successfully deploy
your managed ﬁrewalls to help strength your security posture. The SLR highlights acvity found
on the network and the associated business or security risks that may be present. For more
informaon on the SLR, contact your Palo Alto Networks or Authorized Partner systems engineer.
Stats dump ﬁle generaon for mulple managed ﬁrewalls can take mulple hours to
complete. During this me, you are unable to navigate from the stats dump ﬁle generaon
user interface so it is recommended to generate the stats dump ﬁle from the CLI so you
can connue using the Panorama web interface.
Palo Alto Networks recommends generang a stats dump ﬁle for all managed ﬁrewalls
from the Panorama CLI using the following command. Panorama must be able to reach
your SCP or TFTP server to successfully export the stats dump ﬁle.
• SCP Server
admin> scp export stats-dump to
<username@hostname:SCP_export_path>
• TFTP Server
admin> tftp export stats-dump to <tftp_host_address>
STEP 1 | Log in to the Panorama Web Interface.
STEP 2 | Select Panorama > Support and navigate to the Stats Dump File.
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STEP 3 | Select a managed ﬁrewall for which to generate a stats dump ﬁle.
It is recommended that you generate a stats dump ﬁle for a single managed ﬁrewall from the
Panorama web interface.
A stats dump ﬁle is generated for All devices by default if you do not select a managed ﬁrewall.

STEP 4 | Generate Stats Dump File.
Click Yes when prompted to proceed generang the stats dump ﬁle.
A progress bar of the stats dump ﬁle generaon status is displayed.
Generaon may take up to an hour for a single managed ﬁrewall depending on the volume of
log data. You are unable to navigate from the stats dump ﬁle generaon status window during
this me.
STEP 5 | Click Download Stats Dump File to download the stats dump ﬁle to your local device.
The downloaded stat dumps ﬁle is in a tar.gz ﬁle format.
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Recover Managed Device Connecvity to Panorama
PAN-OS 10.1 introduced the device registraon authencaon key to securely onboard managed
ﬁrewalls, Dedicated Log Collectors, and WildFire appliance to the Panorama™ management
server. The steps below describe how to recover the managed device connecvity to Panorama in
the following scenarios:
• If a managed device disconnects from Panorama without reason and is not able to reconnect.
• You want to transion ﬁrewall management from a Panorama running PAN-OS 10.1 or later
release to a diﬀerent Panorama running PAN-OS 10.1 or a later release.
• If you reset Panorama or the managed ﬁrewall to factory default sengs but the managed
ﬁrewall is unable to connect to Panorama.
Recovering the managed device connecvity to Panorama applies only to managed devices that
are running PAN-OS 10.1 when onboarded to Panorama. The behavior described does not apply
to managed devices running PAN-OS 10.0 and earlier releases or managed devices that were
upgraded to PAN-OS 10.1 while already managed by Panorama.
The following ﬁrewall plaorms are not impacted by the described connecvity issues to
Panorama.
• Managed ﬁrewalls onboarded to Panorama using Zero Touch Provisioning (ZTP).
• CN-Series ﬁrewalls.
• Managed ﬁrewalls deployed on VMware NSX.
• VM-Series ﬁrewalls purchases from a public hypervisor marketplace. See PAYG
ﬁrewalls for more informaon.
STEP 1 | Reset the secure connecon state of the managed device.
1. Log in to the managed device CLI.
• Log in to the ﬁrewall CLI.
• Log in to the Dedicated Log Collector CLI.
• Log in to the WildFire appliance CLI.
2. Reset the secure connecon state.
This command resets the managed device connecon and is irreversible.

admin> request sc3 reset
3. Restart the management server on the managed device.
admin> debug software restart process management-server
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STEP 2 | Clear the secure connecon state a managed device on Panorama and generate a new device
registraon authencaon key.
Clearing the secure connecon state for a managed device on Panorama is irreversible.
This means that the managed device is disconnect and must be added back to
Panorama.
1. Log in to the Panorama CLI.
2. Reset the secure connecon state of a managed device on Panorama.
This command resets the managed device connecon to Panorama and is
irreversible.
admin> clear device-status deviceid <device_SN>
Where <device_SN> is the serial number of the managed device you want to clear the
connecon state for.
3. Create a new device registraon authencaon key on Panorama.
admin> request authkey add devtype <fw_or_lc) count
<device_count> lifetime <key_lifetime> name <key_name> serial
<device_SN>
The devtype and serial arguments are oponal. Omit these two arguments
to make a general use device registraon authencaon key that is not speciﬁc
to a device type or device serial number.
4. Verify the device registraon authencaon key is successfully created and copy the Key
value.
admin> request authkey list <key_name>
STEP 3 | Add the device registraon authencaon key you created to the managed device.
1. Log in to the managed device CLI.
• Log in to the ﬁrewall CLI.
• Log in to the Dedicated Log Collector CLI.
• Log in to the WildFire appliance CLI.
2. Add the device registraon authencaon key you created in the previous step.
admin> request authkey set <auth_key>
For <auth_key>, enter the Key value you copied in the previous step.

Panorama Administrator's Guide Version Version 10.1

658

©2022 Palo Alto Networks, Inc.

Troubleshoong
STEP 4 | Verify the managed device connecvity to Panorama.
admin> show panorama-status
Verify that the Panorama server Connected status displays yes.
If this procedure does not resolve the connecvity issue for your managed device, you
must contact Palo Alto Networks Customer Support for further assistance as a full
reset of all managed device connecons on Panorama may be required.
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