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About the VM-Series Firewall
The Palo Alto Networks VM-Series firewall is the virtualized form of the Palo Alto
Networks next-generaon firewall. It is posioned for use in a virtualized or cloud
environment where it can protect and secure east-west and north-south traffic.
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About the VM-Series Firewall

VM-Series Deployments
The VM-Series firewall can be deployed on the following plaorms:

VM-Series for VMware vSphere Hypervisor (ESXi) and vCloud Air

You can deploy any VM-Series model as a guest virtual machine on VMware ESXi; ideal for
cloud or networks where virtual form factor is required.

For details, see Set Up a VM-Series Firewall on an ESXi Server and Set Up the VM-Series
Firewall on vCloud Air.
VM-Series on VMware NSX-T

You can deploy the VM-100, VM-300, VM-500, or VM-700 in your NSX-T environment.

For details, see Set Up the VM-Series Firewall on VMware NSX-T (North-South).
VM-Series for Amazon Web Services (AWS)

You can deploy any VM-Series model, except the VM-50, on EC2 instances on the AWS Cloud.

For details, see Set Up the VM-Series Firewall on AWS.
VM-Series for Google Cloud Plaorm

You can deploy any VM-Series model, except the VM-50 and the VM-50 Lite on Google
Compute Engine instances. For details, see Set Up the VM-Series Firewall on Google Cloud
Plaorm.
VM-Series for Kernel Virtualizaon Module (KVM)

You can deploy any VM-Series model on a Linux server that is running the KVM hypervisor. For
details, see Set Up the VM-Series Firewall on KVM.
VM-Series for Microso Hyper-V

You can deploy any VM-Series model on a Windows Server 2012 R2 server with the Hyper-V
role add-on enabled or a standalone Hyper-V 2012 R2 server. For details, see Set Up the VM-
Series Firewall on Hyper-V.
VM-Series for Microso Azure

You can deploy any VM-Series model, except the VM-50, on the Azure VNet.

For details, see Set up the VM-Series Firewall on Azure.
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About the VM-Series Firewall

VM-Series in High Availability
High availability (HA) is a configuraon in which two firewalls are placed in a group and their
configuraon is synchronized to prevent a single point of failure on your network. A heartbeat
connecon between the firewall peers ensures seamless failover in the event that a peer goes
down. Seng up the firewalls in a two-device cluster provides redundancy and allows you to
ensure business connuity. In an HA configuraon on the VM-Series firewalls, both peers must be
deployed on the same type of hypervisor, have idencal hardware resources (such as CPU cores/
network interfaces) assigned to them, and have the set same of licenses/subscripons. For general
informaon about HA on Palo Alto Networks firewalls, see High Availability.

The VM-Series firewalls support stateful acve/passive or acve/acve high availability with
session and configuraon synchronizaon. The acve/acve deployment is supported in virtual
wire and Layer 3 deployments on some private cloud hypervisors, and is recommended only if
each firewall needs its own roung instances and you require full, real-me redundancy out of
both firewalls all the me. To configure the VM-Series firewall as an HA pair, see Configure Acve/
Passive HA and Configure Acve/Acve HA.

If you are deploying the VM-Series firewall in the public cloud, such as on the Amazon Web
Services (AWS) or Azure, you can use the tradional acve/passive HA configuraon; see High
Availability for VM-Series Firewall on AWS and Set up Acve/Passive HA on Azure. Alternavely,
because of the innate differences in how resource or region redundancy is built into the cloud
infrastructure as compared to a private data center, to take advantage of nave cloud services and
build a resilient architecture that maximizes upme, see

• AWS— Auto Scale VM-Series Firewalls with the Amazon ELB to deploy mulple firewalls across
two or more Availability Zones within a VPC.

• Azure— VM-Series and Azure Applicaon Gateway Template Parameters.

Features/ Links Supported ESX KVM AWS NSX-
V

NSX-
T
(N/
S)

Hyper-
V

Azure GCP OCI

Acve/Passive HA Yes Yes Yes No Yes Yes Yes No Yes

Acve/Acve HA Yes Yes No No No Yes No No No

HA 1 Yes Yes Yes No Yes Yes Yes Yes Yes

HA2—(session synchronizaon and
keepalive)

Yes Yes Yes No Yes Yes Yes Yes Yes

HA3 Yes Yes No No No Yes No No No

HA1 and HA2 support for the VM-Series on GCP requires PAN-OS 10.0x or later and VM-
Series plugin 2.0.5 or later.
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High availability for the VM-Series firewall on NSX-T (E/W) is achieved through the NSX-T feature
called service health check. This NSX-T feature allows you to simulate high availability in the case
of a service instance failing. When configured with the VM-Series firewall, if a VM-Series service
instance fails, any traffic directed to that firewall is redirect to another firewall instance in the
cluster (for service cluster deployments) or a firewall instance on another host (for host-based
deployments). See Configure the Service Definion on Panorama for the VM-Series firewall on
NSX-T (E/W) for more informaon.
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Upgrade the VM-Series Firewall
Upgrading the PAN-OS version or VM-Series model allows you to add the latest features and fixes
that help improve the security capabilies and performance of your firewalls.

The standard PAN-OS release is just that; the normal version of PAN-OS that can be installed on
all Palo Alto Networks firewalls. The PAN-OS XFR releases are for VM-Series firewalls only and
can include new features and bug fixes for VM-Series firewalls. If you install a PAN-OS XFR image
on the VM-Series firewalls, the features and fixes are not available in PAN-OS versions that are
earlier than the soware version you have installed.

Because XFR images include features and fixes that are specific to VM-Series firewalls, if you
upgrade to an XFR release, you must stay on XFR releases to keep XFR specific features unl
the next major PAN-OS release; all the fixes and capabilies available in XFR will be cumulavely
rolled into the next major PAN-OS release.

• Upgrade the PAN-OS Soware Version (Standalone Version)
• Upgrade the PAN-OS Soware Version (HA Pair)
• Upgrade the PAN-OS Soware Version Using Panorama
• Upgrade the PAN-OS Soware Version (VM-Series for NSX)
• Upgrade the VM-Series Model
• Upgrade the VM-Series Model in an HA Pair
• Downgrade a VM-Series Firewall to a Previous Release

For instrucons on installing your VM-Series firewall, see VM-Series Deployments.

Verify the VM-Series System Requirements for your firewall model before you upgrade. If
your firewall has less than 5.5GB memory, the system capacity (number of sessions, rules,
security zones, address objects, etc) on the firewall will be limited to that of the VM-50
Lite.

Upgrade the PAN-OS Soware Version (Standalone Version)
Review the new features, addressed issues, and known issues and then use the following
procedure to upgrade a firewall that is not in an HA configuraon.

To avoid impacng traffic, plan to upgrade within the outage window. Ensure the firewall
is connected to a reliable power source. A loss of power during an upgrade can make the
firewall unusable.

STEP 1 | Verify that enough hardware resources are available to the VM-Series firewall.

Refer to the VM-Series System Requirements to see the resource requirements for each VM-
Series model. Allocate addional hardware resources before connuing the upgrade process;
the process for assigning addional hardware resources differs on each hypervisor.

If the VM-Series firewall does not have the required resources for the model, it defaults to the
capacity associated with the VM-50.
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STEP 2 | From the web interface, navigate to Device > Licenses and make sure you have the correct
VM-Series firewall license and that the license is acvated.

On the VM-Series firewall standalone version, navigate to Device > Support and make sure
that you have acvated the support license.

STEP 3 | Save a backup of the current configuraon file.

Although the firewall automacally creates a configuraon backup, it is a best pracce
to create and externally store a backup before you upgrade.

1. Select Device > Setup > Operaons and click Export named configuraon snapshot.
2. Select the XML file that contains your running configuraon (for example, running-

config.xml) and click OK to export the configuraon file.
3. Save the exported file to a locaon external to the firewall. You can use this backup to

restore the configuraon if you have problems with the upgrade.

STEP 4 | If you have enabled User-ID, aer you upgrade, the firewall clears the current IP address-
to-username and group mappings so that they can be repopulated with the aributes from
the User-ID sources. To esmate the me required for your environment to repopulate the
mappings, run the following CLI commands on the firewall.

• For IP address-to-username mappings:

• show user user-id-agent state all
• show user server-monitor state all

• For group mappings: show user group-mapping statistics

STEP 5 | Ensure that the firewall is running the latest content release version.
1. Select Device > Dynamic Updates and see which Applicaons or Applicaons and

Threats content release version is Currently Installed.
2. If the firewall is not running the minimum required content release version or a later

version required for PAN-OS, Check Now to retrieve a list of available updates.
3. Locate and Download the desired content release version.

Aer you successfully download a content update file, the link in the Acon column
changes from Download to Install for that content release version.

4. Install the update.
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STEP 6 | Upgrade the VM-Series plugin.
1. Before upgrading, check the latest Release Notes for details on whether a new VM-

Series plugin affects your environment.

For example, suppose a new VM-Series plugin version only includes AWS features. To
take advantage of the new features, you must update the plugin on your VM-Series
firewall instances on AWS.

Do not install an upgrade that does not apply to your environment.

2. Log in to the VM-Series firewall and check the dashboard to view the plugin version.
3. Select Device > Plugins  to view the plugin version. Use Check Now to check for

updates.
4. Select the version of the plugin and click Install in the Acon column to install the plugin.

STEP 7 | Upgrade PAN-OS.

If your firewall does not have internet access from the management port, you can
download the soware image from the Palo Alto Networks Customer Support Portal
and then manually Upload it to your firewall.

1. Select Device > Soware and click Check Now to display the latest PAN-OS updates.
2. Locate and Download the target PAN-OS version.
3. Aer you download the image (or, for a manual upgrade, aer you upload the image),

Install the image.
4. Aer the installaon completes successfully, reboot using one of the following methods:

• If you are prompted to reboot, click Yes.
• If you are not prompted to reboot, select Device > Setup > Operaons and click

Reboot Device.

At this point, the firewall clears the User-ID mappings, then connects to the
User-ID sources to repopulate the mappings.

5. If you have enabled User-ID, use the following CLI commands to verify that the firewall
has repopulated the IP address-to-username and group mappings before allowing traffic.

• show user ip-user-mapping all
• show user group list

6. If you are upgrading to an XFR release for the first me, repeat this step to upgrade to
the corresponding XFR release.

STEP 8 | Verify that the firewall is passing traffic.

Select Monitor > Session Browser and verify that you are seeing new sessions.

Upgrade the PAN-OS Soware Version (HA Pair)
Use the following procedure to upgrade a pair of firewalls in a high availability (HA) configuraon.
This procedure applies to both acve/passive and acve/acve configuraons.
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To avoid downme when upgrading firewalls that are in a high availability (HA) configuraon,
update one HA peer at a me: For acve/acve firewalls, it doesn’t maer which peer you
upgrade first (though for simplicity, this procedure shows you how to upgrade the acve-
secondary peer first). For acve/passive firewalls, you must upgrade the passive peer first,
suspend the acve peer (fail over), update the acve peer, and then return that peer to a
funconal state (fail back). To prevent failover during the upgrade of the HA peers, you must
make sure preempon is disabled before proceeding with the upgrade. You only need to disable
preempon on one peer in the pair.

To avoid impacng traffic, plan to upgrade within the outage window. Ensure the firewalls
are connected to a reliable power source. A loss of power during an upgrade can make
firewalls unusable.

STEP 1 | Verify that enough hardware resources are available to the VM-Series firewall.

Refer to the VM-Series System Requirements to see the resource requirements for each VM-
Series model. Allocate addional hardware resources before connuing the upgrade process;
the process for assigning addional hardware resources differs on each hypervisor.

If the VM-Series firewall does not have the required resources for the model, it defaults to the
capacity associated with the VM-50.

STEP 2 | From the web interface, navigate to Device > Licenses and make sure you have the correct
VM-Series firewall license and that the license is acvated.

On the VM-Series firewall standalone version, navigate to Device > Support and make sure
that you have acvated the support license.

STEP 3 | Save a backup of the current configuraon file.

Although the firewall automacally creates a backup of the configuraon, it is a best
pracce to create and externally store a backup before you upgrade.

Perform these steps on each firewall in the pair:

1. Select Device > Setup > Operaons and click Export named configuraon snapshot.
2. Select the XML file that contains your running configuraon (for example, running-

config.xml) and click OK to export the configuraon file.
3. Save the exported file to a locaon external to the firewall. You can use this backup to

restore the configuraon if you have problems with the upgrade.

STEP 4 | If you have enabled User-ID, aer you upgrade, the firewall clears the current IP address-
to-username and group mappings so that they can be repopulated with the aributes from
the User-ID sources. To esmate the me required for your environment to repopulate the
mappings, run the following CLI commands on the firewall.

• For IP address-to-username mappings:

• show user user-id-agent state all
• show user server-monitor state all

• For group mappings: show user group-mapping statistics
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STEP 5 | Ensure that each firewall in the HA pair is running the latest content release version.

Refer to the release notes for the minimum content release version you must install for a PAN-
OS 10.1 release. Make sure to follow the Best Pracces for Applicaon and Threat Updates.

1. Select Device > Dynamic Updates and check which Applicaons or Applicaons and
Threats to determine which update is Currently Installed.

2. If the firewalls are not running the minimum required content release version or a later
version required for the soware version you are installing, Check Now to retrieve a list
of available updates.

3. Locate and Download the desired content release version.
Aer you successfully download a content update file, the link in the Acon column
changes from Download to Install for that content release version.

4. Install the update. You must install the update on both peers.

STEP 6 | Upgrade the VM-Series plugin.
1. Before upgrading, check the latest Release Notes for details on whether a new VM-

Series plugin affects your environment.

For example, suppose a new VM-Series plugin version only includes AWS features. To
take advantage of the new features, you must update the plugin on your VM-Series
firewall instances on AWS.

Do not install an upgrade that does not apply to your environment.

2. Log in to the VM-Series firewall and check the dashboard to view the plugin version.
3. Select Device > Plugins  to view the plugin version. Use Check Now to check for

updates.
4. Select the version of the plugin and click Install in the Acon column to install the plugin.

When installing the plugin on VM-Series firewalls in an HA pair, install the plugin on the
passive peer before the acve peer. Aer installing the plugin on the passive peer, it will
transion to a non-funconal state. Installing the plugin on the acve peer returns the
passive peer to a funconal state.

STEP 7 | Disable preempon on the first peer in each pair. You only need to disable this seng on one
firewall in the HA pair but ensure that the commit is successful before you proceed with the
upgrade.
1. Select Device > High Availability and edit the Elecon Sengs.
2. If enabled, disable (clear) the Preempve seng and click OK.
3. Commit the change.

STEP 8 | Install the PAN-OS release on the first peer. If you are upgrading to an XFR release, install the
version that corresponds to the XFR release.

To minimize downme in an acve/passive configuraon, upgrade the passive peer first. For
an acve/acve configuraon, upgrade the secondary peer first. As a best pracce, if you are
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using an acve/acve configuraon, we recommend upgrading both peers during the same
maintenance window.

If you want to test that HA is funconing properly before the upgrade, consider
upgrading the acve peer in an acve/passive configuraon first to ensure that failover
occurs without incident.

1. On the first peer, select Device > Soware and click Check Now for the latest updates.
2. Locate and Download the target PAN-OS version.

If your firewall does not have internet access from the management port, you
can download the soware image from the Palo Alto Networks Support Portal
and then manually Upload it to your firewall.

3. Aer you download the image (or, for a manual upgrade, aer you upload the image),
Install the image.

4. Aer the installaon completes successfully, reboot using one of the following methods:

• If you are prompted to reboot, click Yes.
• If you are not prompted to reboot, select Device > Setup > Operaons and Reboot

Device.
5. Aer the device finishes reboong, view the High Availability widget on the Dashboard

and verify that the device you just upgraded is sll the passive or acve-secondary peer
in the HA configuraon.

STEP 9 | Install the PAN-OS release on the second peer. If you are upgrading to an XFR release, install
the version that corresponds to the XFR release.
1. (Acve/passive configuraons only) Suspend the acve peer so that HA fails over to the

peer you just upgraded.

1. On the acve peer, select Device > High Availability > Operaonal Commands and
click Suspend local device.

2. View the High Availability widget on the Dashboard and verify that the state changes
to Passive.

3. On the other peer, verify that it is acve and is passing traffic (Monitor > Session
Browser).

2. On the second peer, select Device > Soware and click Check Now for the latest
updates.

3. Locate and Download the target PAN-OS version.
4. Aer you download the image, Install it.
5. Aer the installaon completes successfully, reboot using one of the following methods:

• If you are prompted to reboot, click Yes.
• If you are not prompted to reboot, select Device > Setup > Operaons and Reboot

Device.
6. (Acve/passive configuraons only) From the CLI of the peer you just upgraded, run the

following command to make the firewall funconal again:
request high-availability state functional
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STEP 10 | (PAN-OS XFR upgrade only) Upgrade the first peer and second peer to PAN-OS XFR by
repeang Step 8 and Step 9.

STEP 11 | Verify that both peers are passing traffic as expected.

In an acve/passive configuraon, only the acve peer should be passing traffic; both peers
should be passing traffic in an acve/acve configuraon.

Run the following CLI commands to confirm that the upgrade succeeded:

• (Acve peers only) To verify that acve peers are passing traffic, run the show session
all command.

• To verify session synchronizaon, run the show high-availability interface ha2
command and make sure that the Hardware Interface counters on the CPU table are
increasing as follows:

• In an acve/passive configuraon, only the acve peer shows packets transmied; the
passive peer will show only packets received.

If you enabled HA2 keep-alive, the hardware interface counters on the passive
peer will show both transmit and receive packets. This occurs because HA2 keep-
alive is bi-direconal, which means that both peers transmit HA2 keep-alive
packets.

• In an acve/acve configuraon, you will see packets received and packets transmied
on both peers.

STEP 12 | If you disabled preempon prior to the upgrade, re-enable it now.
1. Select Device > High Availability and edit the Elecon Sengs.
2. Select Preempve and click OK.
3. Commit the change.

Upgrade the PAN-OS Soware Version Using Panorama
Use the following procedure to upgrade firewalls that you manage with Panorama. This procedure
applies to standalone firewalls and firewalls deployed in a high availability (HA) configuraon.

If Panorama is unable to connect directly to the update server, follow the procedure for
deploying updates to firewalls when Panorama is not internet-connected so that you
can manually download images to Panorama and then distribute the images to firewalls.

Before you can upgrade firewalls from Panorama, you must:

Make sure Panorama is running the same or a later PAN-OS version than you are upgrading
to. You must upgrade Panorama and its Log Collectors to 9.1 before upgrading the managed
firewalls to this version. In addion, when upgrading Log Collectors to 9.1, you must upgrade all
Log Collectors at the same me due to changes in the logging infrastructure.
Plan for an extended maintenance window of up to six hours when upgrading Panorama to
9.1. This release includes significant infrastructure changes, which means that the Panorama
upgrade will take longer than in previous releases.

VM-Series Deployment Guide Version Version 10.1 25 ©2022 Palo Alto Networks, Inc.

https://docs.paloaltonetworks.com/pan-os/10-1/pan-os-upgrade/upgrade-panorama/install-updates-for-panorama-without-internet-connection.html
https://docs.paloaltonetworks.com/pan-os/10-1/pan-os-upgrade/upgrade-panorama/install-content-and-software-updates-for-panorama.html
https://docs.paloaltonetworks.com/panorama/9-0/panorama-admin/manage-licenses-and-updates/deploy-updates-to-firewalls-log-collectors-and-wildfire-appliances-using-panorama.html


About the VM-Series Firewall

Ensure that firewalls are connected to a reliable power source. A loss of power during an
upgrade can make a firewall unusable.

STEP 1 | Aer upgrading Panorama, commit and push the configuraon to the firewalls you are
planning to upgrade.

STEP 2 | Verify that enough hardware resources are available to the VM-Series firewall.

Refer to the VM-Series System Requirements to see the resource requirements for each VM-
Series model. Allocate addional hardware resources before connuing the upgrade process;
the process for assigning addional hardware resources differs on each hypervisor.

If the VM-Series firewall does not have the required resources for the model, it defaults to the
capacity associated with the VM-50.

STEP 3 | From the web interface, navigate to Device > Licenses and make sure you have the correct
VM-Series firewall license and that the license is acvated.

On the VM-Series firewall standalone version, navigate to Device > Support and make sure
that you have acvated the support license.

STEP 4 | Save a backup of the current configuraon file on each managed firewall you plan to upgrade.

Although the firewall automacally creates a configuraon backup, it is a best pracce
to create and externally store a backup before you upgrade.

1. From the Panorama web interface, select Panorama > Setup > Operaons and
click Export Panorama and devices config bundle to generate and export the latest
configuraon backup of Panorama and of each managed appliance.

2. Save the exported file to a locaon external to the firewall. You can use this backup to
restore the configuraon if you have problems with the upgrade.

STEP 5 | Update the content release version on the firewalls you plan to upgrade.

Refer to the Release Notes for the minimum content release version required for PAN-OS 9.1.
Make sure to follow the Best Pracces for Applicaon and Threat Updates when deploying
content updates to Panorama and managed firewalls.

1. Select Panorama > Device Deployment > Dynamic Updates and Check Now for the
latest updates. If an update is available, the Acon column displays a Download link.

2. If not already installed, Download the latest content release version.
3. Click Install, select the firewalls on which you want to install the update, and click OK. If

you are upgrading HA firewalls, you must update content on both peers.

STEP 6 | (HA firewall upgrades only) If you will be upgrading firewalls that are part of an HA pair,
disable preempon. You need only disable this seng on one firewall in each HA pair.
1. Select Device > High Availability and edit the Elecon Sengs.
2. If enabled, disable (clear) the Preempve seng and click OK.
3. Commit your change. Make sure the commit is successful before you proceed with the

upgrade.
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STEP 7 | Download the target PAN-OS release image.
1. Select Panorama > Device Deployment > Soware and Check Now for the latest release

versions.
2. Download the firewall-specific file (or files) for the release version to which you are

upgrading. You must download a separate installaon file for each firewall model (or
firewall series) that you intend to upgrade.

STEP 8 | Install the PAN-OS soware update on the firewalls.
1. Click Install in the Acon column that corresponds to the firewall models you want to

upgrade.
2. In the Deploy Soware file dialog, select all firewalls that you want to upgrade. To reduce

downme, select only one peer in each HA pair. For acve/passive pairs, select the
passive peer; for acve/acve pairs, select the acve-secondary peer.

3. (HA firewall upgrades only) Make sure Group HA Peers is not selected.
4. Select Reboot device aer install.
5. To begin the upgrade, click OK.
6. Aer the installaon completes successfully, reboot using one of the following methods:

• If you are prompted to reboot, click Yes.
• If you are not prompted to reboot, select Device > Setup > Operaons and Reboot

Device.
7. Aer the firewalls finish reboong, select Panorama > Managed Devices and verify the

Soware Version is 9.1.0 for the firewalls you upgraded. Also verify that the HA status of
any passive firewalls you upgraded is sll passive.
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STEP 9 | (HA firewall upgrades only) Upgrade the second HA peer in each HA pair.
1. (Acve/passive upgrades only) Suspend the acve device in each acve/passive pair you

are upgrading.

1. Switch context to the acve firewall.
2. In the High Availability widget on the Dashboard, verify that Local firewall state is

Acve and the Peer is Passive).
3. Select Device > High Availability > Operaonal Commands > Suspend local device.
4. Go back to the High Availability widget on the Dashboard and verify that Local

changed to Passive and Peer changed to Acve.
2. Go back to the Panorama context and select Panorama > Device Deployment >

Soware.
3. Click Install in the Acon column that corresponds to the firewall models of the HA pairs

you are upgrading.
4. In the Deploy Soware file dialog, select all firewalls that you want to upgrade. This me,

select only the peers of the HA firewalls you just upgraded.
5. Make sure Group HA Peers is not selected.
6. Select Reboot device aer install.
7. To begin the upgrade, click OK.
8. Aer the installaon completes successfully, reboot using one of the following methods:

• If you are prompted to reboot, click Yes.
• If you are not prompted to reboot, select Device > Setup > Operaons and Reboot

Device.
9. (Acve/passive upgrades only) From the CLI of the peer you just upgraded, run the

following command to make the firewall funconal again:
request high-availability state functional

STEP 10 | (PAN-OS XFR upgrade only) Upgrade the first peer and second peer to PAN-OS XFR by
repeang Step 8 and Step 9.

STEP 11 | Verify the soware and content release version running on each managed firewall.
1. On Panorama, select Panorama > Managed Devices.
2. Locate the firewalls and review the content and soware versions in the table.

For HA firewalls, you can also verify that the HA Status of each peer is as expected.

STEP 12 | (HA firewall upgrades only) If you disabled preempon on one of your HA firewalls before
you upgraded, then edit the Elecon Sengs (Device > High Availability) and re-enable the
Preempve seng for that firewall and then Commit the change.

Upgrade the PAN-OS Soware Version (VM-Series for NSX)
Choose the upgrade method that best suits your deployment.
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• Upgrade the VM-Series for NSX During a Maintenance Window—use this opon to upgrade
the VM-Series firewall during a maintenance window without changing the OVF URL in the
service definion.

• Upgrade the VM-Series for NSX without disrupng traffic—use this opon to upgrade the VM-
Series firewall without disrupng service to the guest VMs or changing the OVF URL in the
service definion.

The following graphics displays the currently supported combinaons of Panorama and the
Panorama plugin for VMware NSX, as well as the upgrade paths you are required to follow to
upgrade successfully.

• Each box below represents a supported combinaon.
• When upgrading the Panorama plugin for NSX or Panorama in an HA pair, upgrade the passive

Panorama peer first, followed by the acve HA peer.

Before upgrading your VM-Series for VMware NSX deployment, review the upgrade paths shown
below to understand the upgrade steps to arrive at the plugin and PAN-OS combinaon that best
suits your environment.
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Upgrade the VM-Series for NSX During a Maintenance Window
For the VM-Series Firewall NSX edion, use Panorama to upgrade the soware version on the
firewalls.

STEP 1 | Review the VM-Series for VMware NSX upgrade paths.

STEP 2 | Allocate addional hardware resources to your VM-Series firewall.

Verify that enough hardware resources are available to the VM-Series firewall. Refer to the
VM-Series system requirements to see the new resource requirements for each VM-Series
model. Allocate addional hardware resources before connuing the upgrade process. The
process for assigning addional hardware resources differs on each hypervisor.
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STEP 3 | Save a backup of the current configuraon file on each managed firewall that you plan to
upgrade.

Although the firewall will automacally create a backup of the configuraon, it is a best
pracce to create a backup prior to upgrade and store it externally.

1. Select Device > Setup > Operaons and click Export Panorama and devices config
bundle. This opon is used to manually generate and export the latest version of the
configuraon backup of Panorama and of each managed device.

2. Save the exported file to a locaon external to the firewall. You can use this backup to
restore the configuraon if you have problems with the upgrade.

STEP 4 | Check the Release Notes to verify the Content Release version required for the PAN-OS
version.

The firewalls you plan to upgrade must be running the Content Release version required for the
PAN-OS version.

1. Select Panorama > Device Deployment > Dynamic Updates.
2. Check for the latest updates. Click Check Now (located in the lower le-hand corner

of the window) to check for the latest updates. The link in the Acon column indicates
whether an update is available. If a version is available, the Download link displays.

3. Click Download to download a selected version. Aer successful download, the link in
the Acon column changes from Download to Install.

4. Click Install and select the devices on which you want to install the update. When the
installaon completes, a check mark displays in the Currently Installed column.

STEP 5 | Deploy soware updates to selected firewalls.

If your firewalls are configured in HA, make sure to clear the Group HA Peers check box
and upgrade one HA peer at a me.

1. Select Panorama > Device Deployment > Soware.
2. Check for the latest updates. Click Check Now (located in the lower le-hand corner

of the window) to check for the latest updates. The link in the Acon column indicates
whether an update is available.

3. Review the File Name and click Download. Verify that the soware versions that
you download match the firewall models deployed on your network. Aer successful
download, the link in the Acon column changes from Download to Install.

4. Click Install and select the devices on which you want to install the soware version.
5. Select Reboot device aer install, and click OK.
6. If you have devices configured in HA, clear the Group HA Peers check box and upgrade

one HA peer at a me.

STEP 6 | Verify the soware and Content Release version running on each managed device.
1. Select Panorama > Managed Devices.
2. Locate the device(s) and review the content and soware versions on the table.
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Upgrade the VM-Series for NSX Without Disrupng Traffic
Use the following procedure to upgrade the PAN-OS version of the VM-Series firewalls in your
VMware NSX environment. This procedure allows you to perform the PAN-OS upgrade without
disrupng traffic by migrang VMs to different ESXi hosts.

STEP 1 | Review the VM-Series for VMware NSX upgrade paths.

STEP 2 | Save a backup of the current configuraon file on each managed firewall that you plan to
upgrade.

Although the firewall will automacally create a backup of the configuraon, it is a best
pracce to create a backup prior to upgrade and store it externally.

1. Select Device > Setup > Operaons and click Export Panorama and devices config
bundle. This opon is used to manually generate and export the latest version of the
configuraon backup of Panorama and of each managed device.

2. Save the exported file to a locaon external to the firewall. You can use this backup to
restore the configuraon if you have problems with the upgrade.

STEP 3 | Check the Release Notes to verify the Content Release version required for the PAN-OS
version.

The firewalls you plan to upgrade must be running the Content Release version required for the
PAN-OS version.

1. Select Panorama > Device Deployment > Dynamic Updates.
2. Check for the latest updates. Click Check Now (located in the lower le-hand corner

of the window) to check for the latest updates. The link in the Acon column indicates
whether an update is available. If a version is available, the Download link displays.

3. Click Download to download a selected version. Aer successful download, the link in
the Acon column changes from Download to Install.

4. Click Install and select the devices on which you want to install the update. When the
installaon completes, a check mark displays in the Currently Installed column.
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STEP 4 | Download the PAN-OS image to all VM-Series firewalls in the cluster.
1. Login to Panorama.
2. Select Panorama > Device Deployment > Soware.
3. Click Refresh to view the latest soware release and also review the Release Notes to

view a descripon of the changes in a release and to view the migraon path to install
the soware.

4. Click Download to retrieve the soware then click Install.

Do not reboot the VM-Series firewalls aer installing the new soware image.

5. Select the managed devices to be upgraded.
6. Clear the Reboot device aer install check box.

7. Click OK.

STEP 5 | Upgrade the VM-Series firewall on the first ESXi host in the cluster.
1. Login to vCenter.
2. Select Hosts and Clusters.
3. Right-click the host and select Maintenance Mode > Enter Maintenance Mode.
4. Migrate (automacally or manually) all VMs, except the VM-Series firewall, off of the

host.
5. Power off the VM-Series firewall. This should happen automacally upon entering

maintenance mode on the host.
6. (Oponal) Assign addional CPUs or memory to the VM-Series firewall before connuing

with the upgrade process.

Verify that enough hardware resources are available to the VM-Series firewall. Refer to
the VM-Series models to see the new resource requirements for each VM-Series model.

7. Right-click the host and select Maintenance Mode > Exit Maintenance Mode. Exing
maintenance mode causes the NSX ESX Agent Manager (EAM) to power on the VM-
Series firewall. The firewall reboots with the new PAN-OS version.

8. Migrate (automacally or manually) all VMs back to the original host.

STEP 6 | Repeat this process for each VM-Series firewall on each ESXi host.
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STEP 7 | Verify the soware and Content Release version running on each managed device.
1. Select Panorama > Managed Devices.
2. Locate the device(s) and review the content and soware versions on the table.

Upgrade the VM-Series Model
The licensing process for the VM-Series firewall uses the UUID and the CPU ID to generate a
unique serial number for each VM-Series firewall. Hence, when you generate a license, the license
is mapped to a specific instance of the VM-Series firewall and cannot be modified.

Use the instrucons in this secon if you are:

• Migrang from an evaluaon license to a producon license.
• Upgrading the model to allow for increased capacity. For example you want to upgrade from

the VM-100 to the VM-300 model.

• Upgrading capacity, which restarts some crical processes on the firewall. An HA
configuraon is recommended to minimize service disrupon; to upgrade the capacity
on a HA pair, see Upgrade the VM-Series Model in an HA Pair.

• In a private or public cloud deployment, if your firewall is licensed with the BYOL
opon, you must deacvate your VM before you change the instance type or VM
type. Upgrading the model or instance changes the UUID and CPU ID, so you must
apply the license when the .

STEP 1 | Allocate addional hardware resources to your VM-Series firewall.

Before iniang the capacity upgrade, you must verify that enough hardware resources are
available to the VM-Series firewall to support the new capacity. The process for assigning
addional hardware resources differs on each hypervisor.

To check the hardware requirements for your new VM-Series model, see VM-Series Models.

Although the capacity upgrade does not require a reboot of the VM-Series firewall, you need
to power down the virtual machine to change the hardware allocaon.

STEP 2 | Retrieve the license API key from the Customer Support portal.
1. Log in to the Customer Support Portal.

Make sure that you are using the same account that you used to register the
inial license.

2. From the menu on the le, select Assets > API Key Management.
3. Copy the API key.
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STEP 3 | On the firewall, use the CLI to install the API key copied in the previous step.

request license api-key set key <key>

STEP 4 | (If you have internet access) Enable the firewall to Verify Update Server identy on Device >
Setup > Service.

STEP 5 | Commit your changes. Ensure that you have a locally-configured user on the firewall.
Panorama pushed users might not be available aer the deacvaon if the configuraon
exceeds the non-licensed PA-VM objects limit.

STEP 6 | Upgrade the capacity.

Select Device > Licenses > Upgrade VM Capacity and then acvate your licenses and
subscripons in one of the following ways:

• (internet) Retrieve license keys from license server—Use this opon if you acvated your
license on the Customer Support portal.

• (internet) Use an authorizaon code—Use this opon to upgrade the VM-Series capacity
using an authorizaon code for licenses that have not been previously acvated on the
support portal. When prompted, enter the Authorizaon Code and then click OK.

• (no internet) Manually upload license key—Use this opon if your firewall does not have
internet connecvity to the Customer Support portal. From a computer with access to the
internet, log in to the CSP, download a license key file, transfer it to a computer in the same
network as the firewall, and upload it to the firewall.

STEP 7 | Verify that your firewall is licensed successfully.

On the Device > Licenses page, verify that the license was successfully acvated.

Upgrade the VM-Series Model in an HA Pair
Upgrading the VM-Series firewall allows you to increase the capacity on the firewall. Capacity
is defined in terms of the number of sessions, rules, security zones, address objects, IPSec VPN
tunnels, and SSL VPN tunnels that the VM-Series firewall is opmized to handle. When you apply
a new capacity license on the VM-Series firewall, the model number and the associated capacies
are implemented on the firewall.

Verify the VM-Series System Requirements for your firewall model before you upgrade. If
your firewall has less than 5.5GB memory, the capacity (number of sessions, rules, security
zones, address objects, etc) on the firewall will be limited to that of the VM-50 Lite.

This process is similar to that of upgrading a pair of hardware-based firewalls that are in an HA
configuraon. During the capacity upgrade process, session synchronizaon connues, if you
have it enabled. To avoid downme when upgrading firewalls that are in a high availability (HA)
configuraon, update one HA peer at a me.
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Do not make configuraon change to the firewalls during the upgrade process. During the
upgrade process, configuraon sync is automacally disabled when a capacity mismatch is
detected and is then re-enabled when both HA peers have matching capacity licenses.

If the firewalls in the HA pair have different major soware versions (such as 9.1 and 9.0)
and different capacies, both devices will enter the Suspended HA state. Therefore, it is
recommended that you make sure both firewalls are running the same version of PAN-OS
before upgrading capacity.

STEP 1 | Upgrade the capacity license on the passive firewall.

Follow the procedure to Upgrade the VM-Series Model.

The new VM-Series model displays on the dashboard aer some processes restart on this
passive peer. This upgraded peer is now is a non-funconal state because of the capacity
mismatch with its acve peer.

If you have enabled session synchronizaon, verify that sessions are synchronized across HA
peers before you connue to the next step. To verify session synchronizaon, run the show
high-availability interface ha2  command and make sure that the Hardware
Interface counters on the CPU table are increasing as follows:

• In an acve/passive configuraon, only the acve peer show packets transmied and the
passive device will only show packets received.

If you have enabled HA2 keep-alive, the hardware interface counters on the passive
peer will show both transmit and receive packets. This occurs because HA2 keep-alive is
bidireconal which means that both peers transmit HA2 keep-alive packets.

• In an acve/acve configuraon, you will see packets received and packets transmied on
both peers.

STEP 2 | Upgrade the capacity license on the acve firewall.

Follow the procedure to Upgrade the VM-Series Model.

The new VM-Series model displays on the dashboard aer the crical processes restart. The
passive firewall becomes acve, and this peer (previously acve firewall) moves from the inial
state to becoming the passive peer in the HA pair.

Downgrade a VM-Series Firewall to a Previous Release
Use the following workflow to restore the configuraon that was running before you upgraded to
a different feature release. Any changes made since the upgrade are lost. Therefore, it is important
to back up your current configuraon so you can restore those changes when you return to the
newer release.

You cannot downgrade the VM-Series firewall from version 10.0.4 or later to version
10.0.3 or earlier.

Use the following procedure to downgrade to a previous release.
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STEP 1 | Save a backup of the current configuraon file.

Although the firewall automacally creates a backup of the configuraon, it is a best
pracce to create a backup before you upgrade and store it externally.

1. Export named configuraon snapshot (Device > Setup > Operaons).
2. Select the XML file that contains your running configuraon (for example, running-

config.xml) and click OK to export the configuraon file.
3. Save the exported file to a locaon external to the firewall. You can use this backup to

restore the configuraon if you have problems with the downgrade.

STEP 2 | Install the previous feature release image.

Autosave versions are created when you upgrade to a new release.

1. Check Now (Device > Soware) for available images.
2. Locate the image to which you want to downgrade. If the image is not already

downloaded, then Download it.
3. Aer the download completes, Install the image.
4. Select a Config File for Downgrading, which the firewall will load aer you reboot the

device. In most cases, you should select the configuraon that was saved automacally
when you upgraded from the release to which you are now downgrading. For
example, if you are running PAN-OS 9.1 and are downgrading to PAN-OS 9.0.3, select
autosave-9.0.3.

5. Aer the installaon completes successfully, reboot using one of the following methods:

• If you are prompted to reboot, click Yes.
• If you are not prompted to reboot, go to Device Operaons (Device > Setup >

Operaons) and Reboot Device.

VM-Series Deployment Guide Version Version 10.1 37 ©2022 Palo Alto Networks, Inc.



About the VM-Series Firewall

VM-Series Plugin
The VM-Series firewalls include the VM-Series plugin, a built-in plugin architecture for integraon
with public cloud providers or private cloud hypervisors. The VM-Series plugin can be manually
upgraded independent of PAN-OS, enabling Palo Alto Networks® to accelerate the release of new
features, fixes, or integraons with new cloud providers or hypervisors.

The VM-Series plugin enables you to manage cloud-specific interacons between the VM-
Series firewalls and the supported public cloud plaorms—AWS, GCP, and Azure. The plugin
enables publishing custom metrics to cloud monitoring services (such as AWS CloudWatch),
bootstrapping, configuring user credenal provisioning informaon from public cloud
environments, and seamless updates for cloud libraries or agents on PAN-OS.

The VM-Series plugin does not manage capabilies that are common to both VM-Series
firewalls and hardware-based firewalls. For example, VM Monitoring is not part of the VM-
Series plugin because it is a core PAN-OS feature that helps you enforce policy consistently
on your virtual machine workloads from both VM-Series firewalls and hardware-based
firewalls.

The VM-Series plugin does not manage Panorama plugins. For the difference between the
VM-Series plugin and Panorama plugins, see VM-Series Plugin and Panorama Plugins.

The VM-Series plugin is a built-in component that can be upgraded or downgraded, but not
removed. Each PAN-OS release includes a specific VM-Series plugin version that corresponds
to the PAN-OS soware version. When you downgrade to an earlier PAN-OS soware version,
the plugin version is downgraded to the version compable with the PAN-OS version. You can
upgrade or downgrade the VM-Series plugin locally on the virtual firewall, or manage the plugin
version centrally from Panorama.

To enable Panorama to manage the VM-Series plugin version itself, or cloud-specific metrics
publishing your managed firewalls, you must manually install the VM-Series plugin on Panorama as
described in Panorama Plugins.

• Configure the VM-Series Plugin on the Firewall
• Upgrade the VM-Series Plugin

Configure the VM-Series Plugin on the Firewall
Select Device > VM-Series to configure the plugin integraon for the cloud provider on which this
instance of the VM-Series firewall is deployed.
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If your firewall is deployed on a hypervisor or cloud without a public interface (for example,
VMware ESXi), the tab is named VM-Series and displays a general message.

Upgrade the VM-Series Plugin
When a plugin update is released independent of PAN-OS, you can independently upgrade the
plugin version from your VM-Series firewall (like soware or content updates) or from a bootstrap
file.

Each plugin version provides PAN-OS compability informaon and includes new features or bug
fixes for one or more cloud environments.

STEP 1 | Before upgrading, check the latest Release Notes for details on whether a new VM-Series
plugin affects your environment.

For example, suppose a new VM-Series plugin version only includes AWS features. To take
advantage of the new features, you must update the plugin on your VM-Series firewall
instances on AWS.

Do not install an upgrade that does not apply to your environment.
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STEP 2 | Log in to the VM-Series firewall and check the dashboard to view the plugin version.

STEP 3 | Select Panorama > Plugins  and type vm_series in the search field.

Select Check Now to view the available versions.

STEP 4 | Choose a VM-Series plugin version and click Download.

STEP 5 | When the download finishes, click Install in the Acons column.

The firewall automacally uninstalls the previously installed version of the plugin.
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STEP 6 | View the Dashboard to verify that the plugin upgraded successfully.
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Enable Jumbo Frames on the VM-Series Firewall
By default, the maximum transmission unit (MTU) size for packets sent on a Layer 3 interface is
1500 bytes. This size can be manually set to any size from 512 to 1500 bytes on a per-interface
basis. Some configuraons require Ethernet frames with an MTU value greater than 1500 bytes.
These are called jumbo frames.

To use jumbo frames on a firewall you must specifically enable jumbo frames at the global level.
When this is enabled, the default MTU size for all Layer 3 interfaces is set to a value of 9192
bytes. This default value can then be set to any value in the range of 512 to 9216 bytes.

Aer seng a global jumbo frame size it becomes the default value for all Layer 3 interfaces that
have not explicitly had an MTU value set at the interface configuraon level. This can become a
problem if you only want to exchange jumbo frames on some interfaces. In these situaons, you
must set the MTU value at every Layer 3 interface that you do not want to use the default value.

The following procedure describes how to enable jumbo frames on a firewall, set the default MTU
value for all Layer 3 interfaces and to then set a different value for a specific interface.

VM-Series firewall instances deployed with mulple NUMA nodes, come up in packet
MMAP mode when jumbo frame support is enabled. You must disable jumbo frame
support to use DPDK on VM-Series firewall instance deployed with mulple NUMA nodes.

STEP 1 | Enable jumbo frames and set a default global MTU value.
1. Select Device > Setup > Session and edit the Session Sengs secon.
2. Select Enable Jumbo Frame.
3. Enter a value for Global MTU.

The default value is 9192. The range of acceptable values is: 512 - 9216.
4. Click OK.

A message is displayed that informs you that enabling or disabling Jumbo Frame mode
requires a reboot and that Layer 3 interfaces inherit the Global MTU value.

5. Click Yes.

A message is displayed to inform you that Jumbo Frame support has been enabled and
reminds you that a device reboot is required for this change to be acvated.

6. Click OK.
7. Click Commit.
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STEP 2 | Set the MTU value for a Layer 3 interface and reboot the firewall.

The value set for the interface overrides the global MTU value.

1. Select Network > Interfaces.
2. Select an interface of the Layer3 Interface type.
3. Select Advanced > Other Info.
4. Enter a value for MTU.

The default value is 9192. The range of acceptable values is: 512 - 9216.
5. Click OK.
6. Click Commit.
7. Select Device > Setup > Operaons and select Reboot Device.

VM-Series Deployment Guide Version Version 10.1 43 ©2022 Palo Alto Networks, Inc.



About the VM-Series Firewall

Hypervisor Assigned MAC Addresses
By default, the VM-Series firewall uses the MAC address assigned to the physical interface by the
host/hypervisor to deploy a VM-Series firewall with Layer 3 interfaces. The firewall can then use
the hypervisor assigned MAC address in its ARP responses. This capability allows non-learning
switches, such as the VMware vSwitch to forward traffic to the dataplane interface on the firewall
without requiring that promiscuous mode be enabled on the vSwitch. If neither promiscuous
mode nor the use of hypervisor assigned MAC address is enabled, the host will drop the frame
when it detects a mismatch between the desnaon MAC address for an interface and the host-
assigned MAC address.

There is no opon to enable or disable the use of hypervisor assigned MAC addresses on
AWS and Azure. It is enabled by default for both plaorms and cannot be disabled.

If you are deploying the VM-Series firewall in Layer 2, virtual wire, or tap interface modes, you
must enable promiscuous mode on the virtual switch to which the firewall is connected. The use
of hypervisor assigned MAC address is only relevant for Layer 3 deployments where the firewall is
typically the default gateway for the guest virtual machines.

When hypervisor assigned MAC address funconality is enabled on the VM-Series firewall, make
note of the following requirements:

• IPv6 Address on an Interface—In an acve/passive HA configuraon (see VM-Series in High
Availability), Layer 3 interfaces using IPv6 addresses must not use the EUI-64 generated
address as the interface idenfier (Interface ID). Because the EUI-64 uses the 48-bit MAC
address of the interface to derive the IPv6 address for the interface, the IP address is not stac.
This results in a change in the IP address for the HA peer when the hardware hosng the VM-
Series firewall changes on failover, and leads to an HA failure.

• Lease on an IP Address—When the MAC address changes, DHCP client, DHCP relay and
PPPoE interfaces might release the IP address because the original IP address lease could
terminate.

• MAC address and Gratuitous ARP—VM-Series firewalls with hypervisor assigned MAC
addresses in a high-availability configuraon behave differently than the hardware appliances
with respect to MAC addressing. Hardware firewalls use self-generated floang MAC
addresses between devices in an HA pair, and the unique MAC address used on each dataplane
interface (say eth 1/1) is replaced with a virtual MAC address that is common to the dataplane
interface on both HA peers. When you enable the use of the hypervisor assigned MAC address
on the VM-Series firewall in HA, the virtual MAC address is not used. The dataplane interface
on each HA peer is unique and as specified by the hypervisor.

Because each dataplane interface has a unique MAC address, when a failover occurs, the now
acve VM-Series firewall must send a gratuitous ARP so that neighboring devices can learn the
updated MAC/IP address pairing. Hence, to enable a stateful failover, the networking devices
must not block or ignore gratuitous ARPs; make sure to disable the an-ARP poisoning feature
on the internetworking devices, if required.

Perform the following steps to configure the VM-Series firewall to use the interface MAC
addresses provided by the host/hypervisor.

STEP 1 | Select Device > Management > Setup > General Sengs.
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STEP 2 | Click the Edit icon.

STEP 3 | Check the opon to Use Hypervisor Assigned MAC Address.

When the MAC address change occurs, the firewall generates a system log to record this
transion and the interface generates a gratuitous ARP.

STEP 4 | Click OK.

STEP 5 | Commit the change on the firewall. You do not need to reboot the firewall.
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Custom PAN-OS Metrics Published for Monitoring
The firewall navely publishes the following metrics to monitoring systems in the public cloud
such as AWS® CloudWatch, Azure® Applicaon Insights, and Google® Stackdriver. These metrics
allow you to assess firewall performance and usage paerns so that you can set alarms and take
acon to automate events such as launching or terminang instances of the VM-Series firewalls.
Because these metrics are published through content updates on the firewall, make sure that you
have the minimum content release version that is required to enable this capability on your VM-
Series firewall.

Metric Descripon

Dataplane CPU Ulizaon (%) Monitors dataplane CPU usage and measures the traffic
load on the firewall.

Dataplane Packet Buffer
Ulizaon (%)

Monitors dataplane buffer usage and measures buffer
ulizaon. If you have a sudden burst in traffic, monitoring
your buffer ulizaon allows you to ensure that the firewall
does not deplete the dataplane buffer, which results in
dropped packets.

GlobalProtect™ Gateway Acve
Tunnels

Monitors the number of acve GlobalProtect sessions
on a firewall deployed as a GlobalProtect gateway. Use
this metric if you use this VM-Series firewall as a VPN
gateway to secure remote users. Check the datasheet for
the maximum number of acve tunnels supported for your
firewall model.

GlobalProtect Gateway Tunnel
Ulizaon (%)

Monitors the acve GlobalProtect tunnels on a gateway
and measures tunnel ulizaon. Use this metric if you use
this VM-Series firewall as a VPN gateway to secure remote
users.

panSessionConneconsPerSecond Monitors the new connecon establish rate per second.

panSessionThroughputKbps Monitors the throughput in Kbps.

panSessionThroughputPps Monitors the number of packets per second.

Sessions Acve Monitors the total number of sessions that are acve on
the firewall. An acve session is a session that is in the
flow lookup table for which packets will be inspected and
forwarded, as required by policy.

Session Ulizaon (%) Monitors the TCP, UDP, ICMP and SSL sessions that are
currently acve and the packet rate, new connecon
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Metric Descripon

establish rate, and firewall throughput to determine session
ulizaon.

SSLProxyUlizaon (%) Monitors the percentage of SSL forward proxy sessions
with clients for SSL/TLS decrypon.

To publish these metrics, see:

• Enable CloudWatch Monitoring on the VM-Series Firewall
• Enable Azure Applicaon Insights on the VM-Series Firewall
• Enable Google Stackdriver Monitoring on the VM Series Firewall

VM-Series Deployment Guide Version Version 10.1 47 ©2022 Palo Alto Networks, Inc.



About the VM-Series Firewall

Interface Used for Accessing External Services on the
VM-Series Firewall

To access the Palo Alto Networks servers for retrieving licenses and soware and content
updates, and for publishing custom PAN-OS metrics or retrieving IP address and tag mapping for
monitoring virtual machines in your deployment, the VM-Series firewall uses the management
interface except where noted below. To use a dataplane interface instead of the management
interface where supported, you must set up a service route that specifies the dataplane interface
that the firewall can use to access the server or service.

Access to Server or Service Interface Used on the VM-Series Firewall

Licensing Management interface only

Soware Updates Management interface or Service Route

Bootstrapping from a cloud storage
locaon such as AWS S3 bucket, Azure
storage file service, or Google storage
bucket

Management interface only, including when
interfaces are swapped

If your bootstrap.xml file includes
license authcodes, you cannot use a
service route. To license the firewall,
the management interface must be
used.

Publishing PAN-OS metrics to a cloud
monitoring service such as AWS
CloudWatch, Azure Applicaon Insights or
Google Stackdriver

Management interface only, including when
interfaces are swapped

VM Monitoring Management interface or Service Route
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PacketMMAP and DPDK Driver Support
Single-root input/output virtualizaon (SR-IOV) relies on communicaon between virtual
funcon (VF) drivers on the VM-Series firewall, and physical funcon (PF) drivers on the host (the
hypervisor). The host uses PF drivers to talk to its physical NICs, and the VM-Series firewall uses
VF drivers to talk to the PF drivers.

The following diagram is a simple visualizaon of that concept.

SR-IOV

Why use SR-IOV? SR-IOV is a packet acceleraon technology that allows a virtual machine to
directly access packets from the NIC. In contrast, when using a virtual switch, the host processes
the packets, send the packets through a virtual switch, and then the virtual machine receives its
packets.

In the Compability Matrix, PacketMMAP Driver Versions lists both the host version and the
nave driver version on the VM-Series firewall. For example, i40e on the host, and on the firewall,
i40e (for PCI-passthrough) and i40evf (for SR-IOV).

For SR-IOV, let's consider a NIC that uses the i40e PF driver. The host communicates with the NIC
via the i40e driver. The VM-Series firewall can use its VF driver (i40evf) to directly communicate
with the host's PF driver. This allows VM-Series firewall direct access, which improves packet
processing speed. To ensure compability, install a host PF driver version that is later than the
nave PF driver version.

PCI-Passthrough

Why does VM-Series firewall have nave PF drivers? As menoned in Opons for Aaching
VM-Series on the Network, when using PCI-passthrough, the NIC is reserved for the VM-Series
firewall, so the host (or other guests on the host) cannot access the NIC. In a PCI-passthrough
configuraon, the VM-Series firewall uses its nave PF driver to communicate directly with the
host NIC.
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Refer to the PacketMMAP Driver Versions list to determine which PF driver version to install on
the host. Install a PF version that is higher than VM-Series firewall nave PF driver.

Refer to Enable SR-IOV on ESXi and Enable SR-IOV on KVM for PCI-Passthrough.

DPDK

PAN-OS has two packet processing modes—DPDK (default) and MMAP—and each mode has a
corresponding nave driver on the VM-Series firewall. For example, if the firewall is in DPDK
mode, the firewall uses the DPDK i40evf driver version to communicate with the host's i40e
driver (when using SR-IOV). Alternavely, when the firewall is Packet MMAP, it will use a different
i40evf driver version to communicate with the host's i40e driver.

You can enable DPDK on the host (the hypervisor), or on the guest (the VM-Series firewall).
Enabling both yields the best results.

• Compiling OVS with DPDK is part of enabling DPDK on the host.

Refer to Configure OVS and DPDK on the Host.
• VM-Series DPDK enables the nave DPDK driver on the VM-Series firewall, so DPDK does not

need to be enabled on the host, but it is recommended for best performance.
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Enable NUMA Performance Opmizaon on the VM-
Series

To improve performance of your VM-Series firewalls, you can enable non-uniform memory access
(NUMA) performance opmizaon. When NUMA performance opmizaon is enabled, the VM-
Series firewall dataplane uses vCPUs aached to NUMA node 0. The VM-Series firewall dataplane
uses vCPUs belonging to NUMA node 0 only. The VM-Series management plane uses core 0 and
the remaining vCPUs on NUMA node 0 can be used by the VM-Series dataplane. This feature
requires PAN-OS 10.1.1 or later and VM-Series plugin 2.1.1 or later.

NUMA performance opmizaon is disabled by default in PAN-OS 10.1.

If you have a device that contains 64 cores across two NUMA nodes, when NUMA performance
opmizaon is not enabled, the dataplane vCPUs used by the VM-Series firewall might be on
different nodes, which impacts performance. For example, if your system is organized shown in
the following example and you deploy a VM-Series firewall with 32 total cores with 24 dataplane
cores. Without NUMA performance opmizaon, the VM-Series firewall uses cores 1 through 15
on Node 0 and 16 to 24 on Node 1 because it assigns cores in numerical order, regardless of the
node locaon. With NUMA opmizaon enables, the VM-Series only uses cores on Node 0, in
this case 1 through 15 and 33 through 39, regardless of the numerical order. Any cores not used
by the dataplane are assigned to the management plane.

If the number of cores assigned to your VM-Series firewall exceeds the number of vCPUs
on Node 0, the VM-Series uses all the cores on Node 0 but does not use any cores from
other nodes. For example, if you assign 30 cores to your VM-Series firewall but Node 0
has only 24 cores, the VM-Series firewall will only use the 24 cores on Node 0 for the
dataplane.

STEP 1 | Log in to the VM-Series CLI.

STEP 2 | Execute the following command.

request plugins vm_series numa-perf-optimize enable on

Previous NUMA performance optimization: None

Requested NUMA performance optimization: Enabled

Please reboot the PA-VM.

STEP 3 | Aer the reboot is complete, log in to the VM-Series CLI and verify that NUMA opmizaon
was enabled.

show plugins vm_series numa-perf-optimize

NUMA performance optimization: Enabled
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STEP 4 | Verify the number of dataplane cores.

show plugins vm_series dp-cores

Device current DP cores: 15 (Total cores: 16)

STEP 5 | To disable NUMA performance opmizaon, use the following command. This command
requires you to reboot the VM-Series firewall.

request plugins vm_series numa-perf-optimize enable off
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Enable ZRAM on the VM-Series Firewall
If your VM-Series firewall experiences low or out-of memory condions, you can enable ZRAM
to improve memory usage. ZRAM, also called compcache (compressed cache), is a Linux kernel
module for creang a compressed block device in RAM. When enabled, ZRAM is used as swap
disk and allows for faster I/O of swap because it resides in the RAM.

Complete the following steps to enable ZRAM.

STEP 1 | Log in to the VM-Series CLI.

STEP 2 | Find the total memory on the VM by using the following CLI command.

grep pattern “KiB Mem :” mp-log mp-monitor.log

KiB Mem :  9202656 total,   566504 free,  3475840 used,  5160312
 buff/cache
KiB Mem :  9202656 total,   497112 free,  3481944 used,  5223600
 buff/cache
KiB Mem :  9202656 total,   511744 free,  3466768 used,  5224144
 buff/cache
KiB Mem :  9202656 total,   511668 free,  3466340 used,  5224648
 buff/cache
KiB Mem :  9202656 total,   512124 free,  3465700 used,  5224832
 buff/cache
KiB Mem :  9202656 total,   511436 free,  3465976 used,  5225244
 buff/cache
KiB Mem :  9202656 total,   510984 free,  3465944 used,  5225728
 buff/cache

STEP 3 | Convert the above total memory from KB to MB. For example:

9202656 / 1024 = 8987 MB

Take note of the total memory value in MB. You will need this value in the next step.

STEP 4 | Enable ZRAM using the following two CLI commands.

debug software kernelcfg zram-swap enable

debug software kernelcfg zram-swap modify host-mem-threshold <total-
memory-in-MB>

STEP 5 | Reboot the VM-Series firewall.

STEP 6 | Verify that ZRAM is enabled.

debug software kernelcfg zram-swap show config
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VM-Series firewall supports two license types (BYOL and PayGo), and two different
licensing models—Soware Next Generaon Firewall Credits (Soware NGFW) for
flexible configuraons that you specify with a deployment profile, and fixed VM-Series
Model configuraons. Both models also license Security services and other features.

If you are an authorized CSSP partner, see Licenses for Cloud Security Service
Providers (CSSPs) for informaon that pertains to you.

See the following topics for details on creang a support account and managing
licenses:

> VM-Series Firewall Licensing
> Create a Support Account
> Serial Number and CPU ID Format

for the VM-Series Firewall
> Licensing API
> Install a License API Key

> Use Panorama-Based Soware
Firewall License Management

> Soware NGFW Credits
> VM-Series Models
> What Happens When Licenses

Expire?
> Licenses for Cloud Security Service

Providers (CSSPs)

55
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VM-Series Firewall Licensing
This chapter compares the following license informaon:

• License Types: BYOL versus PayGo
• Flexible vCPUs and Fixed Model Licensing: Flexible vCPUs versus fixed models)
• Flexible vCPUs and Fixed Model Deployment: Summary of deployment steps for flexible and

fixed models.

License Types
Palo Alto Networks currently supports two license types: Bring Your Own License (BYOL) and
PAYG (Pay-As-You-Go, also called PayGo).

Type Descripon

BYOL Soware NGFW Credits—Available on VM-Series firewalls running all PAN-OS
releases. VM-Series firewalls running PAN-OS versions 10.0.4 and later offer
advanced features and more flexibility. The flexible license cost is based on the
number of vCPUs, the security services you have enabled, and whether you choose to
provision Panorama to manage the firewall or act as a log collector.

See Soware NGFW Credits for a detailed explanaon.

BYOL VM-Series Model licenses—Available for use with all PAN-OS releases. The number of
vCPUs is fixed according to your chosen VM-Series model.

Flexible vCPUs, available with PAN-OS 10.0.4 and later, support advanced
features and more vCPUs.

The capacity license cost is based on the VM-Series model, the device memory,
storage costs, and the support entlement. Security services and a Panorama
deployment to manage your firewalls are addional costs. The capacity license types
are:

• VM-Series Enterprise License Agreement (Mul-Model ELA)—A comprehensive
one- or three-year licensing agreement for VM-Series firewalls. An individual
license can include a model, security services, a support entlement, and an
oponal device management license for Panorama.

Mul-Model ELA features a token pool from which you allocate tokens to license
VM-Series firewalls. (It is unique to the ELA, and is not the same as the Soware
NGFW Credits pool.)

• Perpetual VM-Series model capacity license with a support entlement and/or
security services bundle 1 or bundle 2.

• Term firewall capacity license with a support entlement and your choice of
security services.
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Type Descripon

PayGo Purchased from a public cloud marketplace (such as AWS, Azure, or GCP), or a Cloud
Security Service Provider (CSSP). Available on the PAN-OS version your provider
supports.

On PAN-OS versions earlier than 9.1.1, PayGo supported only the VM-Series
VM-300 model. For PAN-OS 9.1.1 and later PayGo can support fixed Models.
The tradional VM models, such as VM-100, VM-300, VM-500, and VM-700 are
supported.

Flexible vCPUs and Fixed Model Licensing
What is the difference between flexible vCPU Soware NGFW licensing and fixed vCPU VM-
Series Model licenses? They charge for different things, and they fund them differently. The
following tables provide a quick comparison, and links to greater details.

 Flexible vCPUs VM-Series Model (Fixed vCPUs)

Descripon Cost is based on the number of
vCPUs and your chosen Security
services.

There is no cost for Panorama other
than the vCPUs it consumes.

You purchase reusable Soware
NGFW credits that expire at the
end of a predetermined term. Aer
acvang your credits you can
poron them into credit pools.

To use your credits, choose a credit
profile and create one or more
deployment profiles. Choose your
own combinaon of firewall-as-a-
plaorm components: VM-Series
vCPUs, security services, virtual
Panorama for Management or
Dedicated Log Collecon, and a
support entlement. All firewalls
deployed with a profile are licensed
with the same auth code, and you can
manage them from the deployment
profile.

Cost is based on the VM-Series model
capacity license, device memory,
and storage. Panorama and Security
services are separate purchases.

• VM-Series Enterprise License
Agreement (Mul-Model ELA)—A
comprehensive one- or three-year
licensing agreement for VM-Series
firewalls.

Mul-Model ELA features a token
pool from which you allocate
tokens to license VM-Series
firewalls.

• Perpetual VM-Series model
capacity license with a support
entlement and/or security
services bundle 1 or bundle 2.

• Term firewall capacity license with
a support entlement and your
choice of security services.

Acvaon Requires an acvaon email.
Acvaon and registraon occur
automacally.

Requires an acvaon email and
a separate registraon step aer
acvaon.
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 Flexible vCPUs VM-Series Model (Fixed vCPUs)

Security
services

Threat Prevenon, DNS Security,
GlobalProtect, WildFire, URL Filtering,
SD-WAN, DLP, and other services as
they become available.

When you create your deployment
profile you can choose any
combinaon of security services. You
can add or remove security services
from your profile at any me.

Bundle 1: Threat Prevenon and
premium support entlement.

Bundle 2: Threat Prevenon, DNS
Security, GlobalProtect, WildFire, URL
Filtering, SD-WAN, DLP, and premium
support entlement.

PAN-OS
version

Up to 32 flexible vCPUs and
advanced service opons.

You can deploy a VM-Series model
(fixed vCPUs) on any PAN-OS version.

Funding Reusable credits that allow you to
consume firewall-as-a-plaorm
components.

Aer you purchase credits you must
acvate them, associang them
to a parcular account for your
organizaon. Acvated credits fund a
credit pool from which you can create
a deployment profile.

When firewalls are deployed, credits
are consumed. When firewalls are
deacvated, the credits are released
and returned to your credit pool for
further use.

• Mul-Model ELA: tokens.
• Perpetual VM-Series model

capacity license with a support
entlement and/or security
services bundle 1 or bundle 2.
You determine the configuraon
at me of purchase. You cannot
change the configuraon unless
you purchase a new license.

• Term firewall capacity license with
a support entlement and your
choice of security services.

Deployment
Configuraon

Flexible. A deployment profile can be
changed at any me. Changes to the
profile propagate to all firewalls that
share the deployment profile auth
code.

VM-Series model capacity does not
change, but if you have an ELA, you
an can add Security services.

Perpetual and Term licenses are
configured and paid for in advance
and do not change.

Deployment Aer credit acvaon, create a
deployment profile for a specific
environment or use case (such as
“Protect my NSX Environment”) and
configure firewall vCPUs, security
services, and an oponal virtual
Panorama. You can create any number
of deployment profiles and customize
them at any point in me.

Accept the VM-Series ELA. Deploy
and configure the VM-Series firewall.
Acvate the model license and
register the firewall.
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 Flexible vCPUs VM-Series Model (Fixed vCPUs)
You must have the Customer Support
Portal role Credit Administrator
(applies to account management only)
to acvate and manage Soware
NGFW credits.

Panorama When you create a deployment
profile you can choose to add
Panorama for management, or as a
dedicated log collector for firewalls
that use a deployment profile. This
Panorama can manage firewalls
deployed with the deployment
profile’s shared auth code.

Panorama is a separate expense. A
physical or virtual Panorama can be
used to for firewall management or
for log collecon.

Upgrade or
Downgrade

If the VM-Series firewall or Panorama
has an internet connecon, changes
to your deployment profile are
automacally applied to the firewall.

If the firewall does not have an
internet connecon, manually
stop the firewall. In Assets >
Soware NGFW Credits change
the deployment profile, then in the
CSP, download the license keys, and
transfer them to the VM, obtain the
profile from the CSP, transfer it to
the VM, restart the VM and apply the
license.

You do not have to reboot the firewall
in either case.

Change to a different model requires
a license change and a reboot.

Flexible vCPUs and Fixed Model Deployment
The following checklists compare the deployment processes for Soware NGFW credits and the
VM-Series Model licensing methods.

Flexible vCPUs Fixed vCPUs (VM-Series Model)

1. Create a Support Account.
2. Acvate Credits.

Your organizaon can have many accounts
to represent different cost centers. During
registraon you associate your credit
purchase with an account.

1. Create a Support Account.
2. Acvate VM-Series Model Licenses.
3. Register the VM-Series Firewall.
4. Deploy the VM-Series firewall on Alibaba,

AWS, Azure, Cisco ACI, Cisco CSP, Cisco
ENCS, ESXi, Google Cloud Plaorm,
Hyper-V, KVM, OpenStack. Oracle Cloud
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Flexible vCPUs Fixed vCPUs (VM-Series Model)
3. Create a Deployment Profile.
4. Deploy the VM-Series firewall on Alibaba,

AWS, Azure, Cisco ACI, Cisco CSP, Cisco
ENCS, ESXi, Google Cloud Plaorm,
Hyper-V, KVM, OpenStack. Oracle Cloud
Infrastructure, vCloud Air, NSX-T, or NSX-V

5. Install a Device Cerficate on the VM-
Series Firewall (for site licenses such as
Cortex Data Lake and Auto Focus).

Infrastructure, vCloud Air, NSX-T, or NSX-
V.

5. Install a Device Cerficate on the VM-
Series Firewall (for site licenses such as
Cortex Data Lake and Auto Focus).
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Create a Support Account
You need a support account to log in to the Customer Support Portal (CSP). You must log in to
acvate and manage Soware NGFW credits, access soware updates, or open a case with Palo
Alto Networks technical support. Your support account allows you to view and manage all assets—
appliances, licenses, and subscripons—that you have registered with Palo Alto Networks.

For all licensing opons, except for usage-based licenses that are currently only available in AWS,
you require a support account so that you can download the soware package required to install
the VM-Series firewall.

If you have an exisng support account, you can download and install the VM-Series firewall
soware, then connue to Register the VM-Series Firewall.

STEP 1 | Go to hps://support.paloaltonetworks.com/UserAccount/PreRegister.

STEP 2 | Enter the corporate email address to associate with the support account.

STEP 3 | Choose one of the following opons and fill in the details in the user registraon form:

For a usage-based license in AWS

1. Click Register your Amazon Web Services VM-Series Instance.
2. On the AWS Management Console, find the AWS Instance ID, AWS Product Code, and

the AWS Zone in which you deployed the firewall.
3. Fill in the other details.

For all other licenses

1. Click Register device using Serial Number or Authorizaon Code.
2. Enter the capacity auth code and the sales order number or customer ID.
3. Fill in the other details.

STEP 4 | Submit the form. You will receive an email with a link to acvate your user account.

Complete the steps to acvate the account. Aer your account is verified and the registraon
is complete, you can log in to the support portal.
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Serial Number and CPU ID Format for the VM-Series
Firewall

When you launch an instance of the VM-Series firewall, each instance of the firewall is uniquely
idenfied using the CPU ID and serial number of the firewall. The CPU ID format and the serial
number include informaon on the hypervisor and the license type for each instance of the VM-
Series firewall.

• With the usage-based licensing model of the VM-Series firewalls, at launch the firewall
generates a serial number and CPU ID, and you use these details to Register the Usage-Based
Model of the VM-Series Firewall for Public Clouds (no auth code).

• With the BYOL model, you register a VM-Series Firewall fixed model or a VM-Series firewall
with a flexible license on the Customer Support portal (CSP).

• For a firewall with direct internet access, you can apply the auth code on the firewall to
generate a license file that includes the serial number.

• For a firewall that is offline, you must use the CSP to input the CPU ID, UUID, and the auth
code to generate a license file that includes the serial number. You can then install the
license on the firewall.

License
Type

Serial Number CPU ID

BYOL 15 digits, all numeric

Example: 0071 51 345678909

<Hypervisor>:<ActualCPUID>

Example: ESX:12345678

PAYG 15 digits, alphanumeric

Example: 4
DE0YTAYOGMYYTN

<Hypervisor>:<Instance-
ID>:<CloudProductCode>:<CloudRegion>

Example:

AWSMP:1234567890abcdef0:
6kxdw3bbmdeda
3o6i1ggqt4km:us-west1
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Licensing API
Use the licensing API to register auth codes, retrieve licenses aached to an auth code, renew
licenses, or deacvate all licenses on a VM-Series firewall. In addion, the licensing API enables
you to license firewalls that do not have direct internet access and cannot reach the Palo Alto
Networks license server. You can manage licenses manually or automate licensing with a custom
script or an orchestraon service.

You can also use the Panorama Soware Firewall License plugin for licensing tasks,
including offline licensing. The plugin requires Panorama 10.0.0 or later with VM-Series
plugin 2.0.4 or later, and your managed VM-Series firewalls must be running PAN-OS
9.1.0 or later and VM-Series plugin 2.0.4 or later; the VM-Series firewall for Azure requires
VM-Series plugin 2.0.8.

For model-based licenses, he API allows you to view the details of an auth code so that you can
track the number of unused licenses aached to an auth-code or auth-code bundle that enables
you to license more than one instance of the firewall. An auth-code bundle includes the VM-
Series model, subscripons and support in a single, easy to order format; you can use this bundle
mulple mes to license VM-Series firewalls as you deploy them.

To use the API, each support account is assigned a unique key. Each API call is a POST request,
and the request must include the API key to authencate the request to the licensing server.
When authencated, the licensing server sends the response in json format (content-type
applicaon/json).

• Manage the Licensing API Key
• Use the Licensing API
• Licensing API Error Codes
• Install a License API Key
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Manage the Licensing API Key
To get the API key required to use the licensing API, your account must have super user privileges
on the support portal. The same key is used to acvate and deacvate the license.

The expiraon date of the API key is the same date as that of the latest subscripon in your
support account. If you renew your current subscripons and need to reset the expiraon date
of the API key, you can either regenerate a key (and replace the exisng key with this new key
wherever you've used it) or contact Palo Alto Networks support for help with extending the term
of your exisng API key.

STEP 1 | Get your Licensing API key.
1. Log in to the Palo Alto Networks Support portal with an account that has super user

privileges.
2. Select Assets > API Key Management.
3. Click Enable to view your key and  copy it for use. Once you generate a key, the key is

enabled unl you regenerate or disable it.

STEP 2 | Regenerate or revoke the API key.
1. You can generate a new API key or revoke the use of the key.

• Click Regenerate to generate a new key. If you suspect that an API key may be
compromised, you can generate a new key. Regenerang automacally invalidates the
old key.

• Select Disable if you no longer plan to use the key. Disabling the API key revokes it.

Use the Licensing API
The base URI for accessing the licensing API is hps://api.paloaltonetworks.com/api/license;
based on the task you want to perform, for example acvate licenses, deacvate licenses, or track
license use—the URL will change.

An API request must use the HTTP POST method, and you must include the API key in the
apikey HTTP request header and pass the request parameters as URL-encoded form data with
content-type application/x-www-form-urlencoded.

The API Version is oponal and can include the following values—0 or 1. If specified, it must be
included in the version HTTP request header. The current API version is 1; if you do not specify
a version, or specify version 0, the request uses the current API version.

All API responses are represented in json.

Before you begin, get your Licensing API key and copy it to your local drive. This is required before
you can perform any of the following tasks:

• Acvate Licenses
• Deacvate Licenses
• Track License Usage

Acvate Licenses
Header: apikey
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Parameters: uuid, cpuid, authCode, memory, serialNumber, and vCPU

URL: https://api.paloaltonetworks.com/api/license/activate

The parameters uuid, cpuid, authCode, and serialNumber apply for all VM-Series licenses,
regardless of PAN-OS version.

The oponal parameters memory and vCPU only apply for Flexible vCPUs (PAN-OS 10.0.4 and
later).

• For the inial license acvaon, provide the parameters in the API request. For example:

curl -i -H
 "apikey:a103e3065360acc5e01666fb9335964fcfe668100666db6f3ff43d4544de0###" 
--data-urlencode cpuid=AWS:57060500FFFBE### 
--data-urlencode uuid=EC2278FF-F0CB-45E2-343B-E97984BAC### 
--data-urlencode authCode=D3521### 
--data-urlencode vcpu=4 
--data-urlencode memory=8388608 
https://api.paloaltonetworks.com/api/license/activate

• If you did not save the license keys or had network connecon issues during inial license
acvaon, you can retrieve the license(s) for a firewall that you have previously acvated.

In the API request, provide the cpuid and uuid, or, provide the serialNumber of the
firewall.

Sample request for inial license acvaon using Curl:

curl -i -H "apikey:$APIKEY" --data-urlencode cpuid=51060400FFFBAB1F
 --data-urlencode uuid=564D0E5F-3F22-5FAD-DA58-47352C6229FF --data-
urlencode authCode=I7115398 https://api.paloaltonetworks.com/api/
license/activate

Sample API response:

[{"lfidField":"13365773","partidField":"PAN-SVC-PREM-
VM-300","featureFi--eld":
"Premium","feature_descField":"24 x 7 phone support; advanced
 replacement hardware service","keyField":"m4iZEL1t3n6Oa
+6ll1L7itDZTphYw48N1AMOZXutDgExC5f5pOA52+Qg1jmAxanB
\nKOyat4FJI4k2hWiBYz9cONuKoiaNOtAGhJvAuZmYgqAZejKueWrTzCuLrwxI/iEw
\nkRGR3cYG+j6o84RitR937m2iOk2v9o8RSfLVilgX28nqmcO8LcAnTqbrRWdFtwVk
\nluz47AUMXauuqwpMipouQYjk0ZL7fTHHslhyL7yFjCyxBoYXOt3JiqQ0OCDdBdDI
\n91RkVPylEwTKgSXm3xpzbmC2ciUR5b235gyqdyW8eQXKvaThuR8YyHr1Pdw/lAjs
\npyyIVFa6FufPacfB2RHApQ==\n","auth_codeField":"","errmsgField":null,
"typeField":"SUP","regDateField":"2016-06-03T08:18:41","startDateField":"5/29/2016",
"vm_capacityField":null,"uuidField":null,"cpuidField":null,"mac_baseField":null,
"mac_countField":null,"drrField":null,"expirationField":"8/29/2016
 12:00:00 AM","PropertyChanged":null},
{"lfidField":"13365774","partidField":"PAN-VM-300-TP",
"featureField":"Threat Prevention","feature_descField":"Threat
 Prevention","keyField":"NqaXoaFG+9qj0t9Vu7FBMizDArj
+pmFaQEd6I2OqfBfAibXrvuoFKeXX/K2yXtrl\n2qJhNq3kwXBDxn181z3nrUOsQd/
eW68dyp4jb1MfAwEM8mlnCyLhDRM3EE+umS4b\ndZBRH5AQjPoaON7xZ46VMFovOR
+asOUJXTptS/Eu1bLAI7PBp3+nm04dYTF9O50O
\ndey1jmGoiBZ9wBkesvukg3dVZ7gxppDvz14+wekYEJqPfM0NZyxsC5dnoxg9pciF
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\ncFelhnTYlma1lXrCqjJcFdniHRwO0RE9CIKWe0g2HGo1uo2eq1XMxL9mE5t025im
\nblMnhL06smrCdtXmb4jjtg==\n","auth_codeField":"",
"errmsgField":null,"typeField":"SUB","regDateField":"2016-06-03T08:18:41",
"startDateField":"5/29/2016","vm_capacityField":null,"uuidField":null,
"cpuidField":null,"mac_baseField":null,"mac_countField":null,"drrField":null,
"expirationField":"8/29/2016 12:00:00 AM","PropertyChanged":null} 
...<truncated> 

The feature_Field in the response indicates the type of key that follows in the keyField.
Copy each key to a text file and save it with the .key extension. Because the key is in
json format, it does not have newlines. Make sure to convert it to newlines if your parser
requires them. Make sure to name each key appropriately and save it to the /license folder
of the bootstrap package. For example, include the authcode with the type of key to name
it as I3306691_1pa-vm.key (for the capacity license key), I3306691_1threat.key (for
the Threat Prevenon license key), I3306691_1wildfire.key (for the WildFire subscripon
license key).

Sample API request for retrieving previously acvated licenses using Curl:

curl -i -H "apikey:$APIKEY" --data-urlencode
 serialNumber=007200006142 https://api.paloaltonetworks.com/api/
license/activate 

Sample API response:

[{"lfidField":"13365773","partidField":"PAN-SVC-PREM-
VM-300","featureField":
"Premium","feature_descField":"24 x 7 phone support; advanced
 replacement hardware service","keyField":"m4iZEL1t3n6Oa
+6ll1L7itDZTphYw48N1AMOZXutDgExC5f5pOA52+Qg1jmAxanB
\nKOyat4FJI4k2hWiBYz9cONuKoiaNOtAGhJvAuZmYgqAZejKueWrTzCuLrwxI/iEw
\nkRGR3cYG+j6o84RitR937m2iOk2v9o8RSfLVilgX28nqmcO8LcAnTqbrRWdFtwVk
\nluz47AUMXauuqwpMipouQYjk0ZL7fTHHslhyL7yFjCyxBoYXOt3JiqQ0OCDdBdDI
\n91RkVPylEwTKgSXm3xpzbmC2ciUR5b235gyqdyW8eQXKvaThuR8YyHr1Pdw/lAjs
\npyyIVFa6FufPacfB2RHApQ==\n","auth_codeField":"","errmsgField":null,
"typeField":"SUP","regDateField":"2016-06-03T08:18:41","startDateField":"5/29/2016",
"vm_capacityField":null,"uuidField":null,"cpuidField":null,"mac_baseField":null,
"mac_countField":null,"drrField":null, "expirationField":"8/29/2016
 12:00:00 AM","PropertyChanged":null},
{"lfidField":"13365774","partidField":"PAN-VM-300-TP",
"featureField":"Threat Prevention","feature_descField":
"Threat Prevention","keyField":
"NqaXoaFG+9qj0t9Vu7FBMizDArj+pmFaQEd6I2OqfBfAibXrvuoFKeXX/K2yXtrl
\n2qJhNq3kwXBDxn181z3nrUOsQd/eW68dyp4jb1MfAwEM8mlnCyLhDRM3EE+umS4b
\ndZBRH5AQjPoaON7xZ46VMFovOR+asOUJXTptS/Eu1bLAI7PBp3+nm04dYTF9O50O
\ndey1jmGoiBZ9wBkesvukg3dVZ7gxppDvz14+wekYEJqPfM0NZyxsC5dnoxg9pciF
\ncFelhnTYlma1lXrCqjJcFdniHRwO0RE9CIKWe0g2HGo1uo2eq1XMxL9mE5t025im
\nblMnhL06smrCdtXmb4jjtg==
\n","auth_codeField":"","errmsgField":null,"typeField":"SUB",
"regDateField":"2016-06-03T08:18:41","startDateField":"5/29/2016","vm_capacityField"
:null,"uuidField":null,"cpuidField":null,"mac_baseField":null,
"mac_countField":null,"drrField":null,"expirationField":"8/29/2016
 12:00:00 AM","PropertyChanged":null}
...<truncated>
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Deacvate Licenses
URL: https://api.paloaltonetworks.com/api/license/deactivate

Parameters: encryptedToken

To deacvate the license(s) on a firewall that does not have direct internet access, you must
generate the license token file locally on the firewall and then use this token file in the API
request. For details on generang the license token file, see Deacvate VM, or Deacvate License
(Soware NGFW Credits) and Deacvate a Feature License or Subscripon Using the CLI.

Header: apikey

Request: hps://api.paloaltonetworks.com/api/license/deacvate?encryptedtoken@<token>

Sample API request for license deacvaon using Curl:

curl -i -H "apikey:$APIKEY" --data-urlencode
 encryptedtoken@dact_lic.05022016.100036.tok https://
api.paloaltonetworks.com/api/license/deactivate 

Sample API response:

[{"serialNumField":"007200006150","featureNameField":"","issueDateField":"",
"successField":"Y","errorField":null,"isBundleField":null,"PropertyChanged":null},
{"serialNumField":"007200006150","featureNameField":"","issueDateField":"",
"successField":"Y","errorField":null,"isBundleField":null,"PropertyChanged":null},
{"serialNumField":"007200006150","featureNameField":"","issueDateField":"",
"successField":"Y","errorField":null,"isBundleField":null,"PropertyChanged":null},
{"serialNumField":"007200006150","featureNameField":"","issueDateField":"",
"successField":"Y","errorField":null,"isBundleField":null,"PropertyChanged":null},
{"serialNumField":"007200006150","featureNameField":"","issueDateField":"",
"successField":"Y","errorField":null,"isBundleField":null,"PropertyChanged":null},
{"serialNumField":"007200006150","featureNameField":"","issueDateField":"",
"successField":"Y","errorField":null,"isBundleField":null,
"PropertyChanged":null}]$ 

Track License Usage
URL: https://api.paloaltonetworks.com/api/license/get

Parameters: authCode

Header: apikey

Request: hps://api.paloaltonetworks.com/api/license/get?authCode=<authcode>

Sample API request for tracking license usage using Curl:

curl -i -H "apikey:$APIKEY" --data-urlencode authcode=I9875031
 https://api.paloaltonetworks.com/api/license/get

Sample API response:

HTTP/1.1 200 OK 
Date: Thu, 05 May 2016 20:07:16 GMT 
Content-Length: 182 
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{"AuthCode":"I9875031","UsedCount":4,"TotalVMCount":10,"UsedDeviceDetails":
[{"UUID":"420006BD-113D-081B-F500-2E7811BE80C 
9","CPUID":"D7060200FFFBAB1F","SerialNumber":"007200006142"}]}..... 

Licensing API Error Codes
The HTTP Error Codes that the licensing server returns are as follows:

• 200 Success
• 400 Error
• 401 Invalid API Key
• 500 Server Error
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Install a License API Key
The license API key can be used to acvate, change, or deacvate a license. This procedure applies
for a VM-Series firewall or Panorama deployment.

You must have Super User privileges to retrieve the license API key from the Customer Support
Portal and use the CLI to install the key on the firewall or Panorama.

On Panorama, when you install a license API key Panorama pushes the API key to its managed
devices. If the managed device has an API key installed, Panorama overwrites the old API key with
the new one.

STEP 1 | Retrieve the license API key from the Customer Support Portal.
1. Log in to the Customer Support Portal.
2. Select Assets > Licensing API.
3. Copy the API key.

STEP 2 | Use the CLI to install the API key copied in the previous step. Paste the key into the request:

request license api-key set key <key>

STEP 3 | (oponal) To replace a license deacvaon API key, use the following CLI command to delete
an installed API key.

request license api-key delete

If you delete the API key you must install another license deacvaon key before you can
deacvate licenses.
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Use Panorama-Based Soware Firewall License
Management

The Panorama Soware Firewall License plugin allows you to automacally license a VM-Series
firewall when it connects to Panorama. If your VM-Series firewalls are located in the perimeter
of your deployment and do not have connecvity to the Palo Alto Networks licensing server, the
Soware Firewall License plugin simplifies the license acvaon process by using Panorama to
license the VM-Series firewall.

Addionally, the Soware Firewall License plugin simplifies the license acvaon and deacvaon
of VM-Series firewalls in environments that use auto-scaling and automaon to deploy and delete
firewalls to address changes in the cloud.

Pay-as-you-go (PAYG) licenses are not supported for use with this plugin.

Do not use the Soware Firewall License plugin to license the VM-Series firewall for
VMware NSX. The Panorama plugin for VMware NSX automacally licenses VM-Series
firewalls deployed in NSX and NSX-T

.

Also, do not use this plugin to license firewalls deployed in device groups that include
instances of the VM-Series firewall deployed in NSX-T.

To install the Panorama Soware Firewall License plugin, you must be using Panorama 10.0.0 or
later and VM-Series plugin 2.0.4 or later. Your VM-Series firewalls must be running PAN-OS 9.1.0
or later.

The VM-Series firewall for Azure requires VM-Series plugin 2.0.7 or later.

If you have a standalone Panorama or two Panorama appliances installed in an HA pair with
mulple plugins installed, plugins might not receive updated IP-tag informaon if one or more of
the plugins is not configured. This occurs because Panorama will not forward IP-tag informaon
to unconfigured plugins. Addionally, this issue can occur if one or more of the Panorama plugins
is not in the Registered or Success state (posive state differs on each plugin). Ensure that your
plugins are in the posive state before connuing or execung the commands described below.

If you encounter this issue, there are two workarounds:

• Uninstall the unconfigured plugin or plugins. It is recommended that you do not install a plugin
that you do not plan to configure right away

• You can use the following commands to work around this issue. Execute the following
command for each unconfigured plugin on each Panorama instance to prevent Panorama from
waing to send updates. If you do not, your firewalls may lose some IP-tag informaon.

request plugins dau plugin-name <plugin-name> unblock-device-push yes

You can cancel this command by execung:

request plugins dau plugin-name <plugin-name> unblock-device-push no
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The commands described are not persistent across reboots and must be used again for any
subsequent reboots. For Panorama in HA pair, the commands must be executed on each
Panorama.

STEP 1 | Install the Soware Firewall License Plugin for Panorama.
1. Log in to the Panorama web interface.
2. Select Panorama > Plugins.
3. Click Check Now to get the list of available plugins.
4. Search for sw_fw_license to locate the plugin.
5. Select Download and Install the Soware Licensing plugin.

Aer you successfully install, Panorama refreshes and the Soware Licensing plugin displays
on the Panorama tab.
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STEP 2 | Configure a Bootstrap Definion.
1. Select Panorama > SW Firewall License > Bootstrap Definions.
2. Click Add.
3. Enter a descripve Name to idenfy the Bootstrap Definion.
4. (Oponal) Enter a Descripon of the Bootstrap Definion.
5. Enter the Auth Code that Panorama will use to license the VM-Series firewall when it

connects to Panorama.
6. Click OK.

STEP 3 | Configure a License Manager.
1. Select Panorama > SW Firewall License > License Managers.
2. Click Add.
3. Enter a descripve Name to idenfy the License Manager.
4. (Oponal) Enter a Descripon of the License Manager.
5. Select a Device Group from the drop-down. When a VM-Series firewall bootstrapped

using the license manager connects to Panorama, it is placed in the specified device
group.

6. Select a Template Stack from the drop-down. When a VM-Series firewall bootstrapped
using the license manager connects to Panorama, it is placed in the specified template
Stack.

7. In the Auto Deacvate field, specify the amount of me, in hours, that Panorama
waits before deacvang the license of a disconnected VM-Series firewall. When you
select Never, Panorama does not deacvate a disconnected VM-Series firewall. Auto
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Deacvate is set to Never by default. You can set the deacvaon me, in hours, from
one to 24.

When a Auto Deacvate interval, the plugin might deacvate the license of
stopped VM-Series firewalls that are managed by the same license manager of
firewalls that deacvate as expected.

8. Select a Bootstrap Definion from the drop-down. The selected bootstrap definion
specifies the auth code used by Panorama to license the VM-Series firewalls associated
with the license manager.

9. Click OK.
10. Commit your changes.

STEP 4 | (Oponal) Create an init-cfg.txt file for bootstrap the VM-Series firewall. Aer
configuring a license manager, you can copy and paste bootstrap parameters generated
by Panorama when deploy your VM-Series firewalls. Depending on your deployment, the
parameters displayed might be a subset of those shown in the image below. For example,
if your Panorama appliance is deployed in a public cloud, the bootstrap parameters will
not include the public IP address for Panorama. In that case, you must manually enter the
public IP address in the init-cfg.txt file. Panorama will always generate the auth-key
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and plugin-op-commands=panorama-licensing-mode-on for use in your init-
cfg.txt.

The auth key displayed here is generated by Panorama and used to authencate the VM-Series
firewall connecon to Panorama. Addionally, this auth key is used instead of the VM auth key
that you might generate on Panorama and add to your init-cfg.txt file.

If you use the auth key displayed here in your init-cfg.txt file, do not use a manually
generated VM auth key.

1. Select Panorama > SW Firewall License > License Managers.
2. In the Acon column of a given license manager, click Show Bootstrap Parameters.
3. Copy the displayed informaon and paste it into a text editor to create an init-

cfg.txt file for bootstrapping.
4. Click Close when finished.

STEP 5 | (Oponal) View and deacvate a managed VM-Series firewall. From the Show Devices
dialogue, you can view the devices associated with a given license manager. You can view
the name, serial number, management IP address, connecon status, and amount of me
Panorama waits to deacvate a disconnected firewall. Addionally, you can manually
deacvate the license of managed VM-Series firewall.
1. Select Panorama > SW Firewall License > License Managers.
2. In the Acon column of a given license manager, click Show Devices.
3. To manually deacvate a connected or disconnected (but not yet deacvated) managed

VM-Series firewall, select a one or more listed VM-Series firewalls and click Deacvate.
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STEP 6 | (Oponal) Verify that Panorama has completed the necessary API calls to license connected
firewalls.
1. Log in to the Panorama command line interface.
2. Execute the following command.

show plugins sw_fw_license panorama-api-requests
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Soware NGFW Credits
Soware NGFW credits can be used to fund Soware NGFWs (VM-Series and CN-Series), Cloud-
Delivered Security Services (CDSS), or virtual Panorama appliances in networks with or without
internet access (air-gapped networks, for example).

Use Soware NGFW Credit Esmator to calculate the number of credits required for your
deployment. The Credit Esmator allows you esmate the credits required to license the firewalls
and enable the security services needed to secure your deployment.

You create a deployment profile to configure one or more firewalls based on PAN-OS version,
the number of vCPUs per firewall, the total number of firewalls supported by the deployment
profile, Panorama management or log collecon, and security services. All the VMs created with a
deployment profile share the same authcode.

• Fixed vCPUs—Compable with all PAN-OS versions. Based on VM-Series Models and security
service bundles. Changing the model or service opons requires a new license.

• Flexible vCPUs—Available on PAN-OS 10.0.4 and later. Select a flexible number of vCPUs,
and a flexible selecon of security services. You can modify the deployment profile to add or
decrease the number of vCPUs, add new services as they become available, or remove services.
The maximum number of vCPUs for a deployment profile is 32.

Soware NGFW credits are term-based. Terms can be defined for any amount of me between 1
and 5 years. Both allocated and unallocated credits expire at the end of the agreed upon term. You
can purchase addional credits for a credit pool but the expiraon date must be the same as the
target pool.

If you have an internet connecon to the license server and you stop using a firewall, a security
service, or Panorama deployment, the credits allocated to that resource are refunded to the credit
pool and can be reallocated to a new resource.

If you do not have an internet connecon and cannot connect to the Palo Alto Networks update
server (for example, you are in an air-gapped network) you can manage the VM-Series firewall
locally from its user interface, or from Panorama. Your administrator must then log in to the
Customer Support Portal to return the license token so the funds can be reused.

Use the Supported Hypervisor table below and the Total vCPUs on Dataplane tables that follow
to ensure that you allocate the necessary hardware resources for your chosen number of vCPUs.

Memory Profile Supported Hypervisors Minimum Hard
Drive

4.5GB, 5.5GB ESXi, Hyper-V, KVM 32GB (60GB at
boot)

6.5GB AWS, Azure, ESXi, Google Cloud Plaorm, Hyper-V, KVM,
OCI, Alibaba Cloud, Cisco ACI, Cisco CSP, Cisco ENCS,
NSX-T

60GB
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Memory Profile Supported Hypervisors Minimum Hard
Drive

9GB AWS, Azure, ESXi, Google Cloud Plaorm, Hyper-V, KVM,
OCI, Alibaba Cloud, Cisco ACI, Cisco CSP, Cisco ENCS,
NSX-T

60GB

16GB AWS, Azure, ESXi, Google Cloud Plaorm, Hyper-V, KVM,
OCI, Alibaba Cloud, Cisco ACI, Cisco CSP, NSX-T

60GB

56GB AWS, Azure, ESXi, Google Cloud Plaorm, Hyper-V, KVM,
OCI, Alibaba Cloud, Cisco ACI, Cisco CSP, NSX-T

60GB

For all memory profiles listed above, the minimum vCPUs is 2. You can enable Lite mode if you
choose 4.5GB. Lite mode is an alternave operang mode for environments where resources are
limited. See VM-50 Lite Mode for more informaon.

Lite mode requires minimum 32GB of hard drive space. However, because the VM-Series
base image is common for all vCPU combinaons, you must allocate 60GB of hard drive
space unl you license a VM-Series firewall with 4.5GB memory.

To achieve the best performance, all of the required cores should be available on a single
CPU socket.

The distribuon of vCPUs assigned to the management plane and the dataplane differs depending
on the total number of vCPUs assigned to the VM-Series firewall. Refer to the following tables
(1-16 vCPUs and 17-32 vCPUs) to find out the number of dataplane vCPUs automacally
allocated for a parcular combinaon of memory profile and total vCPUs. For example, with
a memory profile of 16GB and a total of 15 vCPUs, 11 are assigned to the dataplane and the
remaining 4 are assigned to the management plane.

Total vCPUs on Dataplane (1-16)Memory
Profile 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16

4.5GB 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1

5.5GB 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1

6.5GB 1 2 2 2 2 2 2 2 2 2 2 2 2 2 2

9GB 1 2 3 3 4 4 4 4 4 4 4 4 4 4 4

16GB 1 2 3 3 4 5 6 6 7 8 9 9 10 11 12

56GB 1 2 3 3 4 5 6 6 7 8 9 9 10 11 12
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Total vCPUs on Dataplane (17-32)Memory Profile
17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32

4.5GB 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1

5.5GB 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1 1

6.5GB 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2 2

9GB 4 4 4 4 4 4 4 4 4 4 4 4 4 4 4 4

16GB 12 12 12 12 12 12 12 12 12 12 12 12 12 12 12 12

56GB 12 13 14 15 15 16 17 18 18 19 20 21 21 22 23 24

Connue to Soware NGFW tasks:

• Maximum Limits Based on Memory
• Acvate Credits
• Create a Deployment Profile
• Manage a Deployment Profile
• Register the VM-Series Firewall (Soware NGFW Credits)
• Provision Panorama
• Migrate Panorama to a Soware NGFW License
• Transfer Credits
• Renew Your Soware NGFW Credit License
• Deacvate License (Soware NGFW Credits)
• Create and Apply a Subscripon-Only Auth Code
• Customize Dataplane Cores
• Limit Licensed vCPUs
• Migrate a Firewall to a Flexible VM-Series License

Maximum Limits Based on Memory
The following tables provide the maximum number for a parcular object or resource that a single
VM-Series firewall deployment can create, store, manage, or interact with on a firewall configured
with 4.5, 5.5, 6.5, 9, 16, or 56 GB memory. These limits apply to flexible licenses for VM-Series
firewalls running PAN-OS 10.0.4 or later.

The memory profile and the total number of vCPUs determine how many cores are automacally
assigned to the management plane and the dataplane. If you are running PAN-OS version 10.0.1
or later, you have the opon to customize the distribuon of the dataplane cores.

If you are using SW NGFW licensing you can choose a memory profile that supports your
requirements for one or more of the following resources:
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• Address Assignment
• App-ID
• EDL
• GlobalProtect Client VPN
• GlobalProtect Clientless

VPN
• High Availability

• Interfaces
• IPSec VPN
• L2 Forwarding
• Mulcast
• NAT
• Objects

(addresses and
services)

• Policies
• QoS
• Roung
• Security

Profiles
• Security Zones
• Sessions

• SSL
Decrypon

• URL Filtering
• User-ID
• Virtual Routers
• Virtual

Systems
• Virtual Wires

Sessions

Feature 4.5 GB 5.5 GB 6.5 GB 9 GB 16 GB 56 GB

Max sessions (IPv4 or
IPv6)

50,000 64,000 250,000 819,200 2,000,000 10,000,000

Policies

Feature 4.5 GB 5.5 GB 6.5 GB 9 GB 16 GB 56 GB

Security rules 200 250 1,500 10,000 10,000 20,000

Security rule schedules 256 256 256 256 256 256

NAT rules 400 400 3,000 5,000 8,000 15,000

Decrypon rules 100 100 1,000 1,000 1,000 2,000

App override rules 100 100 1,000 1,000 1,000 2,000

Tunnel content inspecon rules 100 100 100 500 500 2,000

SD-WAN rules NA 100 100 100 300 300

Policy based forwarding rules 100 100 100 500 500 2,000

Capve portal rules 10 10 1,000 1,000 1,000 2,000

DoS protecon rules 100 100 1,000 1,000 1,000 1,000
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Security Zones

Feature 4.5 GB 5.5 GB 6.5 GB 9 GB 16 GB 56 GB

Max security zones 15 15 40 40 200 200

Objects (addresses and services)

Feature 4.5 GB 5.5 GB 6.5 GB 9 GB 16 GB 56 GB

Address objects 2,000 2,500 10,000 10,000 20,000 40,000

Address groups 100 125 1,000 1,000 2,500 4,000

Members per address group 2,500 2,500 2,500 2,500 2,500 2,500

Service objects 1,000 1,000 2,000 2,000 2,000 5,000

Service groups 250 250 500 500 250 500

Members per service group 500 500 500 500 500 500

FQDN address objects 2,000 2,000 2,000 2,000 2,000 2,000

Max DAG IP addresses*

(system wide capacity)

1,000 1,000 2,500 200,000 300,000 300,500

Tags per IP address 32 32 32 32 32 32

* Firewall throughput measured with App-ID and User-ID features enabled ulizing AppMix
transacons.

Security Profiles

Feature 4.5 GB 5.5 GB 6.5 GB 9 GB 16 GB 56 GB

Security Profiles 38 38 375 375 750 750

App-ID

Feature 4.5 GB 5.5 GB 6.5 GB 9 GB 16 GB 56 GB

Custom App-ID signatures 6,000 6,000 6,000 6,000 6,000 6,000

Shared custom App-IDs 512 512 512 512 512 512
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Feature 4.5 GB 5.5 GB 6.5 GB 9 GB 16 GB 56 GB

Custom App-IDs

(virtual system specific)

3,208 1,000 6,416 1,000 6,416 6,416

User-ID

Feature 4.5 GB 5.5 GB 6.5 GB 9 GB 16 GB 56 GB

IP-User mappings
(management plane)

524,288 524,288 524,288 524,288 524,288 524,288

IP-User mappings (data plane) 64,000 64,000 64,000 64,000 512,000 512,000

Acve and unique groups used
in policy (aggregate of LDAP
groups, XML API Groups, and
Dynamic User Group).*

1,000 1,000 1,000 1,000 10,000 10,000

Number of User-ID agents 100 100 100 100 100 100

Monitored servers for User-ID 100 100 100 100 100 100

Terminal server agents 400 400 400 400 2,000 2,500

Tags per User*

(PAN-OS 9.1 and later)

32 32 32 32 32 32

*Firewall throughput measured with App-ID and User-ID features enabled ulizing AppMix
transacons.

SSL Decrypon

Feature 4.5 GB 5.5 GB 6.5 GB 9 GB 16 GB 56 GB

Max SSL inbound cerficates 1,000 1,000 1,000 1,000 1,000 1,000

SSL cerficate cache

(forward proxy)

128 128 128 2,000 4,000 8,000

Max concurrent decrypon
sessions

1,024 1,024 6,400 15,000 50,000 100,000

SSL Port Mirror Yes Yes Yes Yes Yes Yes

SSL Decrypon Broker No No No Yes No Yes
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Feature 4.5 GB 5.5 GB 6.5 GB 9 GB 16 GB 56 GB

HSM Supported Yes Yes Yes Yes Yes Yes

URL Filtering

Feature 4.5 GB 5.5 GB 6.5 GB 9 GB 16 GB 56 GB

Total entries for allow
list, block list and custom
categories

25,000 25,000 25,000 25,000 25,000 100,000

Max custom categories 2,849 2,849 2,849 2,849 2,849 2,849

Max custom categories (virtual
system specific)

500 500 500 500 500 500

Dataplane cache size for URL
filtering

90,000 90,000 90,000 90,000 90,000 250,000

Management plane dynamic
cache size

100,000 100,000 100,000 100,000 100,000 600,000

EDL

Feature 4.5 GB 5.5 GB 6.5 GB 9 GB 16 GB 56 GB

Max number of custom lists 30 30 30 30 30 30

Max number of IPs per system 50,000 50,000 50,000 50,000 50,000 50,000

Max number of DNS Domains
per system

50,000 50,000 50,000 5000,000 2,000,000 2,000,00

Max number of URL per
system

50,000 50,000 50,000 100,000 100,000 100,000

Shortest check interval (min) 5 5 5 5 5 5

Interfaces

Feature 4.5 GB 5.5 GB 6.5 GB 9 GB 16 GB 56 GB

Mgmt - out-of-band NA NA NA NA NA NA
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Feature 4.5 GB 5.5 GB 6.5 GB 9 GB 16 GB 56 GB

Mgmt - 10/100/1000 high
availability

NA NA NA NA NA NA

Mgmt - 40Gbps high availability NA NA NA NA NA NA

Mgmt - 10Gbps high availability NA NA NA NA NA NA

Traffic - 10/100/1000 NA NA NA NA NA NA

Traffic - 100/1000/10000 NA NA NA NA NA NA

Traffic - 1Gbps SFP NA NA NA NA NA NA

Traffic - 10Gbps SFP+ NA NA NA NA NA NA

Traffic - 40/100Gbps QSFP+/
QSFP28

NA NA NA NA NA NA

802.1q tags per device 4,094 4,094 4,094 4,094 4,094 4,094

802.1q tags per physical interface 4,094 4,094 4,094 4,094 4,094 4,094

Max interfaces (logical and physical) 512 512 2,048 2,048 4,096 40,96

Maximum aggregate interfaces NA NA NA NA NA NA

Maximum SD-WAN virtual
interfaces

NA 150 300 500 1,000 1,000

Virtual Routers

Feature 4.5 GB 5.5 GB 6.5 GB 9 GB 16 GB 56 GB

Virtual routers 3 3 3 10 20 125

Virtual Wires

Feature 4.5 GB 5.5 GB 6.5 GB 9 GB 16 GB 56 GB

Virtual wires 2 4 12 12 12 12
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Virtual Systems

Feature 4.5 GB 5.5 GB 6.5 GB 9 GB 16 GB 56 GB

Base virtual systems 1 1 1 1 1 1

Max virtual systems

Addional licenses are required for
virtual system capacies above the
base virtual system’s capacity

NA NA NA NA NA NA

Roung

Feature 4.5 GB 5.5 GB 6.5 GB 9 GB 16 GB 56 GB

IPv4 forwarding table size*

(Entries shared across virtual
routers)

1,000 2,500 5,000 10,000 32,000 100,000

IPv6 forwarding table size*

(Entries shared across virtual
routers)

1,000 1,000 5,000 10,000 32,000 100,000

System total forwarding table size 1,000 1,000 5,000 10,000 32,000 100,000

32,000 50 50 50 50 50 50

Max roung peers (protocol
dependent)

500 500 500 500 1,000 1,000

Stac entries - DNS proxy 1,024 1,024 1,024 1,024 1,024 1,024

Bidireconal Forwarding Detecon
(BFD) Sessions

N/A N/A 128 512 1,024 1,024

*Firewall throughput measured with App-ID and User-ID features enabled ulizing AppMix
transacons.

L2 Forwarding

Feature 4.5 GB 5.5 GB 6.5 GB 9 GB 16 GB 56 GB

ARP table size per device 1,500 1,500 2,500 10,000 32,000 128,000

IPv6 neighbor table size 500 500 2,500 10,000 32,000 128,000
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Feature 4.5 GB 5.5 GB 6.5 GB 9 GB 16 GB 56 GB

MAC table size per device 1,500 1,500 2,500 5,000 32,000 128,000

Max ARP entries per broadcast
domain

1,500 1,500 2,500 10,000 32,000 128,000

Max MAC entries per broadcast
domain

1,500 1,500 2,500 5,000 32,000 128,000

NAT

Feature 4.5 GB 5.5 GB 6.5 GB 9 GB 16 GB 56 GB

Total NAT rule capacity 160 400 3,000 5,000 8,000 8,000

Max NAT rules (stac)*

(Configuring stac NAT rules
to full capacity requires that no
other NAT rule types are used.)

160 400 3,000 5,000 8,000 8,000

Max NAT rules (DIP)*

(Configuring DIP NAT rules to
full capacity requires that no
other NAT rule types are used.)

160 400 2,000 3,000 8,000 8,000

Max NAT rules (DIPP) 160 200 400 800 2,000 2,000

Max translated IPs (DIP) 16,000 16,000 128,000 128,000 160,000 160,000

Max translated IPs (DIPP)*

(DIPP translated IP capacity is
proporonal to the DIPP pool
oversubscripon value. The
capacity shown here is based on
an oversubscripon value of 1x.)

200 200 400 800 2,000 2,000

Default DIPP pool
oversubscripon*

(Source IP and source port reuse
across concurrent sessions)

2 2 2 2 8 8

*Firewall throughput measured with App-ID and User-ID features enabled ulizing AppMix
transacons.
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Address Assignment

Feature 4.5 GB 5.5 GB 6.5 GB 9 GB 16 GB 56 GB

DHCP servers 3 3 3 10 20 125

DHCP relays*

(Maximum capacity represents total
DHCP servers and DHCP relays
combined)

500 500 500 500 500 500

Max number of assigned addresses 64,000 64,000 64,000 64,000 64,000 64,000

*Firewall throughput measured with App-ID and User-ID features enabled ulizing AppMix
transacons.

High Availability

Feature 4.5 GB 5.5 GB 6.5 GB 9 GB 16 GB 56 GB

Devices supported 2 2 2 2 2 2

Max virtual addresses 32 32 128 32 32 128

QoS

Feature 4.5 GB 5.5 GB 6.5 GB 9 GB 16 GB 56 GB

Number of QoS policies 100 100 500 1,000 2,000 4,000

Physical interfaces supporng QoS 6 6 6 6 12 12

Clear text nodes per physical
interface

31 31 31 63 63 63

DSCP marking by policy Yes Yes Yes Yes Yes Yes

Subinterfaces supported NA NA NA NA NA NA

IPSec VPN

Feature 4.5 GB 5.5 GB 6.5 GB 9 GB 16 GB 56 GB

Max IKE Peers 25 250 1,000 1,000 1,000 2,000
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Feature 4.5 GB 5.5 GB 6.5 GB 9 GB 16 GB 56 GB

Site to site (with proxy id) 25 250 1,000 2,000 4,000 8,000

SD-WAN IPSec tunnels NA 250 1,000 1,000 1,000 2,000

GlobalProtect Client VPN

Feature 4.5 GB 5.5 GB 6.5 GB 9 GB 16 GB 56 GB

Max tunnels (SSL, IPSec, and IKE
with XAUTH)

25 250 500 2,000 6,000 12,000

GlobalProtect Clientless VPN

Feature 4.5 GB 5.5 GB 6.5 GB 9 GB 16 GB 56 GB

Max SSL tunnels 40 40 100 400 1,200 2,500

Mulcast

Feature 4.5 GB 5.5 GB 6.5 GB 9 GB 16 GB 56 GB

Replicaon (egress interfaces) 100 100 100 100 100 100

Routes 500 500 2,000 2,000 4,000 4,000

Acvate Credits
Within your organizaon you can create many accounts, each with a different purpose. During
acvaon you can choose only one account per default credit pool. Once you the credit pool is
acve, users granted the credit administrator role can allocate the credits for deployments, and
even transfer credits to other pools.

If you have an exisng CSP account and are a superuser or an admin, the system automacally
adds the credit admin role to your profile. If you do not have an exisng account, the CSP
automacally creates an account for you and adds the credit admin role to your profile.

You (the purchaser) receive an email detailing the subscripon, the credit pool ID, the subscripon
start and end date, the amount of credits purchased, and the descripon of the default credit pool
(see “default credit pools” in VM-Series Firewall Licensing).

Secure this email for future reference.

STEP 1 | In the email, click Start Acvaon to view your available credit pools.

VM-Series Deployment Guide Version Version 10.1 87 ©2022 Palo Alto Networks, Inc.



License the VM-Series Firewall

STEP 2 | Select the credit pool you want to acvate. You can use the search field to filter your account
list by number or name.

If you have purchased mulple credit pools (see Soware NGFW Credits), they are
automacally selected. The check marks represent acvaon links for onboarding credits.

You are prompted to authencate or sign in.

If you deselect a credit pool, you see a reminder that if you want to acvate those
credits, you must return to the email and click the Start Acvaon link.

STEP 3 | Select Start Acvaon.

STEP 4 | Select the support account (you can search by account number or name).

STEP 5 | Select the default credit pool.

STEP 6 | Select Deposit Credits.

You see a message that the deposit was successful.

STEP 7 | (oponal) If this is your first credit acvaon, you see the Create Deployment Profile dialog.

Connue to Create a Deployment Profile.

Create a Deployment Profile
To create a deployment profile, you must have a Customer Support Portal account (CSP) and
access to an acvated credit pool.

Before you begin, esmate the number of firewalls that will use the configuraon in the
deployment profile. You don’t have to deploy all the firewalls at once.

STEP 1 | If you already have a credit pool, log into the account, and from the dashboard, select Assets
> Soware NGFW Credits > Create Deployment Profile.

If you have just acvated a credit pool you see the Create Deployment Profile form.

1. Select the VM-Series firewall type.
2. Select the PAN-OS version.

• Fixed Models (VM-Series Models)
• Flexible vCPUs (PAN-OS 10.0.4 and above)

3. Click Next.
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STEP 2 | VM-Series profile.
1. Profile Name.

Name the profile.
2. Number of Firewalls.

Enter the number of firewalls this profile deploys, assuming you have sufficient credits.
You do not have to deploy them all at once.

3. Firewall Model:

Choose a VM-Series model.

Planned vCPU/Firewall (PAN-OS 10.0.4 or above).

Enter the number of vCPUs per firewall.

Security Use Case:  Choose a use case.
4. Customize Subscripons.

Aer selecng a use case, you can add or remove security services.
5. (oponal) Use Credits to Enable VM Panorama.

Choose the Panorama use case(s)—Management and/or Log Collector.

STEP 3 | (oponal) Hover over the queson mark following Protect more, save more to see how your
credit allocaon affects savings.

STEP 4 | Click Calculate Esmated Cost to view the credit total, and the number of credits available
before the deployment.

(oponal) Hover over the queson mark following the esmate to view the credit breakdown
for each component.

STEP 5 | Create the Deployment Profile.

You might have to wait several seconds for the profile to appear in the Current Deployment
Profiles tab list. Before the allocaon is complete, the Credits Consumed/Allocated column
shows 0 and Update Pending.Scroll to the boom and go to the last page to find your profile.

To view your deployment profile later on, click the Details buon on the parent credit pool and
select Current Deployment Profiles.

• Note the Auth Code for your profile on the far right; Soware NGFW credit auth codes
start with D.

• The Credits Consumed/Allocated column shows 0 and Update Pending before the
allocaon is complete.

• The Audit Trail tab shows Credit Transacons and the Deployment Profiles you manage.
You can also search for a profile by me in this tab.

Use search to locate your profile, and expand the row to view the configuraon you
specified when you created the profile.

Manage a Deployment Profile
Aer you create your deployment profile you can edit, copy, or delete it.
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• Edit a Deployment Profile
• Clone a Deployment Profile
• Delete a Deployment Profile

Edit a Deployment Profile
STEP 1 | Select Assets > Soware NGFW Credits and click the Details buon on the credit pool you

used to create your profile.

STEP 2 | Select the Current Deployment Profiles tab.

STEP 3 | On the far right, select the vercal ellipsis (More Opons) and select Edit Profile.

STEP 4 | Make your changes and select Update Deployment Profile.

STEP 5 | Select the Audit Trail tab and use search to locate your profile.

Use search to locate your profile, and expand the row to view the configuraon you specified
when you created the profile.

Clone a Deployment Profile
STEP 1 | Select Assets > Soware NGFW Credits and click the Details buon on the credit pool you

used to create your profile.

STEP 2 | On the far right, select the vercal ellipsis (More Opons) and select Clone Profile.

STEP 3 | Change the profile name, make any other changes, and select Create Deployment Profile.

STEP 4 | Select the Audit Trail tab and use search to locate your profile.

Expand the row to view the configuraon you cloned. It is a new configuraon with a different
Profile Name and auth code.

Delete a Deployment Profile
Before deleng a deployment profile, you must Deacvate License (Soware NGFW Credits) on
any firewall using the deployment profile and then deacvate the VM.

STEP 1 | Select Assets > Soware NGFW Credits and click the Details buon on the credit pool you
used to create your profile.

STEP 2 | On the far right, select the vercal ellipsis (More Opons) and select Delete.

Register the VM-Series Firewall (Soware NGFW Credits)
Registraon requires access to the Palo Alto Networks customer support portal (the CSP) and a
support account. Create one if necessary.

During acvaon, an administrator acvates a credit pool and the credits are deposited. When
anyone creates a deployment profile, an auth code is created. Complete one of the following
procedures to iniate registraon.

• Device can access CSP
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• Device cannot access the CSP

Use the following steps if the firewall is able to connect to the CSP:
1. Log in to the CSP with your account credenals.
2. Select Assets > Soware NFGW Credits.

Locate your credit pool and view Details.
3. View Current Deployment Profiles and choose (or create) a profile.

You will use the auth code from this profile for licensing any firewall you create with it.
An auth code for a flexible firewall license begins with the leer D.

4. Log in to the VM-Series firewall web interface.
5. Verify the Palo Alto Networks update server configuraon.

1. Select Device > Setup > Services.
2. Confirm that Update Server is set to updates.paloaltonetworks.com.
3. Confirm that Verify Update Server Identy is selected.

6. Select Device > Licenses.

1. Select the Acvate feature using authorizaon code link.
2. Enter the VM-Series authorizaon code from the deployment profile.
3. Click OK to confirm the license upgrade.The firewall contacts the Palo Alto Networks

update server and consumes the tokens required for your firewall based on the VM-
Series model.

7. Confirm that the Dashboard displays a valid serial number and that the PA-VM license
displays in the Device > Licenses tab.

8. Verify your firewall is registered on the CSP:

• Select Assets > Soware NFGW Credits
• Auth Code column, View Devices and locate the serial number for your deployment.
• In the credit pool, Credits Consumed, Firewalls Deployed, and vCPUs consumed

should be incremented to reflect your deployment.
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Use the following steps if the firewall is not able to connect to the CSP:

This workflow adds your firewall to the support database. Because the firewall can’t connect to
the license server, you must manually pass the licenses from the CSP to the firewall.

1. Log in to the CSP with your account credenals.
2. Select the new profile and Select the vercal ellipsis (More Opons) and Register

Firewall.

This opens the device registraon form. Enter the informaon for your firewall and
Submit:
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This associates the firewall with the profile and its authcode and assigns a serial number.
3. Click View Devices to see associated firewalls in Soware NGFW Devices.

In the License column, download each license key to a locaon from which you can
safely transfer the files to the firewall.

4. Log in to the firewall and select Device > Licenses.

License keys must be installed through the web interface. The firewall does not
support license key installaon through SCP or FTP.

• Click Manually Upload License.
• Confirm that the Dashboard displays a valid serial number and that the PA-VM license

displays in the Device > Licenses tab.

Provision Panorama
This opon is only visible if you selected Panorama when the deployment profile was created. You
can edit the profile, if necessary.

STEP 1 | Select Assets > Soware NGFW Credits and click the Details buon on the credit pool you
used to create your profile.
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STEP 2 | On the far right, select the vercal ellipsis (More Opons) and select Provision Panorama,
and Provision. You see the list of firewalls provisioned for the current deployment profile.

This creates a Panorama, assigns a serial number and the model type PAN-PRA-1000-CP, and
registers the Panorama as an asset. The Panorama you just provisioned is the last Panorama
listed. Note the auth code starts with F (so it is not the same as the deployment profile), but the
expiraon date is the same as your profile’s credit pool.

Copy the serial number.

STEP 3 | From the deployment profile, View Devices, and select Panorama on the Soware NGFW
Devices page. This displays all SW NGFW Panoramas.

Search By serial number using the serial number you copied.

You can also select Assets > Soware NGFW Devices and Search By serial number with the
serial number you copied.

Migrate Panorama to a Soware NGFW License
You can migrate VM-ELA or perpetual virtual Panorama licensing to Soware Next Generaon
Firewall (Soware NGFW) licensing.

• Migrate a Panorama with Access to the CSP
• Migrate a Panorama HA Pair that Can Access the CSP
• Migrate a Standalone Panorama that Cannot Access the CSP to a Flexible License
• Migrate An HA Pair that Cannot Access the CSP to a Flexible License

Migrate a Panorama with Access to the CSP
Complete the following procedure to migrate your VM-ELA or perpetual virtual Panorama license
to a Soware NGFW license. This migraon allows you to move your exisng Panorama devices
to the Soware NGFW license without disrupon while retaining your exisng serial number.
Because your serial number does not change, your logs and exisng policies are retained.

STEP 1 | Select Assets > Soware NGFW Credits and click the Details link on the credit pool you
used to create your profile.

STEP 2 | On the far right, select the vercal ellipsis (More Opons) and select Provision Panorama and
then click Migrate Exisng.

The CSP displays all virtual Panorama devices associated with your account.

STEP 3 | Select the check box for each virtual Panorama to be migrated.

VM-Series Deployment Guide Version Version 10.1 94 ©2022 Palo Alto Networks, Inc.



License the VM-Series Firewall

STEP 4 | Click Migrate.

Verify that the Current Support Expiraon Date has been updated. Addionally, you can
expand each row to view the individual licenses applied to the selected Panorama.

Migrate a Panorama HA Pair that Can Access the CSP
Complete the following procedure to migrate an HA pair with VM-ELA or perpetual licenses to
a Soware NGFW licensing. This migraon allows you to move your exisng Panorama devices
to the Soware NGFW license without disrupon while retaining your exisng serial number.
Because your serial numbers do not change, your logs and the exisng policies are retained.

STEP 1 | Select Assets > Soware NGFW Credits and click the Details link on the credit pool you
used to create your profile.

STEP 2 | On the far right, select the vercal ellipsis (More Opons) and select Provision Panorama and
then click Migrate Exisng.

The CSP displays all virtual Panorama devices associated with your account.

STEP 3 | Check the box for each virtual Panorama to be migrated.
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STEP 4 | Select Migrate.

Verify that the Current Support Expiraon Date has been updated. Addionally, you can
expand each row to view the individual licenses applied to the selected Panorama.

Migrate a Standalone Panorama that Cannot Access the CSP to a Flexible License
Complete the following procedure to migrate your VM-ELA or perpetual virtual Panorama license
to a Soware NGFW license even though your Panorama cannot access the CSP. Migraon
without the CSP requires a serial number change, but it allows your Panorama devices to migrate
to Soware NGFW licenses and retain your exisng policies.

The minimum version for Panorama support is 8.1. If you must upgrade PAN-OS, do it
before you start the migraon process. If you want to manage firewalls that are using
flexible vCPUs and advanced services, the PAN-OS version must be 10.0.4 or later.

STEP 1 | On your Panorama, upgrade if necessary, and note the serial number and the current support
expiraon date.
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STEP 2 | In the CSP, select Assets > Soware NGFW Credits and click the Details link on a credit
pool. Select a deployment profile, or create one.

STEP 3 | On the far right, select the vercal ellipsis (More Opons) and select Provision Panorama and
select Migrate Exisng.

The CSP displays all virtual Panorama devices associated with your account.

STEP 4 | Check each virtual Panorama to be migrated and select Migrate.

STEP 5 | On Panorama, replace the serial number with the serial number from the Panorama you
provisioned in the CSP. Wait one minute, then refresh the page.

STEP 6 | In the CSP select your provisioned Panorama and download all licenses (the support license,
the management license, and Panorama as a log manager if your deployment profile includes
it.

Securely pass the licenses to your Panorama.

STEP 7 | Upload all Soware NGFW licenses.

STEP 8 | Verify that the Current Support Expiraon Date has been updated. Addionally, you can
expand each row to view the support license and/or logging license applied to the selected
Panorama.

Migrate An HA Pair that Cannot Access the CSP to a Flexible License
Use this procedure when your HA pair cannot communicate with the CSP. This procedure iniates
a failover.

STEP 1 | Select Assets > Soware NGFW Credits and click the Details buon on the a credit pool.

STEP 2 | On the far right, select the vercal ellipsis (More Opons) and select Provision Panorama.

The CSP displays all virtual Panorama devices associated with the current support account.

STEP 3 | Select Provision New, and check the box for each virtual Panorama to be migrated and select
Migrate.

The migrated Panoramas are displayed as Soware NGFW Devices.
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STEP 4 | Verify that the Current Support Expiraon Date has been updated. Addionally, you can
expand each line to view the individual licenses applied to the selected Panorama.

Transfer Credits
From the Customer Support Portal (CSP), transfer credits to a credit pool in the same account, or
to a credit pool in a different account that you can access.

• Different CSP Account
• Different Pool in this Account

Different CSP Account
STEP 1 | Log into your CSP account.

VM-Series Deployment Guide Version Version 10.1 98 ©2022 Palo Alto Networks, Inc.



License the VM-Series Firewall

STEP 2 | Select Assets > Soware NGFW Credits.

• Idenfy the source credit pool and make note of the Credit Pool ID.
• Idenfy the desnaon credit pool and make note of the Credit Pool ID.

If the desnaon is in a different account, select it from the Current Account dropdown on
the upper le, and Select Assets > Soware NGFW Credits. Find the desnaon and note
the credit type and the Credit Pool ID.

STEP 3 | Go to the source credit pool and click Transfer Credits on the boom le.

STEP 4 | Choose Different CSP account.
1. Transfer to—Choose an account name.
2. As credit type—Choose a credit type. At this me, the source and desnaon type must

be the same.
3. Credit Pool ID#—Choose a Credit pool ID number.

If the desnaon account does not have any credit pools of the chosen type, the CSP
prompts you to create a credit pool.

4. Amount to transfer—Enter the amount to transfer.

STEP 5 | Select Update Credits.

You might need to wait a short me or refresh your screen to see the change.

STEP 6 | To view credit transacons for a pool, select Details and select Audit Trail.

Different Pool in this Account
STEP 1 | Log in to your CSP account.

STEP 2 | Select Assets > Soware NGFW Credits.

• Idenfy the desnaon credit pool and make note of the Credit Pool ID.
• If there isn’t a desnaon credit pool of the type you specify, you are prompted to create a

new credit pool.

STEP 3 | Go to the source credit pool and select Transfer Credits on the boom le.

STEP 4 | Select Different Pool in this Account.
1. New credit type—Choose a credit type. At this me, the source and desnaon type

must be the same.
2. Credit Pool ID#—Choose a Credit pool ID number.

If the desnaon account does not have any credit pools of the chosen type, the CSP
prompts you to create a credit pool.

3. Amount to transfer—Enter the amount to transfer.

STEP 5 | Select Update Credits.

You might need to wait a short me or refresh your screen to see the change.
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STEP 6 | To view credit transacons for a pool, select Details and select Audit Trail.

Renew Your Soware NGFW Credit License
When a deployment profile expires, it moves to the from the Current Deployment Profiles tab
to the Renew Profiles tab. From the Renew Profiles tab, you can quickly renew your deployment
profiles from the Palo Alto Networks Customer Support Portal without disrupng operaons
of your VM-Series firewall. Aer a deployment profile expires and moves to the Renew Profiles
tab, you have 30 days to renew the profile. Any deployment profiles not renewed within 30 days
expire and move to the Expired Deployment Profile tab. See What Happens When Licenses
Expire? for more informaon.

Aer renewal, you might noce some changes between your deployment profiles before.
The Prisma NGFW Credits and Virtual NGFW Credits credit pools are now both called
Soware NGFW Credits credit pools. Addionally, the number of credits in your pool
might change aer renewal due to changes in the product pricing model.

STEP 1 | Log in to the Palo Alto Networks Customer Support Portal.

STEP 2 | Select Assests > Soware NGFW Credits.

STEP 3 | Locate the Deployment Profile to be renewed and click Details.

STEP 4 | Select Renew Profiles.

STEP 5 | Click the Renew icon and then click Renew to confirm.
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STEP 6 | Verify that your deployment profile was renewed successfully.
1. Click Current Deployment Profiles.
2. Confirm that the renewed deployment profile is displayed.

Addionally, you can return to the Soware NGFW dashboard to view your credit pool.
Aer a successful renewal, the credit pool displays Renewal Confirmed. This message
remains unl the end of the expiry date of your renewed Soware NGFW credits.

Deacvate License (Soware NGFW Credits)
You must deacvate any licenses from the CSP before you delete a firewall (or the VM hosng the
firewall) or the license credits cannot return to your credit pool.

When you have internet access to the licensing server, deacvang the firewall on the CSP
automacally removes the licenses and the remaining credits are returned to the deployment
profile. Aer you deacvate the license you must delete the firewall or it will connue to consume
credits.

If you don’t have internet access, you must export the license token from the firewall. Then, in
the CSP, start deacvaon and upload the token (or paste in the token text) to complete the
deacvaon.

• Internet access
• No internet access
• No internet access - Panorama management

Direct internet access.
1. Select Assets > Soware NGFW Credits and click the Details buon on the credit pool

you used to create your deployment profile.
2. Locate your deployment profile, and on the far right, select the vercal ellipsis (More

Opons) and select Deacvate Firewall.
3. Check the firewall you want to deacvate, and select Deacvate Firewall.
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No internet access.
1. Log in to the firewall web interface and select Device > Licenses.
2. In the License Management secon, select Deacvate VM.

Verify the list of licenses/entlements to be deacvated on the firewall.
3. Select Complete Manually to start the deacvaon.

Click the Export license token link to save the token file to the client. A token filename
looks like this: 20150128_1307_dact_lic.01282015.130737.tok

At this point the license has been deacvated on the firewall, but the credits have not
been returned to the credit pool.

4. Use the token file to register the changes with the Licensing server:

1. Log into the Palo Alto Networks Customer Support website.
2. Select Assets > VM-Series Auth-Codes > Deacvate License(s).

In the Deacvate Licenses form, paste in the token text, or copy the token to a computer
with internet access and upload the token file to the CSP to complete license removal.

5. Delete the VM

No internet access—Panorama management
1. Log in to the Panorama web interface and select Panorama > Device Deployment >

Licenses.
2. Select Deacvate VMs and select the VM-Series firewall that you want to deacvate.
3. Select Complete Manually to export the token file.
4. Click the Export license token link to save the token file. A token filename looks like this:

20150128_1307_dact_lic.01282015.130737.tok

If the export is successful, a compleon message is displayed, and the firewall reboots
automacally.

5. Use the token file to register the changes with the licensing server.

1. Log into the Palo Alto Networks Customer Support website.
2. Select Assets > VM-Series Auth-Codes > Deacvate License(s).

In the Deacvate Licenses form, paste in the token text, or copy the token to a computer
with internet access and upload the token file to the CSP to complete license removal.

6. (oponal) Remove the deacvated VM-Series firewall as a managed device on Panorama.

Instead of deleng the deacvated firewalls, you can create a separate device
group and assign them to it.

1. Select Panorama > Managed Devices.
2. Select the firewall that you deacvated and click Delete.
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Create and Apply a Subscripon-Only Auth Code
If you have already deployed VM-Series firewalls using a perpetual or ELA license bundle, you can
use Soware NFGW credits to add subscripons to your exisng deployment.

When adding subscripons, keep the following in mind:

• Only select subscripons that are not included in your exisng bundle.
• Ensure that your VM-Series model and PAN-OS version support the subscripon you want to

add.
• Do not apply more than one subscripon-only auth code to a firewall.
• A subscripon-only license cannot be used as a renewal for an exisng subscripon.
• The firewall on which you are applying the auth code must be able to access the Palo Alto

Networks licensing server.

STEP 1 | If you already have a credit pool, log into the account, and from the dashboard, select Assets
> Soware NGFW Credits > Create Deployment Profile.

If you have just acvated a credit pool you see the Create Deployment Profile form.

STEP 2 | Click Next. A subscripon-only deployment profile can only be used on VM-Series firewalls
with
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STEP 3 | VM-Series profile.
1. Profile Name.

Name the profile.
2. Number of Firewalls.

Enter the number of firewalls this profile deploys, assuming you have sufficient credits.
You do not have to deploy them all at once.

3. Firewall Model:

Choose the VM-Series model of the VM-Series firewalls to which you are adding
subscripons.

You can only apply the subscripon-only auth code to VM-Series firewall of the
chosen model.

4. Security Use Case: Choose a use case.
5. Customize Subscripons.

Aer selecng a use case, you can add or remove security services.
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STEP 4 | (oponal) Hover over the queson mark following Protect more, save more to see how your
credit allocaon affects savings.

STEP 5 | Click Calculate Esmated Cost to view the credit total, and the number of credits available
before the deployment.

(oponal) Hover over the queson mark following the esmate to view the credit breakdown
for each component.

STEP 6 | Create the Deployment Profile.

You might have to wait several seconds for the profile to appear in the Current Deployment
Profiles tab list. Before the allocaon is complete, the Credits Consumed/Allocated column
shows 0 and Update Pending. Scroll to the boom and go to the last page to find your profile.

To view your deployment profile later on, click the Details buon on the parent credit pool and
select Current Deployment Profiles.

• Note the Auth Code for your profile on the far right; subscripon-only auth codes start with
D.

• The Credits Consumed/Allocated column shows 0 and Update Pending before the
allocaon is complete.

• The Audit Trail tab shows Credit Transacons and the Deployment Profiles you manage.
You can also search for a profile by me in this tab.

Use search to locate your profile, and expand the row to view the configuraon you
specified when you created the profile.

STEP 7 | Apply the subscripon-only auth code to your firewall.
1. Log in to the CSP with your account credenals.
2. Select Assets > Soware NFGW Credits.

Locate your credit pool and view Details.
3. View Current Deployment Profiles and choose a profile.

You will use the auth code from this profile on any firewall of the model specified when
you created your deployment profile. An auth code for a subscripon-only license begins
with the leer D.

4. Log in to the VM-Series firewall web interface.
5. Verify the Palo Alto Networks update server configuraon.

1. Select Device > Setup > Services.
2. Confirm that Update Server is set to updates.paloaltonetworks.com.
3. Confirm that Verify Update Server Identy is selected.

6. Select Device > Licenses.

1. Select the Acvate feature using authorizaon code link.
2. Enter the subscripon-only auth code from the deployment profile.
3. Click OK to confirm the license applicaon.The firewall contacts the Palo Alto

Networks update server and consumes the tokens required for your subscripon-only
license.
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STEP 8 | Verify that the license is successfully acvated.

On the Device > Licenses page, verify that the license is successfully acvated. For example,
aer acvang the Threat Prevenon license, you should see that the license is valid:

Customize Dataplane Cores
As menoned in Soware NGFW Credits, when a firewall is deployed using Soware NGFW
credits, the memory profile and the total number of vCPUs determine how many cores are
automacally assigned to the management plane and the dataplane. The default configuraons
perform well in most cases.

Customize dataplane cores is an oponal feature that allows you to customize the number of
dataplane cores in two ways:

• During the inial deployment, use the init-cfg.txt file bootstrap parameter plugin-op-
commands=set-dp-cores:<#-cores>. See init-cfg.txt File Components.

• From a deployed firewall, using the VM-Series CLI command request plugins vm_series
dp-cores <#-cores>. This procedure is outlined below.

Typically you increase the number of dataplane cores (which decreases the number of
management plane cores) to improve performance. Dataplane core customizaon does not require
a change to the deployment profile or addional credits because the total number of vCPUs
remains the same.

• Dataplane core customizaon is supported on firewalls running PAN-OS 10.1 or later licensed
with a Soware NGFW credit pool for 10.0.4 and above.

• Dataplane core customizaon is not supported for:

• NSX-T
• Intelligent Traffic Offload

Follow theses steps to customize the dataplane cores on the VM-Series firewall.

STEP 1 | Log in to the VM-Series firewall and view the number of cores.

admin@PA-VM(active)>show plugins vm_series dp-cores
Device current DP cores: 13 (Total cores: 18)
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STEP 2 | Change the number of dataplane cores.

Note that you must have at least one management plane core, and having too few
cores affects performance.

In this example we increase the dataplanes to 14.

admin@PA-VM(active)>request plugins vm_series dp-cores 14
Device current DP cores: 14 (Total cores: 18)

STEP 3 | Reboot the VM-Series firewall.

Select Device > Setup > Operaons and click Reboot Device.

STEP 4 | Use show plugins vm_series dp-cores to verify that the number of DP cores has
changed.

Limit Licensed vCPUs
You can specify the number of vCPUs that are licensed when using Soware NGFW credits
instead of licensing all the vCPUs available on your chosen compute instance. This allows you to
use a larger compute instance without consuming more Soware NGFW credits than necessary.

This feature requires VM-Series plugin 2.1.4 or later.

You can specify the number of vCPUs to be licensed using a new bootstrap plugin op command or
the VM-Series firewall CLI.

• To set the number of cores when bootstrapping a VM-Series firewall, add the following
command to your init-cfg.txt file.

plugin-op-commands=set-cores:<number-of-cores>

For example:

plugin-op-commands=set-cores:4
• To set the number of cores on a VM-Series firewall that has already been deployed, use the

following CLI command.

request plugins vm_series set-cores cores <number-of-cores>

For example:

request plugins vm_series set-cores cores 16

You must reboot the VM-Series firewall for this change to take effect.

You can verify that the vCPU change has taken affect using the show plugins vm_series
cores command in the VM-Series CLI.

If you need to downgrade your VM-Series from 2.1.4 to a previous version, you must set the
number of cores back to the default value for your VM-Series firewall. This does not occur
automacally upon downgrade.
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Migrate a Firewall to a Flexible VM-Series License
You can migrate your VM-Series firewall perpetual or ELA license to a flexible VM-Series firewall
license (funded using Soware NGFW credits). From Panorama you can switch the license on an
individual firewall or on mulple firewalls simultaneously from Panorama.

If the license you want to switch is for a VM-Series firewall with an ELA or perpetual
license, you must choose Fixed Models and use the same VM-Series model and number
of vCPUs when you create the SW NGFW deployment profile for the flexible license.
For example, if you are currently using a VM-100 with 2 vCPUs, when you create the
deployment profile, select Fixed Models, select VM-100, and specify 2 vCPUs. As long as
the capacity is the same, you can add new services.

Complete one of the following procedures to migrate your licenses.

• Standalone Firewall with Access to the CSP
• Standalone Firewall, No Access to the CSP
• Panorama-managed Firewalls with Access to the CSP
• Panorama-managed Firewalls, No Access to the CSP
• Both Panorama-managed Firewall and Panorama Do Not Have Access to the CSP
• Verify the Migraon

Standalone Firewall with Access to the CSP
This process does not disrupt traffic moving through the firewall.

STEP 1 | Log in to the VM-Series firewall web interface.

STEP 2 | Verify the Palo Alto Networks update server configuraon.
1. Select Device > Setup > Services.
2. Confirm that Update Server is set to updates.paloaltonetworks.com.
3. Confirm that Verify Update Server Identy is selected.

STEP 3 | Log in to the CSP and Create a Deployment Profile. If the license you want to migrate is
for a VM-Series firewall with an ELA or perpetual license, you must choose Fixed Models
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and use the same VM-Series model and number of vCPUs when you create the SW NGFW
deployment profile for the flexible license.

You will use the auth code from this profile. An auth code for a flexible firewall license begins
with the leer D, as shown below.
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STEP 4 | Select Device > Licenses.

If the current VM-Series model and the VM-Series model you are migrang to are different,
select the Upgrade VM Capacity link.

If the VM-Series model is the same before and aer migraon, select the Acvate feature
using authorizaon code link.

STEP 5 | Enter the VM-Series authorizaon code from the new deployment profile.

STEP 6 | Click OK to confirm the license upgrade.The firewall contacts the Palo Alto Networks update
server and consumes the tokens required for your firewall based on the VM-Series model.

STEP 7 | (Oponal) Verify the Migraon.

STEP 8 | Repeat this process for each VM-Series firewall in your deployment.

Standalone Firewall, No Access to the CSP
Migrate a license on a firewall without access to the CSP.

STEP 1 | If necessary, install the license API key on your VM-Series firewall.

STEP 2 | Use the CLI to use manual mode to deacvate the fixed-model license.

STEP 3 | Deacvate the VM from the Firewall using the manual procedure, and log in to the CSP and
use the token file to deacvate the VM.

STEP 4 | In the CSP, Create a Deployment Profile with the same VM-Series model, number of vCPUs,
and security subscripons as the previous fixed model license. You will use the auth code
from this profile.

STEP 5 | Select the new profile and click the vercal ellipsis and select Register Firewall.
1. Enter the VM and firewall informaon and select Submit. This associates the firewall

with the profile and its authcode and assigns a serial number.
2. Click View Devices to see associated devices in Soware NGFW Devices.
3. In the License column, download the license keys to a locaon from which you can safely

transfer the files to the host machine.

STEP 6 | On the firewall select Device > Licenses.

License keys must be installed through the web interface. The firewall does not support
license key installaon through SCP or FTP.

STEP 7 | Click Manually Upload License and enter the license keys.

STEP 8 | Confirm that the Dashboard displays a valid serial number and that the PA-VM license
displays in the Device > Licenses tab.

STEP 9 | (oponal) Verify the Migraon.
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Panorama-managed Firewalls with Access to the CSP
Migrate from a fixed license to a flexible license on Panorama-managed firewalls.

STEP 1 | Before you begin, ensure that you install a License API key on the firewall.

STEP 2 | Log in to the Panorama web interface.

STEP 3 | Verify the Palo Alto Networks update server configuraon for the firewalls.
1. Select Device > Setup > Services.
2. Confirm that Update Server is set to updates.paloaltonetworks.com.
3. Confirm that Verify Update Server Identy is selected.

STEP 4 | Create a Deployment Profile for the new license if you have not done so already. This profile
is required to generate the new authorizaon code for the migrated Panorama.
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STEP 5 | Retrieve the VM-Series authorizaon code. A firewall authorizaon code for a flexible license
begins with the leer D, as shown below.
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STEP 6 | Apply the new authorizaon code.
1. Select Panorama > Device Deployment > Licenses and Acvate.
2. Enter your VM-Series authorizaon code.
3. Use the filters to select the managed firewalls to be licensed.
4. Enter your authorizaon code in the Auth Code column for each firewall.
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5. Acvate to confirm the license upgrade. Panorama contacts the Palo Alto Networks
update server and consumes the tokens required for your firewalls based on the VM-
Series model, vCPUs, and services you have chosen.

STEP 7 | (oponal) o.

Panorama-managed Firewalls, No Access to the CSP
Migrate a Panorama-managed VM-Series firewall that cannot access the CSP.

STEP 1 | Before you begin, ensure that you install a License API key on the firewall.

STEP 2 | Panorama, no internet access—Migrate licenses on offline Panorama managed firewalls

STEP 3 | Deacvate the VM from Panorama using the manual procedure, and log in to the CSP and
use the token file to deacvate the VM.

STEP 4 | In the CSP, Create a Deployment Profile with the same VM-Series model, number of vCPUs,
security subscripons, and Panorama as the fixed model license. You will use the auth code
from this profile.

STEP 5 | Select the new profile and click the vercal ellipsis and select Register Firewall.
1. Enter the VM and firewall informaon and select Submit. This associates the firewall

with the profile and its authcode and assigns a serial number.
2. Click View Devices to see associated devices in Soware NGFW Devices.
3. In the License column, download the license keys to a locaon from which you can safely

transfer the files to the host machine.
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STEP 6 | Apply the new authorizaon code.
1. Select Panorama > Device Deployment > Licenses and click Acvate.
2. Use the filters to select the managed firewalls to be licensed.
3. Enter your authorizaon code from your deployment profile in the Auth Code column for

each firewall.

VM-Series Deployment Guide Version Version 10.1 118 ©2022 Palo Alto Networks, Inc.



License the VM-Series Firewall

VM-Series Deployment Guide Version Version 10.1 119 ©2022 Palo Alto Networks, Inc.



License the VM-Series Firewall

4. Click Acvate to confirm the license upgrade. Panorama contacts the Palo Alto Networks
update server and consumes the tokens required for your firewalls based on the VM-
Series model, vCPUs, and services you have chosen.

STEP 7 | (oponal) Verify the Migraon.

Both Panorama-managed Firewall and Panorama Do Not Have Access to the CSP
When both Panorama and a managed firewall cannot access the CSP, migrate a license on the
managed firewall.

STEP 1 | If necessary, install the license API key on your VM-Series firewall.

STEP 2 | Use the CLI to use manual mode to deacvate the fixed-model license.

STEP 3 | Deacvate the VM from the Firewall using the manual procedure, and log in to the CSP and
use the token file to deacvate the VM.

STEP 4 | In the CSP, Create a Deployment Profile with the same VM-Series model, number of vCPUs,
and security subscripons as the previous fixed model license. You will use the auth code
from this profile.

STEP 5 | Select the new profile and click the vercal ellipsis and select Register Firewall.
1. Enter the VM and firewall informaon and select Submit. This associates the firewall

with the profile and its authcode and assigns a serial number.
2. Click View Devices to see associated devices in Soware NGFW Devices.
3. In the License column, download the license keys to a locaon from which you can safely

transfer the files to the host machine.

STEP 6 | On the firewall select Device > Licenses.

License keys must be installed through the web interface. The firewall does not support
license key installaon through SCP or FTP.

STEP 7 | Click Manually Upload License and enter the license keys.

STEP 8 | Confirm that the Dashboard displays a valid serial number and that the PA-VM license
displays in the Device > Licenses tab.

STEP 9 | (oponal) Verify the Migraon.

Verify the Migraon
Verify that your license migraon was successful.

STEP 1 | On the device, check the license expiraon date to verify the license updated successfully.

STEP 2 | Verify that all subscripons enabled in your deployment profile are applied to your device.

STEP 3 | On the CSP, verify that the expected number of credits allocated and credits consumed
match your credit pool.
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STEP 4 | On the CSP, verify that the associated tokens or quanty of licenses have been returned to
your previous auth code.
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VM-Series Models
The VM-Series firewall is available in the following fixed vCPU models—VM-50, VM-100,
VM-200, VM-300, VM-500, VM-700, and VM-1000-HV. These models are available for all
supported PAN-OS versions, unless otherwise noted below. The soware package ( .xva, .ova, or
.vhdx file) that is used to deploy the VM-Series firewall is common across all models.

You can migrate your fixed model ELA or perpetual license to a

flexible license and retain the fixed model, or you can replace the license with a flexible
vCPU license. See VM-Series Firewall Licensing to compare the licensing methods.

• All models can be deployed as guest virtual machines on VMware ESXi and vCloud Air, KVM,
Microso Hyper-V, Cisco ACI, Cisco ENCS, and Cisco CSP.

• In public cloud environments—Amazon Web Services, Azure, Google Cloud Plaorm, Oracle
Cloud Infrastructure, Alibaba Cloud—all models except the VM-50 are supported.

• For VMware NSX, only the VM-100, VM-200, VM-300, VM-500, and VM-1000-HV firewalls
are supported.

When you apply the capacity license on the VM-Series firewall, the model number and the
associated capacies are implemented on the firewall. Capacity is defined in terms of the number
of sessions, rules, security zones, address objects, IPSec VPN tunnels, and SSL VPN tunnels that
the VM-Series firewall is opmized to handle. To make sure that you purchase the correct model
for your network requirements, use the following table to understand the maximum capacity for
each model and the capacity differences by model:

Model Sessions Security
Rules

Dynamic IP
Addresses

Security
Zones

IPSec VPN
Tunnels

SSL VPN
Tunnels

VM-50 50,000 • 250
• 200

in Lite
mode

1,000 15 • 250
• 25 in

Lite
mode

• 250
• 25 in

Lite
mode

VM-100

VM-200

250,000 1,500 2,500 40 1,000 500

VM-300

VM-1000-
HV

800,000 10,000 100,000 40 2,000 2,000

VM-500 2,000,000 10,000 100,000 200 4,000 6,000

VM-700 10,000,000 20,000 100,000 200 8,000 12,000
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For informaon on the plaorms on which you can deploy the VM-Series firewall, see VM-Series
Deployments. For more informaon about the VM-Series firewall models, see the Palo Alto
Networks Firewall comparison tool. You can also review general informaon About the VM-Series
Firewall.

• VM-Series System Requirements
• CPU Oversubscripon
• VM-50 Lite Mode
• VM-Series Model License Types
• Acvate VM-Series Model Licenses
• Register the VM-Series Firewall
• Install a Device Cerficate on the VM-Series Firewall
• Switch Between the BYOL and the PAYG Licenses
• Switch Between VM-Series Model Licenses
• Deacvate License(s)
• Renew VM-Series Firewall License Bundles

VM-Series System Requirements
Each instance of the VM-Series firewall requires a minimum resource allocaon—number of CPUs,
memory, and disk space, on its host server. Use the table below to verify that you allocate the
necessary hardware resources for your VM-Series model or memory profile.

VM-Series
Model

Supported Hypervisors Supported
vCPUs

Minimum
Memory

Minimum
Memory
with GTP
Enabled

Minimum
Hard Drive

VM-50 ESXi, Hyper-V, KVM 2 • 5.5GB
• 4.5GB

in Lite
mode

• 6GB
• 5GB

in Lite
mode

32GB
(60GB at
boot)

VM-100 AWS, Azure, ESXi,
Google Cloud Plaorm,
Hyper-V, KVM, OCI,
IBM Cloud, Alibaba
Cloud, Cisco ACI, Cisco
CSP, Cisco ENCS, NSX-T
(VM-100)

2 6.5GB 7.5GB 60GB
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VM-Series
Model

Supported Hypervisors Supported
vCPUs

Minimum
Memory

Minimum
Memory
with GTP
Enabled

Minimum
Hard Drive

The
VM-100
on Azure
requires 4
vCPUs.

VM-300 AWS, Azure, ESXi,
Google Cloud Plaorm,
Hyper-V, KVM, OCI,
IBM Cloud, Alibaba
Cloud, Cisco ACI, Cisco
CSP, Cisco ENCS, NSX-T
(VM-300)

2, 4 9GB* 10GB 60GB

VM-500 AWS, Azure, Cisco
ACI, Cisco CSP, ESXi,
Google Cloud Plaorm,
Hyper-V, KVM, OCI,
IBM Cloud, NSX-T

2, 4, 8 16GB 20GB 60GB

VM-700 AWS, Azure, ESXi,
Google Cloud Plaorm,
Hyper-V, KVM, OCI,
IBM Cloud, Alibaba
Cloud, Cisco ACI, Cisco
CSP, NSX-T

2, 4, 8, 16 56GB 64GB 60GB

*In 10.1.X, 9 GB might be insufficient depending upon the feature set or combinaon of feature
sets used on the firewall. If you experience memory resource related issues, increase memory
to 11 GB to accommodate the addional memory requirements of some of the features or
combinaon of features. Alternately, you can Enable ZRAM on the VM-Series Firewall to improve
memory usage.

You can enable Lite mode on the VM-50. Lite mode is an alternave operang mode for
environments where resources are limited. See VM-50 Lite Mode for more informaon.

To achieve the best performance, all of the needed cores should be available on a single
CPU socket.

For operaon, the VM-50 firewall requires minimum 32GB of hard drive space. However,
because the VM-Series base image is common to all models, you must allocate 60GB of
hard drive space unl you license the VM-50.

VM-Series Deployment Guide Version Version 10.1 124 ©2022 Palo Alto Networks, Inc.



License the VM-Series Firewall

The number of vCPUs assigned to the management plane and those assigned to the dataplane
differs depending on the total number of vCPUs assigned to the VM-Series firewall. If you assign
more vCPUs than those officially supported by the license, any addional vCPUs are assigned to
the management plane.

Total vCPUs Management Plane vCPUs Dataplane vCPUs

2 1 1

4 2 2

8 2 6

16 4 12

CPU Oversubscripon
The VM-Series firewall supports CPU oversubscripon on all models. CPU oversubscripon allows
you deploy a higher density of VM-Series firewalls on hypervisors running on x86 architecture.
You can deploy two (2:1) to five (5:1) VM-Series firewalls per required allocaon of CPUs. When
planning your deployment, use the following formula to calculate the number of VM-Series
firewalls your hardware can support.

(Total CPUs x Oversub Rao)/CPUs per firewall = total number of VM-Series firewalls

For example, at a 5:1 rao, a host machine with 16 physical CPU and at least 180GB of memory
(40 × 4.5GB) can support up to 40 instances to the VM-50. Each VM-50 requires two vCPUs and
five VM-50s can be associated to each pair of vCPUs.

(16 CPUs x 5)/2 = 40 VM-50 firewalls

Beyond meeng the minimum VM-Series System Requirements, no addional configuraon is
required to take advantage of oversubscripon. Deploy VM-Series firewalls normally and resource
oversubscripon occurs automacally. When planning your deployment, consider other funcons,
such as virtual switches, and guest machines on the host that require hardware resources of their
own.
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VM-50 Lite Mode
The standard VM-50, while the smallest model of the VM-Series, requires more resources than are
available in some environments. The VM-50 Lite mode provides an alternave for environments
where hardware resources are constrained. The VM-50 Lite requires 4.5GB of memory instead of
the 5.5GB required by the standard VM-50. The VM-50 Lite uses the same license as the standard
VM-50 but comes up in Lite mode when allocated 4.5GB of RAM.

• In high availability deployments, both VM-Series firewalls must both be licensed as
a VM-50 Lite to avoid capacity mismatch issues. In the case of a capacity license
mismatch, the VM-50 (non-Lite) is considered to have a higher capacity; the VM-50
becomes non-funconal while the VM-50 Lite remains funconal.

• The VM-50 Lite does not support jumbo frames; the VM-50 and VM-50 Lite do not
support WildFire inline ML.

VM-Series Model License Types
The following licenses and subscripons are available for the VM-Series firewall:

• Capacity License—The VM-Series firewall requires a base license, also called a capacity license,
to enable the model number (VM-50, VM-100, VM-200, VM300, VM-500, VM-700, or
VM-1000-HV) and the associated capacies on the firewall. Capacity licenses are included in a
bundle and can be perpetual or term-based:

• Perpetual License—A license with no expiraon date, it allows you to use the VM-Series
firewall at the licensed capacity, indefinitely. Perpetual licenses are available for the VM-
Series capacity license only.

• Term-Based License—A term-based license allows you to use the VM-Series firewall for a
specified period of me. It has an expiraon date and you will be prompted to renew the
license before it expires. Term-based licenses are available for the capacity licenses, support
entlements, and subscripons.

• VM-Series ELA—For high-growth enterprises, the VM-Series enterprise licensing agreement
(VM-Series ELA) provides a fixed price licensing opon that allows up to unlimited deployment
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of VM-Series firewalls with BYOL. The ELA is offered in one and three-year term agreements
with no true-up at the end of the term.

There are two flavors of the VM-Series ELA:

• If you purchased the VM-Series ELA before December 4, 2018, you have the legacy VM-
Series ELA which includes your choice of a single VM-Series model on any supported
hypervisor or public cloud environment. With this ELA, you receive a single license
authorizaon code for capacity, support, GlobalProtect, PAN-DB URL Filtering, Threat
Prevenon, WildFire subscripons for every instance of the VM-Series firewall. You also
get unlimited deployments of the Panorama virtual appliance included with a device
management license for 1000 firewalls on each.

Palo Alto Networks began phasing out the legacy VM-Series ELA on April 16, 2019. Exisng
enterprise license customers will be nofied by their support representave when their
account is migrated to the Mul-Model ELA. Licensing tokens will be distributed according
to your VM-Series firewall subscripon agreement — no addional acon is necessary for
connued operaon of your firewalls. If you would like to Manage VM-Series ELA License
Tokens, you must designate an ELA administrator. Only a super user role on the Palo Alto
Networks Customer Support Portal (CSP) can assign an ELA administrator.

• The VM-Series Enterprise License Agreement (Mul-Model ELA) you purchase aer
December 4, 2018 (either as a new purchase or as a repurchase of the legacy VM-Series
ELA) is called the mul-model VM-Series ELA that includes most models of the VM-Series
firewall porolio along with the GlobalProtect, PAN-DB URL Filtering, Threat Prevenon,
WildFire subscripons, and support entlement. You also get unlimited deployments of the
Panorama virtual appliance with a device management license for 1000 firewalls on each.

VM-Series Firewall Licenses for Public Clouds
The VM-Series firewall licensing strategy is the same for AWS, Azure, and Google Cloud Plaorm.
There are different license types (see License Types—VM-Series Firewalls), and Bring Your Own
License and Pay-as-you-go licensing methods:

• Bring Your Own License (BYOL)—A license that is purchased from a partner, reseller, or directly
from Palo Alto Networks. BYOL supports individual capacity licenses, support licenses, and
subscripon bundles.

• For individual BYOL licenses, you must apply the auth code aer you deploy the VM-Series
firewall.

• A BYOL license bundle has a single auth code you can include in the bootstrap package (see
Bootstrap the VM-Series Firewall). All the subscripons included in the bundle are licensed
when the firewall launches.

A BYOL license for the VM-Series firewall on OCI GovCloud requires PAN-OS 10.1.2 or
later for FIPS and non-FIPS modes.
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• Pay-as-you-go (PAYG)—Also called usage-based or pay-per-use licensing. PAYG licenses can be
purchased from your Cloud provider:

• AWS: Purchase from AWS Marketplace. Supports hourly and annual PAYG opons.
• Azure: Purchase from Azure Marketplace. Supports the hourly PAYG opon.
• Google Cloud Plaorm: Purchase from Google Cloud Plaorm Marketplace. Google Cloud

Plaorm supports per-minute PAYG opon.
• Oracle Cloud Infrastructure: (PAN-OS 10.0.3 or later) Purchase from Oracle Cloud

Marketplace.

The VM-Series on OCI PAYG license does not support the VM-100.

With the PAYG license bundles, the firewall is prelicensed and ready for use as soon as you
deploy it; you do not receive an auth code. When you stop or terminate the firewall from your
Cloud console, PAYG licenses are suspended or terminated.

A PAYG license applies a VM-Series capacity license based on the hardware allocated to the
instance. the PAYG instance checks the amount of hardware resources available to the instance
and applies the largest VM-Series firewall capacity license allowed for the resources available.
For example, if the instance has 2 vCPUs and 16GB of memory, a VM-100 capacity license is
applied based on the number of vCPUs. However, if the instance has 16 vCPUs and 16GB of
memory, a VM-500 license is applied based on the amount of memory. For more informaon
about VM-Series model resource requirements, see VM-Series System Requirements.

Downgrading PAN-OS is not supported on a PAYG firewall instance that was inially
deployed running PAN-OS 9.1.2. Firewall instances deployed prior to PAN-OS 9.1.2
can be downgraded to older versions of PAN-OS.

The PAYG licenses are bundled as follows:

License Features Bundle 1 Bundle 2

VM-Series firewall capacity license VM-100, VM-300,
VM-500, VM-700

VM-100, VM-300,
VM-500, VM-700

Premium Support

Threat Prevenon (AV, IPS, and
malware prevenon)

GlobalProtect

PAN-DB URL Filtering

WildFire

DNS Security
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When using the VM-Series firewall CLI to view your applied PAYG license, the command
show system info displays a different value from the output displayed for the
command request license info. For PAN-OS versions 9.1.1 and earlier the
command request license info always displays the model as VM-300, regardless
of the VM-Series model that has been applied.

You cannot switch between the PAYG and the BYOL licenses. To move from PAYG to BYOL,
contact your Palo Alto Networks channel partner or sales representave to purchase a BYOL
license and get a BYOL auth code that you can use to license your firewall. If you have deployed
your firewall and want to switch the license, see Switch Between the BYOL and the PAYG
Licenses.

If you have an evaluaon copy of the VM-Series firewall and would like to convert it
to a fully licensed (purchased) copy for the same license type (BYOL to BYOL), you can
deacvate the evaluaon license and acvate the purchased license in its place. See
Upgrade the VM-Series Firewall for instrucons.

VM-Series Enterprise License Agreement (Mul-Model ELA)
The VM-Series Enterprise License Agreement (VM-Series ELA) is a one- or three-year
comprehensive licensing agreement that enables you to purchase VM-Series firewalls, along
with the GlobalProtect, PAN-DB URL Filtering, Threat Prevenon, WildFire, and DNS Security
subscripons. It also includes a support entlement and a device management license for
Panorama. The mul-model VM-Series ELA provides simplified license management with a single
contract that allows you to deploy any model of the VM-Series firewall that meets your enterprise
security needs.

When you purchase the mul-model VM-Series ELA, you forecast the number of firewalls that
you’ll need over the term of your subscripon. Based on your forecast and an addional allotment
that accommodates for future growth, your account on the Customer Support Portal (CSP) is
credited with a license token pool that allows you to deploy any model of the VM-Series firewall.
Depending on the firewall model and the number of firewalls that you deploy, a specified number
of tokens are deducted from your available license token pool. The tokens drawn from your
account are calculated based on the value of each firewall model:

• VM-50—10 tokens
• VM-100—25 tokens
• VM-300—50 tokens
• VM-500—140 tokens
• VM-700—300 tokens

With the VM-Series ELA, there is no true-up due at the end of the term which means that you are
not billed retroacvely even if you deploy more firewalls than your original forecast. So, to balance
flexibility with accountability, the VM-Series ELA terms of use include a bounded and unbounded
period that explains how you can consume tokens and deploy firewalls as the need arises. For
details, refer to the ELA terms and condions. The VM-Series firewalls that you deploy with the
VM-Series ELA do not have a perpetual license and on the expiry of the term, you must renew the
agreement to extend the support entlement and get connued access to soware and content
release updates on the firewalls.
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With the ELA administrator role on the CSP, you can transfer or split the licensing tokens among
other administrators who belong to different departments with their own CSP accounts. This
sharing enables other administrators in your enterprise to deploy the VM-Series firewall on
demand as long as they have tokens available in their respecve CSP accounts. See Manage VM-
Series ELA License Tokens to invite other administrators to share ELA tokens and deploy any
model of the VM-Series firewall that meets your enterprise security need. You can also reclaim
tokens to remove CSP accounts from the VM-Series ELA if you want to redistribute tokens based
on changing organizaonal needs.

Watch VM-Series Mul-Model ELA videos

• Manage VM-Series ELA License Tokens
• Accept the VM-Series ELA

Manage VM-Series ELA License Tokens

The VM-Series Enterprise License Agreement (Mul-Model ELA) (VM-Series ELA) gives you
the flexibility of having a single contract that you can share with other administrators in your
enterprise. You must have the super user role on the Palo Alto Networks Customer Support Portal
(CSP) to acvate the ELA, and upon acvang the ELA authorizaon code you inherit the ELA
administrator role on the CSP.

With the ELA administrator role, you can manage the license token pool available to deploy VM-
Series firewalls and subscripons included in the agreement. You can invite other administrators to
share the VM-Series ELA tokens, grant which models and how many instances of the VM-Series
firewalls are available to each administrator, as well as remove CSP accounts from your VM-Series
ELA. Depending on what you allocate for each grantee, they receive a specific number of tokens
that they can then use to deploy VM-Series firewalls.

Addional purchases and grants do not directly add to the number of available VM-Series
firewalls in a CSP account; instead, ELA license tokens are added to the VM-Series ELA
token pool. The ELA license tokens can subsequently be allocated by the ELA administrator
to a given CSP account to increase the number of available VM-Series firewalls.

STEP 1 | (Legacy VM-Series ELA Customers only) Designate an ELA administrator to manage tokens.

Exisng enterprise license customers who have been migrated to the Mul-Model ELA must
designate an ELA administrator to manage VM-Series ELA license tokens. Upon conversion, no
other acon is necessary for connued operaon of your firewalls, however, you will not be
able to (re)allocate tokens for deploying firewalls unl an ELA administrator has been assigned.
Only an administrator with a super user role on the CSP has the ability to designate an ELA
administrator, who in turn, can manage tokens or grant tokens to other administrators.

1. Log in to the Palo Alto Networks CSP.
2. Select Members > Manage Users.
3. Click on the pencil icon under Acons to edit the user to whom you want to assign the

ELA administrator role.
4. Select ELA Administrator and then click the check mark to add the new role to the

selected user.
5. Connue to step 3.
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STEP 2 | Acvate the ELA authorizaon code.

The administrave user who acvates the ELA inherits the ELA administrator and super
user role on the CSP and has the ability to manage the tokens or grant the tokens to other
administrators.

1. Log in to the Palo Alto Networks CSP.
2. Select Assets > Enterprise Agreements > Acvate Enterprise Agreement.
3. Enter the Authorizaon Code and Agree and Submit the EULA.

Verify the authorizaon code is registered to your account under Enterprise Agreements:
VM-Series. The page displays the Auth Code, Account ID, Account Name, License
Descripon, Expiraon Date, the number of Licenses (used/total) you have, and
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how many are available to deploy within the bounded and unbounded period of the
agreement.

4. Select Assets > VM-Series Auth-Codes to view the authorizaon codes for deploying
each model of the VM-Series firewall and associated subscripons included with the
ELA.

STEP 3 | Grant ELA access to other administrators in your enterprise.

This capability allows you to share the VM-Series ELA with other administrators within your
enterprise or department so that they can deploy VM-Series firewalls on demand. As an ELA
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administrator, you can grant access to other users who are registered with an email address on
the CSP.

1. On Assets > Enterprise Agreements, select Grant ELA Access.
2. Enter the Desnaon Email address of the administrator whom you want to invite.

The desnaon email address that you enter above must be a registered user on the CSP
with a super user role so that they can log in and accept the grant. If the email address is
not registered on the CSP, you must first create a new account for the user on Members
> Create New User.

3. Select Nofy User to trigger a noficaon email to the email address you entered.

The recipient must log in to the CSP to Accept the VM-Series ELA. Aer the recipient
accepts the grant, the account ID is available on Assets > Enterprise Agreements as
shown in the following screenshot.

STEP 4 | Allocate tokens for deploying firewalls.
1. Select Assets > Enterprise Agreements > Manage VM-Series Tokens.

For each account ID, you can specify the number of firewalls by model that you
want to allocate. Based on the quanty and firewall model, the number of tokens are
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automacally calculated and become available for use. In this example, you are allowing
10 instances each of the VM-50 and the VM-500.

2. Verify that the accurate number of firewall instances are deposited in the account.

Select Assets > VM-Series Auth-Code to confirm the auth codes you alloed. In this
example, the account has the ability to provision 10 instances each of the VM-50 and
the VM-500. As the recipients deploy firewalls, the number of tokens are deducted from
the total available pool, and you can view the number of firewall instances that they have
provisioned as a rao of the total quanty you allocated for them. As your security needs
evolve, you have the flexibility to allocate more quanty and allow access to a different
VM-Series firewall model as long as you have tokens available.
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STEP 5 | Remove a CSP account from the VM-Series ELA to reclaim tokens.

You cannot reclaim a poron of the tokens allocated to a CSP account. By reclaiming
tokens, you are removing the enrety of the CSP account from the VM-Series ELA and
reallocang all associated tokens to the token pool.

1. Verify that all tokens associated with the CSP account that you want to remove are
not being ulized by the VM-Series firewalls. Deacvate the VM-Series firewalls as
necessary to provision tokens for removal.

2. Select Assets > Enterprise Agreements > Manage VM-Series Token.

Select the account ID from whom you want to reclaim tokens from and click Reclaim
Token. If tokens are available for reclamaon, you will receive a confirmaon of a
successful removal.

Accept the VM-Series ELA

If your enterprise has purchased a VM-Series ELA, your ELA administrator can invite you to share
the contract and share the license token pool so that you have access to VM-Series firewall auth
codes which enable you to deploy VM-Series firewalls on demand. When you receive a grant for
access to the VM-Series ELA, you get an email noficaon that includes a link to log in to the
Palo Alto Networks Customer Support Portal (CSP) and you must agree and accept the terms of
use. Aer you accept the ELA terms of use, the ELA administrator can allocate which VM-Series
firewall models and how many you are entled to use; the corresponding number of VM-Series
ELA tokens are deposited in your account.
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STEP 1 | Check your email inbox for the grant noficaon.

The noficaon includes the email address of the ELA administrator who has invited you to
share the VM-Series ELA.

STEP 2 | Accept the grant.

You must review the terms and accept the EULA and the support agreement before the ELA
admin can allocate tokens which enable you to deploy VM-Series firewalls.

1. Log in to the Palo Alto CSP.
2. Select VM-Series Auth Codes to Review Tokens Grant.

You must Agree and Accept the EULA and support agreement to accept the grant. If
you reject it, the ELA Admin who gave you the grant receives an email noficaon that
you declined the grant. Do make sure to let the ELA administrator know that you have
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accepted the grant so that you he/she can allocate the VM-Series firewall models and
quanty that you can deploy.

If you belong to mulple accounts on the CSP and accidentally accept the grant
in to the wrong account, you must request the ELA administrator to resend the
grant to you. Do not start using the auth code to provision firewalls unl you
accept the grant in the correct account.

STEP 3 | Verify which VM-Series models and how many are allocated for you.

Aer the ELA administrator allocates the VM-Series firewall models and number of instances
you can provision, you can select Assets > VM-Series Auth Codes to view which models and
how many of each are allocated for you. For example, the grant in the following screenshot
displays the auth codes that enable you to deploy 10 instances each of the VM-50 and the
VM-500.

As you deploy firewalls and register them to the CSP, the number of provisioned firewalls
is incremented. The Quanty of VM Provisioned displays the rao of provisioned to total
available for each model.
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Acvate VM-Series Model Licenses
To acvate the license on your VM-Series firewall, you must have deployed the VM-Series firewall
and completed inial configuraon. To deploy the firewall, see VM-Series Deployments.

Use the instrucons in this secon for all the BYOL models including AWS, Azure, and Google
Public Cloud. For usage-based licensing in public clouds, you do not need to acvate the license.
You must Register the Usage-Based Model of the VM-Series Firewall for Public Clouds (no auth
code) in order to acvate your premium support entlement.

For usage-based models of the VM-Series firewall in the AWS Marketplace, instances with
short and long AWS instance IDs are supported.

Unl you acvate the license on the VM-Series firewall, the firewall does not have a serial number,
the MAC address of the dataplane interfaces are not unique, and only a minimal number of
sessions are supported. Because the MAC addresses are not unique unl the firewall is licensed,
to prevent issues caused by overlapping MAC addresses, make sure that you do not have mulple,
unlicensed VM-Series firewalls.

When you acvate the license, the licensing server uses the UUID and the CPU ID of the virtual
machine to generate a unique serial number for the VM-Series firewall. The capacity auth code in
conjuncon with the serial number is used to validate your entlement.

The VM-Series firewall License tab displays a standard VM-300 license file for all license
models. To find your specific license model informaon, view the system info in the UI, or
the use the CLI to view system info.

Aer you license a VM-Series firewall, if you need to delete and redeploy the VM-Series
firewall, make sure to Deacvate the License(s) on the firewall. Deacvang the license
allows you to transfer the acve licenses to a new instance of the VM-Series firewall
without help from technical support.

• Acvate the License for the VM-Series Firewall (Standalone Version)
• Acvate the License for the VM-Series Firewall for VMware NSX
• Troubleshoot License Acvaon Issues

Acvate the License for the VM-Series Firewall (Standalone Version)
If you have not elected to use the bootstrapping workflow using a subscripon bundle, you must
deploy the VM-Series firewall and complete inial configuraon before you can acvate the
license on your VM-Series firewall.

• Direct internet access
• No internet access
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Direct internet access

To acvate the license, the firewall must be configured with an IP address, netmask, default
gateway, and DNS server IP address.

The firewall must have a valid DNS configuraon and have network connecvity to access the
Palo Alto Networks licensing server.

1. Select Device > Licenses and select the Retrieve license keys from license server link.
2. The firewall will connect to the update server (updates.paloaltonetworks.com), and

download the license and reboot automacally.
3. Log back in to the web interface and confirm that the Dashboard displays a valid serial

number. If the term Unknown displays, it means the device is not licensed.
4. On Device > Licenses, verify that PA-VM license is added to the device.

If you see an error message, check Troubleshoot License Acvaon Issues.

No internet access
1. Select Device > Licenses and click the Acvate Feature using Auth Code link.
2. Click Download Authorizaon File, and download the authorizaonfile.txt on the client

machine.
3. Copy the authorizaonfile.txt to a computer that has access to the internet and log in to

the support portal. Click My VM-Series Auth-Codes link and select the applicable auth
code from the list and click the Register VM link.

4. On the Register Virtual Machine tab upload the authorizaon file. Select the PAN-OS
version and the hypervisor on which you have deployed the firewall, to complete the

VM-Series Deployment Guide Version Version 10.1 139 ©2022 Palo Alto Networks, Inc.



License the VM-Series Firewall

registraon process. The serial number of your VM-Series firewall will be aached to
your account records.

5. Navigate to Assets > My Devices and search for the VM-Series device just registered
and click the PA-VM link. This will download the VM-Series license key to the client
machine.

6. Copy the license key to the machine that can access the web interface of the VM-Series
firewall and navigate to Device > Licenses.

License keys must be installed through the web interface. The firewall does not
support license key installaon through SCP or FTP.

7. Click Manually Upload License link and enter the license key. When the capacity license
is acvated on the firewall, a reboot occurs.

8. Log in to the device and confirm that the Dashboard displays a valid serial number and
that the PA-VM license displays in the Device > Licenses tab.

Acvate the License for the VM-Series Firewall for VMware NSX
Panorama serves as the central point of administraon for the VM-Series firewalls for VMware
NSX and the license acvaon process is automated when Panorama has direct internet access.
Panorama connects to the Palo Alto Networks update server to retrieve the licenses, and when a
new VM-Series firewall for NSX is deployed, it communicates with Panorama to obtain the license.
If Panorama is not connected to the internet, you need to manually license each instance of the
VM-Series firewall so that the firewall can connect to Panorama.

For this integrated soluon, the auth code (for example, PAN-VM-1000-HV-SUB-BND-NSX2)
includes licenses for threat prevenon, URL filtering and WildFire subscripons and premium
support for the requested period.

In order to acvate the license, you must have completed the following tasks:

• Registered the auth code to the support account. If you don’t register the auth code, the
licensing server will fail to create a license.
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• Entered the auth code in the Service Definion on Panorama. On Panorama, select VMware
Service Manager to add the Authorizaon Code to the VMware Service Definion.

If you have purchased an evaluaon auth code, you can license up to 5 VM-Series
firewalls with the VM-1000-HV capacity license for a period of 30 or 60 days. Because
this soluon allows you to deploy one VM-Series firewall per ESXi host, the ESXi cluster
can include a maximum of 5 ESXi hosts when using an evaluaon license.

The following process of acvang the licenses is manual. If you have a custom script or an
orchestraon service, you can use the Licensing API to automate the process of retrieving the
licenses for the VM-Series firewalls.

• Acvate Licenses on VM-Series Firewalls on NSX When Panorama has Internet Access
• Acvate Licenses on VM-Series Firewalls on NSX When Panorama has No Internet Access
• Troubleshoot License Acvaon Issues

Activate Licenses on VM-Series Firewalls on NSX When Panorama has Internet Access

Complete the following procedure to acvate the VM-Series firewall for NSX when Panorama has
access to the internet.

STEP 1 | Verify that the VM-Series firewall is connected to Panorama.
1. Log in to Panorama.
2. Select Panorama > Managed Devices and check that the firewall displays as Connected.

STEP 2 | Verify that each firewall is licensed.

Select Panorama > Device Deployment > Licenses and verify that Panorama has matched the
auth code and applied the licenses to each firewall.

If you do not see the licenses, click Refresh. Select the VM-Series firewalls for which to retrieve
subscripon licenses and click OK.

Activate Licenses on VM-Series Firewalls on NSX When Panorama has No Internet Access

Complete the following procedure to acvate the VM-Series firewall for NSX when Panorama
does not have access to the internet.

STEP 1 | Locate the CPU ID and UUID of the VM-Series firewall.
1. From the vCenter server obtain the IP address of the firewall.
2. Log into the web interface and select Dashboard.
3. Get the CPU ID and the UUID for the firewall from the General Informaon widget.
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STEP 2 | Acvate the auth code and generate the license keys.
1. Log in to the Palo Alto Networks Customer Support website with your account

credenals. If you need a new account, see Create a Support Account.
2. Select Assets > VM-Series Auth Codes, click Add VM-Series Auth Codes to enter the

auth code.
3. Select Register VM in the row that corresponds to the auth code that you just registered,

enter the CPU ID and the UUID of the firewall and click Submit. The portal will generate
a serial number for the firewall.

4. Select Assets > Devices and search for the serial number.
5. Click the link the Acons column to download each key locally to your laptop. In addion

to the subscripon license key, you must get the capacity license and the support license
keys.

STEP 3 | Upload the keys to the firewall.
1. Log in to the firewall web interface.
2. Select Device > Licenses, and select Manually upload license key.
3. Browse to select a key and click OK to install the license on the firewall.

Install the capacity license key file (pa-vm.key) first. When you apply the
capacity license key, the VM-Series firewall will reboot. On reboot, the firewall
will have a serial number that you can use to register the firewall as a managed
device on Panorama.

4. Repeat the process to install each key on the firewall.
5. Select Dashboard and verify that you can see the Serial # in the General Informaon

widget.

STEP 4 | Add the serial number of the firewall on Panorama.

Select Panorama > Managed Devices and click Add to enter the serial number for the VM-
Series firewall for NSX. The firewall should now be able to connect with Panorama so that it
can obtain its configuraon and policy rules.

Troubleshoot License Acvaon Issues
Some of the most common issues with acvang your license are covered in this secon.

Licensing a PA-VM without sufficient memory causes an error similar to the following:

Server error : failed key check : Resource check failed.
      Memory needed: 6.5GB, allocated memory: 4.8GB

To fix this problem, provision the addional memory the license requires, and fetch the license
with the command request license fetch.

If you use any other command it will fail with the following error:

Server error : failed to fetch license: Cannot apply a provisioning
 license feature to an already provisioned device.
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If you see an error that reads Failed to fetch licenses. Failed to get license info. Please try again
later or a generic communicaons error message displays.

Verify the following:

• Can the firewall route traffic to the Palo Alto Networks server using a service route? By
default, the firewall uses the management interface to access the server. If you plan on using
a dataplane interface, make sure that you have set up a service route.

• Is roung over the internet working? SSH into the firewall and ping an publicly accessible
IP address such as 4.2.2.2. Be sure to use the source opon if you are using a dataplane
interface. For example: ping count 3 source 10.0.1.1 host 4.2.2.2.

• Is DNS set up correctly? SSH into the firewall and ping a DNS name such as google.com. For
example:
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If you see an error that reads Invalid Auth Code:

Verify the following:

• You have entered the auth code properly.
• You have registered the auth code to your account on the support portal.
• Your auth code has not reached the maximum provisioning capacity for the VM-Series

firewalls.

• For legacy licenses, log in to the CSP and select Assets > VM-Series Auth-Codes.
• For Soware NGFW Credits, if you know the deployment profile, log in to the CSP and

select Assets > Soware NGFW Credits, locate your profile, and click Details.

You can also select Assets > Soware NGFW Devices and search by Auth-Code.

Register the VM-Series Firewall
When you purchase a VM-Series firewall, you receive an email that includes an auth code for a
capacity license for the VM-Series model, a support entlement auth code, and one or more auth
codes for the subscripon licenses. To use the auth code(s), you must register the code to the
support account on the Palo Alto Networks Customer Support website. In the case of the VMware
integrated NSX soluon, the email contains a single authorizaon code that bundles the capacity
license for one or more instances of the VM-Series model, the support entlement, and one or
more subscripon licenses.

For the usage-based licenses in public clouds (AWS, Azure, or Google Cloud Plaorm), you do not
receive an auth code. However, in order to acvate your premium support entlement with Palo
Alto Networks, you must create a support account and register the VM-Series firewall on the Palo
Alto Networks Customer Support website.

Use the instrucons in this secon to register the capacity auth code or firewall with your support
account:

• Register the VM-Series Firewall (Soware NGFW Credits)
• Register the VM-Series Firewall (with auth code)
• Register the Usage-Based Model of the VM-Series Firewall for Public Clouds (no auth code)

Register the VM-Series Firewall (with auth code)
Complete the following procedure to register your VM-Series firewall with an auth code.

STEP 1 | Log in to the Palo Alto Networks Customer Support website with your account credenals. If
you need a new account, see Create a Support Account.

STEP 2 | Select Assets > VM-Series Auth-Codes > Add VM-Series Auth-Code.
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STEP 3 | In the Add VM-Series Auth-Code field, enter the capacity auth code you received by email,
and click the checkmark on the far right to save your input. The page will display the list of
auth codes registered to your support account.

You can track the number of VM-Series firewalls that have been deployed and the number of
licenses that are sll available for use against each auth code. When all the available licenses
are used, the auth code does not display on the VM-Series Auth-Codes page. To view all the
assets that are deployed, select Assets > Devices.

Register the Usage-Based Model of the VM-Series Firewall for Public Clouds (no auth
code)

To register usage-based firewalls on the Palo Alto Networks Customer Support Portal (CSP) you
can use automac registraon or manual registraon. The automac registraon of the usage-
based firewalls enables you to seamlessly register the firewall as soon as you launch it and access
the site license entlements associated with your CSP account. For details, see Install a Device
Cerficate on the VM-Series Firewall.

Use the following workflow to manually register your VM-Series firewalls. Before you begin the
manual registraon process, log in to the VM-Series firewall and jot down the serial number and
the CPU ID (UUID is oponal) from the dashboard.
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STEP 1 | Log in to the Palo Alto Networks Customer Support website, and click Assets > Devices >
Register New Devices.

1. Select Register usage-based VM-Series models (hourly/annual) purchased from public
cloud Marketplace or Cloud Security Service Provider (CSSP).

2. Select your Cloud Marketplace vendor and click Next.
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STEP 2 | Enter the Serial #, the CPU ID, and the UUID of the VM-Series firewall.

For example, from the Dashboard of the VM-Series firewall on your VM you will see the
following informaon.

If you plan to use the firewall offline, please select the Offline checkbox and enter the
PAN-OS version you plan to use.

STEP 3 | Agree and Submit to accept the EULA and register the firewall.

STEP 4 | Verify that the details on the licenses you purchased are displayed on the CSP Assets page.

Install a Device Cerficate on the VM-Series Firewall
The firewall requires a device cerficate to retrieve the site license entlements and securely
access cloud services such as WildFire, AutoFocus, and Cortex Data Lake. There are two methods
for applying a site license to your VM-Series firewall—One-me password and auto-registraon
PIN. Each password or PIN is generated on the Customer Support Portal (CSP) and unique to your
Palo Alto Networks support account. The method you use depends on the license type used to
deploy your firewall and if your firewalls are managed by Panorama.

• One Time Password—For VM-Series firewalls that have already been registered with Palo Alto
Networks licensing server, you must generate a One-Time Password on the Customer Support
Portal and apply it to your VM-Series firewall. Use this method for VM-Series firewalls with
a BYOL or ELA license in small-scale, unmanaged deployments and manually-deployed VM-
Series firewalls managed by Panorama.

• Registraon PIN—This method allows you to apply a site license to your VM-Series firewall at
inial startup. Use this method for VM-Series firewalls with usage-based licenses (PAYG), that
you bootstrap at launch or with any type of automated deployment, regardless of license type.
The auto-registraon PIN enables you to automacally register your usage-based firewalls at
launch with the CSP and retrieve site licenses.

For the VM-Series firewall on NSX-T, you can add the auto-registraon PIN to your service
definion configuraon so the device cerficate is fetched by the firewall upon inial boot up.
See the service definion configuraon for NSX-T (North-South) and NSX-T (East-West) for more
informaon. If you upgrade previously-deployed firewalls to PAN-OS version that supports device
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cerficates, you can apply a device cerficate to the those firewalls individually using a one-me
password.

One-me passwords and auto-registraon PINs must be used before they expire. If you do not,
you must return to the CSP to generate a new one.

Enable the firewalls to retrieve the site licenses automacally at launch.

The firewall requires the device cerficate to get the site license entlements and securely
access the cloud services. To retrieve the site licenses when you launch the firewall, in the
bootstrap package you must include the authcode in the /license folder, and add the auto
registraon PIN ID and value in the init-cfg.txt file and place it in the /config folder. Adding the
auto registraon PIN ID and value also enable auto-registraon of the PAYG or usage-based
instances on the VM-Series firewall.

1. Log in to the Customer Support Portal (CSP).
2. Generate the VM-Series registraon PIN.

Select Assets > Device Cerficates > Generate Registraon PIN. Save the PIN ID and value.
Make sure to launch the firewall before the PIN expires.

3. Add the registraon PIN ID and value in the init-cfg.txt file.

In addion to the required parameters, you must include:

vm-series-auto-registration-pin-id=

vm-series-auto-registration-pin-value=

4. Log in to the firewall and verify that you can see the site license on the firewall.
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Generate the one-me password (OTP) and manually retrieve the device cerficate on the
firewall.

The firewall requires this device cerficate to get the site license entlements and securely
access the cloud services.

1. Log in to the Customer Support Portal.

Register your VM-Series firewall, if you have not already.
2. Select Assets > Device Cerficates > Generate OTP.

3. Select your firewall from the list to Generate OTP.
4. Log in to the firewall, and retrieve the device cerficate.

Select Setup > Management > Device Cerficate and Get Cerficate

5. Verify that the device cerficate is fetched and that you can see the site license on the
firewall.

If using Panorama to manage the VM-Series firewall, see Install the device cerficate on a
managed firewall.

Switch Between the BYOL and the PAYG Licenses
The VM-Series firewall cannot be converted between the BYOL and PAYG licensing opons. If
you have already deployed and configured a VM-Series firewall with the PAYG or BYOL opon
in AWS, Azure, or Google Cloud Plaorm, and now want to switch to the other opon, use the
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following instrucons to save and export the configuraon on your exisng firewall, deploy a new
firewall, and then restore the configuraon on the new firewall.

STEP 1 | Save a backup of the current configuraon file and store it to an external server.
1. Select Device > Setup > Operaons and Export named configuraon snapshot.
2. Select the XML file that contains your running configuraon (for example, running-

config.xml) and click OK to export the configuraon file.
3. Save the exported file to a locaon external to the firewall.

STEP 2 | Deploy a new firewall and register or acvate the license, as appropriate.

For a new PAYG instance:

1. In the AWS, Azure, or Google Cloud Plaorm Marketplace, select the soware image for
the PAYG licensing bundle you want to deploy.

2. Deploy a new VM-Series firewall in the AWS, Azure, or Google public cloud. See Set Up
the VM-Series Firewall on AWS, Set up the VM-Series Firewall on Azure, or Set Up the
VM-Series Firewall on Google Cloud Plaorm.

3. Register the Usage-Based Model of the VM-Series Firewall for Public Clouds (no auth
code).

For a new BYOL instance:

1. Contact your sales representave or reseller to purchase a BYOL license, and get a BYOL
auth code that you can use to license your firewall.

2. Register the VM-Series Firewall (with auth code).
3. Deploy a new VM-Series firewall in the AWS or Azure public cloud. See Set Up the VM-

Series Firewall on AWS, Set up the VM-Series Firewall on Azure or Set Up the VM-Series
Firewall on Google Cloud Plaorm.

4. Acvate the License for the VM-Series Firewall (Standalone Version).

STEP 3 | On the newly deployed firewall, restore the configuraon that you exported.
1. Access the web interface of the newly deployed firewall.
2. Select Device > Setup > Operaons, click Import named configuraon snapshot, Browse

to the configuraon file on the external host, and click OK.
3. Click Load named configuraon snapshot, select the Name of the configuraon file you

just imported, and click OK.
4. Click Commit to overwrite the running configuraon with the snapshot you just

imported.
5. Verify that the configuraon on the new firewall matches the firewall that you are

replacing, before you delete the firewall or deacvate the licenses on the replaced
firewall.

Switch Between VM-Series Model Licenses
You can switch the license of your currently-deployed VM-Series firewall with the BYOL opon.
For example, you can move from a subscripon bundle to an enterprise license agreement (ELA)
and vice versa, without disrupng traffic moving through the firewall. You can also switch the
license on an individual firewall or on mulple firewalls simultaneously from Panorama.

VM-Series Deployment Guide Version Version 10.1 150 ©2022 Palo Alto Networks, Inc.



License the VM-Series Firewall

Do not use this procedure for switching ELA or perpetual licenses between PAYG and
BYOL. See Switch Between the BYOL and the PAYG Licenses for more informaon.

Complete one of the following procedures to perform one of the following license changes:

• Subscripon bundle 1 to subscripon bundle 2
• Subscripon bundle 1 or 2 to an ELA
• Capacity license to subscripon bundle or ELA

Before switching to an ELA license, you must allocate enough tokens to support the number of
currently-deployed VM-Series firewalls. See VM-Series Enterprise License Agreement (Mul-
Model ELA) for more informaon about the tokens required for each VM-Series model.
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Switch a license on a standalone firewall.
1. Register your authorizaon code.

• For a subscripon bundle, register your new authorizaon code.
• For an ELA, acvate the ELA authorizaon code.

Do not use the ELA authorizaon code to acvate individual VM-Series
firewalls. Aer registering your ELA, use the VM-Series model authorizaon
codes to acvate individual firewalls. You can find these authorizaon codes
on the Customer Support Portal under Assets > VM-Series Auth-Codes.

2. Log in to the VM-Series firewall web interface.
3. Verify the Palo Alto Networks update server configuraon.

1. Select Device > Setup > Services.
2. Confirm that Update Server is set to updates.paloaltonetworks.com.
3. Confirm that Update Server Identy is selected.

4. Apply a VM-Series authorizaon code. A firewall authorizaon code for an ELA begins
with the leer A, as shown below.

1. Select Device > Licenses and select the Acvate feature using authorizaon code
link.

2. Enter your VM-Series authorizaon code.
3. Click OK to confirm the license upgrade.The firewall contacts the Palo Alto Networks

update server and consume the tokens required for your firewall based on the VM-
Series model.

4. Verify the license updated successfully by checking the license expiraon date.
5. Repeat this process for each VM-Series firewall in your deployment.
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Switch licenses on managed firewalls using Panorama.
1. Register your authorizaon code.

• For a subscripon bundle, register your new authorizaon code.
• For an ELA, acvate the ELA authorizaon code.

Do not use the ELA authorizaon code to acvate individual VM-Series
firewalls. Aer registering your ELA, use the VM-Series model authorizaon
codes to acvate individual firewalls. You can find these authorizaon codes
on the Customer Support Portal under Assets > VM-Series Auth-Codes.

2. Log in to the Panorama web interface.
3. Verify the Palo Alto Networks update server configuraon for the firewalls.

1. Select Device > Setup > Services.
2. Confirm that Update Server is set to updates.paloaltonetworks.com.
3. Confirm that Update Server Identy is selected.

4. Apply a VM-Series authorizaon code. A firewall authorizaon code for an ELA begins
with the leer A, as shown below.

1. Select Panorama > Device Deployment > Licenses and click Acvate.
2. Enter your VM-Series authorizaon code.
3. Use the filters to select the managed firewalls to be licensed.
4. Enter your authorizaon code in the Auth Code column for each firewall.
5. Click Acvate to confirm the license upgrade.Panorama contacts the Palo Alto

Networks update server and consume the tokens required for your firewalls based on
the VM-Series model.

6. Verify the license updated successfully by checking the license expiraon date.
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Deacvate License(s)
The license deacvaon process enables you to self-manage licenses. Whether you want to
remove one or more acve licenses or subscripons aributed to a firewall (hardware-based
or VM-Series firewall) or you want to deacvate the VM-Series firewall and unassign all acve
licenses and subscripons, begin the deacvaon process on the firewall or Panorama (not on the
Palo Alto Networks Customer Support web site).

To successfully deacvate a license, you must install a license deacvaon API key and enable
verificaon of the update server identy (enabled by default). PAN-OS uses this deacvaon API
key to authencate with all update a license services. The deacvaon API is key is not required
for manual license deacvaon, where there is not connecvity between the firewall and license
server.

If the firewall/Panorama has internet access and can communicate with the Palo Alto Networks
Licensing servers, the license removal process completes automacally with a click of a buon.
If the firewall/Panorama does not have internet access, you must complete the process manually
in a two-step process. In the first step, from the firewall or Panorama, you generate and export
a license token file that includes informaon on the deacvated keys. In the second step, while
logged in to the Palo Alto Networks Customer Support website, upload the token file to dissociate
the license keys from the firewall.

• Deacvate a Feature License or Subscripon Using the CLI
• Deacvate VM

Deacvate a Feature License or Subscripon Using the CLI
If you installed a license/subscripon on a firewall and need to reassign it to another firewall, you
can deacvate the individual license and re-use the same authorizaon code on another firewall
without help from Technical Support. This capability is supported in the CLI only and is supported
on both physical and virtual devices running PAN-OS. This procedure is typically used with fixed-
model perpetual or ELA licenses.

• Internet Access (Auto Mode)
• No Internet Access (Manual Mode)

Internet Access (Auto Mode)

STEP 1 | Log into the CLI on the firewall.

STEP 2 | View the name of the license key for the feature you want to deacvate.

request license deactivate key features

STEP 3 | Deacvate the license or subscripon.

Use the auto mode to remove the license key.

request license deactivate key features <name> mode auto

The name is the full name for the license key file. For example:

admin@vmPAN2> request license deactivate key features <name>

WildFire_License_2015_01_28_I5820573.key mode auto007200002599
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WildFire License Success
Successfully removed license keys

No Internet Access (Manual Mode)

Use manual mode to remove the license key and generate a license token for a model-based
license. This procedure assumes you have installed the license API key on your firewall.

STEP 1 | Log into the CLI on the firewall.

STEP 2 | View the name of the license key for the feature you want to deacvate.

request license deactivate key features

STEP 3 | Deacvate the license manually from the command line.

request license deactivate key features <name> mode manual

For example:

admin@PA-VM> request license deactivate key features

PAN_DB_URL_Filtering_2015_01_28_I6134084.key mode manual
Successfully removed license keys
dact_lic.01282015.100502.tok

The token file uses the format dact_lic.timestamp.tok, where the mestamp is in the
dmmyyyy.hrminsec format.

STEP 4 | Verify that the token file was generated.

show -token-files

STEP 5 | Export the token file.

Enter this command on a single line:

scp export license-token-file to <username@serverIP>

from <token_filename>

For example:

scp export license-token-file to admin@10.1.10.55:/tmp/ from
dact_lic.01282015.100502.tok
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STEP 6 | Log into the Palo Alto Networks Customer Support portal.
1. Click the Deacvate License(s) link on the Assets tab.
2. Select Assets > VM-Series Auth-Codes and select Deacvate License(s).
3. Upload the token file to complete the deacvaon.

Deacvate VM
When you no longer need a BYOL instance of the VM-Series firewall, you can free up all acve
licenses (subscripon licenses, model-based capacity licenses, and support entlements) from the
web interface, the CLI, or the XML API on the firewall or Panorama. The licenses are credited back
to your account and you can use the same authorizaon codes on a different instance of the VM-
Series firewall.

Deacvang a VM removes all the licenses/entlements and places the VM-Series firewall in
an unlicensed state; the firewall will not have a serial number and can support only a minimal
number of sessions. Because the configuraon on the firewall is le intact, you can re-apply a set
of licenses and restore complete funconality on the firewall, if needed.

Make sure to deacvate licenses before you delete the VM-Series firewall. If you delete the
firewall before deacvang the licenses, you have two opons:

Managed by Panorama—Deacvate the license from Panorama.

Not managed by Panorama—Contact Palo Alto Networks Customer Support for
deacvaon assistance.

• Deacvate the VM from the Firewall
• Deacvate the VM from Panorama

Deactivate the VM from the Firewall

Complete the following process to deacvate the VM license from the firewall.

STEP 1 | Log into the web interface and select Device > Licenses.
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STEP 2 | In the License Management secon, select Deacvate VM.

You can only see this opon on a VM. It is not there on a physical firewall.

STEP 3 | Verify the list of licenses/entlements to be deacvated on the firewall.

STEP 4 | Pick one of the following opons to start deacvang the VM:

• (Internet access to the Palo Alto Networks Licensing server) Select Connue.

You are prompted to reboot the firewall; on reboot the licenses are deacvated.
• (No internet)—Select Complete Manually.

Click the Export license token link to save the token file to your local computer. Here is a
sample token filename: 20150128_1307_dact_lic.01282015.130737.tok

You are prompted to reboot the firewall; on reboot the licenses are deacvated.

STEP 5 | (Manual Process—no internet) Use the token file to register the changes with the Licensing
server:
1. Log into the Palo Alto Networks Customer Support website.
2. Select Assets > VM-Series Auth-Codes > Deacvate License(s).
3. While logged in to the Palo Alto Networks Customer Support website, upload the token

file to complete the deacvaon.

Deactivate the VM from Panorama

Complete the following process to deacvate a VM license from Panorama.

STEP 1 | Log in to the Panorama web interface and select Panorama > Device Deployment > Licenses.
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STEP 2 | Deacvate VMs and select the VM-Series firewall that you want to deacvate.

STEP 3 | Pick one of the following opons to deacvate the VM:

• Connue—If Panorama can communicate directly with the Palo Alto Networks Licensing
servers and can register the changes. To verify that the licenses have been deacvated on
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the firewall, select Refresh on Panorama > Device Deployment > Licenses. The firewall is
automacally rebooted.

• Complete Manually—If Panorama does not have internet access, Panorama generates a
token file.

Click the Export license token link to save the token file to your local computer. Here is a
sample token filename: 20150128_1307_dact_lic.01282015.130737.tok

The successful compleon message is displayed on-screen, and the firewall is automacally
rebooted.

STEP 4 | (Manual process only—no internet) Use the token file to register the changes with the
licensing server.
1. Log into the Palo Alto Networks Customer Support website.
2. Select Assets > VM-Series Auth-Codes > Deacvate License(s).
3. Upload the token file to complete the deacvaon.

STEP 5 | Remove the deacvated VM-Series firewall as a managed device on Panorama.
1. Select Panorama > Managed Devices.
2. Select the firewall that you deacvated from the list of managed devices, and click

Delete.

Instead of deleng the firewalls, if you prefer, you can create a separate device
group and assign the deacvated VM-Series firewalls to this device group.

Renew VM-Series Firewall License Bundles
When your VM-Series firewall bundle licenses are due for renewal, you can log in to the Palo
Alto Networks Customer Support Portal and adjust the license quanty to meet your deployment
needs. At renewal, you can review your usage trends and based your future needs, pick from the
following opons:
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• Renew—You can opt to renew all licenses as is, or to increase or decrease the licensed quanty.
If you decrease the number of licenses you need, you must opt to get a basic bundle for the
firewalls you are not renewing, otherwise you will forfeit the poron that you do not renew. If
you increase the license quanty, the addion is added to your exisng auth code.

• Change to Basic Bundle—If you have a VM-Series bundle 1 or a bundle 2 license that includes
subscripons, you can change to a basic bundle that includes a perpetual capacity license and
support entlement. When you switch to the basic bundle, you retain the VM-Series firewall
model that you had previously purchased. All firewalls that are currently deployed and are
associated with the exisng auth code will connue to funcon, and the support entlement
will have a new expiraon date. For any unprovisioned firewalls, you’ll receive a new auth code
that you can use to deploy new instances.

• Forfeit—Relinquish the licenses that you no longer need. If you have deployed the firewalls
that you don't want to renew, you need to select the serial number of the instances for which
you want to disconnue renewals. You can connue to use these firewall instances with the
soware and content versions that are currently installed, but your subscripons and support
entlements are no longer valid. And to forfeit the license of VM-Series firewalls that you have
not provisioned, just select the quanty that you want to forfeit.

STEP 1 | Log in to the Palo Alto Networks Customer Support Portal with your account credenals.

STEP 2 | Select Assets > VM-Series Auth-Codes and find the auth code you want to renew.

The Renew opon displays for auth codes that are eligible for renewal.
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STEP 3 | Click the Renew link to select the serial numbers to Renew, Change to Basic Bundle, or
Forfeit.

If you have provisioned the firewall, select the appropriate opon in the row that corresponds
to the Serial Number. If you have unprovisioned instances of the firewall, select the quanty
for each renewal opon you choose under Unprovisioned VM Renewal Sengs.

STEP 4 | Save your changes.

You will receive an onscreen confirmaon that your changes are submied for processing.
Aer subming your changes, if you select Renew again, you can view the status of your
request against each serial number. If renewal processing has started, and you need to make
addional revisions, you will be unable to save changes. For assistance, you can contact the
renewals team at renewals@paloaltonetworks.com.
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What Happens When Licenses Expire?
Palo Alto Networks VM-Series firewall licenses and subscripons provide the firewall with added
funconality and/or access to a Palo Alto Networks cloud-delivered service. When a license
is within 30 days of expiraon, a warning message displays in the system log daily unl the
subscripon is renewed or expires. Upon license expiraon, some subscripons connue to
funcon in a limited capacity, and others stop operang completely. Here you can find out what
happens when each subscripon expires.

The precise moment of license expiry is at the beginning of the following day at 12:00 AM
(GMT). For example, if your license is scheduled to end on 1/20 you will have funconality
for the remainder of that day. At the start of the new day on 1/21 at 12:00 AM (GMT),
the license will expire. All license-related funcons operate on Greenwich Mean Time
(GMT), regardless of the configured me zone on the firewall.

License Expiry Behavior

VM-Series You can sll:

• You can connue to configure and use the firewall(s)
you deployed prior to the license expiring with no
change in session capacity. The firewall(s) will not reboot
automacally and cause a disrupon in traffic.

However, if the firewall reboots for any reason, the
firewall enters an unlicensed state. While unlicensed, the
number of supported sessions is limited to 1200. No other
management plane features or configuraon opons are
restricted.

Threat Prevenon Alerts appear in the System Log indicang that the license has
expired.

You can sll:

• Use signatures that were installed at the me the license
expired, unless you install a new Applicaons-only content
update either manually or as part of an automac schedule.
If you do, the update will delete your exisng threat
signatures and you will no longer receive protecon against
them.

• Use and modify Custom App-ID™ and threat signatures.

You can no longer:

• Install new signatures.
• Roll signatures back to previous versions.

DNS Security You can sll:
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License Expiry Behavior
• Use local DNS signatures if you have an acve Threat

Prevenon license.

You can no longer:

• Get new DNS signatures.

Advanced URL Filtering / URL
Filtering

You can sll:

• Enforce policy using custom URL categories.
• Enforce policy using PAN-DB categories that were in your

local cache when the license expired.

You can no longer:

• Get updates to cached PAN-DB categories.
• Connect to the PAN-DB URL filtering database.
• Get PAN-DB categories of uncached URLs.
• Analyze URL requests in real-me using advanced URL

filtering.

WildFire You can sll:

• Forward PEs for analysis.
• Get signature updates every 24-48 hours if you have an

acve Threat Prevenon subscripon.

You can no longer:

• Get five-minute updates through the WildFire public and
private clouds.

• Forward advanced file types such as APKs, Flash files,
PDFs, Microso Office files, Java Applets, Java files (.jar
and .class), and HTTP/HTTPS email links contained in SMTP
and POP3 email messages.

• Use the WildFire API.
• Use the WildFire appliance to host a WildFire private cloud

or a WildFire hybrid cloud.

AutoFocus You can sll:

• Use an external dynamic list with AutoFocus data for a
grace period of three months.

You can no longer:

• Access the AutoFocus portal.
• View the AutoFocus Intelligence Summary for Monitor log

or ACC arfacts.
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License Expiry Behavior

Cortex Data Lake You can sll:

• Store log data for a 30-day grace period, aer which it is
deleted.

• Forward logs to Cortex Data Lake unl the end of the 30-
day grace period.

GlobalProtect You can sll:

• Use the app for endpoints running Windows and macOS.
• Configure single or mulple internal/external gateways.

You can no longer:

• Access the Linux OS app and mobile app for iOS, Android,
Chrome OS, and Windows 10 UWP.

• Use IPv6 for external gateways.
• Run HIP checks.
• Use Clientless VPN.
• Enforce split tunneling based on desnaon domain, client

process, and video streaming applicaon.

Support You can no longer:

• Receive soware updates.
• Download VM images.
• Benefit from technical support.
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Licenses for Cloud Security Service Providers (CSSPs)
The Palo Alto Networks CSSP partners program allows service providers to provide security as
a service or as a hosted applicaon to their end customers. The license offerings that Palo Alto
Networks provides for authorized Cloud Security Service Provider (CSSP) partners are different
from the offerings for enterprise users.

For CSSP partners, Palo Alto Networks supports a usage-based model for the VM-Series firewalls
bundled with subscripons and support. CSSP partners can combine a term-based capacity
license for the VM-Series Models with a choice of subscripon licenses for Threat Prevenon,
URL Filtering, AutoFocus, GlobalProtect, and WildFire, and support entlements that provide
access to technical support and soware updates. If you plan on deploying the firewalls in an HA
configuraon, you can purchase the cost-effecve high availability opon.

• Get the Auth Codes for CSSP License Packages
• Register the VM-Series Firewall with a CSSP Auth Code
• Add End-Customer Informaon for a Registered VM-Series Firewall

Get the Auth Codes for CSSP License Packages
To be a CSSP Partner, you have to enroll in the Palo Alto Networks CSSP partners program. For
informaon on enrolling in the CSSP program, contact your Palo Alto Networks Channel Business
Manager. If you are enrolled, the Palo Alto Network Support portal provides tools that allow you
to select a license package, track license usage, and apply license entlements.

A license package is a combinaon of the following opons:

• Usage term—The pay-per-use opons are hourly, monthly, 1-year, and 3-years.
• VM-Series firewall model—The VM-100, VM-200, VM-300, and VM-1000-HV that give you

the model number and the capacies associated with each model.
• Subscripon bundle—The three opons are basic, bundle 1, and bundle 2. The basic opon

does not include any subscripons; bundle 1 has the Threat Prevenon license that includes
IPS, AV, malware prevenon; bundle 2 has the Threat Prevenon (includes IPS, AV, malware
prevenon), DNS Security, GlobalProtect, WildFire, and PAN-DB URL Filtering licenses.

• Level of support—Premium support or backline support.
• Redundant firewalls—The opon are either high availability (HA) or without HA. This opon is a

cost-effecve opon if you plan to deploy a pair of redundant firewalls.

The offering PAN-VM-300-SP-PREM-BND1-YU, for example, is a one-year term package that
includes the VM-300 with premium support and the subscripon bundle 1. Each package supports
up to a maximum of 10,000 instances of the VM-Series firewall.

Aer you select your license package, you receive an email with your auth code; the fulfillment
process can take up to 48 hours.

STEP 1 | Log in to the Palo Alto Networks Customer Support website with your account credenals. If
you need a new account, see Create a Support Account.
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STEP 2 | Select CSSP > Order History, to view the list of auth codes registered to your support
account.

As you deploy firewalls, you must register each instance of the firewall against an auth code.

Register the VM-Series Firewall with a CSSP Auth Code
To acvate the license on your VM-Series firewall, you must have deployed the VM-Series firewall
and completed inial configuraon. As a CSSP partner, you can choose from the following opons
to register a firewall:

• API—Use the Licensing API if you have a custom script or an orchestraon service. With this
opon, the firewall does not need direct internet access.

• Bootstrap—Use this opon to automacally configure the firewall and license it on first boot.
See Bootstrap the VM-Series Firewall.

• Firewall web interface—You can Acvate the License for the VM-Series Firewall (Standalone
Version) using the firewall web interface. This workflow is valid for firewalls with or without
internet access.

• Customer Support Portal—Use this opon to manually register the firewall on the Palo Alto
Networks Customer Support portal, as shown below.

STEP 1 | Log in to the Palo Alto Networks Customer Support website with your account credenals. If
you need a new account, see Create a Support Account.

STEP 2 | Select CSSP > Order History, to view the list of auth codes registered to your support
account.

STEP 3 | Select CSSP > VM Provisioning Auth Codes, select an Authorizaon Code and click Register
VM.
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STEP 4 | Enter the UUID and CPUID of the VM instance and click Submit. The portal will generate a
serial number for the firewall.

You can track the number of VM-Series firewalls that have been deployed and the
number of licenses that are sll available for use against each auth code. To view all
the total number of firewalls registered against a specific auth code, select CSSP > VM
Provisioning Auth Codes, then select an Authorizaon Code and click Provisioned
Devices.

Add End-Customer Informaon for a Registered VM-Series
Firewall

For CSSP licensees, aer you register the firewall, you can use either the Palo Alto Networks
Support portal or the Licensing API to link the serial number of the VM-Series firewall with the
customer for whom you provisioned the firewall.

• Add End-Customer Informaon for a Registered VM-Series Firewall (Customer Support Portal).
The Support portal authencates with user name and password.

• Add End-Customer Informaon for a Registered VM-Series Firewall (API). The API
authencates using the Licensing API key.

Add End-Customer Informaon for a Registered VM-Series Firewall (Customer
Support Portal)

Complete the following procedure to add end-customer informaon for a registered firewall
through the Customer Support Portal.

STEP 1 | Log in to the Palo Alto Networks Customer Support website with your account credenals.

STEP 2 | Select CSSP > Provisioned Devices.
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STEP 3 | Select the Serial Number and click Add End User Info.
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STEP 4 | Enter the Account Informaon for the customer as follows.

• Customer Reference Id: Required
• Company Name: Required
• DNB #: Data Universal Numbering System (D-U-N-S) number
• Contact Email: Required, end-user email address
• Contact Phone Number: End-user phone number
• Address: Required, end-user address
• Country: Required, ISO 2-leer country code
• City: Required, end-user city name
• Region/State: Required; for the United States and Canada, you must enter an ISO 2-leer

subdivision code; for all other countries, any text string is valid
• Postal Code: Required, end-user postal code
• Company Website: End-user website URL
• Industry: End-user industry type, such as networking or consultancy

Click Submit to save the details.

Aer you add account informaon, you can find all firewalls registered to a customer.
In Search Exisng End User, enter the customer ID or customer name and click Search
to find all firewalls provisioned for the customer.

Add End-Customer Informaon for a Registered VM-Series Firewall (API)
The URL for accessing the API is hps://api.paloaltonetworks.com/api/license/
ReportEndUserInfo.

An API request must use the HTTP POST method, and you must include HTTP requests headers
that include the API key and specify the content type as JSON. API responses are in JSON format.

STEP 1 | Get your Licensing API key.
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STEP 2 | Use the ReportEndUserInfo API to add end-user informaon for a VM-Series Firewall that is
registered to a CSSP.

URL: https://api.paloaltonetworks.com/api/license/ReportEndUserInfo

Headers:

• Content-Type: applicaon/json
• apiKey: API Key

Parameters:

• SerialNumbers: Required, provide at least one valid firewall serial number

• CustomerReferenceId: Required

• CompanyName: Required, end-user company name

• DnBNumber: Data Universal Numbering System (D-U-N-S) number

• PhoneNumber: End-user phone number

• EndUserContactEmail: Required, end-user email address

• Address: Required, end-user address

• Country: Required, ISO 2-leer country code

• City: Required, end-user city name

• Region/State: Required; for the United States and Canada, you must enter an ISO 2-
leer subdivision code; for all other countries, any alpha string is valid

• PostalCode: Required, end-user postal code

• Industry: End-user industry type, such as networking or consultancy

• WebSite: End-user website URL

• CreatedBy: System or person subming this informaon

Sample request to add end-user informaon for a registered VM-Series firewall using Curl:

curl -X POST "http://api.paloaltonetworks.com/api/license/
ReportEndUserInfo" \-H "Content-Type: application/json" \-
H "apikey: your_key_here" \--data-raw '{ "SerialNumbers":
 ["0001A101234"], "CustomerAccountId": 12345, "CompanyName":
 "ExampleInc", "DnBNumber": "123456789", "Address": "123 Main St",
 "City": "Sunnydale", "Region": "CA", "State": "CA", "Country":
 "US", "PostalCode": "12345", "Industry": "Medical", "PhoneNumber":
 "4081234567", "WebSite": "example.com", "EndUserContactEmail":
 "admin@example.com", "CreatedBy": "Jane Doe"}'

Sample API response:

"{"Message": "End User Information Updated Successfully"}"

If you receive an error, see Licensing API Error Codes.
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Server

The VM-Series firewall is distributed in the Open Virtualizaon Alliance (OVA) format,
which is a standard method of packaging and deploying virtual machines. You can
install this soluon on any x86 device that is capable of running VMware ESXi.

In order to deploy a VM-Series firewall you must be familiar with VMware and
vSphere, including vSphere networking, ESXi host setup and configuraon, and virtual
machine guest deployment.

If you want to automate the process of deploying a VM-Series firewall, you can create
a gold standard template with the opmal configuraon and policies, then use the
vSphere API and the PAN-OS XML API to rapidly deploy new VM-Series firewalls in
your network.

See the following topics for informaon:

> Supported Deployments on VMware vSphere Hypervisor (ESXi)
> VM-Series on ESXi System Requirements and Limitaons
> Install a VM-Series firewall on VMware vSphere Hypervisor (ESXi)
> VM Monitoring on vCenter
> Troubleshoot ESXi Deployments
> Performance Tuning of the VM-Series for ESXi

171



Set Up a VM-Series Firewall on an ESXi Server

Supported Deployments on VMware vSphere
Hypervisor (ESXi)

You can deploy one or more instances of the VM-Series firewall on the ESXi server. Where
you place the VM-Series firewall on the network depends on your topology. Choose from the
following opons (for environments that are not using VMware NSX):

• One VM-Series firewall per ESXi host—Every VM server on the ESXi host passes through the
firewall before exing the host for the physical network. VM servers aach to the firewall via
virtual standard switches. The guest servers have no other network connecvity, therefore the
firewall has visibility and control over all traffic leaving the ESXi host. One variaon of this use
case is to also require all traffic to flow through the firewall, including server to server (east-
west) traffic on the same ESXi host.

• One VM-Series firewall per virtual network—Deploy a VM-Series firewall for every virtual
network. If you have designed your network such that one or more ESXi hosts has a group
of virtual machines that belong to the internal network, a group that belongs to the external
network, and a group that belongs to the DMZ, you can deploy a VM-Series firewall to
safeguard the servers in each group. If a group or virtual network does not share a virtual
switch or port group with any other virtual network, it is completely isolated from all other
virtual networks within or across the host(s). Because there is no other physical or virtual path
to any other network, the servers on each virtual network must use the firewall to talk to any
other network. The firewall has visibility and control over all traffic leaving the virtual (standard
or distributed) switch aached to each virtual network.

• Hybrid environment—Both physical and virtual hosts are used. The VM-Series firewall can
replace a physical firewall appliance in a tradional aggregaon locaon. A hybrid environment
achieves the benefits of a common server plaorm for all devices, and unlinks hardware and
soware upgrade dependencies.

Connue with VM-Series on ESXi System Requirements and Limitaons and Install a VM-Series
firewall on VMware vSphere Hypervisor (ESXi).
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VM-Series on ESXi System Requirements and
Limitaons

This secon lists requirements and limitaons for the VM-Series firewall on VMware vSphere
Hypervisor (ESXi). To deploy the VM-Series firewall, see Install a VM-Series firewall on VMware
vSphere Hypervisor (ESXi).

• VM-Series on ESXi System Requirements
• VM-Series on ESXi System Limitaons

VM-Series on ESXi System Requirements
You can create and deploy mulple instances of the VM-Series firewall on an ESXi server. Because
each instance of the firewall requires a minimum resource allocaon—number of CPUs, memory
and disk space—on the ESXi server, make sure to conform to the specificaons below to ensure
opmal performance.

The VM-Series firewall has the following requirements:

• The host CPU must be an x86-based Intel or AMD CPU with virtualizaon extension.
• See the Compability Matrix for supported versions of ESXi. The support for the vmx version

is based on the OVA that you use to deploy the VM-Series firewall, and you cannot modify this
version. Upgrading or downgrading the VM-Series soware version does not change the vmx
version that was enabled at launch.

• See VM-Series System Requirements for the minimum hardware requirements for your VM-
Series model.

• Minimum of two network interfaces (vNICs). One is a dedicated vNIC for the management
interface and one is for the data interface. You can then add up to eight more vNICs for data
traffic. For addional interfaces, use VLAN Guest Tagging (VGT) on the ESXi server or configure
subinterfaces on the firewall.

Hypervisor assigned MAC address are enabled by default. vSphere assigns a unique vNIC
MAC address to each dataplane interface of the VM-Series firewall. If you disable hypervisor
assigned MAC addresses, the VM-Series firewall assigns each interface a MAC address from its
own pool. Because this causes the MAC addresses on each interface to differ, you must enable
promiscuous mode on the port group of the virtual switch to which the firewall’s dataplane
interfaces are aached; this allows the firewall to receive frames (see Provision the VM-Series
Firewall on an ESXi Server). If neither promiscuous mode nor hypervisor assigned MAC address
is enabled, the firewall does not receive any traffic. This is because vSphere does not forward
frames to a virtual machine when the frame’s desnaon MAC address and the vNIC MAC
address do not match.

• Data Plane Development Kit (DPDK) is enabled by default on VM-Series firewalls on ESXi. For
more informaon about DPDK, see Enable DPDK on ESXi.
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• To achieve the best performance out of the VM-Series firewall, you can make the following
adjustments to the host before deploying the VM-Series firewall. See Performance Tuning of
the VM-Series for ESXi for more informaon.

• Enable DPDK. DPDK allows the host to process packets faster by bypassing the Linux
kernel. Instead, interacons with the NIC are performed using drivers and the DPDK
libraries.

• Enable SR-IOV. Single root I/O virtualizaon (SR-IOV) allows a single PCIe physical device
under a single root port to appear to be mulple separate physical devices to the hypervisor
or guest.

Do not configure a vSwitch on the physical port on which you enable SR-IOV. To
communicate with the host or other virtual machines on the network, the VM-Series firewall
must have exclusive access to the physical port and associated virtual funcons (VFs) on that
interface.

• Enable mul-queue support for NICs. Mul-queue allows network performance to scale
with the number of vCPUs and allows for parallel packet processing by creang mulple TX
and RX queues.

VM-Series on ESXi System Limitaons
The VM-Series firewall funconality is very similar to the Palo Alto Networks hardware firewalls,
but with the following limitaons:

• Do not use the VMware snapshots funconality on the VM-Series on ESXi. Snapshots can
impact performance and result in intermient and inconsistent packet loss.See the VMware
best pracce recommendaon for using snapshots.

If you need configuraon backups, use Panorama, or from the firewall, use Export named
configuraon snapshot (Device > Set up > Operaons). Using Export named configuraon
snapshot exports the firewall’s acve configuraon (running-config.xml) and allows you
to save it to any network locaon.

• Dedicated CPU cores are recommended.
• High Availability (HA) Link Monitoring is not supported on VM-Series firewalls on ESXi. Use

Path Monitoring to verify connecvity to a target IP address or to the next hop IP address.
• Up to 10 total ports can be configured; this is a VMware limitaon. One port is used for

management traffic and up to 9 can be used for data traffic.
• Only the vmxnet3 driver is supported.
• Virtual systems are not supported.
• vMoon of the VM-Series firewall is supported on vSphere 6.5, 6.7, and 7.0 if the ESXi hosts

have homogeneous CPU configuraon. PAN-OS 9.1.6 and later is required to Use vMoon to
Move the VM-Series Firewall Between Hosts installed on vSphere 6.5 or 6.7.

• Forged transmit and promiscuous mode must be enabled on the ESXi vSwitch port groups
connected to Layer 2 and vwire interfaces on the VM-Series firewall.

• To use PCI devices with the VM-Series firewall on ESXi, memory mapped I/O (MMIO) must be
below 4GB. You can disable MMIO above 4GB in your server’s BIOS. This is an ESXi limitaon.

• When using ESXi 7.0, interfaces do not come up when aaching VFs to virtual machines with
PCI device passthrough.
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Install a VM-Series firewall on VMware vSphere
Hypervisor (ESXi)

To install a VM-Series firewall you must have access to the Open Virtualizaon Alliance format
(OVA) template. Use the auth code you received in your order fulfillment email to register your
VM-Series firewall and download the OVA template. The OVA template is a zip archive that
contains three types of files:

• .mf: OVF manifest file that contains the SHA-1 digests of individual files in the package
• .ovf: OVF descriptor file that contains all metadata for the package and its contents
• .vmdk: Virtual disk image file that contains the virtualized version of the firewall

Complete the following tasks to install and configure the VM-Series firewall on ESXi.

• Plan the Interfaces for the VM-Series for ESXi
• Provision the VM-Series Firewall on an ESXi Server
• Perform Inial Configuraon on the VM-Series on ESXi
• (Oponal) Add Addional Disk Space to the VM-Series Firewall
• Use VMware Tools on the VM-Series Firewall on ESXi and vCloud Air
• Use vMoon to Move the VM-Series Firewall Between Hosts
• Use the VM-Series CLI to Swap the Management Interface on ESXi

Plan the Interfaces for the VM-Series for ESXi
By planning the mapping of VM-Series Firewall vNICs and interfaces, you can avoid reboots and
configuraon issues. The following table describes the default mapping between VMware vNICs
and VM-Series interfaces when all 10 vNICs are enabled on ESXi.

VMware vNIC VM-Series Interfaces

1 Ethernet 1/0 (mgmt)

2 Ethernet 1/1 (eth1)

3 Ethernet 1/2 (eth2)

4 Ethernet 1/3 (eth3)

5 Ethernet 1/4 (eth4)

6 Ethernet 1/5 (eth5)

7 Ethernet 1/6 (eth6)

8 Ethernet 1/7 (eth7)
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VMware vNIC VM-Series Interfaces

9 Ethernet 1/8 (eth8)

10 Ethernet 1/9 (eth9)

The mapping on the VM-Series Firewall remains the same no maer which vNICs you add on
ESXi. Interfaces you acvate on the firewall always take the next available vNIC on ESXi.

In the following diagram, eth3 and eth4 on the VM-Series Firewall are paired to vNICs 2 and 3 on
ESXi, and eth1 and eth2 are unmapped, as shown on the le.

If you want to add two addional interfaces while maintaining the current mapping, acvate vNICs
4 and 5 and reboot down the firewall. The exisng vNIC mapping is preserved because you added
the interfaces aer the last-mapped inteface.

If you acvate eth1 and eth2 on the VM-Series firewall, the interfaces reorder themselves as
shown on the right, resulng in a mapping mismatch that impacts traffic.

To avoid the issues described in the preceding example, you can do the following:

• When provisioning your ESXi host for the first me, acvate all nine vNICs beyond the first.
Adding all nine vNICs as placeholders before powering on the VM-Series Firewall allows you to
use any VM-Series interfaces regardless of order.

• If all vNICs are acve, adding addional interfaces no longer requires a reboot. Because each
vNIC on ESXi requires that you choose a network, you can create an empty port group as a
network placeholder.

• Do not remove VM-Series firewall vNICs to avoid mapping mismatches.

Provision the VM-Series Firewall on an ESXi Server
Use these instrucons to deploy the VM-Series firewall on a (standalone) ESXi server. For
deploying the VM-Series NSX edion firewall, see Set Up the VM-Series Firewall on VMware
NSX-T.
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STEP 1 | Download the OVA file.

Register your VM-Series firewall and obtain the OVA file from the Palo Alto Networks
Customer Support web site.

The OVA file contains the base installaon. Aer the base installaon is complete, you
must download and install the latest PAN-OS version from the support portal. This
ensures that you have the latest fixes implemented since the base image was created.
For instrucons, see Upgrade the PAN-OS Soware Version (Standalone Version).

STEP 2 | Before deploying the OVA file, set up virtual standard switch(es) or virtual distributed
switch(es) that you need for the VM-Series firewall.

If you are deploying the VM-Series firewall with Layer 3 interfaces, your firewall uses
Hypervisor Assigned MAC Addresses by default. If you choose to disable hypervisor
assigned MAC address, or if you are deploying the firewall with Layer 2, virtual wire,
or tap interfaces, you must configure (set to Accept) any virtual switch aached to
the VM-Series firewall to allow the following modes: promiscuous mode, MAC address
changes, and Forged transmits.

Configure a virtual standard switch or a virtual distributed switch to receive frames for the VM-
Series firewall.

Virtual Standard Switch

1. Navigate to Home > Hosts and Clusters and select a host.
2. Click the Configure tab and view Virtual Switches. For each VM-Series firewall aached a

virtual switch, click on Properes.
3. Highlight a port group corresponding to a virtual switch and click Edit Sengs. In the

vSwitch properes, click the Security tab and set Promiscuous Mode, MAC Address
Changes and Forged Transmits to Accept and then click OK. This change propagates to all
port groups on the virtual switch.

Virtual Distributed Switch

1. Select Home > Networking. Select your virtual distributed switch and highlight the
Distributed Port Group you want to edit.

2. Click Edit Sengs, select Policies > Security, and set Promiscuous Mode, MAC Address
Changes and Forged Transmits to Accept and click OK.
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STEP 3 | Deploy the OVA.

If you add addional interfaces (vNICs) to the VM-Series firewall, you must reboot
(because new interfaces are detected during the boot cycle). To minimize the need
to reboot the firewall, acvate the interfaces at inial deployment or during a
maintenance window.

To view the progress of the installaon, monitor the Recent Tasks list.

1. Log in to vCenter using the vSphere client. You can also go directly to the target ESXi
host if needed.

2. From the vSphere web client, go to Hosts and Clusters, right-click your host, and select
Deploy OVF Template.

3. Browse to the OVA file that you downloaded previously. Select the file, and click Next.
Review the template’s details and click Next.

4. Name the VM-Series firewall instance, and in the Inventory Locaon window, select a
Data Center and Folder, and click Next.

5. Select an ESXi host for the VM-Series firewall, and click Next.
6. Select the datastore to use for the VM-Series firewall, and click Next.
7. Leave the default sengs for the datastore provisioning, and click Next. The default is

Thick Provision Lazy Zeroed.

8. Select the networks to use for the two inial vNICs. The first vNIC is used for the
management interface and the second vNIC for the first data port. Make sure that the
Source Networks map to the correct Desnaon Networks.

9. Review the details, select Power on aer deployment, and click Next.
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10. When the deployment is complete, click the Summary tab to review the current status.

Perform Inial Configuraon on the VM-Series on ESXi
Use the virtual appliance console on the ESXi server to set up network access to the VM-
Series firewall. By default, the VM-Series firewall uses DHCP to obtain an IP address for the
management interface, but, you can also assign a stac IP address. Aer compleng the inial
configuraon, access the web interface to complete further configuraon tasks. If you have
Panorama for central management, refer to the Panorama Administrator’s Guide for informaon
on managing the device using Panorama.

If you are using bootstrapping to perform the configuraon of your VM-Series firewall on ESXi,
refer to Bootstrap the VM-Series Firewall on ESXi.

For general informaon about bootstrapping, see Bootstrap the VM-Series Firewall.

STEP 1 | Gather the required informaon from your network administrator.

• IP address for MGT port
• Netmask
• Default gateway
• DNS server IP address

STEP 2 | Access the console of the VM-Series firewall.
1. Select the Console tab on the ESXi server for the VM-Series firewall, or right click the

VM-Series firewall and select Open Console.
2. Press Enter to access the login screen.
3. Enter the default username/password (admin/admin) to log in.
4. Enter configure to switch to configuraon mode.
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STEP 3 | Configure the network access sengs for the management interface.

Enter the following commands:

set deviceconfig system type static

set deviceconfig system ip-address <Firewall-IP> netmask <netmask> 
default-gateway <gateway-IP> dns-setting servers primary <DNS-IP>

STEP 4 | Commit your changes and exit the configuraon mode.

Enter commit.

Enter exit.

STEP 5 | Verify network access to external services required for firewall management, such as the Palo
Alto Networks Update Server.
1. Use the ping ulity to verify network connecvity to the Palo Alto Networks Update

server as shown in the following example. Verify that DNS resoluon occurs and the
response includes the IP address for the Update server (the Update server does not
respond to ping requests.) Aer verifying DNS resoluon, press Ctrl+C to stop the ping
request.

admin@PA-220 > ping host updates.paloaltonetworks.com

PING updates.paloaltonetworks.com (10.101.16.13) 56(84) bytes
 of data. 
From 192.168.1.1 icmp_seq=1 Destination Host Unreachable 
From 192.168.1.1 icmp_seq=2 Destination Host Unreachable 
From 192.168.1.1 icmp_seq=3 Destination Host Unreachable 
From 192.168.1.1 icmp_seq=4 Destination Host Unreachable  

2. Use the following CLI command to retrieve informaon on the support entlement for
the firewall from the Palo Alto Networks update server: request support check If you
have connecvity, the update server responds with the support status for your firewall.

STEP 6 | Apply the capacity auth code and retrieve a license before you begin tesng the VM-Series
firewall.

An unlicensed VM-Series firewall can process up to approximately 1230 concurrent sessions.
Depending on the environment, the session limit can be reached very quickly, causing
unpredictable results.

Add Addional Disk Space to the VM-Series Firewall
The VM-Series firewall requires a 60GB virtual disk, of which 21GB is used for logging, by default.

• For large deployments, use Panorama to aggregate data from all next-generaon firewalls, and
provide visibility across all the traffic on your network. Panorama provides centralized logging
and reporng.
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• In smaller deployments where you do not use Panorama, you can add a new virtual disk
to increase log storage capacity. The new virtual disk can support 60GB to 2TB of storage
capacity for logs. This task is described below.

When the virtual appliance is configured to use a virtual disk, the VM-Series firewall
no longer stores logs. If the appliance loses connecvity to the virtual disk, logs can be
lost during the failure interval. If necessary, place the newly created virtual disk on a
datastore that provides RAID redundancy. RAID10 provides the best write performance
for applicaons with high logging characteriscs.

STEP 1 | Power off the VM-Series firewall.

STEP 2 | On the ESXi server, add the virtual disk to the firewall.
1. Select the VM-Series firewall on the ESXi server.
2. Click Edit Sengs.
3. Click Add to launch the Add Hardware wizard, and select the following opons when

prompted:

1. Select Hard Disk for the hardware type.
2. Select Create a new virtual disk.
3. Select SCSI as the virtual disk type.
4. Select the Thick provisioning disk format.
5. In the locaon field, select Store with the virtual machine opon. The datastore does

not have to reside on the ESXi server.
6. Verify that the sengs look correct and click Finish to exit the wizard. The new disk is

added to the list of devices for the virtual appliance.

STEP 3 | Power on the firewall.

Powering on the firewall inializes the virtual disk for first-me use. The me that the
inializaon process takes to complete varies by the size of the new virtual disk.

When the new virtual disk is inialized and ready, PAN-OS moves all logs from the exisng disk
to the new virtual disk. New log entries are now wrien to this new virtual disk.

PAN-OS also generates a system log entry that records the new disk.

If you reuse a virtual disk that was previously used for storing PAN-OS logs, all logs
from the exisng disk are overwrien.

STEP 4 | Verify the size of the new virtual disk.
1. Select Device > Setup > Management.
2. In the Logging and Reporng Sengs secon, verify that the Log Storage capacity

accurately displays the new disk capacity.
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Use VMware Tools on the VM-Series Firewall on ESXi and vCloud
Air

The VMware Tools ulity improves VM-Series firewall management from vCenter server and
vCloud Director. VMware Tools are bundled with the soware image for the VM-Series firewall,
and all updates are made available with a new OVF image. You cannot manually install or upgrade
VMware Tools using the vCenter server or vCloud Director.

View the IP address(es) on the management interface and the soware version on the firewall
and Panorama.

In the Hosts and Cluster secon on the vCenter server, select the firewall or Panorama and
view the Summary tab for informaon on the IP address(es) assigned to the management
interface and the soware version currently installed.

View resource ulizaon metrics on hard disk, memory, and CPU. Use these metrics to enable
alarms on the vCenter server.

In the Hosts and Cluster secon on the vCenter server, select the firewall or Panorama and
view the Monitor > Ulizaon tab for informaon on hard disk, memory, and CPU usage.
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Gracefully shutdown or restart the firewall and Panorama from the vCenter server.

In the Hosts and Cluster secon on the vCenter server, select the firewall or Panorama and
select the Acons > Power drop-down.

Create alarm definions for events you want to be nofied about, or events for which you want
to specify an automated acon.

Refer to the VMware documentaon for details on creang alarm definions.

In the Hosts and Cluster secon on the vCenter server, select the firewall or Panorama
and select the Manage > Alarm Definions to add a new trigger and specify an acon
when a threshold is met. For example, missing heartbeats for a specified duraon, or when
memory resource usage exceeds a threshold. The following screenshot shows you how to use
noficaons for heartbeat monitoring on the firewall or Panorama.

Use vMoon to Move the VM-Series Firewall Between Hosts
To maintain traffic flow while using vMoon to move your VM-Series firewall on VMware ESXi
between ESXi hosts with homogeneous CPU configuraons, you must use the PAN-OS CLI to
pause the internal heartbeat monitoring of the VM-Series firewall during vMoon. You can specify
the amount of me, in minutes, that heartbeat monitoring is paused. Heartbeat monitoring can be
paused for up to 60 minutes. When the pause interval expires or you deliberately end the pause
interval, heartbeat monitoring resumes.

vMoon of the VM-Series firewall is supported on vSphere 6.5, 6.7, and 7.0 if the ESXi hosts have
homogeneous CPU configuraon.

These commands are not required when using vMoon if you are running vSphere 7.0 or
later.
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STEP 1 | Log in the VM-Series firewall CLI.

STEP 2 | Set the heartbeat monitoring pause interval using the following command. The pause begins
as soon as the command is executed. If vMoon is taking longer than expected, you can
rerun this command to set a new, longer interval that starts when the command is executed
again.

request system heartbeat-pause set interval <pause-time-in-minutes>

You can view the me remaining in pause interval using the following command.

request system heartbeat-pause show interval

STEP 3 | (Oponal) If you complete vMoon before the pause interval has elapsed, you can end the
pause by seng the interval to zero (0).

request system heartbeat-pause set interval 0

Use the VM-Series CLI to Swap the Management Interface on ESXi
By default, the VM-Series firewall assigns the first interface (eth0) as the management interface.
However, in some deployments, the first interface must be pre-mapped to a public IP address.
Therefore, the management interface must be assigned to a different interface. Assigning a public
IP address to the management interface is a security risk.

This procedure requires VM-Series plugin 2.0.7 or later.

Alternavely, you can enable management interface swap as part of the init-cfg.txt File
Components when bootstrapping.

STEP 1 | Log in to the VM-Series firewall CLI and enter the following command:

set system setting mgmt-interface-swap enable yes

STEP 2 | Confirm that you want to swap the interface and use the eth1 dataplane interface as the
management interface.

STEP 3 | Reboot the firewall for the swap to take effect. Use the following command:

request restart system

STEP 4 | Verify that the interfaces have been swapped. Use the following command:

debug show vm-series interfaces all 
Phoenix_interface   Base-OS_port   Base-OS_MAC        PCI-ID  
       Driver 
mgt(interface-swap) eth0   0e:53:96:91:ef:29   0000:00:04.0 
  ixgbevf 
Ethernet1/1           eth1    0e:4d:84:5f:7f:4d       0000:00:03.0 
  ixgbevf 
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VM Monitoring on vCenter
Install and configure the Panorama plugin for VMware vCenter to retrieve the IP addresses for
guests in your vCenter environment and use that informaon to build policy using Dynamic
Address Groups.

The Panorama plugin for VMware vCenter does not support proxy servers.

• About VM Monitoring on VMware vCenter
• Install the Panorama Plugin for VMware vCenter
• Configure the Panorama Plugin for VMware vCenter

About VM Monitoring on VMware vCenter
The Panorama plugin for VMware vCenter gives you the tools to build policy for your vCenter
environment using Dynamic Address Groups. Dynamic address groups allow you to create policy
that automacally adapts to changes in your environment, such as the addion or deleon of
guests. The VMware vCenter plugin monitors for changes in your vCenter environment and shares
that informaon with Panorama.

The plugin processes the informaon it receives from vCenter and converts it into a set of tags on
Panorama that you can use as match criteria for assigning IP address to dynamic address groups.
Each tag has a prefix that describes the hierarchy above the VM.

In this example, each tag in Panorama begins with the prefix shown below. Each tag includes the
vCenter name, data center name, and cluster name; if you have folders in your vCenter hierarchy,
tags will include the folder names. The order of the objects in the tag matches the order in the
vCenter hierarchy.

vcenter.<vcenter-name>_ParentA_ParentB_Datacenter_CHILD1_CHILD2_Cluster_<tag>

The Panorama plugin for VMware vCenter does not support tags associated to vApps or
resource pools.

The tags are shown in Panorama in the following formats:

• vcenter.<vcenter-name>_<datacenter-name>_<cluster-name>_vmname.<vm-name>—this tag
maps virtual machine IP addresses based on VM name.
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• vcenter.<vcenter-name>_<datacenter-name>_<cluster-name>_guestos.<guest-os>—this tag
maps virtual machine IP addresses based on guest operang system.

• vcenter.<vcenter-name>_<datacenter-name>_<cluster-name>_annotaon.<annotaon>—this
tag maps virtual machine IP addresses based on annotaon.

• vcenter.<vcenter-name>_<datacenter-name>_<cluster-name>_vlanId.<vlan-ID>—this tag
maps virtual machine IP addresses based on VLAN ID.

• vcenter.<vcenter-name>_<datacenter-name>_<cluster-name>_host-ip.<host-ip>—this tag
maps virtual machine IP addresses based on host IP address.

• vcenter.<vcenter-name>_<datacenter-name>_<cluster-name>_<tag-category>.<user-
defined-tag>—this tag maps virtual machine IP addresses based on user-defined tags created in
vCenter.

The plugin supports a maximum of 16 user-defined tags per VM. Any user-defined tags
beyond 16 are not processed.

The Panorama plugin for vCenter cannot process tags that are longer than 128 characters; this
includes leers, numbers, and special characters. Whitespace in vCenter object names is replaced
with forward slashes. Addionally, Panorama does not support non-ASCII special characters or the
following special characters—’<>&” in vCenter VM names and annotaons. Panorama drops tags
containing unsupported characters.

To retrieve endpoint IP-address-to-tag mapping informaon, you must configure a Monitoring
Definion for each vCenter in your virtual environment. The Monitoring Definion specifies the
username and password that allows Panorama to connect to vCenter. It also specifies the device
groups and corresponding nofy groups containing the firewalls to which Panorama pushes the
tags. Aer you configure the Monitoring Definion and the Panorama plugin for VMware vCenter
retrieves the tags, you can create DAGs and add the tags as match criteria.

Install the Panorama Plugin for VMware vCenter
To get started with endpoint monitoring on vCenter, download and install the Panorama Plugin for
VMware vCenter.

If you have a Panorama HA configuraon, repeat this installaon process on each Panorama peer.
When installing the plugin on Panoramas in an HA pair, install the plugin on the passive peer
before the acve peer. Aer installing the plugin on the passive peer, it will transion to a non-
funconal state. Installing the plugin on the acve peer returns the passive peer to a funconal
state.

If you have a standalone Panorama or two Panorama appliances installed in an HA pair with
mulple plugins installed, plugins might not receive updated IP-tag informaon if one or more of
the plugins is not configured. This occurs because Panorama will not forward IP-tag informaon
to unconfigured plugins. Addionally, this issue can occur if one or more of the Panorama plugins
is not in the Registered or Success state (posive state differs on each plugin). Ensure that your
plugins are in the posive state before connuing or execung the commands described below.

If you encounter this issue, there are two workarounds:

• Uninstall the unconfigured plugin or plugins. It is recommended that you do not install a plugin
that you do not plan to configure right away
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• You can use the following commands to work around this issue. Execute the following
command for each unconfigured plugin on each Panorama instance to prevent Panorama from
waing to send updates. If you do not, your firewalls may lose some IP-tag informaon.

request plugins dau plugin-name <plugin-name> unblock-device-push yes

You can cancel this command by execung:

request plugins dau plugin-name <plugin-name> unblock-device-push no

The commands described are not persistent across reboots and must be used again for any
subsequent reboots. For Panorama in HA pair, the commands must be executed on each
Panorama.

STEP 1 | Select Panorama > Plugins.

STEP 2 | Select Upload and click Browse to locate the plugin file.

STEP 3 | Click OK to complete the upload.

STEP 4 | Select the version of the plugin and click Install in the Acon column to install the plugin.
Panorama will alert you when the installaon is complete.

Configure the Panorama Plugin for VMware vCenter
Aer installing the plugin, complete the following procedure to establish a connecon between
Panorama and vCenter.

For the plugin to monitor virtual machines in your vCenter environment, you must have VMware
tools installed. In vCenter, IP addresses of VMs are not externally retrievable; they are only visible
through VMware tools. Addionally, nave read-only permissions are required for the plugin to
retrieve IP address informaon from vCenter.

STEP 1 | Log in to the Panorama web interface.

STEP 2 | Enable monitoring and set the monitoring interval.
1. Select Panorama > VMware vCenter > Setup > General.
2. Select Enable Monitoring. This enables monitoring for all vCenters in your deployment.
3. Set the Monitoring Interval in seconds. The monitoring interval is how oen Panorama

retrieves updated network informaon from vCenter. The default value is 60 seconds
and has a range of 60 to 84600 seconds.
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STEP 3 | Create a nofy group.
1. Select Panorama > VMware vCenter > Setup > Nofy Groups.
2. Click Add.
3. Enter a descripve Name for your nofy group.
4. Select the device groups in your vCenter deployment.

STEP 4 | Add vCenter informaon. The Panorama plugin for VMware vCenter supports up to 16
vCenter instances.
1. Select Panorama > VMware vCenter > Setup > vCenter.
2. Enter a descripve Name for your vCenter.
3. Enter the IP address or FQDN for vCenter and port, if applicable.
4. Enter your vCenter username.
5. Enter and confirm your vCenter password.
6. Click Validate to verify that Panorama can connect to vCenter using the login credenals

you entered.
7. Click OK.

STEP 5 | Configure up to 16 Monitoring Definions.

A vCenter instance can be assigned to only one Monitoring Definion.

1. Select Panorama > VMware vCenter > Monitoring Definion and click Add.
2. Enter a descripve Name and oponally a descripon to idenfy the vCenter for which

you use this definion.
3. Select the vCenter and Nofy Group.
4. Click OK.

STEP 6 | Commit your changes.
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STEP 7 | Verify that you can view the VM informaon on Panorama, and define the match criteria for
Dynamic Address Groups.

You must use the OR operator when using more than one tag in the match criteria;
using the AND operator does not work.

Some browser extensions may block API calls between Panorama and vCenter which
prevents Panorama from receiving match criteria. If Panorama displays no match
criteria and you are using browser extensions, disable the extensions and Synchronize
Dynamic Objects to populate the tags available to Panorama.

STEP 8 | Verify that addresses in your VMs are added to DAGs.
1. Select Panorama > Objects > Address Groups.
2. Click More in the Addresses column of a DAG.

Panorama displays a list of IP addresses added to that DAG based on the match criteria
you specified.

STEP 9 | Use dynamic address groups in policy.
1. Select Policies > Security.
2. Click Add and enter a Name and a Descripon for the policy.
3. Add the Source Zone to specify the zone from which the traffic originates.
4. Add the Desnaon Zone at which the traffic is terminang.
5. For the Desnaon Address, select the Dynamic address group you just created.
6. Specify the acon— Allow or Deny—for the traffic, and oponally aach the default

security profiles to the rule.
7. Repeats Steps 1 through 6 to create another policy rule.
8. Click Commit.

STEP 10 | You can update the dynamic objects from vCenter at any me by synchronizing dynamic
objects. Synchronizing dynamic objects enables you to maintain context on changes in the
virtual environment and allows you to enable applicaons by automacally updang the
Dynamic Address Groups used in policy rules.
1. Select Panorama > VMware vCenter > Monitoring Definion.
2. Click Synchronize Dynamic Objects.

STEP 11 | If a firewall in your vCenter deployment restarts or disconnects from Panorama, that firewall
goes out of sync with the Panorama plugin for vCenter and no receive updates. Aer the
firewall reconnects with Panorama, you must manually synchronize Panorama and the
firewall.
1. Log in to the Panorama CLI.
2. Execute the following command.

admin@Panorama> request plugins vmware_vcenter sync
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Troubleshoot ESXi Deployments
Many of the troubleshoong steps for the VM-Series firewall are very similar to the hardware
versions of PAN-OS. When problems occur, you should check interface counters, system log files,
and if necessary, use debug to create captures.

The following secons describe how to troubleshoot some common problems:

• Basic Troubleshoong
• Installaon Issues
• Licensing Issues
• Connecvity Issues

Basic Troubleshoong
Recommendaon for Network Troubleshoong Tools

It is useful to have a separate troubleshoong staon to capture traffic or inject test
packets in the virtualized environment. It can be helpful to build a fresh OS from scratch
with common troubleshoong tools installed such as tcpdump, nmap, hping, traceroute,
iperf, tcpedit, netcat, etc. This machine can then be powered down and converted to a
template. Each me the tools are needed, the troubleshoong client (virtual machine) can
be quickly deployed to the virtual switch(es) in queson and used to isolate networking
problems. When the tesng is complete, the instance can simply be discarded and the
template used again the next me it is required.

For performance related issues on the firewall, first check the Dashboard from the firewall web
interface. To view alerts or create a tech support or stats dump files navigate to Device > Support.

For informaon in the vSphere client go to Home > Inventory > VMs and Templates, select the
VM-Series firewall instance and click the Summary tab. Under Resources, check the stascs for
consumed memory, CPU and storage. For resource history, click the Performance tab and monitor
resource consumpon over me.

Installaon Issues
• Issues with Deploying the OVA
• Why does the firewall boot into maintenance mode?
• How do I modify the base image file for the VM-1000-HV license?

Issues with Deploying the OVA
• The VM-Series is delivered as a zip archive in the Open Virtualizaon Alliance (OVA) format

that expands into three files.

If you are having trouble deploying the OVA image, make sure the three files are unpacked and
accessible. If necessary, download and extract the OVA image again.
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• The virtual disk in the OVA image is nearly 1GB. It must be present on the computer running
the vSphere client, or it must be accessible as a URL for the OVA image.

• Make sure the network connecon between the vSphere client computer and the target
ESXi host has low latency and sufficient bandwidth. If the connecon is poor, the OVA
deployment can take hours, or meout and fail.

You can minimize this problem if you host the image on a device in the same network as the
ESXi host.

• Any firewalls in the path must allow TCP ports 902 and 443 from the vSphere client to the
ESXi host(s).

• ESX 6.5.0a build 4887370 limits you to 2 CPU cores per socket. If you are deploying a VM-300,
VM-500 or VM-700 to which you want to allocate more than 2 vCPUs per socket, refer to the
VMware KB: hps://kb.vmware.com/s/arcle/53354, for a workaround.

Why does the firewall boot into maintenance mode?
If you have purchased the VM-1000-HV license and are deploying the VM-Series firewall in
standalone mode on a VMware ESXi server, you must allocate the minimum memory your VM-
Series model requires.

To avoid boong in maintenance mode, you must either modify the base image file (see How do I
modify the base image file for the VM-1000-HV license?), or, edit the sengs on the ESXi host or
the vCenter server before you power on the VM-Series firewall.

Also, verify that the interface is VMXnet3. Seng the interface type to any other format causes
the firewall to boot into maintenance mode.

How do I modify the base image file for the VM-1000-HV license?
If you have purchased the VM-1000-HV license and are deploying the VM-Series firewall in
standalone mode on a VMware ESXi server, use these instrucons to modify the following
aributes that are defined in the base image file (.ova or .xva) of the VM-Series firewall.

Important: Modifying values other than those listed here invalidates the base image file.

STEP 1 | Open the base image file, for example 7.0.0, with a text eding tool such as notepad.

STEP 2 | Search for 4096 and change the memory allocated to 5012 (that is 5 GB) as follows:

<Item> 
        <rasd:AllocationUnits>byte * 2^20</rasd:AllocationUnits> 
        <rasd:Description>Memory Size</rasd:Description> 
        <rasd:ElementName>4096MB of memory</rasd:ElementName> 
        <rasd:InstanceID>2</rasd:InstanceID> 
        <rasd:ResourceType>4</rasd:ResourceType> 
        <rasd:VirtualQuantity>4096</rasd:VirtualQuantity> 
<Item> 
        <rasd:AllocationUnits>byte * 2^20</rasd:AllocationUnits> 
        <rasd:Description>Memory Size</rasd:Description> 
        <rasd:ElementName>5120MB of memory</rasd:ElementName> 
        <rasd:InstanceID>2</rasd:InstanceID> 
        <rasd:ResourceType>5</rasd:ResourceType> 
        <rasd:VirtualQuantity>5120</rasd:VirtualQuantity> 
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STEP 3 | Change the number of virtual CPU cores alloed from 2 to 4 or 8 as desired for your
deployment:

<Item> 
        <rasd:AllocationUnits>hertz * 10^6</rasd:AllocationUnits> 
        <rasd:Description>Number of Virtual CPUs</
rasd:Description> 
        <rasd:ElementName>2 virtual CPU(s)</rasd:ElementName> 
        <rasd:InstanceID>1</rasd:InstanceID> 
        <rasd:ResourceType>3</rasd:ResourceType> 
        <rasd:VirtualQuantity>2</rasd:VirtualQuantity> 
        <vmw:CoresPerSocket ova:required="false">2</
vmw:CoresPerSocket> 
      </Item> 
<Item> 
        <rasd:AllocationUnits>hertz * 10^6</rasd:AllocationUnits> 
        <rasd:Description>Number of Virtual CPUs</
rasd:Description> 
        <rasd:ElementName>4 virtual CPU(s)</rasd:ElementName> 
        <rasd:InstanceID>1</rasd:InstanceID> 
        <rasd:ResourceType>3</rasd:ResourceType> 
        <rasd:VirtualQuantity>4</rasd:VirtualQuantity> 
        <vmw:CoresPerSocket ova:required="false">2</
vmw:CoresPerSocket> 
      </Item> 

Alternavely, you can deploy the firewall, and before you power on the VM-Series firewall, edit
the memory and virtual CPU allocaon directly on the ESXi host or the vCenter server.

Licensing Issues
• Why am I unable to apply the support or feature license?
• Why does my cloned VM-Series firewall not have a valid license?
• Does moving the VM-Series firewall cause license invalidaon?

Why am I unable to apply the support or feature license?
Have you applied the capacity auth-code on the VM-Series firewall? Before you can acvate the
support or feature license, you must apply the capacity auth-code so that the device can obtain
a serial number. This serial number is required to acvate the other licenses on the VM-Series
firewall.

Why does my cloned VM-Series firewall not have a valid license?
VMware assigns a unique UUID to each virtual machine including the VM-Series firewall.So, when
a VM-Series firewall is cloned, a new UUID is assigned to it. Because the serial number and license
for each instance of the VM-Series firewall is ed to the UUID, cloning a licensed VM-Series
firewallresults in a new firewall with an invalid license. You need a new auth-code to acvate the
license on the newly deployed firewall. You must apply the capacity auth-code and a new support
license in order to obtain full funconality, support, and soware upgrades on the VM-Series
firewall.
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Does moving the VM-Series firewall cause license invalidaon?
If you are manually moving the VM-Series firewall from one host to another, be sure to select the
opon, This guest was moved to prevent license invalidaon.

Connecvity Issues
• Why is the VM-Series firewall not receiving any network traffic?

Why is the VM-Series firewall not receiving any network traffic?
On the VM-Series firewall. check the traffic logs (Monitor > Logs). If the logs are empty, use the
following CLI command to view the packets on the interfaces of the VM-Series firewall:

show counter global filter
delta yes 
Global counters: 
Elapsed time since last sampling: 594.544 seconds 
-------------------------------------------------------------------------------- 
Total counters shown: 0 
-------------------------------------------------------------------------------- 

In the vSphere environment, check for the following issues:

• Check the port groups and confirm that the firewall and the virtual machine(s) are on the
correct port group

Make sure that the interfaces are mapped correctly.

Network adapter 1 = management

Network adapter 2= Ethernet1/1

Network adapter 3 = Ethernet1/2

For each virtual machine, check the sengs to verify the interface is mapped to the correct
port group.
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• Verify that either promiscuous mode is enabled for each port group or for the enre switch or
that you have configured the firewall to Hypervisor Assigned MAC Addresses.

Since the dataplane PAN-OS MAC addresses are different than the vNIC MAC addresses
assigned by vSphere, the port group (or the enre vSwitch) must be in promiscuous mode if not
enabled to use the hypervisor assigned MAC address:

• Check the VLAN sengs on vSphere.

The use of the VLAN seng for the vSphere port group serves two purposes: It determines
which port groups share a layer 2 domain, and it determines whether the uplink ports are
tagged (802.1Q).

• Check the physical switch port sengs

If a VLAN ID is specified on a port group with uplink ports, then vSphere uses 802.1Q to tag
outbound frames. The tag must match the configuraon on the physical switch or the traffic
does not pass.

Check the port stascs if using virtual distributed switches (vDS); Standard switches do not
provide any port stascs
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Performance Tuning of the VM-Series for ESXi
The VM-Series firewall for ESXi is a high-performance appliance but may require tuning of
the hypervisor to achieve the best results. This secon describes some best pracces and
recommendaons for facilitang the best performance of the VM-Series firewall. For the best
performance, ESXi 6.0.0.0 or later is recommended.

• Install the NIC Driver on ESXi
• Enable DPDK on ESXi
• Enable SR-IOV on ESXi
• Enable ESXi VLAN Access Mode with SR-IOV
• Enable Mul-Queue Support for NICs on ESXi
• VNF Tuning for Performance

Install the NIC Driver on ESXi
For the best performance, use SR-IOV with Intel 10GB network interfaces which requires the
ixgbe 4.4.1 driver to support mulple queues for each interface.

STEP 1 | Obtain a list of network interfaces on the ESXi host.
1. Log in to the ESXi host CLI.
2. Use the following command to return a list of network interfaces:

$ esxcli network nic list

STEP 2 | Determine the driver version for a parcular interface.

You can use either ethtool or esxcli to determine the currently-installed driver version.
The following example uses vNIC4 and returns driver version 3.21.6.

• ethtool—ethtool -l <nic-name>

$ ethtool -I vNIC4 
driver: ixgbe 
version: 3.21.6iov 
firmware-version: 0x80000389  
bus-info: 0000:04:00.0 

• esxcli—esxcli network nic get -n <nic-name>

$  esxcli network nic get -n vNIC4 
   Advertised Auto Negotiation: true 
   Advertised Link Modes:  
   Auto Negotiation: true 
   Cable Type:  
   Current Message Level: 7 
   Driver Info:  
         Bus Info: 0000:04:00.0 
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         Driver: ixgbe 
         Firmware Version: 0x80000389 
         Version: 3.21.6iov 
   Link Detected: false 
   Link Status: Down  
   Name: vNIC4 
   PHYAddress: 0 
   Pause Autonegotiate: true 
   Pause RX: true 
   Pause TX: true 
   Supported Ports: FIBRE 
   Supports Auto Negotiation: true 
   Supports Pause: true 
   Supports Wakeon: false 
   Transceiver: external 
   Wakeon: None 

STEP 3 | Install the new driver.
1. Download the ixgbe 4.4.1 driver from the VMware website. Extract the contents to a

local directory and find the .zip or .vib files for your driver.
2. Create a new folder in your ESXi host datastore.
3. Copy the local .zip or .vib file you extracted to the new folder in your ESXi host

datastore.
4. Enable maintenance mode on the ESXi host.
5. Use one of the following commands to install the new driver, using -d for .zip files, or -v

for .vib files.

• $ esxcli software vib install -d <path to driver .zip file>

• $ esxcli software vib install -v <path to driver .vib file>

You must specify the absolute path to the .zip or .vib file. For example:

$ esxcli software vib install -d  "/vmfs/volumes/
Datastore/DirectoryName/DriverName.zip"

6. Verify the VIB installaon.

$ esxcli software vib list

7. Reboot the ESXi host.

Enable DPDK on ESXi
The Data Plane Development Kit (DPDK) enhances VM-Series performance by increasing network
interface card (NIC) packet processing speed. On the VM-Series firewall, DPDK is enabled by
default on ESXi.

To take advantage of DPDK, you must use a NIC with one of the supported DPDK drivers
menoned in DPDK Driver Versions:
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If you disable DPDK, the NIC uses PacketMMap instead of DPDK. You can disable DPDK using
the command set system setting dpdk-pkt-io off.

See the Compability Matrix for ESXi hypervisor support and PacketMMAP and DPDK driver
support by PAN-OS version.

Enable SR-IOV on ESXi
Single root I/O virtualizaon (SR-IOV) allows a single PCIe physical device under a single root port
to appear to be mulple separate physical devices to the hypervisor or guest. Enable SR-IOV by
enabling virtual funcon devices on the SR-IOV NIC and the modify the guest sengs in vCenter.

SR-IOV on the VM-Series for ESXi requires one of the Intel NIC drivers menoned in
PacketMMAP Driver Versions. See the Compability Matrix for SR-IOV and DPDK driver support
by PAN-OS version.

There are two ways to enable SR-IOV on ESXi.

• SR-IOV passthrough—In this method you enable virtual funcon devices on the SR-IOV NIC
and modify the guest sengs in vCenter, adding the SR-IOV VF interface as adaptor type
“SR-IOV passthrough”. Refer to Assign a Virtual Funcon as SR-IOV Passthrough Adapter to a
Virtual Machine.

This method, which is preferred for PAN-OS 8.1.2 and later, allows you to add the SR-IOV PF
to a vSwitch or DvSwitch.

• PCI Adaptor—This method was required for PAN-OS 8.0 through 8.1.1. You can view the PCI
Adaptor workflow in Enable SR-IOV on ESXi in the 8.1 Deployment Guide.

The PCI Adaptor method has the limitaon that you cannot configure a vSwitch on the physical
port on which you enable SR-IOV. The VM-Series firewall must have exclusive access to the
physical port and associated virtual funcons (VFs) on that interface so it can communicate
with the host or other virtual machines on the network. Refer to Add a PCI Device in the
vSphere Web Client.

Enable ESXi VLAN Access Mode with SR-IOV
The VM-Series firewalls on ESXi can operate in VLAN access mode to support use cases where
it is deployed as a virtual network funcon (VNF) that offers security-as-a-service in a mul-
tenant cloud/data center environment. In VLAN access mode, each VNF has dedicated virtual
network interfaces (VNIs) for each network and it sends and receives packets to/from SR-IOV
virtual funcons (VFs) without VLAN tags; you must enable this capability on the physical and
virtual funcons on the host hypervisor. When you, then enable VLAN access mode on the VM-
Series firewall, the firewall can send and receive traffic without VLAN tags across all its dataplane
interfaces. Addionally, if you configure QoS policies, the firewall can enforce QoS on the access
interface and provide differenated treatment of traffic in a mul-tenant deployment.

By default, the VM-Series firewall on ESXi operates in VLAN trunk mode.
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STEP 1 | On the host system, set up the physical and virtual funcon to operate in VLAN access
mode.
1. Click Networking in the VMware Host Client inventory and click Port groups.
2. In the list that you want to edit, right-click the port group and select Edit sengs.Enter a

new port group Name.Enter a new value for the VLAN ID.

For best performance on the VM-Series firewall, make sure to:

• Enable CPU pinning.
• Disable Replay Protecon, if you have configured IPSec Tunnels.

On the firewall web interface, select Network > IPSec Tunnels, select an IPSec
tunnel, click General, select Show Advanced Opons, and clear Enable Replay
Protecon.

STEP 2 | Access the CLI on the VM-Series firewall.

STEP 3 | Enable VLAN access mode.

request plugins vm-series vlan-mode access-mode on

on enables VLAN access mode; to use VLAN trunk mode, enter request plugins vm-
series vlan-mode access-mode off.

STEP 4 | Reboot the firewall.

request restart system

STEP 5 | Verify the VLAN mode configuraon.

show plugins vm-series vlan-mode

Enable Mul-Queue Support for NICs on ESXi
Mul-queue allows network performance to scale with the number of vCPUs and allows for
parallel packet processing by creang mulple TX and RX queues. Modify the .vmx file or access
Advanced Sengs to enable mul-queue.
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STEP 1 | Enable mul-queue.
1. Open the .vmx file.
2. Add the following parameter:

ethernetX.pnicFeatures = “4”

STEP 2 | Enable receive-side scaling (RSS).
1. Log in to the CLI on the ESXi host.
2. Execute the following command:

$ vmkload_mod -u ixgbe 
$ vmkload_mod ixgbe RSS=”4,4,4,4,4,4” 

STEP 3 | For the best performance, allocate addional CPU threads per ethernet/vSwitch device. This
is limited by the amount of spare CPU resources available on the ESXi host.
1. Open the .vmx file.
2. Add the following parameter:

ethernetX.ctxPerDev = “1”

VNF Tuning for Performance
This topic provides VNF tuning guidance for VM-Series deployments. It is a reference to help you
choose some of the parameter sengs for a VM-Series deployment. Before aempng tuning,
you should be familiar with the steps to install the VM-Series firewall on the VMware vSphere
hypervisor (ESXi), including how to configure tuning parameters and aributes.

This guidance might not apply to VM-Series deployments on top of white-box or grey-box
environments targeng SD-WAN, MSSP, or CSSP use-cases.

VM-Series is a high-performance appliance and is available in various form-factors depending on
size, hypervisor footprint, and its deployment locaon in either private or public cloud.

Global and host-level configuraon changes impact other VMs running on the same host.
You should consider any trade-offs and prudently choose the parameters that best suit your
deployment.

• ESXi Tuning Parameters
• Use Cases
• References

ESXi Tuning Parameters
To achieve best results in performance on VM-series, you can tune hardware, hypervisor, and
network I/O parameters.
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The parameters menoned here do not apply to every deployment model.

• BIOS Sengs
• Physical Sengs
• Virtual NIC Sengs
• NUMA and Resource Consideraons

BIOS Settings

This secon recommends BIOS Power Management, Hyperthreading, and Intel VT-D sengs that
can enhance VM-Series firewall performance, and concludes with a sample BIOS configuraon.

• Power Management
• Hyperthreading
• Intel Virtualizaon Technology for Directed I/O
• Sample BIOS Configuraon

Power Management

For latency-sensive applicaons, any form of power management adds latency to the path where
an idle system (in one of several power-saving modes) responds to an external event. VMware
recommends seng the BIOS power management seng to “stac high performance” (no OS-
controlled power management), effecvely disabling any form of acve power management.
Servers with Intel Nehalem class and later CPUs (Intel Xeon 55xx and later) offer two other power
management opons: C-states and Intel Turbo Boost.

Leaving C-states enabled can increase memory latency and is therefore not recommended for low-
latency workloads. Even the enhanced C-state, known as C1E, introduces longer latencies to wake
up the CPUs from halt (idle) states to full-power. VMware recommends disabling C1E in the BIOS
to further lower latencies.

• For HP, set Power Regulator Mode to Stac High Mode and disable QPI Processor, C-state
support, and C1E Support.

• For Dell, set Power Management Mode, CPU power, and Performance Management to
Maximum Performance.

Another parameter to consider is P-states. For outright performance consideraons, disable P-
state sengs on BIOS.

Intel Turbo Boost can lead to performance variaons over a period of me. For consistent and
determinisc performance, disable Turbo Boost.

Hyperthreading

If the hardware and BIOS support hyperthreading, ESXi automacally enables hyperthreading on
hosts. For the best performance from VM series firewalls, disable hyperthreading on ESXi hosts.

If the deployment environment warrants enabling hyperthreading, then ensure that all CPU
resources for the VM-Series firewall are reserved from the same NUMA/Socket node that has
access to the PCI devices.
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In general, configure the PA-VM as a single NUMA VM. See NUMA and Resource Consideraons
for more details.

Intel Virtualizaon Technology for Directed I/O

Intel Virtualizaon Technology for Directed I/O (Intel VT-D) allows a LAN card to be dedicated
to a guest system, which enables increased network performance beyond that of an emulated
LAN card. Enable this feature at the BIOS. If you plan to leverage SR-IOV for performance
(recommended), enable the SRI-OV BIOS seng.

Sample BIOS Configuraon

The following screenshots show the system profile sengs and the processor sengs for a Dell
BIOS.
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Physical Settings

Most 1GbE or 10GbE network interface cards (NICs) support a feature called interrupt moderaon
or interrupt throling, which coalesces interrupts from the NIC to the host so that the host
doesn’t get overwhelmed and spend all its CPU cycles processing interrupts. However, for latency-
sensive workloads, the me the NIC is delaying the delivery of an interrupt for a received packet
or a packet that has successfully been sent on the wire is the me that increases the latency of
the workload. For best performance on PA-VM, disable interrupt moderaon. For example, disable
physical NIC interrupt moderaon on the ESXi host as follows:

# esxcli system module parameters set -m ixgbe -p
 "InterruptThrottleRate=0"

• Transmit Queue
• Queue Pairing

Transmit Queue

The ESXi uplink pNIC layer also maintains a soware Tx queue of packets queued for transmission,
which by default holds 500 packets. If the workload is I/O intensive with large bursts of transmit
packets, this queue can overflow, leading to packets being dropped in the uplink layer. The Tx
queue size can be increased up to 10,000 packets with the following ESXi command:

# esxcli system settings advanced set -i 10000 -o /Net/
MaxNetifTxQueueLen
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Depending on the physical NIC and the specific version of the ESXi driver being used on the ESXi
host, somemes packets can be dropped in the pNIC driver because the transmit ring on the pNIC
is too small and is filled up. Most pNIC drivers allow you to increase the size of the transmit ring
using the following command:

# ethtool -G vmnic0 tx 4096 

This command increases the Tx ring size to 4096 entries. The maximum size you can set for a
specific pNIC driver, as well as the current Tx ring size in effect, can be determined using the
following command:

# ethtool -g vmnic0

Ring parameters for vmnic0: 

Pre-set maximums: 
RX: 4096 
RX Mini: 0 
RX Jumbo: 0 
TX: 4096
Current hardware settings: 
RX: 512 
RX Mini: 0 
RX Jumbo: 0 
TX: 4096

Queue Pairing

Some pNIC drivers, such as Intel’s ixgbe and Broadcom’s bnx2x, also support “queue pairing”,
which indicates to the ESXi uplink layer that the receive thread (NetPoll) will also process
compleon of transmied packets on a paired transmit queue. For certain transmit-heavy
workloads, this can cause delays in processing transmit compleons, causing the transmit ring for
the vNIC to run out of room for transming addional packets, and forcing the vNIC driver in the
guest OS to drop packets.

Disabling queue pairing for all pNICs on an ESXi host creates a separate thread for processing
pNIC transmit compleons. As a result, compleons are processed in a mely manner, freeing
space in the vNIC’s transmit ring to transmit addional packets.

The ESXi command to disable queue pairing is:

# esxcli system settings advanced set -o /Net/
NetNetqRxQueueFeatPairEnable
  -i 0

For this to take effect, you must reboot the ESXi host.

If PCI-pass through on VM-700 is used on a dedicated host, no performance tuning of the
NIC/NIC driver is needed. However, this deployment mode is not common.
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Virtual NIC Settings

If possible, use SR-IOV for beer performance, as explained in the following topics:

• SR-IOV
• VMXNET3/vSwitch and Virtual Interrupt Coalescing
• Enable Mulqueue Support on Intel x710/x520

SR-IOV

• Changing module parameters for an SR-IOV driver requires an ESXi host reboot.
• Disable physical NIC interrupt moderaon on ESXi host as follows:

# esxcli system module parameters set -m ixgbe -p
 "InterruptThrottleRate=0“

• If you enable mulqueue support, you must also enable Receive-Side Scaling (RSS) for the
driver.

• To enable RSS, set the port value to 4.
• Specify ports in a comma-separated string.

Example—Set 3 NICs with 2 ports each.

$ vmkload_mod -u ixgbe esxcli system module parameters set -m
 ixgbe 
  -p RSS=”4,4,4,4,4,4”

$ vmkload_mod ixgbe RSS=”4,4,4,4,4,4”

Example—Set RSS for a single port:

$ vmkload_mod -u ixgbe esxcli system module parameters set -m
 ixgbe 
  -p RSS=”0,4,0,0,0,0”

VMXNET3/vSwitch and Virtual Interrupt Coalescing

By default, VMXNET3 supports an interrupt coalescing algorithm (for the same reasons that
physical NICs implement interrupt moderaon). To avoid flooding the host system with too many
interrupts, packets are collected and one single interrupt is generated for mulple packets. This is
called interrupt coalescing.

Interrupt coalescence refers to the amount of traffic that a network interface receives, or the
amount of me that passes aer traffic is received, before you issue a hard interrupt. Interrupng
too soon or too frequently results in poor system performance, as the kernel stops (or “interrupts”)
a running task to handle the interrupt request from the hardware. Interrupng too late can result
in traffic loss if the traffic is not taken off the NIC soon enough—more traffic arrives, overwring
the previous traffic sll waing to be received into the kernel.To disable this funconality through
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the vSphere Web Client, go to VM Sengs > Opons > Advanced General > Configuraon
Parameters and add an entry for ethernetX.coalescingScheme with the value disabled.

To disable virtual interrupt coalescing for all virtual NICs on the host (which affects all VMs,
not just the latency-sensive ones), set the advanced networking performance opon. Go to
Configuraon > Advanced Sengs > Net and set CoalesceDefaultOn to 0 (disabled).

Enable Mulqueue Support on Intel x710/x520

Use ESXi 6.0.0 or later, with an ixgbe driver version with mulqueue support. See SR-IOV Driver
Versions in the Compability Matrix. Modify the .vmx file or access Advanced Sengs to enable
mulqueue support:

ethernetX.pnicFeatures = “4”

To set mul-core affinity so a vSwitch can exceed 300K PPS, set:

ethernetX.pnicFeatures = "4"
ethernetX.ctxPerDev = "1"

Seng ethernetX.ctxPerDev = “1”, is like a binary flag (set to 1 to enable). This binary flag
adds a CPU thread to process traffic only from the port ethernetX. This leads to improved traffic
scheduling performance.

NUMA and Resource Considerations

NUMA is Non-Uniform Memory Access. Mul-Core processors have complicated designs. To
tackle performance issues in such systems, you need to be aware of all NUMA and CPU Pinning
nuances. Vital aspects to look for:

• Which cores are our threads are running on? (if hyperthreading is enabled, check
Hyperthreading)

• Which cores are our vCPUs are running on? (affinity)
• In which NUMA socket is the physical NIC card installed?
• Where has memory been allocated? (NUMA effects)

Threads running on any socket see one unified memory space – therefore they can read/write
to memory that is local to other Sockets.

• Is memory shared between different sockets on a node?
• It takes more me to access memory on different sockets than it takes to access local memory.

NUMA effects occur when threads excessively access memory on a different NUMA
domain. To avoid cross-NUMA issues, avoid Quick Path Interconnect (QPi) between Socket 0
communicaon and Socket 1.

For latency-sensive VMs like PA-VM, VMware recommends that you do not over-commit vCPUs
as compared to the number of physical CPUs (processors) on the ESXi host. For example, if the
host has 8 CPU cores, limit the number of vCPUs for your VM to 7. This ensures that the ESXi
VMkernel scheduler has a beer chance of placing the vCPUs on pCPUs that won’t contend with
other scheduling contexts, such as vCPUs from other VMs or ESXi helper worlds. It is a good
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pracce to ensure that the number of vCPUs you allocate to the VM does not exceed the number
of acve CPU-consuming processes or threads in the VM.

For best performance, all vCPUs should be scheduled on the same NUMA node and all VM
memory should fit and be allocated out of the local physical memory aached to that NUMA
node. This can be changed using the VM seng numa.nodeAffinity=0, 1, … where 0, 1,
and so forth, are the socket numbers.

To ensure that the VM gets exclusive access to the CPU resources, set Latency Sensivity to High.
For the new seng to take effect, the VM CPU reservaon must be set to maximum, Memory
should be reserved, and the CPU limit must be set to unlimited.

• In newer versions, use the vSphere Web Client to set the VM Latency Sensivity opon to
High (the default is Normal).

• In older versions, set sched.cpu.latencySensitivity to High.
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Addionally, VM’s vCPUs can be pinned to host CPU cores using the VM seng Host Affinity so
that it is never scheduled to different cores. Keep NUMA and hyperthreading in mind when you
use Host Affinity. Avoid seng Host Affinity if the system is over commied. For more detail see
Potenal Issues with CPU Affinity.

Aer you implement the tuning parameters, use esxtop or CPU charts to check CPU Ready
(%RDY) and Co Stop (%CSTP) for the VM. Both values should be close to 0% to ensure exclusive
access to CPU resources. You can also use esxtop to check for NUMA usage and ensure memory
resources for the VM are not spread across NUMA nodes. For more detail, see Interpreng esxtop
Stascs.
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Use Cases
Use Case 1: vSwitch Deployment

The figure below shows a deployment of a PA-VM on an ESXi host where the data ports “Port
1” and “Port 2” are linked to eth1 and eth2 of the PA-VM. Each port hosts two queue pairs (for
example, Tx0/Rx0, and Tx1/Rx1) or has mulqueue enabled.

Enabling mulqueue and RSS for load balancing packets sent/received to/from mulple queues
enhances processing performance. Based on an internal logic of vCPU to port/queue mapping (in
this case) packets arriving and being sent out from P1/Q0 and P2/Q0 are processed by dataplane
task T1 running on (i.e., pinned to) vCPU1. The data plane task T2 follows a similar associaon, as
shown in the vSwitch deployment diagram above.

The two data plane tasks are running on vCPU1 and vCPU2 and these are non-sibling CPUs
(means that they do not share the same core in case of hyperthreading). This means that even
with hyperthreading enabled the task assignment can be pinned to different cores for high
performance. Also these dataplane task vCPUs all belong to the same NUMA node (or socket) to
avoid NUMA-related performance issues.

Two other performance bolenecks can be addressed with increasing the queue sizes and
dedicang a vCPU or thread to the ports that schedule traffic to and from these ports. Increasing
the queue sizes (Qsize) will accommodate large sudden bursts of traffic and prevent packet drops
under bursty traffic. Adding a dedicated CPU thread (ethernetX.ctxPerDev = 1) to port level
packet processing will allow traffic to be processed at a higher rate, thereby increasing the traffic
throughput to reach line rate.

The PA-VM packet processing technique also determines performance. This can be set to either
DPDK or PacketMMAP. DPDK uses a poll mode driver (depends on the driver type) to constantly
poll for packets received in the queues. This leads to higher throughput performance. Depending
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on the poll period is latency observed by the packets. If the polling is connuous (i.e., busy-poll
a seng from the PANOS cli) then the vCPU ulizaon for the data plane tasks will be a 100%
but will yield the best performance. Internally the soware uses a millisecond-level polling me to
prevent unnecessary ulizaon of CPU resources.

PacketMMAP, on the other hand, has a lower performance than DPDK but it works with any
network level drivers. For DPDK the vSwitch driver must have support for DPDK. PacketMMAP
works with interrupts that are raised when a packet is received by the port and placed in the
receive queue. This means that for every packet, or group of packets, interrupts are raised and
packets are drained off the receive queue for processing. This results in lower latency in packet
processing, but reduced throughput, because interrupts must be processed every me, causing
higher CPU overhead. In general PacketMMAP will have lower packet processing latency than
DPDK (without busy poll modificaon).

Use Case 2: SR-IOV Deployment

The SR-IOV diagram below shows a PAVM deployment similar to the vSwitch use case, but in SR-
IOV mode.

In SR-IOV the compable physical NIC port (manifests as a Physical Funcon) is essenally carved
out into mulple interfaces (manifests as Virtual Funcons). The figure above shows that NIC1
Port1 has a VF named VFX that is associated as one of the PAVM dataplane interfaces — eth1,
for example. A similar associaon is created for Port2 VF to PAVM eth2.The chain of packet
processing is similar to that of the deployment in the vSwitch environment. The only difference
is that the SR-IOV VF drivers should be compable with those used in PAN-OS. Also, since there
is no internal vSwitch (in the host) switching traffic, there is no need to set a dedicated thread
for traffic scheduling from a port (that is, ethernetX.ctxPerDev = 1 is not required in this
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seng). Interfaces with SR-IOV and DPDK will yield even higher packet processing performance
than the vSwitch use case.

References
• Tuning VMware vCloud NFV for Data-Intensive Workloads
• Best Pracces for Performance Tuning of Telco and NFV Workloads in vSphere
• Potenal Issues with CPU Affinity
• Interpreng esxtop Stascs
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vCloud Air

The VM-Series firewall can be deployed in a virtual data center (vDC) on vCloud Air
using the vCloud Air portal, from the vCloud Director portal or using the vCloud Air
API.

> About the VM-Series Firewall on vCloud Air
> Deployments Supported on vCloud Air
> Deploy the VM-Series Firewall on vCloud Air
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About the VM-Series Firewall on vCloud Air
You can deploy the VM-Series firewall in a virtual data center (vDC) on VMware vCloud Air using
the vCloud Air portal or from the vCloud Director portal. And to centrally manage all your physical
and VM-Series firewalls, you can use an exisng Panorama or deploy a new Panorama on premise
or on vCloud Air.

The VM-Series firewall on vCloud Air requires the following:

• ESXi version of the soware image, an Open Virtualizaon Alliance (OVA) file, from the Palo
Alto Networks Customer Support web site. Currently, the vCloud Air Marketplace does not
host the soware image.

In order to efficiently deploy the VM-Series firewall, include the firewall soware image in a
vApp. A vApp is a container for preconfigured virtual appliances (virtual machines and operang
system images) that is managed as a single object. For example, if your vApp includes a set of
mul-ered applicaons and the VM-Series firewall, each me you deploy the vApp, the VM-
Series firewall automacally secures the web server and database server that get deployed with
the vApp.

• License and subscripons purchased from a partner, reseller, or directly from Palo Alto
Networks, in the Bring Your Own License (BYOL) model; the usage-based licensing for the VM-
Series on vCloud Air is not available.

• Due to the security restricons imposed on vCloud Air, the VM-Series firewall on vCloud Air is
best deployed with Layer 3 interfaces and the interfaces must be enabled to use the hypervisor
assigned MAC address. If you do not enable hypervisor assigned MAC address, the VMware
vSwitch cannot forward traffic to the dataplane interfaces on the VM-Series firewall because
the vSwitch on vCloud Air does not support promiscuous mode or MAC forged transmits. The
VM-Series firewall cannot be deployed with tap interfaces, Layer 2 interfaces, or virtual wire
interfaces.

The VM-Series firewall on vCloud Air can be deployed in an acve/passive high availability
configuraon. However, the VM-Series firewall on vCloud Air does not support VM Monitoring
capabilies for virtual machines that are hosted on vCloud Air.

To learn all about vCloud Air, refer to the VMware vCloud Air documentaon.
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Deployments Supported on vCloud Air
To enable applicaons safely, block known and unknown threats, and to keep pace with changes
in your environment, you can deploy the VM-Series firewall on vCloud Air with Layer 3 interfaces
in the following ways:

• Secure the virtual data center perimeter—Deploy the VM-Series firewall as a virtual machine
that connects isolated and routed networks on vCloud Air. In this deployment the firewall
secures all north-south traffic traversing the infrastructure on vCloud Air.

• Set up a hybrid cloud—Extend your data center and private cloud into vCloud Air and use
a VPN connecon to enable communicaon between the corporate network and the data
center. In this deployment, the VM-Series firewall uses IPSec to encrypt traffic and secure users
accessing the cloud.

• Secure traffic between applicaon subnets in the vDC—To improve security, segment your
network and isolate traffic by creang applicaon ers, and then deploy the VM-Series firewall
to protect against lateral threats between subnets and applicaon ers.

The following illustraon combines all three deployments scenarios and includes Panorama.
Panorama streamlines policy updates, centralizes policy management, and provides centralized
logging and reporng.
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Deploy the VM-Series Firewall on vCloud Air
Use the instrucons in this secon to deploy your VM-Series firewall in an on-demand or
dedicated vDC on vCloud Air. This procedure assumes that you have set up your vDC, including
the gateways required to allow traffic in and out of the vDC, and the networks required for roung
management traffic and data traffic through the vDC.

STEP 1 | Obtain the VM-Series OVA image from the Palo Alto Networks Customer Support web site;
the vCloud Air Marketplace does not host the soware image currently.
1. Go to: www.paloaltonetworks.com/services/support.html.
2. Filter by PAN-OS for VM-Series Base Images and download the OVA image. For

example, PA-VM-ESX-9.1.0.ova.

STEP 2 | Extract the Open Virtualizaon Format (OVF) file from the OVA image and import the OVF
file in to your vCloud Air catalog.

When extracng files from the OVA image, make sure to place all the files—.mf, .ovf, and .vmdk
—within the same directory.

For instrucons to extract the OVF file from the OVA image, refer to the VMware
documentaon: hps://www.vmware.com/support/developer/ovf/#sthash.WUp55ZyE.dpuf

When you import the OVF file, the soware image for the VM-Series firewall is listed in My
Organizaon’s Catalogs.
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STEP 3 | Choose your workflow.

A vApp is a collecon of templates for preconfigured virtual appliances that contain virtual
machines, and operang system images.

• If you want to create a new vDC and a new vApp that includes the VM-Series firewall, go to
step 4

• If you have already deployed a vDC and have a vApp and now want to add the VM-Series
firewall to the vApp to secure traffic, go to step 5
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STEP 4 | Create a vDC and a vApp that includes the VM-Series firewall.
1. Log in to vCloud Air.
2. Select VPC OnDemand and select the locaon in which you want to deploy the VM-

Series firewall.

3. Select Virtual Data Centers and click + to add a new Virtual Data Center.
4. Select the vDC, right click and select Manage Catalogs in vCloud Director. You will be

redirected to the vCloud Director web interface.
5. Create a new vApp that contains one or more virtual machines including the VM-Series

firewall:

1. Select My Cloud > vApps, and click Build New vApp.

2. Select Name and Locaon, and the Virtual Datacenter in which this vApp will run. By
default, Leases for runme and storage never expire and the vApp is not automacally
stopped.

3. Add Virtual Machines. To add the VM-Series firewall image from the Look in: drop-
down, select My Organizaon’s Catalog, select the image and click Add. Click Next

4. Configure Resources to specify the Storage Policies for the virtual machines when
deployed. The VM-Series firewall uses the Standard opon.

5. Configure the Virtual Machines. Name each virtual machine and select the network
to which you want it to connect. You must connect NIC 0 (for management access) to
the default routed network; NIC 1 is used for data traffic. You can add addional NICs
later.

6. Verify the sengs and click Finish.
7. Connue to step 6.
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STEP 5 | Add the VM-Series Firewall into a vApp.
1. Log in to vCloud Air.
2. Select your exisng Virtual Data Center from the le pane, right click and select Manage

Catalogs in vCloud Director. You will be redirected to the vCloud Director web interface.
3. Select My Cloud > vApps and click the Name of the vApp in which to include the VM-

Series firewall.
4. Open the vApp (double-click on the name), select Virtual Machines and click  to add a

virtual machine.

1. In the Look in: drop-down, choose My Organizaon’s Catalog, select the VM-Series
firewall image and click Add. Click Next.

2. Click Next to skip Configure Resources. The VM-Series firewall uses the Standard
opon and you do not to modify the Storage Policy.

3. Enter a Name for the firewall and for management access (NIC 0), select the default
routed network and the IP Mode— Stac or DHCP. You can configure NIC 1 and add
addional NICs in step 6. Click Next.

4. Verify how this vApp connects to the vDC— Gateway Address and Network Mask for
the virtual machines in this vApp.

5. Verify that you have added the VM-Series firewall and click Finish.
6. Connue to step 6.
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STEP 6 | Connect the data interface(s) of the VM-Series firewall to an isolated or a routed network, as
required for your deployment.
1. In vCloud Director, select My Cloud > vApps and select the vApp you just created or

edited.
2. Select Virtual Machines and select the VM-Series firewall. Then, right-click and select

Properes.
3. Select Hardware, scroll to the NICs secon and select NIC 1.
4. Aach the dataplane network interface to a vApp network or an organizaonal VDC

network based on your connecvity needs for data traffic to the VM-Series firewall. To
create a new network:

1. In the Network drop-down, click Add Network.
2. Select the Network Type and give it a name and click OK.
3. Verify that the new network is aached to the interface.

5. To add addional NICs to the firewall, click Add and repeat step 4 above. You can aach
a maximum of seven dataplane interfaces to the VM-Series firewall.

6. Verify that the management interface of the VM-Series firewall is aached to the default
routed subnet on the vDC and at least one dataplane interface is connected to a routed
or isolated network.

1. Select My Cloud > vApps and double-click the Name of the vApp you just edited.
2. Verify network connecvity in the vApp Diagram.
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STEP 7 | (Oponal) Edit the hardware resources allocated for the VM-Series firewall.

Required only if you need to allot addional CPU, memory, or hard disk to the firewall.

1. Select My Cloud > vApps and double-click the Name of the vApp you just deployed.

2. Select Virtual Machine and click on the Name of the VM-Series firewall to access the
Virtual Machine Properes.

3. Add addional Hardware resources for the VM-Series firewall:

• See VM-Series System Requirements for the minimum vCPU, memory, and disk
requirements for your VM-Series model.

• NICs: One management and up to seven dataplane interfaces.

STEP 8 | Power on the VM-Series firewall.

STEP 9 | Configure an IP address for the VM-Series firewall management interface.

Perform Inial Configuraon on the VM-Series on ESXi.

The VM-Series firewall on vCloud Air supports VMware Tools, and you can Use VMware Tools
on the VM-Series Firewall on ESXi and vCloud Air to view the management IP address of the
VM-Series firewall.
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STEP 10 | Define NAT rules on the vCloud Air Edge Gateway to enable Internet access for the VM-
Series firewall.
1. Select Virtual Data Centers > Gateways, select the gateway and double-click to add NAT

Rules.
2. Create two DNAT rules. One for allowing SSH access and one for HTTPS access to the

management port’s IP address on the VM-Series firewall.
3. Create a SNAT rule for translang the internal source IP address for all traffic iniated

from the management port on the VM-Series firewall to an external IP address.

To send and receive traffic from the dataplane interfaces on the firewall, you
must create addional DNAT and SNAT rules on the vCloud Air Edge Gateway.

STEP 11 | Log in to the web interface of the firewall.

In this example, the URL for the web interface is hps://107.189.85.254

The NAT rule on the Edge Gateway translates the external IP address and port
107.189.85.254:443 to the private IP address and port 10.0.0.102:443.

STEP 12 | Add the auth code(s) to acvate the licenses on the firewall.

Acvate the License.

STEP 13 | Configure the VM-Series firewall to use the hypervisor assigned MAC address.

Hypervisor Assigned MAC Addresses
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STEP 14 | Configure the dataplane interfaces as Layer 3 interfaces.
1. Select Network > Interfaces > Ethernet.
2. Click the link for ethernet 1/1 and configure as follows:

• Interface Type: Layer3
• Select the Config tab, assign the interface to the default router.
• On the Config tab, select New Zone from the Security Zone drop-down. Define a new

zone, for example untrust, and then click OK.
• Select IPv4, assign a stac IP address.
• On Advanced > Other Info, expand the Management Profile drop-down, and select

New Management Profile.
• Enter a Name for the profile, such as allow_ping, and select Ping from the Permied

Services list, then click OK.
• To save the interface configuraon, click OK.

3. Repeat the process for each addional interface.
4. Click Commit to save the changes.
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Set Up the VM-Series Firewall on
VMware NSX-T

The VM-Series firewall can be deployed on VMware NSX-T to secure North-South and
East-West traffic.

> Set Up the VM-Series Firewall on VMware NSX-T (North-South)
> Set Up the VM-Series Firewall on NSX-T (East-West)
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Set Up the VM-Series Firewall on VMware NSX-T
(North-South)

The VM-Series firewall on VMware NSX-T integrates the Palo Alto next-generaon firewalls
and Panorama with ESXi host servers to provide comprehensive visibility and safe applicaon
enablement of all north-south traffic in your NSX-T soware-defined datacenter.

The following topics provide informaon about the VM-Series firewall on VMware NSX-T:

• Supported Deployments of the VM-Series Firewall on VMware NSX-T (North-South)
• Components of the VM-Series Firewall on NSX-T (North-South)
• Deploy the VM-Series Firewall on NSX-T (North-South)
• Extend Security Policy from NSX-V to NSX-T

Supported Deployments of the VM-Series Firewall on VMware
NSX-T (North-South)

You can deploy one or more instances of the VM-Series firewall as a partner service in your
VMware NSX-T Data Center. Aach a VM-Series firewall to any er-0 or er-1 logical router to
protect north-south traffic. You can deploy the VM-Series firewall as standalone service instance
or two firewalls in a high-availability (HA) pair. Panorama manages the connecon with NSX-T
Manager and the VM-Series firewalls deployed in your NSX-T soware-defined datacenter.

• Tier-0 Inseron—Tier-0 inseron deploys a VM-Series firewall to a er-0 logical router, which
processes traffic between logical and physical networks. When you deploy the VM-Series
firewall with er-0 inseron, NSX-T Manager uses the deployment informaon you configured
on Panorama to aach a firewall to a er-0 logical router in virtual wire mode.

• Tier-1 Inseron—Tier-1 inseron deploys a VM-Series firewall to a er-1 logical router, which
provides downlink connecons to segments and uplink connecon to er-0 logical routers.
NSX-T Manager aaches VM-Series firewalls deployed with er-1 inserons to a er-1 logical
router in virtual wire mode.

Aer deploying the firewall, you configure traffic redirecon rules that send traffic to the VM-
Series firewall when crossing a er-0 or er-1 router. Security policy rules that you configure on
Panorama are pushed to managed VM-Series firewalls and then applied to traffic passing through
the firewall.
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Components of the VM-Series Firewall on NSX-T (North-South)
The following tables show the components of this joint Palo Alto Networks and VMware NSX-T
soluon.

VMware Components

vCenter/ESXi The vCenter server is the centralized management
tool for the vSphere suite. ESXi is a hypervisor
that enables compute virtualizaon.

Refer to VMware’s Compability Matrix for
vCenter compability with your version of NSX-T.

NSX-T Manager VMware NSX-T Data Center 2.4.0 and later must
be installed and registered with the vCenter
server. The NSX-T Manager is required to deploy
the VM-Series firewall on the ESXi hosts within a
ESXi cluster.

Palo Alto Networks Components

PAN-OS The VM-Series base image (PA-VM-NST-9.1.zip) is
required for deploying the VM-Series firewall on
NSX-T.

The minimum system requirement for deploying
the VM-Series firewall for NSX on the ESXi
server depends on your VM-Series model. See
VM-Series Models for the minimum hardware
requirements for your VM-Series model.

Panorama

Panorama must be running the same
release version or later version that the
firewalls that it will manage.

The VM-Series firewall on NSX-T requires
Panorama 9.1 or later.

Panorama is the centralized management tool for
the Palo Alto Networks next-generaon firewalls.
In this soluon, Panorama works with the NSX-
T Manager to deploy, license, and centrally
administer—configuraon and policies—the VM-
Series firewall for NSX-T.

Panorama must be able to connect to the NSX-
T Manager, the VM-Series firewalls and the Palo
Alto Networks update server.

See the Panorama Administrator’s Guide for
informaon about deploying your Panorama
appliance.

VM-Series Deployment Guide Version Version 10.1 227 ©2022 Palo Alto Networks, Inc.

https://docs.paloaltonetworks.com/panorama/10-1/panorama-admin/set-up-panorama/set-up-the-panorama-virtual-appliance/setup-prerequisites-for-the-panorama-virtual-appliance.html


Set Up the VM-Series Firewall on VMware NSX-T

Palo Alto Networks Components

Panorama Plugin for VMware NSX 3.0.0 or later

VM-Series Plugin 1.0.6 or later

VM-Series Firewall Models The VM-100, VM-300, VM-500, and VM-700
support NSX-T.

Deploy the VM-Series Firewall on NSX-T (North-South)
Complete the following tasks to secure North-South traffic in your NSX-T environment with the
VM-Series firewall.

The following procedure refers to NSX-T Manager 3.0

.

• Install the Panorama Plugin for VMware NSX
• Enable Communicaon Between NSX-T Manager and Panorama
• Create Template Stacks and Device Groups on Panorama
• Configure the Service Definion on Panorama
• Deploy the VM-Series Firewall
• Direct Traffic to the VM-Series Firewall
• Apply Security Policy to the VM-Series Firewall on NSX-T
• Use vMoon to Move the VM-Series Firewall Between Hosts

Install the Panorama Plugin for VMware NSX
Download and install the Panorama Plugin for VMware NSX. See the Compability Matrix before
installing or upgrading your plugin.

If you have a Panorama HA configuraon, repeat this installaon process on each Panorama peer.
When installing the plugin on Panorama HA peers, install the plugin on the passive peer before
the acve peer. Aer installing the plugin on the passive peer, it will transion to a non-funconal
state. Installing the plugin on the acve peer returns the passive peer to a funconal state.

If you have a standalone Panorama or two Panorama appliances installed in an HA pair with
mulple plugins installed, plugins might not receive updated IP-tag informaon if one or more of
the plugins is not configured. This occurs because Panorama will not forward IP-tag informaon
to unconfigured plugins. Addionally, this issue can occur if one or more of the Panorama plugins
is not in the Registered or Success state (posive state differs on each plugin). Ensure that your
plugins are in the posive state before connuing or execung the commands described below.

If you encounter this issue, there are two workarounds:

• Uninstall the unconfigured plugin or plugins. It is recommended that you do not install a plugin
that you do not plan to configure right away
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• You can use the following commands to work around this issue. Execute the following
command for each unconfigured plugin on each Panorama instance to prevent Panorama from
waing to send updates. If you do not, your firewalls may lose some IP-tag informaon.

request plugins dau plugin-name <plugin-name> unblock-device-push yes

You can cancel this command by execung:

request plugins dau plugin-name <plugin-name> unblock-device-push no

The commands described are not persistent across reboots and must be used again for any
subsequent reboots. For Panorama in HA pair, the commands must be executed on each
Panorama.

STEP 1 | Select Panorama > Plugins. See the Compability Matrix before installing or upgrading your
plugin.

STEP 2 | Select Check Now to retrieve a list of available updates.

STEP 3 | Select Download in the Acon column to download the plugin.

STEP 4 | Select the version of the plugin and click Install in the Acon column to install the plugin.
Panorama will alert you when the installaon is complete.

Enable Communicaon Between NSX-T Manager and Panorama
Complete the following procedure to enable communicaon between Panorama and NSX-T
Manager. You can connect your Panorama to up to 16 NSX-T Managers. If you are connecng
your Panorama to mulple NSX-T Managers, you must carefully plan your device group hierarchy
and template stacks and consider how they interact with the other components needed for
deployment. Service definions reference device groups and template stacks and push that
informaon to the firewalls in the related ESXi clusters.

STEP 1 | (Oponal) Bypass proxy server sengs, configured on Panorama under Panorama > Setup
> Services > Proxy Server, for communicaon between Panorama and NSX-T Manager. This
command allows Panorama to communicate directly with NSX-T Manager while maintaining
proxied communicaon for other services.
1. Log in to the Panorama CLI.
2. Execute the following command to enable or disable proxy bypass.

admin@Panorama> request plugins vmware_nsx proxy bypass {yes |
no}

Select yes to enable proxy bypass and no to disable proxy bypass. This is set to no by
default.

STEP 2 | Log in to the Panorama web interface.

Using a secure connecon (hps) from a web browser, log in using the IP address and
password you assigned during inial configuraon (hps://<IP address>).
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STEP 3 | Set up access to the NSX-T Manager. Repeat this procedure for each NSX-T Manager to
which you will connect Panorama.
1. Select Panorama > VMware > NSX-T > Service Managers and click Add.
2. Enter a descripve Name for your NSX-T Manager.
3. (Oponal) Add a Descripon for NSX-T Manager.
4. Enter the NSX Manager URL—NSX-T Manager cluster virtual IP address or FQDN—at

which to access the NSX-T Manager.
5. Enter the NSX Manager Login credenals—username and password, so that Panorama

can authencate to the NSX-T Manager.
6. Click OK.

If you change your NSX-T Manager login password, ensure that you update the
password on Panorama immediately. An incorrect password breaks the connecon
between Panorama and NSX-T Manager.

STEP 4 | Commit your changes to Panorama.

Select Commit and Commit to Panorama.

STEP 5 | Verify the connecon status on Panorama.
1. Select Panorama > VMware > NSX-T > Service Managers.
2. Verify the message in the Status column.

When the connecon is successful, the status displays as Registered. This indicates that
Panorama and the NSX-T Manager are in sync.

The unsuccessful status messages are:

• No connecon: Unable to reach/establish a network connecon to the NSX-T
Manager.

• Invalid Credenals: The access credenals (username and/or password) are incorrect.
• Out of sync: The configuraon sengs defined on Panorama are different from what

is defined on the NSX-T Manager.Click the link for details on the reasons for failure.
For example, NSX-T Manager may have a service definion with the same name as
defined on Panorama. To fix the error, use the service definion name listed in the
error message to validate the service definion on the NSX-T Manager. Unl the
configuraon on Panorama and the NSX-T Manager is synchronized, you cannot add a
new service definion on Panorama.

• Connecon Disabled: The connecon between Panorama and the NSX-T Manager
was manually disabled.

Create Template Stacks and Device Groups on Panorama
To manage the VM-Series firewalls on NSX-T using Panorama, the firewalls must belong to a
device group and a template stack. Device groups allow you to assemble firewalls that need
similar policies and objects as a logical unit; the configuraon is defined using the Objects and
Policies tabs on Panorama. Use template stacks to configure the sengs that are required for
the VM-Series firewalls to operate on the network; the configuraon is defined using the Device
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and Network tabs on Panorama. Each template stack used in your NSX-T configuraon must be
associated with a service definion.

Firewalls deployed in NSX-T have two default zones and two interfaces configured in virtual-wire
mode. Ethernet1/1 is part of zone south and ethernet1/2 is part of zone north. To push policy
rules from Panorama to managed firewalls, you must configure zones and interfaces matching
those on the firewall in the corresponding template stack on Panorama.

STEP 1 | Add a device group or a device group hierarchy.
1. Select Panorama > Device Groups, and click Add. You can also create a device group

hierarchy.
2. Enter a unique Name and a Descripon to idenfy the device group.
3. Click OK.
4. Click Commit and select Panorama as the Commit Type to save the changes to the

running configuraon on Panorama.

STEP 2 | Add a template.
1. Select Panorama > Templates, and click Add.
2. Enter a unique Name and a Descripon to idenfy the template.
3. Click OK.
4. Click Commit, and select Panorama as the Commit Type to save the changes to the

running configuraon on Panorama.

STEP 3 | Create a template stack.
1. Select Panorama > Templates, and click Add Stack.
2. Enter a unique Name and a Descripon to idenfy the template.
3. Click Add to add the template you created previously.
4. Click OK.
5. Click Commit, and select Commit to Panorama to save the changes to the running

configuraon on Panorama.
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STEP 4 | Configure the virtual wire, interfaces, and zones. Ensure that you select the correct template
from the drop-down shown below. The objects you create must meet the following criteria:

If you change the default virtual wire or zone names, the virtual wire and zones on
Panorama must match the names used on the firewall.

• Use ethernet1/1 and ethernet1/2.
• The virtual wire object named vw1.
• The first zone named south, type virtual-wire, and contain ethernet1/1.
• The second zone named north, type virtual-wire, and contain ethernet1/2.

Repeat this process for each template in your deployment.

STEP 5 | Click Commit, and select Panorama as the Commit Type to save the changes to the running
configuraon on Panorama.

STEP 6 | Update the DNS and NTP server informaon of your template stack. You must complete this
step if you are using device cerficates in your deployment. This is required to ensure the
firewalls deployed in your NSX-T environment have the correct DNS informaon needed to
reach the device cerficate server.
1. Verify that you specified the correct template stack from the Template drop-down.
2. Select Device > Setup > Services and click the Edit icon.
3. On the Services tab, enter the IP address of the Primary DNS Server and Secondary DNS

Server.
4. On the NTP tab, enter the IP address of the NTP Server.
5. Click OK.
6. Commit your changes to Panorama.

Configure the Service Definion on Panorama
A service definion specifies the configuraon for the VM-Series firewalls installed in your NSX-T
data center environment. The service definion must include the device group, a template stack,
and an OVF URL.
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STEP 1 | Add a new service definion.

You can create up to 32 service definions on Panorama.

1. Select Panorama > VMware > NSX-T > Service Definions.
2. Select Add to create a new service definion.
3. Enter a descripve Name for your service definion.
4. ( Oponal) Add a Descripon that idenfies the funcon or purpose for the VM-Series

firewalls that will be deployed using this service definion.

STEP 2 | Assign a device group and a template stack to the service definion.

Make sure to Create Template Stacks and Device Groups on Panorama.

Because the firewalls deployed in this soluon will be centrally administered from Panorama,
you must specify the Device Group and the Template Stack that the firewalls belong to. All the
firewalls that are deployed using this service definion belong to the specified template stack
and device group.

1. Select the device group or device group hierarchy in the Device Group drop-down.
2. Select the template stack in the Template drop-down.

You cannot reuse a template stack or a device group assigned to one service
definion in another service definion.

STEP 3 | Specify the locaon of the OVF file.

Download the zip file, unzip it to extract and save the .ovf, mf and .vmdk files to the same
directory. The ovf and vmdk files are used to deploy each instance of the firewall.

If needed, modify the security sengs on the server so that you can download the file types.
For example, on the IIS server modify the Mime Types configuraon; on an Apache server edit
the .htaccess file.

Do not change the Panorama service definion OVF path aer a successful NSX
Service Deployment of VM-Series firewalls. Changing the OVF path, aer a successful
VM-Series firewall deployment, can result in a NSX Service Deployment failed state.
You may resolve this failure in NSX-T Manager, however this may cause all VM-Series
firewalls to redeploy.

It is recommended that you use an OVF path name that scales and allows you to change
the base image without impacng your deployed firewalls. Instead of a path such as hps://
acme.com/soware/PA-VM-NST.9.1.0.ovf, use something such as hps://acme.com/
soware/PanoSvcDef1-Cluster1.ovf. Using a stac path reference will eliminate any future
need to change the OVF path. It is recommended to create a path for each Panorama
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service definion (vSphere cluster) in your deployment and change the PAN-OS base images
references on the web server as needed.

In OVF URL, add the locaon of the web server that hosts the ovf file. Both hp and hps are
supported protocols.

Panorama must have network connecvity with the web server to retrieve the OVF file.

You can use the same ovf version or different versions across service definions. Using
different ovf versions across service definions allows you to vary the PAN-OS version on the
VM-Series firewalls in different ESXi clusters.

STEP 4 | Select North South as the Inseron Type for your firewall.

STEP 5 | To automacally retrieve a device cerficate when the VM-Series firewall is deployed by NSX
Manager, configure the device cerficate.

Enable this opon to apply a device cerficate to newly deployed VM-Series firewalls. Only
use this opon when deploying the firewall using a base image OVF that supports device
cerficates. Panorama pushes the device cerficate informaon to NSX Manager as part of the
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service definion. When a new firewall is deployed in NSX, the device cerficate is installed on
the firewall at bootup.

For list of OVFs that support device cerficates for the VM-Series firewall on VMware NSX,
see the Palo Alto Networks Compability Matrix.

If your OVF does support a device cerficate, you must Enable device cerficates regardless
of whether or not you are using a device cerficate. If your OVF does not support a device
cerficate, disable this opon.

1. If you have not done so already, log in to the Customer Support Portal and generate a
Registraon PIN and PIN ID.

2. Under Device Cerficate, click Enable.
3. Copy the PIN ID and enter it into the Device Cerficate PIN ID field.
4. Reenter the PIN ID into the Confirm Device Cerficate PIN ID field.
5. Copy the PIN Value and enter it into the Device Cerficate PIN Value field.
6. Reenter the PIN Value into the Confirm Device Cerficate PIN Value field.

STEP 6 | Click OK to save the service definion.

STEP 7 | Aach the service definion to the service manager.
1. Select Panorama > VMware > NSX-T > Service Manager and click the link of the service

manager name.
2. Under Service Definions, click Add and select your service definion from the drop-

down.
3. Click OK.
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STEP 8 | Add the authorizaon code to license the firewalls.
1. Select Panorama > Device Groups and choose the device group you associated with the

service definion you just created.
2. Under Dynamically Added Device Properes, add the authorizaon code you received

with your order fulfillment email and, oponally, select None from the SW Version drop-
down.

When a new firewall is deployed on NSX-T it is automacally added to the device group,
licensed using the authorizaon code you provided, and upgraded to the PAN-OS
version you specified.

On the support portal, you can view the total number of firewalls that you are authorized
to deploy and the rao of the number of licenses that have been used to the total
number of licenses enabled by your authorizaon code.

STEP 9 | Commit to Panorama.

STEP 10 | On the NSX-T Manager, verify that the service definion is available.

Select System > Service Deployments > Catalog. The service definion is listed as a Service
Instance on the NSX-T Manager.

Deploy the VM-Series Firewall
Aer compleng the configuraon on Panorama, perform the following procedure to launch the
VM-Series firewall in your NSX-T Data Center.

When deploying the VM-Series firewall on NSX-T in high availability, both firewalls are deployed
to the same Device Group and Template Stack.

STEP 1 | Log in to NSX-T Manager.

STEP 2 | Select System > Service Deployments > Deployment.

STEP 3 | Select your service definion from the Partner Service drop-down.

STEP 4 | Click Deploy Service.

STEP 5 | Enter a descripve Service Deployment Name for your VM-Series firewall.
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STEP 6 | Select a er-0 or er-1 router under Aachment Points. NSX-T Manager aaches the VM-
Series firewall to the selected router and redirects traffic passing through that router to the
VM-Series firewall for inspecon. You must select a router with no service inseron aached.

STEP 7 | Select a Compute Manager. The compute manager is the vCenter server managing your
datacenter.

STEP 8 | Select a Cluster. You can deploy the VM-Series firewall on any cluster that does not include
any Edge Transport Nodes.

STEP 9 | Select a Datastore.

STEP 10 | Configure your network sengs.
1. Click Edit Details in the Networks column.
2. Select the Primary Interface Network.
3. Enter the Primary Interface IP.
4. Enter the Primary Gateway Address.
5. Enter the Primary Subnet Mask.
6. Click Save.

STEP 11 | NSX-T Manager prepopulates the Deployment Specificaon and Deployment Template
based on the Partner Service you selected.

STEP 12 | Set the Failure Policy to Allow or Block. The failure policy defines how NSX-T Manager
handles traffic that is directed to the VM-Series firewall if the firewall becomes unavailable.

STEP 13 | Select the Deployment Mode for your VM-Series firewall—Standalone or High Availability.
If you have an edge node cluster and select High Availability, NSX-T Manager will deploy an
addional VM-Series firewall on the standby edge node in addion to the firewall deployed
on the acve edge node.

STEP 14 | Click Save to deploy the VM-Series firewall.

STEP 15 | Verify that your firewalls connected to Panorama.
1. Log in to Panorama.
2. Select Panorama > Managed Devices > Summary.
3. Confirm that your firewalls are listed under the correct device group and the Device

State shows Connected.

The Device Name for the VM-Series firewall is displayed on Panorama as PA-
VM:<nsx.clusterid> for NSX-T (N-S) deployment and as PA-VM:<nsx.servicevmid> for
NSX-T (E-W) deployment.

Direct Traffic to the VM-Series Firewall
Complete the following procedure to direct traffic to your VM-Series firewall. For North-South
traffic, redirecon rules are stateless by default and cannot be changed. Addionally, NSX-T
automacally creates a corresponding reflexive rule for return traffic.
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When you deploy the VM-Series firewall for NSX-T North-South in HA mode, you must create
a traffic redirecon rule for both HA peers. Addionally, you must create the redirecon rule for
acve peer first and the passive peer second.

The reflexive rule does not appear in the NSX-T web interface.

STEP 1 | Log in to NSX-T Manager.

STEP 2 | Verify that your are in Policy mode.

STEP 3 | Select Security > North South Security > Network Introspecon (N-S).

STEP 4 | Click Add Policy.

STEP 5 | Enter a descripve Name for your policy.

STEP 6 | Select a VM-Series firewall service instance from the Redirect To drop-down. NSX-T
Manager will automacally populate the Applied To field based on the service instance you
select.

STEP 7 | Select your newly created policy.

STEP 8 | Click Add Rule.

If your NSX-T environment has Edge Nodes in acve-standby HA, you must create a
redirect rule for each Edge Node. NSX-T does not automacally apply a redirect rule to
the standby node in the event of a failover.

STEP 9 | Click on the Name field and enter a descripve name for the rule.

STEP 10 | By default, the source is set to Any. Complete the following steps to specify a different
source.
1. Click on the edit buon in the Source column.
2. Select the group or groups to set as the Source or click Add Group to create a new group.
3. Click Apply.
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STEP 11 | By default, the desnaon is set to Any. Complete the following steps to specify a different
desnaon.
1. Click on the edit buon in the Desnaon column.
2. Select the group or groups to set as the Desnaon or click Add Group to create a new

group.
3. Click Apply.

STEP 12 | By default, Any service is redirected to the firewall. Complete the following steps to specify
certain services and protocols.
1. Click on the edit buon in the Services column.
2. Select the group or groups to set as the Service or click Add Service to create a new

service.
3. Click Apply.

STEP 13 | Select Redirect from the Acon drop-down to send traffic to your VM-Series firewall.

STEP 14 | Enable the rule. NSX-T Manager publishes the redirecon rule you just created and
automacally creates a reflexive rule for return traffic. The reflexive rule does not appear in
the NSX-T Manager web interface.

STEP 15 | If your VM-Series firewalls are deployed in HA, create another rule for the passive HA peer.

If return traffic is not directed to the VM-Series firewall, manually configure a traffic
redirecon rule for return traffic.

Apply Security Policy to the VM-Series Firewall on NSX-T
Now that you have deployed the VM-Series firewall and created traffic redirecon rules to send
traffic to the firewall, you can use Panorama to centrally manage security policy rules on the VM-
Series firewall.

STEP 1 | Log in to Panorama.
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STEP 2 | Create security policy rules.

By default, the firewall creates a rule that allows Bidireconal Forwarding Detecon
(BFD). Do not create a rule that blocks BFD. If BFD is blocked, NSX-T thinks that the
firewall is unavailable.

1. Select Policies > Security > Prerules.
2. Select the Device Group that you created for managing the VM-Series firewalls on NSX-

T in Create Template Stacks and Device Groups on Panorama.
3. Click Add and enter a Name and a Descripon for the rule. In this example, the security

rule allows all traffic between the WebFrontEnd servers and the Applicaon servers.
4. Select the Source Zone and Desnaon Zone.
5. For the Source Address and Desnaon Address, select or type in an address, stac

address group, or region.

The VM-Series firewall on NSX-T does not support dynamic address groups for
North-South traffic.

6. Select the Applicaon to allow. In this example, we create an Applicaon Group that
includes a stac group of specific applicaons that are grouped together.

1. Click Add and select New Applicaon Group.
2. Click Add to select the applicaon to include in the group.
3. Click OK to create the applicaon group.

7. Specify the acon— Allow or Deny—for the traffic, and oponally aach the default
security profiles for anvirus, an-spyware, and vulnerability protecon, under Profiles.

8. Click Commit, select Commit to Panorama. Click OK.

STEP 3 | Apply the policies to the VM-Series firewalls on NSX-T.
1. Click Commit > Push to Devices > Edit Selecons.
2. Select the device group and click OK.
3. Select Force Template Values. By default, Panorama does not override objects on the

firewall with objects on Panorama that share a name. You must select Force Template
Values to push policy to the managed firewalls.

4. Click Yes to confirm force template values.
5. Click OK.
6. Verify that the commit is successful.

STEP 4 | (Oponal) Use template to push a base configuraon for network and device configuraon
such as DNS server, NTP server, Syslog server, and login banner.

Refer to the Panorama Administrator’s Guide for informaon on using templates.

Use vMoon to Move the VM-Series Firewall Between Hosts
To maintain traffic flow while using vMoon to move your VM-Series firewall between ESXi hosts
with homogeneous CPU configuraons in VMware NSX-T, you must use the PAN-OS CLI to pause
the internal heartbeat monitoring of the VM-Series firewall during vMoon. You can specify the
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amount of me, in minutes, that heartbeat monitoring is paused. Heartbeat monitoring can be
paused for up to 60 minutes. When the pause interval expires or you deliberately end the pause
interval, heartbeat monitoring resumes.

vMoon of the VM-Series firewall is supported on vSphere 6.5, 6.7, and 7.0 if the ESXi hosts have
homogeneous CPU configuraon.

This procedure is not required when using vMoon to move the VM-Series firewall if you
are running vSphere 7.0 or later.

STEP 1 | Log in the VM-Series firewall CLI.

STEP 2 | Set the heartbeat monitoring pause interval using the following command. The pause begins
as soon as the command is executed. If vMoon is taking longer than expected, you can
rerun this command to set a new, longer interval that starts when the command is executed
again.

request system heartbeat-pause set interval <pause-time-in-minutes>

You can view the me remaining in pause interval using the following command.

request system heartbeat-pause show interval

STEP 3 | (Oponal) If you complete vMoon before the pause interval has elapsed, you can end the
pause by seng the interval to zero (0).

request system heartbeat-pause set interval 0

Extend Security Policy from NSX-V to NSX-T
If you are moving from an NSX-V deployment to an NSX-T deployment or combining an NSX-
T deployment with an NSX-V deployment, you can extend your exisng security policy from
NSX-V to NSX-T without having to recreate the policy rules. This is achieved by leveraging your
exisng device groups and sharing them between the NSX-V and NSX-T service definions. Aer
migrang your policy to NSX-T, you can connue using the VM-Series for NSX-V or remove your
NSX-V deployment.

STEP 1 | Install the Panorama Plugin for VMware NSX 3.2.0 or later. See the Panorama Plugin for
VMware NSX 3.2.0 Release Notes before upgrading.

STEP 2 | Configure an NSX-T service definion for each NSX-V service definion in your deployment.
Do not create new device groups; instead use your exisng NSX-V device groups. Using the
exisng device groups allows you to apply the same security policy rules used on NSX-V to
the VM-Series firewalls deployed on NSX-T. If you have policy that reference a parcular
zone, add the same template stack from your NSX-V service definion to your NSX-T service
definion. Addionally, if your device group references a parcular template, ensure that you
select the template stack that includes the template referenced in the device group.
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STEP 3 | Configure an NSX-T service manager and associate the NSX-T service definions to the
service manager.

STEP 4 | Prepare your NSX-T environment and deploy the VM-Series firewall. You must create your
security groups, service chains, and traffic redirecon policy before launching the VM-Series
firewall.

• Deploy the VM-Series Firewall on NSX-T (North-South)
• Deploy the VM-Series Using the Operaons-Centric Workflow

STEP 5 | Add the NSX-T tags to you exisng dynamic address groups.
1. Select Panorama > Objects > Address Groups.
2. Click on the name of an exisng NSX-V dynamic address group.
3. Click Add Match Criteria to display the tags from NSX-V and NSX-T.
4. Add the NSX-T tag to the dynamic address groups. Be sure to use the OR operator

between the tags.
5. When you have added all the necessary tags, click OK.
6. Commit your changes.

STEP 6 | Aer your VM workloads have successfully migrated from NSX-V to NSX-T, you remove
the NSX-V tags from your dynamic address groups if you plan to disconnue use of NSX-
V. All NSX-V tags and corresponding IP addresses are unregistered aer all NSX-V related
configuraon is removed from the Panorama plugin for NSX and VM-Series firewall
configuraon is removed from NSX-V manager.
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Set Up the VM-Series Firewall on NSX-T (East-West)
The VM-Series firewall on VMware NSX-T integrates the Palo Alto next-generaon firewalls
and Panorama with ESXi host servers to provide comprehensive visibility and safe applicaon
enablement of all East-West traffic in your NSX-T soware-defined data center.

• Components of the VM-Series Firewall on NSX-T (East-West)
• VM-Series Firewall on NSX-T (East-West) Integraon
• Supported Deployments of the VM-Series Firewall on VMware NSX-T (East-West)
• Deploy the VM-Series Using the Operaons-Centric Workflow
• Deploy the VM-Series Using the Security-Centric Workflow
• Delete a Service Definion from Panorama
• Migrate from VM-Series on NSX-T Operaon to Security Centric Deployment
• Extend Security Policy from NSX-V to NSX-T
• Use In-Place Migraon to Move Your VM-Series from NSX-V to NSX-T

Components of the VM-Series Firewall on NSX-T (East-West)
The following tables show the components of this joint Palo Alto Networks and VMware NSX-T
(East-West) soluon.

VMware Components

vCenter/ESXi The vCenter server is the centralized management
tool for the vSphere suite. ESXi is a hypervisor
that enables compute virtualizaon.

Refer to VMware’s Compability Matrix for
vCenter compability with your version of NSX-T.

NSX-T Manager VMware NSX-T Data Center 2.5.0 and later must
be installed and registered with the vCenter
server. The NSX-T Manager is required to deploy
the VM-Series firewall on the ESXi hosts within a
ESXi cluster.

Palo Alto Networks Components

PAN-OS PAN-OS 10.1.x and later.

The VM-Series base image, for example PA-VM-
NST-10.1.0zip, is required for deploying the VM-
Series firewall on NSX-T.

The minimum system requirement for deploying
the VM-Series firewall for NSX on the ESXi
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Palo Alto Networks Components

server depends on your VM-Series model. See
VM-Series Models for the minimum hardware
requirements for your VM-Series model.

Panorama

Panorama must be running the same
release version or later version that the
firewalls that it will manage.

The VM-Series firewall on NSX-T requires
Panorama 10.1.0 and later for firewalls running
10.1.0

Panorama is the centralized management tool for
the Palo Alto Networks next-generaon firewalls.
In this soluon, Panorama works with the NSX-
T Manager to deploy, license, and centrally
administer—configuraon and policies—the VM-
Series firewall for NSX-T.

Panorama must be able to connect to the NSX-
T Manager, the VM-Series firewalls and the Palo
Alto Networks update server.

See the 10.1 Panorama Administrator’s Guide
for informaon about deploying your Panorama
appliance.

Panorama Plugin for VMware NSX 3.1.0 or later

4.0.0 or later for the security-centric workflow

VM-Series Plugin 1.0.8 or later

VM-Series Firewall Models The VM-100, VM-300, VM-500, and VM-700
support NSX-T.

Before you deploy the VM-Series
firewall on NSX-T, ensure that you
have sufficient hardware resources
to support the number of VM-Series
firewalls in your chosen deployment
model (service cluster or per host).
This is crical when deploying large
firewalls, such as the VM-700.

VM-Series Firewall on NSX-T (East-West) Integraon
NSX-T Manager, vCenter, Panorama, and the VM-Series firewall work together to meet the
security challenges of your NSX-T Data Center.
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1. Register the VM-Series firewall as a service—Use Panorama to connect to your VMware NSX-
T manager. Panorama communicates with NSX-T Manager using the NSX-T API and establishes
bi-direconal communicaon. On Panorama, you configure the Service Manager by entering
the IP address, username, and password of NSX-T Manager to iniate communicaon.

Aer establishing communicaon with NSX-T Manager, configure the service definion. The
service definion includes the locaon of the VM-Series firewall base image, the authorizaon
code needed to license the VM-Series firewall, and the device groups and template stack to
which the firewall will belong.

Addionally, NSX-T Manager uses this connecon to send updates on the changes in the NSX-
T environment with Panorama.

2. Deploy the VM-Series firewall per host or in a service cluster—NSX-T Manager uses the
informaon pushed from Panorama in the service definion to deploy the VM-Series firewall.
Choose a where the VM-Series firewall will be deployed (in a service cluster or on each ESXi
host) and how NSX-T provides a management IP address to the VM-Series firewall (DHCP or
stac IP). When the firewall boots up, NSX-T manager’s API connects the VM-Series firewall to
the hypervisor so it that can receive traffic from the vSwitch.

3. The VM-Series connects to Panorama—The VM-Series firewall then connects to Panorama to
obtain its license. Panorama gets the license from the Palo Alto Networks update server and
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sends it to the firewall. When the firewall gets its license, it reboots and comes back up with a
serial number.

If Panorama does not have internet access, it cannot retrieve licenses and push them
to the firewall, so you have to manually license each firewall individually. If the VM-
Series firewall does not have internet access, you must manually add the serial numbers
to Panorama to register them as managed devices, so Panorama can push template
stacks, device groups, and other configuraon informaon. For more informaon, see
Acvate the License for the VM-Series Firewall for VMware NSX.

4. Panorama sends security policy to the VM-Series firewall—When the firewall reconnects to
Panorama, it is added to device group and template stack defined in the service definion and
Panorama pushes the appropriate security policy to that firewall. The firewall is now ready to
secure traffic in your NSX-T data center.

5. Create network introspecon rules to redirect traffic to the VM-Series firewall—On the NSX-
T Manager, create a service chain and network introspecon rules that redirect traffic in your
NSX-T data center.

6. Send real-me updates from NSX-T Manager—The NSX-T Manager sends real-me updates
about changes in the virtual environment to Panorama. These updates include changes in group
membership and IP addresses of virtual machines in groups that send traffic to the VM-Series
firewall.

7. Panorama sends dynamic updates—As Panorama receives updates from NSX-T Manager, it
sends those updates from its managed VM-Series firewalls. Panorama places virtual machines
into dynamic address groups based on criteria that you determine and pushes dynamic address
group membership informaon to the firewalls. This allows firewalls to apply the correct
security policy to traffic flowing to and from virtual machines in your NSX-T data center.

Supported Deployments of the VM-Series Firewall on VMware
NSX-T (East-West)

You can deploy one or more instances of the VM-Series firewall as a partner service in your
VMware NSX-T Data Center to secure East-West traffic and perform micro-segmentaon. To
configure the VM-Series firewall to perform micro-segmentaon, you can deploy the firewalls in a
service cluster or per host.

• Service Cluster—In a clustered deployment, all the VM-Series firewalls are installed on a
single cluster. Traffic between VMs and groups are redirected to the VM-Series cluster for
policy inspecon and enforcement before connuing to its desnaon. When you configure a
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clustered deployment, you can specify a parcular host within the cluster or select Any and let
NSX-T choose a host.

• Host-Based—In a per host deployment, an instance of the VM-Series firewall is installed on
each host in the ESXi cluster. Traffic between guests on the same host is inspected by the
local firewall, so it does not need to leave the host for inspecon. Traffic leaving the host is
inspected by the firewall before reaching the vSwitch.

Aer deploying the firewall, you configure traffic redirecon rules that send traffic to the VM-
Series firewall. Security policy rules that you configure on Panorama are pushed to managed VM-
Series firewalls and then applied to traffic passing through the firewall.

To deploy your VM-Series firewall on VMware NSX-T, you have two workflow opons—
operaons-centric and security-centric deployment.

• Operaons-centric—in an operaons-centric workflow, some porons of the deployment
procedure are performed on Panorama and the remainder are performed on NSX-T manager.
On Panorama, you must first enable communicaon between Panorama and NSX-T Manager,
configure the service definion, and launch the VM-Series firewall. Then, you must log in to
NSX-T Manager to connue the configuraon by creang service chains and steering rules. To
complete your VM-Series deployment, you must return to Panorama to create security policy.

• Security-centric—in a security-centric workflow, you can use Panorama as a single pane of glass
to control and manage security operaons. You complete the enre deployment workflow from
Panorama. The Panorama plugin for VMware NSX pushes configuraon to NSX-T Manager that
creates service chains and steering rules.
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It is recommended that you select one deployment workflow for your VM-Series deployment on
NSX-T for ease of use. However, the VM-Series firewall for VMware NSX-T does support the use
of both workflows on the same plugin.

Deploy the VM-Series Using the Operaons-Centric Workflow
Complete the following tasks to deploy the VM-Series firewall to secure East-West traffic in your
NSX-T data center.

• Install the Panorama Plugin for VMware NSX
• Enable Communicaon Between NSX-T Manager and Panorama
• Create Template Stacks and Device Groups on Panorama
• Configure the Service Definion on Panorama
• Launch the VM-Series Firewall on NSX-T (East-West)
• Add a Service Chain
• Direct Traffic to the VM-Series Firewall
• Apply Security Policies to the VM-Series Firewall on NSX-T (East-West)
• Use vMoon to Move the VM-Series Firewall Between Hosts

Install the Panorama Plugin for VMware NSX
Download and install the Panorama Plugin for VMware NSX. See the Compability Matrix before
installing or upgrading your plugin.

If you have a Panorama HA configuraon, repeat this installaon process on each Panorama peer.
When installing the plugin on Panorama HA peers, install the plugin on the passive peer before
the acve peer. Aer installing the plugin on the passive peer, it will transion to a non-funconal
state. Installing the plugin on the acve peer returns the passive peer to a funconal state.

If you have a standalone Panorama or two Panorama appliances installed in an HA pair with
mulple plugins installed, plugins might not receive updated IP-tag informaon if one or more of
the plugins is not configured. This occurs because Panorama will not forward IP-tag informaon
to unconfigured plugins. Addionally, this issue can occur if one or more of the Panorama plugins
is not in the Registered or Success state (posive state differs on each plugin). Ensure that your
plugins are in the posive state before connuing or execung the commands described below.

If you encounter this issue, there are two workarounds:

• Uninstall the unconfigured plugin or plugins. It is recommended that you do not install a plugin
that you do not plan to configure right away

• You can use the following commands to work around this issue. Execute the following
command for each unconfigured plugin on each Panorama instance to prevent Panorama from
waing to send updates. If you do not, your firewalls may lose some IP-tag informaon.

request plugins dau plugin-name <plugin-name> unblock-device-push yes

You can cancel this command by execung:

request plugins dau plugin-name <plugin-name> unblock-device-push no
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The commands described are not persistent across reboots and must be used again for any
subsequent reboots. For Panorama in HA pair, the commands must be executed on each
Panorama.

STEP 1 | Select Panorama > Plugins.

STEP 2 | Select Check Now to retrieve a list of available updates.

STEP 3 | Select Download in the Acon column to download the plugin.

STEP 4 | Select the version of the plugin and click Install in the Acon column to install the plugin.
Panorama will alert you when the installaon is complete.

Enable Communicaon Between NSX-T Manager and Panorama
Complete the following procedure to enable communicaon between Panorama and NSX-T
Manager. You can connect your Panorama to up to 16 NSX-T Managers. If you are connecng
your Panorama to mulple NSX-T Managers, you must carefully plan your device group hierarchy
and template stacks and consider how they interact with the other components needed for
deployment. Service definions reference device groups and template stacks and push that
informaon to the firewalls in the related ESXi clusters.

STEP 1 | (Oponal) Bypass proxy server sengs, configured on Panorama under Panorama > Setup
> Services > Proxy Server, for communicaon between Panorama and NSX-T Manager. This
command allows Panorama to communicate directly with NSX-T Manager while maintaining
proxied communicaon for other services.
1. Log in to the Panorama CLI.
2. Execute the following command to enable or disable proxy bypass.

admin@Panorama> request plugins vmware_nsx proxy bypass {yes |
no}

Select yes to enable proxy bypass and no to disable proxy bypass. This is set to no by
default.

STEP 2 | Log in to the Panorama web interface.

Using a secure connecon (hps) from a web browser, log in using the IP address and
password you assigned during inial configuraon (hps://<IP address>).
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STEP 3 | Set up access to the NSX-T Manager. Repeat this procedure for each NSX-T Manager to
which you will connect Panorama.
1. Select Panorama > VMware > NSX-T > Service Managers and click Add.
2. Enter a descripve Name for your NSX-T Manager.
3. (Oponal) Add a Descripon for NSX-T Manager.
4. Enter the NSX Manager URL—NSX-T Manager cluster virtual IP address or FQDN—at

which to access the NSX-T Manager.
5. Enter the NSX Manager Login credenals—username and password, so that Panorama

can authencate to the NSX-T Manager.
6. Click OK.

If you change your NSX-T Manager login password, ensure that you update the
password on Panorama immediately. An incorrect password breaks the connecon
between Panorama and NSX-T Manager.

STEP 4 | Commit your changes to Panorama.

Select Commit and Commit to Panorama.

STEP 5 | Verify the connecon status on Panorama.
1. Select Panorama > VMware > NSX-T > Service Managers.
2. Verify the message in the Status column.

When the connecon is successful, the status displays as Registered. This indicates that
Panorama and the NSX-T Manager are in sync.

The unsuccessful status messages are:

• No connecon: Unable to reach/establish a network connecon to the NSX-T
Manager.

• Invalid Credenals: The access credenals (username and/or password) are incorrect.
• Out of sync: The configuraon sengs defined on Panorama are different from what

is defined on the NSX-T Manager.Click the link for details on the reasons for failure.
For example, NSX-T Manager may have a service definion with the same name as
defined on Panorama. To fix the error, use the service definion name listed in the
error message to validate the service definion on the NSX-T Manager. Unl the
configuraon on Panorama and the NSX-T Manager is synchronized, you cannot add a
new service definion on Panorama.

• Connecon Disabled: The connecon between Panorama and the NSX-T Manager
was manually disabled.

Create Template Stacks and Device Groups on Panorama
To manage the VM-Series firewalls for NSX-T using Panorama, the firewalls must belong to a
device group and a template that is a member of a template stack. Device groups allow you to
assemble firewalls that need similar policies and objects as a logical unit; the configuraon is
defined using the Objects and Policies tabs on Panorama. Use template stacks to configure the
sengs that are required for the VM-Series firewalls to operate on the network and associate;
the configuraon is defined using the Device and Network tabs on Panorama. And each template
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stack with zones used in your NSX-T configuraon on Panorama must be associated with a service
definion; at a minimum, you must create a zone within the template stack so that the NSX-T
Manager can redirect traffic to the VM-Series firewall.

Panorama can support deployments of both NSX-T North-South and NSX-T East-West at the
same me. It is recommend that you configure separate device groups, template stacks, and
service definions for NSX-T North-South and NSX-T East-West.

STEP 1 | Add a device group or a device group hierarchy.
1. Select Panorama > Device Groups, and click Add. You can also create a device group

hierarchy.
2. Enter a unique Name and a Descripon to idenfy the device group.
3. Click OK.
4. Click Commit and select Panorama as the Commit Type to save the changes to the

running configuraon on Panorama.

STEP 2 | Add a template.
1. Select Panorama > Templates, and click Add.
2. Enter a unique Name and a Descripon to idenfy the template.
3. Click OK.
4. Click Commit, and select Panorama as the Commit Type to save the changes to the

running configuraon on Panorama.

STEP 3 | Create a template stack.
1. Select Panorama > Templates, and click Add Stack.
2. Enter a unique Name and a Descripon to idenfy the template.
3. Click OK.
4. Click Commit, and select Commit to Panorama to save the changes to the running

configuraon on Panorama.
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STEP 4 | Create the zone(s) for each template.

Each zone is mapped to a service profile on NSX-T Manager. To qualify, a zone must be of the
virtual wire type and a template associated with a service definion.

You can add up to 32 zones in each template.

1. Select Network > Zones.
2. Select the correct template in the Template drop-down.
3. Select Add and enter a zone Name.
4. Set the interface Type to Virtual Wire.
5. Click OK.
6. Verify that the zones are aached to the correct template.

7. Click Commit, and select Panorama as the Commit Type to save the changes to the
running configuraon on Panorama.

Panorama creates a corresponding service profile on NSX-T Manager for each qualified
zone upon commit.

STEP 5 | Update the DNS and NTP server informaon of your template stack. You must complete this
step if you are using device cerficates in your deployment. This is required to ensure the
firewalls deployed in your NSX-T environment have the correct DNS informaon needed to
reach the device cerficate server.
1. Verify that you specified the correct template stack from the Template drop-down.
2. Select Device > Setup > Services and click the Edit icon.
3. On the Services tab, enter the IP address of the Primary DNS Server and Secondary DNS

Server.
4. On the NTP tab, enter the IP address of the NTP Server.
5. Click OK.
6. Commit your changes to Panorama.

Configure the Service Definion on Panorama
A service definion specifies the configuraon for the VM-Series firewalls installed in your NSX-T
data center environment. The service definion must include the device group, a template stack,
and an OVF URL.

STEP 1 | (Oponal) Configure a Nofy Group

Create a nofy group by specifying devices groups that should be nofied of changes in
the virtual environment. The firewalls included in the specified device groups receive a real-
me update of security groups and IP addresses of guest VMs in them. The firewalls use this
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update to determine the most current list of members that constute dynamic address groups
referenced in policy

1. Select Panorama > VMware > Nofy Group and click Add.
2. Give your Nofy Group a descripve Name.
3. Select the boxes of all devices groups that should be nofied of changes to the virtual

environment. If a device group does not have a check box available, it means that the
device group is automacally included by virtue of the device group hierarchy.

4. Click OK.

STEP 2 | Add a new service definion.

You can create up to 32 service definions on Panorama.

1. Select Panorama > VMware > NSX-T > Service Definions.
2. Select Add to create a new service definion.
3. Enter a descripve Name for your service definion.
4. (Oponal) Add a Descripon that idenfies the funcon or purpose for the VM-Series

firewalls that will be deployed using this service definion.

STEP 3 | Assign a device group and a template stack to the service definion.

Make sure to Create Template Stacks and Device Groups on Panorama.

Because the firewalls deployed in this soluon will be centrally administered from Panorama,
you must specify the Device Group and the Template Stack that the firewalls belong to. All the
firewalls that are deployed using this service definion belong to the specified template stack
and device group.

1. Select the device group or device group hierarchy in the Device Group drop-down.
2. Select the template stack in the Template drop-down.

You cannot reuse a template stack or a device group assigned to one service
definion in another service definion.

STEP 4 | Specify the locaon of the OVF file.

Download the zip file, unzip it to extract and save the .ovf, mf and .vmdk files to the same
directory. The ovf and vmdk files are used to deploy each instance of the firewall.

Do not change the Panorama service definion OVF path aer a successful NSX
Service Deployment of VM-Series firewalls. Changing the OVF path, aer a successful
VM-Series firewall deployment, can result in a NSX Service Deployment failed state.
You may resolve this failure in NSX-T Manager, however this may cause all VM-Series
firewalls to redeploy.

It is recommended that you use an OVF path name that scales and allows you to change
the base image without impacng your deployed firewalls. Instead of a path such as hps://
acme.com/soware/PA-VM-NST.9.1.0.ovf, use something such as hps://acme.com/
soware/PanoSvcDef1-Cluster1.ovf. Using a stac path reference will eliminate any future
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need to change the OVF path. It is recommended to create a path for each Panorama
service definion (vSphere cluster) in your deployment and change the PAN-OS base images
references on the web server as needed.

In OVF URL, add the locaon of the web server that hosts the ovf file. Both hp and hps are
supported protocols.

You can use the same ovf version or different versions across service definions. Using
different ovf versions across service definions allows you to vary the PAN-OS version on the
VM-Series firewalls in different ESXi clusters.

STEP 5 | (Oponal) Select a Nofy Group.

STEP 6 | Select East West as the Inseron Type for your firewall.

STEP 7 | (Oponal) Enable Health Check. Health check is enabled by default in Panorama plugin for
VMware NSX 3.2.0 and later. In older versions of the plugin, health check is disabled by
default. Also called service health check, this NSX-T feature allows you to simulate high
availability in the case of a service instance failing. When configured with the VM-Series
firewall, if a VM-Series service instance fails, any traffic directed to that firewall is redirect to
another firewall instance in the cluster (for service cluster deployments) or a firewall instance
on another host (for host-based deployments).

You cannot disable or enable Health Check in a service definion aer comming
and deploying VM-Series firewalls in NSX-T. Aempng to commit a change in the
Health Check configuraon returns commit failure. To change this, you must delete and
recreate your service definion and redeploy your VM-Series firewalls.

STEP 8 | To automacally retrieve a device cerficate when the VM-Series firewall is deployed by NSX
Manager, configure the device cerficate.

Enable this opon to apply a device cerficate to newly deployed VM-Series firewalls. Only
use this opon when deploying the firewall using a base image OVF that supports device
cerficates. Panorama pushes the device cerficate informaon to NSX Manager as part of the
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service definion. When a new firewall is deployed in NSX, the device cerficate is installed on
the firewall at bootup.

For list of OVFs that support device cerficates for the VM-Series firewall on VMware NSX,
see the Palo Alto Networks Compability Matrix.

If your OVF does support a device cerficate, you must Enable device cerficates regardless
of whether or not you are using a device cerficate. If your OVF does not support a device
cerficate, disable this opon.

1. If you have not done so already, log in to the Customer Support Portal and generate a
Registraon PIN and PIN ID.

2. Under Device Cerficate, click Enable.
3. Copy the PIN ID and enter it into the Device Cerficate PIN ID field.
4. Reenter the PIN ID into the Confirm Device Cerficate PIN ID field.
5. Copy the PIN Value and enter it into the Device Cerficate PIN Value field.
6. Reenter the PIN Value into the Confirm Device Cerficate PIN Value field.

STEP 9 | Click OK to save the service definion.

VM-Series Deployment Guide Version Version 10.1 255 ©2022 Palo Alto Networks, Inc.

https://docs.paloaltonetworks.com/compatibility-matrix/panorama/plugins.html
https://support.paloaltonetworks.com


Set Up the VM-Series Firewall on VMware NSX-T

STEP 10 | Aach the service definion to the service manager.

You cannot use a service definion in more than one service manager.

1. Select Panorama > VMware > NSX-T > Service Manager and click the link of the service
manager name.

2. Under Service Definions, click Add and select your service definion from the drop-
down.

3. Click OK.

STEP 11 | Add the authorizaon code to license the firewalls.
1. Select Panorama > Device Groups and choose the device group you associated with the

service definion you just created.
2. Under Dynamically Added Device Properes, add the authorizaon code you received

with your order fulfillment email and, oponally, select None from the SW Version drop-
down.

When a new firewall is deployed on NSX-T it is automacally added to the device group,
licensed using the authorizaon code you provided, and upgraded to the PAN-OS
version you specified.

On the support portal, you can view the total number of firewalls that you are authorized
to deploy and the rao of the number of licenses that have been used to the total
number of licenses enabled by your authorizaon code.

STEP 12 | Commit to Panorama.
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STEP 13 | On the NSX-T Manager, verify that the service definion is available.

Select System > Service Deployments > Catalog. The service definion is listed as a Service
Instance on the NSX-T Manager.

Launch the VM-Series Firewall on NSX-T (East-West)
Complete the following procedure to deploy the VM-Series firewall as a service in your NSX-T
environment. The Deployment Specificaon and Deployment Template fields are automacally
populated with informaon pushed from Panorama as part of the service definion.

Do not edit any sengs under Deployment Aributes. These values are imported from
Panorama and changing them causes the deployment to fail.

STEP 1 | Log in to the NSX-T Manager.

STEP 2 | Select System > Service Deployments > Deployment.

STEP 3 | Select your service definion from the Partner Service drop-down.

STEP 4 | Click Deploy Service.

STEP 5 | Enter a descripve Name for your service deployment.

STEP 6 | Select the Compute Manager (vCenter).

STEP 7 | Select a Deployment Type—Clustered or Host Based.

STEP 8 | If you selected Clustered as the Deployment Type, enter the Clustered Deployment Count
to specify the number of VM-Series firewall instances to deploy on the cluster.

STEP 9 | Select a Host if you are launching the VM-Series in a clustered deployment. Select a
parcular host from the Host drop-down or Any to allow NSX-T Manager to choose the host.
This opon is grayed out in Per Host deployments.

STEP 10 | Select a Data Store as the repository for the VM-Series firewall. In a clustered deployment,
select a shared data store if you choose Any for the host or select a local data store if you
specified a parcular host.

STEP 11 | Configure the Networks sengs.
1. In the Networks column, click Set.
2. Select the Network for eth0 - Management Nic.
3. Select the Network Type—DHCP or Stac IP Pool. If you choose Stac IP Pool, select an

IP Pool.
4. Check eth1 - Data-1 Nic.
5. Click Save.
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STEP 12 | Select or configure a Service Segment. To configure a service segment, complete the
following procedure.
1. Click Acon in the Service Segments column.

2. Click Add Service Segment.
3. Enter a descripve Name.
4. Select a Transport Zone (Overlay).
5. Click Save and Close.

STEP 13 | Select the Cluster where the service will be deployed. You must select a cluster with NSX
Configuraon.

STEP 14 | Click Save.

STEP 15 | Verify that your firewalls deployed successfully.
1. Select System > Service Deployments > Service Instances.
2. Confirm that your firewalls are listed and the Deployment Status shows Up.

STEP 16 | Verify that your firewalls connected to Panorama.
1. Log in to Panorama.
2. Select Panorama > Managed Devices > Summary.
3. Confirm that your firewalls are listed under the correct device group and the Device

State shows Connected.

The Device Name for the VM-Series firewall is displayed on Panorama as PA-
VM:<nsx.clusterid> for NSX-T (N-S) deployment and as PA-VM:<nsx.servicevmid> for
NSX-T (E-W) deployment.

Add a Service Chain
A service chain is a grouping of services set in logical sequence. When traffic is redirected to the
service chain, it moves through each service in the order you configure.

STEP 1 | Select Security > Network Introspecon Sengs > Service Chains > Add Chain.

STEP 2 | Enter a descripve Name and Descripon (oponal) for your service chain.

STEP 3 | Select the Service Segment that you applied when you deployed the VM-Series firewall.
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STEP 4 | Set the forward path. The service chain is a logical sequence of service profiles, so traffic
moves through the services in the order you specify as the forward path.
1. Select Set Forward Path > Add Profile in Sequence.
2. Select a service profile. The service column is populated automacally based on the

service profile you select.
3. Click Add.
4. (Oponal) If you have other partner service profiles in your NSX-T environment, click

Add Profile in Sequence to add them to this service chain.

You can select only one service profile per service definion.

5. Click Save when you have finished adding service profiles.

STEP 5 | In the Reverse Path column, check Inverse ForwardPath for return traffic to move through
the service chain in reverse order.

STEP 6 | (Oponal) If other partner service profiles are selected, set a reverse path.

You must select the same VM-Series service profile set in the Forward Path.

1. Select Set Reverse Path > Add Profile in Sequence.
2. Select a service profile. The service column is populated automacally based on the

service profile you select.
3. Click Add.
4. (Oponal) If you have other, service profiles in your NSX-T environment, click Add Profile

in Sequence to add them to this service chain.
5. Click Save when you have finished adding service profiles.

STEP 7 | Set the Failure Policy—Allow or Block. This defines the acon NSX-T takes if a service profile
fails.

STEP 8 | Click Save.

Direct Traffic to the VM-Series Firewall
Configure policy rules to direct traffic virtual machines or groups of virtual machines to the VM-
Series firewall.

STEP 1 | Select Security > Network Introspecon (E-W) > Rules > Add Policy.

STEP 2 | Click New Policy to give your policy a descripve name.

STEP 3 | Select your service chain from the Redirect To drop-down.
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STEP 4 | Select the policy and click Add Rule.

STEP 5 | Click New Rule to give your rule a descripve name.

STEP 6 | Select a source.
1. Click the pencil icon in the source column to choose a source group of virtual machines.

2. Check the source group or groups.
3. Click Apply.
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STEP 7 | Select a Desnaon.
1. Click the pencil icon in the desnaon column to choose a source group of virtual

machines.

2. Check the desnaon group or groups.
3. Click Apply.

STEP 8 | (Oponal) Select Services to which the rule will be applied.

STEP 9 | Choose one of the following in the Applied To field:

• Select DFW to apply the rule to all virtual NICs aached to the logical switch.
• Select Groups to apply the rule to virtual NICs of members virtual machines in the specified

group or groups.

STEP 10 | Select the Acon—Redirect or Do Not Redirect.

STEP 11 | Click Publish.

STEP 12 | Repeat this process to create addional policy or rules.

Apply Security Policies to the VM-Series Firewall on NSX-T (East-West)
Now that you have created the redirecon rules on the NSX-T Manager, you can now use
Panorama for centrally administering policies on the VM-Series firewalls.

To manage centralized policy, aach the dynamic address group as a source or desnaon
address in security policy and push it to the firewalls; the firewalls can dynamically retrieve the IP
addresses of the virtual machines that are included in each security group to enforce compliance
for traffic that originates from or is desned to the virtual machines in the specified group.
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STEP 1 | Log in to Panorama.

STEP 2 | Create dynamic-address groups.
1. Select Objects > Address Groups.
2. Select the Device Group you created for managing your VM-Series on NSX-T firewall

from the Device Group drop-down.
3. Click Add and enter a Name and Descripon for the dynamic address group.
4. Select Type as Dynamic.
5. Add Match Criteria to your dynamic address group.

Some browser extensions may block API calls between Panorama and NSX-T
which prevents Panorama from receiving match criteria. If Panorama displays no
match criteria and you are using browser extensions, disable the extensions and
Synchronize Dynamic Objects to populate the tags available to Panorama.

6. Click Add Match Criteria.
7. Select the And or Or operator and click the plus (+) icon next to the security group name

to add it to the dynamic address group.

The security groups that display in the match criteria dialog are derived from the
groups you defined on the NSX-T Manager. Only the groups that are referenced
in the security policies and from which traffic is redirected to the VM-Series
firewall are available here.

8. Click OK.
9. Repeat these steps to create the appropriate number of dynamic address groups required

for your deployment.
10. Commit your changes.
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STEP 3 | Create security policy rules.

1. Select Policies > Security > Prerules.
2. Select the Device Group that you created for managing the VM-Series firewalls on NSX-

T in Create Template Stacks and Device Groups on Panorama.
3. Click Add and enter a Name and a Descripon for the rule. In this example, the security

rule allows all traffic between the WebFrontEnd servers and the Applicaon servers.
4. Select the Source Zone and Desnaon Zone. The zone name must be the same in both

columns.
5. For the Source Address and Desnaon Address, select or type in an address, address

group or region. In this example, we select an address group, the Dynamic address group
you created previously.

6. Select the Applicaon to allow. In this example, we create an Applicaon Group that
includes a stac group of specific applicaons that are grouped together.

1. Click Add and select New Applicaon Group.
2. Click Add to select the applicaon to include in the group.
3. Click OK to create the applicaon group.

7. Specify the acon— Allow or Deny—for the traffic, and oponally aach the default
security profiles for anvirus, an-spyware, and vulnerability protecon, under Profiles.

8. Repeats the steps above to create the pernent policy rules.
9. Click Commit, select Commit Type as Panorama. Click OK.

STEP 4 | Apply the policies to the VM-Series firewalls for NSX-T.
1. Click Commit, and select Commit Type Device Groups.
2. Select the device group, NSX-T Device Group in this example and click OK.
3. Verify that the commit is successful.

STEP 5 | Validate that the members of the dynamic address group are populated on the VM-Series
firewall.
1. From Panorama, switch device context to launch the web interface of a firewall to which

you pushed policies.
2. On the VM-Series firewall, select Policies > Security, and select a rule.
3. Select the drop-down arrow next to the address group link, and select Inspect. You can

also verify that the match criteria is accurate.

4. Click the more link and verify that the list of registered IP addresses is displayed.

Policy will be enforced for all IP addresses that belong to this address group, and are
displayed here.
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STEP 6 | (Oponal) Use template to push a base configuraon for network and device configuraon
such as DNS server, NTP server, Syslog server, and login banner.

Refer to the Panorama Administrator’s Guide for informaon on using templates.

STEP 7 | Create a Zone Protecon profile and aach it to a zone.

A zone protecon profile provides flood protecon and has the ability to protect against port
scanning, port sweeps and packet-based aacks. It allows you to secure intra-er and inter-er
traffic between virtual machines within your data center and traffic from the Internet that is
desned to the virtual machines (workloads) in your data center.

1. Select your Template.
2. Select Network > Network Profiles > Zone Protecon to add and configure a new

profile.
3. Select Network > Zones, click the default-zone listed and select the profile in the Zone

Protecon Profile drop down.

STEP 8 | Create a DoS Protecon profile and aach it to DoS Protecon policy rule.
1. Select your Device Group.
2. Select Objects > Security Profiles > DoS Protecon to add and configure a new profile.

• A classified profile allows the creaon of a threshold that applies to a single source IP.
For example, you can configure a max session rate for an IP address that matched the
policy, and then block that single IP address once the threshold is triggered.

• An aggregate profile allows the creaon of a max session rate for all packets matching
the policy. The threshold applies to new session rate for all IP addresses combined.
Once the threshold is triggered it affects all traffic that matches the policy.

3. Create a new DoS Protecon policy rule in Policy > DoS Protecon, and aach the new
profile to it.

Use vMoon to Move the VM-Series Firewall Between Hosts
To maintain traffic flow while using vMoon to move your VM-Series firewall between ESXi hosts
with homogeneous CPU configuraons in VMware NSX-T, you must use the PAN-OS CLI to pause
the internal heartbeat monitoring of the VM-Series firewall during vMoon. You can specify the
amount of me, in minutes, that heartbeat monitoring is paused. Heartbeat monitoring can be
paused for up to 60 minutes. When the pause interval expires or you deliberately end the pause
interval, heartbeat monitoring resumes.

vMoon of the VM-Series firewall is supported on vSphere 6.5, 6.7, and 7.0 if the ESXi hosts have
homogeneous CPU configuraon.

This procedure is not required when using vMoon to move the VM-Series firewall if you
are running vSphere 7.0 or later.

STEP 1 | Log in the VM-Series firewall CLI.

STEP 2 | Set the heartbeat monitoring pause interval using the following command. The pause begins
as soon as the command is executed. If vMoon is taking longer than expected, you can
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rerun this command to set a new, longer interval that starts when the command is executed
again.

request system heartbeat-pause set interval <pause-time-in-minutes>

You can view the me remaining in pause interval using the following command.

request system heartbeat-pause show interval

STEP 3 | (Oponal) If you complete vMoon before the pause interval has elapsed, you can end the
pause by seng the interval to zero (0).

request system heartbeat-pause set interval 0

Deploy the VM-Series Using the Security-Centric Workflow
You can use the security-centric workflow to control and manage your VM-Series firewall for
NSX-T from Panorama. You do not need to access NSX-T Manager to create service chains and
steering rules; however, the service deployment must sll be created on NSX-T Manager.

• Install the Panorama Plugin for VMware NSX
• Enable Communicaon Between NSX-T Manager and Panorama
• Create Template Stacks and Device Groups on Panorama
• Configure the Service Definion on Panorama
• Launch the VM-Series Firewall on NSX-T (East-West)
• Create Dynamic Address Groups
• Create Security Policies
• Create Dynamic Address Group Membership Criteria
• Generate Steering Policy
• Generate Steering Rules

Install the Panorama Plugin for VMware NSX
Download and install the Panorama Plugin for VMware NSX. See the Compability Matrix before
installing or upgrading your plugin.

The security-centric deployment workflow requires Panorama plugin for VMware NSX
4.0.0. Addionally, you must upgrade to plugin 4.0.0 from Panorama plugin for VMware
NSX 3.2.x

If you have a Panorama HA configuraon, repeat this installaon process on each Panorama peer.
When installing the plugin on Panorama HA peers, install the plugin on the passive peer before
the acve peer. Aer installing the plugin on the passive peer, it will transion to a non-funconal
state. Installing the plugin on the acve peer returns the passive peer to a funconal state.

If you have a standalone Panorama or two Panorama appliances installed in an HA pair with
mulple plugins installed, plugins might not receive updated IP-tag informaon if one or more of
the plugins is not configured. This occurs because Panorama will not forward IP-tag informaon
to unconfigured plugins. Addionally, this issue can occur if one or more of the Panorama plugins
is not in the Registered or Success state (posive state differs on each plugin). Ensure that your
plugins are in the posive state before connuing or execung the commands described below.
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If you encounter this issue, there are two workarounds:

• Uninstall the unconfigured plugin or plugins. It is recommended that you do not install a plugin
that you do not plan to configure right away

• You can use the following commands to work around this issue. Execute the following
command for each unconfigured plugin on each Panorama instance to prevent Panorama from
waing to send updates. If you do not, your firewalls may lose some IP-tag informaon.

request plugins dau plugin-name <plugin-name> unblock-device-push yes

You can cancel this command by execung:

request plugins dau plugin-name <plugin-name> unblock-device-push no

The commands described are not persistent across reboots and must be used again for any
subsequent reboots. For Panorama in HA pair, the commands must be executed on each
Panorama.

STEP 1 | Select Panorama > Plugins.

STEP 2 | Select Check Now to retrieve a list of available updates.

STEP 3 | Select Download in the Acon column to download the plugin.

STEP 4 | Select the version of the plugin and click Install in the Acon column to install the plugin.
Panorama will alert you when the installaon is complete.

Enable Communicaon Between NSX-T Manager and Panorama
Complete the following procedure to enable communicaon between Panorama and NSX-T
Manager. You can connect your Panorama to up to 16 NSX-T Managers. If you are connecng
your Panorama to mulple NSX-T Managers, you must carefully plan your device group hierarchy
and template stacks and consider how they interact with the other components needed for
deployment. Service definions reference device groups and template stacks and push that
informaon to the firewalls in the related ESXi clusters.

STEP 1 | (Oponal) Bypass proxy server sengs, configured on Panorama under Panorama > Setup >
Services > Proxy Server, for communicaon between Panorama and NSX-T Manager.

This command allows Panorama to communicate directly with NSX-T Manager while
maintaining proxied communicaon for other services.

1. Log in to the Panorama CLI.
2. Execute the following command to enable or disable proxy bypass.

admin@Panorama> request plugins vmware_nsx proxy bypass {yes |
no}

Select yes to enable proxy bypass and no to disable proxy bypass. This is set to no by
default.

STEP 2 | Log in to the Panorama web interface.

Using a secure connecon (hps) from a web browser, log in using the IP address and
password you assigned during inial configuraon (hps://<IP address>).
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STEP 3 | Set up access to the NSX-T Manager.
1. Select Panorama > VMware > NSX-T > Service Managers and click Add.
2. Enter a descripve Name for your NSX-T Manager.
3. (Oponal) Add a Descripon for NSX-T Manager.
4. Enter the NSX Manager URL—NSX-T Manager cluster virtual IP address or FQDN—at

which to access the NSX-T Manager.
5. Enter the NSX Manager Login credenals—username and password, so that Panorama

can authencate to the NSX-T Manager.
6. Click OK.
7. Repeat this procedure for each NSX-T Manager to which you will connect Panorama.

If you change your NSX-T Manager login password, ensure that you update the
password on Panorama immediately. An incorrect password breaks the connecon
between Panorama and NSX-T Manager.

STEP 4 | Commit your changes to Panorama.

Select Commit and Commit to Panorama.

STEP 5 | Verify the connecon status on Panorama.
1. Select Panorama > VMware > NSX-T > Service Managers.
2. Verify the message in the Status column.

When the connecon is successful, the status displays as Registered. This indicates that
Panorama and the NSX-T Manager are in sync.

The unsuccessful status messages are:

• No connecon: Unable to reach/establish a network connecon to the NSX-T
Manager.

• Invalid Credenals: The access credenals (username and/or password) are incorrect.
• Out of sync: The configuraon sengs defined on Panorama are different from what

is defined on the NSX-T Manager.Click the link for details on the reasons for failure.
For example, NSX-T Manager may have a service definion with the same name as
defined on Panorama. To fix the error, use the service definion name listed in the
error message to validate the service definion on the NSX-T Manager. Unl the
configuraon on Panorama and the NSX-T Manager is synchronized, you cannot add a
new service definion on Panorama.

• Connecon Disabled: The connecon between Panorama and the NSX-T Manager
was manually disabled.

Create Template Stacks and Device Groups on Panorama
To manage the VM-Series firewalls for NSX-T using Panorama, the firewalls must belong to a
device group and a template that is a member of a template stack. Device groups allow you to
assemble firewalls that need similar policies and objects as a logical unit; the configuraon is
defined using the Objects and Policies tabs on Panorama. Use template stacks to configure the
sengs that are required for the VM-Series firewalls to operate on the network and associate;
the configuraon is defined using the Device and Network tabs on Panorama. And each template
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stack with zones used in your NSX-T configuraon on Panorama must be associated with a service
definion that you will create later; at a minimum, you must create a zone within the template
stack so that the NSX-T Manager can redirect traffic to the VM-Series firewall. Later, you will
associate a device group and template to your NSX-T deployment create a service definion.

Panorama can support deployments of both NSX-T North-South and NSX-T East-West at the
same me. You must configure separate device groups, template stacks, and service definions for
NSX-T North-South and NSX-T East-West.

STEP 1 | Add a device group or a device group hierarchy.
1. Select Panorama > Device Groups, and click Add. You can also create a device group

hierarchy.
2. Enter a unique Name and a Descripon to idenfy the device group.
3. Click OK.
4. Click Commit and select Panorama as the Commit Type to save the changes to the

running configuraon on Panorama.

STEP 2 | Add a template.
1. Select Panorama > Templates, and click Add.
2. Enter a unique Name and a Descripon to idenfy the template.
3. Click OK.
4. Click Commit, and select Panorama as the Commit Type to save the changes to the

running configuraon on Panorama.

STEP 3 | Create a template stack and add your newly created template.
1. Select Panorama > Templates, and click Add Stack.
2. Enter a unique Name and a Descripon to idenfy the template stack.
3. Under Templates, click Add and select the template you created in step 2 from the drop-

down.
4. Click OK.
5. Click Commit, and select Commit to Panorama to save the changes to the running

configuraon on Panorama.

STEP 4 | Create the zone(s) for each template.

The Panorama plugin for VMware NSX maps each zone to a service profile on NSX-T
Manager. To qualify, a zone must be of the virtual wire type and be part of a template you will
associate with a service definion; see Configure the Service Definion on Panorama for more
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informaon. In most uses cases, a single zone is sufficient. However, you must create mulple
zones for mul-tenancy

You can add up to 32 zones in each template.

1. Select Network > Zones.
2. Select the correct template in the Template drop-down.
3. Select Add and enter a zone Name.
4. Set the interface Type to Virtual Wire.
5. Click OK.
6. Verify that the zones are aached to the correct template.

7. Click Commit, and select Panorama as the Commit Type to save the changes to the
running configuraon on Panorama.

STEP 5 | Update the DNS and NTP server informaon of your template stack. You must complete this
step if you are using device cerficates in your deployment. This is required to ensure the
firewalls deployed in your NSX-T environment have the correct DNS informaon needed to
reach the device cerficate server.
1. Verify that you specified the correct template stack from the Template drop-down.
2. Select Device > Setup > Services and click the Edit icon.
3. On the Services tab, enter the IP address of the Primary DNS Server and Secondary DNS

Server.
4. On the NTP tab, enter the IP address of the NTP Server.
5. Click OK.
6. Commit your changes to Panorama.

Configure the Service Definion on Panorama
A service definion allows you to register the VM-Series firewall as a partner security service on
the NSX-T Manager. The service definion must include the device group, a template stack, and
an OVF URL.

STEP 1 | (Oponal) Configure a Nofy Group

Create a nofy group by specifying devices groups that should be nofied of changes in
the virtual environment. The firewalls included in the specified device groups receive a real-
me update of security groups and IP addresses of guest VMs in them. The firewalls use this
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update to determine the most current list of members that constute dynamic address groups
referenced in policy.

1. Select Panorama > VMware > Nofy Group and click Add.
2. Give your Nofy Group a descripve Name.
3. Select the boxes of all devices groups that should be nofied of changes to the virtual

environment. If a device group does not have a check box available, it means that the
device group is automacally included by virtue of the device group hierarchy.

4. Click OK.

STEP 2 | Add a new service definion.

You can create up to 32 service definions on Panorama.

1. Select Panorama > VMware > NSX-T > Service Definions.
2. Select Add to create a new service definion.
3. Enter a descripve Name for your service definion.
4. (Oponal) Add a Descripon that idenfies the funcon or purpose for the VM-Series

firewalls that will be deployed using this service definion.

STEP 3 | Assign a device group and a template stack to the service definion.

Make sure to Create Template Stacks and Device Groups on Panorama.

Because the firewalls deployed in this soluon will be centrally administered from Panorama,
you must specify the Device Group and the Template Stack that the firewalls belong to. All the
firewalls that are deployed using this service definion belong to the specified template stack
and device group.

1. Select the device group or device group hierarchy in the Device Group drop-down.
2. Select the template stack in the Template drop-down.

You cannot reuse a template stack or a device group assigned to one service
definion in another service definion.
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STEP 4 | Specify the locaon of the OVF file.

Download the zip file, unzip it to extract and save the .ovf, mf and .vmdk files to the same
directory. The ovf and vmdk files are used to deploy each instance of the firewall.

Do not change the Panorama service definion OVF path aer a successful NSX
Service Deployment of VM-Series firewalls. Changing the OVF path, aer a successful
VM-Series firewall deployment, can result in a NSX Service Deployment failed state.
You may resolve this failure in NSX-T Manager, however this may cause all VM-Series
firewalls to redeploy.

In OVF URL, add the locaon of the web server that hosts the ovf file. Both hp and hps are
supported protocols.

You can use the same ovf version or different versions across service definions. Using
different ovf versions across service definions allows you to vary the PAN-OS version on the
VM-Series firewalls in different ESXi clusters.

STEP 5 | (Oponal) Select a Nofy Group.

STEP 6 | Select East West as the Inseron Type for your firewall.

STEP 7 | (Oponal) Enable Health Check.

Health check is enabled by default. Also called service health check, this NSX-T feature allows
you to simulate high availability in the case of a service instance failing. When configured with
the VM-Series firewall, if a VM-Series service instance fails, any traffic directed to that firewall
is redirect to another firewall instance in the cluster (for service cluster deployments) or a
firewall instance on another host (for host-based deployments).

You cannot disable or enable Health Check in a service definion aer comming
and deploying VM-Series firewalls in NSX-T. Aempng to commit a change in the
Health Check configuraon returns commit failure. To change this, you must delete and
recreate your service definion and redeploy your VM-Series firewalls.

STEP 8 | To automacally retrieve a device cerficate when the VM-Series firewall is deployed by NSX
Manager, configure the device cerficate.

Enable this opon to apply a device cerficate to newly deployed VM-Series firewalls. Only
use this opon when deploying the firewall using a base image OVF that supports device
cerficates. Panorama pushes the device cerficate informaon to NSX Manager as part of the
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service definion. When a new firewall is deployed in NSX, the device cerficate is installed on
the firewall at bootup.

For list of OVFs that support device cerficates for the VM-Series firewall on VMware NSX,
see the Palo Alto Networks Compability Matrix.

If your OVF does support a device cerficate, you must Enable device cerficates regardless
of whether or not you are using a device cerficate. If your OVF does not support a device
cerficate, disable this opon.

1. If you have not done so already, log in to the Customer Support Portal and generate a
Registraon PIN and PIN ID.

2. Under Device Cerficate, click Enable.
3. Copy the PIN ID and enter it into the Device Cerficate PIN ID field.
4. Reenter the PIN ID into the Confirm Device Cerficate PIN ID field.
5. Copy the PIN Value and enter it into the Device Cerficate PIN Value field.
6. Reenter the PIN Value into the Confirm Device Cerficate PIN Value field.
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STEP 9 | Click OK to save the service definion.
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STEP 10 | Aach the service definion to the service manager.

You cannot use a service definion in more than one service manager.

1. Select Panorama > VMware > NSX-T > Service Manager and click the link of the service
manager name.

2. Under Service Definions, click Add and select your service definion from the drop-
down.

3. Click OK.
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STEP 11 | Add the authorizaon code to license the firewalls.
1. Select Panorama > Device Groups and choose the device group you associated with the

service definion you just created.
2. Under Dynamically Added Device Properes, add the authorizaon code you received

with your order fulfillment email and, oponally, select None from the SW Version drop-
down.

When a new firewall is deployed on NSX-T it is automacally added to the device group,
licensed using the authorizaon code you provided, and upgraded to the PAN-OS
version you specified.

On the support portal, you can view the total number of firewalls that you are authorized
to deploy and the rao of the number of licenses that have been used to the total
number of licenses enabled by your authorizaon code.

STEP 12 | Commit to Panorama.
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STEP 13 | On the NSX-T Manager, verify that the service definion is available.

Select System > Service Deployments > Catalog. The service definion is listed as a Service
Instance on the NSX-T Manager.

Launch the VM-Series Firewall on NSX-T (East-West)
Complete the following procedure to deploy the VM-Series firewall as a service in your NSX-T
environment. The Deployment Specificaon and Deployment Template fields are automacally
populated with informaon pushed from Panorama as part of the service definion.

Do not edit any sengs under Deployment Aributes. These values are imported from
Panorama and changing them causes the deployment to fail.

STEP 1 | Log in to the NSX-T Manager.

STEP 2 | Select System > Service Deployments > Deployment.

STEP 3 | Select your service definion from the Partner Service drop-down.

STEP 4 | Click Deploy Service.

STEP 5 | Enter a descripve Name for your service deployment.

STEP 6 | Select the Compute Manager (vCenter).

STEP 7 | Select a Deployment Type—Clustered or Host Based.

STEP 8 | If you selected Clustered as the Deployment Type, enter the Clustered Deployment Count
to specify the number of VM-Series firewall instances to deploy on the cluster.

STEP 9 | Select a Host if you are launching the VM-Series in a clustered deployment. Select a
parcular host from the Host drop-down or Any to allow NSX-T Manager to choose the host.
This opon is grayed out in Host Based deployments.

STEP 10 | Select a Data Store as the repository for the VM-Series firewall. In a clustered deployment,
select a shared data store if you choose Any for the host or select a local data store if you
specified a parcular host.

STEP 11 | Configure the Networks sengs.
1. In the Networks column, click Set.
2. Select the Network for eth0 - Management Nic.
3. Select the Network Type—DHCP or Stac IP Pool. If you choose Stac IP Pool, select an

IP Pool.
4. Check eth1 - Data-1 Nic.
5. Verify that both interfaces are checked.
6. Click Save.

VM-Series Deployment Guide Version Version 10.1 276 ©2022 Palo Alto Networks, Inc.



Set Up the VM-Series Firewall on VMware NSX-T

STEP 12 | Select or configure a Service Segment. To configure a service segment, complete the
following procedure.
1. Click Acon in the Service Segments column.

2. Click Add Service Segment.
3. Enter a descripve Name.
4. Select a Transport Zone (Overlay).
5. Click Save and Close.

STEP 13 | Select the Cluster where the service will be deployed. You must select a cluster with NSX
Configuraon.

STEP 14 | Click Save.

STEP 15 | Verify that your firewalls deployed successfully.
1. Select System > Service Deployments > Service Instances.
2. Confirm that your firewalls are listed and the Deployment Status shows Up.

STEP 16 | Verify that your firewalls connected to Panorama.
1. Log in to Panorama.
2. Select Panorama > Managed Devices > Summary.
3. Confirm that your firewalls are listed under the correct device group and the Device

State shows Connected.

The Device Name for the VM-Series firewall is displayed on Panorama as PA-
VM:<nsx.clusterid> for NSX-T (N-S) deployment and as PA-VM:<nsx.servicevmid> for
NSX-T (E-W) deployment.

Create Dynamic Address Groups
A security group is a logical container that assembles guests across mulple ESXi hosts in the
cluster. When you create a dynamic address group that meets the right criteria and commit your
changes, a corresponding security group is created on the NSX-T Manager. Creang security
groups is required to manage and secure the guests.

For a dynamic address group to become a security group on NSX-T, you must add match criteria
in the dynamic address group in the following format: ‘_nsxt_<dynamic-address-group-
name>’. The dynamic address name added in the match criteria must match the dynamic address
group name exactly. For example, a dynamic address group called applicaons must include match
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criteria ‘_nsxt_applications’. Addionally, you must include the dynamic address group in a
device group in a service definion, which is part of a service manager, and commied.

Each security group created from a dynamic address group is in the following format:
<service-def-name>_<dynamic-address-group-name>. For example,
ServiceDef1_applications.

Each dynamic address group you create must have a unique name across each device
group configured on your Panorama.

STEP 1 | Configure a dynamic address group for each security group required for your deployment.
1. Select Objects > Address Groups.
2. Verify that you are configuring the dynamic address groups in a device group associated

with an NSX-T service definion.
3. Click Add and enter a Name and Descripon for the address group.
4. Select Type as Dynamic.
5. Define the match criteria.

For the dynamic address group to become a security group in NSX-T Manager,
the match criteria string must be enclosed in single quotes with the prefix
_nsxt_ followed by the exact name of the Address Group. For example,
‘_nsxt_PAN_APP_NSX’.

6. Repeat this process for each security group you require.
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STEP 2 | Commit your changes.

Create Security Policies
Create security policy rules that will used to auto generate steering rules used in used in steering
policy.

When you Generate Steering Rules, you will have the opon to generate steering rules based on
pre-rules, post-rules, or all. If you select All, the VMware plugin for NSX creates a steering rule for
each applicable security in the pre and post rules. This can result in the creaon of unnecessary
steering rules and make managing the rules more difficult. To help easily separate your steering
rules from your security rules, you can create your steering rules as post rules and security rules as
pre rules.

To auto generate a steering rule based on a security rules created on Panorama, the security rule
must meet the following criteria:

• Belongs to a parent or child device group registered with an NSX-T Service Manager.
• Is an intrazone policy and includes only one zone.
• Does not include a stac address group, IP range, or netmask configured for the rule.

When deciding where to define your NSX-T steering rules in Panorama—pre or post rulesbase—
consider the number of security policy rules and NSX-T steering rules you will create on Panorama
and the order in which the rules are applied to traffic. Pre-rules are applied to traffic before post-
rules.

• Pre-Rules—you can use the Panorama pre-rulebase to define your NSX-T steering rules and
VM-Series firewall security policy rules. If your define the security rules and steering rules in
the same rulebase, you must consider the order of the security rules relave to the steering
rules. When you have a large rulebase that includes both steering rules and security policy
rules, it might become difficult to manage both types of rules as you scale.

• Post-Rules—separang your security policy rules used for inspecon and enforcement from
the security rules used to generate NSX-T steering rules can help you scale in deployment
with a large amount of rules. When you auto generate your steering rules, the plugin generates
a steering rule for every rule in the specified rulebase that meets the necessary criteria.
Therefore, by separang the two types of rules, you can prevent unintenonally generang
extraneous steering rules. Use of the post rulebase for steering rules is recommended;
especially in deployments with large amounts of security policy rules.

The source and desnaon dynamic address groups you specify in the security rule. When you
auto generate a steering rule, where the rule is applied (NSX-T Distributed Firewall or Security
Group) depends on the source and desnaon you specified when configuring the security rule.
If you selected any for the source or desnaon, NSX-T Manager applies the steering rule to the
Distributed Firewall. If you select a dynamic address group for the source and desnaon, the
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steering is applied to the guest VMs in those security groups. If you manually create steering rules,
you can specify the security group(s) where the steering rule is applied.

Ensure that your security policy that is used to define steering rules do not include dynamic
address groups configured as part of an operaons-centric deployment workflow. If you do,
the steering rules source and desnaon will be pushed to NSX-T Manager as source-any and
desnaon-any. This might impact traffic in your NSX-T environment.

If you disable a security rule that you will use to auto generate a steering rule, the steering
rule will be disabled as well.

• Use the Pre Rulebase to Define NSX-T Steering Rules
• Use the Post Rulebase to Define NSX-T Steering Rules
• Apply Security Policies to the VM-Series Firewall on NSX-T (East-West)

Use the Pre Rulebase to Define NSX-T Steering Rules

The following procedure describes how to create the security policy rules that will be used to
generate NSX-T steering rules and how to create the security policy Panorama will push to the
VM-Series firewaa for traffic inspecon and enforcement.

Do not apply the traffic redirecon policies unless you understand how rules work on the NSX-T
Manager as well as on the VM-Series firewall and Panorama. The default policy on the VM-Series
firewall is set to deny all traffic, which means that all traffic redirected to the VM-Series firewall
will be dropped.

Create security policy rules in the associated device group. For each security rule set the Rule
Type to Intrazone, select one zone in the associated template stack, and select the dynamic
address groups as the source and desnaon. Creang a qualifying security policy in Panorama
helps in the creaon of a corresponding steering rule on NSX-T Manager upon steering rule
generaon and commit in Panorama.

STEP 1 | In Panorama, select Policies > Security > Pre Rules.

STEP 2 | Click Add and enter a Name and Descripon for your security policy rule.

STEP 3 | Verify that you are configuring the security rules in a device group associated with an NSX-T
service definion.

STEP 4 | Set the Rule Type to intrazone (Devices with PAN-OS 6.1 or later).

STEP 5 | In the Source tab, set the source zone to the zone from the template stack associated with
the service definion. Then select a dynamic address group (NSX-T security group) you
created previously as the Source Address. Do not add any stac address groups, IP ranges, or
netmasks as a Source Address.

STEP 6 | In the Desnaon tab, Panorama does not allow you to set a desnaon zone because you
set the rule type to intrazone. Then select a dynamic address group (NSX-T security group)
you created previously as the Desnaon Address. Do not add any stac address groups, IP
ranges, or netmasks as a Desnaon Address.

STEP 7 | Click OK.
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STEP 8 | Repeat steps 1 through 7 for each steering rule you require.

STEP 9 | Commit your changes.

STEP 10 | Apply Security Policies to the VM-Series Firewall on NSX-T (East-West).

Use the Post Rulebase to Define NSX-T Steering Rules

STEP 1 | Create security rules.
1. In Panorama, select Policies > Security > Post Rules.
2. Verify that you are configuring the security rules in a device group associated with an

NSX-T service definion.
3. Click on the name of a security rule to edit.
4. Set the Rule Type to intrazone (Devices with PAN-OS 6.1 or later).
5. In the Source tab, set the source zone to the zone from the template stack associated

with the service definion. Then select a dynamic address group you created previously
as the Source Address. Do not add any stac address groups, IP ranges, or netmasks as a
Source Address.

6. In the Desnaon tab, Panorama does not allow you to set a desnaon zone because
you set the rule type to intrazone. Then select a dynamic address group you created
previously as the Desnaon Address. Do not add any stac address groups, IP ranges,
or netmasks as a Desnaon Address.

7. Click OK.
8. Repeat steps 1 through 7 for each steering rule you require.

STEP 2 | Commit your changes to Panorama.

STEP 3 | Apply Security Policies to the VM-Series Firewall on NSX-T (East-West).

Apply Security Policies to the VM-Series Firewall on NSX-T (East-West)

Now that you have defined the steering rules, you can now use Panorama for centrally
administering policies on the VM-Series firewalls.

To manage centralized policy, aach the dynamic address group as a source or desnaon
address in security policy and push it to the firewalls; the firewalls can dynamically retrieve the IP
addresses of the virtual machines that are included in each security group to enforce compliance
for traffic that originates from or is desned to the virtual machines in the specified group.
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STEP 1 | Create security policy rules.

1. Select Policies > Security > Prerules.
2. Select the Device Group that you created for managing the VM-Series firewalls on NSX-

T in Create Template Stacks and Device Groups on Panorama.
3. Click Add and enter a Name and a Descripon for the rule. In this example, the security

rule allows all traffic between the WebFrontEnd servers and the Applicaon servers.
4. Select the Source Zone and Desnaon Zone. The zone name must be the same in both

columns.
5. For the Source Address and Desnaon Address, select or type in an address, address

group or region. In this example, we select an address group, the Dynamic address group
you created previously.

6. Select the Applicaon to allow. In this example, we create an Applicaon Group that
includes a stac group of specific applicaons that are grouped together.

1. Click Add and select New Applicaon Group.
2. Click Add to select the applicaon to include in the group.
3. Click OK to create the applicaon group.

7. Specify the acon— Allow or Deny—for the traffic, and oponally aach the default
security profiles for anvirus, an-spyware, and vulnerability protecon, under Profiles.

8. Repeats the steps above to create the pernent policy rules.
9. Click Commit, select Commit Type as Panorama. Click OK.

STEP 2 | Apply the policies to the VM-Series firewalls for NSX-T.
1. Click Commit, and select Commit Type Device Groups.
2. Select the device group, NSX-T Device Group in this example and click OK.
3. Verify that the commit is successful.
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STEP 3 | Validate that the members of the dynamic address group are populated on the VM-Series
firewall.
1. From Panorama, switch device context to launch the web interface of a firewall to which

you pushed policies.
2. On the VM-Series firewall, select Policies > Security, and select a rule.
3. Select the drop-down arrow next to the address group link, and select Inspect. You can

also verify that the match criteria is accurate.

4. Click the more link and verify that the list of registered IP addresses is displayed.

Policy will be enforced for all IP addresses that belong to this address group, and are
displayed here.

STEP 4 | (Oponal) Use template to push a base configuraon for network and device configuraon
such as DNS server, NTP server, Syslog server, and login banner.

Refer to the Panorama Administrator’s Guide for informaon on using templates.

STEP 5 | Create a Zone Protecon profile and aach it to a zone.

A zone protecon profile provides flood protecon and has the ability to protect against port
scanning, port sweeps and packet-based aacks. It allows you to secure intra-er and inter-er
traffic between virtual machines within your data center and traffic from the Internet that is
desned to the virtual machines (workloads) in your data center.

1. Select your Template.
2. Select Network > Network Profiles > Zone Protecon to add and configure a new

profile.
3. Select Network > Zones, click the default-zone listed and select the profile in the Zone

Protecon Profile drop down.

STEP 6 | Create a DoS Protecon profile and aach it to DoS Protecon policy rule.
1. Select your Device Group.
2. Select Objects > Security Profiles > DoS Protecon to add and configure a new profile.

• A classified profile allows the creaon of a threshold that applies to a single source IP.
For example, you can configure a max session rate for an IP address that matched the
policy, and then block that single IP address once the threshold is triggered.

• An aggregate profile allows the creaon of a max session rate for all packets matching
the policy. The threshold applies to new session rate for all IP addresses combined.
Once the threshold is triggered it affects all traffic that matches the policy.

3. Create a new DoS Protecon policy rule in Policy > DoS Protecon, and aach the new
profile to it.
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Create Dynamic Address Group Membership Criteria
In NSX-T, you can configure the membership criteria for your virtual machines and IP set
belonging to an NSX-T security group (dynamic address group) in the Panorama plugin for NSX.
For each dynamic address group, you must specify a service definion and define up to five match
criteria and each criterion includes up to five match rules.

You create this membership criteria on the plugin and then push it to NSX-T Manager.
However, this does not apply the membership criteria to guest virtual machines in your
deployment. You must define and apply membership data, such as tags, to your guest VMs
in NSX-T Manager.

The rules that the Panorama plugin for NSX-T idenfies and classifies virtual machines based
on two membership types—Virtual Machine or IP set. The keys and operators usable with each
member type are listed in the table below.

Member Type Key Operator

IP Set Tag Equals

Virtual Machine • Tag
• Name
• OS Name
• Computer Name

• Equals
• Contains
• Starts With
• Ends With
• Not Equals (Not applicable with

Tag key)

Membership criteria changes should be made only on Panorama; do not make changes
on NSX-T Manager. If you make changes on NSX-T Manager, the Panorama plugin for
VMware NSX show the service definion as out-of-sync. You should click on the Out-of-
Sync link to see the specific reason for the out-of-sync status. If a membership criteria
change is the cause, perform a configuraon sync by clicking NSX-T Config-Sync.

STEP 1 | Select Panorama > VMware > NSX-T > Membership Criteria > Add.

To add or modify membership criteria for a service definion, with at least one dynamic
address group, you can click on the service definion name instead of clicking Add.

STEP 2 | From the Name, select a service definion for the Membership Criteria. The selected
service definion must have East_West inseron type and used as part of a security-centric
deployment.

STEP 3 | Click Add to specify a dynamic address group.
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STEP 4 | Select a Dynamic Address Group from the drop-down. The drop-down lists the dynamic
address groups associated with the specified service definion.

The plugin UI displays dynamic and stac address groups configured on Panorama.
Take care not accidently select a stac address group when configuring membership
criteria.

STEP 5 | Click Add to define the criteria associated with the chosen dynamic address group.

STEP 6 | Enter a descripve name for the Criteria.

STEP 7 | Click Add to define a rule.

STEP 8 | Define a rule. You can create up to five rules.
1. Enter a descripve name for the rule.
2. Select the Member Type—Virtual Machine or IP Set.
3. Select the Key—Tag, Name, OS Name, Computer Name.
4. Select the Operator—Equals, Contains, Starts With, Ends With, Not Equals.
5. Enter the Value.

If the Key is set to Tag, the Value is the Tag. The plugin user interface does not list the
Tags, so you must use the Panorama CLI (with NSX-T Manager 3.0.0. and later).

request plugins vmware_nsx nsx_t nsxt-tags service-definition
<SD_name>

6. (Oponal) Enter the Scope. Scope is applicable only with the key Tag. Scope is an
oponal value applied to an object tag in NSX-T. The scope is defined on NSX-T
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Manager. For example, if you tag virtual machines based on operang system, you can
create tags for Windows, Linux, and MacOS and then set the scope of each tag to OS.

To view the tags and scope, use the Panorama CLI (with NSX-T Manager 3.0.0 and later).

Execute the following command to view the list of tags.

request plugins vmware_nsx nsx_t nsxt-tags service-definition
<SD_name>

Execute the following command to view the scope associated with the specified tag.

request plugins vmware_nsx nsx_t nsxt-scope tag <tag_value>
service-definition <SD-name>

7. Click OK.
8. (Oponal) Click Add to create addional (up to five total) rules.
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STEP 9 | On the Dynamic Address Group window, click OK to finish or Add to create addional
criteria (up to five total) and rules.

STEP 10 | On the Membership Criteria window, click OK to finish or Add to specify addional dynamic
address groups.

Generate Steering Policy
Steering policy is used by NSX-T to define the service chain to which traffic will be steered. You
can create steering policy manually or you can auto generate steering policy.

When you auto generate steering policy, the Panorama plugin for VMware NSX-T creates a
steering policy for each specified service manager and the associated service definions. By
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default, TCP strict is disabled and the Failure Policy is set to Allow. Auto-generated policy uses the
auto_<service-def-name>_<zone-name>_steering_policy naming format.

When TCP Strict is enabled, the firewall enforces the requirement of the three-way handshake.
If the firewall picks up traffic mid-session (for example, due to asymmetric traffic) and does not
detect a three-way handshake, the session is dropped. See VMware NSX-T documentaon for
more informaon.

The Failure Policy defines what happens to traffic if the firewall goes down. If you select Allow, the
traffic connues on to its desnaon. If you select Block, the traffic is dropped.

Addionally, you have the opon to select all your service managers instead of selecng specific
service managers. Choosing All is not recommended if any of your service managers contain
operaons-centric service definions. The plugin will create steering policy for each zone
associated with the operaon-centric service definions and then push it to NSX-T Manager. If
you do choose All, verify that the service manager you select when you auto generang steering
policy includes only security-centric service definions.

If you auto-generate steering policy, you must also auto-generate steering rules. And you
manually create steering policy, you must also manually create steering rules.

• Auto Generate Steering Policy
• Manually Create Steering Policy

Steering policy changes should be made only on Panorama; do not make changes on NSX-
T Manager. If you make changes on NSX-T Manager, the Panorama plugin for VMware
NSX show the service definion as out-of-sync. You should click on the Out-of-Sync link to
see the specific reason for the out-of-sync status. If a steering policy change is the cause,
perform a configuraon sync by clicking NSX-T Config-Sync.

Auto Generate Steering Policy

Use the following procedure to auto generate steering policy.

The following steps are for specifying service managers instead of selecng All.

STEP 1 | Select Panorama > VMware > NSX-T > Network Introspecon > Policy.

STEP 2 | Click Auto Generate.

STEP 3 | For Service Managers, choose Select.

If you select All instead of selecng specific service managers, the plugin will generate
steering policy for each service definion associated with each service manager in your
configuraon. Addionally, make sure that your selected service manager includes
security-centric service definions.

STEP 4 | Click Add to select the service manager.

STEP 5 | Select a Service Manager from the drop-down.

VM-Series Deployment Guide Version Version 10.1 288 ©2022 Palo Alto Networks, Inc.

https://docs.vmware.com/en/VMware-NSX-T-Data-Center/3.0/administration/GUID-DE6FE8CB-017E-41C8-85FC-D71CF27F85C2.html?hWord=N4IghgNiBcIC4GMAOACAznATgSwXEAvkA


Set Up the VM-Series Firewall on VMware NSX-T

STEP 6 | Click Add to select the service definions.

STEP 7 | Select the service definion from the drop-down.

STEP 8 | Click OK and click OK again.

STEP 9 | Commit your changes to Panorama.

Manually Create Steering Policy

Use the following procedure to manually create steering policy.

STEP 1 | Select Panorama > VMware > NSX-T > Network Introspecon > Policy.

STEP 2 | Click Add.

STEP 3 | Enter a descripve Name for your steering policy.

The steering policy name cannot include any spaces.

STEP 4 | Select a Service Definion from the drop-down.

STEP 5 | Select a Service Chain from the drop-down.

STEP 6 | ( Oponal) Enable TCP Strict. This opon is disabled by default.

STEP 7 | Choose the Failure Policy— Allow or Block. Allow is the default.

STEP 8 | Click OK.
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STEP 9 | Commit your changes to Panorama.

Generate Steering Rules
Steering rules are defined in steering policy. A rule defines the source and desnaon of the
traffic, introspecon services, the NSX-T objects the rule is applied to, and the traffic redirecon
policy. You can create steering rules manually or generate steering rules automacally.

You must generate or create steering policy before generang or creang steering rules.

To auto generate a steering rule based on a security rules created on Panorama, the security rule
must meet the following criteria:

• Belongs to a parent or child device group registered with an NSX-T Service Manager.
• Is an intrazone policy and includes only one zone.
• Does not include a stac address group, IP range, or netmask configured for the rule.

Auto-generated steering rules uses the auto_<device-group-name>_<device-group-rule-name>
naming format.

By default, auto-generated steering rules are configured without an NSX services specified.
Addionally, the NSX Traffic Direcon is set to in-out, Logging is disabled, IP protocol is ipv4-
ipv6, and the Acon is set to redirect. Aer auto-generang rules, you can update the steering to
change the default values.

Addionally, you have the opon to select all your service managers instead of selecng specific
service managers. Choosing All is not recommended.

If you auto-generate steering policy, you must also auto-generate steering rules. And if you
manually create steering policy, you must also manually create steering rules.

• Auto Generate Steering Rules
• Manually Create Steering Rules

Steering rules changes should be made only on Panorama; do not make changes on NSX-
T Manager. If you make changes on NSX-T Manager, the Panorama plugin for VMware
NSX show the service definion as out-of-sync. You should click on the Out-of-Sync link
to see the specific reason for the out-of-sync status. If a steering rules change is the cause,
perform a configuraon sync by clicking NSX-T Config-Sync.
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Auto Generate Steering Rules

Use the following procedure to auto generate steering rules.

When you auto generate a steering rule, where the rule is applied (NSX-T Distributed Firewall
or Security Group) depends on the source and desnaon you specified when configuring the
security rule. If you selected Any for the source or desnaon, NSX-T Manager applies the
steering rule to the Distributed Firewall. If you select a dynamic address group for the source and
desnaon, the steering is applied to the guest VMs in those security groups.

If you make any changes to device group configuraon that is also part of steering rule
configuraon, such as source and desnaon address group that map to the Applied To seng in
a steering rule, you must auto generate the steering rule again for the changes to take effect.

The following steps are for specifying service managers instead of selecng All.

STEP 1 | Select Panorama > VMware > NSX-T > Network Introspecon > Rule.

STEP 2 | Click Auto Generate.

STEP 3 | Select the type of Security Rules from the drop-down—All, Pre Rulebase only, or Post
Rulebase only. The security rules are pulled from the service definions specified in the
following steps.

If you regenerate steering rules, all current rules are deleted and new rules are created
based on the selected rule base. If you originally created steering rules using the Pre
Rulebase and then regenerate steering rules using the Post Rulebase, only the post-
rulebase steering rules will remain.

STEP 4 | For Type, choose Select.

STEP 5 | Click Add to specify the Service Manager(s) and Service Definion(s).

STEP 6 | Select a Service Manager from the drop-down.

STEP 7 | Click Add to select the service definion(s).

STEP 8 | Click OK.

STEP 9 | Click OK to finish or Add to specify addional service managers and service definions.

STEP 10 | (Oponal) Click on an auto-generated rule to modify the following default opons.

If you regenerate steering rules, any changes you made to a previously-generate
steering rule will be overwrien.

• Enable NSX-T Logging.
• Click Add to specify NSX Services, such as Acve Directory Server, HTTPS, DNS, etc.
• Disable the rule. If you disable a steering rule but the corresponding security rule is enabled

(Device Group > Policies > Security), the steering rule will also be enabled.
• Applied to allows you change where the steering rule is applied—DFW or Security Group.
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STEP 11 | Clean up unwanted or incorrect steering rules.

If, for example, your device group contains security rules in the same rulebase as your NSX-
T steering rules, the plugin generates security rules based on those non-NSX-T security
rules. Because those rules do not refer to an NSX-T dynamic address group, the source and
desnaon for those rules will be set to Any Any in NSX-T Manager. This condion can impact
how NSX-T Manager directs traffic. To avoid this, you must manually delete the incorrect
steering rules.

1. Select the incorrect steering rules.
2. Click Delete.
3. Click Yes to confirm the deleon.

STEP 12 | Commit your configuraon to push it to NSX-T Manager.

Manually Create Steering Rules

Use the following procedure to manually create steering rules.

STEP 1 | Select Panorama > VMware > NSX-T > Network Introspecon > Rule.

STEP 2 | Click Add.

STEP 3 | Enter a descripve Name for the steering rule.

The steering rule name cannot include any spaces.

STEP 4 | Select a Steering Policy from the drop-down.

STEP 5 | Select a Device Group from the drop-down.
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STEP 6 | Select a Security Rule from the drop-down.

The Security Rule drop-down displays rules from all security rules across all device
groups of Service Definion. Ensure you select the appropriate security rule.

STEP 7 | Specify the Acon—Redirect or Do Not Redirect.

STEP 8 | (Oponal) Enable NSX-T Logging.

STEP 9 | Specify the IP Protocol—ipv4-ipv6, ipv4, or ipv6.

STEP 10 | Specify the NSX Traffic Direcon—in-out, in, or out.

STEP 11 | (Oponal) Click Add to specify NSX Services, such as Acve Directory Server, HTTPS, DNS,
etc.

The following ALG services are not supported: FTP, TFTP, ORACLE_TNS,
SUN_RPC_TCP, SUN_RPC_UDP, MS_RPC_TCP, MS_RPC_UDP, NBNS_BROADCAST,
NBDG_BROADCAST.

STEP 12 | Applied To—DFW or Security Groups. You can select one or more security group. Security
groups are created from dynamic address groups configured on Panorama. The security
group names are formaed as follows <servicedefinition>_<dynamic-address-
group>. If you select DFW, the steering rule is applied to all guest VMs, regardless of their
security membership.

STEP 13 | (Oponal) Disable the rule.

STEP 14 | Click OK.
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STEP 15 | Commit your configuraon to push it to NSX-T Manager.

Delete a Service Definion from Panorama
Complete the following procedure to delete a service definion from your NSX-T configuraon on
Panorama.

STEP 1 | Log in to Panorama.

STEP 2 | For a security-centric deployment, delete the steering rules and steering policy associated
with the service definion to be deleted.
1. Select Panorama > VMware > NSX-T > Network Introspecon > Rules.
2. Select the steering rules to be deleted.
3. Click Delete.
4. Select Panorama > VMware > NSX-T > Network Introspecon > Policy.
5. Select the steering policy to be deleted.
6. Click Delete.

STEP 3 | Commit your changes.

STEP 4 | Delete the VM-Series firewalls deployed in NSX-T that are associated with service definion
to be deleted.
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STEP 5 | Delete the membership criteria associated with the service definion.
1. Select Panorama > VMware > NSX-T > Membership Criteria.
2. Select the criteria to be deleted.
3. Click Delete.

STEP 6 | Unlink the service definion from the service manager with which it is associated.
1. Select Panorama > VMware > NSX-T > Service Managers.
2. Click the service manager name.
3. Select the service definion.
4. Click Delete.
5. Click OK.

STEP 7 | Commit your changes to Panorama.

Migrate from VM-Series on NSX-T Operaon to Security Centric
Deployment

Use the following procedure to migrate your operaons-centric NSX-T deployment to a security-
centric NSX-T deployment.

STEP 1 | Log in to Panorama.
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STEP 2 | Modify the match criteria of your dynamic address groups to follow the format required for a
security-centric deployment.
1. Select Objects > Address Groups.
2. Verify that you are configuring the dynamic address groups in a device group associated

with an NSX-T service definion.
3. Click on the name of a previously created NSX-T dynamic address group.
4. Edit the match criteria.

For the dynamic address group to become a security group in NSX-T Manager,
the match criteria string must be enclosed in single quotes with the prefix
_nsxt_ followed by the exact name of the Address Group. For example,
‘_nsxt_PAN_APP_NSX’.

5. Repeat this process for each security group you require.

STEP 3 | Set the security rules to be as NSX-T steering rules to intrazone.
1. In Panorama, select Policies > Security > Pre Rules.
2. Verify that you are configuring the security rules in a device group associated with an

NSX-T service definion.
3. Click Add and enter a Name and Descripon for your security policy rule.
4. Set the Rule Type to intrazone (Devices with PAN-OS 6.1 or later).
5. In the Source tab, set the source zone to the zone from the template stack associated

with the service definion. Then select a dynamic address group you created previously
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as the Source Address. Do not add any stac address groups, IP ranges, or netmasks as a
Source Address.

6. In the Desnaon tab, Panorama does not allow you to set a desnaon zone because
you set the rule type to intrazone. Then select a dynamic address group you created
previously as the Desnaon Address. Do not add any stac address groups, IP ranges,
or netmasks as a Desnaon Address.

7. Click OK.
8. Repeat steps 1 through 7 for each steering rule you require.
9. Commit your changes.

STEP 4 | Auto generate new steering policy.

The following steps are for specifying service managers instead of selecng All.

1. Select Panorama > VMware > NSX-T > Network Introspecon > Policy.
2. Click Auto Generate.
3. For Service Managers, choose Select.

If you select All instead of selecng specific service managers, the plugin will
generate steering policy for each service definion associated with each service
manager in your configuraon.

4. Click Add to select the service manager.
5. Select a Service Manager from the drop-down.
6. Click Add to select the service definions.
7. Select the service definion from the drop-down.
8. Click OK and click OK again.

9. Commit your changes.
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STEP 5 | Auto generate new steering rules.

If you auto-generate steering policy, you must also auto-generate steering rules. And if you
manually create steering policy, you must also manually create steering rules.

The following steps are for specifying service managers instead of selecng All.

1. Select Panorama > VMware > NSX-T > Network Introspecon > Rule.
2. Click Auto Generate.
3. Select the type of Security Rules from the drop-down—All, Pre Rulebase only, or Post

Rulebase only. The security rules are pulled from the service definions specified in the
following steps.

4. For Type, choose Select.
5. Click Add to specify the Service Manager(s) and Service Definion(s).
6. Select a Service Manager from the drop-down.
7. Click Add to select the service definion(s).
8. Click OK.
9. Click OK to finish or Add to specify addional service managers and service definions.
10. (Oponal) Click on an auto-generated rule to modify the default opons.

STEP 6 | Create Dynamic Address Group Membership Criteria.

STEP 7 | Commit your changes to Panorama.
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STEP 8 | Delete the operaons-centric steering rules from NSX-T Manager.
1. Log in to NSX-T Manager.
2. Select Security > Network Introspecon (E-W) > Rules.
3. Select each operaons-centric steering rules.
4. Click Delete.
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STEP 9 | Delete the operaons-centric service chain from NSX-T Manager.
1. Log in to NSX-T Manager.
2. Select Security > Network Introspecon Sengs > Service Chains.
3. Click the vercal ellipses.
4. Click Delete.
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Extend Security Policy from NSX-V to NSX-T
If you are moving from an NSX-V deployment to an NSX-T deployment or combining an NSX-
T deployment with an NSX-V deployment, you can extend your exisng security policy from
NSX-V to NSX-T without having to recreate the policy rules. This is achieved by leveraging your
exisng device groups and sharing them between the NSX-V and NSX-T service definions. Aer
migrang your policy to NSX-T, you can connue using the VM-Series for NSX-V or remove your
NSX-V deployment.

STEP 1 | Install the Panorama Plugin for VMware NSX 3.2.0 or later. See the Panorama Plugin for
VMware NSX 3.2.0 Release Notes before upgrading.

STEP 2 | Configure an NSX-T service definion for each NSX-V service definion in your deployment.
Do not create new device groups; instead use your exisng NSX-V device groups. Using the
exisng device groups allows you to apply the same security policy rules used on NSX-V to
the VM-Series firewalls deployed on NSX-T. If you have policy that reference a parcular
zone, add the same template stack from your NSX-V service definion to your NSX-T service
definion. Addionally, if your device group references a parcular template, ensure that you
select the template stack that includes the template referenced in the device group.

STEP 3 | Configure an NSX-T service manager and associate the NSX-T service definions to the
service manager.

STEP 4 | Prepare your NSX-T environment and deploy the VM-Series firewall. You must create your
security groups, service chains, and traffic redirecon policy before launching the VM-Series
firewall.

• Deploy the VM-Series Firewall on NSX-T (North-South)
• Deploy the VM-Series Using the Operaons-Centric Workflow
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STEP 5 | Add the NSX-T tags to you exisng dynamic address groups.
1. Select Panorama > Objects > Address Groups.
2. Click on the name of an exisng NSX-V dynamic address group.
3. Click Add Match Criteria to display the tags from NSX-V and NSX-T.
4. Add the NSX-T tag to the dynamic address groups. Be sure to use the OR operator

between the tags.
5. When you have added all the necessary tags, click OK.
6. Commit your changes.

STEP 6 | Aer your VM workloads have successfully migrated from NSX-V to NSX-T, you remove
the NSX-V tags from your dynamic address groups if you plan to disconnue use of NSX-
V. All NSX-V tags and corresponding IP addresses are unregistered aer all NSX-V related
configuraon is removed from the Panorama plugin for NSX and VM-Series firewall
configuraon is removed from NSX-V manager.

Use In-Place Migraon to Move Your VM-Series from NSX-V to
NSX-T

Complete the following procedure to migrate your VM-Series firewall configuraon from NSX-
V to NSX-T. By migrang your configuraon, you can reuse policy and dynamic address groups
already configured on Panorama. This procedure refers to informaon and processes published in
VMware documentaon as well as steps specific to PAN.

This procedure supports operaons-centric NSX-V deployments only. An deployment means that
your policy rules for redirecng traffic to the VM-Series firewall were created in NSX-V Manager,
not Panorama.

This procedure requires NSX-T Manager 3.1.0 or later.

It is recommended that plan for security downme while performing this migraon.

STEP 1 | Prepare your NSX-V and NSX-T environments for migraon based on the steps described by
VMware.
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STEP 2 | Install the Panorama Plugin for VMware NSX 3.2.0 or later. See the Panorama Plugin for
VMware NSX 3.2.0 Release Notes before upgrading.

STEP 3 | Enable Communicaon Between NSX-T Manager and Panorama.

STEP 4 | Configure an NSX-T service definion for each NSX-V service definion in your deployment.
Do not create new device groups; instead use your exisng NSX-V device groups. Using the
exisng device groups allows you to apply the same security policy rules used on NSX-V to
the VM-Series firewalls deployed on NSX-T. If you have policy that reference a parcular
zone, add the same template stack from your NSX-V service definion to your NSX-T service
definion. Addionally, if your device group references a parcular template, ensure that you
select the template stack that includes the template referenced in the device group.

STEP 5 | Configure an NSX-T service manager and associate the NSX-T service definions to the
service manager.

STEP 6 | Verify that your NSX-T configuraon is present on NSX-T Manager.
1. Log in to NSX-T Manager.
2. Select System > Service Deployments > Catalog.
3. Confirm that your NSX-T service definion is listed.
4. Select Security > Network Introspecon Sengs > Service Profiles.
5. Confirm that your zones associated with your NSX-T template are listed.

STEP 7 | If you have not already done so, add a compute manager in NSX-T Manager. Aer you have
verified that the Registraon Status and Connecon Status are up, connue below.

STEP 8 | Import the NSX-V configuraon to NSX-T.
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STEP 9 | Uninstall the service instance from NSX-V.

This step will result in traffic disrupon.

1. Log in to your vSphere client.
2. Select Installaon and Upgrade > Service Deployment.
3. Select your service deployment.
4. Click Delete.
5. Click Delete to confirm.
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STEP 10 | Resolve Configuraon issues on NSX-T Manager. While resolving configuraon issues, you
must take specific acons to migrate your VM-Series firewall configuraon. In most cases,
you can accept the recommendaons presented by NSX-T Manager.
1. When resolving service inseron configuraon, verify that you selected the correct

service definion that you previously configured on Panorama for the VM-Series on
NSX-T.

2. Connue resolving the remaining configuraon.
3. Before moving to Migrate Configuraon, you will be asked to provide a transport zone

for the service inseron.
4. Map the service profiles on NSX-V to the corresponding service profiles on NSX-T.

1. Auto_PAN_VendorTPL can be skipped.
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2. Map the NSX-T service profile to the corresponding NSX-V service profile.
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STEP 11 | Migrate the configuraon.

STEP 12 | Verify that your configuraon has been migrated successfully.
1. Select Inventory > Groups to verify that your IP sets and security groups are present.

You can click on the security group name to see that the correct IP address are a part of
the security group.

2. Select Security > Network Introspecon Sengs > Service Segment to confirm that a
service segment has been created.

3. Select Security > Network Introspecon Sengs > Service Chains to confirm that a
service chain has been created. Click the Profiles link in the Forward Path and Reverse
Path columns to view your service profile.

4. Select Security > Network Introspecon (E-W) to confirm that a traffic redirecon rule
has been created to direct traffic to the service profile of the VM-Series firewall.

STEP 13 | If applicable, modify and migrate edges.

STEP 14 | Configure and migrate your hosts.
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STEP 15 | Add the NSX-T tags to you exisng dynamic address groups.
1. Select Panorama > Objects > Address Groups.
2. Click on the name of an exisng NSX-V dynamic address group.
3. Click Add Match Criteria to display the tags from NSX-V and NSX-T.
4. Add the NSX-T tag to the dynamic address groups. If you choose not to remove the NSX-

V tags, be sure to use the OR operator between the tags.
5. When you have added all the necessary tags, click OK.
6. Commit your changes.

STEP 16 | Launch the VM-Series Firewall on NSX-T (East-West). You do not need to create a new
service segment; instead select the service segment created during migraon.
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The VM-Series firewall can be deployed in the public Amazon Web Services (AWS)
cloud and AWS GovCloud. It can then be configured to secure access to the
applicaons that are deployed on EC2 instances and placed into a Virtual Private
Cloud (VPC) on AWS.

> About the VM-Series Firewall on
AWS

> Deployments Supported on AWS
> Deploy the VM-Series Firewall on

AWS
> VM-Series Integraon with an AWS

Gateway Load Balancer
> High Availability for VM-Series

Firewall on AWS
> Use Case: Secure the EC2 Instances

in the AWS Cloud

> Use Case: Use Dynamic Address
Groups to Secure New EC2 Instances
within the VPC

> Use Case: VM-Series Firewalls as
GlobalProtect Gateways on AWS

> VM Monitoring on AWS
> Auto Scale VM-Series Firewalls with

the Amazon ELB Service
> List of Aributes Monitored on the

AWS VPC
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About the VM-Series Firewall on AWS
The Amazon Web Service (AWS) is a public cloud service that enables you to run your applicaons
on a shared infrastructure managed by Amazon. These applicaons can be deployed on scalable
compung capacity or EC2 instances in different AWS regions and accessed by users over the
internet.

For networking consistency and ease of management of EC2 instances, Amazon offers the Virtual
Private Cloud (VPC). A VPC is apporoned from the AWS public cloud, and is assigned a CIDR
block from the private network space (RFC 1918). Within a VPC, you can carve public/private
subnets for your needs and deploy the applicaons on EC2 instances within those subnets. To
then enable access to the applicaons within the VPC, you can deploy the VM-Series firewall on
an EC2 instance. The VM-Series firewall can then be configured to secure traffic to and from the
EC2 instances within the VPC.

The VM-Series firewall is available in both the public AWS cloud and on AWS GovCloud. The VM-
Series firewall in public AWS and AWS GovCloud supports the Bring Your Own License (BYOL)
model and the hourly Pay-As-You-Go (PAYG), the usage-based licensing model that you can
avail from the AWS Marketplace. For licensing details, see VM-Series Firewall Licenses for Public
Clouds.

• AWS EC2 Instance Types
• VM-Series Firewall on AWS GovCloud
• VM-Series Firewall on AWS China
• VM-Series Firewall on AWS Outposts
• AWS Terminology
• Management Interface Mapping for Use with Amazon ELB
• Performance Tuning for the VM-Series Firewall on AWS

AWS EC2 Instance Types
For supported instance types, see VM-Series Models on EC2 Instances.

You can deploy the VM-Series firewall on an AWS instance size with more resources than the
minimum VM-Series System Requirements. If you choose a larger instance size for the VM-Series
firewall model, although the firewall only uses the max vCPU cores and memory shown in table, it
does take advantage of the faster network performance that AWS provides. If you want to change
the instance type on your VM-Series firewall that is licensed with the BYOL opon, you must
deacvate the VM before you switch the instance type to ensure that your license is valid. See
Upgrade the VM-Series Model to know why.

For guidance with sizing the VM-Series firewall on AWS, refer to this arcle.

VM-Series Firewall on AWS GovCloud
AWS GovCloud is an isolated AWS region that meets the regulatory and compliance requirements
of the US government agencies and customers.
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To secure your workloads that contain all categories of Controlled Unclassified Informaon (CUI)
data and government-oriented, publicly available data in the AWS GovCloud (US) Region, the VM-
Series firewall provides the same robust security features in the standard AWS public cloud and
on AWS GovCloud. The VM-Series firewall on AWS GovCloud and the standard AWS public cloud
support the same capabilies.

See AMI on AWS GovCloud to Deploy the VM-Series Firewall on AWS.

VM-Series Firewall on AWS China
The VM-Series firewall is available with the BYOL opon on the AWS China Marketplace, and is
available in the AWS China (Beijing) and the AWS China (Ningxia) regions. You must have an AWS
China account that is separate from your global AWS account to access this image and use AWS
resources on AWS China.

Make sure to review the VM-Series System Requirements before Launch the VM-Series Firewall
on AWS.

VM-Series Firewall on AWS Outposts
To provide the same level of security to the workloads located on-premises as those workloads
located in the AWS cloud, you can install the VM-Series firewall on AWS on an AWS Outposts
rack at your on-premises locaon. Use the AWS marketplace BYOL AMIs for your AWS region to
deploy the VM-Series firewall instances in your AWS Outposts subnets.

See Register the VM-Series Firewall (with auth code), to create a support account and register
the VM-Series firewall on the Palo Alto Networks Customer Support website for acvang your
support entlement with Palo Alto Networks.

AWS Terminology
This document assumes that you are familiar with the networking and configuraon of the AWS
VPC. In order to provide context for the terms used in this secon, here is a brief refresher on the
AWS terms (some definions are taken directly from the AWS glossary) that are referred to in this
document:

Term Descripon

EC2 Elasc Compute Cloud

A web service that enables you to launch and manage Linux/UNIX and
Windows server instances in Amazon's data centers.
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Term Descripon

AMI Amazon Machine Image

An AMI provides the informaon required to launch an instance, which
is a virtual server in the cloud.

The VM-Series AMI is an encrypted machine image that includes the
operang system required to instanate the VM-Series firewall on an
EC2 instance.

ELB Elasc Load Balancing

ELB is an Amazon web service that helps you improve the availability
and scalability of your applicaons by roung traffic across mulple
Elasc Compute Cloud (EC2) instances. ELB detects unhealthy EC2
instances and reroutes traffic to healthy instances unl the unhealthy
instances are restored. ELB can send traffic only to the primary
interface of the next hop load-balanced EC2 instance. So, to use ELB
with a VM-Series firewall on AWS, the firewall must be able to use the
primary interface for dataplane traffic.

ENI Elasc Network Interface

An addional network interface that can be aached to an EC2
instance. ENIs can include a primary private IP address, one or more
secondary private IP addresses, a public IP address, an elasc IP
address (oponal), a MAC address, membership in specified security
groups, a descripon, and a source/desnaon check flag.

IP address types for
EC2 instances

An EC2 instance can have different types of IP addresses.

• Public IP address: An IP address that can be routed across the
internet.

• Private IP address: A IP address in the private IP address range as
defined in the RFC 1918. You can choose to manually assign an IP
address or to auto assign an IP address within the range in the CIDR
block for the subnet in which you launch the EC2 instance.

If you are manually assigning an IP address, Amazon reserves the first
four (4) IP addresses and the last one (1) IP address in every subnet for
IP networking purposes.

• Elasc IP address (EIP): A stac IP address that you have allocated
in Amazon EC2 or Amazon VPC and then aached to an instance.
Elasc IP addresses are associated with your account, not with a
specific instance. They are elasc because you can easily allocate,
aach, detach, and free them as your needs change.

An instance in a public subnet can have a Private IP address, a Public IP
address, and an Elasc IP address (EIP); an instance in a private subnet
will have a private IP address and oponally have an EIP.
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Term Descripon

Instance type Amazon-defined specificaons that spulate the memory, CPU,
storage capacity, and hourly cost for an instance. Some instance types
are designed for standard applicaons, whereas others are designed
for CPU-intensive, memory-intensive applicaons, and so on.

VPC Virtual Private Cloud

An elasc network populated by infrastructure, plaorm, and
applicaon services that share common security and interconnecon.

IGW Internet gateway provided by Amazon.

Connects a network to the internet. You can route traffic for IP
addresses outside your VPC to the internet gateway.

IAM Role Identy and Access Management

Required for enabling High Availability for the VM-Series firewall
on AWS. The IAM role defines the API acons and resources the
applicaon can use aer assuming the role. On failover, the IAM Role
allows the VM-Series firewall to securely make API requests to switch
the dataplane interfaces from the acve peer to the passive peer.

An IAM role is also required for VM Monitoring. See List of Aributes
Monitored on the AWS VPC.

Subnets A segment of the IP address range of a VPC to which EC2 instances
can be aached. EC2 instances are grouped into subnets based on
your security and operaonal needs.

There are two types of subnets:

• Private subnet: The EC2 instances in this subnet cannot be reached
from the internet.

• Public subnet: The internet gateway is aached to the public
subnet, and the EC2 instances in this subnet can be reached from
the internet.

Security groups A security group is aached to an ENI and it specifies the list of
protocols, ports, and IP address ranges that are allowed to establish
inbound/outbound connecons on the interface.

In the AWS VPC, security groups and network ACLs control
inbound and outbound traffic; security groups regulate
access to the EC2 instance, while network ACLs regulate
access to the subnet. Because you are deploying the VM-
Series firewall, set more permissive rules in your security
groups and network ACLs and allow the firewall to safely
enable applicaons in the VPC.
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Term Descripon

Route tables A set of roung rules that controls the traffic leaving any subnet that is
associated with the route table. A subnet can be associated with only
one route table.

Key pair A set of security credenals you use to prove your identy
electronically. The key pair consists of a private key and a public key. At
me of launching the VM-Series firewall, you must generate a key pair
or select an exisng key pair for the VM-Series firewall. The private
key is required to access the firewall in maintenance mode.

CloudWatch Amazon CloudWatch is a monitoring service that allows you to collect
and track metrics for the VM-Series firewalls on AWS. When enabled,
the firewalls use AWS APIs to publish nave PAN-OS metrics to
CloudWatch.

Management Interface Mapping for Use with Amazon ELB
By default, the elasc network interface (ENI) eth0 maps to the MGT interface on the firewall
and ENI eth1 maps to ethernet 1/1 on the firewall. Because the ELB can send traffic only to the
primary interface of the next hop load-balanced EC2 instance, the VM-Series firewall must be able
to use the primary interface for dataplane traffic.

The firewall can receive dataplane traffic on the primary interface in the following scenarios where
the VM-Series firewall is behind the Amazon ELB Service (for a topology diagram, see Auto Scale
VM-Series Firewalls with the Amazon ELB Service):

• The VM-Series firewall(s) is securing traffic outbound directly to the internet without the need
for using a VPN link or a Direct Connect link back to the corporate network.

• The VM-Series firewall secures an internet-facing applicaon when there is exactly one
backend server, such as a web server, for each firewall. The VM-Series firewalls and web
servers can scale linearly, in pairs, behind ELB.

At present, for use cases that require an ELB sandwich-type deployment to scale out
firewalls and applicaon layer EC2 instances, swapping the management interface
will not allow you to seamlessly deploy the ELB soluon. The ability to swap the
management interface only parally solves the integraon with ELB.

To allow the firewall to send and receive dataplane traffic on eth0 instead of eth1, you must swap
the mapping of the ENIs within the firewall such that ENI eth0 maps to ethernet 1/1 and ENI eth1
maps to the MGT interface on the firewall as shown below.
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If possible, swap the management interface before you configure the firewall or define
policy rules.

Swapping how the interfaces are mapped allows ELB to distribute and route traffic to healthy
instances of the VM-Series firewall located in the same or different Availability Zones on AWS for
increased capacity and fault tolerance.

The interface swap is only required when the VM-Series firewall is behind the Amazon ELB
Service. If your requirement is to deploy the VM-Series firewalls in a tradional high availability set
up, you don’t need to configure the interface swap that is described in this secon. Connue to
High Availability for VM-Series Firewall on AWS.

To swap the interfaces, you have the following opons:

• At launch—When you launch the firewall, you can either enter the mgmt-interface-
swap=enable command in the User data field on the AWS management console (see Launch
the VM-Series Firewall on AWS) or CLI or you can include the new mgmt-interface-swap
operaonal command in the bootstrap configuraon.

• Aer launch—Aer you launch the firewall, Use the VM-Series Firewall CLI to Swap the
Management Interface (set system setting mgmt-interface-swap enable yes
operaonal command) on the firewall.

• To prevent unpredictable behavior on the firewall, pick one method to consistently
specify the interface swap seng—in the bootstrap configuraon, from the CLI on
the firewall, or using the Amazon EC2 User data field on the AWS console.

• Ensure that you have access to the AWS console (management console or CLI) to
view the IP address of the eth1 interface. Also, verify that the AWS Security Group
rules allow connecons (HTTPS and SSH) to the new management interface.

• If you configured the firewall or defined policy rules before interface swap, check
whether any IP address changes for eth0 or eth1 impact policy rules.

Performance Tuning for the VM-Series Firewall on AWS
The following configuraons affect performance:

• PAN-OS versions 9.0.3 and earlier support AWS C5 and M5 instance types that have Elasc
Network Adapter support for SR-IOV mode by default. For more details, see Elasc Network
Adapter – High Performance Network Interface for Amazon EC2.
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• PAN-OS versions 9.0.4 and later provide DPDK support for C5 and M5 instance types by
default. When the firewall is in DPDK mode, it uses DPDK drivers. For a list of supported
drivers, see PacketMMAP and PDK Drivers on VM-Series Firewalls and the official DPDK
release notes.

• To benefit from IETF RFC 8926 (Geneve) encapsulaon and improved throughput, upgrade to
PAN-OS 10.0.2 or later and refer to VM-Series Integraon with AWS Gateway Load Balancer.

Use the VM-Series CLI to view your DPDK sengs or enable packed I/O.

View the DPDK Configuraon on Your Firewall
STEP 1 | Log in to the VM-Series firewall CLI.

STEP 2 | View your DPDK configuraon. If DPDK is enabled the output is as follows:

> show system setting dpdk-pkt-io on

Device current Packet IO mode:     DPDK 
Device DPDK Packet IO capable:     yes
Device default Packet IO mode:     DPDK

Enable DPDK Packed I/O
STEP 1 | Log in to the VM-Series firewall CLI

STEP 2 | Enable DPDK:

> set system setting dpdk-pkt-io on

STEP 3 | Reboot the device.

On the firewall, select Device > Setup > Operaons and select Reboot Device.
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Deployments Supported on AWS
The VM-Series firewall secures inbound and outbound traffic to and from EC2 instances within
the AWS Virtual Private Cloud (VPC). Because the AWS VPC only supports an IP network (Layer 3
networking capabilies), the VM-Series firewall can only be deployed with Layer 3 interfaces.

• Deploy the VM-Series firewall to secure the EC2 instances hosted in the AWS Virtual Private
Cloud.

If you host your applicaons in the AWS cloud, deploy the VM-Series firewall to protect
and safely enable applicaons for users who access these applicaons over the internet. For
example, the following diagram shows the VM-Series firewall deployed in the Edge subnet to
which the internet gateway is aached. The applicaon(s) are deployed in the private subnet,
which does not have direct access to the internet.

When users need to access the applicaons in the private subnet, the firewall receives
the request and directs it to the appropriate applicaon, aer verifying security policy and
performing Desnaon NAT. On the return path, the firewall receives the traffic, applies
security policy and uses Source NAT to deliver the content to the user. See Use Case: Secure
the EC2 Instances in the AWS Cloud.

Figure 1: VM-Series for EC2 Instances

• Deploy the VM-Series firewall for VPN access between the corporate network and the EC2
instances within the AWS Virtual Private Cloud.

To connect your corporate network with the applicaons deployed in the AWS Cloud, you can
configure the firewall as a terminaon point for an IPSec VPN tunnel. This VPN tunnel allows
users on your network to securely access the applicaons in the cloud.

For centralized management, consistent enforcement of policy across your enre network, and
for centralized logging and reporng, you can also deploy Panorama in your corporate network.
If you need to set up VPN access to mulple VPCs, using Panorama allows you to group the
firewalls by region and administer them with ease.
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Figure 2: VM-Series for VPN Access

• Deploy the VM-Series firewall as a GlobalProtect gateway to secure access for remote users
using laptops. The GlobalProtect agent on the laptop connects to the gateway, and based
on the request, the gateway either sets up a VPN connecon to the corporate network
or routes the request to the internet. To enforce security compliance for users on mobile
devices (using the GlobalProtect App), the GlobalProtect gateway is used in conjuncon with
the GlobalProtect Mobile Security Manager. The GlobalProtect Mobile Security Manager
ensures that mobile devices are managed and configured with the device sengs and account
informaon for use with corporate applicaons and networks.

In each of the use cases above, you can deploy the VM-Series firewall in an acve/
passive high availability (HA) pair. For informaon on seng up the VM-Series firewall
in HA, see Use Case: Use Dynamic Address Groups to Secure New EC2 Instances
within the VPC.

• Deploy the VM-Series firewall with the Amazon Elasc Load Balancing (ELB) service, whereby
the firewall can receive dataplane traffic on the primary interface in the following scenarios
where the VM-Series firewall is behind the Amazon ELB:

• The VM-Series firewall(s) is securing traffic outbound directly to the internet without the
need for using a VPN link or a Direct Connect link back to the corporate network.

• The VM-Series firewall secures an internet-facing applicaon when there is exactly one
back-end server, such as a web server, for each firewall. The VM-Series firewalls and web
servers can scale linearly, in pairs, behind ELB.

If you want to Auto Scale VM-Series Firewalls with the Amazon ELB Service, use the
CloudFormaon Template available in the GitHub repository repository to deploy the VM-
Series in an ELB sandwich topology with an internet-facing classic ELB and an either an internal
classic load balancer or an internal applicaon load balancer (internal ELB).
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Figure 3: VM-Series with ELB

You cannot configure the firewall to send and receive dataplane traffic on eth0 when the
firewall is in front of ELB. The VM-Series firewall must be placed behind the Amazon ELB.

You can either Use the VM-Series Firewall CLI to Swap the Management Interface or
enable it on bootstrap. For details, see Management Interface Mapping for Use with
Amazon ELB.

If you want to deploy a load balancer sandwich topology, see Auto Scale VM-Series
Firewalls with the Amazon ELB Service.

In addion to the links above that are covered under the Palo Alto Networks official
support policy, Palo Alto Networks provides Community supported templates in the Palo
Alto Networks GitHub repository that allow you to explore the soluons available to
jumpstart your journey into cloud automaon and scale on AWS. See AWS Transit VPC
for a hub and subscribing VPC deployment that enables you to secure traffic between
VPCs, between a VPC and an on-prem/hybrid cloud resource, and secure outbound traffic
to the internet.
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Deploy the VM-Series Firewall on AWS
• Obtain the AMI
• Planning Worksheet for the VM-Series in the AWS VPC
• Launch the VM-Series Firewall on AWS
• Launch the VM-Series Firewall on AWS Outpost
• Create a Custom Amazon Machine Image (AMI)
• Encrypt EBS Volume for the VM-Series Firewall on AWS
• Use the VM-Series Firewall CLI to Swap the Management Interface
• Enable CloudWatch Monitoring on the VM-Series Firewall

Obtain the AMI
Get the Amazon Machine Image for the public AWS cloud and the AWS GovCloud from the
respecve Marketplace.

• AMI in the Public AWS Cloud
• AMI on AWS GovCloud
• Get the VM-Series Firewall Amazon Machine Image (AMI) ID

AMI in the Public AWS Cloud
The AMI for the VM-Series firewall is available in the AWS Marketplace for both the Bring Your
Own License (BYOL) and the usage-based pricing opons.

For purchasing licenses with the BYOL opon, contact your Palo Alto Networks sales engineer or
reseller.
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AMI on AWS GovCloud
The Bring Your Own License (BYOL) model and the usage-based model of the VM-Series firewall
is available on the AWS GovCloud Marketplace.

With a GovCloud account, you can search for Palo Alto Networks and find the AMIs for the VM-
Series firewall on the Marketplace. Make sure to review the supported EC2 instance types before
you launch the firewall. For details, see Launch the VM-Series Firewall on AWS.

Table 1: Review System Requirements and Limitations for VM-Series on AWS

Requirement Details

EC2 instance types The EC2 instance type you select must meet the VM-Series System
Requirements for the VM-Series firewall model. If you deploy the
VM-Series firewall on an EC2 instance type that does not meet these
requirements, the firewall will boot into maintenance mode

To support VM Monitoring and high availability on AWS,
the VM-Series firewall must be able to directly reach the
AWS API service endpoints without any proxy servers
between the firewall management interface and the AWS
API endpoints (such as ec2.us-west-2.amazonaws.com).
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Requirement Details

Amazon Elasc Block
Storage (EBS)

The VM-Series firewall must use the Amazon Elasc Block Storage
(EBS) volume for storage. EBS opmizaon provides an opmized
configuraon stack and addional, dedicated capacity for Amazon EBS
I/O.

Networking Because the AWS only supports Layer 3 networking capabilies, the
VM-Series firewall can only be deployed with Layer 3 interfaces. Layer
2 interfaces, virtual wire, VLANs, and subinterfaces are not supported
on the VM-Series firewall deployed in the AWS VPC.

Interfaces Support for a total of eight interfaces is available—one management
interface and a maximum of seven Elasc Network Interfaces (ENIs) for
data traffic. The VM-Series firewall does not support hot aachment of
ENIs; to detect the addion or removal of an ENI you must reboot the
firewall.

Your EC2 instance type selecon determines the total
number of ENIs you can enable. For example, the c3.8xlarge
supports eight (8) ENIs.

Support entlement
and Licenses

For the Bring Your Own License model, a support account and a valid
VM-Series license are required to obtain the Amazon Machine Image
(AMI) file, which is required to install the VM-Series firewall in the
AWS VPC. The licenses required for the VM-Series firewall—capacity
license, support license, and subscripons for Threat Prevenon, URL
Filtering, WildFire, etc—must be purchased from Palo Alto Networks.
To purchase the licenses for your deployment, contact your sales
representave. See VM-Series Firewall Licenses for Public Clouds.

For the usage-based licensing model, hourly and annual pricing bundles
can be purchased and billed directly to AWS. You must however,
register your support entlement with Palo Alto Networks. For details
see, Register the Usage-Based Model of the VM-Series Firewall for
Public Clouds (no auth code).

Get the VM-Series Firewall Amazon Machine Image (AMI) ID
Use the following instrucons to find the AMI ID for the VM-Series firewall that matches the
PAN-OS version, license type,  and AWS region in which you want to launch the VM-Series
firewall.

STEP 1 | Install AWS CLI on the client that you are using to retrieve the AMI ID, and login with your
AWS credenals.

Refer to the AWS documentaon for instrucons on installing the CLI.
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STEP 2 | Find the AMI-ID with the following CLI command.

aws ec2 describe-images --filters "Name=product-
code,Values=<license-type-value>" Name=name,Values=PA-VM-AWS*<PAN-
OS-version>*  --region <region> --output json

 You need to replace the value in the angle brackets <> with the relevant informaon as shown
below:

• Use the VM-Series product code for each license type. The values are:

• Bundle 1—

            e9yfvyj3uag5uo5j2hjikv74n
           

• Bundle 2—

            hd44w1chf26uv4p52cdynb2o
           

• BYOL—

            6njl1pau431dv1qxipg63mvah
           

• Use the PAN-OS version— 10.0. If there are mulple feature releases within a PAN-OS
version all the AMI-IDs are listed for you. For example,  in 9.0.x, you will view a lisng of the
AMI IDs for PAN-OS versions 9.0, 9.0.3.xfr, 9.0.5.xfr, and 9.0.6, and you can use the AMI-ID
for the PAN-OS version you need.

• Get the AWS region details from: hps://docs.aws.amazon.com/general/latest/gr/
rande.html.

For example: To find the AMI-ID for the VM-Series Bundle 1 for PAN-OS 10.0.0 in US
California region, the CLI command is:

       aws ec2 describe-images --filters "Name=product-
code,Values=e9yfvyj3uag5uo5j2hjikv74n" "Name=name,Values=PA-VM-
AWS*10.0*"  --region us-west-1 --output json
      

The output is:

       {

            "ProductCodes": [

                {

                    "ProductCodeId": "e9yfvyj3uag5uo5j2hjikv74n", 
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                    "ProductCodeType": "marketplace"

                }

            ], 

             "VirtualizationType": "hvm", 

            "Hypervisor": "xen", 

            "ImageOwnerAlias": "aws-marketplace", 

            "EnaSupport": true, 

            "SriovNetSupport": "simple", 

            "ImageId": "ami-06f7a63d7481d0ded", 

            "State": "available", 

            "BlockDeviceMappings": [

                {

                    "DeviceName": "/dev/xvda", 

                    "Ebs": {

                        "SnapshotId": "snap-0009036179b39824b", 

                        "DeleteOnTermination": false, 

                        "VolumeType": "gp2", 

                        "VolumeSize": 60, 

                        "Encrypted": false

                    }

                }

            ], 

            "Architecture": "x86_64", 

            "ImageLocation": "aws-marketplace/PA-VM-AWS-10.0.0-
f1260463-68e1-4bfb-bf2e-075c2664c1d7-ami-06f7a63d7481d0ded.1", 

            "RootDeviceType": "ebs", 

            "OwnerId": "679593333241", 

            "RootDeviceName": "/dev/xvda", 
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            "CreationDate": "2020-07-20T12:45:22.000Z", 

            "Public": true, 

            "ImageType": "machine", 

            "Name": "PA-VM-AWS-10.0.0-f1260463-68e1-4bfb-
bf2e-075c2664c1d7-ami-06f7a63d7481d0ded.1"

        }
      

You can also output to a table format. For example, to see AMI for BYOL image for PAN-OS
10.0.2:

aws ec2 describe-images --filters "Name=product-
code,Values=6njl1pau431dv1qxipg63mvah" "Name=name,Values=PA-VM-
AWS*10.0.2*" --region us-west-1 --output table --query "Images[*].
{Name:Name,AMI:ImageId,State:State}"

-------------------------------------------------------------------------------------------------------------------------|
                          DescribeImages      
                     |+-----------------------
+---------------------------------------------------------------------------------
+-------------+|     AMI     |                   Name 
                   |  State  |+-----------------------
+---------------------------------------------------------------------------------
+-------------+| ami-037b90bd9b630f594| PA-VM-
AWS-10.0.2-7064e142-2859-40a4-ab62-8b0996b842e9-
ami-07a0e94019f2a2001.4 | available |+-----------------------
+---------------------------------------------------------------------------------
+-------------+

Planning Worksheet for the VM-Series in the AWS VPC
For ease of deployment, plan the subnets within the VPC and the EC2 instances that you want
to deploy within each subnet. Before you begin, use the following table to collate the network
informaon required to deploy and insert the VM-Series firewall into the traffic flow in the VPC:

All VM-Series firewall interfaces must be assigned an IPv4 address when deployed in a
public cloud environment. IPv6 addresses are not supported.

Configuraon Item Value

VPC CIDR

Security Groups

Subnet (public) CIDR

Subnet (private) CIDR
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Configuraon Item Value

Subnet (public) Route Table

Subnet (private) Route Table

Security Groups

• Rules for Management Access to
the firewall (eth0/0)

• Rules for access to the
dataplane interfaces of the
firewall

• Rules for access to the
interfaces assigned to the
applicaon servers.

VM-Series firewall behind ELB

EC2 Instance 1 (VM-Series firewall)

An EIP is only required
for the dataplane
interface that is
aached to the public
subnet.

Subnet:

Instance type:

Mgmt interface IP:

Mgmt interface EIP:

Dataplane interface eth1/1

• Private IP:
• EIP (if required):
• Security Group:

Dataplane interface eth1/2

• Private IP:
• EIP (if required):
• Security Group:

EC2 Instance 2 (Applicaon to be
secured)

Repeat these set of values for
addional applicaon(s) being
deployed.

Subnet:

Instance type:

Mgmt interface IP:

Default gateway:

Dataplane interface 1

• Private IP:
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Configuraon Item Value

Requirements for HA If you are deploying the VM-Series firewalls in a high
availability (acve/passive) configuraon, you must
ensure the following:

• Create an IAM role and assign the role to the VM-
Series firewall when you are deploying the instance.
See IAM Roles for HA.

• Deploy the HA peers in the same AWS availability
zone.

• The acve firewall in the HA pair must have at a
minimum three ENIs: two dataplane interfaces and
one management interface.

The passive firewall in the HA pair, must have one
ENI for management, and one ENI that funcons as
dataplane interface; you will configure the dataplane
interface as an HA2 interface.

Do not aach addional dataplane interfaces
to the passive firewall in the HA pair. On
failover, the dataplane interfaces from
the previously acve firewall are moved —
detached and then aached—to the now
acve (previously passive) firewall.

Launch the VM-Series Firewall on AWS
If you have not already registered the capacity authcode that you received with the order
fulfillment email with your support account, see Register the VM-Series Firewall. Aer registering,
deploy the VM-Series firewall using an AMI published in the Marketplace or Create a Custom
Amazon Machine Image (AMI) in the AWS VPC as follows:

All VM-Series firewall interfaces must be assigned an IPv4 address when deployed in a
public cloud environment. IPv6 addresses are not supported.

STEP 1 | Access the AWS Console.

Log in to the AWS console and select the EC2 Dashboard.
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STEP 2 | Set up the VPC for your network needs.

Whether you launch the VM-Series firewall in an exisng VPC or you create a new VPC, the
VM-Series firewall must be able to receive traffic from the EC2 instances and perform inbound
and outbound communicaon between the VPC and the internet.

Refer to the AWS VPC documentaon for instrucons on creang a VPC and seng it up for
access.

For an example with a complete workflow, see Use Case: Secure the EC2 Instances in the AWS
Cloud.

1. Create a new VPC or use an exisng VPC. Refer to the AWS Geng Started
documentaon.

2. Verify that the network and security components are defined suitably.

• Enable communicaon to the internet. The default VPC includes an internet gateway,
and if you install the VM-Series firewall in the default subnet it has access to the
internet.

• Create subnets. Subnets are segments of the IP address range assigned to the VPC in
which you can launch the EC2 instances. The VM-Series firewall must belong to the
public subnet so that it can be configured to access the internet.

• Create security groups as needed to manage inbound and outbound traffic from the
EC2 instances/subnets.

• Add routes to the route table for a private subnet to ensure that traffic can be routed
across subnets and security groups in the VPC, as applicable.

3. If you want to deploy a pair of VM-Series firewalls in HA, you must define IAM Roles for
HA before you can Configure Acve/Passive HA on AWS.

4. (Oponal) If you are using bootstrapping to perform the configuraon of your VM-Series
firewall, refer to Bootstrap the VM-Series Firewall on AWS. For more informaon about
bootstrapping, see Bootstrap the VM-Series Firewall and Choose a Bootstrap Method.

STEP 3 | Launch the VM-Series firewall.

Although you can add addional network interfaces (ENIs) to the VM-Series
firewall when you launch, AWS releases the auto-assigned Public IP address for the
management interface when you restart the firewall. Hence, to ensure connecvity to
the management interface you must assign an Elasc IP address for the management
interface, before aaching addional interfaces to the firewall.

If you want to conserve EIP addresses, you can assign one EIP address to the eth 1/1 interface
and use this interface for both management traffic and data traffic. To restrict services
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permied on the interface or limit IP addresses that can log in the eth 1/1 interface, aach a
management profile to the interface.

1. On the EC2 Dashboard, click Launch Instance.
2. Select the VM-Series AMI. To get the AMI, see Obtain the AMI.
3. Launch the VM-Series firewall on an EC2 instance.

1. Choose the EC2 instance type for allocang the resources required for the firewall,
and click Next. See VM-Series System Requirements, for resource requirements.

2. Select the VPC.
3. Select the public subnet to which the VM-Series management interface will aach.
4. Select Automacally assign a public IP address. This allows you to obtain a publicly

accessible IP address for the management interface of the VM-Series firewall.

You can later aach an Elasc IP address to the management interface; unlike
the public IP address that is disassociated from the firewall when the instance is
terminated, the Elasc IP address provides persistence and can be reaached to
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a new (or replacement) instance of the VM-Series firewall without the need to
reconfigure the IP address wherever you might have referenced it.

5. Select Launch as an EBS-opmized instance.
6. Add another network interface for deployments with ELB so that you can swap the

management and data interfaces on the firewall. Swapping interfaces requires a
minimum of two ENIs (eth0 and eth1).

• Expand the Network Interfaces secon and click Add Device to add another
network interface.

Make sure that your VPC has more than one subnet so that you can add addional
ENIs at launch.

If you launch the firewall with only one ENI:

• The interface swap command will cause the firewall to boot into
maintenance mode.

• You must reboot the firewall when you add the second ENI.
• Expand the Advanced Details secon and in the User data field enter mgmt-

interface-swap=enable as text to perform the interface swap during launch.

Bootstrap Package—If you are bootstrapping the firewall with the
bootstrap package, you can also enter a semicolon separator aer mgmt-
interface-swap=enable, then enter vmseries-bootstrap-aws-
s3bucket=<bucketname>.

User Data—If you are bootstrapping with user data, enter a semicolon separator
aer mgmt-interface-swap=enable, and enter addional key-value pairs
according to Enter a Basic Configuraon as User Data (Public Clouds).

AWS Secret—If you are bootstrapping with an AWS secret, enter a semicolon
separator aer mgmt-interface-swap=enable, and enter the secret name as a
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key-value pair, as described in Step 3 of Bootstrap the VM-Series Firewall on AWS.
For example:

7. Accept the default Storage sengs. The firewall uses volume type SSD (gp2).

This key pair is required for first me access to the firewall. It is also required
to access the firewall in maintenance mode.

8. (Oponal) Tagging. Add one or more tags to create your own metadata to idenfy and
group the VM-Series firewall. For example, add a Name tag with a Value that helps
you remember that the ENI interfaces have been swapped on this VM-Series firewall.

9. Select an exisng Security Group or create a new one. This security group is for
restricng access to the management interface of the firewall. At a minimum consider
enabling hps and ssh access for the management interface.

10.If prompted, select an appropriate SSD opon for your setup.
11.Select Review and Launch. Review that your selecons are accurate and click Launch.
12.Select an exisng key pair or create a new one, and acknowledge the key disclaimer.
13.Download and save the private key to a safe locaon; the file extension is .pem. You

cannot regenerate this key, if lost.

It takes 5-7 minutes to launch the VM-Series firewall. You can view the progress on
the EC2 Dashboard.When the process completes, the VM-Series firewall displays on
the Instances page of the EC2 Dashboard.
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STEP 4 | Configure a new administrave password for the firewall.

On the VM-Series firewall CLI, you must configure a unique administrave password
before you can access the web interface of the firewall. To log in to the CLI, you require
the private key that you used to launch the firewall.

1. Use the public IP address to SSH into the Command Line Interface (CLI) of the VM-Series
firewall. You will need the private key that you used or created in 3 above to access the
CLI.

If you added an addional ENI to support deployments with ELB, you must first
create and assign an Elasc IP address to the ENI to access the CLI, see 6.

If you are using PuTTY for SSH access, you must convert the .pem format to a .ppk
format. See hps://docs.aws.amazon.com/AWSEC2/latest/UserGuide/puy.html

2. Enter the following command to log in to the firewall:

ssh-i <private_key.pem> admin@<public-ip_address>
3. Configure a new password, using the following command and follow the onscreen

prompts:
configure
set mgt-config users admin password

4. If you have a BYOL that needs to be acvated, set the DNS server IP address so that the
firewall can aceess the Palo Alto Networks licensing server. Enter the following command
to set the DNS server IP address:

set deviceconfig system dns-setting servers primary <ip_address>
5. Commit your changes with the command:

commit
6. Terminate the SSH session.

STEP 5 | Shutdown the VM-Series firewall.
1. On the EC2 Dashboard, select Instances.
2. From the list, select the VM-Series firewall and click Acons > Stop.

STEP 6 | Create and assign an Elasc IP address (EIP) to the ENI used for management access to the
firewall and reboot the VM-Series firewall.
1. Select Elasc IPs and click Allocate New Address.
2. Select EC2-VPC and click Yes, Allocate.
3. Select the newly allocated EIP and click Associate Address.
4. Select the Network Interface and the Private IP address associated with the

management interface and click Yes, Associate.

STEP 7 | Create virtual network interface(s) and aach the interface(s) to the VM-Series firewall. The
virtual network interfaces are called Elasc Network Interfaces (ENIs) on AWS, and serve as
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the dataplane network interfaces on the firewall. These interfaces are used for handling data
traffic to/from the firewall.

You will need at least two ENIs that allow inbound and outbound traffic to/from the firewall.
You can add up to seven ENIs to handle data traffic on the VM-Series firewall; check your EC2
instance type to verify the maximum number supported on it.

1. On the EC2 Dashboard, select Network Interfaces, and click Create Network Interface.
2. Enter a descripve name for the interface.
3. Select the subnet. Use the subnet ID to make sure that you have selected the correct

subnet. You can only aach an ENI to an instance in the same subnet.
4. Enter the Private IP address to assign to the interface or select Auto-assign to

automacally assign an IP address within the available IP addresses in the selected
subnet.

5. Select the Security group to control access to the dataplane network interface.
6. Click Yes, Create.

7. To aach the ENI to the VM-Series firewall, select the interface you just created, and
click Aach.

8. Select the Instance ID of the VM-Series firewall, and click Aach.
9. Repeat the steps above for creang and aaching at least one more ENI to the firewall.

STEP 8 | (Not required for the Usage-based licensing model) Acvate the licenses on the VM-Series
firewall.

This task is not performed on the AWS management console. Access to the Palo Alto
Networks support portal and the web interface of the VM-Series firewall is required for
license acvaon.

See Acvate the License.
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STEP 9 | Disable Source/Desnaon check on every firewall dataplane network interface(s). Disabling
this opon allows the interface to handle network traffic that is not desned to the IP
address assigned to the network interface.
1. On the EC2 Dashboard, select the network interface, for example eth1/1, in the

Network Interfaces tab.
2. In the Acon drop-down, select Change Source/Dest. Check.

3. Click Disabled and Save your changes.
4. Repeat Steps 1-3 for each firewall dataplane interface.

VM-Series Deployment Guide Version Version 10.1 334 ©2022 Palo Alto Networks, Inc.



Set Up the VM-Series Firewall on AWS

STEP 10 | Configure the dataplane network interfaces as Layer 3 interfaces on the firewall.

For an example configuraon, see steps 14 through 17 in Use Case: Secure the EC2 Instances
in the AWS Cloud.

On the applicaon servers within the VPC, define the dataplane network interface of
the firewall as the default gateway.

1. Using a secure connecon (hps) from your web browser, log in using the EIP address
and password you assigned during inial configuraon (hps://<Elasc_IP address>). You
will see a cerficate warning; that is okay. Connue to the web page.

2. Select Network > Interfaces > Ethernet.
3. Click the link for ethernet 1/1 and configure as follows:

• Interface Type: Layer3
• On the Config tab, assign the interface to the default router.
• On the Config tab, expand the Security Zone drop-down and select New Zone.

Define a new zone, for example VM_Series_untrust, and then click OK.
• On the IPv4 tab, select either Stac or DHCP Client.

If using the Stac opon, click Add in the IP secon, and enter the IP address and
network mask for the interface, for example 10.0.0.10/24.

Make sure that the IP address matches the ENI IP address that you assigned earlier.

If using DHCP, select DHCP Client; the private IP address that you assigned to the
ENI in the AWS management console will be automacally acquired.

4. Click the link for ethernet 1/2 and configure as follows:

• Interface Type: Layer3
• Security Zone: VM_Series_trust
• IP address: Select the Stac or DHCP Client radio buon.

For stac, click Add in the IP secon, and enter the IP address and network mask for
the interface. Make sure that the IP address matches the aached ENI IP address that
you assigned earlier.

5. Click Commit. Verify that the link state for the interfaces are up.

For DHCP, clear the Automacally create default route to default gateway
provided by server check box. For an interface that is aached to the private
subnet in the VPC, disabling this opon ensures that traffic handled by this
interface does not flow directly to the internet gateway on the VPC.
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STEP 11 | Create NAT rules to allow inbound and outbound traffic from the servers deployed within
the VPC.
1. Select Policies > NAT on the web interface of the firewall.
2. Create a NAT rule to allow traffic from the dataplane network interface on the firewall to

the web server interface in the VPC.
3. Create a NAT rule to allow outbound access for traffic from the web server to the

internet.

STEP 12 | Create security policies to allow/deny traffic to/from the servers deployed within the VPC.
1. Select Policies > Security on the web interface of the firewall.
2. Click Add, and specify the zones, applicaons and logging opons that you would like to

execute to restrict and audit traffic traversing through the network.

STEP 13 | Commit the changes on the firewall.

Click Commit.

STEP 14 | Verify that the VM-Series firewall is securing traffic and that the NAT rules are in effect.
1. Select Monitor > Logs > Traffic on the web interface of the firewall.
2. View the logs to make sure that the applicaons traversing the network match the

security policies you implemented.

Launch the VM-Series Firewall on AWS Outpost
Follow this procedure to deploy the VM-Series firewall on an AWS Ouptost rack. If you have not
already registered the capacity authcode that you received with the order fulfillment email, with
your support account, see Register the VM-Series Firewall.

All VM-Series firewall interfaces must be assigned an IPv4 address when deployed in a
public cloud environment. IPv6 addresses are not supported.

STEP 1 | Access the AWS Outposts Console.
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STEP 2 | Extend your VPC to include your AWS Outpost rack.

The VM-Series firewall must be able to receive traffic from the EC2 instances and perform
inbound and outbound communicaon between the VPC and the internet.

Refer to the AWS Outpost documentaon for instrucons on connecng your Outpost to your
VPC.

1. Verify that the network and security components are defined suitably.

• Enable communicaon to the internet. The Outpost requires a local gateway to
connect to your local LAN and the internet.

• Create an Outpost subnet.
• Create security groups as needed to manage inbound and outbound traffic from the

EC2 instances/subnets.
• Add routes to the route table for a private subnet to ensure that traffic can be routed

across subnets and security groups in the VPC, as applicable.
2. If you want to deploy a pair of VM-Series firewalls in HA, you must define IAM Roles for

HA before you can configure High Availability for VM-Series Firewall on AWS.
3. (Oponal) If you are using bootstrapping to perform the configuraon of your VM-Series

firewall, refer to Bootstrap the VM-Series Firewall on AWS. For more informaon about
bootstrapping, see Bootstrap the VM-Series Firewall.

STEP 3 | Launch the VM-Series firewall.

Although you can add addional network interfaces (ENIs) to the VM-Series
firewall when you launch, AWS releases the auto-assigned Public IP address for the
management interface when you restart the firewall. Hence, to ensure connecvity to
the management interface you must assign an Elasc IP address for the management
interface, before aaching addional interfaces to the firewall.

If you want to conserve EIP addresses, you can assign one EIP address to the eth 1/1 interface
and use this interface for both management traffic and data traffic. To restrict services
permied on the interface or limit IP addresses that can log in the eth 1/1 interface, aach a
management profile to the interface.

1. On the EC2 Dashboard, click Launch Instance.
2. Select the VM-Series AMI. To get the AMI, see Obtain the AMI.
3. Launch the VM-Series firewall on an EC2 instance.

1. Choose the EC2 instance type for allocang the resources required for the firewall,
and click Next. See VM-Series System Requirements, for resource requirements.

2. Select the VPC.
3. Select the public subnet on Outpost to which the VM-Series management interface

will aach.
4. Select Automacally assign a public IP address. This allows you to obtain a publicly

accessible IP address for the management interface of the VM-Series firewall.

You can later aach an Elasc IP address to the management interface; unlike
the public IP address that is disassociated from the firewall when the instance is
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terminated, the Elasc IP address provides persistence and can be reaached to
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a new (or replacement) instance of the VM-Series firewall without the need to
reconfigure the IP address wherever you might have referenced it.

5. Select Launch as an EBS-opmized instance.
6. Add another network interface for deployments with ELB so that you can swap the

management and data interfaces on the firewall. Swapping interfaces requires a
minimum of two ENIs (eth0 and eth1).

• Expand the Network Interfaces secon and click Add Device to add another
network interface.

Make sure that your VPC has more than one subnet so that you can add addional
ENIs at launch.

If you launch the firewall with only one ENI:

• The interface swap command will cause the firewall to boot into
maintenance mode.

• You must reboot the firewall when you add the second ENI.
• Expand the Advanced Details secon and in the User data field enter mgmt-

interface-swap=enable as text to perform the interface swap during launch.

If you are bootstrapping the firewall, you can also enter vmseries-
bootstrap-aws-s3bucket=<bucketname> with a comma
separator aer mgmt-interface-swap=enable.

7. Accept the default Storage sengs. The firewall uses volume type SSD (gp2)

This key pair is required for first me access to the firewall. It is also required
to access the firewall in maintenance mode.

8. (Oponal) Tagging. Add one or more tags to create your own metadata to idenfy and
group the VM-Series firewall. For example, add a Name tag with a Value that helps
you remember that the ENI interfaces have been swapped on this VM-Series firewall.
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9. Select an exisng Security Group or create a new one. This security group is for
restricng access to the management interface of the firewall. At a minimum consider
enabling hps and ssh access for the management interface.

10.If prompted, select an appropriate SSD opon for your setup.
11.Select Review and Launch. Review that your selecons are accurate and click Launch.
12.Select an exisng key pair or create a new one, and acknowledge the key disclaimer.
13.Download and save the private key to a safe locaon; the file extension is .pem. You

cannot regenerate this key, if lost.

It takes 5-7 minutes to launch the VM-Series firewall. You can view the progress on
the EC2 Dashboard.When the process completes, the VM-Series firewall displays on
the Instances page of the EC2 Dashboard.

STEP 4 | Configure a new administrave password for the firewall.

On the VM-Series firewall CLI, you must configure a unique administrave password
before you can access the web interface of the firewall. To log in to the CLI, you require
the private key that you used to launch the firewall.

1. Use the public IP address to SSH into the Command Line Interface (CLI) of the VM-Series
firewall. You will need the private key that you used or created in 3 above to access the
CLI.

If you added an addional ENI to support deployments with ELB, you must first
create and assign an Elasc IP address to the ENI to access the CLI, see 6.

If you are using PuTTY for SSH access, you must convert the .pem format to a .ppk
format. See hps://docs.aws.amazon.com/AWSEC2/latest/UserGuide/puy.html

2. Enter the following command to log in to the firewall:

ssh-i <private_key.pem> admin@<public-ip_address>
3. Configure a new password, using the following command and follow the onscreen

prompts:
configure
set mgt-config users admin password

4. If you have a BYOL that needs to be acvated, set the DNS server IP address so that the
firewall can aceess the Palo Alto Networks licensing server. Enter the following command
to set the DNS server IP address:

set deviceconfig system dns-setting servers primary <ip_address>
5. Commit your changes with the command:

commit
6. Terminate the SSH session.

STEP 5 | Shutdown the VM-Series firewall.
1. On the EC2 Dashboard, select Instances.
2. From the list, select the VM-Series firewall and click Acons > Stop.
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STEP 6 | Create and assign an Elasc IP address (EIP) to the ENI used for management access to the
firewall and reboot the VM-Series firewall.
1. Select Elasc IPs and click Allocate New Address.
2. Select EC2-VPC and click Yes, Allocate.
3. Select the newly allocated EIP and click Associate Address.
4. Select the Network Interface and the Private IP address associated with the

management interface and click Yes, Associate.

STEP 7 | Create virtual network interface(s) and aach the interface(s) to the VM-Series firewall. The
virtual network interfaces are called Elasc Network Interfaces (ENIs) on AWS, and serve as
the dataplane network interfaces on the firewall. These interfaces are used for handling data
traffic to/from the firewall.

You will need at least two ENIs that allow inbound and outbound traffic to/from the firewall.
You can add up to seven ENIs to handle data traffic on the VM-Series firewall; check your EC2
instance type to verify the maximum number supported on it.

1. On the EC2 Dashboard, select Network Interfaces, and click Create Network Interface.
2. Enter a descripve name for the interface.
3. Select the subnet. Use the subnet ID to make sure that you have selected the correct

subnet. You can only aach an ENI to an instance in the same subnet.
4. Enter the Private IP address to assign to the interface or select Auto-assign to

automacally assign an IP address within the available IP addresses in the selected
subnet.

5. Select the Security group to control access to the dataplane network interface.
6. Click Yes, Create.

7. To aach the ENI to the VM-Series firewall, select the interface you just created, and
click Aach.

8. Select the Instance ID of the VM-Series firewall, and click Aach.
9. Repeat the steps above for creang and aaching at least one more ENI to the firewall.
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STEP 8 | (Not required for the Usage-based licensing model) Acvate the licenses on the VM-Series
firewall.

This task is not performed on the AWS management console. Access to the Palo Alto
Networks support portal and the web interface of the VM-Series firewall is required for
license acvaon.

See Acvate the License.

STEP 9 | Disable Source/Desnaon check on every firewall dataplane network interface(s). Disabling
this opon allows the interface to handle network traffic that is not desned to the IP
address assigned to the network interface.
1. On the EC2 Dashboard, select the network interface, for example eth1/1, in the

Network Interfaces tab.
2. In the Acon drop-down, select Change Source/Dest. Check.

3. Click Disabled and Save your changes.
4. Repeat Steps 1-3 for each firewall dataplane interface.
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STEP 10 | Configure the dataplane network interfaces as Layer 3 interfaces on the firewall.

For an example configuraon, see steps 14 through 17 in Use Case: Secure the EC2 Instances
in the AWS Cloud.

On the applicaon servers within the VPC, define the dataplane network interface of
the firewall as the default gateway.

1. Using a secure connecon (hps) from your web browser, log in using the EIP address
and password you assigned during inial configuraon (hps://<Elasc_IP address>). You
will see a cerficate warning; that is okay. Connue to the web page.

2. Select Network > Interfaces > Ethernet.
3. Click the link for ethernet 1/1 and configure as follows:

• Interface Type: Layer3
• On the Config tab, assign the interface to the default router.
• On the Config tab, expand the Security Zone drop-down and select New Zone.

Define a new zone, for example VM_Series_untrust, and then click OK.
• On the IPv4 tab, select either Stac or DHCP Client.

If using the Stac opon, click Add in the IP secon, and enter the IP address and
network mask for the interface, for example 10.0.0.10/24.

Make sure that the IP address matches the ENI IP address that you assigned earlier.

If using DHCP, select DHCP Client; the private IP address that you assigned to the
ENI in the AWS management console will be automacally acquired.

4. Click the link for ethernet 1/2 and configure as follows:

• Interface Type: Layer3
• Security Zone: VM_Series_trust
• IP address: Select the Stac or DHCP Client radio buon.

For stac, click Add in the IP secon, and enter the IP address and network mask for
the interface. Make sure that the IP address matches the aached ENI IP address that
you assigned earlier.

5. Click Commit. Verify that the link state for the interfaces are up.

For DHCP, clear the Automacally create default route to default gateway
provided by server check box. For an interface that is aached to the private
subnet in the VPC, disabling this opon ensures that traffic handled by this
interface does not flow directly to the internet gateway on the VPC.
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STEP 11 | Create NAT rules to allow inbound and outbound traffic from the servers deployed within
the VPC.
1. Select Policies > NAT on the web interface of the firewall.
2. Create a NAT rule to allow traffic from the dataplane network interface on the firewall to

the web server interface in the VPC.
3. Create a NAT rule to allow outbound access for traffic from the web server to the

internet.

STEP 12 | Create security policies to allow/deny traffic to/from the servers deployed within the VPC.
1. Select Policies > Security on the web interface of the firewall.
2. Click Add, and specify the zones, applicaons and logging opons that you would like to

execute to restrict and audit traffic traversing through the network.

STEP 13 | Commit the changes on the firewall.

Click Commit.

STEP 14 | Verify that the VM-Series firewall is securing traffic and that the NAT rules are in effect.
1. Select Monitor > Logs > Traffic on the web interface of the firewall.
2. View the logs to make sure that the applicaons traversing the network match the

security policies you implemented.

Create a Custom Amazon Machine Image (AMI)
A custom VM-Series AMI gives you the consistency and flexibility to deploy a VM-Series
firewall with the PAN-OS version you want to use on your network instead of being restricted
to using only an AMI that is published to the AWS public Marketplace or to the AWS GovCloud
Marketplace. Using a custom AMI speeds up the process of deploying a firewall with the PAN-OS
version of your choice because it reduces the me to provision the firewall with an AMI published
on the AWS public or AWS GovCloud marketplace, and then performing soware upgrades to get
to the PAN-OS version you have qualified or want to use on your network. Addionally, you can
then use the custom AMI in the Auto Scaling VM-Series Firewalls CloudFormaon Templates or
any other templates that you have created.

You can create a custom AMI with the BYOL, Bundle 1, or Bundle 2 licenses. The process of
creang a custom AMI requires you to remove all configuraon from the firewall and reset it to
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factory defaults, so in this workflow you’ll launch a new instance of the firewall from the AWS
Marketplace instead of using an exisng firewall that you have fully configured.

When creang a custom AMI with a BYOL version of the firewall, you must first acvate
the license on the firewall so that you can access and download PAN-OS soware updates
to upgrade your firewall, and then deacvate the license on the firewall before you reset
the firewall to factory defaults and create the custom AMI. If you do not deacvate the
license, you lose the license that you applied on this firewall instance.

STEP 1 | Launch the VM-Series firewall from the Marketplace.

See 3

STEP 2 | (Only for BYOL) Acvate the license.

STEP 3 | Install soware updates and upgrade the firewall to the PAN-OS version you plan to use.

STEP 4 | (Only for BYOL) Deacvate the license.

STEP 5 | Perform a private data reset.

A private data reset removes all logs and restores the default configuraon.

The system disks are not erased, so the content updates from Step 4 are intact.
1. Access the firewall CLI.
2. Remove all logs and restore the default configuraon.

        request system private-data-reset
       

Enter y to confirm.

The firewall reboots to inialize the default configuraon.
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STEP 6 | Create the custom AMI.
1. Log in to the AWS Console and select the EC2 Dashboard.
2. Stop the VM-Series firewall.
3. Select the VM-Series firewall instance, and click Image > Create Image.

4. Enter a custom image name, and click Create Image.

The disk space of 60GB is the minimum requirement.

5. Verify that the custom AMI is created and has the correct product code.

1. On the EC2 Dashboard, select AMI.
2. Select the AMI that you just created. Depending on whether you selected an AMI

with the BYOL, Bundle 1, or Bundle 2 licensing opons, you should see one of the
following Product Codes in the details:

• BYOL—6njl1pau431dv1qxipg63mvah
• Bundle 1—6kxdw3bbmdeda3o6i1ggqt4km
• Bundle 2—806j2of0qy5osgjjixq9gqc6g
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STEP 7 | Encrypt EBS Volume for the VM-Series Firewall on AWS.

If you plan to use the custom AMI with EBS encrypon for an Auto Scaling VM-Series Firewalls
with the Amazon ELB Service deployment, you must use the default master key for your AWS
account.

STEP 8 | Configure the administrave password on the firewall.

See 4

Encrypt EBS Volume for the VM-Series Firewall on AWS
EBS encrypon is available for all AWS EC2 Instance Types on which you can deploy the VM-
Series firewall. To securely store data on the VM-Series firewall on AWS, you must first create a
copy of an AMI that is published on the AWS public or GovCloud Marketplace, or use a custom
AMI, and then encrypt the EBS volume with a customer master key (CMK) on the AWS Key
Management Service (KMS). You can use the default master key for your AWS account or any
CMK that you have previously created using the AWS Key Management Service, and EBS the
KMS interact to ensure data security.

STEP 1 | Create an encrypon key on AWS or skip this step if you want to use the default master key
for your account.

You will use this key to encrypt the EBS volume on the firewall. Note that the key is region
specific.
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STEP 2 | Use the key to encrypt the EBS volume on the firewall.

You must create a copy of the AMI that you want to encrypt. You can copy an AMI that is
published on the AWS public or GovCloud Marketplace, or use a custom AMI (Create a Custom
Amazon Machine Image (AMI)).

1. On the EC2 Dashboard, select the AMI and Copy AMI.

2. Set the details for the AMI.
Make sure to select Encrypt target EBS snapshots.

3. Select the encrypon key and Copy AMI to create an encrypted EBS snapshot.
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4. Select EC2 Dashboard > Snapshots to verify that the EBS snapshot is encrypted with the
key you selected above.

Use the VM-Series Firewall CLI to Swap the Management Interface
If you did not swap the management interface (MGT) with the dataplane interface (ethernet 1/1)
when deploying the firewall, you can use the CLI to enable the firewall to receive dataplane traffic
on the primary interface aer launching the firewall.

STEP 1 | Complete Steps 1 through 7 in Launch the VM-Series Firewall on AWS.

Before you proceed, verify that the firewall has a minimum of two ENIs (eth0 and eth1).
If you launch the firewall with only one ENI, the interface swap command will cause the
firewall to boot into maintenance mode.

STEP 2 | On the EC2 Dashboard, view the IP address of the eth1 interface and verify that the AWS
Security Group rules allow connecons (HTTPS and SSH) to the new management interface
(eth1).

STEP 3 | Log in to the VM-Series firewall CLI and enter the following command:

set system setting mgmt-interface-swap enable yes

STEP 4 | Confirm that you want to swap the interface and use the eth1 dataplane interface as the
management interface.

STEP 5 | Reboot the firewall for the swap to take effect. Use the following command:

request restart system

STEP 6 | Verify that the interfaces have been swapped. Use the following command:

debug show vm-series interfaces all 
Phoenix_interface   Base-OS_port   Base-OS_MAC        PCI-ID  
       Driver 
mgt(interface-swap) eth0   0e:53:96:91:ef:29   0000:00:04.0 
  ixgbevf 
Ethernet1/1           eth1    0e:4d:84:5f:7f:4d       0000:00:03.0 
  ixgbevf 

Enable CloudWatch Monitoring on the VM-Series Firewall
The VM-Series firewall on AWS can publish nave PAN-OS metrics to AWS CloudWatch, which
you can use to monitor the firewalls. These metrics allow you to assess performance and usage
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paerns that you can use to take acon for launching or terminang instances of the VM-Series
firewalls.

The firewalls use AWS APIs to publish the metric to a namespace, which is the locaon on AWS
where the metrics are collected at a specified me interval. When you configure the firewalls to
publish metrics to AWS CloudWatch, there are two namespaces where you can view metrics—
the primary namespace collects and aggregates the selected metric for all instances configured to
use the namespace, and the secondary namespace that is automacally created with the suffix 
_dimensions allows you to filter the metrics using the hostname and AWS instance ID metadata
(or dimensions) and get visibility into the usage and performance of individual VM-Series firewalls.

You can monitor the metric in CloudWatch or create auto scaling policies to trigger alarms and
take an acon to manually deploy a new instance of the firewall when the monitored metric
reaches a threshold value. Refer to the AWS CloudWatch and Auto Scaling Groups (ASG)
documentaon on best pracces for seng the alarm condions for a scale out or scale in acon.

For a descripon on the PAN-OS metrics that you can publish to CloudWatch, see Custom PAN-
OS Metrics Published for Monitoring.

STEP 1 | Assign the appropriate permissions for the AWS Identy and Access Management (IAM) user
role that you use to deploy the VM-Series firewall on AWS.

Whether you launch a new instance of the VM-Series firewall or upgrade an exisng VM-
Series firewall on AWS, the IAM role associated with your instance, must have permissions to
publish metrics to CloudWatch.

1. On the AWS console, select IAM.
2. Edit the IAM role to grant the following permissions:

You can copy and the paste the permissions here:
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{
    "Version": "2012-10-17",
    "Statement": [
        {
           "Effect": "Allow",
            "Action": [
                "cloudwatch:PutMetricData"
            ],
            "Resource": [
                "*"
            ]
        }
    ]
}
        

STEP 2 | Enable CloudWatch on the VM-Series firewall on AWS.
1. Log in to the web interface on the VM-Series firewall
2. Select Device > VM-Series.
3. In AWS CloudWatch Setup, click Edit ( ) and select Enable CloudWatch Monitoring.

1. Enter the CloudWatch Namespace to which the firewall can publish metrics. The
namespace cannot begin with AWS.

The aggregated metrics for all VM-Series firewall in an HA pair or auto scaling
deployment are published to the namespace you entered above. The namespace with
the _dimensions suffix that is automacally created enables you to filter and view
metrics for an specific VM-Series firewall using the hostname or AWS instance ID
metadata aached to the firewall.

2. Set the Update Interval to a value between 1-60 minutes. This is the frequency at
which the firewall publishes the metrics to CloudWatch. The default is 5 minutes.

4. Commit the changes.

Unl the firewall starts to publish metrics to CloudWatch, you cannot configure alarms
for PAN-OS metrics.
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STEP 3 | Verify that you can see the metrics on CloudWatch.
1. On the AWS console, select CloudWatch > Metrics, to view CloudWatch metrics by

category.
2. From the Custom Metrics drop-down, select the namespace.

3. Verify that you can see PAN-OS metrics in the viewing list.

To filter by hostname or AWS Instance ID of a specific firewall, select _dimensions.
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STEP 4 | Configure alarms and acon for PAN-OS metrics on CloudWatch.

Refer to the AWS documentaon: hp://docs.aws.amazon.com/AmazonCloudWatch/latest/
monitoring/AlarmThatSendsEmail.html

A VM-Series firewall with bootstrap configuraon will take about 7-9 minutes to be available
for service. So, here are some examples on how to set alarms that trigger auto scaling for the
VM-Series firewall:

• If you have deployed 2 instances of the VM-Series firewalls as Global Protect Gateways
that secure remote users, use the GlobalProtect Gateway Acve Tunnels metric. You
can configure an alarm for when the number of acve tunnels is greater than 300 for 15
minutes, you can deploy 2 new instances of the VM-Series firewall, which are bootstrapped
and configured to serve as Global Protect Gateways.

• If you are using the firewall to secure your workloads in AWS, use the Session Ulizaon
metric to scale in or scale out the firewall based on resource usage. You can configure an
alarm for when the session ulizaon metric is greater than 60% for 15 minutes, to deploy
one instance of the VM-Series instance firewall. And conversely, if Session Ulizaon is less
than 50% for 30 minutes, terminate an instance of the VM-Series firewall.
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VM-Series Integraon with an AWS Gateway Load
Balancer

The AWS Gateway Load Balancer (GWLB) is an AWS managed service that allows you to deploy
a stack of VM-Series firewalls and operate in a horizontally scalable and fault-tolerant manner.
You can then expose the AWS GWLB with the stack of firewalls as a VPC endpoint service for
traffic inspecon and threat prevenon. By creang Gateway Load Balancer endpoints (GWLBE)
for the VPC endpoint service, you can easily insert an auto-scaling VM-Series firewall stack in the
outbound, east-west, and inbound traffic paths of your applicaons. VM-Series firewalls and the
GWLB use the GENEVE encapsulaon to keep your traffic packet headers and payload intact,
providing complete visibility of the source’s identy to your applicaons.

The VM-Series firewall supports decrypon when deployed behind a GWLB for forward
and inbound use cases, including TLS1.2 and TLS1.3 ulizing DHE/ECDHE ciphers.

Deploying the VM-Series firewall behind a GWLB requires you to configure the AWS
transit gateway.

The image below describes how the integraon of GWLB with VM-Series simplifies your AWS
transit gateway(TGW) environments. You aach a centralized security VPC to your transit
gateway. The centralized security VPC includes a GWLB to scale and load-balance traffic across
the stack of VM-Series firewalls.

To ensure that the VM-Series firewall can inspect traffic that is routed between VPC aachments,
you must enable appliance mode on the transit gateway VPC aachment for the security VPC
containing the VM-Series firewall. You can enable appliance mode using the command:

modify-transit-gateway-vpc-attachment --transit-gateway-attachment-id
 <value> --options ApplianceModeSupport=enable
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For more instrucons, see enabling appliance mode.

This ensures that bidireconal traffic is routed symmetrically—both request and response traffic
are directed to the same Gateway Endpoint in the firewall VPC and the GWLB will maintain
persistence to the same VM-Series firewall for inspecon before connuing to the correct
desnaon.

When deployed with a GWLB, you can use the VM-Series firewall to protect:

• Inbound traffic—traffic originang outside the VPC and desned to resources within your
applicaon VPC, such as web servers. VM-Series firewalls prevent malware and vulnerabilies
from entering the network in traffic allowed by AWS security groups.

• Outbound traffic—traffic originang within the applicaon VPCs and desned to external
resources on the Internet. The VM-Series firewalls protect outbound traffic flows by ensuring
that workloads in applicaon VPCs connect to permied services (such as Windows Update)
and allowed URL categories and prevenng data exfiltraon of sensive informaon.
Addionally, VM-Series security profiles prevent malware and vulnerabilies from entering the
network in the return traffic.

• East-West traffic—in a transit gateway environment, East-West traffic refers to Inter-
VPC traffic, such as the traffic between source and desnaon workloads in two different
applicaon VPCs. The VM-Series firewalls protect east-west traffic flows against malware
propagaon.

To protect the inbound traffic to your applicaon VPCs:

1. Create GWLBE endpoints(GWLBE1 and GWLBE2 in the figure above) having separate subnets
associated in your spoke VPCs. Ensure that you have separate subnets for GWLB Endpoints,
ALB, and Applicaon and Transit Gateway aachment within the applicaon VPC.

2. Add route tables in the applicaon VPC (in addion to the VPC local route) as follows:

1. Route table with IGW edge associaon - Add route desned to ALB with target as GWLBE.
2. Route table with ALB subnet associaon - Add route desned to 0.0.0.0/0 with target as

GWLBE.
3. Route table with GWLBE subnet associaon - Add route desned to 0.0.0.0/0 with target as

IGW.

With these routes in place, the inbound traffic arriving at VPC IGW is routed towards GWLBE.
The GWLBE forwards the traffic to GWLB which in turn sends the traffic to the VM-Series
Firewall in the Security VPC for inspecon. The firewall sends the request traffic back to the
applicaon VPC GWLBE, which then forwards the traffic to the applicaon through ALB.
Response traffic to this request is sent by ALB towards the applicaon GWLBE which then
sends the traffic to GWLB. The GWLB in turn sends the traffic to the VM-Series firewall. Aer
inspecng the response traffic, the firewall sends the response traffic back to the applicaon
GWLBE which in turn sends the traffic to IGW.

To protect the outbound traffic of the applicaon VPCs:

1. Create a GWLBE(GWLBE3 in the figure above) in the centralized firewall VPC. Ensure that you
have separate subnets for GWLB Endpoint, Transit Gateway aachment, NAT Gateway within
the Security VPC.

2. Create a NAT Gateway in the Security VPC.
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3. Add route tables as follows:

1. Route table with Applicaon subnet associaon - Add route desned to 0.0.0.0/0 with
target as TGW. This is in addion to the VPC local route.

2. Route tables in Security VPC:

• Route table with TGW aachment subnet associaon - In addion to VPC local route,
add route desned to 0.0.0.0/0 with target as GWLBE3.

• Route table with GWLBE subnet associaon - In addion to VPC local route, add route
desned to 0.0.0.0/0 with target as NAT Gateway. Add route desned to Applicaon
VPC CIDRs with target as TGW.

• Route table with NAT Gateway Subnet associaon - In addion to VPC local route, add
route desned to 0.0.0.0/0 with target as IGW. Add route desned to Applicaon VPC
CIDRs with target as GWLBE3.

3. Add Transit Gateway Route tables as follows:

• Route table with App1-1 VPC TGW-Aachment associaon - Add route desned to
0.0.0.0/0 with aachment ID as Security VPC TGW aachment.

• Route table with App2-2 VPC TGW-Aachment associaon - Add route desned to
0.0.0.0/0 with aachment ID as Security VPC TGW aachment.

• Route table with Security VPC TGW-Aachment associaon - (a) Add route desned
to App-1 VPC CIDR with aachment ID as Applicaon-1 VPC TGW aachment. (b)
Add route desned to App-2 VPC CIDR with aachment ID as Applicaon-2 VPC TGW
aachment.

With this configuraon in place, outbound traffic iniated from Applicaon(App1) is sent to
TGW and TGW forwards that to the Security VPC subnet. The traffic is then routed to Security
GWLBE(GWLBE3) which sends the traffic to VM-Series firewall for inspecon through GWLB.
The VM-Series firewall sends the traffic back to GWLBE3 aer inspecon and GWLBE3
forwards the traffic to NAT Gateway which sends the traffic through IGW. Similarly, the
response traffic passes through the NAT Gateway to GWLBE3, VM-Series firewall, and TGW
aer which it is routed back to the applicaon.

The East-West traffic is also managed with the routes and configuraon described in the steps
above. When the traffic is sent from App1 to App2, the traffic passes through TGW which
routes the traffic to GWLBE3. The GWLBE3 forwards the traffic to the VM-Series firewall
through GWLB. The VM-Series firewall sends the packet back to GWLBE3 aer inspecon.
GWLBE3 then forwards the packet to App2 through TGW. The response traffic from App-2 to
App-1 will take the reverse path.

It is recommended to have all subnets in the same AZ to avoid cross-zone traffic
charges.

Manual Integraon of the VM-Series with a Gateway Load
Balancer

Refer to the following topics to manually integrate the VM-Series firewall with an AWS gateway
load balancer.

• Enable VM-Series Integraon with a Gateway Load Balancer
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• Manually Integrate the VM-Series with a Gateway Load Balancer
• (Oponal) Associate a VPC Endpoint with a VM-Series Interface
• (Oponal) Enable Overlay Roung for the VM-Series on AWS

Enable VM-Series Integraon with a Gateway Load Balancer
When integrang the VM-Series firewall with a GWLB, you must first enable the VM-Series
firewall to properly process traffic redirected to the firewall by the GWLB endpoints. You can
enable this funconality using the VM-Series firewall CLI, through the VM-Series bootstrapping
package, or the user-data field in the AWS console.

VM-Series firewall deployment with a GWLB requires:

• PAN-OS 10.0.2 or later
• VM-Series plugin 2.0.2 or later
• Panorama 10.0.2 or later if you using Panorama to manage your firewalls

The table below lists the commands required to enable GWLB traffic inspecon with a VPC
endpoint. Operaon commands can be used in the a bootstrapping init-cfg.txt file or in the user-
data field in the AWS console.

Bootstrap Parameter CLI Command Descripon

mgmt-interface-swap=enable set system seng mgmt-
interface-swap enable yes

This command
requires the
firewall to
reboot before
taking effect.

Swaps eth0 and eth1. GWLB
by default, sends traffic
only to Eth0 of its target
instances. By swapping,
Eth0 becomes the data
interface and eth1 becomes
the management interface.

plugin-op-commands=aws-
gwlb-inspect:enable

request plugins vm_series
aws gwlb inspect enable
<yes/no>

Enables the VM-Series
firewall to process traffic
passing through a GWLB.

Manually Integrate the VM-Series with a Gateway Load Balancer
Complete the following procedure to manually integrate your VM-Series firewall on AWS with a
GWLB.

If you associate VPC endpoints to an interface or subinterfaces via user data while
bootstrapping and your bootstrap.xml file does not include the interface configuraon, you
can configure the interfaces aer the firewall boots up.

All VM-Series firewall interfaces must be assigned an IPv4 address when deployed in a
public cloud environment. IPv6 addresses are not supported.
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STEP 1 | Set up the security VPC. See the AWS documentaon for more informaon about creang
your security VPC.

• Create two subnets—one for management and one for data.
• Create two security groups—one for firewall management and one for data.
• The management subnet security groups should allow hps and ssh for management access.
• Ensure that the security group(s) in your data VPC allows GENEVE-encapsulated packets

(UDP port 6081).
• If your deployment includes a transit gateway and traffic that will move between VPCs, you

must enable appliance mode on security VPC aachment.

The target group of the GWLB cannot use HTTP for health checks because the VM-
Series firewall does not allow access with an unsecured protocol. Instead, use another
protocol such as HTTPS or TCP.
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STEP 2 | Launch the VM-Series firewall.
1. On the EC2 Dashboard, click Launch Instance.
2. Select the VM-Series AMI. To get the AMI, see Obtain the AMI.
3. Launch the VM-Series firewall on an EC2 instance.

1. Choose the EC2 instance type for allocang the resources required for the firewall,
and click Next. See VM-Series System Requirements, for resource requirements.

2. Select the security VPC.
3. Select the data subnet to aach to eth0.
4. Select Launch as an EBS-opmized instance.
5. Add another network interface for eth1 to act as the management interface aer the

interface swap. Swapping interfaces requires a minimum of two ENIs (eth0 and eth1).

• Expand the Network Interfaces secon and click Add Device to add another
network interface.

Make sure that your VPC has more than one subnet so that you can add addional
ENIs at launch.

If you launch the firewall with only one ENI:

• The interface swap command will cause the firewall to boot into
maintenance mode.

• You must reboot the firewall when you add the second ENI.
• Expand the Advanced Details secon and in the User data field enter as text to

perform the interface swap during launch.

mgmt-interface-swap=enable

plugin-op-commands=aws-gwlb-inspect:enable

If you set the target type to the IP address of a specific interface on the
VM-Series firewall, you do not need to enable management interface
swap.

6. Accept the default Storage sengs. The firewall uses volume type SSD (gp2).
7. If prompted, select an appropriate SSD opon for your setup.
8. (Oponal) Tagging. Add one or more tags to create your own metadata to idenfy and

group the VM-Series firewall. For example, add a Name tag with a Value that helps
you remember that the ENI interfaces have been swapped on this VM-Series firewall.

9. Select the data Security Group for eth0 (data interface). Enable traffic on UDP port
6081.
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If you enable health checks to the firewall, you cannot use HTTP. Instead, use another
protocol such as HTTPS or TCP.

10.Select Review and Launch. Review that your selecons are accurate and click Launch.
11.Select an exisng key pair or create a new one, and acknowledge the key disclaimer.

This key pair is required for first me access to the firewall. It is also required
to access the firewall in maintenance mode.

12.Download and save the private key to a safe locaon; the file extension is .pem. You
cannot regenerate this key, if lost.

It takes 5-7 minutes to launch the VM-Series firewall. You can view the progress on
the EC2 Dashboard.When the process completes, the VM-Series firewall displays on
the Instances page of the EC2 Dashboard.

STEP 3 | Aach the management security group to eth1 (management interface). Allow ssh and hps.
See the AWS Documentaon for more informaon.

STEP 4 | Create and assign an Elasc IP address (EIP) to the ENI used for management access (eth1) to
the firewall.
1. Select Elasc IPs and click Allocate New Address.
2. Select EC2-VPC and click Yes, Allocate.
3. Select the newly allocated EIP and click Associate Address.
4. Select the Network Interface and the Private IP address associated with the

management interface and click Yes, Associate.
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STEP 5 | Configure a new administrave password for the firewall.

On the VM-Series firewall CLI, you must configure a unique administrave password
before you can access the web interface of the firewall. To log in to the CLI, you require
the private key that you used to launch the firewall.

1. Use the EIP to SSH into the Command Line Interface (CLI) of the VM-Series firewall. You
will need the private key that you used or created above and using the user name admin
to access the CLI.

If you are using PuTTY for SSH access, you must convert the .pem format to a .ppk
format. See hps://docs.aws.amazon.com/AWSEC2/latest/UserGuide/puy.html

2. Enter the following command to log in to the firewall:

ssh-i <private_key.pem> admin@<public-ip_address>
3. Configure a new password, using the following command and follow the onscreen

prompts:
configure
set mgt-config users admin password

4. If you have a BYOL that needs to be acvated, set the DNS server IP address so that the
firewall can aceess the Palo Alto Networks licensing server. Enter the following command
to set the DNS server IP address:

set deviceconfig system dns-setting servers primary <ip_address>
5. Commit your changes with the command:

commit
6. Terminate the SSH session.
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STEP 6 | Configure the dataplane network interface as a Layer 3 interface on the firewall.

On the applicaon servers within the VPC, define the dataplane network interface of
the firewall as the default gateway.

1. Using a secure connecon (hps) from your web browser, log in using the EIP address
and password you assigned during inial configuraon (hps://<Elasc_IP address>). You
will see a cerficate warning; that is okay. Connue to the web page.

2. Select Network > Interfaces > Ethernet.
3. Click the link for ethernet 1/1 and configure as follows:

• Interface Type: Layer3
• On the Config tab, assign the interface to the default virtual router.
• On the Config tab, expand the Security Zone drop-down and select New Zone.

Define a new zone and leave the remaining fields with default values and then click
OK.

• On the IPv4 tab, select DHCP Client.

If using DHCP, select DHCP Client; the private IP address that you assigned to the
ENI in the AWS management console will be automacally acquired.

• On the Advanced tab, create a management profile to enable HTTP service as part of
management profile creaon and allow Health check probes from GWLB.

4. Click Commit. Verify that the link state for the interface is up.

STEP 7 | Create security policies to allow/deny traffic.

Because the VM-Series treats traffic as intrazone when integrated with a GWLB, a
default intrazone rule allows all traffic. It is a best pracce to override the default
intrazone rule with a deny acon for traffic that does not match any of your other
security policy rules.

1. Select Policies > Security on the web interface of the firewall.
2. Click Add, and specify the security zones, applicaons and logging opons that you

would like to execute to restrict and audit traffic traversing through the network.

STEP 8 | Commit the changes on the firewall.

Associate a VPC Endpoint with a VM-Series Interface
You can associate one or more VPC endpoints with an interface or subinterface of the VM-
Series firewall. You can provide consistent policy enforcement by associang all the endpoints
in a single VPC to the same subinterface on the firewall. Or, if your deployment has VPCs with
overlapping IP address, you can associate endpoints in different VPCs with different subinterfaces
for differenated policy enforcement.

Associang a VPC to an interface or subinterface is not mandatory to integrate the VM-
Series firewall with a GWLB.
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You can configure interfaces and associate a VPC with firewall interfaces using the following
methods:

• Include the interface configuraon in your bootstrap.xml file and the associaon
commands as part of the init-cfg.txt file or AWS user-data.

• Aer deploying the firewall, manually configure your interfaces and use the firewall CLI to
associate your VPCs with interfaces.

You can associate mulple VPC endpoints to a single interface on the VM-Series firewall.
However, you must associate each VPC endpoint individually. For example, to associate
VPC endpoint 1 and VPC endpoint 2 with subinterface ethernet1/1.2, you must execute the
associaon command separately for each VPC endpoint.

The table below describes the commands used to associate a VPC with an interface. You can
include the operaon command in your init-cfg.txt file or in the AWS user-data.

Bootstrap Parameter CLI Command Descripon

plugin-op-commands=

aws-gwlb-associate-
vpce:<vpce-
id>@ethernet<subinterface>

request plugins vm_series
aws gwlb associate vpc-
endpoint <vpce-id> interface
<subinterface>

Associates a VPC endpoint
with an interface or
subinterface on the firewall.
The specified interface is
assigned to a security zone.

— request plugins vm_series
aws gwlb disassociate vpc-
endpoint <vpce-id> interface
<subinterface>

Disassociates a VPC
endpoint with an interface or
subinterface on the firewall.
The specified interface is
assigned to a security zone.
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Bootstrap Parameter CLI Command Descripon

— show plugins vm_series aws
gwlb

Displays the operang state
of the firewall as it relates to
your GWLB deployment. It
does not display the firewall
configuraon.

For example, if you configure
an associaon to an interface
that does not exist, that
associaon is configured but
not part of the operang
state. Therefore, it is not
displayed.

When associang a VPC endpoint using the bootstrapping init-cfg.txt file or AWS user-date, you
can list mulple interfaces or subinterfaces together. All the commands must be on a single line in
a comma-separated list with no spaces as shown in the following example.

plugin-op-commands=aws-gwlb-inspect:enable,aws-gwlb-associate-
vpce:vpce-0913731043b5c0ebc@ethernet1/1.1,aws-gwlb-associate-
vpce:vpce-08207ccb4cb23a1de@ethernet1/1.1,aws-gwlb-associate-
vpce:vpce-07b66cca88821d6e1@ethernet1/1.2,aws-gwlb-associate-
vpce:vpce-0a9a583fdb928492b@ethernet1/1.3

If you are using subinterfaces to separate traffic, create a subinterface for each VPC and associate
it to a VPC.
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STEP 1 | Configure the subinterface.
1. Log in to the firewall web interface.
2. Select Network > Interface.
3. Highlight ethernet1/1 and click Add Subinterface.
4. Enter a numerical suffix (1 to 9,999) to idenfy the subinterface.
5. Enter a VLAN Tag (1 to 4,094) for the subinterface. This field is required but the VLAN is

not used.
6. Select Virtual Router as default.
7. Select a Security Zone.
8. On the IPv4 tab, set the Type to DHCP Client.
9. Click OK.
10. Repeat this command for each VPC endpoint.

STEP 2 | Associate the interface with a VPC endpoint.
1. Log in to the firewall CLI.
2. Execute the following command:

request plugins vm_series aws gwlb associate vpc-endpoint <vpce-
id> interface <subinterface>

For example:

request plugins vm_series aws gwlb associate vpc-endpoint
vpce-02c4e6g8ha97h7e39 interface ethernet1/1.4

You can locate the VPC endpoint ID in the AWS console.

3. Repeat this command for each interface and VPC endpoint associaon.

STEP 3 | Verify your interface to VPC endpoint associaons.
show plugins vm_series aws gwlb

GWLB enabled:      True
Overlay Routing:  False
-------------------------------------------------------------
VPC endpoint                    Interface

VM-Series Deployment Guide Version Version 10.1 365 ©2022 Palo Alto Networks, Inc.



Set Up the VM-Series Firewall on AWS

--------------------------------------------------------------
vpce-0aeb1a919bd4ae609           ethernet1/1.1
vpce-0294375bfe413f04a           ethernet1/1.2

STEP 4 | If necessary, you can use the following command to disassociate a VPC endpoint from a
interface.

request plugins vm_series aws gwlb disassociate vpc-endpoint <vpce-
id> interface <subinterface>

Enable Overlay Roung for the VM-Series on AWS

Overly roung requires PAN-OS 10.0.5 or later.

Using overlay roung in your VM-Series firewall integraon the AWS GWLB allows you to use
two-zone policy to inspect traffic leaving (egressing) your AWS environment. This allows packets
to leave the VM-Series firewall through a different interface than that which they entered through.

When overlay roung is configured, the firewall is able to perform a Layer 3 route lookup a
packet’s inner header. If the desnaon is the same as the ingress interface, the packet will be
directed as normal. All future packets in the session are treated as vwire; as if overlay roung
was not enabled. If the packet is going to an outbound desnaon, the firewall decapsulates
the packet and forwards the packet to the IGW or NAT gateway. When the packet returns, the
firewall reapplies the encapsulaon.

Use the following procedure to enable overlay roung.

STEP 1 | Before you begin, ensure that you create different subnets for the trust and untrust
interfaces.
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STEP 2 | Manually Integrate the VM-Series with a Gateway Load Balancer.

STEP 3 | (Oponal) Associate a VPC Endpoint with a VM-Series Interface.

STEP 4 | Use overlay roung CLI command. This CLI command is not required if you included the
overlay roung op-command in the AWS user-data or the init-cfg.txt bootstrap file.
1. Log in to the firewall command line interface.
2. Execute the following command.

request plugins vm_series aws gwlb overlay-routing enable yes

STEP 5 | Log in to the firewall web interface.

STEP 6 | Disable Automacally create default route poinng to default gateway provided by server
on the trust (ingress) interface.
1. Select Network > Interfaces > Ethernet.
2. Click on your trust interface and then the IPv4 tab.
3. Uncheck Automacally create default route poinng to default gateway provided by

server.
4. Click OK.
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STEP 7 | Configure interface Ethernet 1/2.
1. Select Network > Interfaces > Ethernet.
2. Select the Interface Type—Layer 3.
3. On the Config tab, expand the Security Zone drop-down and select New Zone. This zone

will act as your untrust zone and direcng outbound traffic out of your security VPC.
Define the new zone, such as VM-Series-untrust, and then click OK.

4. On the IPv4 tab, select DHCP Client.
5. Select Automacally create default route poinng to default gateway provided by

server.
6. Click OK.
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STEP 8 | Configure a virtual router.
1. Select Network > Virtual Routers > Add.
2. Enter a descripve Name for the virtual router.
3. Under Interfaces, Add Ethernet1/1, any subinterfaces under Ethernet1/1, and

Ethernet1/2.
4. Click Stac Routes > Add.

1. Enter a descripve name for the stac route.
2. As the Desnaon, enter the private IP address of the applicaon VPC subnet.
3. Select the trust (ingress) interface from the Interface drop-down.
4. For Next Hop, select IP Address and enter the IP address of the gateway of the trust

interface. You can find the gateway IP address on Network > Interfaces > Ethernet >
Dynamic-DHCP Client.

5. Click OK.
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5. Ensure that the stac routes can reach all applicaon VPC in your deployment. You
can either make a few large aggregated routes (covering all RFC1918) or applicaon
VPC specific routes. If you use subinterfaces, you do not need to route back to the sub-
interface. The egress check looks only for the matching interface instead of the matching
subinterface.

6. Click OK.

STEP 9 | Create a NAT policy for traffic egressing Ethernet1/2.
1. Select Policies > NAT > Add.
2. Enter a descripve Name for the NAT policy rule.
3. Select ipv4 from the NAT Type drop-down.
4. On the Original Packet tab, set the Source Zone to any and the Desnaon Zone to

your untrust (egress) zone.
5. On the Translated Packet tab, set the following parameters.

• Translaon Type: Dynamic IP and Port
• Address Type: Interface Address
• Interface: Select your untrust (egress) port from the drop-down.
• IP Address: None

6. Click OK.
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STEP 10 | Commit your changes.

VM-Series Auto Scaling Group with AWS Gateway Load Balancer
The Palo Alto Networks auto scaling template for AWS help you integrate and configure the VM-
Series firewall with a GWLB to protect applicaons deployed in AWS. The template leverage AWS
scalability features to independently and automacally scale VM-Series firewalls deployed in AWS
to meet surges in applicaon workload resource demand.

These templates are community supported.

This soluon provides a security VPC template and an applicaon template. The security VPC
template deploys the VM-Series firewall auto scaling group, a GWLB, a GWLBE, GWLBE subnet,
security aachment subnet, and a NAT gateway for each availability zone. Download the
CloudFormaon templates from the Palo Alto Networks GitHub Repository.

The VM-Series Auto Scaling template for integraon with an AWS GWLB includes the following
building blocks:

All VM-Series firewall interfaces must be assigned an IPv4 address when deployed in a
public cloud environment. IPv6 addresses are not supported.

Building Block Descripon

PAN
Components

• Panorama running 10.0.2 or later
• PAN-OS 10.0.2 or later
• VM-Series plugin 2.0.2 or later installed on Panorama

Firewall
template

(Community
supported
template)

Based on the number of availability zones (AZs) you choose, the firewall-
new-vpc-v3.0.template deploys the following:

The template supports a maximum of four AZs.

• Subnets for Lambda management, transit gateway aachments, GWLB
endpoints, and NAT gateways, as well as trust subnets.

• Routes tables for each subnet
• Transit gateway aachments and route tables
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Building Block Descripon

• NAT and internet gateways
• An auto scaling group with one VM-Series firewall per AZ.
• One GWLB and a GWLB endpoint in each AZ.

The VPC CIDR for the firewall template should be larger than /23.

Due to the many variaons in a producon environment that includes but
is not limited to a specific number components, such as subnets, availability
zones, route tables, and security groups. You must deploy the firewall-
new-vpc-v3.0.template in a new VPC.

VM-Series Auto Scaling template for AWS does not deploy a transit
gateway or Panorama. You must deploy a transit gateway and
Panorama before launching firewall-new-vpc-v3.0.template.

Applicaon
template

(Community
supported
template)

Based on the number of availability zones (AZs) you choose, the panw-aws-
app-v3.0.template deploys the following:

The template supports a maximum of four AZs.

• Subnets for Lambda, transit gateway aachments, GWLB endpoints,
applicaon load balancers.

• Routes tables for each subnet, as well as an inbound route table associated
with the internet gateway to direct inbound traffic to the GWLB endpoint.

• One applicaon load balancer
• One internet gateway
• An auto scaling group with one Ubuntu instance per AZ.

The VPC CIDR for the applicaon template should be larger than /23.

The applicaon template is intended to be used as an example for
validang the security template.

Lambda
funcons

AWS Lambda provides robust, event-driven automaon without the need
for complex orchestraon soware. In addion to deploying the components
described in the rows above, the firewall-new-vpc-v3.0.template
performs the following funcons:

• Adds or removes an interface (ENI) when a firewall is launched or
terminated.

• Deletes all the associated resources when you delete a stack or terminate
an instance.

• Removes a firewall as a Panorama managed device when there is a scale-in
event.
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Building Block Descripon

• Deacvates the license when a scale-in event results in a firewall
terminaon.

• Monitors the transit gateway periodically for new aachments or
detachments, and updates the route tables accordingly in the security VPC.

Bootstrap files

The
bootstrap.xml
file provided
in the GitHub
repository is
provided for
tesng and
evaluaon
only. For a
producon
deployment,
you must
modify the
sample
credenals
in the
bootstrap.xml
prior to
launch.

This soluon requires the init-cfg.txt file and the bootstrap.xml file so that the
VM-Series firewall has the basic configuraon for handling traffic.

• The init-cfg.txt file includes the mgmt-interface-swap operaonal
command to enable the firewall to receive dataplane traffic on its primary
interface (eth0). This auto-scaling soluon requires the swapping of the
dataplane and management interfaces to enable the GWLB to forward
web traffic to the auto-scaling er of VM-Series firewalls.

• The bootstrap.xml file enables basic connecvity for the firewall
network interfaces and allows the firewall to connect to the AWS
CloudWatch namespace that matches the stack name you enter when you
launch the template.

If you need to delete these templates from AWS, always delete the applicaon template
first. Aempng to delete the firewall template causes the deleon to fail.

• Before Launching the Templates
• Launch the Firewall Template
• Launch the Applicaon Template

Before Launching the Templates
Before you launch the templates to integrate a VM-Series firewall auto scaling group with an AWS
GWLB, you must complete the following procedure.

STEP 1 | Ensure that you have the following before you begin.

• Obtain the auth code for a bundle that supports the number of firewalls that might
be required for your deployment. You must save this auth code in a text file named
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authcodes (no extensions), and put the authcodes file in the /license folder of the
bootstrap package.

• Download the files required to launch the VM-Series Gateway Load Balancer template from
the GitHub repository.

• Create a Transit Gateway. This transit gateway connects your security and applicaon VPCs.

• Take note of the transit gateway ID; you will need it later when deploying the template.
• You must add a 0.0.0.0/0 route to the applicaon aachment route table poinng to the

security aachment to protect east-west and outbound traffic.
• Ensure that Default route table associaon and Default route table propagaon are

disabled.
• The recommended VPC CIDR for the firewall and applicaon templates should be larger

than /23.

The target group of the gateway GWLB cannot use HTTP for health checks because
the VM-Series firewall does not allow access with an unsecured protocol. Instead use
HTTPS or TCP.

STEP 2 | Deploy Panorama running 10.0.2 and configure the following.

Panorama must allow AWS public IP addresses. The VM-Series firewall accesses Panorama
using the external IP address of the NAT gateway created by the template.

STEP 3 | Download and install the VM-Series plugin on Panorama.
1. Select Panorama > Plugins  and use Check Now to look for new plugin packages. The

VM-Series plugin name is vm_series.
2. Consult the plugin release notes to determine which version provides upgrades useful to

you.
3. Select a version of the plugin and select Download in the Acon column.
4. Click Install in the Acon column. Panorama alerts you when the installaon is complete.
5. To view the plugin, select Device  > VM-Series.
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STEP 4 | Configure the template.
1. Log in to the Panorama web interface.
2. Select Panorama > Templates and click Add.

1. Enter a descripve Name.
2. Click OK.

3. Configure the virtual router.

1. Select Network > Virtual Routers.
2. Ensure that you have selected the template you create above from the Template

drop-down.
3. Click Add.
4. Name the virtual router using the following format: VR-<tempstackname>.
5. Enable ECMP on the virtual router.
6. Click OK.

4. Configure the interface and create the zone.

1. Select Network > Interfaces and click Add Interface.
2. Select Slot 1 and then select the Interface name (for example, ethernet 1/1).
3. Set Interface Type to Layer 3.
4. On the Config tab, select New Zone from the Security Zone drop-down. In the Zone

dialog, define a Name for new zone, for example Internet, and then click OK.
5. In the Virtual Router drop-down, select virtual router your created above.
6. Select IPv4 and click DHCP Client.
7. Click OK.

5. Create a management profile that allows HTTPS on the interface created above to
support Health Checks.

1. Select Network > Network Profiles > Interface Mgmt and click Add.
2. Select the protocols that the interface permits for management traffic: Ping, Telnet,

SSH, HTTP, HTTP OCSP, HTTPS, or SNMP.

Don’t enable HTTP or Telnet because those protocols transmit in cleartext
and therefore aren’t secure.

6. Assign the Interface Management profile to an interface.

1. Select Network > Interfaces, select the type of interface (Ethernet, VLAN, Loopback,
or Tunnel), and select the interface.

2. Select Advanced > Other info and select the Interface Management Profile you just
added.

3. Click OK.
7. Configure the DNS server and FQDN refresh me.

1. Select Device > Setup > Services and click the Edit icon.
2. Set the Primary DNS Server to 169.254.169.253. This is the AWS DNS address.
3. Set the Minimum FQDN Refresh Time to 60 seconds.
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4. Click OK.
8. Commit your changes. This is required before proceeding to the next step.
9. Create an administrator.

1. Select Device > Administrators.
2. Enter pandemo as the Name.
3. Set the Password to demopassword and Confirm.
4. Click OK.

10. Commit your changes.

STEP 5 | Configure a template stack and add the template to the template stack.
1. Select Panorama > Templates and Add Stack.
2. Enter a unique Name to idenfy the stack.
3. Click Add and select the template.
4. Click OK to save the template stack.

STEP 6 | Create the Device Group.
1. Select Panorama > Device Groups.
2. Click Add.
3. Enter a descripve Name.
4. Click OK.
5. Add an allow all security pre-rule.

1. Select Policies > Security > Pre Rules and click Add.
2. Enter a descripve Name.
3. Under Source, User, Desnaon, Applicaon, and Service/URL Category, select any.
4. Under Acons, select Allow.
5. Click OK.

6. Commit your changes.

STEP 7 | Add the license deacvaon API key for the firewall to Panorama.
1. Log in to the Customer Support Portal.
2. Select Assets > API Key Management.
3. Copy the API key.
4. Use the CLI to install the API key copied in the previous step.

request license api-key set key <key>
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STEP 8 | Aer deploying Panorama, you must open the following ports as described below on the
Panorama security group in AWS.

• Port 443 (HTTPS)—Upon inial deployment of the firewall template, leave HTTPS open so
Lambda can connect to Panorama.

When you secure port 443 you specify an IP address range from which you will allow
connecons, as well as the EIPs assigned to the NAT gateways. The number of NAT
gateways in your deployment depends on the number of availability zones you configure. To
find NAT gateway EIPs in AWS, go to VPC > NAT Gateways. Note the EIP informaon for
the security group for HTTPS.

Addionally, to allow Panorama to release the firewall license aer stack deleon, you must
allow traffic from the CIDR range of the region where you deployed the firewall template.
You can find the CIDR for your region at this link.

• Port 3978—Port 3978 must be able to receive traffic from any IP address.

Launch the Firewall Template
This workflow describes how to deploy the firewall template.

All VM-Series firewall interfaces must be assigned an IPv4 address when deployed in a
public cloud environment. IPv6 addresses are not supported.

STEP 1 | Modify the init-cfg.txt file and upload it to the /config folder.

Because you use Panorama to bootstrap the VM-Series firewalls, your init-cfg.txt file
should be modified as follows. No bootstrap.xml file is needed.

Ensure that you use the device group and template names you created above in the init-cfg.txt
file.

type=dhcp-client
ip-address=
default-gateway=
netmask=
ipv6-address=
ipv6-default-gateway=
hostname=
vm-auth-key=
panorama-server=
panorama-server-2=
tplname=
dgname=
dhcp-send-hostname=yes
dhcp-send-client-id=yes
dhcp-accept-server-hostname=yesdhcp-accept-server-domain=yes
plugin-op-commands=aws-gwlb-inspect:enable

Your init-cfg.txt file must include plugin-op-commands=aws-gwlb-inspect:enable.
This is required when integrang the VM-Series firewall with a GWLB.

You must add the device cerficate auto-registraon PIN to the init-cfg.txt file to automacally
install a device cerficate when your VM-Series firewall instance is deployed.
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STEP 2 | Add the license auth code in the /license folder of the bootstrap package.
1. Use a text editor to create a new text file named authcodes (no extension).
2. Add the authcode for your BYOL licenses to this file, and save. The authcode must

represent a bundle, and it must support the number of firewalls that might be required
for your deployment. If you use individual authcodes instead of a bundle, the firewall
only retrieves the license key for the first authcode in the file.

STEP 3 | Upload Lambda code for the firewall template (panw-aws.zip) and the Applicaon
template (app.zip) to an S3 bucket. You can use the same S3 bucket that you use for
bootstrapping.

If the Applicaon stack is managed by a different account than the firewall, use the Applicaon
account to create another s3 bucket in the same AWS region as the firewall template and copy
app.zip to that s3 bucket.

STEP 4 | Select the firewall template.
1. In the AWS Management Console, select CloudFormaon > Create Stack.
2. Select Upload the latest firewall template from the Git repository, to choose the firewall

template to deploy the resources that the template launches. Click Open and Next.
3. Specify the Stack name. The stack name allows you to uniquely idenfy all the resources

that are deployed using this template.

STEP 5 | Enter a descripve Name for your stack. The name must be 28 characters or less.

STEP 6 | Configure the parameters for the VPC.
1. Enter the number of availability zones and select the region from the availability zone

drop-down.
2. Look up the AMI ID for the VM-Series firewall and enter it. Make sure that the AMI ID

matches the AWS region, PAN-OS version and the BYOL or PAYG licensing opon you
opted to use. See Get the Amazon Machine Image IDs for more informaon.

3. Select the EC2 Key pair (from the drop-down) for launching the firewall. To log in to the
firewalls, you must provide the name of this key pair and the private key associated with
it.

4. Select Yes if you want to Enable Debug Log. Enabling the debug log generates more
verbose logs that help with troubleshoong issues with the deployment. These logs are
generated using the stack name and are saved in AWS CloudWatch.

By default, the template uses CPU ulizaon as the scaling parameter for the VM-Series
firewalls. Custom PAN-OS metrics are automacally published to the CloudWatch namespace
that matches the stack name you specified earlier.

STEP 7 | Specify the name of the Amazon S3 bucket(s).
1. Enter the name of the S3 bucket that contains the bootstrap package.

If the bootstrap bucket is not set up properly or if you enter the bucket name incorrectly,
the bootstrap process fails, and you cannot log in to the firewall. Health checks for the
load balancers also fail.

2. Enter the name of the S3 bucket that contains the panw-aws.zip file. As menoned
earlier you can use one S3 bucket for the Bootstrap and Lambda code.
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STEP 8 | Specify the keys for enabling API access to the firewall and Panorama.
1. Enter the key that the firewall must use to authencate API calls. The default key is

based on the sample file and you should only use it for tesng and evaluaon. For a
producon deployment, you must create a separate PAN-OS login just for the API call
and generate an associated key.

2. Enter the API Key to allow AWS Lambda to make API calls to Panorama. For a
producon deployment, you should create a separate login just for the API call and
generate an associated key.

STEP 9 | Add your AWS account number(s). You must provide the account number used to deploy any
VPC that is connected to your GWLB. Add these values as a comma-separated list. You can
add addional account numbers aer deploying the template.

To locate your account number, click your AWS username in the top right of the AWS console
and select My Security Credenals.

STEP 10 | Enter the transit gateway ID. The transit gateway ID is required to secure east-west and
outbound traffic. If you do not enter a transit gateway ID, the template assumes that only
inbound traffic should be inspected by firewalls integrated with the GWLB.

STEP 11 | Enter the CIDR for the security VPC.

STEP 12 | Review the template sengs and launch the template.
1. Select I acknowledge that this template might cause AWS CloudFormaon to create

IAM resources.
2. Click Create to launch the template. The CREATE_IN_PROGRESS event displays.
3. On successful deployment the status updates to CREATE_COMPLETE.

STEP 13 | Verify that the template has launched all required resources.

STEP 14 | Create rules allowing the NAT gateway IP address(es) on the security group where your
Panorama appliance is deployed. This is required to allow your firewalls to connect to
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Panorama. You can find the list of NAT gateway IP addresses in the CFT security stack
output.
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1. Access the AWS VPC console.
2. Select Security Groups on the navigaon pane.
3. Select the security where Panorama is deployed.
4. Select Acons > Edit Inbound Rules > Add rule.
5. Add rules allowing the NAT gateway IP addresses for Custom TCP Rule for port range

3978.
6. Click Save rules.

Launch the Applicaon Template
Complete the following procedure to launch the applicaon template.

STEP 1 | Create an S3 bucket from which you will launch the applicaon template.

• If this is a cross-account deployment, create a new bucket.
• If there is one account you can create a new bucket or use the S3 bucket you created earlier

(you can use one bucket for everything).

STEP 2 | Upload the app.zip file into the S3 bucket.

STEP 3 | Select the applicaon launch template you want you launch.
1. In the AWS Management Console, select CloudFormaon > CreateStack
2. Select Upload a template to Amazon S3, to choose the applicaon template to deploy

the resources that the template launches within the same VPC as the firewalls, or to a
different VPC. Click Open and Next.

3. Specify the Stack name. The stack name allows you to uniquely idenfy all the resources
that are deployed using this template.

STEP 4 | Select the Availability Zones (AZ) that your setup will span in Select list of AZ.

STEP 5 | Enter a descripve VPC Name.
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STEP 6 | Configure the parameters for Lambda.
1. Enter the S3 bucket name where app.zip is stored.
2. Enter the name of the zip file name.

STEP 7 | Select the EC2 instance type for the Ubuntu web server launched by this template.

STEP 8 | Enter your Amazon EC2 key pair.
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STEP 9 | Enter the name of the service configuraon (Service Name) for the GWLB endpoint in the
security VPC.
1. Select DynamoDB from the Services drop-down in the AWS console.
2. Select Tables and locate your security VPC table. The table name will be <stack name>-

gwlb-<region>. For example—c-deployment-gwlb-us-east-1.
3. Click the Items tab and copy the Service Name.
4. Paste the Service Name into the applicaon template configuraon parameters.
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STEP 10 | Enter the transit gateway ID. This is the same transit gateway you created before deploying
the firewall template.

STEP 11 | Review the template sengs and launch the template.

STEP 12 | Aer the applicaon has been deployed, you must add a route to the transit gateway route
table to enable east-west and outbound traffic inspecon.
1. Log in to the AWS VPC console.
2. Select Transit Gateway Route Tables and choose your transit gateway route table.

This route table is created by the template and is called <app-stack-name>-<region>-
PANWAppARt.

3. Select Routes and click Create stac route.
4. Enter 0.0.0.0/0 in the CIDR field.
5. From the Choose aachment drop-down, select the VM-Series firewall VPC aachment.
6. Click Create stac route.

STEP 13 | (Oponal) Create a bason host (also called a jump box) to access the web server created by
the applicaon template.
1. Create a public-facing subnet in your applicaon VPC.
2. Add a route to this subnet from your IP address to the internet gateway.
3. Create a new EC2 instance in the public subnet with a public IP address.
4. Create a security group for this EC2 instance that allows SSH from your IP address.
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High Availability for VM-Series Firewall on AWS
The VM-Series firewall on AWS supports acve/passive HA only; if it is deployed with Amazon
Elasc Load Balancing (ELB), it does not support HA (in this case ELB provides the failover
capabilies).

• Overview of HA on AWS
• IAM Roles for HA
• HA Links
• Heartbeat Polling and Hello Messages
• Device Priority and Preempon
• HA Timers
• Configure Acve/Passive HA on AWS Using a Secondary IP
• Configure Acve/Passive HA on AWS Using Interface Move
• Migrate Acve/Passive HA on AWS

Overview of HA on AWS
To ensure redundancy, you can deploy the VM-Series firewalls on AWS in an acve/passive
high availability (HA) configuraon. The acve peer connuously synchronizes its configuraon
and session informaon with the idencally configured passive peer. A heartbeat connecon
between the two devices ensures failover if the acve device goes down. There are two opons
for deploying the VM-Series firewall on AWS in HA—Secondary IP move and Dataplane Interface
(ENI) move.

To ensure that all traffic to your internet-facing applicaons passes through the firewall, you
have two opons. You can either configure the applicaon’s public IP address on the Untrust
interface (E1/2 in the illustraon above) of the VM-Series firewall, or you can configure AWS
ingress roung. The AWS ingress roung capability allows you to associate route tables with the
AWS Internet gateway and add route rules to redirect the applicaon traffic through the VM-
Series firewall. This redirecon ensures that all internet traffic passes through the firewall without
having to reconfigure the applicaon endpoints.

Secondary IP Move
When the acve peer goes down, the passive peer detects this failure and becomes acve.
Addionally, it triggers API calls to the AWS infrastructure to move the configured secondary IP
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addresses from the dataplane interfaces of the failed peer to itself. Addionally, AWS updates the
route tables to ensure that traffic is directed to the acve firewall instance. These two operaons
ensure that inbound and outbound traffic sessions are restored aer failover. This opon allows
you to take advantage of DPDK to improve the performance of your VM-Series firewall instances
and provides beer failover me than interface-move HA, while supporng all the features
provided by interface-move.

Secondary IP Move HA requires VM-Series plugin 2.0.1 or later.

Dataplane Interface Move
When the acve peer goes down, the passive peer detects the failure and becomes acve.
Addionally, it triggers API calls to the AWS infrastructure to move all the dataplane interfaces
(ENIs) from the failed peer to itself.

IAM Roles for HA
AWS requires that all API requests must be cryptographically signed using credenals issued by
them. In order to enable API permissions for the VM-Series firewalls that will be deployed as an
HA pair, you must create a policy and aach that policy to a role in the AWS Identy and Access
Management (IAM) service. The role must be aached to the VM-Series firewalls at launch. The
policy gives the IAM role permissions for iniang API acons required to move interfaces or
secondary IP addresses from the acve peer to the passive peer when failover is triggered.

For detailed instrucons on creang policy, refer to the AWS documentaon on Creang
Customer Managed Polices. For detailed instrucons on creang an IAM role, defining which
accounts or AWS services can assume the role, defining which API acons and resources the
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applicaon can use upon assuming the role, refer to the AWS documentaon on IAM Roles for
Amazon EC2.

The IAM policy, which is configured in the AWS console, must have permissions for the following
acons and resources (at a minimum):

The following IAM acons, permissions, and resources are required to enable HA. To
enable AWS Cloudwatch monitoring, see Enable CloudWatch Monitoring on the VM-
Series Firewall

for the required IAM acon.

IAM Acon,
Permission, or
Resource

Descripon Interface Move Secondary IP
Move

AachNetworkInterfaceFor permission to aach an ENI to
an instance.

DescribeNetworkInterfacesFor fetching the ENI parameters in
order to aach an interface to the
instance.

DetachNetworkInterfaceFor permission to detach the ENI
from the EC2 instance.

DescribeInstances For permission to obtain
informaon on the EC2 instances
in the VPC.

AssociateAddress For permissions to move public
IP addresses associated with the
primary IP addresses from the
passive to acve interfaces.

AssignPrivateIpAddressesFor permissions to assign
secondary IP addresses and
associated public IP addresses to
interfaces on the passive peer.

DescribeRouteTables For permission to retrieve all route
tables associated to the VM-Series
firewall instances.

ReplaceRoute For permissions to update the
AWS route table entries.

GetPolicyVersion For permission to retrieve AWS
policy version informaon.
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IAM Acon,
Permission, or
Resource

Descripon Interface Move Secondary IP
Move

GetPolicy For permission to retrieve AWS
policy informaon.

ListAachedRolePoliciesFor permission to retrieve the list
of all managed policies aached to
a specified IAM role.

ListRolePolicies For permission to retrieve a list
of the names of inline policies
embedded in a specified IAM role.

GetRolePolicy For permission to retrieve a
specified inline policy embedded
in a specified IAM role.

policy For permission to access the IAM
policy Amazon Resource Name
(ARN).

role For permission to access the IAM
roles ARN.

route-table For permission to access the route
table Amazon Resource Name
(ARN) to update it upon failover.

Wild card (*) In the ARN field use the * as a wild
card.

The following screenshot shows the access management sengs for the IAM role described
above for secondary-IP HA:
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The minimum permissions you need for interface move HA are:
{"Version": "2012-10-17","Statement": [{"Sid":
"VisualEditor0","Effect": "Allow","Action":
["ec2:AttachNetworkInterface","ec2:DetachNetworkInterface","ec2:DescribeInstances","ec2:DescribeNetworkInterfaces"],"Resource":
"*"}]}

The minimum permissions you need for secondary IP move HA are: {"Version":
"2012-10-17","Statement": [{"Sid": "VisualEditor0","Effect": "Allow","Acon":
["ec2:AachNetworkInterface","ec2:DetachNetworkInterface","ec2:DescribeInstances","ec2:DescribeNetworkInterfaces",
“ec2:AssignPrivateIpAddresses”,“ec2:AssociateAddress”,“ec2:DescribeRouteTables”],"Resource":
"*"}{"Sid": "VisualEditor1","Effect": "Allow","Acon": "ec2:ReplaceRoute", "Resource":
"arn:aws:ec2:*:*:route-table/*"}]}

HA Links
The devices in an HA pair use HA links to synchronize data and maintain state informaon. on
AWS, the VM-Series firewall uses the following ports:
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• Control Link—The HA1 link is used to exchange hellos, heartbeats, and HA state informaon,
and management plane sync for roung and User-ID informaon. This link is also used to
synchronize configuraon changes on either the acve or passive device with its peer.

The Management port is used for HA1. TCP port 28769 and 28260 for cleartext
communicaon; port 28 for encrypted communicaon (SSH over TCP).

• Data Link—The HA2 link is used to synchronize sessions, forwarding tables, IPSec security
associaons and ARP tables between devices in an HA pair. Data flow on the HA2 link is
always unidireconal (except for the HA2 keep-alive); it flows from the acve device to the
passive device.

Ethernet1/1 must be assigned as the HA2 link; this is required to deploy the VM-Series firewall
on AWS in HA. The HA data link can be configured to use either IP (protocol number 99) or
UDP (port 29281) as the transport.

The VM-Series firewall on AWS does not support backup links for HA1 or HA2.

Heartbeat Polling and Hello Messages
The firewalls use hello message and heartbeats to verify that the peer device is responsive and
operaonal. Hello messages are sent from one peer to the other at the configured Hello Interval to
verify the state of the device. The heartbeat is an ICMP ping to the HA peer over the control link,
and the peer responds to the ping to establish that the devices are connected and responsive. For
details on the HA mers that trigger a failover, see HA Timers. (The HA mers for the VM-Series
firewall are the same as that of the PA-5200 Series firewalls).

Device Priority and Preempon
The devices in an HA pair can be assigned a device priority value to indicate a preference for which
device should assume the acve role and manage traffic upon failover. If you need to use a specific
device in the HA pair for acvely securing traffic, you must enable the preempve behavior on
both the firewalls and assign a device priority value for each device. The device with the lower
numerical value, and therefore higher priority, is designated as acve and manages all traffic on
the network. The other device is in a passive state, and synchronizes configuraon and state
informaon with the acve device so that it is ready to transion to an acve state should a
failure occur.

By default, preempon is disabled on the firewalls and must be enabled on both devices. When
enabled, the preempve behavior allows the firewall with the higher priority (lower numerical
value) to resume as acve aer it recovers from a failure. When preempon occurs, the event is
logged in the system logs.

Preempon is not recommended for HA in the VM-Series firewall on AWS.

HA Timers
High availability (HA) mers are used to detect a firewall failure and trigger a failover. To reduce
the complexity in configuring HA mers, you can select from three profiles: Recommended,
Aggressive, and Advanced. These profiles auto-populate the opmum HA mer values for the
specific firewall plaorm to enable a speedier HA deployment.
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Use the Recommended profile for typical failover mer sengs and the Aggressive profile for
faster failover mer sengs. The Advanced profile allows you to customize the mer values to
suit your network requirements.

HA Timer on the VM-Series
on AWS

Default values for Recommended/Aggressive profiles

Promoon hold me 2000/500 ms

Hello interval 8000/8000 ms

Heartbeat interval 2000/1000 ms

Max number of flaps 3/3

Preempon hold me 1/1 min

Monitor fail hold up me 0/0 ms

Addional master hold up
me

500/500 ms

Configure Acve/Passive HA on AWS Using a Secondary IP
Complete the following procedure to deploy new VM-Series firewalls as an HA pair with
secondary IP addresses.

All VM-Series firewall interfaces must be assigned an IPv4 address when deployed in a
public cloud environment. IPv6 addresses are not supported.
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STEP 1 | Before you deploy the VM-Series firewalls for you HA pair, ensure the following:

• Refer to the VPC Planning Worksheet to ensure that your VPC is prepared for the VM-
Series firewall.

• Secondary IP Move HA requires VM-Series plugin 2.0.1 or later.
• Deploy both HA peers in the same AWS availability zone.

Starng with VM-Series plugin 2.0.3, you can deploy the HA peers in different availability
zones. However, during an HA failover event, the route tables are updated but the
secondary IP is not moved. This type of deployment is not recommended.

• Create an IAM role and assign the role to the VM-Series firewalls when you deploy the
instances.

• The acve and passive firewalls must have at least four interfaces each—a management
interface, an HA2 interface, an untrust interface, and a trust interface. Addionally, the trust
and untrust interfaces on the acve firewall must assigned a secondary IP address.

The management interface must be used as the HA1 interface.
• Verify that the network and security components are defined suitably.

• Enable communicaon to the internet. The default VPC includes an internet gateway,
and if you install the VM-Series firewall in the default subnet it has access to the internet.

• Create subnets. Subnets are segments of the IP address range assigned to the VPC in
which you can launch the EC2 instances. The VM-Series firewall must belong to the
public subnet so that it can be configured to access the internet.

• Create a data security group that includes the firewall data interfaces. Addionally,
configure the security to allow all traffic (0.0.0.0/0), so security is enforced by the
firewalls. This is required to maintain exisng sessions during failover.

• Add routes to the route table for a private subnet to ensure that traffic can be routed
across subnets and security groups in the VPC, as applicable.

• If you are bootstrapping the firewall, create the necessary S3 bucket containing the required
bootstrap files.
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STEP 2 | Deploy the VM-Series Firewall on AWS.
1. If your VM-Series firewalls do not have the VM-Series plugin 2.0.1 or later installed,

upgrade the plugin before connuing.
2. Configure ethernet 1/1 as the HA2 interface on each HA peer.

1. Open the Amazon EC2 console.
2. Select Network Interface and then choose then select your network interface.
3. Select Acons > Manage IP Addresses.
4. Leave the field blank to allow AWS to assign an IP address dynamically or enter an IP

address within the subnet range for the VM-Series firewall.
5. Click Yes and Update.
6. Select Acons > Change Source/Dest. Check and select Disable.
7. Repeat this process on the second (to be passive) HA peer.

3. Add a secondary IP address to your dataplane interfaces on the first (to be acve) HA
peer.

1. Select Network Interface and then choose then select your network interface.
2. Select Acons > Manage IP Addresses > IPv4 Addresses > Assign new IP.
3. Leave the field blank to allow AWS to assign an IP address dynamically or enter an IP

address within the subnet range for the VM-Series firewall.
4. Click Yes and Update.

4. Associate a secondary Elasc (public) IP address with the untrust interface of the acve
peer.

1. Select Elasc IPs and then choose then select the Elasc IP address to associate.
2. Select Acons > Associate Elasc IP.
3. Under Resource Type, select Network Interface.
4. Chose the network interface with which to associate the Elasc IP address.
5. Click Associate.

5. For outbound traffic inspecon, add an entry to the subnet route table that sets the next
hop as the firewall trust interface.

1. Select VPC > Route Tables.
2. Choose your subnet route table.
3. Select Acons > Edit routes > Add route.
4. Enter the Desnaon CIDR Block or IP address.
5. For Target, enter the network interface of the firewall trust interface.
6. Click Save routes.

6. To use AWS Ingress Roung, create a route table and associate the internet gateway to
it. Then add an entry with the next hop set as the acve firewall untrust interface.

1. Select Route Tables > Create route table.
2. (Oponal) Enter a descripve Name tag for your route table.
3. Click Create.
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4. Click your route table and select Acons > Edit edge associaons.
5. Select Internet gateways and choose your VPC internet gateway.
6. Click Save.
7. Click your route table and select Acons > Edit routes.
8. For the Target, select Network Interface and choose the untrust interface of the

acve firewall.
9. Click Save routes.

STEP 3 | Configure the interfaces on the firewall. You must configure the HA2 data link and at least
two Layer 3 interfaces for your untrust and trust interfaces. Complete this workflow on the
first HA peer and then repeat the steps on the second HA peer.
1. Log in to the firewall web interface.
2. Select Network > Interfaces > Ethernet and click on your untrust interface. In this

example, the HA2 interface is 1/1, the trust interface is ethernet 1/2, and the untrust
interface is ethernet 1/3.

3. Click the link for ethernet 1/1 and configure as follows:

• Interface Type: HA
4. Click the link for ethernet 1/2 and configure as follows:

• Interface Type: Layer3
• On the Config tab, assign the interface to the default router.
• On the Config tab, expand the Security Zone drop-down and select New Zone.

Define a new zone, for example trust-zone, and then click OK.
• On the IPv4 tab, select DHCP Client.
• Check Enable.
• On the untrust interface, check Automacally create default route poinng to default

gateway provided by server. This opon tells the firewall to create a stac route to a
default gateway.

• Repeat these steps for ethernet 1/3.
5. Repeat the above steps on the passive peer.
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STEP 4 | Enable HA.
1. Select Device > High Availability > General.
2. Edit the Setup sengs.
3. Enter the private IP address of the passive peer in the Peer HA1 IP address field.
4. Click OK.

5. Edit the Elecon Sengs to specify a parcular firewall to be the acve peer. Enter a
lower numerical Device Priority value on the acve firewall. If both firewalls have the
same Device Priority value, the firewall with the lowest MAC value on the HA1 control
becomes the acve firewall.

Enabling preempon is not recommended.

6. Click OK.
7. Commit your changes.
8. Repeat the above steps on the passive peer.

STEP 5 | Set up the Control Link (HA1) to use the management port.
1. Select Device > High Availability > General, and edit the Control Link (HA1) secon.

2. (Oponal) Select Encrypon Enabled, for secure HA communicaon between the peers.
To enable encrypon, you must export the HA key from a device and import it into the
peer device.

1. Select Device > Cerficate Management > Cerficates.
2. Select Export HA key. Save the HA key to a network locaon that the peer device can

access.
3. On the peer device, navigate to Device > Cerficate Management > Cerficates, and

select Import HA key to browse to the locaon that you saved the key and import it
in to the peer device.
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STEP 6 | Set up the Data Link (HA2) to use ethernet1/1.
1. Select Device > High Availability > General, edit the Data Link (HA2) secon.
2. Select Port ethernet1/1.
3. Enter the IP address for ethernet1/1. This IP address must be the same that assigned to

the ENI on the EC2 Dashboard.
4. Enter the Netmask.
5. Enter a Gateway IP address if the HA1 interfaces are on separate subnets.
6. Select IP or UDP for Transport. Use IP if you need Layer 3 transport (IP protocol number

99). Use UDP if you want the firewall to calculate the checksum on the enre packet
rather than just the header, as in the IP opon (UDP port 29281).

7. (Oponal) Modify the Threshold for HA2 Keep-alive packets. By default, HA2 Keep-alive
is enabled for monitoring the HA2 data link between the peers. If a failure occurs and
this threshold (default is 10000 ms) is exceeded, the defined acon will occur. A crical
system log message is generated when an HA2 keep-alive failure occurs.

You can configure the HA2 keep-alive opon on both devices, or just one device
in the HA pair. If you enable this opon on one device, only that device will send
the keep-alive messages.

STEP 7 | Aer your finish configuring HA on both firewalls, verify that the firewalls are paired in
acve/passive HA.
1. Access the Dashboard on both firewalls and view the High Availability widget.
2. On the acve HA peer, click Sync to peer.
3. Confirm that the firewalls are paired and synced.

• On the passive firewall: the state of the local firewall should display Passive and the
Running Config should show as Synchronized.

• On the acve firewall: the state of the local firewall should display Acve and the
Running Config should show as Synchronized.

4. From the firewall command line interface, execute the following commands:

• To verify failover readiness:

show plugins vm_series aws ha state
• To show secondary IP mapping:

show plugins vm_series aws ha ips
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Configure Acve/Passive HA on AWS Using Interface Move
Complete the following procedure to configure acve-passive HA using interface move mode.

All VM-Series firewall interfaces must be assigned an IPv4 address when deployed in a
public cloud environment. IPv6 addresses are not supported.

STEP 1 | Make sure that you have followed the prerequisites.

For deploying a pair of VM-Series firewalls in HA in the AWS cloud, you must ensure the
following:

• Select the IAM role you created when launching the VM-Series firewall on an EC2 instance;
you cannot assign the role to an instance that is already running. See IAM Roles for HA.

For detailed instrucons on creang an IAM role, defining which accounts or AWS services
can assume the role, and defining which API acons and resources the applicaon can use
upon assuming the role, refer to the AWS documentaon.

• DPDK is not supported on the VM-Series firewall on AWS in an interface-move HA
deployment. If your have VM-Series plugin 2.0.1 or later on your firewalls, you must disable
DPDK.

Disabling DPDK requires the firewall to reboot. If you are using bootstrapping to deploy
the VM-Series firewall, you can avoid reboong the firewall by disabling DPDK in the ini-
cfg.txt file by using op-cmd-dpdk-pkt-io=off. See Bootstrap the VM-Series Firewall on
AWS for more informaon.

• The acve firewall in the HA pair must have at a minimum three ENIs: two dataplane
interfaces and one management interface.

The passive firewall in the HA pair, must have one ENI for management, and one ENI that
funcons as dataplane interface; you will configure the dataplane interface as an HA2
interface.

Do not aach addional dataplane interfaces to the passive firewall in the HA pair.
On failover, the dataplane interfaces from the previously acve firewall are moved —
detached and then aached—to the now acve (previously passive) firewall.

• The HA peers must be deployed in the same AWS availability zone.

STEP 2 | Launch the VM-Series Firewall on AWS.

STEP 3 | (VM-Series plugin 2.0.1 or later) Disable DPDK on the acve and passive firewalls. DPDK
is enabled by default and interface-move HA mode does not support DPDK, so you must
disable it; enabling Packet MMAP.
1. Log in to the passive firewall CLI.
2. Disable DPDK using the following command. Execung this command restarts the

firewall.

admin@PA-VM> set system setting dpdk-pkt-io off
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STEP 4 | Enable HA.
1. Select Device > High Availability > General, and edit the Setup secon.
2. Select Enable HA.

STEP 5 | Configure ethernet 1/1 as an HA interface. This interface must be used for HA2
communicaon.
1. Select Network > Interfaces.
2. Confirm that the link state is up on ethernet1/1.
3. Click the link for ethernet1/1 and set the Interface Type to HA.

STEP 6 | Set up the Control Link (HA1) to use the management port.
1. Select Device > High Availability > General, and edit the Control Link (HA1) secon.

2. (Oponal) Select Encrypon Enabled, for secure HA communicaon between the peers.
To enable encrypon, you must export the HA key from a device and import it into the
peer device.

1. Select Device > Cerficate Management > Cerficates.
2. Select Export HA key. Save the HA key to a network locaon that the peer device can

access.
3. On the peer device, navigate to Device > Cerficate Management > Cerficates, and

select Import HA key to browse to the locaon that you saved the key and import it
in to the peer device.
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STEP 7 | Set up the Data Link (HA2) to use ethernet1/1.
1. Select Device > High Availability > General, edit the Data Link (HA2) secon.
2. Select Port ethernet1/1.
3. Enter the IP address for ethernet1/1. This IP address must be the same that assigned to

the ENI on the EC2 Dashboard.
4. Enter the Netmask.
5. Enter a Gateway IP address if the HA1 interfaces are on separate subnets.
6. Select IP or UDP for Transport. Use IP if you need Layer 3 transport (IP protocol number

99). Use UDP if you want the firewall to calculate the checksum on the enre packet
rather than just the header, as in the IP opon (UDP port 29281).

7. (Oponal) Modify the Threshold for HA2 Keep-alive packets. By default, HA2 Keep-alive
is enabled for monitoring the HA2 data link between the peers. If a failure occurs and
this threshold (default is 10000 ms) is exceeded, the defined acon will occur. A crical
system log message is generated when an HA2 keep-alive failure occurs.

You can configure the HA2 keep-alive opon on both devices, or just one device
in the HA pair. If you enable this opon on one device, only that device will send
the keep-alive messages.

STEP 8 | Set the device priority and enable preempon.

Use this seng if you want to make sure that a specific device is the preferred acve device.
For informaon, see Device Priority and Preempon.

1. Select Device > High Availability > General and edit the Elecon Sengs secon.
2. Set the numerical value in Device Priority. Make sure to set a lower numerical value on

the device that you want to assign a higher priority to.

If both firewalls have the same device priority value, the firewall with the lowest
MAC address on the HA1 control link will become the acve device.

3. Select Preempve.

You must enable preempve on both the acve and the passive device.
4. Modify the failover mers. By default, the HA mer profile is set to the Recommended

profile and is suited for most HA deployments.
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STEP 9 | (Oponal) Modify the wait me before a failover is triggered.
1. Select Device > High Availability > General and edit the Acve/Passive Sengs.
2. Modify the Monitor fail hold up me to a value between 1-60 minutes; default is 1

minute. This is the me interval during which the firewall will remain acve following a
link failure. Use this seng to avoid an HA failover triggered by the occasional flapping
of neighboring devices.

STEP 10 | Configure the IP address of the HA peer.
1. Select Device > High Availability > General, and edit the Setup secon.
2. Enter the IP address of the HA1 port on the peer. This is the IP address assigned to the

management interface (ethernet 0/0), which is also the HA1 link on the other firewall.
3. Set the Group ID number between 1 and 63. Although this value is not used on the VM-

Series firewall on AWS, but cannot leave the field blank.

STEP 11 | Configure the other peer.

Repeat steps 3 to 9 on the HA peer.

STEP 12 | Aer you finish configuring both devices, verify that the devices are paired in acve/passive
HA.
1. Access the Dashboard on both devices, and view the High Availability widget.
2. On the acve device, click the Sync to peer link.
3. Confirm that the devices are paired and synced, as shown below:

• On the passive device: The state of the local device should display passive and the
configuraon is synchronized.

• On the acve device: The state of the local device should display acve and the
configuraon is synchronized.

STEP 13 | Verify that failover occurs properly.
1. Verify the HA mode.

show plugins vm_series aws ha failover-mode
2. Verify that the packet IO mode is set to packet MMAP.

show system setting dpdk-pkt-io
3. Shut down the acve HA peer.

1. On the EC2 Dashboard, select Instances.
2. From the list, select the VM-Series firewall and click Acons > Stop.

4. Check that the passive peer assumes the role of the acve peer and that the dataplane
interfaces have moved over to the now acve HA peer.

Migrate Acve/Passive HA on AWS
Both high availability modes are supported, allowing you to migrate between each mode if your
deployment requires it. Because interface-move mode does not support DPDK, you must disable
it on the VM-Series firewall before compleng the migraon. Disabling DPDK requires you to
reboot the VM-Series firewall, which will impact any traffic sessions on the acve firewall.
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• Migrate Acve/Passive HA on AWS to Secondary IP Mode
• Migrate Acve/Passive HA on AWS to Interface Move Mode

Migrate Acve/Passive HA on AWS to Secondary IP Mode
Complete the following procedure to migrate your exisng VM-Series firewall HA pair from
interface-move HA to secondary-IP HA.

Secondary IP Move HA requires VM-Series plugin 2.0.1 or later.

STEP 1 | Upgrade the VM-Series Plugin on the passive HA peer and then the acve peer.

STEP 2 | Create secondary IP address for all data interfaces on the acve peer.
1. Log in to the AWS EC2 console.
2. Select Network Interface and then choose then select your network interface.
3. Select Acons > Manage IP Addresses > IPv4 Addresses > Assign new IP.
4. Leave the field blank to allow AWS to assign an IP address dynamically or enter an IP

address within the subnet range for the VM-Series firewall.
5. Click Yes and Update.

STEP 3 | Associate a secondary Elasc (public) IP address with the untrust interface of the acve peer.
1. Log in to the AWS EC2 console.
2. Select Elasc IPs and then choose then select the Elasc IP address to associate.
3. Select Acons > Associate Elasc IP.
4. Under Resource Type, select Network Interface.
5. Chose the network interface with which to associate the Elasc IP address.
6. Click Associate.

STEP 4 | Create a route table poinng the subnet containing the trust interface.
1. Select Route Tables > Create route table.
2. (Oponal) Enter a descripve Name tag for your route table.
3. Select your VPC.
4. Click Create.
5. Select Subnet Associaons > Edit subnet associaons.
6. Select the Associate checkbox for the subnet containing the trust interface.
7. Click Save.
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STEP 5 | Update the IAM roles with addional acons and permissions required to migrate to
secondary IP move HA.

IAM Acon, Permission, or Resource Descripon

AssociateAddress For permissions to move public IP addresses
associated with the primary IP addresses from the
passive to acve interfaces.

AssignPrivateIpAddresses For permissions to move secondary IP addresses and
associated public IP addresses from the passive to
acve interfaces.

UnassignPrivateIpAddress For permissions to unassign secondary IP addresses
and associated public IP addresses from interfaces on
the acve peer.

DescribeRouteTables For permission to retrieve all route tables associated
to the VM-Series firewall instances.

ReplaceRoute For permission to update the AWS route table
entries.

GetPolicyVersion For permission to retrieve AWS policy version
informaon.

GetPolicy For permission to retrieve AWS policy informaon.

ListAachedRolePolicies For permission to retrieve the list of all managed
policies aached to a specified IAM role.

ListRolePolicies For permission to retrieve a list of the names of inline
policies embedded in a specified IAM role.

GetRolePolicy For permission to retrieve a specified inline policy
embedded in a specified IAM role.

policy For permission to access the IAM policy Amazon
Resource Name (ARN).

role For permission to access the IAM roles ARN.

route-table For permission to access the route table ARN.

Wild card (*) In the ARN field use the * as a wild card.
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STEP 6 | Create new interfaces (ENIs) on the passive firewall in the same subnet as the acve firewall
data interfaces.

Do not assign secondary IP addresses to these new interfaces.

1. Open the Amazon EC2 console.
2. Select Network Interfaces > Create Network Interfaces.
3. Enter a descripve Name for your new interface.
4. Under Subnet, select the subnet of the untrust interface of the acve firewall.
5. Under Private IP, leave the field blank to allow AWS to assign an IP address dynamically

or enter an IP address within the subnet range for the untrust interface of the acve
firewall.

6. Under Security groups, select one or more security groups.
7. Select Yes and Create.
8. Select Acons > Change Source/Dest. Check and select Disable.
9. Repeat these steps for the subnet of the trust interface of the acve firewall.

STEP 7 | Aach the new ENIs to the passive firewall instance. You must aach these ENIs to the
passive firewall in the correct order because the secondary IP HA method is based on the
network interface index assigned by AWS. For example, if eth1/2 on the acve firewall is
part of subnet A and eth1/3 is part of subnet B, then you must aach the interface that is
part of subnet A and the interface that is part of subnet B. In this example, AWS has assigned
an index value of 2 to eth1/2 and a value of 3 to eth1/3. This indexing must be maintained
for the failover to occur successfully.
1. To aach the ENIs created above, select the untrust interface your created and click

Aach.
2. Select the Instance ID of the of the passive firewall and click Aach.
3. Repeat these steps for the trust interface.

STEP 8 | Log into the passive and set the interfaces to get their IP addresses through DHCP.
1. Log in to the passive VM-Series firewall web interface.
2. Select Network > Interfaces.
3. Click on the first data interface.
4. Select IPv4.
5. Select DHCP Client.
6. On the untrust interface only, select Automacally create default route poinng to

default gateway provided by server.
7. Click OK.
8. Repeat this process for each data interface.
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STEP 9 | If you have configure any NAT policies on the VM-Series firewall that reference the private
IP addresses of the data interfaces, those policies must be updated to reference the newly
assigned secondary IP addresses instead.
1. Access the web interface of the acve VM-Series firewall.
2. Select Policies > NAT.
3. Click on the NAT policy rule to be modified and then Translated Packet.
4. Under Translated Address, click Add and enter the secondary IP address created in AWS.
5. Delete the primary IP address.
6. Click OK.
7. Repeat these steps as necessary.
8. Commit your changes.

STEP 10 | Enable secondary IP HA failover mode.
1. Access the VM-Series firewall CLI on the acve peer.
2. Execute the following command.

request plugins vm_series aws ha failover-mode secondary-ip
3. Commit your changes.
4. Comfirm your HA mode by execung the following command.

show plugins vm_series aws ha failover-mode
5. Repeat this command on the passive peer.

STEP 11 | Aer your finish configuring HA on both firewalls, verify that the firewalls are paired in
acve/passive HA.
1. Access the Dashboard on both firewalls and view the High Availability widget.
2. On the acve HA peer, click Sync to peer.
3. Confirm that the firewalls are paired and synced.

• On the passive firewall: the state of the local firewall should display Passive and the
Running Config should show as Synchronized.

• On the acve firewall: the state of the local firewall should display Acve and the
Running Config should show as Synchronized.

4. From the firewall command line interface, execute the following commands:

• To verify failover readiness:

show plugins vm_series aws ha state
• To show secondary IP mapping :

show plugins vm_series aws ha ips

Migrate Acve/Passive HA on AWS to Interface Move Mode
Complete the following procedure to migrate your exisng VM-Series firewall HA pair from
secondary-IP HA to interface-move HA.
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STEP 1 | Disable DPDK support on the passive HA peer. Interface-move HA mode does not support
DPDK, so you must disable it; enabling Packet MMAP.
1. Log in to the passive firewall CLI.
2. Disable DPDK using the following command. Execung this command restarts the

firewall.

admin@PA-VM> set system setting dpdk-pkt-io off

STEP 2 | Disable DPDK support on the acve HA peer.
1. Log in to the acve firewall CLI.
2. Disable DPDK using the following command. Execung this command restarts the

firewall.

admin@PA-VM> set system setting dpdk-pkt-io off

Restarng the firewall will impact traffic.

STEP 3 | Change the HA mode on the acve peer from secondary-IP mode to interface-move mode.
1. Access the VM-Series firewall CLI on the acve peer.
2. Execute the following command.

request plugins vm_series aws ha failover-mode interface-move
3. Commit your changes.
4. Comfirm your HA mode by execung the following command.

show plugins vm_series aws ha failover-mode
5. Repeat this command on the passive peer.

STEP 4 | Delete the data interfaces from the passive firewall instance.
1. Log in to the AWS EC2 console.
2. Select Network Interfaces.
3. Select a data interface on the passive firewall instance and click Delete.
4. In the Delete Network Interface window, click Yes, Delete.
5. Repeat this process for each data interface on the passive firewall instance.
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Use Case: Secure the EC2 Instances in the AWS Cloud
In this example, the VPC is deployed in the 10.0.0.0/16 network with two /24 subnets:
10.0.0.0/24 and 10.0.1.0/24. The VM-Series firewall will be launched in the 10.0.0.0/24 subnet to
which the internet gateway is aached. The 10.0.1.0/24 subnet is a private subnet that will host
the EC2 instances that need to be secured by the VM-Series firewall; any server on this private
subnet uses NAT for a routable IP address (which is an Elasc IP address) to access the internet.
Use the Planning Worksheet for the VM-Series in the AWS VPC to plan the design within your
VPC; recording the subnet ranges, network interfaces and the associated IP addresses for the EC2
instances, and security groups, will make the setup process easier and more efficient.

The following image depicts the logical flow of traffic to/from the web server to the internet.
Traffic to/from the web server is sent to the data interface of the VM-Series firewall that is
aached to the private subnet. The firewall applies policy and processes incoming/outgoing traffic
from/to the internet gateway of the VPC. The image also shows the security groups to which the
data interfaces are aached.
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STEP 1 | Create a new VPC with a public subnet (or select an exisng VPC).
1. Log in to the AWS console and select the VPC Dashboard.
2. Verify that you’ve selected the correct geographic area (AWS region). The VPC will be

deployed in the currently selected region.
3. Select Start VPC Wizard, and select VPC with a Single Public Subnet.

In this example, the IP CIDR block for the VPC is 10.0.0.0/16, the VPC name is Cloud
DC, the public subnet is 10.0.0.0/24, and the subnet name is Cloud DC Public subnet.
You will create a private subnet aer creang the VPC.

4. Click Create VPC.
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STEP 2 | Create a private subnet.

Select Subnets, and click Create a Subnet. Fill in the informaon.

In this example, the Name tag for the subnet is Web/DB Server Subnet, it is created in the
Cloud Datacenter VPC and is assigned a CIDR block of 10.0.1.0/24.

STEP 3 | Create a new route table for each subnet.

Although a main route table is automacally created on the VPC, we recommend
creang new route tables instead of modifying the default route table.

To direct outbound traffic from each subnet, you will add routes to the route table associated
with each subnet, later in this workflow.

1. Select Route Tables > Create Route Table.
2. Add a Name, for example CloudDC-public-subnet-RT, select the VPC you created in

Step 1, and click Yes, Create.
3. Select the route table, click Subnet Associaons and select the public subnet.

4. Select Create Route Table.
5. Add a Name, for example CloudDC-private-subnet-RT, select the VPC you created in

Step 1, and click Yes, Create.
6. Select the route table, click Subnet Associaons and select the private subnet.
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STEP 4 | Create Security Groups to restrict inbound/outbound internet access to the EC2 instances in
the VPC.

By default, AWS disallows communicaon between interfaces that do not belong to the same
security group.

Select Security Groups and click the Create Security Group buon. In this example, we create
three security groups with the following rules for inbound access:

• CloudDC-Management that specifies the protocols and source IP addresses that can
connect to the management interface of the VM-Series firewall. At a minimum you need
SSH, and HTTPS. In this example, we enable SSH, ICMP, HTTP, and HTTPS on the network
interfaces that are aached to this security group.

The management interface (eth 0/0) of the VM-Series firewall will be assigned to CloudDC-
management-sg.

• Public-Server-CloudDC that specifies the source IP addresses that can connect over HTTP,
FTP, SSH within the VPC. This group allows traffic from the external network to the firewall.

The dataplane interface eth1/1 of the VM-Series firewall will be assigned to Public-Server-
CloudDC.

• Private-Server-CloudDC that has very limited access. It only allows other EC2 instances on
the same subnet to communicate with each other, and with the VM-Series firewall.

The dataplane interface eth1/2 of the VM-Series firewall and the applicaon in the private
subnet will be aached to this security group.

The following screenshot shows the security groups for this use case.

STEP 5 | Deploy the VM-Series firewall.

Only the primary network interface that will serve as the management interface will
be aached and configured for the firewall during the inial launch. The network
interfaces required for handling data traffic will be added in Step 6.

See Step 3 in Launch the VM-Series Firewall on AWS.
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STEP 6 | Create and aach virtual network interface(s), referred to as Elasc Network Interfaces
(ENIs), to the VM-Series firewall. These ENIs are used for handling data traffic to/from the
firewall.
1. On the EC2 Dashboard, select Network Interfaces, and click Create Network Interface.
2. Enter a descripve name for the interface.
3. Select the subnet. Use the subnet ID to make sure that you have selected the correct

subnet. You can only aach an ENI to an instance in the same subnet.
4. Enter the Private IP address that you want to assign to the interface or select Auto-

assign to automacally assign an IP address within the available IP addresses in the
selected subnet.

5. Select the Security group to control access to the network interface.
6. Click Yes, Create.

In this example, we create two interfaces with the following configuraon:

• For Eth1/1 (VM-Series-Untrust)

• Subnet: 10.0.0.0/24
• Private IP:10.0.0.10
• Security group: Public-Server-CloudDC

• For Eth1/2 (VM-Series-Trust)

• Subnet: 10.0.1.0/24
• Private IP: 10.0.1.10
• Security group: Private-Server-CloudDC

7. To aach the ENI to the VM-Series firewall, select the interface you just created, and
click Aach.

8. Select the Instance ID of the VM-Series firewall, and click Aach.
9. Repeat steps 7 and 8 to aach the other network interface.
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STEP 7 | Create an Elasc IP address and aach it to the firewall dataplane network interface that
requires direct internet access.

In this example, VM-Series_Untrust is assigned an EIP. The EIP associated with the interface is
the publicly accessible IP address for the web server in the private subnet.

1. Select Elasc IPs and click Allocate New Address.
2. Select EC2-VPC and click Yes, Allocate.
3. Select the newly allocated EIP and click Associate Address.
4. Select the Network Interface and the Private IP address associated with the interface

and click Yes, Associate.

In this example, the configuraon is:

STEP 8 | Disable Source/Desnaon check on each network interface aached to the VM-Series
firewall. Disabling this aribute allows the interface to handle network traffic that is not
desned to its IP address.
1. Select the network interface in the Network Interfaces tab.
2. In the Acon drop-down, select Change Source/Dest. Check.
3. Click Disabled and Save your changes.
4. Repeat steps 1-3 for addional network interfaces, firewall-1/2 in this example.
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STEP 9 | In the route table associated with the public subnet (from step 3), add a default route to the
internet gateway for the VPC.
1. From the VPC Dashboard, select Route Tables and find the route table associated with

the public subnet.
2. Select the route table, select Routes and click Edit.
3. Add a route to forward packets from this subnet to the internet gateway. In this example,

0.0.0.0.0 indicates that all traffic from/to this subnet will use the internet gateway
aached to the VPC.

STEP 10 | In the route table associated with the private subnet, add a default route to send traffic to
the VM-Series firewall.

Adding this route enables the forwarding of traffic from the EC2 instances in this private
subnet to the VM-Series firewall.

1. From the VPC Dashboard, select Route Tables and find the route table associated with
the private subnet.

2. Select the route table, select Routes and click Edit.
3. Add a route to forward packets from this subnet to the VM-Series firewall network

interface that resides on the same subnet. In this example, 0.0.0.0/0 indicates that all
traffic from/to this subnet will use eni-abf355f2 (ethernet 1/2, which is CloudDC-VM-
Series-Trust) on the VM-Series firewall.

For each web or database server deployed on an EC2 instance in the private
subnet, you must define a default route to the IP address of the VM-Series
firewall so that the firewall is the default gateway for the server.

Perform steps 11 through 16 on the VM-Series firewall.
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STEP 11 | Configure a new administrave password for the firewall.

An SSH tool such as PuTTY is required to access the CLI on the firewall and change the
default administrave password. You cannot access the web interface unl you SSH
and change the default password.

1. Use the public IP address you configured on the firewall, to SSH into the Command Line
Interface (CLI) of the VM-Series firewall.

You will need the private key that you used or created in Launch the VM-Series Firewall
on AWS, steps 3-12 to access the CLI.

2. Enter the following command to log in to the firewall:
ssh-i <private_key_name> admin@<public-ip_address>

3. Configure a new password, using the following command and follow the onscreen
prompts:
configure
set mgt-config users admin password
commit

4. Terminate the SSH session.

STEP 12 | Access the web interface of the VM-Series firewall.

Open a web browser and enter the EIP of the management interface. For example:
hps://54.183.85.163

STEP 13 | Acvate the licenses on the VM-Series firewall. This step is only required for the BYOL
license; the usage-based licenses are automacally acvated.

See Acvate the License.
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STEP 14 | On the VM-Series firewall, configure the dataplane network interfaces on the firewall as
Layer 3 interfaces.
1. Select Network > Interfaces > Ethernet.
2. Click the link for ethernet 1/1 and configure as follows:

• Interface Type: Layer3
• Select the Config tab, assign the interface to the default router.
• On the Config tab, expand the Security Zone drop-down and select New Zone. Define

a new zone, for example untrust, and then click OK.
• Select IPv4, select DHCP Client; the private IP address that you assigned to the

network interface in the AWS management console will be acquired automacally.
• On the Advanced > Other Info tab, expand the Management Profile drop-down, and

select New Management Profile.
• Enter a Name for the profile, such as allow_ping, and select Ping from the Permied

Services list, then click OK.
• To save the interface configuraon, click OK.

3. Click the link for ethernet 1/2 and configure as follows:

• Interface Type: Layer3
• Select the Config tab, assign the interface to the default router.
• On the Config tab, expand the Security Zone drop-down and select New Zone.

Define a new zone, for example trust, and then click OK.
• Select IPv4, select DHCP Client.
• On the IPv4 tab, clear the Automacally create default route to default gateway

provided by server check box. For an interface that is aached to the private subnet
in the VPC, disabling this opon ensures that traffic handled by this interface does not
flow directly to the IGW on the VPC.

• On the Advanced > Other Info, expand the Management Profile drop-down, and
select the allow_ping profile you created earlier.

• Click OK to save the interface configuraon.
4. Click Commit to save the changes. Verify that the Link state for the interface is up .  If

the link state is not up, reboot the firewall.
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STEP 15 | On the VM-Series firewall, create Desnaon NAT and Source NAT rules to allow inbound/
outbound traffic to/from the applicaons deployed within the VPC.
1. Select Policies > NAT.
2. Create a Desnaon NAT rule that steers traffic from the firewall to the web server.

1. Click Add, and enter a name for the rule. For example, NAT2WebServer.
2. In the Original Packet tab, make the following selecons:

• Source Zone: untrust (where the traffic originates)
• Desnaon Zone: untrust (the zone for the firewall dataplane interface with which

the EIP for the web server is associated.)
• Source Address: Any
• Desnaon Address: 10.0.0.10
• In the Translated Packet tab, select the Desnaon Address Translaon check box

and set the Translated Address: to 10.0.1.62, which is the private IP address of the
web server.

3. Click OK.

3. Create a Source NAT rule to allow outbound traffic from the web server to the internet.

1. Click Add, and enter a name for the rule. For example, NAT2External.
2. In the Original Packet tab, make the following selecons:

• Source Zone: trust (where the traffic originates)
• Desnaon Zone: untrust (the zone for the firewall dataplane interface with which

the EIP for the web server is associated.)
• Source Address: Any
• Desnaon Address: Any

3. In the Translated Packet tab, make the following selecons in the Source Address
Translaon secon:

• Translaon Type: Dynamic IP and Port
• Address Type: Translated Address
• Translated Address: 10.0.0.10 (the firewall dataplane interface in the untrust zone.)

4. Click OK.

4. Click Commit to save the NAT policies.
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STEP 16 | On the VM-Series firewall, create security policies to manage traffic.

Instead of entering a stac IP address for the web server, use a dynamic address
group. Dynamic address groups allow you to create policy that automacally adapts
to changes so that you do not need to update the policy when you launch addional
web servers in the subnet. For details, see Use Case: Use Dynamic Address Groups
to Secure New EC2 Instances within the VPC.

1. Select Policies > Security.

In this example, we have four rules. A rule that allows management access to the firewall
traffic, a rule to allow inbound traffic to the web server, a third rule to allow internet
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access to the web server, and in the last rule we modify a predefined intrazone-default
rule to log all traffic that is denied.

2. Create a rule to allow management access to the firewall.

1. Click Add and enter a Name for the rule. Verify that the Rule Type is universal.
2. In the Source tab, add untrust as the Source Zone.
3. In the Desnaon tab, add trust as the Desnaon Zone.
4. In the Applicaons tab, Add ping and ssh.
5. In the Acons tab, set the Acon to Allow.
6. Click OK.

3. Create a rule to allow inbound traffic to the web server.

1. Click Add and enter a Name for the rule and verify that the Rule Type is universal.
2. In the Source tab, add untrust as the Source Zone.
3. In the Desnaon tab, add trust as the Desnaon Zone.
4. In the Applicaons tab, Add web-browsing.
5. In the Service/URL Category tab, verify that the service is set to applicaon-default.
6. In the Acons tab, set the Acon to Allow.
7. In the Profile Sengs secon of the Acons tab, select Profiles and then aach the

default profiles for anvirus, an-spyware, and vulnerability protecon.
8. Click OK.

4. Create a rule to allow internet access to the web server.

1. Click Add and enter a Name for the rule and verify that the Rule Type is universal.
2. In the Source tab, add trust as the Source Zone.
3. In the Source Address secon of the Source tab, add 10.0.1.62, the IP address of the

web server.
4. In the Desnaon tab, add untrust as the Desnaon Zone.
5. In the Service/URL Category tab, verify that the service is set to applicaon-default.
6. In the Acons tab, set the Acon to Allow.
7. In the Profile Sengs secon of the Acons tab, select Profiles and then aach the

default profiles for anvirus, an-spyware, and vulnerability protecon.
8. Click OK.

5. Edit the interzone-default rule to log all traffic that is denied. This predefined interzone
rule is evaluated when no other rule is explicitly defined to match traffic across different
zones.

1. Select the interzone-default rule and click Override.
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2. In the Acons tab, select Log at session end.
3. Click OK.

6. Review the complete set of security rules defined on the firewall.
7. Click Commit to save the policies.

STEP 17 | Verify that the VM-Series firewall is securing traffic.
1. Launch a web browser and enter the IP address for the web server.
2. Log in to the web interface of the VM-Series firewall and verify that you can see the

traffic logs for the sessions at Monitor > Logs > Traffic.

• Traffic inbound to the web server (arrives at EC2 instance in the AWS VPC):

• Traffic outbound from the web server (EC2 instance in the AWS VPC):

You have successfully deployed the VM-Series firewall as a cloud gateway!
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Use Case: Use Dynamic Address Groups to Secure New
EC2 Instances within the VPC

In a dynamic environment such as the AWS-VPC where you launch new EC2 instances on
demand, the administrave overhead in managing security policy can be cumbersome. Using
Dynamic Address Groups in security policy allows for agility and prevents disrupon in services or
gaps in protecon.

In this example, you can use the VM Informaon Source on the firewall to monitor a VPC and use
Dynamic Address Groups in security policy to discover and secure EC2 instances. As you spin up
EC2 instances, the Dynamic Address Group collates the IP addresses of all instances that match
the criteria defined for group membership, and then security policy is applied for the group. The
security policy in this example allows internet access to all members of the group.

Instead of using VM Informaon Source on the firewall, you can opt to use Panorama as
the central point for communicang with your VPCs. Using the AWS plugin on Panorama,
you can retrieve the IP address-to-tag mapping and register the informaon on the
managed firewalls for which you configure noficaon. For more details on this opon, see
VM Monitoring with the AWS Plugin on Panorama.

This workflow in the following secon assumes that you have created the AWS VPC and deployed
the VM-Series firewall and some applicaons on EC2 instances. For instrucons on seng up the
VPC for the VM-Series, see Use Case: Secure the EC2 Instances in the AWS Cloud.

STEP 1 | Configure the firewall to monitor the VPC.
1. Select Device > VM Informaon Sources.
2. Click Add and enter the following informaon:

1. A Name to idenfy the VPC that you want to monitor. For example, VPC-CloudDC.
2. Set the Type to AWS VPC.
3. In Source, enter the URI for the VPC. The syntax is

ec2.<your_region>.amazonaws.com
4. Add the credenals required for the firewall to digitally sign API calls made to the

AWS services. You need the following:

• Access Key ID: Enter the alphanumeric text string that uniquely idenfies the user
who owns or is authorized to access the AWS account.

• Secret Access Key: Enter the password and confirm your entry.
5. (Oponal) Modify the Update interval to a value between 5-600 seconds. By default,

the firewall polls every 5 seconds. The API calls are queued and retrieved within
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every 60 seconds, so updates may take up to 60 seconds plus the configured polling
interval.

6. Enter the VPC ID that is displayed on the VPC Dashboard in the AWS management
console.

7. Click OK, and Commit the changes.
8. Verify that the connecon Status displays as  connected

STEP 2 | Tag the EC2 instances in the VPC.

For a list of tags that the VM-Series firewall can monitor, see List of Aributes Monitored on
the AWS VPC.

A tag is a name-value pair. You can tag the EC2 instances either on the EC2 Dashboard on the
AWS management console or using the AWS API or AWS CLI.

In this example, we use the EC2 Dashboard to add the tag:
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STEP 3 | Create a dynamic address group on the firewall.

View the tutorial to see a big picture view of the feature.

1. Select Object > Address Groups.
2. Click Add and enter a Name and a Descripon for the address group.
3. Select Type as Dynamic.
4. Define the match criteria.

1. Click Add Match Criteria, and select the And operator.
2. Select the aributes to filter for or match against. In this example, we select the

ExternalAccessAllowed tag that you just created and the subnet ID for the private
subnet of the VPC.

5. Click OK.
6. Click Commit.
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STEP 4 | Use the dynamic address group in a security policy.

To create a rule to allow internet access to any web server that belongs to the dynamic address
group called ExternalServerAccess.

1. Select Policies > Security.
2. Click Add and enter a Name for the rule and verify that the Rule Type is universal.
3. In the Source tab, add trust as the Source Zone.
4. In the Source Address secon of the Source tab, Add the ExternalServerAccess group

you just created.
5. In the Desnaon tab, add untrust as the Desnaon Zone.
6. In the Service/URL Category tab, verify that the service is set to applicaon-default.
7. In the Acons tab, set the Acon to Allow.
8. In the Profile Sengs secon of the Acons tab, select Profiles and then aach the

default profiles for anvirus, an-spyware, and vulnerability protecon.
9. Click OK.

10. Click Commit.

STEP 5 | Verify that members of the dynamic address group are populated on the firewall.

Policy will be enforced for all IP addresses that belong to this address group, and are displayed
here.

1. Select Policies > Security, and select the rule.
2. Select the drop-down arrow next to the address group link, and select Inspect. You can

also verify that the match criteria is accurate.
3. Click the more link and verify that the list of registered IP addresses is displayed.
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Use Case: VM-Series Firewalls as GlobalProtect
Gateways on AWS

Securing mobile users from threats and risky applicaons is oen a complex mix of procuring
and seng up the security and IT infrastructure, ensuring bandwidth and upme requirements in
mulple locaons around the globe while staying within your budget.

The VM-Series firewall on AWS melds the security and IT logiscs required to consistently and
reliably protect devices used by mobile users in regions where you do not have a presence.
By deploying the VM-Series firewall in the AWS cloud, you can quickly and easily deploy
GlobalProtect™ gateways in any region without the expense or IT logiscs that are typically
required to set up this infrastructure using your own resources.

To minimize latency, select AWS regions that are closest to your users, deploy the VM-Series
firewalls on EC2 instances, and configure the firewalls as GlobalProtect gateways. With this
soluon, the GlobalProtect gateways in the AWS cloud enforce security policy for internet traffic
so there is no need to backhaul that traffic to the corporate network. Addionally, for access
to resources on the corporate network, the VM-Series firewalls on AWS leverage the LSVPN
funconality to establish IPSec tunnels back to the firewall on the corporate network.

For ease of deployment and centralized management of this distributed infrastructure, use
Panorama to configure the GlobalProtect components used in this soluon. Oponally, to ensure
that mobile devices, such as smartphones and tablets, are safe for use on your network, use a
Mobile Device Manager to configure and manage mobile devices.

• Components of the GlobalProtect Infrastructure
• Deploy GlobalProtect Gateways on AWS

Components of the GlobalProtect Infrastructure
To block risky applicaons and protect mobile users from malware, you must set up the
GlobalProtect infrastructure, which includes the GlobalProtect portal, the GlobalProtect gateway,
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and the GlobalProtect app. Addionally, for access to corporate resources, you must set up an
IPSec VPN connecon between the VM-Series firewalls on AWS and the firewall in the corporate
headquarters using LSVPN (a hub and spoke VPN deployment).

• The GlobalProtect agent/app is installed on each end-user system that is allowed to access
corporate applicaons and resources. The agent first connects to the portal to obtain
informaon on the gateways and then establishes a secure VPN connecon to the closest
GlobalProtect gateway. The VPN connecon between the end-user system and the gateway
ensures data privacy.

• The GlobalProtect portal provides the management funcons for the GlobalProtect
infrastructure. Every end-user system receives configuraon informaon from the portal,
including informaon about available gateways as well as any client cerficates that may be
required to connect to the GlobalProtect gateway(s). In this use case, the GlobalProtect portal is
a hardware-based firewall that is deployed in the corporate headquarters.

• The GlobalProtect gateway delivers mobile threat prevenon and policy enforcement based on
applicaons, users, content, device, and device state. In this use case, the VM-Series firewalls
on AWS funcon as the GlobalProtect gateways. The GlobalProtect gateway scans each user
request for malware and other threats, and, if policy allows, sends the request to the internet or
to the corporate network over the IPSec tunnel (to the LSVPN gateway).

• For LSVPN, you must configure the GlobalProtect portal, GlobalProtect gateway for LSVPN
(hub), and the GlobalProtect Satellites (spokes).

In this use case, the hardware-based firewall in the corporate office is deployed as the
GlobalProtect portal and the LSVPN gateway. The VM-Series firewalls on AWS are configured
to funcon as GlobalProtect satellites. The GlobalProtect satellites and gateway are configured
to establish an IPSec tunnel that terminates on the gateway. When a mobile user requests an
applicaon or resource that resides on the corporate network, the VM-Series firewall routes
the request over the IPSec tunnel.

Deploy GlobalProtect Gateways on AWS
To secure mobile users, in addion to deploying and configuring the GlobalProtect gateways
on AWS, you need to set up the other components required for this integrated soluon. The
following table includes the recommended workflow:

Deploy the VM-Series firewall(s) on AWS.

See Deploy the VM-Series Firewall on AWS.

Configure the firewall at the corporate headquarters.

In this use case, the firewall is configured as the GlobalProtect portal and the LSVPN gateway.

• Configure the GlobalProtectportal.
• Configure the GlobalProtectportal for LSVPN.
• Configure the portal to authencateLSVPN satellites.
• Configure the GlobalProtectgateway for LSVPN.
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Set up a template on Panorama for configuring the VM-Series firewalls on AWS as
GlobalProtect gateways and LSVPN satellites.

To easily manage this distributed deployment, use Panorama to configure the firewalls on AWS.

• Create template(s) on Panorama.

Then use the following links to define the configuraon in the templates.

• Configure the firewall asa GlobalProtect gateway.
• Prepare the satellite tojoin the LSVPN.

Create device groups on Panorama to define the network access policies and internet access
rules and apply them to the firewalls on AWS.

See Create device groups.

Apply the templates and the device groups to the VM-Series firewalls on AWS, and verify that
the firewalls are configured properly.

Deploy the GlobalProtect client soware.

Every end-user system requires the GlobalProtect agent or app to connect to the GlobalProtect
gateway.

See Deploy the GlobalProtectclient soware.
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Resource Monitoring on AWS
As you deploy or terminate resources in the AWS public cloud, you can either use the Panorama
plugin for AWS or use the AWS resource informaon sources on the firewall to consistently
enforce security policy rules on these workloads. See the Compability Matrix for Panorama
plugin version informaon.

The Panorama plugin for AWS is built for scale and allows you to monitor up to 1000 AWS
VPCs on the AWS public cloud. With this plugin, you use Panorama as an anchor to poll your
AWS accounts for tags, and then distribute the metadata (IP address-to-tag mapping) to many
firewalls in a device group. Because Panorama communicates with your AWS accounts to retrieve
AWS resource informaon, you’re able to streamline the number of API calls made to the cloud
environment. When using Panorama and the AWS plugin, you can centralize the retrieval of
tags and Security policy management to ensure consistent policies for hybrid and cloud-nave
architectures. See AWS Resource Monitoring with the AWS Plugin on Panorama.

If you do not have Panorama or you have a simpler deployment and need to monitor 10 VPCs or
fewer, you can use the VM Informaon Source on the firewall (hardware or VM-Series firewall) to
monitor your AWS workloads. You can use the metadata, which the firewall retrieves, in Dynamic
Address Groups and reference them in Security policies to secure your VM workloads as they spin
up or down and IP addresses change frequently. See Use Case: Use Dynamic Address Groups to
Secure New EC2 Instances within the VPC.

AWS Resource Monitoring with the AWS Plugin on Panorama
As you deploy or terminate resources in the AWS public cloud, you need a way to synchronously
update Security policy on your Palo Alto Networks® firewall(s) so that you can secure these EC2
instances. To enable this capability from Panorama, you must install the AWS plugin on Panorama
and enable API communicaon between Panorama and your AWS VPCs. Panorama can then
collect a predefined set of aributes (or metadata elements) as tags for your AWS resources and
register the informaon to your Palo Alto Networks® firewall(s). When you reference these tags
in Dynamic Address Groups and match against them in Security policy rules, you can consistently
enforce policy across all assets deployed within your AWS accounts.

• Set Up the AWS Plugin for Monitoring on Panorama
• List of Aributes Monitored on the AWS VPC

Set Up the AWS Plugin for VM Monitoring on Panorama
To find all the virtual machine workloads that your organizaon has deployed in the AWS public
cloud, you need to install the AWS plugin on Panorama and configure Monitoring Definions
that enable Panorama to authencate to your AWS VPC(s) and retrieve VM informaon on the
workloads. Panorama retrieves the IP address of the VMs that are running— public IP address, and
primary and secondary private IP addresses—and the associated tags. For a list of the metadata
elements that Panorama supports, see List of Aributes Monitored on the AWS VPC.

Aer Panorama fetches the aributes, to push the virtual machine informaon from Panorama
to the firewalls, you must add the firewalls (hardware or VM-Series) as managed devices on
Panorama, and group the firewalls into one or more Device Groups. You can then specify which
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device groups are part of the Nofy Group, which is a configuraon element in a Monitoring
Definion, that Panorama uses to register the IP address-to-tag mapping it retrieves from AWS.

Finally, to consistently enforce Security policies across the EC2 instances, you must set up
Dynamic Address Groups and reference them in policy rules that allow or deny traffic to the IP
addresses of the VMs. For streamlining your configuraon and managing policies and objects
centrally from Panorama, you can define the Dynamic Address Groups and Security policy rules on
Panorama and push them to the firewalls instead of managing the Dynamic Address Groups and
Security policy rules locally on each firewall.

The AWS plugin version 2.0 is for monitoring EC2 instances for up to 1000 VPCs on the
AWS public cloud, AWS GovCloud, and AWS China. However, because Panorama cannot
be deployed on AWS China, the IAM role does not support instance profiles on AWS
China; you must provide the AWS credenals.

• Planning Checklist for VM Monitoring on AWS
• IAM Roles and Permissions for Panorama
• Install or Upgrade the AWS Plugin
• Configure the AWS Plugin for VM Monitoring

Planning Checklist for VM Monitoring on AWS
For Panorama to interact with the AWS APIs and collect informaon on your EC2 instances,
you need to create an IAM role and assign the policies that grant the permissions required to
authencate to AWS and access the EC2 instances within your VPC. You can add 100 IAM roles
to manage up to 1000 VPCs on Panorama.

Gather the VPC ID.
Tag your EC2 instances on AWS. You can tag (define a name-value pair) the EC2 instances
either on the EC2 Dashboard on the AWS management console or using the AWS API or AWS
CLI. See List of Aributes Monitored on the AWS VPC for the list of supported aributes.
Check for duplicate IP addresses across the VPCs for which you will enable monitoring. If you
have duplicate IP addresses across AWS VPCs, the metadata will be appended together or
swapped and this may cause unexpected results in policy enforcement.

Duplicate IP addresses are wrien to the plugin_aws_ret.log file that you can access
from the CLI on Panorama.

Review the requirements for Panorama and the managed firewalls:

• Minimum system requirements—Panorama virtual appliance or hardware-based Panorama
appliance.

Panorama Minimum Requirements

Memory CPUs Number of
Monitored VPCs

Number of Tags RegisteredSystem
Resources

16GB 4 1-100 Panorama 9.1 or later with AWS
plugin v 2.0 is tested to retrieve
10,000 IP addresses with 13 tags

VM-Series Deployment Guide Version Version 10.1 427 ©2022 Palo Alto Networks, Inc.

https://docs.paloaltonetworks.com/pan-os/10-1/pan-os-admin/policy/monitor-changes-in-the-virtual-environment/use-dynamic-address-groups-in-policy.html


Set Up the VM-Series Firewall on AWS

Panorama Minimum Requirements

32 GB 8 100-500

64 GB 16 500-1000

for each, or 5000 IP addresses with
25 tags for each, and successfully
register them to the firewalls
included within a device group.The
tag length—includes name and
value—for each EC2 instance is
assumed to be 64 bytes per tag. For
example, the EC2 instance name
tag is aws.ec2.tag.Name.prod-web-
app-4523-lvss6j.

Panorama OS
version

9.1 or later

AWS plugin
version

2.0.0 or later

Licenses Acve support license and a device management license on Panorama for
managing the firewalls.

Next-generaon firewalls must also have a valid support license.

Roles and
Permissions
to retrieve
metadata on the
EC2 instances

See IAM Roles and Permissions for Panorama

• You must add the firewalls as managed devices on Panorama and create Device Groups
so that you can configure Panorama to nofy these groups with the VM informaon it
retrieves. Device groups can include VM-Series firewalls or virtual systems on the hardware
firewalls.

• If your Panorama appliances are in a high availability configuraon, you must manually install
the same version of the AWS plugin on both Panorama peers. Addionally, if you are using
instance profiles, you must aach the same instance profile to both Panorama peers.

You configure the AWS plugin on the acve Panorama peer only. On commit, the
configuraon is synced to the passive Panorama peer. Only the acve Panorama
peer polls the AWS accounts you have configured for VM Monitoring.

• Set up the credenals/permissions that Panorama requires to digitally sign API calls to the
AWS services.

You can choose whether you want to provide the long-term credenals—Access Key ID and
Secret Access Key—that enable access to the resources within each AWS account, or set up
an Assume Role on AWS to allow access to defined AWS resources within the same AWS
account or cross-accounts. With an Assume Role, you must set up a trust relaonship and
define the permissions while creang the role itself. This is specifically useful in a cross-
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account deployment where the querying account does not have permissions to see or
handle data from the queried account. For the Panorama plugin to successfully authencate
to the VPC and retrieve the tags, you must configure the Assume Role to use the AWS
Security Token Service (STS) API to any AWS service. And a user from the querying account
must have STS permissions to query the Assume Role and obtain the temporary security
credenals to access resources. If your Panorama is deployed on AWS, you can opt to use
an instance profile instead of providing the AWS credenals for the IAM role. The instance
profile includes the role informaon and associated credenals that Panorama needs to
digitally sign API calls to the AWS services. See IAM Roles and Permissions for Panorama for
more details.

IAM Roles and Permissions for Panorama
With the AWS plugin version 2.0, you can use IAM roles or instance profiles to enable Panorama
to authencate and retrieve metadata on the resources deployed within your AWS account(s).

• When your Panorama is not deployed on AWS, you have two opons. You can either provide
the long-term IAM credenals for the AWS accounts you want to monitor, or set up an Assume
Role on AWS to allow access to defined AWS resources within the same AWS account or
cross-accounts. An Assume Role is recommended as the more secure opon.

• When your Panorama is deployed on AWS, in addion to the two opons listed above, you can
also add an instance profile that allows the IAM role to be passed to the EC2 instance. You can
use an instance profile where all your monitored resources and Panorama are hosted within
the same account, or an instance profile with Assume Role for cross account access where your
Panorama and monitored resources are deployed across different AWS accounts. If you use the
instance profile, you do not enter your AWS credenals on Panorama.

Opon 1: IAM role with long term credenals

Roles and
Permissions
Required

The AWS credenals associated with the AWS account that has the VPC/EC2
instances you want to monitor.

The JSON format for the minimum permissions associated with the IAM role
with long-term credenals is as follows:

{ "Path": "/", "UserName": "panorama_vm_programmatic",
  "UserId": "AIDAIZXXXXCR5JPII4XYZ",
  "Arn": "arn:aws:iam::412383210500:user/
          panorama_vm_programmatic",
  "CreateDate": "2018-07-06T19:14:31Z",
  "GroupList": [],
  "AttachedManagedPolicies":
   [
     { "PolicyName": "ReadOnlyAccess", 
       "PolicyArn": "arn:aws:iam::aws:policy/ReadOnlyAcce
ss"
     } 
   ] 
},
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Inputs on
Panorama

Enter the Access Key ID and Secret Access Key for the user in Panorama >
Plugins > AWS > Setup > IAM Role.

Opon 2: IAM role with Assume Role

Roles and
Permissions
Required

While you can use this opon to monitor VPCs within the same or cross account,
this opon is recommended to enable cross account access by assuming a role
that allows you to access resources to which you may normally have access.

To assume a role from a different account, your AWS account must be trusted
by that role and defined as a trusted enty in its trust policy. In addion, a user
who wants to access a role in a different account must have a policy with secure
token service (STS) access that specifies the role ARN.

On Account 1 that you want to monitor:

• Create an IAM role with required permissions. For VM Monitoring you need
AmazonEC2ReadOnlyAccess.

• Copy the Role ARN.
• Create a user and add the Account ID for Account 2 as a trusted enty. This

allows Account 2 the permissions to use this role to access the resources
within your Account 1.

On Account 2 that requires access to account 1

• Aach the following policy with STS permissions and modify the Role ARN to
match what you created on Account 1.

{ "Version": "2012-10-17",
  "Statement": 
   {
     "Effect": “Allow",
     "Action": "sts:AssumeRole", 
     "Resource":"arn:aws:iam::012347211234:role/
                 PAN-OS-assume-role"
   }
}

Inputs on
Panorama

• Enter the Access Key ID and Secret Access Key for the user on Account 2 on
Panorama > Plugins > AWS > Setup > IAM Role.

• Enter the Role ARN for the AWS Account 1 which you want to monitor in the
Panorama > Plugins > AWS > Monitoring Definions.

Opon 3: Instance profile

Roles and
Permissions
Required

Only when Panorama is deployed as an EC2 instance on AWS
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Note that when you use the AWS Management console to create an
IAM role, the console automacally creates an instance profile with the
same name as the role. Because the role and the instance profile has
the same name, when you launch tour Panorama (EC2 instance) with
an IAM role, the instance profile of the same name is associated with
it.

When Panorama and the resources you want to monitor are all in a single AWS
account.

Create an IAM role with AmazonEC2ReadOnlyAccess.

Inputs on
Panorama

Select Instance Profile as the opon in Panorama > Plugins > AWS > Setup >
IAM Role.

Opon 4: Instance profile with Assume Role

Roles and
Permissions
Required

Use instance profile with Assume role when Panorama and the resources you
want to monitor are deployed across AWS accounts.

For Panorama HA, make sure to aach the same instance profile to both
Panorama peers.

On Account 1, where your EC2 instances are deployed:

• Create an IAM role.
• To this role, add the AWS Account ID (Account 2) where your Panorama is

deployed as a trusted enty.
• Aach the JSON policies as detailed above for VM Monitoring.
• Copy the Role ARN.This role is required for Panorama to retrieve metadata on

your EC2 instances or EKS clusters.

On Account 2, where your Panorama is deployed:

• Create an IAM role and aach the JSON policy (with the STS policy and
resource ARN you got from Account 1).

• For each addional AWS account you want to monitor, copy the same STS
policy and modify the Role ARN.

Inputs on
Panorama

• Select Instance Profile as the opon in Panorama > Plugins > AWS > Setup >
IAM Role

• Enter the Role ARN for the AWS account which you want to monitor in the
Panorama > Plugins > AWS > Monitoring Definions.

For example Account 1 in this example.

Install or Upgrade the AWS Plugin
To get started with monitoring your EC2 instances on AWS, refer to the Compability Matrix for
the Panorama Plugin for AWS and VM-Series plugin versionsrequired to support VM monitoring.
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To upgrade a Panorama plugin for AWS version 1.0.1 installaon to version 2.0.x, you must first
upgrade to the Panorama and VM-Series plugin versions required for version 2.0.x, then install as
directed below to perform an upgrade.

Aer you install the AWS plugin v2.0 you cannot downgrade to v1.0.

If you have a Panorama HA configuraon, repeat the installaon/upgrade process on each
Panorama peer.

Install or uninstall plugins during a planned maintenance window.

If you currently have a Panorama plugin for any cloud plaorm installed, installing (or
uninstalling) an addional plugin requires a Panorama reboot so commit changes.

If you have a standalone Panorama or two Panorama appliances installed in an HA pair with
mulple plugins installed, plugins might not receive updated IP-tag informaon if one or more of
the plugins is not configured. This occurs because Panorama will not forward IP-tag informaon
to unconfigured plugins. Addionally, this issue can occur if one or more of the Panorama plugins
is not in the Registered or Success state (posive state differs on each plugin). Ensure that your
plugins are in the posive state before connuing or execung the commands described below.

If you encounter this issue, there are two workarounds:

• Uninstall the unconfigured plugin or plugins. It is recommended that you do not install a plugin
that you do not plan to configure right away

• You can use the following commands to work around this issue. Execute the following
command for each unconfigured plugin on each Panorama instance to prevent Panorama from
waing to send updates. If you do not, your firewalls may lose some IP-tag informaon.

request plugins dau plugin-name <plugin-name> unblock-device-push yes

You can cancel this command by execung:

request plugins dau plugin-name <plugin-name> unblock-device-push no

The commands described are not persistent across reboots and must be used again for any
subsequent reboots. For Panorama in HA pair, the commands must be executed on each
Panorama.
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STEP 1 | Log in to the Panorama Web Interface, select Panorama > Plugins and click Check Now to
get the AWS plugin version that supports VM monitoring.

STEP 2 | Download and Install the plugin.

Aer you successfully install, Panorama refreshes and the AWS plugin displays on the
Panorama > Plugins tab.

On the Panorama Dashboard General Informaon widget you can verify the Panorama
Plugin for AWS version that is installed.

STEP 3 | (Panorama in HA) Commit > Commit to Panorama.

If your Panorama is in HA, commit the changes to the Panorama configuraon to ensure that
tags are registered to the Panorama peer on failover.

Configure the AWS Plugin for VM Monitoring
To begin monitoring the virtual machines in your AWS public cloud deployment, aer you Install
the AWS Plugin you must create a Monitoring Definion. This definion specifies the IAM Role
that is authorized to access the EC2 instances within the AWS VPC you want to monitor and the
Nofy Group that includes the firewalls to which Panorama should push all the IP-address-to-tag
mappings it retrieves. In order to enforce policy, you must then create Dynamic Address Groups
and reference them in Security policy. The Dynamic Address Groups enable you to filter the tags
you want to match on, so that the firewall can get the public and private IP addresses registered
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against each tag, and then allow or deny access to traffic to and from the workloads based on the
policy rules you define.

STEP 1 | Log in to the Panorama web interface.

STEP 2 | Set up the following objects for enabling VM Monitoring on AWS.

Add an IAM Role.

An IAM role is an enty that allows you to delegate access so that Panorama can make
service requests on your behalf to the AWS resources (virtual machines that are deployed as
EC2 instances).

1. Select Panorama > Plugins > AWS > Setup > IAM Role > Add.

2. Enter a Name and oponally a Descripon to idenfy the IAM role.
3. Select Account Type—Instance Profile or AWS Account Credenals.If your Panorama is

deployed on AWS, you can choose to either aach an instance profile with the correct
permissions to your Panorama or add the credenals associated with the IAM role on
Panorama. If your Panorama is not deployed on AWS, you must enter the credenals for
the IAM role locally on Panorama.

4. (For AWS Account Credenals only) Enter the Secret Access Key and re-enter it to
confirm, and click OK.

Add a nofy group.

1. Select Panorama > Plugins > AWS > Setup > Nofy Groups > Add.

2. Enter a Name to idenfy the group of firewalls to which Panorama pushes the VM
informaon it retrieves.

3. Select the Device Groups, which are a group of firewalls or virtual systems, to which
Panorama will push the VM informaon (IP address-to-tag mapping) it retrieves from
your AWS VPCs. The firewalls use the update to determine the most current list of
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members that constute dynamic address groups referenced in policy. If you are using
the Panorama plugin for Azure and AWS, you can target the same firewall or virtual
system with tags from both environments.

Think through your Device Groups carefully.

• Because a Monitoring Definion can include only one nofy group, make sure
to select all the relevant Device Groups within your nofy group. If you want
to unregister the tags that Panorama has pushed to a firewall included in a
nofy group, you must delete the Monitoring Definion.

• To register tags to all virtual systems on a firewall enabled for mulple virtual
systems, you must add each virtual system to a separate device group on
Panorama and assign the device groups to the nofy group. If you assign all
the virtual systems to one device group, Panorama will register tags to only
one virtual system on the firewall.

4. Select the tags that you want to retrieve from the AWS VPCs.

You can Select All 32 Tags (the default) or pick the Custom Tags you want to retrieve
for your instances. With the Custom Tags opon, you can Add the predefined tags and
the user-defined tags that you want to use as match criteria in Security policy. If you are
monitoring a large number of EC2 instances, reducing the number of tags you retrieve
ensures more efficient use of the CPU and memory capacity on your Panorama. Refer to
Planning Checklist for VM Monitoring on AWS for some guidelines.

Verify that monitoring is enabled on the plugin. This seng must be enabled for Panorama
to communicate with the AWS public cloud for VM Monitoring.

The checkbox for Enable Monitoring is on Panorama > Plugins > AWS > Setup > General.
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STEP 3 | Create a Monitoring Definion for each VPC you want to monitor.

When you add a new Monitoring definion, it is enabled by default.

• Select Panorama > Plugins > AWS > Monitoring Definion, to Add a new definion.
• Enter a Name and oponally a Descripon to idenfy the AWS VPC for which you use this

definion.
• Enter the Endpoint URI. The syntax is ec2.<your_region>.amazonaws.com;

For AWS China, it is ec2.<your region>.amazonaws.com.cn.
• (Oponal) Enter the Role ARN, if you have set up role chaining and IAM roles with

temporary credenals that have permissions to use the AWS STS API to access AWS
resources with the same account or cross-account. The Role ARN must belong to the VPC
you want to monitor.

• Select the IAM Role, Add the VPC ID from the VPC Dashboard on the AWS management
console, and Nofy Group.

STEP 4 | Commit the changes on Panorama.

Verify that the status for the Monitoring Definion displays as Success. If it fails, verify that
you entered the AWS VPC ID accurately and provided the correct keys and IDs for authorizing
access.

Click Validate to verify that Panorama can authencate using the IAM role and keys
and to communicate with the AWS VPCs you’ve entered above.
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STEP 5 | Verify that you can view the VM informaon on Panorama, and define the match criteria for
Dynamic Address Groups.

On HA failover, the newly acve Panorama aempts to reconnect to the AWS cloud
and retrieve tags for all monitoring definions. If Panorama is unable to reconnect
with even one of the monitoring definions that you have configured and enabled,
Panorama generates a system log message

Unable to process accounts after HA switch-over; user-
intervention required.

If this happens, you must log into Panorama and verify the monitoring definions to
fix invalid credenals or remove invalid accounts. Although Panorama is disconnected
from the AWS cloud, all tags that were retrieved for the monitoring definions before
the failover, are retained and the firewalls can connue to enforce policy on that list
of IP addresses. Panorama removes all tags associated with the accounts only when
you delete a monitoring definion. As a best pracce, to monitor this issue, you can
configure acon-oriented log forwarding to an HTTPS desnaon from Panorama so
that you can take acon immediately.
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STEP 6 | Know where to find the logs related to the AWS plugin on Panorama for troubleshoong.

• Use the CLI command less plugins-log to view a list of all available logs

plugin_aws_ret.log displays logs related to IP address and tag retrieval.

plugin_aws_proc.log displays logs related to processing of the registered IP address and tags.

plugin_aws.log displays logs related to the AWS plugin configuraon and daemons.

Use show plugins aws vm-mon-status for the status of the Monitoring Definions.

admin@Panorama> show plugins aws vm-mon-status
Mon-Def Name      VPC           Status  Last Updated Time         
 Error Msg
-----------------------------------------------------------------------------
MD-Ins-Prof-ARN  vpc-07986b091  Success 2019-12-02T10:24:56.007000
MD-gov           vpc-7ea1cf1a   Success 2019-12-02T10:24:56.008000
MD-IAM-ARN       vpc-025a83c123 Success 2019-12-02T10:24:56.012000
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Auto Scaling VM-Series Firewalls with the Amazon ELB
Service

The Palo Alto Networks auto scaling templates for AWS help you deploy configure and deploy
VM-Series firewalls to protect applicaons deployed in AWS. The templates leverage AWS
scalability features to independently and automacally scale VM-Series firewalls deployed in AWS
to meet surges in applicaon workload resource demand.

• VM-Series automaon capabilies include the PAN-OS API and bootstrapping (using a
bootstrap file for version 2.0, and Panorama for version 2.1).

• AWS automaon technology includes CloudFormaon templates and scripts for AWS services
such as Lambda, auto scaling groups (ASGs), Elasc Load Balancing (ELB), S3, and SNS.

The templates are available on the Palo Alto Networks GitHub repository for Auto Scaling VM-
Series Firewalls in AWS:

• Version 2.0 provides a firewall template and an applicaon template. These templates and the
supporng scripts deploy VM-Series firewalls, an internet facing firewall, an internal firewall,
and applicaon ASGs in a single Virtual Private Cloud (VPC) or mulple VPCs.

In version 2.0, Palo Alto Networks supports the firewall template while the applicaon
template is community-supported. See VM-Series Auto Scale Template for AWS Version 2.0 for
deployment details.

• Version 2.1 adds support for deployment in a single VPC and adds support for a load balancer
sandwich topology that enables you to deploy the VM-Series firewalls in to a front-end VPC
and the back-end applicaons in to one or more applicaon VPCs connected by VPC peering or
AWS PrivateLink.

In version 2.1 you can implement both applicaon load balancers (ALBs) and network load
balancers (NLBs) in VPCs. Version 2.1 includes two firewall templates and five applicaon
templates. See VM-Series Auto Scaling Templates for AWS Version 2.1 for deployment details.

If you have an exisng template deployment, there is no migraon procedure.

The following table compares some high-level features of each template version.

Features / Requirements Version 2.0 Version 2.1

Panorama running PAN-OS
9.0.1 or a later release in
Panorama mode.

(Oponal) If you choose to use
Panorama, you must configure VPC
peering between the VM-Series
firewall VPC and the applicaon VPCs.

(Required) Deploy the
Version 2.1 templates.
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Features / Requirements Version 2.0 Version 2.1
Panorama
in a high
availability
(HA)
configuraon
is not
supported.

Peered traffic traverses the public
internet.

On
Panorama,
you must
manually
install the
VM-Series
plugin to
enable
VM-Series
firewalls
to publish
PAN-OS
metrics
for auto
scaling.

Bootstrapping bootstrap.xml config file in an S3
bucket.

An init-cfg.txt file
for Panorama.

Palo Alto Networks S3
bucket sample

Use your own S3 bucket or use the
sample in panw-aws-autoscale-v20-
us-west-2.

Use your own S3
bucket for the
deployment.

Single VPC or separate
VPCs (hub and spoke)

Yes Yes

New VPC Yes Yes

Exisng VPC (brown field) No Yes

Availability zones per VPC 2 2-4

External load balancer ALB only ALB or NLB

Internal load balancer NLB only ALB or NLB

AWS PrivateLink
connecon to the VM-
Series firewall VPC and the
backend servers.

No Yes

For details on the templates see:

• VM-Series Auto Scaling Templates for AWS Version 2.0
• VM-Series Auto Scaling Templates for AWS Version 2.1
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VM-Series Auto Scaling Templates for AWS Version 2.0
To help you manage increased applicaon scaling, version 2.0 of the auto scaling VM-Series
firewall template provides a hub and spoke architecture that simplifies deployment. This version
of the soluon provides two templates that support a single and mulple-VPC deployment both
within a single AWS account and across mulple AWS accounts.

• Firewall Template—The firewall template deploys an applicaon load balancer (ALB) and VM-
Series firewalls within auto scaling groups across two Availability Zones (AZs). This internet-
facing ALB distributes traffic that enters the VPC across a pool of VM-Series firewalls. The VM-
Series firewalls automacally publish custom PAN-OS metrics that enable auto scaling.

Palo Alto Networks officially supports the firewall template and, with a valid support
entlement, you can request assistance from Palo Alto Networks Technical Support.

The following applicaon template deploys the network load balancer depicted in the
preceding image.

• Applicaon Template—The applicaon template deploys a network load balancer (NLB) and
one auto scaling group (ASG) with a web server in each AZ.

The applicaon template is community supported. This template is provided as an example to
help you get started with a basic web applicaon. For a producon environment, either use
your own applicaon template or customize this template to meet your requirements.

These templates allow you to deploy a load balancer sandwich topology with an internet-facing
ALB and an internal NLB. The ALB is accessible from the internet and distributes traffic that enters
the VPC across a pool of VM-Series firewalls. The firewalls then route traffic using NAT policy to
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NLBs, which distributes traffic to an auto scaling er of web or applicaon servers. The VM-Series
firewalls are enabled to publish custom PAN-OS metrics to AWS CloudWatch where you can
monitor the health and resource load on the VM-Series firewalls and then use that informaon to
trigger auto scaling events in the appropriate ASGs on firewalls.

• What Components Does the VM-Series Auto Scaling Template for AWS (v2.0) Leverage?
• How Does the VM-Series Auto Scaling Template for AWS (v2.0) Enable Dynamic Scaling?
• Plan the VM-Series Auto Scaling Template for AWS (v2.0)
• Customize the Firewall Template Before Launch (v2.0)
• Launch the VM-Series Auto Scaling Template for AWS (v2.0)
• Customize the Bootstrap.xml File (v2.0)
• Stack Update with VM-Series Auto Scaling Template for AWS (v2.0)
• Modify Administrave Account and Update Stack
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What Components Does the VM-Series Auto Scaling Template for AWS (v2.0)
Leverage?

The VM-Series Auto Scaling template for AWS includes the following building blocks:

Building Block Descripon

Firewall template

(Palo Alto Networks
officially supported
template)

The firewall-v2.0.template deploys a new VPC with subnets,
route tables, an AWS NAT gateway, two Availability Zones (AZs), and
security groups required for roung traffic across these AZs. This
version 2.0 template also deploys an external ALB, and an ASG with a
VM-Series firewall in each AZ.

Due to the many variaons in a producon environment that includes
but is not limited to a specific number components, such as subnets,
availability zones, route tables, and security groups. You must deploy
the firewall-v2.0.template in a new VPC.

VM-Series Auto Scaling template for AWS does not deploy
Panorama and Panorama is oponal. Panorama provides
ease of policy management and central visibility. If you want
to use Panorama to manage the VM-Series firewalls that the
soluon deploys, you can either use an M-Series appliance
or Panorama virtual appliance inside your corporate
network or you can use a Panorama virtual appliance on
AWS.

This soluon includes an AWS NAT gateway that the firewalls use
to iniate outbound requests for retrieving updates, connecng to
Panorama, and publishing metrics to AWS CloudWatch.

Applicaon template

(Community
supported template)

The applicaon template deploys an NLB and an ASG with a web
server in each AZ. Because the NLB has a unique IP address for each
AZ and the NAT policy rule on the firewalls must reference a single IP
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address, there is one ASG for each of the two AZs. All firewalls in an
ASG use an idencal configuraon.

Version 2.0 of the auto scaling soluon includes two applicaon
templates:

• The panw_aws_nlb-v2.0.template allows you to deploy the
applicaon template resources within the same VPC as the one in
which you deployed the firewall template (same AWS account).

• The panw_aws_nlb_vpcv-2.0.template allows you to deploy
the applicaon template resources in a separate VPC using the
same AWS account or mulple AWS accounts.

Lambda funcons AWS Lambda provides robust, event-driven automaon without
the need for complex orchestraon soware. In the firewall-
v2.0.template, AWS Lambda monitors a Simple Queue Service
(SQS) to learn about NLBs that publish to the queue. When the
Lambda funcon detects a new NLB, it creates a new NAT policy rule
and applies it to the VM-Series firewalls within the ASG. The firewalls
have a NAT policy rule for each applicaon and the firewalls use the
NAT policy rule (that maps the port to NLB IP address) to forward
traffic to the NLB in front of the applicaon web servers.

You need to create the Security policy rule to allow or
deny applicaon traffic for your deployment. The sample
bootstrap.xml file does not include any Security policy
rules. You should use Panorama to centrally manage your
firewalls and simplify creang Security policy rules.

There are addional funcons:

• Adds or removes an interface (ENI) when a firewall is launched or
terminated.

• Deletes all the associated resources when you delete a stack or
terminate an instance.

• Removes a firewall as a Panorama managed device when there is a
scale-in event.

• Deacvates the BYOL license when a scale-in event results in a
firewall terminaon.

To learn more about the Lambda funcons, refer to hp://
paloaltonetworks-aws-autoscale-2-0.readthedocs.io/en/latest/

Bootstrap files

The bootstrap.xml
file provided in the
GitHub repository is
provided for tesng

This soluon requires the init-cfg.txt file and the bootstrap.xml file so
that the VM-Series firewall has the basic configuraon for handling
traffic.
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and evaluaon only.
For a producon
deployment, you
must modify the
sample credenals
in the bootstrap.xml
prior to launch.

• The init-cfg.txt file includes the mgmt-interface-swap
operaonal command to enable the firewall to receive dataplane
traffic on its primary interface (eth0). This auto-scaling soluon
requires the swapping of the dataplane and management interfaces
to enable the ALB to forward web traffic to the auto-scaling er of
VM-Series firewalls. For details, see Management Interface Mapping
for Use with Amazon ELB.

• The bootstrap.xml file enables basic connecvity for the firewall
network interfaces and allows the firewall to connect to the AWS
CloudWatch namespace that matches the stack name you enter
when you launch the template.

To deploy the soluon, see Launch the VM-Series Auto Scaling Template for AWS (v2.0).

How Does the VM-Series Auto Scaling Template for AWS (v2.0 and v2.1) Enable
Dynamic Scaling?

VM-Series firewall scale in and scale out using VM-Series firewalls that are deployed using auto
scaling templates based on custom PAN-OS metrics. The VM-Series firewalls navely publish
these metrics to the Amazon CloudWatch console and, based on the metrics you choose for the
scaling parameters, you can define CloudWatch alarms and policies to dynamically deploy or
terminate instances for managing the applicaon traffic in your AWS deployment.

The firewalls publish metrics to AWS CloudWatch every five minutes (by default). When a
monitored metric reaches the configured threshold for the defined me interval, CloudWatch
triggers an alarm and iniates an auto-scaling event.

When the auto-scaling event triggers the deployment of a new firewall, the new instance
bootstraps at launch and an AWS Lambda funcon configures the firewall with NAT policy rules.
A NAT policy rule is created for each applicaon and the rule references the IP addresses for each
network load balancer in your deployment. When the applicaon load balancer receives a request,
it forwards the request to the firewall on the assigned TCP port. The firewall then inspects the
traffic and forwards it to the corresponding network load balancer, which then forwards the
request to a web server in its target group.

Plan the VM-Series Auto Scaling Template for AWS (v2.0 and v2.1)
The items in this checklist are acons and choices you must make to implement this soluon.

Planning Checklist for Templates v2.0 and v2.1

Verify the
requirements for
deploying the
VM-Series Auto
Scaling template.

The auto scaling template requires AWS Lambda and S3 Signature
versions 2 or 4, and can deploy VM-Series firewalls running supported 
PAN-OS versions. You need to look up the list of supported regions
and the AMI IDs, to provide as an input in the firewall template.
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Assign the
appropriate
permissions for
the IAM user role.

The user who deploys the VM-Series Auto Scaling template must
either have administrave privileges or have the permissions listed in
the iam-policy.json to launch this soluon successfully. Copy and paste
the permissions from this file in to a new IAM policy and then aach
the policy to a new or exisng IAM role.

For a cross-account deployment, to access resources that are in a
different AWS accounts, the IAM role for the user who deploys the
applicaon template must have full SQS access permissions and a trust
relaonship that authorizes her to write to the SQS queue that belongs
to the firewall template.

Collect the details
required for a
cross-account
deployment.

For a deployment where the firewall template and the applicaon
template are in different accounts, the account that hosts the firewall
template resources is the trusng account and the other AWS
account(s) that hold the applicaon template resources are the trusted
accounts. To launch the applicaon template in a cross-account
deployment, you need the following informaon:

• Cross-account Role Amazon Resource Name (ARN) of the account
in which you are deploying the applicaon template.

• External ID, which you defined when creang the IAM role that
grants full SQS access to the trusng account.

• The 10-digit account number for every AWS account in which you
plan to launch the applicaon template. Because the account that
hosts the firewall template resources serves as a trusng account,
and it owns the resources that the users of the applicaon template
need, you need to list the account number for each trusted account
that can access the firewall resources.

Create a Support
Account on
the Palo Alto
Networks Support
portal, if you don’t
already have one.

You can opt for the BYOL or PAYG licenses.

• For BYOL, you must register an auth code to your Palo Alto
Networks support account prior to launching the VM-Series Auto
Scaling template and add the auth-code to the /license folder
with filename as authcodes in the bootstrap package. See Launch
the VM-Series Auto Scaling Template for AWS (v2.0) or Launch the
Firewall Template (v2.1) for details.

• For PAYG, you must register the VM-Series firewalls to acvate
your support entlement.

(For PAYG only)
Review and
accept the End
User License

In the AWS Marketplace, search for Palo Alto Networks, and select the
bundle you plan to use. The VM-Series firewalls will fail to deploy if
you have not accepted the EULA for the bundle you plan to use.
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Agreement
(EULA).

Required, if you
are launching
a VM-Series
firewall in an AWS
account for the
first me.

• Search for VM-Series Next Generaon Firewall Bundle 2, for
example.

• Click Connue, and select Manual Launch. Review the agreement
and click Accept Soware Terms to accept the EULA.

You can now close the browser.

Decide whether
you plan to use
the public S3
buckets or your
private S3 bucket
for AWS Lambda,
Python scripts,
and templates.

Palo Alto Networks provides public S3 buckets in all AWS regions
included in the supported regions list. These S3 buckets include all the
templates, AWS Lambda code, and the bootstrap files that you need.

Palo Alto Networks recommends using the bootstrap files in
the public S3 bucket only for evaluang this soluon. For a
producon deployment, you must create a private S3 bucket
for the bootstrap package.

The naming convenon for the S3 bucket is panw-aws-autoscale-
v20-<region_name>. For example, the bucket in the AWS Oregon
region is panw-aws-autoscale-v20-us-west-2.

To use your private S3 bucket, you must download and copy the
templates, AWS Lambda code, and the bootstrap files to your private
S3 bucket. You can place all the required files for both the firewall
template and the applicaon template in one S3 bucket or place them
in separate S3 buckets.
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Download the
templates, AWS
Lambda code, and
the bootstrap files.

• Get the files for deploying the firewall template (applicaon load
balancer and the VM-Series firewalls) from the GitHub repository.

Do not mix and match files across VM-Series Auto
Scaling template versions.

• Templates and Lambda code:

• panw-aws.zip
• firewall-v2.X.template

• Bootstrap files:

• init-cfg.txt
• bootstrap.xml

The bootstrap.xml file bundled with this soluon is designed
to help you get started, and is provided for tesng and
evaluaon only. For a producon deployment, you must
modify the bootstrap.xml prior to launch.

• iam-policy: The user who deploys the VM-Series Auto Scaling
template must have either the administrave privileges or the
permissions listed in this file to successfully launch this soluon.

The firewall template is supported by Palo Alto Networks
Technical Support.

• Get the files for deploying the NLB and the web servers from the
GitHub repository versions 2.0 or 2.1.

• Templates:

• pan_aws_nlb-2.X.template—Use this template to deploy the
applicaon template resources within same VPC as the one
in which you deployed the firewall template (same AWS
account).

• pan_aws_nlb_vpc-2.X.template—Use this template to deploy
the applicaon template resources in a different VPC. This
template allows you to deploy the resources within the same
AWS account or in a different AWS account as long as you
have the appropriate permissions to support a cross-account
deployment.

• pan_nlb_lambda.template—Creates an AWS Network Load
balancer, which mulplexes traffic to register scaled-out
backend web servers.

• Lambda code and Python scripts.

Customize the
bootstrap.xml

To ensure that your producon environment is secure, you must
customize the bootstrap.xml file with a unique administrave
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file for your
producon
environment.

username and password for producon deployments. The default
username and password are pandemo/demopassword. You can also
use this opportunity to create an opmal firewall configuraon with
interfaces, zones, and security policy rules that meet your applicaon
security needs.

Decide whether
you want to
use Panorama
for centralized
logging, reporng,
and firewall
management.

Panorama is an opon for administrave ease and is the best pracce
for managing the firewalls. It is not required to manage the auto scaling
er of VM-Series firewalls deployed in this soluon.

If you want to use Panorama, you can either a Panorama virtual
appliance on AWS or use an M-Series appliance or a Panorama virtual
appliance inside your corporate network.

The Panorama must be in Panorama mode and not
Management Only mode.

To successfully register the firewalls with Panorama, you must collect
the following details:

• API key for Panorama—So that AWS Lambda can make API requests
to Panorama, you must provide an API key when you launch the
VM-Series Auto Scaling template. As a best pracce, in a producon
deployment, create a separate administrave account just for the
API call and generate an associated API key.

• Panorama IP address—You must include the IP address in the
configuraon (init-cfg.txt) file. The firewalls must be able to access
this IP address from the VPC; to ensure a secure connecon, use a
direct connect link or an IPSec tunnel.

• VM auth key—Allows Panorama to authencate the firewalls so that
it can add each firewall as a managed device. You must include this
key in the configuraon (init-cfg.txt) file.

The vm auth key is required for the lifeme of the deployment.
Without a valid key in the connecon request, the VM-Series
firewall will be unable to register with Panorama. For details on the
key, see Generate the VM Auth Key on Panorama.

• Template stack name and the device group name to which to
assign the firewalls—You must first add a template and assign it
to a template stack, create a device group on Panorama, and then
include the template stack name and the device group name in the
configuraon (init-cfg.txt) file.
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In order to reduce the cost and scale limits of using Elasc IP
addresses, the firewalls do not have public IPs. If you are not
using Panorama to manage the firewalls, you must deploy
a jump server (a bason host with an EIP address) that
aaches to the Untrust subnet within the VPC to enable
SSH and/or HTTPS access to the VM-Series firewalls. By
default, this soluon includes an AWS NAT gateway that
the firewalls use to iniate outbound requests for retrieving
updates, connecng to Panorama, and publishing metrics to
AWS CloudWatch.

Get started Launch the VM-Series Auto Scaling Template for AWS (v2.0).

Customize the Firewall Template Before Launch (v2.0 and v2.1)
To simplify the deployment workflow, the firewall displays a limited set of parameters for which
you need to provide inputs when launching the template. If you would like to view and customize
other opons included in the template, you can use a text eding tool such as Notepad or Visual
Studio Code to specify values that you prefer before you launch the VM-Series Auto Scaling
template for AWS v2.0 or 2.1.

Use the following table to view the list of parameters that you are allowed to customize for your
deployment of the auto scaling firewall template for AWS. Modifying parameters from this list is
within the official support policy of Palo Alto Networks through the support opons that you've
purchased.

Parameter Descripon Default Value

CIDR Block for the VPC The IP address space that you want to
use for the VPC.

The subnets you modify
below must belong to this
VPC CIDR block and be
unique.

192.168.0.0/16

Management Subnet CIDR
Block

Comma-delimited list of CIDR blocks for
the management subnet of the firewalls.

192.168.0.0/24,
192.168.10.0/24

Untrust Subnet CIDR Block Comma-delimited list of CIDR blocks for
the Untrust subnet.

192.168.1.0/24,
192.168.11.0/24

Trust Subnet CIDR Block Comma-delimited list of CIDR blocks for
the Trust subnet.

192.168.2.0/24,
192.168.12.0/24
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Parameter Descripon Default Value

NAT Gateway Subnet CIDR
Block

Comma-delimited list of CIDR blocks for
the AWS NAT Gateway.

192.168.100.0/24,
192.168.101.0/24

Lambda Subnet CIDR Block Comma-delimited list of CIDR blocks for
the Lambda funcons.

192.168.200.0/24,
192.168.201.0/24

Firewall Instance size AWS Instance Types and size that you
want for the VM-Series firewalls in your
deployment.

M4.xlarge

Choose your Scaling
Parameter

You do not
need to
modify the
template for
the scaling
parameter.
You can
set AWS
CloudWatch
alarms on
the AWS
console for
one or more
custom PAN-
OS metrics
on which
you want
to trigger
autoscaling.

The template publishes all the following
metrics to AWS CloudWatch:

• CPU—DataPlane CPU Ulizaon
• AS—Acve Sessions
• SU—Session Ulizaon
• SSPU—SSL Proxy Ulizaon
• GPU—GlobalProtect Gateway

Ulizaon
• GPAT—GlobalProtect Gateway

Ulizaon AcveTunnels
• DPB—Dataplane Packet Buffer

Ulizaon

Dataplane CPU
Ulizaon

Choose me in seconds for
Scaling Period

The period in seconds over which the
average stasc is applied. Must be a
mulple of 60.

900

Maximum VM-Series
Instances

Maximum number of VM-Series firewalls
in the auto scaling group.

3

Minimum VM-Series
Instances

Minimum number of VM-Series firewalls
in the auto scaling group.

1

ScaleDown threshold value
in percentage/value

Value at which a scale in event is
triggered.

20
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Parameter Descripon Default Value

ScaleUp threshold value in
percentage/value

Value at which scale out event is
triggered.

80

Launch the VM-Series Auto Scaling Template for AWS (v2.0)
You can choose to deploy the firewall template in one VPC and the sample applicaon template in
the same VPC as the one in which you deployed the firewalls, or in a different VPC.

If the applicaons that you want to secure belong to a separate AWS account, the sample
applicaon template includes support for cross-account deployments. The soluon supports a hub
and spoke architecture whereby you can deploy the firewall template in one AWS account and
use it as a hub to secure your applicaons (spokes) that belong to the same or to different AWS
accounts.

All VM-Series firewall interfaces must be assigned an IPv4 address when deployed in a
public cloud environment. IPv6 addresses are not supported.

• Launch the VM-Series Firewall Template
• Launch the Applicaon Template
• (Required only if you deploy more than one internal load balancer) Enable Traffic to the ELB

Service (v2.0 and v2.1)

Launch the VM-Series Firewall Template

This workflow tells you how to deploy the applicaon load balancer and the VM-Series firewalls
using the firewall template.

This firewall template includes an AWS NAT gateway that the firewalls use to iniate
outbound requests for retrieving updates, connecng to Panorama, and publishing metrics
to AWS CloudWatch. If you are not using Panorama to manage the firewalls, you must
deploy a jump server (a bason host with an EIP address) that aaches to the Untrust
subnet within the VPC to enable SSH and/or HTTPS access to the VM-Series firewalls.
This jump server is required because the management interface on the VM-Series firewalls
has a private IP address only.

STEP 1 | Review the checklist for Plan the VM-Series Auto Scaling Template for AWS (v2.0).

Make sure that you have completed the following tasks:

• (For PAYG only) Reviewed and accepted the EULA for the PAYG bundle you plan to use.
• (For BYOL only) Obtained the auth code. You need to enter this auth code in the /license

folder of the bootstrap package.
• Downloaded the files required to launch the VM-Series Auto Scaling template from the

GitHub repository.
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STEP 2 | Modify the init-cfg.txt file. You must add the device cerficate auto-registraon PIN to the
init-cfg.txt file to automacally install a device cerficate when your VM-Series firewall
instance is deployed.

vm-series-auto-registration-id=

vm-series-auto-registration-pin-value=

For more details read about the bootstrapping process and the init-cfg.txt file.

If you’re using Panorama to manage the firewalls, complete the following tasks:

1. Generate the VM Auth Key on Panorama. The firewalls must include a valid key in the
connecon request to Panorama. Set the lifeme for the key to 8760 hours (1 year).

2. Open the init-cfg.txt file with a text editor, such as Notepad. Make sure that you do
not alter the format as this causes a failure in deploying the VM-Series Auto Scaling
template. Add the following informaon as name-value pairs:

• IP addresses for the primary Panorama and oponally a secondary Panorama. Enter:

panorama-server=

panorama-server-2=
• Specify the template stack name and the device group to which you want to assign

the firewall. Enter:

tplname=

dgname=
• VM auth key. Enter:

vm-auth-key=
3. Verify that you have not deleted the command for swapping the management interface

(mgmt) and the dataplane interface (ethernet 1/1) on the VM-Series firewall on AWS. For
example, the file must include name-value pairs as shown here:

op-command-modes=mgmt-interface-swap

vm-auth-key=755036225328715

panorama-server=10.5.107.20

panorama-server-2=10.5.107.21

tplname=FINANCE_TG4

dgname=finance_dg
4. Save and close the file.

STEP 3 | (For BYOL only) Add the license auth code in the /license folder of the bootstrap package.
For more informaon see Prepare the Bootstrap Package.
1. Create a new .txt file with a text editor, such as Notepad.
2. Add the authcode for your BYOL licenses to this file,then save the file with authcodes

(no file extension) and upload it to the /license folder. The auth code must support the
number of firewalls that may be required for your deployment. You must use an auth
code bundle instead of individual auth codes so that the firewall can simultaneously fetch
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all license keys associated with a firewall. If you use individual auth codes instead of a
bundle, the firewall retrieves only the license key for the first auth code included in the
file.

STEP 4 | Change the default credenals for the VM-Series firewall administrator account defined in
the bootstrap.xml file.

Required for using the VM-Series Auto Scaling template in a producon environment.

The bootstrap.xml file in the GitHub repository is provided for tesng and evaluaon only. For
a producon deployment, you must Customize the Bootstrap.xml File (v2.0) prior to launch.
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STEP 5 | Prepare the Amazon Simple Storage (S3) buckets for launching the VM-Series Auto Scaling
template to a producon environment.

Make sure to create the S3 buckets in the same region in which you plan to deploy the
template; the bootstrapping files hosted in the public S3 bucket are provided only to
make it easier for you to evaluate the template.

1. Create a new S3 bucket for the bootstrap files.

1. Sign in to the AWS Management Console and open the S3 console.
2. Click Create Bucket.
3. Enter a Bucket Name and a Region, and click Create. The bucket must be at the S3

root level. If you nest the bucket, bootstrapping fails because you cannot specify a
path to the locaon of the bootstrap files.

2. Upload the bootstrap files to the S3 bucket. The bootstrap folders must be in the root
folder of the S3 bucket.

1. Click the name of bucket and then click Create folder.
2. Create the following folder structure for bootstrapping.

3. Click the link to open the config folder.
4. Select Acons > Upload and Add Files, browse to select the init-cfg.txt file and

bootstrap.xml file, and click Open.
5. Click Start Upload to add the files to the config folder. The folder can contain only

two files: init-cfg.txt and the bootstrap.xml.

6. (For BYOL only) Click the link to open the license folder and upload the txt file with
the auth code required for licensing the VM-Series firewalls.
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3. Upload the AWS Lambda code (panw-aws.zip file) to an S3 bucket. In this example, the
AWS Lambda code is in the same S3 bucket as the bootstrap package.

1. Click the bucket name.
2. Click Add Files to select the panw-aws.zip file, click Open.
3. Click Start Upload to add the zip file to the S3 bucket.

STEP 6 | Select the firewall template.

If you need to Customize the Firewall Template Before Launch (v2.0), do that now and select
the modified template.

1. In the AWS Management Console, select CloudFormaon > Create Stack.
2. Select Upload a template to Amazon S3, choose the firewall-v2.0.template and click

Open and Next.
3. Specify the Stack name. The stack name allows you to uniquely idenfy all the resources

that this template deploys.

STEP 7 | Configure the parameters for the VPC.
1. Enter the parameters for the VPC Configuraon as follows:

1. Enter a VPCName.
2. Select the two Availability Zones that your setup spans in Select two AZs.
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STEP 8 | Select your preferences for the VM-Series firewalls.

1. Look up the AMI ID for the VM-Series firewall and enter it. Make sure that the AMI ID
matches the AWS region, PAN-OS version and the BYOL or PAYG licensing opon you
opted to use.

2. Select the EC2 Key pair (from the drop-down) for launching the firewall. To log in to the
firewalls, you must provide the name of this key pair and the private key associated with
it.

3. Restrict SSH access to the firewall’s management interface. Make sure to supply a CIDR
block that corresponds to your dedicated management IP addresses or network. Do not
make the allowed source network range larger than necessary and do not ever configure
the allowed source as 0.0.0.0/0. Verify your IP address before configuring it on the
template to make sure that you do not lock yourself out.

4. Select Yes if you want to Enable Debug Log. Enabling the debug log generates more
verbose logs that help with troubleshoong issues with the deployment. These logs are
generated using the stack name and are saved in AWS CloudWatch.

By default, the template uses CPU ulizaon as the scaling parameter for the VM-Series
firewalls. Custom PAN-OS metrics are automacally published to the CloudWatch namespace
that matches the stack name you specified earlier.

STEP 9 | Specify the name of the Amazon S3 bucket(s).

You can use one S3 bucket for the bootstrap package and the zip file.

1. Enter the name of the S3 bucket that contains the bootstrap package.

If the bootstrap bucket is not set up properly or if you enter the bucket name incorrectly,
the bootstrap process fails and you cannot be able to log in to the firewall. Health checks
for the load balancers also fail.

2. Enter the name of the S3 bucket that contains the panw-aws.zip file.
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STEP 10 | Specify the keys for enabling API access to the firewall and Panorama.

1. Enter the key that the firewall must use to authencate API calls. The default key
is based on the sample bootstrap.xml file and you should only use it for tesng and
evaluaon. For a producon deployment, you must create a separate PAN-OS login just
for the API call and generate an associated key.

2. Enter the API Key to allow AWS Lambda to make API calls to Panorama, if you are using
Panorama for centralized management. For a producon deployment, you should create
a separate login just for the API call and generate an associated key.

3. Copy and paste the license deacvaon API key for your account. This key is required
to successfully deacvate licenses on your firewalls when a scale-in event occurs. To get
this key:

1. Log in to the Customer Support Portal.
2. Select Assets > API Key Management.
3. Copy the API key.

STEP 11 | Enter the name for the applicaon load balancer.

STEP 12 | (Oponal) Apply tags to idenfy the resources associated with the VM-Series Auto Scaling
template.

Add a name-value pair to idenfy and categorize the resources in this stack.

STEP 13 | Review the template sengs and launch the template.
1. Select I acknowledge that this template might cause AWS CloudFormaon to create

IAM resources.
2. Click Create to launch the template. The CREATE_IN_PROGRESS event displays.
3. On successful deployment the status updates to CREATE_COMPLETE.

Unless you customized the template, the VM-Series Auto Scaling template launches
an ASG that includes one VM-Series firewall in each AZ, behind the applicaon load
balancer.
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STEP 14 | Verify that the template has launched all required resources.
1. On the AWS Management Console, select the stack name to view the Output for the list

of resources.

2. On the EC2 Dashboard, select Auto Scaling Groups. Verify that in each AZ, you have one
ASG for the VM-Series firewalls with the one firewall in each ASG. The ASG name prefix
includes the stack name.

3. Log in to the VM-Series firewall. You must deploy a jump server or use Panorama to
access the web interface on the firewall.

• It can take up to 20 minutes for the firewalls to boot up and be available to
handle traffic.

• When you finish tesng or a producon deployment, the only way to ensure
charges stop occurring is to completely delete the stack. Shung down
instances, or changing the ASG maximum to 0 is not sufficient.

STEP 15 | Save the following informaon. You need to provide these values as inputs when deploying
the applicaon template.

• IP addresses of the NAT Gateway in each AZ. You need this IP address to restrict HTTP
access to the web servers if you deploy the applicaon in a different VPC. Specifying this
IP address ensures that the firewall secures access your applicaons in a different VPC,
and that nobody can bypass the firewall to directly access the web server. The sample
applicaon template (panw_aws_nlb_vpc-2.0.template) displays a template validaon error
if you do not enter the NAT Gateway IP addresses; you must enter the IP addresses as a
comma-separated list.

• Network Load Balancer SQS URL. An AWS Lambda funcon in the firewall stack monitors
this queue so that it can learn about any network load balancers that you deploy, and create
NAT policy rules (one per applicaon) on the VM-Series firewalls that enable the firewalls to
send traffic to the network load balancer IP address.

Launch the Application Template

The applicaon template allows you to complete the sandwich topology and is provided so that
you can evaluate the auto scaling soluon. This applicaon template deploys a network load
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balancer and a pair of web servers behind the auto scaling group of VM-Series firewalls, which you
deployed using the firewall template. The web servers in this template have a public IP address for
direct outbound access to retrieve soware updates. Use this template to evaluate the soluon,
but build your own template to deploy to producon. For a custom template, make sure to enable
SQS Messaging Between the Applicaon Template and Firewall Template.

When launching the applicaon template, you must select the template based on whether you
want to deploy the applicaon template within the same VPC (panw_aws_nlb-2.0.template) in
which you deployed the firewall template or in a separate VPC (panw_aws_nlb_vpc-2.0.template).
For a separate VPC, the template provides supports for cross-account deployments. A cross-
account deployment requires you to create an IAM role and enable permissions and trust
relaonship between the trusng AWS account and the trusted AWS account, and the account
informaon is required as input when launching the template.

STEP 1 | (Required only for a cross-account deployment) Create the IAM role. Refer to AWS
documentaon.

This role grants access to a user who belongs to a different AWS account. This user requires
permissions to access the Simple Queue Service (SQS) resource in the firewall template. The
firewall uses this queue to learn about each network load balancer that you deploy so that
it can create NAT policy to send traffic to the web servers that are behind the network load
balancer.

• For Account ID, type the AWS account ID of the account into which you are deploying the
applicaon template. Specifying that account ID allows you to grant access to the resources
in your account that hosts the firewall template resources.

• Select Require external ID and enter a value that is a shared secret. Specifying an external
ID allows the user to assume the role only if the request includes the correct value.

• Choose Permissons to allow Amazon SQS Full Access.
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STEP 2 | Use the Palo Alto Networks public S3 bucket or prepare your private (S3) bucket for
launching the applicaon template.
1. Create a zip file with all the files in the GitHub repository, excluding the three .template

files, named nlb.zip in the screenshot below.
2. Upload the zip file to the S3 bucket you created earlier or to a new bucket.

3. Copy the pan_nlb_lambda template into the same bucket to which you copied the nlb.zip
file.

STEP 3 | Select the applicaon template to launch.
1. In the AWS Management Console, select CloudFormaon > Create Stack.
2. Select Upload a template to Amazon S3, to choose the panw_aws_nlb-2.0.template to

deploy the resources that the template launches within the same VPC as the firewalls, or
the panw_aws_nlb_vpc-2.0.template to deploy the resources in to a different VPC. Click
Open and Next.

3. Specify the Stack name. The stack name allows you to uniquely idenfy all the resources
that are deployed using this template.

VM-Series Deployment Guide Version Version 10.1 461 ©2022 Palo Alto Networks, Inc.

https://github.com/PaloAltoNetworks/pan_nlb_v1
https://github.com/PaloAltoNetworks/pan_nlb_v1


Set Up the VM-Series Firewall on AWS

STEP 4 | Configure the parameters for the VPC and network load balancer.
1. Select the two Availability Zones that your setup will span in Select list of AZ. If you are

deploying within the same VPC make sure to select the same Availability Zones that you
selected for the firewall template.

2. Enter a CIDR Block for the VPC. The default CIDR is 192.168.0.0/16.

3. (Only if you are using the panw_aws_nlb-2.0.template to deploy the applicaons within
the same VPC)

Select the VPC ID and the Subnet IDs associated with the trust subnet on the firewalls
in each AZ. The network load balancer is aached to the trust subnet on the firewalls, to
complete the load balancer sandwich topology.

4. Enter a name for the network load balancer.

STEP 5 | Configure the parameters for AWS Lambda.

1. Enter the S3 bucket name where nlb.zip and the pan_nlb_lambda.template is stored.
2. Enter the name of the pan_nlb_lambda.template and the zip file name.
3. Paste the SQS URL that you copied earlier.
4. Enter a unique TableName. This table stores a mapping of the port and IP address for the

applicaons associated with the network load balancer in your deployment.

When you delete the applicaon stack this table is deleted. Therefore, if mulple
instances of the network load balancer write to the same table and the table is deleted,
the NAT rules on the firewalls not funcon properly and the applicaon traffic maybe be
inaccurately forwarded to the wrong port/network load balancer.

STEP 6 | Modify the web server EC2 instance type to meet your deployment needs.

STEP 7 | Select the EC2 Key pair (from the drop-down) for launching the web servers. To log in to the
web servers, you must provide the key pair name and the private key associated with it.
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STEP 8 | (Only if you are using the panw_aws_nlb_vpc-2.0.template) Lock down access to the web
servers.

1. Restrict SSH From access to the web servers. Only the IP addresses you list here can log
in to the web servers.

2. Restrict HTTP access to the web servers. Enter the public IP addresses of the NAT
gateway from the firewall template output, and make sure to separate IP addresses with
commas. Entering the NAT gateway IP address allows you to ensure that all web traffic
to the applicaon servers are secured by the VM-Series firewalls.

STEP 9 | (Only if you are using the panw_aws_nlb_vpc-2.0.template) Configure the other parameters
requires to launch the applicaon template stack in a different VPC.

1. Select SameAccount true if you are deploying this applicaon template within the same
AWS account as the firewall template, and leave the cross account role and external ID
blank; select false for a cross-account deployment.

For a cross-account deployment, enter the Amazon Resource Number (ARN) for the
CrossAccountRole and ExternalId that you defined in (Required only for a cross-account
deployment) Create the IAM role. Refer to AWS documentaon.You can get the ARN
from Support > Support Center on the AWS Management Console.

2. Enter the VPC Namein which you want to deploy the applicaon template resources.
3. Oponal Change the NLBSubnetIPBlocks for the Management subnet for the network

load balancer.

STEP 10 | Review the template sengs and launch the template.
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STEP 11 | Verify that the network load balancer is deployed and in a ready state.

STEP 12 | Get the DNS name for the applicaon load balancer, and enter it into a web browser.

For example: hp://MVpublic-elb-123456789.us-east-2.elb.amazonaws.com/

When the web page displays, you have successfully launched the auto scaling template.

STEP 13 | Verify that each firewall has a NAT policy rule to the IP address of each network load
balancer.

When you deploy the applicaon template to launch another instance of a network load
balancer and pair of web servers, the firewall learns about the port allocated for the next
network load balancer instance and creates another NAT policy rule. So, if you deploy the
applicaon template three mes, the firewall has three NAT policy rules for ports 81, 82, and
83.

STEP 14 | If you have launched the applicaon template more than once, you need to Enable Traffic to
the ELB Service.

Enable Traffic to the ELB Service (v2.0 and v2.1)

If you add a second or addional internal load balancers (ILBs) in your deployment, you must
complete addional configuraon so that the internal load balancer, the VM-Series firewalls auto
scaling groups, and the web servers can report as healthy and traffic is load balanced across all
your AWS resources.

In v2.0, the ILB can only be a network load balancer. In v2.1 the ILB can be an applicaon
load balancer or a network load balancer.
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STEP 1 | On the AWS management console, verify the ports allocated for each network balancer on
the DynamoDB table.

When you launch a new internal load balancer, the applicaon template must send an SQS
message to the SQS URL you provided as input when you launched the template. The AWS
Lambda funcon in the firewall template monitors the SQS and adds the port mapping to the
DynamoDB table for the firewall template. Starng at port 81, the port allocated for every
addional internal load balancer you deploy increments by 1. So, the second internal load
balancer uses port 82, and the third port uses port 83.

1. Select the DynamoDB service on the AWS management console.
2. Select Tables and click the table that matches the stack name for your firewall template.

For example, MV-CFT20-firewall-us-east-2.

In the Items list, view the ports used by the internal load balancers that are publishing to
the SQS associated with the firewall template.

STEP 2 | Create a target group. The internal load balancer sends requests to registered targets using
the port and protocol that you specify for the servers in the target group.

When you add a new target group, use the port informaon that you verified on the
DynamoDB table.
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STEP 3 | Edit the listener rules on the internal load balancer to route requests to the target web
servers.
1. On the AWS management console, select Load Balancers in the Load Balancing secon,

and select the internal load balancer that matches your stack name.
2. Select View/edit rules to modify the rules for the listener.
3. Select Insert rule and add a path-based route to forward traffic to the target group you

defined above as follows:

STEP 4 | Aach the target group to both VM-Series firewalls auto scaling groups.
1. Select Auto Scaling Groups in the Auto Scaling secon and select an auto scaling group

that matches the stack name.
2. Select Details > Editand select the new target group from the Target Groups drop-down.

STEP 5 | Log in to each web server that was deployed by the applicaon template, create a new
directory with the target group name and copy the index.html file into the directory. Unl
you set up the path to the index.html file, the health check for this web server reports as
unhealthy.

sudo su
cd/var/www/html
mkdir <target-groupname>
cp index.html <target-groupname>
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STEP 6 | Verify the health status of the web servers.

Select Auto Scaling Groups, and use the applicaon stack name to find the webserver auto
scaling group to verify that the web servers are reporng healthy.

Customize the Bootstrap.xml File (v2.0)
The bootstrap.xml file provided in the GitHub repository uses a default username and password
for the firewall administrator. Before deploying the VM-Series Auto Scaling template in a
producon environment, at a minimum, you must create a unique username and password for the
administrave account on the VM-Series firewall. Oponally, you can fully configure the firewall
with zones, policy rules, security profiles and export a golden configuraon snapshot. You can then
use this configuraon snapshot as the bootstrap.xml file for your producon environment.

You have two ways to customize the bootstrap.xml file for use in a producon environment:

• Opon 1: Launch a VM-Series firewall on AWS using the bootstrap files provided in the GitHub
repository, modify the firewall configuraon and export the configuraon to create a new
bootstrap.xml file for the VM-Series Auto Scaling template. See Use the GitHub Bootstrap Files
as Seed.

• Opon 2: Launch a new VM-Series firewall on AWS without using the bootstrap files, add a
NAT policy rule to ensure that the VM-Series firewall handles traffic properly, and export the
configuraon to create a new bootstrap.xml file for the VM-Series Auto Scaling template. See
Create a new Bootstrap File from Scratch.

If you have deployed the template and now need to change the credenals for the
administrave user or add a new administrave user and update the template stack,
see Modify Administrave Account and Update Stack.

Create a new Bootstrap File from Scratch

Launch a new VM-Series firewall on AWS using the AMI for a supported PAN-OS version (see
the compability matrix for Panorama plugins), without using the sample bootstrap.xml file, and
export the configuraon to create a new bootstrap.xml file for use with the VM-Series Auto
Scaling template v2.0.

STEP 1 | Deploy the VM-Series Firewall on AWS (no bootstrapping required) and use the public IP
address to SSH into the Command Line Interface (CLI) of the VM-Series firewall. You will
need to configure a new administrave password for the firewall.

STEP 2 | Log in to the firewall web interface.

STEP 3 | (Oponal) Configure the firewall. You can configure the dataplane interfaces, zones and
policy rules.
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STEP 4 | Commit the changes on the firewall.

STEP 5 | Export the configuraon file and name it as bootstrap.xml. (Device > Setup > Operaon
> Export Named Configuraon Snapshot).

STEP 6 | Download the bootstrap.xml file from the GitHub repository, open it with a text eding tool,
and copy lines 353 to 356. These lines define the AWS CloudWatch namespace to which the
firewall publishes custom PAN-OS metrics that are required for the firewalls to auto scale.

STEP 7 | Edit the configuraon file you exported earlier to include the AWS CloudWatch informaon.
Search for </management> and paste the lines 353 to 356 aer </management>.

STEP 8 | Delete the management interface configuraon.

1. Search for </service> and delete the ip-address, netmask and default gateway that
follow.

2. Search for </type> and delete the ip-address, netmask, default gateway, and public-key
that follow.

STEP 9 | Save the file. You can now proceed with Launch the VM-Series Auto Scaling Template for
AWS (v2.0).

Use the GitHub Bootstrap Files as Seed

Launch a VM-Series firewall on AWS from the AWS Marketplace using the bootstrap files
provided in the GitHub repository, modify the firewall configuraon for your producon
environment. Then, export the configuraon to create a new bootstrap.xml file that you can now
use for the VM-Series Auto Scaling template.

STEP 1 | To launch the firewall see Bootstrap the VM-Series Firewall on AWS.
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STEP 2 | Add an elasc network interface (ENI) and associate an elasc IP address (EIP) to it, so that
you can access the web interface on the VM-Series firewall. See Launch the VM-Series
Firewall on AWS for details.

STEP 3 | Use the EIP address to log in to the firewall web interface with admin as the username and
password.

STEP 4 | Add a secure password for the administrave user account (Device > Local User Database >
Users).

STEP 5 | (Oponal) Configure the firewall for securing your producon environment.

STEP 6 | Commit the changes on the firewall.

STEP 7 | Generate a new API key for the administrator account. Copy this new key to a new file. You
will need to enter this API key when you launch the VM-Series Auto Scaling template; the
AWS services use the API key to deploy the firewall and to publish metrics for auto scaling.

STEP 8 | Export the configuraon file and save it as bootstrap.xml. (Device > Setup > Operaon >
Export Named Configuraon Snapshot).

STEP 9 | Open the bootstrap.xml file with a text eding tool and delete the management interface
configuraon.

STEP 10 | (Required if you exported a PAN-OS 8.0 configuraon) Ensure that the seng to validate the
Palo Alto Networks servers is disabled. Look for <server-verification>no</server-
verification>.

STEP 11 | If the check is yes, change it to no.

STEP 12 | Save the file. You can now proceed with Launch the VM-Series Auto Scaling Template for
AWS (v2.0).

SQS Messaging Between the Applicaon Template and Firewall Template
So that the VM-Series firewalls deployed using the firewall-v2.0.template can detect and send
traffic to the network load balancers to which you want to automacally distribute incoming
traffic, the firewall template includes a lambda funcon that monitors a Simple Queue Service for
messages. The message allows the lambda funcon to learn about a new network load balancer
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and then automacally create a NAT policy rule on the firewall to send traffic to the IP address
of the network load balancer. In order to route traffic properly within the AWS infrastructure,
the message must also include basic informaon on the DNS, VPC ID, and the AZ to which the
network load balancer belongs.

If you are building your own applicaon template, you must set up your applicaon template
to post two types of messages to the SQS URL that the firewall template in the VM-Series
autoscaling template version 2.0 uses to learn about network load balancers to which it must
distribute traffic in your environment:

• ADD-NLB message that informs the firewalls when a new network load balancer is available.
• DEL-NLB message that informs the firewalls when a network load balancer has been

terminated and is no longer available.

The following examples of each message type includes sample values. You need to modify these
message with values that match your deployment.

ADD-NLB Message

msg_add_nlb= { 'MSG-TYPE': 'ADD-NLB', 'AVAIL-ZONES': [{'NLB-
IP':'192.168.2.101', 'ZONE-NAME':'us-east-2a', 'SUBNET-ID':
 'subnet-2a566243'}, {'NLB-IP':'192.168.12.101', 'ZONE-NAME':'us-
east-2b', 'SUBNET-ID': 'subnet-2a566243 '}], 'DNS-NAME':
 'publicelb1-2119989486.us-east-2.elb.amazonaws.com', 'VPC-ID':
 'vpc-42ba9f2b', 'NLB-NAME': 'publicelb1' }

DEL-NLB Message

msg_del_nlb= { 'MSG-TYPE': 'DEL-NLB', 'DNS-NAME':
 'publicelb1-2119989486.us-east-2.elb.amazonaws.com', }

Refer to the AWS documentaon for details on how to send a message to an Amazon SQS Queue,
or review the describe_nlb_dns.py in the sample applicaon template package to see how the
applicaon template constructs the messages.

Stack Update with VM-Series Auto Scaling Template for AWS (v2.0)
A stack update allows you to modify the resources that the VM-Series Auto Scaling template—
firewall-v2.0.template—deploys. Instead of deleng your exisng deployment and redeploying the
soluon, use the stack update to modify the following parameters:

• License—Switch from BYOL to PAYG and vice versa or switch from one PAYG bundle to
another.

• Other stack resources— Change the launch configuraon parameters such as the Amazon
Machine Image (AMI) ID, the AWS instance type, key pair for your auto scaling groups. You can
also update the API key associated with the administrave user account on the firewall.

Changing the AMI-ID allows you to deploy new instances of the VM-Series firewalls
with a different PAN-OS version.

When you deploy the VM-Series Auto Scaling template, the auto scaling groups and the launch
configuraon are automacally created for you. The launch configuraon is a template that an
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auto scaling group uses to launch EC2 instance, and it specifies parameters such as the AMI ID,
the instance type, key pair for your auto scaling group. To launch VM-Series firewalls with your
updated parameters, you must first update the stack and then delete the exisng auto scaling
groups in each AZ. To prevent service disrupon, delete the auto scaling group in one AZ first, and
wait for the new firewall instances to launch with the updated stack parameters. Then, verify that
the firewalls have inherited the updates you made before you proceed to complete the changes in
the other AZ.

For crical applicaons, perform a stack update during a maintenance window.

You can update stack directly or create change sets. The workflow in this document takes you
through the manual stack update.

STEP 1 | In the AWS CloudFormaon console, select the parent stack that you want to update and
choose Acons > Update Stack.

STEP 2 | Modify the resources that you want to update.

• PAN-OS version—To modify the PAN-OS version look up the AMI ID for the version you
want to use and enter the ID.

• License opon—Switch from BYOL to PAYG or across PAYG bundles 1 and 2.

If you’re switching to BYOL, make sure to include the auth code in the bootstrap package (See
steps 3 and 5).

If you’re switching between PAYG bundle version 1 and 2, look up the AMI ID for the VM-
Series firewall.

• Other stack resources— You can modify the AMI ID, the instance type, security group, key
pair for the stack resources, or the API key associated with the administrave user account
on the firewall.

If you create a new administrave user account or modify the credenals of the exisng
administrator on the firewall, in order to update that stack and deploy new firewalls with the
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updated API key, you need to follow the workflow in Modify Administrave Account and
Update Stack.

STEP 3 | Acknowledge the noficaons and review the changes and click Update to iniate the stack
update.

STEP 4 | On the EC2 dashboard > Auto Scaling Groups and pick an AZ in which to delete the ASG.

Deleng an ASG automacally triggers the process of redeploying a new ASG. The firewalls in
the new ASG use the updated stack configuraon.

STEP 5 | Verify that the updated parameters are used to launch the VM-Series firewalls in the new
ASG.

Use a phased rollout process, where you test the new ASG thoroughly and ensure that the
firealls are properly handling traffic. Then, wait one hour before connuing to the next ASG.

STEP 6 | Repeat steps 4 and 5 to replace the ASG in the other AZ.

Modify Administrave Account and Update Stack (v2.0)
If you have already deployed the template and now want to change the password for the
administrave account or create a new administrave user account on the VM-Series firewall,
you must generate a new API key and update the template stack with the new API key for the
administrave user account. And in order to ensure that new firewall instances are configured
with the updated administrave user account, you need to export the firewall configuraon
and rename it to bootstrap.xml, then upload it to the S3 bootstrap folder that the VM-Series
AutoScaling template uses.
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STEP 1 | Log in to the web interface of the firewall and change the credenals for an exisng
administrave user or create a new account.

STEP 2 | Generate the API key.

STEP 3 | Export the current running configuraon and rename it to bootstrap.xml.

STEP 4 | Upload this bootstrap.xml file to the S3 bootstrap folder; see Customize the Bootstrap.xml
File (v2.0).

STEP 5 | Update the API key in the stack to ensure that newly launched firewalls will have the
updated administrator account.

See Stack Update with VM-Series Auto Scaling Template for AWS (v2.0).

VM-Series Auto Scaling Templates for AWS Version 2.1
The VM-Series Auto Scaling templates enable you to deploy a single auto scaling group (ASG) of
VM-Series firewalls to secure inbound traffic from the internet to your applicaon workloads on
AWS. You can deploy the VM-Series firewall ASG and the applicaon workloads within a single
VPC as shown below.

You can also deploy the firewall ASG in a centralized VPC and your applicaon workloads in
separate VPCs within the same region, forming a hub and spoke architecture, as shown below.
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With the hub and spoke architecture you can streamline the delivery of centralized security and
connecvity for AWS deployments with many applicaons, VPCs, or accounts. This architecture
can increase agility. Your network security administrators manage the firewall VPC, and DevOps
administrators or applicaon developers can manage the applicaon VPCs.

Ensure that the applicaon VPCs connected to the firewall VPC, do not have an Internet
Gateway (IGW), and use a connuous monitoring and security compliance service such as
Prisma Public Cloud.

You can use a single AWS account or mulple AWS accounts to monitor and secure traffic
between VPCs and the internet. Centralizing firewalls in a single VPC can reduce costs for
deployments with mulple VPCs and/or mulple accounts.

To provide flexibility with securing your applicaon workloads, version 2.1 allows you to deploy
an applicaon load balancer or a network load balancer for both the external load balancer
that fronts your VM-Series firewall ASG, and the internal load balancer (ILB) that fronts your
applicaon workloads.

When an applicaon load balancer fronts the applicaon workloads, you can connect the firewall
VPC to the applicaon VPC using VPC peering. When an NLB fronts the applicaon workloads
you can use VPC Peering or an AWS Private Link to connect the firewall and applicaon VPCs, as
summarized below:

Firewall VPC LB(External) Applicaon VPC LB (Internal) Connecon Method

ALB NLB AWS Private Link

NLB NLB AWS Private Link

NLB ALB VPC Peering
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Firewall VPC LB(External) Applicaon VPC LB (Internal) Connecon Method

ALB ALB VPC Peering

If you deploy in a single VPC you can use all the load balancing combinaons in the previous table.

You can deploy the templates in both and greenfield (new VPC and applicaons) and brownfield
(exisng VPC and applicaons) use cases.

Template New Exisng

Firewall firewall-new-vpc-v2.1.template

panw-aws-same-vpc-v2.1.template

firewall-exisng-vpc-v2.1.template

panw-aws-same-vpc-v2.1.template

Applicaon panw-aws-nlb-new-vpc-
v2.1.template

panw-aws-alb-new-vpc-
v2.1.template

panw-aws-alb-exisng-vpc-
v2.1.template

panw-aws-nlb-exisng-vpc-
v2.1.template

What Components Do the VM-Series Auto Scaling Template for AWS (v2.1) Leverage?
The VM-Series Auto Scaling template for AWS includes the following building blocks.

• VM-Series Firewall Templates
• Applicaon Templates
• Lambda Funcons
• Panorama
• Bootstrap Files

VM-Series Firewall Templates

The firewall templates deploy an internet-facing external load balancer and VM-Series firewalls
within an auto scaling group that spans a minimum of two Availability Zones (AZs). The external
load balancer distributes incoming VPC traffic across the pool of VM-Series firewalls. It can be
an applicaon load balancer (ALB) or a network load balancer (NLB). The VM-Series firewalls
automacally publish custom PAN-OS metrics that enable auto scaling.

Template Descripon

firewall-new-vpc-v2.1.template Deploys a firewall stack with two to four availability
zones in a new VPC.

firewall-exisng-vpc-v2.1.template Deploys a firewall stack with two to four availability
zones in an exisng VPC.

To deploy in an exisng VPC you must enter:

• VPC ID
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Template Descripon
• Internet Gateway ID. This is an exisng gateway.
• Subnet CIDR lists for the Management, Untrust, Trust,

NAT Gateway and Lambda subnets. The template
uses the CIDRs to create these subnets.

If you choose to create a new ELB, the template
connects the firewall ASG to the ELB backend pool. If
you use an exisng ELB, you must manually connect the
firewall ASG to the exisng load balancer backend.

See Customize the Firewall Template Before Launch (v2.0 and v2.1) for more on these parameters.

Application Templates

The applicaon template deploys an internal load balancer (ILB) and one auto scaling group with a
web server in each availability zone (AZ).

Template Descripon

panw-aws-same-vpc-v2.1.template Deploy applicaon in same VPC as the firewall
VPC. You can choose a network or applicaon
load balancer.

panw-aws-alb-new-vpc-v2.1.template Deploy applicaon in a new VPC, using ALB as
the internal load balancer, and using VPC Peering
between the firewall VPC and applicaon VPC.
Supports both same account and cross-account
deployments.

You must supply the following parameters:

• Hub account ID
• Hub VPC ID for VPC peering
• Hub VPC trust subnet CIDRs. The template

uses these for route table construcon aer
VPC peering is established, one CIDR per
availability zone.

• StsAssumeRoleARN (output from the Hub
template for SQS access)

panw-aws-nlb-new-vpc-v2.1.template Deploy applicaon in a new VPC, using NLB
as the internal load balancer, and using NLB
Endpoint Services/Interfaces to communicate
between the firewall VPC and applicaon VPC.

You must supply these parameters.

• Hub account ID
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Template Descripon
• StsAssumeRoleARN (output from the Hub

template for SQS access)

panw-aws-alb-exisng-vpc-v2.1.template Deploy ALB in an exisng Applicaon VPC. You
must supply the VPC ID for your applicaon, and
an exisng Subnet ID.

This template deploys the load balancer in the
applicaon VPC and establishes the lambda
resources. You must detach your target workload
from any exisng load balancer, and connect it to
the new load balancer.

panw-aws-nlb-exisng-vpc-v2.1.template Deploy NLB in an exisng Applicaon VPC.
Deploy applicaon in a new VPC, using NLB
as the internal load balancer, and using NLB
Endpoint Services/Interfaces to communicate
between the firewall VPC and applicaon VPC.

Lambda Functions

AWS Lambda provides robust, event-driven automaon without the need for complex
orchestraon soware. AWS Lambda monitors a Simple Queue Service (SQS) to learn about
load balancers (ALBs or NLBs) that publish to the queue. When the Lambda funcon detects
a new load balancer, it creates a new NAT policy rule and applies it to the VM-Series firewalls
within the ASG. The firewalls have a NAT policy rule for each applicaon, and the firewalls use the
NAT policy rule (that maps the port to the load balancer IP address) to forward traffic to the load
balancer in front of the applicaon web servers.

The Lambda funcons also delete all the configuraon items that Lambda added to the device
group and template stack in Panorama. This includes the NAT rule, Address Object, and Stac
Routes that were pushed to the VM-Series firewall. The Lambda funcon handles delicensing as
well.

To learn more about the Lambda funcons, refer to the
Palo Alto Networks AWS AutoScale Documentaon.

Panorama

You must have Panorama management server in Panorama mode to configure Auto Scaling v2.1.

The Panorama management server provides centralized monitoring and management of mulple
Palo Alto Networks next-generaon firewalls from a single locaon. Panorama allows you to
oversee all applicaons, users, and content traversing your network, and use this knowledge to
create applicaon enablement policies that protect and control the network. If you are not familiar
with Panorama please see the Panorama Administrator’s Guide.

Managed firewalls are bootstrapped with an init-config.txt file. A sample file is included in
the GitHub repository so that you can copy the configuraon from the template stack and device
group when you create them in your exisng Panorama.
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The untrust and trust zones created in Panorama must be all lower case.

In Panorama you must configure your network interfaces using DHCP.

• Only eth1/1 should automacally create default route trust and untrust zones.
• The Security Policy zones are named untrust and trust.

All zone names must be lower case

• The templates configure an Administrator account named pandemo and the password
demopassword.

• Create a virtual router with the naming convenon VR-<TemplateStackName>. On the virtual
router ECMP tab, enable ECMP.

• To set the DNS server address on Panorama, select Device > Setup > Services. Set the Primary
DNS Server to 169.254.169.253, the Secondary DNS Server to 8.8.8.8, and the FQDN Refresh
Time (sec) to 60. Panorama requires the AWS DNS server IP address to resolve the FQDN of
the internal load balancer on AWS. The FQDN refresh me is the interval at which Panorama
commits newly detected internal load balancers.

Aer the applicaon template has launched, Lambda populates the following in Panorama:

• NAT policy
• Address object for LB in Applicaon Template
• Stac routes in the virtual router
• Tcp81 service object

The v2.1 firewall template includes an AWS NAT gateway that the firewalls use to iniate
outbound requests for retrieving updates, connecng to Panorama, and publishing metrics to
AWS CloudWatch. The NAT Gateways also have Elasc IP addresses aached to them for each
zone.

You need the following Panorama resources to work with the Auto Scale templates for AWS.

Panorama API Key You need a Panorama API key to authencate the API. Lambda uses
your API key to autoconfigure template and device group opons. To
generate the API key, see Get Your API Key.

Panorama License
Deacvaon Key

The template requires a license deacvaon API key and the “Verify
Update Server Identy” to be enabled to deacvate the license keys
from Panorama. The license deacvaon key should be obtained from
Palo Alto Customer Support Portal as described in Install a License API
Key.

Panorama VM-Auth-
Key

You need a vm-auth-key to enable bootstrapped firewalls to connect
to Panorama and receive their bootstrap configuraon. See Generate
the VM Auth Key on Panorama.
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Panorama
Management
Interface Access

• Port 443 (HTTPS)—Upon inial deployment of the firewall template,
leave HTTPS open so Lambda can connect to Panorama. Wait to
receive the following confirmaon of connecon in Panorama:

When you secure port 443 you specify an IP address range from
which you will allow connecons, as well as the EIPs assigned to
the NAT gateways. There are two NAT gateways and the EIPs
associated with them. To find NAT gateway EIPs in AWS, go to VPC
> NAT Gateways. Note the EIP informaon for the security group
for HTTPS.

• Port 3978—Port 3978 must be able to receive traffic from any IP
address.

Bootstrap Files

The GitHub auto scaling repository includes an init-cfg.txt file so that the VM-Series firewall
has the basic configuraon to:

• Perform interface swap so the VM-Series firewall untrust traffic uses AWS ENI for eth0.

• Communicate to Panorama for device group and template configuraon.

The auto scaling GitHub repository has the basic configuraon to get started. This auto scaling
soluon requires swapping the dataplane and management interfaces to enable the load balancer
to forward web traffic to the VM-Series firewall auto scaling er. For details on management
interface mapping with the Amazon ELB as shown in Management Interface Mapping for Use with
Amazon ELB.

Plan to Deploy VM-Series Auto Scaling Templates for AWS (v2.1)
Before starng the deployment, review the following resources.

See Auto Scaling VM-Series Firewalls with the Amazon ELB Service for an overview of
template features, and account planning.
Customize the Firewall Template Before Launch (v2.0 and v2.1). The basic parameters in this
topic apply to all template versions.
How Does the VM-Series Auto Scaling Template for AWS (v2.0 and v2.1) Enable Dynamic
Scaling?

These concepts apply to all template versions.

Launch the Firewall Template (v2.1)
You can choose to deploy the firewall and applicaon templates in the same VPC or in separate
VPCs.
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The templates support a hub and spoke architecture in which you can deploy the firewall template
in one AWS account and use it as a hub to secure applicaons (spokes) that belong to the same or
to different AWS accounts.

This workflow tells you how to deploy the external load balancer and the VM-Series firewalls
using the firewall template. The vm-auth-key must be configured on Panorama prior to launching
this template.

STEP 1 | Review the checklists in Plan to Deploy VM-Series Auto Scaling Templates for AWS (v2.1)
and Plan the VM-Series Auto Scaling Template for AWS (v2.0 and v2.1).

Verify that you have completed the following tasks:

• (For PAYG only) Review and accept the EULA for the PAYG bundle you plan to use.
• (For BYOL only) Obtain the auth code for a bundle that supports the number of firewalls

that might be required for your deployment. You must save this auth code in a text file
named authcodes (no extensions), and put the authcodes file in the /license folder of
the bootstrap package.

If you use individual auth codes instead of a bundle, the firewall only retrieves the
license key for the first auth code in the file.

• Download the files required to launch the VM-Series Auto Scaling v2.1 template from the
GitHub repository.
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STEP 2 | Modify the init-cfg.txt file and upload it to the /config folder.

Because you use Panorama to bootstrap the VM-Series firewalls, your init-cfg.txt file
should be modified as follows. No bootstrap.xml file is needed.

type=dhcp-client

ip-address=

default-gateway=

netmask=

ipv6-address=

ipv6-default-gateway=

hostname=

vm-auth-key=

panorama-server=

panorama-server-2=

tplname=AWS-tmplspoke1

dgname=AWS-dgspoke1

dns-primary=169.254.169.253

dns-secondary=8.8.8.8

op-command-modes=mgmt-interface-swap

dhcp-send-hostname=yes
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dhcp-send-client-id=yes

dhcp-accept-server-hostname=yesdhcp-accept-server-domain=yes

vm-series-auto-registration-id=

vm-series-auto-registration-pin-value=

Verify that op-command-modes=mgmt-interface-swap exists. This is the command for
swapping the management interface (mgmt) and the dataplane interface (ethernet 1/1) on
the VM-Series firewall on AWS. Use the AWS DNS server IP address of 169.254.169.253 for
faster load balancer DNS name resoluon.

You must add the device cerficate auto-registraon PIN to the init-cfg.txt file to automacally
install a device cerficate when your VM-Series firewall instance is deployed.

STEP 3 | (For BYOL only) Add the license auth code in the /license folder of the bootstrap package.
1. Use a text editor to create a new text file named authcodes (no extension).
2. Add the authcode for your BYOL licenses to this file, and save. The authcode must

represent a bundle, and it must support the number of firewalls that might be required
for your deployment. If you use individual authcodes instead of a bundle, the firewall
only retrieves the license key for the first authcode in the file.
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STEP 4 | Upload Lambda code for the firewall template (panw-aws-zip) and the Applicaon
template (ilb.zip) to an S3 bucket. You can use the same S3 bucket that you use for
bootstrapping.

If the Applicaon stack is managed by a different account than the firewall, use the Applicaon
account to create another s3 bucket in the same AWS region as the firewall template and copy
ilb.zip to that s3 bucket.

STEP 5 | Select the firewall template.
1. In the AWS Management Console, select CloudFormaon > Create Stack.
2. Select Upload a template to Amazon S3, to choose the applicaon template to deploy

the resources that the template launches within the same VPC as the firewalls, or to a
different VPC. Click Open and Next.

3. Specify the Stack name. The stack name allows you to uniquely idenfy all the resources
that are deployed using this template.
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STEP 6 | Configure the parameters for the VPC.
1. Be sure to select at least two availability zones

2. Look up the AMI ID for the VM-Series firewall and enter it. Make sure that the AMI ID
matches the AWS region, PAN-OS version and the BYOL or PAYG licensing opon you
opted to use.

3. Select the EC2 Key pair (from the drop-down) for launching the firewall. To log in to the
firewalls, you must provide the name of this key pair and the private key associated with
it.

4. For the SSH from field, the firewalls will be managed by Panorama and do NOT have an
EIP for the management interface. But just in case you decide to assign an EIP configure
the IP range you would connect from.

5. Select Yes if you want to Enable Debug Log. Enabling the debug log generates more
verbose logs that help with troubleshoong issues with the deployment. These logs are
generated using the stack name and are saved in AWS CloudWatch.

By default, the template uses CPU ulizaon as the scaling parameter for the VM-Series
firewalls. Custom PAN-OS metrics are automacally published to the CloudWatch namespace
that matches the stack name you specified earlier.
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STEP 7 | Specify the name of the Amazon S3 bucket(s).

1. Enter the name of the S3 bucket that contains the bootstrap package.

If the bootstrap bucket is not set up properly or if you enter the bucket name incorrectly,
the bootstrap process fails, and you cannot log in to the firewall. Health checks for the
load balancers also fail.

2. Enter the name of the S3 bucket that contains the panw-aws.zip file. As menoned
earlier you can use one S3 bucket for the Bootstrap and Lambda code.

STEP 8 | Specify the keys for enabling API access to the firewall and Panorama.

1. Enter the key that the firewall must use to authencate API calls. The default key is
based on the sample file and you should only use it for tesng and evaluaon. For a
producon deployment, you must create a separate PAN-OS login just for the API call
and generate an associated key.

2. Enter the API Key to allow AWS Lambda to make API calls to Panorama. For a
producon deployment, you should create a separate login just for the API call and
generate an associated key.

STEP 9 | Enter the name for the applicaon load balancer.
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STEP 10 | Review the template sengs and launch the template.
1. Select I acknowledge that this template might cause AWS CloudFormaon to create

IAM resources.
2. Click Create to launch the template. The CREATE_IN_PROGRESS event displays.
3. On successful deployment the status updates to CREATE_COMPLETE.

STEP 11 | Verify that the template has launched all required resources.
1. On the EC2 Dashboard, select Auto Scaling Groups. Verify that in each AZ, you have one

ASG for the VM-Series firewalls. The ASG name prefix includes the stack name.
2. On the AWS Management Console, select the stack name to view the Output for the list

of resources.
3. Your output should look similar to the output in the following image.

• Take note of the Network Load Balancer Queue name.
• Take note of the Elasc Load Balancer public DNS name.

It may take up to 20 minutes for the firewalls to boot up and be available to handle
traffic.

When you are finished with a tesng or a producon deployment, the only way
to ensure charges stop occurring is to completely delete the stack. Shung down
instances, or changing the ASG maximum to 0 is not sufficient.
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STEP 12 | Save the following firewall template informaon. You must provide these values as inputs
when deploying the applicaon template.

• IP addresses of the NAT Gateway in each AZ—You need this IP address to restrict HTTPS
access to your Panorama so that Lambda can use the EIPs for the NAT Gateway to
communicate with Panorama when needed.

• Network Load Balancer SQS URL—A Lambda funcon in the firewall stack monitors this
queue so that it can learn about any network load balancers that you deploy and create
NAT policy rules (one per applicaon) in the Panorama that enable the firewalls to send
traffic to the network load balancer IP address.

Launch the Applicaon Template (v2.1)
The applicaon templates allow you to complete the sandwich topology and are provided so that
you can evaluate the auto scaling soluon. This applicaon template deploys either an applicaon
or network load balancer and a pair of web servers behind the auto scaling group of VM-Series
firewalls, which you deployed using the firewall template.

Use this template to evaluate the soluon but customize your own template to deploy
to producon. For a custom template, make sure to enable SQS messaging between the
Applicaon template and the Firewall template.

When launching the applicaon template, you must select the template based on whether you
want to deploy the applicaon template within the same VPC in which you deployed the firewall
template or in a separate VPC. See Enable Traffic to the ELB Service (v2.0 and v2.1).

STEP 1 | Create an S3 bucket from which you will launch the applicaon template.

• If this is a cross-account deployment, create a new bucket.
• If there is one account you can create a new bucket or use the S3 bucket you created earlier

(you can use one bucket for everything).

STEP 2 | Upload the ilb.zip file into the S3 bucket.
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STEP 3 | Select the applicaon launch template you want you launch.
1. In the AWS Management Console, select CloudFormaon > CreateStack
2. Select Upload a template to Amazon S3, to choose the applicaon template to deploy

the resources that the template launches within the same VPC as the firewalls, or to a
different VPC. Click Open and Next.

3. Specify the Stack name. The stack name allows you to uniquely idenfy all the resources
that are deployed using this template.

STEP 4 | Configure the parameters for the VPC and network load balancer.
1. Select the two Availability Zones that your setup will span in Select list of AZ. If you are

deploying within the same VPC make sure to select the same Availability Zones that you
selected for the firewall template.

2. If deploying to a new VPC enter a CIDR Block for the VPC. The default CIDR is
192.168.0.0/16.

3. If deploying to the same VPC you will select the previous VPC and use the Trust subnets.

STEP 5 | Select the load balancer type.
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STEP 6 | Configure the parameters for Lambda.
1. Enter the S3 bucket name where ilb.zip is stored.
2. Enter the name of the zip file name.
3. Paste the SQS URL that you copied earlier.

STEP 7 | Modify the web server EC2 instance type to meet your needs.

STEP 8 | Select the EC2 Key pair (from the drop-down) for launching the web servers. To log in to the
web servers, you must provide the key pair name and the private key associated with it.

STEP 9 | Select the IP address of the network you will be accessing the servers from for management
access only. Web traffic comes through the ELBDNS name you copied when you launched
the firewall template.

STEP 10 | Review the template sengs and launch the template.
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STEP 11 | Aer compleon of the applicaon template it can take up to 20 minutes for the web pages
to become acve.
1. Verify that the applicaon template load balancer is marked acve.

2. Verify that Panorama has a NAT object in the device group.

3. Verify that Panorama has an address object in the device group.

4. Verify that Panorama has stac routes in the template stack.

STEP 12 | Get the DNS name you saved earlier for the applicaon load balancer and enter it into a web
browser.
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STEP 13 | Upon successful launch your browser should look like this output.

Create a Custom Amazon Machine Image (v2.1)
A custom VM-Series AMI gives you the consistency and flexibility to deploy a VM-Series
firewall with the PAN-OS version you want to use on your network instead of being restricted
to using only an AMI that is published to the AWS public Marketplace or to the AWS GovCloud
Marketplace. Using a custom AMI speeds up the process of deploying a firewall with the PAN-OS
version of your choice because it reduces the me to provision the firewall with an AMI published
on the AWS public or AWS GovCloud marketplace, and then perform soware upgrades to get to
the PAN-OS version you want to use on your network. Addionally, you can use the custom AMI
in the Auto Scaling VM-Series Firewalls CloudFormaon Templates or any other templates that
you have created.

You can create a custom AMI with the BYOL, Bundle 1, or Bundle 2 licenses. The process of
creang a custom AMI requires you to remove all configuraon from the firewall and perform a
private data reset, so in this workflow you’ll launch a new instance of the firewall from the AWS
Marketplace instead of using an exisng firewall that you have fully configured.

When creang a custom AMI with a BYOL version of the firewall, you must first acvate
the license on the firewall so that you can access and download PAN-OS content and
soware updates to upgrade your firewall, and then deacvate the license on the firewall
before performing the private data reset and creang the custom AMI. If you do not
deacvate the license, you lose the license that you applied on this firewall instance.

STEP 1 | Launch the VM-Series firewall from the Marketplace.

See Launch the VM-Series firewall.

STEP 2 | (Only for BYOL) Acvate the license.

STEP 3 | Install latest content on the firewall.

STEP 4 | (Only for BYOL) Deacvate the license.
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STEP 5 | Perform a private data reset.

A private data reset removes all logs and restores the default configuraon.

The system disks are not erased, so the content updates from Step 4 are intact.
1. Access the firewall CLI.
2. Export a copy of the configuraon.
3. Remove all logs and restore the default configuraon.

request system private-data-reset

Enter y to confirm.

The firewall reboots to inialize the default configuraon.
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STEP 6 | Create the custom AMI.
1. Log in to the AWS Console and select the EC2 Dashboard.
2. Stop the VM-Series firewall.
3. Select the VM-Series firewall instance, and click Image > Create Image.

4. Enter a custom image name, and click Create Image.

The disk space of 60GB is the minimum requirement.

5. Verify that the custom AMI is created and has the correct product code.

1. On the EC2 Dashboard, select AMI.
2. Select the AMI that you just created. Depending on whether you selected an AMI

with the BYOL, Bundle 1, or Bundle 2 licensing opons, you should see one of the
following Product Codes in the details:

• BYOL—6njl1pau431dv1qxipg63mvah
• Bundle 1—6kxdw3bbmdeda3o6i1ggqt4km
• Bundle 2—806j2of0qy5osgjjixq9gqc6g
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STEP 7 | Encrypt EBS Volume for the VM-Series Firewall on AWS.

If you plan to use the custom AMI with EBS encrypon for an Auto Scaling VM-Series Firewalls
with the Amazon ELB Service deployment, you must use the default master key for your AWS
account.

VM-Series Auto Scaling Template Cleanup (v2.1)
If you deployed the templates as a test, delete them to save resources and lower costs.

STEP 1 | In the AWS Management Console, select Cloud Formaon > Create Stack.

STEP 2 | Locate the firewall template and applicaon template you launched previously and delete
both templates.

For more informaon on deleng template stacks see, “What is AWS CloudFormaon?“

Failure to delete your template stack incurs charges from AWS.

SQS Messaging Between the Applicaon Template and Firewall Template (v2.1)
VM-Series firewalls deployed using one of the firewall templates can detect and send traffic to
the load balancers to which you want to automacally distribute incoming traffic. To accomplish
this, the firewall template includes a lambda funcon that monitors a Simple Queue Service for
messages. The message allows the lambda funcon to learn about a new load balancer and then
automacally create a NAT policy rule on the firewall to send traffic to the load balancer’s IP
address. To route traffic properly within the AWS infrastructure, the message must also include
basic informaon on the DNS, VPC ID, and the AZ to which the load balancer belongs.

If you are building your own applicaon template, you must set up your applicaon template to
post ADD and DEL messages to the SQS URL that the firewall template uses to learn about load
balancers to which it must distribute traffic in your environment:

• ADD-NLB message that informs the firewalls when a new network load balancer is available.
• DEL-NLB message that informs the firewalls when a network load balancer has been

terminated and is no longer available.
• ADD-ALB message that informs the firewalls when a new applicaon load balancer is available.
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• DEL-ALB message that informs the firewalls when a applicaon load balancer has been
terminated and is no longer available.

The following examples of each message type include sample values. You must modify these
messages with values that match your deployment.

ADD-NLB Message

msg_add_nlb= {

       "MSG-TYPE": "ADD-NLB",

       "AVAIL-ZONES": [

       {

           "NLB-IP":"192.168.2.101", 

           "ZONE-NAME":"us-east-2a",

           "SUBNET-ID": "subnet-2a566243"

       },

       {

           "NLB-IP":"192.168.12.101",

           "ZONE-NAME":"us-east-2b",

           "SUBNET-ID": "subnet-2a566243 "

       }

       ],

            "DNS-NAME": "publicelb1-2119989486.us-
east-2.elb.amazonaws.com",
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           "VPC-ID": "vpc-42ba9f2b",

           "NLB-NAME": "publicelb1" 

}

DEL-NLB Message

msg_del_nlb= {

 "MSG-TYPE": "DEL-NLB",

 "DNS-NAME": "publicelb1-2119989486.us-east-2.elb.amazonaws.com", 

}

ADD-ALB

{   "AVAIL-ZONES": [

       {

           "SUBNET-CIDR": "172.32.0.0/24",

           "SUBNET-ID": "subnet-0953a3a8e2a8208a9",

           "ZONE-NAME": "us-east-2a"

       },

       {

           "SUBNET-CIDR": "172.32.2.0/24",

           "SUBNET-ID": "subnet-0a9602e4fb0d88baa",

           "ZONE-NAME": "us-east-2c"
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       },

       {

           "SUBNET-CIDR": "172.32.1.0/24",

           "SUBNET-ID": "subnet-0b31ed16f308b3c4d",

           "ZONE-NAME": "us-east-2b"

       }

   ],

   "VPC-PEERCONN-ID": "pcx-0538bb05dbe2e1b8e",

   "VPC-CIDR": "172.32.0.0/16",

   "ALB-NAME": "appILB-908-0",

   "ALB-ARN":"arn:aws:elasticloadbalancing:us-
east-2:018147215560:loadbalancer/app/appILB-908-0/1997ed20eeb5bcef",

   "VPC-ID": "vpc-0d9234597da6d9147",

   "MSG-TYPE": "ADD-ALB",

   "DNS-NAME": "internal-appILB-908-0-484644265.us-
east-2.elb.amazonaws.com"

}

DEL-ALB Message

{

   "MSG-TYPE": "DEL-ALB",
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   "DNS-NAME": "internal-appILB-908-0-484644265.us-
east-2.elb.amazonaws.com"

}

Refer to the AWS documentaon for details on how to send a message to an Amazon SQS Queue.

Stack Update with VM-Series Auto Scaling Template for AWS (v2.1)
A stack update allows you to modify the resources that the VM-Series Auto Scaling template
firewall template deploys. Instead of deleng your exisng deployment and redeploying the
soluon, use the stack update to modify launch configuraon parameters.

You can modify the AWS instance type, the key pair for your auto scaling groups, and the APi key
associated with the adminstrave user account on the firewall.

You do not have to update the stack to modify default noficaons or create auto scaling
alarms. See Change Scaling Parameters and CloudWatch Metrics (v2.1).

When you deploy the VM-Series Auto Scaling template, the auto scaling groups and the launch
configuraon are automacally created for you. The launch configuraon is a template that an
auto scaling group uses to launch EC2 instance, and it specifies parameters such as the instance
type, the key pair for your auto scaling group, or the API key associated with the administrave
user account on the firewall.

For crical applicaons, perform a stack update during a maintenance window.

You can update your stack directly or create change sets. The workflow in this document takes
you through the manual stack update.

STEP 1 | In the AWS CloudFormaon console, select the parent stack that you want to update and
choose Acons > Update Stack.
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STEP 2 | Modify the resources that you want to update.

You can modify the instance type, security group, key pair for the stack resources, or the API
key associated with the administrave user account on the firewall.

If you create a new administrave user account or modify the credenals of the exisng
administrator on the firewall, in order to update that stack and deploy new firewalls with the
updated API key, you need to follow the workflow in Modify Administrave Account (v2.1).

STEP 3 | Acknowledge the noficaons and review the changes and click Update to iniate the stack
update.

Modify Administrave Account (v2.1)
If you have already deployed the template and now want to change the password for the
administrave account or create a new administrave user account on the VM-Series firewall,
you must generate a new API key and update the template stack with the new API key for the
administrave user account.

STEP 1 | Log in to the web interface of the firewall and change the credenals for an exisng
administrave user or create a new account.

STEP 2 | Generate the API key.

STEP 3 | Update the API key in the stack to ensure that newly launched firewalls have the updated
administrator account.

See Stack Update with VM-Series Auto Scaling Template for AWS (v2.0).

Change Scaling Parameters and CloudWatch Metrics (v2.1)
This task describes how to use custom PAN-OS metrics as scaling parameters to trigger auto scale
acons.

When you launch the firewall template, the template creates a namespace with scale-in and
scale-out policies that you can use to define auto scaling acons. The policy names include the
namespace, as shown below:

• <Custom Namespace>-scalein - Remove 1 instance
• <Custom Namespace>-scaleout - Add 1 instance

Each PAN-OS metric has a default noficaon that you can delete and replace with auto scale
acons. For each metric, create two acons: one that determines when to add a VM-Series
firewall, and another that determines when to remove a VM-Series firewall.

STEP 1 | In AWS, select Services > CloudWatch > Metrics.
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STEP 2 | Choose a Custom Namespace link, and select the metrics link to view the custom PAN-OS
metrics.

STEP 3 | Check a box to select a metric, then select the Graphed metrics tab.
1. In the Stascs column, choose a stasc criteria (such as average, minimum and

maximum) and choose a me period.
2. In the Acons column select the bell (Create alarm).

STEP 4 | Define an alarm that removes a firewall when CPU ulizaon meets or falls below the criteria
you set, over the me frame you set.
1. Select Edit to change the graph tle.
2. Under Alarm details fill in the Name and Descripon, choose an operator, and set the

minimum value to maintain the current instances. If the minimum value is not maintained,
an instance is removed.

3. Under Acons, delete the default noficaon.
4. Select +AutoScaling Acon.

• Use the From the list to select your namespace.
• From Take this acon, select the policy to remove an instance.

5. Select Create Alarm.

STEP 5 | Create a second alarm that adds a firewall when CPU ulizaon meets or exceeds the criteria
you set.
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STEP 6 | To view your alarms, select Services > CloudWatch > Alarms.

To edit an alarm from this window, check the box next to the alarm and select Acon > Edit.
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List of Aributes Monitored on the AWS VPC
As you provision or modify virtual machines in your AWS VPCs, you have two ways of monitoring
these instances and retrieving the tags for use as match criteria in dynamic address groups.

• VM Informaon Source—On a next-gen firewall, you can monitor up to a total of 32 tags—14
pre-defined and 18 user-defined key-value pairs (tags).

• AWS Plugin on Panorama—The Panorama plugin for AWS allows you to connect Panorama to
your AWS VPC on the public cloud and retrieve the IP address-to-tag mapping for your virtual
machines. Panorama then registers the VM informaon to the managed Palo Alto Networks®

firewall(s) that you have configured for noficaon. With the plugin, Panorama can retrieve a
total of 32 tags for each virtual machine, 11 predefined tags and up to 21 user-defined tags.

The maximum length of the tag-value (name and value included) must be 116
characters or less. If a tag is longer than 116 characters, Panorama does not retrieve
the tag and register it on the firewalls.

Aributes
Monitored on
the AWS-VPC

VM
Informaon
Source on the
Firewall

AWS Plugin on
Panorama

AMI ID ImageId.<ImageId string> Yes Yes

Architecture Architecture.<Architecture string> Yes No

Availability
Zone

AvailabilityZone.<string> Yes Yes

Guest OS GuestOS.<guest OS name> Yes No

IAM Instance
Profile

Iam-instance-profile.<instanceProfileArn> No Yes

Instance ID InstanceId.<InstanceId string> Yes No

Instance State InstanceState.<instance state> Yes No

Instance Type InstanceType.<instance type> Yes No

Key Name KeyName.<KeyName string> Yes Yes

Owner ID

The value for
this aribute is
fetched from
the ENI.

Account-number.<OwnerId> No Yes
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Aributes
Monitored on
the AWS-VPC

VM
Informaon
Source on the
Firewall

AWS Plugin on
Panorama

Placement

Tenancy, Group
Name

Placement.Tenancy.<string>

Placement.GroupName.<string>

Yes Yes

Private DNS
Name

PrivateDnsName.<Private DNS Name> Yes No

Public DNS
Name

PublicDnsName.<Public DNS Name> Yes Yes

Subnet ID SubnetID.<subnetID string> Yes Yes

Security Group
ID

Sg-id.<sg-xxxx> No Yes

Security Group
Name

Sg-name.<SecurityGroupName> No Yes

VPC ID VpcId.<VpcId string> Yes Yes

Tag (key, value) aws-tag.<key>.<value> Yes;

Up to a
maximum
of 18 user
defined
tags are
supported.
The user-
defined tags
are sorted
alphabecally,
and the first
18 tags are
available for
use on the
firewalls.

Yes;

Up to a
maximum
of 21 user
defined tags are
supported. The
user-defined
tags are sorted
alphabecally,
and the first
21 tags are
available for use
on Panorama
and the firewalls.

IAM Permissions Required for Monitoring the AWS VPC
In order to enable VM Monitoring the user’s AWS login credenals ed to the AWS Access Key
and Secret Access Key must have permissions for the aributes listed above. These privileges
allow the firewall to iniate API calls for monitoring the virtual machines in the AWS VPC.
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The IAM policy associated with the user must either have global read-only access such as
AmazonEC2ReadOnlyAccess, or must include individual permissions for all of the monitored
aributes. The following IAM policy example lists the permissions for iniang the API acons for
monitoring the resources in the AWS VPC:

{ 
    "Version": "2012-10-17", 
    "Statement": [ 
        { 
            "Effect": "Allow", 
            "Action": [ 
                "ec2:DescribeAvailabilityZones", 
                "ec2:DescribeImages", 
                "ec2:DescribeInstances", 
                "ec2:DescribeInstanceStatus", 
                "ec2:DescribeKeyPairs", 
                "ec2:DescribePlacementGroups", 
                "ec2:DescribeRegions", 
                "ec2:DescribeSubnets", 
                "ec2:DescribeTags", 
                "ec2:DescribeVpcs" 
            ], 
            "Resource": [ 
                "*" 
            ] 
} 
    ] 
} 
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Kernel-based Virtual Machine (KVM) is an open-source virtualizaon module for
servers running Linux distribuons. The VM-Series firewall can be deployed on a Linux
server that is running the KVM hypervisor.

This guide assumes that you have an exisng IT infrastructure that uses Linux and
have the foundaon for using Linux/Linux tools. The instrucons only pertain to
deploying the VM-Series firewall on KVM.

> VM-Series on KVM— Requirements and Prerequisites
> Supported Deployments on KVM
> Install the VM-Series Firewall on KVM
> Performance Tuning of the VM-Series for KVM
> Intelligent Traffic Offload
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VM-Series on KVM—Requirements and Prerequisites
• Opons for Aaching the VM-Series on the Network
• Prerequisites for VM-Series on KVM

Table 2: VM-Series on KVM System Requirements

Requirements Descripon

Hardware Resources See VM-Series System Requirements for the minimum hardware
requirements for your VM-Series model.

Soware Versions See the supported KVM soware versions in the Compability Matrix.

SR-IOV Drivers See PacketMMAP Driver Versions drivers in the Compability Matrix.

DPDK Drivers See DPDK Driver Versions in the Compability Matrix.

If you use one of the supported NIC drivers on VM-Series on KVM,
DPDK is enabled by default.

Network Interfaces
—Network Interface
Cards and Soware
Bridges

The VM-Series on KVM supports a total of 25 interfaces — 1
management interface and a maximum of 24 network interfaces for
data traffic.

VM-Series deployed on KVM supports soware-based virtual switches
such as the Linux bridge or the Open vSwitch bridge, and direct
connecvity to PCI passthrough or an SR-IOV capable adapter.

If you plan to establish connecvity using PCI-passthrough or SR-IOV,
you cannot configure a vSwitch on the physical port used for SR-IOV
or PCI-passthrough. To communicate with the host and other virtual
machines on the network, the VM-Series firewall must have exclusive
access to the physical port and associated virtual funcons (VFs) on
that interface.

• On the Linux bridge and OVS, the e1000 and Viro drivers are
supported; the default driver rtl8139 is not supported.
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Requirements Descripon

• For PCI passthrough/SR-IOV support, the VM-Series firewall has
been tested for the following network cards:

• Intel 82576 based 1G NIC: SR-IOV support on all supported
Linux distribuons; PCI-passthrough support.

• Intel 82599 based 10G NIC: SR-IOV support on all supported
Linux distribuons; PCI-passthrough support.

• Intel X710 10G NIC: SR-IOV support on all supported Linux
distribuons; PCI-passthrough support

• Intel X722 10G NIC: SR-IOV support on all supported Linux
distribuons; PCI-passthrough support

• Broadcom 57112 and 578xx based 10G NIC: SR-IOV support on
all supported Linux distribuons; No PCI-passthrough support.

• Mellanox ConnectX5 10G/25G/50G/100G NIC: SR-IOV support
on all supported Linux distribuons.

• Refer to PacketMMAP Driver Versions in the Compability
Matrix

SR-IOV capable interfaces assigned to the VM-Series
firewall, must be configured as Layer 3 interfaces or as
HA interfaces.

Opons for Aaching the VM-Series on the Network
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• With a Linux bridge or OVS, data traffic uses the soware bridge to connect guests on the
same host. For external connecvity, data traffic uses the physical interface to which the bridge
is aached.

• With PCI passthrough, data traffic is passed directly between the guest and the physical
interface to which it is aached. When the interface is aached to a guest, it is not available to
the host or to other guests on the host.

• With SR-IOV, data traffic is passed directly between the guest and the virtual funcon to which
it is aached.

Prerequisites for VM-Series on KVM
Before you install the VM-Series firewall on the Linux server, review the following secons:

• Prepare the Linux Server
• Prepare to Deploy the VM-Series Firewall

Prepare the Linux Server
Before you install the VM-Series firewall on KVM, verify that you have a working Linux
environment and that your networking infrastructure supports the connecvity a that your chosen
deployment requires.

• Verify Linux Support
• Verify the Networking Infrastructure
• Install Mellanox Soware Tools
• Enable Virtual Funcons for Mellanox CX5 NICs on the VM-Series Firewall on KVM
• Verify the Host Configuraon

Verify Linux Support

Verify that you have the correct environment to support your installaon.

Check the Linux distribuon version. For a list of supported versions, see VM-Series for KVM in
the Compability Matrix.
Verify that you have installed and configured KVM tools and packages that are required for
creang and managing virtual machines, such as Libvirt.
If you want to use a SCSI disk controller to access the disk to which the VM-Series firewall
stores data, you must use virsh to aach the viro-scsi controller to the VM-Series firewall. You
can then edit the XML template of the VM-Series firewall to enable the use of the viro-scsi
controller. For instrucons, see Enable the Use of a SCSI Controller.

KVM on Ubuntu 12.04 does not support the viro-scsi controller.

Verify the Networking Infrastructure

Verify that you have set up the networking infrastructure for steering traffic between the guests
and the VM-Series firewall and ensure you have connecvity to an external server or the Internet.
The VM-Series firewall can connect using a Linux bridge, the Open vSwitch, PCI passthrough, or
SR-IOV capable network card.
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Make sure that the link state for each interface you plan to use is Up—somemes you have to
manually bring up the interface.
If using a Linux bridge or OVS, verify that you have set up the bridges required to send/receive
traffic to/from the firewall. If not, create bridge(s) and verify that they are up before you begin
installing the firewall.
If using SR-IOV or PCI-passthrough, verify the PCI ID of all the interfaces. To view the list, use
the following command:

Virsh nodedev-list –tree

See Verify PCI-ID for Ordering of Network Interfaces on the VM-Series Firewall.
If using SR-IOV or PCI-passthrough, verify that the virtualizaon extensions (VT-d/IOMMU)
are enabled in the BIOS. For example, to enable IOMMU, intel_iommu=on must be defined
in /etc/grub.conf. Refer to the documentaon provided by your system vendor for
instrucons.
If using PCI-passthrough, ensure that the VM-Series firewall has exclusive access to the
interface(s) that you plan to aach to it.

To allow exclusive access, you must manually detach the interface(s) from the Linux server.

Virsh nodedev-detach <pci id of interface>

For example:

Virsh nodedev-detach pci_0000_07_10_0

In some cases, you might need to edit /etc/libvirt/qemu.conf and uncomment
relaxed_acs_check = 1.

If using SR-IOV, verify that the virtual funcon capability is enabled for each port that you plan
to use on the network card. With SR-IOV, a single Ethernet port (physical funcon) can be split
into mulple virtual funcons. A guest can be mapped to one or more virtual funcons.

Enable virtual funcons as follows:

1. Create a new file in this locaon: /etc/modprobe.d/
2. Use vi to edit the file to make the funcons persistent:

vim /etc/modprobe.d/igb.conf
3. Enable the number of number of virtual funcons required:

options igb max_vfs=4

In the above example, aer you save the changes and reboot the Linux server, each
interface (or physical funcon) will have 4 virtual funcons.

Refer to the documentaon provided by your network vendor for details on the actual number
of virtual funcons supported, and instrucons to enable virtual funcons.

Install Mellanox Software Tools

If you are using a Mellanox CX5 card, install the Mellanox soware tools on the host. Before
installing, verify Linux support and your networking infrastructure.
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STEP 1 | From the host, download the package for Mellanox OpenFabric Enterprise Distribuon for
Linux (MLNX_OFED) for your OS version from the following link:

hps://www.mellanox.com/products/infiniband-drivers/linux/mlnx_ofed

STEP 2 | Run the installaon command:

mlnxofedinstall

If you have all the prerequisite packages installed, the above command installs all the
MLNX_OFED packages. Connue to Step 3.

If your environment doesn’t have the required packages, the installer lists all the packages that
you must install. Aer you install the packages, rerun the installaon command and connue to
Step 3.

STEP 3 | Reboot the host.

STEP 4 | Check the status of the Mellanox soware tools.

# mst status
MST modules: 
------------------------------------------------------------------
  MST PCI module is not loaded
  MST PCI configuration module loaded

MST devices:
------------------------------------------------------------------
/dev/mst/mt4121_pciconf0     - PCI configuration cycles access.
        domain:bus:dev.fn=0000:3b:00.0 addr.reg=88 data.reg=92
        Chip revision is: 00

STEP 5 | Ensure Mellanox is updated on the PCI list:

# lspci | grep Mellanox
3b:00.0 Ethernet controller: Mellanox Technologies MT28800 Family
 [ConnectX-5 Ex]
3b:00.1 Ethernet controller: Mellanox Technologies MT28800 Family
 [ConnectX-5 Ex]

Enable Virtual Functions for Mellanox CX5 NICs on the VM-Series Firewall on KVM

Install the Mellanox soware tools before you enable virtual funcons on Mellanox Cx5 NICs.

STEP 1 | Ensure Mellanox Soware Tools (mst) are started.

STEP 2 | Enable the number of number of virtual funcons required. For example:

mlxconfig -d /dev/mst/mt4121_pciconf0 set SRIOV_EN=1 NUM_OF_VFS=4

Aer you save the changes and reboot the Linux server, each interface (or physical funcon)
in the above example will have 4 virtual funcons. Refer to the documentaon provided by
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your network vendor for details on the actual number of virtual funcons supported, and the
instrucons to enable virtual funcons.

You might see the following error message the first me you enable virtual funcons on
Mellanox Cx5 NICs:

[ 1429.841162] mlx5_core 0000:3b:00.1:
 mlx5_port_module_event:1025:(pid 0): Port module
 event[error]: module 1, Cable error, One or more network
 ports have been powered down due to insufficient/
unadvertised power on the PCIe slot. Please refer to the
 card's user manual for power specifications or contact
 Mellanox support

To resolve the issue, enter the following command sequence on the Linux server:

# mlxconfig -d <dev> set ADVANCED_POWER_SETTINGS=1
# mlxconfig -d <dev> set DISABLE_SLOT_POWER_LIMITER=1
# reboot

STEP 3 | Check the status of the virtual funcons.

# cat  /sys/class/net/enp59s0f1/device/sriov_numvfs

(Oponal) If the virtual funcons are not set correctly (the status is 0 or empty), run the
following command:

# echo 4 > /sys/class/net/enp59s0f1/device/sriov_numvfs

STEP 4 | List the PCI devices to accurately match the number of virtual funcons loaded on the
respecve physical funcon for Mellanox:

# lspci | grep Mellanox
3b:00.0 Ethernet controller: Mellanox Technologies MT28800 Family
 [ConnectX-5 Ex]
3b:00.1 Ethernet controller: Mellanox Technologies MT28800 Family
 [ConnectX-5 Ex]
3b:00.2 Ethernet controller: Mellanox Technologies MT28800 Family
 [ConnectX-5 Ex Virtual Function]
3b:00.3 Ethernet controller: Mellanox Technologies MT28800 Family
 [ConnectX-5 Ex Virtual Function]
3b:00.4 Ethernet controller: Mellanox Technologies MT28800 Family
 [ConnectX-5 Ex Virtual Function]
3b:00.5 Ethernet controller: Mellanox Technologies MT28800 Family
 [ConnectX-5 Ex Virtual Function]
3b:00.6 Ethernet controller: Mellanox Technologies MT28800 Family
 [ConnectX-5 Ex Virtual Function]
3b:00.7 Ethernet controller: Mellanox Technologies MT28800 Family
 [ConnectX-5 Ex Virtual Function]
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3b:01.0 Ethernet controller: Mellanox Technologies MT28800 Family
 [ConnectX-5 Ex Virtual Function]
3b:01.1 Ethernet controller: Mellanox Technologies MT28800 Family
 [ConnectX-5 Ex Virtual Function]

Verify the Host Configuration

Configure the host for maximum VM-Series performance. Refer to Performance Tuning of the VM-
Series for KVM for informaon about configuring each opon below.

Enable DPDK. DPDK allows the host to process packets faster by bypassing the Linux kernel.
Instead, interacons with the NIC are performed using drivers and the DPDK libraries. Open
vSwitch is required to use DPDK with the VM-Series firewall.
Enable SR-IOV. Single root I/O virtualizaon (SR-IOV) allows a single PCIe physical device
under a single root port to appear to be mulple separate physical devices to the hypervisor or
guest.
Enable mul-queue support for NICs. Mul-queue viro-net allows network performance to
scale with the number of vCPUs and allows for parallel packet processing by creang mulple
TX and RX queues.
Isolate CPU resources in a NUMA Node. You can improve performance of VM-Series on
KVM by isolang the CPU resources of the guest VM to a single non-uniform memory access
(NUMA) node.

Prepare to Deploy the VM-Series Firewall
Purchase the VM-Series model and register the authorizaon code on the Palo Alto Networks
Customer Support web site. See Create a Support Account and Register the VM-Series
Firewall.
Obtain the qcow2 image and save it on the Linux server. As a best pracce, copy the image to
the folder: /var/lib/libvirt/qemu/images.

If you plan to deploy more than one instance of the VM-Series firewall, make the required
number of copies of the image. Because each instance of the VM-Series firewall maintains a
link with the .qcow2 image that was used to deploy the firewall, to prevent any data corrupon
issues ensure that each image is independent and is used by a single instance of the firewall.
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Supported Deployments on KVM
You can deploy a single instance of the VM-Series firewall per Linux host (single tenant) or
mulple instances of the VM-Series firewalls on a Linux host. The VM-Series firewall can be
deployed with virtual wire, Layer 2, or Layer 3 interfaces. If you plan on using SR-IOV capable
interfaces on the VM-Series firewall, you can only configure the interfaces as Layer 3 interfaces.

• Secure Traffic on a Single Host
• Secure Traffic Across Linux hosts

Secure Traffic on a Single Host
To secure east west traffic across guests on a Linux server, the VM-Series firewall can be deployed
with virtual wire, Layer 2, or Layer 3 interfaces. The illustraon below shows the firewall with
Layer 3 interfaces, where the firewall and the other guests on the server are connected using
Linux bridges. In this deployment, all traffic between the web servers and the database servers is
routed through the firewall; traffic across the database servers only or across the web servers only
is processed by the bridge and is not routed through the firewall.

Secure Traffic Across Linux hosts
To secure your workloads, more than one instance of the VM-Series firewalls can be deployed on
a Linux host. If, for example, you want to isolate traffic for separate departments or customers,
you can use VLAN tags

to logically isolate network traffic and route it to the appropriate VM-Series firewall. In the
following example, one Linux host hosts the VM-Series firewalls for two customers, Customer A
and Customer B, and the workload for Customer B is spread across two servers. In order to isolate
traffic and direct it to the VM-Series firewall configured for each customer, VLANs are used.
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In another variaon of this deployment, a pair of VM-Series firewalls are deployed in a high
availability set up. The VM-Series firewalls in the following illustraon are deployed on a Linux
server with SR-IOV capable adapters. With SR-IOV, a single Ethernet port (physical funcon) can
be split into mulple virtual funcons. Each virtual funcon aached to the VM-Series firewall is
configured as a Layer 3 interface. The acve peer in the HA pair secures traffic that is routed to it
from guests that are deployed on a different Linux server.
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Install the VM-Series Firewall on KVM
The libvirt API that is used to manage KVM includes a host of tools that allow you to create
and manage virtual machines. To install the VM-Series firewall on KVM you can use any of the
following methods.

• virt-manager—Deploy the VM-Series using the virt-manager virtual machine manager. Virt-
manager provides a convenient wizard to help you through the installaon process.

• virsh—Deploy the VM-Series using the KVM command line. Create an XML file that defines the
virtual machine instance and bootstrap XML file that defines the inial configuraon sengs of
the firewall. Then install the firewall by mounng an ISO image as a CD-ROM.

• virt-install—Another opon to deploy the VM-Series firewall using the KVM command line. Use
this opon to create the definion for the VM-Series firewall and install it.

This document provides steps for installing the VM-Series firewall on KVM using virt-manager and
virsh.

• Install the VM-Series Firewall Using Virt-Manager
• Install the VM-Series Firewall Using an ISO
• Use the VM-Series CLI to Swap the Management Interface on KVM
• Enable the Use of a SCSI Controller
• Verify PCI-ID for Ordering of Network Interfaces on the VM-Series Firewall

Install the VM-Series Firewall Using Virt-Manager
Use the following procedure uses virt-manager to install the VM-Series firewall on a server
running KVM on RHEL.

• Provision the VM-Series Firewall on a KVM Host
• Perform Inial Configuraon of the VM-Series Firewall on KVM

Provision the VM-Series Firewall on a KVM Host
Use the following instrucons to provision the KVM host for the VM-Series firewall.
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STEP 1 | Create a new virtual machine and add the VM-Series Firewall for KVM image to virt-mgr.
1. On the Virt-manager, select Create a new virtual machine.
2. Add a descripve Name for the VM-Series firewall.

3. Select Import exisng disk image, browse to the image, and set the OS Type: Linux and
Version: Red Hat Enterprise Linux 6.

If you prefer, you can leave the OS Type and Version as Generic.

4. To add network adapters for the data interfaces:
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STEP 2 | Configure the memory and CPU sengs.
1. Set the Memory to the minimum memory based on the VM-Series System Requirements

of your VM-Series model.
2. Set CPU to the minimum CPUs based on the VM-Series System Requirements of your

VM-Series model.

STEP 3 | Enable configuraon customizaon and select the management interface bridge.
1. Select Customize configuraon before install.
2. Under Advanced opons, select the bridge for the management interface, and accept the

default sengs.
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STEP 4 | Configure virtual disk sengs.
1. Select Disk, expand Advanced opons and select Storage format — qcow2; Disk Bus—

Viro or IDE, based on your set up.

If you want to use a SCSI disk bus, see Enable the Use of a SCSI Controller.

2. Expand Performance opons, and set Cache mode to writethrough. This seng
improves installaon me and execuon speed on the VM-Series firewall.
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STEP 5 | Configure network adapters.
1. Select Add Hardware > Network if you are using a soware bridge such as the Linux

bridge or the Open vSwitch.
2. For Host Device, enter the name of the bridge or select it from the drop down list.
3. To specify the driver, set Device Model to e-1000 or viro. These are the only supported

virtual interface types.

4. Select Add Hardware > PCI Host Device for PCI-passthrough or an SR-IOV capable
device.

5. In the Host Device list, select the interface on the card or the virtual funcon.
6. Click Apply or Finish.
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STEP 6 | Click Begin Installaon . Wait 5-7 minutes for the installaon to complete.

By default, the XML template for the VM-Series firewall is created and stored at etc/
libvirt/qemu.

STEP 7 | (Oponal) Bootstrap the VM-Series firewall

If you are using bootstrapping to perform the configuraon of your VM-Series firewall
on KVM, refer to Bootstrap the VM-Series Firewall on KVM. For more informaon about
bootstrapping, see Bootstrap the VM-Series Firewall.

STEP 8 | Configure the network access sengs for the management interface.
1. Open a connecon to the console.
2. Log into the firewall with username/password: admin/admin.
3. Enter configuraon mode with the following command:

configure

4. Use the following commands to configure the management interface:

1. set deviceconfig system type static

2. set deviceconfig system ip-address <Firewall-IP>
 netmask <netmask> default-gateway <gateway-IP> dns-setting
 servers primary <DNS-IP>

where <Firewall-IP> is the IP address you want to assign to the management interface,
<netmask> is the subnet mask, <gateway-IP> is the IP address of the network gateway,
and <DNS-IP> is the IP address of the DNS server.

3. commit
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STEP 9 | Verify which ports on the host are mapped to the interfaces on the VM-Series firewall. In
order to verify the order of interfaces on the Linux host, see Verify PCI-ID for Ordering of
Network Interfaces on the VM-Series Firewall.

To make sure that traffic is handled by the correct interface, use the following command to
idenfy which ports on the host are mapped to the ports on the VM-Series firewall.

admin@PAN-VM> debug show vm-series interfaces all 
Phoenix_interface    Base-OS_port       Base-OS_MAC PCI-ID 
 mgt                          eth0          52:54:00:d7:91:52
 0000:00:03.0 
 Ethernet1/1             eth1          52:54:00:fe:8c:80
 0000:00:06.0 
 Ethernet1/2             eth2          0e:c6:6b:b4:72:06
 0000:00:07.0 
 Ethernet1/3             eth3          06:1b:a5:7e:a5:78
 0000:00:08.0 
 Ethernet1/4             eth4          26:a9:26:54:27:a1
 0000:00:09.0 
 Ethernet1/5             eth5          52:54:00:f4:62:13
 0000:00:10.1 

STEP 10 | Access the web interface of the VM-Series firewall and configure the interfaces and define
security rules and NAT rules to safely enable the applicaons that you want to secure.

Refer to the PAN-OS Administrator’s Guide.

Perform Inial Configuraon of the VM-Series Firewall on KVM
Use the virtual appliance console on the KVM server to set up network access to the VM-
Series firewall. By default, the VM-Series firewall uses DHCP to obtain an IP address for the
management interface. However, you can assign a stac IP address. Aer compleng the inial
configuraon, access the web interface to complete further configuraons tasks. If you have
Panorama for central management, refer to the Panorama Administrator’s Guide for more
informaon on managing the device using Panorama.

If you are using bootstrapping to perform the configuraon of your VM-Series firewall on KVM,
refer to Bootstrap the VM-Series Firewall on KVM.

For general informaon about bootstrapping, see Bootstrap the VM-Series Firewall.

STEP 1 | Gather the required informaon from your network administrator.

• IP address for MGT port
• Netmask
• Default gateway
• DNS server IP address
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STEP 2 | Access the console of the VM-Series firewall.
1. Select the Console tab on the KVM server for the VM-Series firewall, or right-click the

VM-Series firewall and select Open Console.
2. Press enter to access the login screen.
3. Enter the default username/password (admin/admin) to log in.
4. Enter configure to switch to configuraon mode.

STEP 3 | Configure the network access sengs for the management interface.

Enter the following commands:

set deviceconfig system type static

set deviceconfig system ip-address <Firewall-IP> netmask <netmask> 
default-gateway <gateway-IP> dns-setting servers primary <DNS-IP> 

STEP 4 | Commit your changes and exit the configuraon mode.

Enter commit.

Enter exit.

Install the VM-Series Firewall Using an ISO
Manually create the XML definion of the VM-Series firewall, then use virsh to import the
definion as an ISO. Virsh is the most powerful tool that allows for full administraon of the
virtual machine.

• Use an ISO File to Deploy the VM-Series Firewall
• Sample XML file for the VM-Series Firewall

Use an ISO File to Deploy the VM-Series Firewall
If you want to pass a script to the VM-Series firewall at boot me, you can mount a CD-ROM
with an ISO file. The ISO file allows you to define a bootstrap XML file that includes the inial
configuraon parameters for the management port of the firewall. The VM-Series firewall on first
boot checks for the bootstrap-networkconfig.xml file, and uses the values defined in it.

If a single error is encountered in parsing the bootstrap file, the VM-Series firewall will
reject all the configuraon in this file and boot with default values.

STEP 1 | Create the XML file and define it as a virtual machine instance.

For a sample file, see Sample XML file for the VM-Series Firewall.

In this example, the VM-Series firewall is called PAN_Firewall_DC1.

For example:

user-PowerEdge-R510:~/kvm_script$ sudo vi /etc/libvirt/qemu/
PAN_Firewall_DC1.xml 
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user-PowerEdge-R510:~/kvm_script$ sudo virsh define/etc/libvirt/
qemu/PAN_Firewall_DC1.xml 
Domain PAN_Firewall_DC1_bootstp defined from /etc/libvirt/qemu/
PAN_Firewall_DC1.xml 
user-PowerEdge-R510:~/kvm_script$ sudo virsh -q attach-interface
 PAN_Firewall_DC1_bootstp bridge br1 --model=virtio --persistent 
user-PowerEdge-R510:~/kvm_script$ virsh list --all 
 Id    Name                         State 
--------------------------------------------- 
 -   PAN_Firewall_DC1_bootstp     shut off 

STEP 2 | Create the bootstrap XML file.

You can define the inial configuraon parameters in this file and name it bootstrap-
networkconfig.

If you do not want to include a parameter, for example panorama-server-secondary.
Delete the enre line from the file. If you leave the IP address field empty, the file will
not be parsed successfully.

Use the following example as a template for the bootstrap-networkconfig file. The bootstrap-
networkconfig file can include the following parameters only:

<vm-initcfg> 
<hostname>VM_ABC_Company</hostname> 
<ip-address>10.5.132.162</ip-address> 
<netmask>255.255.254.0</netmask> 
<default-gateway>10.5.132.1</default-gateway> 
<dns-primary>10.44.2.10</dns-primary> 
<dns-secondary>8.8.8.8</dns-secondary> 
<panorama-server-primary>10.5.133.4</panorama-server-primary> 
<panorama-server-secondary>10.5.133.5</panorama-server-secondary> 
</vm-initcfg> 

STEP 3 | Create the ISO file. In this example, we use mkisofs.

Save the ISO file in the images directory (/var/lib/libvirt/image) or the qemu directory (/
etc/libvirt/qemu) to ensure that the firewall has read access to the ISO file.

For example:

# mkisofs -J -R -v -V "Bootstrap" -A "Bootstrap" -ldots -l -
allow-lowercase -allow-multidot -o <iso-filename> bootstrap-
networkconfig.xml

STEP 4 | Aach the ISO file to the CD-ROM.

For example:

# virsh -q attach-disk <vm-name> <iso-filename> sdc --type cdrom --
mode readonly –persistent\
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Sample XML file for the VM-Series Firewall

<?xml version="1.0"?> 
<domain type="kvm"> 
<name>PAN_Firewall_DC1</name> 
<memory>4194304</memory> 
<currentMemory>4194304</currentMemory> 
<vcpu placement="static">2</vcpu> 
<os> 
<type arch="x86_64">hvm</type> 
<boot dev="hd"/> 
</os> 
<features> 
<acpi/> 
<apic/> 
<pae/> 
</features> 
<clock offset="utc"/> 
<on_poweroff>destroy</on_poweroff> 
<on_reboot>restart</on_reboot> 
<on_crash>restart</on_crash> 
<devices> 
<emulator>/usr/libexec/qemu-kvm</emulator> 
<disk type="file" device="disk"> 
<driver type="qcow2" name="qemu"/> 
<source file="/var/lib/libvirt/images/panos-kvm.qcow2"/> 
<target dev="vda" bus="virtio"/> 
</disk> 
<controller type="usb" index="0"/> 
<controller type="ide" index="0"/> 
<controller type="scsi" index="0"/> 
<serial type="pty"> 
<source path="/dev/pts/1"/> 
<target port="0"/> 
<alias name="serial0"/> 
</serial> 
<console type="pty" tty="/dev/pts/1"> 
<source path="/dev/pts/1"/> 
<target type="serial" port="0"/> 
<alias name="serial0"/> 
</console> 
<input type="mouse" bus="ps2"/> 
<graphics type="vnc" port="5900" autoport="yes"/> 
</devices> 
</domain> 

To modify the number of vCPUs assigned on the VM-Series firewall, change the value 2 to
4 or 8 vCPUs in this line of the sample XML file:

<vcpu placement="static">2</vcpu>
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Use the VM-Series CLI to Swap the Management Interface on
KVM

By default, the VM-Series firewall assigns the first interface (eth0) as the management interface.
However, in some deployments, the first interface must be pre-mapped to a public IP address.
Therefore, the management interface must be assigned to a different interface. Assigning a public
IP address to the management interface is a security risk.

Alternavely, you can enable management interface swap as part of the init-cfg.txt File
Components when bootstrapping.

STEP 1 | Log in to the VM-Series firewall CLI and enter the following command:

set system setting mgmt-interface-swap enable yes

STEP 2 | Confirm that you want to swap the interface and use the eth1 dataplane interface as the
management interface.

STEP 3 | Reboot the firewall for the swap to take effect. Use the following command:

request restart system

STEP 4 | Verify that the interfaces have been swapped. Use the following command:

debug show vm-series interfaces all 
Phoenix_interface   Base-OS_port   Base-OS_MAC        PCI-ID  
       Driver 
mgt(interface-swap) eth0   0e:53:96:91:ef:29   0000:00:04.0 
  ixgbevf 
Ethernet1/1           eth1    0e:4d:84:5f:7f:4d       0000:00:03.0 
  ixgbevf 

Enable the Use of a SCSI Controller
If you want the VM-Series firewall to use the disk bus type SCSI to access the virtual disk, use the
following instrucons to aach the viro scsi controller to the firewall and then enable the use of
the viro-scsi controller.

KVM on Ubuntu 12.04 does not support the viro-scsi controller; the viro-scsi controller
can only be enabled on the VM-Series firewall running on RHEL or CentOS.

This process requires virsh because Virt manager does not support the viro-scsi controller.

STEP 1 | Create an XML file for the SCSI controller. In this example, it is called virt-scsi.xml.

[root@localhost~]# cat /root/virt-scsi.xml 
<controller type='scsi' index='0' model='virtio-scsi'> 
<address type='pci' domain='0x0000' bus='0x00'
 slot='0x0b'function='0x0'/> 
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</controller> 

Make sure that the slot used for the viro-scsi controller does not conflict with another
device.

STEP 2 | Associate this controller with the XML template of the VM-Series firewall.

[root@localhost~]# virsh attach-device --config <VM-Series_name> /
root/virt-scsi.xml 
Device attached successfully 

STEP 3 | Enable the firewall to use the SCSI controller.

[root@localhost~]# virsh attach-disk <VM-Series_name>/var/lib/
libvirt/images/PA-VM-6.1.0-c73.qcow2
sda --cache none --persistent 
Disk attached successfully 

STEP 4 | Edit the XML template of the VM-Series firewall. In the XML template, you must change the
target disk and the disk bus, used by the firewall.

By default, the XML template is stored at etc/libvirt/qemu.

<disk type='file' device='disk'> 
      <driver name='qemu' type='qcow2' cache='writeback'/> 
      <source file='/var/lib/libvirt/images/PA-VM-7.0.0-c73.qcow2'/
> 
      <target dev='sda' bus='scsi'/> 
      <address type='drive' controller='0' bus='0' target='0'
 unit='0'/> 
</disk> 

Verify PCI-ID for Ordering of Network Interfaces on the VM-Series
Firewall

Regardless of whether you use a virtual interfaces (Linux/OVS bridge) or PCI devices (PCI-
passthrough or SR-IOV capable adapter) for connecvity to the VM-Series firewall, the VM-Series
firewall treats the interface as a PCI device. The assignment of an interface on the VM-Series
firewall is based on PCI-ID which is a value that combines the bus, device or slot, and funcon
of the interface. The interfaces are ordered starng at the lowest PCI-ID, which means that the
management interface (eth0) of the firewall is assigned to the interface with the lowest PCI-ID.

Let's say you assign four interfaces to the VM-Series firewall, three virtual interfaces of type
viro and e1000 and the fourth is a PCI device. To view the PCI-ID for each interface, enter the
command virsh dumpxml $ domain <name of the VM-Series firewall> on the
Linux host to view the list of interfaces aached to the VM-Series firewall. In the output, check for
the following networking configuraon:
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<interface type='bridge'> 
      <mac address='52:54:00:d7:91:52'/> 
      <source bridge='mgmt-br'/> 
      <model type='virtio'/> 
      <address type='pci' domain='0x0000' bus='0x00' slot='0x03'
 function='0x0'/> 
    </interface> 
     
   <interface type='bridge'> 
      <mac address='52:54:00:f4:62:13'/> 
      <source bridge='br8'/> 
      <model type='e1000'/> 
      <address type='pci' domain='0x0000' bus='0x00' slot='0x10'
 function='0x0'/> 
    </interface> 
     
   <interface type='bridge'> 
      <mac address='52:54:00:fe:8c:80'/> 
      <source bridge='br8'/> 
      <model type='e1000'/> 
      <address type='pci' domain='0x0000' bus='0x00' slot='0x06'
 function='0x0'/> 
    </interface> 
    
   <hostdev mode='subsystem' type='pci' managed='yes'> 
      <source> 
        <address domain='0x0000' bus='0x08' slot='0x10'
 function='0x1'/> 
      </source> 
      <address type='pci' domain='0x0000' bus='0x00' slot='0x07'
 function='0x0'/> 
    </hostdev> 

In this case, the PCI-ID of each interface is as follows:

• First virtual interface PCI-ID is 00:03:00
• Second virtual interface PCI-ID is 00:10:00
• Third virtual interface PCI-ID is 00:06:00
• Fourth interface PCI-ID is 00:07:00

Therefore, on the VM-Series firewall, the interface with PCI-ID of 00:03:00 is assigned as eth0
(management interface), the interface with PCI-ID 00:06:00 is assigned as eth1 (ethernet1/1), the
interface with PCI-ID 00:07:00 is eth2 (ethernet1/2) and the interface with PCI-ID 00:10:00 is
eth3 (ethernet1/3).
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Performance Tuning of the VM-Series for KVM
The VM-Series firewall for KVM is a high-performance appliance but may require tuning of
the hypervisor to achieve the best results. This secon describes some best pracces and
recommendaons for facilitang the best performance of the VM-Series firewall.

By default, KVM uses a linux bridge for VM networking. However, the best performance in a
virtual environment is realized with dedicated I/O interfaces (PCI passthrough or SR-IOV). If a
virtual switch is required, use a performance-opmized virtual switch (such as Open vSwitch with
DPDK).

• Install KVM and Open vSwitch on Ubuntu 16.04.1 LTS
• Enable Open vSwitch on KVM
• Integrate Open vSwitch with DPDK
• Enable SR-IOV on KVM
• Enable VLAN Access Mode with SR-IOV
• Enable Mul-Queue Support for NICs on KVM
• Isolate CPU Resources in a NUMA Node on KVM

Install KVM and Open vSwitch on Ubuntu 16.04.1 LTS
For ease of installaon, Ubuntu 16.04.1 LTS is recommended for use as the KVM hypervisor
plaorm.

STEP 1 | Install KVM and OVS.
1. Log in to the Ubuntu CLI.
2. Execute the following commands:

$ sudo apt-get install qemu-kvm libvirt-bin ubuntu-vm-builder
 bridge-utils 
$ sudo apt-get install openvswitch-switch 

STEP 2 | Check and compare the versions of relevant packages.

Execute the following commands:

$ virsh --version 1.3.1
$ libvirtd --version
libvirtd (libvirt) 1.3.1
$ /usr/bin/qemu-system-x86_64 --version
QEMU emulator version 2.5.0 (Debian
1:2.5+dfsg-5ubuntu10.6), Copyright (c) 2003-2008
Fabrice Bellard
$ ovs-vsctl --version
ovs-vsctl (Open vSwitch) 2.5.0
Compiled Mar 10 2016 14:16:49
DB Schema 7.12.1
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Enable Open vSwitch on KVM
Enable OVS by modifying the guest XML definion network sengs.

Modify the guest XML definion as follows.

[...]
    <interface type='bridge'>
       <mac address='52:54:00:fb:00:01'/>
       <source bridge='ovsbr0'/>
       <virtualport type='openvswitch'/>
       <model type='virtio'/>
       <address type='pci' domain='0x0000' bus='0x00' slot='0x03'
 function='0x0'/>
   </interface>
[...]

Integrate Open vSwitch with DPDK
To integrate Open vSwitch (OVS) with DPDK, you must install the required components and then
configure OVS. DPDK is enabled by default on the VM-Series firewall for KVM.

• Install QEMU, DPDK, and OVS on Ubuntu
• Configure OVS and DPDK on the Host
• Edit the VM-Series Firewall Configuraon File

Install QEMU, DPDK, and OVS on Ubuntu
Before you can enable DPDK on OVS, you must install QEMU 2.5.0, DPDK 2.2.0, and OVS 2.5.1.
Complete the following procedures to install the components.

STEP 1 | Log in to the KVM host CLI.

STEP 2 | Install QEMU 2.5.0 by execung the following commands:

apt-get install build-essential gcc pkg-config glib-2.0 libglib2.0-
dev libsdl1.2-dev
libaio-dev libcap-dev libattr1-dev libpixman-1-dev
apt-get build-dep qemu
apt-get install qemu-kvm libvirt-bin
wget http://wiki.qemu.org/download/qemu-2.5.0.tar.bz2
tar xjvf qemu-2.5.0.tar.bz2
cd qemu-2.5.0
./configure
make
make install

STEP 3 | Install dpdk-2.2.0.
1. Execute the following commands:

wget http://dpdk.org/browse/dpdk/snapshot/dpdk-2.2.0.tar.gz 
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tar xzvf dpdk-2.2.0.tar.gz 
cd dpdk-2.2.0 
vi config/common_linuxapp 

2. Change CONFIG_RTE_APP_TEST=y to CONFIG_RTE_APP_TEST=n
3. Change CONFIG_RTE_BUILD_COMBINE_LIBS=n to

CONFIG_RTE_BUILD_COMBINE_LIBS=y
4. Execute the following command:

vi GNUmakefile

5. Change ROOTDIRS-y := lib drivers app to ROOTDIRS-y := lib drivers
6. Execute the following command:

make install T=x86_64-native-linuxapp-gcc

STEP 4 | Install OVS 2.5.1 by execung the following commands:

wget http://openvswitch.org/releases/openvswitch-2.5.1.tar.gz 
tar xzvf openvswitch-2.5.1.tar.gz 
cd openvswitch-2.5.1 
./configure –with-dpdk=”/root/dpdk-2.2.0/x86_64-native-linuxapp-
gcc/” 
make  
make install 

Configure OVS and DPDK on the Host
Aer installing the necessary components to support OVS and DPDK, you must configure the
host to use OVS and DPDK.

STEP 1 | Log in to the KVM host CLI.

STEP 2 | If you are replacing or reconfiguring an exisng OVS-DPDK setup, execute the following
commands to reset any previous configuraon. Repeat the command for each interface.

rm /usr/local/var/run/openvswitch/<interface-name>

STEP 3 | Configure inial huge pages for OVS.

echo 16384 > /sys/kernel/mm/hugepages/hugepages-2048kB/nr_hugepages

STEP 4 | Mount huge pages for QEMU:

mkdir /dev/hugepages 
mkdir /dev/hugepages/libvirt 
mkdir /dev/hugepages/libvirt/qemu 
mount -t hugetlbfs hugetlbfs /dev/hugepages/libvirt/qemu 
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STEP 5 | Use the following command to kill any currently exisng OVS daemon.

killall ovsdb-server ovs-vswitchd

STEP 6 | Create directories for the OVS daemon.

mkdir -p /usr/local/etc/openvswitch 
mkdir -p /usr/local/var/run/openvswitch 

STEP 7 | Clear old directories.

rm -f /var/run/openvswitch/vhost-user* 
rm -f /usr/local/etc/openvswitch/conf.db 

STEP 8 | Inialize the configuraon database.

ovsdb-tool create /usr/local/etc/openvswitch/conf.db\ 
/usr/local/share/openvswitch/vswitch.ovsschema 

STEP 9 | Create an OVS DB server.

ovsdb-server --remote=punix:/usr/local/var/run/openvswitch/db.sock
 \ 
--remote=db:Open_vSwitch,Open_vSwitch,manager_options \ 
--private-key=db:Open_vSwitch,SSL,private_key \ 
--certificate=db:Open_vSwitch,SSL,certificate \ 
--bootstrap-ca-cert=db:Open_vSwitch,SSL,ca_cert \ 
--pidfile --detach 

STEP 10 | Inialize OVS.

ovs-vsctl --no-wait init

STEP 11 | Start the database server.

export DB_SOCK=/usr/local/var/run/openvswitch/db.sock

STEP 12 | Install the igb_uio module (network device driver) for DPDK.

cd ~/dpdk-2.2.0/x86_64-native-linuxapp-gcc/kmod 
modprobe uio 
insmod igb_uio.ko 
cd ~/dpdk-2.2.0/tools/ 
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STEP 13 | Enable DPDK on interfaces using PCI-ID or interface name.

./dpdk_nic_bind.py --bind=igb_uio <your first data interface> 

./dpdk_nic_bind.py --bind=igb_uio <your second data interface> 

STEP 14 | Start the OVS daemon in DPDK mode. You can change the number of cores for ovs-
vswitchd. By changing -c 0x1 to -c 0x3, you can have two core run this daemon.

ovs-vswitchd --dpdk -c 0x3 -n 4 -- unix:$DB_SOCK --pidfile --
detach 
echo 50000 > /sys/kernel/mm/hugepages/hugepages-2048kB/
nr_hugepages 

STEP 15 | Create the OVS bridge and aach ports to the OVS bridge.

ovs-vsctl add-br ovs-br0 -- set bridge ovs-br0
 datapath_type=netdev 
ovs-vsctl add-port ovs-br0 dpdk0 -- set Interface dpdk0 type=dpdk 
ovs-vsctl add-br ovs-br1 -- set bridge ovs-br1
 datapath_type=netdev 
ovs-vsctl add-port ovs-br1 dpdk1 -- set Interface dpdk1 type=dpdk  

STEP 16 | Create DPDK vhost user ports for OVS.

ovs-vsctl add-port ovs-br0 vhost-user1 -- set Interface vhost-user1
 type=dpdkvhostuser 
ovs-vsctl add-port ovs-br1 vhost-user2 -- set Interface vhost-user2
 type=dpdkvhostuser 

STEP 17 | Set the number of hardware queues of the NIC used by the host.

ovs-vsctl set Open_vSwitch . other_config:n-dpdk-rxqs=8 
ovs-vsctl set Open_vSwitch . other_config:n-dpdk-txqs=8 

STEP 18 | Set the CPU mask used for OVS.

ovs-vsctl set Open_vSwitch . other_config:pmd-cpu-mask=0xffff 

STEP 19 | Set the necessary permissions for DPDK vhost user ports. In the example below, 777 is used
to give read, write, and executable permissions.

chmod 777 /usr/local/var/run/openvswitch/vhost-user1 
chmod 777 /usr/local/var/run/openvswitch/vhost-user2 
chmod 777 /dev/hugepages/libvirt/qemu  

VM-Series Deployment Guide Version Version 10.1 532 ©2022 Palo Alto Networks, Inc.



Set Up the VM-Series Firewall on KVM

Edit the VM-Series Firewall Configuraon File
Edit the VM-Series firewall XML configuraon file to support OVS and DPDK. You can access the
XML configuraon file or aer deploying the VM-Series firewall. If you do this aer deploying
the firewall, be sure to shut down the firewall before making any changes. The values below are
examples, your values for each parameter will vary based on your VM-Series model.

STEP 1 | Log in to the KVM host CLI.

STEP 2 | Edit the XML configuraon file of your VM-Series firewall.
1. Open the XML config file using virsh edit $<your-vm-series-name>.
2. Sets the memory backing for the hugepage. Ensure that you provide enough memory

to support the VM-Series firewall model you are deploying on the host. See VM-Series
System Requirements for more informaon.

<memory unit='KiB'>12582912</memory> 
  <currentMemory unit='KiB'>6291456</currentMemory> 
  <memoryBacking> 
    <hugepages/> 

3. Set the necessary CPU flags for VM.

<cpu mode='host-model'> 

4. Enable memory sharing between the VM and the host.

<numa> 
      <cell id='0' cpus='0,2,4,6' memory='6291456' unit='KiB'
 memAccess='shared'/> 
      <cell id='1' cpus='1,3,5,7' memory='6291456' unit='KiB'
 memAccess='shared'/> 
    </numa> 

5. Set the DPDK vhost user ports as the VM -series firewall’s network interfaces.
Addionally, set the number of viro virtual queues provided to the VM-Series firewall
by the host.

<interface type='vhostuser'> 
      <mac address='52:54:00:36:83:70'/> 
      <source type='unix' path='/usr/local/var/run/
openvswitch/vhost-user1' mode='client'/> 
<model type='virtio'/> 
<driver name=’vhost’ queues=’8’/> 
      <address type='pci' domain='0x0000' bus='0x00'
 slot='0x04' function='0x0'/> 
    </interface> 
    <interface type='vhostuser'> 
      <mac address='52:54:00:30:d7:94'/> 
      <source type='unix' path='/usr/local/var/run/
openvswitch/vhost-user2' mode='client'/> 
<model type='virtio'/> 
<driver name=’vhost’ qeueus=’8’> 
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      <address type='pci' domain='0x0000' bus='0x00'
 slot='0x05' function='0x0'/> 
    </interface> 

Enable SR-IOV on KVM
Single root I/O virtualizaon (SR-IOV) allows a single PCIe physical device under a single root port
to appear to be mulple separate physical devices to the hypervisor or guest. To enable SR-IOV
on a KVM guest, define a pool of virtual funcon (VF) devices associated with a physical NIC and
automacally assign VF devices from the pool to PCI IDs.

For SR-IOV with Intel 10GB network interfaces (ixgbe driver), the driver version must be 4.2.5
or later to support mulple queues for each NIC interface. See the Compability Matrix for
PacketMMAP and DPDK driver support by PAN-OS version.

STEP 1 | Define a network for a pool of VFs.
1. Generate an XML file with text similar to the following example. Change the value of pf

dev to the ethdev corresponding to your SR-IOV device’s physical funcon.

<network> 
   <name>passthrough</name> 
   <forward mode='hostdev' managed='yes'> 
     <pf dev='eth3'/> 
   </forward> 
</network> 

2. Save the XML file.
3. Execute the following commands:

$ virsh net-define <path to network XML file> 
$ virsh net-autostart passthrough 
$ virsh net-start passthrough

STEP 2 | To ensure that the VM-Series firewall boots in DPDK mode, edit the guest VM XML
configuraon on the KVM hypervisor to add the following:

<cpu mode='host-passthrough' check='none'/>

This ensures that the CPU flags are exposed.

To verify that the CPU flags are exposed on the VM:

cat /proc/cpuinfo

In the flags output for PAN-OS 10.1 or later with DPDK 18.11, you need AVX, or AES and
SSE flags.

STEP 3 | Aer defining and starng the network, modify the guest XML definion to specify the
network.

<interface type='network'> 
    <source network='passthrough'> 
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</interface> 

When the guest starts, a VF is automacally assigned to the guest.

STEP 4 | Add the mulcast MAC address to the host.

When SR-IOV is enabled, mulcast traffic is filtered by the PF. This filtering causes applicaons
that rely on mulcast, such as OSPF, to fail. To prevent this filtering, you must manually add the
mulcast MAC address to the host using the following command:

#ip maddress add <multicast-mac> dev <interface-name>

Enable VLAN Access Mode with SR-IOV
The VM-Series firewalls on KVM can operate in VLAN access mode to support use cases where
it is deployed as a virtual network funcon (VNF) that offers security-as-a-service in a mul-
tenant cloud/data center environment. In VLAN access mode, each VNF has dedicated virtual
network interfaces (VNIs) for each network and it sends and receives packets to/from SR-IOV
virtual funcons (VFs) without VLAN tags; you must enable this capability on the physical and
virtual funcons on the host hypervisor. When you, then enable VLAN access mode on the VM-
Series firewall, the firewall can send and receive traffic without VLAN tags across all its dataplane
interfaces. Addionally, if you configure QoS policies, the firewall can enforce QoS on the access
interface and provide differenated treatment of traffic in a mul-tenant deployment.

By default, the VM-Series firewall on KVM operates in VLAN trunk mode.

STEP 1 | On the host system, set up the physical and virtual funcon to operate in VLAN access
mode.

ip link set [inf_name] vf [vf_num] vlan [vlan_id].

For best performance on the VM-Series firewall, make sure to:

• Enable CPU pinning. See Isolate CPU Resources in a NUMA Node on KVM.
• Disable Replay Protecon, if you have configured IPSec Tunnels.

On the firewall web interface, select Network > IPSec Tunnels  select an IPSec
tunnel, and click General, and select Show Advanced Opons and clear Enable
Replay Protecon.

STEP 2 | Access the CLI on the VM-Series firewall.

STEP 3 | Enable VLAN access mode.

request plugins vm-series vlan-mode access-mode on

on enables VLAN access mode; to use VLAN trunk mode, enter request plugins vm-
series vlan-mode access-mode off.

STEP 4 | Reboot the firewall.

Enterrequest restart system.
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STEP 5 | Verify the VLAN mode configuraon.

show plugins vm-series vlan-mode

Enable Mul-Queue Support for NICs on KVM
Modify the guest XML definion to enable mul-queue viro-net. Mul-queue viro-net allows
network performance to scale with the number of vCPUs and allows for parallel packet processing
by creang mulple TX and RX queues.

Modify the guest XML definion. Insert a value from 1 to 256 for N to specify the number
of queues. For the best results, match the number of queues with number of dataplane cores
configured on the VM.

<interface type='network'> 
      <source network='default'/> 
      <model type='virtio'/> 
      <driver name='vhost' queues='N'/> 
</interface> 

Isolate CPU Resources in a NUMA Node on KVM
You can improve performance of VM-Series on KVM by isolang the CPU resources of the guest
VM to a single non-uniform memory access (NUMA) node. On KVM, you can view the NUMA
topology virsh. The following example is from a two-node NUMA system:

STEP 1 | View the NUMA topology. In the example below, there are two NUMA nodes (sockets), each
with a four-core CPU with hyperthreading enabled. All the even-numbered CPU IDs belong
to one node and all the odd-numbered CPU IDs belong to the other node.

% virsh capabilities
<…>
  <topology>
    <cells num='2'>
      <cell id='0'>
        <memory unit='KiB'>33027228</memory>
        <pages unit='KiB' size='4'>8256807</pages>
        <pages unit='KiB' size='2048'>0</pages>
        <distances>
          <sibling id='0' value='10'/>
          <sibling id='1' value='20'/>
        </distances>
        <cpus num='8'>
          <cpu id='0' socket_id='1' core_id='0' siblings='0,8'/>
          <cpu id='2' socket_id='1' core_id='1' siblings='2,10'/>
          <cpu id='4' socket_id='1' core_id='2' siblings='4,12'/>
          <cpu id='6' socket_id='1' core_id='3' siblings='6,14'/>
          <cpu id='8' socket_id='1' core_id='0' siblings='0,8'/>
          <cpu id='10' socket_id='1' core_id='1' siblings='2,10'/>
          <cpu id='12' socket_id='1' core_id='2' siblings='4,12'/>
          <cpu id='14' socket_id='1' core_id='3' siblings='6,14'/>
        </cpus>
      </cell>
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      <cell id='1'>
        <memory unit='KiB'>32933812</memory>
        <pages unit='KiB' size='4'>8233453</pages>
        <pages unit='KiB' size='2048'>0</pages>
        <distances>
          <sibling id='0' value='20'/>
          <sibling id='1' value='10'/>
        </distances>
        <cpus num='8'>
          <cpu id='1' socket_id='0' core_id='0' siblings='1,9'/>
          <cpu id='3' socket_id='0' core_id='1' siblings='3,11'/>
          <cpu id='5' socket_id='0' core_id='2' siblings='5,13'/>
          <cpu id='7' socket_id='0' core_id='3' siblings='7,15'/>
          <cpu id='9' socket_id='0' core_id='0' siblings='1,9'/>
          <cpu id='11' socket_id='0' core_id='1' siblings='3,11'/>
          <cpu id='13' socket_id='0' core_id='2' siblings='5,13'/>
          <cpu id='15' socket_id='0' core_id='3' siblings='7,15'/>
       </cpus>
    </cell>
</cells>

STEP 2 | Pin vCPUs in a KVM guest to specific physical vCPUs, use the cpuset aribute in the guest
xml definion. In this example, all 8 vCPUs are pinned to physical CPUs in the first NUMA
node. If you do not wish to explicitly pin the vCPUs, you can omit the cputune block, in
which case, all vCPUs will be pinned to the range of CPUs specified in cpuset, but will not be
explicitly mapped.

<vcpu cpuset='0,2,4,6,8,10,12,14'>8</vcpu> 
<cputune> 
  <vcpupin vcpu='0' cpuset='0'/> 
  <vcpupin vcpu='1' cpuset='2'/> 
  <vcpupin vcpu='2' cpuset='4'/> 
  <vcpupin vcpu='3' cpuset='6'/> 
  <vcpupin vcpu='4' cpuset='8'/> 
  <vcpupin vcpu='5' cpuset='10'/> 
  <vcpupin vcpu='6' cpuset='12'/> 
  <vcpupin vcpu='7' cpuset='14'/> 
</cputune> 
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Intelligent Traffic Offload
Intelligent Traffic Offload is a VM-Series firewall Security subscripon that, when configured with
the NVIDIA BlueField-2 DPU, increases capacity throughput for the VM-Series firewall. The VM-
Series firewall and the BlueField-2 DPU must be installed on an x86 physical host running Ubuntu
18.04, with kernel version 4.15.0-20. The VM-Series firewall must be deployed in virtual wire
mode.

The Intelligent Traffic Offload (ITO) service routes the first few packets of a flow to the firewall
for inspecon to determine whether the rest of the packets in the flow should be inspected or
offloaded. This decision is based on policy or whether the flow can be inspected (for example,
encrypted traffic can’t be inspected). By only inspecng flows that can benefit from security
inspecon, the overall load on the firewall is greatly reduced and VM-Series firewall performance
increases without sacrificing security.

The current NVIDIA BlueField-2 DPU scalability limitaons are as follows:

• Session table capacity: 500,000 sessions
• Session table update rate: 7000 sessions/second
• Connecons per second: 20,000
• Offload hairpin rate: ~90 Gbps for 1500 byte packets

If offload traffic to the BlueField-2 DPU exceeds 7,000 sessions per second, or the offload session
table is full, traffic sll flows through the VM-Series firewall and is inspected. When the sessions
per second drops below 7,000, intelligent traffic offload to the Bluefield-2 DPU resumes.

Acve/Passive HA is supported for the VM-Series firewalls running on physical hosts with
idencal configuraons.

Intelligent Traffic Offload does not support the accelerated aging session seng.

• Intelligent Traffic Offload Requirements
• Intelligent Traffic Offload Interfaces
• High Availability
• Install the BlueField-2 DPU
• Install the VM-Series Firewall
• Check the BlueField-2 DPU System
• Enable Virtual Funcons
• Install or Upgrade the BlueField Bootstream Soware
• Install or Upgrade the Debian Package
• Run Intelligent Traffic Offload
• BlueField-2 DPU Troubleshoong
• PAN-OS Troubleshoong
• References
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Intelligent Traffic Offload Requirements
ITO requires one VM-Series firewall and one BlueField-2 DPU installed on the same x86 physical
host. Acve/Passive high availability for VM-Series firewalls is supported.

You can deploy only one VM-Series firewall and one BlueField-2 DPU per host.

• Network switch with 2 available 100GB/s ports (4 for HA).

If want to use VLANs, make sure your switch is capable.
• X86 physical host hardware requirements.

• Minimum 120GB available RAM (64GB for server / 56GB for VM-Series firewall)
• Minimum 18 Physical cores
• Bluefield-2 SmartNIC MBF2M516A-CEEOT with two 100GB/s ports installed in PCI-e slot

3 or 4.
• A cerfied 100GigE SFP for each port on the BlueField2 DPU, as recommended by the

NVIDIA BlueField Ethernet DPU User Guide.
• X86 host soware requirements.

• Ubuntu 18.04, with kernel version 4.15.0-20.
• Bluefield Binary bootstream version: 5.3-1.0.0.1

Accept the End User License Agreement to start the download.
• Virtual machine for the VM-Series firewall.

• PAN-OS 10.1 or later.
• VM-Series Plugin 2.1.0 or later.
• To license Intelligent Traffic Offload, create a Soware NGFW deployment profile for 10.0.4

and above, with a minimum of 18 vCPUs and the Intelligent Traffic Offload service. The
profile can include other security services.

With PAN-OS 10.1.1 or later and VM-Series Plugin 2.1.1 or later, to license Intelligent Traffic
Offload, create a Soware NGFW deployment profile for 10.0.4 and above, with a minimum
of six (6) vCPUs and the Intelligent Traffic Offload service. The profile can include other
security services.

Intelligent Traffic Offload Interfaces
An Intelligent Traffic Offload deployment connects three types of interfaces:

• PAN-OS virtual interfaces:

• eth0: management interface
• eth1, eth2: dataplane
• eth3: HA interface
• eth4: gRPC interface

• BlueField-2 DPU physical interfaces (created from the host OS).
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• Host physical interfaces for the BlueField-2 DPU 100GB ports (created from the host OS).

You connect the PAN-OS interfaces to the BlueField-2 DPU through SR-IOV virtual funcons
(VFs) you create on the physical host (see Enable Virtual Funcons).

In the following figure, the two BlueField-2 DPU ports are shown as Physical Funcons PF0 and
PF1. These PFs can be observed from the host side as enp4s0f0 and enp4s0f1, and are divided
into mulple VFs for SR-IOV funconality.

• The first VF for each PF must be the data port (eth1:pf0vf0).
• An addional VF is required for the control channel for the gRPC client/server interface

(eth4:pf0v1).
• VFs from the host side are as follows:

• enp4s0f0 is represented by pf0vf0 and pf1vf0 on the BlueField-2 DPU, and are used for
data.

• enp4s0f1 is represented by pf0vf1 and is used for gRPC control traffic.

High Availability
Acve/Passive HA is supported for a pair of VM-Series firewalls deployed in Vwire mode on
physical hosts.

• The firewalls must be installed on physical hosts with the BlueField-2 DPU configured as
specified in Intelligent Traffic Offload Requirements.

• For the HA2 interface (see the figures in Acve Packet Flow and Passive Packet Flow), use the
same Mellanox interface (cx-3, cx-4, or cx-5) on both hosts.

• (oponal) To support traffic switching, the hosts must be on separate VLANs so you can use
VLAN tags to select the primary, as described in Secure Traffic Across Linux Hosts.

ITO H/A focuses on VM-Series firewall availability. Each firewall maintains a session table, and
each BlueField-2 DPU maintains a flow table. The HA configuraon synchronizes the acve
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session table, ensuring it is mirrored to the passive firewall at runme. The session table stores
both sessions that require inspecon and sessions that are marked for offload.

HA uses the PAN-OS interface eth3, which is on a NIC on the VM-Series firewall. Eth3 is used to
select the acve firewall, and sync the VM-Series firewall session tables on the acve/passive pair.

Acve Packet Flow
The following diagram steps through the acve packet flow for an HA configuraon that uses an
oponal VLAN configuraon.

1. Packet is sent from the client applicaon to the network switch.
2. The packet arrives at the switch port that is programmed to add a VLAN 100 tag to the

packets.
3. The tagged packets can only go to Port Pa1 as the interface for port Ps1 is down because that

firewall is in passive mode.
4. The packet arrives at port Pa1 and VLAN 100 is removed from the packet and the packet is

delivered to the firewall eth1.
5. The firewall is running in vWire mode so the packet is processed by the firewall and then sent

out eth2.
6. The packet arrives at port Pa2 and VLAN 200 is added.
7. The packet is sent out port Pa2 and can only be delivered to port Ps because the other VLAN

200 port Ps2 is down.
8. The packet arrives at port Ps and the VLAN 200 tag is removed.
9. The packet is sent out port Ps with no VLAN tag
10.The packet is delivered to the server.
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Failover Event
A failover event occurs when there is either a noficaon from the acve VM-Series firewall or
the passive firewall detects that the acve is not responding. When this happens the network
connecons to ports Pa1 and Pa2 go down and the network connecons to ports Ps1 and Ps2
become acve.

Passive Packet Flow
When the VM-Series firewall is in the passive state, the BlueField-2 DPU on the passive
member is live but does not pass traffic unl there is a failover and the co-located VM-Series
firewall becomes acve. The following diagram steps through the passive packet flow for an HA
configuraon that uses an oponal VLAN configuraon.

1. The packet is sent from the client applicaon to the network switch.
2. The packet arrives at the switch port that is programmed to add a VLAN 100 tag to the

packets.
3. The tagged packets can only go to Port Ps1 because the interface for port Pa1 is down and that

firewall has now moved from passive to acve.
4. The packet arrives at port Ps1 and VLAN 100 is removed from the packet and the packet is

delivered to the firewall eth1.
5. The firewall is running in vWire mode so the packet is processed by the firewall and then sent

out eth2.
6. The packet arrives at port Ps2 and VLAN 200 is added.
7. The packet is sent out port Ps2 and can only be delivered to port Ps because the other VLAN

200 port Pa2 is down.
8. The packet arrives at port Ps and the VLAN 200 tag is removed.
9. The packet is sent out port Ps with no VLAN tag.
10.The packet is delivered to the server.

VM-Series Deployment Guide Version Version 10.1 542 ©2022 Palo Alto Networks, Inc.



Set Up the VM-Series Firewall on KVM

Install the BlueField-2 DPU
Install the BlueField-2 DPU on the physical host before you install the VM-Series firewall. For
informaon on the BlueField-2 DPU, see the soware documentaon: NVIDIA BLUEFIELD DPU
FAMILY SOFTWARE V3.5.0.11563 DOCUMENTATION.

1. Install the BlueField-2 DPU on the host machine as directed in the NVIDIA BlueField Ethernet
DPU User Guide.

2. Install the BlueField drivers as directed in the NVIDIA BlueField-2 DPU Soware Quick Start
Guide.

Install the VM-Series Firewall
The standard installaon for KVM on the VM-Series firewall installs PAN-OS. Follow the
installaon steps in the following secons.

• VM-Series on KVM—Requirements and Prerequisites
• Install the VM-Series Firewall Using Virt-Manager or Install the VM-Series Firewall Using an

ISO

Enable Virtual Funcons
As menoned in Intelligent Traffic Offload Interfaces virtual funcons (VFs) connect PAN-OS
interfaces to the BlueField-2 DPU.

The maximum number of virtual funcons VFs per port is 2. You need a total of three—two for the
data path and one for the management interface.

STEP 1 | Enable virtual funcons on the host machine.

• By default the BlueField-2 DPU uses the first VF for the datapath, i.e. enp4s0f0v0 and
enp4s0f1v0 in the following example.

• The other VF, enp4s0f0v1, is used for the management interface for the service running
on the BlueField-2 card (not to be confused with the VM-Series firewall management
interface).

$ cat /sys/class/net/enp4s0f0/device/sriov_totalvfs

   8

$ echo 2 > /sys/class/net/enp4s0f0/device/sriov_numvfs

$ cat /sys/class/net/enp4s0f1/device/sriov_totalvfs

   8

$ echo 2 > /sys/class/net/enp4s0f1/device/sriov_numvfs
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STEP 2 | Allocate VFs to the VM-Series firewall from the KVM hypervisor.

The Guest PAN-OS won’t boot unless VFs are allocated to the VM.

1. Shut off the VM.
2. On KVM use virt-manager to add VFs to the VM.

• Select Add Hardware, select VF0 of PF1, and click Finish.
• Select Add Hardware, select VF0 of PF0, and click Finish.
• Select Add Hardware, select VF1 of PF0, and click Finish.

Check the BlueField-2 DPU System
The BlueField-2 DPU first communicates with the host when the Rshim driver driver is installed
on the host. The Rshim provides a y (accessible through minicom) interface and a networking
interface called tmfifo_net0. With the tmfifo_net0 interface you can ssh in to the BlueField-2 DPU
from the host. The Rshim driver runs on the x86 Hypervisor OS, and in fact, the OFED installaon
installs an Rshim driver by default.
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STEP 1 | Log in to the host machine.

$ ssh user@<host-ip-address>

$ password: 

STEP 2 | If the host network interface for the Rshim driver does not have an IP address, you must
create one.

$ ip addr add dev tmfifo_net0 192.168.100.1/24

STEP 3 | From the host machine log in to the BlueField-2 DPU subsystem.

$ ssh ubuntu@192.168.100.2

$ password: ubuntu

If this is your first login the system prompts you to replace the default password with a new
password.

STEP 4 | Change the default password on the BlueField-2 DPU.

Log in to BlueField-2 DPU with inial username as ubuntu and the password ubuntu.

Once you log in, the system prompts you to set up a new password.

WARNING: Your password has expired.
You must change your password now and login again!
Changing password for ubuntu.
Current password: *****
New password:  *****
Retype new password: *****
passwd: password updated successfully

Log out and log in with your new password.

STEP 5 | Check the soware version.

$ ofed_info -s

This should return the following version or later:

$ MLNX_OFED_LINUX-5.3-0.3.3

STEP 6 | Check that the Bluefield 2 DPU is in the correct mode.

The correct mode is embedded CPU funcon ownership mode. See the Embedded CPU
Funcon Ownership Mode documentaon for instrucons to check and configure the mode.
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Install or Upgrade the BlueField Bootstream Soware
Follow these steps to ensure you have the latest Bluefield bootstream (BFB) soware for the
BlueField-2 DPU. The BFB includes the BlueField OS and other soware such as drivers and
network interfaces.

STEP 1 | Download the BFB package to the physical host for the BlueField-2 DPU.

Get the latest version of the driver for the OS running on the DPI ARM cores from the NVIDIA
website—you must accept the end-user license agreement to download.

STEP 2 | Install the BFB from the Rshim boot locaon on the physical host.

Note, the filename below (the string starng with DOCA and ending with .bfb) does not
contain spaces. Enter the command on a single line.

$ cat DOCA_v1.0_BlueField_OS_Ubuntu_20.04-5.3-1.0.0.0-3.6.0.11699-1-
aarch64.bfb > /dev/rshim0/boot

STEP 3 | Log in to the BlueField-2 DPU.

Use the new password you created in Check the BlueField-2 DPU System.

$ ssh ubuntu@192.168.100.2

$ password: 

STEP 4 | Apply the firmware upgrade on the BlueField-2 DPU.

Enter the following command on a single line.

$ sudo /opt/mellanox/mlnx-fw-updater/firmware/
mlxfwmanager_sriov_dis_aarch64_41686

STEP 5 | Power cycle the system.

Log off the BlueField-2 DPU and return to Linux host.

$ ipmitool chassis power cycle

STEP 6 | Log in to the BlueField-2 DPU.

$ ssh ubuntu@192.168.100.2

$ password: 

VM-Series Deployment Guide Version Version 10.1 546 ©2022 Palo Alto Networks, Inc.

https://www.mellanox.com/eula/blue-os?mtag=bluefield_sw_drivers&mrequest=downloads&mtype=BlueField&mver=BFBs&mname=Ubuntu20.04&mfile=DOCA_v1.0_BlueField_OS_Ubuntu_20.04-5.3-1.0.0.0-3.6.0.11699-1-aarch64.bfb
https://www.mellanox.com/eula/blue-os?mtag=bluefield_sw_drivers&mrequest=downloads&mtype=BlueField&mver=BFBs&mname=Ubuntu20.04&mfile=DOCA_v1.0_BlueField_OS_Ubuntu_20.04-5.3-1.0.0.0-3.6.0.11699-1-aarch64.bfb


Set Up the VM-Series Firewall on KVM

STEP 7 | Start the opof (open offload) service on the BlueField-2 DPU. opof is a standalone service at
this me.

The VFs must exist before you start opof. See Enable Virtual Funcons.

$ opof_setup

$ service opof restart

STEP 8 | Verify the opof service is running without issues.

$ service opof status

Install or Upgrade the Debian Package
If the Debian package version is earlier than 1.0.4 you must upgrade.

STEP 1 | On the BlueField-2 DPU, check the version of the opof package.

$ opof -v

If it is earlier than 1.0.4 it must be upgraded.

STEP 2 | Add the NViIDIA repository for packages.

$ cd /etc/apt/sources.list.d

Enter each wget command all on one line. There are no spaces in the URLs:

wget https://linux.mellanox.com/public/repo/doca/1.0/ubuntu20.04/
doca.list

wget -qO - https://linux.mellanox.com/public/repo/doca/1.0/
ubuntu20.04/aarch64/GPG-KEY-Mellanox.pub | sudo apt-key add -

$ apt update

STEP 3 | On the BlueField-2 DPU check the Debian package in the repository.

$ apt search opof

Sorting... Done
Full Text Search... Done
opof/now 1.0.4 arm64 [installed,local]
  Nvidia Firewall Open Offload Daemon

STEP 4 | On ARM, uninstall the obsolete Debian package.

$ apt remove opof

STEP 5 | Install the new Debian package.

$ apt install opof
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STEP 6 | Set up and restart the opof service.

$ opof_setup

$ service opof restart

STEP 7 | Verify the opof service is running without issues.

$ service opof status

Run Intelligent Traffic Offload
This soluon requires a subscripon to the Intelligent Traffic Offload soware and a minimum
of 18 physical cores for the best performance/throughput. By default, PAN-OS allocates 2 cores
for Intelligent Traffic Offload, 4 cores for management processes and the remaining 12 cores for
dataplane processing.

• Set Up Intelligent Traffic Offload on the VM-Series Firewall
• Set Up the Intelligent Traffic Offload Service on the BlueField-2 DPU
• Start or Restart the Intelligent Traffic Offload Service
• Get Service Status and Health

Set Up Intelligent Traffic Offload on the VM-Series Firewall
Follow these steps to enable Intelligent Traffic Offload on PAN-OS.

STEP 1 | Bring up the PAN-OS VM. This assumes that you already have a VM instance created and are
restarng it.

$ virsh start <vm-name>

STEP 2 | Use SSH to log in to the VM-Series firewall management interface.

$ ssh admin@<panos-management-IP-address>

$ admin@PA-VM>

STEP 3 | Verify that Intelligent Traffic Offload is installed and licensed.

admin@PA-VM> show intelligent-traffic-offload

Intelligent Traffic Offload:
  Configuration            : Enabled
  Operation Enabled        : True
  Min number packet        : 8
  Min Rate                 : 95
  TCP ageing               : 12-
  UDP ageing               : 20

Configuration:Enabled means Intelligent Traffic Outload is licensed.

Operation Enabled:True means you have rebooted a configured device.
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STEP 4 | Enable Intelligent Traffic Offload.

Use the following command to enable ITO without reboong the system.

admin@PA-VM> set session offload yes

You can also use set session offload no to disable the ITO without reboong the
system.

STEP 5 | Validate Intelligent Traffic Offload.

admin@PA-VM> show session info | match offload

Hardware session offloading:      True
Hardware UDP session offloading:  True

To view global counters, use the following command:

admin@PA-VM> show counter global | match flow_offload

See Session Counters for more on the organizaon of the output and a descripon of each
counter.

Set Up the Intelligent Traffic Offload Service on the BlueField-2 DPU
The service must be built as described in Set Up Intelligent Traffic Offload on the VM-Series
Firewall.

STEP 1 | From the host machine, log in to the BlueField-2 DPU complex.

$ ssh ubuntu@192.168.100.2

$ password: ubuntu
$ ubuntu> sudo -i

STEP 2 | Set up the preliminary configuraon in the BlueField-2 DPU OS.

root@bf2SmartNIC:~# opof_setup

[ INFO ] No num of hugepages specified, use 2048 
[ INFO ] No gRPC port specified, use pf0vf1
Configure ovs fallback 
Configure grpc for pf0vf1 
Reserved 2048*2MB hugepages

Start or Restart the Intelligent Traffic Offload Service
If the ITO service is running on a DPU, the service probably started automacally. To check the
status, run the following command:

$ service opof status

If the opof service is not running, enter the following command to start the controller:

$ service opof start
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To restart the service, run the following command:

$ service opof restart

Get Service Status and Health
Use opof to get the service status and health. Each command has its own command-line help, for
example: $ opof -h

• Query a session:

$ opof query -i <session_id>
• Query service offload stascs:

$ opof stats

BlueField-2 DPU Troubleshoong
Use the following procedure to power cycle the system.

1. To power cycle the system, log out of the BlueField-2 DPU and return to the Linux host OS.

$ ipmitool chassis power cycle
2. If the interfaces do not come up aer the power cycle, log in to the BlueField-2 DPU and enter:

$ /sbin/mlnx_bf_configure
3. Return to the host OS and enter:

$ sudo /etc/init.d/openibd restart

PAN-OS Troubleshoong
Validate Traffic Flows

Data traffic can be generated from the client and consumed through the Intelligent Traffic Offload
setup by a server. IPERF3 can be used to generate traffic, as discussed in Run IPERF3 Tests. Once
the traffic is iniated, the first few packets of the flow are sent to the PA-VM which decides if the
flow needs to be offloaded or not.

An applicaon override policy must be defined to idenfy flows for offload. A TCP flow sets the
FIN/RST flag on a control packet and sends it to the PA-VM. When the PA-VM decides to offload
the flow, use show session all to display the offloaded flows. Use show session id <flowID>
to provide informaon on the state of the flow. An offloaded flow has the state Offload: yes.

The flow counters are not updated while subsequent packets of the flow are in the offload state
and are passing through the BlueField-2 DPU. Once the flow completes, the offload service
triggers an age-out mer (TCP aging configured from the CLI). When the mer expires, the service
collects the updated flow stascs and sends them to the VM-Series firewall. The firewall then
updates its flow session counters, and show session id <flowID> returns the updated
values.

Session Counters
Use the following command to view session counters.
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admin@PA-VM > show counter global | match flow_offload

The output columns for each counter are:

Counter Name | Value | Rate | Severity | Category | Aspect | Descripon.

• Value—Number of occurrences since system start.
• Rate—Frequency of counter change.
• Severity—Info, Warning, Drop. Used for Tech Support.
• Category—Flow (a component of a session).
• Aspect—Offload for an enre flow.

Counter Name Descripon

flow_offload_rcv_cpu Number of packets received by CPU with session
offloaded

flow_offload_session_update Number of mes the session needs to be updated

flow_offload_session_insert Number of sessions inserted in the offload device

flow_offload_session_delete Number of sessions deleted from offload device

flow_offload_delete_msg_failed Number of del messages to GRPC that failed

flow_offload_add_msg_failed Number of session messages to GRPC that failed

flow_offload_session_verify Number of verify messages to the offload device

flow_offload_verify_msg_failed Number of verify messages to GRPC that failed

flow_offload_update_session_stat HW indicates flow age out

flow_offload_missing_session_stat Cannot find session for stats

flow_offload_invalid_session Offload invalid session ID

flow_offload_del_session_fail Offload Delete invalid session

flow_offload_add_session_fail Offload Add session failed

flow_offload_get_session_fail Offload Get session failed

flow_offload_grpc_fail Offload grpc call failed

flow_offload_acve_session Number of acve offloaded sessions

flow_offload_aged_session Number of aged out offloaded sessions

flow_offload_session Number of offloaded sessions
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Run IPERF3 Tests
Iperf3 is an oponal simple applicaon for generang traffic that is effecve in running data traffic
tests. To run the server as a service, use iperf3 -s -D. By default the applicaon expects
packets on TCP/UDP desnaon port 5201, but the port can be changed.

• Single flow—For single iperf3 flows enter:

iperf3 -c <server-ip-address> -t 60

• Mulple flows—To iniate 20 concurrent flows for a 60 second duraon, enter:

iperf3 -c <ip of server> -P 20 -t 60

Validate Intelligent Traffic Offload
You can use VM-Series firewall logs to validate the connecvity between the ITO client running
on the firewall and the offload service on the BlueField-2 DPU. The expected log output for a
successful offload is as follows.

admin@auto-pavm> less mp-log pan_grpcd.log

[PD] dec free list 0xe0ff022000 
RS LIB INIT in DP! 
pan_fec_app_init: fec_data 0xe0feef1088, maxentries 120 
[FEC] enc free list 0xe0feef1100, dec free list 0xe0feef10b8 
Creating dp grpc ring buf
Initializing dp grpc ring buf
Mapping flow data memory
Found offload parameters
Heart beat found 1
Established connection to offload device

OPOF Troubleshoong
You can also view the offload service logs to validate connecvity:

root@linux:~# service opof status

● opof.service - Nvidia Firewall Intelligent Traffic Offload Daemon
   Loaded: loaded (/etc/systemd/system/opof.service; disabled; vendor
 preset: enabled)
   Active: active (running) since Fri 2021-05-21 18:40:38 UTC; 3h
 48min ago
    Docs: file:/opt/mellanox/opof/README.md
  Process: 163906 ExecStartPre=/usr/sbin/opof_pre_check (code=exited,
 status=0/SUCCESS)
  Main PID: 163922 (nv_opof)
   Tasks: 30 (limit: 19085)
   Memory: 50.7M
   CGroup: /system.slice/opof.service
       └─163922 /usr/sbin/nv_opof -n 1 -a
 0000:03:00.0,representor=[0] -a 0000:03:00.1,representor=[0]
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May 21 18:40:38 localhost.localdomain nv_opof[163922]: EAL: Probe PCI
 driver: mlx5_pci (15b3:a2d6) device: 0000:03:00.0 (socket 0)
May 21 18:40:38 localhost.localdomain nv_opof[163922]: EAL:  Invalid
 NUMA socket, default to 0
May 21 18:40:38 localhost.localdomain nv_opof[163922]: EAL: Probe PCI
 driver: mlx5_pci (15b3:a2d6) device: 0000:03:00.0 (socket 0)
May 21 18:40:38 localhost.localdomain nv_opof[163922]: EAL:  Invalid
 NUMA socket, default to 0
May 21 18:40:38 localhost.localdomain nv_opof[163922]: EAL: Probe PCI
 driver: mlx5_pci (15b3:a2d6) device: 0000:03:00.1 (socket 0)
May 21 18:40:38 localhost.localdomain nv_opof[163922]: EAL:  Invalid
 NUMA socket, default to 0
May 21 18:40:38 localhost.localdomain nv_opof[163922]: EAL: Probe PCI
 driver: mlx5_pci (15b3:a2d6) device: 0000:03:00.1 (socket 0)
May 21 18:40:39 localhost.localdomain nv_opof[163922]: EAL: No legacy
 callbacks, legacy socket not created
May 21 18:40:39 localhost.localdomain nv_opof[163922]: EAL: No legacy
 callbacks, legacy socket not created
May 21 18:40:42 localhost.localdomain nv_opof[163922]: Server
 listening on: 169.254.33.51:3443

The logs show that the Intelligent Traffic Offload is communicang with the VM-Series firewall
PA-VM over the server listening on IP address, and you see the VFs along with other
details of the DPDK parameters. Also aached is a log from the addion of a TCP flow that is
offloaded.

References
• NVIDIA BlueField Ethernet DPU User Guide
• NVIDIA BLUEFIELD DPU FAMILY SOFTWARE V3.5.0.11563 D
• Nvidia DPU Intelligent Traffic Offload Daemon
• OpenOffload gRPC GITHUB
• PAN-OS Administrator’s Guide
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Hyper-V

The VM-Series firewall can be deployed on a server running Microso Hyper-V.
Hyper-V is packaged as a standalone hypervisor or as an add-on/role for Windows
Server.

> Supported Deployments on Hyper-V
> System Requirements on Hyper-V
> Linux Integraon Services
> Install the VM-Series Firewall on Hyper-V
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Supported Deployments on Hyper-V
You can deploy one or more instances of the VM-Series on hosts running Hyper-V. Where you
place the VM-Series firewall depends on your network topology. VM-Series supports tap, virtual
wire, Layer 2, and Layer 3 interface deployments.

• Secure Traffic on a Single Hyper-V Host
• Secure Traffic Across Mulple Hyper-V Hosts

Secure Traffic on a Single Hyper-V Host
The VM-Series firewall is deployed on a single Hyper-V host along with other guest VMs. In the
example below, the VM-Series firewall has a Layer 3 interfaces and the VM-Series and other guest
VMs are connected by Hyper-V vSwitches. All traffic between the web servers and database
servers is routed through the firewall. Traffic across the database servers only or across the web
servers only is processed by the external vSwitch and not routed through the firewall.

Secure Traffic Across Mulple Hyper-V Hosts
You can deploy your VM-Series firewall to secure the traffic of mulple Hyper-V hosts. In the
example below, the VM-Series is deployed in Layer 2 mode protecng traffic to and from the
guest VMs. A single VM-Series firewall protects traffic between four guest VMs spread across
two Hyper-V hosts. VLAN tagging is used to logically isolate traffic and direct it to the firewall.
Addionally, management traffic is decoupled from all other traffic by placing it on its own
external vSwitch.
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System Requirements on Hyper-V
The VM-Series requires a minimum resource allocaon on the Hyper-V host, so make sure to
conform to the requirements listed below to ensure opmal performance.

• The host CPU must be a 64-bit x86-based Intel or AMD CPU with virtualizaon extension.
• See VM-Series System Requirements for the minimum hardware requirements for your VM-

Series model.
• Minimum of two network adapters. The VM-Series firewall supports synthec network

adapters, which provide beer performance than emulated network adapters. Hyper-V
supports up to eight synthec network adapters.

• Refer to the Compability matrix for the Windows Server versions supported.

Hyper-V Server does not have a nave graphical user interface; all configuraon is done
through PowerShell. However, you can use Hyper-V Manager running on a remote machine
to manage the firewall.If you use the Hyper-V role add-on, you can manage the firewall using
Hyper-V Manager or PowerShell.

• The VM-Series firewall supports SR-IOV/PCI-Passthrough.

DPDK is only supported with Nvidia/Mellanox(Mlx5) SRIOV devices. Trunk mode with
SR-IOV is not supported.
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Linux Integraon Services
Linux Integraon Services (LIS) is a package of drivers and services that enhance the performance
of Linux-based virtual machines on Hyper-V. The VM-Series firewall supports the following
services to improve the integraon between the host and the virtual machine:

• Graceful Shutdown—Allows you to perform a graceful shutdown of the VM-Series firewall from
the Hyper-V management interface without having to log into the guest.

• Heartbeat to Hyper-V Manager—Provides heartbeat monitoring of the running status of guest
VMs from the Hyper-V management interface.

• Firewall Management IP Address Visibility—Allows you to use Hyper-V Manager to view the IP
address assigned to the management interface on the firewall.
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Install the VM-Series Firewall on Hyper-V
Use the instrucons in this secon to deploy your VM-Series firewall on a Hyper-V host. A Palo
Alto Networks support account and a valid VM-Series license are required to download the VHDX
image file and install the VM-Series on the Hyper-V host. If you have not already registered the
capacity auth-code that you received with the order fulfillment email, with your support account,
see Register the VM-Series Firewall. Aer compleng the registraon connue to the following
tasks:

• Before You Begin
• Performance Tuning of the VM-Series Firewall on Hyper-V
• Provision the VM-Series Firewall on a Hyper-V host with Hyper-V Manager
• Provision the VM-Series Firewall on a Hyper-V host with PowerShell
• Perform Inial Configuraon on the VM-Series Firewall

Before You Begin
Before installing and configuring your VM-Series firewall, know and account for the following
items as needed when you configure your VM-Series firewall:

• Virtual Switch Types
• MAC Address Spoofing

Virtual Switch Types
Before installing the VM-Series, you must create the vSwitches required for providing external
connecvity for management access and for roung traffic from and to the virtual machines that
the firewall will secure. Hyper-V allows you to create three types of vSwitches:

• External vSwitch—binds to a physical network adapter and provides the vSwitch access to a
physical network.

• Internal vSwitch—passes traffic between the virtual machines and the Hyper-V host. This type
of vSwitch does not provide connecvity to a physical network connecon.

• Private vSwitch—passes traffic between the virtual machines on the Hyper-V host only.

An external vSwitch is required for management of the VM-Series firewall. Other vSwitches
connected to the VM-Series firewall can be of any type and will depend on your network
topology.

MAC Address Spoofing
If you are deploying the VM-Series firewall with interfaces enabled in Layer 3 mode, make sure
to enable use of hypervisor assigned MAC addresses so that the hypervisor and the firewall can
properly handle packets. Alternavely, use the Hyper-V Manager to enable MAC address spoofing
on the virtual network adapter for each dataplane interface on the firewall. For more informaon,
see Hypervisor Assigned MAC Addresses.

If you are deploying the VM-Series firewall with interfaces enabled in Layer 2 mode or virtual-wire
mode, you must enable MAC address spoofing on the virtual network adapter in Hyper-V for each
dataplane interface on the firewall. This seng is required to ensure that packets sent by the VM-
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Series are not dropped by the virtual network adapter if the source MAC address does not match
the outgoing interface MAC address.

Performance Tuning of the VM-Series Firewall on Hyper-V
The VM-Series firewall for Hyper-V is a high-performance appliance but may require tuning
of the hypervisor to achieve the best results. This secon describes some best pracces and
recommendaons for facilitang the best performance of the VM-Series firewall.

• Disable Virtual Machine Queues
• Isolate CPU Resources in a NUMA Node

Disable Virtual Machine Queues
Palo Alto Networks recommends disabling virtual machine queues (VMQ) for all NICs on
the Hyper-V host. This opon is prone to misconfiguraon and can cause reduced network
performance when enabled.

STEP 1 | Login to Hyper-V Manager and select your VM.

STEP 2 | Select Sengs > Hardware > Network Adapter > Hardware Acceleraon.

STEP 3 | Under Virtual machine queue, uncheck Enable virtual machine queue.

STEP 4 | Click Apply save your changes and OK to exit the VM sengs.

Isolate CPU Resources in a NUMA Node
You can improve performance of VM-Series for Hyper-V by isolang the CPU resources of the
guest VM to a single non-uniform memory access (NUMA) node. You can view the NUMA sengs
of your VM in Hyper-V Manager by selecng Sengs > Hardware > Processor > NUMA.

Provision the VM-Series Firewall on a Hyper-V host with Hyper-V
Manager

Use these instrucons to deploy the VM-Series firewall on Hyper-V using Hyper-V Manager.

STEP 1 | Download the VHDX file.

Register your VM-Series firewall and obtain the VHDX file.

1. Go to hps://www.paloaltonetworks.com/services/support.
2. Filter by PAN-OS for VM-Series Base Images and download the VHDX file. For example,

PA-VM-HPV-7.1.0.vhdx.

STEP 2 | Set up any vSwitch(es) that you will need.

To create a vSwitch:

1. From Hyper-V Manager, select the host and select Acon > Virtual Switch Manager to
open the Virtual Switch Manager window.

2. Under Create virtual switch, select the type of vSwitch (external, internal, or private) to
create and click Create Virtual Switch.
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STEP 3 | Install the firewall.
1. On the Hyper-V Manager, select the host and select Acon > New > Virtual Machine.

Configure the following sengs in the New Virtual Machine Wizard:

1. Choose a Name and Locaon for the VM-Series firewall. The VM-Series firewall
stores the VHDX file at the specified locaon.

2. Choose Generaon 1. This is the default opon and the only version supported.
3. For Startup Memory, assign the memory based on the VM-Series System

Requirements of your VM-Series model.

Do not enable dynamic memory; the VM-Series firewall requires stac
memory allocaon.

4. Configure Networking. Select an external vSwitch to connect the management
interface on the firewall.

5. To connect the Virtual Hard Disk, select Use an exisng virtual hard disk and browse
to the VHDX file you downloaded earlier.

6. Review the summary and click Finish.
2. Assign virtual CPUs to the firewall.

1. Select the VM you created and navigate to Acon > Sengs.
2. Select Processor and enter the minimum number of CPUs based on the VM-Series

System Requirements of your VM-Series model..
3. Click OK.

STEP 4 | Connect at least one network adapter for the dataplane interface on the firewall.
1. Select Sengs > Hardware > Add Hardware and select the Hardware type for your

network adapter.

Legacy Network Adapter and SR-IOV are not supported. If selected, the VM-
Series firewall will boot into maintenance mode.

2. Click OK.

STEP 5 | (Oponal) Enable MAC address spoofing on Hyper-V if you are not using Layer 3 with
hypervisor assigned MAC address.
1. Double click the dataplane virtual network adapter and click Advanced Sengs.
2. Click the Enable MAC address spoofing check box and click Apply.

STEP 6 | Power on the firewall.

Select the firewall from the list of Virtual Machines and navigate to Acon > Start to power on
the firewall.

Provision the VM-Series Firewall on a Hyper-V host with
PowerShell

Use these instrucons to deploy the VM-Series firewall on Hyper-V using PowerShell.
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STEP 1 | Download the VHDX file.

Register your VM-Series firewall and obtain the VHDX file.

1. Go to hps://www.paloaltonetworks.com/services/support.
2. Filter by PAN-OS for VM-Series Base Images and download the VHDX file. For example,

PA-VM-HPV-7.1.0.vhdx.

STEP 2 | Set up any vSwitch(es) that you will need.

Create a vSwitch by using the following commands. Give the vSwitch a name and choose the
switch type.

> New-VMSwitch -Name <"switch-name"> -SwitchType <switch-type>

STEP 3 | Install the VM-Series firewall.
1. Create the new virtual machine and set the memory based on the VM-Series System

Requirements of your VM-Series model.

> NEW-VM -Name <vm-name> -MemoryStartupBytes 4GB -
VHDPath <file-path-to-vhdx> 

2. Set processor count based on the VM-Series System Requirements of your VM-Series
model.

> SET-VMProcessor –VMName <vm-name> –Count 2 

STEP 4 | Connect at least one network adapter for the management interface on the firewall.

Connect the default network adapter created during VM creaon to management vSwitch.

> connect-VMNetworkAdapter -vmname <vm-name> -Name <"network-
adapter-name"> -SwitchName <"management-vswitch">

STEP 5 | (Oponal) Enable MAC address spoofing on Hyper-V if you are not using Layer 3 with
hypervisor assigned MAC address.

> Set-VMNetworkAdapter -vmname <vm-name> -Name <"network-adapter-
name"> -MacAddressSpoofing On

STEP 6 | Power on the firewall.

For example:

> Start-VM -vmname <vm-name>
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Perform Inial Configuraon on the VM-Series Firewall
Use these instrucons to perform the inial configuraon of your VM-Series firewall. By default,
the VM-Series firewall uses DHCP to obtain an IP address for the management interface.
However, you can assign a stac IP address. Aer compleng the inial configuraon, access
the web interface to complete further configuraons tasks. If you have Panorama for central
management, refer to the Panorama Administrator’s Guide for informaon on managing the
device using Panorama.

If you are using bootstrapping to perform the configuraon of your VM-Series firewall on
Hyper-V, refer to Bootstrap the VM-Series Firewall on Hyper-V. For general informaon about
bootstrapping, see Bootstrap the VM-Series Firewall.

STEP 1 | Gather the required informaon from your network administrator.

• Management port IP address
• Netmask
• Default gateway
• DNS server IP address

STEP 2 | Access the console of the VM-Series firewall.
1. In Hyper-V Manager, select the VM-Series firewall and click Connect from the Acons

list.
2. Log in to the firewall with the default username and password: admin/admin
3. Enter configuraon mode using the following command: configure

STEP 3 | Configure the network access sengs for the management interface.

Enter the following commands:

set deviceconfig system type static

set deviceconfig system ip-address <Firewall-IP> netmask <netmask> 
default-gateway <gateway-IP> dns-settingservers primary <DNS-IP>

where <Firewall-IP> is the IP address you want to assign to the management interface,
<netmask> is the subnet mask, <gateway-IP> is the IP address of the network gateway, and
<DNS-IP> is the IP address of the DNS server.

STEP 4 | Commit your changes and exit the configuraon mode.
1. Enter commit.
2. Enter exit.
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STEP 5 | Verify that you can view the management interface IP address from the Hyper-V Manager.
1. Select the VM-Series firewall from the list of Virtual Machines.
2. Select Networking. The first network adapter that displays in the list is used for

management access to the firewall; subsequent adapters in the list are used as the
dataplane interfaces on the firewall.

STEP 6 | Verify network access to external services required for firewall management, such as the Palo
Alto Networks Update Server.
1. Use the ping ulity to verify network connecvity to the Palo Alto Networks Update

server as shown in the following example. Verify that DNS resoluon occurs and the
response includes the IP address for the Update server; the update server does not
respond to a ping request.

admin@PA-220 > ping host updates.paloaltonetworks.com

PING updates.paloaltonetworks.com (10.101.16.13) 56(84) bytes
 of data. 
From 192.168.1.1 icmp_seq=1 Destination Host Unreachable 
From 192.168.1.1 icmp_seq=2 Destination Host Unreachable 
From 192.168.1.1 icmp_seq=3 Destination Host Unreachable 
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From 192.168.1.1 icmp_seq=4 Destination Host Unreachable  

Aer verifying DNS resoluon, press Ctrl+C to stop the ping request.

2. Use the following CLI command to retrieve informaon on the support entlement for
the firewall from the Palo Alto Networks update server:

request support
check 

If you have connecvity, the update server will respond with the support status for your
firewall.

STEP 7 | (Oponal) Verify that your VM-Series jumbo frame configuraon does not exceed the
maximum MTU supported on Hyper-V.

The VM-Series has a default MTU size of 9216 bytes when jumbo frames are enabled.
However, the maximum MTU size supported by the physical network adapter on the Hyper-
V host is 9000 or 9014 bytes depending on the network adapter capabilies. To verify the
configured MTU on Hyper-V:

1. In Windows Server 2012 R2, open the Control Panel and navigate to Network and
Internet > Network and Sharing Center > View network status and tasks.

2. Click on a network adapter or virtual switch from the list.
3. Click Properes.
4. Click Configure.
5. On the Advanced tab, select Jumbo Packet from the list.
6. Select 9000 or 9014 bytes from the Value drop-down menu.
7. Click OK.

If you have enabled jumbo frames on Hyper-V, Enable Jumbo Frames on the VM-Series
Firewall and set the MTU size to match that configured on the Hyper-V host.

When you enable jumbo frames on the VM-Series firewall, it is applied to all interfaces.
If you do not need to jumbo frames on all interfaces, in the case of OSPF establishment
with neighbors for example, you must manually set the MTU for the specific interface
to 1496.

STEP 8 | Access the web interface of the VM-Series firewall and configure the interfaces and define
security rules and NAT rules to safely enable the applicaons you want to secure.

Refer to the PAN-OS Administrator’s Guide.
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VM-Series firewall on Azure brings the security features of Palo Alto Networks next
generaon firewall as a virtual machine in the Azure Marketplace. The VM-Series
firewall provides a complete set of security funconality to ensure that your virtual
machine workloads and data are protected, and the capabilies that the firewall
enables are different from nave security features such as Security Groups, Web
Applicaon Firewalls and nave, port-based firewalls.

On Azure, the VM-Series firewall is available in the bring your own license (BYOL)
model or in the pay-as-you-go (PAYG) hourly model. Microso Azure allows you to
deploy the firewall to secure your workloads within the virtual network in the cloud,
so that you can deploy a public cloud soluon or you can extend the on-premises IT
infrastructure to create a hybrid soluon.

> About the VM-Series Firewall on
Azure

> Deployments Supported on Azure
> Deploy the VM-Series Firewall from

the Azure Marketplace (Soluon
Template)

> Deploy the VM-Series Firewall
from the Azure China Marketplace
(Soluon Template)

> Panorama Orchestrated
Deployments in Azure

> Deploy the VM-Series with the Azure
Gateway Load Balancer

> Create a Custom VM-Series Image
for Azure

> Use Azure Security Center
Recommendaons to Secure Your
Workloads

> Deploy the VM-Series Firewall on
Azure Stack

> Enable Azure Applicaon Insights on
the VM-Series Firewall

> VM Monitoring on Azure
> Set up Acve/Passive HA on Azure
> Use the ARM Template to Deploy the

VM-Series Firewall
> Deploy the VM-Series and Azure

Applicaon Gateway Template
> Secure Kubernetes Services on Azure
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About the VM-Series Firewall on Azure
The VM-Series firewall on Azure must be deployed in a virtual network (VNet) using the Resource
Manager deployment mode. You can deploy the VM-Series firewall on the standard Azure public
cloud, Azure China, and Azure Government—including DoD on Azure Government, which meets
the security requirements for DoD Impact Level 5 data and FedRAMP High standards.

The VM-Series firewall on the marketplace for the Azure public cloud, Azure Government, and
Azure DoD regions, supports both the Bring Your Own License (BYOL) model and the hourly Pay-
As-You-Go (PAYG) opon (usage-based licensing) For licensing details, see License Types—VM-
Series Firewalls, and refer to the list of supported Azure regions in which you can deploy the VM-
Series firewall.

For Azure China, the VM-Series firewall is available in the BYOL opon only. See Deploy the VM-
Series Firewall from the Azure China Marketplace (Soluon Template) for the workflow.

You can also deploy the VM-Series firewall on Azure Stack, Microso's private cloud soluon that
enables you to use Azure services within your organizaon's datacenter. With Azure Stack, you
can build out a hybrid cloud soluon that unifies your public Azure deployment with your on-
premise Azure Stack set up. You can download the VM-Series firewall BYOL offer from the Azure
Marketplace and make it available to your tenants on Azure Stack. For instrucons, see Deploy the
VM-Series Firewall on Azure Stack.

• Azure Networking and VM-Series Firewall
• Azure Security Center Integraon
• VM-Series Firewall Templates on Azure
• Minimum System Requirements for the VM-Series on Azure
• Support for High Availability on VM-Series on Azure

Azure Networking and VM-Series Firewall
The Azure VNet infrastructure does not require virtual machines to have a network interface in
each subnet. The architecture includes an internal route table (called system routes) that directly
connects all virtual machines within a VNet such that traffic is automacally forwarded to a virtual
machine in any subnet. For a desnaon IP address that is not within the VNet, the traffic is
sent to the default Internet gateway or to a VPN gateway, if configured. In order to route traffic
through the VM-Series firewall, you must create user defined routes (UDRs) that specify the next
hop for traffic leaving a subnet. This route forces traffic desned to another subnet to go to the
VM-Series firewall instead of using the system routes to directly access the virtual machine in the
other subnet. For example, in a two-ered applicaon with a web er and a database er, you can
set up UDRs for direcng traffic from the web subnet to the DB subnet through the VM-Series
firewall.
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On Azure, UDRs are for traffic leaving a subnet only. You cannot create user defined routes
to specify how traffic comes into a subnet from the Internet or to route traffic to virtual
machines within a subnet. UDRs allow you to direct outbound traffic to an interface on
the VM-Series firewall so that you can always ensure that the firewall secures traffic to the
internet also.

For documentaon on Microso Azure, refer to hps://azure.microso.com/en-us/
documentaon/.

The soluon templates for deploying the VM-Series firewall that are available in the Azure
Marketplace, have three network interfaces. To Set up Acve/Passive HA on Azure, you will need
to add an addional interface for the HA2 link. If you want to customize the template, use the
ARM templates that are available in the GitHub repository.

Azure Security Center Integraon
Microso has deprecated Azure Security Center support for partner security soluons and
replaced it with Azure Sennel.

The VM-Series firewall is integrated with Azure Security Center to provide a unified view for
monitoring and alerng on the security posture of your Azure workloads. On Azure Security
Center, the VM-Series firewall is available as a partner security soluon that protects your Azure
workloads from threats and migates any gaps in securing your business and intellectual property
in the public cloud. To enable this integraon and display logs as security alerts directly on the
Azure Security Center dashboard, the VM-Series firewall on Azure includes a Log Forwarding
profile.

To get started, you need to enable Azure Security Center on your Azure subscripon. You then
have two ways in which you can enable this integraon:

• Deploy the VM-Series firewall based on a recommendaon on the Azure Security Center
dashboard.

When the Azure Security Center dashboard recommends that you deploy a VM-Series firewall
to secure a workload that is exposed to the internet, you can only deploy the firewall in an new
resource group or an exisng resource group that is empty. This is because Azure currently
restricts you from deploying a mul NIC appliance in an exisng resource group. Therefore,
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aer you deploy the VM-Series firewall you must manually configure it to be in the path of
traffic of the workload that you need to secure.

When you deploy the firewall from Azure Security Center, the firewall is launched with three
network interfaces—management, external facing (untrust) and internal facing (trust)—and
a user defined route (UDR) that sends all outbound traffic from the trust subnet to the trust
interface on the firewall so that internet-bound traffic is always inspected by the firewall.
The default configuraon includes two example Security Policy rules—the outbound-default
rule allows all traffic from the trust zone to the untrust zone on the applicaon default port,
and the inbound-default rule allows all web-browsing traffic from the untrust zone to the
trust zone, aer inspecng traffic with the default Anvirus, An-spyware, and Vulnerability
Protecon security profiles. The firewall also forwards all files that are intercepted with the
inbound or outbound rule to the WildFire public cloud for analysis. Both rules include a URL
Filtering profile that blocks all traffic to the URL categories copyright-infringement, dynamic-
dns, extremism, malware, phishing, and unknown. In addion to these security profiles, both
Security policy rules are enabled to log at session end and to forward Threat and WildFire
Submissions logs as security alerts to the Azure Security Center dashboard.

To make praccal use of this integraon and Deploy a VM-Series Firewall Based on an Azure
Security Center Recommendaonwithin the same resource group as the workloads you want
to secure, you can stage a workload with a public IP address that is exposed to the internet.
When Azure Security Center detects the security risk, it triggers a recommendaon to deploy
a next-generaon firewall, and you can then deploy the VM-Series firewall in a new resource
group into which you can add your workloads later. You must then delete the workload that
you staged to trigger the recommendaon.

• Select a VM-Series firewall that you have already deployed for securing your workloads. If you
have a Standard er of Azure Security Center subscripon, Azure Security Center discovers
and displays all exisng VM-Series firewalls that you have deployed either from the Azure
Marketplace or using a customized deployment with Azure CLI, PowerShell or ARM template.
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The firewalls within your Azure subscripon are grouped under Security Soluons on the Azure
Security Center dashboard.

Microso Azure does not support the discovery of exisng firewalls with the Free er
subscripon.

To Connect an Exisng VM-Series Firewall From Azure Security Center, you must set up a
Linux virtual machine and configure Syslog forwarding to forward firewall logs in the Common
Event Format as alerts to Azure Security Center. The addional configuraon enables a single
pane of glass view for monitoring all your Azure assets.

Forwarding a large volume of logs to Azure Security Center, may result in addional
subscripon cost to you.

VM-Series Firewall Templates on Azure
You can deploy the VM-Series firewall on Azure using templates. Palo Alto Networks provides two
kinds of templates—Soluon templates and ARM templates.

• Soluon Templates in the Azure Marketplace —The soluon templates that are available in the
Azure Marketplace allow you to deploy the VM-Series firewall using the Azure portal. You can
use an exisng resource group and storage account (or create them new) to deploy the VM-
Series firewall with the following default sengs for all regions except Azure China:

• VNet CIDR 10.8.0.0/16; you can customize the CIDR to a different private IP address range.
• Three subnets— 10.8.0.0/24 (management), 10.8.1.0/24 (untrust), 10.8.2.0/24 (trust)
• Three network interfaces, one in each subnet. If you customize the VNet CIDR, the subnet

ranges map to your changes.

To use the soluon template, see Deploy the VM-Series Firewall from the Azure Marketplace
(Soluon Template) for Azure China, see Deploy the VM-Series Firewall from the Azure China
Marketplace (Soluon Template).
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• ARM Templates in the GitHub Repository—In addion to Marketplace based deployments,
Palo Alto Networks provides Azure Resource Manager templates in the GitHub Repository to
simplify the process of deploying the VM-Series firewall on Azure.

• Use the ARM Template to Deploy the VM-Series Firewall—The basic ARM template includes
two JSON files (a Template file and a Parameters File) to help you deploy and provision
all the resources within the VNet in a single, coordinated operaon. These templates are
provided under an as-is, best effort, support policy.

If you want to use the Azure CLI to locate all the images available from Palo Alto
Networks, you the need the following details to complete the command (show vm-
image list):

• Publisher: paloaltonetworks
• Offer: vmseries-flex
• SKU: byol, bundle1, bundle 2
• Version: 10.0.0, or latest

• Deploy the VM-Series and Azure Applicaon Gateway Template to support a scale out
security architecture that protects your internet-facing web applicaons using two VM-
Series firewalls between a pair of (external and internal) Azure load balancers VM-Series and
Azure Applicaon Gateway. This template is currently not available for Azure China.

• Use the ARM template to deploy the VM-Series firewall in to an exisng Resource Group,
for example when you want to Set up Acve/Passive HA on Azure.

In addion to the ARM templates above that are covered under the Palo Alto Networks official
support policy, Palo Alto Networks provides Community supported templates in the Palo Alto
Networks GitHub repository that allow you to explore the soluons available to jumpstart your
journey in to cloud automaon and scale on Azure.

Minimum System Requirements for the VM-Series on Azure
You must deploy the VM-Series firewall in the Azure Resource Manager (ARM) mode only; the
classic mode (Service Management based deployments) is not supported. The VM-Series firewall
on Azure must meet the following requirements:

• Azure Linux VMs of the following types—Supported models.

These types include support for Accelerated Networking (SR-IOV).
• For memory, disk and CPU cores required to deploy the VM-Series firewall, see VM-Series

System Requirements.

You can add addional disk space of 40GB to 8TB for logging purposes. The VM-Series firewall
uses Azure managed disks where available; it does not ulize the temporary disk that Azure
provides with some instance types.

• Up to eight network interfaces (NICs). A primary interface is required for management access
and up to seven interfaces for data traffic.

On Azure, because a virtual machine does not require a network interface in each subnet, you
can set up the VM-Series firewall with three network interfaces (one for management traffic
and two for dataplane traffic). To create zone-based policy rules on the firewall, in addion to
the management interface, you need at least two dataplane interfaces so that you can assign
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one dataplane interface to the trust zone, and the other dataplane interface to the untrust zone.
For an HA deployment, you will need another interface for the HA2 link between the HA peers.

Because the Azure VNet is a Layer 3 network, the VM-Series firewall on Azure supports Layer
3 interfaces only.

Support for High Availability on VM-Series on Azure
To ensure availability, you can Set up Acve/Passive HA on Azurein a tradional configuraon
with session synchronizaon, or use a scale out architecture using cloud-nave load balancers
such as the Azure Applicaon Gateway or Azure Load Balancer to distribute traffic across a set
of healthy instances of the firewall. For details, see Deploy the VM-Series and Azure Applicaon
Gateway Template.

VM-Series on Azure Service Principal Permissions
For Panorama to interact with the Azure APIs and collect informaon on your workloads,
you need to create an Azure Acve Directory applicaon and a Service Principal that has the
permissions required to authencate with Azure AD and access the resources within your
subscripon.

To create the Acve Directory applicaon and Service Principal, follow the instrucons in How to:
Use the portal to create an Azure AD applicaon and service principal that can access resources.
During the applicaon generaon process, there is a step to "Assign applicaon to role" and assign
an IAM role of "reader" to the applicaon.

If you don't have the necessary permissions to create and register the AD applicaon, ask your
Azure AD or subscripon administrator to create a Service Principal.

Aer the applicaon has been registered, record these values so you can enter them in the
Panorama plugin for Azure at a later me:

• Applicaon ID
• Secret Key (record it when you make the secret key; the secret key is not visible once you

navigate away from the page).
• Tenant ID

Permissions
The following table lists the minimum built-in roles required and the granular permissions if you
would like to customize the role.

To support Permissions

Azure High Availability See Set up Acve/Passive HA on Azure.

Azure Applicaon
Insights

Enable Azure Applicaon
Insights on the VM-Series
Firewall

“Microsoft.Authorization/*/read”,

“Microsoft.Network/networkInterfaces/*”,

“Microsoft.Network/networkSecurityGroups/*”,

“Microsoft.Network/virtualNetworks/*”,
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To support Permissions
“Microsoft.Compute/virtualMachines/read”

Azure Monitoring

Set Up the Azure Plugin
for Monitoring on
Panorama

Requires a minimum Role of Reader for Service Principal.
Alternavely, you can add the following custom permissions:

“Microsoft.Compute/virtualMachines/read”,

“Microsoft.Network/networkInterfaces/read”,

“Microsoft.Network/virtualNetworks/read”,

“Microsoft.Network/locations/serviceTags/read”

"Microsoft.Network/loadBalancers/read",

"Microsoft.Network/publicIPAddresses/read"

"Microsoft.Resources/subscriptions/
resourcegroups/read",

“Microsoft.Resources/subscriptions/
resourcegroups/*”,

“Microsoft.Resources/deployments/write”,

“Microsoft.Resources/deployments/
operationStatuses/read”,

“Microsoft.Resources/deployments/read”,

“Microsoft.Resources/deployments/delete”

"Microsoft.Network/publicIPPrefixes/write",

"Microsoft.Network/publicIPPrefixes/read",

"Microsoft.Network/publicIPPrefixes/delete",

"Microsoft.Network/publicIPAddresses/write",

"Microsoft.Network/publicIPAddresses/read",

"Microsoft.Network/publicIPAddresses/delete",

"Microsoft.Network/publicIPAddresses/join/
action",

Panorama Orchestrated
Deployments

Create a Custom Role
and Associate it with an
Acve Directory

"Microsoft.Network/natGateways/write",

"Microsoft.Network/natGateways/read",

"Microsoft.Network/natGateways/delete",

"Microsoft.Network/natGateways/join/action",

 "Microsoft.Network/virtualNetworks/read",

"Microsoft.Network/virtualNetworks/write",
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To support Permissions
"Microsoft.Network/virtualNetworks/delete",

"Microsoft.Network/virtualNetworks/subnets/
write",

"Microsoft.Network/virtualNetworks/subnets/
read",

"Microsoft.Network/virtualNetworks/subnets/
delete",

"Microsoft.Network/virtualNetworks/subnets/join/
action",

"Microsoft.Network/virtualNetworks/
virtualNetworkPeerings/read",

"Microsoft.Network/networkSecurityGroups/write",

"Microsoft.Network/networkSecurityGroups/read",

"Microsoft.Network/networkSecurityGroups/
delete",

"Microsoft.Network/networkSecurityGroups/join/
action",

"Microsoft.Network/loadBalancers/write",

"Microsoft.Network/loadBalancers/read",

"Microsoft.Network/loadBalancers/delete",

"Microsoft.Network/loadBalancers/probes/join/
action",

"Microsoft.Network/loadBalancers/
backendAddressPools/join/action",

"Microsoft.Network/loadBalancers/
frontendIPConfigurations/read",

"Microsoft.Network/locations/serviceTags/read",

"Microsoft.Network/applicationGateways/read",

"Microsoft.Network/networkInterfaces/read",

"Microsoft.Compute/virtualMachineScaleSets/
write",

"Microsoft.Compute/virtualMachineScaleSets/
read",
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To support Permissions
"Microsoft.Compute/virtualMachineScaleSets/
delete",

"Microsoft.Compute/virtualMachineScaleSets/
virtualMachines/read",

"Microsoft.Compute/virtualMachines/read",

"Microsoft.Compute/images/read",

"Microsoft.insights/components/write",

"Microsoft.insights/components/read",

"Microsoft.insights/components/delete",

 "Microsoft.insights/autoscalesettings/write"
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Deployments Supported on Azure
Use the VM-Series firewall on Azure to secure your network users in the following scenarios:

• Hybrid and VNet to VNet—The VM-Series firewall on Azure allows you to securely extend
your physical data center/private cloud into Azure using IPSec and ExpressRoute. To improve
your data center security, if you have segmented your network and deployed your workloads
in separate VNets, you can secure traffic flowing between VNets with an IPSec tunnel and
policies that allow applicaon traffic.

• Inter-Subnet —The VM-Series firewall can front your servers in a VNet and protects against
lateral threats for inter-subnet traffic between applicaons in a mul-er architecture.

• Gateway—The VM-Series firewall serves as the VNet gateway to protect Internet-facing
deployments in the Azure Virtual Network (VNet). The VM-Series firewall secures traffic
desned to the servers in the VNet and it also protects against lateral threats for inter-subnet
traffic between applicaons in a mul-er architecture.

• GlobalProtect—Use the Azure infrastructure to quickly and easily deploy the VM-Series firewall
as GlobalProtect™ and extend your gateway security policy to remote users and devices,
regardless of locaon.

You can connue with Deploy the VM-Series Firewall from the Azure Marketplace (Soluon
Template), Deploy the VM-Series Firewall on Azure Stack, or Orchestrate a VM-Series Firewall
Deployment in Azure.

You can also learn about the VM-Series Firewall Templates on Azure that you can use to deploy
the firewall.

For informaon on bootstrapping, see Bootstrap the VM-Series Firewall on Azure.
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Deploy the VM-Series Firewall from the Azure
Marketplace (Soluon Template)

The following instrucons describe how to deploy the soluon template for the VM-Series firewall
that is available in the Azure® Marketplace and the Azure Government Marketplace. To use the
customizable Azure Resource Manager (ARM) templates available in the GitHub repository, see
Use the ARM Template to Deploy the VM-Series Firewall.

All VM-Series firewall interfaces must be assigned an IPv4 address when deployed in a
public cloud environment. IPv6 addresses are not supported.

STEP 1 | Set up an Azure account.
1. If you don’t have one already, create a Microso® account.
2. Log in to the Azure portal (https://portal.azure.com or https://

portal.azure.us) using your Microso account credenals.

If you are using a trial subscripon, you may need to open a support request
(Help + Support > New Support Request) to increase the quota of allocated VM
cores.
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STEP 2 | Find the VM-Series soluon template in the Azure Marketplace.
1. Select Marketplace > Virtual Machines.
2. Search for Palo Alto Networks® and a list of offerings for the VM-Series firewall will

display. For the differences in the BYOL (bring your own license) and PAYG (pay as you
go) models, see VM-Series Firewall Licenses for Public Clouds.

3. Select an offering to Create a new VM-Series firewall.
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STEP 3 | Deploy the firewall.
1. Configure basic sengs for the firewall.

1. Select your Azure Subscripon.
2. Create a new resource group or select an exisng resource group that is empty. The

resource group will hold all the resources associated with the VM-Series firewall for
this deployment.

Azure has removed the opon to select an exisng resource group for
Marketplace soluons that enable mulple network interface controllers
(NICs). To deploy the firewall into an exisng resource group, use the ARM
template in the GitHub Repository or use your own custom ARM template.

3. Select the Azure Region in which you are deploying the firewall.
4. Enter a Username for the firewall administrator.
5. Select the Authencaon type—Password or SSH Public Key.

You must enable SSH key authencaon if you plan to use the firewall in
FIPS-CC operaonal mode. Although you can deploy the VM-Series firewall
using a username and password, you will be unable to authencate using the
username and password aer changing the operaonal mode to FIPS-CC.
Aer reseng to FIPS-CC mode, you must use the SSH key to log in and can
then configure a username and password that you can use for subsequently
logging in to the firewall web interface. For details on creang the SSH key,
refer to the Azure documentaon.

6. Enter a Password (up to 31 characters) or copy and paste an SSH public key for
securing administrave access to the firewall.

2. Configure networking.

1. Select an exisng Azure Virtual Network (VNet) or create a new one and enter the IP
address space for the VNet. By default, the Classless Inter-Domain Roung (CIDR) IP
address is 10.8.0.0/16.

2. Configure the subnets for the network interfaces.

If you use the default subnets, you must review the configuraon. If you
use an exisng VNet, you must have set up three subnets: one each for the
management,trust, and untrust interfaces. If you create a new VNet, verify or change
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the prefixes for each subnet. The default subnets are 10.8.0.0/24 for the management
subnet, 10.8.1.0/24 for the untrust subnet, and 10.8.2.0/24 for the trust subnet.

3. Enter the source IP address or IP range (include the CIDR block) that can access the
VNet. Network Security Group: inbound source IP allows you to restrict inbound
access to the Azure VNet.

Restrict access to the firewall. Make sure to supply a CIDR block that
corresponds to your dedicated management IP addresses or network. Do
not make the allowed source network range larger than necessary and never
configure the allowed source as 0.0.0.0/0. Verify your IP address before you
configure it on the template to make sure that you do not lock yourself out.

3. Define management access to the firewall.

1. Use the default variable ((new) fwMgmtPublicIP)) to assign a Public IP address to the
management interface (eth0) of the firewall.

Azure accelerated networking is not supported on the management interface.

2. Enter a prefix to access the firewall using a DNS name. You must combine the prefix
you enter with the suffix displayed on screen to access the web interface of the
firewall. For example: <yourname><your-region>.cloudapp.azure.com

3. Select latest VM-Series Version.
4. Enter a display name to idenfy the VM-Series firewall within the resource group.
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4. Add the informaon to configure the firewall at launch. See Bootstrap the VM-Series
Firewall on Azure.

1. Select yes to Enable Bootstrap.
2. Enter the Storage Account Name that holds the Bootstrap Package.
3. Enter the Storage Account Access Key. This firewall needs this access key to

authencate to the storage account and access the files stored within.
4. Add the File share name to which you have uploaded the files required for

bootstrapping the firewall. The storage account must be in the same region in which
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you are deploying the firewall and it must have the correct folder structure for
bootstrapping.

5. Select the Azure virtual machine er and size to meet your needs. Use the Change
size link to view supported instance types, and to review the Minimum System
Requirements for the VM-Series on Azure.

5. Review the summary, and OK. Then accept the terms of use and privacy policy, and
Create to launch the firewall.

6. Verify that you have successfully deployed the VM-Series firewall.

1. Select Dashboard > Resource Groups and select the resource group.
2. Select your resource group and see the Overview for detailed status on which

resources are deployed successfully.

STEP 4 | Aach a public IP address for the untrust interface of the VM-Series firewall. When you
create a new public IP address, you get one from the block of IP addresses that Microso
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owns, so you can’t choose a specific one. The maximum number of public IP addresses you
can assign to an interface is based on your Azure subscripon.
1. On the Azure portal, select the network interface for which you want to add a public IP

address (such as the eth1 interface).
2. Select IP Configuraons > Add and, for Public IP address, select Enabled. Create a new

public IP address or select one that you have available.
3. Verify that you can view the secondary IP address associated with the interface.

When you aach a secondary IP address to a network interface, the VM-Series firewall
does not automacally acquire the private IP address assigned to the interface. You
will need to manually configure the private IP address using the VM-Series firewall web
interface. See Configure the dataplane network interfaces as Layer 3 interfaces on
the firewall.

STEP 5 | Log in to the web interface of the firewall.
1. On the Azure portal, in All Resources, select the VM-Series firewall and view the full

DNS name for the firewall.

1. Using a secure (hps) connecon from your web browser, log in to the DNS name for the
firewall.

2. Enter the usernamepassword that you defined in the parameters file. You will see a
cerficate warning but that is OK—connue to the web page.
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STEP 6 | Acvate the licenses on the VM-Series firewall.

For the BYOL version

1. Create a Support Account.
2. Register the VM-Series Firewall (with auth code).
3. On the firewall web interface, select Device > Licenses and select Acvate feature using

authencaon code.
4. Enter the capacity authencaon code (auth-code) that you registered

on the support portal. The firewall will connect to the update server
(updates.paloaltonetworks.com), and download the license and reboot
automacally.

5. Log back in to the web interface and confirm the following on the Dashboard:

• A valid serial number displays in Serial#.

If the term Unknown displays, it means the firewall is not licensed. To view traffic logs
on the firewall, you must install a valid capacity license.

• The VM Mode displays as Microso Azure.

For the PAYG version

1. Create a Support Account.
2. Register the Usage-Based Model of the VM-Series Firewall for Public Clouds (no auth

code).

STEP 7 | Configure the dataplane network interfaces as Layer 3 interfaces on the firewall.

If you are hosng mulple websites or services with different IP addresses and SSL cerficates
on a single server, you might need to configure more than one IP address on the VM-Series
firewall interfaces.

1. Select Network > Interfaces > Ethernet.
2. Click ethernet 1/1 and configure as follows:

• Set Interface Type to Layer3 (default).
• On the Config tab, assign the interface to the default router.
• Also on the Config tab, expand the Security Zone drop-down and select New Zone.

Define a new zone called UnTrust, and then click OK.

• On the IPv4 tab, select DHCP Client if you plan to assign only one IP address on the
interface—the firewall will automacally acquire the private IP address assigned in
the ARM template. If you plan to assign more than one IP address, select Stac and

VM-Series Deployment Guide Version Version 10.1 585 ©2022 Palo Alto Networks, Inc.



Set up the VM-Series Firewall on Azure

manually enter the primary and secondary IP addresses assigned to the interface on
the Azure portal.

• Disable (clear) the Automacally create default route to default gateway provided
by server to ensure that traffic handled by this interface does not flow directly to the
default gateway in the VNet.

3. Click ethernet 1/2 and configure as follows:

• Set Interface Type to Layer3 (default).
• Set Security Zone to Trust.
• Set IP address DHCP Client or Stac.
• Disable (clear) the Automacally create default route to default gateway provided

by serverto ensure that traffic handled by this interface does not flow directly to the
default gateway in the VNet.

4. Commit your changes and verify that the link state for the interfaces is up.
5. Add a stac route on the virtual router of the VM-Series firewall for any networks that

the firewall needs to route.

For example, to add a default route to the desnaon subnets for the servers that the
firewall secures:

• Select Network > Virtual Router > default >
• Select Stac Routes > IPv4, and add the next hop IP address for the desnaon

servers. You can set x.x.x.1 as the next hop IP address for all traffic (desned to
0.0.0.0/0 from interface ethernet1/1).

STEP 8 | Configure the firewall for your specific deployment.

• Gateway—Deploy a third-party load balancer in front of the UnTrust zone.
• Hybrid and Inter-VNet—Deploy an Azure VPN Gateway or a NAT virtual machine in front

the UnTrust zone.
• Inter-Subnet—On the VM-Series firewall, add an intrazone Security policy rule to allow

traffic based on the subnets aached to the Trust interface.
• GlobalProtect™—Deploy a NAT virtual machine in front of the UnTrust zone.

STEP 9 | Direct traffic to the VM-Series firewall.
1. To ensure that the VM-Series firewall secures all traffic within the Azure resource group,

configure stac routes on the firewall.
2. Configure user defined routes to direct all traffic through the interfaces on the VM-Series

firewall. Refer to the Azure documentaon on UDRs for details.

The user defined routes on the internal subnets must send all traffic through the Trust
interface. The user defined routes on the UnTrust side direct all traffic from the Internet
through the UnTrust interface on the VM-Series firewall. The traffic from the Internet
may be coming from an Azure Applicaon Gateway or Azure Load Balancer, or through
the Azure VPN Gateway in the case of a hybrid deployment that connects your on-
premise network with the Azure cloud.
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STEP 10 | To publish PAN-OS® metrics to Azure Applicaon Insights, see Enable Azure Applicaon
Insights on the VM-Series Firewall.
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Deploy the VM-Series Firewall from the Azure China
Marketplace (Soluon Template)

The following instrucons show you how to deploy the soluon template for the VM-Series
firewall that is available in the Azure China Marketplace. The Azure China Marketplace supports
only the BYOL model of the VM-Series firewall. You can deploy the firewall in a exisng resource
group that is empty or into a new resource group. The default VNet in the template is 10.0.0.0/16,
and it deploys a VM-Series firewall has 3 network interfaces, one management and two dataplane
interfaces as shown below. To use the customizable ARM templates available in the GitHub
repository, see Use the ARM Template to Deploy the VM-Series Firewall.

All VM-Series firewall interfaces must be assigned an IPv4 address when deployed in a
public cloud environment. IPv6 addresses are not supported.

STEP 1 | Set up an Azure account.
1. Create a Microso account.
2. Log in to the Azure portal (https://portal.azure.com) using your Microso

account credenals.

If you are using a trial subscripon, you may need to open a support request
(Help + Support > New Support Request) to increase the quota of allocated VM
cores.
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STEP 2 | Find the VM-Series soluon template in the Azure Marketplace.
1. Search for Palo Alto Networks on the Azure China marketplace (hps://market.azure.cn).

The offering for the different PAN-OS versions of the VM-Series firewalls displays.

2. Select an offering and click Immediate deployment of.

STEP 3 | Deploy the firewall.
1. Select your Azure Subscripon.
2. Select a resource group for holding all the resources associated with the VM-Series

firewall in this deployment.

You can deploy the VM-Series firewall into a new Resource Group, or an exisng
Resource Group that is empty. To deploy the firewall into an exisng resource
group that has other resources, use the ARM template in the GitHub Repository
or your own custom ARM template. Ensure that the exisng resources match the
parameter values you provide in the ARM template.

1. If you create a new resource group, enter a name for the resource group and select
the Azure China region where you want to deploy the firewall.

2. If you select an exisng resource group, select the Azure China region for this
resource group, and select complete deployment.

3. Configure basic sengs for the firewall.

1. Enter the storage account name for an exisng account or create a new one.
2. Enter the name for the blob storage container to which the firewall vhd mage will be

copied and saved.
3. Enter a DNS name for accessing the Public IP address on the management

interface (eth0) of the firewall. To access the web interface of the firewall,
you must combine the prefix you enter with the suffix, for example
<yourDNSname><china_region>.cloudapp.azure.com.

4. Enter a Username for the firewall administrator.
5. Enter a Password for securing administrave access to the firewall.
6. Select the Azure virtual machine er and size to meet your needs. See Minimum

System Requirements for the VM-Series on Azure.
7. Enter a VmName, which is a display name to idenfy the VM-Series firewall within the

resource group.
8. Use a PublicIPAddressName to label the firewall management interface within the

resource group. Microso Azure binds the DNS name that you defined with this name
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so that you can access the management interface on the firewall from the public
internet.

9. Enter a VirtualNetworkName to idenfy your VNet. The default IP Address Prefix for
the VNet is 10.0.0.0/16. You can change this to meet your IP addressing needs.

10.Configure the subnets for the network interfaces. If you use an exisng VNet, you
must have defined three subnets, one each for the management, trust and untrust
interfaces. If you create a new VNet, verify or change the prefixes for each subnet.
The default subnets are 10.0.1.0/24, 10.0.2.0/24, and 10.0.3.0/24. You can allocate
these subnets to the management, trust, and untrust interfaces as you would like.

4. Review the summary, accept the terms of use and privacy policy, and click Immediate
deployment to deploy the firewall. The deployment maybe take 20 minutes and you can
use the link on the page to verify progress.

5. Verify that you have successfully deployed the VM-Series firewall.

1. Log in to the Azure China portal (hps://portal.azure.cn) using your Microso account
credenals.

2. Select Dashboard > Resource Groups, select the resource group.
3. Select All Sengs > Deployments > Deployment History for detailed status
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STEP 4 | Aach a public IP address for the untrust interface of the VM-Series firewall. This allows
you to access the interface from the public internet and is useful for any internet-facing
applicaon or service.
1. On the Azure portal, select the network interface for which you want to add a public IP

address. For example the eth1 interface.
2. Select IP Configuraons > Add and for Public IP address, select Enabled. Create a new

public IP address or select one that you have available.
3. Verify that you can view the secondary IP address associated with the interface.

When you aach a secondary IP address to a network interface, the VM-Series firewall
does not automacally acquire the private IP address assigned to the interface. You
will need to manually configure the private IP address using the VM-Series firewall web
interface. See Configure the dataplane network interfaces as Layer 3 interfaces on
the firewall.

Each interface on the VM-Series firewall on Azure can have one dynamic (default) or stac
private IP address, and mulple public IP addresses (stac or dynamic) associated with it.
The maximum number of public IP addresses you can assign to an interface is based on your
Azure subscripon. When you create a new public IP address you get one from the block of IP
addresses Microso owns, so you can’t choose a specific one.

STEP 5 | Log in to the web interface of the firewall.
1. On the Azure portal, in All Resources, select the VM-Series firewall and view the full

DNS name for the firewall.

2. Using a secure connecon (hps) from your web browser, log in to the DNS name for the
firewall.

3. Enter the username/password you defined earlier. You will see a cerficate warning; that
is okay. Connue to the web page.
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STEP 6 | Acvate the licenses on the VM-Series firewall.
1. Create a Support Account.
2. Register the VM-Series Firewall (with auth code).
3. On the firewall web interface, select Device > Licenses and select Acvate feature using

authencaon code.
4. Enter the capacity auth-code that you registered on the support portal. The firewall will

connect to the update server (updates.paloaltonetworks.com), and download the license
and reboot automacally.

5. Log back in to the web interface and confirm the following on the Dashboard:

• A valid serial number displays in Serial#.

If the term Unknown displays, it means the device is not licensed. To view traffic logs
on the firewall, you must install a valid capacity license.

• The VM Mode displays as Microso Azure.

STEP 7 | Configure the dataplane network interfaces as Layer 3 interfaces on the firewall.

If you are hosng mulple websites or services with different IP addresses and SSL cerficates
on a single server, you might need to configure more than one IP address on the VM-Series
firewall interfaces.

1. Select Network > Interfaces > Ethernet.
2. Click the link for ethernet 1/1 and configure as follows:

• Interface Type: Layer3 (default).
• On the Config tab, assign the interface to the default router.
• On the Config tab, expand the Security Zone drop-down and select New Zone. Define

a new zone called UnTrust, and then click OK.
• On the IPv4 tab, select DHCP Client if you plan to assign only one IP address on the

interface. The private IP address assigned in the ARM template will be automacally
acquired. If you plan to assign more than one IP address select Stac and manually
enter the primary and secondary IP addresses assigned to the interface on the Azure
portal.

• Clear the Automacally create default route to default gateway provided by server
check box. Disabling this opon ensures that traffic handled by this interface does not
flow directly to the default gateway in the VNet.

3. Click the link for ethernet 1/2 and configure as follows:

• Set Interface Type to Layer3 (default).
• Security Zone: Trust
• IP address: Select DHCP Client or Stac.
• Clear the Automacally create default route to default gateway provided by server

check box. Disabling this opon ensures that traffic handled by this interface does not
flow directly to the default gateway in the VNet.

4. Click Commit. Verify that the link state for the interfaces is up.
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STEP 8 | Configure the firewall for your specific deployment.

• Gateway—Deploy a 3rd party load balancer in front of the UnTrust zone.
• Hybrid and Inter-VNet—Deploy an Azure VPN Gateway or a NAT virtual machine in front

the UnTrust zone.
• Inter-Subnet—On the VM-Series firewall, add an intra-zone security policy rule to allow

traffic based on the subnets aached to the Trust interface.
• GlobalProtect—Deploy a NAT virtual machine in front of the UnTrust zone.

STEP 9 | Direct traffic to the VM-Series firewall.
1. To ensure that the VM-Series firewall secures all traffic within the Azure resource group,

configure stac routes on the firewall.
2. Configure UDRs to direct all traffic through the interfaces on the VM-Series firewall.

Refer to the Azure documentaon on UDRs for details.

The UDRs on the internal subnets must send all traffic through the Trust interface.
The UDRs on the UnTrust side direct all traffic from the Internet through the UnTrust
interface on the VM-Series firewall. The traffic from the Internet may be coming from an
Azure Applicaon Gateway or Azure Load Balancer, or through the Azure VPN Gateway
in case of a hybrid deployment that connects your on-premises network with the Azure
cloud.
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Panorama Orchestrated Deployments in Azure
The Panorama plugin for Azure centrally deploys, configures, and monitors your security posture
in Azure cloud. It orchestrates VM-Series deployments in your Azure network so that you can
enable security policies for managed firewalls. The plugin links to your Azure ARM deployment
and Azure Monitor pages, providing visibility into the deployment status, usage, and performance
of your VM-Series firewalls.

In Azure, the plugin orchestrates the deployment of Azure resources such as load balancers,
subnets and NAT gateways as well as VM-Series firewall autoscaling sets. In Panorama the plugin
automacally configures Panorama device groups, template stacks, and NAT policies. It reads the
tags from your Azure resources, then centrally enables tag-based policies on a group of firewalls.

The Panorama plugin can orchestrate deployments in one or more regions in your Azure
environment. A deployment can consist of a hub stack or an inbound stack or both, depending on
the traffic that needs to be secured for your deployment:

• A Hub firewall stack protects outbound traffic and East-West traffic between your applicaon
workloads.

• An Inbound firewall stack secures traffic to and from your public facing applicaons.

You can configure the number of firewalls in each stack. You have the opon to configure a stac
amount of firewalls in your deployment or a range for the VMSS to use for scaling. Both stacks in
the deployment create a VMSS of VM-Series firewalls and they can each scale up to as many as
25 firewalls.

Hub Stack

A deployment uses a Hub stack and leverages the Azure Internal Standard Load Balancer (with
HA ports) to scale and load balance across a set of firewalls. You can then use the Standard Load
balancer’s private IP address (2, “Hub/Egress Private IP” in the following figure) to route traffic
to the firewalls for inspecon and threat prevenon. The Hub stack secures your applicaons’
outbound and East-West traffic.
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To protect your outbound traffic and East-West traffic, add route rules in your applicaon VNETs
to redirect traffic to the Hub stack for inspecon.

Inbound Stack

An Inbound firewall stack scales independently and adds visibility and security to your
applicaons’ Inbound traffic.

To protect your inbound HTTP traffic, add UDRs in the Applicaon Gateway’s subnet route tables
to route all traffic to the Inbound stack (3, Ingress Private IP in the following figure). To protect
the non-HTTP inbound traffic, use the Panorama plugin to create front-end entries for your
applicaon endpoints (4, Ingress Public IP Front Ends in the following figure). To enable inspecon,
the Panorama plugin automacally creates load balancer rules on the Azure Public Standard Load
Balancer and NAT rules on the firewalls.

If you only have HTTP/HTTPS inbound traffic you can leave out the Inbound stack and protect
that traffic with just the hub stack.

VM-Series Deployment Guide Version Version 10.1 595 ©2022 Palo Alto Networks, Inc.



Set up the VM-Series Firewall on Azure

See Prepare for an Orchestrated Deployment and Orchestrate a VM-Series Firewall Deployment
in Azure.

Prepare for an Orchestrated Deployment
Complete the following tasks before you orchestrate a VM-Series firewall on Azure.

• Configuraon Prerequisites
• Orchestraon Permissions
• Create a Custom Role and Associate it with an Acve Directory
• Find Your Azure Directory Domain Name

All VM-Series firewall interfaces must be assigned an IPv4 address when deployed in a
public cloud environment. IPv6 addresses are not supported.

Configuraon Prerequisites
Complete the following basic tasks on Panorama and Azure.
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• Azure

• Create a service principal to enable the plugin to make API calls.
• Plan a CIDR block specifically dedicated to VM-Series firewall Transit VNet. The plugin

manages this CIDR block and uses it to deploy the inial firewall VNet and perform as future
upgrades to new template stacks.

The minimum CIDR range is /22.
• Panorama

• Ensure that you have a valid license API key configured on Panorama. This allows the plugin
to manage delicensing on scale-in autoscaling events. See Install a License Deacvaon API
Key.

• Install the latest version of the VM-series plugin on Panorama to allow Applicaon Insight
configuraon to be added to template stack.

• Qualified Azure Regions

Panorama orchestrated deployments are supported in all regions that support the VM-Series
firewall. The following regions have been qualified; if you deploy in an unlisted region and you
encounter an issue, contact support.

• West US
• West US 2
• North Central US
• East US
• East US 2
• West Europe
• Germany West Central
• UAE North
• West India
• Australia Southeast

While planning your deployment please note that if you are currently running a Panorama Plugin
for Azure version 2.x, upgrading to the current version is not allowed. Along with this, once the
current version is installed, downgrading to a version 2.x plugin is not allowed. See Panorama
Plugin for Azure in the Compability Matrix.

Orchestraon Permissions
The is a sample JSON file with permissions for the Template Deployer role. In the
AssignableScopes secon, include all relevant subscripons that must be queried, including
the subscripon into which the deployment is deployed and EVERY subscripon containing an
applicaon VNET that is peered to the VM-Series firewall VNet where protected resources exist.

{
    "Name": "Template Deployment",
    "IsCustom": true,
    "Description": "Manage template deployments.",
    "Actions": [

VM-Series Deployment Guide Version Version 10.1 597 ©2022 Palo Alto Networks, Inc.

https://docs.paloaltonetworks.com/vm-series/9-0/vm-series-deployment/license-the-vm-series-firewall/deactivate-the-licenses/install-a-license-deactivation-api-key.html
https://docs.paloaltonetworks.com/vm-series/9-0/vm-series-deployment/license-the-vm-series-firewall/deactivate-the-licenses/install-a-license-deactivation-api-key.html
https://docs.paloaltonetworks.com/compatibility-matrix/panorama/plugins.html#id17C8A0XB0V8_idfc4e17c7-49c7-4be0-a442-30b62a579a20


Set up the VM-Series Firewall on Azure

        "Microsoft.Resources/subscriptions/resourcegroups/*",
        "Microsoft.Resources/deployments/write",
        "Microsoft.Resources/deployments/operationStatuses/read",
        "Microsoft.Resources/deployments/read",
        "Microsoft.Resources/deployments/delete",
        "Microsoft.Network/publicIPPrefixes/write",
        "Microsoft.Network/publicIPPrefixes/read",
        "Microsoft.Network/publicIPPrefixes/delete",
        "Microsoft.Network/publicIPAddresses/write",
        "Microsoft.Network/publicIPAddresses/read",
        "Microsoft.Network/publicIPAddresses/delete",
        "Microsoft.Network/publicIPAddresses/join/action",
        "Microsoft.Network/natGateways/write",
        "Microsoft.Network/natGateways/read",
        "Microsoft.Network/natGateways/delete",
        "Microsoft.Network/natGateways/join/action",
        "Microsoft.Network/virtualNetworks/read",
        "Microsoft.Network/virtualNetworks/write",
        "Microsoft.Network/virtualNetworks/delete",
        "Microsoft.Network/virtualNetworks/subnets/write",
        "Microsoft.Network/virtualNetworks/subnets/read",
        "Microsoft.Network/virtualNetworks/subnets/delete",
        "Microsoft.Network/virtualNetworks/subnets/join/action",
        "Microsoft.Network/virtualNetworks/virtualNetworkPeerings/
read",
        "Microsoft.Network/networkSecurityGroups/write",
        "Microsoft.Network/networkSecurityGroups/read",
        "Microsoft.Network/networkSecurityGroups/delete",
        "Microsoft.Network/networkSecurityGroups/join/action",
        "Microsoft.Network/loadBalancers/write",
        "Microsoft.Network/loadBalancers/read",
        "Microsoft.Network/loadBalancers/delete",
        "Microsoft.Network/loadBalancers/probes/join/action",
        "Microsoft.Network/loadBalancers/backendAddressPools/join/
action",
        "Microsoft.Network/loadBalancers/frontendIPConfigurations/
read",
        "Microsoft.Network/locations/serviceTags/read",
        "Microsoft.Network/applicationGateways/read",
        "Microsoft.Network/networkInterfaces/read",
        "Microsoft.Compute/virtualMachineScaleSets/write",
        "Microsoft.Compute/virtualMachineScaleSets/read",
        "Microsoft.Compute/virtualMachineScaleSets/delete",
        "Microsoft.Compute/virtualMachineScaleSets/virtualMachines/
read",
        "Microsoft.Compute/virtualMachines/read",
        "Microsoft.Compute/images/read",
        "Microsoft.insights/components/write",
        "Microsoft.insights/components/read",
        "Microsoft.insights/components/delete",
        "Microsoft.insights/autoscalesettings/write"
    ]
     "NotActions": [
    ],
     "AssignableScopes": [
        "/subscriptions/{deployment-subscription}",
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        "/subscriptions/{app1-subscription}",
        "/subscriptions/{app2-subscription}",
        .
        .
        .
    ]
}

Create a Custom Role and Associate it with an Acve Directory
STEP 1 | To create an Acve Directory in Azure, Navigate to Azure Acve Directory and click on App

Registraons on the le. Create a custom role using the permissions the plugin requires.

An example JSON is included below.

1. Click add and provide a name. Select the role created from the above JSON file, leave
"Assign access to" as Acve Directory user, and then select the acve directory created
in the first step and click Save.

2. Select the type.

Do not modify anything under Redirect URI.

STEP 2 | Create a custom role with the permissions the plugin requires.

See Orchestraon Permissions.

1. Log in to the Azure CLI.

az login

2. Create a custom role from the file in Orchestraon Permissions.

az role definition create --role-definition <role-json-file> 

VM-Series Deployment Guide Version Version 10.1 599 ©2022 Palo Alto Networks, Inc.



Set up the VM-Series Firewall on Azure

STEP 3 | Associate the role with Acve Directory you created in Step 1. You can use the console or
the CLI.

You must repeat this step in every subscripon defined in the assignableScope
secon of the custom role in Orchestraon Permissions.

Console

1. On the Azure portal, navigate to Subscripons and select your subscripon.
2. On the le select Access Control (IAM) and then Role Assignments on the top bar.
3. Select Add and chose add role assignment.

• Select the role created you created in Step 3 and leave "Assign access to" as Acve
Directory user.

• Select the acve directory created in Step 1 and click Save.

CLI:

In the following command, <role-name> refers to the name in the sample JSON file, in the
earlier example, Template Deployment.

az ad sp create-for-rbac --name <name-of-service-principal>
--role <role-name>
--output json

Find Your Azure Directory Domain Name
For the plugin to provide links to your Azure deployment and Applicaon Insights instance in
Azure Portal, you must idenfy the directory domain for your subscripon, as shown below:

Orchestrate a VM-Series Firewall Deployment in Azure
You can create a maximum of ten orchestrated deployments. Addionally, each orchestrated
deployment supports up to 100 front-end applicaons.

Azure China and Azure Government are not supported.

All VM-Series firewall interfaces must be assigned an IPv4 address when deployed in a
public cloud environment. IPv6 addresses are not supported.
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STEP 1 | Create a service principal.
Onboard your created service principal credenals to give the Panorama Plugin permissions to
make necessary API calls to orchestrate your deployment

1. Select Setup > Service Principal > Add.
2. Enter a Name and an oponal Descripon to idenfy the service account.
3. Enter the Subscripon ID for the Azure subscripon you want to monitor.

You must login to your Azure portal to get this subscripon ID.
4. Enter the Client ID.The client ID is the Applicaon ID associated with your Azure Acve

Directory applicaon.
5. Enter the Client Secret and re-enter it to confirm.
6. Enter the Tenant ID.

The tenant ID is the Directory ID you saved when you set up the Acve Directory
applicaon.

7. Click Validate to verify that the keys and IDs you entered are valid, and Panorama can
communicate with the Azure subscripon using the API.

It can take up to a minute to validate. You can update the page to check your progress.
8. When the service principal is valid, commit your changes.

The commit ensures the service principal is available when you configure the deployment.
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STEP 2 | Configure your Azure deploymenet.
1. Select Deployments and Add a configuraon.
2. Select Build > General.

• Supply a Name and an oponal Descripon.
• Choose a service principal from the drop list.

You must select a valid service principal to enable the Azure tab.

If you don’t see your service principal, return to Step 1 and ensure the service
principal is valid and commied.

3. On the Build > Azure tab, select a region.

The drop list is dynamic—it lists all regions that have a Palo Alto Networks VM-Series
Next Generaon Firewall image.

• Exisng VNET.

• Select No to create a new VNET.

The plugin uses the VNET CIDR and Directory Domain to create a VNET for you.
• Select Yes to indicate an exisng VNET.

• VNET CIDR—Enter your CIDR range. The prefix must be smaller than or equal to /22.
For example, 192.168.0.0/22.

• Directory Domain—See Find Your Azure Directory Domain Name. This string is part
of the URL for all resources in the subscripon, and it helps the plugin link to your
deployments.
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If you selectYes the plugin asks for the VNET Resource Group, the VNET Name, the
Security CIDR, and the Directory Domain.

• VNET Resource Group—Choose from a list of all resource groups in your selected
region.

• VNET Name—Choose from a list of VNETS in your chosen resource group.
• Security CIDR—Enter your CIDR range. The prefix must be smaller than or equal

to /22. For example, 192.168.0.0/22.
• Directory Domain—See Find Your Azure Directory Domain Name. This string is part

of the URL for all resources in the subscripon, and it helps the plugin link to your
deployments.

The VNET Resource Group and VNET name help the plugin locate your exisng VNET.
Anything the plugin deploys goes into a resource group that the plugin manages.
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STEP 3 | Configure the VM-Series firewall stacks for your deployment.
You can deploy the Hub stack to protect Outbound/East-West traffic. You can deploy the
Inbound stack to protect inbound traffic. You can also deploy both stacks if all traffic flows
need to be protected.
The configuraon parameters are the same for both stacks.

• License Type—Select BYOL, Bundle 1, or Bundle 2.
• License Authcode—(BYOL only). Enter the authcode sent in your Welcome leer.
• VM Size

• The drop list displays the VM sizes that correlate with the authcode you entered.
• Bundle1 or Bundle2—Choose any VM size.

Exisng Device Group—The device group must be unique across both stacks and deployments.
That is, you need a separate dedicated device group for each stack in each deployment.

If you select No the plugin creates a device group.

If you select Yes, select an exisng device group from the dropdown list.

• Min Firewalls— A value between 1 and 25 for a VMSS.
• Max Firewall— A value between 1 and 25 for a VMSS.
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STEP 4 | Select Build > Firewall > Basic to configure informaon common to both Stacks.

For Image Type, select Marketplace Image or Custom Image.

• Image Resource Group—(custom image only) Choose the resource group containing your
custom image. For a custom image, the list displays all resource groups that contain an
image from the region you selected in Step 2.b.

• Image—(custom image only) The dropdown list displays all images in your chosen resource
group.

• Soware Version—(Marketplace Image) Only valid soware versions are displayed. Consult
the Compability Matrix for the minimum PAN-OS version.

• Username—The administrator user name for the firewall you create. The name must be legal
for both VM-Series firewall and Azure. Refer to What are the user name requirments when
creang a VM?

• Password—The administrator password for the firewall you create. The password must
meet the character and length requirements (31 characters) for both VM-Series firewall and
Azure. Refer to What are the password requirements when creang a VM?.

• Confirm Password—Re-enter your password.
• Primary Panorama IP—Specify the Panorama IP address the firewall can use to connect to

the Panorama when it boots up. Choose between the public or private IP address displayed
in the dropdown list, or type in the Panorama IP address.

• Secondary Panorama IP—(Only if Panorama is in HA setup.) Specify the Secondary
Panorama IP the firewall can use to connect to the Panorama when it boots up. Choose
from dropdown list or type in the correct IP.

• Configure Device Cerficate PIN. Because these values are encrypted you must enter and
confirm each value.

• Device Cerficate PIN ID—The device cerficate ID.
• Confirm Device Cerficate PIN ID
• Device Cerficate PIN Value—The cerficate PIN value.
• Confirm Device Cerficate PIN Value

STEP 5 | Select Build > Firewall > Advanced oponal default values.

Check Advanced to edit the default values.

• Autoscaling Metric—Default is Data Plane CPU Ul Percent.
• Scale In Threshold—Accept the default or define a scale in thresholdt.
• Scale Out Threshold—Accept the default or define a scale in threshold.
• Jumbo Frame—Disabled by default.

Click OK and commit your changes. Refresh the page unl you can see the Deploy buon, and
click Deploy to launch the deployment. Once the deployment starts, informaon is wrien to
the Deployments page.

Deployment takes 15-20 minutes to complete.
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STEP 6 | Select Azure > Deployments to view deployment status.

• The Resource Group column displays resource groups the plugin has created.
• The firewall’s management interface uses the Firewall Access IP to connect to Panorama.

You must whitelist this address to ensure that Panorama can connect with Panorama to get
the needed configuraon.

If Panorama is deployed in a Public Cloud, make sure to add the Firewall Access IP
to the Panorama security group.

See Ports Used for Panorama to determine which ports you need to open to allow traffic.
• Open the link in the Deployment Status column for addional details for each stack.

• Hub-Stack—The Hub stack Public IP matches the Firewall Access IP in the deployment
summary because the NAT gateway is the same for egress traffic from the deployment
and the management traffic from the firewalls.

All outbound and East-West traffic should be routed to the Egress Private IP for
inspecon. You can direct traffic to this address if you configured UDRs.

• Inbound-Stack—The Private IP is the address on the Azure internal load balancer that
fronts the firewalls. You can direct traffic to this address if you are configuring UDRs.

• Follow the links to view deployment informaon and Applicaon Insights on Azure.
• The Deployment details can show Success, Warning, and Failure messages
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STEP 7 | Configure inbound protecon for backend TCP/UDP applicaons.

The public load balancer that fronts the inbound firewall stack is the entry point for any back-
end UDP or TCP applicaons. Add the following configuraon to allow the plugin to manage
the necessary load balancer and firewall configuraon to route to your backend applicaon.

1. Select Azure > Deployments and select your deployment.
2. Select the Protect tab and click Add.
3. Supply the applicaon Name and choose a Protocol.

Enter the protecon details:

• Frontend IP Type—Select one of New Public IP, Exisng Frontend, and Exisng Public
IP.

If you select Exisng Frontend, the Frontend Name lists all known front ends on the
load balancer.

• Resource Group—(Exisng Public IP only) From the dropdown list, select the resource
group where your desired frontend IP address exists.

• IP Name—(Exisng Public IP only) Use to map IP to a frontend on the load balancer,
configure the load balancer, and create a NAT rule.

• Frontend Port—Add the frontend port that should be configured to receive traffic on
the public load balancer.

• Backend IP—Add the IP address of your backend applicaon.
• Backend Port—Add the port your backend applicaon is expecng to receive traffic

on.

Click OK.
4. Commit to add the configuraon on the load balancer and push to the firewalls.
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Deploy the VM-Series with the Azure Gateway Load
Balancer

You can now deploy the VM-Series firewall for Azure in integraon with the Azure gateway
load balancer (GWLB). By integrang with the Azure GWLB, you are no longer required to use a
standard load balancer, which requires the VM-Series firewall to apply source NAT on the traffic
to maintain flow symmetry. The applicaon of source NAT to traffic obfuscates the source’s
identy from applicaons. By using the Azure GWLB, traffic’s packet header and payload remains
intact, which provides complete visibility of the source’s identy to the desnaon. When Azure
GWLB integraon is enabled, the VM-Series uses vxlan packets to inspect the inner packet of
traffic and apply policy to that packet.

When deployed behind a Azure GWLB, you must create subinterfaces on the firewall to enforce
zone-based security policy. Addionally, you must apply the VLAN-ID 1 and 2 to the respecve
subinterfaces.

With this integraon, you can deploy the VM-Series firewall as a backend to the Azure GWLB in
all supported regions.

VM-Series firewall integraon with the Azure gateway load balancer requires PAN-OS
10.1.4 or later.

STEP 1 | Create the custom PA-VM vhd image for Azure.

az image create -g <resource-group> <image-name> --os-type Linux --
source <vhd_path>

STEP 2 | Create the management virtual network before deploying the VM-Series firewall. See the
Azure documentaon for more informaon.

Ensure that the managment subnet allows hps and ssh traffic for management
access.
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STEP 3 | Deploy the VM-Series firewall in the management virtual network using the custom PA-VM
image using the Azure Portal.
1. On the Networking tab, set the management public IP address SKU type to Standard.

2. On the Advanced tab, configure the VNIs and ports for the internal and external tunnels.

The VNI and port informaon is defined using the Custom Data field in the Azure portal.
You must define the internal and external port and VNI numbers in the range of 800 to
1000.

plugin-op-commands=azure-gwlb-inspect:enable+internal-port-
<internalport>+external-port-<externalport>+internal-vni-
<internalvni>+external-vni-<internalvni>
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STEP 4 | Configure the dataplane network interface as a Layer 3 interface on the firewall.
1. Log in to the VM-Series firewall user interface.
2. Select Network > Interfaces > Ethernet.
3. Click the link for ethernet 1/1 and configure as follows:

• Interface Type: Layer3
• On the Config tab, assign the interface to the default router.
• On the Config tab, expand the Security Zone drop-down and select New Zone.

Define a new zone and then click OK.
• On the IPv4 tab, select DHCP Client.

If using DHCP, select DHCP Client; the private IP address that you assigned to the
ENI in the AWS management console will be automacally acquired.

• On the Advanced tab, create a management profile to allow health checks to be
received by the firewall.

4. Click Commit. Verify that the link state for the interface is up.
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STEP 5 | (Oponal) If you enable health probes on the GWLB, you must create a stac route and
disable Automacally create default route poinng to default gateway provided by server
on the VM-Series firewall.
1. Log in to the VM-Series firewall user interface.
2. Select Network > Interfaces and select your data interface.
3. On the IPv4 tab, uncheck Automacally create default route poinng to default

gateway provided by server.

4. Click OK.
5. Select Network > Virtual Routers and select the virtual router associated with the data

interface.
6. Select Stac Routes and click Add.
7. Configure the stac route.
8. Click OK.
9. Commit your changes.
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STEP 6 | To enforce zone-based security policies, create two subinterfaces under eth1/1.
1. Log in to the firewall web interface.
2. Select Network > Interface.
3. Highlight ethernet1/1 and click Add Subinterface.
4. Enter a numerical suffix (1 to 9,999) to idenfy the subinterface.
5. Enter a VLAN Tag (1 to 4,094) for the subinterface. This field is required but the VLAN is

not used.
6. Select a Virtual Router.
7. Select a Security Zone.
8. On the IPv4 tab, set the Type to DHCP Client.
9. Click OK.
10. Repeat this command for the second subinterface.
11. Commit your changes.
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Create a Custom VM-Series Image for Azure
You can create a custom VM-Series firewall image for later use in your Azure deployment. A
custom image gives you the flexibility and consistency to deploy the VM-Series firewall with
the PAN-OS version you want to use instead of being restricted to using only an image available
though the Azure marketplace. Addionally, your custom image can include the latest content and
anvirus updates.

Creang a custom image requires that you remove all private data—user configuraon, users,
plugin configuraon, etc—before creang the VHD. Addionally, Complete the following
procedure to prepare and create a custom image.

If the VM-Series firewall used to create your custom image was deployed using a premium
disk type, any VM-Series firewall deployed using the custom image must be deployed using
the same premium disk type. However, if you create an image using firewall deployed with
a standard disk type, you can deploy the firewall using a standard or premium disk type.

STEP 1 | Log in to Azure.

STEP 2 | Deploy the VM-Series firewall from the Azure Marketplace.

STEP 3 | (BYOL license only) Acvate your license.

STEP 4 | Upgrade the VM-Series Firewall to PAN-OS 10.0.3. Upgrading to PAN-OS 10.0.3 also
upgrades the VM-Series plugin to 2.0.3.

STEP 5 | Access the VM-Series firewall command line interface via SSH using the username and
password provided in the Azure Marketplace template.

STEP 6 | Verify that you VM-Series firewall has the correct PAN-OS, VM-Series plugin, content, and
anvirus versions.

show system info

STEP 7 | ( BYOL license only) Deacvate your license.

STEP 8 | Perform a private data reset on the VM-Series firewall. This command requires the firewall to
reboot. You must wait for the VM-Series firewall to reboot complete before connuing; the
reboot can take five to seven minutes.

request system private-data-reset
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STEP 9 | Create a new VHD image from the VM-Series instance.
1. Log in to the Azure CLI.
2. Verify that you are using the correct subscripon.

az account set --subscription <subscription-id>
3. Execute the following commands to generalize the VM, allowing it to be imaged for

mulple deployments, and create the new VHD.

az vm deallocate --resource-group <myResourceGroup> --name
<myVM>

az vm generalize --resource-group <myResourceGroup> --name
<myVM>

STEP 10 | Create a new VM-Series firewall from your custom image.

az image create --resource-group <myResourceGroup> --name <myImage>
--source <resource-id-of-VM>

STEP 11 | Aer deploying a VM-Series firewall with your custom image, verify your deployment.
1. You should log in to the firewall using the credenals you used previously.
2. Aer logging in successfully, verify that your firewall is running the correct PAN-OS

version and has the correct content and anvirus versions.

show system info

STEP 12 | ( Oponal) Copy the custom image to another region.

az image copy –source-resource-group <source-rg> –source-object-name
<pa-vm-image-name> –target-location <target-region> –target-resource-
group <destination-rg>
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Use Azure Security Center Recommendaons to Secure
Your Workloads

Microso has deprecated Azure Security Center support for partner security soluons
and replaced it with Azure Sennel.

When you deploy new workloads within your Azure subscripon that is enabled for Azure
Security Center, Azure Security Center enables you to secure these workloads in two ways. In
one workflow, Azure Security Center recommends you to deploy a new instance of the VM-Series
firewall to secure an internet-facing applicaon workload. In the other workflow, Azure Security
Center discovers VM-Series firewalls (partner security soluons) that you have deployed within
the Azure subscripon and you have to then perform addional configuraon to connect the VM-
Series firewall to Azure Security Center so that you can view alerts on the dashboard. See Azure
Security Center Integraon for details on the integraon and the pros and cons of each workflow:

• Deploy a VM-Series Firewall Based on an Azure Security Center Recommendaon
• Connect an Exisng VM-Series Firewall From Azure Security Center

Deploy a VM-Series Firewall Based on an Azure Security Center
Recommendaon

Azure Security Center scans your Azure resources and provides recommendaons to secure
workloads that need a next-generaon firewall. The recommendaon displays on the dashboard
and you can then either deploy a new instance of the VM-Series firewall from the Azure
marketplace or you can use the Azure CLI, Powershell, or an ARM template. The advantage of
using a customized deployment using Azure CLI, Powershell, or an ARM template is that you can
deploy the VM-Series firewall within the same resource group as the workload that you need to
secure. When you deploy the VM-Series firewall using the Azure marketplace, Azure requires that
you deploy the firewall into a new resource group or an empty resource group only. Therefore, the
marketplace deployment requires you to then ensure that the traffic from the workload you want
to secure is steered to the firewall that is in a different resoource group.

STEP 1 | Log in to your Azure portal and access the Security Center dashboard.

STEP 2 | Select Recommendaons.
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STEP 3 | Select Add a Next Generaon Firewall, select the workload you want to secure.

STEP 4 | Choose whether you want to deploy a new instance of the VM-Series firewall or use an
exisng instance of the VM-Series firewall.

To use this workflow, stage a workload with a public IP address that is exposed to the internet
and deploy an instance of the VM-Series firewall in a new resource group. Then, delete the
workload you staged, and deploy your producon workloads within the resource group in
which you deployed the VM-Series firewall.

• To Create New, see Deploy the VM-Series Firewall from the Azure Marketplace (Soluon
Template).

• To Use exisng soluon, select the VM-Series firewall that you have previously deployed.

Connect an Exisng VM-Series Firewall From Azure Security
Center

When Azure Security Center detects that you have deployed the VM-Series firewall within the
Azure subscripon, it displays the firewall as a security soluon. You can then connect the VM-
Series firewall to Security Center using the Common Event Format (CEF) over Syslog, and view
firewall logs as alerts on the Security Center dashboard.

STEP 1 | Log in to your Azure portal and access the Security Center dashboard.
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STEP 2 | Select Security Soluons to view all available VM-Series firewalls within this Azure
subscripon.

STEP 3 | Expand Discovered soluons, and select the VM-Series firewall instance that is in the same
resource group as the workload you want to secure and click Connect.

To view firewall logs as alerts on the Security Center dashboard, you need to follow the four-
step process that displays on screen.
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STEP 4 | On successfully connecng the VM-Series firewall to Security Center, the VM-Series firewall
displays in the Connected soluons list.

Click View to verify that the firewall is protecng the workload that you need to secure.

Use Panorama to Forward Logs to Azure Security Center
If you are using Panorama to manage your firewalls, you can use templates and device groups
to forward firewall logs to Azure Security Center. With the default Azure Security Center Log
Forwarding profile, Threat and WildFire Submissions logs of low, medium, high, or crical severity
generated on the firewall are displayed as security alerts on the Azure Security Center dashboard.
So that you can focus and triage alerts more efficiently, you can set up granular log filters to
only forward logs of interest to you, or forward high and crical severity logs only. You can
also selecvely aach the log forwarding profile to a few Security policy rules based on your
applicaons and security needs.

To enable the Azure Security Center integraon from Panorama, use the following workflow.

STEP 1 | Add the firewall as a managed device on Panorama.

STEP 2 | From Panorama, create a template and a device group to push log forwarding sengs to the
firewalls that will be forwarding logs to Azure Security Center.
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STEP 3 | Specify the log types to forward to the Logging Service.

The way you enable forwarding depends on the log type. For logs that are generated based on
a policy match, you use a log forwarding profile within a device group, and for other logs types
you use the Log Sengs configuraon within a template.

1. Configure forwarding of System, Configuraon, User-ID, and HIP Match logs.

1. Select Device > Log Sengs.
2. Select the Template that contains the firewalls you want to forward logs to the

Logging Service.
3. For each log type that you to forward to the Logging Service, Add a match list filter.

Give it a Name, oponally define a Filter.
4. Add Built-in Acons and enter a Name. The Azure-Security-Center-Integraon acon

will be auto selected. Click OK.

5. Click OK.
2. Configure forwarding of all other log types that are generated when a policy match

occurs such as Traffic, Threat, WildFire Submission, URL Filtering, Data Filtering, and
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Authencaon logs. To forward these logs, you must create and aach a log forwarding
profile to each policy rule for which you want to forward logs.

1. Select the Device Group, and then select Objects > Log Forwarding to Add a profile.
In the log forwarding profile match list, add each log type that you want to forward.

2. Select Add in Built-in Acons to enable the firewalls in the device group to forward
the logs to Azure Security Center.

3. Create basic security policy rules in the device group you just created and select
Acons to aach the Log Forwarding profile you created for forwarding logs to Azure
Security Center. Unl the firewall has interfaces and zones and a basic security policy,
it will not let any traffic through, and only traffic that matches a security policy rule
will be logged (by default).

4. For each rule you create, select Acons and select the Log Forwarding profile that
allows the firewall to forward logs to Azure Security Center.

STEP 4 | Commit your changes to Panorama and push them to the template and device group you
created.

STEP 5 | Verify that the firewall logs are being forwarded to Azure Security Center.
1. Log in the Azure portal, select Azure Security Center.
2. Verify that you can see firewall logs as Security alerts on the Azure Security Center

dashboard.
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Deploy the VM-Series Firewall on Azure Stack
You can deploy the VM-Series firewall on Azure Stack to secure inter-subnet traffic between
applicaons in a mul-er architecture and outbound traffic from servers within your Azure Stack
deployment. If you want to use the VM-Series firewall as a gateway that secures inbound traffic
desned to the servers within your Azure Stack deployment, you must deploy a NAT appliance
in front of the firewall that receives inbound traffic and forwards it to the firewall. The NAT
appliance is required because on Azure Stack you cannot assign a public IP address to a non-
primary interface of a virtual machine, such as the VM-Series firewall.

The VM-Series firewall on Azure stack does not have support for bootstrapping, Azure
Applicaon Insights, or the Azure Security Center integraon.

Unlike on public Azure, you do not have a soluon template to deploy the VM-Series firewall
on Azure Stack. Therefore, you must use an ARM template to deploy the VM-Series firewall. To
get started, you can use the community supported sample ARM template on GitHub, and then
develop your own ARM template for producon deployments.

All VM-Series firewall interfaces must be assigned an IPv4 address when deployed in a
public cloud environment. IPv6 addresses are not supported.

STEP 1 | Download marketplace items from Azure to AzureStack.

To deploy the VM-Series firewall on Azure Stack, you need access to the BYOL offer of the
VM-Series firewall PAN-OS image (8.1 or later). You can download the image directly from the
Azure Marketplace to Azure Stack in a connected deployment.

STEP 2 | Access the Azure Stack portal.

Your Azure Stack operator (either a service provider or an administrator in your organizaon),
should provide the correct URL to access the portal.

STEP 3 | Deploy the VM-Series firewall.

A soluon template for the VM-Series firewall is not available on Azure Stack. Therefore, you
must reference the image that you downloaded in the previous step, in an ARM template to
deploy the VM-Series firewall. To get started, you can deploy the sample ARM template that is
available on GitHub under the community supported policy:

1. Get the sample Azure Stack GitHub template.

• Select azurestackdeploy.json to view the contents.
• Click Raw and copy the contents of the JSON file.

2. Deploy the sample GitHub template.

You can deploy the firewall in a exisng resource group that is empty or into a new
resource group. The default VNet in the template is 192.168.0.0/16, and it deploys
a VM-Series firewall has three network interfaces, one management interface
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on 192.168.0.0/24 subnet and two dataplane interfaces on 192.168.1.0/24 and
192.168.2.0/24 subnets. You can customize these subnets to match your needs.

• Log in to the Azure Stack portal.
• Select New > Custom > Template deployment.

• Edit template, delete all exisng content in the template, and paste the JSON
template contents you copied earlier andSave.

• Edit parameters, enter the values for the required parameters and modify the defaults
if you need to, then click OK.

VM-Series Deployment Guide Version Version 10.1 624 ©2022 Palo Alto Networks, Inc.



Set up the VM-Series Firewall on Azure

• Choose the Subscripon you want to use, and then click OK.
• Choose an exisng Resource Group that is empty or create a new one, and click OK.
• Click Create. A new le on the dashboard displays the progress of the template

deployment.
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STEP 4 | Next Steps:
1. Log in to the web interface of the firewall.

Using a secure connecon (hps) from your web browser, log in to the DNS name for
the firewall. Enter the username/password you defined earlier. You will see a cerficate
warning; that is okay. Connue to the web page.

2. Acvate the licenses on the VM-Series firewall.

1. Create a Support Accountand Register the VM-Series Firewall (with auth code)
2. On the firewall web interface, select Device > Licenses and select Acvate feature

using authencaon code.
3. Enter the capacity auth-code that you registered on the support portal. The firewall

will connect to the update server (updates.paloaltonetworks.com), and download the
license and reboot automacally.

4. Log back in to the web interface on the Dashboard, confirm that a valid Serial#
displays.

The VM Mode displays as Microso Azure.

If the term Unknown displays, it means the device is not licensed. To view traffic logs
on the firewall, you must install a valid capacity license.

STEP 5 | Configure the dataplane network interfaces as Layer 3 interfaces on the firewall.
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Enable Azure Applicaon Insights on the VM-Series
Firewall

The VM-Series firewall on Azure can publish custom PAN-OS metrics navely to Azure
Applicaon Insights that you can use to monitor the firewalls directly from the Azure portal. These
metrics allow you to assess performance and usage paerns that you can use to set alarms and
take acon to automate events such as launching or terminang instances of the VM-Series
firewalls. See Custom PAN-OS Metrics Published for Monitoring for a descripon on the metrics
that are available.

STEP 1 | On the Azure portal, create your Applicaon Insights instance to monitor the firewall and
copy the Instrumentaon Key from Configure > Properes.

The firewall needs this key to authencate to the Applicaon Insights instance and publish
metrics to it. See VM-Series on Azure Service Principal Permissions for the permissions
required.
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STEP 2 | Enable the firewall to publish metrics to your Applicaon Insights instance.
1. Log in to the VM-Series firewall on Azure.
2. Select Device > VM-Series > Azure.
3. Edit Azure Applicaon Insights and enter the Instrumentaon Key you copied earlier.

The default interval for publishing metrics is five minutes. You can change this to vary
from 1-60 minutes.

4. Commit your changes.

The firewall generates a system log to it record the success or failure to authencate to
Azure Applicaon Insights.
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STEP 3 | Verify that you can view the metrics on the Azure Applicaon Insights dashboard.
1. On the Azure portal, select the Applicaon Insights instance, and select Monitoring >

Metrics to view the PAN-OS custom metrics.

2. Select the metric(s) that you want to monitor for trends and trigger alerts. Refer to the
Microso Azure documentaon for details on exploring metrics on Applicaon Insights.
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Monitoring on Azure
Monitoring on Microso® Azure® enables you to dynamically update security policy rules to
consistently enforce Security policy across all assets deployed within your Azure subscripon.
To enable this capability, you need to install the Panorama plugin for Azure and enable API
communicaon between Panorama and your Azure subscripons. Panorama can then collect
the IP address-to-tag mapping for all your Azure assets and push or distribute Azure resources
informaon to your Palo Alto Networks® firewall(s).

• About Monitoring on Azure
• Set Up the Azure Plugin for Monitoring on Panorama
• Aributes Monitored Using the Panorama Plugin on Azure

About Monitoring on Azure
As you deploy or terminate virtual machines in the Azure public cloud, you can use the Panorama
plugin for Azure to consistently enforce security policy rules on these workloads.

The Panorama plugin for Azure is built for scale and allows you to monitor up to 100 Azure
subscripons on the Azure public cloud. With this plugin, you use Panorama as an anchor to poll
your subscripons for tags, and then distribute the metadata (IP address-to-tag mapping) to many
firewalls in a device group. Because Panorama communicates with your Azure subscripons to
retrieve Azure resource informaon, you’re able to streamline the number of API calls made to the
cloud environment. Although you can define Security policy locally on the firewall, using Panorama
and the plugin centralizes Security policy management, ensuring consistent policies for hybrid and
cloud-nave architectures.

See the Panorama plugin version informaon in the Compability Matrix.

Set Up the Azure Plugin for Monitoring on Panorama
To find all the workloads that your organizaon has deployed in the Azure cloud, you need to
install the Azure plugin on Panorama and configure Monitoring Definions that enable Panorama
to authencate to your Azure subscripon(s) and retrieve informaon on the Azure workloads.
Panorama retrieves the primary private IP address of Azure resources and the associated tags.
For a list of the metadata elements that Panorama supports, see Aributes Monitored Using the
Panorama Plugin on Azure.

Aer Panorama fetches the aributes, to push the resource informaon from Panorama to the
firewalls, you must add the firewalls (hardware or VM-Series) as managed devices on Panorama,
and group the firewalls into one or more Device Groups. You can then specify which device groups
are part of the Nofy Group, which is a configuraon element in a Monitoring Definion, that
Panorama uses to register the IP address-to-tag mapping it retrieves from Azure.

Finally, to consistently enforce Security policies across your Azure workloads, you must set up
Dynamic Address Groups and reference them in policy rules that allow or deny traffic to the IP
addresses of the Azure resources. For streamlining your configuraon and managing policies and
objects centrally from Panorama, you can define the Dynamic Address Groups and Security policy
rules on Panorama and push them to the firewalls instead of managing the Dynamic Address
Groups and Security policy rules locally on each firewall.
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The Azure plugin is for monitoring Azure resources on the Azure public cloud. Azure
Government or Azure China are not supported.

• Planning Checklist for VM Monitoring with the Azure Plugin
• Install the Azure Plugin
• Configure the Azure Plugin for Monitoring

Planning Checklist for Monitoring with the Azure Plugin
Set up the Acve Directory applicaon and a Service Principal to enable API access—For
Panorama to interact with the Azure APIs and collect informaon on your workloads, you need
to create an Azure Acve Directory Service Principal. This Service Principal has the permissions
required to authencate to the Azure AD and access the resources within your subscripon.

To complete this set up, you must have permissions to register an applicaon with your Azure
AD tenant, and assign the applicaon to a role in your subscripon. If you don't have the
necessary permissions, ask your Azure AD or subscripon administrator to create a Service
Principal with an IAM role of reader or the custom permissions specified in VM-Series on Azure
Service Principal Permissions.
Make sure that the subscripon ID is unique across Service Principals. Panorama allows you
to use only one service principal to monitor an Azure subscripon. You can monitor up to
100 Azure subscripons, with 100 Service principal resources. Starng with Panorama plugin
for Azure version 3.2.0, you can monitor up to 500 Azure subscripons. Take note of the
processing mes described in the table below.

Number of Subscripons

100 200 300 400 500

System
Resources
Ulizaon

• CPU:
22%

• Memory:
0.025
MB

• CPU:
23.8%

• Memory:
0.025 MB

• CPU:
31.8%

• Memory:
0.025 MB

• CPU:
28.6%

• Memory:
0.025 MB

• CPU:
39.2%

• Memory:
0.025 MB

Average Time
to Process All
Monitoring
Definions

1 Hour, 15
Minutes

2 Hours, 30
Minutes

3 Hours, 30
Minutes

4 Hours 5 Hours

Average
Tag Update
Processing
Time

5 minutes 10 minutes 15 minutes 20 minutes 25 minutes

The informaon in the table above was captured on an instance with 8 vCPUs and
32GB of memory.
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Panorama can push up to 8000 IP address-to tag mappings to the firewalls or virtual system
assigned to a device group. Review the requirements for Panorama and the managed firewalls:

• Minimum system requirements (see the Panorama Plugin informaon in the Compability
Matrix):

Panorama virtual appliance or hardware-based Panorama appliance running Panorama
8.1.3 or later, with an acve support license and a device management license for managing
firewalls.

Licensed next-generaon firewalls running PAN-OS 8.0 or 8.1.
• You must add the firewalls as managed devices on Panorama and create Device Groups so

that you can configure Panorama to nofy these groups with the informaon it retrieves.
Device groups can include VM-Series firewalls or virtual systems on the hardware firewalls.

• The number of tags that the Panorama plugin can retrieve and register is as follows:

On Panorama running 8.1.3 or later managing firewalls running PAN-OS 8.1.3 or lower, the
firewalls or virtual systems included within a device group can have 7000 IP addresses with
10 tags each, or 6500 IP addresses with 15 tags each.

On Panorama 8.1.3 or later managing firewalls running PAN-OS 8.0.x, 2500 IP addresses
with 10 tags each.

• If your Panorama appliances are in a high availability configuraon, you must manually
install the same version of the Azure plugin on both Panorama peers.

You configure the Azure plugin on the acve Panorama peer only. On commit, the
configuraon is synced to the passive Panorama peer. Only the acve Panorama
peer polls the Azure subscripons you have configured for Monitoring.

Install the Azure Plugin
To get started with Monitoring on Azure, you need to download and install the Azure plugin on
Panorama. If you have a Panorama HA configuraon, repeat this installaon process on each
Panorama peer.

If you currently have installed a Panorama plugin, the process of installing (or uninstalling)
another plugin requires a Panorama reboot to enable you to commit changes. So, install
addional plugins during a planned maintenance window to allow for a reboot.

If you have a standalone Panorama or two Panorama appliances installed in an HA pair with
mulple plugins installed, plugins might not receive updated IP-tag informaon if one or more of
the plugins is not configured. This occurs because Panorama will not forward IP-tag informaon
to unconfigured plugins. Addionally, this issue can occur if one or more of the Panorama plugins
is not in the Registered or Success state (posive state differs on each plugin). Ensure that your
plugins are in the posive state before connuing or execung the commands described below.

If you encounter this issue, there are two workarounds:

• Uninstall the unconfigured plugin or plugins. It is recommended that you do not install a plugin
that you do not plan to configure right away

VM-Series Deployment Guide Version Version 10.1 632 ©2022 Palo Alto Networks, Inc.

https://docs.paloaltonetworks.com/compatibility-matrix/panorama/plugins.html
https://docs.paloaltonetworks.com/panorama/8-1/panorama-admin/manage-firewalls/add-a-firewall-as-a-managed-device
https://docs.paloaltonetworks.com/panorama/8-1/panorama-admin/manage-firewalls/manage-device-groups/add-a-device-group


Set up the VM-Series Firewall on Azure

• You can use the following commands to work around this issue. Execute the following
command for each unconfigured plugin on each Panorama instance to prevent Panorama from
waing to send updates. If you do not, your firewalls may lose some IP-tag informaon.

request plugins dau plugin-name <plugin-name> unblock-device-push yes

You can cancel this command by execung:

request plugins dau plugin-name <plugin-name> unblock-device-push no

The commands described are not persistent across reboots and must be used again for any
subsequent reboots. For Panorama in HA pair, the commands must be executed on each
Panorama.

STEP 1 | Log in to the Panorama Web Interface, select Panorama > Plugins and click Check Now to
get the list of available plugins.

STEP 2 | Select Download and Install the plugin.

Aer you successfully install, Panorama refreshes and the Azure plugin displays on the
Panorama tab.

STEP 3 | Restart Panorama.

Select Panorama > Setup > Operaons > Reboot Panorama

Configure the Azure Plugin for Monitoring
To begin monitoring the resources in your Azure public cloud deployment, aer you Install
the Azure Plugin you must create a Monitoring Definion. This definion specifies the Service
Principal that is authorized to access the resources within the Azure subscripon you want to
monitor and the Nofy Group that includes the firewalls to which Panorama should push all the
IP-address-to-tag mappings it retrieves. In order to enforce policy, you must then create Dynamic
Address Groups and reference them in Security policy. The Dynamic Address Groups enable you
to filter the tags you want to match on, so that the firewall can get the primary private IP address
registered for the tags, and then allow or deny access to traffic to and from the workloads based
on the policy rules you define.

STEP 1 | Log in to the Panorama web interface.

VM-Series Deployment Guide Version Version 10.1 633 ©2022 Palo Alto Networks, Inc.



Set up the VM-Series Firewall on Azure

STEP 2 | Set up the following objects for enabling Monitoring on Azure.

Add a Service Principal.

The Service Principal is the service account that you created on the Azure portal. This
account is aached to the Azure AD and has limited permissions to access and monitor the
resources in your Azure subscripon.

1. Select Panorama > Plugins > Azure > Setup > Service Principal > Add.

2. Enter a Name and oponally a Descripon to idenfy the service account.
3. Enter the Subscripon ID for the Azure subscripon you want to monitor. You must login

to your Azure portal to get this subscripon ID.
4. Enter the Client Secret and re-enter it to confirm.
5. Enter the Tenant ID. The tenant ID is the Directory ID you saved when you set up the

Acve Directory applicaon.
6. Click Validate to verify that the keys and IDs you entered are valid ,and Panorama can

communicate with the Azure subscripon using the API.
Add a nofy group.

1. Select Panorama > Plugins > Azure > Setup > Nofy Groups > Add.
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2. Enter a Name and oponally a Descripon to idenfy the group of firewalls to which
Panorama pushes the informaon it retrieves.

3. Select the Device Groups, which are a group of firewalls or virtual systems, to which
Panorama will push the informaon (IP address-to-tag mapping) it retrieves from your
Azure subscripons. The firewalls use the update to determine the most current list of
members that constute dynamic address groups referenced in policy.

Think through your Device Groups carefully.

• Because a Monitoring Definion can include only one nofy group, make sure
to select all the relevant Device Groups within your nofy group. If you want to
deregister the tags that Panorama has pushed to a firewall included in a nofy group,
you must delete the Monitoring Definion.

• To register tags to all virtual systems on a firewall enabled for mulple virtual systems,
you must add each virtual system to a separate device group on Panorama and assign
the device groups to the nofy group. Panorama will register tags to only one virtual
system, if you assign all the virtual systems to one device group.

4. Verify that monitoring is enabled on the plugin. This seng must be enabled for
Panorama to communicate with the Azure public cloud for Monitoring.

The checkbox for Enable Monitoring is on Panorama > Plugins > Azure > Setup >
General.
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STEP 3 | Create a Monitoring Definion.

When you add a new Monitoring definion, it is enabled by default.

• Select Panorama > Plugins > Azure > Monitoring Definion, to Add a new definion.
• Enter a Name and oponally a Descripon to idenfy the Azure subscripon for which you

use this definion.
• Select the Service Principal and Nofy Group.

Panorama requires the keys and IDs that you specify in the Service Principal configuraon
to generate an Azure Bearer Token which is used in the header of the API call to collect
informaon on your workloads.

STEP 4 | Commit the changes on Panorama.

Verify that the status for the Monitoring Definion displays as Success. If it fails, verify that
you entered the Azure Subscripon ID accurately and provided the correct keys and IDs for the
Service Principal.
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STEP 5 | Verify that you can view the informaon on Panorama, and define the match criteria for
Dynamic Address Groups.

Some browser extensions may block API calls between Panorama and Azure which
prevents Panorama from receiving match criteria. If Panorama displays no match
criteria and you are using browser extensions, disable the extensions and Synchronize
Dynamic Objects to populate the tags available to Panorama.

On HA failover, the newly acve Panorama aempts to reconnect to the Azure cloud
and retrieve tags for all monitoring definions. If there is an error with reconnecng
even one monitoring definion, Panorama generates a system log message

Unable to process subscriptions after HA switch-over;
 user-intervention required.

When you see this error, you must log in to Panorama and fix the issue, for example
remove an invalid subscripon or provide valid credenals, and commit your changes
to enable Panorama to reconnect and retrieve the tags for all monitoring definions.
Even when Panorama is disconnected from the Azure cloud, the firewalls have the list
of all tags that had been retrieved before failover, and can connue to enforce policy
on that list of IP addresses. Panorama removes all tags associated with the subscripon
only when you delete a monitoring definion. As a best pracce, to monitor this issue,
configure acon-oriented log forwarding to an HTTPS desnaon from Panorama so
that you can take immediate acon.
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Aributes Monitored Using the Panorama Plugin on Azure
When using the Panorama plugin for Azure, Panorama gathers the following set of metadata
elements or aributes on the virtual machines in your Microso® Azure® deployment. Panorama
can retrieve a total of 32 tags for each VM, 11 predefined tags and up to 21 user-defined tags.

The maximum length of a tag can be 127 characters. If a tag is longer than 127
characters, Panorama does not retrieve the tag and register it on the firewalls. Also the
tags should not include non-ASCII special characters such as { or ".

The following aributes are monitored in all Panorama plugin for Azure versions.

Virtual Machine

VM Monitoring Example

VM Name azure-tag.vm-name.web_server1

Network Security Group Name azure-tag.nsg-name.myNSG

OS Type azure-tag.os-type.Linux

OS Publisher azure-tag.os-publisher.Canonical

OS Offer azure-tag.os-offer.UbuntuServer

OS SKU azure-tag.os-sku.14.04.5-LTS

Subnet azure-tag.subnet.weber

VNet azure-tag.vnet.untrustnet

Azure Region azure-tag.region.east-us

Resource Group Name azure-tag.resource-group.myResourceGroup

Subscripon ID azure.sub-id.93486f84-8de9-44f1-b4a8-
f66aed312b64

User Defined Tags

Up to a maximum of 21 user defined
tags are supported. The user-defined
tags are sorted alphabecally, and the
first 21 tags are available for use on
Panorama and the firewalls.

azure-tag.mytag.value

Load Balancer
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Panorama plugin on Azure version 3.0 or later supports tags for each applicaon gateway and
standard load balancer (both public and private IP addresses). Each load balancer has predefined
tags for resource group, load balancer name and region, and supports up to 21 user-defined tags
specific to load balancing.

Load Balancer Tags Example

Load Balancer azure.<type>.myLoadBalancer

Azure Region azure-tag.region.east-us

Resource Group Name azure-tag.resource-group.myResourceGroup

User Defined Tags

Up to a maximum of 21 user defined
tags are supported. The user-defined
tags are sorted alphabecally, and the
first 21 tags are available for use on
Panorama and the firewalls.

azure-tag.mytag.value

Subnet/VNET

Panorama plugin on Azure version 3.0 or later supports tags for each Subnet and VNET in your
subscripon. Each subnet and VNET tag is associated with the full IP CIDR range so you can
create policies based on a CIDR range rather than individual IP addresses. The plugin queries
every subnet and VNET in your subscripon and creates tags for them.

Subnet and VNET Tags Example

Subnet Name azure.subnet-name.web

VNET Name azure.vnet-name.myvnet

Service Tag Monitoring

Panorama plugin on Azure version 3.0 supports service tags.

Azure Service tags simplify security for Azure virtual machines and Azure virtual networks
because you can restrict network access to just the Azure services you want to use. A service tag
represents a group of IP address prefixes for a parcular Azure service. For example, a tag can
represent all storage IP addresses.

The plugin makes a daily API call (at 5:00 am UTC) to retrieve all service tags from the Azure
Portal, parses the payload to form IP-Service Mappings, and stores the mappings in the plugin
database. The mappings are passed to configd, then on to Panorama. If the API call fails to
return service informaon, the plugin forms the IP-Service mappings from the contents of
service_tags_public.json. Plugin logs report the origin of the IP-Service mappings, the
daily retrieval or the JSON file.
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The plugin also updates service tags for a new installaon of the plugin, commit events, and
monitoring definion addion or deleon.

A sample IP-Service mapping is shown below:

Service Name: AppServiceManagementazure.svc-tag.<service-name>
Example:
    azure.svc-tag.AppServiceManagement.WestUS2
Public IP CIDRs:
    13.166.40.0/26
    54.179.89.0/18

VM-Series Deployment Guide Version Version 10.1 640 ©2022 Palo Alto Networks, Inc.



Set up the VM-Series Firewall on Azure

Set up Acve/Passive HA on Azure
You can configure a pair of VM-Series firewalls on Azure in an acve/passive high availability (HA)
configuraon. For HA on Azure, you must deploy both firewall HA peers within the same Azure
Resource Group and you must install the same version of the VM-Series Plugin on both HA peers.

• Set up Acve/Passive HA on Azure (North-South & East-West Traffic)—If you have an internet-
facing applicaon deployed on your Azure infrastructure, and you need to secure north-south
traffic, you require a floang IP address to secure traffic on failover. This floang IP address,
which enables external connecvity, is always aached to the acve peer. On failover, the
process of detaching the IP address and reaaching it to the now acve peer can take a few
minutes.

• Set up Acve/Passive HA on Azure (East-West Traffic Only)—If your applicaon access and
security requirements are contained within the Azure infrastructure and you need to secure
east-west traffic only, you do not need a floang IP address. Instead, the HA implementaon
automacally reconfigures the UDRs in the Azure roung tables to provide a faster failover
me.

All VM-Series firewall interfaces must be assigned an IPv4 address when deployed in a
public cloud environment. IPv6 addresses are not supported.

To enable HA on the VM-Series firewall on Azure, you must create an Azure Acve Directory
applicaon and Service Principal that includes the permissions listed in the table below.

Azure HA
Type

Permissions Role Scope

Secondary
IP Move
HA

"Microsoft.Authorization/
*/read""Microsoft.Compute/
virtualMachines/
read""Microsoft.Network/
networkInterfaces/
*""Microsoft.Network/
networkSecurityGroups/
*""Microsoft.Network/
virtualNetworks/join/
action""Microsoft.Network/
virtualNetworks/subnets/join/action"

The following permissions are required only if
you have assigned a public IP address to any of
your data interfaces. Standard SKU interface is
recommended.

"Microsoft.Network/
publicIPAddresses/join/
action""Microsoft.Network/
publicIPAddresses/

• Virtual network in which
the VMs are deployed

• Two VM-Series firewalls
• NICs of both VM-Series

firewalls
• Network Security Group
• Public IP addresses of

the VM-Series firewalls
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Azure HA
Type

Permissions Role Scope

read""Microsoft.Network/
publicIPAddresses/write"

UDR HA "Microsoft.Authorization/
*/read""Microsoft.Compute/
virtualMachines/
read""Microsoft.Network/
routeTables/*""Microsoft.Network/
networkInterfaces/*"

• Two VM-Series firewalls
• NICs of both VM-Series

firewalls
• Route tables associated

with UDR

Secondary
IP Move
and UDR

"Microsoft.Authorization/
*/read""Microsoft.Compute/
virtualMachines/
read""Microsoft.Network/
networkInterfaces/
*""Microsoft.Network/
networkSecurityGroups/
*""Microsoft.Network/
routeTables/*""Microsoft.Network/
virtualNetworks/join/
action""Microsoft.Network/
virtualNetworks/subnets/join/action"

The following permissions are required only if
you have assigned a public IP address to any of
your data interfaces. Standard SKU interface is
recommended.

"Microsoft.Network/
publicIPAddresses/join/
action""Microsoft.Network/
publicIPAddresses/
read""Microsoft.Network/
publicIPAddresses/write"

• Virtual network in which
the VMs are deployed

• Two VM-Series firewalls
• NICs of both VM-Series

firewalls
• Network Security Group
• Public IP addresses of

the VM-Series firewalls
• Route tables associated

with UDR

Set up Acve/Passive HA on Azure (North-South & East-West
Traffic)

If you want to secure north-south traffic to your applicaons in your Azure infrastructure, use this
workflow with floang IP addresses that can quickly move from one peer to the other. Because
you cannot move the IP address associated with the primary interface of the firewall on Azure,
you need to assign a secondary IP address that can funcon as a floang IP address. When the
acve firewall goes down, the floang IP address moves from the acve to the passive firewall
so that the passive firewall can seamlessly secure traffic as soon as it becomes the acve peer. In
addion to the floang IP address, the HA peers also need HA links—a control link (HA1) and a
data link (HA2)—to synchronize data and maintain state informaon.
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• Set up the Firewalls for Enabling HA
• Configure Acve/Passive HA on the VM-Series Firewall on Azure

Set up the Firewalls for Enabling HA
Gather the following details for configuring HA on the VM-Series firewalls on Azure.

Set up the Acve Directory applicaon and a Service Principal to enable programmac API
access.

• For the firewall to interact with the Azure APIs, you need to create an Azure Acve
Directory Service Principal. This Service Principle has the permissions required to
authencate to the Azure AD and access the resources within your subscripon.To
complete this set up, you must have permissions to register an applicaon with your Azure
AD tenant, and assign the applicaon to a role in your subscripon. If you don't have the
necessary permissions, ask your Azure AD or subscripon administrator to create a Service
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Principal. See the table above for the required permissions. Copy the following details for
use later in this workflow:

• Client ID—The Applicaon ID associated with the Acve Directory (On the Azure portal,
click Home > Azure Acve Directory > App registraons, select your applicaon and
copy the ID).

• Tenant ID—The Directory ID associated with the Acve Directory (On the Azure portal,
click Home > Azure Acve Directory > Properes > Directory ID, select the applicaon
and copy the ID).

• Azure Subscripon ID—The Azure subscripon in which you have deployed the firewalls.
You must login to your Azure portal to get this subscripon ID.

• Resource Group Name— The resource group name in which you have deployed the
firewalls that you want to configure as HA peers. Both firewalls must be in the same
resource group.
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• Secret Key—The authencaon key associated with the Acve Directory applicaon (On
the Azure portal, click Home > Azure Acve Directory > Cerficates & secrets, copy
the Value under Client secrets. If you do not have a Secret Key, create one first, then
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copy the value). To log in as the applicaon, you must provide both the key value and the
Applicaon ID.
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Know where to get the templates you need to deploy the VM-Series firewalls within the same
Azure Resource Group.

For an HA configuraon, both HA peers must belong to the same Azure Resource Group. If you
deploy the first instance of the firewall from the Azure Marketplace, and must use your custom
ARM template for deploying the second instance of the firewall into the exisng Resource
Group. The reason you need a custom template or the Palo Alto Networks sample template is
because Azure does not support the ability to deploy the firewall in to an Resource Group that
is not empty.

Copy the deployment informaon for the first firewall instance. For example:

Match the VM Name of VM-Series firewall as shown in the screenshot above with the
Hostname on the firewall web interface. You must add the same name on Device > Setup >
Management, because the hostname of the firewall is used to trigger failover.
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Plan the network interface configuraon on the VM-Series firewalls on Azure.

To set up HA, you must deploy both HA peers within the same Azure Resource Group and
both firewalls must have the same number of network interfaces. A minimum of four network
interfaces is required on each HA peer:

• Management interface (eth0)—Private and public IP address associated with the primary
interface. The public IP address enables access to the firewall web interface and SSH access.

You can use the private IP interface on the management interface as the HA1 peer IP
address for the control link communicaon between the acve/passive HA peers. If you
want a dedicated HA1 interface, you must aach an addional network interface on each
firewall, and this means that you need five interfaces on each firewall.

• Untrust interface (eth1/1)—Primary private IP address with /32 netmask, and secondary IP
configuraon with both a private IP address (any netmask) and a public IP address.

On failover, when the passive peer transions to the acve state, the public IP address
associated with the secondary IP configuraon is detached from the previously acve peer
and aached to the now acve HA peer.

• Trust interface (eth1/2)—Primary and secondary private IP addresses. On failover, when the
passive peer transions to the acve state, the secondary private IP address is detached
from the previously acve peer and is aached to the now acve HA peer.

• HA2 (eth 1/3)—Primary private IP address. The HA2 interface is the data link that the HA
peers use for synchronizing sessions, forwarding tables, IPSec security associaons and ARP
tables.

Interface Acve firewall
peer

Passive
firewall peer

Descripon

Trust Secondary IP
address

— The trust interface of the acve peer requires
a secondary IP configuraon that can float to
the other peer on failover. This secondary IP
configuraon on the trust interface must be a
private IP address with the netmask of the servers
that it secures. On failover, the VM-Series plugin
calls the Azure API to detach this secondary
private IP address from the acve peer and aach
it to the passive peer. Aaching this IP address to
the now acve peer ensures that the firewall can
receive traffic on the floang IP on the untrust
interface and send it through to the floang IP on
the trust interface and on to the workloads.

Untrust Secondary IP
address

— The untrust interface of the firewall requires a
secondary IP configuraon that includes a stac
private IP address with a netmask for the untrust
subnet, and a public IP address for accessing the
back-end servers or workloads over the internet.
On failover, the VM-Series plugin calls the Azure
API to detach the secondary IP configuraon
from the acve peer and aach it to the passive
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Interface Acve firewall
peer

Passive
firewall peer

Descripon

peer before it transions to the acve state. This
process of floang the secondary IP configuraon,
enables the now acve firewall to connue
processing inbound traffic that is desned to the
workloads.

HA2 Add a NIC
to the
firewall from
the Azure
management
console.

Add a NIC
to the
firewall from
the Azure
management
console.

On the acve and passive peers, add a dedicated
HA2 link to enable session synchronizaon.

The default interface for HA1 is the management
interface, and you can opt to use the management
interface instead of adding an addional interface
to the firewall. For enabling data flow over the
HA2 link, you need to add an addional network
interface on the Azure portal and configure the
interface for HA2 on the firewall.

Configure Acve/Passive HA on the VM-Series Firewall on Azure
In this workflow, you deploy the first instance of the VM-Series firewall using the VM-Series
firewall soluon template in the Azure marketplace, and the second instance of the firewall using
the sample GitHub template.

The authencaon key (client secret) associated with the Acve Directory applicaon
required for seng up the VM-Series firewall in an HA configuraon, is encrypted with
VM-Series plugin version 1.0.4 on the firewall and on Panorama. Because the key is
encrypted in VM-Series plugin version 1.0.4, you must install the same version of the
plugin on Panorama and the managed VM-Series firewalls in order to centrally manage the
firewalls from Panorama.
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STEP 1 | Deploy the VM-Series firewall using a soluon template and set up the network interfaces
for HA.

1. Add a secondary IP configuraon to the untrust interface of the firewall.

You must aach the secondary IP configuraon—with a private IP address (any netmask)
and a public IP address—to the firewall that will be designated as the acve peer. The
secondary IP configuraon always stays with the acve HA peer, and moves from one peer
to the another when a failover occurs.

In this workflow, this firewall will be designated as the acve peer. The acve HA peer
has a lower numerical value for device priority that you configure as a part of the HA
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configuraon on the firewall, and this value indicates a preference for which firewall
assumes the role of the acve peer.

2. Add a secondary IP configuraon to the trust interface of the firewall.

The secondary IP configuraon for the trust interface requires a stac private IP address
only. This IP address moves from the acve firewall to the passive firewall on failover so that
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traffic flows through from the untrust to the trust interface and to the desnaon subnets
that the firewall secures.

3. Aach a network interface for the HA2 communicaon between the firewall HA peers.

1. Add a subnet within the virtual network.
2. Create and aach a network interface to the firewall.

4. Set up your route table on Azure.

Your next hop should point to the floang IP address as shown here:
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STEP 2 | Configure the interfaces on the firewall.

Complete these steps on the acve HA peer, before you deploy and set up the passive HA
peer.

1. Log in to the firewall web interface.
2. Configure ethernet 1/1 as the untrust interface and ethernet 1/2 as the trust interface.

Select Network > Interfaces and configure as follows:
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3. Configure ethernet 1/3 as the HA interface.

To set up the HA2 link, select the interface and set Interface Type to HA. Set link speed
and duplex to auto.
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STEP 3 | Configure the VM-Series plugin to authencate to the Azure resource group in which you
have deployed the firewall.

Set up the Azure HA configuraon on the VM-Series plugin.

To encrypt the client secret, use the VM-Series plugin version 1.0.4 or later. If using Panorama
to manage your firewalls, you must install the VM-Series plugin version 1.0.4 or later.

1. Select Device > VM-Series to enable programmac access between the firewall plugin and
the Azure resources.

2. Enter the Client ID. The client ID is the Applicaon ID associated with your Azure Acve
Directory applicaon.

3. Enter the Client Secret and re-enter it to confirm.
4. Enter the Tenant ID. The tenant ID is the Directory ID you saved when you set up the

Acve Directory applicaon.
5. Enter the Subscripon ID for the Azure subscripon you want to monitor.
6. Enter the Resource Group name.
7. (For Azure Stack deployments only) Enter the Resource Mgr Endpoint URL.

This field is available in VM-Series plugin 2.1.2 and later.

8. Click Validate to verify that the keys and IDs you entered are valid, and that VM-Series
plugin can successfully communicate with the Azure resources using the API.
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STEP 4 | Enable HA.

1. Select Device > Setup > HA.
2. Enter Peer HA1 IP address as the private IP address of the passive peer.
3. (Oponal) Edit the Control Link (HA1). If you do not plan to use the management interface

for the control link and have added an addional interface (for example ethernet 1/4), edit
this secon to select the interface to use for HA1 communicaon.

4. Edit the Data Link (HA2) to use Port ethernet 1/3 and add the IP address of this peer and
the Gateway IP address for the subnet.

STEP 5 | Commit the changes.

STEP 6 | Set up the passive HA peer within the same Azure Resource Group.
1. Deploy the second instance of the firewall.

• Download the custom template and parameters file from GitHub.
• Log in to the Azure Portal.
• Search for custom template and select Deploy from a custom template.
• Select Build your own template in the editor > Load file.
• Select the azuredeploy.json that you downloaded earlier, and Save.
• Complete the inputs, agree to the terms and Purchase.

Make sure to match the following inputs to that of the firewall instance you have
already deployed— Azure subscripon, name of the Resource Group, locaon of
the Resource Group, name of the exisng VNet into which you want to deploy the
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firewall, VNet CIDR, Subnet names, Subnet CIDRs, and start the IP address for the
management, trust and untrust subnets.

2. Repeat Step 1and Step 2to set up the interfaces and configure the firewall as the passive
HA peer.

3. Skip Step 3 and complete Enable HA (Step 5). In Step 4 modify the IP addresses as
appropriate for this passive HA peer.

STEP 7 | Aer you finish configuring both firewalls, verify that the firewalls are paired in acve/
passive HA.

1. Access the Dashboard on both firewalls, and view the High Availability widget.
2. On the acve firewall, click the Sync to peer link.
3. Confirm that the firewalls are paired and synced, as shown as follows:

• On the passive firewall: the state of the local firewall should display passive and the
Running Config should show as synchronized.

• On the acve firewall: The state of the local firewall should display acve and the
Running Config should show as synchronized.

4. On the passive peer, verify that the VM-Series plugin configuraon is now synced.

Select Device > VM-Series and validate that you can view the Azure HA configuraon that
you had omied configuring on the passive peer.

Set up Acve/Passive HA on Azure (East-West Traffic Only)
If your resources are all deployed within the Azure infrastructure and you do not need to enforce
security for north south traffic to the Azure VNet, you can deploy a pair of VM-Series firewalls
in an acve/passive high availability (HA) configuraon without floang IP addresses. The HA
peers will sll need HA links—a control link (HA1) and a data link (HA2)—to synchronize data and
maintain state informaon.

You must have the VM-Series Plugin version 1.0.9 or later, and you must deploy both firewall HA
peers within the same Azure Resource Group.
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• Set up the Firewalls for Enabling HA
• Configure Acve/Passive HA on the VM-Series Firewall on Azure

Set up the Firewalls for Enabling HA
Gather the following details for configuring HA on the VM-Series firewalls on Azure.

Set up the Acve Directory applicaon and a Service Principal to enable programmac API
access.

• For the firewall to interact with the Azure APIs, you need to create an Azure Acve
Directory Service Principal. This Service Principle has the permissions required to
authencate to the Azure AD and access the resources within your subscripon.To
complete this set up, you must have permissions to register an applicaon with your Azure
AD tenant, and assign the applicaon to a role in your subscripon. If you don't have the
necessary permissions, ask your Azure AD or subscripon administrator to create a Service
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Principal. See the table above for the required permissions. Copy the following details for
use later in this workflow:

• Client ID—The Applicaon ID associated with the Acve Directory (On the Azure portal,
click Home > Azure Acve Directory > App registraons, select your applicaon and
copy the ID).

• Tenant ID—The Directory ID associated with the Acve Directory (On the Azure portal,
click Home > Azure Acve Directory > Properes > Directory ID, select the applicaon
and copy the ID).

• Azure Subscripon ID—The Azure subscripon in which you have deployed the firewalls.
You must login to your Azure portal to get this subscripon ID.

• Resource Group Name— The resource group name in which you have deployed the
firewalls that you want to configure as HA peers. Both firewalls must be in the same
resource group.
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• Secret Key—The authencaon key associated with the Acve Directory applicaon (On
the Azure portal, click Home > Azure Acve Directory > Cerficates & secrets, copy
the Value under Client secrets. If you do not have a Secret Key, create one first, then
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copy the value). To log in as the applicaon, you must provide both the key value and the
Applicaon ID.
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Know where to get the templates you need to deploy the VM-Series firewalls within the same
Azure Resource Group.

For an HA configuraon, both HA peers must belong to the same Azure Resource Group. If you
deploy the first instance of the firewall from the Azure Marketplace, and must use your custom
ARM template or the Palo Alto Networks sample GitHub template for deploying the second
instance of the firewall into the exisng Resource Group. The reason you need a custom
template or the Palo Alto Networks sample template is because Azure does not support the
ability to deploy the firewall in to an Resource Group that is not empty.

Copy the deployment informaon for the first firewall instance. For example:

Match the VM Name of VM-Series firewall as shown in the screenshot above with the
Hostname on the firewall web interface. You must add the same name on Device > Setup >
Management, because the hostname of the firewall is used to trigger failover.
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Plan the network interface configuraon on the VM-Series firewalls on Azure.

To set up HA, you must deploy both HA peers within the same Azure Resource Group and
both firewalls must have the same number of network interfaces. A minimum of four network
interfaces is required on each HA peer:

• Management interface (eth0)—Private and public IP address associated with the primary
interface. The public IP address enables access to the firewall web interface and SSH access.

You can use the private IP interface on the management interface as the HA1 peer IP
address for the control link communicaon between the acve/passive HA peers. If you
want a dedicated HA1 interface, you must aach an addional network interface on each
firewall, and this means that you need five interfaces on each firewall.

• Untrust interface (eth1/1)—Primary private IP address with /32 netmask.

On failover, when the passive peer transions to the acve state, the VM-Series plugin
automacally sends traffic to the primary private IP address of the passive peer. The Azure
UDRs enable the traffic flow.

• Trust interface (eth1/2)—Primary private IP address. On failover, when the passive peer
transions to the acve state, the VM-Series plugin automacally sends traffic to the
primary private IP address of the passive peer.

• HA2 (eth 1/3)—Primary private IP address. The HA2 interface is the data link that the HA
peers use for synchronizing sessions, forwarding tables, IPSec security associaons and ARP
tables.

Interface Acve firewall peer Passive firewall peer Descripon

HA2 Add a NIC to the
firewall from the
Azure management
console.

Add a NIC to the
firewall from the
Azure management
console.

On the acve and
passive peers, add a
dedicated HA2 link
to enable session
synchronizaon.

The default interface
for HA1 is the
management interface,
and you can opt to
use the management
interface instead of
adding an addional
interface to the
firewall. For enabling
data flow over the
HA2 link, you need
to add an addional
network interface
on the Azure portal
and configure the
interface for HA2 on
the firewall.

VM-Series Deployment Guide Version Version 10.1 666 ©2022 Palo Alto Networks, Inc.



Set up the VM-Series Firewall on Azure

Configure Acve/Passive HA on the VM-Series Firewall on Azure
In this workflow, you deploy the first instance of the VM-Series firewall using the VM-Series
firewall soluon template in the Azure marketplace, and the second instance of the firewall using
the sample GitHub template.

The authencaon key (client secret) associated with the Acve Directory applicaon
required for seng up the VM-Series firewall in an HA configuraon, is encrypted with
VM-Series plugin version 1.0.9 on the firewall and on Panorama. Because the key is
encrypted in VM-Series plugin version 1.0.9, you must install the same version of the
plugin on Panorama and the managed VM-Series firewalls in order to centrally manage the
firewalls from Panorama.

STEP 1 | Deploy the VM-Series firewall using a soluon template and set up the network interfaces
for HA.

For securing east west traffic within an Azure VNet, you only need a primary IP address for the
trust and untrust firewall interfaces. When a failover occurs, the UDR changes and the route
points to the primary IP address of the peer that transions to the acve state.

1. Add a Primary IP configuraon to the trust interface of the acve firewall peer.

In this workflow, this firewall will be designated as the acve peer. The acve HA peer
has a lower numerical value for device priority that you configure as a part of the HA
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configuraon on the firewall, and this value indicates a preference for which firewall
assumes the role of the acve peer.

2. Add a Primary IP configuraon to the untrust interface of the acve firewall peer.

3. Aach a network interface for the HA2 communicaon between the firewall HA peers.

VM-Series Deployment Guide Version Version 10.1 668 ©2022 Palo Alto Networks, Inc.



Set up the VM-Series Firewall on Azure

1. Add a subnet within the virtual network.
2. Create and aach a network interface to the firewall.

4. Set up your route table on Azure.

Create a route to the Next hop of Primary IP address of the trust and untrust interfaces of
the acve firewall peer.

Aer failover, the next hop for the Database server to Frontend server route will change
from 10.9.2.5 to 10.9.2.4. Similarly, the next hop of Frontend server to Database server
route will change from 10.9.1.5 to 10.9.1.4.
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STEP 2 | Configure the interfaces on the firewall.
Complete these steps on the acve HA peer, before you deploy and set up the passive HA
peer.

1. Log in to the firewall web interface.
2. Configure ethernet 1/1 as the untrust interface and ethernet 1/2 as the untrust

interface.

Select Network > Interfaces and configure as follows:
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3. Configure ethernet 1/3 as the HA interface.

To set up the HA2 link, select the interface and set Interface Type to HA. Set link speed
and duplex to auto.
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STEP 3 | Configure the VM-Series plugin to authencate to the Azure resource group in which you
have deployed the firewall.

Set up the Azure HA configuraon on the VM-Series plugin.

To encrypt the client secret, use the VM-Series plugin version 1.0.4 or later. If using Panorama
to manage your firewalls, you must install the VM-Series plugin version 1.0.4 or later.

1. Select Device > VM-Series to enable programmac access between the firewall plugin and
the Azure resources.

2. Enter the Client ID. The client ID is the Applicaon ID associated with your Azure Acve
Directory applicaon.

3. Enter the Client Secret and re-enter it to confirm.
4. Enter the Tenant ID. The tenant ID is the Directory ID you saved when you set up the

Acve Directory applicaon.
5. Enter the Subscripon ID for the Azure subscripon you want to monitor.
6. Enter the Resource Group name.
7. (For Azure Stack deployments only) Enter the Resource Mgr Endpoint URL.

This field is available in VM-Series plugin 2.1.2 and later.

8. Click Validate to verify that the keys and IDs you entered are valid, and that VM-Series
plugin can successfully communicate with the Azure resources using the API.
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STEP 4 | Enable HA.

1. Select Device > Setup > HA.
2. Enter Peer HA1 IP address as the private IP address of the passive peer.
3. (Oponal) Edit the Control Link (HA1). If you do not plan to use the management interface

for the control link and have added an addional interface (for example ethernet 1/4), edit
this secon to select the interface to use for HA1 communicaon.

4. Edit the Data Link (HA2) to use Port ethernet 1/3 and add the IP address of this peer and
the Gateway IP address for the subnet.

STEP 5 | Commit the changes.

STEP 6 | Set up the passive HA peer within the same Azure Resource Group.
1. Deploy the second instance of the firewall.

• Download the custom template and parameters file from GitHub.
• Log in to the Azure Portal.
• Search for custom template and select Deploy from a custom template.
• Select Build your own template in the editor > Load file.
• Select the azuredeploy.json that you downloaded earlier, and Save.
• Complete the inputs, agree to the terms and Purchase.

Make sure to match the following inputs to that of the firewall instance you have
already deployed— Azure subscripon, name of the Resource Group, locaon of
the Resource Group, name of the exisng VNet into which you want to deploy the
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firewall, VNet CIDR, Subnet names, Subnet CIDRs, and start the IP address for the
management, trust and untrust subnets.

2. Repeat Step 1and Step 2to set up the interfaces and configure the firewall as the passive
HA peer.

3. Skip Step 3 and complete Enable HA (Step 5). In Step 4 modify the IP addresses as
appropriate for this passive HA peer.

STEP 7 | Aer you finish configuring both firewalls, verify that the firewalls are paired in acve/
passive HA.

1. Access the Dashboard on both firewalls, and view the High Availability widget.
2. On the acve firewall, click the Sync to peer link.
3. Confirm that the firewalls are paired and synced, as shown as follows:

• On the passive firewall: the state of the local firewall should display passive and the
Running Config should show as synchronized.

• On the acve firewall: The state of the local firewall should display acve and the
Running Config should show as synchronized.

4. On the passive peer, verify that the VM-Series plugin configuraon is now synced.

Select Device > VM-Series and validate that you can view the Azure HA configuraon that
you had omied configuring on the passive peer.
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Use the ARM Template to Deploy the VM-Series Firewall
In addion to Marketplace based deployments, Palo Alto Networks provides a GitHub repository
which hosts sample ARM templates that you can download and customize for your needs. ARM
templates are JSON files that describe the resources required for individual resources such as
network interfaces, a complete virtual machine or even an enre applicaon stack with mulple
virtual machines.

ARM templates are for advanced users, and Palo Alto Networks provides the ARM template
under the community supported policy. To learn about ARM templates, refer to the Microso
documentaon on ARM Templates.

To simplify the deployment of all the required resources, the two-er sample template (hps://
github.com/PaloAltoNetworks/azure/tree/master/two-er-sample) includes two json files:

• Template File—The azureDeploy.json is the main resources file that deploys all the components
within the resource group.

• Parameters File—The azureDeploy.parameters.json is the file that includes the parameters
required to successfully deploy the VM-Series firewall in the VNet. It includes details such
as the virtual machine er and size, username and password for the firewall, the name of the
storage container for the firewall. You can customize this file for your Azure VNet deployment.

To help you deploy the firewall as a gateway for Internet-facing applicaons, the template
provisions the VM-Series firewall, a database server, and a web server. The VNet uses the
private non-routable IP address space 192.168.0.0/16. You can modify the template to use
172.16.0.0/12, or 10.0.0.0/8.

The ARM template also provides the necessary user-defined rules and IP forwarding flags to
enable the VM-Series firewall to secure the Azure resource group. For the five subnets—Trust,
Untrust, Web, DB, and NAT—included in the template, you have five route tables, one for each
subnet with user defined rules for roung traffic to the VM-Series firewall and the NAT virtual
machine.

For the four subnets—Trust, Untrust, Web, and DB—included in the template, you have four route
tables, one for each subnet with user defined rules for roung traffic to the VM-Series firewall.

Figure 4: Deploying VM-Series Firewall using the ARM Template

STEP 1 | Download the two-er sample ARM template from the GitHub repository.

Download and save the files to a local client: hps://github.com/PaloAltoNetworks/azure/tree/
master/two-er-sample
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STEP 2 | Create a Resource Group on Azure.
1. Log in to the Azure CLI using the command: azurelogin

If you need help, refer to the Azure documentaon on installing the CLI, or for details on
how to access the CLI on Azure Government or Azure China.

2. Switch to Resource Manager mode using the command:azureconfig mode arm
3. Create a resource group.

STEP 3 | Deploy the ARM template.
1. Open the Parameters File with a text editor and modify the values for your deployment:

In Azure China, you must edit the path for the storage account that hosts the
VHD image required to deploy the VM-Series firewall. In the variables secon of
the template file, find the parameter called userImageNameURI and replace the
value with the locaon where you saved the VHD image.

2. Deploy the template in the resource group you created.

azure group create -v -n “<YourResourceGroupName>”

-l “<YourAzureLocation>” -d “<GiveASmallDeploymentLabel>”

-f azureDeploy.json -e azureDeploy.parameters.json

3. Check the progress/status of the deployment from the Azure CLI:

azure group deployment show "<YourResourceGroupName>"
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“<YourDeploymentLabel>“

When the template is successfully deployed the ProvisioningStateis Running.

If the ProvisioningStateis Failed, you must check for errors on the
Azure portal at Resource Group > Events. Filter for only events in the last one
hour, select the most recent events, and drill down to find the errors.

4. Verify that you have successfully deployed the VM-Series firewall.

1. Select Dashboard > Resource Groups, select the resource group.
2. Select All Sengs > Deployments > Deployment History for detailed status.

The address space within the VNet uses the prefix 192.168, which is defined
in the ARM template.

5. Aach a public IP address to the untrust interface on the firewall.
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STEP 4 | Configure the firewall as a VNet gateway to protect your Internet-facing deployment.
1. Log in to the management interface IP address on the firewall.
2. Configure the dataplane network interfaces as Layer 3 interfaces on the firewall

(Network > Interfaces > Ethernet).
3. Add stac rules to the virtual router on the firewall. To route traffic through the firewall

in this example, you need three stac routes on the firewall (Network > Virtual Routers,
select the router and click Stac Routes):

1. Route all outbound traffic through the UnTrust zone, ethernet1/1 to the Azure router
at 192.168.1.1.

2. Route all inbound traffic desned to the web server subnet through the Trust zone,
ethernet1/2 to the Azure router at 192.168.2.1.

3. Route all inbound traffic desned to the database server subnet through the Trust
zone, ethernet1/2 to the Azure router at 192.168.2.1.

4. Create security policy rules (Policies > Security) to allow inbound and outbound traffic
on the firewall. You also need security policy rules to allow appropriate traffic from the
web server subnet to the database server subnet and vice versa.

5. Commit the changes on the firewall.
6. Verify that the VM-Series firewall is securing traffic (Monitor > Logs > Traffic).

VM-Series Deployment Guide Version Version 10.1 678 ©2022 Palo Alto Networks, Inc.



Set up the VM-Series Firewall on Azure

Deploy the VM-Series and Azure Applicaon Gateway
Template

The VM-Series and Azure Applicaon Gateway template is a starter kit that you can use to deploy
VM-Series firewalls to secure web workloads for internet-facing deployments on Microso Azure
(currently not available for Azure China).

This template deploys two VM-Series firewalls between a pair of (external and internal) Azure load
balancers. The external load balancer is an Azure Applicaon Gateway, which is an HTTP (Layer 7)
load balancer that also serves as the internet-facing gateway, which receives traffic and distributes
it through the VM-Series firewall on to the internal load balancer. The internal load balancer is an
Azure Load Balancer (Layer 4) that fronts a pair of web servers. The template supports the BYOL
and the Azure Marketplace versions of the VM-Series firewall.

As demand on your web workloads increases and you increase capacity for the web server er
you can manually deploy addional VM-Series firewalls to secure your web server er.

• VM-Series and Azure Applicaon Gateway Template
• Start Using the VM-Series & Azure Applicaon Gateway Template
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VM-Series and Azure Applicaon Gateway Template
The VM-Series and Azure Applicaon Gateway template launches an Azure Applicaon Gateway
(Layer 7 load balancer) and an Azure (Layer 4) load balancer. Nested between the Applicaon
gateway and the load balancer are a pair of VM-Series firewalls in an Availability Set, and a pair of
sample web servers running Apache2 on Ubuntu in another Availability Set. The Availability Sets
provide protecon from planned and unplanned outages. The following topology diagram shows
the resources that the template deploys:

You can use a new or an exisng storage account and resource group in which to deploy all the
resources for this soluon within an Azure locaon. It does not provide default values for the
resource group name and storage account name, you must enter a name for them. While you can
create a new or use an exisng VNet, the template creates a default VNet named vnet-FW with
the CIDR block 192.168.0.0/16, and allocates five subnets (192.168.1.0/24 - 192.168.5.0/24)
for deploying the Azure Applicaon Gateway, the VM-Series firewalls, the Azure load balancer
and the web servers. Each VM-Series firewall is deployed with three network interfaces—
ethernet0/1 in Mgmt subnet (192.168.0.0/24), ethernet1/1 in Untrust subnet (192.168.1.0/24),
and ethernet1/2 in the Trust subnet (192.168.2.0/24).

The template creates a Network Security Group (NSG) that allows inbound traffic from any source
IP address on ports 80,443, and 22. It also deploys the pair of VM-Series firewalls and the web
server pair in their respecve Availability Sets to ensure that at least one instance of each is
available during a planned or unplanned maintenance window. Each Availability Set is configured
to use three fault domains and five update domains.

The Azure Applicaon Gateway acts as a reverse-proxy service, which terminates a client
connecon and forwards the requests to back-end web servers. The Azure Applicaon Gateway is
set up with an HTTP listener and uses a default health probe to test that the VM-Series firewall IP
address (for ethernet1/1) is healthy and can receive traffic.

The template does not provide an auto-scaling soluon; you must plan your capacity
needs and then deploy addional resources to Adapt the Template for your deployment.
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The VM-Series firewalls are not configured to receive and secure web traffic desned to the web
servers. Therefore, at a minimum, you must configure the firewall with a stac route to send traffic
from the VM-Series firewalls to the default router, configure desnaon NAT policy to send traffic
back to the IP address of the load balancer, and configure Security policy rules. The NAT policy
rule is also required for the firewall to send responses back to the health probes from the HTTP
listener on the Azure Applicaon Gateway. To assist you with a basic firewall configuraon, the
GitHub repository includes a sample configuraon file called appgw-sample.xml that you can use to
get started.

Start Using the VM-Series & Azure Applicaon Gateway Template
The VM-Series & Azure Applicaon Gateway template launches all the resources you need to
deploy and secure your web workloads for Internet facing deployments on Microso Azure,
excluding Azure China. This secon provides details on how to deploy the template, configure the
firewalls to route and secure traffic desned to the web servers, and extend the capabilies and
resources that this template provides to accommodate your deployment needs.

• Deploy the Template to Azure
• VM-Series and Azure Applicaon Gateway Template Parameters
• Sample Configuraon File
• Adapt the Template

Deploy the Template to Azure
Use the following instrucons to deploy the template to Azure.

All VM-Series firewall interfaces must be assigned an IPv4 address when deployed in a
public cloud environment. IPv6 addresses are not supported.
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STEP 1 | Deploy the template.

Currently not available for deploying in Azure China.

1. Access the template from hps://github.com/PaloAltoNetworks/azure-
applicaongateway

2. Click Deploy to Azure.
3. Fill in the details for deploying the template. See VM-Series and Azure Applicaon

Gateway Template Parameters for a descripon and the default values, if any, for each
parameter.

At a minimum, you have to pick the Azure Subscripon, Resource Group, Locaon,
Storage Account Name, and a Username/password or SSH Key for the administrave
account on the VM-Series firewalls.

4. Click Purchase to accept the terms and condions and deploy the resources.

If you have validaon errors, click to view the details and fix your errors.
5. On the Azure portal, verify that you have successfully deployed the template resources,

including the VM-Series firewalls.

1. Select Dashboard > Resource Groups, select the resource group.
2. Select Overview to review all the resources that have been deployed. The deployment

status should display Succeeded.
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3. Note the Public IP address or the DNS name assigned to eth0-VM-Series0 and eth0-
VM-Series1 to access the management interface of the VM-Series firewalls.

STEP 2 | Log in to the firewalls.
1. Using a secure connecon (hps) from your web browser, log in to the IP address for

eth0-VM-Series0 or the DNS name for the firewall.
2. Enter the username/password you defined in the parameters file. You will see a

cerficate warning; that is okay. Connue to the web page.
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STEP 3 | Configure the VM-Series firewall.

You can either configure the firewall manually or import the Sample Configuraon File provided
in the GitHub repository and customize it for your security needs.

• Configure the firewall manually—You must do the following at a minimum:

1. Configure the dataplane network interfaces as Layer 3 interfaces on the firewall
(Network > Interfaces > Ethernet).

2. Add a stac rule to the virtual router on the firewall. This stac rule specifies the
firewall’s untrust interface IP address as the nexthop address for any traffic desned for
ethernet1/1. (Network > Virtual Routers, select the router and click Stac Routes).

3. Create security policy rules (Policies > Security) to allow inbound and outbound traffic
on the firewall.

4. Add NAT policies (Policies > NAT). You must create desnaon NAT and source NAT
rules on the firewall to send traffic to the web servers and back out to the client who
iniated the request.

The desnaon NAT rule is for all traffic that arrives on the firewall’s untrust interface.
This rule is required to translate the desnaon IP address on the packet to that of the
internal load balancer so that all traffic is directed to the internal load balancer and on to
the backend web servers.

The source NAT rule is for all traffic from the backend web server and desned to the
untrust interface on the firewall. This rule translates the source address to the IP address
of the trust interface on the firewall

5. Commit your changes.

• Import the sample configuraon file:
6. Download and save the Sample Configuraon File to your local client.
7. Select Device > Setup > Operaons, click Import named configuraon snapshot, Browse

to the sample configuraon file that you have saved locally, and click OK.
8. Click Load named configuraon snapshot, select the Name of the sample configuraon

file you just imported, and click OK.
9. Change the IP address of the address objects and the stac route to match the IP

address from the CIDR block you used. Update address objects to use the private IP
addresses for eth1-VM-Series0 and eth1-VM-Series1.

10. Important! Create a new admin user account. Select Device > Administrators and Add a
new account.

11. Modify the Hostname in the General Sengs widget in Device > Setup > Management.
12. Commit your changes, and log out. The commit overwrites the running configuraon

with the sample configuraon file and updates you just made. On commit, the hostname
and the administrator user account that you specified when deploying the template
are overwrien. You will now need to log in using the new admin user account and
password.

• Log in to the firewall—Use the credenals you created and delete the pandemo
administrave account imported as part of the sample configuraon file.
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STEP 4 | Log in and configure the other instance of the VM-Series firewall.

See step Configure the VM-Series firewall.

STEP 5 | Verify that you have configured the firewalls properly.

From your web browser, use hp to access the IP address or DNS name for the app gateway.
You should be able to view the default Apache 2 Ubuntu web page.

If you have used the sample configuraon firewall, log in to the firewall and view the Traffic
logs generated on session start in Monitor > Logs > Traffic.

VM-Series and Azure Applicaon Gateway Template Parameters
The following table lists the required and oponal parameters and the default values, if any.

Parameter Descripon

Resource group Create new or use exisng (no default).

Subscripon The type of Azure subscripon you will use to cover the cost of the
resources deployed with the template.

Locaon Select the Azure locaon to which you want to deploy the
template (no default).

Network Security Group

Network Security Group
Name

The network security group limits the source IP addresses from
which the VM-Series firewalls and web servers can be accessed.

Default: nsg-mgmt
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Parameter Descripon

Network Security Group
Inbound Src IP

The source IP addresses that can log in to the management port of
the VMs deployed by the template.

The default value 0.0.0.0/0 means you can log into the firewall
management port from any IP address.

Storage Account

Storage Account Name Create new or enter the name of an exisng Storage Account (no
default). The name must be globally unique.

Storage Account Type Choose between standard and premium storage and your data
replicaon needs for local redundancy, geo-redundancy, and read-
access geo-redundancy.

The default opon is Locally Redundant Storage (LRS). The other
opons are Standard GRS, Premium LRS, and Standard RAGRS.

VNet

Virtual Network Create new or enter the name of an exisng VNet.

The default name for the VNet is vnet-FW

Virtual Network Address
Prefix

192.168.0.0/16

Azure Applicaon Gateway

App Gateway Name myAppGw

App Gateway DNS
Name

Enter a globally unique DNS name for the Azure Applicaon
Gateway.

App Gateway Subnet
Name and Prefix

Default name is AppGWSubnet and the subnet prefix is
192.168.3.0/24.

Azure Load Balancer and Web Servers

Internal Load Balancer
Name

myPrivateLB

Internal Load Balancer
Subnet Name and Prefix

Default name is backendSubnet and the subnet prefix is
192.168.4.0/24.

Backend Vm Size The default size is Standard er D1 Azure VM. Use the drop-down
in the template to view the other Azure VM opons available for
the backend web servers.
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Parameter Descripon

Firewalls

Firewall Model Choose from BYOL or PAYG (bundle 1 or bundle 2, each bundle
includes the VM-300 and a set of subscripons).

Firewall Vm Name and
Size

The default name for the firewall is VM-Series, and the default size
is Standard er D3 Azure VM.

Use the drop-down in the template to view the other Azure VM
opons available for the VM-Series firewalls

Mgmt Subnet Name and
Prefix

The management subnet for the VM-Series firewalls and the web
servers deployed in this soluon.

Default name is Mgmt and the subnet prefix is 192.168.0.0/24.

Mgmt Public IP Address
Name

Enter a hostname to access the management interface on each
firewall. The names must be globally unique.

Trusted Subnet Name
and Prefix

The subnet to which eth1/1 on the VM-Series firewall is
connected; this subnet connects the VM-Series firewall to the
Azure Applicaon gateway. The firewall receives web traffic
desned to the web servers on eth1/1.

Default name is Trust and the subnet prefix is 192.168.2.0/24.

Untrusted Subnet Name The subnet to which eth1/2 on the VM-Series firewall is
connected. The firewall receives return and outbound web traffic
on this interface.

Default name is Untrust and the subnet prefix is 192.168.1.0/24.
The name must be globally unique.

Username Enter the username for the administrave account on the VM-
Series firewalls and the web servers.

Authencaon Type You must either enter a password for authencaon or use an SSH
public key (no default).

Sample Configuraon File
To help you get started, the GitHub repository contains a sample configuraon file named appgw-
sample.xml that includes the following rules/objects:

• Address objects—Two address objects, firewall-untrust-IP and internal-load-
balancer-IP, which you will need to modify to match the IP addresses in your setup. You
need to modify these address objects to use the private IP addresses assigned to eth1-VM-
Series0 and eth1-VM-Series1 on the Azure portal.
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• Stac route—The default virtual router on the firewall has a stac route to 192.168.1.1, and
this IP address is accurate if you use the default template values. If you have changed the
Untrust subnet CIDR, you’ll need to update the IP address to match your setup. All traffic
coming from the backend web servers, desned for the applicaon gateway, uses this IP
address as the next hop for delivering packets to the untrust interface on the firewall.

• NAT Policy Rule—The NAT policy rule enables desnaon NAT and source NAT.

• The desnaon NAT rule is for all traffic that arrives on the firewall’s untrust interface
(ethernet1/2), which is the firewall-untrust-IP address object. This rule translates the
desnaon IP address on the packet to that of the internal load balancer so that all traffic is
directed to the internal load balancer and thus to the backend web servers.

• The source NAT rule is for all traffic from the backend web server and desned to the
untrust network interface on the firewall. This rule translates the source address to the IP
address of the trust interface on the firewall (ethernet1/2).

• Security Policy Rule—Two Security policy rules are defined in the sample configuraon file. The
first rule allows all inbound web-browsing traffic and generates a log at the start of a session on
the firewall. The second rule blocks all other traffic and generates a log at the start and end of
a session on the firewall. You can use these logs to monitor all traffic to the web servers in this
deployment.

• Administrave User Credenals— The sample configuraon file includes a username and
password for logging in to the firewall, which is set to pandemo/demopassword. Aer you
import the sample configuraon, you must either change the password and set it to a strong,
custom password or create a new administrator account and delete the pandemo account.

Adapt the Template
As your needs evolve, you can scope your capacity needs and extend the template for your
deployment scenario. Here are some ways you can build on the starter template to meet your
planned capacity needs:

• Deploy addional VM-Series firewalls behind the Azure Applicaon Gateway. You can manually
install more VM-Series firewalls into the same Availability Set or launch a new Availability Set
and manually deploy addional VM-Seri es firewalls.

• Configure the VM-Series firewalls beyond the basic configuraon provided in the sample
configuraon file in the GitHub repository.

• Enable HTTPS load balancing (SSL offload) on the Azure Applicaon Gateway. Refer to the
Azure documentaon for details.

• Add or replace the sample web servers included with the template.
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Secure Kubernetes Services on Azure
To secure Azure Kubernetes services, you must first install the Azure plugin on Panorama and
configure an Azure Secure Kubernetes Services on Azure  deployment. The Azure plugin for
Panorama supports tag-based VM monitoring and Secure Kubernetes Services on Azure , secures
inbound traffic for Azure Kubernetes Services (AKS) clusters, and monitors outbound traffic from
AKS clusters. The Panorama orchestrated deployment allows you to leverage Azure auto scale
metrics and the scale-in and scale-out thresholds to manage surges in demand for applicaon
workload resources by independently scaling the VM-Series firewalls.

To secure inbound traffic for your AKS cluster, you must first Secure Kubernetes Services on Azure
. The Panorama orchestrated deployment works with Secure Kubernetes Services on Azure  to
gather informaon about your network and resources, then create an auto-scaling er of VM-
Series firewalls for either Secure Kubernetes Services on Azure  deployments. See the Palo Alto
Networks Compability Matrix, to verify the minimum OS, plugin, and template versions required
to secure AKS clusters.

Palo Alto Networks provides an AKS template that deploys an Azure Kubernetes Service (AKS)
cluster in a new Azure VNet. The Azure plugin on Panorama helps you set up a connecon which
can monitor Azure Kubernetes cluster workloads, harvesng services you have annotated as
“internal load balancer” and creang tags you can use in dynamic address groups. You can leverage
Panorama dynamic address groups to apply security policy on inbound traffic routed to services
running on your AKS cluster.

• How Does the Panorama Plugin for Azure Secure Kubernetes Services?
• Secure an AKS Cluster

How Does the Panorama Plugin for Azure Secure Kubernetes
Services?

You can use VM-Series firewalls to secure inbound traffic for Azure Kubernetes Service (AKS)
clusters. The VM-Series firewall can only secure services exposed by a load balancer (such as an
Azure Load Balancer). Outbound traffic can only be monitored.

This chapter reviews different components that enable the Azure Plugin for Panorama to connect
to an AKS cluster.

• Requirements
• A Sample Hub-and-Spoke Topology to Secure AKS Clusters
• User-Defined Roung
• AKS Cluster Communicaon
• Dynamic Address Groups with Kubernetes Labels

Requirements
This soluon requires the following components. See the Panorama plugin informaon in the
Compability Matrix for the minimum version requirements.

• VM-Series firewalls.
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• Panorama—Your Panorama version must be the same or higher than your VM-Series PAN-OS
version.

• Panorama Plugin for Azure.
• A Panorama orchestrated deployment.
• Azure AKS template version 1.0. This template creates an AKS cluster.

You must enable AKS advanced networking (CNI) for the cluster.

An AKS deployment requires advanced networking to configure VNet Peering for the hub and
spoke VNets (see A Sample Hub-and-Spoke Topology to Secure AKS Clusters).

A Sample Hub-and-Spoke Topology to Secure AKS Clusters
The following diagram illustrates a sample auto scale deployment that secures inbound traffic for
Azure AKS clusters. Let’s review some of the components.

• Auto Scaling Infrastructure—The Azure Auto Scaling templates create the messaging
infrastructure and the basic hub and spoke architecture.

• AKS Clusters—The Palo Alto Networks AKS template creates an AKS cluster in a new VNet.
Given the name of the Spoke resource group, the template tags the VNet and AKS cluster with
the Spoke resource group name, so the resource group can be discovered by the Azure Auto
Scaling plugin for Panorama. The Azure plugin for Panorama queries service IP addresses on
the Staging ILB to learn about AKS cluster services.

Only one Spoke firewall scale set can be associated with an AKS Cluster; if you expose
mulple services in a single AKS cluster, they must be protected by the same Spoke.

For each resource group, create a subnet-based address group. In the above diagram,
for example, create an address group for 10.240.0.0/24 (AKS Cluster 1).
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• VNet Peering—You must manually configure VNET peering to communicate with other VNets
in the same region.

Cross-region peering is not supported.

You can use other automaon tools to deploy AKS clusters. If you deploy in an exisng
VNet (the Hub Firewall VNet, for example) you must manually configure VNet peering
to the inbound and outbound hub and spoke resource groups, and manually tag the
VNet and AKS cluster with the resource group name.

• User Defined Routes and Rules—You must manually configure user-defined routes and rules
(see User-Defined Roung). In the diagram above, incoming traffic can be redirected, according
to UDR rules, to the Firewall ILB for inspecon. Outbound traffic exing an AKS Cluster is
redirected to the Hub Firewall ILB with Azure user-defined roung (UDR) rules. The soluon
assumes Allow All as a default policy for Kubernetes orchestraon to funcon as-is, but to
apply policy you can use an allowlist or a denylist to allow or deny outbound traffic.

User-Defined Roung
You must manually create user-defined roung and roung rules to govern inbound or outbound
traffic.

Inbound

In the above diagram, inbound traffic from the Applicaon gateway is driven to the backend pool,
and based on UDR rules, redirected to the Firewall ILB. For example, create a UDR poinng to the
VNet subnet so that the traffic for Kubernetes services is pointed to the firewall ILB.

Outbound

On the Hub firewall set, for each AKS cluster being protected, you must create stac routes for
the cluster subnet CIDR, with the next hop being the gateway address of the Hub VNet trust
subnet.

All outbound traffic for an AKS cluster is directed to the Hub firewall set with a single UDR rule.

AKS Cluster Communicaon
The Panorama plugin for Azure can only communicate with the AKS controller node for a given
AKS cluster. For Outbound AKS traffic, the next hop is the Hub Firewall ILB. Because Outbound
traffic is monitored, you must Allow All traffic. The following topics emphasize common pracces
that help you establish connecvity. Keep them in mind when you plan your networks and
subnets.

• Create AKS Cluster Authencaon
• Use An Address Group to Idenfy Traffic
• Add the Subnet Address Group to the Top-Level Policy
• Prevent Applicaon Disrupon when Workload and AKS Cluster VNets Are Peered

Create AKS Cluster Authentication

When you connect the AKS cluster in Azure plugin for Panorama you must enter a secret
authorizaon token. Use Kubernetes commands to perform the following steps.
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STEP 1 | Create a ClusterRole.

STEP 2 | Create a ClusterRoleBinding.
1. Create a .yaml file for the ClusterRoleBinding. For example, create a text file named

crb.yaml.

  apiVersion: rbac.authorization.k8s.io
  kind: ClusterRoleBinding
  metadata: 
    name: default-view
  roleRef:
    apiGroup: rbac.authorization.k8s.io
    kind: ClusterRole
    name: view
  subjects:
  - kind: ServiceAccount
  name: default
  namespace: default

2. Use Azure Cloud Shell to apply the crb.yaml role binding.

kubectl apply -f crb.yaml
3. View the service account you just created.

kubectl get serviceaccounts

STEP 3 | Save the service account credenal to a .json file.
1. On your local machine, change to the directory in which you want to save the credenal.
2. Use kubectl commands to create the token.

MY_SA_TOKEN=‘kubectl get serviceaccounts default -o
jsonpath=’{.secrets[0].name}’‘

3. View the token name.
$ echo $MY_SA_TOKEN

4. Display the credenal.
kubectl get secret $MY_SA_TOKEN -o json

You need the token when you connect the AKS cluster in Azure plugin for Panorama, in
Step 3.d.

Use An Address Group to Identify Traffic

To create some granularity for monitored Outbound traffic, create an address group specifically for
the AKS cluster VNet subnet (for example, 10.240.0.97/32 in the above diagram). You can then
write rules that allow incoming or returning traffic rather than using Allow All.

If you create an address group, be careful to maintain the communicaon between the AKS
controller and any worker nodes. See Add the Subnet Address Group to the Top-Level Policy.

If communicaon is interrupted, applicaon traffic can be lost or your applicaon
deployment might have problems.
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Add the Subnet Address Group to the Top-Level Policy

To maintain connecvity, the address group must be part of the top-level policy in Panorama. You
can configure the cluster address group, or bootstrap the cluster to configure the cluster address
group.

Add the address group to the top-level policy before you configure VNet peering or User-
Defined Roung.

Prevent Application Disruption when Workload and AKS Cluster VNets Are Peered

If an AKS cluster co-exists with VM workloads that run in separate VNets, and the VNet is peered
with both the workload spoke (Inbound) and the Hub (Outbound), you must create address groups
to differenate the workloads and the AKS traffic, and add the address group to Top-Level Policy
as described above.

Dynamic Address Groups with Kubernetes Labels
When monitoring an AKS cluster resource, the Azure plugin automacally generates the following
IP tags for AKS services.

  aks.<aks cluster name>.<aks service name>

Tags are not generated for nodes, pods, or other resources.

If the AKS service has any labels, the tag is as follows (one per label):

  aks.<aks cluster name>.svc.<label>.<value>

If a labelSelector tag is defined for a cluster, the plugin generates the following IP tag:

  aks_<labelSelector>.<aks cluster name>.<aks service name>

Secure an AKS Cluster
To enable Panorama to connect to the load balancers in an Azure Kubernetes Services (AKS)
cluster, you must enable the Azure plugin on Panorama to establish a connecon with your AKS
cluster. Then, you must configure the device groups and templates to which the firewalls belong
so that Panorama can push configuraon objects and policy rules to your managed firewalls.

• Before You Begin
• Use the Template to Deploy an AKS Cluster
• Connect the AKS Cluster in Azure Plugin for Panorama
• Set Up VNet Peering
• Redirect Traffic to a Firewall ILB
• Apply Policy to Relevant AKS Service
• Deploy and Secure AKS Services
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Before You Begin
To secure AKS you must first deploy the Azure Auto Scaling soluon available on GitHub.

To secure a web applicaon running as a service within a Kubernetes cluster you must plan the
VNets, subnets, and UDRs. VM-Series firewalls and Panorama provide you security and visibility
of your Kubernetes services.

Review “How Does the Panorama Plugin for Azure Secure Kubernetes Services?”.
You must have AKS advanced networking to use the Palo Alto Networks AKS template.
Design your AKS subnets before you deploy AKS clusters. Review A Sample Hub-and-Spoke
Topology to Secure AKS Clusters, and AKS Cluster Communicaon.

The template creates a single AKS cluster (Service) as a sample. You must specify CIDR
ranges for the VNet, VNet subnet, and the service. The CIDR ranges must not overlap
Size your subnets to your requirements. Avoid unnecessarily large ranges, as they can affect
performance.
See User-Defined Roung. Specify specific UDR routes rather than broad subnet-specific
routes.

Plan how you want to peer your VNets. If you are peering AKS clusters, be sure you have read
AKS Cluster Communicaon.
Think about the ways in which you want to idenfy traffic.

If you plan to use an address group on Outbound AKS traffic, see Add the Subnet Address
Group to the Top-Level Policy.
If you have service names or tags that are not unique across namespaces, use the label
selector to filter both a tag and a namespace so that you get a unique result.

Use the Template to Deploy an AKS Cluster
The Azure AKS template is a sample that provisions a cluster in a new VNet.

STEP 1 | On GitHub, go to PaloAltoNetworks/azure-aks and locate the build package in the
repository.

STEP 2 | Unzip the build package. Edit the files azuredeploy.json and parameters.json for
your own deployment, and save.

STEP 3 | Issue the following Azure CLI commands to deploy the template.

az group deployment validate --resource-group RG_NAME 
--template-file azuredeploy.json 
--parameters @parameters.json

az group deployment create --name DEPLOYMENT_NAME 
--resource-group RG_NAME
--template-file azuredeploy.json 
--parameters @parameters.json
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STEP 4 | Deploy your applicaons or services on the AKS Cluster.
1. Annotate your service YAML file so that the type is load balancer, and annotate it as

service.beta.kubernetes.io/azure-load-balancer-internal: "true". For example:

  apiVersion: v1
    kind: Service
  metadata:
   name: azure-vote-front
   labels:
     service: "azure-vote-front"
     tier: "stagingapp"
   annotations:
     service.beta.kubernetes.io/azure-load-balancer-internal:
 "true"
  spec:
   type: LoadBalancer
 ports:
 - port: 80
 selector:
  app: azure-vote-front

2. If you have not done so, create AKS cluster authencaon before connuing.
3. Deploy your service on your AKS cluster.

For example, you can deploy your applicaon through kubectl:

kubectl apply -f myapplication.yaml

For a sample, see: hps://github.com/Azure-Samples/azure-vong-app-redis/blob/
master/azure-vote-all-in-one-redis.yaml

4. Use kubectl to get the service IP for the deployed service.

kubectl get services -o wide

In the EXTERNAL-IP column 10.240.0.97 is for the ILB, according to your annotaon in
Step a. Use the service IP to create a user defined route on Azure.
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STEP 5 | Create a UDR rule to point your service to the Firewall ILB behind the Applicaon Gateway.

In Azure, go to your inbound spoke resource group, view the route table and add a new route
based on the desnaon service IP. In the following screen, the value in the tov1service
ADDRESS PREFIX column is the service IP.

Connect the AKS Cluster in Azure Plugin for Panorama
This task assumes you have deployed a Panorama orchestrated deployment, and that you have
created templates, template stacks and device groups.

See the Panorama online help for more on filling out each form.
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STEP 1 | Select Panorama > Azure > Deployments to view the monitoring definion you created
when you configured the deployment. As shown below, if Auto Program Routes is enabled,
the firewall routes are programmed for you.
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STEP 2 | In AKS, tag your Resource Groups. The tags are name/value pairs.
1. Select Home > Resource groups and choose a resource group.
2. Select Tags and define name/value pairs. As shown in the following figure, the tag names

must be inboundgrouprg and HubRG:

• inboundgrouprg—your spoke resource group name
• HubRG—your hub resource group name

The template takes the name of the Spoke resource group as a parameter, and tags the
VNet and AKS cluster with the Spoke resource group name so that it can be discovered
by the Panorama plugin for Azure.

The templates deploy resources in separate VNets. If you manually deploy the AKS
cluster and service in the same VNet as the Spoke firewall set, you must manually
create tags for the spoke resource group name.
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STEP 3 | In Panorama, select Panorama > Azure > Setup.
1. On the General tab, enable monitoring.
2. On the Nofy Groups tab, Add a noficaon group and select the device groups to be

nofied.

3. On the Service Principal tab, Add and Validate a service principal.

Use the Service Principal you created for the orchestrated deployment.

4. On the AKS Cluster tab, Add an AKS cluster.

• Enter the exact name of the AKS cluster.
• Enter the API server address. To find the address in Azure, view your AKS service and

select Overview.
• Upload the AKS credenal JSON file (see Create AKS Cluster Authencaon).

5. Fill in the remaining fields and Add one or more tags.

If you have service names or tags that are not unique across namespaces, use
the label selector to filter both a tag and a namespace so that you get a unique
result.
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STEP 4 | Select Panorama > Azure > Monitoring Definion
1. Add a Monitoring definion.
2. Enter a name and descripon, and select AKS Cluster Monitoring.
3. Select an AKS Cluster and a Nofy Group, check Enable, and click OK.

Set Up VNet Peering
If you plan to use an address group to idenfy traffic, be sure to add the subnet address group to
your top-level Panorama plicy before you configure peering.

Aer deploying an AKS cluster, set up VNet Peering from the Inbound VNet to your cluster, and
from your cluster to the Firewall VNet.

Redirect Traffic to a Firewall ILB
You must manually create user defined routes (UDRs) and roung rules to redirect traffic to a
parcular ILB. For an example, see how the diagram in “How Does the Panorama Plugin for Azure
Secure Kubernetes Services?” depicts an inbound UDR.

STEP 1 | Create URL roung rules that redirect web traffic to the appropriate backend pool.
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STEP 2 | Update the UDR rules for the applicaon gateway subnet to add a route for the service
CIDR, with the next hop being the Inbound Firewall Load Balancer from the Spoke firewall
resource group.

Apply Policy to Relevant AKS Service
STEP 1 | In Panorama, select Policies.

STEP 2 | In the Device Group list, choose the device group for your AKS service.

STEP 3 | Add a Security Policy rule. Fill out the form, and on the Desnaon tab Add the desnaon
address or address group.

Deploy and Secure AKS Services
These steps outline how you can secure inbound and outbound traffic traversing to Kubernetes
services using VM-Series firewall and the Azure Plugin for Panorama.

STEP 1 | In the applicaon deployment environment, create a YAML file for the applicaon or use a
file that already exists. The following is a sample applicaon YAML file:

apiVersion: apps/v1
kind: Deployment
metadata:
  name: azure-vote-back
spec:
  replicas: 1 
  selector:
    matchLabels:
      app: azure-vote-back
  template:
    metadata:
      labels:
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        app: azure-vote-back
    spec:
      containers:
      - name: azure-vote-back
        image: redis
        resources:
          requests:
            cpu: 100m
            memory: 128Mi
          limits:
            cpu: 250m
            memory: 256Mi
        ports:
        - containerPort: 6379
          name: redis
---
apiVersion: v1
kind: Service
metadata:
  name: azure-vote-back
  labels:
    service: backend
spec:
  ports:
  - port: 6379
  selector:
    app: azure-vote-back
---
apiVersion: apps/v1
kind: Deployment
metadata:
  name: azure-vote-front
spec:
  replicas: 5
  selector:
    matchLabels:
      app: azure-vote-front
  template:
    metadata:
      labels:
        app: azure-vote-front
    spec:
      containers:
      - name: azure-vote-front
        image: microsoft/azure-vote-front:v1
        resources:
          requests:
            cpu: 100m
            memory: 128Mi
          limits:
            cpu: 250m
            memory: 256Mi
        ports:
        - containerPort: 80
        env:
        - name: REDIS
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          value: "azure-vote-back"
---
apiVersion: v1
kind: Service
metadata:
  name: azure-vote-front
  labels:
    service: "azure-vote-front"
    type: "production"
    providesecurity: "yes"
    a: "value"
    b: "value"
    c: "value"
    tier: "stagingapp"
  annotations:
    service.beta.kubernetes.io/azure-load-balancer-internal: "true"
spec:
  type: LoadBalancer
  ports:
  - port: 80
  selector:
    app: azure-vote-front

STEP 2 | Edit your YAML file to label Kubernetes services.

Labels enable the corresponding tag-to-IP mapping to be created when you use the Panorama
plugin for AKS to connect to the cluster. For example, in the above sample file look for the
applicaon labels in the service metadata. They are: azure-vote-back and azure-vote-
front.

STEP 3 | In your AKS cluster, apply the YAML file.
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STEP 4 | In Panorama, create an Address Group using a resource group tag.
1. On the Objects tab, select a device group from the Device Group list.
2. Select Address Groups and Add an Address Group.

1. Specify a name, and select the Dynamic type.
2. Add addresses. Adding spawns a window that lists detected addresses. Populang the

list can take several minutes.
3. You can choose one or more addresses for the Match Criteria. Select AND or OR for

the criteria relaonship.
4. If you have many addresses, enter a string in the search box to filter the output, as

shown in the following figure.
5. In the address list, click the + to include the address in the address group match

criteria.
6. When the match criteria is complete, click OK.

STEP 5 | Show Policy using the address group.
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STEP 6 | View secured AKS services.

In Panorama > Azure > Deployments, view your monitoring definion, and in the Acon
column select the Protected Applicaons and Services link.

The Protected? column summarizes the security status of your resource groups. It might take
several minutes for the window to populate. If you have many resource groups, enter a string
in the search box to filter the output.

This output is based on the Azure resource group configuraon; it does not query the device
group or template stack membership.

VM-Series Deployment Guide Version Version 10.1 705 ©2022 Palo Alto Networks, Inc.



Set up the VM-Series Firewall on Azure

VM-Series Deployment Guide Version Version 10.1 706 ©2022 Palo Alto Networks, Inc.



Set Up the VM-Series Firewall on
OpenStack

The VM-Series firewall for OpenStack allows you to provide secure applicaon
delivery along with network security, performance and visibility.

> VM-Series Firewall for OpenStack
> Components of the VM-Series for OpenStack Soluon
> Heat Template for a Basic Gateway Deployment
> Heat Templates for Service Chaining and Service Scaling
> Install the VM-Series Firewall in a Basic Gateway Deployment
> Install the VM-Series Firewall with Service Chaining or Scaling
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VM-Series Deployments in OpenStack
The Heat Orchestraon templates provided by Palo Alto Networks allow you to deploy the VM-
Series firewall individually, through service chaining, or dynamically with service scaling.

• Basic Gateway
• Service Chaining and Service Scaling

Basic Gateway
The VM-Series firewall for OpenStack allows you to deploy the VM-Series firewall on the KVM
hypervisor running on a compute node in your OpenStack environment. This soluon uses Heat
Orchestraon Templates and bootstrapping to deploy the VM-Series firewall and a Linux server.
The VM-Series firewall protects the deployed Linux server by inspecng the traffic going in and
out of the server. The sample bootstrap files allow the VM-Series firewall to boot with basic
configuraon for handling traffic.

These heat template files and the bootstrap files combine to create two virtual machines, the VM-
Series firewall and Linux server, in a network configuraon similar to that shown below.

Service Chaining and Service Scaling
Deploying the VM-Series firewall through service chaining or service scaling is not
supported on OpenStack Queens.

Service chaining is a Contrail feature that deploys a VM-Series firewall as a service instance in
your OpenStack environment. A service chain is a set of service virtual machines, such as firewalls
or load balancers, and each virtual machine in the service chain is a service instance. Service
scaling allows you to dynamically deploy addional instances of the VM-Series firewall. Using
CPU ulizaon or incoming bytes per second metrics gathered by Ceilometer, OpenStack deploys
or shuts down addional instances of the VM-Series firewall to meet the current needs of your
network.
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The VM-Series firewall in OpenStack soluon leverages heat orchestraon templates to configure
and deploy the components required for service chaining and service scaling. The heat templates
provided by Palo Alto networks create a service template, service instance, and service policy (to
direct traffic to the VM-Series firewall) to deploy two Linux servers and the VM-Series firewall
service instance between them.
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Components of the VM-Series for OpenStack Soluon
The VM-Series firewall in an OpenStack environment has been tested with the following
components.

Component Descripon

Soware See the Compability Matrix for details about supported soware
versions.

VM-Series Hardware
Resources

See VM-Series System Requirements for the minimum hardware
requirements for your VM-Series model.

In OpenStack, flavors define the CPU, memory, and storage
capacity of a compute instance. When seng up your Heat
template, choose the compute flavor that meets or exceeds the
hardware requirements for the VM-Series model.

Fuel Master Fuel is a web UI-driven deployment and management tool for
OpenStack.

OpenStack Controller This node runs most of the shared OpenStack services, such API
and scheduling. Addionally, the Horizon UI runs on this node.

OpenStack Compute The compute node contains the virtual machines, including the
VM-Series firewall, in the OpenStack deployment. The compute
node that houses the VM-Series must meet the following criteria:

• Instance type OS::Nova::Server
• Allow configuraon of at least three interfaces
• Accept the VM-Series qcow2 image
• Accept the compute flavor parameter

Install the OpenStack compute node on a bare-metal
server because the VM-Series firewall does not support
nested virtualizaon.

Contrail Controller The Contrail controller node is a soware-defined networking
controller used for management, control, and analycs for the
virtualized network. It provides roung informaon to the compute
and gateway nodes.

Addionally, the Contrail controller provides the necessary support
for service chaining and service scaling.

Contrail Gateway The Contrail gateway node provides IP connecvity to external
networks from virtual networks. MPLS over GRE tunnels from the
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Component Descripon

virtual machines terminate at the gateway node, where packets are
decapsulated and sent to their desnaons on IP networks.

Ceilometer (OpenStack
Telemetry)

In the case of the VM-Series firewall for OpenStack, Ceilometer
monitors CPU ulizaon for service scaling. When CPU ulizaon
meets the defined thresholds, a new service instance of the VM-
Series firewall is deployed or shut down.

Heat Orchestraon
Template Files

Palo Alto Networks provides a sample Heat template for deploying
the VM-Series firewall. This template is made up of a main
template and an environment template. These files instanate one
VM-Series instance with one management interface and two data
interfaces.

In a basic gateway deployment, the template instanates a Linux
server with one interface. The interface of the server aaches to
the private network created by the template.

In a service chaining or service scaling deployment, the templates
instanate two Linux servers with one server aached to each
data interface of the firewall.

VM-Series Firewall
Bootstrap Files

The VM-Series firewall bootstrap files consist of a init-cfg.txt file,
bootstrap.xml file, and VM-Series auth codes. Along with the Heat
template files, Palo Alto Networks provides a sample init-cfg.txt
and bootstrap.xml files. You must provide your own auth codes to
license your VM-Series firewall and acvate any subscripons. See
Bootstrap the VM-Series Firewall for more informaon about VM-
Series bootstrap files.
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Heat Template for a Basic Gateway Deployment
The heat template file includes the following four files to help you launch the VM-Series firewall
on KVM in OpenStack. All four files are required to deploy the VM-Series firewall and Linux
server.

• pan_basic_gw.yaml—Defines the resources created to support the VM-Series firewall and Linux
server on the compute node, such as interfaces and IP addresses.

• pan_basic_gw_env.yaml—Defines the environment that the VM-Series firewall and Linux server
exist in. Many parameters in the pan_basic_gw.yaml file reference the parameters defined in
this file, such as flavor for the VM-Series and the Linux server.

• init-cfg.txt—Includes the operaonal command to enable DHCP on the firewall management
interface.

• bootstrap.xml—Provides basic configuraon for the VM-Series firewall. The bootstrap.xml file
configures the data interfaces and IP addresses. These values must match the corresponding
values in the pan_basic_gw.yaml file.

Addionally, the bootstrap.xml file includes a NAT rule called untrust2trust. This rule translate
the trust port on the server to the untrust port of the VM-Series firewall.

You have two opons for passing bootstrapping files to OpenStack—file injecon (personality files)
or user data.

File injecon is no longer supported beginning with OpenStack Queens; you must use user
data instead.

The table below describes resources that the pan_basic_gw.yaml template file creates and
provides the default value, if applicable.

Resource Descripon

pan_fw_instance VM-Series firewall with a management interface and two data
interfaces.

server_instance A Linux server with a single interface.

pan_trust_net A connecon to the internal network to which the trust interface
of the firewall and trust interface of the server are aached.

pan_trust_subnet Subnet aached to the trust interface on the firewall
(pan_trust_net) and has a CIDR value of 192.168.100.0/24.

pan_untrust_net Untrust network to which the untrust port of the firewall is
aached.

pan_untrust_subnet Subnet aached to the untrust interface of the firewall
(pan_untrust_net) and has a CIDR value of 192.168.200.0/24.
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Resource Descripon

allow_ssh_hps_icmp_secgroupSecurity group that allows TCP on ports 22 and 443 and ICMP
traffic.

pan_untrust_port The untrust port of the VM-Series firewall deployed in Layer
3 mode. The Heat template provides a default IP address of
192.168.200.10 to this port.

If you change this IP address in the heat template, you must
change the IP address in the bootstrap.xml file.

pan_untrust_floang_ip A floang IP address assigned from the public_network.

pan_untrust_floang_ip_assocThis associates the pan_untrust_floang_ip to the
pan_untrust_port.

pan_trust_port The trust port of the VM-Series firewall Layer 3 mode.

server_trust_port The trust port of the Linux server Layer 3 mode. The Heat
template provides a default IP address of 192.168.100.10 to this
port.

If you change this IP address in the heat template, you must
change the IP address in the bootstrap.xml file.

The pan_basic_gw.yaml file references the pan_basic_gw_env.yaml for many of the values needed
to create the resources need to deploy the VM-Series firewall and Linux server. The heat template
environment file contains the following parameters.

Parameter Descripon

mgmt_network The VM-Series firewall management interface aaches to the
network specified in this parameter. The template does not create the
management network; you must create this before deploying the heat
templates. The default value is mgmt_ext_net.

public_network Addresses that the OpenStack cluster and the virtual machines in the
cluster use to communicate with the external or public network. The
public network provides virtual IP addresses for public endpoints,
which are used to connect to OpenStack services APIs. The template
does not create the public network; you must create this before
deploying the heat templates. The default value is public_net.

pan_image This parameter specifies the VM-Series base image used by the Heat
template when deploying the VM-Series firewall. The default value is
pa-vm-7.1.4.
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Parameter Descripon

pan_flavor This parameter defines the hardware resources allocated to the VM-
Series firewall. The default value is m1.medium. This value meets the
VM-Series on KVM System Requirements described in the Set Up the
VM-Series Firewall on KVM chapter.

server_image This parameter tells the Heat template which image to use for the
Linux server. The default value is Ubuntu-14.04.

server_flavor This parameter defines the hardware resources allocated to the Linux
server. The default value is m1.small.

server_key The server key is used for accessing the Linux server through ssh. The
default value is server_key. You can change this value by entering a
new server key in the environment file.
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Heat Templates for Service Chaining and Service Scaling
Deploying the VM-Series firewall through service chaining or service scaling is not
supported on OpenStack Queens.

The heat template environment file defines the parameters specific to the VM-Series firewall
instance deployed through service chaining or service scaling. The parameters defined in the
environment file are divided into secons described below. There are two versions of the heat
templates for service chaining—vwire and L3— and one for service scaling.

Service chaining requires the heat template files and two bootstrap files to launch the VM-Series
firewall service instance and two Linux servers in the le and right networks.

• Template files—This template defines the resources created to support the VM-Series firewall
and two Linux servers, such as interfaces and IP addresses.

• service_chaining_template_vm.yaml for vwire deployments.
• service_chaining_template_L3.yaml for L3 deployments.
• service_scaling_template.yaml for service scaling deployments.

• Environment file—This environment file defines the environment that the VM-Series firewall
and Linux servers exist in. Many parameters in the template reference the parameters defined
in this file, such as flavor for the VM-Series and the names of the Linux servers.

• service_chaining_env_vm.yaml for vwire deployments.
• service_chaining_env_L3.yaml for L3 deployments.
• service_scaling_env.yaml for service scaling deployments.

• service_instance.yaml—(Service Scaling only) This is a nested heat template that is reference
by Service_Scaling_template.yaml to deploy the service instance. It provides the necessary
informaon to deploy service instances for scaling events.

• init-cfg.txt—Provides the minimum informaon required to bootstrap a VM-Series firewall. The
init-cfg.txt provided only includes the operaonal command to enable DHCP on the firewall
management interface.

• <file_name>_bootstrap.xml—Provides basic configuraon for the VM-Series firewall. The
bootstrap.xml file configures the data interfaces. These values must match the corresponding
values in the heat templates files.

For more informaon about the init-cfg.txt and bootstrap.xml files, see Bootstrap Configuraon
Files.

The following tables describe the parameters of the environment file.

• Virtual Network
• Virtual Machine
• Service Template
• Service Instance
• IPAM
• Service Policy
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• Alarm

Virtual Network
The virtual network configuraon paramaters in the heat template environment file define the
virtual network that connects the VM-Series firewall and the two Linux servers deployed by the
heat template.

Virtual Network (VN Config)

management_network The VM-Series firewall management interface aaches to the network
specified in this parameter.

le_vn or
le_network

Name of the le virtual network.

right_vn or
right_network

Name of the right virtual network.

le_vn_fqdn Fully qualified domain name of the le virtual network.

right_vn_fqdn Fully qualified domain name of the right virtual network

route_target Edit this value so route target configuraon matches that of your
external gateway.

Virtual Machine
The virtual machine parameters define the le and right Linux servers. The name of the port
tuple is defined here and referenced by the heat template. In Contrail, a port tuple is an ordered
set of virtual network interfaces connected to the same virtual machine. With a port tuple, you
can create ports and pass that informaon when creang a service instance. The heat template
creates the le, right, and management ports and adds them to the port tuple. The port tuple
is then linked to the service instance. When you launch the service instance using the heat
templates, the port tuple maps the service virtual machine to the virtual machine deployed in
OpenStack.

Virtual Machine (VM Config)

flavor The flavor of the le and right virtual machines. The default value is
m1.small.

le_vm_image or
right_vm_image or
image

The name of the soware image for the le and right virtual machines.
Change this value to match the file name of the image you uploaded.

The default is TestVM, which is a default image provided by
OpenStack.
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Virtual Machine (VM Config)

svm_name The name applied to the VM-Series firewall.

le_vm_name and
right_vm_name

The name of the le and right virtual machines.

port_tuple_name The name of the port tuple used by the two Linux servers and the VM-
Series firewall.

server_key The server key is used for accessing virtual machines through SSH. The
default value is server_key. You can change this value by entering a
new server key in the environment file.

Service Template
The service template defines the parameters of the service instance, such as the soware image,
virtual machine flavor, service type, and interfaces. Service templates are configured within the
scope of a domain and can be used on all projects within the specified domain.

Service Template (ST Config)

S_Tmp_name The name of the service template.

S_Tmp_version The service template version. The default value is 2. Do not change
this parameter because service template version 2 is required to
support port tuples.

S_Tmp_service_mode Service mode is the network mode used by the VM-Series firewall
service instance. For the L3 network template, the default value is in-
network. For the virtual wire template, the default value is transparent.

S_Tmp_service_type The type of service being deployed by the template. The default value
is firewall and should not be changed when deploying the VM-Series
firewall.

S_Tmp_image_name This parameter specifies the VM-Series base image used by the Heat
template when deploying the VM-Series firewall. Edit this parameter
to match the name of the VM-Series firewall image uploaded to your
OpenStack environment.

S_Tmp_flavor This parameter defines the hardware resources allocated to the VM-
Series firewall. The default value is m1.large.

S_Tmp_interface_type_mgmt
S_Tmp_interface_type_le
S_Tmp_interface_type_right

The parameters define the interface type for management, le, and
right interfaces.
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Service Template (ST Config)

domain The domain where this service template is ed to. The default value is
default-domain.

Service Instance
The service instance poron of the heat template environment file provides the name of the
individual instance deployed by the heat template and service template.

Service Instance (SI Config)

S_Ins_name The service instance name. This is the name of the VM-Series firewall
instance in Contrail.

S_Ins_fq_name The fully qualified name of the service instance.

IPAM
IP address management (IPAM) provides the IP address informaon for the interfaces of the
service instance. Changes these parameters to best suit your environment.

IPAM (IPAM Config)

NetIPam_ip_prefix_mgmtThe IP prefix of the management interface on the VM-Series firewall.
The default value is 172.2.0.0.

NetIPam_ip_prefix_len_mgmtThe IP prefix length of the management interface on the VM-Series
firewall. The default value is /24.

NetIPam_ip_prefix_le The IP prefix of the le interface on the VM-Series firewall. The
default value is 10.10.1.0.

NetIPam_ip_prefix_len_leThe IP prefix length of the le interface on the VM-Series firewall. The
default value is /24.

NetIPam_ip_prefix_right The IP prefix of the right interface on the VM-Series firewall. The
default value is 10.10.2.0.

NetIPam_ip_prefix_len_rightThe IP prefix length of the right interface on the VM-Series firewall.
The default value is /24.

NetIPam_addr_from_start_trueThis parameter determines how IP addresses are assigned to VMs
on the subnets described above. If true, any new VM takes the next
available IP address. If false, any new VM is assigned an IP address at
random. The default value is true.
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Service Policy
The service policy defines the traffic redirecon rules and policy that point traffic passing between
the le and right virtual machines to the VM-Series firewall service instance.

Service Policy (Policy Config)

policy_name The name of the service policy in Contrail that redirects traffic through
the VM-Series firewall. For the L3 template, the default value is
PAN_SVM_policy-L3. For the virtual wire template, the default value is
PAN_SVM_policy-vw.

policy_fq_name The fully qualified name of the service policy.

simple_acon The default acon Contrail applies to traffic going to the VM-Series
firewall service instance. The default value is pass because the VM-
Series firewall will apply its own security policy to the traffic.

protocol The protocols allowed by Contrail to pass to the VM-Series firewall.
The default value is any.

src_port_end and
src_port_start

Use this parameter to specify source port(s) that should be associated
with the policy rule. You can enter a single port, a list of ports
separated with commas, or a range of ports in the form of <port>-
<port>.

The default value is -1 in the provided heat templates; meaning any
source port.

direcon This parameter defines the direcon of traffic that is allowed by
Contrail to pass to the VM-Series firewall. The default value is <> or
bidireconal traffic.

dst_port_end and
dst_port_start

Use this parameter to specify desnaon port(s) that should be
associated with the policy rule. You can enter a single port, a list
of ports separated with commas, or a range of ports in the form of
<port>-<port>.

The default value is -1 in the provided heat templates; meaning any
desnaon port.

Alarm
The alarm parameters are used in service scaling and are not included in the service chaining
environment files. These parameters define the thresholds used by Contrail to determine when
scaling should take place. This set of parameters is only used the service scaling heat template.

The default me configured under the cooldown parameters is intended to allow the firewall
enough me to boot up. If you change the cooldown values, leave sufficient me for each new
firewall instance to boot up.
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Alarm

meter_name The metric monitored by Ceilometer and used by contrail to determine
when an addional VM-Series firewall should be deployed or brought
down. The heat template uses CPU ulizaon or bytes per second as
metrics for service scaling.

cooldown_inial The amount me Contrail waits before launching a addional service
instance aer the inial service instance is launched. The default is
1200 seconds.

cooldown_scaleup The amount of me Contrail waits between launching addional
service instance aer the first scale up service instance launch. The
default is 1200 seconds.

cooldown_scaledown The amount of me Contrail waits between shung down addional
service instances aer the first scale up service instance shut down.
The default is 1200 seconds.

period_high The interval during which the average CPU load is calculated as high
before triggering an alarm. The default value is 300 seconds.

period_low The interval during which the average CPU load is calculated as low
before triggering an alarm. The default value is 300 seconds.

threshold_high The value of CPU ulizaon in percentage or bytes per second that
Contrail references before launching a scale up event. The default is
40% CPU ulizaon or 2800 bytes per second.

threshold_low The value of CPU ulizaon in percentage or bytes per second that
Contrail references before launching a scale down event. The default is
20% CPU ulizaon or 12000 bytes per second.
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Install the VM-Series Firewall in a Basic Gateway
Deployment

Complete the following steps to prepare the heat templates, bootstrap files, and soware images
needed to deploy the VM-Series firewall in OpenStack. Aer preparing the files, deploy the VM-
Series firewall and Linux server.

STEP 1 | Download the Heat template and bootstrap files.

Download the Heat template package from the GitHub repository.

STEP 2 | Download the VM-Series base image.
1. Login in to the Palo Alto Networks Customer Support Portal.
2. Select Soware Updates and choose PAN-OS for VM-Series KVM Base Images from the

Filter By drop-down.
3. Download the VM-Series for KVMqcow2 file.

STEP 3 | Download Ubuntu 14.04 and upload the image to the OpenStack controller.

The Heat template needs an Ubuntu image for launching the Linux server.

1. Download Ubuntu 14.04.
2. Log in to the Horizon UI.
3. Select Project > Compute > Images > Create Image.
4. Name the image Ubuntu 14.04 to match the parameter in the pan_basic_gw_env.yaml

file.
5. Set Image Source to Image File.
6. Click Choose File and navigate to your Ubuntu image file.
7. Set the Format to match the file format of your Ubuntu image.
8. Click Create Image.

STEP 4 | Upload the VM-Series for KVM base image to the OpenStack controller.
1. Log in to the Horizon UI.
2. Select Project > Compute > Images > Create Image.
3. Name the image to match the image name in your Heat template.
4. Set Image Source to Image File.
5. Click Choose File and navigate to your VM-Series image file.
6. Set the Format to QCOW2-QEMU Emulator.
7. Click Create Image.
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STEP 5 | Upload the bootstrap files. You have two opons for passing bootstrapping files to
OpenStack—file injecon (personality files) or user data. To pass the bootstrap files using
user-data, you must place the files in a tar ball (.tgz file) and encode that tar ball with base64.

File injecon is no longer supported beginning with OpenStack Queens; you must use
user data instead.

• For file injecon, upload the init-cfg.txt, bootstrap.xml, and your VM-Series auth codes to
your OpenStack controller or a web server that the OpenStack controller can access.

• If using the --user-data method to pass the bootstrap package to the config-drive, you
can use the following command to create the tar ball and encode the tar ball (.tgz file) with
base64:

tar -cvzf <file-name>.tgz config/
license software content
base64 -i <in-file> -o <outfile>

STEP 6 | Edit the pan_basic_gw.yaml template to point to the bootstrap files and auth codes.

• If you are using personality files, specify the file path or web server address to the locaon
of your files under personality. Uncomment whichever lines you are not using.

  pan_fw_instance: 
    type: OS::Nova::Server 
    properties: 
      image: { get_param: pan_image } 
      flavor: { get_param: pan_flavor } 
      networks: 
        - network: { get_param: mgmt_network } 
        - port: { get_resource: pan_untrust_port } 
        - port: { get_resource: pan_trust_port } 
      user_data_format: RAW 
      config_drive: true 
      personality: 
        /config/init-cfg.txt: {get_file: "/opt/pan_bs/init-
cfg.txt"} 
#        /config/init-cfg.txt: { get_file: "http://
web_server_name_ip/pan_bs/init-cfg.txt" } 
        /config/bootstrap.xml: {get_file: "/opt/pan_bs/
bootstrap.xml"} 
#        /config/bootstrap.xml: { get_file: "http://
web_server_name_ip/pan_bs/bootstrap.xml" } 
        /license/authcodes: {get_file: "/opt/pan_bs/authcodes"} 
#        /license/authcodes: {get_file: "http://
web_server_name_ip/pan_bs/authcodes"} 

• If you are using user-data, specify the file path or web server address to the locaon of your
files under user_data. If you have more than one

pan_fw_instance:
    type: OS::Nova::Server
    properties:
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      image: { get_param: pan_image }
      flavor: { get_param: pan_flavor }
      networks:
        - port: { get_resource: mgmt_port }
        - port: { get_resource: pan_untrust_port }
        - port: { get_resource: pan_trust_port }
      user_data_format: RAW
      config_drive: true
      user_data:
#        get_file: http://10.0.2.100/pub/repository/panos/images/
openstack/userdata/boot.tgz
        get_file: /home/stack/newhot/bootfiles.tgz

STEP 7 | Edit the pan_basic_gw_env.yaml template environment file to suit your environment. Make
sure that the management and public network values match those that you created in your
OpenStack environment. Set the pan_image to match the name you assigned to the VM-
Series base image file. You can also change your server key here.

root@node-2:~# cat basic_gateway/pan_basic_gw_env.yaml 
parameters: 
  mgmt_network: mgmt_ext_net 
  public_network: public_net 
  pan_image: pa-vm-image 
  pan_flavor: m1.medium 
  server_image: Ubuntu-14.04 
  server_flavor: m1.small 
  server_key: server_key 

STEP 8 | Deploy the Heat template.
1. Execute the command source openrc
2. Execute the command heat stack-create <stack-name> -f <template> -

e ./<env-template>

STEP 9 | Verify that your VM-Series firewall is deployed successfully.

You can use the following commands to check the creaon status of the stack.

• Check the stack status with heat stack-list
• View a detailed list of events that occurred during stack creaon with heat event-list
• View details about your stack with heat stack-show

STEP 10 | Verify that the VM-Series firewall is bidireconally inspecng traffic accessing the Linux
server.
1. Log in to the firewall.
2. Select Monitor > Logs > Traffic to view the SSH session.
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Install the VM-Series Firewall with Service Chaining or
Scaling

Complete the following steps to prepare the heat templates, bootstrap files, and soware images
needed to deploy the VM-Series firewall. Aer preparing the files, deploy the VM-Series firewall
service and two Linux servers.

Deploying the VM-Series firewall through service chaining or service scaling is not
supported on OpenStack Queens.

STEP 1 | Download the Heat template and bootstrap files.

Download the Heat template package from the GitHub repository.

STEP 2 | Download the VM-Series base image.
1. Login in to the Palo Alto Networks Customer Support Portal.
2. Select Soware Updates and choose PAN-OS for VM-Series KVM Base Images from the

Filter By drop-down.
3. Download the VM-Series for KVMqcow2 file.

STEP 3 | Download Ubuntu 14.04 and upload the image to the OpenStack controller.
For service chaining, you can use the default image provided by OpenStack called TestVM. Skip
this step when using TestVM. An Ubuntu image is required for service scaling.

1. Download Ubuntu 14.04.
2. Log in to the Horizon UI.
3. Select Project > Compute > Images > Create Image.
4. Name the image Ubuntu 14.04 to match the parameter in the pan_basic_gw_env.yaml

file.
5. Set Image Source to Image File.
6. Click Choose File and navigate to your Ubuntu image file.
7. Set the Format to match the file format of your Ubuntu image.
8. Click Create Image.

A server key is required when using an Ubuntu image. Ensure that the server key is
added to the environment file.
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STEP 4 | Upload the VM-Series for KVM base image to the OpenStack controller.
1. Log in to the Horizon UI.
2. Select Project > Compute > Images > Create Image.
3. Name the image to match the image name in your Heat template.
4. Set Image Source to Image File.
5. Click Choose File and navigate to your VM-Series image file.
6. Set the Format to QCOW2-QEMU Emulator.
7. Click Create Image.

STEP 5 | Upload the bootstrap files. The files must be uploaded to the folder structure described here.
The heat template uses this folder structure to locate the bootstrap files.
1. Log in to your OpenStack controller.
2. Create the following folder structure:

/root/bootstrap/config/

/root/bootstrap/license/
3. Using SCP or FTP, add the init-cfg.txt and bootstrap.xml files to the config folder and add

your VM-Series auth codes to the license folder.

STEP 6 | Edit the template environment file to suit your environment. Verify that the image names in
the environment file match the names you gave the files when you uploaded them.

parameters:
# VN config
  management_network: 'mgmt_net'
  left_vn: 'left_net'
  right_vn: 'right_net'
  left_vn_fqdn: 'default-domain:admin:left_net'
  right_vn_fqdn: 'default-domain:admin:right_net'
  route_target: "target:64512:20000"
# VM config  
  flavor: 'm1.small'
  left_vm_image: 'TestVM'
  right_vm_image: 'TestVM' 
  svm_name: 'PAN_SVM_L3'
  left_vm_name: 'Left_VM_L3'
  right_vm_name: 'Right_VM_L3'
  port_tuple_name: 'port_tuple_L3'
#ST Config 
  S_Tmp_name: PAN_SVM_template_L3
  S_Tmp_version: 2
  S_Tmp_service_mode: 'in-network'
  S_Tmp_service_type: 'firewall'
  S_Tmp_image_name: 'PA-VM-8.0.0'
  S_Tmp_flavor: 'm1.large'
  S_Tmp_interface_type_mgmt: 'management'
  S_Tmp_interface_type_left: 'left'
  S_Tmp_interface_type_right: 'right'
  domain: 'default-domain'
# SI Config    
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  S_Ins_name: PAN_SVM_Instance_L3
  S_Ins_fq_name: 'default-domain:admin:PAN_SVM_Instance_L3'
#IPAM Config
  NetIPam_ip_prefix_mgmt: '172.2.0.0'
  NetIPam_ip_prefix_len_mgmt: 24
  NetIPam_ip_prefix_left: '10.10.1.0'
  NetIPam_ip_prefix_len_left: 24
  NetIPam_ip_prefix_right: '10.10.2.0'
  NetIPam_ip_prefix_len_right: 24
  NetIPam_addr_from_start_true: true
#Policy Config  
  policy_name: 'PAN_SVM_policy-L3'
  policy_fq_name: 'default-domain:admin:PAN_SVM_policy-L3'
  simple_action: 'pass'
  protocol: 'any'
  src_port_end: -1
  src_port_start: -1
  direction: '< >'
  dst_port_end: -1
  dst_port_start: -1

STEP 7 | Edit the template files to point to the bootstrap files and auth codes. Under Personality,
specify the file path to the locaon of your files. Uncomment whichever lines you are not
using.

Pan_Svm_instance:
    type: OS::Nova::Server
    depends_on: [ mgmt_InstanceIp, left_InstanceIp,
 right_InstanceIp ]
    properties:
      name: {get_param: svm_name }
      image: { get_param:  S_Tmp_image_name }
      flavor: { get_param: S_Tmp_flavor }
      networks:
        - port: { get_resource: mgmt_VirtualMachineInterface }
        - port: { get_resource: left_VirtualMachineInterface }
        - port: { get_resource: right_VirtualMachineInterface }
      user_data_format: RAW
      config_drive: true
      personality:
        /config/init-cfg.txt: {get_file: "/root/bootstrap/config/
init-cfg.txt"}
#        /config/init-cfg.txt: { get_file: "http://10.4.1.21/
op_test/config/init-cfg.txt" }
        /config/bootstrap.xml: {get_file: "/root/bootstrap/config/
Service_Chaining_bootstrap_L3.xml"}
#        /config/bootstrap.xml: { get_file: "http://10.4.1.21/
op_test/config/Service_Chaining_bootstrap_L3.xml" }
#        /license/authcodes: {get_file: "/root/bootstrap/license/
authcodes"}
#        /license/authcodes: {get_file: "http://10.4.1.21/op_test/
license/authcodes"}
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STEP 8 | Upload the heat template files.
1. Log in to your OpenStack Controller.
2. Use SCP or FTP to add the heat template file and environment file.

STEP 9 | Deploy the Heat template.
1. Execute the command source openrc
2. Execute the command heat stack-create <stack-name> -f <template> -

e ./<env-template>

STEP 10 | Verify that your VM-Series firewall is deployed successfully.

You can use the following commands to check the creaon status of the stack.

• Check the stack status with heat stack-list
• View a detailed list of events that occurred during stack creaon with heat event-list
• View details about your stack with heat stack-show

STEP 11 | Verify that the VM-Series firewall is bidireconally inspecng traffic between the Linux
servers.
1. Log in to the firewall.
2. Select Monitor > Logs > Traffic to view the SSH session.
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Google Cloud Plaorm

You can deploy a VM-Series firewall on a Google Compute Engine instance on the
Google Cloud Plaorm.

> Supported Deployments on Google Cloud Plaorm
> Prepare to Set Up the VM-Series Firewall on Google Public Cloud
> Deploy the VM-Series Firewall on Google Cloud Plaorm
> VM Monitoring with the Panorama Plugin for GCP
> Auto Scaling the VM-Series Firewall on Google Cloud Plaorm

729
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About the VM-Series Firewall on Google Cloud Plaorm
VM-Series firewalls bring next-generaon firewall features to the Google® Cloud Plaorm
(GCP™).

To maximize performance, VM-Series firewalls on GCP support the Data Plane Development Kit
(DPDK) libraries, which provide fast packet processing and improve network performance based
on specific combinaons of VM-Series firewall licenses and Google Cloud Plaorm virtual machine
(VM) sizes.

• Google Cloud Plaorm and the VM-Series Firewall
• Minimum System Requirements for the VM-Series Firewall

Google Cloud Plaorm and the VM-Series Firewall
The VM-Series firewall integraon with Google Cloud Plaorm (GCP) allows you to deploy the
VM-Series firewall as a virtual machine (VM) running on a Google Compute Engine instance.
This process is simplified when you Deploy the VM-Series Firewall from Google Cloud Plaorm
Marketplace.

Aer you deploy the VM-Series firewall, you can configure the following oponal services:

• Enable Google Stackdriver Monitoring on the VM Series Firewall—From the firewall, push PAN-
OS metrics to the Google Stackdriver service.

• Enable VM Monitoring to Track VM Changes on Google Cloud Plaorm—Set up a VM
informaon source that monitors the specific GCP zone containing your instances. The
monitored VM metadata can include predefined GCP properes (such as the project ID) and
user-defined properes (such as labels and network tags).

Minimum System Requirements for the VM-Series Firewall
You must choose a VM-Series Firewall License for Public Clouds and a license method: bring-
your-own-license (BYOL) or pay-as-you-go (PAYG). To deploy a VM-Series firewall on a Google
Compute Engine instance, you must choose a machine type that supports the VM-Series System
Requirements for your license.

A single Google Compute Engine instance supports up to eight network interfaces. If you want to
configure eight interfaces, choose n1-standard-8 or a larger machine type.

Bundles 1 and 2Capacity BYOL

PAYG Marketplace

VM-100 Firewall   

VM-200 Firewall   

VM-300 Firewall
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Bundles 1 and 2Capacity BYOL

PAYG Marketplace

VM-1000-HV Firewall   

VM-500 Firewall   

VM-700 Firewall   

The VM-Series firewall supports the predefined  standard machine types listed below. You can
choose a higher performing machine type or you can create your own custom machine type if the
resource requirements are compable with your VM-Series firewall license.

• n1-standard-4
• n1-standard-8
• n1-standard-16
• n2-standard-4
• n2-standard-8
• n2-standard-16
• n2-standard-32

Custom Machine Types:

• e2-standard-4
• e2-standard-8
• e2-standard-16
• e2-standard-32
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Supported Deployments on Google Cloud Plaorm
You can deploy the VM-Series firewall on a Google® Compute Engine instance in a network in
your virtual private cloud (VPC). The deployment types are:

• Internet Gateway
• Segmentaon Gateway
• Hybrid IPSec VPN

Internet Gateway
The VM-Series firewall secures North/South traffic to and from the internet to protect
applicaons from known and unknown threats. A Google project can have up to five VPC
networks. For a typical example of an internet gateway, refer to the Google configuraon
examples.

In public cloud environments, it is a common pracce to use a scale-out architecture (see the
figure below) rather than larger, higher performing VMs. This architecture (somemes called a
sandwich deployment) avoids a single point of failure and enables you to add or remove firewalls
as needed.

Segmentaon Gateway
A segmentaon gateway secures East/West traffic between virtual private clouds (VPCs) to
ensure data protecon compliance and applicaon access. The following figure shows a firewall
securing both North/South and East/West traffic.
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Hybrid IPSec VPN
The VM-Series firewall serves as an IPSec VPN terminaon point, which enables secure
communicaons to and from applicaons hosted on Google Cloud Plaorm (GCP).

The deployment in the figure below shows a site-to-site VPN from an on-premises network to a
VM-Series firewall deployed on GCP and an IPSec connecon from an on-premises network to a
Google Cloud VPN gateway.
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Prepare to Set Up VM-Series Firewalls on Google Public
Cloud

The process to Deploy the VM-Series Firewall from Google Cloud Plaorm Marketplace requires
preparaon tasks.

If you are deploying using the Google Marketplace, you must create your project networks and
subnetworks, and plan networks and IP address assignments for the VM-Series firewall interfaces
in advance. During the deployment, you must choose from exisng networks and subnetworks.

Refer to the following topics when planning your deployment:

• General Requirements
• Install the VM-Series Plugin on Panorama
• Install the Panorama Plugin for GCP
• Prepare to Deploy from the GCP Marketplace

General Requirements
The components in this checklist are common to deploying a VM-Series firewall that you manage
directly or with Panorama. Addional requirements apply for Panorama plugin for services such as
Stackdriver monitoring, VM monitoring, auto scaling or securing Kubernetes deployments.

Always consult the Compability Matrix for Panorama plugin informaon for public clouds.This
release requires the following soware:

• GCP account—You must have a GCP user account with a linked email address and you must
know the username and password for that email address.

• Google Cloud SDK—If you have not done so, install Google Cloud SDK, which includes Google
Cloud APIs, gcloud and other command line tools. You can use the command line interface to
deploy the firewall template and other templates.

• PAN-OS on VM-Series firewalls on GCP—VM-Series firewalls running a PAN-OS version
available from the Google Marketplace.

• VM-Series firewalls—VM-Series firewalls that you want to manage from Panorama must
be deployed in Google Cloud Plaorm using a Palo Alto Networks image from the Google
Marketplace. Firewalls must meet the Minimum System Requirements for the VM-Series
Firewall.

• VM-Series Licenses—You must license a VM-Series firewall to obtain a serial number. A
serial number is required to add a VM-Series firewall as a Panorama managed device. If you
are using the Panorama plugin for GCP to deploy VM-Series firewalls you must supply a
BYOL auth code. The Google Marketplace handles your service billing, but the firewalls you
deploy will directly interface with the Palo Alto Networks licensing server.

• VM-Series plugin on the firewall—VM-Series firewalls running PAN-OS 9.0 and later include
the VM-Series plugin, which manages integraon with public and private clouds. As shown
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in the Compability Matrix, the VM-Series plugin has a minimum version that corresponds
to each PAN-OS release.

When there is a major PAN-OS upgrade the VM-Series plugin version is automacally
upgraded. For minor releases it is up to you to determine whether a VM-Series plugin
upgrade is necessary, and if so, perform a manual upgrade. See Install the VM-Series Plugin
on Panorama.

• Panorama running in Management mode—A Panorama physical or virtual appliance running a
PAN-OS version that is the same or later than the managed firewalls. Virtual instances do not
need to be deployed in GCP.

• You must have a licensed version of Panorama.
• Panorama must have network access to the VPCs in which the VMs you want to manage are

deployed.
• If you intend to manage VMs deployed in GCP, or configure features such as auto scaling,

your PAN-OS and VM-Series plugin versions must meet the Public Cloud  requirements to
support the Panorama plugin for GCP.

• VM-Series plugin on Panorama. See Install the VM-Series Plugin on Panorama
• Panorama plugin for GCP version 2.0.0—The GCP plugin manages the interacons required

to license, bootstrap and configure firewalls deployed with the VM Monitoring or Auto Scaling
templates. The GCP plugin, in conjuncon with the VM Monitoring or Auto Scaling templates,
uses Panorama templates template stacks, and device groups to program NAT rules that direct
traffic to managed VM-Series firewalls.

See Install the Panorama Plugin for GCP.

Install the VM-Series Plugin on Panorama
On Panorama, install or upgrade to the VM-Series plugin version that supports the GCP features
you want to configure, as detailed in the Compability Matrix table for Public Clouds.

Inial installaon—Because the VM-Series plugin is oponal on Panorama, the first me you
install you must download the VM-Series plugin from the Support portal, then go to Panorama >
Device Deployment > Plugins to upload and install.

Upgrade—Go to Panorama > Device Deployment > Plugins and click Check Now. Install a version
that meets the requirements in the Compability Matrix table for Public Clouds.

Install the Panorama Plugin for GCP
The Panorama plugin for GCP is required if you want to use Panorama to manage VM Monitoring
or Auto Scaling deployments created with Palo Alto Networks templates. Install the plugin version
that supports the GCP features you want to configure, as detailed in the Compability Matrix
table for Public Clouds.

You cannot upgrade the Panorama Plugin for GCP from version 1.0.0 to version 2.0.x. If
you have installed version 1.0.0, remove it before installing 2.0.x.

If you have a standalone Panorama or two Panorama appliances installed in an HA pair with
mulple plugins installed, plugins might not receive updated IP-tag informaon if one or more of
the plugins is not configured. This occurs because Panorama will not forward IP-tag informaon
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to unconfigured plugins. Addionally, this issue can occur if one or more of the Panorama plugins
is not in the Registered or Success state (posive state differs on each plugin). Ensure that your
plugins are in the posive state before connuing or execung the commands described below.

If you encounter this issue, there are two workarounds:

• Uninstall the unconfigured plugin or plugins. It is recommended that you do not install a plugin
that you do not plan to configure right away

• You can use the following commands to work around this issue. Execute the following
command for each unconfigured plugin on each Panorama instance to prevent Panorama from
waing to send updates. If you do not, your firewalls may lose some IP-tag informaon.

request plugins dau plugin-name <plugin-name> unblock-device-push yes

You can cancel this command by execung:

request plugins dau plugin-name <plugin-name> unblock-device-push no

The commands described are not persistent across reboots and must be used again for any
subsequent reboots. For Panorama in HA pair, the commands must be executed on each
Panorama.

STEP 1 | Verify your Panorama installaon.

On Panorama, ensure that your PAN-OS version meets the requirements to support GCP auto
scaling.

STEP 2 | Remove the Panorama plugin for GCP v1.0.

If you have the Panorama plugin v1.0 installed you must remove it.

STEP 3 | Install the Panorama plugin for GCP.

Select Panorama > Plugins, and type gcp in the search bar. Install the plugin version that
supports the features you want to configure (see the Compability Matrix table for Public
Clouds).

Aer the installaon you can see the plugin in the Panorama dashboard General Informaon
list. View Panorama > Google Cloud Plaorm and you see the Setup, Monitoring Definion,
and AutoScaling interfaces.

STEP 4 | (Oponal) If your Panorama appliances are in a high availability configuraon, you must
manually install the same version of the Google plugin on both Panorama peers.

Configure the Google plugin on the acve Panorama peer only. On commit, the
configuraon syncs to the passive Panorama peer. Only the acve Panorama peer polls
Google VMs you have configured for VM Monitoring.

Prepare to Deploy from the GCP Marketplace
Review these requirements to ensure that you have proper accounts and permissions before you
use the Google Marketplace to deploy the firewall on a Google Compute Engine (GCE) instance.

• General Accounts and Permissions
• Available Google Resources
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• Google Authencaon Methods
• SSH Key Pair

General Accounts and Permissions
You, and any users you allow, must have the following minimal roles or equivalent
Identy and Access Management (IAM) permissions to connect to the VM-Series firewall:

Compute Viewer—Compute Viewer enables you to get and list compute engine resources
without being able to read the data stored on those resources.
Storage Object Viewer—Enables you to bootstrap using a Google storage bucket in the
same project.

Users in your organizaon might have IAM permissions or predefined roles that
are more permissive than required. Ensure that you appropriately restrict VM-Series
firewall access.

You can also restrict access with service accounts, as described in Google Authencaon
Methods.
Monitoring Metric Writer—Required for Stackdriver.

Available Google Resources
Your project must have sufficient resources to deploy the VM-Series firewall as a Google Compute
Engine instance. If you are deploying a GCP Marketplace soluon, determine whether the
soluon deploys other VMs in addion to the firewall. In the Google Cloud Console, select IAM
& admin > Quotas to review the resource quotas for your project and the networks and disk
space consumed. If you are running out of resources you can ask Google to allocate more for your
organizaon.

Google Authencaon Methods
GCP supports mulple ways to connect to an instance. You can authencate with a service
account or an SSH key pair.

1. Service Accounts—Service Accounts apply to applicaons or VMs—not to end users. They
are commonly used to control access when you use programs or scripts, or when you access
the firewall from the gcloud command line. If you are using Google Service Accounts to
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authencate instances or applicaons, you must know the email address for the account(s).
Refer to Creang and Managing Service Account Keys.

Using a service account is necessary if you want to connect to the VM-Series firewall from
outside the project—either from a different project or from the command line. For example, if
you want to enable a physical next generaon firewall to monitor your VM-Series firewall, you
must save the VM-Series firewall service account informaon to a JSON file. In the physical
firewall, you upload the file when you configure the connecon.

1. Select IAM & Admin > Service accounts and choose +Create Service Account.

Enter the service account name and descripon, and click Create.
2. Select a role type from the drop menu, and on the right, select an appropriate access level.

For example, select Project > Editor. You can select mulple roles for a service account.
When you are finished, click Connue.

3. Grant specific users permission to access this service account. Select members from the
Permissions column on the right to give them permission to access the roles in the previous
step.

2. SSH Keys—If you deploy the VM-Series firewall from the Marketplace, you must supply one
Open SSH key in RSA format for the Google Compute Engine instance metadata.

The VM-Series firewall only accepts one key at deployment.

At deployment me, you paste the public key into the Marketplace deployment, as described
in SSH Key Pair. Aer deployment you use the private key to SSH in to the firewall to configure
the administrator account. To add users, see Manage Firewall Administrators.

You can authencate in several ways:

• Create service accounts for instances—You can create a service account for a specific instance
or instance group, and grant specific permissions, which in turn can be granted to users.

• Use the default service account for your project—If you are using the Google Cloud Plaorm
(GCP™) Console, then you logged in with your email address and can access a GCE instance
based on whatever permissions or roles the project administrator assigned to your account.

Every Google Compute Engine instance created with the Google Cloud Console or the gcloud
command line tool has a default service account with the name in email address format:

<project-number>-compute@developer.gserviceaccount.com

To see the service account name for the firewall instance, view the instance details and scroll to
the boom (refer to the Compute Engine default service account).

The default service account can manage authencaon to VMs in the same project as a VM-
Series firewall. Access scopes allow the firewall to iniate API calls to VMs in the Google Cloud
project.
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• Use IAM permissions and the Google APIs—If you use the Google SDK APIs and gcloud, then
you must call the APIs to authencate.

• You typically use the Google SDK when you want to manage the firewall from a command
line or you want to run a script to configure the firewall.

• You need to access the Google APIs if a virtual machine you connect to has a custom image
with applicaons that require Google APIs.

SSH Key Pair
When you deploy the VM-Series firewall from the Google Marketplace you need an SSH key pair
to authencate with the VM-Series firewall.

Create the key pair according to your key generator documentaon. Do not edit the public
key file. Eding risks introducing illegal characters.

The VM-Series firewall manages authencaon differently than GCE instances. Aer deployment,
you first log in with the admin user. The VM-series firewall default user name is accepted only
once. Aer a successful login you set an administrator username and password for the VM-Series
web interface (see Deploy the VM-Series Firewall from Google Cloud Plaorm Marketplace).

The Google Marketplace deployment interface SSH key field displays the following placeholder:

admin:ssh-rsa your-SSH-key

admin is the VM-Series firewall Administrator user name required to log in to the firewall for the
first me. You add the admin: prefix into the Marketplace field when you Deploy the VM-Series
Firewall from Google Cloud Plaorm Marketplace.

You cannot log in to the VM-Series firewall if you do not supply the enre public key, or your key
has illegal characters when you paste the key into the Marketplace SSH key field. When you SSH
in to the VM-Series firewall for the first me, the public key is transferred to the firewall.

If the public key is corrupted, you must delete the deployment and start over. Any networks and
subnetworks remain, but the firewall rules must be recreated.

STEP 1 | Create an SSH key pair and store the SSH Key pair in the default locaon for your operang
system menoned in Locang an SSH key.

• Linux or MacOS—Use ssh-keygen to create the key pair in your .ssh directory.

• Windows—Use PuTTYgen to create the key pair.

The content of the Key comment field does not maer to the VM-Series firewall; you can
accept the default (the key creaon date) or enter a comment that helps you remember the
name of the key pair. Use the Save private key buon to store the private key in your .ssh
directory.
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STEP 2 | Select the full public key.

• Linux or MacOS—Open your public key in a text editor and copy the public key.
• Windows—You must use the PuTTY Key Generator to view the public key. Launch

PuTTYgen, click Load, and browse to private key you saved in your .ssh directory.

In PuTTYgen, scroll down to ensure you select the enre key, right click, and choose Copy.

STEP 3 | Enter the public key in the SSH key field as detailed below.
1. In the Marketplace SSH key field, delete the placeholder text, and type:

admin:

Make sure there are no extra spaces following the colon.
2. Insert the cursor aer admin: and choose Paste as plain text. The key must be on a

single line, as shown below:

3. Move the cursor to the end of the key, add a space, and type: admin

The final contents of the SSH key field must be:

admin:ssh-rsa [KEY] admin

STEP 4 | Check the key.

Aer the deployment, and before you aempt to log in to the firewall, view the management
instance and check the key for linefeeds or extra spaces:

If the key is all on one line and the format is admin:ssh-rsa [KEY] admin, you are finished.
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STEP 5 | (oponal) If something is wrong you must replace the key.

1. Click the X to delete the key, then click + Add item.
2. Enter the key as described in Step 3. Now the SSH key field must show:

admin:ssh-rsa [KEY] admin
3. Click Save to deploy the updated deployment.
4. Re-check the key.

Virtual Private Cloud (VPC) Network Planning
Before you deploy from the Google Market place, make a plan for VPC networks (referred to as
networks), subnetworks (also called subnets), and Google firewall rules. You must create networks
and subnetworks before you start to Deploy the VM-Series Firewall from Google Cloud Plaorm
Marketplace.

The Marketplace deployment page displays only networks and subnetworks that exist
when you start the deployment. If a network is missing, you must exit the deployment,
create the network, and start over.

VPC networks—You must create a custom network specifically for each VM-Series firewall
network interface.

See VM-Series Firewall Licenses for Public Clouds to determine the number of network
interfaces needed based on your VM-Series firewall license. At a minimum, set up the three
VPC networks and subnets required to launch the VM-Series firewall.
A GCP project has a default network with preset configuraons and firewall rules; you can
delete the default network, if unused.
By default, there are up to five networks in a project. Your GCP administrator can request
addional networks for your project.
To connect to the management interface you must create a GCP firewall rules that allows
access. You can do this during the deployment if you choose Enable GCP Firewall rule for
connecons to Management interface then supply a CIDR block for Source IP in GCP
Firewall rule for connecons to Management Interface.

Be sure your networks include all instances you want to secure.

Subnetworks—A compute engine instance can support up to eight Layer 3 interfaces on a
single instance. The Management, Trust, and Untrust interfaces consume three interfaces and
you can create up to five addional dataplane interfaces. Typically the dataplane interfaces
represent applicaon networks.
IP address—You supply IP address ranges when you create interface subnetworks, and you
have the opon to enable an external address when you deploy a subnetwork.

• When you create a network subnet, you must specify an IP address range. This range is used
for your internal network, so it cannot overlap with other subnets.

• During deployment, you can choose to enable an external IP address when you create
a network interface. By default, you are given an ephemeral IP address. You cannot
supply a reserved stac IP address during the deployment, but you can promote the
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ephemeral address to a stac IP address aer you complete the deployment process (see
Promong an ephemeral external IP address).

Network Interface Planning
When you deploy from Google Cloud Plaorm Marketplace, the default VM-Series firewall
deployment has three interfaces: the Management plane interface and the Untrust and Trust
dataplane interfaces. You can define addional dataplane instances, depending on the available
compute resources on your VM; see VM-Series Firewall Licenses for Public Clouds.

All VM-Series firewall interfaces must be assigned an IPv4 address when deployed in a
public cloud environment. IPv6 addresses are not supported.

During the deployment you have the opportunity to name these interfaces.

Interface Order

When you deploy with Marketplace, the order of the network interfaces is predefined. The
Management interface maps to eth0, Untrust to eth1, and Trust to eth2. Marketplace uses this
order because mapping the Management interface to eth0 and the Untrusted interface to eth1 is a
requirement if you need to Swap the Management Interface for load balancing.

Management Interface

The first network interface you add is mapped to eth0 on the firewall and includes the opon to
enable IP forwarding. You use this network interface to manage the VM-Series firewall. Typically,
this interface has an external IP address.

An external IP address is only required if a dataplane interface is aached to the
public subnet. At creaon me, you can receive an ephemeral IP address and
later promote it to a stac IP address aer you complete the deployment (refer to
Promong an ephemeral external IP address).

Dataplane Interfaces (Untrust, Trust)

When you deploy from Marketplace, the order in which you add interfaces is predetermined.

• You configure the Untrust interface aer the Management interface. This order means that
the untrusted interface is mapped to eth1. The Untrust interfaces are typically aached to the
public subnet, and have an external IP address.

An external IP address is only required if a dataplane interface is aached to the public
subnet. At creaon me, you can receive an ephemeral IP address, then promote it to a
stac IP address, as discussed in Promong an ephemeral external IP address.

• The Trust interface follows the Untrust interface, and it is mapped to eth2. The Trust network
oen does not have an external IP address. You can add any addional dataplane interfaces
aer the Trust interface.

Addional Dataplane Interfaces

Plan interfaces for applicaons you must secure, such as web servers, databases, and other
applicaons in your network. You can create up to five addional dataplane interfaces in addion
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to the three required to launch your firewall. Ensure that the applicaons you want to secure are
in networks that connect to the VM-Series firewall.
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Deploy the VM-Series Firewall on Google Cloud
Plaorm

To deploy the VM-Series firewall using the GCP market place template, you must first create a
VPC network for each interface on the firewall. Aer you deploy the firewall from the Google
Marketplace, you can log in to the firewall to adjust the configuraon to work within your GCP
VPC configuraon. You can also enable monitoring so you can collect metrics that enable you to
improve resource management or create Security policy rules that automacally adapt to changes
in your applicaon environment.

• Deploy the VM-Series Firewall from Google Cloud Plaorm Marketplace
• Management Interface Swap for Google Cloud Plaorm Load Balancing
• Use the VM-Series Firewall CLI to Swap the Management Interface
• Enable Google Stackdriver Monitoring on the VM Series Firewall
• Enable VM Monitoring to Track VM Changes on Google Cloud Plaorm (GCP)
• Use Dynamic Address Groups to Secure Instances Within the VPC
• Use Custom Templates or the gcloud CLI to Deploy the VM-Series Firewall

Deploy the VM-Series Firewall from Google Cloud Plaorm
Marketplace

You can use Google® Cloud Plaorm Marketplace to deploy the VM-Series firewall on a fixed
vCPU capacity license (VM-Series Models). The licensed images available from public clouds are:

• VM-Series Next-Generaon Firewall Bundle 1
• VM-Series Next-Generaon Firewall Bundle 2
• VM-Series Next-Generaon Firewall (BYOL)

See Deploy the VM-Series Firewall from Google Cloud Plaorm Marketplace for more about these
license opons.

The Marketplace deploys an instance of the VM-Series firewall with a minimum of one
management interface and two dataplane interfaces (Trust and Untrust). You can add addional
dataplane interfaces for up to five Google Compute Engine instances in your virtual private cloud
(VPC).

Before you deploy the VM-Series firewall, you must create or choose a project in your
organizaon and create any networks and subnets that will connect to the firewall, as described in
VPC Network Planning and Network Interface Planning.

You cannot aach mulple network interfaces to the same VPC network. Every interface you
create must have a dedicated network with at least one subnet. Ensure that your networks include
any addional dataplane instances you create.

All VM-Series firewall interfaces must be assigned an IPv4 address when deployed in a
public cloud environment. IPv6 addresses are not supported.
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STEP 1 | Choose a Bootstrap Method.

STEP 2 | Locate the VM-Series firewall lisng in the Marketplace.
1. Log in to the Google Cloud Console.
2. From the Products and Services menu, select Marketplace.
3. Search for VM-Series.
4. Select one of the VM-Series firewall licensing opons.

STEP 3 | Click Launch on Compute Engine.

STEP 4 | Name the instance and choose resources.
1. Enter the Deployment Name (this name is displayed in the Deployment Manager). The

name must be unique and cannot conflict with any other deployment in the project.
2. Select a Zone. See Regions and Zones for a list of supported zones.
3. Select a Machine Type based on the VM-Series System Requirements for your license

and the Minimum System Requirements for the VM-Series Firewall on Google Cloud
Plaorm.

STEP 5 | Specify instance metadata.

The opons Bootstrap Bucket and Interface Swap affect the inial configuraon the first me
the VM-Series firewall boots.

1. Bootstrap Bucket (Oponal)—If you plan to use a bootstrap file, enter the name of
a storage bucket, or the path to a folder within the storage bucket, that contains the
bootstrap package. You need permission to access the storage bucket. For example:

vmseries-bootstrap-gce-storagebucket=<bucketname>

or

vmseries-bootstrap-gce-storagebucket=<bucketname/directoryname>

If you choose to bootstrap with custom metadata, connue to Step 6.
2. Interface Swap (Oponal)—Swap the Management interface (eth0) and the first

dataplane interface (eth1) at deployment me. Interface swap is only necessary when
you deploy the VM-Series firewall behind Google Cloud Plaorm HTTP(S) Load

VM-Series Deployment Guide Version Version 10.1 745 ©2022 Palo Alto Networks, Inc.

https://console.cloud.google.com/marketplace
https://cloud.google.com/compute/docs/regions-zones/
https://docs.paloaltonetworks.com/content/techdocs/en_US/vm-series/10-1/vm-series-deployment/about-the-vm-series-firewall/vm-series-models/vm-series-system-requirements.html


Set Up the VM-Series Firewall on Google Cloud Plaorm

Balancing. For details, see Management Interface Swap for Google Cloud Plaorm Load
Balancing.

3. SSH key—Paste in the public key from an SSH key pair. Follow the instrucons for your
OS in SSH Key Pair, to create, copy, and paste the key. Windows users must view the key
in PuTTY, copy from the user interface, and paste into Marketplace deployment.

If the key is not formaed properly, the VM-Series firewall does not allow you to
log in. You must delete the deployment and start over.

4. Click More to reveal addional metadata opons. The opons blockProjectKeys, and
enableSerialConsole are properes of the instance; you can change these metadata
values aer a successful deployment.

• blockProjectKeys (Oponal)—If you Block Project Keys, you can use only the public
SSH key you supply to access the instance.

• enableSerialConsole (Oponal)—Interacng with the Serial Console enables you to
monitor instance creaon and perform interacve debugging tasks.

STEP 6 | Specify custom metadata.
If you choose to bootstrap with custom metadata, add any key-value pairs that you did not add
in Step 5. See init-cfg.txt File Components for the list of key-value pairs. For example:

STEP 7 | Configure the boot disk.
1. Boot disk type—Select from SSD Persistent disk or Standard Persistent Disk. See

Storage Opons.
2. Enter the Boot disk size—60GB is the minimum size. You can edit the disk size later but

you must stop the VM to do so.
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STEP 8 | Configure the management interface.
1. Management VPC Network name—Choose an exisng network
2. Management Subnet name—Choose an exisng subnet.
3. Enable External IP for Management interface (Oponal)—If you enable this opon, you

can use the IP address assigned to the VM-Series firewall management interface to use
SSH to access the VM-Series firewall web interface.

4. Enable GCP Firewall rule for connecons to Management interface (Oponal)—This
opon automacally creates a GCP firewall Allow rule for an external source IP address
that you supply.

5. Source IP in GCP Firewall rule for connecons to Management Interface—If you Enable
GCP Firewall rule for connecons to Management interface, enter a source IP address
or a CIDR block.

• Do not use 0.0.0.0/0. Supply an IP address or a CIDR block that corresponds to your
dedicated management IP addresses or network. Do not make the source network
range larger than necessary.

• Verify the address to ensure that you do not lock yourself out.

STEP 9 | Configure the Untrust dataplane interface.
1. Untrust VPC Network name—Choose an exisng network.
2. Untrust Subnet name—Choose an exisng subnet.
3. Enable External IP for Untrust—Enable GCP to provide an ephemeral IP address to act as

the external IP address.

STEP 10 | Configure the Trust dataplane interface.
1. Trust VPC Network name—Choose an exisng network.
2. Trust Subnet name—Choose an exisng network.
3. Enable External IP for Trust—Enable GCP to provide an ephemeral IP address to act as

the external IP address.

STEP 11 | Configure addional interfaces. You must enter the number of dataplane interfaces you want
to add; the default is 0 (none). The deployment page always displays fields for five addional
dataplanes numbered 4 through 8.
1. Addional Dataplane interfaces—Enter the number of addional dataplane instances.

If this number is 0 (default), dataplane numbers 4 through 8 are ignored even
if you fill out the interface fields. If, for example, you specify 2 and then fill out
informaon for three interfaces, only the first two are created.

2. Addional Dataplane # VPC name—Choose an exisng network.
3. Dataplane # Subnet name—Choose a subnet that exists.
4. Enable External IP for dataplane # interface—Enable GCP to provide an ephemeral IP

address to act as the external IP address.

STEP 12 | Deploy the instance.

STEP 13 | Use Google Cloud Deployment Manager to view and manage your deployment.
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STEP 14 | Use the CLI to change the administrator password on the firewall.
1. Log in to the VM-Series firewall from the command line. In your SSH tool, connect to the

External IP for the management interface, and specify the path to your private key.

Windows users: Use PuTTY to connect to the VM-Series firewall and issue command line
instrucons. To specify the path to the private key, select Connecon > SSH > Auth. In
Private key file for authencaon: click Browse to select your private key.

2. Enter configuraon mode:

VMfirewall> configure
3. Enter the following command:

VMfirewall# set mgt-config users admin password
4. Enter and confirm a new password for the administrator.
5. Commit your new password:

VMfirewall# commit
6. Return to command mode:

VMfirewall# exit
7. (Oponal) If you used a bootstrap file for interface swap, use the following command to

view the interface mapping:

VMfirewall> debug show vm-series interfaces all

STEP 15 | Access the VM-Series firewall web interface.
1. In a browser, create a secure (hps) connecon to the IP address for the management

interface.

If you get a network error, check to see that you have a GCP firewall rule that allows the
connecon.

2. When prompted, enter the username (admin) and the administrator password you
specified from the CLI.

3. (Oponal) If you bootstrapped, then Verify Bootstrap Compleon.

If you see problems, search the log informaon on the VM-Series firewall. Choose
Monitor > System and, in the manual search field, enter  description contains
'bootstrap' and look for a message in the results that indicates that the bootstrap
was successful.

Aer you log in to the firewall, you can add administrators and create interfaces, zones, NAT
rules, and policy rules, just as you would on a physical firewall.

Management Interface Swap for Google Cloud Plaorm Load
Balancing

Because internal load balancing can send traffic only to the primary interface of the next hop load-
balanced Google Compute Engine instance, the VM-Series firewall must be able to use eth0 for
dataplane traffic.
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All VM-Series firewall interfaces must be assigned an IPv4 address when deployed in a
public cloud environment. IPv6 addresses are not supported.

The firewall can receive dataplane traffic on eth0 if the VM-Series firewall is behind the Google
Cloud Plaorm internal load balancing interface.

• The VM-Series firewalls secure traffic outbound directly to the internet without requiring a
VPN link or a Direct Connect link back to the corporate network.

• The VM-Series firewall secures an internet-facing applicaon when there is exactly one back-
end server, such as a web server, for each firewall. The VM-Series firewalls and web servers can
scale linearly, in pairs, behind the Google internal load balancing address.

To allow the firewall to send and receive dataplane traffic on eth0 instead of eth1, you must swap
the mapping of the internal load balancing network interface within the firewall so that eth0 maps
to ethernet 1/1, and eth1 maps to the MGT interface on the firewall.

If possible, swap the management interface mapping before you configure the firewall and
define policy rules.

Swapping how the interfaces are mapped allows Google Cloud Plaorm to distribute and route
traffic to healthy instances of the VM-Series firewall located in the same or different zones.

Swap the Management Interface
You can swap the interfaces when you , or you can configure the firewall aer it is created.

At creaon— When you deploy the VM-Series firewall, you can enable interface swap in two
ways.

• Google Cloud Console — In the Create Instance form, enter a key-value pair in the Metadata
field, where mgmt-interface-swap is the key, and enable is the value.

• Bootstrap File — Create a bootstrap file the includes the mgmt-interface-swap operaonal
command in the bootstrap configuraon, as described in Bootstrap the VM-Series Firewall on
Google Cloud Plaorm. In the Create Instance form, enter a key-value pair in the Metadata
field to enable the bootstrap opon.

From the VM-Series firewall—Log in to the firewall, and Use the VM-Series Firewall CLI to Swap
the Management Interface. In operaonal mode, issue the following command:

set system setting mgmt-interface-swap enable yes
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• Pick one method to specify the interface swap seng— the bootstrap configuraon
file, the firewall CLI, or the Google Compute Engine instance Metadata field (accessed
from the Google Cloud Console). Using one method ensures predictable behavior on the
firewall.

From the Google Cloud Console you cannot confirm whether you have swapped eth0
and eth1. Aer swapping, you must remember that load balancing is on eth0 and the
firewall management interface is eth1 so that you can properly configure Google Cloud
Plaorm load balancing, and create security policy rules to secure load balancing to
one or more VM-Series firewalls.

• If you configured the VM-Series firewall before swapping, check whether any IP address
changes for eth0 and eth1 impact policy rules.

Use the VM-Series Firewall CLI to Swap the Management Interface
This task is only required if your architecture places the VM-Series firewall behind the
Google Cloud Plaorm internal load balancer.

If you did not specify metadata to swap the management interface (MGT) with the dataplane
interface when you deployed the firewall, you can use the CLI to enable the firewall to receive
dataplane traffic on the primary interface.

STEP 1 | Deploy the VM-Series Firewall from Google Cloud Plaorm Marketplace.

Before you proceed, verify that the firewall has a minimum of two network interfaces
(eth0 and eth1). If you launch the firewall with only one interface, the interface swap
command causes the firewall to boot into maintenance mode.

STEP 2 | On the Google Cloud Console, view the VM instance details to verify the network interface
IP addresses of the eth1 interface and verify that any security rules allow connecons
(HTTPS and SSH) to the new management interface (eth1).

STEP 3 | Log in to the VM-Series firewall CLI and enter the following command:

set system setting mgmt-interface-swap enable yes

You can view the default mapping from the command line interface. The output is similar to
this:

> debug show vm-series interfaces all
Interface_name  Base-OS_port
  mgt              eth0
  Ethernet1/1      eth1
  Ethernet1/2      eth2

STEP 4 | Confirm that you want to swap the interface (use the eth1 dataplane interface as the
management interface).

STEP 5 | Reboot the firewall for the swap to take effect:

request restart system
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STEP 6 | Verify that the interfaces have been swapped:

debug show vm-series interfaces all

Enable Google Stackdriver Monitoring on the VM Series Firewall
A VM-Series firewall on a Google® Compute Engine instance can publish custom PAN-OS metrics
to Google Stackdriver. These metrics allow you to assess performance and usage paerns so that
you can manage your firewall resources accordingly.

• Google Stackdriver Permissions
• Enable Google Stackdriver

Google Stackdriver Permissions
Authencaon requirements vary based on whether you can use the default service account to
authencate or need to use Google APIs to authencate.

You can authencate in two ways:

• Use the default service account for the VM-Series firewall instance—If you are using the
Google Cloud Plaorm (GCP™) Console, then you logged in with your email address and can
access the instance based on whatever permissions or roles the project administrator assigned
to your account.

• Use IAM permissions and the Google APIs—If you use the Google SDK APIs and gcloud, then
you must call the APIs to authencate. You typically use the Google SDK when you want to
manage the firewall from a command line or you want to run a script to configure the firewall.

Every Google Compute Engine instance created with the Google Cloud Console or the gcloud
command line tool has a default service account with the name in email address format:

<project-number>-compute@developer.gserviceaccount.com

To see the service account name for the firewall instance, view the instance details and scroll to
the boom (refer to the Compute Engine default service account).

The default service account can manage authencaon for monitoring VMs in the same project as
a VM-Series firewall.

• Access scopes allow the firewall to iniate API calls to monitor VMs in a Google Cloud project.
• You don’t need to access the Google APIs unless one of the monitored virtual machines has a

custom image with applicaons that require Google APIs.

If you want to set up monitoring from a physical firewall or from a VM-Series firewall in a different
project, you must use the Google APIs to authencate. There are two prerequisites:

• Google APIs must be installed.
• Your account must have the roles Monitoring Metric Writer and Stackdriver Account Viewer.

Enable Google Stackdriver
For a descripon of the PAN-OS metrics that you can publish to Google Stackdriver, see Custom
PAN-OS Metrics Published for Monitoring.
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STEP 1 | Push PAN-OS metrics from a VM-Series firewall on a Google Compute Engine instance to
Stackdriver.
1. Log in to the web interface on the VM-Series firewall.
2. Select Device > VM-Series. Under Google Cloud Stackdriver Monitoring Setup, click

Edit (  ).

1. Check Publish PAN-OS metrics to Stackdriver.

2. Set the Update Interval (range is 1 - 60 minutes; default is 5). This is the frequency at
which the firewall publishes the metrics to Stackdriver.

3. Click OK.
3. Commit your changes.

Wait unl the firewall starts to publish metrics to Stackdriver before you configure alarms
for PAN-OS metrics.
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STEP 2 | Verify that you can see the metrics on Stackdriver.
1. In the Google Cloud Console, select Products and Services > Monitoring.
2. In Stackdriver, choose Resources > Metrics Explorer.
3. In the Find resource type and metric secon, enter custom in the search field to filter

the PAN-OS metrics.

STEP 3 | Configure alerts and acons for PAN-OS metrics on Stackdriver. See Monitoring Quickstart
for Google Compute Engine and Stackdriver Introducon to Alerng.

Enable VM Monitoring to Track VM Changes on Google Cloud
Plaorm (GCP)

You can enable any firewall that runs PAN-OS 9.0 (virtual or physical) to monitor applicaon
workloads deployed on Google Compute Engine instances. VM Monitoring enables you to monitor
a predefined set of metadata elements or aributes on the VM-Series firewall. In the PAN-OS 9.1
Administrator’s Guide, see Aributes Monitored on Virtual Machines in Cloud Plaorms.

With an awareness of virtual machine adds, moves, and deletes within a Google VPC, you can
create Security policy rules that automacally adapt to changes in your applicaon environment.
As you deploy or move virtual machines, the firewall collects aributes (or metadata elements).
You can use this metadata for policy matching and to define Dynamic Address Groups (see Use
Dynamic Address Groups to Secure Instances Within the VPC).

You can configure up to ten VM informaon sources on each firewall or on each virtual system
on a firewall capable of mulple virtual systems. Informaon sources can also be pushed using
Panorama templates.

To perform VM monitoring, you must have the IAM role Monitoring Metric Writer.
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STEP 1 | Log in to your deployed firewall.

VM-Series Deployment Guide Version Version 10.1 754 ©2022 Palo Alto Networks, Inc.



Set Up the VM-Series Firewall on Google Cloud Plaorm

STEP 2 | Enable VM Monitoring.
1. Select Device > VM Informaon Sources.
2. Add a VM informaon source and enter the following informaon:

• Specify a Name to idenfy the instance that you want to monitor.
• Select the Google Compute Engine Type.
• Select Enabled.
• Choose the Service Authencaon Type.

• If you choose VM-Series running in GCE, you are authencang with the default
service account generated when an instance is created. This is part of the instance
metadata.

• If you want to monitor from a firewall outside the current project, choose Service
Account. You must upload the service account credenals in JSON format. See
Creang and Managing Service Account Keys.

• (Oponal) Modify the Update interval to a value between 5-600 seconds. By default
the firewall polls every 5 seconds. The API calls are queued and retrieved every 60
seconds, an update takes up to 60 seconds plus the configured polling interval.

• (Oponal) To change the number of hours before meout, check Enable meout
when the source is disconnected and enter the Timeout (hours) before the
connecon to the monitored source is closed (range is 2 to 10; default is 2).

If the firewall cannot access the host and the specified limit is reached, the firewall
closes the connecon to the source.

• Click OK and Commit your changes.
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STEP 3 | Verify the connecon status.

If the connecon status is pending or disconnected, verify that the source is operaonal and
that the firewall is able to access the source. If you use a port other than the Management
(MGT) port for communicang with the monitored source, then you must change the service
route (select Device > Setup > Services, click Service Route Configuraon, and modify the
Source Interface for the VM Monitor service).

Use Dynamic Address Groups to Secure Instances Within the VPC
In a dynamic environment such as the Google® Cloud Plaorm (GCP™), where you launch
new instances on demand, the administrave overhead in managing Security policy can be
cumbersome. Using use dynamic address groups in policy enables agility and prevents disrupon
in services or gaps in protecon.

This workflow assumes that you have deployed the VM-Series firewall, configured some
applicaons on instances, and enabled Google Stackdriver monitoring.

STEP 1 | Configure the firewall to monitor the VPC.

STEP 2 | Label instances in the VPC.
A label is a name-value pair. You can label resources from the Google Cloud Console, from
Google API calls, or from the Google Cloud Shell. In this task we are labeling instances;
however, labels can be applied to many resources, as described in Labeling Resources.

You can also add labels from the Instance browser.

The labels you create support your strategy for differenang your resources in ways that are
useful to your Security policy.
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STEP 3 | Create a dynamic address group on the firewall.
1. Select Objects > Address Groups.
2. Add a dynamic address group and specify a Name and a Descripon.
3. Set Type to Dynamic.
4. Define the match criteria.

1. Add Match Criteria and select the And operator.
2. Select the aributes to filter for or to match against.

5. Click OK.
6. Click Commit.
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STEP 4 | Use the dynamic address group in a Security policy rule.

Create a rule to allow internet access to any web server that belongs to the dynamic address
group called my-data.

1. Select Policies > Security.
2. Add a rule and a Name for the rule and verify that the Rule Type is universal.
3. In the Source tab, add trust as the Source Zone.
4. In the Source Address secon, Add your new my-data group.
5. In the Desnaon tab, add untrust as the Desnaon Zone.
6. In the Service/URL Category tab, verify that the service is set to applicaon-default.
7. In the Acons tab, set the Acon to Allow.
8. In the Profile Sengs, set the Profile Type to Profiles and then aach the default profiles

for Anvirus, An-Spyware, and Vulnerability Protecon.
9. Click OK.
10. Click Commit.

STEP 5 | Verify that members of the dynamic address group are populated on the firewall.

Policy will be enforced for all IP addresses that belong to this address group and that are
displayed here.

1. Select Policies > Security and select the rule.
2. Select Inspect from the drop-down. You can also verify that the match criteria is

accurate.
3. Click more to verify that the list of registered IP addresses is displayed.

Use Custom Templates or the gcloud CLI to Deploy the VM-Series
Firewall

The official VM-Series images published on Google Cloud Plaorm Marketplace are available
in the paloaltonetworksgcp-public project. You need to know the secure path to these
images if you want to call them from the gcloud command line, or refer to them in a template
you have wrien or adapted.

• BYOL: vmseries-byol-<version>
• PAYG Bundle 1: vmseries-bundle1-<version>
• PAYG Bundle 2: vmseries-bundle2-<version>

Use the gcloud CLI to find the current image names and project:

  gcloud compute images list --project paloaltonetworksgcp-public
  --no-standard-images
  NAME                  PROJECT                   FAMILY  DEPRECATED 
 STATUS
  vmseries-bundle1-810  paloaltonetworksgcp-public                   
   READY
  vmseries-bundle2-810  paloaltonetworksgcp-public                   
   READY
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  vmseries-byol-810     paloaltonetworksgcp-public                   
   READY

Add the --uri flag to see the image paths:

  gcloud compute images list --project paloaltonetworksgcp-public
  --no-standard-images --uri

  https://www.googleapis.com/compute/v1/projects/paloaltonetworksgcp-
public
  /global/images/vmseries-bundle1-810
  https://www.googleapis.com/compute/v1/projects/paloaltonetworksgcp-
public
  /global/images/vmseries-bundle2-810
  https://www.googleapis.com/compute/v1/projects/paloaltonetworksgcp-
public
  /global/images/vmseries-byol-810

For an example, download the gcp-two-er template from hps://github.com/PaloAltoNetworks.

This template separates the image name (which includes the PAN-OS version) from the URL path.
In two-tier-template.py the image variable expects the image name; for example: vmseries-
byol-810. vm-series-template.py uses the values of COMPUTE_URL_BASE and sourceImage
to build the path.
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VM Monitoring with the Panorama Plugin for GCP
The Panorama plugin for Google Cloud Plaorm (GCP) version 2.0.0 enables you to create a VM
monitoring configuraon that authencates with a GCP project and monitors VM-Series firewalls
and other VMs deployed within it. Once you establish a connecon to your project, the plugin
can retrieve IP-address-to-tag communicaon between Panorama and GCP assets. Tags can be
predefined aributes, user-defined labels for VMs, and user-defined network tags (see Review and
Create Tags).

The Panorama plugin for GCP retrieves the internal and external IP addresses from running VMs,
and periodically retrieves IP-to-tag mappings from VMs in connected GCP VPCs.

You can use tags to organize VMs into dynamic address groups, and then reference your tags in
Security policy rules that allow or deny traffic to specific VM IP addresses. To consistently enforce
Security policy, you can then push rules to your VM-Series firewalls.

• Configure VM Monitoring with the Panorama Plugin for GCP

Configure VM Monitoring with the Panorama Plugin for GCP
This topic describes the steps to prepare your GCP assets for VM monitoring, review the required
Panorama elements, and describes how to configure VM Monitoring in the Panorama plugin for
Google Cloud Plaorm (GCP).

• Configure GCP Assets for VM Monitoring
• Review and Create Tags
• Configure VM Monitoring with the Panorama Plugin for GCP

• Prepare Panorama to Configure VM Monitoring
• Set Up VM Monitoring

Configure GCP Assets for VM Monitoring
You can monitor VM-Series firewalls you deployed from the GCP marketplace, firewalls you
deployed with auto scaling Firewall templates, GCE instances you created from to the GCP
console or the gcloud command line, or other virtual machines deployed in GCP. If you deploy
PAN-OS VMs from the Marketplace, follow the instrucons in Set Up the VM-Series Firewall on
Google Cloud Plaorm.

Review IAM Roles

Ensure that you have the following minimum permissions for VM Monitoring tasks:

• In GCP console, create a service account for your project and grant the permission project
owner or editor.

Service account creaon cannot be automated. If you do not have permission to create a
service account you can ask an administrator to create it and assign an appropriate role to you.

• View your service account: read-only.
• View PAN-OS VMs deployed from the Google Marketplace: Compute viewer.
• Assign a user-defined tag to an instance: Project owner, editor or Instance Admin.
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Create a Service Account

Before you use the GCP plugin on Panorama to configure VM Monitoring, you must use the GCP
console to create a service account that grants permissions to access your GCP project, VM-
Series firewalls deployed within it, any other VMs that you want Panorama to manage, and related
networks and subnetworks. The GCP plugin for Panorama retrieves pre-defined aributes for
Google assets, user defined VM labels, and user-defined network tags.

Every project has a default service account that was automacally created when the project was
created. If you create a separate service account specifically for VM Monitoring you have greater
control of users and their roles. You can configure up to 100 service accounts per project.

STEP 1 | In the Google Cloud Plaorm console, select the project you want to monitor.

STEP 2 | Select IAM & Admin > Service accounts and choose +Create Service Account.

Enter the service account name and descripon, and click Create.

STEP 3 | Select a role type from the drop menu, and on the right, select an appropriate access level.

For example, select Project > Editor. You can select mulple roles for a service account.

When you are finished, click Connue.

STEP 4 | Grant specific users permission to access this service account. Select members from the
Permissions column on the right to give them permission to access the roles in the previous
step.

STEP 5 | (Oponal) Click +CREATE KEY to create a credenal that allows you to authencate with the
Google Cloud CLI to access VM-Series firewalls, networks, and other VMs associated with
this service account.

The key is downloaded automacally. Be sure to store it in a secure locaon. The JSON format
for the generated private key is as follows:

{
  "type": "service_account",
  "project_id": "gcp-xxx",
  "private_key_id": "252e1e7a2e9c84b5d4dbb6195b1de074594b6499",
  "private_key": "-----BEGIN PRIVATE KEY-----
\nMIIEvgIBADANBgkqhkiG9w0BAQEFAASCBKgwggSkAgEAAoIBAQDAd0i+RMKCtrsO
\n4KHnzTAPrgoBjRgpjyNcvQmdUqHr\n-----END PRIVATE KEY-----\n",
  "client_email": "dlp-vm-monit-svc-acct@gcp-
xxx.iam.gserviceaccount.com",
  "client_id": "108932514695821539229",
  "auth_uri": "https://accounts.google.com/o/oauth2/auth",
  "token_uri": "https://oauth2.googleapis.com/token",
  "auth_provider_x509_cert_url": "https://www.googleapis.com/
oauth2/v1/certs",
  "client_x509_cert_url": "https://www.googleapis.com/
robot/v1/metadata/x509/dlp-vm-monit-svc-acct%40gcp-
xxx.iam.gserviceaccount.com"
}
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Review and Create Tags
“Tag” is a general term for predefined aributes, user-defined labels, and user-defined network
tags.

• Predefined tags (aributes) are automacally created for Google VMs. When you configure VM
Monitoring you can choose to monitor all 8 of the predefined aributes, or you can create a
customized list of aributes to monitor.

• You can define your own tags for VM labels and network tags.

Tag VMs and networks so that you can idenfy and group them so that you can structure rules to
enforce Security policy. You can tag any VM deployed in your Google project—for example, a VM-
Series firewall, a web server, an applicaon server, or a load balancer.

• Tags must be associated with a VM. This also applies to networks and subnetworks.
• If there are mulple IP addresses associated with an instance (for example if you tagged the

VM-Series firewall trust and untrust interfaces), Panorama generates mulple sets of tag
informaon.

The total number of tags that the Panorama plugin can retrieve and register depends on the PAN-
OS version Panorama is running and the version of the managed VM-Series firewalls.

Google zone, Google region, VPC name, and Subnet name are used to tag network interfaces on
VMs with mulple interfaces. specific to network interface.

Predefined Attributes

The Google Cloud Plaorm plugin for Panorama retrieves the following predefined tags from any
managed VM:

• Project ID—For example: google.project-id.myProjectId.

To find your project informaon in the Google console, select your project, then select IAM &
Admin > Sengs.

• Service account—Your service account in the form of an email address. For example:
google.svc-accnt.sa-name@project-id.iam.gserviceaccount.com.

To find your Service account, view the VM instance details.
• VPC name—The name of the VPC network for a managed VM. For example: google.vpc-

name.myvnet.
• Subnet name—The name of a subnet you created for a managed VM interface. For example,

for the VM-Series firewall untrust interface, the name of the subnet you created for the untrust
interface: google.subnet-name-untrust.web.

• OS SKU—The operang system you chose when you deployed the managed VM. For example:
google.os-sku.centos-7.

This aribute is not supported if the VM uses a custom image.

• Google zone—The zone you selected when you deployed the VM. For example:
google.zone.us-east1-c.

• Google region—The region containing the zone you selected. For example: google.region.us-
east1.
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• Instance group name—For example: google.instance-group.myInstanceGroup. To view or create
an instance group in the Google console, select Compute Engine > Instance Group.

User-defined Labels

Panorama uses up to 16 user-defined labels. If you have more than 16 labels, Panorama sorts your
user-defined labels alphabecally and uses the first 16 tags.

Review the Google requirements for label key-value pairs: Keys have a minimum length of 1
character and a maximum length of 63 characters, and cannot be empty. Values can be empty, and
have a maximum length of 63 characters.

To create or view labels in the GCP console, go to Compute Engine > VM Instances and select
Show Info Panel. Select one or more VMs and in the Info Panel, select Labels. Click +Add a label,
add a key and value, and click Save.

User-defined Network Tags

Panorama uses up to 8 user-defined network tags, If you have more than 8 tags, Panorama sorts
your user-defined labels alphabecally and uses the first 8 tags.

Note that Google limits network tags as follows:

• Maximum 63 characters per tag.
• You can use lowercase leers, numbers, and dashes; a tag must start with a lowercase leer,

and end with a number or a lowercase leer.

To create or view network tags in the GCP console, go to Compute Engine > VM Instances and
select an instance. Edit the instance, and scroll down to Network Tags, enter tags (separated by
commas), and Save. See Configuring Network Tags.

Configure VM Monitoring with the Panorama Plugin for GCP
Aer you tag your GCP assets and create a service account, make your assets available to
Panorama so you can set up VM monitoring.

Prepare Panorama to Configure VM Monitoring

Follow these steps to enable Panorama to manage and monitor your GCP assets. Any VM
deployed in GCP can be a managed device in Panorama.

STEP 1 | In Panorama, add the VM-Series firewalls and other VMs associated with your GCP project
as managed devices.

STEP 2 | Add a Device Group and assign managed devices to it. A Device Group is a group of firewalls
or virtual systems that you want to manage as a group.

A VM can be a member of only one Device Group. Plan your Device Groups carefully.

STEP 3 | Add a template. Name the template and accept the default VPC.

STEP 4 | Add a template stack. Add the stack, Add the template you just created, and select your
devices.

STEP 5 | Commit the changes.
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Set Up VM Monitoring

STEP 1 | If you have not done so, Install the Panorama Plugin for GCP.

STEP 2 | Log in to the Panorama web interface and select Panorama > Google Cloud Plaorm.

STEP 3 | Set up VM monitoring.
1. Configure general sengs.

1. Select Panorama > Google Cloud Plaorm > Setup > General. To edit the sengs,
click the gear.

• Check Enable Monitoring to permit VM monitoring on all projects for which you
configure a service account.

• Enter the Monitoring Interval in seconds. This is the length of me between tag
retrieval events.

2. Add a nofy group. A nofy group is a list of Device Groups to which Panorama pushes
IP-address-to-tag mappings and updates.

A project can have only one nofy group.

1. Select Panorama > Google Cloud Plaorm > Setup > Nofy Groups and click Add.
2. Enter a Name to idenfy the group of firewalls to which Panorama pushes the VM

informaon (IP address-to-tag mappings) it retrieves.
3. Select the Device Groups to which Panorama will push the VM informaon (IP

address-to-tag mappings) retrieved from your project. The VM-Series firewalls use the
update to determine the current member list for Dynamic Address Groups referenced
in Security policy.

Plan your Device Groups carefully.

4. Select predefined or custom tags.

• Select All 8 Predefined Tags—Choose this opon to select all predefined aributes
(tags).

• Custom Tags—Choose this opon to create tag lists for predefined aributes, user-
defined labels, and user-defined network tags.

5. • Make sure to include all relevant Device Groups in a single nofy group.
• If you want to deregister the tags that Panorama has pushed to a firewall included

in a nofy group, you must delete the monitoring definion.
• To register tags to all virtual systems on a firewall enabled for mulple virtual

systems, you must add each virtual system to a separate Device Group on
Panorama and assign the Device Groups to the nofy group. Panorama will register
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tags to only one virtual system, if you assign all the virtual systems to one Device
Group.

3. Add a GCP Service Account Credenal.

• Name the service account credenal.
• (Oponal) Enter a descripon of the service account.
• Browse to upload the JSON file generated when you created the service account.

You must use the Panorama web interface. You cannot use the CLI to add a
service account

You can only use a service account for one credenal. Do not create mulple
credenals from a single JSON file.

Aer you add a service account credenal, you can validate the credenal from your Panorama
command line:

request plugins gcp validate-service-account <svc-acct-credential-
name>

STEP 4 | Create a Monitoring Definion.

A monitoring definion consists of the service account credenal for your project and a nofy
group. All the networking assets in your project are monitored, and the tags retrieved are
pushed to the Device Groups you list in your monitoring definion. When you add a new
monitoring definion, it is enabled by default.

A project can have only one monitoring definion, and a monitoring definion can
include only one nofy group.

1. Select Panorama > Google Cloud Plaorm > Monitoring Definion and click Add.
2. Name the monitoring definion.
3. Enter an oponal Descripon for the project and assets you are monitoring.
4. Select the Service Account credenal you created in the previous step.
5. Select a Nofy Group.
6. Enable monitoring for the elements associated with this service account.

STEP 5 | Commit the changes on Panorama.

Verify that the status for the Monitoring Definion displays as Success. If it fails, verify that
you entered the project ID accurately and provided the correct keys and IDs for the service.
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STEP 6 | Verify that you can view the VM informaon on Panorama, and define the match criteria for
Dynamic Address Groups.

On HA failover, the newly acve Panorama aempts to reconnect to Google Cloud Plaorm
and retrieve tags for all monitoring definions. If there is an error with reconnecng even one
monitoring definion, Panorama generates a system log message:

Unable to process subscriptions after HA switch-over; user-
intervention required.

If you see this error, fix the issue in Panorama. For example, remove an invalid subscripon
or provide valid credenals, and commit your changes to enable Panorama to reconnect and
retrieve the tags for all monitoring definions.

Even when Panorama is disconnected from Google Cloud Plaorm, the firewalls have
the list of all tags that had been retrieved before failover, and can connue to enforce
policy on that list of IP addresses. When you delete a monitoring definion, Panorama
removes all tags associated with registered VMs. As a best pracce, configure acon-
oriented log forwarding to an HTTPS desnaon from Panorama so that you can
take immediate acon.
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Auto Scaling the VM-Series Firewall on Google Cloud
Plaorm

The Panorama plugin for Google Cloud Plaorm (GCP) version 2.0.0 assists you in deploying the
VM-Series firewall in GCP and enables Panorama to manage VM-Series firewalls securing VM
monitoring or auto scaling deployments in GCP. Using Panorama for centralized policy and firewall
management increases operaonal efficiency in managing and maintaining a distributed network
of firewalls.

With Panorama maintaining your GCP managed instance groups you can create applicaon
enablement policies that protect and control the network.

The auto scaling deployment supports using a shared VPC network configuraon or VPC network
peering to create a common VPC network in which a host project contains shared VPC networks
and the VM-Series firewalls, and a service project contains a vm-based or container-based
applicaon deployment (a Kubernetes cluster). Palo Alto networks supplies templates to help you
deploy the VM-Series firewalls in the host project and deploy an oponal sample applicaon in the
service project.

BYOL and PAYG licenses can be used for the VM-Series firewalls. During licensing, VM-Series
firewall instances talk directly to the Palo Alto Networks license server.

If you choose BYOL your deployment can deacvate license instances in response to a scale-
down event. If a VM-Series firewall’s deployment informaon is configured in the Panorama
plugin for GCP and the firewall is automacally removed, Panorama detects the firewall status and
automacally deregisters the firewall.

• Auto Scaling Components for Google Cloud Plaorm
• Deploy GCP Auto Scaling Templates

Auto Scaling Components for Google Cloud Plaorm
Typical GCP auto scaling deployments use a host project and a service project and form a
common VPC network between the two. The Panorama plugin for GCP can secure an auto
scaling deployment in a single project with host and service VPCs, or host and service projects
in a shared VPC or peered VPC network configuraon, where the host project contains the VM-
Series firewalls and the shared VPC networks, and the service project contains your applicaon
deployment. If your applicaon is deployed in a Kubernetes cluster, a peered VPC is required.

• Auto Scaling Requirements
• Prepare to Deploy the Auto Scaling Templates

Auto Scaling Requirements
General Requirements—Ensure your environment meets the basic requirements.
Panorama Plugin for GCP—If you have not done so, Install the Panorama Plugin for GCP.

If you previously installed the Panorama plugin for GCP version 1.0.0, remove it before
you install 2.0.X. You cannot upgrade.
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Palo Alto Networks Auto Scale templates version 1.0—Palo Alto Networks provides the
templates to deploy VM-Series firewall instances in the host project and configure and deploy
a sample applicaon in a service project. See About the Auto Scaling Templates for more about
the templates.

Download the templates from GitHub. The zip file contains separate zip files for the firewall
and applicaon templates.

Prepare to Deploy the Auto Scaling Templates
Complete the following tasks before you deploy the auto scaling templates.

• Prepare a Host Project and Required Service Accounts
• Obtain a Licensing API Key
• Configure the Panorama Plugin for GCP to Secure an Auto Scaling Deployment
• Prepare a VM-Series Firewall Bootstrap Package for Auto Scaling

Prepare a Host Project and Required Service Accounts

You need a host project and a service project to form the shared VPC topology that supports
the firewall and applicaon templates. You can create a new host project or prepare an exisng
project to act as your host.

To set up the Shared VPC an organizaon administrator must grant the host project administrator
the Shared VPC Admin role. The Shared VPC Admin can enable a project to act as a host, and
grant the Service Project Admin role to the service project administrator. Review the GCP
documentaon on Administrators and IAM roles.

STEP 1 | In the GCP console, create a GCP project to act as the host. If you want to use an exisng
project, skip to the next step.

To create a new project, select your organizaon or No organizaon, click New Project and fill
in your project informaon. Note, this is your only chance to EDIT the project ID.

The Google Cloud SDK must be installed and configured so that you can authencate
with your host project from the CLI. You will use the command line interface to deploy
the firewall template and the applicaon template, and to aach the service project to
the host project.
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STEP 2 | Enable APIs and services required for auto scaling. The required APIs are:

Cloud Pub/Sub API
Cloud Deployment Manager API
Cloud Storage API
Compute Engine API
Google Compute Engine Instance Group Manager API
Google Compute Engine Instance Group Updater API
Google Compute Engine Instance Groups API
Kubernetes Engine API
Stackdriver API
Stackdriver Logging API
Stackdriver Monitoring API

You can enable APIs from the GCP console or the GCP CLI, as shown below.

Enable APIs from the GCP console

1. Select the host project, and from the Navigaon menu, select APIs & Services.
2. Search for and view each required API.
3. ENABLE any APIs that do not display the “API enabled” status.

Enable APIs from the CLI

1. In the CLI, view your configuraon to ensure that you are in the correct project.

gcloud config list

If not, set the project as follows:

gcloud config set project <project-name>

2. Issue the following commands to enable the required APIs.

gcloud services enable pubsub.googleapis.com
gcloud services enable deploymentmanager.googleapis.com
gcloud services enable storage-component.googleapis.com
gcloud services enable compute.googleapis.com
gcloud services enable replicapool.googleapis.com
gcloud services enable replicapoolupdater.googleapis.com
gcloud services enable resourceviews.googleapis.com
gcloud services enable container.googleapis.com
gcloud services enable stackdriver.googleapis.com
gcloud services enable logging.googleapis.com
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gcloud services enable monitoring.googleapis.com

3. Confirm that the required APIs are enabled.

gcloud services list --enabled

STEP 3 | Create a service account for deploying the VM-Series firewall, and assign the IAM roles
required for auto scaling a service or a Kubernetes cluster.

When you configure the firewall templates you add the email address for this service account
to the VM-Series firewall .yaml file. Within the host project, the template uses credenals
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from this service account to create a host VPC with subnets, deploy VM-Series firewalls in the
VPC, configure Stackdriver custom metrics, create a Pub/Sub topic, and more.

1. In the GCP console select IAM & Admin > Service accounts and select +CREATE SERVICE
ACCOUNT.

Fill in the service account details and click CREATE.
2. Give the service account permission to auto-scale resources in this project.

Select a role type from the drop menu, and on the right, select an appropriate access level.
For example, select Project > Editor. You can select mulple roles for a service account.

Compute Engine > Compute Admin
Compute Engine > Compute Network User
Pub/Sub > Admin
Monitoring > Monitoring Metric Writer
Stackdriver > Stackdriver Accounts Editor
Storage > Storage Admin
(GKE only) Kubernetes > Kubernetes Engine Cluster Admin
(GKE only) Kubernetes > Kubernetes Engine Viewer

Connue when you are finished adding roles.
3. Click +CREATE KEY to create a key for the host service account.

• (Oponal) Add email addresses to grant other users or administrators access to this
service account.

• Click JSON to download the private key in JSON form.
• Store the key in a safe locaon. You will need this key when you Deploy GCP Auto

Scaling Templates.
4. Click DONE.
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STEP 4 | Create a service account that a Panorama administrator can use to interact with this host
project.

1. In the GCP console select IAM & Admin > Service accounts and select +CREATE SERVICE
ACCOUNT.

2. Fill in the service account details and click CREATE.
3. Grant service account access.

Select a role type from the drop menu, and on the right, select an appropriate access level.
For example, select Project > Editor. You can select mulple roles for a service account.

Compute Engine > Compute Viewer
Deployment Manager > Viewer
Pub/Sub > Admin

Click CONTINUE.
4. Click +CREATE KEY to create a key for the host service account.

• (Oponal) Add email addresses to grant other users or administrators access to this
service account.

• Select JSON to download the private key in JSON form.
• Store the key in a safe locaon. You will need this key when you Configure the Panorama

Plugin for GCP to Secure an Auto Scaling Deployment.

STEP 5 | (oponal) In the CLI, ensure you can communicate with your new host project.
1. Set your project to the host project you just created.

gcloud set project <your-autoscale-host-project-name>
2. Create a configuraon for auto scaling. Your new configuraon is automacally acvated

unless you disable acvaon.
gcloud config configurations create <CONFIGURATION_NAME> gcloud
config list

Obtain a Licensing API Key

You need a Licensing API key so Panorama can license and de-license managed assets in GCP.

STEP 1 | Log in to the Support portal and selectAssets > Licensing API and click Enable. The key is
displayed.

Only a Super User can view the Enable link to generate this key. See How to Enable,
Regenerate, Extend the Licensing API Key.

STEP 2 | Select the key and copy it.
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STEP 3 | From the CLI, SSH in to Panorama and issue the following command, replacing <key> with
the API key you copied from the support portal:

request license api-key set key <key>

API Key is successfully set

Configure the Panorama Plugin for GCP to Secure an Auto Scaling Deployment

In Panorama, create assets to support the auto scaling firewall deployment.

STEP 1 | Create a template, and a template stack that includes the template, and Commit the changes.

STEP 2 | In the Network context, select either the template or the template stack. Select Virtual
Routers and Add a virtual router.

When the firewall template creates stac routes, they are added to this virtual router.

Define only one router for the auto scale deployment.
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STEP 3 | In the Network context, select the template you created, select Interfaces and Add Interface.

• On the Config tab, select a slot, select the Interface name and select the Layer3 Interface
Type. From the Security Zone menu, select New Zone, name the zone Untrust and click OK.

• On the IPv4 tab enable DHCP Client and Automacally create default route poinng to
default gateway provided by server (enabled by default) and click OK.

STEP 4 | Add the ethernet1/2 (Trust) Layer 3 interface.

• On the Config tab, chose the same slot as the previous step, select the Interface name
(ethernet1/2), and select the Layer3 Interface Type. From the Security Zone menu, select
New Zone name the zone Trust and click OK.

• On the IPv4 tab enable DHCP Client, disable Automacally create default route poinng to
default gateway provided by server and click OK.
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STEP 5 | Return to your template stack and the virtual router you created earlier. Place the untrust
and trust interfaces (ethernet1/1 and ethernet1/2) in the virtual router, and click OK.

STEP 6 | Configure Stackdriver for your auto scaling deployment.

You must have the VM-Series plugin on Panorama to configure Stackdriver.

1. In the Device context, select the template stack you created earlier from the Template
drop menu.

2. Select Device > VM-Series > Google and click the Edit cog (  ). Enable Publish PAN-OS
metrics to Stackdriver.

3. Commit your changes.
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STEP 7 | Create a Device Group that references the template or template stack you created in step 1.
This Device Group will contain the VM-Series firewalls you create with the firewall template.

1. Add a security policy that allows web-browsing traffic from Untrust to Trust.

In the Policies context, select the Device Group you just created. Select Security > Pre
Rules and Add the following security policy.

STEP 8 | Set up the GCP service account for the host project.
1. In the Panorama context, expand Google Cloud Plaorm, select Setup, and click Add.
2. Supply a name and descripon for the host service account you created in Step 4.
3. Upload the JSON credenals file you created in Step 4.4.

Aer you add a service account credenal, you can validate the credenal from your
Panorama command line (you cannot validate from the web interface):

request plugins gcp validate-service-account
 gcp_service_account <svc-acct-credential-name>
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STEP 9 | Set up auto scaling on the Panorama plugin for GCP.
1. In the Panorama context, expand Google Cloud Plaorm, select AutoScaling, and click

Add.
2. Supply the Firewall Deployment Name and an oponal descripon for the deployment.
3. For the GCP Service Account Credenal, supply the GCP service account name from

Step 8.

4. Chose the Device Group you created in Step 7, and the Template Stack you created in
Step 1.

5. Disable License Management Only to ensure traffic is secured.

STEP 10 | Commit your changes.

Prepare a VM-Series Firewall Bootstrap Package for Auto Scaling

During bootstrap, the inial request from the firewall provides the host IP address and serial
number, and the VM auth key so Panorama can validate the VM auth key and add the firewall
as a managed device. Panorama can then assign the firewall to the appropriate device group and
template so that you can centrally configure and administer the firewall using Panorama.

In this case, you must generate a VM auth key on Panorama and include the key in the init-cfg.txt
file that you use for bootstrapping. The VM auth key allows Panorama to authencate the newly
bootstrapped VM-Series firewall. The bootstrap package must include.

• In the /config directory, an init-cfg.txt file that includes the Panorama IP address
• In the /license directory, the VM authencaon key in a file named authcodes.

The lifeme of the key can vary between 1 hour and 8760 hours (1 year). Aer the specified
me, the key expires and Panorama will not register VM-Series firewalls without a valid auth-
key in this connecon request.

STEP 1 | Set up a Google storage bucket with the folders required to Bootstrap the VM-Series Firewall
on Google Cloud Plaorm. You can use an exisng bootstrap package or create a new
bootstrap package, for these folders.

STEP 2 | Edit the values in the sample init-cfg.txt file to customize the file for your environment.

The firewall templates include a sample init-cfg.txt file.

Parameter Value Comment

type dhcp-client  

VM-Series Deployment Guide Version Version 10.1 777 ©2022 Palo Alto Networks, Inc.

https://cloud.google.com/storage/docs/creating-buckets
https://docs.paloaltonetworks.com/vm-series/9-1/vm-series-deployment/bootstrap-the-vm-series-firewall/bootstrap-the-vm-series-firewall-on-google.html
https://docs.paloaltonetworks.com/vm-series/9-1/vm-series-deployment/bootstrap-the-vm-series-firewall/bootstrap-the-vm-series-firewall-on-google.html


Set Up the VM-Series Firewall on Google Cloud Plaorm

Parameter Value Comment

hostname <pa-vm> Oponal name you assigned
when you prepared the host
project. Only required if a
specific host is necessary, and
dhcp-send-hostname is no.

vm-auth-key <vmauthkey> A key that Panorama must
validate before adding a
firewall as a managed device.
See Generate the VM Auth
Key On Panorama.

panorama-server <panorama-ip> The IP address of the
Panorama management
device you configured in
Configure the Panorama
Plugin for GCP to Secure an
Auto Scaling Deployment

tplname <template-stack-name> The template stack you
created in Configure the
Panorama Plugin for GCP
to Secure an Auto Scaling
Deployment.

dgname <dg-name> The name of the Device
Group you created in the
Panorama Plugin for GCP.

dns-primary Your primary DNS server.

dns-secondary Your secondary DNS server.

dhcp-send-hostname yes Leave as is.

dhcp-send-client-id yes Leave as is.

dhcp-accept-server-hostname yes Leave as is.

dhcp-accept-server-domain yes Leave as is.

STEP 3 | Upload your edited init-cfg.txt file to the /config folder in your bootstrap package.

STEP 4 | If you are using BYOL, create a text file named authcodes (no extension), add your auth
code, and upload the file to the /license folder.
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Deploy GCP Auto Scaling Templates
• About the Auto Scaling Templates
• Deploy the Firewall Template
• Prepare a Service Project
• Configure the Shared VPC
• Deploy the Applicaon Template
• Onboard a New Applicaon
• Sample GKE Service Templates

About the Auto Scaling Templates
Download the Palo Alto Networks auto scaling templates from hps://github.com/
PaloAltoNetworks/GCP-AutoScaling. The zip file contains separate zips for firewall and applicaon
templates. Each zip is a template directory containing several files, but you only need to edit the
YAML files.

• Firewall Templates
• Applicaon Template

Firewall Templates

The firewall directory files create VM-Series firewalls and other deployment resources. They
create new networks and the familiar subnetworks for the VM-Series firewall: management,
untrust, and trust. They also deploy a Cloud Pub/Sub messaging service to relay informaon from
GCP to the Panorama plugin for GCP. With this infrastructure in place, the plugin can leverage
dynamic address groups to apply security policy on inbound traffic routed to services running
on GCP, and use auto scale metrics to deploy VM-Series firewalls to meet increased demand for
applicaon workload resources or to eliminate firewalls that are no longer needed.

To configure your load balancer, edit the .yaml file for an external applicaon load balancer (ALB)
or network load balancer (NLB).

• ALB (HTTP External Load Balancer)

To customize an ALB, edit vm-series-fw-alb.yaml.

HTTP external load balancer is a proxy-based load balancer that performs SNAT and DNAT on
the inbound traffic from Internet. The HTTP load balancer is designed to support only the 80
and 8080 TCP ports.

To support mulple applicaons using HTTP load balancer in load balancer sandwich
architecture, we can use the GCP HTTP load balancer urlMap and namedPort to map different
URLs to different ports in the load balancer. In turn, the VM-Series firewall can translate the
ports to different applicaons, each represented by one internal load balancer per applicaon.
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• NLB (TCP Load Balancer)

To customize an NLB, edit vm-series-fw-nlb.yaml.

TCP load balancer is a non-proxy based load balancer, which means it doesn't perform NATing
on inbound traffic from the Internet.

TCP load balancer in GCP allows adding mulple frontend IP addresses with an arbitrary port,
making it possible to support mulple applicaons.

Another advantage of TCP load balancer is that the original client IP address is preserved,
which is desirable for some applicaons.

Application Template

The applicaon directory provides a sample applicaon. You configure and deploy an internal
load balancer (ILB) to enable your applicaon servers to subscribe to the Pub/Sub service and
communicate with your VM-Series firewalls and the GCP plugin on Panorama.

To customize the applicaon template, edit apps.yaml as described in Deploy the Firewall
Template and Applicaon Template.

Deploy the Firewall Template
Edit the Firewall Templates from the host project.

All VM-Series firewall interfaces must be assigned an IPv4 address when deployed in a
public cloud environment. IPv6 addresses are not supported.

STEP 1 | Edit the vm-series-fw-nlb.yaml or vm-series-fw-alb.yaml environment variables
to reflect your cloud environment.

The sample in this workflow is for the NLB. See vm-series-fw-nlb.yaml and vm-series-fw-
alb.yaml for further explanaon of the template parameters.

properties:
    region: us-east1
    zones:
    -us-east1-b
    # Do not modify the lb-type field.
    lb-type: nlb
    cloud-nat: yes
    forwarding-rule-port: 80

# Only one app is allowed
    urlPath-namedPort-maps:
    - appName: app1

# ssh key PUBLIC:
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    - optional

The autoscaling firewall template requires you to enter the value in single quotes and prepend
the key with admin: followed by a space. This is the same convenon used for the Google
Marketplace template, as detailed in SSH Key Pair. For example:

    bootstrap-bucket: bootstrap-autoscale

    image: vmseries-byol-814
    machine-type: n1-standard-4

For the service-account, supply the email address for the host project service account you
created earlier (step 3).

     service-account: sa-pan@gcp-autoscale-
kk.iam.gserviceaccount.com

The fw-instance-tag value will be the managed instance group name in the deployment.

     fw-instance-tag: vm-series-fw

Choose one metric for auto scaling. Possible values are: panSessionAcve,
panSessionUlizaon, DataPlaneCPUUlizaonPct, DataPlanePacketBufferUlizaon, or
panSessionUlizaon.

metric: custom.googleapis.com/VMSeries/panSessionActive

max-size: 2
min-size: 1
target-type: GAUGE
util-target: 100 

# Greenfield deployment
mgmt-network-cidr: 172.22.2.0/24
untrust-network-cidr: 172.22.1.0/24
trust-network-cidr: 172.22.3.0/24
mgmt-network-access-source-range:
- 199.167.54.229/32
- 199.167.52.5/32
mgmt-network-access-ports:
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- 22
- 443

STEP 2 | Deploy the firewall template.

gcloud deployment-manager deployments create <your-template> 
--config apps.yaml
--automatic-rollback-on-error

Take note of the outputs the CLI prints aer the deployment—the subnet names, the
deployment name, and the Panorama Pub/Sub topic name. You need these values to configure
the Shared VPC and for the applicaon template deployment.

The firewall deployment name must be configured in the Panorama plugin for GCP auto scaling
definion.

Prepare a Service Project
Create a separate service project, or choose an exisng project, for your applicaon.

To learn more about host and service projects in a shared VPC, see the Shared VPC Overview, and
review the Administrators and IAM roles. A host project administrator must have the proper role
to set up the Shared VPC and make the applicaon project a service project for the host project.
See the instrucons in Provisioning Shared VPC.

STEP 1 | Enable the service project APIs from the GCP console or the CLI.

The required APIs are:

Cloud Deployment Manager API
Cloud Pub/Sub API
Compute Engine API

Enable APIs from the GCP console

1. Select the service project, and from the Navigaon menu, select APIs & Services.
2. Search for and view each required API.
3. ENABLE any APIs that do not display the “API enabled” status.

Enable APIs from the CLI

1. In the CLI, view your configuraon to ensure that you are in the correct project.

gcloud config list

If not, set the project as follows:

gcloud config set project <project-name>

2. Issue the following commands to enable the required APIs.

gcloud services enable deploymentmanager.googleapis.com
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gcloud services enable pubsub.googleapis.com
gcloud services enable compute.googleapis.com

3. Confirm that the required APIs are enabled.

gcloud services list --enabled

STEP 2 | Make the applicaon project a service project for the host project.

Add the service account from Service/applicaon project administrator as a member in host
project with following roles:

• Compute Network User
• Pub/Sub Admin

STEP 3 | Choose a VPC configuraon.

• If the Service project will share the networks in the host project, connue to Configure the
Shared VPC.

• If the Service project has its own VPC network for the applicaon deployment, connue to
Configure a Peered VPC.

Configure the Shared VPC
Aer the firewall template is deployed in the host project, configure the service project that
supports your applicaons. An administrator with shared VPC credenals performs these tasks
from the host project. To understand more about the host project and service projects in the
context of shared VPC, see the Shared VPC Overview.

STEP 1 | Create a shared VPC using the Trust VPC created when you deployed the firewall template.

Set up a shared VPC for the host (firewall) project:

gcloud compute shared-vpc enable HOST_PROJECT_ID

STEP 2 | Aach the service/applicaon project to the host project.
gcloud compute shared-vpc associated-projects add
[SERVICE_PROJECT_ID]--host-project [HOST_PROJECT_ID]

Addional opons are available to share only specific subnets, rather than all subnets in the
host project.

STEP 3 | If you want to use the sample applicaon template to deploy an applicaon, connue to
Deploy the Applicaon Template.

If you have already deployed an applicaon and you want to secure it in your auto scaling
deployment, go to Manually Onboard an Applicaon to an Exisng Auto Scaling Deployment.

If you have deployed a service in a GKE cluster, connue to Onboard a GKE Cluster in a Shared
VPC.
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Configure a Peered VPC
A VPC network peering connecon must be made between two VPCs. If the VPCs are in two
different projects, a connecon must be created in both projects.

STEP 1 | In the host project, peer the Trust VPC network of the Firewall deployment with the
Applicaon VPC.

gcloud beta compute networks peerings create [PEERING-NAME] \
    --network=[MY-LOCAL-NETWORK] \
    --peer-project [SERVICE-PROJECT-ID] \
    --peer-network [PEER-NETWORK-NAME] \
   [--import-custom-routes] \
   [--export-custom-routes]

STEP 2 | In the service project, peer the Trust VPC network of the applicaon deployment with the
Trust VPC network of the Firewall deployment.

gcloud beta compute networks peerings create [PEERING-NAME] \
    --network=[MY-LOCAL-NETWORK] \
    --peer-project [HOST-PROJECT-ID] \
    --peer-network [PEER-NETWORK-NAME] \
   [--import-custom-routes] \
    [--export-custom-routes]

STEP 3 | If you want to use the sample applicaon template to deploy an applicaon, connue to
Deploy the Applicaon Template.

If you have already deployed an applicaon and you want to secure it in your auto scaling
deployment, go to Manually Onboard an Applicaon to an Exisng Auto Scaling Deployment.

If you have deployed a service in a GKE cluster, connue to Onboard a GKE Cluster in a Peered
VPC.

Deploy the Applicaon Template
The Service project administrator deploys the Applicaon Template from the service project.

STEP 1 | Create a separate applicaon project (service project) to deploy the applicaon (see Prepare a
Service Project).

STEP 2 | Prepare the apps.yaml file as outlined in apps.yaml.

STEP 3 | Deploy a new applicaon with the applicaon template and define a label for the named
port.

gcloud deployment-manager deployments create <your-template>
--config apps.yaml
--automatic-rollback-on-error

Connue to View the Onboarded Applicaon in the Panorama Plugin for GCP.
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Onboard a New Applicaon
When you use the Applicaon Template to deploy an applicaon, it takes care of the connecon
to the host project. You can secure applicaons you did not deploy with the applicaon template,
provided they are deployed in a service project with the capabilies described in Prepare a Service
Project.

• Manually Onboard an Applicaon to an Exisng Auto Scaling Deployment
• Onboard a GKE Cluster

Manually Onboard an Application to an Existing Auto Scaling Deployment

To secure an applicaon you have deployed using an external load balancer and an auto-scaled
VM-Series firewall deployment, follow these steps. For each applicaon you onboard, you must
supply the applicaon name, the named ports, and the path.

STEP 1 | Prepare to add a new named port and URL path to the HTTP external load balancer created
when you deployed the firewall template.

STEP 2 | Update all instance groups named-ports with an addional service name and port values. The
following sample onboards the applicaons app2 and app3.

gcloud compute instance-groups set-named-ports
fw-template2-fw-igm-us-east1-b 
--zone us-east1-b 
--named-ports=app1:80,app2:81,app3:82

gcloud compute instance-groups set-named-ports
fw-template2-fw-igm-us-east1-c 
--zone us-east1-c 
--named-ports=app1:80,app2:81,app3:82

STEP 3 | Create a new hp-health-check.

gcloud compute backend-services create fw-template2-backend-app3
--protocol="HTTP" 
--port-name=app3 
--http-health-checks=fw-template2-healthcheck-app3
--load-balancing-scheme="EXTERNAL" 
--global

STEP 4 | Create a new backend service with the port-name created earlier on the HTTP external load
balancer.

gcloud compute backend-services create fw-template2-backend-app3
--protocol="HTTP" --port-name=app3 
--http-health-checks=fw-template2-healthcheck-app3 --load-
balancing-scheme="EXTERNAL" 
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--global 

Check to see if the new backend service is visible.

gcloud compute backend-services list

STEP 5 | Edit url-maps and add new path rule. For example:

- paths:
    - /app3
    - /app3/*service: 
    https://www.googleapis.com/compute/v1/projects/<project-name>/
global/backendServices/fw-template2-backend-app3

gcloud compute url-maps edit fw-template2-ext-loadbalancer

STEP 6 | To secure this applicaon with the VM-Series firewall, manually trigger the pub/sub message
through the gcloud CLI. This sends a message to the topic created in the firewall template.

gcloud pubsub topics publish
  projects/topics/hj-asg-891ca3-gcp-pavmqa-panorama-apps-
deployment 
  --attribute ilb-ip=172.22.9.34,
    app-deployment-name=hj-asg-891ca3-app1,
    ilb-port=80,
    named-port=81,
    network-cidr=172.22.9.0/24,
    fw-deployment-name=hj-asg-891ca3,
    host-project=gcp-pavmqa,
    type=ADD-APP 
  --message "ADD-APP"

STEP 7 | View the Onboarded Applicaon in the Panorama Plugin for GCP.

STEP 8 | (Oponal) To update applicaon aributes, such as ilb-ip, ilb-port, or named-port, issue the
pubsub command:

gcloud pubsub topics publish projects/gcp-pavmqa/topics/hj-
asg-891ca3-gcp-pavmqa-panorama-apps-deployment
  --attribute ilb-ip=172.22.9.34,
    app-deployment-name=hj-asg-891ca3-app1,
    ilb-port=80,
    named-port=81,
    network-cidr=172.22.9.0/24,
    fw-deployment-name=hj-asg-891ca3,
    host-project=gcp-pavmqa,
    type=UPDATE-APP 
  --message "UPDATE-APP"
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STEP 9 | (Oponal) To stop securing the applicaon, issue the following command:

gcloud pubsub topics publish projects/gcp-pavmqa/topics/hj-
asg-891ca3-gcp-pavmqa-panorama-apps-deployment
  --attribute ilb-ip=172.22.3.20,app-deployment-name=fw-templ-3-
app-1,
    ilb-port=80,
    named-port=80,
    fw-deployment-name=hj-asg-891ca3,
    type=DEL-APP
  --message "DEL-APP"

Onboard a GKE Cluster

To onboard a private GKE cluster, the GCP plugin for Panorama requires the following informaon.

• In GCP, expose the ELB frontend for the cluster to the GKE service so the VM-Series firewall
can get the named port informaon for the service.

• The cluster API server address.
• The service account credenal for the service in which the cluster is deployed, in JSON format.

The GKE cluster name must not exceed 24 characters. This ensures that if you deploy
auto scaling in a peered VPC configuraon the stac route name does not exceed 31
characters.

• Onboard a GKE Cluster in a Shared VPC
• Onboard a GKE Cluster in a Peered VPC
• View the Onboarded Applicaon in the Panorama Plugin for GCP
• View the Deployment Status from the CLI

Onboard a GKE Cluster in a Shared VPC

To onboard the GKE cluster you must share the Host project Trust network VPC with the Service
project. See Configure the Shared VPC.

For security reasons, only private clusters should be used in an auto scaling deployment.
See Creang a private cluster.

STEP 1 | Set the Host project ID.

gcloud config set project [HOST_PROJECT_ID]
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STEP 2 | (oponal) Set compute zone or region for clusters.

If the cluster is zonal, enter the following:

gcloud config set compute/zone [COMPUTE_ZONE]

If the cluster is regional, enter the following:

gcloud config set compute/region [COMPUTE_REGION]

STEP 3 | In the Host project, update secondary ranges in the Trust VPC subnet.

gcloud compute networks subnets update [TRUST_SUBNETWORK_NAME]
  --add-secondary-ranges 
  [PODS_IP_RANGE_NAME] = [POD_RANGE_CIDR],
  [SERVICE_IP_RANGE_NAME]=[SERVICE_RANGE_CIDR]

Pods and service IP ranges must be within: 10.0.0.0/8, 172.16.0.0/12 or
192.168.0.0/16, and cannot collide with exisng IP ranges in the subnetwork.

STEP 4 | In the Service project, create a private cluster in the shared VPC.
1. Set the Service project ID.

gcloud config set project [SERVicE_PROJECT_ID]

2. Create a private cluster in the shared VPC.

gcloud container clusters create  [CLUSTER_NAME] 
  --project [SERVICE_PROJECT_ID]
  --zone=[ZONE_NAME]
  --enable-ip-alias
  --enable-private-nodes
  --network projects/[HOST_PROJECT_ID]/global/networks/
[NETWORK_NAME]
  --subnetwork projects/[HOST_PROJECT_ID]/regions/
[REGION_NAME]
  /subnetworks/[TRUST_SUBNETWORK_NAME] 
  --cluster-secondary-range-name=[PODS_IP_RANGE_NAME] 
  --services-secondary-range-name=[SERVICE_IP_RANGE_NAME] 
  --master-ipv4-cidr=[MASTER_IPV4_CIDR]
  --enable-master-authorized-networks
  --master-authorized-networks=[PANORAMA_MANAGEMENT_IP/32],
  [MY_MANAGEMENT_IP/32]

STEP 5 | Check your current cluster context:

kubectl config current-context
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STEP 6 | Check all cluster contexts.

kubectl config get-context

STEP 7 | Change to another cluster.

kubectl config use-context [CONTEXT_NAME]

If you created your cluster in the GCP console, generate a kubeconfig entry:

gcloud container clusters get-credentials [CLUSTER_NAME]

STEP 8 | Create a cluster role in a .yaml file—for example, gke_cluster_role.yaml.

apiVersion: rbac.authorization.k8s.io/v1beta1
kind: ClusterRole
metadata:
  name: gke-plugin-role
rules:
  - apiGroups:
      - ""
    resources:
      - services
    verbs:
      - list

STEP 9 | Apply the cluster role.

kubectl apply -f gke_cluster_role.yaml

STEP 10 | Create a cluster role binding in a .yaml file—for example,
gke_cluster_role_binding.yaml.

kind: ClusterRoleBinding
apiVersion: rbac.authorization.k8s.io/v1beta1
metadata:
  name: gke-plugin-role-binding
subjects:
  - kind: ServiceAccount
    name: [SERVICEACCOUNT_NAME]
    namespace: default
roleRef:
  kind: ClusterRole
  name: gke-plugin-role
  apiGroup: rbac.authorization.k8s.io
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STEP 11 | Apply the cluster role binding.

kubectl apply -f gke_cluster_role_binding.yaml

STEP 12 | Create a service account.

kubectl create serviceaccount [SERVICEACCOUNT_NAME]

STEP 13 | Export the service account secret token in JSON format.

MY_TOKEN=`kubectl get serviceaccounts [SERVICEACCOUNT_NAME] 
-o jsonpath='{.secrets[0].name}'`

kubectl get secret $MY_TOKEN -o json > [FILE_NAME].json

STEP 14 | Get the API server address.

kubectl config view --minify | grep server | cut -f 2- -d ":" | tr
 -d " "

STEP 15 | In the Panorama plugin for GCP, add the service account informaon.

Select Panorama > Google Cloud Plaorm > Setup.

Name the credenal, enter a descripon, and enter the API server address from step 14, and
for GKE Service Account Credenal, upload the JSON file you exported in step 13.

Aer you add a service account credenal, you can validate the credenal from your Panorama
command line (you cannot validate from the web interface):

request plugins gcp validate-service-account gke_service_account
 <svc-acct-credential-name>

STEP 16 | Set up auto scaling on the Panorama plugin for GCP.
1. In the Panorama context, expand Google Cloud Plaorm, select AutoScaling, and click

Add.
2. Supply the Firewall Deployment Name and an oponal descripon for the deployment.
3. For the GCP Service Account Credenal, supply the GCP service account name created

in Prepare a Host Project and Required Service Accounts, step 4.
4. Chose the Device Group and the Template Stack you created in when you configured the

Panorama plugin.
5. Disable License Management Only to ensure traffic is secured.
6. Enter the exact GKE Cluster Name.
7. (Oponal) Enter a Descripon of the GKE cluster.
8. Enter the Network CIDR for the GKE cluster.
9. Select the GKE Service Account corresponding to the GKE cluster.

VM-Series Deployment Guide Version Version 10.1 790 ©2022 Palo Alto Networks, Inc.



Set Up the VM-Series Firewall on Google Cloud Plaorm

STEP 17 | Commit your changes.

STEP 18 | (Oponal) Create and deploy a service template according to Using the Sample GKE Service
Templates, or deploy a GKE service in the GCP console. .

Onboard a GKE Cluster in a Peered VPC

To onboard the GKE cluster you must create and peer the Service VPC with the firewall Trust
network in the Host project, as described in Configure a Peered VPC.

For security reasons, only private clusters should be used in an auto scaling deployment.
See Creang a private cluster.

STEP 1 | Set the project ID.

gcloud config set project [PROJECT_ID]

STEP 2 | Set compute zone or region for clusters.

If the cluster is zonal, enter the following:

gcloud config set compute/zone [COMPUTE_ZONE]

If the cluster is regional, enter the following:

gcloud config set compute/region [COMPUTE_REGION]

STEP 3 | Update the service project VPC network with the secondary IP ranges for the pods and
services.

gcloud compute networks subnets update [GKE_PEERED_VPC_SUBNETWORK]
--region=[REGION] 
--add-secondary-ranges PODS_IP_RANGE_NAME=[ip cidr],
  SERVICE_IP_RANGE_NAME=[ip cidr]

STEP 4 | Enable cloud NAT.

Cloud NAT is required to deploy a private cluster.

gcloud compute routers create [ROUTER_NAME]
  --network [NETWORK_NAME] 
  --region [REGION_NAME]

gcloud compute routers nats create [NAT_CONFIG_NAME]
  --router-region [REGION_NAME] 
  --router [ROUTER_NAME] 
  --nat-all-subnet-ip-ranges 
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  --auto-allocate-nat-external-ip

STEP 5 | Create a new private cluster in the Service VPC.

gcloud container clusters create [CLUSTER_NAME] 
  --project [SERVICE_PROJECT_ID]
  --zone=[ZONE_NAME]
  --enable-ip-alias
  --network [NETWORK_NAME]
  --subnetwork [SUBNETWORK_NAME]
  --enable-private-nodes
  --cluster-secondary-range-name=[PODS_IP_RANGE_NAME]
  --services-secondary-range-name=[SERVICE_IP_RANGE_NAME]
  --master-ipv4-cidr=[MASTER_IPV4_CIDR]
  --enable-master-authorized-networks
  --master-authorized-networks=[PANORAMA_MANAGEMENT_IP/32],
  [MY_MANAGEMENT_IP/32]

STEP 6 | Check your current cluster context:

kubectl config current-context

STEP 7 | Check all cluster contexts.

kubectl config get-context

STEP 8 | Change to another cluster.

kubectl config use-context [CONTEXT_NAME]

If you created your cluster in the GCP console, generate a kubeconfig entry:

gcloud container clusters get-credentials [CLUSTER_NAME]

STEP 9 | Create a cluster role in a .yaml file—for example, gke_cluster_role.yaml.

apiVersion: rbac.authorization.k8s.io/v1beta1
kind: ClusterRole
metadata:
  name: gke-plugin-role
rules:
  - apiGroups:
      - ""
    resources:
      - services
    verbs:
      - list
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STEP 10 | Apply the cluster role.

kubectl apply -f gke_cluster_role.yaml

STEP 11 | Create a cluster role binding in a .yaml file—for example,
gke_cluster_role_binding.yaml.

kind: ClusterRoleBinding
apiVersion: rbac.authorization.k8s.io/v1beta1
metadata:
  name: gke-plugin-role-binding
subjects:
  - kind: ServiceAccount
    name: [SERVICEACCOUNT_NAME]
    namespace: default
roleRef:
  kind: ClusterRole
  name: gke-plugin-role
  apiGroup: rbac.authorization.k8s.io

STEP 12 | Apply the cluster role binding.

kubectl apply -f gke_cluster_role_binding.yaml

STEP 13 | Create a service account.

kubectl create serviceaccount [SERVICEACCOUNT_NAME]

STEP 14 | Export the service account secret token in JSON format.

MY_TOKEN=`kubectl get serviceaccounts [SERVICEACCOUNT_NAME] 
-o jsonpath='{.secrets[0].name}'`

kubectl get secret $MY_TOKEN -o json >[FILE_NAME].json

STEP 15 | Get the API server address.

kubectl config view --minify | grep server | cut -f 2- -d ":" | tr
 -d " "
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STEP 16 | In the Panorama plugin for GCP, add the service account informaon.

Select Panorama > Google Cloud Plaorm > Setup.

Name the credenal and enter the API server address from Step 15, and upload the JSON file
you exported in Step 14.

Aer you add a service account credenal, you can validate the credenal from your Panorama
command line:

request plugins gcp validate-service-account <svc-acct-credential-
name>

STEP 17 | Set up auto scaling on the Panorama plugin for GCP.
1. In the Panorama context, expand Google Cloud Plaorm, select AutoScaling, and click

Add.
2. Supply the Firewall Deployment Name and an oponal descripon for the deployment.
3. For the GCP Service Account Credenal, supply the GCP service account name from

Step 16.
4. Chose the Device Group and the Template Stack you created in when you configured the

Panorama plugin.
5. Disable License Management Only to ensure traffic is secured.
6. Enter the exact GKE Cluster Name.
7. (Oponal) Enter a Descripon of the GKE cluster.
8. Enter the Network CIDR for the GKE cluster.
9. Select the GKE Service Account corresponding to the GKE cluster.

STEP 18 | (Oponal) In your service project, create and deploy a GKE template according to Using the
Sample GKE Service Templates, or deploy a GKE service use the GCP console. Onboard a
GKE Cluster

View the Onboarded Application in the Panorama Plugin for GCP

Select Panorama > Google Cloud Plaorm > Autoscaling to view your onboarded applicaon. The
Details column is only visible if you have an onboarded applicaon.

Each link in the Details column triggers an acon.
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• Show Status— View the details for applicaons onboarded to a GCP VM-Series firewall
deployment.

The following fields display informaon obtained from the selected deployment. You specified
these values in the pub/sub message or through GKE cluster service polling.

• Applicaon/GKE Service Name—An applicaon deployment name, or the name of a GKE
service.

• Host Project—The name of the host project.
• Cluster/Namespace—A GKE cluster name followed by the namespace for example,

mycluster/namespace9.

• Named Port—The port assigned to the named port for the service.
• ILB IP—The ILB IP address.
• ILB Port—The ILB port number.

For autoscaling an applicaon, this property is ilb-port in apps.yaml.

For securing a GKE cluster, this value is the port number of the GKE cluster, as specified in
the .yaml file you used to deploy the service in your cluster.

• Configuraon Programmed— True if a NAT Rule exists, False if not.
• Protected— True when an applicaon is onboarded successfully, or False if onboarding

failed. If False, see the Not Protected Reason column for an explanaon.
• Not Protected Reason— If Protected is False, displays the reason the applicaon is not

protected. Some common reasons are:

• Configuraon Programmed—True if a NAT Rule exists, False if not.
• Protected—True when an applicaon is onboarded successfully, or False if onboarding

failed. If False, see the Not Protected Reason column for an explanaon.
• Not Protected Reason—If Protected is False, displays the reason the applicaon is not

protected. Some common reasons are:

• You deployed a UDP service in the GKE cluster.
• You specified a named port that is already in use. Only one applicaon can listen on a

specific named port.
• You chose the License management only opon, so we do not program the

configuraon.
• No matching label found for GKE services.

• Delicense Inacve VMs—Answer Yes to trigger the delicensing funcon for inacve VMs.
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• Trigger GKE Services Sync—Answer Yes to poll the services running in the clusters, and
program the NAT, address, and service objects, and stac routes if necessary. By default,
Panorama automacally polls 10 minutes aer the compleon of the previous poll.

View the Deployment Status from the CLI

You can use the Panorama CLI to manage deployed applicaons. The command line acons
parallel those described in View the Onboarded Applicaon in the Panorama Plugin for GCP. In
the following commands, the autoscaling_name is the Firewall Deployment Name you entered
in the auto scaling configuraon.

• List the onboarded (protected) applicaons.

show plugins gcp show-protected-apps autoscaling_name <fw-
deployment-name>

• Trigger the delicensing funcon for firewalls in the specified deployment.

request plugins gcp force-delicensing autoscaling_name <fw-
deployment-name>

• For a GKE deployment, force the plugin to read the pub-sub messages, and sync NAT rules that
are programmed based on the pub-sub messages.

request plugins gcp gke-service-discovery autoscaling_name <fw-
deployment-name>

Parameters in the Auto Scaling Templates for GCP
You can download the template .zip file from hps://github.com/PaloAltoNetworks/GCP-
AutoScaling. The .zip file contains directories to support firewall templates for network load
balancer and applicaon load balancer configuraons, and the applicaon template.

The template YAML files have the following general format:

#Copyright and license information
    :
    :
imports:                     <do not change>
    :
    :
resources:
    -name: vm-series-fw      <do not change>
    -type:vm-series-fw.py    <do not change
    -properties:
    :
    :
outputs:                     <do not change>
    :
    :

In all .yaml files, you customize the resources properes for your deployment. Do not change
anything in the imports or outputs secons.
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• Firewall Templates
• Applicaon Template

Firewall Templates

The following secons detail the parameters for the NLB and ALB .yaml files.

• vm-series-fw-nlb.yaml
• vm-series-fw-alb.yaml

vm-series-fw-nlb.yaml

In the vm-series-fw-nlb.yaml template, edit the -properties.

Parameter Sample Value Comment

region us-central1 hps://cloud.google.com/
compute/docs/regions-zones

zones

- <list of zones>

zones- us-central1-a If applicable, list mulple
zones as follows:

zones- us-central1-a- us-
central1-b- us-central1-c- us-
central1-f

lb-type nlb Do not change.

cloud-nat yes Do not change.

forwarding-rule-port 80 80 or 8080

urlPath-namedPort-maps-
appname urlPath-namedPort-m

aps
-MyApplication

Enter your applicaon name.

sshkey 'admin:ssh-rsa <PASTE KEY>' Review SSH Key Pair. In
single quotes, type admin:
followed by a space, and
paste in your key. This is the
same convenon used for the
Google Marketplace template.

bootstrap-bucket bootstrap-autoscale The name of the GCP bucket
that contains your bootstrap
file.

image vm-series-byol-814 The BYOL image currently
available from the Google
marketplace.
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Parameter Sample Value Comment
If you are using PAYG or
another license model, the
image might be different.

machine-type n1-standard-4 n1-standard-4 is default for
BYOL.

If your license permits it,
you can use any machine
type in Minimum System
Requirements for the VM-
Series Firewall.

service-account The unique service account
name for the host project.

fw-instance-tag vm-series-fw The instance tag you provided
in GCP.

metric custom.googleapis.com/
VMSeries/panSessionAcve

The custom API path for VM-
Series, and your chosen auto
scaling metric.

Supply only one of the
following metrics.

panSessionActive
panSessionUtilizatio
n
DataPlaneCPUUtilizat
ionPct
DataPlanePacketBuffe
rUtilization
panSessionUtilizatio
n

max-size 2

min-size 1

target-type GAUGE Currently GAUGE is the only
valid type.

ul-target 100

To deploy the VM-Series firewall you need a dedicated network and subnetwork for the
firewall’s managment, untrust, and trust interfaces. Fill out the informaon for either a
greenfield deployment (configure the template to create new networks) or brownfield
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Parameter Sample Value Comment
deployment (use exisng networks). Be sure to remove or comment out the network
deployment parameters you are not using.

Greenfield Deployment: Enter values to create management, untrust, and trust networks and
subnetworks for the firewall.

mgmt-network-cidr 172.22.2.0/24

untrust-network-cidr 172.22.1.0/24

trust-network-cidr 172.22.3.0/24

mgmt-network-access-
source-range- <permied-ip-
range>

mgmt-network-access-source-range
- <permitted-ip-range-1>
- <permitted-ip-range-2>

mgmt-network-access-ports-
<port-number> mgmt-network-access

-ports
- 22
- 443

Brownfield Deployment: Enter the name of each exisng network or subnetwork

mgmt-network my-mgmt-network

mgmt-subnet my-mgmt-subnet

trust-network my-trust-network

trust-subnet my-trust-subnet

untrust-network my-untrust-network

untrust-subnet my-untrust-subnet

vm-series-fw-alb.yaml

In the vm-series-fw-alb.yaml template, edit the -properties.

Parameter Sample Value Comment

region us-central1 hps://cloud.google.com/
compute/docs/regions-zones

zones zones- us-central1-a If applicable, list mulple zones
as follows:
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Parameter Sample Value Comment
- <list of zones> zones- us-central1-a- us-

central1-b- us-central1-c- us-
central1-f

lb-type alb Do not change.

cloud-nat yes Do not change.

forwarding-rule-port 80 80

connecon-draining-meout 300 The meout value in seconds.

urlPath-namedPort-m
aps:
- appname:
  namedPort:
  urlMapPaths:
  - '/app1'
  - '/app1/*'

urlPath-namedPort-m
aps: 
- appName: app1
  namedPort: 80    
urlMapPaths:
  - '/app1'
  - '/app1/*'
- appName: app2
  namedPort: 81
  urlMapPaths:
  - '/app2'
  - '/app2/*'

List your apps and the
corresponding named port

sshkey 'admin:ssh-rsa <PASTE KEY>' Review SSH Key Pair. In
single quotes, type admin:
followed by a space, and paste
in your key. This is the same
convenon used for the Google
Marketplace template.

bootstrap-bucket bootstrap-bucket-name The name of the GCP bucket
that contains your bootstrap
file.

image vm-series-byol-814 The BYOL image currently
available from the Google
marketplace.

If you are using PAYG or
another license model, the
image might be different

machine-type n1-standard-4 n1-standard-4 is default for
BYOL.

If your license permits it, you
can use any machine type in
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Parameter Sample Value Comment
Minimum System Requirements
for the VM-Series Firewall.

service-account The unique service account name for the service project.

fw-instance-tag vm-series-fw The instance tag you provided
in GCP.

metric custom.googleapis.com/
VMSeries/panSessionAcve

The custom API path for VM-
Series, and your chosen auto
scaling metric.

Supply only one of the
following metrics.

panSessionActive
panSessionUtilization
DataPlaneCPUUtilizati
onPct
DataPlanePacketBuffer
Utilization
panSessionUtilization

max-size 2

min-size 1

target-type GAUGE Currently GAUGE is the only
valid type.

ul-target 100 Enter the goal ulizaon target
value for the auto scaling.

Greenfield Deployment: Enter values to create management, untrust, and trust networks and
subnetworks for the firewall.

mgmt-network-cidr 192.168.12.0/24

untrust-network-cidr 192.168.11.0/24

trust-network-cidr 192.168.11.0/24

mgmt-network-access-
source-range- <permied-
ip-range>

mgmt-network-access-source-range- <permitted-
ip-range-1>- <permitted-ip-range-2>

mgmt-network-access-
ports- <port-number>

mgmt-network-access-
ports- 22- 443
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Parameter Sample Value Comment

Brownfield Deployment: Enter the name of each exisng network or subnetwork

mgmt-network exisng-vpc-mgmt

mgmt-subnet exisng-subnet-mgmt

trust-network exisng-vpc-trust

trust-subnet exisng-subnet-trust

untrust-network exisng-vpc-untrust

untrust-subnet exisng-subnet-untrust

Application Template
apps.yaml

The applicaon template creates the connecon between the host project (which contains the
VM-Series firewalls) and the service project, which contains the applicaon or services that the
firewall deployment secures.

Parameter Sample Value Comment

host-project your-host-project-name The name of the project
containing the VM-Series
firewall deployment.

fw-deployment-
name

my-vm-series-firewall-name

region us-central1 hps://cloud.google.com/
compute/docs/regions-zones

zones

- <list of zones>

zones- us-central1-a If applicable, list mulple
zones as follows:

zones- us-central1-a
-
us-central1-b-
us-central1-c-
us-central1-f

app-machine-type n1-standard-2 The machine type for the VM
running your applicaon or
service. If your license permits
it, you can use any machine
type in Minimum System
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Parameter Sample Value Comment
Requirements for the VM-
Series Firewall.

app-instance-tag web-app-vm You applied this tag (label) in
GCP.

sshkey 'admin:ssh-rsa <PASTE KEY>' Review SSH Key Pair. In
single quotes, type admin:
followed by a space, and
paste in your key. This is the
same convenon used for the
Google Marketplace template.

trust-network <project-name>/<vpc-network-
name>

For a shared VPC, the
<project-name> is the host
project name.

For peered VPCs the <project-
name> is the Service project
name.

trust-subnet <project-name>/<subnet-name> For a shared VPC, the
<project-name> is the host
project name.

For peered VPCs the <project-
name> is the Service project
name.

trust-subnet-cidr 10.2.0.0/24 For a greenfield deployment,
the Host project Trust subnet
CIDR (the trust-network-
cidr parameter in the firewall
template).

For a brownfield deployment,
the CIDR for the Trust
network.

vm-series-fw-
template-topic

<pubsub-topic> Enter the topic name created
by the firewall deployment.
The applicaon template
posts a message to the
topic to program the firewall
configuraon to forward
traffic.
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Parameter Sample Value Comment

ilb-port 80 Enter the port number for
your applicaon’s internal-
load-balancer-port. output.

urlPath-namedPort 83 Enter the port number for the
urlPath-namedPort output.

Sample GKE Service Templates
These sample templates demonstrate how to configure a GKE service so it is secured by the VM-
Series firewall. For the basics on creang your own cluster services, see Creang a private cluster.

• Using the Sample GKE Service Templates
• gke_cluster_role.yaml
• gke_cluster_role_binding.yaml
• web-deployment.yaml
• web-service.yaml
• web-deployment-v2.yaml
• web-service-v2.yaml
• Mulple Ports in a Service

Using the Sample GKE Service Templates

You can create a service template based on the sample content in the .yaml files that follow.
Typically you create a single .yaml file.

To be secured by the VM-Series firewall, services in the cluster must be labeled "panw-named-
port=<named_port>" as shown in web-service.yaml or web-service-v2.yaml.

1. Deploy a .yaml file as follows:

kubectl apply -f [FILE_NAME].yaml

2. Configure the VPC deployment.

• In a shared VPC deployment, launch the GKE cluster in the shared VPC as described in
Configure the Shared VPC.

• In a peered VPC deployment, peer the GKE cluster VPC to the host project Trust network.
See Configure a Peered VPC.

Aer a deployment, you can delete all services deployed in the service template .yaml file
as follows:

kubectl delete -f [FILE_NAME].yaml
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gke_cluster_role.yaml

apiVersion: rbac.authorization.k8s.io/v1beta1
kind: ClusterRole
metadata:
  name: gke-plugin-role
rules:
  - apiGroups:
      - ""
    resources:
      - services
    verbs:
      - list

gke_cluster_role_binding.yaml

kind: ClusterRoleBinding
apiVersion: rbac.authorization.k8s.io/v1beta1
metadata:
  name: gke-plugin-role-binding
subjects:
  - kind: ServiceAccount
    name: hj-gke-891ca3-cluster1-sa
    namespace: default
roleRef:
  kind: ClusterRole
  name: gke-plugin-role
  apiGroup: rbac.authorization.k8s.io

web-deployment.yaml

apiVersion: extensions/v1beta1
kind: Deployment
metadata:
  name: web
  namespace: default
spec:
  selector:
   matchLabels:
    run: web
  template:
   metadata:
    labels:
      run: web
   spec:
    containers:
    - image: gcr.io/google-samples/hello-app:1.0
      imagePullPolicy: IfNotPresent
      name: web
      ports:
      - containerPort: 8080
       protocol:  TCP

VM-Series Deployment Guide Version Version 10.1 805 ©2022 Palo Alto Networks, Inc.



Set Up the VM-Series Firewall on Google Cloud Plaorm

web-service.yaml

apiVersion: v1
kind: Service
metadata:
  name: web
  namespace: default
  annotations:
    cloud.google.com/load-balancer-type: "Internal"
  labels:
    panw-named-port-port1: "80"
spec:
  ports:
  # the port that this service should serve on
  - name: port1 
    port: 80
    protocol: TCP
    targetPort: 8080
  selector:
    run: web
  type: LoadBalancer

web-deployment-v2.yaml

apiVersion: extensions/v1beta1
kind: Deployment
metadata:
  name: web2
  namespace: default
spec:
  selector:
    matchLabels:
      run: web2
  template:
    metadata:
      labels:
        run: web2
    spec:
      containers:
      - image: gcr.io/google-samples/hello-app:2.0
        imagePullPolicy: IfNotPresent
        name: web2
        ports:
        - containerPort: 8080
          protocol: TCP

web-service-v2.yaml

apiVersion: v1
  kind: Service
  metadata:
    name: web2
    namespace: default
    annotations:
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      cloud.google.com/load-balancer-type: "Internal"
    labels:
      panw-named-port-port2: "81"
  spec:
    ports:
    # the port that this service should serve on
    - name: port2
      port: 81
      protocol: TCP
      targetPort: 8080
    selector:
      run: web2
    type: LoadBalancer

Multiple Ports in a Service

For mulple ports in one service, edit labels and map the target port name and number in the
format panw-named-port-<service-spec-port-name>, as shown in the sample below.

apiVersion: v1
kind: Service
metadata:
  name: carts
  annotations:
    cloud.google.com/load-balancer-type: "Internal"
  labels:
    panw-named-port-carts-http: "6082"
    panw-named-port-carts-https: "6083"
  namespace: default
spec:
  type: LoadBalancer
  ports:
  # the port that this service should serve on
  - name: carts-http
    protocol: TCP
    port: 80
    targetPort: 80
  - name: carts-https
    protocol: TCP
    port: 443
    targetPort: 443
  selector:
    name: carts
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If you have virtualized the tradional appliance-based network infrastructure at your
branch or remote office with the Cisco 5400 Series Enterprise Network Compute
System (ENCS) appliance, you can use Enterprise NFV Infrastructure Soware (NFVIS)
to deploy the VM-Series firewall within your Cisco network. The VM-Series firewall
serves as a virtual network funcon (VNF) with next-generaon firewall capabilies
to safely enable all applicaons and protect your branch or remote office users and
network from threats.

The Cisco Enterprise Network Compute System (ENCS) appliances combine with Cisco
Integrated Services Virtual Routers (ISRV) and NFVIS soware to support Soware-
Defined Branch (SD-Branch) network architectures.

> Plan Your Cisco ENCS Deployment
> Prepare the VM-Series Firewall Image for Cisco ENCS
> Deploy the VM-Series Firewall on Cisco ENCS

809

https://www.cisco.com/c/en/us/products/collateral/routers/5400-enterprise-network-compute-system/datasheet-c78-738512.html
https://www.cisco.com/c/en/us/solutions/enterprise-networks/enterprise-network-functions-virtualization-nfv/index.html?dtid=osscdc000283
https://www.cisco.com/c/en/us/products/routers/enterprise-nfv-infrastructure-software/index.html
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Plan Your Cisco ENCS Deployment
In your Cisco SD-Branch, deploy the VM-Series Firewall on the Cisco ENCS appliance as a VNF
that provides next generaon firewall capabilies to secure your applicaons and users at the
branch office. You can deploy the firewall in a virtual wire, Layer 2, or Layer 3 deployment, and in
high availability configuraon.

To manage the VM-Series firewall, the Panorama appliance can be deployed on premises or in the
cloud. The following topology shows the VM-Series firewall at the branch edge.

Cisco ENCS Requirements

For supported NFVIS versions and hardware plaorms, see the Palo Alto Networks Compability
Matrix.

In NFVIS, set up networks and bridges.

Create virtual NICs and aach them to a virtual bridge so the ENCS appliance can steer
traffic through the VM-Series firewall.

On the Cisco ENCS appliance, the VM-Series firewall supports up to 8 dataplane interfaces.

The dataplane interfaces of the VM-Series firewall on Cisco ENCS support Viro
mode only; ENCS SR-IOV and PCI passthrough modes are not supported.

Set up network connecons for VM-Series firewall management access. If you are using
Panorama, ensure that Panorama has network access to manage the firewall you deploy.

Python 2.7. Required on your local machine if you are using the command line to convert.

VM-Series Firewall and Panorama Requirements

VM-Series Firewall—The VM-50 and VM-100 are recommended. The VM-300, VM-500, and
VM-700 are also supported, provided the ENCS hardware has sufficient resources that can be
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assigned to the VM-Series firewall. Consult the VM-Series System Requirements to ensure that
the Cisco ENCS appliance has adequate resources to support the VM-Series model you choose.

qcow2 file (the PAN-OS for VM-Series KVM base image) for PAN-OS 9.1 or later. See
Convert a qcow2 File from the Graphical User Interface, Step 2 or Convert a qcow2 File
from the Command Line Interface, Step 2.
VM-Series firewall capacity license and subscripon auth codes that meet your
requirements. See VM-Series Model License Types. You enter auth codes in the NFVIS user
interface, or include the auth codes in the authcodes text file in the conversion folder as
described in Convert a qcow2 File from the Command Line Interface, Step 4.
With PAN-OS 9.1, the VM-Series firewall on Cisco ENCS supports Viro with DPDK mode
enabled by default.

Panorama hardware or virtual appliance. While you can deploy a single VM-Series firewall
in a Cisco SD-Branch network, it is more common to deploy firewalls in many branches and
centrally manage them with Panorama.

Panorama version 9.1 or later. The version must be the same or higher than the version on
your VM-Series firewall.
A VM auth key generated on Panorama. This key allows the VM-Series firewall to
authencate with Panorama.
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Prepare the VM-Series Firewall Image for Cisco ENCS
You can convert a PAN-OS qcow2 file from the NFVIS graphical user interface or the command
line interface.

• Convert a qcow2 File from the Graphical User Interface
• Convert a qcow2 File from the Command Line Interface

Convert a qcow2 File from the Graphical User Interface
Use the NFVIS graphical user interface to enter image packaging and bootstrap informaon.

STEP 1 | In NFVIS, go to VM Life Cycle > Image Repository > Image Packaging.

STEP 2 | Fill in the package informaon as shown below, supplying your own values.

1. Enter a Package Name and VM Version, and for the VM Type, choose Firewall.
2. Enable the Serial Console.
3. Leave the Sriov Driver(s) field blank, as SR-IOV is not supported.
4. Select Local to choose a qcow2 file you uploaded previously, or click Upload Raw Images to

upload a qcow2 file.

• Log in to the Palo Alto Networks Customer Support Portal.

If you have not already done so, create a support account and register the VM-Series
firewall.

• Select Support > Soware Updates and from the Filter By drop-down, select Pan OS for
VM-Series KVM Base Image, for example, version 9.1.

• Download the qcow2 image.

VM-Series Deployment Guide Version Version 10.1 812 ©2022 Palo Alto Networks, Inc.

https://www.paloaltonetworks.com/support-login


Set Up a VM-Series Firewall on a Cisco ENCS Network

STEP 3 | Upload the bootstrap files.

STEP 4 | Set the Advanced Configuraon.

STEP 5 | Enter values for Custom Properes.
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STEP 6 | Set values for your resource requirements and choose the Default profile, or add a profile for
the current configuraon.

Click Submit to save your package.

STEP 7 | Click Register to register the new image.

Convert a qcow2 File from the Command Line Interface
To create a bootstrap file from the command line interface, you create the file
image_properties_template.xml then use the using the VM Image Packaging ulity to
create a .tar file, which you convert using the nfvpt.py script. The output is a tar.gz file that
can be uploaded from the NFVIS user interface.

STEP 1 | Create or choose a folder on your local machine (the conversion folder) in which you want to
download and save the files necessary to convert the VM-Series firewall qcow2 image to the
Cisco ENCS format.

STEP 2 | Obtain the VM-Series firewall qcow2 image.
1. Log in to the Palo Alto Networks Customer Support Portal.

If you have not already done so, create a support account and register the VM-Series
firewall.

2. Select Support > Soware Updates and from the Filter By drop-down, select Pan OS for
VM-Series KVM Base Image, for example, version 9.1.

3. Download the qcow2 image to the conversion folder.
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STEP 3 | Create the following init-cfg.txt file in the conversion folder.

type=static 
ip-address=${IP_ADDRESS} 
default-gateway=${GATEWAY} 
netmask=${NETMASK} 
ipv6-address= 
ipv6-default-gateway= 
hostname=${HOSTNAME}
vm-auth-key=${VM_AUTH_KEY}
panorama-server=${PANORAMA_SERVER} 
panorama-server-2= 
tplname= 
dgname= 
dns-primary=${DNS_SERVER}
dns-secondary= 
op-command-modes=jumbo-frame, mgmt-interface-swap** 
dhcp-send-hostname=yes 
dhcp-send-client-id=yes 
dhcp-accept-server-hostname=yes 
dhcp-accept-server-domain=yes

STEP 4 | Create a text file named authcodes (no extension), and enter the auth codes for the VM-
Series firewall capacity and subscripons. Save the file in the conversion folder.

STEP 5 | Create the following image_properties_template.xml file in the conversion folder,
and supply values for your deployment:

<image_properties>
    <vnf_type>FIREWALL</vnf_type>
    <name>pafw</name>
    <version>9.1.0</version>
    <bootup_time>-1</bootup_time>
    <root_file_disk_bus>virtio</root_file_disk_bus>
    <root_image_disk_format>qcow2</root_image_disk_format>
    <vcpu_min>2</vcpu_min>
    <vcpu_max>8</vcpu_max>
    <memory_mb_min>4096</memory_mb_min>
    <memory_mb_max>16384</memory_mb_max>
    <vnic_max>8</vnic_max>
    <root_disk_gb_min>32</root_disk_gb_min>
    <root_disk_gb_max>60</root_disk_gb_max>
    <console_type_serial>true</console_type_serial>
    <sriov_supported>true</sriov_supported>
    <pcie_supported>false</pcie_supported>
    <monitoring_supported>false</monitoring_supported>
    <monitoring_methods>ICMPPing</monitoring_methods>
    <low_latency>true</low_latency>
    <privileged_vm>true</privileged_vm>
    <custom_property>
        <HOSTNAME> </HOSTNAME>
    </custom_property>
    <custom_property>
        <IP_ADDRESS> </IP_ADDRESS>
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    </custom_property>
    <custom_property>
        <NETMASK> </NETMASK>
    </custom_property>
    <custom_property>
        <GATEWAY> </GATEWAY>
    </custom_property>
    <custom_property>
        <PANORAMA_SERVER> </PANORAMA_SERVER>
    </custom_property>
    <custom_property>
        <DNS_SERVER> </DNS_SERVER>
    </custom_property>
    <custom_property>
        <VM_AUTH_KEY> </VM_AUTH_KEY>
    </custom_property>
    <default_profile>VM-50</default_profile>
    <profiles>
        <profile>
                <name>VM-50</name>
                <description>VM-50 profile</description>
                <vcpus>2</vcpus>
                <memory_mb>5120</memory_mb>
                <root_disk_mb>60000</root_disk_mb>
        </profile>
        <profile>
                <name>VM-100-n-200</name>
                <description>VM-100 and VM-200 profile</
description>
                <vcpus>2</vcpus>
                <memory_mb>7168</memory_mb>
                <root_disk_mb>60000</root_disk_mb>
        </profile>
        <profile>
                <name>VM-300</name>
                <description>VM-300 profile</description>
                <vcpus>2</vcpus>
                <memory_mb>9216</memory_mb>
                <root_disk_mb>60000</root_disk_mb>
        </profile>
        <profile>
                <name>VM-1000-HV</name>
                <description>VM-1000-HV profile</description>
                <vcpus>4</vcpus>
                <memory_mb>9216</memory_mb>
                <root_disk_mb>60000</root_disk_mb>
        </profile>
        <profile>
                <name>VM-500</name>
                <description>VM-500 profile</description>
                <vcpus>4</vcpus>
                <memory_mb>16384</memory_mb>
                <root_disk_mb>60000</root_disk_mb>
        </profile>
    </profiles>
    <cdrom>true</cdrom>
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    <bootstrap_file_1>/config/init-cfg.txt</bootstrap_file_1>
    <bootstrap_file_2>/config/bootstrap.xml</bootstrap_file_2>
    <bootstrap_file_3>/license/authcodes</bootstrap_file_3>
</image_properties>

STEP 6 | Download the image packaging ulity.
1. Log in to the Enterprise NFVIS user interface and select VM Life Cycle  > Image

Repository.
2. Click the Browse Datastore tab, and navigate to data > intdatastore > uploads >

vmpackagingulity.
3. Download nfvisvmpackagingtool.tar to the conversion folder.
4. Untar the file:

tar -xvf nfvisvmpackagingtool.tar

STEP 7 | In the conversion folder that contains the qcow2, the init-config.txt and the
authcodes file, run the nfvpt.py script. See the nfvpt.py image packaging ulity
documentaon.

The following sample creates the image file Palo-Alto-9.1.0, and a VM-100 profile. Opons
are space-separated (the sample shows opons on separate lines for clarity only) and custom
opons are key-value pairs with a colon separator.

./nfvpt.py -o Palo-Alto-9.1.0 -i PA-VM-KVM-9.1.0.qcow2 
-n PAN902 -t FIREWALL -r 9.1.0 
--monitored false 
--privileged true 
--bootstrap /config/init-cfg.txt:init-cfg.txt,/license/
authcodes:authcodes 
--min_vcpu 2 --max_vcpu 8 
--min_mem 4096 --max_mem 16384 
--min_disk 10 --max_disk 70 
--vnic_max 8 
--optimize true 
--console_type_serial true 
--profile VM-100,"VM-100 profile",2,7168,61440 
--default_profile VM-100 
--custom HOSTNAME:hello
--custom IP_ADDRESS:10.2.218.24
--custom NETMASK:255.255.255.0
--custom GATEWAY:10.2.218.1
--custom DNS_SERVER:10.55.66.10
--custom PANORAMA_SERVER:0.10.10.0
--custom VM_AUTH_KEY:123451234512345
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STEP 8 | Upload the converted image.
1. In the NFVIS user interface, select VM Life Cycle  > Image Repository and click the blue

Images icon to show the Drop Files or Click circle.
2. Drag the converted file into the circle, or click to browse and select your file.
3. In the Status column, click Start.

When the upload is complete, the image is registered, and the file you uploaded displays
in the Image Registraon tab Images list.
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Deploy the VM-Series Firewall on Cisco ENCS
Before you begin to deploy the firewall, make sure that you have created network connecons for
management access to the VM-Series firewall. If you are using Panorama, ensure that Panorama
has management connecvity to the firewall.

STEP 1 | Deploy the VM-Series firewall.
1. In Enterprise NFVIS, click VM Life Cycle > Deploy.
2. Drag the firewall icon to the appropriate network. In this example, the firewall connects

to a management network and a LAN network.

3. Deploy the VM-Series firewall.

If you are using Panorama to manage the firewall, the firewall displays as Connected on
Panorama > Managed Devices > Summary. If the firewall is not connected to Panorama,
check that you have provided the correct Panorama IP address and that the devices can
communicate over the network.
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STEP 2 | Configure the VM-Series firewall dataplane interfaces.

See configure a Layer 3 interface, configure a Layer 2 interface, or configure virtual wires.
If using Panorama, the following steps show you how to configure the firewall for a Layer 3
deployment.

1. Add a template and assign the firewall to the template.
2. Select the Network and in the Template drop-down, select the template you created.
3. Select Network > Interfaces > Ethernet.
4. Click ethernet 1/1 and configure as follows:

• Set Interface Type to Layer3.
• On the Config tab, assign the interface to the default router.
• Also on the Config tab, expand the Security Zone drop-down and select New Zone.

Define a new zone called UnTrust for example, and then click OK.

• On the IPv4 tab, select DHCP Client or Stac. If you choose stac, enter the IP
address.

5. Repeat b-e for each network interface.
6. Commit > Commit and Push to commit all configuraon changes to Panorama and the

managed firewalls.

Verify that the link state for the firewall interfaces is up.
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STEP 3 | Configure Security policies to safely enable applicaons and users on your network.

If using Panorama, the following steps show you how to use device groups to centrally manage
policy rules for your managed firewalls.

1. Add a device group and assign the managed firewalls to your device group.

2. Configure the security policies for the device group.

STEP 4 | Verify that the VM-Series firewall is securing traffic on your network.
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Set up the VM-Series Firewall on
Oracle Cloud Infrastructure

Deploy the VM-Series firewall on Oracle Cloud Infrastructure (OCI) cloud. With the
VM-Series on OCI, you can protect and segment your workloads, prevent advanced
threats, and improve visibility into your applicaons as you move to the cloud.

OCI is a public cloud compung service that enables you to run your applicaons in a
highly-available, hosted environment offered by Oracle. You can deploy the VM-Series
firewall to secure your applicaons and services running your OCI environment.

> OCI Shape Types
> Deployments Supported on OCI
> Prepare to Set Up the VM-Series Firewall on OCI
> Deploy the VM-Series Firewall From the Oracle Cloud Marketplace
> Configure Acve/Passive HA on OCI
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OCI Shape Types
The VM-Series firewalls support the following OCI VM shapes. See Oracle Cloud Infrastructure
documentaon for more informaon about VM shapes.

VM-Series Model Minimum OCI Shape

• VM-100
• Soware NFGW Credit-based VM-Series

VM.Standard2.4

• VM-300
• Soware NFGW Credit-based VM-Series

VM.Standard2.4

• VM-500
• Soware NFGW Credit-based VM-Series

VM.Standard2.8

• VM-700
• Soware NFGW Credit-based VM-Series

VM.Standard2.16

• VM-100, VM-300, VM-500, and VM-700
• Soware NFGW Credit-based VM-Series

VM.Opmized3.Flex

You can deploy the VM-Series firewall on an OCI instance with more resources than the minimum
VM-Series System Requirements. If you chooses a larger shape size for the VM-Series firewall
model. Although the firewall only uses the maximum vCPUs cores and memory listed on the
system requirements page, it does take advantage of the faster network performance that the
larger shape provides.
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Deployments Supported on OCI
Use the VM-Series firewall on OCI to secure your cloud environment in the following scenarios:

• North-South Traffic—You can use the VM-Series firewall to secure traffic entering your cloud
network from an untrusted source or exing your cloud network to reach an untrusted source.
For either type of traffic, you must configure route table rules in your Virtual Cloud Network
(VCN) and NAT policy rules on the firewall.

In this example, outbound traffic is exing the trust subnet in your VCN. You must configure
source address translaon policy onto a public IP address and a route table rule that redirects
that traffic to the firewall. The route rule points outgoing traffic to the firewall’s interface in the
trust subnet of the VCN. When the firewall receives this traffic, it performs the source address
translaon on the traffic and applies any other security policy you have configured.

• Inter-VCN Traffic (East-West)—The VM-Series firewall allows you to secure traffic moving
within your cloud environment between VCNs. Each subnet must belong to a different VCN
because, by default, no route rules are used to enable traffic within a VCN. In this scenario, you
configure an interface on the firewall connected to a subnet in each VCN.

In the example below, a user in the Trust Subnet wants to access data in the DB Subnet.
Configure a route on OCI that reaches DB Subnet CIDR next hop, which points to the interface
Trust Subnet network on the VM-Series firewall.
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Prepare to Set Up the VM-Series Firewall on OCI
The process to deploy the VM-Series firewall on Oracle Cloud Infrastructure requires the
compleon of preparaon tasks.

• Virtual Cloud Networks
• SSH Keys
• Inial Configuraon User Data

Virtual Cloud Networks

A virtual cloud network (VCN) is a virtual, private network that you set up in your OCI
environment. To deploy the VM-Series firewall in OCI, your VCN must have at least three virtual
network interfaces cards (VNICs) for the management interface and two data interfaces.

OCI uses a series of route tables to send traffic out of your VCN and one route table is added to
each subnet. A subnet is a division of your VCN. If you do not specify a route table, the subnet
uses the VCN’s default route table.Each route table rule specifies a desnaon CIDR block and a
next hop (target) for any traffic that matches the CIDR. OCI only uses a subnet’s route table if the
desnaon IP address is outside the VCN’s specified CIDR block; route rules are not required to
enable traffic within the VCN. And, if traffic has overlapping rules, OCI use the most specific rule
in the route table to route traffic.

If there is no route rule that matches the traffic that is aempng to leave the VCN, the
traffic is dropped.

Each subnet requires a route table and once you have added a route table to a subnet, you cannot
change it. However, you can add, remove, or edit rules in a route table aer it has been created.

SSH Keys

You must create an SSH key pair to login to the firewall for the first me. You cannot use the
default username and password to access the firewall for the first me. Aer the firewall boots
up for the first me, you must access the firewall through the CLI and create a new username and
password.

1. Create an SSH key pair and store the SSH Key pair in the default locaon for your operang
system.

• On Linux or MacOS, use ssh-keygen to create the key pair in your .ssh directory.

• On Windows, use PuTTYgen to create the key pair.

The content of the Key comment field does not maer to the VM-Series firewall; you can
accept the default (the key creaon date) or enter a comment that helps you remember the
name of the key pair. Use the Save private key buon to store the private key in your .ssh
directory.
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2. Select the full public key.

• Linux or MacOS:

Open your public key in a text editor and copy the public key.
• Windows: You must use the PuTTY Key Generator to view the public key. Launch PuTTYgen,

click Load, and browse to private key you saved in your .ssh directory.

In PuTTYgen, scroll down to ensure you select the enre key, right click, and choose Copy.

Inial Configuraon User Data

You must provide the following bootstrapping parameters when seng up the VM-Series firewall
instance. OCI uses this informaon to perform the inial configuraon of the firewall, which
provides the firewall with a hostname and license and connects the firewall to Panorama, if
applicable.

The Panorama-related fields are required only if you have a Panorama appliance and want
use Panorama to manage your VM-Series firewall.

Field Descripon

hostname= Host name for the firewall.

vm-auth-key= Virtual machine authencaon key for registering
the firewall with Panorama.

panorama-server= IPv4 or IPv6 address of the primary Panorama
server. This field is not required but recommended
for centrally managing your firewalls.

panorama-server-2= IPv4 or IPv6 address of the secondary Panorama
server. This field is not required but recommended.
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Field Descripon

tplname= Panorama template stack name. If you add a
Panorama server IP address, as a best pracce
assign the firewall to a template stack on Panorama
and enter the template stack name in this field
so that you can centrally manage and push
configuraon sengs to the firewall.

dgname= Panorama device group name. If you add a
Panorama server IP address, as a best pracce
create a device group on Panorama and enter the
device group name in this field so that you can
group the firewalls logically and push policy rules
to the firewall.

authcodes= Used to license the VM-Series firewall with the
Palo Alto Networks licensing server.

op-command-modes=jumbo-frame Used to enable jumbo frame mode on the VM-
Series firewall. Because OCI deploys VM instances
in jumbo mode by default, it is recommended that
you launch the VM-Series firewall in jumbo mode
to achieve the best throughput.

Paste the bootstrapping parameters into the OCI console in the following format.

hostname=<fw-hostname>

vm-auth-key=<auth-key>

panorama-server=<panorama-ip>

panorama-server-2=<panorama2-ip>

tplname=<template-stack-name>

dgname=<device-group-name>

authocodes=<firewall-authcode>

op-command-modes=jumbo-frame
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Deploy the VM-Series Firewall From the Oracle Cloud
Marketplace

Complete the following procedure to deploy the VM-Series firewall in OCI from the Oracle Cloud
Marketplace.

All VM-Series firewall interfaces must be assigned an IPv4 address when deployed in a
public cloud environment. IPv6 addresses are not supported.

STEP 1 | Log in to the Oracle Cloud Marketplace.

STEP 2 | Find the VM-Series firewall applicaon in the Oracle Cloud Marketplace.
1. Search for Palo Alto Networks and a list of offerings for the VM-Series firewall will

display.
2. Select an offering.
3. Click Get App.
4. Select your Region and click Sign In.
5. Select the Version and Compartment.
6. Accept the Oracle and Partner terms.
7. Click Launch Instance.

STEP 3 | Enter a descripve Name for your VM-Series firewall instance.

STEP 4 | Select an Availability Domain.

STEP 5 | Select Virtual Machine under Shape Type.

VM-Series Deployment Guide Version Version 10.1 829 ©2022 Palo Alto Networks, Inc.



Set up the VM-Series Firewall on Oracle Cloud Infrastructure

STEP 6 | Select the shape with the number of CPUs, amount of RAM, and number of interfaces
required for the VM-Series firewall model. See the Compute Shapes page for the amount
resources provided by the different compute shapes. See VM-Series System Requirements
for more informaon about the resources required for each VM-Series firewall model.

STEP 7 | Under Networking, select your Virtual cloud network compartment, Virtual cloud network,
Subnet compartment, and Subnet for your management interface. You can only add one
interface when creang the VM-Series firewall instance. You will add addional interfaces
later.

STEP 8 | (Oponal) Set the boot volume to a size larger than the default. By default, the boot volume
is set to 60GB. Complete this procedure if you require a larger boot volume to support
features such as aaching logs.
1. Select Custom boot volume size (in GB).
2. Enter 60 or greater. 60 GB is the minimum hard drive size required by the VM-Series

firewall.

STEP 9 | Add your SSH key.
1. Under Add SSH Key, select Paste SSH Key.
2. Paste your SSH key into the field provided.
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STEP 10 | Add the bootstrapping parameters.
1. Click Show Advanced Opons.
2. Under User data, select Paste cloud-init script.
3. Paste the boostrap parameters into the field provided.

hostname=<fw-hostname>

vm-auth-key=<auth-key>

panorama-server=<panorama-ip>

panorama-server-2=<panorama2-ip>

tplname=<template-stack-name>

dgname=<device-group-name>

authcodes=<firewall-authcode>

op-command-modes=jumbo-frame

STEP 11 | Click Create.

When the VM-Series firewall is launched, OCI creates and aaches a primary VNIC to the
instance. This VNIC resides in the subnet you specified in the instance network seng and
connects to the VM-Series firewall’s management interface.

STEP 12 | Configure a new administrave password for the firewall.
1. Use the management IP address to SSH into the command line interface (CLI) of the VM-

Series firewall.
2. Enter the following command to log in to the firewall:

ssh-i <private_key.pem> admin@<public-ip_address>
3. Configure a new password, using the following command and follow the onscreen

prompts:
configure
set mgt-config users admin password
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STEP 13 | Aach a vNIC to your VM-Series firewall instance for each data interface. You must aach at
least two data interfaces to your firewall instance—untrust and trust.
1. Select your newly launched VM-Series firewall instance and select Aached VNICs >

Create VNIC.
2. Enter a descripve Name for your vNIC.
3. Select your VCN from the Virtual Cloud Network drop-down.
4. Select your subnet from the Subnet drop-down.
5. Specify a Private IP Address. This is only required if your want to choose a parcular

IP for the vNIC. If you do not specify an IP, OCI will assign an IP address from the CIDR
block you assigned to the subnet.

6. Select Assign Public IP Address for public facing vNICs such as your untrust subnet.
7. Click Create VNIC.
8. Repeat this procedure for each vNIC your deployment requires.
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STEP 14 | Configure the dataplane network interfaces as Layer 3 interfaces on the firewall.
1. Log in to the firewall.
2. Select Network > Interfaces > Ethernet.
3. Click the link for ethernet 1/1 and configure as follows:

• Interface Type: Layer3
• On the Config tab, assign the interface to the default router.
• On the Config tab, expand the Security Zone drop-down and select New Zone.

Define a new zone, for example untrust-zone, and then click OK.
• On the IPv4 tab, select either Stac.
• Click Add in the IP secon and enter the IP address and network mask for the

interface. Make sure that the IP address matches the IP address that you assigned
to the corresponding subnet in VCN. For example, if you add this interface to your
untrust zone, make sure you assign the untrust vNIC IP address configured in your
VCN.

4. Repeat this procedure for each vNIC configured in your VCN except your management
vNIC.

Always only delete interfaces at the boom of the interface list. Deleng firewall
interfaces in the wrong order results in a interface mismatch between the firewall and
OCI. For example, say you have five data interfaces, then delete interface two on the
firewall and add a new interface at the boom. Aer reboong the firewall, the newly
added interface will take the place of the deleted interface two instead of taking a
place at the boom of the list.
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Configure Acve/Passive HA on OCI
You can configure a pair of VM-Series firewalls on OCI in an acve/passive high availability (HA)
configuraon. To ensure upme in an HA setup on OCI, you must create a secondary, floang
IP addresses that can quickly move from one peer to the other. When the acve firewall goes
down, the floang IP address moves from the acve to the passive firewall so that the passive
firewall can seamlessly secure traffic as soon as it becomes the acve peer. In addion to the
floang IP address, the HA peers also need HA links—a control link (HA1) and a data link (HA2)—
to synchronize data and maintain state informaon.

The VM-Series firewall for OCI in FIPS mode does not support high availability.

To allow the firewalls to move the floang IP address upon failover, you must place the firewall
instances in a dynamic group on OCI. Dynamic groups allow you to group the firewall instances
as principal actors and create policy to allow the instances in the dynamic group to make API calls
against OCI services. You will use matching rules to add the HA peer instances to the dynamic
group and then create the policy the floang IP from one VNIC to another.

Both VM-Series firewalls in the HA pair must have the same number of network interfaces. Each
firewall requires a minimum of four interfaces—management, untrust, trust, and HA. You can
configure addional data interfaces as required by your deployment.

• Management interface—the private and public IP addresses associated with the primary
interface. You can use the private IP address on the management interface as the IP address for
the HA1 interface between the peers. If you want a dedicated HA interface, you must aach an
addional interface to each firewall, for a total of five interfaces each.

• Untrust and trust interfaces—each of these data interfaces on the acve HA peer require a
primary and secondary IP address. Upon failover, when the passive HA peer transions to the
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acve state, the secondary private IP address is detached from the previously acve peer and
aached to the now acve HA peer.

• HA2 interface—this interface has a single private IP address on each HA peer. The HA2
interface is the data link peers use to synchronize sessions, forwarding tables, IPsec security
associaons, and ARP tables.

STEP 1 | Deploy the VM-Series Firewall From the Oracle Cloud Marketplace and set up the network
interfaces for HA.
1. (Oponal) Configure a dedicated HA1 interface on each HA peer.

1. From the OCI Console, select Compute > Instances and click on the name of your
acve peer instance.

2. Select Aached VNICs and click Create VNIC.
3. Enter a descripve name for your HA1 interface.
4. Select the VCN and subnet.
5. Enter a private IP address.
6. Click Create VNIC.
7. Repeat this process on your passive peer instance.

2. Configure an HA2 interface on each HA peer.

1. From the OCI Console, select Compute > Instances and click on the name of your
acve peer instance.

2. Select Aached VNICs and click Create VNIC.
3. Enter a descripve name for your HA2 interface.
4. Select the VCN and subnet. The HA2 interface should be on a separate subnet from

your data interfaces.
5. Enter a private IP address.
6. Click Create VNIC.
7. Repeat this process on your passive peer instance.

3. Add a secondary IP address to your dataplane interfaces on the acve peer.

1. From the OCI Console, select Compute > Instances and click on the name of your
acve peer instance.

2. Select Aached VNICs and click on your untrust VNIC.
3. Select IP Addresses and click Assign Private IP Address.
4. Enter the IP address and click Assign.
5. Repeat this procedure for each dataplane interface on your acve peer.
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STEP 2 | Create security rules to allow the HA peers to synchronize data and maintain state
informaon. By default, OCI allows ICMP traffic only. You must open the necessary HA ports.
1. Open the ports for your HA1 interface.

1. From the OCI Console, select Networking > Virtual Cloud Networks and select your
VCN.

2. Select Subnets and select the subnet containing your HA1 interface.
3. Select Security Lists and click the default security list to edit it.
4. Click Add Ingress Rule.
5. Enter the Source CIDR that includes the HA peer HA1 port IP address.
6. Select TCP from the IP Protocol drop-down.
7. Click +Addional Ingress Rule. You need to create two addional rules for TCP ports

28260 and 28769.
8. If encrypon is enabled on your VM-Series firewall for the HA1 link, create an

addional rules for ICMP and TCP port 28.
9. Click Add Ingress Rules.

2. Open the ports for your HA2 interface.

1. From the OCI Console, select Networking > Virtual Cloud Networks and select your
VCN.

2. Select Subnets and select the subnet containing your HA2 interface.
3. Select Security Lists and click the default security list to edit it.
4. Click Add Ingress Rule.
5. Enter the Source CIDR that includes the HA peer HA2 port IP address.
6. Select UDP or IP from the IP Protocol drop-down.
7. If the transport mode is UDP, enter 29281 into Source Port Name. If the transport

mode is IP, enter 99 into Source Port Name.
8. Click Add Ingress Rules.
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STEP 3 | Add both HA peers to a dynamic group and create policy that allows the HA peers to move
the floang IP address. You must have the OCID of each HA peer instance to build the
dynamic group matching rules, so have those on hand to past into the rule builder.
1. Create the dynamic group.

1. From the OCI Console, select Identy > Dynamic Groups > Create Dynamic Group.
2. Enter a descripve Name for your dynamic group.
3. Click Rule Builder.
4. Select Any of the following rules from the first drop-down.
5. Select Match instances with ID: from the Aributes drop-down and paste one of the

peer OCIDs into the Value field.
6. Click +Addional Line.
7. Select Match instances with ID: from the Aributes drop-down and paste the other

peer OCID into the Value field.
8. Click Add Rule.

9. Click Create Dynamic Group.
2. Create the policy rule.

1. From the OCI Console, select Identy > Policies > Create Policy.
2. Enter a descripve Name for your policy.
3. Enter the first policy statement.

Allow dynamic-group <dynamic_group_name> to use virtual-
network-family in compartment <compartment_name>

4. Click +Another Statement.
5. Enter the second policy statement.

Allow dynamic-group <dynamic_group_name> to use instance-
family in compartment <compartment_name>

6. Click Create.
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STEP 4 | Configure the interfaces on the firewall. You must configure the HA2 data link and at least
two Layer 3 interfaces for your untrust and trust interfaces. Complete this workflow on the
first HA peer and then repeat the steps on the second HA peer.
1. Log in to the firewall web interface.
2. (Oponal) If you are using the management interface as HA1, you must set the interface

IP Type to stac and configure a DNS server.

1. Select Device > Setup > Interfaces > Management.
2. Set the IP Type to Stac.
3. Enter the private IP address of the primary VNIC of your VM-Series firewall instance.
4. Click OK.
5. Select Device > Setup > Services.
6. Click Edit.
7. Enter the IP address of the Primary DNS Server.
8. Click OK.
9. Commit your changes.

3. Select Network > Interfaces > Ethernet and click on your untrust interface. In this
example, the HA2 interface is 1/1, the trust interface is ethernet 1/2, and the untrust
interface is ethernet 1/3.

4. Click the link for ethernet 1/1 and configure as follows:

• Interface Type: HA
5. Click the link for ethernet 1/2 and configure as follows:

• Interface Type: Layer3
• On the Config tab, assign the interface to the default router.
• On the Config tab, expand the Security Zone drop-down and select New Zone.

Define a new zone, for example trust-zone, and then click OK.
• On the IPv4 tab, select either Stac.
• Click Add in the IP secon and enter the primary IP address and network mask for the

interface. Make sure that the IP address matches the IP address that you assigned to
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the corresponding subnet in VCN. For example, if you add this interface to your trust
zone, make sure you assign the trust vNIC IP address configured in your VCN.

• Click Add in the IP secon and enter the secondary, floang IP address and network
mask.

6. Click the link for ethernet 1/3 and configure as follows:

• Interface Type: Layer3
• On the Config tab, assign the interface to the default router.
• On the Config tab, expand the Security Zone drop-down and select New Zone.

Define a new zone, for example untrust-zone, and then click OK.
• On the IPv4 tab, select either Stac.
• Click Add in the IP secon and enter the primary IP address and network mask for

the interface. Make sure that the IP address matches the IP address that you assigned
to the corresponding subnet in VCN. For example, if you add this interface to your
untrust zone, make sure you assign the untrust vNIC IP address configured in your
VCN.

• Click Add in the IP secon and enter the secondary, floang IP address and network
mask.
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STEP 5 | Enable HA.
1. Select Device > High Availability > General.
2. Edit the Setup sengs.
3. Enter the private IP address of the passive peer in the Peer HA1 IP address field.
4. Click OK.

5. (Oponal) Edit the Control Link (HA1). If you do not plan to use the management
interface for the control link and have added an addional interface (for example
ethernet 1/4), edit this secon to select the interface to use for HA1 communicaon.

6. Edit the Data Link (HA2) to use Port ethernet 1/1 and add the IP address of acve peer
and the Gateway IP address for the subnet.

7. Select IP or UDP from the Transport drop-down. Ethernet is not supported.

8. Click OK.

STEP 6 | Commit your changes.

STEP 7 | Repeat step 4 and step 5 on the passive HA peer.
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STEP 8 | Aer your finish configuring HA on both firewalls, verify that the firewalls are paired in
acve/passive HA.
1. Access the Dashboard on both firewalls and view the High Availability widget.
2. On the acve HA peer, click Sync to peer.
3. Confirm that the firewalls are paired and synced.

• On the passive firewall: the state of the local firewall should display Passive and the
Running Config should show as Synchronized.

• On the acve firewall: the state of the local firewall should display Acve and the
Running Config should show as Synchronized.
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You can use the VM-Series firewall to secure your resources deployed in IBM Cloud.

> About the VM-Series Firewall on IBM Cloud
> Prepare to Set Up VM-Series Firewalls on IBM Cloud
> Deploy the VM-Series Firewall Using IBM Cloud Schemacs
> High Resiliency for VM-Series Firewall on IBM Cloud
> Use Case: Deploy a NLB Using the VM-Series Firewall
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About the VM-Series Firewall on IBM Cloud
The VM-Series Next Generaon Firewalls (NGFW) allow you to migrate your business-crical
applicaons to the cloud and protect the increased public cloud footprint from threats, data loss,
and business disrupon by:

• Offering unmatched applicaon visibility and precise control.
• Prevenng threats from moving laterally between workloads and stopping data exfiltraon.
• Eliminang security-induced applicaon development bolenecks with automaon and

centralized management.

See the following topics for system requirements and licensing informaon:

• Licensing Informaon
• System Requirements for VM-Series Firewall on IBM Cloud

Licensing Informaon
The VM-Series firewall supports the bring-your-own-license (BYOL) model on IBM Cloud. For
more informaon, see

Bring Your Own License (BYOL).

System Requirements for VM-Series Firewall on IBM Cloud
To deploy a VM-Series firewall on an IBM Cloud instance, you must choose a machine type that
supports the VM-Series System Requirements for your license.

Refer to the table below for the minimum recommended predefined standard machine types.

Capacity Minimum Recommended Predefined Machine Types

VM-100 Firewall bx2d-2x8

VM-200 Firewall bx2d-2x8

VM-300 Firewall bx2d-4x16

VM-500 Firewall bx2d-4x16

VM-700 Firewall bx2d-16x64

You can choose a higher performing machine type or create your own custom machine type, if the
resource requirements are compable with your VM-Series firewall license. A single IBM Cloud
instance supports up to five network interfaces. For more informaon on machine types, see
Instance Profiles.
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Prepare to Set Up VM-Series Firewalls on IBM Cloud
Deploying the VM-Series Firewall from IBM Cloud Plaorm requires preparaon tasks. If you are
deploying using the IBM Cloud catalog, you must create your project networks and subnetworks,
and plan IP address assignments for the VM-Series firewall interfaces in advance. During the
deployment, you must choose from exisng networks and subnetworks.

• Prerequisites
• Dependencies
• General Requirements

Prerequisites
To set-up the VM-Series Firewall on IBM Cloud, you will need:

• Access to IBM Cloud Gen 2 VPC
• A VPC with at least two subnets and one IP address unassigned in each subnet. The IP

Addresses to the VM-Series VSI will be assigned from the user provided subnets. For more
informaon, see

• One of the following regions to install PAN-OS:

• us-east
• us-south
• ca-tor
• eu-gb
• eu-de
• eu-fr2
• au-syd
• jp-osa
• jp-tok

Dependencies
Before you can apply the template in IBM Cloud, complete the following steps:

• Ensure that you have the following permissions in IBM Cloud Identy and Access Management:

• Manager service access role for IBM Cloud Schemacs
• Operator plaorm role for VPC Infrastructure
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• Ensure the following resources exist in your VPC Gen 2 environment:

• VPC
• SSH Key - Public SSH Key Doc
• VPC has 2 subnets - one for management, the other for data plane traffic
• Floang IP (FIP) address to assign to the management interface of VM-Series instance post

deployment. FIP is used to access your VPC virtual server instance over the public internet.
For more informaon, see Creang a floang IP address.

General Requirements
The components in this checklist are common to deploying a VM-Series firewall that you manage
directly or with Panorama.

Refer to the Compability Matrix for Panorama plugin informaon for public clouds.This release
requires the following soware:

• IBM Cloud account—You must have an IBM Cloud user account with a linked email address and
you must know the username and password for that email address.

IBM Cloud SDK—If you have not done so, install the IBM Cloud Soware, which includes IBM
Cloud APIs and command line tools. You can use the command line interface to deploy the
firewall template and other templates.

• PAN-OS on VM-Series firewalls on IBM Cloud—VM-Series firewalls running a PAN-OS version
available from the IBM Cloud Catalog.

• VM-Series firewalls—VM-Series firewalls that you want to manage from Panorama must
be deployed in IBM Cloud Plaorm using a Palo Alto Networks image from the IBM Cloud
Catalog. Firewalls must meet the Minimum System Requirements for the VM-Series Firewall.

• VM-Series Licenses—You must license a VM-Series firewall to obtain a serial number. A
serial number is required to add a VM-Series firewall as a Panorama managed device. If you
are using the Panorama plugin for IBM Cloud to deploy VM-Series firewalls, you must supply
a BYOL auth code. The IBM Cloud handles your service billing, but the firewalls you deploy
will directly interface with the Palo Alto Networks licensing server.

• VM-Series plugin on the firewall—VM-Series firewalls running PAN-OS 9.0 and later include
the VM-Series plugin, which manages integraon with public and private clouds. As shown

VM-Series Deployment Guide Version Version 10.1 846 ©2022 Palo Alto Networks, Inc.

https://cloud.ibm.com/docs/vpc?topic=vpc-creating-a-vpc-using-the-rest-apis#create-floating-ip-api-tutorial
https://docs.paloaltonetworks.com/compatibility-matrix/panorama/plugins.html
https://cloud.ibm.com/docs/cli?topic=cli-install-ibmcloud-cli
https://docs.paloaltonetworks.com/vm-series/10-1/vm-series-deployment/license-the-vm-series-firewall/vm-series-models/license-typesvm-series-firewalls/vm-series-firewall-licenses-for-public-clouds.html
https://docs.paloaltonetworks.com/vm-series/10-1/vm-series-deployment/about-the-vm-series-firewall/vm-series-plugin.html


Set Up the VM-Series Firewall on IBM Cloud

in the Compability Matrix, the VM-Series plugin has a minimum version that corresponds
to each PAN-OS release.

When there is a major PAN-OS upgrade the VM-Series plugin version is automacally
upgraded. For minor releases it is up to you to determine whether a VM-Series plugin
upgrade is necessary, and if so, perform a manual upgrade.

• Panorama running in Management mode—A Panorama physical or virtual appliance running
a PAN-OS version that is the same or later than the managed firewalls. Virtual instances do
not need to be deployed in IBM Cloud.

You must have:

• A licensed version of Panorama.
• Panorama having network access to the VPCs in which the VMs you want to manage are

deployed.
• VM-Series plugin on Panorama. See Install the VM-Series Plugin on Panorama.
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Deploy the VM-Series Firewall Using IBM Cloud
Schemacs

To deploy the VM-Series firewall using the IBM catalog template, you must first create a VPC
network for each interface on the firewall. For instrucons on creang a VPC network, see Geng
Started with VPC network.

You can deploy the VM-Series Next-Generaon Firewall (BYOL) through IBM cloud Schemacs.
The IBM cloud terraform template deploys an instance of the VM-Series firewall with a minimum
of one management interface and two dataplane interfaces. You can add addional dataplane
interfaces for up to five IBM cloud instances in your virtual private cloud (VPC).

Before you deploy the VM-Series firewall, you must create or choose a project in your
organizaon and create any networks and subnets that will connect to the firewall. You cannot
aach mulple network interfaces to the same VPC network. Every interface you create must
have a dedicated network with at least one subnet. Ensure that your networks include any
addional dataplane instances you create.

All VM-Series firewall interfaces must be assigned an IPv4 address when deployed in a
public cloud environment. IPv6 addresses are not supported.

STEP 1 | Locate the VM-Series firewall lisng in IBM Cloud Catalog.
1. Log in to IBM Cloud.
2. Click Catalog.
3. Search for Palo Alto Networks VM-Series Firewall - BYOL in the IBM Cloud catalog

search box.
4. Click the Palo Alto Networks VM-Series Firewall - BYOL le.

STEP 2 | Configure your workspace.
1. Enter the Deployment Name (this name is displayed in the Deployment Manager). The

name must be unique and cannot conflict with any other deployment in the project.
2. Select a Resource group. For instrucons to create a resource group, see Creang a

Resource Group.
3. Enter relevant Tags. Tags help you in idenfying your deployment.

STEP 3 | Specify the values for following parameters:

Parameter Descripon Sample Value

image_name VM-Series image to be installed. pa-vm-kvm-9-1-3-1
or pa-vm-kvm-10-0-6

region VPC region that you want your VPC virtual
servers to be provisioned.

us-east
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Parameter Descripon Sample Value

ssh_key_name The name of your public SSH key to be used
for VSI. For informaon on creang an SSH
key, see Public SSH Key.

vm-series-ssh-key

subnet_id1 The ID of the subnet (management) which will
be associated with the first interface of the
VNF instance. Click the subnet details in the
VPC Subnet Lisng to determine this value.

0717-xxxxxx-xxxx-
xxxxx-8fae-xxxxx

subnet_id2 The ID of the subnet (data-plane) which will
be associated with the second interface of the
VNF instance. Click the subnet details in the
VPC Subnet Lisng to determine this value.

0717-xxxxxx-xxxx-
xxxxx-8fae-xxxxx

vnf_instance_name Name of the VNF instance to be provisioned
(lower-case).

vm-series-fw-vsi

vnf_profile The profile of compute CPU and memory
resources to be used when provisioning
the vnf instance. For more informaon, see
Instance Profiles.

bx2-8x32

vnf_security_group The name of the security group to which the
VNF Instance's first interface(management)
belongs to.

vm-series-mgmt-sg

STEP 4 | Installing the terraform template.
1. Click Install.
2. Navigate to IBM cloud > Schemacs > Workspaces and choose your workspace to view

and edit details related to your workspace.

STEP 5 | Accessing the management interface of the VM Series Firewall.
1. Navigate to IBM cloud > VPC Infrastructure > Floang IPs and copy the Floang IP of

your VPC instance on which you have deployed the VM Series Firewall.
2. Open a browser and enter the IP address in the URL region of the browser prefixing it

with hps(for example, hps://161.xxx.173.xxx). The VM Series Firewall management
interface login screen appears. If you are using a VPN connecon, you may have to
terminate the connecon before connecng to the VM-Series console (URL).

3. Login to the interface using the following credenals: Username: admin Password: admin

You will be prompted to change your password on your first login. You will be
able to access the interface only aer logging in with the changed password.
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High Resiliency for VM-Series Firewall on IBM Cloud
You can deploy the VM-Series firewalls on IBM Cloud to ensure redundancy in the network by
using the acve/acve high availability (HA) configuraon. The Network Load Balancer (NLB)
Route Mode feature is used to support the VM-Series HA and is currently supported only with
private IP and TCP data traffic.

The ingress roung capability allows you to associate route tables with the IBM Internet
gateway and add route rules to redirect the applicaon traffic through the VM-Series firewall.
This redirecon ensures that all internet traffic passes through the firewall without having to
reconfigure the applicaon endpoints.

• Configure IBM VPC VM-Series for HA
• Deploy the VM-Series Firewall
• Deploy the NLB
• Configure Security Groups
• Configure Custom Routes
• Consideraons for NLB Failovers and Custom Routes

For more informaon on Network Load Balancer for VPC Gen 2 Offering, see

• Load Balancer for VPC Gen 2 Catalog Tile
• About IBM Cloud Network Load Balancer for VPC

Configure IBM VPC VM-Series for HA
To configure the VPC resources for HA you will need to:

• Create a VPC. For instrucons on creang a VPC network, see Geng Started with VPC
network.

• Create one subnet for the VM-Series management traffic interface. This can be shared between
mulple VM-Series to support clustering.

• Create one subnet that will be shared between the VM-Series data traffic interface and the
Network Load Balancer (NLB).

• Create any addional subnets needed for the VSI workloads that will be routed through the
NLB or VNF's.

• Grant a service authorizaon for your IBM Cloud Account to allow the NLB to modify custom
routes if an NLB failover occurs.

Deploy the VM-Series Firewall
While deploying the VM-Series firewall in HA mode, you will need to ensure the following:

• The VM-Series data interface is on the same shared subnet as the NLB we will provision later.
• Allow IP Spoofing is enabled on the VM-Series data interface (shared subnet with NLB)

through the Network Interfaces page of the VPC VSI User Interface.
• Health checks for the VNF configuraon is enabled from the NLB.
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Deploy the NLB
You can deploy an NLB using the UI, CLI, or REST API. For instrucons on deploying an NLB, see
Creang a route mode Network Load Balancer for VPC.

Configure Security Groups
The VM-Series data network interface is aached to a VPC Security Group. While configuring the
Security Groups, ensure that the Security Group has Inbound rules that allow traffic on the health
port setup between the NLB and the VM-Series. For example, if the health check is set up for
TCP on Port 80 (HTTP), then create an inbound rule under the same Security Group. Addionally,
ensure that the rules are created to allow or restrict data traffic.

Configure Custom Routes
Custom routes are created to ensure that the ingress data traffic is routed through the NLB on its
way to the VM-Series and target desnaon. In some cases custom routes may also be needed
to ensure egress traffic is returned to the original client source. For more informaon, see About
roung tables and routes.

Consideraons for NLB Failovers and Custom Routes
• Deploy the NLB as an acve/passive cluster. Ensure that each node has a disnct IP and the

acve IP is used in the custom routes that are created. You can use an nslookup on the NLB
hostname, to determine the primary IP for use in your route config.

• Configure the VM-Series to allow traffic from both the acve and passive NLB nodes. This is
needed for the health check. The NLB IP's can be retrieved from the NLB UI > Overview  >
Private IPs.

• The custom routes are automacally updated to hop to the new NLB IP, if the NLB fails over to
the other node.
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Use Case: Deploy a NLB Using the VM-Series Firewall
In this example, the client is in a different zone compared to the rest of the resources.
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Step 1: The ingress roung table directs the traffic towards the LBs in the direcon of client to
server. In this case, since the client is in a different zone, the traffic source for the roung table is
the VPC Zone.

Step 2: The Load Balancer sends the packets to one of the firewalls. Since the FW DP subnets and
the server subnet are in the same VPC, they can reach each other through the default gateways.

You need not configure custom roung on the firewall if the DP interface is configured as DHCP.
If the stac IP is configured on the DP interface, then the default route needs to be configured on
the FW.

Step 3: Aach the Interface management profile that permits HTTP/HTTPS probes to the DP
interface.

Step 4: Configure the security policy to allow the ingress traffic.
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Step 5: For the return traffic moving in the direcon of server to client, there must be an egress
roung table aached to the subnet of the server, direcng the traffic (desned to the client) to
the LB. The LB forwards the packet to the same FW as the traffic in the other direcon. The FW
will forward the packet via its default gateway to the client.
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Deploying the VM-Series firewall on Alibaba Cloud protects networks you create
within Alibaba Cloud. You can deploy VM-Series firewalls to protect internet facing
applicaons and hybrid cloud deployments.

> VM-Series Firewall on Alibaba Cloud
> Minimum System Requirements for the VM-Series Firewall on Alibaba Cloud
> Prepare to Deploy the VM-Series Firewall on Alibaba Cloud
> Deploy the VM-Series Firewall on Alibaba Cloud
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VM-Series Firewall on Alibaba Cloud
You can deploy the VM-Series firewall to secure inbound and outbound north-south traffic in
Alibaba Cloud.

Securing east-west traffic within the same VPC is not supported because Alibaba Cloud
does not support subnet roung.

The VM-Series firewall on Alibaba Cloud runs on the KVM hypervisor and supports up to 8
network interfaces when you select an Alibaba Cloud instance with sufficient resources (see
Minimum System Requirements for the VM-Series Firewall on Alibaba Cloud).

The VM-Series firewall on Alibaba Cloud supports BYOL licensing and the VM-Series ELA
on Alibaba Cloud Internaonal Regions and Mainland China. PAYG licensing is not currently
supported.

In Alibaba Cloud, your VPC logically isolates your virtual network. Aer creang a VPC, you can
create VSwitches to further segment your virtual private network, as shown in the following
diagram. To secure inbound traffic, both DNAT and SNAT must be configured on the firewall.

Inbound traffic originates from a client outside of your VPC going to the VM-Series firewall
untrust interface. The firewall inspects the traffic and sends it to an applicaon through the trust
interface. Traffic returning from the applicaon must travel through the VM-Series firewall trust
interface, which inspects the return traffic flow and sends it out through the untrust interface.

Outbound traffic typically originates from an external applicaon. Typically you route the internet
facing traffic within a VPC to a NAT gateway (with EIP aached). To do this, add a default gateway
route in the VPC roung table, with the VM-Series firewall IP address of the applicaon subnet as
the next hop. Configure SNAT using the untrust interface IP to ensure traffic originang from the
internet returns through the VM-Series firewall.

Refer to Secure North-South Traffic on Alibaba Cloud for a sample configuraon.
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Minimum System Requirements for the VM-Series
Firewall on Alibaba Cloud

On Alibaba Cloud, you can deploy the VM-Series firewall on the KVM hypervisor (see VM-Series
Deployments).

• VM-Series Firewall Soware Requirements
• Alibaba Cloud Instance Type Recommendaons for the VM-Series Firewall
• Alibaba Cloud CLI

VM-Series Firewall Soware Requirements
Ensure that you have the soware and licenses required to complete a VM-Series deployment on
Alibaba Cloud.

• To deploy the VM-Series firewall on Alibaba Cloud, you must use a VM-Series image you obtain
from the Alibaba Marketplace. The image incorporates PAN-0S version 10.0.3 and VM-Series
plugin version 2.0.3.

• Before you deploy, choose the VM-Series ELA or BYOL license, a capacity license, and a
subscripon bundle. See VM-Series Model License Types.

• You must be able to SSH into the VM-Series firewall to complete the deployment. If your OS
does not support SSH, install third-party soware, such as Puy.

Alibaba Cloud Instance Type Recommendaons for the VM-Series
Firewall

Before creang the VM-Series firewall, you must choose an Elasc Compute Service (ECS)
instance type that supports the minimum system requirements for your VM-Series model. Review
the instance type documentaon to ensure the ECS instance type has the resources to secure
your network configuraon.

VM-Series Model Elasc Compute Service Instance Types

VM-100 ecs.g5.xlarge, ecs.sn2ne.xlarge

VM-300 ecs.g5.xlarge, ecs.sn2ne.xlarge

VM-500 ecs.g5.2xlarge, ecs.sn2ne.2xlarge

VM-700 ecs.g5.4xlarge, ecs.sn2ne.4xlarge

Alibaba Cloud CLI
Aliyun version 3.0.4 or higher. See Prepare to Use the Aliyun Command Line Interface.
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Prepare to Deploy the VM-Series Firewall on Alibaba
Cloud

This task uses the Aliyun CLI to create a VPC and VSwitches for the VM-Series firewall, however,
you should plan your network before you start. Evaluate the applicaons you want to protect, and
determine where you will deploy the VM-Series firewall to inspect and secure north-south traffic.

• Choose Licenses and Plan Networks
• Prepare to Use the Aliyun Command Line Interface

Choose Licenses and Plan Networks
Evaluate the applicaons you need to protect and create networks that permit the VM-Series
firewall to inspect your inbound and outbound applicaon traffic.

STEP 1 | Plan and design your VPC.
1. Plan networks, including CIDR Blocks for your VPCs and VSwitches.

Refer to Create a VPC and Configure Networks for a sample procedure.
2. Plan your IP addresses. If you need specific addresses or address ranges, refer to the

Elasc IP Address User Guide.
3. Plan security groups.

STEP 2 | Evaluate your applicaons and network configuraons and calculate the firewall capacity you
need to secure your applicaons and networks.

STEP 3 | Obtain VM-Series firewall licenses.

Although you do not need a license to install the VM-Series firewall (you can acvate a license
aer the installaon), you must choose an appropriate VM-Series model and ECS instance type
before deploying the firewall.

1. Choose a VM-Series model.

The VM-Series firewall supports up to 8 interfaces, provided the VM-Series
model and Alibaba Cloud instance have sufficient resources.You can use the
model

Use the VM-Series model you have chosen to choose one of the Alibaba Cloud Instance
Type Recommendaons for the VM-Series Firewall.

2. Choose a VM-Series capacity license that meets your needs.
3. Purchase a BYOL subscripon bundle (if you do not already have one). You receive

an auth code for your VM-Series subscripon, and you must supply it during the
deployment.

STEP 4 | Plan how to configure Alibaba accounts and permissions to access the VM-Series firewall. For
a start, see the Security FAQ, and learn about Instance RAM Roles.

VM-Series Deployment Guide Version Version 10.1 858 ©2022 Palo Alto Networks, Inc.

https://www.alibabacloud.com/help/doc-detail/54095.html
https://www.alibabacloud.com/help/doc-detail/54484.htm
https://www.alibabacloud.com/help/faq-list/65080.html
https://www.alibabacloud.com/help/doc-detail/25387.html
https://www.alibabacloud.com/help/doc-detail/25378.html
https://www.alibabacloud.com/help/doc-detail/40570.htm
https://www.alibabacloud.com/help/doc-detail/54235.html


Set Up the VM-Series Firewall on Alibaba Cloud

Prepare to Use the Aliyun Command Line Interface
This chapter focuses on the ECS Console, however, everything you do in the ECS Console can
be done from the Aliyun command line interface. The CLI is required if you want to use the VM-
Series firewall to secure load balancing on Alibaba Cloud.

Install and configure a recent version of Aliyun, the Alibaba Cloud command line interface.

STEP 1 | Create an AccessKey and save the Access Key ID and Secret in a secure place.

STEP 2 | Download a supported version of Aliyun from hps://github.com/aliyun/aliyun-cli.

STEP 3 | Install Aliyun.

STEP 4 | Configure Aliyun.

The configuraon prompts you for your Access Key informaon and other informaon.

If your deployment uses a storage bucket, the region must match the region for your bucket.

aliyun configure 
Configuring profile '' in '' authenticate mode... 
Access Key Id [*************8rq]: *************8rq 
Access Key Secret [***************************tM2]: 
***************************tM2 
Default Region Id [us-west-1]: us-west-1
Default Output Format [json]: json (Only support json))
Default Language [zh|en] en: en 
Saving profile[] ...Done. 
 available regions: 
... 
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Deploy the VM-Series Firewall on Alibaba Cloud
The VM-Series firewall assumes a minimum of three interfaces: management, untrust, and trust.
When you create an Alibaba Cloud VPC, it is logically isolated. To segment your virtual private
network into subnets you create VSwitches, each having its own CIDR block. Because the VM-
Series firewall has mulple interfaces, it can inspect traffic on all subnets.

Typically external inbound traffic encounters the VM-Series firewall untrust interface. The firewall
inspects the inbound traffic and sends it to an applicaon through the trust interface. Return
traffic from the applicaon goes to the firewall’s trust interface, where the firewall inspects the
return traffic and sends it out through the untrust interface.

The following tasks demonstrate how to use the console to create the VM-Series firewall
infrastructure.

• Create a VPC and Configure Networks
• Create and Configure the VM-Series Firewall
• Secure North-South Traffic on Alibaba Cloud
• Configure Load Balancing on Alibaba Cloud

Create a VPC and Configure Networks
Use the Alibaba Cloud console to create a VPC, VSwitches, security groups, and security group
rules.

All VM-Series firewall interfaces must be assigned an IPv4 address when deployed in a
public cloud environment. IPv6 addresses are not supported.

STEP 1 | Open the VPC console and select your region from the menu. Note, the region you select
must provide one of the instance types that Palo Alto Networks supports.

STEP 2 | From the Alibaba Cloud Console home page, select Products and Services > Networking >
Virtual Private Cloud.

STEP 3 | Create a VPC.
In this step you create a VPC and Management, Untrust, and Trust VSwitches. The ECS console
creates a VPC and a switch using the same form.

1. Select Create VPC.

Specify the VPC name, an IPv4 CIDR Block, and a descripon. Refer to Create a VPC.

Property Value

Name Your choice

IPV4 CIDR Bock Your choice. Refer to the CIDR block FAQ.
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Property Value

Resource Group Your Choice.

2. Select Create VSwitch.

• Name the VSwitch Management.

• Choose the Zone, specify an IPv4 CIDR Block that is a subset of the block you
specified for the VPC, and specify a Descripon.

• At the boom, click Add to add another vSwitch (do not click OK unl you have
added all VSwitches).

Refer to Create a VSwitch.
3. Add the Untrust VSwitch in the same manner.
4. Add the Trust VSwitch.
5. Click OK.

View the VPC details and make any changes before you click Complete.

STEP 4 | Create security groups and security group rules.

• From the Alibaba Cloud Console home page, select Elasc Compute Service > Networking
& Security > Security Groups.

• On the upper right, click Create Security Group.

1. Create the management security group.

Refer to Create a security group to fill out the following fields.

Property Value

Template Customize

Security Group Name Management

Security Group Type Basic

Network Type VPC

VPC Select the VPC you created earlier.
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Property Value

Resource Group Your choice

• Complete the form and click OK.

ECS console prompts you to create rules for this security group. This task describes
some basic security group rules that allow you to bring up the VM-Series Firewall. You
can create more rules to enforce your network security requirements.

2. Select Create Rules Now and create rules for HTTPS and SSH.

Select the Inbound tab, and click Add Security Group Rule.

• Create an Inbound rule to allow HTTPS in this security group. For example:

Property Value

Rule Direcon Inbound

Acon Allow

Protocol Type HTTPS (443)

Priority 100

Authorizaon Type

Authorizaon Object

Refer to Add security group rules.

• Click Add Security Group Rule to create an inbound rule to allow SSH on the
management interface.

Property Value

Rule Direcon Inbound

Acon Allow

Protocol Type Customized TCP

Port Range 1/65535

Authorizaon Type Refer to Add security group rules.
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Property Value

Authorizaon Object

Click OK and select Back to return to the Security Groups page.
3. Select Create Security Group and create the Untrust security group.

When prompted, create a rule for the Untrust security group.

Property Value

Rule Direcon Inbound

Acon Allow

Protocol Type Custom TCP

Port Range 1/65535

Priority 100

Authorizaon Type

Authorizaon Object

Refer to Add security group rules.

Click OK and select Back to return to the Security Groups page.
4. Create the Trust security group.

When prompted, click Add Security Group Rule and duplicate the Untrust rule.

Connue to Create and Configure the VM-Series Firewall.

Create and Configure the VM-Series Firewall
This task uses the ECS console to create a VM-Series firewall instance with a minimum of three
interfaces: management, untrust, and trust. An ECS instance supports a single NIC by default, and
automacally aaches an Elasc Network Interface (ENI) to it. To support the VM-Series firewall,
you must separately create the Untrust and Trust Elasc Network Interfaces (ENIs) and aach
them to your instance.

STEP 1 | From the Alibaba Cloud console home page, select Elasc Compute Service > Instances &
Images > Instances, and click Create Instance on the upper right.

STEP 2 | Select Custom Launch.
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STEP 3 | Basic Configuraons.
1. Fill in the following values. For example:

Property Value

Billing Method Subscripon.

Region Your choice. You can also select a Zone. The region you select
must provide one of the required instance types.

Instance Type One of the types in Alibaba Cloud Instance Type
Recommendaons for the VM-Series Firewall. You can use Type-
based Selecon to search for the instance type.

Image Select Marketplace Image and search the Alibaba Marketplace
for “VM-Series”. The image combines the OS and the VM-Series
firewall.

Storage Choose a disk type and specify 60 GB.

Snapshot Your choice.
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Property Value

Duraon Your choice.

2. Select Next: Networking.

STEP 4 | On the Networking page, supply the following values.
1. Network (select VPC).

• Choose the VPC you created in Create a VPC and Configure Networks.
• Choose the Management VSwitch.

2. Public IP Address.

If you do not have a public IP address, enable Assign Public IP address and the system
will allocate one. If you must use a specific IP address, or an address in a specific range,
you can request a custom IP address. Refer to the Elasc IP Address User Guide.

3. Security Group.

Select the Management security group.
4. Elasc Network Interface.

The Management interface is already aached to eth0.
5. Select Next: System Configuraons.
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STEP 5 | On the System Configuraons page, fill in the following values.
1. Logon Credenals: Select Key Pair.

Password authencaon is not supported.

2. Name the VM-Series firewall instance and supply a Host name.

Make any correcons.

Select Preview to view your sengs thus far.
3. Following Advanced (based or instance RAM roles or cloud-init) click Show.

• The RAM role is oponal.
• In the User Data field, enter basic bootstrap informaon as key-value pairs separated

by newlines. See Enter a Basic Configuraon as User Data (Public Clouds). For
example, enter the following in the User Data field.

type=dhcp-client
hostname=Ca-FW-DC1
vm-auth-key=7550362253****
panorama-server=10.*.*.20
panorama-server-2=10.*.*.21
tplname=FINANCE_TG4
dgname=finance_dg
op-cmd-dpdk-pkt-io=on
dhcp-send-hostname=yes
dhcp-send-client-id=yes
dhcp-accept-server-hostname=yes
dhcp-accept-server-domain=yes
authcodes=I7115398
vm-series-auto-registration-pin-id=abcdefgh1234****
vm-series-auto-registration-pin-value=zyxwvut-0987****

op-command-modes (mgmt-interface-swap and jumbo frame) are not
supported for Alibaba Cloud.

op-cmd-dpdk-pkt-io=on supports DPDK. If you want to specify
PacketMMAP, specify op-cmd-dpdk-pkt-io=off

Grouping is Oponal. Select Preview to view the configuraon before ordering.

STEP 6 | View the terms of service, and select Create Order to create the VM-Series firewall instance.

View the purchase order and select Subscribe.

STEP 7 | From the console home page, choose  > Elasc Compute Service > Networks and Security >
ENIs and select Create ENI in the top right corner. Create elasc network interfaces for the
Untrust and Trust interfaces.
1. Create the Untrust ENI.

In the Acons column, select Bind to Instance and select the instance you just created.
2. Create the Trust ENI and bind it to the instance.
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STEP 8 | Allocate Elasc IP (EIP) addresses.

Allocate EIP addresses for the VM-Series firewall Management interface and the Untrust
network interface. In this example the Trust interface is not exposed to the internet, so you
don’t need a third IP address.

If you already have two EIPs, go to the next step.

1. Associate an EIP with the VM-Series firewall Management interface.
2. Associate an EIP with the VM-Series firewall Untrust network interface.

The second interface you aach is assigned to network interface 1 on the VM-Series
firewall.

STEP 9 | Restart your instance to aach the new network interfaces.

On the Instances list, select your instance, select Manage, and select Restart on the upper
right.

STEP 10 | SSH in to the VM-Series firewall with the security key and set the admin password:

developer1$ ssh -i dev1-vpc1.pem admin@18.***.145.153
Welcome admin.

admin> configure
Entering configuration mode
[edit]
admin# set mgt-config users admin password
Enter password:<password>
Confirm password:<password>
[edit]
admin# commit

STEP 11 | Access the VM-Series firewall web interface.

Open a web browser and enter the EIP for the management interface.

Secure North-South Traffic on Alibaba Cloud
Aer creang a VPC, you can create VSwitches to segment your virtual private network into
subnets. This sample features a VPC with CIDR 192.168.0.0/16; you can enter your own values.
Four VSwitches create four subnets.

VSwitch Name Interface Sample CIDR

mgmt eth0 192.168.0.0/24

untrust eth1 192.168.1.0/24

web eth2 192.168.2.0/24

db eth3 192.168.3.0/24
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In the following diagram, the VM-Series firewall connects to two trusted subnets, web and db.
Inbound traffic is iniated when an external client accesses the VM-Series firewall’s Untrust
interface. The firewall inspects the traffic and sends it to an applicaon. For example, the firewall
sends traffic to a Web server through the Trust interface. The traffic returning from the Web
server must hit the VM-Series firewall’s Trust interface. The firewall inspects the return traffic
flow, and sends it out through the Untrust interface.

To secure inbound traffic, both DNAT and SNAT must be configured on the firewall.

STEP 1 | Create NAT rules for inbound traffic.

Here’s a sample of the NAT rules for inbound traffic protecon.

           <nat>
              <rules>
                <entry name="inbound_web">
                  <source-translation>
                    <dynamic-ip-and-port>
                      <interface-address>
                        <interface>ethernet1/2</interface>
                      </interface-address>
                    </dynamic-ip-and-port> 
                 </source-translation>
                  <destination-translation>
                    <translated-address>web_server</translated-
address>
                  </destination-translation>
                  <to>
                    <member>untrust</member>
                  </to>
                  <from>
                    <member>any</member>
                  </from>
                  <source>
                   <member>any</member>
                  </source>
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                  <destination>
                    <member>fw_untrust</member>
                  </destination>
                  <service>any</service>
                  <to-interface>ethernet1/1</to-interface>
                </entry>
              </rules>
            </nat>

        <address>
            <entry name="fw_untrust">
              <ip-netmask>192.168.1.4</ip-netmask>
            </entry>
            <entry name="fw_trust">
              <ip-netmask>192.168.2.201</ip-netmask>
            </entry>
            <entry name="web_server">
              <ip-netmask>192.168.2.203</ip-netmask>
            </entry>
        </address>

STEP 2 | Secure outbound traffic.

As shown in the diagram above, an applicaon iniates the outbound traffic. For example, a
web server must run yum install to update rpm packages. Typically the internet facing

VM-Series Deployment Guide Version Version 10.1 869 ©2022 Palo Alto Networks, Inc.



Set Up the VM-Series Firewall on Alibaba Cloud

traffic within a VPC is routed to a NAT gateway (with an EIP aached). To secure outbound
traffic, you must force outbound traffic to go through the VM-Series firewall.

1. Add a default gateway route in the VPC roung table with firewall IP in the subnet of the
web server as the next hop.

2. View your entry in the route table.

3. Configure SNAT rules using the Untrust interface IP to ensure traffic returning from the
internet goes through the VM-Series firewall.
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Here's a sample SNAT configuraon.

            <nat>              
              <rules>
                <entry name="outbound_web">
                  <source-translation>
                    <dynamic-ip-and-port>
                      <interface-address>
                        <interface>ethernet1/1</interface>
                      </interface-address>
                    </dynamic-ip-and-port>
                  </source-translation>
                  <to>
                    <member>untrust</member>
                  </to>
                  <from>
                    <member>trust</member>
                  </from>
                  <source>
                    <member>any</member>
                  </source>
                  <destination>
                    <member>any</member>
                  </destination>
                  <service>any</service>
                  <to-interface>any</to-interface>
                </entry>
              </rules>
           </nat>

Configure Load Balancing on Alibaba Cloud
On Alibaba Cloud, you can deploy the VM-Series firewall in a load balancer sandwich
configuraon where the firewall is deployed between a public network and a private network, as
shown below.
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In Create a VPC and Configure Networks, you created Untrust and Trust ENIs and aached them
to the VM-Series firewall instance as secondary ENIs.

When you use the console to add mulple backend servers to Alibaba Server Load Balancer (SLB),
the SLB sends traffic to the primary ENI of the next-hop backend servers. Because the primary
ENI is the management interface, traffic must go to the Untrust interface (a secondary ENI) for
inspecon.

To ensure that internet traffic goes to dataplane interfaces rather than the management interface,
use the Alibaba CLI to aach the VM-Series firewall untrust ENIs to your SLB instance.

You must install the Aliyun command line interface to use the following CLI commands.

STEP 1 | Create the public and private VPCs for a load balancer sandwich configuraon, and deploy
the VM-Series firewalls.

The remaining steps are sample CLI commands you can adapt to your environment.

STEP 2 | Create the load balancer.

slb CreateLoadBalancer --RegionId us-west-1 --LoadBalancerName wli-
slb 
--VpcId vpc-rj91ry36ghwgc8cf2fr7z --LoadBalancerSpec slb.s1.small 
--AddressType internet --MasterZoneId us-west-1a 
--SlaveZoneId us-west-1b 
{
        "NetworkType": "classic",
        "LoadBalancerName": "**********",
        "Address": "***********,
        "ResourceGroupId": "rg-************ofi",
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        "RequestId": "0B8BA2AA-E837-****-****-B82A8A1D5FBB",
        "AddressIPVersion": "ipv4",
        "LoadBalancerId": "lb-******************mvz",
        "VSwitchId": "",
        "VpcId": "vpc-*****************r7z"
}

STEP 3 | Add backend servers.

Use the CLI to add interfaces one at a me. The order in which you add the interfaces
determines which NIC receives the interface.

aliyun slb AddBackendServers --LoadBalancerId lb-
******************mvz
--BackendServers
'[
       {
              "ServerId":"eni-******************bzw",
              "Type":"eni","Weight":"100"
       }
]'

STEP 4 | Create an HTTP Listener that performs a health check.

aliyun slb CreateLoadBalancerHTTPListener
--LoadBalancerId lb-******************mvz
--ListenerPort 80 --StickySession on
--HealthCheck on --HealthCheckURI '/'
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Palo Alto Networks integrates as a service with Cisco Applicaon-Centric
Infrastructure (ACI). ACI is a soware-defined networking (SDN) soluon for easily
deploying new workloads and network services. Using an SDN controller called the
Cisco Applicaon Policy Infrastructure Controller (APIC), you deploy the firewall
service between Endpoint Groups (EPGs). EPGs act as a container for applicaons or
applicaon ers. When you place a firewall between EPGs, security policy configured
on the firewall secures the traffic between the EPGs. The APIC provides a single pane
of glass for managing the network topology, network policies, and connecvity for the
enre data center and supports inserng L4 - L7 devices, such as a hardware-based or
VM-Series firewall. Panorama is required for centralized security management.

> Palo Alto Networks Firewall Integraon with Cisco ACI
> Prepare Your ACI Environment for Integraon
> Integrate the Firewall with Cisco ACI in Network Policy Mode
> Endpoint Monitoring in Cisco ACI
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Palo Alto Networks Firewall Integraon with Cisco ACI
Palo Alto Networks integraon with Cisco ACI allows you to insert a firewall between EPGs as a
Layer 4 to Layer 7 service. The firewall then secures the east-west traffic between the applicaon
ers within those EPGs or north-south traffic between users and the applicaons.

The figure below shows an example of a physical ACI deployment that includes integrated Palo
Alto Network firewalls. All the enes in the ACI Fabric are connected to leaf switches and those
leaf switches are connected to larger spine switches. As users access the applicaon, the ACI
fabric moves the traffic to the correct desnaon. To secure the traffic between the applicaon
ers, the network administrator inserts the Palo Alto Networks firewalls as L4 to L7 services
between each EPG and creates a service graph to define what services the L4 to L7 device
provides.

Aer the firewall services have been deployed, traffic now flows logically as shown below. Traffic
to and from the end users and each er in the applicaon regardless of where or how each enty
is physically connected to the network.

When the firewall is integrated with Cisco ACI, traffic is sent to the firewall with a policy-based
redirect (PBR). Addionally, configuraon of the firewall and configuraon of the APIC are
completely separate. Network policy mode does not rely on any other configuraon integraon
between the firewall and the APIC, so it provides greater flexibility of configuraon and
deployment of the firewall.
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For east-west traffic, define a bridge domain and subnet in the ACI fabric for the firewall.
Configure contracts between EPGs that send traffic to the firewall using a PBR. The PBR forwards
traffic to the firewall based on policy containg the firewall’s IP and MAC address. The firewall
interfaces are always in Layer 3 mode and traffic is received and routed back to the ACI fabric.
You can configure separate interfaces for consumer and provider connecons or a single interface
for ingress and egress traffic. The procedure in this document uses a single interface because
it simplifies the integraon; you do not need to configure as many interfaces, IP addresses, or
VLANs. However, when using a single interface, you cannot uses zone informaon in defining
security policy and you must modify the default intra-zone policy on the firewall to deny traffic.

For north-south traffic, you must use a dedicated policy called an L3Out. An L3Out contains the
informaon required for the tenant to connect to external roung devices and access external
networks. L3Out connecons contain an external network EPG that represent the networks
accessible through the L3Out policy. Just as the L3Out can group all external networks into a
single EPG, you can use a vzAny object ACI to represent all EPGs in a VRF. Using a vzAny object
simples the applicaon of the outbound traffic contract because, whenever a new EPG is added to
the VRF, the contract is automacally applied. In this scenario, the external network provides the
contract and the vzAny object (all internal EPGs) consume it.

The following secon provide addional details about components and concepts that make up the
integraon between the Next-Generaon Firewall and Cisco ACI.

• Service Graph Templates
• Mul-Context Deployments

Service Graph Templates
Firewalls are deployed in Cisco ACI through service graphs. A service graph allows you to integrate
Layer 4 - Layer 7 devices, such as a firewall, into the flow of traffic without the need for the L4-L7
device to be the default gateway for the servers in the ACI fabric.

Firewalls are represented in the ACI fabric as an L4-L7 device that you configure in the APIC
as a device cluster. A single firewall or two firewalls deployed as an HA pair are configured as a
device cluster. Each device cluster has one or more logical interfaces that describe the interface
informaon of the device cluster and map the path of the member firewall with a VLAN from the
physical or virtual machine monitor (VMM) domain.

Service graph templates define the firewall device cluster that you insert into the traffic flow
between EPGs. Addionally, the service graph template defines the how the firewall is integrated
and the logical interfaces that are assigned to the consumer and provider EPGs. Aer creang
your service graph template, you assign it to EPGs and contracts. Because the service graph
template is not ed to a specific EPG or contract, you can reuse it between mulple EPGs. The
APIC then deploys the service graph template by connecng it to the bridge domain between
EPGs.

Mul-Context Deployments
Cisco ACI integraon supports physical firewalls divided into contexts that are managed by ACI as
individual firewalls. On the firewall, these contexts are the virtual systems (vsys) on the firewalls
and each firewall is licensed to support a certain number of vsys instances. When deploying a
mul-vsys firewall in ACI, you must configure a chassis manager in the tenant and assign it to the
firewall service.
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Prepare Your ACI Environment for Integraon
Before you can integrate the firewall with a device package, you must complete the following
steps to prepare your Cisco ACI environment.

STEP 1 | Deploy Panorama.

STEP 2 | Deploy the firewall.

• Physical Firewall—Connect the firewall’s out-of-band management port to one leaf switch
port and connect at least one firewall data interface to the switch. Firewall interfaces on a
physical firewall are configured with VLANs to ensure connecvity to the correct networks.
Deploy the firewall according to the plaorm-specific installaon guide.

• VM-Series Firewall—When configuring the virtual hardware for the VM-Series firewall,
set the port-group for the management interface. Each VM-Series firewall connected to
the network requires its own virtual NIC. Deploy the VM-Series firewall based on your
hypervisor.

STEP 3 | Configure the management IP address on each firewall and Panorama.

Perform inial configuraon on:

• Hardware-based firewall
• VM-Series firewall
• Panorama

STEP 4 | Add your firewall(s) to Panorama as a managed device.

STEP 5 | Install feature licenses on your firewall(s).

• Register and acvate licenses on your physical firewall.
• Register and Acvate VM-Series Model Licenseson your VM-Series firewall.
• Manage firewall licenses using Panorama.

STEP 6 | Establish Cisco ACI fabric and management connecvity.

As part of this configuraon, create a physical domain and VLAN namespace. Ensure that data
interfaces of any physical firewalls are part of the physical domain.

STEP 7 | Create a Cisco ACI VMM domain profile.

If you are using virtual machines or the VM-Series firewall, create a virtual machine monitor
(VMM) domain profile for the VMware vSphere environment. The VMM domain specifies the
connecvity policy between vSphere and the ACI fabric.
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Integrate the Firewall with Cisco ACI in Network Policy
Mode

In network policy mode, you integrate a pair of firewalls in high availability (HA) into the east-west
or north-south traffic by using a policy-based redirect to a single logical HA interface. The firewall
and ACI fabric are configured separately and address objects on the firewall are mapped to EPGs
in the ACI fabric.

You can use network policy mode to deploy a Palo Alto Networks firewall to secure east-west or
north-south traffic.

• Deploy the Firewall to Secure East-West Traffic in Network Policy Mode
• Deploy the Firewall to Secure North-South Traffic in Network Policy Mode

Deploy the Firewall to Secure East-West Traffic in Network Policy
Mode

The following procedure describes how to deploy a Palo Alto Networks firewall to secure east-
west traffic in the your Cisco ACI environment using unmanaged mode with policy-based redirect.
This procedure assumes that you have completed the following:

• Firewalls are operaonal and connected to a leaf switch in your Cisco ACI environment.
Addionally, the management interface of each firewall must be reachable by the APIC.

• Firewalls are deployed in acve/passive HA mode. This procedure does not cover HA network
setup and assumes you have completed this in advance.

To secure east-west traffic, define a bridge domain and subnet in the ACI fabric for the firewall.
Configure contracts between EPGs that send traffic to the firewall using a PBR. The PBR forwards
traffic to the firewall based on policy containing the firewall’s IP and MAC address. The firewall
interfaces are always in Layer 3 mode and traffic is received and routed back to the ACI fabric.
You can configure separate interfaces for consumer and provider connecons or a single interface
for ingress and egress traffic. The procedure in this document uses a single interface because
it simplifies the integraon; you do not need to configure as many interfaces, IP addresses, or
VLANs. However, when using a single interface, you cannot uses zone informaon in defining
security policy and you must modify the default intra-zone policy on the firewall to deny traffic.

This procedure deploys the firewall in one-arm mode. In one-arm mode, the traffic enters and
exits the firewall through a single interface. This common firewall interface is used for both
consumer and provider interfaces in the service graph template. Using a single interface simplifies
integraon with the firewall by reducing the number IP addresses, VLANs, and interfaces that
you must configure. However, a one-arm deployment model is intrazone, so you cannot use zone
informaon to define security policy.

On the firewall:

• Create a Virtual Router and Security Zone
• Configure the Network Interfaces
• Configure a Stac Default Route
• Create Address Objects for the EPGs
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• Create Security Policy Rules

On the Cisco APIC:

• Create a VLAN Pool and Domain
• Configure an Interface Policy for LLDP and LACP for East-West Traffic
• Establish the Connecon Between the Firewall and ACI Fabric
• Create a VRF and Bridge Domain
• Create an L4-L7 Device
• Create a Policy-Based Redirect
• Create and Apply a Service Graph Template

Create a Virtual Router and Security Zone
Configure a virtual router and zone on the firewall for each VRF in the tenant.

STEP 1 | Log in to the firewall.

STEP 2 | Select Network > Virtual Routers and click Add.

STEP 3 | Give the virtual router a descripve Name.

STEP 4 | Click OK.

STEP 5 | Select Network > Zones and click Add.

STEP 6 | Give the zone a descripve Name.

STEP 7 | Choose Layer 3 from the Type drop-down.
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STEP 8 | Click OK.

STEP 9 | Commit your changes.

Configure the Network Interfaces
Configure the Ethernet interfaces that connect the firewall to the ACI leaf switches. The VLAN ID
number used in this configuraon should be a member of the VLAN pool assigned to the firewalls
in ACI.

The VM-Series firewall does not support aggregate Ethernet groups.

STEP 1 | Select Network > Interfaces > Ethernet and click Add Aggregate Group.

STEP 2 | Enter a number for the aggregate group in the second Interface Name field.

STEP 3 | Select Layer 3 from the Interface Type drop-down.

STEP 4 | Select the LACP tab and click Enable LACP.

STEP 5 | Select Fast as the Transmission Rate.

STEP 6 | Under High Availability Opons, select Enable in HA Passive State.

Do not select Same System MAC Address for Acve-Passive HA. This opon makes
the firewall pair appear as a single device to the switch, so traffic will flow to both
firewalls instead of just the acve firewall.
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STEP 7 | Click OK.

STEP 8 | Click on the name of an Ethernet interface to configure it and add it to the aggregate group.
1. Select Aggregate Ethernet from the Interface Type drop-down.
2. Select the interface you defined in the aggregate Ethernet group configuraon.
3. Click OK.
4. Repeat this step for each other member interface of the aggregate Ethernet group.

STEP 9 | Add a subinterface on the aggregate Ethernet interface for the tenant and VRF.
1. Select the row of your aggregate Ethernet group and click Add Subinterface.
2. In the second Interface Name field, enter a numerical suffix to idenfy the subinterface.
3. In the Tag field, enter the VLAN tag of the subinterface.
4. Select the virtual router you configured previously from the Virtual Router drop-down.
5. Select the zone you configured previously from the Zone drop-down.
6. Select the IPv4 tab.
7. Select the Stac Type.
8. Click Add and enter the subinterface IP address and network mask in CIDR notaon.
9. Click OK.
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Configure a Stac Default Route
Configure a stac default route to direct traffic from the Ethernet subinterfaces to the subnet
router.

STEP 1 | Select Network > Virtual Routers and click on the virtual router you created previously in
this procedure.

STEP 2 | Select Stac Routes > IPv4 and click Add.

STEP 3 | Enter a descripve Name.

STEP 4 | Enter 0.0.0.0/0 in the Desnaon field.

STEP 5 | From the Interface drop-down, select the aggregate Ethernet group you created previously in
this procedure.

STEP 6 | Select IP Address from the Next Hop drop-down and enter the IP address of the next hop
router.

STEP 7 | Click OK.

STEP 8 | Click OK again.

STEP 9 | Commit your changes.

Create Address Objects for the EPGs
You must define address objects and map them to endpoint groups (EPGs) to be used in security
policy. Address groups are the best way map security groups to a group of servers using an
endpoint IP address range. Create one address object for each of your EPGs.

STEP 1 | Select Objects > Address and click Add.
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STEP 2 | Enter a descripve name for your address object.

STEP 3 | Select IP Netmask from the Type drop-down.

STEP 4 | Enter the IP Netmask.

STEP 5 | Click OK.

STEP 6 | Repeat this process for each EPG.

STEP 7 | Commit your changes.

Create Security Policy Rules
Create security policy rules to control the traffic moving between your EPGs. By default, the
firewall allows all intrazone traffic. Therefore, because the EPGs are in the same zone, all between
those EPGs is allowed. Before creang a new rules, you will change the default intrazone rule from
allow to deny.

STEP 1 | Select Policies > Security.

STEP 2 | Click on intrazone-default to highlight the row and click Override.

STEP 3 | Select the Acon tab.

STEP 4 | Select Deny from the Acon drop-down.

STEP 5 | Click OK.

STEP 6 | Configure addional security policy rules based on your needs using the address objects and
zone you created for your EPG.
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Create a VLAN Pool and Domain
Configure the VLAN pool that will be used to allocate VLANs to the firewall when you aach
interfaces to the ACI infrastructure for EPGs. The firewall’s VLAN pull should have a stac VLAN
range.

Configure a dedicated domain for the firewall. A domain for the firewall is required to map the
VLANs to the EPGs. Create a physical domain for a physical firewall and create a VMM domain for
a VM-Series firewall.

STEP 1 | Create a VLAN pool.
1. Log in to your APIC.
2. Select Fabric > Access Policies > Pools > VLAN.
3. Right-click VLAN and select Create VLAN Pool.
4. Enter a descripve Name for your VLAN pool.
5. Select Dynamic Allocaon for Allocaon Mode.
6. Click the plus (+) buon to the right of Encap Blocks.
7. Enter your VLAN range in the VLAN Range field.
8. Select Stac Allocaon form the Allocaon Mode drop-down.
9. Click OK.
10. Click Submit.

STEP 2 | (Physical firewall only) Create a physical domain.
1. Select Fabric > Access Policies > Physical and External Domains > Physical Domains.
2. Right-click Physical Domain and select Create Physical Domain.
3. Enter a descripve Name for your physical domain.
4. Select the VLAN pool you created in the previous procedure from the VLAN Pool list.
5. Click Submit.
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STEP 3 | (VM-Series firewall only) Create a VMM domain.
1. Select Virtual Networking > VMM Domains > VMware.
2. Right-click VMware and select Create vCenter Domain.
3. Enter a descripve Name for your VMM domain.
4. Select VMware vSphere Distributed Switch from the Virtual Switch drop-down.
5. Select VLAN from the Encapsulaon drop-down.
6. Select your VLAN pool from the VLAN Pool drop-down.
7. Click the plus (+) buon to the right of vCenter Credenals.
8. Enter a descripve Profile Name and your vCenter login informaon.
9. Click the plus (+) buon to the right of vCenter.
10. Enter a descripve Name.
11. Select vCenter from the Type drop-down.
12. Enter your vCenter IP address under IP/Hostname.
13. Select the vCenter Credenals profile you just created from the Associated Credenal

drop-down.
14. Click Submit.

Configure an Interface Policy for LLDP and LACP for East-West Traffic
Create policy that enables LLDP and LACP on the ACI interfaces that connect to your firewall.

LLDP is necessary for forwarding to work correctly in the ACI environment; ACI does not deploy
a subnet router interface on a leaf switch unless it detects an endpoint on the switch that requires
one. LLDP helps determine if a subnet router interface is required.

LACP provides greater resiliency and recovery speed on a link failure.

STEP 1 | Create an LLDP Interface Policy.
1. Select Fabric > Access Policies > Interface Policies > Policies > LLDP Interface.
2. Right-click on LLDP Interface and select Create LLDP Interface Policy.
3. Enter a descripve Name for your LLDP interface policy.
4. Select Enabled for Receive State.
5. Select Enabled for Transmit State.
6. Click Submit.

STEP 2 | Create a Port Channel policy to enable LACP.
1. Select Fabric > Access Policies > Interface Policies > Policies > Port Channel.
2. Right-click on Port Channel and select Create Port Channel Policy.
3. Enter a descripve Name for your port channel policy.
4. Select LACP Acve from the Mode drop-down.
5. Click Submit.
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Establish the Connecon Between the Firewall and ACI Fabric
Aach your firewall to the leaf switch through a VPC connecon using the Ethernet interface (or
aggregate Ethernet group) you configured on your firewall earlier in this procedure. Connect the
interface or interfaces to the same ports on the leaf switches.

STEP 1 | Select Fabric > Access Policies > Quick Start.

STEP 2 | Click Configure an interface, PC, and VPC.

STEP 3 | Click the green and white plus (+).

STEP 4 | Select the leaf switch or switches to which you firewall is connected from the Switches drop-
down.

STEP 5 | Click the green and white plus (+).

STEP 6 | Select VPC as the Interface Type.

STEP 7 | In the Interfaces field, enter the number of the interface your firewall uses to connect to the
leaf switch.

STEP 8 | Enter a descripve name into the Interface Selector Name field.

STEP 9 | Select LLDP-Enabled from the LLDP Policy drop-down.

STEP 10 | Select LACP Acve from the Port Channel Policy drop-down.

STEP 11 | Select Bare Metal for a physical firewall or ESX Hosts for the VM-Series from the Aached
Device Type drop-down.

STEP 12 | Select Choose One for Domain.

STEP 13 | Select the physical domain or VMM domain you created previously in this procedure from
the Domain drop-down.

STEP 14 | Click Save.

STEP 15 | Click Save and then Submit.

STEP 16 | Repeat this procedure for the second firewall in your HA pair.
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Create a VRF and Bridge Domain
A tenant requires a VRF for all bridge domains and subnets. In this example, you will create a
single, common VRF for the firewall and endpoints. Then configure a dedicated bridge domain for
your firewall and disable dataplane learning. Disabling dataplane learning is required to use Policy
Based Redirect in a bridge domain.

STEP 1 | Create a VRF.
1. On the Tenants tab, double-click on the name of your tenant.
2. Select Networking > VRFs.
3. Right-click VRFs and select Create VRF.
4. Enter a descripve Name for your VRF.
5. Clear the Create A Bridge Domain check box.
6. Click Finish.
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STEP 2 | Create a bridge domain for the firewall.
1. On the Tenants tab, double-click on the name of your tenant.
2. Select Networking > Bridge Domains.
3. Right-click Bridge Domains and select Create Bridge Domain.
4. Enter a descripve Name for your bridge domain.
5. Select the VRF you created in the previous procedure from the VRF drop-down.
6. Click Next.

Create an L4-L7 Device
You must define the firewall as an L4-L7 device in the APIC so ACI can insert it into the traffic
flow. You configure L4-L7 devices in the APIC as a device cluster, which is a construct that
represents a single firewall or a firewall HA pair acng as a single device. Device clusters have one
or more logical interfaces, which define the path of the member firewalls with a VLAN from the
physical domain.

STEP 1 | On the Tenants tab, double-click on the name of your tenant.

STEP 2 | Select Services > L4-L7 > Devices.

STEP 3 | Right-click Devices and select Create L4-L7 Device.

STEP 4 | Clear the Managed check box.

STEP 5 | Enter a descripve Name for your L4-L7 Device.

STEP 6 | Select Firewall from the Service Type drop-down.

STEP 7 | Select Physical for a physical firewall or Virtual for a VM-Series firewall from the Device Type
drop-down.

STEP 8 | Select the physical or VMM domain you created previously from the Domain drop-down.
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STEP 9 | Select HA Node for View.

STEP 10 | Under Device 1, click the plus (+) icon to the right of Device Interfaces.

STEP 11 | Enter a descripve Name for this interface.

STEP 12 | Under Path, select the path to the primary firewall in your HA pair.

STEP 13 | Click Update.

STEP 14 | Under Device 2, click the plus (+) icon to the right of Device Interfaces.

STEP 15 | Enter a descripve Name for this interface.

STEP 16 | Under Path, select the path to the secondary firewall in your HA pair.

STEP 17 | Click Update.

STEP 18 | Under Cluster, click the plus (+) icon to the right of Cluster Interfaces.

STEP 19 | Enter a descripve Name for the cluster.

STEP 20 | Select the two interfaces you configured above from the list under Concrete Interfaces.
The APIC requires that you configure two interfaces. However, because there is only one
connecon between the firewall and the ACI fabric, only one of the interfaces is used.

STEP 21 | Under Encap, enter a VLAN from the from the stac VLAN pool you created earlier. Traffic
will be redirected to the firewall on the VLAN assigned here.

STEP 22 | Click Update.
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STEP 23 | Click Finish.

Create a Policy-Based Redirect
Configure the policy based redirect that sends the traffic between your EPGs to the firewall. Policy
based redirect leverages the MAC address of the interface on the firewall. Before configuring the
PBR seng on the APIC, you must get the MAC address from the firewall.

STEP 1 | Get the MAC address of the firewall.
1. Log into the firewall CLI.
2. Use the command show interface all to display the MAC addresses of your

configured interfaces.
3. Copy the MAC address of the interface that will receive the redirected traffic.

STEP 2 | Create the L4-L7 Policy-Based Redirect.
1. Log into the APIC.
2. On the Tenants tab, double-click on the name of your tenant.
3. Select Policies > Protocol > L4-L7 Policy Based Redirect.
4. Right-click L4-L7 Policy Based Redirect and select Create L4-L7 Policy Based Redirect.
5. Enter a descripve Name for your Policy Based Redirect.
6. Click the plus (+) icon to the right of Desnaons.
7. In the IP field, enter the IP address of the interface that will receive the redirected traffic.
8. In the MAC field, enter the MAC address that you copied from the firewall CLI.
9. Click OK.
10. Click Submit.
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Create and Apply a Service Graph Template
Create a service graph template that uses the device cluster represenng the firewall in a policy-
based redirect integraon. Aer creang the service graph, you must apply it to EPGs to protect
traffic. A contract and contract filter rules define the traffic that can be forwarded to the firewall.

STEP 1 | Create a service graph template.
1. On the Tenants tab, double-click on the name of your tenant.
2. Select Services > L4-L7 > L4-L7 Service Graph Templates.
3. Right-click L4-L7 Service Graph Template and select Create L4-L7 Service Graph

Template.
4. Enter a descripve Graph Name for your service graph template.
5. Select Create a New One for Graph Type.
6. Click and drag the L4-L7 device you created in the previous procedure between the

consumer and provider EPGs.
7. Select Routed for Firewall.
8. Select Routed Redirect.
9. Click Submit.
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STEP 2 | Apply the service graph template.
1. On the Tenants tab, double-click on the name of your tenant.
2. Select Services > L4-L7.
3. In the EPGs Informaon pane, select your consumer and provider EPGs from the

Consumer EPG and Provider EPG drop-downs.
4. Select Create a New Contract.
5. Enter a descripve Contract Name.
6. Clear No Filter (Allow All Traffic). Using this opon is not recommended. To allow all

traffic between the EPGs to be redirected to the firewall, it is recommended that you
create a filter to do this.

7. Click the plus (+) icon to the right of Filter Entries.
8. Create a rule (or rules) to define what traffic is allowed to pass between the EPGs and

redirected to the firewall.
9. Click Next.

10. Select the service graph template you created in the previous procedure from the Service
Graph Template drop-down.

11. In the consumer and provider pane, select the bridge domain containing your firewall
from the BD drop-downs.

12. Select the policy based redirect you created previously from the Redirect Policy drop-
downs.

13. Select the cluster interface you created with you L4-L7 device from the Cluster Interface
drop-downs.
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Deploy the Firewall to Secure North-South Traffic in Network
Policy Mode

Use network policy mode to secure north-south traffic entering and exing your data center using
unmanaged mode with policy-based redirect. This procedure assumes that you have completed
the following:

• Firewalls are operaonal and connected to a leaf switch in your Cisco ACI environment.
Addionally, the management interface of each firewall must be reachable by the APIC.

• Firewalls are deployed in acve/passive HA mode. This procedure does not cover HA network
setup and assumes you have completed this in advance.

To establish external connecvity to networks outside of your ACI fabric, you must configure an
L3Out. And L3Out is a dedicated policy that contains the parameters required to connect external
roung devices to a tenant. Addionally, an L3Out contain an external EPG (called an external
network in the APIC UI) that represents networks accessible through the L3Out. The external EPG
is not dynamically populated and follows a zero-trust model, so you must define the networks
in the EPG. To make configuraon easier, you can configure a network of 0.0.0.0/0 to assign all
networks to the external EPG.

To secure inbound traffic, connect your firewall or firewalls in an HA pair to your border-leaf
switches. Border-leaf switches are leaf switches that provide Layer 3 connecons to external
routers. The firewalls peer with the border-leaf switches using the open shortest path first
(OSPF) protocol that is configured on each leaf switch in the vPC pair and communicates with
the firewalls using a switch virtual interface (SVI). On the firewall, you configure a virtual router
dedicated to the interfaces that connect to your data center. Addionally, this procedure includes

For outbound traffic, the firewall adverses the external networks to the border-leaf switches
using OSPF. Addionally, the external network EPG is configured to allow all networks adversed
by the firewall into that EPG. You create a contract between a vzAny managed object and the
external networks EPG to allow traffic from any EPG within the VRF to reach the external
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networks through the firewall. The vzAny managed object allows you to consolidate all EPGs in
a VRF to one or more contracts instead of creang a separate contracts for each EPG. The EPGs
collected in the vzAny managed object consume the contact provided by the external EPG.

Unlike in service manager mode, management if the ACI infrastructure and the firewalls is
completed separately.

On the APIC—

• Create a VLAN Pool and External Routed Domain
• Configure an Interface Policy for LLDP and LACP for North-South Traffic
• Create an External Routed Network
• Configure Subnets to Adverse to the External Firewall
• Create an Outbound Contract
• Create an Inbound Web Contract
• Apply Outbound and Inbound Contracts to the EPGs

On the firewall—

• Create a Virtual Router and Security Zone for North-South Traffic
• Configure the Network Interfaces
• Configure Route Redistribuon and OSPF
• Configure NAT for External Connecons

Create a VLAN Pool and External Routed Domain
Create a VLAN pool to allocate VLANs to the firewall as you aach interfaces to the infrastructure
to support the EPGs in your ACI fabric. You should use a stac VLAN range for the firewall.

Addionally, you must create a physical domain to map the VLANs to the EPGs. The following
procedure creates a physical domain dedicated to the firewall.

STEP 1 | Create a VLAN pool.
1. Log in to your APIC.
2. Select Fabric > Access Policies > Pools > VLAN.
3. Right-click VLAN and select Create VLAN Pool.
4. Enter a descripve Name for your VLAN pool.
5. Select Dynamic Allocaon for Allocaon Mode.
6. Click the plus (+) buon to the right of Encap Blocks.
7. Enter your VLAN range in the VLAN Range field.
8. Select Stac Allocaon form the Allocaon Mode drop-down.
9. Click OK.
10. Click Submit.
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STEP 2 | Create an external routed domain.
1. Select Fabric > Access Policies > Physical and External Domains > External Domains.
2. Right-click External Routed Domain and select Create Layer 3 Domain.
3. Enter a descripve Name for your physical domain.
4. Select the VLAN pool you created in the previous procedure from the VLAN Pool list.
5. Click Submit.

Configure an Interface Policy for LLDP and LACP for North-South Traffic
Create policy that enables LLDP and LACP on the ACI interfaces that connect to your firewall.

LLDP is necessary for forwarding to work correctly in the ACI environment; ACI does not deploy
a subnet router interface on a leaf switch unless it detects an endpoint on the switch that requires
one. LLDP helps determine if a subnet router interface is required.

LACP provides greater resiliency and recovery speed on a link failure.

STEP 1 | Create an LLDP Interface Policy.
1. Select Fabric > Access Policies > Interface Policies > Policies > LLDP Interface.
2. Right-click on LLDP Interface and select Create LLDP Interface Policy.
3. Enter a descripve Name for your LLDP interface policy.
4. Select Enabled for Receive State.
5. Select Enabled for Transmit State.
6. Click Submit.

STEP 2 | Create a Port Channel policy to enable LACP.
1. Select Fabric > Access Policies > Interface Policies > Policies > Port Channel.
2. Right-click on Port Channel and select Create Port Channel Policy.
3. Enter a descripve Name for your port channel policy.
4. Select LACP Acve from the Mode drop-down.
5. Click Submit.

Create an External Routed Network
The firewalls pass IP roung informaon to the ACI ovar a Layer 3 OSPF network. ACI uses a
switch virtual interface (SVI) on the leaf switches with an IP address on each switch for connecon
resilience. Create a Layer 3 routed network to peer with the firewall using OSPF.

STEP 1 | On the Tenants tab, double-click on the name of your tenant.

STEP 2 | Select Networking > External Routed Networks.

STEP 3 | Right-click External Routed Networks and select Create Routed Outside.

STEP 4 | Enter a descripve Name for your External Routed Network.

STEP 5 | Select your VRF with external connecvity from the VRF drop-down.
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STEP 6 | Select the external routed domain you created previously form the External Routed Domain
drop-down.

STEP 7 | Select OSPF.

STEP 8 | Enter an OSPF Area ID. The Area ID can be expressed in decimal number or doed decimal
form. For example, Area 1 is the same as Area 0.0.0.1 or Area 271 is the same as Area
0.0.1.15. The Area ID range is 0 (0.0.0.0) to 4294967295 (255.255.255.255).

STEP 9 | Select Regular Area for the OSPF Area Type.

STEP 10 | Click the plus (+) buon to the right of Nodes and Interface Profiles to create a Node Profile
with a node that for the border-leaf switches that connect to the firewall.

STEP 11 | Enter a descripve Name for your Node Profile.

STEP 12 | Aach nodes to your Node Profile.
1. Click the plus (+) buon to the right of Nodes. This opens the Select Node window.
2. Select the node that your firewall is connected to from the Node ID drop-down.
3. Enter the IP address of the router aached to the leaf switch in Router ID.
4. Click OK.
5. Click the plus (+) buon to the right of Nodes and Interface Profiles.
6. Enter a descripve Name for your Node Profile.
7. Click the plus (+) buon to the right of Nodes. This opens the Select Node window.
8. Select the node that your secondary HA firewall is connected to from the Node ID drop-

down.
9. Enter the IP address of the router aached to the second leaf switch in Router ID.
10. Click OK.
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STEP 13 | Aach an OSPF Interface Profile for your Node Profile.
1. Enter a descripve Name for your OSPF Interface Profile.
2. Click Next.
3. Select Create OSPF Interface Policy from the OSPF Policy drop-down.
4. Enter a descripve Name for your OSPF Interface Policy.
5. Select MTU Ignore.
6. Click Submit.
7. Click Next.
8. Click SVI.
9. Click the plus (+) buon to the right of SVI Interfaces. This opens the Select SVI window.
10. Click Virtual Port Channel.
11. Select the Path to the port and port channel interface where the firewall connects to the

leaf switch.
12. In Encap, enter the VLAN encapsulaon used for your layer 3 outside profile.
13. Select Trunk for Mode.
14. In the Side A IPv4 Primary Address field, enter the primary IP address of the path

aached to the layer 3 outside profile.
15. In the Side B IPv4 Primary Address field, enter the secondary IP address of the path

aached to the layer 3 outside profile.
16. Click OK.

STEP 14 | Click OK to close the Create Interface Profile window.

STEP 15 | Click OK to close the Create Node Profile window.

STEP 16 | Click Next.

STEP 17 | Click the plus (+) buon to the right of External EPG Networks. This opens the Create
Routed Outside window.

STEP 18 | Enter a descripve Name for you External Network.

STEP 19 | Add a subnet to you External Network.
1. Click the plus (+) buon to the right of Subnets.
2. Enter the IP address and mask of the subnet’s default gateway.
3. Select Export Route Control Subnet.
4. Select External Subnets for External EPG.
5. Click OK.

STEP 20 | Click Finish.

Configure Subnets to Adverse to the External Firewall
By default, subnets in the ACI fabric are not adversed to external networks. You must configure
the subnets to be adversed externally.
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STEP 1 | On the Tenants tab, double-click on the name of your tenant.

STEP 2 | Select Networking > Bridge Domains > <your bridge domain>.

STEP 3 | Click L3 Configuraons.

STEP 4 | Click the plus (+) buon to the right of Associated L3 Outs.

STEP 5 | Select the Layer 3 external routed network connecon you created in the previous procedure
from the L3 Out drop-down.

STEP 6 | Click Update.

STEP 7 | Select Networking > Bridge Domains > <your bridge domain> > Subnets > <externally
adversed subnet>.

STEP 8 | Set the Scope to Adversed Externally.

STEP 9 | Click Submit.

Create an Outbound Contract
Create a contract with a filter that allows DNS, NTP, HTTP, and HTTPS traffic. You will use this
contract to allow all endpoints in the VRF to reach the external networks but limits the traffic sent
to the firewall.

STEP 1 | On the Tenants tab, double-click on the name of your tenant.

STEP 2 | Select Contracts > Filters

STEP 3 | Right-click on Filters and select Create Filter.

STEP 4 | Enter a descripve Name for the filter.

STEP 5 | Create a filter entry for UDP traffic.
1. Click the plus (+) buon to the right of Entries.
2. Enter a descripve Name for the UDP filter.
3. Select IP from the EtherType drop-down.
4. Select udp from the IP Protocol drop-down.
5. Select dns from the Desnaon Port From drop-down.
6. Click Update.
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STEP 6 | Create a filter entry for TCP traffic.
1. Click the plus (+) buon to the right of Entries.
2. Enter a descripve Name for the TCP filter.
3. Select IP from the EtherType drop-down.
4. Select tcp from the IP Protocol drop-down.
5. Select dns from the Desnaon Port From drop-down.
6. Click Update.

STEP 7 | Create a filter entry for NTP traffic.
1. Click the plus (+) buon to the right of Entries.
2. Enter a descripve Name for the NTP filter.
3. Select IP from the EtherType drop-down.
4. Select udp from the IP Protocol drop-down.
5. In the Desnaon Port From field, enter 123.
6. Click Update.

STEP 8 | Create a filter entry for HTTP traffic.
1. Click the plus (+) buon to the right of Entries.
2. Enter a descripve Name for the HTTP filter.
3. Select IP from the EtherType drop-down.
4. Select tcp from the IP Protocol drop-down.
5. Select hp from the Desnaon Port From drop-down.
6. Click Update.

STEP 9 | Create a filter entry for HTTPS traffic.
1. Click the plus (+) buon to the right of Entries.
2. Enter a descripve Name for the HTTP filter.
3. Select IP from the EtherType drop-down.
4. Select tcp from the IP Protocol drop-down.
5. Select hps from the Desnaon Port From drop-down.
6. Click Update.
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STEP 10 | Click Submit.

STEP 11 | Create a contract for outbound traffic.
1. On the Tenants tab, double-click on the name of your tenant and select Contracts.
2. Right-click on Contracts and select Create Contract.
3. Enter a descripve Name for your Contract.
4. Click the plus (+) buon to the right of Subjects.
5. Enter a descripve Name for you Subject.
6. Under Filter Chain, click the plus (+) buon to the right of Filters.
7. Select the filter you created previously from the drop-down.
8. Click OK.

STEP 12 | Click Submit.

Create an Inbound Web Contract
You must also create a contract and filters to allow inbound traffic to reach the servers behind
the firewall. The following procedure describes the process of creang a contract and filters that
allows HTTP and HTTPS web traffic to access resources behind the firewall.

STEP 1 | On the Tenants tab, double-click on the name of your tenant.

STEP 2 | Select Contracts > Filters

STEP 3 | Right-click on Filters and select Create Filter.

STEP 4 | Enter a descripve Name for the filter.

STEP 5 | Create a filter entry for HTTP traffic.
1. Click the plus (+) buon to the right of Entries.
2. Enter a descripve Name for the HTTP filter.
3. Select IP from the EtherType drop-down.
4. Select tcp from the IP Protocol drop-down.
5. Select hp from the Desnaon Port From drop-down.
6. Click Update.
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STEP 6 | Create a filter entry for HTTPS traffic.
1. Click the plus (+) buon to the right of Entries.
2. Enter a descripve Name for the TCP filter.
3. Select IP from the EtherType drop-down.
4. Select tcp from the IP Protocol drop-down.
5. Select hps from the Desnaon Port From drop-down.
6. Click Update.

STEP 7 | Click Submit.

STEP 8 | Create a contract for inbound web traffic.
1. On the Tenants tab, double-click on the name of your tenant and select Contracts.
2. Right-click on Contracts and select Create Contract.
3. Enter a descripve Name for your Contract.
4. Click the plus (+) buon to the right of Subjects.
5. Enter a descripve Name for you Subject.
6. Under Filter Chain, click the plus (+) buon to the right of Filters.
7. Select the filter you created previously from the drop-down.
8. Click OK.

STEP 9 | Click Submit.

Apply Outbound and Inbound Contracts to the EPGs
Now you must apply the inbound and outbound contracts to the appropriate EPGs.

For all the EPGs (EPG collecon) within a VRF to send traffic to an external desnaon, each
internal EPG must contract with the external EPG. Typically, you would need to create a separate
contract between each internal EPG and the external EPG. However, using a vzAny object you can
apply the same contract to all EPGs dynamically. The EPG collecon consumes the contract and
the external EPG provides the contract. You can configure specific traffic profiles in the contract or
send all traffic to the firewall and allow it to control the traffic leaving the datacenter. Addionally,
any new EPG that joins the VRF will automacally has the contract applied to it.

Apply the inbound contract so the internal EPG is the provider and the external EPG is the
consumer. Traffic flowing to the internal EPG is fist checked against the contract and any allowed
traffic is then secured further by the firewall as necessary.
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STEP 1 | Apply the outbound contract to all EPGs in the VRF.
1. On the Tenants tab, double-click on the name of your tenant.
2. Select Networking > VRFs > <you VRF> > EPG Collecon for VRF.
3. Click the plus (+) buon to the right of Consumed Contracts.
4. Select your outbound contract from the Name drop-down.
5. Click Update.
6. Select Networking > External Routed Networks > <your external routed network> >

Networks > External.
7. Click the plus (+) buon to the right of Provided Contracts.
8. Select your outbound contract from the Name drop-down.
9. Click Update.

STEP 2 | Apply the inbound contract so an internal EPG provides it to the external EPG.
1. On the Tenants tab, double-click on the name of your tenant.
2. Select Applicaon Profiles > <your applicaon profile> > Applicaon EPGs > <your

applicaon EPG> > Contracts.
3. Right-click on Contracts and select Add Provided Contract.
4. Select your inbound contract from the Contract drop-down.
5. Click Submit.
6. On the same tenant, select Networking > External Routed Networks > <your external

routed network> > Networks > External.
7. On the Contracts tab, click the plus (+) buon to the right of Consumed Contracts.
8. Select your inbound contract from the Name drop-down.
9. Click Update.

Create a Virtual Router and Security Zone for North-South Traffic
Create a virtual router and security zone on the firewall to match the tenant and VRF on ACI.

STEP 1 | Log in to the firewall.

STEP 2 | Select Network > Virtual Routers and click Add.

STEP 3 | Give the virtual router a descripve Name.
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STEP 4 | Click OK.

STEP 5 | Select Network > Zones and click Add.

STEP 6 | Give the zone a descripve Name.

STEP 7 | Choose Layer 3 from the Type drop-down.

STEP 8 | Click OK.

STEP 9 | Commit your changes.
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Configure the Network Interfaces
Configure an aggregate Ethernet interface, member interfaces, and subinterface that your firewall
uses to connect to the ACI leaf switches. If you are using a VM-Series firewall, use discreet
interfaces instead of aggregate interfaces.

The VM-Series firewall does not support aggregate Ethernet groups.

STEP 1 | Select Network > Interfaces > Ethernet and click Add Aggregate Group.

STEP 2 | Enter a number for the aggregate group in the second Interface Name field.

STEP 3 | Select Layer 3 from the Interface Type drop-down.

STEP 4 | Select the LACP tab and click Enable LACP.

STEP 5 | Select Fast as the Transmission Rate.

STEP 6 | Under High Availability Opons, select Enable in HA Passive State.

Do not select Same System MAC Address for Acve-Passive HA. This opon makes
the firewall pair appear as a single device to the switch, so traffic will flow to both
firewalls instead of just the acve firewall.

STEP 7 | Click OK.
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STEP 8 | Click on the name of an Ethernet interface to configure it and add it to the aggregate group.
1. Select Aggregate Ethernet from the Interface Type drop-down.
2. Select the interface you defined in the aggregate Ethernet group configuraon.
3. Click OK.
4. Repeat this step for each other member interface of the aggregate Ethernet group.

STEP 9 | Add a subinterface on the aggregate Ethernet interface for the tenant and VRF.
1. Select the row of your aggregate Ethernet group and click Add Subinterface.
2. In the second Interface Name field, enter a numerical suffix to idenfy the subinterface.
3. In the Tag field, enter the VLAN tag of the subinterface.
4. Select the virtual router you configured previously from the Virtual Router drop-down.
5. Select the zone you configured previously from the Zone drop-down.
6. Select the IPv4 tab.
7. Select the Stac Type.
8. Click Add and enter the subinterface IP address and network mask in CIDR notaon.
9. Click OK.

Configure Route Redistribuon and OSPF
Configure route redistribuon to make roung informaon from the firewall available to the
external-facing routers aached to your leaf switches. Then configure OSPF on the firewall and
assign a router-id, area number, and interface to form adjacencies.
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STEP 1 | Configure route redistribuon.
1. Select Network > Virtual Routers and click on the virtual router you created earlier.
2. Select Redistribuon Profile > IPv4 > Add.
3. Enter a descripve Name for your redistribuon profile.
4. Enter a priority.
5. For Redistribute, select Redist.
6. Check connect and stac under General Filters.
7. Click OK.

STEP 2 | Configure OSPF.
1. Select Network > Virtual Routers and click on the virtual router you created earlier.
2. Select Router Sengs > ECMP and select Enable.
3. Select OSPF and choose Enable.
4. Enter the OSPF Router ID.
5. Under Area, click Add.
6. Enter the Area ID. This value must match the value you assigned when you created the

external routed network on the APIC. On the firewall, this must be entered in doed
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decimal form. For example, if you entered an Area ID of 10 in the APIC, the equivalent
on the firewall is 0.0.0.10.

7. Select Interface > Add.
8. Enter the interface that connects to your external network EPG and click OK.
9. Select Export Rules > Add.
10. Select the Redistribuon Profile you created above from the Name drop-down and click

OK.
11. Select Allow Redistribute Default Route.
12. Click OK.

Configure NAT for External Connecons
You only need to configure NAT if the firewall has an external interface used for connecng to
networks outside of your data center. While NAT is not required, you can use this procedure to
translate private IP addressing in your data center to public IP addressing outside. Begin seng
up NAT by configuring address translaon for traffic entering server inside an EPG in your data
center. Then configure a NAT policy that translates the source address of outbound traffic from
any EPG to the external interface IP address.

VM-Series Deployment Guide Version Version 10.1 908 ©2022 Palo Alto Networks, Inc.



Set Up a Firewall in Cisco ACI

STEP 1 | Configure address translaon for traffic entering an EPG in your data center.
1. Select Policies > NAT and click Add.
2. Enter a descripve Name for your NAT policy rule.
3. Select Original Packet and click Add under Source Zone.
4. Select the source zone from the drop-down.
5. Select the desnaon zone from the Desnaon Zone drop-down.
6. Select Any for the Source Address.
7. Click Add under Desnaon Address and enter the external IP address.

8. On the Translated Packet tab, select the Translaon Type under Desnaon Address
Translaon.

9. Select an address from the Translated Address drop-down.
10. Click OK.
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STEP 2 | Configure address translaon for outbound traffic.
1. Select Policies > NAT and click Add.
2. Enter a descripve Name for your outbound NAT policy.
3. Select Original Packet and click Add under Source Zone.
4. Select the zone that matches your ACI tenant and VRF.
5. Select the external zone from the Desnaon Zone drop-down.

6. On the Translated Packet tab, select the Translaon Type under Source Address
Translaon.

7. Enter addional required address informaon.
8. Click OK.

STEP 3 | Commit your changes.
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Endpoint Monitoring in Cisco ACI
The Cisco ACI plugin for Panorama allows you to build security policy for your Cisco ACI fabric
using Dynamic Address Groups. The plugin monitors for changes in an Applicaon Policy
Infrastructure Controller (APIC) fabric in your Cisco ACI environment and shares that informaon
with Panorama. Each Panorama with the Cisco ACI plugin installed can support up to 16 APIC
clusters. And each monitoring definion has one cluster and one nofy group.

The number of endpoints that the Cisco ACI plugin can monitor is dependent the amount of
memory allocated to Panorama. If you have a Panorama virtual appliance, make sure you assign
the necessary amount of memory for the endpoints in your environment. See the Panorama
Admin Guide for more informaon about preparing your virtual Panorama.

Panorama Memory Endpoints

8GB 10,000

16GB 20,000

The Cisco ACI plugin processes the endpoint informaon and converts it into a set of tags that
can be used as match criteria for placing IP addresses in dynamic address groups. The tags are
constructed in the following format:

cisco.cl_<cluster>.tn_<tenant>.ap_<app-profile>.{epg_<EPG> | uepg_<micro-EPG>}

• cisco.cl_<cluster>—this tag groups IP addresses into a dynamic address group based on the
Cisco ACI cluster and displays the name of your cluster.

• cisco.cl_<cluster>.tn_<tenant>—this tag groups IP addresses into a dynamic address group
based on tenant and displays the name of your cluster and tenant.

• cisco.cl_<cluster>.tn_<tenant>.ap_<app-profile>—this tag groups IP addresses into a dynamic
address group base on applicaon profile and displays the name of your cluster, tenant, and
applicaon profile.

• cisco.cl_<cluster>.tn_<tenant>.ap_<app-profile>.epg_<EPG>—this tag groups IP addresses
into a dynamic address group based on EPG and displays the name of your cluster, tenant,
applicaon profile, and EPG.

• cisco.cl_<cluster>.tn_<tenant>.ap_<app-profile>.uepg_<micro-EPG>—this tag groups IP
addresses into a dynamic address group based on micro-EPG and displays the name of your
cluster, tenant, applicaon profile, and micro-EPG.

• cisco.cl_<cluster>.tn_<tenant>.l2out_<L2-external-endpoint>—this tag groups IP addresses
into dynamic address groups based on L2 external endpoint and displays the name of you
cluster, tenant, and L2 external endpoint.

• cisco.cl_<cluster>.tn_<tenant>.bd_<bridge-domain>.subnet_<subnet>—this tag groups IP
address into a dynamic address group based on subnet and displays the name of you cluster,
tenant, bridge domain, and subnet.

To retrieve endpoint IP-address-to-tag mapping informaon, you must configure a Monitoring
Definion for each APIC fabric in your Cisco ACI environment. The Monitoring Definion specifies
the username and password that allows Panorama to connect to the APICs. It also specifies the
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device groups and corresponding nofy groups containing the firewalls to which Panorama pushes
the tags. Aer you configure the Monitoring Definion and the Cisco ACI plugin retrieves the tags,
you can create dynamic address groups and add the tags as match criteria.

The Cisco ACI plugin uses two intervals to retrieve informaon from the APIC. The first is the
monitoring interval.

• Monitoring interval—The monitoring interval is the amount of me that the plugin waits before
querying for changes in the fabric. If no changes occurred, the monitoring interval resets.
If changes are detected, the plugin processes the changes before reseng the monitoring
interval. The default monitoring interval is 60 seconds. You can set the monitoring interval from
60 seconds to one day (86,400 seconds).

• Full-sync interval—The full-sync interval is the amount of me that the plugin waits before
updang the dynamic objects from all fabrics regardless of any changes occurred. This
ensures that the plugin is synchronized with the fabric even if a change event is missed by
the monitoring interval. The default full-sync interval is 10 minutes. You can set the full-sync
interval from 600 seconds (10 minutes) and 86,400 seconds (one day).

You must configure the full-sync interval through the Panorama CLI.

If you configure a value for the monitoring interval greater than that of the full-sync
interval, the full-sync interval is ignored and a full synchronizaon is performed at every
monitoring interval.

If Panorama loses its connecon with the APIC, Panorama will aempt to reconnect five mes.
Aer five failed aempts, Panorama stops monitoring for changes in your clusters and displays the
reconnecon aempts in the system log. To recover and begin monitoring your clusters again, you
must perform a commit on Panorama.

• Install the Panorama Plugin for Cisco ACI
• Configure the Cisco ACI Plugin
• Panorama Plugin for Cisco ACI Dashboard

Install the Panorama Plugin for Cisco ACI
To get started with endpoint monitoring on Cisco ACI, download and install the Cisco ACI plugin
on Panorama.

If you have a Panorama HA configuraon, repeat this installaon process on each Panorama peer.
When installing the plugin on Panoramas in an HA pair, install the plugin on the passive peer
before the acve peer. Aer installing the plugin on the passive peer, it will transion to a non-
funconal state. Installing the plugin on the acve peer returns the passive peer to a funconal
state.

If you have a standalone Panorama or two Panorama appliances installed in an HA pair with
mulple plugins installed, plugins might not receive updated IP-tag informaon if one or more of
the plugins is not configured. This occurs because Panorama will not forward IP-tag informaon
to unconfigured plugins. Addionally, this issue can occur if one or more of the Panorama plugins
is not in the Registered or Success state (posive state differs on each plugin). Ensure that your
plugins are in the posive state before connuing or execung the commands described below.

If you encounter this issue, there are two workarounds:
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• Uninstall the unconfigured plugin or plugins. It is recommended that you do not install a plugin
that you do not plan to configure right away

• You can use the following commands to work around this issue. Execute the following
command for each unconfigured plugin on each Panorama instance to prevent Panorama from
waing to send updates. If you do not, your firewalls may lose some IP-tag informaon.

request plugins dau plugin-name <plugin-name> unblock-device-push yes

You can cancel this command by execung:

request plugins dau plugin-name <plugin-name> unblock-device-push no

The commands described are not persistent across reboots and must be used again for any
subsequent reboots. For Panorama in HA pair, the commands must be executed on each
Panorama.

STEP 1 | Verify that your virtual Panorama has enough memory to support the number endpoints in
your ACI environment.

STEP 2 | Select Panorama > Plugins.

STEP 3 | Select Check Now to retrieve a list of available updates.

STEP 4 | Select Download in the Acon column to download the plugin.

STEP 5 | Select the version of the plugin and click Install in the Acon column to install the plugin.
Panorama will alert you when the installaon is complete.

Configure the Cisco ACI Plugin
Aer installing the plugin, you must set the monitoring interval, configure a nofy group, and
establish a connecon between Panorama and the APIC fabric.

STEP 1 | (Oponal) Configure the full-sync interval.
1. Log in to the Panorama CLI.
2. Enter configure mode.

admin@Panorama> configure
3. Use the following command to set the full-sync interval. The default interval is 600

seconds (10 minutes). The range is 600 seconds to 86,400 seconds (one day).
admin@Panorama# set plugins cisco full-sync-interval <interval-in-
seconds>

STEP 2 | Log in to the Panorama web interface.

STEP 3 | You must add the firewalls as managed devices on Panorama and create Device Groups so
that you can configure Panorama to nofy these groups with the VM informaon it retrieves.
Device groups can include VM-Series firewalls or virtual systems on the hardware firewalls.
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STEP 4 | Enable monitoring, set the monitoring interval, and enable bypass proxy.
1. Select Panorama > Cisco ACI > Setup > General.
2. Select Enable Monitoring. This enables monitoring for all clusters in your deployment.
3. Set the Monitoring Interval in seconds. The monitoring interval is how oen Panorama

retrieves updated network informaon from the APIC. The default value is 60 seconds
and the range is 60 seconds to 86,400 seconds (one day).

4. (Oponal) Select Bypass Proxy to Bypass proxy server sengs, configured on Panorama
under Panorama > Setup > Services > Proxy Server, for communicaon between
Panorama and the APIC. This allows Panorama to communicate directly with the APIC
while maintaining proxied communicaon for other services.

STEP 5 | Create a nofy group.
1. Select Panorama > Cisco ACI > Setup > Nofy Groups.
2. Click Add.
3. Enter a descripve Name for your nofy group.
4. Select the device groups in your ACI deployment.
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STEP 6 | Add ACI fabric informaon.
1. Select Panorama > Cisco ACI > Setup > ACI Fabric.
2. Enter a descripve Name for your cluster.
3. Enter the IP address or FQDN for each APIC in the cluster as a comma-separated list.

When using FQDN, do not include hps:// in the URL.

4. Enter your APIC username.
5. Enter and confirm your APIC password.
6. Click OK.

STEP 7 | Configure the Monitoring Definion.
1. Select Panorama > Cisco ACI > Monitoring Definion and click Add.
2. Enter a descripve Name and oponally a descripon to idenfy the Cisco ACI cluster

for which you use this definion.
3. Select the Cluster Info and Nofy Group.
4. Click OK.

STEP 8 | Commit your changes.
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STEP 9 | Verify that you can view the EPG informaon on Panorama, and define the match criteria for
Dynamic Address Groups.

Some browser extensions may block API calls between Panorama and the APIC which
prevents Panorama from receiving match criteria. If Panorama displays no match
criteria and you are using browser extensions, disable the extensions and Synchronize
Dynamic Objects to populate the tags available to Panorama.

Panorama does not immediately process new monitoring definions and populate the
match criteria available to dynamic address. You should wait for the duraon of your
configured monitoring interval before verifying that EPG informaon.

STEP 10 | Verify that addresses in your EPGs are added to dynamic address groups.
1. Select Panorama > Objects > Address Groups.
2. Click More in the Addresses column of a dynamic address group.

Panorama displays a list of IP addresses added to that dynamic address group based on
the match criteria you specified.

STEP 11 | Use dynamic address groups in policy.
1. Select Policies > Security.
2. Click Add and enter a Name and a Descripon for the policy.
3. Add the Source Zone to specify the zone from which the traffic originates.
4. Add the Desnaon Zone at which the traffic is terminang.
5. For the Desnaon Address, select the Dynamic address group you just created.
6. Specify the acon— Allow or Deny—for the traffic, and oponally aach the default

security profiles to the rule.
7. Repeats Steps 1 through 6 to create another policy rule.
8. Click Commit.

See Use Dynamic Address Groups in Policy for more informaon.

STEP 12 | You can update the dynamic objects from the APIC at any me by synchronizing dynamic
objects. Synchronizing dynamic objects enables you to maintain context on changes in the

VM-Series Deployment Guide Version Version 10.1 916 ©2022 Palo Alto Networks, Inc.

https://docs.paloaltonetworks.com/pan-os/10-1/pan-os-admin/policy/monitor-changes-in-the-virtual-environment/use-dynamic-address-groups-in-policy.html


Set Up a Firewall in Cisco ACI

virtual environment and allows you to enable applicaons by automacally updang the
Dynamic Address Groups used in policy rules.
1. Select Panorama > Cisco ACI > Monitoring Definion.
2. Click Synchronize Dynamic Objects.

On HA failover, the newly acve Panorama aempts to reconnect to the APIC and
retrieve tags for all monitoring definions. If there is an error with reconnecng even
one monitoring definion, Panorama generates a system log message

Unable to process subscriptions after HA switch-over;
 user-intervention required.

When you see this error, you must log in to Panorama and fix the issue, for example
remove an invalid APIC IP or provide valid credenals, and commit your changes to
enable Panorama to reconnect and retrieve the tags for all monitoring definions. Even
when Panorama is disconnected from the APIC, the firewalls have the list of all tags
that had been retrieved before failover, and can connue to enforce policy on that
list of IP addresses. If you perform a commit before resolving the failover error, the
newly acve Panorama will not push any IP-to-tag mapping informaon and clearing
the mapping informaon from the firewalls. As a best pracce, to monitor this issue,
configure acon-oriented log forwarding to an HTTPS desnaon from Panorama so
that you can take immediate acon.

Panorama Plugin for Cisco ACI Dashboard
The Panorama plugin for Cisco ACI dashboard provides a bird’s-eye view of the ACI infrastructure
monitored by the plugin. The dashboard consists of two pages—the first page provides an
overview of various objects monitored by the plugin on a set of clickable les; clicking a le takes
you to the second page that provides further informaon about the object displayed on the le.

Aer installing the plugin, you can access the dashboard by selecng Panorama > Cisco ACI >
Dashboard.

The dashboard only queries for and counts pre-rule security policies configured on
Panorama; it does not include post-rules, default-rules, or NAT rules.

Dashboard Tiles Descripon

Tenant Tags Displays the total number of tenants Panorama retrieved from the
APIC. Addionally, it displays the number of dynamic address groups
associated with tenants and the number of tenants used in policy.
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Dashboard Tiles Descripon
If a
tenant’s
health
score
is zero
(0) on
the
APIC,
Panorama
does
not
retrieve
informaon
about
that
tenant.
Therefore,
the
tenant
count
on
Panorama
will
not
match
the
total
on the
APIC.

Click the le to drill down and view the following columns.

• Tenant Name—list all the tenants retrieved by Panorama.
• Tenant Tag—the Panorama tag associated with each tenant.
• Dynamic Address Group—displays the dynamic address groups

associated with the listed tag.
• In Policy—shows if the listed dynamic address group is used in policy.

Applicaon Profiles Displays the total number of applicaon profiles Panorama retrieved
from the APIC. Addionally, it displays the number of dynamic
address groups associated with applicaon profiles and the number of
applicaon profiles used in policy.

Click the le to drill down and view the following columns.

• Applicaon Profile Name—lists all applicaon profiles retrieved by
Panorama.

• Tenant Name—displays the tenant associated with the listed
applicaon profile.

• Applicaon Profile Tag—the Panorama tag associated with each
applicaon profile.

• Dynamic Address Group—displays the dynamic address groups
associated with the listed tag.

• In Policy—shows if the listed dynamic address group is used in policy.
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Dashboard Tiles Descripon

End Point Groups Displays the total number of end point groups (EPG) Panorama
retrieved from the APIC. Addionally, it displays the number of dynamic
address groups associated with EPGs and the number of EPGs used in
policy.

Click the le to drill down and view the following columns.

• EPG Name—lists all EPGs retrieved by Panorama.
• Applicaon Profile Name—lists the EPG’s associated applicaon

profile.
• Tenant Name—displays the tenant associated with the listed

applicaon profile.
• EPG Tag—the Panorama tag associated with each EPG.
• Dynamic Address Group—displays the dynamic address groups

associated with the listed tag.
• In Policy—shows if the listed dynamic address group is used in policy.

Micro End Point
Groups

Displays the total number of micro end point groups (EPG) Panorama
retrieved from the APIC. Addionally, it displays the number of dynamic
address groups associated with micro EPGs and the number of micro
EPGs used in policy.

Click the le to drill down and view the following columns.

• Micro EPG Name—lists all EPGs retrieved by Panorama.
• Applicaon Profile Name—lists the Micro EPG’s associated

applicaon profile.
• Tenant Tag—displays the tenant associated with the listed applicaon

profile.
• Micro EPG Tag—the Panorama tag associated with each Micro EPG.
• Dynamic Address Group—displays the dynamic address groups

associated with the listed tag.
• In Policy—shows if the listed dynamic address group is used in policy.

Bridge Domains Displays the total number of bridge domains Panorama retrieved from
the APIC. Addionally, it displays the number of dynamic address
groups associated with brdige domains and the number of bridge
domains used in policy.

Click the le to drill down and view the following columns.

• Bridge Domain Name—lists all bridge domains retrieved by
Panorama.

• Tenant Name—displays the tenant associated with the listed bridge
domain.
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Dashboard Tiles Descripon
• Bridge Domain Tag—the Panorama tag associated with each bridge

domain.
• Dynamic Address Group—displays the dynamic address groups

associated with the listed tag.
• In Policy—shows if the listed dynamic address group is used in policy.

Service Graphs Displays the total number of Service Graphs monitored by the plugin
as well as well as the number of firewalls in line with monitored service
graphs.

Click the le to drill down and view the following columns.

• Service Graph Name—lists all service graphs retrieved by Panorama.
• Producer EPG—displays the producer EPG associated with the

service graph.
• FW InLine—displays the firewall associated with the service graph.
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CSP

You can deploy the VM-Series firewall as a network virtual service on the Cisco Cloud
Security Plaorm (CSP). Because the Cisco CSP is a RHEL KVM plaorm, the VM-
Series firewall is deployed using the VM-Series firewall for KVM base image.

With the VM-Series firewall on Cisco CSP, you can protect your workloads, prevent
advanced threats, and improve visibility into the applicaons on your virtual network.

> VM-Series on Cisco CSP System Requirements
> Deploy the VM-Series Firewall on Cisco CSP
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VM-Series on Cisco CSP System Requirements
You can create and deploy mulple instances—standalone or as an HA pair—of the VM-Series
firewall on your Cisco CSP.

The VM-Series firewall has the following requirements:

• See the Compability Matrix for supported versions of CSP and PAN-OS.
• Bootstrap Package converted to a ISO file
• See VM-Series System Requirements for the minimum hardware requirements for your VM-

Series model.
• Minimum of two network interfaces (vNICs). One is a dedicated vNIC for the management

interface and one is for the data interface. You can then add up to eight more vNICs for data
traffic.

• The VM-Series firewall on Cisco CSP supports all VM-Series models except the VM-50.
• SR-IOV, packet MMAP, and DPDK mode are supported.
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Deploy the VM-Series Firewall on Cisco CSP
Complete the following procedure to deploy the VM-Series firewall on Cisco CSP.

STEP 1 | Download the VM-Series qcow2 base image file from the Customer Support Portal.

STEP 2 | Create a bootstrap ISO file for the VM-Series firewall.
1. Create a Bootstrap Package for your VM-Series firewall.
2. Create an ISO file containing the bootstrap package using your preferred tool.

STEP 3 | Log in to the Cisco CSP web interface.

STEP 4 | Upload the VM-Series firewall qcow2 image and ISO file.
1. Select Configuraon > Repository.
2. Click the plus (+) icon.
3. Click Browse and navigate to your qcow2 file.
4. Click Upload.
5. Click Browse and navigate to your ISO file.
6. Click Upload.
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STEP 5 | Create the VM-Series firewall service.
1. Enter a descripve Name for the VM-Series firewall.
2. Select the Target Host Name from the drop-down.
3. Select the qcow2 file you uploaded from the Image Name drop-down.

4. Select the Day Zero Config.

1. Click the Day Zero Config plus (+) icon.
2. Select the bootstrap ISO file from the Source File Name drop-down.
3. Click Submit.

5. Allocate the number of cores and memory required for your VM-Series firewall model.
6. Add enough vNICs to support the number of VM-Series interfaces configured in your

bootstrap ISO file.

See the Cisco Cloud Service Plaorm documentaon for more informaon about creang and
deploying a service instance.

STEP 6 | Aer the bootstrap process is complete, log in to your VM-Series firewall using the
management IP address your specified in the bootstrap ISO file.

The firewall should be up and configure based on the parameters you defined in the bootstrap
package.
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Endpoint Monitoring for Cisco TrustSec
Install and configure the Panorama plugin for Cisco TrustSec to retrieve the IP
addresses of endpoints in your environment and build security policy for those
endpoints using Dynamic Address Groups.

> Panorama Plugin for Cisco TrustSec
> Install the Panorama Plugin for Cisco TrustSec
> Configure the Panorama Plugin for Cisco TrustSec
> Troubleshoot the Panorama Plugin for Cisco TrustSec
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Panorama Plugin for Cisco TrustSec
The Panorama plugin for Cisco TrustSec enables you to create security policy for your TrustSec
environment using dynamic address groups. The plugin monitors for changes in TrustSec security
groups and registers that informaon with Panorama and forwards IP informaon to the firewall,
so Panorama can apply the correct policy to corresponding endpoints. The Panorama plugin for
Cisco TrustSec supports up to 16 pxGrid (Cisco ISE) servers.

The Panorama plugin for Cisco TrustSec currently supports dynamic objects but not stac
objects.

The Panorama plugin processes the endpoint informaon and converts it to a set of tags that you
can use as match criteria for placing IP addresses in dynamic address groups. Panorama creates
a tag for each security group tag (SGT) on your pxGrid servers. The tags are constructed in the
following format:

cts.svr_<pxgrid-server-name>.sgt_<SGT-name>

To retrieve endpoint IP-address-to-tag mapping informaon, you must configure a Monitoring
Definion for each pxGrid server in your environment. The pxGrid server configuraon specifies
the username and password and is referenced by the monitoring definion that allows Panorama
to connect to the pxGrid. Addionally, you can configure the plugin to verify the pxGrid
server identy with a cerficate profile on Panorama. It also specifies the device groups and
corresponding nofy groups containing the firewalls to which Panorama pushes the tags. Aer
you configure the Monitoring Definion and the plugin retrieves the tags, you can create dynamic
address groups and add the tags as match criteria.

The Panorama Plugin for Cisco TrustSec version 1.0.2 and later supports Bulk Sync and PubSub
monitoring modes. The plugin selects a mode based on the Panorama version—Bulk Sync mode if
the Panorama version is earlier than 10.0.0, and PubSub mode on Panorama 10.0.0 and later. The
user interface displays the configuraon opons for the default monitoring mode.

• Bulk Sync
• PubSub

Bulk Sync
Bulk Sync mode uses two intervals to retrieve informaon from your pxGrid servers—the
monitoring interval and full-sync interval. This mode is the default when the Panorama Plugin
for Cisco TrustSec version 1.0.2 or later is installed on a Panorama version earlier than 10.0.0.
Panorama versions earlier than 10.0.0 support IP-tab updates to configd every 10 seconds.

• Monitoring interval—The monitoring interval is the amount of me that the plugin waits before
querying for changes. If no changes have occurred, the monitoring interval resets. If there are
changes, the plugin processes the changes before reseng the monitoring interval. The default
monitoring interval is 60 seconds. You can set the monitoring interval from 10 seconds to one
day (86,400 seconds).

The minimum monitoring interval is 30 seconds when the Panorama plugin for Cisco
TrustSec 1.0.0 is installed.
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• Full-sync interval—The full-sync interval is the amount of me that the plugin waits before
updang the dynamic objects from all pxGrid servers regardless of any changes occurred. This
ensures that the plugin is synchronized with the pxGrid server even if a change event is missed
by the monitoring interval. You can set the full-sync interval from 600 seconds (10 minutes) to
86,400 seconds (one day). You must configure the full-sync interval from the Panorama CLI.

If the monitoring interval is greater than the full-sync interval, the full-sync interval is
ignored and a full synchronizaon is performed at every monitoring interval.

PubSub
PubSub mode monitors noficaons directly from the Cisco ISE server (the subscripon daemon),
parses for IP tags, and sends relevant informaon to the tag processing daemon (tag-proc). PubSub
is the default mode when the Panorama Plugin for Cisco TrustSec version 1.0.2 or later is installed
on Panorama version 10.0.0 or later. Panorama versions 10.0.0 or later support IP-tab updates to
configd every 100 milliseconds.

• Push interval—The push interval is the amount of me between pushes. If the previous push
takes too much me, the next push is triggered as soon as it finishes. The minimum push
interval is 100 milliseconds (0 seconds) and the maximum is 60 seconds. The default push
interval is 0 seconds.

• Enable Full Sync—Enable this opon to trigger a complete update. If you enable full sync, you
can set the full-sync interval. Default is no.

• Full-sync interval—The full-sync interval is the amount of me that the plugin waits before
updang the dynamic objects from all pxGrid servers regardless of any changes occurred. The
default full-sync interval is 10 minutes. You can set the full-sync interval from 600 seconds
(10 minutes) to 86,400 seconds (one day). You must configure the full-sync interval from the
Panorama CLI.

• Reconnecon interval—The inial reconnecon interval is 1 second, and it is doubled if the
previous reconnecon failed. The maximum reconnecon interval is 64 sec. There is no limit to
the number of reconnecon aempts.
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Install the Panorama Plugin for Cisco TrustSec
To get started with endpoint monitoring with Cisco TrustSec, download and install the Cisco
TrustSec plugin on Panorama. To correlate the plugin version with the Panorama version, see
Panorama Plugins in the Compability Matrix.

Cisco TrustSec plugin upgrade or downgrade requires a commit.

If you have a Panorama HA configuraon, repeat this installaon process on each Panorama
peer. When installing the plugin on Panorama appliances in an HA pair, install the plugin on the
passive peer before the acve peer. Aer installing the plugin on the passive peer, it will transion
to a non-funconal state. Installing the plugin on the acve peer returns the passive peer to a
funconal state.

If you have a standalone Panorama or two Panorama appliances installed in an HA pair with
mulple plugins installed, plugins might not receive updated IP-tag informaon if one or more of
the plugins is not configured. This occurs because Panorama will not forward IP-tag informaon
to unconfigured plugins. Addionally, this issue can occur if one or more of the Panorama plugins
is not in the Registered or Success state (posive state differs on each plugin). Ensure that your
plugins are in the posive state before connuing or execung the commands described below.

If you encounter this issue, there are two workarounds:

• Uninstall the unconfigured plugin or plugins. It is recommended that you do not install a plugin
that you do not plan to configure right away

• You can use the following commands to work around this issue. Execute the following
command for each unconfigured plugin on each Panorama instance to prevent Panorama from
waing to send updates. If you do not, your firewalls may lose some IP-tag informaon.

request plugins dau plugin-name <plugin-name> unblock-device-push yes

You can cancel this command by execung:

request plugins dau plugin-name <plugin-name> unblock-device-push no

The commands described are not persistent across reboots and must be used again for any
subsequent reboots. For Panorama in HA pair, the commands must be executed on each
Panorama.

STEP 1 | Select Panorama > Plugins.

STEP 2 | Click Check Now to get the latest version of the plugin.

STEP 3 | Select Download in the Acon column to download the plugin.

STEP 4 | Select the version of the plugin and click Install in the Acon column to install the plugin.
Panorama will alert you when the installaon is complete.
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Configure the Panorama Plugin for Cisco TrustSec
Aer you install the plugin, you must also assign a nofy group to your Cisco TrustSec plugin
configuraon. A nofy group is a list of device groups that includes the firewalls to which
Panorama should push all the tags it retrieves from the pxGrid server.

Each Panorama with the Cisco TrustSec plugin installed can support up to 16 pxGrid servers and
16 monitoring definions. And each monitoring definion has one pxGrid server and one nofy
group.

The Panorama plugin for Cisco TrustSec currently supports dynamic objects but not stac
objects.

The following configuraon instrucons cover both Bulk Sync and PubSub monitoring modes;
some user interface features are enabled, or visible based on the monitoring mode.

STEP 1 | Configure the full-sync interval if you want to change it from the default 600 seconds (10
minutes).
1. Log in to the Panorama CLI.
2. Enter configure mode.

admin@Panorama> configure
3. Use the following command to set the full-sync interval. The range is 600 seconds to

86,400 seconds (one day).
admin@Panorama# set plugins cisco_trustsec full-sync-interval
<interval-in-seconds>

STEP 2 | Log in to the Panorama web interface.

STEP 3 | You must add the firewalls as managed devices on Panorama and create Device Groups so
that you can configure Panorama to nofy these groups with the VM informaon it retrieves.
Device groups can include VM-Series firewalls or virtual systems on the hardware firewalls.
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STEP 4 | Configure Cisco TrustSec monitoring.
1. Select Panorama > Cisco TrustSec > Setup > General.

Enable Cisco TrustSec Monitoring is enabled by default. This enables monitoring for all
clusters in your deployment.

The user interface selects the PubSub monitoring mode if the Panorama plugin for Cisco
TrustSec is 1.0.2 or later is installed on Panorama 10.0.0 or later:

The plugin selects Bulk Sync mode when it is installed on a Panorama version earlier than
10.0.0:

2. Click the gear to edit the setup parameters.

• Push Interval (PubSub only)—Minimum 0, maximum 60 seconds, default is 0 (100
milliseconds).

• Enable Full Sync (PubSub only, oponal)—Select this oponal to enable a full sync.
Default is no.

• Full Sync Interval.

• PubSub—If Enable Full Sync is selected, you can set the full sync interval in
seconds. Range is 600 seconds to 86400 seconds (one day), and the default value
is 600

• Bulk Sync—Enabled by default in Bulk Sync mode. Range is 600 seconds to 86400
seconds (one day), and the default value is 600.

• Monitoring Interval (Bulk Sync only)—10 to 86400 seconds, default is 60—Set the
polling interval at which Panorama queries the pxGrid server for endpoint address
informaon. This is the me period between the end of a monitoring event and the
start of the next event.
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STEP 5 | Create a nofy group.
1. Select Panorama > Cisco TrustSec > Setup > Nofy Groups.
2. Click Add.
3. Enter a descripve Name for your nofy group.
4. Select the device groups you created in previously.

STEP 6 | (Oponal) If enabling server identy verificaon of the pxGrid server, configure a cerficate
profile on Panorama.

STEP 7 | Create, acvate, and approve the pxGrid client name and client password.
1. Log in to the Panorama CLI.
2. Execute the following command to create the client name.

• If you have a cerficate profile, create the client name as follows:

admin@Panorama> request plugins cisco_trustsec create-account
client-name <client-name> host <ise-server-ip>

• If you skipped Step 6 and you do not have a cerficate, enter:

request plugins cisco_trustsec create-account server-cert-
verification-enabled no client-name <client-name>host <host-
name>

3. Execute the following command to create the client name.

admin@Panorama> request plugins cisco_trustsec create-account
 client-name test host 10.10.10.15

AccountCreate in progress...
AccountCreate successful.
  client nodename: test
  client password: PmVKBmPgf63Hypq

AccountActivate in progress...
AccountActivate successful.
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Please approve the account on the server.

4. Log in to your Cisco ISE server to approve the account.
5. Select Administraon > pxGrid Services > All Clients.
6. Select the client name you create on Panorama.
7. Click Approve.

STEP 8 | Add pxGrid server informaon. The Panorama plugin for Cisco TrustSec supports up to 16
pxGrid (Cisco ISE) servers.
1. Select Panorama > Cisco TrustSec > Setup > pxGrid Server.
2. Enter a descripve Name for your pxGrid server.
3. In the Host field, enter the IP address or FQDN for your pxGrid server.
4. Enter the client name you created in the previous step.
5. Enter and confirm the client password you generated in the previous step.
6. Verify the pxGrid server identy.

1. Select Verify server cerficate.
2. Select your cerficate profile from the Cert Profile drop-down.

7. Click OK.
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STEP 9 | Configure the Monitoring Definion.
1. Select Panorama > Cisco TrustSec > Monitoring Definion and click Add.
2. Enter a descripve Name and oponally a Descripon to idenfy the monitoring

definion.
3. Select the pxGrid Server.
4. (Oponal) Set Panorama to Monitor pxGrid sessions in AUTHENTICATED state. By

default, Panorama retrieves IP-Tag mappings from sessions in the “STARTED” state.
ISE sessions have the “STARTED” state when there is a corresponding accounng start
packet. If no accounng start packet is present for the session, then the session state is
“AUTHENTICATED”.

5. Select the Nofy Group.
6. Click OK.

STEP 10 | Commit your changes.

STEP 11 | Create acve ISE sessions so that Panorama can learn SGT tags for dynamic address group
definion. To create acve sessions, use ISE to authencate devices.

Panorama does not collect default SGT tags on ISE.
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STEP 12 | Create dynamic address groups and verify that addresses are added to dynamic address
groups.
1. Select Objects > Address Groups.
2. Select the Device Group you created for monitoring endpoints in your Cisco TrustSec

environment from the Device Group drop-down.
3. Click Add and enter a Name and Descripon for the dynamic address group.

The dynamic address group naming convenon is: cts.svr_<server-
name>.sgt_<SGT-name>

4. Select Type as Dynamic.
5. Click Add Match Criteria.
6. Select the And or Or operator and click the plus (+) icon next to the security group name

to add it to the dynamic address group.

Panorama can only display security group tags it has learned from acve sessions.
Security group tags in live sessions appear in the match criteria list.

7. Select Panorama > Objects > Address Groups.
8. Click More in the Addresses column of a dynamic address group.

Panorama displays a list of IP addresses added to that dynamic address groups based on
the match criteria you specified.
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STEP 13 | Use dynamic address groups in policy.

Dynamic address groups are empty unl you aach them to a policy. You won’t see any
IP addresses in your dynamic address group unless a policy is using it.

1. Select Policies > Security.
2. Click Add and enter a Name and a Descripon for the policy.
3. Add the Source Zone to specify the zone from which the traffic originates.
4. Add the Desnaon Zone at which the traffic is terminang.
5. For the Desnaon Address, select the dynamic address group you just created.
6. Specify the acon— Allow or Deny—for the traffic, and oponally aach the default

security profiles to the rule.
7. Repeats Steps 1 through 6 to create another policy rule.
8. Click Commit.

STEP 14 | (Oponal) Update the dynamic objects from the pxGrid server at any me by synchronizing
dynamic objects. Synchronizing dynamic objects enables you to maintain context on changes
in the virtual environment and allows you to enable applicaons by automacally updang
the dynamic address groups used in policy rules.
1. Select Panorama > Cisco TrustSec > Monitoring Definion.
2. Click Synchronize Dynamic Objects.
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Troubleshoot the Panorama Plugin for Cisco TrustSec
• Plugin Status Commands
• Debug Commands
• Debug Logs

Plugin Status Commands
• Clear counters:

clear plugins cisco_trustsec counters

• Display monitor status:

show plugins cisco_trustsec status

• Display counters:

show plugins cisco_trustsec counters

Debug Commands
• Check IP addresses in dynamic address groups.

show object registered-ip tag <tag>

show object registered-ip all

• Fetch the tags of an IP address from a server. The fetched ip-tag mappings are logged in
plugin_cisco_trustsec.log. No ip-tag mappings are pushed to the nofy group
associated with the server. No retry if failed.

debug plugins cisco_trustsec query pxgrid-server $server-name ip
 $ip-address

• Force synchronize with a server and push the mappings to the configd process. No retry if
failed.

request plugins cisco_trustsec synchronize-dynamic-objects name
 $server-name

• Force synchronize with all servers and push the mappings to the configd process. No retry if
failed.

 request plugins cisco_trustsec synchronize-dynamic-objects all
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• Force synchronize the mappings from configd process to VM-Series firewalls. No retry if failed.

request plugins cisco_trustsec sync

Debug Logs
The logs are in the following locaons on the disk:

/opt/plugins/var/log/pan/plugin_cisco_trustsec.log
/opt/plugins/var/log/pan/plugin_cisco_trustsec_sub.log
/opt/plugins/var/log/pan/plugin_cisco_trustsec_ret.log
/opt/plugins/var/log/pan/plugin_cisco_trustsec_proc.log

The size limit for a log file (shared by all plugins installed on your Panorama device) is 10 million
bytes. A log file can accept 93,000 session logins. If you configure log rotaon, a backup log can
support 186,000 session logins.

• Change the plugin debug level.

 request plugins debug level $level plugin-name cisco_trustsec

• off: No debug log.
• low: Dump only basic debug logs.
• medium: Dump detailed debug logs.
• high: Dump everything including request/response messages with servers.

• Merge the logs into a single log file:

request plugins cisco_trustsec merge-logs

• Show the debug log in the CLI:

• Cisco TrustSec plugin version 1.0.2 or later installed on a Panorama version earlier than
10.0.0:

tail mp-log plugin_cisco_trustsec_merged.log

• Cisco TrustSec plugin version 1.0.2 or later installed on Panorama version 10.0.0 or later:

tail follow yes plugins-log
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Set Up the VM-Series Firewall on
Nutanix AHV

The VM-Series firewall for Nutanix AHV allows you to deploy the VM-Series
firewall on devices capable of running the Nutanix Acropolis Hypervisor. If you are
using Panorama to manage your VM-Series firewalls on Nutanix AHV, you can use
the Panorama plugin for Nutanix to perform VM monitoring. This allows you to
dynamically inform the firewall of changes in your Nutanix environment and ensure
that policy is applied to virtual machines as they join your network.

> Deploy the VM-Series Firewall on Nutanix AHV
> VM Monitoring on Nutanix
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VM Monitoring on Nutanix
Install and configure the Panorama plugin for Nutanix to monitor changes in your Nutanix
environment and build policy using dynamic address groups.

• About VM Monitoring on Nutanix
• Install the Panorama Plugin for Nutanix
• Configure the Panorama Plugin for Nutanix

About VM Monitoring on Nutanix
The Panorama plugin for Nutanix facilitates the use of dynamic address groups by monitoring
virtual machines in your Nutanix environment. Prism Central groups enes in your Nutanix
environments by categories and filters them further by value. Panorama creates tags based on
categories and values you define in Prism Central. When a virtual machine is placed in a category
and assigned a value, Panorama applies the corresponding tag to the virtual machine’s IP address.
You can then create security policy by using the tags as match criteria for dynamic address groups
in Panorama.

In the example above, we have two categories—Dev and HR—with two values within each of
them. And these categories are within the cluster, which is within Prism Central. Aer you begin
monitoring your Nutanix environment, Panorama uses value, category, cluster, and Prism Central
to form tags. When you view the match criteria for dynamic address groups, the tags are listed in
the following format.

ntnx.PC-<prism-central-name>.CL-<cluster-name>.<category>.<value>

With the informaon in the example above, Panorama creates the following tags.

ntnx.PC-PrismCentralHQ.CL-ClusterAlpha.Dev.Engineering

ntnx.PC-PrismCentralHQ.CL-ClusterAlpha.Dev.QA

ntnx.PC-PrismCentralHQ.CL-ClusterAlpha.HR.Recruiting
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ntnx.PC-PrismCentralHQ.CL-ClusterAlpha.HR.Benefits

To secure these workloads in these categories, use tags such as these as match criteria in the
dynamic address groups. You can then use the dynamic address groups as source and desnaon
address groups in your security policy rules. When a virtual machine joins a dynamic address
group, the policy your created is applied automacally.

Install the Panorama Plugin for Nutanix
To get started with endpoint monitoring on Nutanix, download and install the Panorama plugin for
Nutanix.

If you have a Panorama HA configuraon, repeat this installaon process on each Panorama peer.
When installing the plugin on Panoramas in an HA pair, install the plugin on the passive peer
before the acve peer. Aer installing the plugin on the passive peer, it will transion to a non-
funconal state. Installing the plugin on the acve peer returns the passive peer to a funconal
state.

If you have a standalone Panorama or two Panorama appliances installed in an HA pair with
mulple plugins installed, plugins might not receive updated IP-tag informaon if one or more of
the plugins is not configured. This occurs because Panorama will not forward IP-tag informaon
to unconfigured plugins. Addionally, this issue can occur if one or more of the Panorama plugins
is not in the Registered or Success state (posive state differs on each plugin). Ensure that your
plugins are in the posive state before connuing or execung the commands described below.

If you encounter this issue, there are two workarounds:

• Uninstall the unconfigured plugin or plugins. It is recommended that you do not install a plugin
that you do not plan to configure right away

• You can use the following commands to work around this issue. Execute the following
command for each unconfigured plugin on each Panorama instance to prevent Panorama from
waing to send updates. If you do not, your firewalls may lose some IP-tag informaon.

request plugins dau plugin-name <plugin-name> unblock-device-push yes

You can cancel this command by execung:

request plugins dau plugin-name <plugin-name> unblock-device-push no

The commands described are not persistent across reboots and must be used again for any
subsequent reboots. For Panorama in HA pair, the commands must be executed on each
Panorama.

STEP 1 | Log in to the Panorama user interface.

STEP 2 | Select Panorama > Plugins.

STEP 3 | Select Check Now to retrieve a list of available updates.

STEP 4 | Select Download in the Acon column to download the plugin.

STEP 5 | Select the version of the plugin and click Install in the Acon column to install the plugin.
Panorama will alert you when the installaon is complete.
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Configure the Panorama Plugin for Nutanix
Aer installing the plugin, complete the following procedure to establish a connecon between
Panorama and Prism Central.

STEP 1 | Log in to the Panorama web interface.

STEP 2 | Enable monitoring and set the monitoring interval.
1. Select Panorama > Nutanix > Setup > General.
2. Select Enable Monitoring.
3. Set the Monitoring Interval in seconds. The monitoring interval is how oen Panorama

retrieves updated networking informaon from Prism Central.

STEP 3 | Create a nofy group.
1. Select Panorama > Nutanix > Setup > Nofy Groups.
2. Click Add.
3. Enter a descripve Name for your nofy group.
4. Select the device groups in your Nutanix deployment.
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STEP 4 | Add Prism Central informaon.
1. Select Panorama > Nutanix > Setup > Nutanix Prism Central.
2. Click Add.
3. Enter a descripve Name for your Prism Central.
4. Enter the IP address or FQDN for Prism Central.
5. Enter your Prism Central username.
6. Enter and confirm your Prism Central password.
7. Click Validate to confirm that you entered the Prism Central credenals correctly.

If you return to the Nutanix Prism Central Info window aer clicking OK, clicking
the Validate buon returns a credenal validaon error message. This is the
expected behavior. Although Panorama displays dots in the password field,
the field is empty; this causes the validaon to fail despite Panorama being
successfully connected to Prism Central.

8. Click OK.

STEP 5 | Configure the Monitoring Definion.
1. Select Panorama > Nutanix > Monitoring Definion and click Add.
2. Enter a descripve Name and oponally a descripon to idenfy the Prism Central for

which you use this definion.
3. Select the Prism Central and Nofy Group.
4. Click OK.

STEP 6 | Commit your changes.
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STEP 7 | Verify that you can view the VM informaon on Panorama, and define the match criteria for
dynamic address groups.
1. Select Panorama > Objects > Address Groups and click Add.
2. Enter a descripve Name for your dynamic address groups.
3. Select Dynamic from the Type drop-down.
4. Click Add Match Criteria. You can select dynamic tags as the match criteria to populate

the members of the group. Select the And or Or operator and select the aributes that
you would like to filter for or match against. and then click OK.

5. Commit your changes.

STEP 8 | Verify that addresses in your VMs are added to dynamic address groups.
1. Select Panorama > Objects > Address Groups.
2. Click More in the Addresses column of a dynamic address group.

Panorama displays a list of IP addresses added to that dynamic address group based on
the match criteria you specified.
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STEP 9 | Use dynamic address groups in policy.
1. Select Policies > Security.
2. Click Add and enter a Name and a Descripon for the policy.
3. Add the Source Zone to specify the zone from which the traffic originates.
4. Add the Desnaon Zone at which the traffic is terminang.
5. For the Desnaon Address, select the Dynamic address group you just created.
6. Specify the acon— Allow or Deny—for the traffic, and oponally aach the default

security profiles to the rule.
7. Repeat Steps 1 through 6 to create another policy rule.
8. Click Commit.
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Bootstrapping allows you to create a repeatable and streamlined process of deploying
new VM-Series firewalls on your network because it allows you to create a package
with the model configuraon for your network and then use that package to deploy
VM-Series firewalls anywhere.

You can either bootstrap the firewall with complete configuraon so that the firewall
is fully configured at startup, or you can begin with a basic configuraon—a minimal
inial configuraon that enables you to boot the firewall and then register with
Panorama to complete the configuraon.

If you choose the basic configuraon and you are deploying on AWS, Azure or GCP,
you can use the bootstrap package and an init-cfg.txt file. Alternavely, you can
bootstrap with user data. Instead of providing bootstrap configuraon parameters in
files, you enter them as key-value pairs directly into the AWS or GCP user interface
when you launch a VM-Series firewall. Azure has a similar process with which you
provide the bootstrap parameters in a template or other text file accessed from the
Azure CLI.

If you create the bootstrap package, you deliver it from an external device (such as a
virtual disk, a virtual CD-ROM, or a cloud storage device (such as a bucket).

> Choose a Bootstrap Method
> VM-Series Firewall Bootstrap

Workflow
> Bootstrap Package
> Bootstrap Configuraon Files
> Generate the VM Auth Key on

Panorama
> Create the init-cfg.txt File
> Create the bootstrap.xml File
> Prepare the Licenses for

Bootstrapping
> Prepare the Bootstrap Package

> Bootstrap the VM-Series Firewall on
AWS

> Bootstrap the VM-Series Firewall on
Azure

> Bootstrap the VM-Series Firewall on
ESXi

> Bootstrap the VM-Series Firewall on
Google Cloud Plaorm

> Bootstrap the VM-Series Firewall on
Hyper-V

> Bootstrap the VM-Series Firewall on
KVM

> Verify Bootstrap Compleon
> Bootstrap Errors
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Choose a Bootstrap Method
You can bootstrap the VM-Series firewall with a basic configuraon or a complete configuraon.

A complete configuraon uses the bootstrap package and includes everything you need to
fully configure the firewall at boot up. This includes configuraon parameters (in init-cfg.txt),
content updates, and soware versions. A complete configuraon can include both init-cfg.txt and
bootstrap.xml files.

Configuraon Method Configuraon Locaon Comment

Specify complete
configuraon informaon
in /config/bootstrap.xml in
the bootstrap package.

Public cloud storage

AWS S3 bucket, Azure
storage account, or Google
storage bucket.

• Full bootstrap package in the
storage bucket.

• Requires cloud storage and
an IAM role to access it.

A basic configuraon is a minimal configuraon that enables you to launch, license, and register
the VM-Series firewall. The basic configuraon does not support plugins, content, soware
images, or bootstrap.xml.

Aer you boot the firewall you can connect with Panorama to complete the configuraon, or log
in to the firewall to update content and soware manually. The following table briefly contrasts
three ways you can store and access a basic configuraon:

Configuraon Method Configuraon Locaon Comment

init-cfg.txt

Store basic configuraon
parameters as key-value
pairs in config/init-cfg.txt in
the bootstrap package.

Public cloud storage

• AWS S3 bucket
• Azure storage account
• GCP storage bucket

• Requires cloud storage and
an IAM role to access it. The
Panorama admin must also
be granted access to the
bucket.

User data

Enter configuraon
parameters into the public
cloud user interface as key-
value pairs.

VM Instance

• Alibaba: User data
• AWS: User data
• Azure: Custom data
• GCP: GCP metadata
• Oracle Cloud

Infrastructure: User data

• The inial configuraon
parameters are stored with
the VM.

• No need for separate storage
and the associated IAM role.

AWS Secret Manager

Enter configuraon
parameters into the AWS
secret manager as key-value
pairs.

Encrypted in AWS Secret
Manager.

• You need an IAM role to
create a secret. Others can
be granted permission to get
the secret.
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Configuraon Method Configuraon Locaon Comment
• To get the secret, pass the

secret name using user data.

See the VM-Series firewall bootstrap workflow to compare the workflow for the basic and
complete configuraons.

• Basic Configuraon
• Complete Configuraon

Basic Configuraon
A basic configuraon includes the inial configuraon and licenses. You can use the bootstrap
package to pass the key-value pairs for the inial configuraon, or you can enter the bootstrap
parameters key-value pairs as user data.

If you do not use Panorama, you can use the inial configuraon to bootstrap the firewall, then log
in and complete the configuraon manually. If you use Panorama, your inial configuraon must
include bootstrap parameters for the IP addresses for your Panorama servers and the VM Auth
Key so the bootstrapped firewall can register with Panorama and complete the full configuraon.

• Add a Basic Configuraon to the Bootstrap Package
• Enter a Basic Configuraon as User Data (Public Clouds)
• Save a Basic Configuraon in the AWS Secrets Manager

Add a Basic Configuraon to the Bootstrap Package
The inial configuraon is a minimal configuraon that enables you to launch, license, and register
the VM-Series firewall, and connect with Panorama, if applicable. You deliver the configuraon
(init-cfg.txt) in the bootstrap package.

Enter a Basic Configuraon as User Data (Public Clouds)
When you deploy the VM-Series firewall from a public cloud user interface, you can enter
the configuraon parameters as user data during the launch/deployment process. If you have
sufficient permissions to deploy a firewall from your cloud account, and access Panorama (if you
are using it), you can skip creang a bootstrap package, creang configuraon files, and other
bootstrap tasks related to cloud storage (a storage bucket, IAM roles, or service accounts that
grant external access to storage).

Configuraon parameters include the values in init-cfg.txt File Components, and the following
addional values only available as user data:

• authcodes—The authcode use to register the VM-Series firewall. For example,
authcodes=I7115398.

• mgmt-interface-swap—Used to swap the management interface when the VM-Series
firewall is behind a load balancer in an AWS or GCP deployment. For example, mgmt-
interface-swap=enable.

You can enter configuraon parameters as key-value pairs directly into the Alibaba, AWS, GCP
or OCI user interface. You can also define the configuraon from a text file or a cloud-nave
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template, such as an AWS Cloud Formaon template, Azure ARM template, a GCP YAML file, or a
Terraform template.

Each cloud has a different term for user data, and uses different separators between bootstrap
parameters.

• Alibaba Cloud User Data —Use a newline (\n) for each parameter, and if a parameter has
mulple opons, use commas to separate them.

• AWS User Data—Use a semicolon or newline (\n). If a parameter has more than one opon,
separate opons with a comma. For example:

  type=dhcp-client
  hostname=palo1
  panorama-server=<PANORAMA-1 IP>
  panorama-server-2=<PANORAMA-2 IP>
  tplname=STK-NGFW-01
  dgname=DG-NGFW-01
  dns-primary=169.254.169.253
  dns-secondary=8.8.8.8
  op-command-modes=mgmt-interface-swap
  dhcp-send-hostname=yes
  dhcp-send-client-id=yes
  dhcp-accept-server-hostname=yes
  dhcp-accept-server-domain=yes
  vm-auth-key= <YOUR AUTH KEY HERE>
  authcodes= <<YOUR AUTH CODE HERE>
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If you choose to save your basic configuraon in the AWS Secrets Manager, enter the secret
name as a key-value pair in the user data field. For example:

• Azure Custom Data—Use a semicolon. If a parameter has more than one opon, separate
opons with a comma. For example:

type=dhcp-client; op-command-modes=jumbo-frame;
plugin-op-commands=numa-perf-optimize:enable,set-dp-cores:30
vm-series-auto-registration-pin-id=abcdefgh1234****;
vm-series-auto-registration-pin-value=zyxwvut-0987****

• GCP Custom Metadata—In a file, such as a YAML file or Terraform template, use a newline (\n)
for each parameter, and if a parameter has mulple opons, use commas to separate them. For
example:

type=dhcp-client
op-command-modes=mgmt-interface-swap,jumbo-frame
plugin-op-commands=numa-perf-optimize:enable,set-dp-cores:30
vm-series-auto-registration-pin-id=abcdefgh1234****
vm-series-auto-registration-pin-value=zyxwvut-0987****

• Oracle Cloud Infrastructure User Data—Use a newline (\n) for each parameter, and if a
parameter has mulple opons, use commas to separate them.
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Save a Basic Configuraon in the AWS Secrets Manager
You can use the AWS Secrets Manager to store the basic configuraon as a secret, and then use
User Data to bootstrap a VM with the parameters stored in the secret. To perform this task you
need permission to use the Secrets Manager.

• The secret creator must have full Secrets Manager administrator permissions. A Secrets
Manager administrator can permit others to use the secret, as described in Authencaon and
access control for AWS Secrets Manager.

For example, the following policy statement allows you to get the secret value:

{
  "Version": "2012-10-17",
    {
      "Effect": "Allow",
      "Action": "secretsmanager:GetSecretValue",
      "Resource": 
      "arn:aws:secretsmanager:us-east-1:688382******:secret:My_bts-
******"
    }
}

Refer to Acons, Resources, and Context Keys You Can Use in an IAM Policy or Secret Policy
for AWS Secrets Manager to see acons that require permission, such as list, get, and rotate
secret.

• (Oponal) To encrypt the secret you can use the DefaultEncryponKey from AWS Secrets
Manager.

STEP 1 | Log in to the AWS console and under Security, Identy and Compliance, select Secrets
Manager and select Store a new secret.
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STEP 2 | Select other type of secrets.
1. Enter the key-value pairs to define the basic configuraon.

mgmt-interface-swap does not work as a key-value pair in an AWS secret.
It must be entered as: op-command-modes=mgmt-interface-swap

2. Select the DefaultEncryponKey, and click Next.

STEP 3 | Supply the secret name and descripon.
1. Edit the resource permissions to securely access secrets across AWS accounts. For

example:

{
    "Version": "2012-10-17",
    "Statement": [
    {
        "Sid": "VisualEditor0",
        "Effect": "Allow",
        "Action": "s3:ListBucket",
        "Resource": "arn:aws:s3:::sn-bootstrap"
    },
    {
        "Sid": "VisualEditor1",
        "Effect": "Allow",
        "Action": "s3:GetObject",
        "Resource": "arn:aws:s3:::sn-bootstrap/*"
    },
    {
        "Effect": "Allow",
        "Action": "secretsmanager:GetSecretValue",
        "Resource": "arn:aws:secretsmanager:us-
east-1:688382******:
                           secret:My_bootstrap"
    }

VM-Series Deployment Guide Version Version 10.1 953 ©2022 Palo Alto Networks, Inc.



Bootstrap the VM-Series Firewall

  ]
}

2. (Oponal) You can examine the secret from the command line (if you have permission).
For example:

# aws secretsmanager get-secret-value --secret-id My_bootstrap
{
    "ARN": "arn:aws:secretsmanager:us-east-1:688382******:
                secret:My_bootstrap",
    "Name": "My_bootstrap",
    "VersionId": "01b6853d-e187-479f-***********",
    "SecretString": "{\"mgmt-interface-swap\":\"enable\",
        \"vm-auth-key\":\"AAA\",\"panorama-server\":
\"10.*.*.1\",
        \"panorama-server-2\":\"10.*.*.2\",\"dgname\":\"dg-
s0000h\",
        \"tplname\":\"tpl-santosh\",\"license-authcode\":
\"AAAA\"}",
    "VersionStages": [ "AWSCURRENT" ],
    "CreatedDate": 1581018411.847
}

Complete Configuraon
A complete configuraon ensures the firewall is fully configured on boot up. The bootstrap.xml
file includes the inial configuraon, licenses, soware, content, and a version of the VM-Series
plugin. You can create bootstrap.xml manually or you can export an exisng configuraon, as
described in Create the bootstrap.xml File.
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VM-Series Firewall Bootstrap Workflow
Use the following workflow to bootstrap your VM-Series firewall. Refer to the following figure for
an overview of both complete and basic bootstrapping procedures.

STEP 1 | (Oponal) For security reasons, you can only bootstrap a firewall when it is in factory default
state. If you want to use the bootstrap package to bootstrap a VM-Series firewall that has
been previously configured, reset the firewall to factory default sengs.

STEP 2 | Choose a bootstrap method.

Aer you familiarize yourself with the bootstrap package, assess whether you want to use a
complete configuraon, or use a basic configuraon and oponally use Panorama to manage
the bootstrapped firewall.

If you choose a basic configuraon, decide whether to use the bootstrap package, or enter the
configuraon parameters as key-value pairs in user data.
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STEP 3 | (Oponal) If you want to use Panorama to manage the VM-Series firewalls being
bootstrapped, generate the VM auth key on Panorama. You must include this key in the
init-cfg.txt file (vm-auth-key) or enter the key-value pair as user data.

STEP 4 | Prepare the licenses for bootstrapping.

STEP 5 | If you choose the basic configuraon and you plan to bootstrap with user data, skip to Step
7.

If you plan to use the basic configuraon and the bootstrap package, create the init-cfg.txt file
and prepare the bootstrap package.

If you choose the complete configuraon, create the bootstrap.xml file and prepare the full
bootstrap package.

STEP 6 | Prepare the bootstrap package and save the bootstrap package in the appropriate delivery
format for your hypervisor.

STEP 7 | Bootstrap the VM-Series firewall.

• Bootstrap the VM-Series Firewall on AWS
• Bootstrap the VM-Series Firewall on Azure
• Bootstrap the VM-Series Firewall on ESXi
• Bootstrap the VM-Series Firewall on Google Cloud Plaorm
• Bootstrap the VM-Series Firewall on Hyper-V
• Bootstrap the VM-Series Firewall on KVM

STEP 8 | Verify bootstrap compleon.
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Bootstrap Package
The bootstrap process is iniated only on first boot when the firewall is in a factory default state.

• Bootstrap Package Structure
• Bootstrap Package Delivery

Bootstrap Package Structure
The bootstrap package must include the /config, /license, /software, and /content
folders, even if they are empty. The /plugins folder is oponal. For an example, see Prepare the
Bootstrap Package.

• /config folder—Contains the configuraon files. The folder can hold two files: init-cfg.txt
and the bootstrap.xml. For details, see Bootstrap Configuraon Files.

If you intend to pre-register VM-Series firewalls with Panorama with bootstrapping,
you must generate a VM auth key on Panorama and include the generated key in the
init-cfg.txt file. See Generate the VM Auth Key on Panorama.

• /license folder—Contains the license keys or auth codes for the licenses and subscripons that
you intend to acvate on the firewalls. If the firewall does not have Internet connecvity, you
must either manually obtain the license keys from the Palo Alto Networks Support portal or
use the Licensing API to obtain the keys and then save each key in this folder. For details, see
Prepare the Licenses for Bootstrapping.

You must include an auth code bundle instead of individual auth codes so that the
firewall or orchestraon service can simultaneously fetch all license keys associated
with a firewall. If you use individual auth codes instead of a bundle, the firewall will
retrieve only the license key for the first auth code included in the file.

• /soware folder—Contains the soware images required to upgrade a newly provisioned
VM-Series firewall to the desired PAN-OS version for your network. You must include all
intermediate soware versions between the current version and the final PAN-OS soware
version to which you want to upgrade the VM-Series firewall. Refer to VM-Series Firewall
Hypervisor Support in the Compability Matrix.

• /content folder—Contains the applicaon and threat updates, WildFire updates, and the
BrightCloud URL filtering database for the valid subscripons on the VM-Series firewall. You
must include the minimum content versions required for the desired PAN-OS version. If you do
not have the minimum required content version associated with the PAN-OS version, the VM-
Series firewall cannot complete the soware upgrade.

• /plugins folder—Oponal folder contains a single VM-Series plugin image.

Bootstrap Package Delivery
The file type used to deliver the bootstrap package to the VM-Series firewall varies based on
your hypervisor. Use the table below to determine the file type your hypervisor or cloud vendor
supports.
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External Device for Bootstrapping
(Bootstrap Package Format)

AWS Azure ESXi Google Hyper-V KVM

CD-ROM (ISO image) — — Yes — Yes Yes

Block Storage Device — — Yes — Yes Yes

Storage Account — Yes — — — —

Storage Bucket Yes — — Yes — —

When you aach the storage device to the firewall, the firewall scans for a bootstrap package and,
if one exists, the firewall uses the sengs defined in the bootstrap package.

If you have included a Panorama server IP address in the file, the firewall connects with Panorama.
If the firewall has Internet connecvity, it contacts the licensing server to update the UUID and
obtain the license keys and subscripons. The firewall is then added as an asset in the Palo Alto
Networks Support portal. If the firewall does not have Internet connecvity, it either uses the
license keys you included in the bootstrap package, or it connects to Panorama to retrieve the
appropriate licenses and deploys them to the managed firewalls.
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Bootstrap Configuraon Files
The bootstrap package must include the basic configuraon in config/init-cfg.txt. The
complete configuraon (in /config/bootstrap.xml file) is oponal.

When you include init-cfg.txt file and the bootstrap.xml file in the bootstrap package,
the firewall merges the configuraons of those files, and if any sengs overlap, the firewall uses
the values defined in the init-cfg.txt file.

• init-cfg.txt
• bootstrap.xml

init-cfg.txt
Contains basic informaon for configuring the management interface on the firewall, such as
the IP address type (stac or DHCP), IP address (IPv4 only or both IPv4 and IPv6), netmask, and
default gateway. The DNS server IP address, Panorama IP address and device group and template
stack parameters are oponal.

You can use the generic name init-cfg.txt, or to be more specific, you can prepend the UUID
or Serial number of each firewall to the filename (for example: 0008C100105-init-cfg.txt).

When the firewall boots, it searches for a text file that matches its UUID or serial number and,
if none is found, it searches using the generic filename init-cfg.txt. For a sample file, see
Create the init-cfg.txt File.

If you are using Panorama to manage your bootstrapped VM-Series firewalls:

• You must generate a VM auth key on Panorama and include the key in the init-
cfg.txt file. For more informaon, see Generate the VM Auth Key on Panorama.

• The Panorama appliance that manages the firewalls must be in Panorama mode. If
you use a Panorama appliance in Management-Only mode, firewall logs are dropped
because Panorama in Management-Only mode does not have a Log Collector Group
that can store firewall logs.

bootstrap.xml
The oponal bootstrap.xml file contains a complete configuraon for the firewall. If you are
not using Panorama to centrally manage your firewalls, the bootstrap.xml file provides a way
to automate the process of deploying firewalls that are configured at launch.

You can define the configuraon manually or export the running configuraon (running-
config.xml) from an exisng firewall and save the file as bootstrap.xml. If you export
bootstrap.xml file, make sure to export the XML file from a firewall deployed on the same
plaorm or hypervisor as your deployment. See Create the bootstrap.xml File.
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Generate the VM Auth Key on Panorama
If you want to use Panorama to manage the VM-Series firewalls that you are bootstrapping, you
must generate a VM auth key on Panorama and include the key in the basic configuraon (init-
cfg.txt) file. The VM auth key allows Panorama to authencate the newly bootstrapped VM-
Series firewall. So, to manage the firewall using Panorama, you must include the IP address for
Panorama and the VM auth key in the basic configuraon file as well as the license auth codes in
the /license folder of the bootstrap package. The firewall can then provide the IP address, serial
number, and the VM auth key in its inial connecon request to Panorama so that Panorama can
verify the validity of the VM auth key and add the firewall as a managed device. If you provide
a device group and template in the basic configuraon file, Panorama will assign the firewall to
the appropriate device group and template so that you can centrally configure and administer the
firewall using Panorama.

The lifeme of the key can vary between 1 hour and 8760 hours (1 year). Aer the specified me,
the key expires and Panorama will not register VM-Series firewalls without a valid auth-key in this
connecon request.

STEP 1 | Log in to the Panorama CLI or access the API:

• In the CLI, use the following operaonal command:

request bootstrap vm-auth-key generate lifetime <1-8760>

For example to generate a key that is valid for 24 hrs, enter the following:

request bootstrap vm-auth-key generate lifetime 24 
VM auth key 755036225328715 generated. Expires at: 2015/12/29
 12:03:52 

• In the API, use the following URL:

https://<Panorama_IP_address>/api/?
type=op&cmd=<request><bootstrap><vm-auth-
key><generate><lifetime><number-of-hours></lifetime></generate></
vm-auth-key></bootstrap></request>

where the lifeme is the number of hours for which the VM auth key is valid.
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STEP 2 | Verify the validity term of the VM auth key(s) you generated on Panorama. Make sure that
the validity term allows enough me for the firewall(s) to register with Panorama.

https://<Panorama_IP_address>/api/?
type=op&cmd=<request><bootstrap><vm-auth-key><show></show></vm-
auth-key></bootstrap></request>

STEP 3 | Add the generated VM auth key to the basic configuraon (init-cfg.txt) file. See Create the
init-cfg.txt File
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Create the init-cfg.txt File
The init-cfg.txt file is required to bootstrap the VM-Series firewall. It provides the basic
informaon the firewall needs to connect to your network.

• init-cfg.txt File Components
• Sample init-cfg.txt File

Complete the following procedure to create the init-cfg.txt file.

STEP 1 | Create a new text file.

Use a text editor such as Notepad, EditPad, or other plain-text editors to create a text file.

STEP 2 | Add the basic network configuraon for the management interface on the firewall.

If any of the required parameters are missing in the file, the firewall exits the bootstrap
process and boots up using the default IP address, 192.168.1.1. You can view the
system log on the firewall to detect the reason for the bootstrap failure. For errors, see
Licensing API.

There are no spaces between the key and value in each field. Do not add spaces as they
could cause failures during parsing on the mgmtsrvr side.

• To configure the management interface with a stac IP address, you must specify the IP
address, type of address, default gateway, and netmask. An IPv4 address is required, IPv6
address is oponal. For syntax, see Sample init-cfg.txt File.

• To configure the management interface as a DHCP client, you must specify only the type of
address. If you enable the DHCP client on the management interface, the firewall ignores
the IP address, default gateway, netmask, IPv6 address, and IPv6 default gateway values
defined in the file. For syntax, see Sample init-cfg.txt File.

When you enable DHCP on the management interface, the firewall takes the DHCP assigned
IP address and is accessible over the network. You can view the DHCP assigned IP address on
the General Informaon widget on the Dashboard or with the CLI command show system
info. However, the default stac management IP address 192.168.1.1 is retained in the
running configuraon (show config running) on the firewall. This stac IP address ensures
that you can always restore connecvity to your firewall, in the event you lose DHCP access to
the firewall.

STEP 3 | Add the VM auth key to register a VM-Series firewall with Panorama.

To add a VM-Series firewall on Panorama, you must add the VM auth key that you generated
on Panorama to the basic configuraon (init-cfg.txt) file. For details on generang a key,
see Generate the VM Auth Key on Panorama.

STEP 4 | Add details for accessing Panorama.

• Add IP addresses for the primary and secondary Panorama servers.
• Specify the template and the device group to which you want to assign the firewall.
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STEP 5 | (Recommended) Add the VM-Series registraon pin and value for installing the device
cerficate.

If you want to install the device cerficate on the VM-Series firewall at launch, you must
generate the VM-Series registraon pin ID and value on the CSP and include it in the init-
cfg.txt file. This pin and value also applies any site licenses that use the PAYG license.

STEP 6 | (Oponal) Include addional parameters for the firewall.

• Add IP address for the primary and secondary DNS servers.
• Add the hostname for the firewall.
• Enable either jumbo frames or mulple-virtual systems (or both)
• Enable management interface swap (mgmt) and the dataplane interface (ethernet 1/1) for

the VM-Series firewall on AWS or GCP. For more informaon on changing the management
interface, see Management Interface Mapping for Use with Amazon ELB or Management
Interface Swap for Google Cloud Plaorm Load Balancing.

• Enable or disable DPDK.

init-cfg.txt File Components
The following table describes the bootstrap parameters in the init-cfg.txt file.

Field Descripon

type= Type of management IP address: stac or dhcp-client. This field is
required.

ip-address= IPv4 address. This field is ignored if the type is dhcp-client. If the type
is stac, an IPv4 address is required; the ipv6-address field is oponal
and can be included.

You cannot specify the management IP address and netmask
configuraon for the VM-Series firewall in AWS and Azure. If defined,
the firewall ignores the values you specify.

default-gateway= IPv4 default gateway for the management interface. This field is
ignored if the type is dhcp-client. If the type is stac, and ip-address is
used, this field is required.

netmask= IPv4 netmask. This field is ignored if the type is dhcp-client. If the
type is stac, and ip-address is used, this field is required.

ipv6-address= (Oponal) IPv6 address and /prefix length of the management
interface. This field is ignored if the type is dhcp-client. If the type is
stac, this field can be specified along with the ip-address field, which
is required.
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Field Descripon

ipv6-default-gateway= IPv6 default gateway for the management interface. This field is
ignored if the type is dhcp-client. If the type is stac and ipv6-address
is used, this field is required.

hostname= Host name for the firewall.

panorama-server= IPv4 or IPv6 address of the primary Panorama server. This field is not
required but recommended for centrally managing your firewalls.

panorama-server-2= IPv4 or IPv6 address of the secondary Panorama server. This field is
not required but recommended.

tplname= Panorama template stack name. If you add a Panorama server IP
address, as a best pracce assign the firewall to a template stack on
Panorama and enter the template stack name in this field so that you
can centrally manage and push configuraon sengs to the firewall.

dgname= Panorama device group name. If you add a Panorama server IP
address, as a best pracce create a device group on Panorama and
enter the device group name in this field so that you can group the
firewalls logically and push policy rules to the firewall.

cgname= Panorama collector group name. If you want to bootstrap the firewall
to send logs to a Panorama collector group, you must first configure
a collector group on Panorama and then configure the firewall to
forward logs to Panorama.

On the M-Series appliances, a default Collector Group is predefined
and already contains the local Log Collector as a member. On the
Panorama virtual appliance, you must add the Collector Group and
add the local Log Collector as a member.

dns-primary= IPv4 or IPv6 address of the primary DNS server.

dns-secondary= IPv4 or IPv6 address of the secondary DNS server.

vm-auth-key= Virtual machine authencaon key for Panorama (see Generate the
VM Auth Key on Panorama). This field is ignored when bootstrapping
hardware firewalls.

op-command-modes= The following values are allowed: mul-vsys, jumbo-frame, mgmt-
interface-swap. If you enter mulple values, use a space or a comma
to separate the entries.

• multi-vsys—(Hardware-based firewalls only) Enables mulple
virtual systems.
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Field Descripon

• jumbo-frame—Enables the default MTU size for all Layer 3
interfaces to be set at 9192 bytes.

• mgmt-interface-swap—(VM-Series firewall on AWS, Google,
ESXi, and KVM only) Allows you to swap the management
interface (MGT) with the dataplane interface (ethernet 1/1) when
deploying the firewall. For details, see

• Management Interface Mapping for Use with Amazon ELB
• Management Interface Swap for Google Cloud Plaorm Load

Balancing
• Use the VM-Series CLI to Swap the Management Interface on

ESXi
• Use the VM-Series CLI to Swap the Management Interface on

KVM

op-cmd-dpdk-pkt-io= The value on or off allows you to enable or disable Data Plane
Development Kit (DPDK) in environments where the firewall supports
DPDK. DPDK allows the host to process packets faster by bypassing
the Linux kernel; interacons with the NIC are performed using
drivers and the DPDK libraries.

plugin-op-commands= Specify VM-Series plugin operaon commands.

Mulple commands must be entered on a single, comma
separated list with no spaces.

• sriov-access-mode-on—This command is only valid for VM-
Series firewall on ESXi and KVM hypervisors.

For KVM only, if you enable sriov-access-mode-on, do not
enable op-command-modes=jumbo-frame.

• aws-gwlb-inspect:enable—Enables VM-Series Integraon
with an AWS Gateway Load Balancer.

• aws-gwlb-associate-vpce:<vpce-
id>@ethernet<subinterface> —Allows you to Associate a
VPC Endpoint with a VM-Series Interface or subinterface on the
firewall. The specified interface is assigned to a security zone.

• aws-gwlb-overlay-routing:enable—Use this command
to Enable Overlay Roung for the VM-Series on AWS when
integrated with a AWS GWLB.

• set-dp-cores:<#-cores>—Customize the number of
dataplane vCPUs for a VM-Series firewall running PAN-OS 10.1
or later deployed with a Soware NGFW license. This opon is
not supported on NSX-T. For more informaon, see Customize
Dataplane Cores.
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Field Descripon

• plugin-op-commands=set-cores:<number-of-cores>—
specify the number of vCPUs that are licensed when using
Soware NGFW credits instead of licensing all the vCPUs available
on your chosen compute instance. For more informaon, see Limit
Licensed vCPUs.

• numa-perf-optimize:enable—enables NUMA performance
opmizaon on the VM-Series firewall with VM-Series plugin
2.1.2 or later installed. For more informaon, see Enable NUMA
Performance Opmizaon on the VM-Series.

dhcp-send-hostname= The value of yes or no comes from the DHCP server. If yes, the
firewall will send its hostname to the DHCP server. This field is
relevant only if type is dhcp-client.

dhcp-send-client-id= The value of yes or no comes from the DHCP server. If yes, the
firewall will send its client ID to the DHCP server. This field is relevant
only if type is dhcp-client.

dhcp-accept-server-
hostname=

The value of yes or no comes from the DHCP server. If yes, the
firewall will accept its hostname from the DHCP server. This field is
relevant only if type is dhcp-client.

dhcp-accept-server-
domain=

The value of yes or no comes from the DHCP server. If yes, the
firewall will accept its DNS server from the DHCP server. This field is
relevant only if type is dhcp-client.

vm-series-auto-
registraon-pin-id

and

vm-series-auto-
registraon-pin-value

The VM-Series registraon PIN ID and value for installing the device
cerficate on the VM-Series firewall. The PIN ID and value also
enable you to automacally acvate the site licenses for AutoFocus
and Cortex Data Lake on PAYG instances of the firewall.

You must generate this in registraon PIN ID and value on the Palo
Alto Networks CSP. See Install a Device Cerficate on the VM-Series
Firewall for informaon on generang PIN ID and value.

Sample init-cfg.txt File
The following sample basic configuraon files show all the parameters that are supported in the
file; required parameters are in bold.

Sample init-cfg.txt file (Stac IP Address) Sample init-cfg.txt file (DHCP Client)

type=stac

ip-address=10.*.*.19

default-gateway=10.*.*.1

type=dhcp-client

ip-address=

default-gateway=
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Sample init-cfg.txt file (Stac IP Address) Sample init-cfg.txt file (DHCP Client)

netmask=255.255.255.0

ipv6-address=2001:400:f00::1/64

ipv6-default-gateway=2001:400:f00::2*

hostname=Ca-FW-DC1

vm-auth-key=7550362253****

panorama-server=10.*.*.20

panorama-server-2=10.*.*.21

tplname=FINANCE_TG4

dgname=finance_dg

dns-primary=10.5.6.6

dns-secondary=10.5.6.7

op-command-modes=jumbo-frame,mgmt-
interface-swap**

op-cmd-dpdk-pkt-io=***

plugin-op-commands=

dhcp-send-hostname=no

dhcp-send-client-id=no

dhcp-accept-server-hostname=no

dhcp-accept-server-domain=no

vm-series-auto-registraon-pin-
id=abcdefgh1234****

vm-series-auto-registraon-pin-
value=zyxwvut-0987****

netmask=

ipv6-address=

ipv6-default-gateway=

hostname=Ca-FW-DC1

vm-auth-key=7550362253****

panorama-server=10.*.*.20

panorama-server-2=10.*.*.21

tplname=FINANCE_TG4

dgname=finance_dg

dns-primary=10.5.6.6

dns-secondary=10.5.6.7

op-command-modes=jumbo-frame,mgmt-
interface-swap**

op-cmd-dpdk-pkt-io=***

plugin-op-commands=

dhcp-send-hostname=yes

dhcp-send-client-id=yes

dhcp-accept-server-hostname=yes

dhcp-accept-server-domain=yes

vm-series-auto-registraon-pin-
id=abcdefgh1234****

vm-series-auto-registraon-pin-
value=zyxwvut-0987****
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You cannot specify the management IP address and netmask configuraon for the VM-
Series firewall on AWS. If defined, the firewall ignores the values you specify because AWS
uses a back-end metadata file to assign the management IP address and netmask.

*The IPv6 default gateway is required if you include an IPv6 address.

**The mgmt-interface-swap operaonal command pertains only to a VM-Series
firewall on AWS or GCP.

***The op-cmd-dpdk-pkt-io=off is for disabling DPDK on the VM-Series firewall on
ESXi, KVM, and GCP (DPDK is enabled by default).

**** The vm-series-auto-registration-pin-id and vm-series-auto-
registration-pin-value are required for two use cases:

• Acvaon of site licenses—AutoFocus or Cortex Data Lake—with Pay-As-You-Go
(PAYG) license opons of the VM-Series firewall.

• Retrieve and install the device cerficate on the VM-Series firewall.
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Create the bootstrap.xml File
Use these instrucons to export the configuraon from a firewall running on the same plaorm or
hypervisor as your target deployment.

STEP 1 | Export a configuraon from a firewall.
1. Select Device > Setup > Operaons.
2. Select the configuraon file you want to export.

• To export the running configuraon, in the Configuraon Management secon,
Export named configuraon snapshot and select running config.xml from the drop-
down.

• To export a previous version of a firewall configuraon, in the Configuraon
Management secon, Export configuraon version and select the appropriate
configuraon version in the drop-down.

STEP 2 | Rename the configuraon file and save.
1. Rename the file to bootstrap.xml.

For the bootstrap process to be successful, the filename must be an exact (case-sensive)
match.

2. Save the bootstrap.xml file in the same locaon as the init-cfg.txt file.
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Prepare the Licenses for Bootstrapping
To license the firewall during the bootstrapping process, you must purchase the auth codes and
register the licenses and subscripons on the Palo Alto Networks Support portal before you begin
bootstrapping.

For the VM-Series firewalls running BYOL (not applicable for usage-based licensing—PAYG), you
must have an auth code bundle that includes the capacity auth code, support subscripon, and
any other subscripons you require. The process of preparing the licenses for bootstrapping
depends on whether the firewall has Internet access when bootstrapping:

• Direct Internet access—The firewall is connected directly to the Internet.
• Indirect Internet access—The firewall is managed by Panorama, which has direct Internet access

and the ability to fetch the license keys on behalf of the firewall.
• No Internet access—The firewall uses an orchestraon service or a custom script to fetch the

license keys on behalf of the firewall.

For VM-Series firewalls with Internet access.

Enter the auth code in the /license folder when you Prepare the Bootstrap Package.

For VM-Series firewalls with indirect Internet access.
1. Register the auth code on the Palo Alto Networks Support portal.

1. Go to the Support portal, log in, and select Assets > Register New Device > Register
device using Serial Number or Authorizaon Code.

2. Follow the steps to Register the VM-Series Firewall.
3. Click Submit.

2. Acvate the auth codes on the Palo Alto Networks Support portal to generate license
keys.

1. Go to the Support portal, log in, and select the Assets tab.
2. For each serial number, click the Acon link.
3. Select the Acvate Auth-Code buon.
4. Enter the Authorizaon code, click Agree, and Submit.
5. Download the license keys and save it to a local folder.
6. Connue to Prepare the Bootstrap Package; you must add the license keys that you

downloaded to the \license folder in the bootstrap package.

For a custom script or an orchestraon service that can access the Internet on behalf of
firewalls.

The script or service must fetch the CPU ID and the UUID from the hypervisor on which the
firewall is deployed and access the Palo Alto Networks Support portal with CPU ID, UUID, API
key and the auth code to obtain the required keys. See Licensing API.
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Prepare the Bootstrap Package
On AWS, Azure, or GCP, you can create the bootstrap package in your public cloud storage.

• VM-Series plugin version 1.0.13 and earlier, and versions 2.0.0 and 2.0.1 support one bootstrap
package per storage bucket.

• VM-Series plugin versions 2.0.2 and later also support subfolders within your public cloud
storage bucket. Within a bucket you can create mulple folders and subfolders, each containing
a bootstrap package. Typically a folder represents configuraon for a group of VMs, such as a
Panorama device group.

To access the bootstrap package, specify the full path to the bootstrap folder. For example: my-
storage/my-firewalls/bootstrap-2020-10-15

Use the following procedure to prepare the bootstrap package.

STEP 1 | Create the top-level directory structure for the bootstrap package.

On your local client or laptop, or in a public cloud storage bucket, create the following folders:

/config 
/content 
/software 
/license
/plugins

You can leave a folder empty, but you must have /config, /license, /software, and /
content folders. The /plugins folder is oponal, and only required if you are upgrading the
VM-Series plugin independent of a PAN-OS release.

Do not place any other files or folders in the bootstrap structure. Adding other files or folders
will result in a bootstrapping failure.

/my-storage                     
   /my-firewalls                
      /internal     /external   
        /config        /config  
        /content       /content 
        /license       /license 
        /plugins       /plugins 
        /software      /software

STEP 2 | Add content within each folder.

For an overview of the process, see Bootstrap Package. For details on the files in the /config
folder, see Bootstrap Configuraon Files.

/config 
  0008C100105-init-cfg.txt 
  0008C100107-init-cfg.txt 
  bootstrap.xml
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/content 
  panupv2-all-contents-488-2590 
  panup-all-antivirus-1494-1969 
  panup-all-wildfire-54746-61460 
/software 
  PanOS_vm-10.0.0 
/license
  authcodes 
  0001A100110-url3.key
  0001A100110-threats.key 
  0001A100110-url3-wildfire.key
/plugins
  vm_series-2.0.2

• If you save the keys to the license folder, you can use a file naming convenon
that works for you, but keep the .key extension in the filename. For auth codes,
create a text file named authcodes (without a file extension), add your auth codes
to that file, and save it to the license folder.

• Use an auth code bundle instead of individual auth codes so that the firewall or
orchestraon service can simultaneously fetch all license keys associated with a
firewall. If you use individual auth codes instead of a bundle, the firewall will retrieve
only the license key for the first auth code included in the file.

• In the /plugins folder, supply only one VM-Series plugin binary. Do not supply
mulple plugin versions.

STEP 3 | Create the bootstrap package.

For VM-Series firewalls, create the image in the appropriate format for your hypervisor. See
Bootstrap Package Delivery.
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Bootstrap the VM-Series Firewall on AWS
STEP 1 | Choose a bootstrap method.

• To add a basic configuraon to the bootstrap package, connue to Step 2.
• To enter a basic configuraon as user data or use user data to get the basic configuraon

from an AWS secret, connue to Step 3.

STEP 2 | Prepare an S3 bucket, and an IAM role to enable read access.

To bootstrap using a file, you must be familiar with AWS S3 and IAM permissions required
for compleng this process. For detailed instrucons on creang policy, refer to the AWS
documentaon on Creang Customer Managed Polices.

The management interface of the VM-Series firewall must be able to access the S3 bucket to
complete bootstrapping. You can either assign a public IP address or an elasc IP address to
the management interface so that the S3 bucket can be accessed over the Internet. Or, create
a AWS VPC endpoint in the same region as the S3 bucket, if you prefer to create a private
connecon between your VPC and the S3 bucket and do not want to enable internet access on
the firewall management interface. For more informaon refer to the AWS documentaon on
seng up VPC endpoints.

1. Create an IAM role with inline policy to enable read access to the S3 bucket [ListBucket,
GetObject]. For detailed instrucons on creang an IAM role, defining which accounts
or AWS services can assume the role, defining which API acons and resources the
applicaon can use upon assuming the role, refer to the AWS documentaon on
IAM Roles for Amazon EC2. When launching the VM-Series firewall, you must aach
this role to enable access to the S3 bucket and the objects included in the bucket for
bootstrapping successfully.

2. On the AWS console, create an Amazon Simple Storage Service (S3) bucket, or create a
subdirectory in an exisng S3 bucket.

The S3 bucket in the following example, vmseries-aws-bucket, is at the All Buckets root
folder level.

{
   "Version": "2012-10-17", 
   "Statement": [ 
   { 
      "Effect": "Allow", 
      "Action": ["s3:ListBucket"], 
      "Resource": ["arn:aws:s3:::<bucketname>"] 
   }, 
   { 
      "Effect": "Allow", 
      "Action": ["s3:GetObject"], 
      "Resource": ["arn:aws:s3:::<bucketname>/*"] 
      } 
   ] 
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} 

3. Create the folders within the S3 bucket as described in Prepare the Bootstrap Package.

• Create the structure directly in your S3 bucket.

• (Oponal) Add content within each folder. You can leave a folder empty, but you must
have all the \config, \content, \license, and \soware folders. The \plugins folder is
oponal.

If you have enabled logging in Amazon S3, a Logs folder is automacally created
in the S3 bucket. The Logs folder helps troubleshoot issues with access to the S3
bucket.
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STEP 3 | Launch the VM-Series firewall on AWS. Choose one of the following.

• init-cfg.txt—If you are using a file to configure the firewall, aach the IAM role you
created in Step 2.1, expand the Advanced Details secon, and in the User Data field, specify
the path to an S3 bucket, directory, or subdirectory. For example,

vmseries-bootstrap-aws-s3bucket=<bucketname>

or

vmseries-bootstrap-aws-s3bucket=<bucketname/directoryname>

• User Data—If you are using user data to configure the firewall, expand the Advanced Details
secon and in the User Data field enter the inial bootstrap parameters as described in
Enter a Basic Configuraon as User Data (Public Clouds).

• AWS Secrets Manager—If you stored your basic configuraon as described in Save a Basic
Configuraon in the AWS Secrets Manager, expand the Advanced Details secon and in the
User Data field choose As text and enter the secret name as a key-value pair. For example:

Select Review and Launch. For more details, see Launch the VM-Series firewall on AWS.
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STEP 4 | Verify Bootstrap Compleon. Select the firewall instance on the AWS Management console
and choose Acons > Instance Sengs > Get Instance Screenshot.

• The screenshot shows bootstrapping in progress. A successful bootstrap is shown below:

• If you are using an S3 bucket and the S3 bucket does not have the correct permissions or
you do not have all four folders in the S3 bucket, you see the following error message:
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Bootstrap the VM-Series Firewall on Azure
The VM-Series firewall on Azure supports Azure Files service for bootstrapping.

STEP 1 | Choose a bootstrap method.

• To add a basic configuraon to the bootstrap package, connue to Step 2.

To manage the bootstrap package for the VM-Series firewall on Azure, you must be familiar
with storage accounts on Azure and know how to create a file share and directory objects
that contain the folder structure required for the bootstrap package. You can share an Azure
file share across many virtual machines so that all firewalls deployed in the same region as
the storage account that hosts the file share can access the files concurrently.

The management interface of the VM-Series firewall must be able to access the file share
that holds the bootstrap package so that it can complete bootstrapping.

• To Enter a Basic Configuraon as User Data (Public Clouds), connue to Step 3.2.

STEP 2 | Set up the bootstrap package within an Azure Files service.
1. On the Azure portal, select or create a storage account.
2. Create a file share within the Azure Files service.

3. Create the folders within the storage account.

• Create the top-level directory structure for the bootstrap package directly in the root
folder and create a subfolder for each bootstrap configuraon.

• Add content folders within each folder. You can leave a folder empty but you must
have all four folders (config, license, soware and content) in the parent folder. In the
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following screenshot, you can see that the config folder has the init-cfg.txt file
uploaded to it.
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STEP 3 | Deploy the VM-Series Firewall from the Azure Marketplace (Soluon Template).

• If you are using a file to configure the firewall, connue to Step 3.1
• If you are using custom data to configure the firewall, connue to Step 3.2.

1. If you choose to use the bootstrap package, select Enable Bootstrap: Yes and provide the
informaon required to access the file share that holds the bootstrap files.

1. Storage Account Name— This is the Azure storage account in which you created the
file share for the bootstrap folders.

2. Storage Account Access Key—The firewall needs this access key to authencate to
the storage account and access the files stored within. To copy this access key, select
the storage account name, and then select Sengs > Access Keys.
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3. File-share—The file-share name that contains the bootstrap package.
4. (Oponal) Share-directory—The path to a subfolder within the file-share. If you have

a common file share that serves as a repository for bootstrap configuraons for
different set ups, you can use a share-directory to create a folder hierarchy and access
a specific set of subfolders within the common file-share.

2. Enter the configuraon parameters as custom data. For the key-value pairs, see Enter
a Basic Configuraon as User Data (Public Clouds). Separate each key-value pair with a
semicolon. For example:

type=dhcp-client; op-command-modes=jumbo-frame;
vm-series-auto-registration-pin-id=abcdefgh1234****;
vm-series-auto-registration-pin-value=zyxwvut-0987****

Provide custom data using one of the methods in Custom data and Cloud-Init on Azure
Virtual Machines.

STEP 4 | Verify Bootstrap Compleon.
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Bootstrap the VM-Series Firewall on ESXi
You can bootstrap the VM-Series firewall using an ISO image or a virtual hard disk.

• Bootstrap the VM-Series Firewall on ESXi with an ISO
• Bootstrap the VM-Series Firewall on ESXi with a Block Storage Device

Bootstrap the VM-Series Firewall on ESXi with an ISO
Use these instrucons to bootstrap the VM-Series firewall on an ESXi server using an ISO.

STEP 1 | Create an ISO image and upload it to a Virtual Machine File System (VMFS) datastore or to a
Network File System (NFS) volume.
1. Prepare the Bootstrap Package.
2. Create an ISO image. The tool you use to create the image varies based on your client

operang system.
3. Upload the ISO image to a VMFS datastore or to an NFS volume that is accessible to the

ESX/ESXI host.

STEP 2 | Deploy the firewall.
1. Provision the VM-Series Firewall on an ESXi Server.

By default, the firewall is deployed with two network interfaces— one for management
traffic and one data traffic. Make sure that the first ethernet interface on the firewall,
which is its management interface, is connected to the virtual switch port-group assigned
for device management.

2. Do not power on the firewall.

STEP 3 | Aach the bootstrap image to the firewall.
1. Select the VM-Series firewall from the Inventory list.
2. Click Edit Sengs and select Virtual Hardware.
3. Select Datastore iso file in the CD DVD drive drop-down, and browse for the ISO image.
4. Power on the firewall. The firewall will begin with the bootstrapping process, which will

take several minutes. The status messages on the success or failure of the process will
display on the console.

5. Verify Bootstrap Compleon.

Bootstrap the VM-Series Firewall on ESXi with a Block Storage
Device

Use these instrucons to bootstrap the VM-Series firewall on an ESXi server using a block storage
device.
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STEP 1 | Create the bootstrap package and the virtual hard disk.
1. Create the bootstrap package.
2. Deploy a Linux virtual machine.
3. On the Linux machine, Prepare the Bootstrap Package. You can leave the folder empty,

but you must have all four folders.
4. Aach a new data disk less than 39 GB to the Linux virtual machine.
5. Paron the disk and format the file system as ext3.
6. Make a directory for the new file system and mount the disk to the Linux virtual

machine.
7. Copy the contents of your bootstrap package to the disk.
8. Unmount the disk.
9. Detach the disk from the Linux virtual machine. Take note of the Disk File describing

the bootstrap disk you created; it shows the datastore name and path to the disk.
Addionally, do not check the Delete Files From Datastore check box; doing so deletes
the disk.

STEP 2 | Deploy the firewall.
1. Provision the VM-Series Firewall on an ESXi Server.
2. Do not power on the firewall.

STEP 3 | Aach the bootstrap package to the firewall.
1. Select the VM-Series firewall from the Inventory list.
2. Click Edit Sengs and select Virtual Hardware.
3. From the New Device drop-down, select Exisng Hard Disk. Select the bootstrap disk

according to the datastore and path noted previously.
4. Power on the firewall. The firewall will begin with the bootstrapping process, which will

take several minutes. The status messages on the success or failure of the process will
display on the console.

5. Verify Bootstrap Compleon.
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Bootstrap the VM-Series Firewall on Google Cloud
Plaorm
STEP 1 | Choose a bootstrap method.

STEP 2 | Log in to Google Cloud Console.

• To add a basic configuraon to the bootstrap package, create bootstrap files as described in
Prepare the Bootstrap Package, and connue to Step 3.

• To enter a basic configuraon as custom metadata, skip to Step 4.

STEP 3 | Select Storage > Browser, and click Create Bucket.

You can use this bucket to bootstrap the firewall when you Deploy the VM-Series Firewall from
Google Cloud Plaorm Marketplace.

If you intend to bootstrap using a Google storage bucket in the same project, you must have
devstorage.read_only IAM privileges.

You can create and populate the bucket at the top level, or you can create a bucket with
subfolders within it so that many bootstrap packages can share the same bucket.

1. Enter the bucket name, choose the default storage class, and choose a locaon. Note,
the locaon in the storage bucket must be compable with the zone you specify for the
compute engine instance.

2. Click Create.
3. In the Storage Browser, click the bucket name to open it.
4. Click Create Folder and name the folder config. Click Create.
5. Repeat, creang folders for content, license, and software, as shown below. All

folders must be present, even if they are empty.

6. (Oponal) If you created an init-cfg.txt file, open the config folder. Click Upload
Files, browse to select your init-cfg.txt file, and click Open.

7. Open the license folder and upload the authcodes file.
8. Connue unl you have uploaded all the bootstrap files.
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STEP 4 | Add the inial configuraon parameters as metadata. Add each key-value pair as described in
Enter a Basic Configuraon as User Data (Public Clouds).

STEP 5 | See Deploy the VM-Series Firewall from Google Cloud Plaorm Marketplace for deployment
details.
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Bootstrap the VM-Series Firewall on Hyper-V
You can bootstrap the VM-Series firewall using an ISO image or a virtual hard disk.

• Bootstrap the VM-Series Firewall on Hyper-V with an ISO
• Bootstrap the VM-Series Firewall on Hyper-V with a Block Storage Device

Bootstrap the VM-Series Firewall on Hyper-V with an ISO
Use these instrucons to bootstrap the VM-Series firewall on a Hyper-V server with an ISO.

STEP 1 | Create an ISO image.
1. Prepare the Bootstrap Package.
2. Create an ISO image. The tool you use to create the image varies based on your client

operang system.
3. Upload the ISO image to a locaon accessible to the Hyper-V host.

STEP 2 | Deploy the firewall.
1. Provision the VM-Series Firewall on a Hyper-V host with Hyper-V Manager.

By default, the firewall is deployed with two network interfaces— one for management
traffic and one data traffic. Make sure that the first ethernet interface on the firewall,
which is its management interface, is connected to the vSwitch assigned for device
management.

2. Do not power on the firewall.

STEP 3 | Aach the bootstrap image to the firewall.
1. In Hyper-V Manager, select the VM-Series firewall from the Virtual Machines list.
2. Click Sengs > Hardware > IDE Controller > DVD Drive.

If you have more than one DVD drive, the ISO image must be applied to the first
drive.

3. Under Media, click the Image file radio buon.
4. Click Browse and select your uploaded ISO image.
5. Click Apply and Ok to exit the virtual machine sengs.
6. Power on the firewall. The firewall will begin with the bootstrapping process, which will

take several minutes. The status messages on the success or failure of the process will
display on the console.

7. Verify Bootstrap Compleon.

Bootstrap the VM-Series Firewall on Hyper-V with a Block Storage
Device

Use these instrucons to bootstrap the VM-Series firewall on a Hyper-V server with a block
storage device.
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STEP 1 | Create the bootstrap package and the virtual hard disk.
1. Deploy a Linux virtual machine.
2. On the Linux machine, Prepare the Bootstrap Package. You can leave the folder empty,

but you must have all four folders.
3. Aach a new data disk less than 39 GB to the Linux virtual machine.

1. Power of the Linux virtual machine.
2. In Hyper-V, select the Linux virtual machine from the Virtual Machines list.
3. Select Sengs > Hardware > IDE Controller.
4. Select Hard Drive and click Add.
5. Select Virtual Hard Disk and click New.
6. Follow the on-screen instrucons to create a new VHD. Note the name and path of

the new VHD.
7. Click Apply then OK to exit the virtual machine sengs.
8. Power on the Linux virtual machine.

4. Connect to the CLI of the Linux virtual machine.
5. Paron the disk and format the file system as ext3.
6. Make a directory for the new file system and mount the disk to the Linux virtual

machine.
7. Copy the contents of your bootstrap package to the disk.
8. Unmount the disk.
9. Detach the disk from the Linux virtual machine.

1. Power of the Linux virtual machine.
2. Select the Linux virtual machine from the Virtual Machines list.
3. Select Sengs > Hardware > IDE Controller.
4. Select the VHD you created.
5. Click Remove. This detaches the VHD but does not delete it.

STEP 2 | Deploy the firewall.
1. Provision the VM-Series Firewall on a Hyper-V host with Hyper-V Manager.
2. Do not power on the firewall.

VM-Series Deployment Guide Version Version 10.1 986 ©2022 Palo Alto Networks, Inc.



Bootstrap the VM-Series Firewall

STEP 3 | Aach the bootstrap disk image to the firewall.
1. Select the firewall from the Virtual Machines list.
2. Select Sengs > Hardware > IDE Controller.
3. Select Hard Drive and click Add.
4. Select Virtual Hard Disk and click Browse.
5. Browse to the bootstrap VHD you created, select it, and click Open.
6. Click Apply and OK to exit the Virtual Machine sengs.
7. Power on the firewall. The firewall will begin with the bootstrapping process, which will

take several minutes. The status messages on the success or failure of the process will
display on the console.

8. Verify Bootstrap Compleon.
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Bootstrap the VM-Series Firewall on KVM
You can bootstrap the VM-Series firewall on KVM using an ISO image or a virtual hard disk.

• Bootstrap the VM-Series Firewall on KVM with an ISO
• Bootstrap the VM-Series Firewall on KVM With a Block Storage Device

Bootstrap the VM-Series Firewall on KVM with an ISO
Use these instrucons to bootstrap the VM-Series firewall on a KVM server using an ISO.

STEP 1 | Create an ISO image.
1. Prepare the Bootstrap Package.
2. Create an ISO image. The tool you use to create the image varies based on your client

operang system.
3. Upload the ISO image to a locaon accessible to the KVM host.

STEP 2 | Deploy the firewall.
1. Install the VM-Series Firewall on KVM.

By default, the firewall is deployed with two network interfaces— one for management
traffic and one data traffic. Make sure that the first ethernet interface on the firewall,
which is its management interface, is connected to the virtual switch port-group assigned
for device management.

2. Do not power on the firewall.

STEP 3 | Aach the bootstrap image to the firewall.
1. In virt-manager, double-click on the VM-Series firewall to open the console.
2. View the VM hardware details by navigang to View > Details.
3. Open the Add New Virtual Hardware menu by clicking Add Hardware.
4. Change the device type to IDE CDROM.
5. Click the Select managed or other exisng storage radio buon and click Browse. Locate

the ISO image you created and click Choose Volume.
6. Click Finish to exit the Add New Virtual Hardware menu.
7. Power on the firewall by navigang to Virtual Machine > Run. The firewall will begin with

the bootstrapping process, which will take several minutes. The status messages on the
success or failure of the process will display on the console.

8. Verify Bootstrap Compleon.

Bootstrap the VM-Series Firewall on KVM With a Block Storage
Device

Use these instrucons to bootstrap the VM-Series firewall on a KVM server with a block storage
device.
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STEP 1 | Create the bootstrap package and the virtual hard disk.
1. Create the bootstrap package.
2. Create a new disk image less than 39 GB in size and paron the disk and format the

file system as ext3. The tools used to complete this process vary based on your client
operang system.

3. Mount the disk image file and copy the prepared bootstrap package to the disk image
files.

4. Copy the contents of your bootstrap package to the disk.
5. Unmount the disk image.
6. Upload the disk image file to a locaon accessible to the KVM host.

STEP 2 | Deploy the firewall.
1. Install the VM-Series Firewall on KVM.
2. Do not power on the firewall.

STEP 3 | Aach the bootstrap disk image to the firewall.
1. In virt-manager, double click on the VM-Series firewall to open the console.
2. View the VM hardware details be selecng View > Details.
3. Open the Add New Virtual Hardware menu by clicking Add Hardware.
4. Select Storage and the select Select or create custom storage.
5. Click the Manage buon to open the Choose Storage Volume dialog, and select the disk

image file that you previously created.
6. Click Choose Volume.
7. Ensure that the device type is Disk Device and do not change the Bus Type.
8. Click Finish.
9. Power on the firewall. The firewall will begin with the bootstrapping process, which will

take several minutes. The status messages on the success or failure of the process will
display on the console.

10. Verify Bootstrap Compleon.
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Verify Bootstrap Compleon
You can see basic status logs on the console during the bootstrap and you can verify that the
process is complete.

STEP 1 | If you included panorama-server, tplname, and dgname in your init-cfg.txt file,
check Panorama managed devices, the device group, and the template name.

STEP 2 | Verify the general system sengs and configuraon. Access the web interface and select
Dashboard > Widgets > System or use the CLI operaonal commands show system info
and showconfig running.

STEP 3 | Verify the license installaon. Select Device > Licenses or use the CLI operaonal command
request license info.

STEP 4 | If you have Panorama configured, manage the content versions and soware versions from
Panorama. If you do not have Panorama configured, use the web interface to manage content
versions and soware versions.
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Bootstrap Errors
If you receive an error message during the bootstrapping process, refer to the following table for
details.

Error message (Severity) Reasons

Boot image error (high) • No external device was detected with the bootstrap package.

Or

• A crical error happened while boong from the image on the
external device. The bootstrap process was aborted.

No bootstrap config file
on external device (high)

The external device did not have the bootstrap configuraon file.

Bad or no parameters
for mandatory
networking informaon
in the bootstrap config
file (high)

The networking parameters required for bootstrapping were
either incorrect or missing. The error message lists the value—IP
address, netmask, default gateway—that caused the bootstrap
failure.

Failed to install license
key for file <license-key-
filename> (high)

The license key could not be applied. This error indicates that the
license key used was invalid. The output includes the name of
the license key that could not be applied.

Failed to install license
key using authcode
<authcode> (high)

The license auth code could not be applied. This error indicates
that the license auth code used was invalid. The output includes
the name of the authcode that could not be applied.

Failed content update
commits (high)

The content updates were not successfully applied.

USB media prepared
successfully using given
bundle (informaonal)

The bootstrap image has been successfully complied on the USB
flash device. <username>: Successfully prepared the USB using
bundle <bundlename>

Successful bootstrap
(informaonal)

The firewall was successfully provisioned with the bootstrap
configuraon file. The output includes the license keys installed
and the filename of the bootstrap configuraon. On the VM-
Series firewalls only, the PAN-OS version and content update
version are also displayed.

Read about the Bootstrap Package and how to Prepare the Bootstrap Package.
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